
Veriteq  

Spectrum 4.0

User Guide

> > > > >

w w w . v e r i t e q . c o m

w w w . v a i s a l a . c o m



Copyright
Copyright © 2010 Veriteq Instruments, Inc. All rights reserved.

No copying, distribution, publication, modification, or incorporation of this document, in whole or part, is permitted 
for commercial purposes without the express written permission of Veriteq Instruments.

Veriteq, a Vaisala company
13775 Commerce Parkway
Richmond, BC V6V 2V4
Canada 

Trademarks
Veriteq Instruments, Veriteq, and Veriteq Spectrum are trademarks of Veriteq Instruments. 

Windows is a registered trademark of Microsoft Corporation.

All other trademarks referred to are the property of their respective owners.

Disclaimer and Limitation of Liability
Veriteq Instruments, Inc. and its subsidiaries assume no responsibility for any damage or loss resulting from the 
use of this manual.

Veriteq Instruments, Inc. and its subsidiaries assume no responsibility for any loss or claims by third parties which 
may arise through the use of this software. Veriteq Instruments, Inc. and its subsidiaries assume no responsibility 
for any damage or loss caused by deletion of data as a result of hardware malfunction. Be sure to make backup 
copies of all important data to protect against data loss.

Veriteq Instruments, Inc. makes no warranties, either expressed or implied, regarding Veriteq data loggers or soft-
ware, its merchantability, or its fitness for any particular purpose. The exclusion of implied warranties is not per-
mitted by some states. As such, the exclusion may not apply to you.

Veriteq Spectrum has been tested using a variety of network systems. However, the large number of possible 
hardware and network configurations makes testing under every circumstance impossible. If you have trouble us-
ing Veriteq Spectrum software, contact Veriteq Instruments.

Technical Support
Call Veriteq for free technical support 1-866-861-3388 (8am-4pm Pacific Standard Time) 

Email customersupport@veriteq.com

Document part number: 880-0100-00 

Release date: July 2010
.





Introducing Veriteq Spectrum.................................................................................................... 1
Welcome........................................................................................................................................... 2
Conventions Used in this Document ................................................................................................ 2
Understanding the Veriteq Spectrum System................................................................................... 2

SP-Series Data Loggers............................................................................................................. 5
Understanding the Spectrum Window.............................................................................................. 5

Using the Menus........................................................................................................................ 6
Using the Tool Bar .................................................................................................................... 8

Using the Online User’s Guide......................................................................................................... 9
Getting Help ..................................................................................................................................... 9

Installing Spectrum Software....................................................................................................11
System Requirements ..................................................................................................................... 12
Installing Spectrum Software ......................................................................................................... 12

Getting Started .......................................................................................................................... 15
Setting Up and Using Spectrum—Overview................................................................................. 16
Ensuring Data Loggers are Calibrated............................................................................................ 16
Connecting Data Loggers to PCs.................................................................................................... 16
Setting up PC Communication Ports .............................................................................................. 17
Configuring Data Loggers .............................................................................................................. 18

Configuring the Data Logger Description............................................................................... 21
Setting the Data Logger Sample Timing ................................................................................. 22
Setting the Clear Mode............................................................................................................ 22
Setting the Start Mode ............................................................................................................. 24
Setting the Stop Mode ............................................................................................................. 25
Setting the Sample Interval ..................................................................................................... 26
Enabling and Disabling Logger Channels............................................................................... 27
Configuring Channels to Work with Transducers................................................................... 28
Configuring Warm Up Time ................................................................................................... 30
Configuring Data Logger Channels to Work with Thermocouples ........................................ 31
Clearing Logger Samples ........................................................................................................ 32

Mounting Data Loggers.................................................................................................................. 33
Using External Temperature Probes............................................................................................... 33
Caring for Relative Humidity Sensors............................................................................................ 34

Transferring Logger Files......................................................................................................... 35
Transferring Data............................................................................................................................ 36
Setting Transfer Preferences........................................................................................................... 36

Configuring the Default File Name Format ............................................................................ 36
Transferring Logger Data to the PC ............................................................................................... 37
Setting System Date and Time ....................................................................................................... 41



Working with Graphs................................................................................................................ 43
Displaying Existing Graph Files..................................................................................................... 44
Creating New Graph Files .............................................................................................................. 44
Inserting Logger Files..................................................................................................................... 44
Inserting Multiple Logger Files...................................................................................................... 46
Scrolling Through Graphs .............................................................................................................. 46
Pinpointing Graph Values and Times............................................................................................. 46
Adding Graph Titles ....................................................................................................................... 47
Selecting a Graph Font ................................................................................................................... 47
Zooming In ..................................................................................................................................... 48

Zooming In Using the Zoom Selection Box............................................................................ 48
Zooming In by Formatting the Time Scale ............................................................................. 50

Zooming Out................................................................................................................................... 51
Formatting Time Zones .................................................................................................................. 51
Formatting Measurement Units ...................................................................................................... 52

Specifying the Y-axis Scale..................................................................................................... 52
Changing the Decimal Place Precision.................................................................................... 53

Changing the Temperature Scale.................................................................................................... 53
Setting Sample Smoothing ............................................................................................................. 54
Displaying Line Numbers on Graphs ............................................................................................. 55
Copying and Pasting Graphs .......................................................................................................... 56
Exporting Graph Data..................................................................................................................... 56
Saving Graphs................................................................................................................................. 58
Printing Graphs............................................................................................................................... 58

Printing Line Numbers on Graphs........................................................................................... 58
Print Preview ........................................................................................................................... 59
Printing Graphs........................................................................................................................ 59

Viewing Reports and Statistics................................................................................................ 61
Working with Reports .................................................................................................................... 62
Copying and Pasting Report Data .................................................................................................. 63
Saving Reports................................................................................................................................ 64
Printing Reports.............................................................................................................................. 64

Troubleshooting........................................................................................................................ 65
Serial Port Problems ....................................................................................................................... 66

Software Error Messages you May Encounter….................................................................... 66
Frequently Asked Questions........................................................................................................... 67

Glossary..................................................................................................................................... 69
A– B................................................................................................................................................ 70
C–E ................................................................................................................................................ 70
F–K ................................................................................................................................................ 70
L–Q ................................................................................................................................................ 70
R–T ................................................................................................................................................ 71
U–Z ................................................................................................................................................ 72

Index........................................................................................................................................... 73





1

1 Introducing Veriteq Spectrum

Welcome.............................................................. 2

Conventions Used in this Document.................... 2

Understanding the Veriteq Spectrum System...... 2

Understanding the Spectrum Window ................. 5

Using the Online User’s Guide ............................ 9

Getting Help......................................................... 9



Introducing Veriteq Spectrum

2

Welcome

Welcome to Veriteq Spectrum 4.0 software. Veriteq Spectrum provides record-
ings of temperature, humidity, and other conditions. Veriteq Spectrum software 
is designed to be used with SP-Series Data Loggers.
With Veriteq Spectrum you can:
• Create electronic records of temperature, humidity, and other conditions.
• Create graphs and reports from logger files.
• Produce detailed graph reports.
• Overlay logger files from other Veriteq SP-Series Data Loggers within the 

same graph to check relationships between logger files.
• Zoom-in and zoom-out for a customized view of the graph.
• Use the on-screen graph cursor to pinpoint exact values, times, and dates.
• Open multiple graph windows.
• View, customize, and print tabular-format reports with dates, times, and 

logged values. 
• Export graph data and reports to external databases, word processors, or 

spreadsheets.
• Manually or automatically scale graphs.
• Use multiple Y-axes scaling and ranges.
• Enable and disable input channels.
• Set data logger start and stop times, sample intervals, and other logger set-

tings.

Conventions Used in this Document

This document uses the following conventions:
• Select: Choose a menu item, check box, or option with a mouse.
• Click: Click a button with a mouse.
• A sequence of actions is indicated by a list separated by the greater than 

sign.
For example, “select File>Save As...” means choose the Save As... item 
from the File menu.

• Menu selections, items you select, the names of boxes and tabs, and buttons 
you click are shown in bold.

• Keys on the keyboard are shown in SMALL CAPS.

Understanding the Veriteq Spectrum System

The Veriteq SP-Series system consists of one or more Veriteq SP-Series Data 
Loggers, Veriteq Spectrum 4.0 software, a Veriteq cable (PC-IC cable if con-
necting by Serial port, INT-USB-DL cable if connecting by USB, or Digi and 
Ethernet cables if connecting via Digi or Veriteq vNet device through the net-
work), and a PC with an attached printer. 
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The SP-Series Data Loggers are connected to a PC and the Spectrum software 
is used to configure settings such as the sampling interval. The data loggers are 
then placed in the area where conditions are to be monitored and they record 
the information. The data loggers collect the information and store it in their in-
ternal memory. Once the desired information is collected, it is transferred to a 
PC with Spectrum.  The data is imported (“inserted”) into a Spectrum graph and 
Spectrum software is used to display, analyze, print graphical or tabular reports, 
and export the information.
The following illustration shows how the Veriteq SP-Series system is used to 
collect and report data.



Introducing Veriteq Spectrum

4

Place the data logger in the area you want to monitor.

Connect the data logger to the PC and transfer data to PC.
Veriteq Spectrum creates a logger file (.spl).

Insert the Logger file (.spl) into a newly created or existing Graph. 

Customize and verify the Graph file.

Print the Graph file or Report and

1

2

3

4

6

Data logger

The data logger collects and stores the information.

5 Graph file (.spg)

Spreadsheet file

Printed Graph 

Serial or USB Logger cable 

or Digi/vNet Device

Data logger

Customize and view Report (data in tabular format).
Export file to spreadsheet, database, or word processor.

have it signed and approved.

Printed Report 

Logger file (.spl)

Connect the data logger to the PC and configure the data logger
 (sample intervals, channels, start time, stop time, and so on). 

Serial or USB Logger cable 

or Digi/vNet Device
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SP-Series Data Loggers

Each Veriteq SP-Series Data Logger is factory-calibrated against National In-
stitute of Standards and Technology (NIST) traceable standards. All calibration 
information is stored digitally in the logger’s memory. For data logger specifi-
cations, see www.veriteq.com or contact Veriteq.
There are many models of SP-Series Data Loggers to choose from, including 
the SP-1000, SP-1400, SP-1700, SP-2000, and SP-4000. Each logger has one 
or more channels and can monitor and record data, including ambient temper-
ature and relative humidity. Many loggers can also have optional plug-in exter-
nal probes attached.

Understanding the Spectrum Window

The following illustration shows the main sections of the Spectrum window, 
with items described in Table 1: 

Title bar
Menu bar
Toolbar

Graph plot area

Left-side axis (Y)

Right-side axis (Y)

 

Graph time zone Logger file names                          Graph file name 

(here, RH)

(here, temperature)

Title

Status bar

Graphing grid details 

Time axis (X)

Channel information  
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Using the Menus

The following illustration provides an overview of the menus on the Spectrum 
window. Take a few minutes to become familiar with the menu items. Right-
click on various parts of the window to discover additional ways to access the 
menu items.

Table 1: Items in the Spectrum Window

Title bar Shows the name of the active Graph file

Menu bar Allows access to the various software functions.

Toolbar Allows quick access to the most used software functions.

Graph title Shows the graph title, if you have added one.

Graph plot area The Graph file is displayed here.

Left-side Y-axis scale Shows the scale for the data displayed in the graph.

Right-side Y-axis 
scale

This scale is used when two or more scales are displayed on 
the graph. 

X-Axis time scale Shows the time scale.

Graphing grid details Shows the time per division, graph duration, and date and time 
format.

Channel information Shows the name(s) of the logger files currently being dis-
played, along with other identifying information including the 
logger serial number, logger description, logger channel num-
ber, measurement units, and measurement parameter. 
The color shown for each channel corresponds to the color of 
the graph lines.

Status bar Displays information about the menu items and the toolbar. If 
the software is idle, the message Press F1 for Help is dis-
played. You can alternatively display or hide the status bar by 
selecting View>Status Bar.

Graph Time Zone Shows the time zone used for this Graph file.
The default time zone is based on the time zone setting of the 
PC when the Graph file was created.  The time zone can be 
changed using the Format>Time Zone menu item. 
Note: The logger data displayed is based on UTC time, an 

absolute time reference.

Graph file name Shows the name and location of the Graph file.
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Create a new blank Graph file (.spg)
Open an existing Graph file (.spg)

Save the Graph file
Close the Graph file

Save the Graph file under a different name
Insert a Logger file (.spl) into an open Graph file

View a preview of the printed Graph file

Show or hide the Toolbar

Produce a report associated with the active Graph file

Change the title that appears above the graph
Position the cursor on the graph
Remove the cursor from the graph
Zoom in to enlarge a portion of the graph
Zoom out
Scroll the graph to the left
Scroll the graph to the right

Change the time zone
Move window split line to change view of data and graph proportion

Open the Logger Setup window
Change the logger description
Change the logger sample timing
Enable or disable channels
Clear the data stored in the data logger

Set Spectrum options such as temperature scale, file name formats, export options, etc.

Open a copy of the active graph in a new window
Arrange open windows in a cascade

Tile open windows vertically
Tile open windows horizontally

Switch to another open window

Open a PDF version of this User’s Guide

Go to the Veriteq Instruments web site

View information on this version of Spectrum software

 

Change the units on the Y-axis of the graph

Transfer information from the data logger to your PC

Change the time scale on the X-axis of the graph

Copy contents of graph to Clipboard. 

Print the Graph file

Change the settings on the printer

Insert a Logger file from sGo into an open Graph file

Exit Spectrum software

Export the Graph file

Show or hide the Status Bar
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Using the Tool Bar

The Veriteq Spectrum Toolbar allows quick access to the most commonly used 
features of the program. You can hide or display the toolbar by selecting 
View>Toolbar.
The following table describes the function of each of the toolbar icons.

Toolbar 
icon Function

Creates a new Graph file you can insert Logger files into. Same 
as File>New.

Opens an existing Graph file (.spg) 

Saves the currently-active Graph file using the same file name

Inserts a Logger file into the currently-active Graph file

Copies graph to the Clipboard

Positions a vertical cursor line on the active graph to determine 
exact graph values and times

Removes the vertical cursor line from the active graph

Zooms-in for a closer look at graph data

Zooms-out 

Scrolls the graph to the left
Time base is shifted backward by one graph division

Scrolls the graph to the right
Time base is shifted forward by one graph division

Opens the Logger Setup window

Transfers logger data to the computer and creates Logger file
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Using the Online User’s Guide

Veriteq Spectrum includes an online version of this user’s guide in PDF format.
To access this guide from within Veriteq Spectrum, press F1 or click the Help 
icon on the tool bar.

Getting Help

For more information about Veriteq Instruments products and services, visit 
our websites at www.veriteq.com and www.vaisala.com/veriteq.

For technical and product application support:

For information, sales, pricing, and quotations: 

 

Prints the currently-active graph

Telephone 1-866-861-3388 (North America only) (or +1 604-
273-6850)

Email customersupport@veriteq.com
Free technical support is available from Veriteq 
from 8am-4pm PST Monday - Friday

Telephone 1-800-683-8374 (North America only) (or +1 604-
273-6850)

Email sales@veriteq.com

http://www.veriteq.com
http://www.veriteq.com
http://www.veriteq.com
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System Requirements

Veriteq Spectrum Software requires a PC with the following minimum config-
uration:

• 32-bit version of Windows® 2000. 
• 32-bit or x64 versions of: Windows® XP, Windows Server® 2003, Win-

dows Vista®, Windows Server® 2008, and Windows® 7. 
• one available Serial or USB communication port (for transferring logger 

data files; you can view graphs and reports for previously transferred logger 
files without this port). 

Installing Spectrum Software

To install Spectrum software:

1. Ensure you have administrator privileges. 
2. Start Windows, log in as the administrator, and close all running applica-

tions.
3. Insert the Veriteq Spectrum CD into the CD-ROM drive and wait for it to 

start automatically. If it does not start automatically, from the Start menu, 
select Run. Type d:\setup and press the ENTER key. If d:\ is not your CD-
ROM drive, type the appropriate drive letter.
The Veriteq Spectrum Setup window opens. 

4. Click Next. 
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5. Accept the default Destination Folder, or click the Browse... button to se-
lect a new Destination Folder. 

6. Click Next.
7. Accept the default Program Folder or select another folder from the list of 

Existing Folders.
8. Click Next.
9. Click Finish.
Spectrum is now installed. Continue to Getting Started for information on log-
ger configuration and using Spectrum.
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Setting Up and Using Spectrum—Overview

The main steps in setting up and using Veriteq Spectrum are:
1. Ensure that the data loggers are calibrated. (See page 16.)
2. Connect the data loggers to the PC. (See page 16.)
3. Select a communications port. (See page 17.)
4. Configure the data logger. (See page 18.)
5. Place the data logger in the area you want to monitor and collect samples 

for the desired time. (See page 33.)
6. Transfer the raw data in the form of a Logger file (.spl) to the PC. (See 

Chapter 4.)
7. Insert Logger files (.spl) into Graph files (.spg). (See Chapter 5.)
8. View, copy, customize and print Graph files. (See Chapter 5.)
9. View, copy, customize and print Reports. (See Chapter 6.)

Ensuring Data Loggers are Calibrated

Veriteq SP-Series Data Loggers are calibrated at Veriteq Instruments and 
should be calibrated on a suitable frequency as determined by the accuracy re-
quirements of the application in which the product is used. 
Veriteq Instruments recommends a 90-day interval for the most critical appli-
cations, while a one-year interval may be adequate for less demanding situa-
tions. 
To calibrate your loggers, contact Veriteq Instruments for pricing, lead times, 
and delivery arrangements.
Note: Treat the calibration process very carefully. The consequences of poor 

calibration can be very expensive. Veriteq SP-Series Data Loggers are 
high-accuracy instruments. In order to maintain the specified accuracy, 
it is essential to have trained calibration personnel, strict calibration 
procedures, and proper test and calibration facilities. If you have ques-
tions about the calibration process, contact Veriteq Instruments.

Connecting Data Loggers to PCs

To connect your data logger to a PC using USB or Serial cable:

1. USB only: Using the supplied Veriteq Spectrum + USB cable driver CD, 
install USB drivers on your PC.
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2. Connect the data logger to a Veriteq USB or Serial cable. 

3. Attach the other end of this cable to the PC (as shown below) connecting 
to the USB port. 

To connect your data logger to a PC using a Digi or vNet device:

1. Connect Digi or vNet device (will be referred to as device, following) to 
power supply and Ethernet outlet.

2. Connect data logger to device (Digi requires Veriteq cable).
3. Obtain static IP address for device from your IT department. If your net-

working policy requires you to reserve IP addresses using DHCP, see 
www.veriteq.com/digi for instructions.

4. Insert device driver CD into PC. The Device Setup Wizard launches auto-
matically. Click NEXT.

5. Select device that matches the MAC address from the bottom of your de-
vice. Click NEXT.

6. In the Configure Network Settings window, enter a Static IP address. Click 
NEXT two times.

7. In the Configure Real Port Settings screen, select “Install Digit Real Port 
on this computer”. Click NEXT. 

8. Click NEXT again. The settings are saved.
9. Click FINISH. Drivers required to connect to your data logger through the 

device have been installed.

Setting up PC Communication Ports

Before using a data logger with Veriteq Spectrum, you must select the correct 
PC serial communication (COM) port. Veriteq Spectrum can support up to 
4096 COM ports, numbered COM1 to COM4096.

To select a COM port:

1. Using Windows Device Manager, determine which COM port has been al-
located to your data logger. Make a note of it.
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2. In Spectrum, choose Tools>Options, then choose the General tab.
3. From the COM port drop-down list, select an available COM port.

4. Click OK.
Once you have selected a COM port, you do not need to change the setting un-
less you change the communication port your loggers are connected to.

Configuring Data Loggers

Setting up the data logger varies slightly depending on the data logger you are 
using and the configuration options you prefer.

To configure data loggers:

1. If you have not already done so, connect the logger to the PC.
2. From Spectrum, do one of the following:

• Select Logger>Setup.
• Press F11.
• Click the Logger Setup toolbar button ( ).
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3. The Logger Setup window opens. 

The information shown in the Logger Setup window relates to the data 
logger connected to the COM port you have specified. Some fields shown 
will vary depending on the model of data logger in use. 
You can use this window to:

• Edit the data logger description.
• Set the sample timing.
• Enable or disable data logger channels.

Any changes will affect only the data logger currently connected to the 
COM.

4. Click Close to close.

Understanding the Logger Setup Window

The following table describes the information displayed on the Logger Setup 
window:

Description Logger description. (For information on configuring the logger description, see 
Configuring the Data Logger Description on page 21.)

Hardware Model Hardware model number of the currently-connected data logger. 

Hardware Revision Hardware version number associated with the currently connected data log-
ger.

Firmware Version Firmware version associated with the currently connected data logger.

Serial Number
Unique eight-character product serial number of the currently-connected data 
logger. This number should match the serial number label on the back of the 
data logger.
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Logger Status

Indicates the sampling status of the currently-connected data logger. The pos-
sible modes are:
• Sampling: The logger is currently taking samples and the memory is 

not full.
• Sampling (wrapped): The logger is currently taking samples with 

the memory full. The oldest reading is discarded and replaced with 
the newest.

• Stopped at specified time: The logger is not sampling and has 
stopped because the user-set stop time has been reached.

• Stopped when full: The logger is not sampling and has stopped 
because it is configured to stop when the memory is full. 

• Start at specified time: The logger is not sampling, but is set to 
begin sampling as soon as the Start time is reached.

• No enabled channels: The logger is not sampling because no chan-
nels are enabled.

The Setup button to the right of the Logger Status enables you to clear the log-
ger’s memory and change the Sample Interval, Start Mode, and Stop Mode 
settings.

Start Time

Indicates either the time that the currently-connected data logger began taking 
samples, or the time (in the future) that it is set to begin taking readings
Future Start times are indicated by a ( ) symbol. 
For information on changing the Start Time, see Setting the Start Mode on 
page 24.

Sample Interval

Indicates the current sample interval setting (how frequently the data logger is 
programmed to take readings). For information on setting sample intervals, 
see Setting the Sample Interval on page 26. 
Note: The most frequent sampling rate possible with SP-1016 and SP-1416 

loggers is once per minute. For other loggers, the most frequent sam-
pling possible is once every 10 seconds; however, sampling of this fre-
quency will have a negative effect on battery life.

Stop Mode
Indicates how the currently-connected data logger is set to stop while record-
ing samples in its memory. There are three choices: Wrap when full, Stop 
when full, and Stop at specified time. For more information on setting Stop 
modes, see Setting the Stop Mode on page 25.

Stop Time
Indicates the programmed Stop Time, if set.
If a Stop Time has not been set, it reads None.
For information on setting the Stop Time, see Setting the Stop Mode on 
page 25.

Samples per channel
Identifies how many samples have been stored for each enabled channel on 
the currently connected logger, the capacity available (in samples) for each 
channel, and the percentage of memory used.
Click the Refresh button to update values.

Log Time
Identifies the length of time the data logger has been recording.
The value is based on the number of samples in the memory multiplied by the 
sampling interval.
Click the Refresh button to update values.

Warmup Time This function applies to SP-4000 data loggers. See Configuring Warm Up 
Time on page 30.

Channel 1 Temperature or Relative Humidity or other measured condition.
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Configuring the Data Logger Description

The Data Logger Description helps identify the logger every time you commu-
nicate with it. Using a description that refers to the application or location of 
the data logger, and checking the logger description prior to each use, is a quick 
way to ensure you have the correct logger.

To configure the Description for the currently-connected logger:

1. Do one of the following:
• Select Logger>Description...
• Press F11 or Select Logger>Setup or click the Logger Setup icon on 

the toolbar ( ). In the window that appears, click Setup in the row for 
Description.

2. In the box provided, type a description of the data logger, using up to six-
teen characters.

3. Click OK to save or Cancel to close without saving.
The text from the Description field is displayed on all on-screen graphs, tabular 
displays and printouts. The text can also be used in the creation of a default file 
name when transferring logger data to a PC if you choose to include it. 

Channel 2
(there can be more 
than 2 channels)

Temperature or Relative Humidity or other measured condition. Veriteq 4000-
Series data loggers have several channels, each which can be configured for 
use with various transducers. See Configuring Channels to Work with 
Transducers on page 28.

Click the Refresh button to update the currently displayed values. Click the 
Setup... button to enable and disable channels.
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Setting the Data Logger Sample Timing

To set the logger sample timing:

Do one of the following:
• Select Logger>Sample Timing...
• Select Logger>Setup, and click the Setup... button in the row for Log-

ger Status.
• Press F11 and click the Setup... button in the row for Logger Status.
The Logger Sample Timing window opens.

There are four main steps in setting the Logger Sample Timing:

Setting the Clear Mode

To configure the Clear mode:
1. Select Logger>Sample Timing....

1. Setting the Clear Mode See page 22.

2. Setting the Start Mode See page 24.

3. Setting the Stop Mode See page 25.

4. Setting the Sample Interval See page 26.
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1. Under Clear Mode, select one of the following options:

Do not clear logger This is the default setting if the logger memory is 
not yet full.
Use this setting when the logger memory is not yet 
full and all you want to do is change Stop mode set-
tings without clearing the existing samples. 
If the logger memory is full, or if Start mode or 
Sample Interval changes are required, you must 
use the Clear logger setting to make the necessary 
changes.

Clear Logger This is the default setting if the logger memory is 
full.
The Clear logger setting allows you to modify 
both Start and Stop mode parameters and change 
Sample Interval values. Choosing this setting re-
sults in the logger’s memory being cleared follow-
ing completion of the setup changes. You will lose 
data unless you transfer it first.
If you are in doubt as to whether the information on 
the logger is still valuable, first make a copy of the 
data using Logger>Transfer, and then make the 
necessary logger setup changes.
When you choose Clear logger, the Start Mode 
and Stop Mode radio buttons become available.
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Setting the Start Mode

The Start Mode enables you to choose how, and when the data logger starts 
taking samples.

To set the Start Mode:

1.  Under Clear Mode, select the Clear logger option.

2. Under Start Mode, select one of the following options: 

3. When you choose the Start at specified time option, the Start Time sec-
tion of the Logger Sample Timing window becomes available. Use the 
Date, Hours, and Minutes drop-down lists and AM/PM radio buttons to 
set the time you want the data logger to begin recording samples. 

Note: You can not choose a date or time earlier than the current date and 
time values. 

Start now This option sets a connected data logger to start taking 
samples immediately (within one sample interval) after the 
changes in the Logger Sample Timing window have been 
applied to the logger’s memory.

Start at 
specified 
time

This option sets a connected data logger to start taking 
samples at a pre-defined date and time in the future. Until 
then, the logger remains dormant. This delayed start fea-
ture helps to save logger memory and minimizes the col-
lection of unwanted data. You can also use the Start Time 
option to ensure that multiple data loggers are synchro-
nized to start logging at the same time.



Veriteq Spectrum 4.0 User’s Guide

25

If desired, use the Preset button to automatically set the start time hours 
and minutes to the earliest possible setting for the date selected. For any 
day other than the current day, this value is 12:00AM.

You can use the Start at specified time option in conjunction with the Stop at 
specified time option to create a pre-defined data logger monitoring period.

Setting the Stop Mode

The Stop Mode enables you to choose how the connected data logger operates 
once the memory is full, or when a specified time is reached. 
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To set the Stop Mode:

1. Under Stop Mode, select one of the following options:

The Log Time drop-down lists enable you to set an elapsed time for the data 
logger to collect samples. For example, you can set the data logger to collect 
samples for 24 hours, 48 hours, 7 days, and so on.
The Stop Time drop-down lists enable you to set absolute date and time values 
for when the logger is to stop taking samples.
Note: The Log Time and Stop Time options are interrelated. Setting the Log 

Time to a specified period automatically adjusts the Stop Time values. 
Adjusting the Stop Time Date and Time values, in turn, automatically 
adjusts the Log Time values.

Setting the Sample Interval

You can change the sample intervals on the logger to suit the requirements of 
the application. You can set up more frequent sampling intervals to capture rap-
idly changing data, or spread out the readings to maximize memory and cover 
extended monitoring periods.

Wrap when full This is the default method of collecting samples on 
the data logger. When you choose this setting, sam-
ples are recorded in a first in, first out manner. When 
the memory is full, the logger continues to take sam-
ples by discarding the oldest one, and replacing it 
with the newest one. 
The Wrap when full setting ensures that you always 
have the latest data when you transfer from the data 
logger. The length of time that the memory fills and 
wraps around is a function of the Sample Interval 
(see Setting the Sample Interval on page 26) you have 
set on the logger. Veriteq Spectrum automatically 
calculates this time and displays it in the Log Time 
section of the Logger Sample Timing window.
Note: If the memory wraps around too quickly, you 

can choose a longer sample interval.

Stop when full When you choose this method, the logger stops tak-
ing readings once the memory is full. This option al-
lows the maximum amount of samples to be taken 
without overwriting data. It is particularly important 
in any application where there is an excessive time 
delay between the gathering of the data and the trans-
ferring of that data to the PC.

Stop at specified 
time

This method enables you to set a precise time for a 
logger to stop recording data. When you choose this 
setting, both the Log Time and Stop Time sections 
of the Logger Sample Timing window are available.
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Note: You can only change sample intervals if you set the Clear Mode to the 
Clear logger setting (see Setting the Clear Mode on page 22).

To change the sample interval on the currently-connected logger:

1. Select Logger>Sample Timing....

2. Under Sample Interval, use the drop-down lists to set the Days, Hours, 
Minutes, and Seconds to the desired sample interval.
If you want to use a sample interval of once per minute, click the Default 
button.
You can choose intervals ranging from a minimum of ten seconds to once 
every 24 hours.
The total period covered by a logger before the memory is full depends on 
how many channels are enabled and the sample interval. This information 
is automatically calculated in the Log Time section of the Logger Sample 
Timing window.

Note: Running the logger with a sample interval shorter than one minute for a 
prolonged time shortens the battery life.

Enabling and Disabling Logger Channels

The Logger Channels option enables you to enable or disable the channels on 
the currently-connected data logger. 
Note: During this process the data logger’s memory is cleared. If the informa-

tion on the data logger is still of value, transfer the data to a PC before 
enabling or disabling channels.
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To enable or disable data logger channels:

1. Do one of the following:
• Select Logger>Channels... 

• You can also enable or disable data logger channels by selecting Log-
ger>Setup (or pressing F11 or clicking the Logger Setup icon on the 
toolbar ( )). Then, in the Logger Setup window, click the Setup... but-
ton beside the channel you want to enable or disable.

2. In the window that appears, select or deselect the checkbox to enable or dis-
able a channel.

3. Click OK. This initiates the process of clearing the data logger’s memory.
Note: 
• A channel must be enabled before it can start collecting readings.
• It is a good idea to disable unused channels to maximize logger memory.
• If you are using a temperature and humidity data logger, remember that the 

humidity sensor requires temperature values. You cannot disable the tem-
perature sensor channel if you are using the humidity channel. 

Configuring Channels to Work with Transducers

This section applies only to those using Veriteq SP-4000 series data loggers. 
Used with transducers, you can configure SP-4000 series data loggers to dis-
play measurements in units other than milliAmps or volts. 

To configure SP-4000 loggers to work with transducers:

1. In Spectrum, choose Logger>Setup.
2. From the Setup window, click Setup next to the channel to configure.
Different loggers offer different channel types, each with different setup win-
dows and slightly different steps. In general, configure the logger’s typical units 
and range to reflect the units and range you want to display. 
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3. To setup a DC Current channel:

a. Ensure the Channel is enabled by selecting the Channel Enabled check 
box.

b. If applicable, enter a new channel description.
c. From Input Signal, specify the range for your transducer output. 
d. Under Display Units, specify the range and units to display instead of 

the input signal range. For example, psi instead of mA.
e. To set warmup time and save transducer battery life, see Configuring 

Warm Up Time on page 30.
4. To setup a Voltage channel:

a. Ensure the Channel is enabled by selecting the Channel Enabled check 
box.

b. If applicable, enter a new channel description.
c. If applicable, for input range, choose whether this is a 1 or 10 volt range 

channel.
d. From Input Signal, specify the range for your transducer output.
e. Under Display Units, specify the range and units to display instead of 

the input signal range. For example, psi instead of v.
Veriteq also supports a Boolean DC Voltage Channel type on some SP-
4000 loggers. For this type, specify the Threshold Voltage and the result-
ing display units. For example, if you want voltage above the threshold 
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value to show as 1, indicate 1 for Above Threshold and specify the units. 
Boolean choices are typically 1 (above threshold) and 0 (below threshold). 

5. Click OK.

Configuring Warm Up Time

Note: This section only applies to Veriteq SP-4000 data loggers.
Some SP-4000 data loggers have the ability to switch power from an external 
battery onto a transducer using the Warmup Time feature, also known as the 
XPS excitation control switch. This is useful for conserving power when an ex-
ternal transducer is being powered from an external battery. 
Set transducer warm up time to a number of minutes or seconds before data is 
recorded by the data logger. To set when the data logger will record data, see 
Setting the Data Logger Sample Timing on page 22.

To configure transducer warmup time:

1. Choose Logger>Setup.
2. From the row for the channel you want to set up the warm up time for, click 

Setup.
3. From the Setup Channel screen, click Warmup Time.
4. From the Warmup Time screen, select the Timer radio button. 
You can also set up warmup time from the Logger Setup window.
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5. For Timer Value, set the number of minutes or seconds you want the trans-
ducer to begin warming up before taking a sample. The default is 10 sec-
onds. 

6. Click OK.

Configuring Data Logger Channels to Work with Thermocouples

This section applies only to those using Veriteq SP-1700 Series Loggers. Ver-
iteq SP-1700 loggers work with various types of thermocouples (E, J, K, R, S, 
and T). You need to configure your channel to specify the type of thermocouple 
you are using. 

To configure SP-1700 loggers to work with thermocouples:

1. In Spectrum, choose Logger>Setup.
2. From the Setup window, click Setup next to the channel to configure.
3. From the Setup Thermocouple Channel screen, select Enable Channel.

4. From the Display Method list, choose your thermocouple type.
5. Enter a description.
6. Advanced: If your installation includes very long thermocouple cables, 

Veriteq may recommend you specify a temperature offset. Enter it here. All 
values will be adjusted by this offset.
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7. Click OK to save or cancel to close without saving. 

Clearing Logger Samples

Clearing a logger deletes all recorded samples in a logger’s memory. 
You can clear the data logger without making any setup changes, or as an es-
sential part of the following logger setup functions:
• Enabling or disabling channels
• Changing Start Mode settings
• Changing logger sample intervals
Note: You do not have to clear the data logger samples before you start a new 

logging session, but doing so minimizes the storage of unneeded infor-
mation.

To clear the logger without changing the logger setup:

1. Select Logger>Clear.... 

2. In the Confirm System Time window, check the system time. 
If the time shown is correct, click OK. 
If the time shown is incorrect, click Cancel, and then use the Windows 
Control Panel to make the appropriate changes. See Setting System Date 
and Time on page 41. 

Note: The PC's date and time must be accurate when clearing a data log-
ger’s memory or the date and time values in future logger files may 
be incorrect.

After you click OK, a confirmation window opens.

3. Click OK.
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Mounting Data Loggers

Because they are small and light, you can easily mount Veriteq data loggers in 
the field using a variety of techniques including Velcro strips, double-sided 
tape, duct tape, and magnetic strips. 
In harsh environments, place the data logger in a standard industrially-rated en-
closure, and run external sensors and probes from the enclosure using special 
fittings in the openings. 

Some tips for placing the data loggers:

Ventilation: Don’t obstruct the air passage holes in the logger. There should be 
a clear path for the air to get to the internal sensors (if they are used or availa-
ble).
Vibration: Excessive vibration can knock the unit off its mounting. If the lo-
cation is subject to excessive jarring or vibration, mount the logger more se-
curely.
Temperature: Excessive temperature (low or high) can affect adhesives. 
Moisture: Moisture can also affect the adhesive durability.
Permanence: Make sure the mounting location is permanent for the duration 
of the recording period.
Public access: If the logger location is too visible, people may interfere with 
the readings. Make sure it is not too accessible.

Using External Temperature Probes

Veriteq SP 1000, 1016, 1400, 1416, and 1700-series data loggers have external 
temperature channel(s) for use with an external temperature probe. Using the 
external temperature probe enables you to collect data from hard-to-get-at lo-
cations, such as in duct work or under pipe insulation.
You can use an external temperature probe with these data loggers, provided 
the probe was calibrated with the data logger.

To use an external temperature probe:

1. Enable the desired channel on the logger (see Enabling and Disabling Log-
ger Channels on page 27). If you do not need to monitor from the internal 
temperature sensor, disable it to conserve memory. 

Note: You can disable most unused channels - external probe or not - to 
save data logger memory. One exception is the internal temperature 
channel on SP-1700 data loggers.
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2. Attach the temperature probe to the connector on the data logger.

3. Use the Logger>Setup window to test the data logger operation (refresh 
the readings as required).

4. Place the logger in the desired location and start recording.

Caring for Relative Humidity Sensors

Each Veriteq SP-2000 data logger has a relative humidity sensor. Although the 
sensor has been designed to resist contamination and condensation, avoid ex-
posing the data logger to contaminants, if possible.
For information on specific environments, contact Veriteq Instruments.
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Transferring Data

When you transfer data from a data logger’s memory, Spectrum creates a copy 
of the data and stores it on your PC as a logger file.
After inserting a logger file into Spectrum, you can view the information as a 
graph or as a tabular report.
Note: The transfer process does not affect or delete the data on the data logger.
Before transferring data, you may want to set the transfer preferences. 
You should also ensure that you have write permission to the folder on the PC 
where you are going to save your transferred files.

Setting Transfer Preferences

You can configure the default file name format for the Logger file. 

Configuring the Default File Name Format

To configure the default file name format:

1. Select Tools>Options, then choose the Transfer tab.

2. In each of the three fields, select the information you want to include in the 
file name. The options for each field are:

Option Format

None This field is not used in the Logger file name format
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3. Click OK.

Transferring Logger Data to the PC

To transfer the information stored in the data logger to the PC:

1. Connect the data logger to the PC (see page 16).
2. Ensure that the COM port is configured (see page 17).
3. Ensure that you have write permission to the folder on the PC where you 

are going to save the transferred files.
4. Do one of the following:

• Select Logger>Transfer.
• Press F12.
• Click the Transfer values toolbar icon ( ).

Serial number Eight digit logger serial number

Description Description of logger

Date and time yyyy-MM-dd_hh-mm, where:
• yyyy is the year
• MM is the month
• dd is the day
• hh is the hour
• mm is the minutes

Date yyyy-MM-dd, where:
• yyyy is the year
• MM is the month
• dd is the day

Time hh-mm, where:
• hh is the hour
• mm is the minutes

Option Format
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This starts the communications process between the logger and the PC and 
opens the Transfer Wizard window.

5. Confirm that the current date and time shown in the window are correct. If 
the date and time are not correct, use the Windows Control Panel to update 
the system and time. See Setting System Date and Time on page 41.

Note: The PC's date and time must be correct when setting up a data logger, or 
transferring logger data. Otherwise, the timestamp in the Logger file is 
incorrect.

6. Click Next. 

7. Edit or confirm the description of the logger using a maximum of 40 char-
acters. The default entry for this field draws from the existing Description 
in the logger’s memory (maximum 16 characters, see Configuring Data 
Loggers on page 18). You can accept the default, or use the extra characters 
to further describe the application or location of the data logger.
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Note: Changing the description here does not modify the description in the 
logger’s memory. 

8. Edit or confirm the description of listed logger channels using a maximum 
of 12 characters. 

9. Click Next.
10. Accept the default name for the Logger file or click the Browse... button to 

save the Logger file under a different name.

11. Click Finish.
The logger transfers its data to the PC while displaying the progress of the 
transfer in the Transferring Samples window.

Note:  After the transfer, the data remains in the logger. If the logger mem-
ory was not full, the data logger continues to store additional data in 
its internal memory without interruption. If you want to clear the 
data logger, see Clearing Logger Samples on page 32.
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12. A dialog box appears, prompting you to insert the newly transferred logger 
file into a new graph or the active (current) graph, if one is active. Choose 
the appropriate radio button.

13. Click OK.

14. From the Select Channels window that appears, confirm the channels you 
want to display in the graph.

15. Click OK.
16. If one of the channels you want to display records relative humidity, the fol-

lowing window opens. Confirm the display method for the relative humid-
ity channel.

17. Click OK.
18. The newly transferred file will appear in the active graph or a new graph 

based on your choice in step 12.
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Setting System Date and Time

To set the PC’s date and time using the Windows operating system:

1. Select Start>Control Panel, and then double-click Date/Time.
2. Reset the time to the correct values.
3. Click OK.
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Displaying Existing Graph Files

To open an existing Graph file (.spg):

1. Do one of the following:
• Select File>Open.
• Press CTRL+O.
• Click the Open File icon on the toolbar ( ).

2. Navigate to the Graph file you want to open.
3. Click Open.
The graph opens in the Spectrum window.

Creating New Graph Files

To create a new graph:

1. Do one of the following:
• Select File>New.
• Press CTRL+N.
• Click on the New Graph icon on the toolbar ( ).

An empty graph window opens, ready for you to insert one or more Logger 
files. The new Graph file has a default name (for example, Graph1). You can 
rename the graph when you save it.

Inserting Logger Files

To insert a Logger file into a new graph:

1. Do one of the following:
• Select File>Insert Logger Files...
• Select File>Insert Logger Files from sGo Folder...
• Press CTRL+I.
• Right-click the graph, and select Insert Logger Files...
• Right-click the graph, and select Insert Logger Files from sGo Folder..
• Click the Insert Logger File icon on the toolbar ( ).

2. Navigate to the Logger file you want to insert.
3. Click Open. 
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The Select Channels window opens.

4. Select the channels you want to display in the graph.
5. Click OK. 
6. If you are inserting a file with temperature and humidity, and the option for 

confirming display method for relative humidity has been set to YES, the 
Confirm Relative Humidity Channel window opens, prompting you to 
choose a display method for relative humidity

a. Confirm the method for displaying values:
• Relative Humidity
• Dewpoint.

b. Click OK. 
If you do not want to see this window every time you work with humidity 
logger files, do one of the following:

• Select the Do not display this message again check box before 
clicking OK.

• Select Tools>Options, choose the Insert tab, and clear the Confirm 
display method for relative humidity channels check box.

7. The Logger file is displayed as a graph in the Graph file. If the Logger file 
has more than one channel, Spectrum automatically selects distinct colors 
for each graph line.

You can insert multiple logger files in one graph. This works best if the range 
and dates measured in the logger files are similar. For more, see Inserting Mul-
tiple Logger Files on page 46.
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Inserting Multiple Logger Files

You can insert more than one Logger file into a single Graph file. This enables 
you to easily compare data, and is especially useful for before-and-after studies 
or to check interactions of data collected from different loggers.
To insert additional Logger files into a Graph file, follow the instructions in In-
serting Logger Files on page 44 for each Logger file you want to insert.

Scrolling Through Graphs

Scrolling allows you to shift the view of an on-screen graph to the right or to 
the left. Each time you scroll, the graph view shifts by one graph division.

To scroll the on-screen graph to the left:

1. Do one of the following:
• Select Format>Scroll Backward.
• Press ALT+Left Arrow.
• Click the Scroll Backward icon on the toolbar ( ).

To scroll the graph to the right:

1. Do one of the following:
• Select Format>Scroll Forward.
• Press ALT+Right Arrow.
• Click the Scroll Forward icon on the toolbar ( ).

Pinpointing Graph Values and Times

To pin-point exact values and times on the currently-active graph:

1. Do one of the following:
• Select Format>Position Cursor.
• Press F7.
• Right-click the graph, and then select Position Cursor.

•  Click the Position cursor icon on the toolbar ( ).
2. Position the cursor line along the X axis using the mouse or the arrow keys. 

The values at the bottom left portion of the window indicate the exact date 
and time where the cursor line is positioned as well as the exact values that 
correspond to that point.
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3. To lock the cursor in place, click the mouse or press ENTER.

To remove the vertical cursor bar:

1. Do one of the following:
• Select Format>Remove Cursor.
• Press F8.
• Right-click the graph.
• Click the Remove cursor icon on the toolbar ( ).

Adding Graph Titles

To add a descriptive title to the currently active graph:

1. Do one of the following:
• Select Format>Title...
• Right-click the center of the window, just above the graph, and select 

Format Title...
• Double-click the center of the window, just above the graph.
The Title window opens.

2. Type the desired title (up to 50 characters long).
3. Click OK.

Selecting a Graph Font

You can select any font that is on the PC to use for all displayed and printed 
graphs.

Date/time

Measured readings
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To change the graph font:

1. Select Tools>Options, then choose the General tab.
2. Click the Graph Font... button.

3. Select the desired Font, Font style, and Size.
4. Click OK.
5. If the font style and size are inappropriate, choose Restore Defaults.

Zooming In

Zooming allows you to look closer at a portion of the currently-displayed 
graph. It also enables you to eliminate extraneous data and produce a graph and 
a tabular printout that cover a set time period, such as 24 hours.
You can zoom-in two ways:
• Use the zoom selection box. This is the quickest and easiest way to zoom. 
• Use the Format>Time Scale... option. This gives you precise control over 

the X-axis time scale of the zoom. You can zoom-in by entering exact start 
and end times and dates. For instructions on using this option, see Zooming 
In by Formatting the Time Scale on page 50).

Zooming In Using the Zoom Selection Box

To zoom in on the graph using the zoom selection box:

1. Do one of the following:
• Select Format>Zoom-in.
• Press F9.
• Right-click the graph, and then select Zoom-in.
• Click the Zoom-in icon on the toolbar ( ).
A vertical line appears on the graph. 

2. Use the mouse or arrow keys to move the vertical line to the beginning of 
the section you want to zoom-in on.
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3. Either:
a. Press and hold the left mouse button, and move the second cursor line 

to the end of the section you want to zoom in on.
b. Release the mouse button and the zoomed-in area is displayed.
Or:

a. Press ENTER to anchor the vertical line. 
b. Use the arrow keys to stretch the zoom selection box. 
c. Press ENTER and the zoomed in area is displayed.

Note: If you have difficulty stretching the Zoom box accurately over the data, 
try turning off the Time Scale rounding setting. Select Tools>Options, 
then choose the General tab and clear the Automatically round off 
time scale after zooming in check box.



Working with Graphs

50

Zooming In by Formatting the Time Scale

To zoom in by formatting the time scale:

1. Do one of the following:
• Select Format>Time Scale...
• Place the cursor over the date and time at the bottom of the graph, and 

right-click, and then select Format>Time Scale... 
The Format Time Scale window opens.
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2. Under Start Time, use the drop-down lists to select the start date and time 
that correspond to the beginning of the section of the graph you want to 
view in greater detail.

3. Under End Time, use the drop-down lists to select the end date and time 
that correspond to the end of the section of the graph you want to view in 
greater detail.
You can also use the Preset buttons to automatically set the time to the 
beginning of the Calendar day chosen (12:00:00 AM).

4. Click OK.

Zooming Out

To zoom-out:

1. Do one of the following:
• Select Format>Zoom-Out.
• Press F10.
• Right-click the graph, and then select Zoom-out.

• Click the Zoom-out icon on the toolbar ( ).
You can keep zooming out until you have returned the graph to its original con-
dition.

Formatting Time Zones

Veriteq Spectrum Software sets the default time zone when the Graph file is 
created.  If desired, the time zone can be changed.

To change the time zone:

1. Do one of the following:
• Select Format>Time Zone.
• Right-click the x-axis of the graph, and then select Format>Time Zone.
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2. Select the appropriate time zone from the drop-down list.
3. Click OK.

Formatting Measurement Units

Veriteq Spectrum Software automatically determines Y-axes scales appropri-
ate for any displayed graph and sets a default level of decimal place precision. 
If desired, you can override these settings.

Specifying the Y-axis Scale

To change a Y-axis scale:

1. Do one of the following:
• With the Graph file you want to modify open, select

Format>Units...
• Right-click the Y-axis units, and select Format>Units...
• Double-click the Y-axis units. 
The Format Units window opens.

2. Under Units, use the drop-down list to select the desired units of measure-
ment.

3. Choose to apply the settings to the current graph or all new graphs (System 
Default) using the appropriate radio buttons. If you select System Default, 
the settings entered here automatically apply to new graphs that use the 
same units (that is, °C, °F, and so on).

4. Under Scale, select the Manual button, then enter the maximum and min-
imum values for the axis that you want displayed.

5. Click Apply to apply changes, and OK to close.
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Changing the Decimal Place Precision

To change decimal place precision:

1. Do one of the following:
• With the Graph file you want to modify open, select

Format>Units...
• Right-click the Y-axis units, and select Format>Units...
• Double-click the Y-axis units. 
The Format Units window opens.

2. Under Units, use the drop-down list to select the measurement units you 
want to change.

3. Under Change Settings For, use the drop-down list to select where you 
want the changes to apply—the Current Graph or System Default. If you 
select System Default, the settings entered here automatically apply to new 
graphs that use the same units.

4. Under Decimal Places, select the Manual option and use the drop-down 
list to select the desired number of decimal places.

5. Click Apply to apply changes, and OK to close.

Changing the Temperature Scale

You can display temperature in Fahrenheit or Celsius.

To change the temperature scale:

1. Select Tools>Options, then choose the General tab.
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2. Under Temperature scale, select Fahrenheit or Celsius.

This setting affects the data in all graphs, displays, and printed reports.

Setting Sample Smoothing

In Spectrum, sample smoothing controls how samples in a logger file are inter-
preted when they are inserted into a graph, allowing you to dampen the effects 
of ‘noise’ in Logger files. 
Sample smoothing is the minimum change in input signal required to cause a 
change in displayed channel values, and is defined in raw analog-to-digital con-
verter counts. 
Spectrum allows you to set two different sample smoothing values: one for 
thermocouple channels, the other for other channel types. 
Note: Sample smoothing only affects how samples are interpreted and pre-

sented in graphs and reports; the data in the loggers and the logger files 
is not affected by any settings related to sample smoothing.
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To set sample smoothing:

1. Select Tools>Options, then choose the Insert tab.

2. Under Sample smoothing (in raw counts), select one of the following op-
tions.

3. Click OK.

Displaying Line Numbers on Graphs

Spectrum displays the lines on graphs in different colors. If desired, you can 
add numbers to the lines in the graph.

Zero Produces the most responsive graph, but makes 
the recorded readings susceptible to noise

One (default) Suitable for most applications

Two Decreases input noise and produces a more sta-
ble graph
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To display numbers on the graph lines:

1. Select Tools>Options, then choose the General tab.

2. Under Line numbers on displayed graphs, select Enabled.
3. Click OK.

Copying and Pasting Graphs

Spectrum allows you to copy graphs into the Clipboard for pasting into other 
applications, such as Microsoft Word.

To copy graph data:

1. From Spectrum, choose Edit>Copy.
2. Go to the application you want to paste the graph image into. In this appli-

cation, choose Edit>Paste.

Exporting Graph Data

Spectrum allows you to export graph data into either .txt or .csv format. You 
can also specify whether to have date and time saved within one column or sep-
arated. As an alternative, you can view and save the Report; it contains identical 
data, plus much more.
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To export graph data to .txt or .csv files:

1. By default, date and time are exported in a single column. 
To have date and time exported into separate columns:

a. Select Tools>Options, then choose the Export tab.
b. Select the Export the date and time in separate columns option.

c. Click OK
2. To export the file, choose File>Export.... 

The File Save As window opens.

3. Navigate to the location where you want to save the file.
4. In the File name box, type the desired file name.
5. In the Save as type box, accept the default CSV (comma-separated val-

ues)(.csv) file type, or select Text (Comma delimited)(*.txt). You can 
readily import either file format into most popular spreadsheet and data-
base programs for further analysis and manipulation.

6. Click Save. 
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Saving Graphs

To save changes to a graph file (.spg) for later use:
1. Choose File>Save or File>Save As.
2. Navigate to the location to save your file, enter a file name, and click Save.
To export graph data, use File Export and see Exporting Graph Data on page 
56.

Printing Graphs

Printing Line Numbers on Graphs

Spectrum displays lines on graphs in different colors. For monochromatic 
printers, Spectrum automatically adds numbers to the graph lines when the 
graph is printed (when in auto mode). 

To change this option:

1. Select Tools>Options, then choose the General tab.

2. Under Line numbers on printed graphs, select one of the following op-
tions.

Auto Lines are numbered if the graph is printed on a monochro-
matic printer and not numbered if the graph is printed on a 
color printer.

Disabled Lines are not numbered on the printed graph, even if it is 
printed on a monochromatic printer.

Enabled Lines are numbered on the printed graph, even if it is 
printed on a color printer.
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3. Click OK.

Print Preview

To view a print preview of the current graph:

1. Select File>Print Preview.
The Print Preview window opens.

2. If you want to view the graph in more detail, select Zoom In.
3. When you are ready to print the file, select Print....

Printing Graphs

To print a currently-active graph:

1. Do one of the following:

• Click the Print Graph icon on the toolbar ( ), which sends the graph 
immediately to the printer. (Skip steps 2 &3). 

• Select File>Print.
• Press CTRL+P.
The Print window opens.

2. Configure the printer settings.
3. Click Print.
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6 Viewing Reports and Statistics
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Working with Reports

Reports display logger file information in a tabular format. You must have at 
least one file inserted in Spectrum to view a report. To insert a file, see Inserting 
Logger Files on page 44.

To view a report for the currently-active graph:

1. Do one of the following:
• Select View>Report.
• Press F6.
• Right-click anywhere on the graph and select View Report.
• Double-click anywhere on the graph.

2. The Report window summarizes the information in the Graph file, as well 
as related information on the data loggers whose files are inserted and the 
loggers’ setup parameters.

3. To print the report, from the Report window, select File>Print or press 
CTRL+P.

To change the font size in printed reports:

1. Do one of the following:
• From Spectrum, select Tools>Options, then choose the Report tab.
• From the Report window, select Tools>Options, then choose the Report 

tab.
• From the Report window, right-click and choose Options, then choose 

the Report tab.
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2. From the Report tab, on the Printer font size box, select an option from the 
drop-down list, or type the desired font size.

3. Click OK. 

Copying and Pasting Report Data

You can copy report data from all Spectrum Reports for use in other applica-
tions, such as Microsoft Word or Microsoft Excel.

To copy report data:

1. From Spectrum, choose the report to view from the View menu.
2. From the report window, choose Edit>Select All.
3. From View Report, with all contents highlighted, choose Edit>Copy.
4. Go to the application you want to paste the report data into. In this applica-

tion, choose Edit>Paste.
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Saving Reports

To save report data:

1. From the report window, choose File>Save As.

2. Navigate to the location where you want to save the file.
3. In the File name box, type the desired file name.
4. In the Save as type box, choose one of the following file types for your file:

• CSV (comma-separated values)(.csv) 
• Text (Comma delimited)(*.txt)
• Plain text (*.txt). 

You can readily import these file formats into most popular spreadsheet 
and database programs for further analysis and manipulation.

5. Click Save.

Printing Reports

To print reports, from the report window, do the following:
1. Select File>Print.
2. Configure the printer settings.
3. Click Print. 
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7 Troubleshooting
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Serial Port Problems

If you are experiencing difficulties communicating with Veriteq data loggers, 
here are some tips and things to try before calling Veriteq Instruments.

Software Error Messages you May Encounter…

Unable to allocate COM port because it is busy

This error message means that Spectrum was unable to allocate the COM port 
because it was already allocated by a different program. You may have to wait 
until the COM port becomes available. 

Unable to allocate COM port because it is unavailable 

This error message means that Spectrum was unable to allocate the COM port 
because it did not exist in the operating system. Check your available COM 
ports.

Unable to receive sync byte from COM port

This error message means that Spectrum sent a request message to the data log-
ger, but did not receive any response from the data logger. This could mean the 
data logger is unplugged or the cable is not connected properly.

Unable to receive all of the bytes from COM port

This error message means that Spectrum sent a request message to the data log-
ger, but received an incomplete response message from the data logger. This 
may mean there is a problem with the COM port on this PC, a problem with the 
cable, or a problem with the logger itself. Check these possibilities.

Unable to communicate with logger on COM port

This error message covers miscellaneous error conditions, other than those list-
ed previously. This message could mean that there is a problem with the COM 
port on this PC, a problem with the cable, or a problem with the logger.    
Things to Try:  
1. Does the logger and interface cable work on a different PC? If so, the prob-

lem likely resides in the serial port configurations on the PC.
2. Are there other devices (such as a mouse) that use the serial port in question 

without problems? If so, that port is likely not the problem.
3. Can you transfer data using a different interface cable? If so, the cable may 

be damaged.
4. Can you transfer data using a different logger (with the same interface ca-

ble)? If so, the data logger may be damaged.

Invalid hardware model

This error message means that Spectrum did not recognize the hardware model 
of the data logger, and as a result, did not know how to interpret the information 
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stored in the data logger. Ensure you are using a data logger supported by Spec-
trum. 

Unable to create logger file

This error message is generated when Spectrum attempts to create a logger file 
on a disk and an error occurs. Some possible reasons include: 
• The disk is full. 
• The user does not have write access to the disk. Ensure the user has write 

permission to the folder where the logger file is being saved.
• The file is already open by a different program. Close it.
• The file name is invalid. Try using a more simple .spl file name. 

Frequently Asked Questions

I have recently upgraded Veriteq Spectrum software to the latest version. Will 
this new software work with my existing loggers and files?
Yes. Each version of Veriteq Spectrum software is designed with backward 
compatibility. This means that it works with all previous versions of loggers or 
files created from those loggers.

I have recently purchased a new logger. Will it work with my older version of 
Spectrum software?
Not always. In our pursuit of continual product improvement, we periodically 
upgrade logger hardware or release new logger models. Unfortunately, these 
changes may not be recognized by an older version of Veriteq Spectrum soft-
ware and can result in difficulties. For that reason, each logger that you pur-
chase includes a note indicating which software version it must be used with. 
The safest choice is to always upgrade to the latest version of software. Contact 
Veriteq Instruments if you require a software update.

Does the software account for daylight savings time changes?
Yes. Daylight savings time changes are automatically accounted for in all graph 
and tabular displays.

How many logger files can I overlay onto the same graph?
You can overlay many channels of data onto the same graph; in testing, we in-
serted more than 100 channels successfully.

Do all graphs have to be created from one data logger?
No. You can create graphs using files from different data loggers and different 
data logger models.
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A– B

C–E

F–K

L–Q

Ambient temperature The average or mean temperature of the surrounding air that comes in con-
tact with the equipment or instrument.

Axis A line that borders one side of the graph area, providing a frame of reference 
for measurement or comparison. In Spectrum software, measurement values 
are plotted on the vertical Y-axis while date and time values are plotted on the 
horizontal X-axis.

Calibrate To compare and correlate readings against a standard measurement.

Calibration certificate Documented evidence that a product has been calibrated against a standard 
measurement reference and that it falls within the specified requirements.

Channel The path through which an instrument receives the input signals it measures.

Dewpoint Dewpoint is defined as the temperature at which the amount of moisture 
present in the air is the MAXIMUM amount the air can hold (at a constant 
pressure and water vapor content). This means that when the temperature 
falls to the dew point, the relative humidity is 100% and the air is considered 
saturated.
Dewpoint does not vary with temperature, as does relative humidity (RH). 
Rather, dewpoint is a DIRECT measure of the actual moisture content in the 
air and thus is preferred as the unit of measurement in many scientific and 
industrial applications—particularly in tightly controlled environments where 
precise indications of water content in the air are required.
The dewpoint is never greater than the air temperature. Once the dewpoint is 
reached and the air temperature continues to drop, water vapor is forced to 
leave the air through condensation. This condensation may take the form of 
water droplets, dew, or may remain suspended in the air as clouds or fog.
To better understand how dewpoint and relative humidity are related to each 
other, try inserting a logger file with relative humidity (RH) channel values into 
a graph twice—once, displaying RH using dewpoint and once displaying RH 
using relative humidity.
In Spectrum, dewpoint readings below 0 degrees C are recorded as frost-
point. 

Graph file A file that is created to display the data from one or more Logger files. Graph 
files retain formatting information such as graph title, zoom levels, Y-axis scal-
ing, and Logger file data; and are identified by their .spg extension (for exam-
ple, LAB_1.spg).

Local time A value equal to the current time used at a particular location. A relative indi-
cator of time meaningful only if Time Zone Information is also known. Local 
Time contrasts with UTC Time, an absolute time reference. The software 
records Local Time and UTC Time in each Logger file.
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R–T

Logger file A file that is created after transferring a logger’s data to the PC. The file con-
tains the collected readings (from all active channels) for the transferred log-
ger, including the logger’s description, model number, serial number, 
firmware version number, file description, Local time, and UTC (Universal 
Time Coordinated) time. Logger files are identified by their .spl extension (for 
example, PRIMARY_GAS_FLOW.spl). Logger files cannot be viewed 
directly—you have to insert the Logger file into a Graph file before the data is 
displayed as a graph.

NIST An acronym for the National Institute of Standards and Technology.

Range Normal operating limits, specified by the lowest calibration point to the high-
est calibration point.

Relative humidity Relative humidity is the measure of the amount of water vapor in the air com-
pared to how much it can possibly hold at that temperature. A relative humid-
ity of 50% means that the air contains only one-half as much water as it could 
possibly hold. The capacity of air to hold water is heavily dependent on the 
temperature of the air. The colder the air, the less water it can hold. Air at 
50°F can hold only one-quarter the amount of water as air at 95°F.

Sample A measurement reading that is stored to data logger’s memory.

Sample smoothing 
(deadband)

A setting in Spectrum (Tools>Options>Insert tab - Sample smoothing) that 
controls how the samples in a logger file are interpreted when they are 
inserted into a graph. Sample smoothing (or sample deadband) is the mini-
mum change in the input signal required to cause a change in the displayed 
channel values. Sample smoothing is used to dampen the effects of noise, 
and is defined in terms of raw analog-to-digital converter counts.

Sample interval The sample interval is the rate at which the logger takes and records readings 
to memory. The sample interval applies to all enabled channels on the logger. 
You may want to occasionally change the sample interval on the logger 
because:
• Faster sample rates may be required by the application.
• You need to record readings over a longer duration.
• You want to minimize the collection of unnecessary data.

Scale The range of values a graph displays.

Serial port The communications port to which you can attach devices such as a modem, 
mouse, or serial printer to the computer. The serial communication ports on 
the computer are commonly referred to as COM1, COM2, COM3, and so on. 
Serial ports exchange data sequentially, one unit at time.

Stability The ability of a sensor or measurement instrument to maintain its perfor-
mance characteristics over a specified period of time.

Thermistor A temperature-sensing element (a thermally-sensitive resistor) composed of 
sintered semiconductor material that exhibits a large change in resistance in 
proportion to a small change in temperature. The relationship between tem-
perature and resistance is approximated for most thermistors by the Stein-
hart-Hart equation.

Traceable Capable of being traced back to a recognized measurement standard or ref-
erence. 
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U–Z

Transfer The term used when the software makes a copy of the data contained in a 
connected data logger. The transfer process creates a file on the PC but does 
not affect or delete the data on the logger. Other terms commonly used to 
describe the transfer process are download, upload, backup, or copy.

USB An acronym for Universal Serial Bus, a standard for connecting external 
devices such as a mouse, keyboard, scanner, printer. USB offers many ben-
efits over serial and parallel port connections, including thinner and cheaper 
cables, greater expandability (with the addition of a USB hub, a single USB 
port can handle over 100 peripheral devices) and greater speed. 

UTC An acronym for Universal Time Coordinated, UTC is a standard time com-
mon to every place in the world. Also known as Greenwich Mean Time (GMT) 
and World Time. UTC is expressed using a 24-hour clock but can be con-
verted into a 12-hour clock (AM and PM). An absolute time reference that 
does not rely on Time Zone information, UTC contrasts with Local time. UTC 
and Local Time information is contained in Logger files and is used to form 
the time base on logger graphs and data. 

Zooming Enlarging a portion of an on-screen graph.
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