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第一章：ENVI 概述 
如何使用本手册 
本手册包括若干章节；每章描述 ENVI 提供的一系列处理程序。多数章节遵循 ENVI 的菜单

结构。例如，第 4 章的标题为 “Basic Tools”，它描述的功能可以在 ENVI 的 Basic Tools 下拉菜单
下找到。5 个附录分别针对：ENVI 基本功能、文件格式、波谱库、地图投影以及描述 ENVI 该版
本的新特征。该介绍性章节包括与 ENVI 图形用户界面（GUI）的交互，使用 ENVI 窗口，及其它
介绍性材料。新的 ENVI 用户使用前务必认真阅读本手册，以及附带的 ENVI 教程。 

对于章节中的每个主题，功能描述之后给出了实现它的一步步向导。向导中描述了参数，通常

还附有建议和例子。大多数功能 （除了交互的功能） 从 ENVI 的下拉主菜单启动。出现包含接受
用户输入参数的对话框。许多参数包含系统默认值并且有一些是可选的。当功能运行时，出现一个

处理状态窗口。 

运行功能的一步步向导被编号并且用粗体显示。鼠标控制菜单选项与用斜体字印刷的下拉菜单

一同出现。子菜单用 “>” 连接。每个步骤内的选项用项目符号显示。按钮名用引号标明，对话框标
题以大写字母开头。一些对话框内部有下拉菜单。每个下拉菜单下的选项通常在以该下拉菜单名

为标题的一节中描述。 

例如，这些是如何对一个文件进行中值滤波的向导： 

1. 从 ENVI 主菜单，选择 Filters > Convolutions > Median 。 

将出现一个文件选择对话框, 允许你交互地改变目录并选定需要的输入文件。 

2. 通过点击文件名，再点击 “OK” 或 “Open”，来选择所需要的文件。 

若有必要，使用任意空间和/或波谱的构造子集（subsetting）。 

3. 当出现 Convolution Parameters 对话框，在 “Size” 文本框中，输入所需要的滤波器大小。 

4. 选择输出到 “File” 或 “Memory”，若需要，键入一个输出文件名。 

5. 点击 “OK”，开始处理。 
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ENVI 图形用户界面（ GUI ）  
要有效地使用 ENVI，你必须熟悉图形用户界面（GUI）的概念。GUI 提供与菜单和数据交互

的一种图形方式。通过使用鼠标或其它指定设备来指向和单击或点击和拖曳，从而完成选择。本手

册假设你熟悉这些概念，并且把描述限定到 ENVI 的 GUI 。 

ENVI 用户界面由小部件（widgets） 或控件（controls） 构成。小部件是 GUI 的组装部件––––
它们允许你通过点击、输入文本、或选择，以与程序交互。选项由菜单组成，这些菜单由小部件构

成。选择某个菜单项可以弹出一个对话框，它要求用户输入和交互。 

所有的 ENVI 操作通过使用 ENVI主菜单来激活，它由横跨屏幕顶部的一系列按钮排列成的小
部件组成（显示在上面），或沿着一条边（显示在右边）。布局取决于用户选择的配置参数（第 786 页
上的 “ENVI Configuration File”）。在该文档中，主菜单上的菜单项被称为 “ENVI下拉菜单”，并且
用斜体印刷。以下部分将更详细地描述小部件和菜单。 

鼠标按键描述 

ENVI 整篇都提到使用三个按键的鼠标。没有至少 3 个按键的鼠标（或模拟 3个按键的方式）
和适当的鼠标驱动程序软件的系统，将不能运行 ENVI 要求第 3个鼠标按键完成的部分。对于 ENVI 
for Macintosh 和 ENVI for Windows，包括了三按键模拟。要模拟一个三按键鼠标： 

对于Windows ： 

·中间按键的模拟是通过按"Ctrl" 键和鼠标左键实现的。 

对于Macintosh ： 

·苹果鼠标的单个按键作为鼠标左键。 

·右键的模拟是通过按"Apple" 键和鼠标按键实现的。 

·中间按键的模拟是通过按"Option" 键和鼠标按键实现的。 

下拉菜单 

下拉菜单由菜单项和附加按钮组成,这些按钮仅当鼠标左键按在菜单项上时出现。下拉菜单用于
从一个层叠的选择列表中选择单个 ENVI 菜单项或操作。在名字后有箭头的菜单项含有子菜单，若
选中出现子菜单项。在名字后带有 “...” 的菜单项，启动一个需要附加用户交互的弹出对话框。没有
圆点的菜单项直接执行指定操作。你可以通过在菜单项上单击和按住鼠标左键、或拖曳下拉选择下

拉菜单，当合适的菜单项或操作高亮度显示时释放鼠标按键。 

图 1-1 ：下拉菜单。 

菜单栏 

菜单栏只不过是横跨另外一些小部件顶部的一组下拉菜单标签。运用上述描述的关于下拉菜单

的用法进行选择。所有的菜单栏都有一个 File 下拉菜单，在其下面可以选择 Cancel 关闭小部件。 

图 1-2 ：菜单栏。 
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按钮小部件 

按钮小部件 （ 在整篇文档中称为"按钮" ） 由一个包含描述 ENVI 功能或操作的文本标签的
矩形组成。在矩形内用鼠标左键点击文本,来执行与按钮相对应的功能。 

切换按钮与单选按钮 

切换按钮是一个圆形或菱形的，含有外部相关文本的按钮。点击按钮或相关文本，在选（on）
和不选（off）之间切换按钮。一些切换按钮组是单选型按钮，只允许一次选择一个按钮。这时，选
择一个按钮将导致其它的所有已选按钮被取消。 

图 1-3 ：一个含小部件类型的对话框例子。 

复选框（check boxes） 

复选框与切换按钮相似。在框上点击来选择选项，并且框用"X"标记。用这种小部件，可以一次
选择多个选项。 

箭头切换按钮 

箭头切换按钮是由与文本相关的一个矩形按钮框架内的两个箭头组成的一个位图按钮。点击按

钮，在两种可能选项之间切换显示。已选择的选项显示在相关的文本框中。 

可编辑的文本小部件和标签小部件 

可编辑的文本小部件是提供用户键盘输入的矩形框。ENVI中，许多可编辑的文本小部件首次出
现时，含有系统默认的文本字符串。可编辑的文本小部件的内容可以通过在框内点击鼠标左键以标

签要插入的文本位置，然后用键盘输入文本来实现。 

标签小部件由用于标签其它小部件的文本组成。标签小部件不能被编辑。 

列表小部件 

列表小部件由含有一列可用选项的矩形框组成。在文本选项上用鼠标左键点击选择。若有更多

的选项可以在列表小部件定义的大小内显示，位于小部件右边的垂直滚动条允许你向上或向下滚动

列表，直到看见需要的选项。若使用 UNIX 平台，当一列表选项比列表小部件定义的宽度宽时，会
出现第二个滚动条（水平滚动条）。要选择列表小部件中的选项，你有下列选择： 

·要选择单个选项，在该选项上点击鼠标左键。 

·要在列表中选择一组连续选项，在第一项上点击，按住键盘上的 "shift" 键，然后在最后一项
上点击鼠标左键，以选择两者之间所有选项，或点击并向下拖曳到该范围的最后一项。 

·要在列表中选择不连续出现的多个选项，在需要的项上点击鼠标左键，按住键盘上的 "ctrl" 键，
然后在其它需要的项上点击鼠标左键。要从一组已选择的选项中取消选择，使用同样的方法。 
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用于绘图的小部件 

用于绘图的小部件由显示 ENVI 图像和图形的一个矩形区域组成。移动鼠标光标到绘图小部件
处，并点击鼠标的左、中或右键分别执行 ENVI的各个任务（取决于窗口的功能）。绘图小部件可以
调整大小：点击小部件的一角，按下鼠标左键，然后拖曳到窗口需要的大小。 

箭头增量按钮 

箭头增量按钮是一个内含两个小箭头的可编辑的文本小部件。文本小部件内的值可以使用键盘

输入来改变，或通过使用箭头增加或减少参数的值。在向上/向下箭头上点击鼠标左键，变化量为 1
地增加/减少文本框的值。在向上/向下箭头上点击鼠标中键，变化量为 5 地增加/减少文本框的值。
在箭头上点击鼠标右键，将重新设置参数到它的初始值。 

图 1-4 ：用于绘图的小部件 

图 1-5 ：一个箭头增量按钮 

Slider 小部件 

slider 小部件由一个带有标签的工具条, 一个附属的滚动工具条，和（特别地）滚动工具条附近
的文本值组成。点击并按住鼠标左键，直至拖曳到一个新的位置，以改变 slider 的值。视操作系统
情况而定，移动 slider时，其值可以连续地显示，或刚释放 slider按钮，其值就被更新。 

图 1-6 ：一个 Slider 小部件。 

ENVI对话框基础 

你和 ENVI 的交互将经常通过对话框进行。这些对话框由不同的小部件组成，并且当 ENVI 需
要你输入以便继续运行功能时会“弹出”（见图 1-3 ）。它们经常通过选择一个后面带有"..."的下拉
菜单项来激活。在一个对话框中，你可以发现各个小部件，包括系统预先设置的默认值。在一个对

话框中，显示这些值的目的是允许你根据自己的需要选择它们。 

大多数对话框包含标签为"OK"和"Cancel"的按钮。点击"OK"按钮，告诉 ENVI 把输入传递给功
能。点击"Cancel"，在没有启动功能的情况下退出对话框。 

通用的图像显示概念 
ENVI 中的图像显示由一组三个不同的图像窗口组成：主图像窗口、滚动窗口和缩放窗口。ENVI 
图像显示的一个例子如图 1-7 所示。一个显示组的单个图像窗口可以被缩放和放置在屏幕的任何一
处。多个图像的显示可以通过从 ENVI的 File下拉菜单下的 Display Controls子菜单中选择 Start New 
Display来启动，或通过点击现有波段列表内的"New"（参见第 47页的"The 可利用波段列表"）。 

主图像窗口 

主图像窗口由一幅以全分辨率显示的图像的一部分组成。该窗口在你第一次载入一幅图像时自

动地被启动。窗口的起始大小由在 envi.cfg 配置文件中设置的参数控制 （参见第 786 页上的 "The 
ENVI Configuration File"） 。它也能动态地被缩放 （参见第 45 页上的"Resizing Windows"）。ENVI 
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允许装载多个主图像窗口及相应的的滚动和缩放窗口。 

主图像窗口内的功能菜单 

在主图像窗口内点击鼠标右键，切换隐藏子菜单的开启和关闭。该 "Functions" 菜单控制所有
的 ENVI 交互显示功能，这包括：图像链接和动态覆盖；空间和波谱剖面图；对比度拉伸；彩色制
图；诸如 ROI的限定、光标位置和值、散点图和表面图等交互特征；诸如注记、网格、图像等值线
和矢量层等的覆盖（叠置）；动画以及显示特征。 

滚动窗口 

滚动窗口是一个以二次抽样的分辨率显示大图像的小图像显示窗口。滚动窗口位置和大小最初

在 envi.cfg 文件中被设置并且可以被修改。只有要显示的图像比主图像窗口以全分辨率能显示的图
象大时，才会出现滚动窗口。你可以动态地将其缩放到任何大小直至全屏（参见第 45 页上的 
"Resizing Windows "）。当你练习这一选项时，重采样系数会自动改变以适用于新的图像大小。重采
样系数出现在滚动窗口标题栏的括号内。对于滚动窗口中被再次重采样的大图像，你可以缩放到区

域内，并减少重采样系数。可能出现多个滚动窗口，每个窗口对应于一个已载入的主图像窗口。 

图 1－7：一个 ENVI显示组。这些窗口可以分别置于屏幕的任何位置。 

缩放窗口 

缩放窗口是一个小的图像显示窗口，它以用户自定义的缩放系数使用像元复制来显示主图像窗

口的一部分。缩放窗口的大小、位置和系统默认的缩放系数最初在 envi.cfg 文件中被设置，并且可
以被用户修改。缩放窗口提供无限缩放能力，缩放系数出现在窗口标题栏的括号中。缩放窗口能动

态地调整大小，直至屏幕中可利用的尺寸（参见第 45页上的 "Resizing Windows"）。可以显示多个
缩放窗口, 每个窗口对应于一个已载入的主显示窗口。 

调整窗口大小 

许多 ENVI 窗口能动态调整大小直至全屏。这包括图像显示、矢量窗口及所有除散布图和动画
窗口之外的辅助窗口。窗口大小的调整通过用鼠标指针点住它的一角并拖到所需要的图像大小来实

现。 

当前显示 

每次只有一幅显示的图像（主图像、滚动和缩放窗口的组合）是"激活"的。激活的显示是下一
幅图像将被载入的那个显示组。通过在现有波段列表中输入适当的显示数，来设置活动显示。请注

意：没有必要为了将一个功能应用到一个显示而激活该显示，并且使用这些功能不会激活显示。 

辅助窗口 

ENVI 图像显示可以有很多相关的辅助窗口。这些窗口典型地由 ENVI 的交互显示功能来启
动，并且可以包括 X、Y、Z 及任意的剖面、直方图、散点图、表面图（透视图）和动画窗口。它
们都各自附属于一个特定的图像显示组。多个显示可以有各自独立的辅助窗口组。 

Administrator
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矢量显示列表 

矢量显示列表由一个矢量窗口及与之相关的 "Vector Window Params" 对话框组成。一个矢量显
示组的例子如图 1-8 所示。同图像显示窗口一样，矢量窗口可以调整大小及放置于屏幕任何位置（参
见第 277页的"Vector Layers"）。 

图 1-8:一个 ENVI矢量显示组 

数据管理 
ENVI 为管理图像、矢量数据、对话框和单个窗口提供很多工具。这些工具将在以下部分讨论。 

可用波段列表 

可利用波段列表是用于存取 ENVI 图像文件和这些文件的单个图像波段的控制面板。无论何时
一个图像文件被打开，现有波段列表在它自己的对话框中出现，它包含所有打开的文件和任何内存

数据项（在内存中进行计算，但没有保存）的现有图像波段的一张列表，不管图象是否显示。若打

开了多个文件，那么所有文件的所有波段按先后顺序列出，最新打开文件的波段位于列表最顶部。

现有波段列表用于将灰阶和彩色图像装载到活动显示、打开和关闭文件、或从内存中删除单个波段 
（参见第 97 页上的"可利用波段列表 " ）。 

可用矢量列表 

可利用矢量列表包含一列内存中现有的用于在图像显示窗口或矢量显示窗口显示的所有矢量文

件。一旦载入，所有读入内存的矢量层按先后顺序列出，最新读入的矢量位于列表最顶部。你将使

用现有的矢量列表启动矢量显示组，以及从内存中删除矢量层（参见第 114 页的"Available Vectors 
List "）。 

浏览目录列表和 Geo－Browser 

浏览目录列表列出一个已选择的目录中的所有 ENVI 文件，打印文件信息，允许打开选定的文
件，以及启动 Geo－Browser文件显示。Geo－Browser在一张世界地图上用一面红旗标记所有的地
理编码数据的位置。用户可以缩放地图，然后在红旗上点击来选择所需要的文件（参见第 93 页上
的"Scan Directory List"）。 

打开文件列表 

打开文件列表是一个用于管理 ENVI 图像文件的工具。它列出了当前打开文件和任何内存数据
项的所有名字。选择一个文件名，将列出该文件所有的已知信息。这包括诸如完整的路径和图像名

等参数；线、样点和波段数；标题大小；文件类型；数据类型；交叉；数据的字节顺序；以及是否

采用了地理坐标定位，是否波长与波段相关联。选项包括删除内存数据项，关闭或删除单个文件，

以及将内存计算结果写到磁盘文件。这些操作允许最优使用系统内存（参见第 124页的 “Open Files 
List” ）。 
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小部件控制器列表 

小部件控制器列表可以在 ENVI 系统下拉菜单下找到。它列出所有主要的 ENVI 窗口，包括：
主图像、滚动和缩放窗口、所有辅助窗口，以及许多 ENVI 交互功能中使用的其它窗口和对话框。
小部件控制器列表可以通过在名字上点击，调用任何窗口或对话框到前景（参见第 760 页上的" 
Widget Controller List "）。例如，若你需要访问现有波段列表，但它隐藏在你的图像后面，步骤如下： 

1. 选择 System > Widget Controller List. 

2. 点击”可利用波段列表”. 

ENVI处理状态窗口  

当计算进行时，大多数 ENVI 功能显示处理状态。功能启动后（通常通过点击 OK 按钮），会
立即出现一个标准的状态窗口。窗口标题与正在执行的功能相匹配，并且显示结果是否被置于内存

或到一个输出文件中。当数据被处理时，一个标有 ”% Complete” 的滑动块及时地更新。标有”Inc:”
的文本框显示每个数据处理增量的大小，这基于 tile size（参见第 50 页上 的"Tiling Operations" ）。
功能自动地判定处理增量的大小。例如，图 1-9 中显示的值 ”16.67%” 表明数据将按照若干 tiles 进
行处理，每个 tile包含总数据的 16.67%（当在滑动块工具条上显示时，分数的增量将舍入到最接近
的整数）。 

图 1-9 ：处理状态窗口。 

注意 

若增量小于 100%，可以用"Cancel"按钮终止处理。此时，当下一个增量发生时，功能将被中断。
若增量等于 100%，不可能再中断功能。 

内存管理 
ENVI 允许处理大的数据集, 甚至在机器上使用边缘内存配置。例如, 典型的处理任务经常在只
有 16Mb物理内存的机器上使用大于 200Mb的数据集。若处理一项任务没有足够内存，数据集被分
成易处理的片段，在内存中处理，然后写到磁盘文件上。在配置比较高档的机器上，可以在在内存

中处理较大的数据集，而不必创建磁盘文件。 

Tiling操作 

 ENVI 允许使用 "tiling " 处理大图像和控制系统内存的使用。tile是从磁盘或内存中按片段读
取的一段数据。ENVI 中的单个 tile 大小是通过在 ENVI 配置文件中设置所需要的值来控制的（参
见第 786 页上的"The ENVI Configuration File"）。 

对于按 BSQ （按波段顺序）存储的图像，每个 tile 是单个波段的一个空间子集。对于按 BIL
（波段按行交叉）格式存储的图像，每个 tile是一幅图像所有波段的一行。对于 BIP（波段按像元交
叉）格式, 每个 tile 是一幅图象中所有波段行的所有像素。Tiling 通常是对用户透明的，ENVI 用它
来保证硬件内存的限制不影响处理的进行（（参见第 786 页上的"Configuration File Details"和第 
793 页上的"Additional Caching Information"）。 
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文件与内存功能运行对比 

对于有较大随机存储器（RAM）的系统，可能不用反复地将中间处理结果存储到磁盘文件，而
进行有效的图像处理。对于大多数功能，ENVI 允许把处理结果写到一个磁盘文件或保存在系统内
存中。 

注意 

若你选择使用内存项，定期地将你的结果保存到磁盘文件。 

ENVI 文件格式 
ENVI 支持若干种图像文件格式，描述如下。本节也涉及 ENVI 标题文件的格式、文件命名原
则，以及跨平台的可移植性问题。 

ENVI 图像文件 

ENVI 使用一个通用化的栅格数据格式，它由一个简单的 “flat binary file” 和一个相应的小的 
ASCII（文本）标题文件组成。这种方式允许 ENVI 灵活地使用几乎任何一种图像格式, 包括那些
嵌有文件标题信息的格式。支持所有数据类型的原始格式（字节型、整型、长整型、浮点型、双精

度型或复数型）。通用的栅格数据按照 BSQ、BIP 或 BIL 格式，以二进制字节流存储（参见第 795 
页上的 “ENVI File Formats”）。 

BSQ （波段顺序格式） 
在它最简单的格式中，数据是按照 BSQ 格式的。每行数据后面紧接着同一波谱波段的下一行

数据。这种格式最适于对单个波谱波段中任何部分的空间（X，Y）存取。 

BIP （波段按像元交叉格式） 
按 BIP 格式存储的图像按顺序存储第一个像元所有的波段，接着是第二个像元的所有波段，然
后是第 3 个像元的所有波段，等等，交叉存取直到像元总数为止。这种格式为图像数据波谱（Z） 的
存取提供最佳性能。 

BIL （波段按行交叉格式） 
按 BIL 格式存储的图像先存储第一个波段的第一行，接着是第二个波段的第一行，然后是第三
个波段的第一行，交叉存取直到波段总数为止。每个波段随后的行按照类似的方式交叉存取。这种

格式提供了空间和波谱处理之间一种折衷方式，它是大多数 ENVI 处理任务中所推荐的文件格式。 

ENVI 头文件 

单独的 ENVI 文本头文件提供关于图像尺寸、嵌入的头文件（若存在）、数据格式及其它相关
信息。ENVI 头文件包含用于读取图像数据文件的信息，它通常创建于一个数据文件第一次被 ENVI 
存取时。必需信息通过交互式输入，或自动地用 file ingest 创建，并且以后可以编辑修改。若有必
要，你可以在 ENVI 之外使用一个文本编辑器生成一个 ENVI头文件（参见第 797 页上的 “ENVI 
Header Format” ）。 
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ENVI 的文件命名约定 

ENVI 的文件处理程序设计的极其灵活。ENVI 软件对文件命名除不能使用用于头文件的扩展
名 .hdr 之外，不加以任何限制。为了便于使用，一些 ENVI 功能预先载入含特定扩展名的文件列
表。这些扩展名如下表所示，当运行 ENVI 时，应当使用一致，以便文件处理效率最高。若需要，
这也并不排除你使用另外的文件名。 

 

文件类型 扩展名 

ENVI Image 未定义 

ENVI Bad Lines List .bll 

SIR-C Compressed Data Product .cdp 

ENVI Header File .hdr 

ENVI Calibration Factors .cff 

ENVI PPI Count File .cnt 

ENVI Density Slice Range File .dsr 

ENVI Vector File .evf 

ENVI Band Math or Spectral Math Expression .exp 

ENVI Tape Script .fmt 

ENVI Grid File .grd 

ENVI Filter Kernels .ker 

ENVI Map Key .key 

ENVI Contour Levels File .lev 

ENVI Look Up Table .lut 

ENVI Mosaic Template File .mos 

ENVI n-D Visualizer State .ndv 

ENVI GCP file .pts 

ENVI Region of Interest .roi 

ENVI Statistics Report .txt 

ENVI Spectral Library .sli 

ENVI Statistics File .sta 

ENVI Surface View Path File .pat 

JPL AIRSAR Compressed Stokes Matrix Radar Data .stk 

ENVI Vector Template File .vec 

 

表 1-1: ENVI 文件类型 
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跨平台的文件可移植性 

当使用 ENVI 命名文件时，要考虑的一个附加因素是跨平台的可移植性。在 UNIX 系统上
的文件名后附加一个 .hdr 。在 Windows 系统上，.hdr 代替当前的扩展名。这对于保持图像文件和
它们相应的（.hdr）头文件之间的关系是特别重要的 。例如，一个名为 image_1.img 的 UNIX 图
像文件将 image_1.img.hdr 作为它相应的头文件。一个 名为 image_1.img 的 Windows 图像文件将 
image_1.hdr 作为它相应的头文件。在 Windows 下，两幅图像 image_1.img 和 image_1.dat 将有
同样的头文件名 image_1.hdr，并且若这两幅图像大小和特征不同，那么 ENVI 将会出现问题。在 
UNIX 下，同样的两个文件将有相应的头文件名 image_1.img.hdr 和 image_1.dat.hdr，因此不会发
生混乱。若图像的跨平台可移植性存在问题，那么最简单的解决方案是仅使用 8 个字符并且不用扩
展名来命名图像文件。这样，图像文件 image_1 在 UNIX 和 Windows 下有同样的头文件名
（image_1.hdr ）。此外，将图像从 UNIX 系统移到 Windows 系统前，可以按 Windows 约定对图
像和头文件进行重命名。 

ENVI 支持的输入文件格式 
ENVI支持的输入文件格式如下所示。有关这些格式的更多信息在第 60 页的“Open Image 

File”，第 64 页的 “Open External File” 以及第 83 页的 “Open Vector File” 上可以找到。ENVI 
支持许多输入文件格式： 

●  Flat Binary Files: 

● BSQ （band sequential format） 

● BIL （band interleaved by line format） 

● BIP （band interleaved by pixel format） 

●  Remote Sensing Format Files: 

● ADRG                          ● GeoTIFF 

● AIRSAR                         ● HDF 

● ArcView Raster （.bil）                  ● HDF MAS-50 

● ATSR                               ● JERS 

● AVHRR                          ● MRLC 

● CADRG                          ● NITF 

● CIB  ● NLAPS CD 

● DMSP （NOAA）  ● PDS Image 

● DOQ （USGS）  ● RADARSAT 

● EOSAT FAST IRS-1  ● SeaWiFS 

● EOSAT FAST TM  ● SIR-C 

● ERS  ● SPOT CD 

● ESA Landsat TM  ● TIMS 
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● ESA SHARP  ● TOPSAR 

● GeoSPOT 

●  Image Processing Formats 

● ArcView Raster （.bil）  ● ER Mapper 

● ERDAS 7.5 （.lan）  ● PCI （.pix） 

● ERDAS 8.x （.img） 

● Other Generic Image Formats: 

● ASCII  ● PICT 

● BMP ● SRF 

● GIF  ● TIFF （GeoTIFF） 

● HDF  ● TIFF world files （.tfw） 

● JPEG  ● XWD 

●  Digital Elevation Formats 

● USGS DEM  ● USGS SDTS DEM 

● DMA DTED 

 

要获得更多信息，参见第 79 页的“Digital Elevation Formats”。 

●  Vector Files: 

● ARC/INFO Interchange ● MapInfo Interchange 

Format 

● ArcView Shape File  ● Microstation DGN 

● DXF  ● USGS DLG 

● ENVI Vector File （.evf）  ● USGS DLG in SDTS Format 

ENVI 支持的输出文件格式 
ENVI 支持的输出文件格式如下所示。关于这些格式的更多信息参见第 310 页的“ Display 

Output Options ”，第 384 页的“ Output Data to External File ”，以及第 279 页的“ The Vector 
Window Parameters Dialog ”。 

 

●  ENVI Flat Binary Files: 

●  BSQ （band sequential format） 

●  BIL （band interleaved by line format） 

●  BIP （band interleaved by pixel format） 
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●  Generic Image Formats 

●  ASCII  ●  PICT 

●  BMP  ●  SRF 

●  GIF  ●  TIFF （GeoTIFF） 

●  HDF  ●  TIFF world files （.tfw） 

●  JPEG  ●  XWD 

●  Image Processing Formats 

●  ArcView Raster （.bil）  ●  ER Mapper 

●  ERDAS 7.5 （.lan）  ●  PCI （.pix） 

●  Vector Formats 

●  ArcView Shape File  ●  DXF 

●  ENVI Vector File （.evf） 

第二章 文件存取与显示 
启动ENVI 
在试图启动 ENVI 之前，一定要确认是按照安装向导正确安装了 ENVI 。 

要启动 ENVI ： 

·  要在 Unix 下启动 ENVI , 在 UNIX 命令行输入 “envi”。 

·  要在 Unix 下启动 ENVI RT, 在 UNIX 命令行输入 “envi_rt”。 

·  要从 Windows NT 3.51 或 Macintosh 系统启动 ENVI（或 ENVI RT），双击 ENVI 或 ENVI 
RT 图标。 

·  要从Windows 95，Windows 98，或Windows NT 4.0 系统启动 ENVI （或 ENVI RT），从 
Windows 任务栏选择：Start > Programs > ENVI 3.2 > ENVI 3.2 。 

当程序成功地载入和运行时，出现 ENIV 主菜单。 

File菜单 
所有数据文件读取到 ENVI ，都是通过从 ENVI 主菜单上的 File 下拉菜单进行选择。各个菜

单项在以下几节叙述。 

图 2-1： ENVI 的 File菜单. 

Open Image File （打开图像文件） 
Open Image File 是一个普通的文件打开程序。使用该项打开 ENVI 图像文件（flat binary files，
第 795 页的 “ENVI File Formats”有所描述） 或其它已知格式的二进制图像文件。 ENVI 自动地识
别和读取下列类型的文件：TIFF、GeoTIFF、GIF、JPEG、BMP、SRF、HDF、PDS、MAS-50、NLAPS、

Administrator
第二章文件存取与显示
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RADARSAT 和 AVHRR 。数据仍保留它原有格式，必要的信息从数据文件头中读取。 ENVI 直接
读取其它几种文件类型（参见第 64 页的 “Open External File”）。 

1. 选择 File > Open Image File. 

2. 当出现 Enter Data Filename 对话框，点击文件名，再点击“OK” 或“Open” 以打开选择的文
件。 

·  要选择一组连续显示的文件，在该组的第一个文件上点击，然后按住它的同时，点击该组的
最后一个文件。或者，用鼠标左键点击和拖曳来选择所需要的组。 

·  要选择非连续显示的多个文件，按住 “Ctrl” 键，在每个所需要的文件上点击。 

·  要改变目录来查找你的文件，在 “File Name” 文本框输入路径名（“Path” for UNIX）。 

图 2-2: Reconcile ROIs Parameters 对话框. 

注意 
若你得到 “File does not appear to be a valid Radarsat file” 这样一个错误消息，使用 File > Open 

External File 来选择正确的数据类型（参见第 64 页的 “Open External File”）。 

当 ENVI 第一次打开一个文件，它需要关于文件特征的特定信息。通常，这些信息存储在与图
像文件同名的一个独立的文本头文件，但是文件扩展名为.hdr 。若文件打开时没有找到 ENVI 头
文件，你必须在 Header Information 对话框中输入一些基本的参数（如下所示）。一旦文件打开，波
段在可利用波段列表中列出（参见第 97 页的 “可用波段列表”）。 

注意 
一些数据格式没有 .hdr 文件也能自动打开。这些格式包括：TIFF、 GeoTIFF、 GIF、 JPEG、 

BMP、 SRF、 HDF、 PDS、 MAS-50、 NLAPS、RADARSAT 和 AVHRR 。 

Header Information 对话框 

若在打开一个文件时没有发现头文件 （ .hdr 文件 ） 或其它有效的头文件信息， 就会出现
Header Info对话框。你将使用这个对话框输入样本或像元数、行数、波段数、在从文件的开头到数
据开始处（嵌入的文件头）的字节偏移量、数据的存储顺序（"交叉"）（BSQ: band sequential，BIP: band 
interleaved by pixel，or BIL: band interleaved by line）、数据的字节顺序（"Host （Intel）": Host Least 
Significant First for DEC machines and PCs 或 "Network （IEEE）": Network Most Significant First for 
all other platforms）、数据类型（字节， 整数，浮点等），以及文件类型。其它选项包括设置默认的
Z-Plot range，默认的显示拉伸，地理坐标的输入（entry of georeferencing information），相关的波长
和 FWHM值（full-width-half-maximum），传感器类型，波段名以及坏波段。 

图 2-3：Header Information对话框 

在 ENVI 显示一幅导入的图像前，你必须将必要信息输入到 Header Info（图 2-3）窗口。若一
个文件没有 ENVI 文件头或其它支持的文件头格式，这个窗口自动地出现。每次打开一个数据文件
时，ENVI 搜索头文件并使用该信息来打开文件。这些信息只需输入一次，当选择 Header Info窗口
底部的 “OK” 按钮，它自动地保存到输入目录中的一个 ENVI 头文件。ENVI 的 Edit Header 功能
也可以用来更改已存在的头文件的信息（参见第 217 页的 “Edit ENVI Header”）。 

注意 
当直接访问  CD-ROM 驱动器时，头文件被保存到  envi.cfg 文件指定的“Alternate Header 
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Directory”，因为你不能写到 CD-ROM 输入目录（参见第 777 页的 “Installing and Customizing 
ENVI”）。该文件生成系统允许你直接使用 CD-ROM 上的文件，甚至不用将数据拷贝到你的磁盘上。 

打开外部文件 
 ENVI 支持的输入文件，请参阅第 54 页上的 “ENVI Supported Input File Formats”。 

虽然上述的 Open Image File 功能可以打开大多数文件类型，对于特定的已知文件类型，利用
内部或外部的文件头信息通常会更加方便。使用 Open External File 选项，ENVI 从内部文件头读取
必要的参数，因此你不必在 Header Infor对话框输入任何信息。ENVI 能读取这些标准文件类型的若
干格式，这包括精选的遥感格式、图像处理格式、通用图像格式及数字高程模型（参见第 54 页上
的“ENVI Supported Input File Formats”）。 

1. 选择 File > Open External File > the desired format。 

2. 当出现标准文件选择对话框，选择一个文件名然后点击“Open”。 

·  要选择一组连续列出的文件，在该组的第一个文件上点击，然后按住的同时，点击该组的最
后一个文件。或者，用鼠标左键点击和拖曳来选择所需要的组。 

·  要选择非连续列出的多个文件，按住 “Ctrl” 键，在每个所需要的文件上点击。 

3. 若 ENVI 提示你键入输出文件名，按要求为每个文件输入一个名字。 

4. 要获得有关如何存取文件格式的详细描述，请浏览以下几节。 

遥感格式 

 ENVI 支持大多数遥感格式，或通过磁带读取性能把数据导入成 ENVI 自身格式，或通过将
数据参数输入到上述的 Header Infor对话框。利用内在的文件头信息，可直接读取几种其它的遥感
（栅格〕格式。描述如下。 

 ADRG 

要打开来自 Defense Mapping Agency 的 ARC Digitized Raster Graphics 格式文件： 

1. 选择 File > Open External File > Remote Sensing Formats > ADRG. 

2. 当出现文件选择对话框时，选择扩展名为 .img的文件来打开。 

文件头信息将从 .gen 文件读取，图像波段被输入到可利用波段列表。 通常，ENVI 不读取相
关的图例图像，并且不支持地理坐标定位（georeferencing〕。考虑到速度因素，从 ADRG overview 图
像生成滚动窗口。 

ATSR 
ENVI 读取来自 the Rutherford Appleton Laboratory（RAL）SADIST-2 处理软件 for the ATSR-1 and 

ATSR-2 instruments的栅格亮度温度/反射率（GBT），the gridded browse （GBROWSE），以及栅格
海洋表面温度（GSST）数据。ENVI 在文件内部自动地打开所有的图像产品内容。 

要打开 ATSR-1 和 ATSR-2 文件: 

1. 选择 File > Open External File > Remote Sensing Formats > ATSR. 

2. 当出现文件选择对话框时，选择所需要的输入文件。 
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所有已选定的图像产品打开后显示在可利用波段列表中。对于前面的视图和最底部的视图图像，

波段名分别包含 “FV” 和 “NV”。波段名也提供图象单位（units）。 

AVHRR 
要读取来自 CD-ROM 或磁盘上的 Level 1b AVHRR 数据（包括 LAC/HRPT、GAC Level 1b 和

KLM）： 

1. 选择 File > Open External File > Remote Sensing Formats > AVHRR CD. 

2. 当出现文件选择对话框时，选择所需要的输入文件。 

ENVI 将直接读取 10-bit 压缩格式作为整型数据，解压缩格式作为整型数据，8-bit 格式作为字
节型数据。必要的文件头信息被自动提取，波段被置于可利用波段列表中。要使用嵌入的信息来对

地理坐标数据进行定位，请参阅第 430 页的 “VHRR Utilities”。 

CADRG 
要打开来自 Defense Mapping Agency 的压缩的 ARC数字栅格图象格式： 

1. 选择 File > Open External File > Remote Sensing Formats > CADRG. 

2. 当出现文件选择对话框时，选择 A.toc 文件得到一个所有 frame 文件的列表。 

·  要打开单个 frame 文件， 选择 File > Open External File > Remote Sensing Formats > NITF. 

出现 NITF.TOC File 对话框。 

3. 选择所需要的 frame 文件来打开。 

4. 通过选择 Mosaic Files? 标签附近的 “Yes” 或 “No”，来选择是否把所有文件镶嵌到一个虚
拟的镶嵌图中。 

5. 点击“OK”。 

在已选定的 frame 中的所有文件，以及虚拟镶嵌图〔若选了〕，显示在可利用波段列表中。 

注意 
每个 frame 文件可以由显示在可利用波段列表中的几百个单独的文件组成。 

CIB 
要打开来自 Defense Mapping Agency 的 Controlled Image Base （CIB） 格式： 

1. 选择 File > Open External File > Remote Sensing Formats > CIB. 

2. 当出现文件选择对话框时，选择 A.toc 文件得到一个所有 frame 文件的列表。 

·  要打开单个 frame 文件， 选择 File > Open External File > Remote Sensing Formats > NITF. 

出现 NITF.TOC File 对话框。 

3. 选择所需要的 frame 文件来打开。 

4. 通过选择 Mosaic Files? 标签附近的 “Yes” 或 “No”，来选择是否把所有文件镶嵌到一个虚
拟的镶嵌图。 

5. 点击“OK”。 

在已选定的 frame 中的所有文件，以及虚拟镶嵌图〔若选了〕，显示在可利用波段列表中。 
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注意 
每个 frame 文件可以由显示在可利用波段列表中的几百个单独的文件组成。 

DMSP （NOAA） 
要直接读取 NOAA DMSP（只有 OLS格式）格式到 ENVI： 

1. 选择 File > Open External File > Remote Sensing Formats > DMSP （NOAA）. 

2. 当出现文件选择对话框时，选择一个要读取的文件。 

ENVI 自动地提取文件头信息，并把图像波段输入到可利用波段列表中。 

DOQ （USGS） 
要读取 USGS Digital Orthophoto Quadrangle 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > DOQ （USGS）. 

2. 当出现文件选择对话框时，选择一个要读取的文件。 

ENVI 自动地提取文件头信息，包括 UTM georeferencing 信息，并把图像波段 （灰阶或 RGB） 
输入到可利用波段列表中。 

EOSAT FAST IRS-1 
要读取 EOSAT FAST 格式的 IRS-1 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > EOSAT FAST IRS-1. 

2. 当出现文件选择对话框时，选择 header.dat 文件来读取。 

文件名必须遵循 header.dat 和 bandx.dat 中的命名约定，where x = 波段数 或 x = p for 
panchromatic. ENVI 自动地提取文件头信息，包括 UTM georeferencing 信息，并把图像波段输入到 
可利用波段列表 。ENVI 将打开所有波段，并把它们放到一个 ENVI 元文件中（参见第 380 页的 
“Create New File”）。ENVI按照传感器类型给各波段赋予波长值。 

EOSAT FAST TM 
要读取 EOSAT FAST 格式的 Landsat TM 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > EOSAT FAST TM. 

2. 当出现文件选择对话框，选择下列文件中的一个： 

·  对于 EOSAT Fast TM 格式数据，选择 header.dat 。 

·  对于 EOSAT Landsat 7 FAST panchromatic 数据，选择 HPN 头文件。 

·  对于 the 6 VNIR/SWIR EOSAT Landsat 7 FAST 数据波段，选择 HRF 头文件。 

·  对于 EOSAT Landsat 7 FAST thermal 波段，选择 HTM 头文件。 

文件名必须遵循 header.dat 和 bandx.dat 中的命名约定，这里 x = 波段数。ENVI 自
动地提取文件头信息，包括 UTM georeferencing 信息，并把图像波段输入到可利用波段列表中。
ENVI 将打开所有波段，并把它们放到一个 ENVI meta 文件中（参见第 380 页的 “Create New 
File”）。ENVI按照传感器类型给各波段赋予波长值。 
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ERS 
要读取 ERS-1 和 ERS-2 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > ERS. 

2. 当出现文件选择对话框时，选择一个要读取的文件。 

ENVI 自动地提取必要的文件头信息，并把图像波段输入到可利用波段列表。 

ESA SHARP 
European Space Agency（欧空局）的 SHARP 数据包括 5 个 AVHRR 波段和辅助信息。ENVI 
读取 5 个 AVHRR 数据波段；辅助信息作为 3 个附加波段读取。附加波段是关于经/纬网、海岸线
和国界的 0-1 栅格图像。 

要读取 European Space Agency 格式的 AVHRR 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > ESA SHARP. 

2. 选择输入数据文件。 

输入文件必须按照 dat_xx.xxx 和 lea_xx.xxx的约定命名。 

AVHRR 波段和三个辅助波段显示在可利用波段列表中。 

ESA Landsat TM 
要读取 European Space Agency Landsat TM 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > ESA Landsat TM. 

2. 选择输入数据文件。 

这些文件必须按照 dat_xx.xxx 和 lea_xx.xxx 的约定命名。ENVI 自动地提取必要的文
件头信息，包括任何 UTM georeferencing 信息，并在可利用波段列表中列出所有波段。ENVI 将打
开所有 BSQ 格式的波段，并把它们放到一个 ENVI meta 文件中（参见第 380 页的 “Create New 
File”）。 

GeoSPOT - ArcView Raster （.bil） 
SPOT 提供它们的数据大多为 GeoSPOT格式。ArcView 栅格图像文件有一个相似的格式规范。

在从 SPOT 图像得到的文档中有 GeoSPOT 格式的详细描述。虽然 GeoSPOT 格式提供很多种栅格
和矢量数据，但是目前 ENVI 只支持 GeoSPOT 栅格图像。这些图像的文件扩展名为 .bil，并且
有一个相应的扩展名为 .hdr 的头文件。ENVI 将从头文件中读取 UTM 和 State Plane projection 
georeferencing 信息。 

1. 选择 File > Open External File > Remote Sensing Formats > GeoSPOT –ArcView Raster（.bil）. 

2. 当出现文件选择对话框时，改变目录到 GeoSPOT 图像和头文件所在位置，然后选择要读取
的文件。 

ENVI 自动地提取文件头信息，并把图像波段输入到可利用波段列表。 

GeoTIFF 
要读取 GeoTIFF 格式文件并提取 georeferencing 信息： 

1. 选择 File > Open External File > Remote Sensing Formats > GeoTIFF. 
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2. 当出现文件选择对话框，选择所需要的输入文件。 

ENVI 将读取 GeoTIFF 图像，自动地提取必要的头文件信息（包括相应的 georeferencing 信息） 
并把图像放到可利用波段列表中。 

HDF 
ENVI 所支持的 HDF 文件包括栅格格式、以 2 或 3-D 科学数据格式存储的图象，以及以 1-D

科学数据格式存储的图。HDF 图文件被直接读入到一个 ENVI 图示窗口。 

要读取 HDF 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > HDF. 

2. 当出现文件选择对话框时，选择所需要的输入文件。 

3. 当出现 HDF Dataset Selection 对话框时，点击文件名附近的文本框，再点击 “OK” 来选择
所需要读取的文件。 

·  要选择所有的文件，点击 “Select All”. 

·  要清除所有文件，点击 “Clear”. 

·  要选择连续列出的一组文件，先点击第一项，按住 “shift” 键的同时，点击最后该组中的一
项。 

·  要选择非连续列出的一组文件，先点击一项，按住 “Ctrl” 键的同时，点击其它所有需要的
项。 

·  若一个 3-D 数据文件被选定，出现 Data Set Storage Order 对话框。 

通过在BSQ （band sequential）、BIL （band interleaved by line） 或 BIP （band interleaved by pixel）
上点击，来选择 HDF 数据存储顺序。 

所有已选定的 1-D HDF 文件将被直接地读到一个 ENVI 图示窗口。 

2-D 和 3-D 文件将被读取，并被放到可利用波段列表中。 

HDF MAS-50 
要读取 Modis Airborne Simulator 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > HDF MAS-50. 

2. 当出现文件选择对话框时，选择所需要的输入文件。 

ENVI 自动地提取必要的文件头信息（包括波长），并把波段放置到可利用波段列表。ENVI 自
动地应用比例系数来缩放数据以与辐射单位相适应。 

注意 
要获取另外的 HDF 文件，选择 File > Open External File >Remote Sensing Formats > HDF 

（见上面）. 

JERS 
要读取 JERS 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > JERS. 
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2. 当出现文件选择对话框时，选择要读取的图像文件。 

ENVI 自动地提取必要的文件头信息，并把图像波段放置到可利用波段列表中。 

MRLC 
ENVI 读取 Multi-Resolution Land Characteristics （MRLC） 格式 TM 和 DEM 

文件并提取 UTM georeferencing 信息。 

·  要打开 Landsat TM 数据（所有波段）： 

1. 选择 File > Open External File > Remote Sensing Formats > MRLC. 

2. 当出现文件选择对话框时，选择其中一个 TM（.dda）图像文件。 

ENVI 自动地提取文件头信息，包括 UTM georeferencing 信息，并把图像波段输入到可利
用波段列表中。ENVI 将打开所有的波段，并把它们放到一个 ENVI meta文件中（参见第 380 页
的 “Create New File”）。ENVI 赋予波段波长值。 

·  要打开 DTED 数字高程模型数据（DEM）： 

1. 选择 File > Open External File > Remote Sensing Formats > MRLC. 

2. 当出现文件选择对话框时，选择 DEM （.dda） 文件。 

ENVI 自动地提取文件头信息，包括 UTM georeferencing 信息，并把数据输入到可利用波段列
表中。 

NITF 
ENVI 读取未压缩的和矢量量化（vector quantization，VQ）压缩的 NITF 2.0 和 2.1 图像数据，

并自动地创建一幅底图和嵌入图像的虚拟镶嵌图。NITF 符号和标签，除了 CGM 符号，被读入到
一个单独的 ENVI 注记文件（参见第 250 页的 “Annotation”）。NITF 文本数据显示在 ENVI 的 
report 对话框中，而没有任何附加的格式编排。 

要读取 National Imagery Transmission 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > NITF. 

2. 当出现文件选择对话框时，选择所需要的输入文件。 

当符号和标签呈现时，出现一个 NITF File Parameters 对话框。 

3. 输入符号和/或标签输出注记文件名，然后点击 “OK”。 

ENVI 自动地提取文件头信息，并创建一幅该文件中所有未压缩和 VQ 压缩图像的虚拟镶嵌图
（参见第 619 页的 “Image Mosaicking”）。虚拟镶嵌图的波段被输入到可利用波段列表中。符号和/
或标签注记文件可以覆盖在虚拟镶嵌图上（参见第 624 页的“Virtual Mosaic”）。任何一幅符号位图
都将显示为注记 “RGB Image” 的插页。 

NLAPS CD 
要从 CD-ROM 或从磁盘上读取 Landsat TM 和 MSS BSQ（band sequential）以及 BIL（band 

interleaved by line）NLAPS 格式数据： 

1. 选择 File > Open External File > Remote Sensing Formats > NLAPS CD. 

2. 当文件选择对话框出现时，系统默认地列出头文件（.hd），选择所需要的 .hd 文件打开。 
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ENVI 自动地提取必要的文件头信息，包括 UTM georeferencing 信息，并在可利用波段列表中
列出所有波段。ENVI 将打开所有 BSQ 格式的波段，并把它们放到一个 ENVI meta文件中（参见
第 380 页的 “Create New File”）。 

PDS Image 
ENVI 只读取未压缩的 PDS 格式，不支持 VAX浮点型（复数型，双精度型或实型）数据。要
读取贴有 PDS 数据产品标签的未压缩的 Planetary Data System 格式文件： 

1. 选择 File > Open External File > Remote Sensing Formats > PDS Image. 

2. 当出现文件选择对话框，选择所需要的 .img 输入文件。 

ENVI 自动地提取必要的文件头信息，并把图像输入到可利用波段列表中。 

RADARSAT （from CD or Disk） 
要把 RADARSAT 数据文件读入到 ENVI： 

1. 选择 File > Open External File > Remote Sensing Formats > RADARSAT. 

2. 当出现文件选择对话框，选择所需要的输入文件。 

ENVI 从数据文件、leader 文件和/或 trailer 文件中自动地提取必要的文件头信息，包括 UTM 
georeferencing 信息。图像的波段被输入到可利用波段列表中。 

·  对于整型格式 RADARSAT 数据： 

当出现 RADARSAT File Import 对话框，选择 Import Data Type > Unsigned Integer. 

图像的波段将被输入到可利用波段列表中。 

·  对于字节缩放： 

1. 当出现 RADARSAT File Import 对话框时，选择 Import Data Type > Scale to Byte. 

2. 输入缩放比例最小和最大数据值或使用系统默认值。 

如果已经找到，“Min” 和 “Max“ 值自动被输入为 CEOS标题中直方图的 2%（ are automatically 
entered as the 2% points from the histogram in the CEOS header if it is found）。若不能得到 CEOS 文件
头，你必须输入这些值。 

3. 点击 “OK” ，开始读取数据。 

图像的波段被输入到可利用波段列表中。 

注意 
复合型 RADARSAT 数据被读到 ENVI，作为 as byte Q and I Stoke’s parameters for the RAW 

product type and as integer*2 Q and I for the SLC product. 

SeaWiFS 
要从 CD-ROM或磁盘上读取 CEOS LAC 1B，LAC 2A，LAC 2B，SeaWiFS HDF Level 1A 和 1B

格式 SeaWiFS数据（从 OrbImage获得），以及 SeaWiFS HDF格式数据（从 NASA / Goddard获得）： 

1. 选择 File > Open External File > Remote Sensing Formats > SeaWiFS. 

2. 当出现文件选择对话框时，选择要读取的图像文件。 
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ENVI 自动地提取文件头信息，并把图像波段输入到可利用波段列表。要使用嵌入的信息对数
据进行地理坐标定位或创建几何学信息，请参阅第 440 页的 “SeaWiFS Utilities”。 

SPOT CD 
要从 CD-ROM 或磁盘上直接读取 1A，2A 和 1B SPOT 数据： 

1. 选择 File > Open External File > Remote Sensing Formats > SPOT CD. 

2. 当出现文件选择对话框时，选择要读取的图像文件。 

ENVI 自动地提取文件头信息，并把图像波段输入到可利用波段列表 。 

TIMS 
要从 CD-ROM 或磁盘上读取来自 NASA 热红外多波谱扫描仪（TIMS）的数据： 

1. 选择 File > Open External File > Remote Sensing Formats > TIMS. 

2. 选择 TIMS 文件名，然后点击 “OK”。 

波段显示在可利用波段列表中。ENVI 假定数据有 6 个波段，638 个像元加上每行开头有 60 
个字节的偏移量，并且是按照 BIL 存储顺序。系统默认的波长数值被输入到文件头中，并且可以编
辑（若有必要）。 

TOPSAR 
要读取原始 TOPSAR （AIRSAR Integrated Processor Data） 格式数据文件（Cvv，入射角， 相

关图象或 DEM）： 

1. 选择 File > Open External File > Remote Sensing Formats > TOPSAR. 

2. 当出现文件选择对话框时，选择需要读取的文件。 

ENVI 自动地提取必要的文件头信息，并把图像波段放置到可利用波段列表中。 

注意 
要读取所有的 TOPSAR 文件，并自动地将它们转换为自身的单位（physical units），请参阅第 

755 页的“Convert TOPSAR Data”。要综合 AIRSAR 图像，请参阅第 729页的 “Decompress-Synthesize 
Images”。 

图像处理格式 

ENVI 读取存储在 ArcView， ERDAS， ER Mapper 和 PCI 中的图像处理格式文件。ENVI 
自动地提取必要的文件头信息，并把波段输入到可利用波段列表 。 

ArcView Raster（.bil） 
ENVI 可以读取 ArcView 栅格格式文件。这些图像文件的扩展名为 .bil ，并且有一个相应的

扩展名为 .hdr 的头文件。ENVI 将从该头文件中读取 UTM 和 State Plane projection georeferencing 
信息。 

1. 选择 File > Open External File > Image Processing Formats > ArcView Raster （.bil）. 

2. 当出现文件选择对话框时，选择要读取的文件。 

ENVI 自动地提取文件头信息，并把图像波段输入到可利用波段列表。 
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ERDAS 7.5 （.lan） 
要打开按 ERDAS 的文件格式存储的文件： 

1. 选择 File > Open External File > Image Processing Formats > ERDAS 7.5 （.lan）. 

2. 当出现文件选择对话框时，选择一个输入文件来读取。 

ENVI 自动地提取必要的文件头信息，并把图像波段输入到可利用波段列表。ENVI 将从相应
的 ERDAS 7.5 .pro 文件中读取 UTM georeferencing 信息。 

ERDAS 8.x（.img） 
要打开按 ERDAS Imagine 文件格式存储的文件： 

1. 选择 File > Open External File > Image Processing Formats > ERDAS 8.x （.img）. 

2. 当出现文件选择对话框时，选择一个输入文件来读取。 

ENVI 自动地提取必要的文件头信息，并把图像波段输入到可利用波段列表。 

注意 
ENVI 不能读取其它的与 ERDAS 文件相对应的文件头信息。同样，因为 ERDAS 的 tiling 

scheme 对于 ENVI 来说不是最优化的，ERDAS 对大文件的导入将会极慢。在使用 ENVI 之前，
我们建议在 ERDAS 中转换成一个标准的 flat 文件。 

ER Mapper 
要打开以栅格 ER Mapper 文件格式存储的文件： 

1. 选择 File > Open External File > Image Processing Formats > ER Mapper. 

2. 当出现文件选择对话框时，选择要读取的数据头文件（.ers） 。 

ENVI 自动地提取必要的文件头信息，包括 UTM georeferencing 信息（未旋转），并把图像波
段输入到可利用波段列表中。 

注意 
ENVI 不能读取有符号 8-bit，无符号 16-bit，无符号 32-bit 数据或 ER Mapper 算法文件。 

PCI（.pix） 
要打开以 PCI 数据库文件格式存储的文件： 

1. 选择 File > Open External File > Image Processing Formats > PCI （.pix）. 

2. 当出现文件选择对话框时，选择一个要读取的文件。 

ENVI 自动地提取必要的文件头信息，包括 UTM georeferencing 信息，并把图像波段输入到可
利用波段列表中。 

注意 
不能使用该选项直接读取包含多种数据类型的 PCI 文件或交叉格式的文件。 

通用图像格式 

ENVI 可以读取通用图像格式数据，这包括 ASCII、BMP、GIF、HDF、JPEG、PICT、SRF、
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TIFF 及 XWD。这些文件除了 TIFF 和 BMP 保持原有格式外，都被转换成 ENVI 格式文件。更
详细的说明，请参见第 78 页的 “Input TIFF” 和第 77 页的 “Input ASCII”。 

注意 
除 TIFF、HDF 和 BMP 格式图像之外，将通用图像文件转换成 ENVI 格式只限于与系统内存
完全匹配的图象。 

要打开包括 BMP、GIF、HDF、JPEG、PICT、SRF 及 XWD 等标准图像文件格式： 

1. 选择 File > Open External File > Generic Image Formats. 

2. 从要选项的层叠式列表中，选择要读取的文件类型。 

3. 当出现标准的 ENVI 文件选择对话框时，选择一个要转换成 RGB 格式的文件。 

4. 当出现 External File Conversion 对话框，选择输出到 “File” 或 “Memory”。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中输入想得到的输出文件名，或者
使用 “Choose” 按钮来选择一个输出文件名。 

文件可以被转换和读入到内存，或输出到一个 RGB 磁盘文件。若选择输出到一个文件，由嵌
入文件头中的信息创建一个新的文件和标准的 ENVI 头文件。 

5. 点击 “OK” ，开始转换。 

出现一个显示处理过程的状态窗口。当完成后，来自转换文件的波段显示在可利用波段列表中

（参见第 97 页的 “可利用波段列表”），它们可以用 ENVI 功能进行标准显示和分析。 

Input ASCII 
你可以使用 Open External File 功能打开一个 ASCII 文件，作为一幅图像。每个 ASCII 值将

被作为像元的 DN 值进行读取。ASCII 值之间必须用空格或逗号隔开。文件顶部非数字的或用分号
开始的几行将被跳过。样本（samples）数将由一行中的数值的数目决定，行数将由文件中的行数决
定。在 ENVI 中打开 ASCII 文件，按照以下步骤： 

1. 选择 File > Open External File > Generic Image Formats > ASCII. 

2. 当出现标准文件对话框时，选择要导入的一个 ASCII 文件。 

样本数和行数（列和行）被自动地选定。 

3. 当出现 Input ASCII File 对话框时，从 “Interleave” 按钮菜单选择 BSQ、BIL 或 BIP 。 

4. 从 “Data Type” 按钮菜单选择正确的数据类型。 

5. 通过在框内键入一个数字，或在 “Number of Bands” 标签附近的箭头按钮上点击，来键入或
选择输入波段数。 

6. 点击 “OK”。 

波段将被读入内存，并在可利用波段列表中用于显示。 

Input TIFF 
ENVI 所支持的 TIFF 文件包括 tiled 文件、TIFF world 文件（.tfw）、GeoTIFF，以及 1-bit， 

4-bit，8-bit 和 24 bit 文件。 

1. 选择 File > Open External File > Generic Image Formats > TIFF. 
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2. 当出现标准文件选择对话框时，选择要输入的一个 TIFF 文件，然后点击 “OK”。 

·  若你有一个与 TIFF 相对应的 .tfw 文件，进行下列附加步骤。 

A. 当出现 TIFF World File Input Projection 对话框时，（若有必要）选择所需要的输入投影，并
键入区域代号 （zone number） 。 

·  若你选择 “Arbitrary”，通过在 “Coordinates” 标签附近的箭头切换按钮上点击，来选择 “Pixel 
Based” 或 “Map Based”。 

Pixel-based 将左上角作为原点，而 map-based 将左下角作为原点。每种选择都只影响 “y” 轴。 

·  若选择 “Geographic Lat/Lon:”，点击 “Datum” 按钮，从 “Select Geographic Datum” 对话框
的列表中选择一个数据。 

使用Molodensky 变换进行数据变换。 

（参见网页 http://www.connect.net/jbanta/ ）. 

·  若选择 “UTM”，在“Zone” 文本框中输入数字，或点击 “Zone” 按钮，再从后来的对话框的
列表中选择。 

·  若选择的是 “State Plane...” 投影中的一个，输入或选择一个区域，并使用箭头切换按钮来选
择 “Feet” 或 “Meters”。要对 UTM 投影计算区域代号，点击 “Zone” 按钮，然后输入经纬度值。 

·  要为一个 State Plane 投影选择区域代号，点击 “Zone” 按钮，然后选择所需要的区域名。
NOS 和 USGS 区域代号都显示在区域名附近。 

B. 点击 “OK”。 

注意 
若你有一个 GeoTIFF 文件和一个 TIFF world 文件，所有的投影信息将从 GeoTIFF 文件直接
读取。 

波段显示在可利用波段列表中，可以用于显示。 

Digital Elevatin Formats 

美国地质勘察数字高程模型（USGS DEM）数据、美国国防部制图机构数字地形高程数据（DMA 
DTED）以及 Spatial Data Transfer Standard （SDTS DEM） 格式能被 ENVI 直接读取。要获取一
种特定的数字高程文件格式，首先遵循这些向导，然后按下列步骤处理。在已转换的文件中，高程

以完全的精确度（full precision）保留。要地理坐标定位（georeference）DEMs，用 ENVI 的配准功
能，通过利用拐角处坐标和给出的像元大小，来纠正（warp） DEM 到一个特定的投影 （参见第 598 
页的 “Image-to-Map Registration”）。 

DMA DTEDs 
要从 CD-ROM 或磁盘上将 DMA DTED 文件转换和镶嵌成 ENVI 图像文件： 

1. 选择 File > Open External File > Digital Elevation Formats > DMA DTED. 

2. 当出现文件选择对话框时，选择所需要的输入文件名。 

选定一个文件名后，出现 DMA DTED Reader Input Parameters 对话框。该对话框和 USGS DEM 
对话框有相同的参数（详细说明，请见第 79 页的 “USGS DEM”）。 



 25

USGS DEM 
要将已存在磁盘上的 USGS DEM 文件转换和镶嵌成 ENVI 图像文件（DEMs 也可以从磁带直
接读取，参见第 393 页的 “Read Known Tape Formats”）： 

1. 选择 File > Open External File > Digital Elevation Formats > USGS DEM。 

2. 当出现文件选择对话框时，选择所需要的输入文件名。 

3. 点击 “OK”。 

·  若你想转换一个以上的 DEM 文件，点击 “Input Additional File” 然后使用文件选择对话框
选择新的文件。 

·  要自动地镶嵌 DEM 文件到一幅基于地理坐标的图像中，点击 “Mosaic Files” 标签附近的 
“Yes”。 

4. 选择输出到 “File” 或 “Memory”。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入需要的输出文件名，或者使
用 “Choose” 按钮选择一个输出文件名。 

一个新文件和标准的 ENVI 头文件由嵌入文件头中的信息创建了。 

图 2-4: DEM Reader Input Parameters 对话框. 

若没有选择镶嵌，并且要输出到一个文件，每个 DEM 都转换成自己的图像。这时，你应当输
入一个没有扩展名的文件名。输出文件为每个单独的图像名自动地增加一位数字（例如，第一个文

件为 “_1”，第二个文件为 “_2” 等等）。 

5. 点击 “OK” ，开始转换。 

出现一个显示处理进展的状态窗口。当完成后，来自转换文件的波段显示在可利用波段列表中

（参见第 97 页的 “Available Bands List”），它们可以使用 ENVI 功能进行标准显示和分析。 

USGS SDTS DEM 
ENVI 可以读取空间数据转换标准（SDTS）格式的 USGS 数字高程模型（DEMs）。投影信息
能被自动读取。 

1. 选择 File > Open External File > Digital Elevation Formats > USGS SDTS DEM. 

2. 当出现文件选择对话框时，选择 catalog 目录（通常为 xxxxCATD.DDF 文件）。 

3. 当出现 USGS SDTS DEM Input Parameters 对话框，从以下选项中作出适当的选择： 

·  若你想转换一个以上的 DEM 文件，点击 “Input Additional File” 然后使用文件选择对话框
选择新的文件。 

·  要自动地镶嵌 DEM 文件到一幅基于地理坐标的图像中，点击 “Mosaic Files” 标签附近的 
“Yes”。 

4. 选择输出到 “File” 或 “Memory”。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入需要的输出文件名，或者使
用 “Choose” 按钮选择一个输出文件名。 

一个新文件和标准的 ENVI 头文件由嵌入文件头中的信息被创建。 
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若没有选择镶嵌并且要输出到一个文件，每个 DEM 都转换成自己的图像。在这种情况下，你
应当输入一个没有扩展名的文件名。输出文件为每个单独的图像名自动地增加一位数字（例如，第

一个文件为 “_1”，第二个文件为 “_2” 等等）。 

5. 点击 “OK” ，开始转换。 

出现一个显示处理进展的状态窗口。当完成后，来自转换文件的波段显示在可利用波段列表中

（参见第 97 页的 “Available Bands List”），它们可以使用 ENVI 功能进行标准显示和分析。 

打开矢量文件 
该菜单选项允许你打开 ARCView Shape 文件、ARC / INFO 交换（Interchange）格式文件、DXF 

矢量文件、MapInfo Interchange 格式（.mif）、微型工作站 DGN （.dgn）、USGS DLG 文件、USGS 
SDTS 文件以及 ENVI 矢量格式（.evf）文件。你可以随意地导入多个矢量层；然而，应注意每个
文件应该只包含一个矢量层。 

1. 选择 File > Open Vector File > the desired format. 

2. 当出现标准文件选择对话框时，选择一个文件名，然后点击 “Open”。 

·  要选择一组连续显示的文件，在该组的第一个文件上点击，然后按住的同时，点击该组的最
后一个文件。或者，用鼠标左键点击和拖曳以选择所需要的组。 

·  要选择非连续显示的多个文件，按住 “Ctrl” 键，在每个所需要的文件上点击。 

3. 请看以下几节关于如何存取特定文件格式的详细描述。 

ArcView Shape 文件 

ENVI 能读取 ArcView Shape 文件，并将其转换成 ENVI 矢量文件。也能读取包含 ArcView 
Shape 文件属性（出现在 ArcView文件中）的文件。 

1. 选择 File > Open Vector File > ArcView Shape File. 

2. 当出现标准文件选择对话框时，选择你所需要的文件名。 

3. 当出现 Import ArcView Shape File Parameters 对话框，选择适当的选项： 

·  要选择导入另一个文件： 

A. 点击 “Input Additional File”。 

B. 从新的标准文件选择对话框时中选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

图 2-5: The ArcView File Parameters Dialog 

·  要从列表中删除一个文件，在 “Selected Files” 列表中使文件名突出，然后点击 “Delete”。 

4. 对于列表中的每个文件，选种文件名（使其高亮度显示），然后选择 “File” 或 “Memory” 输
出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI的矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 
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输出。 

5. 通过高亮度显示文件名，并在数据的投影上点击，来为每层指定投影类型。 

6. 点击 “OK” ，开始转换。 

出现一个显示进展状况的状态窗口。当 ENVI 完成转换处理，每个已转换的文件作为一个层显
示在 Available Vectors List 中 （第 114 页的 “Available Vectors List”）。 

ARC/INFO Interchange Format 文件 

该选项允许你转换和导入 ARC/INFO Interchange 格式文件（仅非压缩的）到 ENVI 矢量格式
文件或内存数据项。 

1. 选择 File > Open Vector File > ARC/INFO Interchange Format. 

2. 当出现标准文件选择对话框时，选择一个文件名。 

3. 当出现 ARC/INFO Interchange Input Parameters，从适当的选项中选择。 

·  要导入一个以上文件： 

A. 点击 “Input Additional File”。 

B. 从新的标准文件选择对话框时中选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

要转换的文件被列在 Input Parameters 对话框中的 “Selected Files:” 部分。 

4. 对于列表中的每个文件，选中文件名（呈高亮度显示），然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI的矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 
输出。 

5. 通过选中文件名并在数据的投影上点击，来为每层指定投影类型。 

6. 点击 “OK” ，开始转换。 

当 ENVI 完成转换处理时，每个已转换的文件作为一个层显示在 Available Vectors List 中 （第 
114 页的 “Available Vectors List”）。 

DXF 格式文件 

注意每个 DXF 输入文件应该只包含一个层。通过使用独立的 DXF 文件，多层 DXF 数据可
以被导入到 ENVI 。要按 ENVI 矢量格式转换和导入 DXF 矢量文件到文件或内存： 

1. 选择 File > Open Vector File > DXF. 

2. 当出现标准文件选择对话框时，选择一个文件名。 

3. 当出现 DXF File Parameters 对话框，从适当的选项中选择。 

·  要导入一个以上的 DXF文件： 
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A. 点击 “Input Additional File”。 

B. 当出现新的标准文件选择对话框时，选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

要转换的文件被列在 Input Parameters 对话框中的 “Selected Files:” 部分。 

4. 对于列表中的每个文件，选中文件名，然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI 矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 输
出。 

5. 通过选中文件名，并在数据的投影上点击，来为每层指定投影类型。 

6. 点击 “OK” ，开始转换。 

出现一个显示处理状态的状态窗口。当 ENVI 完成转换处理时，每个已转换的文件作为一个层
显示在 Available Vectors List 中 （参见第 114 页的 “Available Vectors List”）。你也可以从主显示窗
口访问它们（参见第 277 页的 “Vector Layers”）。 

MapInfo 

ENVI 能读取 MapInfo Interchange （.mif） 格式矢量文件以及与包含 .mif 文件属性信息相
关的 .mid 文件。ENVI 能自动读取投影信息。若 MapInfo 文件使用不被 ENVI 支持的投影，ENVI 
将使用任意的投影、文本和风格。 

文件将被转换成 ENVI 矢量文件（.evf）。 

1. 选择 File > Open Vector File > MapInfo. 

2. 当出现标准文件选择对话框时，选择你所需要的文件名。 

3. 当出现 Import MapInfo File Parameters 对话框时，选择适当的选项： 

·  要选择导入另一个文件： 

A. 点击 “Input Additional File”。 

B. 从新的标准文件选择对话框时，选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

要转换的文件被列在 Input Parameters 对话框中的 “Selected Files:” 部分。 

4. 对于列表中的每个文件，选中文件名，然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI 矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 输
出。 

5. 点击 “OK” ，开始转换。 



 29

出现一个显示处理状态的状态窗口。当 ENVI 完成转换处理时，每个已转换的文件作为一个层
显示在 Available Vectors List 中 （参见第 114 页的 “Available Vectors List”）。 

Microstation DGN 

ENVI 能读取 Microstation and Intergraph DGN（.dgn）格式文件，并将其转换成 ENVI 矢量文
件（.evf）。 Line、string、shape、curve、ellipse 和 arc 等基本类型将被解码。 

1. 选择 File > Open Vector File > Microstation DGN. 

2. 当出现标准文件选择对话框时，选择你所需要的文件名。 

3. 当出现 Import MapInfo DGN File Parameters 对话框时，选择适当的选项： 

·  要选择导入另一个文件： 

A. 点击 “Input Additional File”。 

B. 从新的标准文件选择对话框时，选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

4. 对于列表中的每个文件，选中文件名，然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI 矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 输
出。 

5. 通过选中文件名，并在数据的投影上点击，来为每层指定投影类型。 

6. 输入 DGN 比例系数，来转换矢量到适当的投影比例。 

地理投影使用度，其它类型使用米或英尺作单位。 

7. 点击 “OK” ，开始转换。 

出现一个显示处理状态的状态窗口。当 ENVI 完成转换处理时，每个已转换的文件作为一个 
ENVI 矢量层显示在 Available Vectors List 中 （参见第 114 页的 “Available Vectors List”）。 

USGS DLG 文件 

注意每个 DLG 文件应该只包含一个层。UTM 和 Albers Equal Area 投影信息将从文件头中读
取，并用于矢量投影。若你的 USGS DLG 文件以 USGS optional 格式储存在磁盘上，你可以使用
这个命令把它们以 ENVI 矢量格式导入到一个文件（或内存）。若你的文件存储在磁带上，请参阅
第 393 页上的 “Read Known Tape Formats”。ENVI 通常不能读取属性数据。 

1. 选择 File > Open Vector File > USGS DLG. 

2. 当出现标准文件选择对话框时，选择一个文件名。 

3. 当出现 DLG Reader Input Parameters 对话框时，从适当的选项中选择： 

·  要导入一个以上的 DLG 文件： 

A. 点击 “Input Additional File”。 
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B. 从新的标准文件选择对话框中，选择一个文件名。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

要转换的文件被列在 DLG Reader Input Parameters 对话框中的 “Selected Files:”部分。 

4. 对于列表中的每个文件，选中文件名，然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI 矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 输
出。 

5. 点击 “OK” ，开始转换。 

出现一个显示处理状态的状态窗口。当 ENVI 完成转换处理，每个已转换的文件作为一个层显
示在 Available Vectors List 中 （参见第 114 页的 “Available Vectors List”）。也可以从 Display 菜单
中的 “Vector Layers” 选项来选择它们 （参见第 277 页的 “Vector Layers”）。 

USGS SDTS 文件 

使用该选项来将空间数据转换标准格式的 USGS DLG 文件按 ENVI 矢量格式导入到一个文
件 （或内存）。ENVI 只提取空间对象的线、区域和点，并自动地读取投影信息。ENVI 通常不能
读取属性数据。 

1. 选择 File > Open Vector File > USGS SDTS. 

2. 当出现标准文件选择对话框时，选择 catalog 目录文件（通常为 xxxxCATD.DDF 文件）。 

3. 当出现 Import USGS SDTS DLG-3 File Parameters 对话框时，从适当的选项中选择： 

·  要导入一个以上文件： 

A. 点击 “Input Additional File”。 

B. 从新的标准文件选择对话框时，选择另一个 catalog 目录文件。 

·  要更改一个层名，在 “Layer Name” 文本框输入一个新名。 

·  要从列表中删除一个文件，在 “Selected Files” 列表中选中文件名，然后点击 “Delete”。 

要转换的文件被列在 Parameters 对话框中的 “Selected Files:”部分。 

4. 对于列表中的每个文件，选中文件名，然后选择 “File” 或 “Memory” 输出。 

·  若选择输出到 “File”，在 “Enter Output Filename” 文本框中键入输出文件名。 

ENVI 以 ENVI 矢量文件格式保存文件。当操作不同层时，你可以混合 “File” 和 “Memory” 输
出。 

5. 点击 “OK” ，开始转换。 

出现一个显示处理状态的状态窗口。当 ENVI 完成转换处理，每个已转换的文件作为一个层显
示在 Available Vectors List 中 （参见第 114 页的 “Available Vectors List”）。也可以从 Display 菜单
中的 “Vector Layers” 选项来选择它们（参见第 277 页的 “Vector Layers”）。 
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ENVI 矢量文件（.evf） 

内部的 ENVI 矢量文件格式 （.evf） 提供一种快速和高效的存储和处理矢量格式信息的方法。
你可以从任何矢量文件提取信息，并创建一个 ENVI 矢量文件。注意无论什么时候你读取 DLG 或 
DXF 文件并选择了文件输出，.evf 文件将自动地被创建。要打开一个 ENVI 矢量文件，按照以下
步骤： 

1. 选择 File > Open Vector File > ENVI Vector File （ .evf） 

2. 当出现标准文件选择对话框时，选择一个要读取的文件。 

已选定文件的每个层将自动地被导入到 Available Vectors List 中（参见第 114 页的 “Available 
Vectors List”）。 

Open Previous File 
 Open Previous File 菜单项包含一列在 ENVI 中 20 个最近打开的文件。选择一个所需要的文
件名，将打开该文件。每个新打开的文件被添加到列表的顶部。当已经打开 20 个文件以上，列表
底部的文件被删除。被 “sticky” 的文件仍将保持在先前文件列表的顶部 （关于文件 “sticky” 的详
细介绍，参见第 761 页的 “Edit Current Configuration”）。Open Previous File 菜单项下的文件名存储
在一个用户选择的 ASCII 文件中（参见第 761 页的 “Edit Current Configuration”）。该文件的格式在
第 808 页的 “ENVI Previous Files List” 中有描述。 

·  要从先前文件列表中打开一个文件，选择 File > Open Previous File > desired file name. 

文件将显示在可利用波段列表中。 

Scan Directory List 
当你打开文件时，你将发现扫描目录以定位想得到的文件是非常有用的。ENVI 提供递归

（recursive）目录扫描，并允许你选择多个文件来打开。geo-browser 选项允许浏览地理坐标图象
（georeferenced images）的定位（location）图，并打开基于地理坐标的文件 （参见第 95 页的 
“Geo-Browser”）。 

图 2-6: Directory Scan 对话框. 

1. 选择 File > Scan Directory List. 

2. 当出现 Directory Scan 对话框时，你可以输入目录名，或使用 “Choose” 按钮，通过在一个
文件上点击来选择一个目录。 

·  要添加已选择的目录到 Selected Directories List ，点击 “Add”。 

·  要添加一个目录和它所有的子目录到 Selected Directories List，点击 “Add Recursively”。 

（所有递归扫描的目录名前都出现一个 “+” ）。 

·  要从 Selected Directories List 删除一个目录，从列表中选中目录名，然后点击 “Selete”。 

·  要清除目录列表，点击 “Clear”。 

3. 一旦 ENVI 列出所有需要扫描的目录，点击 “OK”。 

出现 Scanned ENVI Files 对话框，它包含所列目录中找到的一列 ENVI 文件。使用 Scanned 
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ENVI Files 对话框，你可以打开许多文件。 

图 2-7: 已扫描的 ENVI 文件列表. 

注意 
若一个文件头与它的 ENVI 文件不匹配，ENVI 将显示一个警告消息。出现 Header Info 对话
框，以便你输入正确的信息。 

·  要忽略警告的文件，点击 “Cancel”。 

Scanned ENVI Files 对话框有一个菜单栏，它带有两个下拉菜单：File 和 Options 。 

·  为了使用打开文件并把图像波段放到可利用波段列表中： 

1. 在一个文件名上点击。 

2. 选择 File > Open File. 

·  要从列表中删除一个文件： 

在一个文件名上点击。 

2. 选择 File > Remove File. 

·  要从列表删除所有文件： 

1. 在一个文件名上点击。 

2. 选择 File > Remove All Files. 

·  要添加一个新目录，并从该目录中选择文件：选择 Options > Scan New Directory List. 

出现 Directory Scan 对话框。 

Geo-Browser 

有些情况下，你可能想扫描文件并根据它们的地理位置来打开。ENVI 的 Geo-Browser 允许浏
览这种对地理坐标定位图像位置的地图。要启动 ENVI 的 Geo-Browser： 

1. 从 Scanned ENVI Files 对话框内，选择 Options > Geo-Browser. 

ENVI 绘出一幅具有大陆和国家轮廓的世界地图。在 United States 内部，也出现州的轮廓。 

地理坐标定位图像的位置 （ ENVI 文件头中指定的基准像元（reference pixel）的位置 ） 在
世界地图上用旗帜标出。对于同一位置的多个文件，ENVI 绘出不同颜色的旗帜，并且旁边有一个
数字，它显示出在该位置是第几个文件。 

注意 
鼠标光标的经度和纬度显示在地图的左上角。 

2. 从以下选项中选择： 

·  要改变窗口的大小，按住并拖曳窗口的一角。 

·  要使地图在一点上集中（center the map on a point），点击鼠标左键。 

·  要放大地图区域，按住并拖曳鼠标中键。 
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·  要缩小回来，点击鼠标中键。 

·  要识别与旗帜相对应的文件，在旗帜旁点击鼠标右键。 

ENVI 在 Located Files List 中突出显示相对应的文件。 

对于有多个文件的地方，多次点击鼠标右键，以突出显示各自对应的文件。 

3. 当你通过突出显示已经选择一个文件后，选择 File > Open File 来打开。 

图 2-8: ENVI’s Geo-Browser zoomed on the United States. 

可用波段列表 
这个专用的工具列出 ENVI 已打开文件的所有波段，以便让你可以访问它们。它也允许你访问
一个文件内的单个波段。一旦 ENVI 打开一个文件， 可用波段列表（ABL）自动地包含一个该文
件中所有图像波段的列表（图 2-9）。若打开了多个文件，所有文件的所有波段按顺序显示，最近打
开的文件的波段在列表顶部。ABL 允许你显示灰阶和彩色图像、启动新的显示窗口、打开新文件、
关闭文件，以及设置显示边框。 

当你打开任何文件，ABL 自动地出现。 

要访问可用波段列表： 

1. 选择 File > Available Bands List. 

·  列表右边出现一个滚动条。若有必要，允许你滚动波段列表。 

·  通过在对话框的任意一角点击鼠标左键，然后拖曳到所需要的大小和/或形状，你可以拉伸和
调整 ABL 的大小。 

可用波段列表有一个菜单栏，它带有两个下拉菜单：File 和 Options，提供的辅助功能描述如
下。 

图 2-9: 可用波段列表：左边的对话框显示一个正导入的灰阶波段；右边的对话框显示正导入
的 RGB 波段。 

显示一幅灰阶图象 

1. 从 Available Bands List 内，选择 “Gray Scale” 切换按钮。 

2. 点击需要的波段名，它将显示在一个标签为 “Selected Band:” 的小文本框中。 

·  在所需要的波段名上双击鼠标左键，来把该波段自动导入到活动显示。 

3. 若有必要，改变活动显示（参见第 99 页的 “Selecting the Active Display”）。若没有打开的显
示窗口，那么将出现一个新的显示组。 

4. 在窗口底部点击 “Load Band”，来导入波段到显示，并出现一个图像窗口和相应的缩放/滚动
窗口。 

ENVI 用 2% 的线性拉伸系统默认值来显示所有图像。你可以在 envi.cfg 文件中改变系统
默认的拉伸值，或通过在图像头文件中设置一个拉伸系统默认值。（参见第 127 页的 “Edit ENVI 
Header”）。 
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显示一幅彩色合成图象 

1. 从 Available Bands List 内，选择 “RGB Color” 切换按钮。 

2. 在序列中点击所需要显示的红、绿和蓝波段名（或在每个 R、G 或 B 波段使用切换按钮）。 

·  在蓝波段名上双击鼠标左键，以把彩色图像自动导入到活动显示。 

3. 若有必要，改变活动显示（参见第 99 页的 “Selecting the Active Display”）。 

4. 一旦波段名导入到标签为 “R:”、“G:”、“B:” 的文本框中，点击 “Load RGB” 来显示彩色合
成图像。 

ENVI 用 2% 的系统默认线性拉伸值来显示所有图像。你可以在 envi.cfg 文件中改变系统
默认拉伸值，或通过在图像头文件中设置一个系统默认拉伸值。 

选择当前显示窗口 

ENVI 允许你同时打开多个显示窗口，允许任何灰阶和彩色图像一起显示。当你导入图像，你
可以选择一个现有的显示窗口或打开一个新的显示窗口来显示你的新图像。该显示将被称为 “Active 
display”。 

当没有任何打开的显示窗口，ABL 底部的按钮将显示 “No Display”。第一个导入的图像将自动
地显示在一个新窗口。 

要选择活动显示，请按以下步骤： 

1. 从 ABL 内，， 点击 “Display #X” 按钮菜单（其中 “X” 是与显示窗口标题栏内数字相对应
的数字），然后从列表中选择所需要的显示。 

·  要开始一个新的显示，从按钮菜单选择 “New Display”。 

点击 “Load Band” 或 “Load RGB” ，以把选定的波段导入选定的显示（见前面）。 

Fold 

在 Available Band List 中，你可以列出许多波段，特别是高波谱数据。Fold 选项允许你将一个
数据集的所有波段“折叠”显示，以便它们可以在 ABL 中一行显示。这使你的 ABL 保持简短，
并易于操作。 

要将一个数据集“折叠”成一行，按照以下步骤： 

1. 在 ABL 内点击你想的数据集的任何一个波段名。 

2. 点击 “Fold” 按钮。 

所有的波段将被“折叠”，并且数据集将在列表中以下列格式显示：<文件名[波段数]> 见图 2-10。 

·  要 “Unfold” 数据集并使它可用于处理，简单地在 ABL中点击被压缩的文件名。 

File 下拉菜单 

可利用波段列表 的 File 菜单包含打开新文件、列出打开的文件以及关闭文件等功能。 
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打开文件与打开文件列表 
·  要选择一个新文件来打开： 

1. 从 ABL 中，选择 File > Open Image File. 

2. 当 Enter Data Filename 对话框打开，选择你的新文件。 

·  要显示所有打开文件的一个列表： 

从 ABL，选择 File > Open Files List （参见第 124 页的 “Open Files List”）。 

Closing Files 
你可以从 ABL 中，使用 Close Selected File 或 Close All Files 选项来删除内存文件、波段或整

个磁盘文件。Close Selected File 功能允许你容易地刷新内存文件和关闭不再需要显示的磁盘文件。 

·  要关闭 “Selected Band” 文本小部件中当前导入的波段，或 “R”、“G”、“B” 文本小部件中的
波段，选择 File > Close Selected File. 

若要关闭一个来自磁盘文件的波段，ENVI关闭文件，文件中的所有波段将从 ABL 中消失。但
是文件仍保存在磁盘上，你可以使用 File > Open Image File 重新将它打开。 

警告 

一旦用这种方式删除一个内存文件，将无法再次恢复该图像。 

·  要关闭所有文件，选择 File > Close All Files. 

一个警告对话框将提示你对此进行确认。 

Cancel 
·  要在文件保持打开且波段保持有效的时候，关闭 ABL ，选择 File > Cancel. 

你可以通过从主菜单中选择 File > Available Bands List，在任何时候再次调用可利用波段列表。 

Options下拉菜单 

Available Bands List 的 Options 下拉菜单包含的功能有：通过波长选择一个波段，显示简化的
波段名，设置显示边框，以及将 ABL 中每个数据集的所有波段压缩或“Fold”成单个层。 

Wavelength Locator 
对于在文件头有相关波长值的文件，你可以用Wavelength Locator使用一个波长来选择要显示的

波段。 

1. 从 ABL，选择 Options > Wavelength Locator. 

2. 当出现 Wavelength Locator 对话框，输入你想定位的波长，然后点击 “Apply”。 

包含该波长的波段将突出显示在 ABL 中。该对话框保持打开，直到选择了 “Cancel” 按钮。 

显示波段名 
·  要在 ABL 中显示一个简化的波段名列表，选择 Options > Display Short Band Names. 

·  要在 ABL 中列出完整的波段名，选择 Options > Display Full Band Names. 
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显示边框 
若有必要，ENVI 允许你添加虚拟的边框到图像显示窗口。这些边框允许你在图像周围添加注
记。 

1. 选择 Options > Set Display Borders. 

2. 当出现对话框，在文本框的相应位置，为左、右、上、下图像边界输入所需要的像元数（例
如，在左边的文本框中输入左边框的，右边的文本框中输入右边框的等等）。 

注意 
输入 0 值来显示没有边框的图像，或删除原先显示的边框。 

3. 通过在 “Border Color” 下拉按钮上点击需要的颜色，以确定边框的颜色。当将图像输出到附
言（postscript）或一个图像文件时，边框的颜色可以更改。 

4. 点击 “Load Band” 或 “Load RGB”，来应用新的边框导入图像。 

以这种方式创建的边框是虚拟的边框，但是可以通过写入一个输出文件，来把它们永久地附加

到图像中（参见第 310 页的 “Display Output Options”）。 

·  为了下次显示，将所有边框的值重新设置为 0 ，选择 Options > Reset Display Borders. 

Fold 所有波段 
·  要在 ABL 中，把每个文件集的所有波段压缩成单个层，选择 Options > Fold All Bands. 

·  要解压缩一个数据集，在压缩的文件名上点击。 

图 2-10: 可利用波段列表 中压缩成一行的 bhtmref.img 6 个波段数据 

ENVI 图象显示窗口 
一旦你已经打开一个图像文件，你将通过 ENVI 图像显示窗口来和你的图像交互。当你显示波
段时，通常会发现三个窗口：Scroll（滚动）窗口、主图像窗口，及缩放窗口 （从一般到特殊移动）。
你可以使用多个显示窗口组。组中的每个窗口可以调整大小。 

注意 
当你在这些显示窗口中使用鼠标操作时，鼠标的功能在各种窗口类型中会改变。要获取如何在

各种窗口内操作鼠标的更详细信息，请参阅各个窗口描述中的表格。 

Scroll 窗口 

一旦你使用 ABL 将波段导入到显示，你将很可能在 Scroll 窗口内看见一个降低分辨率显示的
完整图像。重采样的分辨率将显示在标题栏中的圆括号内，并且滚动窗口内的一个方框将绘出在主

窗口中按全分辨率显示区域轮廓。仅在当前图像大于主图像窗口按全分辨率可以显示的情况下，出

现滚动窗口。因此若滚动窗口没有出现，你的图像小得足以用全分辨率浏览。这种情况，请参阅第 106 
页的 “The Main Image Window”。 

从滚动窗口控制主图像窗口 
滚动窗口包括一个 “Main Window indicator（主窗口指示器）” 方框，它绘出主图像窗口内按全

分辨率显示的图像部分的轮廓。你应该意识到主窗口指示器方框的大小与主图像窗口的大小直接相
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关联。若你改变主图像窗口的大小，主窗口指示器也将改变大小。若你调整主图像窗口大小，以便

按全分辨率显示整幅图像，滚动窗口将消失，因为不再需要它。若你随后再调整主窗口大小，以致

于按全分辨率不能显示整幅图像，滚动窗口将自动地再次出现。 

图 2-11: 滚动窗口。注意图像中央的主窗口指示器方框（框形轮廓）。 

要控制主窗口指示器的位置，按照表2-1 中的向导来获得你所需要的功能。 

 

鼠标按键 功能 

左键 在滚动窗口内主图像窗口指示器之外的任何地方点击并拖曳。缩放

窗口和主图像窗口相继更新。 

点击、拖曳并释放主窗口指示器方框，来重新定位主图像。当你释

放鼠标按键，缩放和主图像窗口更新。 

或者： 

点击，将被选定的像元定位于主图像指示器方框和主图像显示的中

央。 

中键 点击并拖曳 meta zoom box 。 

右键 点击来取消 meta zoom 。 

表2-1: 在滚动窗口内鼠标按键的功能 

调整滚动窗口大小 
在某些情况下，你可能想调整滚动窗口的大小。你可以用两种方式改变大小： 

·通过按住一角并拖曳到所需要的图像大小，动态地调整滚动窗口大小。 

·使用 envi.cfg 配置文件中的参数设置，来改变系统默认的滚动窗口大小（参见附录 A， 
“Installing and Customizing ENVI”）。 

滚动窗口 meta zoom 
当显示非常大的图像时，滚动窗口图像可能被重采样过多，以致于难以看到图像特征。滚动窗

口 meta zoom 允许你放大一个区域和减小滚动窗口的重采样系数。被放大的区域取代了滚动窗口中
的整幅图像，并作为整个数据集来使用。原来的滚动窗口图像用鼠标点击可以被重新显示（鼠标按

键功能，见表 2-1）。 

注意 
若选择的区域小于当前主图像窗口的大小，滚动窗口 meta zoom不能被缩放。 

要放大滚动窗口，点击并拖曳鼠标中键，把 meta zoom indicator box 拖到所需要区域的周围。
滚动窗口中这个区域将重新放置图像。 

要在滚动窗口显示原来的整幅图像，在滚动窗口点击鼠标右键。 

主图像窗口 

主图像窗口按全分辨率显示图像的一部分。该窗口在首次导入一幅图像时被自动创建。此外，

每次你从 Display Controls 菜单选择 Start New Display 或从 ABL 中选择 “New Display” 作为活
动显示，就出现一个新的主图像窗口。 
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调整主图像窗口大小 
选择以下选项之一，改变主图像窗口大小： 

·  通过按住一角并拖曳到所需要的图像大小，动态地调整主图像窗口直到现有的屏幕大小。 

·  选择 Functions > Display Characteristic > Change Display Parameters. 

在适当的文本框内输入所需要的大小。 

·  使用 envi.cfg 配置文件中的参数设置，来改变系统默认的滚动窗口大小（参见附录A， 
“Installing and Customizing ENVI”）。 

图像窗口滚动条 
主图像窗口边框内的滚动条允许你移动所显示的图像。当你使用滚动条时，滚动窗口的图形框

移动，以显示你在整幅图像中的哪个部分。显示图像窗口滚动条，有三种方法： 

要每次都在主图像窗口显示滚动条： 

1. 选择 System > Edit Current Configuration. 

2. 在 Edit System Preferences 窗口，点击 “Display Defaults”。 

出现 Preferences: Display Defaults 对话框。 

3. 点击 “Image Window Scroll Bars” 箭头切换按钮来选择 “Yes”。 

4. 点击 “OK”。 

5. 在 Edit System Preferences 窗口，选择 File > Save Configuration. 

·  不存盘退出，选择 File > Cancel。 

6. 键入一个输出文件名，然后点击 “OK”。 

·  要开启或关闭一个主图像窗口的滚动条： 

1. 在打开的显示中，选择 Functions > Display Characteristics > Change Display Parameters. 

2. 出现 Display Parameters 对话框。 

3. 点击 “Scroll Bars” 箭头切换按钮，选择 “Yes” 或 “No”。 

4. 点击 “OK”。 

或： 

·  使用鼠标右键双击缩放窗口的 cross-hair box 。 

从主图像窗口控制缩放窗口 

主图像窗口包含一个方框，该方框在它相应的缩放窗口中绘出显示的数据范围（描述如下）。通

过使用鼠标来围绕主图像窗口移动缩放框（ “Zoom Window Indicator” ），你可以改变该框限定的区
域。 

注意 
一些交互处理（从 Functions 菜单选择的那些）改变了表2-2中列出的鼠标功能。这些处理包括
定义感兴趣区域、注记以及动态覆盖。这些功能可以被关闭，以恢复鼠标按键的标准操作。 
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图2-12: 一个 ENVI 主图像窗口。这个主图像窗口属于第 1 个显示。 

注意在右上角的缩放窗口指示器（白色边框） 。 

 

鼠标

按键 
功能 

左键 在缩放窗口指示器内点击并拖曳到一个新的位置。当释

放按钮时，缩放窗口更新。 

或： 

点击使缩放窗口指示器的中心定在当前像元位置。按住

按钮并拖曳，来连续地更新缩放窗口。 

中键 没有功能 

右键 切换该显示的 Functions 子菜单on/off 。 

表 2-2：主图像窗口内的鼠标按键功能 

 

切换显示的 Functions 菜单 
显示的 Functions 菜单为你提供了一个常用交互显示操作的下拉菜单，这些操作仅应用于当前

显示窗口。这个下拉菜单出现在主图像窗口的左上角。 ENVI 允许你在开启和关闭之间切换菜单： 

·  在主图像窗口内点击鼠标按键，来在开启和关闭之间切换显示窗口 Functions 菜单。 

从 Functions 菜单选择的任何操作，将只应用于当前显示窗口（参见第 152 页的 “The Main 
Display Functions Menu”）。 

缩放窗口 

缩放窗口提供无限制的缩放能力，例如放大或缩小以及 panning，你可以用它来检查图像中被缩
放的部分。ENVI 使用像元复制来缩放，这允许你在缩放窗口内使用符号框（symbol box），选择任
意的缩放系数。而且，你可以开启缩放窗口和图像窗口的 cross-hairs，以及开启和关闭图像窗口的
缩放框。 

以下几节详述了如何结合不同的鼠标按键，使用符号框来控制缩放系数，如何定位缩放窗口的

中央，开启和关闭图示符（graphics），及 panning 。 

你还可以通过重新定位缩放窗口指示器方框，来控制缩放框的内容，这在第 106 页的 “The 
Main Image Window” 中有所讨论。 

调整大小和放置缩放窗口 
要调整大小或移动缩放窗口，从以下选项中选择。 

·  要把缩放窗口放到合适的位置，点击标题栏并拖曳鼠标左键。 

·  通过按住一角并拖曳到所需要的图像大小，动态地调整缩放窗口大小。主图像窗口中相应的
缩放窗口指示器方框自动地改变它的大小和形状，以与显示的缩放窗口相匹配。 

·  通过使用 Functions > Display Characteristics 菜单选项，来改变缩放窗口的大小和位置。 
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·  改变 envi.cfg 配置文件中的系统默认缩放窗口大小的参数设置（参见附录 A， “Installing and 
Customizing ENVI”）。 

图 2-13: 带有符号框的 ENVI 缩放窗口。 

注意当前的缩放系数10 ，显示在窗口标题栏中。 

控制缩放窗口的缩放系数 
当前的缩放系数以一个数字的形式显示在缩放窗口标题栏中的圆括号内。系统默认的缩放系数

为 4 。使用不同的鼠标按键和缩放窗口中的符号框，你可以改变缩放系数，以及开启和关闭显示的
缩放窗口和主图像窗口中的十字准线。表 2-3 描述了缩放窗口的符号功能及其相应的鼠标按键描
述。 

缩放窗口内的鼠标按键功能 
除了与缩放窗口符号框及控制缩放系数相关的鼠标按键功能外，在缩放窗口之内的任何一处（不

在符号框上）点击，鼠标左、右键执行不同的任务。表 2-4 描述了这些功能。 

 

缩放窗口符

号 
功能 

加号 用鼠标左键点击使缩放系数加1。 

用鼠标中键点击来加倍缩放系数（即 2， 4， 8， 
16...）。 

用右键点击以返回到系统默认缩放系数值 4 。 

减号  

十字准线方

框 
 

表 2-3： 用鼠标按键描述的缩放窗口符号功能。 

 

鼠标按键 功能 

左按钮 点击来将被选定的像元定位于缩放窗口的中央。. 

或： 

点击，并按住从窗口中央向光标位置方向移动（移动

的速度随光标与缩放窗口中央的距离而不同。离中央越

近，移动速度越慢）。 

中间按钮 没有功能 

右按钮 点击，在开启和关闭之间切换缩放窗口符号（即 +，
－）。 

表 2-4：缩放窗口内的鼠标按键功能。 

可用矢量列表（Available Vectors List） 
一些数据文件，像公路或水路的 “地图”，是以矢量文件存储的。ENVI 对矢量文件的处理不同
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于图像文件，因此当导入矢量文件到内存后，你必须通过 Available Vectors List （图 2-14） 访问矢
量文件。 

能在 Available Vectors List（AVL） 中显示的数据文件包括 ENVI 矢量文件、DLG、SDTS、
DXF或 ARC/INFO Interchange 和 ArcView Shape 文件。 

若你使用 File > Open Vector File ，已经打开多个矢量文件，Available Vectors List 列出所有打
开的文件，并显示当前使用的层。从 Available Vectors List 中，你可以选择要显示的矢量覆盖在一
幅图像上或在一个单独的窗口显示，并使用两个下拉菜单：File 和 Options 。 

·  通过在对话框的一角点击鼠标左键并拖曳到所需要的大小和/或形状，你可以拉伸和调整 
AVL 的大小。 

Loading Vectors for Display 

在 ENVI 中显示矢量文件，按照下列步骤： 

1. 从 ENVI 主菜单，选择 File > Available Vectors List. 

所有打开的矢量层将出现在 AVL 中。 

2. 通过在层名上点击，来选择要导入到矢量或图像显示的矢量层。 

·  要选择所有层，点击 “Select All Layers”。 

·  要清除所有层，点击 “Deselect All Layers”。 

·  要从列表中删除一个层，点击层名，然后点击 “Remove Selected”。 

3. 在 Available Vectors List 中点击 “Load Selected”，将矢量导入到一个矢量或显示窗口。 

4. 当出现 Load Vector Layers 对话框时，通过在所需要的窗口名上点击，来选择一个矢量目的
文件显示窗口。 

图 2-14: Available Vectors List. 

·  若一个图像显示窗口被打开，该显示名（即 Display #1） 将出现在列表中。点击所需要的显
示窗口名，在已显示的图像上绘制矢量图。 

·  若一个矢量窗口被打开，矢量窗口名（即 Vector Window #1） 将出现在列表中。点击所需
要的矢量窗口名，在该窗口内绘制矢量图。 

·  通过选择 “New Vector Window”，矢量可以被绘制到一个新的矢量窗口。 

5. 点击 “OK”。 

将出现 Vector Window Parameters 对话框，它列有已被选择的矢量（参见第 122 页的 “The 
Vector Window Parameters Dialog”）。 

File 下拉菜单 

File 下拉菜单中的选项允许你打开新的矢量文件，导出矢量层到一个感兴趣区域（ROI）或 
ArcView 文件，以及把层从内存中保存到一个文件。 



 42

注意 
ENVI 矢量文件可以被转换成 DXF，通过使用 Utilities > Vector Utilities > Convert EVF to DXF 

功能（参见第 390 页的 “Convert EVF to DXF ”）。 

·  要打开 Available Vectors List 对话框中的一个文件： 

1. 选择 File > Open Vector File > vector file type. 

2. 当出现标准文件选择对话框时，选择所需要的文件（有关细节，见第 83 页的 “Open Vector 
File”）。 

·  要把矢量层导出到一个感兴趣区域（ROI）： 

1. 通过点击它们的名字，来选择要导出的矢量。 

2. 选择 File > Export Layers to ROI. 

3. 当出现 Select Data File to Associate with new ROIs 对话框时，选择所需要的数据文件。 

4. ROIs 将显示在 Region of Interest Controls 对话框中。 

警告 

这可以创建非常大的 ROIs 。 

·  要把矢量层导出到一个 ArcView 兼容文件集，它包括一个 shape 文件（.shp）， 一个 index 
文件（.shx） 和一个数据库文件（.dbf）： 

1. 在 Available Vectors List 中，通过点击它们的名字，选择要导出的矢量。 

·  要导出所有的层，点击 “Select All Layers”。 

·  要选择多个层，但不是所有的层，按住键盘上 “Ctrl” 键的同时，在你想要导出的各层上点
击。 

2. 选择 File > Export Layers to ArcView. 

·  若你决定不想从 Available Vectors List 导出任何矢量，选择 File > Cancel to 退出，这时并没
有从内存中删除已导入的矢量。 

3. 当出现 Output Layer to ArcView Shape File 对话框时，输入所需要的输出文件名，然后点击 
“OK”。 

对于每个已选择的层，都会出现该对话框。 

每个 ArcView 矢量文件只能包含一种类型的矢量（多边形、点等等），因此对于每种矢量类型， 
ENVI 将使用一个基名（base name）和附加的扩展名。多边形使用扩展名 .pg ，点使用扩展名 .pt 。 

警告 

导出到 ArcView 的矢量层必须是正确的拓扑结构，否则在 ArcView 中的结果将无法预测。 

·  要把当前内存中的矢量层保存到一个文件： 

1. 在 Available Vectors List 中，通过在层名上点击，选择当前内存中的层。 

2. 选择 File > Save Memory Layers to File. 
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3. 键入一个输出文件名。 

Options 下拉菜单 

Options 下拉菜单的选项包括：启动一个新的矢量窗口，从内存中删除所有矢量层，编辑层名，
更改投影类型，把层从一种投影转换成另一种投影，创建各种世界（world）边界矢量，以及创建新
的空矢量层。 

·  要启动一个新的空矢量窗口和相应的参数对话框，选择 Options > Start New Vector Window. 

·  要从内存中删除所有的矢量层，选择 Options > Remove All Layers. 

注意 
一旦以这种方式从内存中删除矢量，恢复这些层的唯一方法是再次从磁盘读取它们。 

·  要在 Available Vectors List 内编辑层名： 

1. 选择 Options > Edit Layer Names. 

2. 当出现 Edit Layer Names 对话框时，点击你要修改的层名。 

该层名将显示在 “Edit Selected Item:” 文本框中。 

3. 通过在框中键入，来改变层名。 

·  要返回未编辑过的层名，点击 “Reset”。 

4. 点击 “OK”。 

·  要改变一个层的投影类型： 

若一个层取名不当，使用该选项。 

1. 选择 Options > Edit Layer Projection. 

2. 当出现 Edit Layer Projection 对话框时，通过点击一个新的投影类型来选择它。 

·  若你选择 “Arbitrary”，你可以选择 “Coordinates” 标签附近的 “Pixel Based ” 或 “Map 
Based”。 

·  若选择 “Geographic Lat/Lon:”，通过点击 “Datum” 按钮，并在 Select Geographic Datum 对
话框内现有的基准点中选择。你可以选择一种基准点类型。 

·  若选择 “UTM”，在“Zone” 文本框中输入数字，选择 “N” 或 “S” 切换按钮，然后选择一个
基准点（若有必要）。 

·  若选择的是任一 “State Plane...” 投影，通过点击箭头切换按钮来选择 “Feet” 或 “Meters”，
然后通过在 “Zone” 文本框中输入来选择一个区域，或点击“Zone”从列表中选择。 

3. 点击 “OK”。 

改变类型并不影响任何数据点，它只改变投影名。要在投影之间转换，见以下所述。更多的地

图投影信息，请参阅第 457 页的 “Map Projection Utilities”。 

·  要把一个层从一种投影转换成另一种投影： 

1. 在 Available Vectors List 中，点击一个层名。 
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2. 选择 Options > Convert Layer Projection. 

3. 当出现 Convert Layer Projection 对话框时，从列表中选择一种投影类型。 

·  若你选择  “Arbitrary”，你可以选择  “Coordinates” 标签附近的  “Pixel Based” 或  “Map 
Based”。 

·  若你选择 “Geographic Lat/Lon:”，通过点击 “Datum” 按钮以及在 Select Geographic Datum 
对话框内现有的基准点中选择，你可以选择一种基准点类型。 

·  若选择 “UTM”，在“Zone” 文本框中输入数字，选择 “N” 或 “S” 切换按钮，然后选择一个
基准点（若有必要）。 

·  若选择的是任一 “State Plane...” 投影，通过点击箭头切换按钮来选择 “Feet” 或 “Meters”，
然后通过在 “Zone” 文本框中输入来选择一个区域，或点击“ Zone ”从列表中选择。 

4. 若有必要，输入一个新的层名。 

5. 选择输出到 “File” 或 “Memory”。 

·  若你选择 “File” 输出，键入一个输出文件名。 

6. 点击 “OK”。 

有关投影变换的更多信息，请参阅第 457 页的 “Map Projection Utilities”。 

·  要从高分辨率或低分辨率数据库中创建各种世界性边界矢量层：包括行政边界，海岸线，河
流以及USA States 。 

1. 选择 Options > Create World Boundaries. 

2. 通过点击层名附近的复选框，来选择所需要的层。 

·  要选择一系列层，输入起始数和结尾数，然后点击 “Add Range”。 

·  要选择所有层，点击 “Select All”。 

·  要清除所有层，点击 “Clear”。 

3. 选择输出到 “File” 或 “Memory”。 

·  若你选择输出到 “File”，键入所需要的输出根文件名，或使用 “Choose” 按钮来选择一个输
出文件名。 

为每个已选择的层，都创建一个 .evf 输出文件，并用层的缩写附加在根文件名后来命名。高分
辨率的行政边界、海岸线、河流层将分别用 “_hp”、 “_hc” 或 “_hr” 命名。 低分辨率的层将以同
样方式命名，但是用 “_lp” 等。USA States 层将在根名后附加 “_usa”。 

警告 

从高分辨率数据库建立的层，将产生非常大的输出文件 （每个约 20 MB）。 

4. 点击 “OK” 来建立矢量层。 

已选择的层将出现在 Available Vectors List 中。 

·  要从一个现有的矢量层中使用投影和边界，来创建一个新的矢量窗口，按照以下步骤： 

创建一个新的空矢量层，这样你可以输入自己的带有多边形、线、点和属性的矢量层。这个矢
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量层可以和现有矢量层、地理坐标定位栅格图像或来自用户自定义输入的用相同的投影和地理边界

（size）。一个空矢量层也可以通过在没有地理坐标定位的栅格图像上绘制矢量来创建。 

1. 选择 Options > Create New Vector Layer > using existing vector layer. 

2. 当出现 New Vector Layer Parameters 对话框时，点击矢量层名，设置投影和大小边界。 

3. 键入一个层名，选择输出到 “File” 或 “Memory”，若有必要，键入一个输出文件名。 

·  由一幅栅格图像，使用投影和边界（或 size in pixels），来创建一个新的矢量窗口： 

1. 选择 Options > Create New Vector Layer > using raster image file. 

2. 当 Select Image File for New Vector Layer 对话框出现时，选择所需要的图像文件，然后点击 
“OK”。 

3. 当出现 New Vector Layer Parameters 对话框时，键入一个层名，选择输出到 “File” 或 
“Memory”；若有必要，键入一个输出文件名。 

·  使用用户自定义的参数来创建一个新的矢量窗口： 

1. 选择 Options > Create New Vector Layer > using user defined parameters. 

2. 当出现 New Vector Layer Parameters 对话框时，选择需要的投影类型；若有必要，输入一个
区域号（Zone number）。 

3. 在 “X/Ymin” 和 “X/Ymax” 文本框中，按已选择的投影单位输入限定框的坐标。 

4. 键入一个层名，选择输出到 “File” 或 “Memory”，若有必要，键入一个输出文件名。 

ENVI 矢量窗口 
为了显示矢量数据及合成简单的矢量地图，ENVI 提供了一个独立于操作系统的（stand-alone） 

GIS 图表窗口。ENVI 也在标准 ENVI 显示上提供矢量覆盖，包括在所有窗口内（包括缩放窗口）
覆盖图的真矢量化（true vectorization）。矢量数据的精确度完全被保留，避免 “Pixellation”。矢量可
以从多种输入文件中读取，也可以在一个矢量窗口或在图像上创建和绘制新的矢量层。当交互地跟

踪矢量时，显示纬度/经度和地图坐标信息。当光标跟踪每个矢量时，一个 Vector Information 窗口
可以适时地显示属性信息。你可以直接查询矢量 GIS 的属性信息，生成具有已选定属性信息的新层。
由 ENVI 内部的 .evf 格式，创建 ArcView Shape 文件以及相应的 .dbf 属性文件和索引，或DXF 文
件。用 ENVI 强大的图像处理能力生成的新矢量层，以及 ENVI 中矢量层的变化，很容易导出工
业标准的 GIS 格式。 

ENVI 的矢量窗口提供了浏览下列数据的一种方式，如 USGS Digital Line Graphs（DLG）、USGS 
DLGs空间数据转换标准格式、DXF 文件、ARC/INFO Interchange 文件及 ArcView Shape 文件等矢
量数据。你可以浏览、编辑和查询与 ArcView Shape 文件相关的属性，也可以创建你自己的矢量文
件和属性。ENVI 的矢量窗口包括：一个矢量显示窗口或图像窗口，及一个 Vector Window Parameters 
#N 对话框。该对话框控制矢量的显示以及与矢量属性的交互。 

The Vector Window Parameters Dialog 

矢量数据通常由多个矢量数据层组成。例如，图 2-15 显示出现有的矢量层，包括 “Cities”、
“Counties”、“Roads” 和 “States”。和矢量窗口一同出现的Vector Window Parameters 对话框 （图 
2-15），允许你控制矢量层的显示、添加新的矢量、为用于图象到地图的配准来导出矢量层坐标，以
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及浏览、编辑和查询矢量属性。当矢量覆盖在一个显示的图像上，它们可以被绘制在图像窗口和/或
滚动和缩放窗口中。有关与矢量窗口交互的细节，请参阅第 277 页的 “Cursor Functions in Vector 
Windows” 和第 279 页的 “The Vector Window Parameters Dialog”。 

图 2-15: Vector Window （左） 和相应的 Vector Window Parameters 对话框。 

矢量属性 
矢量层可以有相应的属性。ENVI 能读取 ArcView Shape 文件属性，并可以与之交互。你可以

使用光标选择矢量窗口中的矢量来突出显示相应的属性，或选择一个属性来突出显示相应的矢量。

你可以进行矢量属性查询，使用简单的数学和逻辑运算选择属性，以创建新的矢量层。ENVI 也允
许你编辑现有属性或给矢量添加新属性。点的属性名可以被绘制在矢量窗口中，点的符号大小与属

性值有关。（参见第 290 页的 “Vector Attributes”）。 

注意 
目前，ENVI 只读取 ArcView Shape 文件属性或通过 ENVI 功能添加的属性。 

打开文件列表（Open Files List） 
若你需要关于当前在 ENVI 中打开的或存储在内存中的文件的信息，Open Files List 菜单选项

将为你提供这些信息。你也可以使用该功能来打开新文件、关闭文件、将内存数据项保存到磁盘，

以及编辑 ENVI 文件头。你应当有规律地定期地使用 Open Files List ，以便从系统内存中删除仅存
在于内存的计算结果。 

·  要显示当前所有打开的图像文件的一个列表，选择 File > Open Files List. 

从 Open Files List 内，你将获取大量有用的功能部件， 这些可以在 File 和 Options 下拉菜单
中找到。这些功能部件描述如下。 

图 2-16: Open Files List. 

获取文件信息 

ENVI 可以提供关于各个文件的重要信息。 

·  从 Open Files List 内，在文件名上点击。 

ENVI 显示来自 ENVI 头文件的信息和参数，这包括完整路径和图像名；行数，样本数和波段
数（维）；文件大小；交叉格式（BSQ， BIL， BIP）；数据类型（字节，整型等）；文件类型；数据
的字节顺序（Host 或 Network）；以及数据是否已地理坐标定位，是否任何波长与波段相关。 

File 下拉菜单 

File 下拉菜单允许你打开新文件、关闭文件、删除内存数据项、删除磁盘中的文件，以及保存
内存数据项到磁盘。 

·  要打开一个新文件： 

1. 从 Open Files List 内，选择 File > Open New File. 

2. 当出现标准的 ENVI 文件选择对话框时，选择所需要的文件，然后点击 “OK”。 

·  要选择一组连续显示的文件，在该组的第一个文件上点击，然后按住的同时，点击该组的最
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后一个文件。或者，用鼠标左键点击和拖曳来选择所需要的组。 

·  要选择非连续显示的多个文件，按住 “Ctrl” 键，在每个所需要的文件上点击。 

ENVI 打开文件，并将它添加到打开文件列表中。文件信息显示在对话框的右边。 

·  要关闭所有文件（包括自动被删除的内存数据项），从 Open Files List 内选择 File > Close All 
Files 。 

·  要在不关闭打开的磁盘文件情况下，删除那些仅存在于内存中的“文件”，在 Open Files List 
内选择 File > Delete All Memory Items 。 

警告 

用这种方式删除的内存数据项是不能恢复的。 

·  要把当前内存中的文件写到磁盘： 

1. 从 Open Files List 内，选择 File > Save Selected File to Disk. 

2. 当出现 Memory to File Storage 对话框，键入一个输出文件名，然后点击 “OK” 来保存文件。 

选择一个文件而不是内存数据项，这是无效的，因为该文件没必要被再次保存。 

·  要从磁盘存储器中删除一个选择的文件： 

1. 从 Open Files List 中，选择 File > Delete Selected File from Disk 。 

因为这是一次彻底的操作，一个警告消息出现，来确认你想永久地删除该文件。 

2. 点击 “Yes” ，删除该文件。 

·  要从 Open Files List 中关闭一个已选定的文件，选择 File > Close Selected File. 

注意 
若出现一个提示，这说明该文件的一个或多个波段在一个活动显示窗口中当前正被显示。选择 

“Yes” 来关闭该文件，并从显示中删除相应的波段。 

若该文件是一个内存数项，那么任何相应的显示被关闭。 

·  要关闭 Open Files List ，选择 File > Cancel. 

Options 下拉菜单 

Options 下拉菜单允许你编辑文件头（有关细节，参见第 127 页的 “Edit ENVI Header”）。 

1. 从 Open Files List 内，点击需要的文件名。 

2. 选择 Options > Edit Header. 

3. 当出现 Header Info: 对话框，更改所需要的文件头参数，然后点击 “OK” ，保存更改。 

编辑 ENVI 文件头 
ENVI 在一个单独的文本头文件中保存关于文件的信息。这个头文件名与图像文件名相同，但
是文件扩展名为.hdr 。 Edit ENVI Header 功能允许你更改文件头信息。每当打开一个数据文件，
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ENVI 便搜索头文件，并使用这些信息来打开文件。 

若你需要编辑 ENVI 文件头，按照以下步骤： 

1. 选择 File > Edit ENVI Header. 

标准的 ENVI Input File 对话框将打开，为你提供一个打开文件的列表，可以从中选择。 

2. 在所需要的文件名上点击。 

在标签为 “File Information” 的文本框内，ENVI 显示关于该文件的细节。 

3. 确认这些信息是正确的。 

要编辑所显示的参数，按照以下步骤： 

4. 点击 “OK” 来启动一个 Header Info 对话框（见下）。 

Header Info 对话框有一个可编辑的文本区，及 Input Header Info From 和 Edit Attributes 下拉
菜单。 

5. 当你完成编辑后，点击“OK”。 

若已经对当前打开文件的文件头编辑完毕，ENVI 将关闭该文件；当你选择“OK”时，再重新
打开。因为当该文件关闭时，该文件使用的显示也将关闭。你必须从 ENVI 主菜单，或可利用波段
列表中重新启动这些显示。 

Header Info对话框 

Header Info 对话框包括：用于通用图像参数的可编辑的文本区与两个下拉菜单。从 Header Info 
对话框里，你可以点击 Edit Attributes 下拉菜单中的选项，调用编辑特定文件头参数的独立对话框。
这些参数包括波段名、波长、地图信息等。有关细节如下。 

编辑通用图象参数 

在 Header Info 对话框中，你可以编辑通用图像参数。每个文本区的说明如下： 

·  “Samples” 文本区显示文件中的样本数。 

·  “Lines” 文本区显示文件中的行数。 

·  “Bands” 文本区显示文件中存储的波段数。 

·  “Offset” 文本区显示从文件开头到实际数据起始处的字节偏移量。（“偏移量”有时被称为嵌
入的文件头。） 

·  “Xstart” 和 “Ystart” 文本区显示其它图像子集的图像的像元偏移量。偏移量允许链接相关的
图像，以及使用动态覆盖图。 

图 2-17: Header Information 对话框。 

·  使用 “Data Type” 下拉菜单，来选择适当的数据类型 （字节型<byte>，整型<integer>， 无
符号整型<unsigned integer>，长整型<long integer>，无符号长整型<unsigned long integer>，浮点型
<floating point>，双精度型<double precision>，复合型<complex>，或双精度复合型<double complex>）。 

·  使用“Byte Order” 下拉菜单，来选择数据的字节顺序。这个参数在不同的平台有所不同： 
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·  对于 DEC 和 PC 机，选择 “Host （Intel）”: Host Least Significant First. 

·  对于其它的所有平台，选择 “Network （IEEE）”: Network Most Significant First. 

·  使用 “Interleave” 下拉菜单，选择下列选项，以确定数据存储顺序： 

·  “BSQ” 代表波段顺序存储格式。 

·  “BIL” 代表波段按行交叉格式。 

·  “BIP” 代表波段按像元交叉格式。 

·  使用Header Info 对话框底部的文本区来插入描述该数据文件的字符串文本。 

·  “File Type” 按钮下拉菜单的说明如下。 

文件类型 
ENVI 使用 “File Type” 文件头区域自动地识别某些数据文件类型。 “File Type” 文本区允许许

多文件类型在以它们本身的格式存在时就有一个  ENVI 文件头。通过查看  menu 目录下的 
filetype.txt 文件（ENVI 各版本都有），你可以看到一个所有认可的文件类型列表。你可以编辑该文
件，并添加新的用户自定义文件类型（参见《ENVI 程序指南》第 6 章， “Custom File Input”）。 

文件类型包括 ENVI 特有的文件类型，诸如元文件（meta files）、分类文件、虚拟镶嵌（virtual 
mosaics）、 波谱库及 FFT 结果。文件类型也包括特定的数据格式，如NLAPS、RadarSat、Spot 等。
此外还认可 TIFF、BMP、ERDAS 8.x 和 PCI 文件。 

从菜单输入文件头信息 

Header Info 对话框的 Input Header Info From 下拉菜单允许将文件头信息从另一个文件合并到
当前文件头。 

1. 选择 Input Header Info From > Other File. 

2. 选择所要读取的头信息文件，然后点击 “OK”。 

Edit Attributes 按钮 

Header Info 对话框的 Edit Attributes 下拉菜单为你提供了一种编辑波段名、波长等辅助的文件
头信息的方法。Edit Attributes 菜单也允许你决定用什么样的图像来显示复数数据类型，编辑地图、
分类、Z-plot 及拉伸信息。 

这些选项的详细描述如下。 

编辑辅助头信息 
ENVI 文件头可以有相应的依赖于图像数据类型的辅助信息（波段名、波谱库名、波长、Bad
波段列表、FWHM 等）。你可以更改这些值，或按照下列步骤将它们读入到头文件： 

·  要选择 Bad 波段： 

1. 选择 Edit Attributes > Bad Bands List. 

2. 在 Edit Bad Bands List values 对话框，选择 bad 波段。 

·  要选择连续显示的一组文件，先点击第一项，按住 “shift” 键的同时，点击该组最后一项。 
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·  要选择非连续显示的一组文件，先点击一项，按住 “Ctrl” 键的同时，点击其它所有需要的
项。 

·  要取消选择所有波段，点击 “Clear”。 

·  要选择一个特定范围的波段： 

A. 在 “Add Range” 按钮旁的两个文本框，键入起始和结尾波段数。 

B. 点击 “Add Range”。 

3. 点击 “OK”。 

·  要选择其它属性来编辑： 

1. 选择  Edit Attributes > Band Names，Spectral Library Names，Wavelengths，或 FWHM 
（Full-Width-Half-Maximum） 来激活相应的对话框。 

图 2-18: Edit Bad Bands List values 和 Edit Band Name values 对话框。 

若你以前添加或编辑了上述列出的参数值，则那些值显示在 “Current Parameter Values: ” 文本标
签的下面（“参数”指上面显示的其中一项）。否则，显示出系统默认值。 

2. 从显示的列表中，点击你想编辑的值。 

该值突出地显示在 “Edit Selected Item” 标签下的文本框中。 

3. 在文本框中，键入新值。 

·  要从 ASCII 文件导入数据： 

1. 在任一 Edit Values 对话框，点击 “Import ASCII”。 

2. 当出现标准的 ENVI 文件选择对话框时，打开所需要的 ASCII 文件。 

ASCII 文件的行数必须与图像文件中的波段数相匹配。ASCII 文件可以有一列或多列 ASCII 
数据，然而用于导入波段名的文件只能包含字符串。当你打开显示有来自 ASCII 文件开头几个值的
文件时，出现 Input ASCII File 对话框。 

图 2-19: Input ASCII File 对话框。 

·  “ Wavelength Column ” 文本框指定从 ASCII 文件哪一列读取波长。 

·  “ Multiply Factor ” 文本框中输入的乘法比例系数，允许对波长值进行 on-the-fly缩放。例如，
键入值 “100” 再按回车键，将使导入的波长值乘以 100 。 

·  “ FWHM ” 栏指定从哪列来获取波段宽度信息（用于波谱重采样）。 

·  “ Bad Bands List ” 栏使用 “0” 来屏蔽指定波长的波段。 

3. 点击 “OK” ，键入新的参数值，并返回到 Header Info 对话框。 

4. 在 Header Info 对话框，点击 “OK” ，将所有改变写入头文件。 

默认的装入波段 
每当打开文件，该选项允许波段被自动地导入到可利用波段列表的灰阶或 R、 G、和 B 文本

框。点击 “Load” 或 “Load RGB” 按钮，系统显示默认的波段。可以选择灰阶图像或彩色图像。 

1. 从 Header Info 对话框，选择 Edit Attributes > Default Bands to Load. 
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Default Bands to Load 对话框显示该文件中所有波段的一个列表。 

2. 点击波段名，来导入红（R）、绿（G） 和 蓝（B） 电子枪。 

·  若只有一个波段被选择，它将作为灰阶图像被导入。 

·  点击 “Reset” 来清除所有波段。 

3. 点击 “OK” ，返回 Header Info 窗口。 

Map Information 对话框 
地图信息与地理坐标定位的文件相关。要建立地理坐标定位的数据坐标系统，用户必须知道一

个像元（基准像元） 的样本和行坐标、像元的大小（米）、地图投影以及该像元的地图坐标。 

1. 从 Header Info 对话框，选择 Edit Attributes > Map Info. 

2. 在 Map Information 对话框里，标签为 “Image Coord X” 和 “Y” 文本框中输入基准像元的
坐标，标签为 “Pixel Size X” 和 “Y” 文本框中输入像元大小。 

3. 通过点击 “Change Projection” 并从投影列表中选择适当的投影，以确定地图投影。 

·  若你选择  “Arbitrary”，你可以选择  “Coordinates” 标签附近的  “Pixel Based” 或  “Map 
Based ”。 

·  若你选择 “Geographic Lat/Lon:”，通过点击 “Datum” 按钮，并从 Select Geographic Datum 对
话框中选择可利用的数据，以确定数据类型。 

·  若你选择 “UTM”，在 “Zone” 文本框中输入数字，选择 “N” 或 “S” 切换按钮，然后再选
择一个数据（若有必要）。 

·  若选择的是 “State Plane...” 投影中的一个，通过点击箭头切换按钮，选择 “Feet ” 或 
“ Meters ”；通过在 “Zone” 文本框中输入，或点击 “Zone” 从列表中选择，以确定一个区域。 

4. 在适当的文本框中输入基准像元的坐标。 

相应的纬度和经度将被自动计算，并可通过点击切换按钮到 “Geographic Coordinates” 来查看。 

5. 点击 “OK” ，返回到 Header Info 窗口。 

图 2-20: Map Information 对话框。 

Geographic Corners 
若你的文件没有被地理坐标定位，但是包括地理信息，该选项允许你把信息放到 ENVI 头

文件中。目前，ENVI用第一个地理点（geographic point ）在 geo-browser 上放置一面旗帜以显
示文件的位置（参见第 95 页的 “Geo-Browser”）。其它的点作为用户信息仍保留在文件头中。 

1. 从 Header Info 对话框，选择 Edit Attributes > Geographic Corners. 

2. 输入第一和第四像元间的位置，及其相应的纬度和经度。 

图 2-21: Class Color Map Editing 对话框。 

像元大小（Pixel Sizes） 
要在文件头中输入一个像元的大小： 

1. 从 Header Info 对话框，选择 Edit Attributes > Pixel Sizes. 
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2. 将 X 和 Y 像元大小输入到适当的文本框中，并从 “Units” 下拉菜单中选择所需要的单位。 

分类信息（Classification Info） 
若你需要为某类修改类别名和颜色，按照下列步骤： 

1. 从 Header Info 对话框，选择 Edit Attributes > Classification Info. 

要使该选项有效，“File Type” 必须设置为 “Classification”。 

2. 在 Classification Info 对话框中，输入类别号；然后点击 “OK”。 

3. 当出现 Class Color Map Editing 对话框时，从 “Selected Classes” 列表点击要更改区域的类
别名。 

·  一旦你选择了类别名，你可以在 “Class Name:” 文本区内更改它。 

·  要在 RGB 颜色空间（三种颜色各为 0-255 ）更改类别颜色，移动三个标签为 Red、 Green 
或 Blue 的滑动块。 

·  要重新设置为原来的类别颜色和名称，点击 “Reset”。 

·  要在 HSV 或 HLS 颜色空间更改类别颜色： 

A. 从 Class Color Map Editing 对话框内的 “System” 下拉菜单中选择适当的系统。 

B. 移动 “Hue，Saturation，Value” 或 “Hue，Lightness，Saturation” 滑动块到所需要的值。 

4. 要彻底地更改，点击 “OK”。 

注意 
在 24 位彩色显示器上，ENVI 将不能自动地运行这些颜色更改。对于 24 位硬件，对图像更改

颜色，是通过点击 “Apply Changes” 按钮来替代的。这个按钮只有当 24为彩色时才出现。 

z-图信息（Z Plot Information） 
若你需要编辑用于绘制 Z 剖面图、设置轴标题、设置 Z Plot 方框大小或指定一个另外的 Z 剖

面图文件名的参数，按照以下步骤： 

1. 从 Header Info 对话框，选择 Edit Attributes > Z Plot Information. 

2.  Edit Z Plot Information 对话框将打开，允许你来设置这些参数： 

·  要设置 Z plot Range，在 “Z Plot Range” 标签旁的左、右文本框中分别输入最小值和最大值。 

·  要设置轴标题，在 “X Axis Title” 和 “Axis Title” 文本框内输入所需要的轴标题。 

·  要指定方框的大小（按像元）来计算平均波谱，在 “Z Plot Average Box” 文本区内输入参数。 

·  要指定另一个文件名，以从中提取 Z 剖面图： 

A. 点击 “Default Additional Z Profiles”。 

B. 当出现 Default Additional Z Profiles 对话框，点击 “Add New File”。 

C. 选择所需要的文件名，然后点击 “OK”。文件名将出现在列表中。 

·  要从列表中删除一个文件名，先点击文件名，然后点击 “Remove Selected File”。 
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传感器类型（Sensor Type） 
要在 ENVI 文件头中存储传感器类型信息： 

1. 从 Header Info 对话框，选择 Edit Attributes > Sensor Type. 

2. 从列表中选择合适的类型。 

缺省拉伸（Default Stretch） 
要设置系统默认的拉伸，以便用于显示波段： 

1. 从 Header Info 对话框，选择 Edit Attributes > Default Stretch. 

2. 从 “Default Stretch” 文本框附近的下拉菜单，选择适当的拉伸类型。 

供你选择的包括 % linear（线性拉伸百分比），linear range（线性拉伸范围），gaussian（高斯分
布），equalize（均衡化），square root（平方根）或 none（不拉伸） 。一些拉伸要求你输入附加信
息。 

·  对于 “% linear” 拉伸，输入剪去（slip）数据的百分比（即 5%）。 

·  对于 “Linear Range” 拉伸，输入最小和最大 DN 值，用于拉伸。 

·  对于 “Gaussian” 拉伸，输入标准差数，用于拉伸。 

ENVI 将在 .hdr 文件中保存拉伸设置。无论你什么时候显示这幅图像，该拉伸设置将覆盖掉 
envi.cfg 文件中的系统整体默认拉伸。 

复数型Lookup功能（Complex Lookup Function） 
对于复数数据类型，你可以使用该选项决定显示哪幅图像。 

1. 在 Header Info 对话框中，选择 Edit Attributes > Complex Lookup Function. 

2. 当出现 Complex Data Lookup Function 对话框时，从下拉菜单中选择所需要的 lookup 功能。 

选项有：“Real”（数的实部），“Imaginary”（虚部），“Power”（幂，模的 log10），“Magnitude”（模，
实部和虚部平方和的平方根），以及 “Phase”（相位，虚部除以实部的反正切值）––––系统默认的图
像是 “Power”。 

行偏移量（Row Offsets） 
你可以使用该选项设置额外字节数，以便在行的起始和结尾跳读。 

1. 在 Header Info 对话框，选择 Edit Attributes > Row Offsets. 

2. 在 Edit Row Offsets 对话框，通过点击箭头按钮或在文本框中键入，以输入或选择要跳过的
前缀和后缀字节数。 

3. 点击 “OK”。 

波段偏移量（Band Offsets） 
你可以使用该选项设置额外字节数，以便在波段的起始和结尾跳读。 

1. 在 Header Info 对话框，选择 Edit Attributes > Band Offsets. 

2. 在 Edit Band Offsets 对话框，通过点击箭头按钮或在文本框中键入，以输入或选择每个波段
要跳过的前缀和后缀字节数。 



 54

3. 点击 “OK”。 

输入IDL变量（Import IDL Variables） 
该选项允许你输入任何在 ENVI 命令行中定义的 IDL 变量。一维变量将被放入一个图示窗口

中。二维和三维变量作为内存数据项将显示在 Available Band List 中。有关细节，请参阅 ENVI 
Programmer’s Guide 。 

·  要把 IDL 变量输入到 ENVI： 

1. 选择 File > Import IDL Variables. 

2. Import IDL Variables 对话框将显示一个所有被定义的变量列表。 

3. 通过在变量名旁的复选框内点击，选择所需要的变量名输入。 

·  要添加一系列变量名，输入起始和结尾变量号，然后点击 “Add Range” 按钮。 

·  要选择所有变量名，点击 “Select All” 按钮。 

·  要清除已选择的变量名，点击 “Clear” 按钮。 

4. 要在 IDL 中保存数据的一个备份，使用箭头切换按钮来选择 “Yes”。若选择了 “No”，那么
数据将被输入到 ENVI 并从 IDL 中删除。 

5. 点击 “OK” ，输入所需要的变量。 

一维变量将被放入一个图示窗口中。二维和三维变量作为内存数据项将显示在 Available Band 
List 中。 

输出为 IDL 变量（Export to an IDL Variable） 
用该功能（在 ENVI RT [run-time 版本]中无效），你可以将一个 ENVI 波段或文件（若需要，
可以用其子集）输出为预先定义的 IDL 变量。在运行该功能之前，你必须在 ENVI 命令行定义 IDL 
变量名。 

注意 
若在 IDL 窗口中看不到 ENVI 命令行，选择 Window > Command Input. 

1. 在 ENVI 命令行，定义 IDL 变量（例如，若你想定义一个名为 ”test” 的 IDL 变量，你应
当在命令行输入“test=0”）。 

最初不必限定该变量正确的数据类型和大小。当数据导出到 IDL 变量，ENVI 将指定它的值。 

2. 选择 File > Export to an IDL Variable. 

3. 当出现文件选择对话框时，选择所需要的波段或文件，并根据需要构造子集。 

4. 若你定义了一个以上变量，选择数据将要导出到的变量名。 

5. 点击 “OK”。 

在 ENVI 命令行导出的数据将可以使用。 
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执行启动批处理文件（Execute Startup Script） 
ENVI 的启动批处理文件允许你启动 ENVI 时打开图像文件、导入波段显示、打开矢量文件和

ROI 文件。当 ENVI 启动时，若在 envi.cfg 文件中设置了一个文件名，该批处理自动地执行。
可以使用该功能在任何时候执行。有关 ENVI 启动批处理文件的描述，请看第 792 页的 “ENVI 
Startup Script”。 

·  要执行一个 ENVI 启动批处理文件： 

1. 选择 File > Execute Startup Script. 

2. 选择需要启动的批处理文件名，然后点击 “OK”。 

将Session存为批处理文件（Save Session to Script） 
该选项允许你把当前打开的图像文件、图像显示和它们的波段保存到 ENVI 启动批处理文件。

要执行这个启动文件，请参阅第 141 页的 “Execute Startup Script”。 

要把当前 session 保存到一个启动批处理文件： 

1. 选择 File > Save Session to Script. 

2. 当出现 Output ENVI Script Filename 对话框时，输入需要的启动文件名（通常扩展名
为.ini）。 

关闭所有文件（Close All Files） 
·  当你在 ENVI 中已经完成对文件的操作，通过选择 File > Close All Files关闭它们。 

出现一个要求你确认的警告消息。 

注意 
ENVI 将关闭所有磁盘文件并删除所有内存中的数据项。在选择该按钮前，确认你保存了内存
中所有重要的数据项。 

文件选择（File Selection） 
在你把任何 ENVI 功能应用到一个特定数据集之前，你必须首先选择包含该数据的文件。要保

证一致性，几乎每个 ENVI 图像处理功能都使用一个标准的输入文件选择对话框（图 2-22）。该对
话框允许你选择一个输入文件或一个波段；它提供空间的和波谱的子集，并且在某种情况下提供输

入数据的掩膜。 

为了提醒你准备使用哪个功能，功能名显示在文件选择对话框的标题栏内，后面紧接着 “Input 
File”。例如，在 图 2-22 标题栏内写着 “File Subset Input File”，因为当前功能是文件构造子集。 

构造子集选项的详细描述，请浏览以下三节。 

·  要选择一个波段或文件来处理： 

图 2-22: 文件选择对话框时。 

1. 在 “Select By” 附加的箭头切换按钮上点击，获得打开文件的一个列表；或打开文件中所有
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波段的一个列表。 

2. 在标签为 “Select Input File” 或 “Select Input Band” 的栏中，点击所需要的文件或波段名。 

·  在所需要的文件或波段名上双击鼠标左键，来自动地启动该功能（没有子集被应用）。 

3. 点击 “OK” ，执行该功能。 

·  要打开一个新文件： 

1. 在 Input File 对话框中，点击 “Open Image File” 或 “Open Spectral Library”。 

2. 当出现文件选择对话框时，选择所需要的文件名。 

·  要使用上一次用过的输入文件，点击 “Previous”。 

·  若有必要，再次点击 “Previous” ，以使用与上次同样大小的文件的相同空间或波谱子集（参
见第 145 页的 “Standardized ENVI Spatial Subsetting” 或第 148 页的 “Standardized ENVI Spectral 
Subsetting”）。 

3. 点击 “OK” 或 “Open”。 

·  若你决定不导入任何文件，点击 “Cancel” ，退出文件选择对话框。 

若该功能不应当用于整个文件或波段，当前功能允许构造子集。请参照以下三节的 “Subsetting”。 

对ENVI影像取子区（Standardized ENVI Spatial Subsetting） 

在一些情况下，你可能不想将一个功能用于一幅完整的图像。若你选择这幅图像的一个空间子

集，该功能将只应用到这个空间子集。通过输入需要的始末地图或像元值，或在图像上拉一个方框

可以得到空间子集。构造子集的向导如下。关于通过波谱波段而不是通过空间区域构造子集的信息，

请见下节。 

·  从文件选择对话框时内，点击 “Spatial Subset” 按钮。 

Spatial Subset 对话框将被打开，但它的外观呈多样化，视当前数据是以样本 -线为基础
（sample-line-based ）或地理坐标定位的情况而定（图 2-23）。 

 

图 2-23: 一幅地理坐标定位图像的 Spatial Subset 对话框。 

你可以通过使用下列方法之一构造图像子集。 

·  要通过起始和结尾值来选择，为样本和/或行把起始和结尾值输入到适当的文本框中。 

原数据集的大小和当前选择的子集大小出现在文本框下面。 

·  要使用与上次输入的空间大小相同的文件的空间子集，点击 “Previous” 按钮。 

·  从图像交互地选择空间子集： 

1. 在 “Band” 文本框中输入需要的波段号（用于显示）。 

2. 点击 “Subset By Image” 来打开 Subset Function 对话框。 

Subset Function 对话框显示已选图像波段的一个二次抽样形式（图 2-24）。该图像上的一个
方框绘出了当前选择的子集轮廓。 
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图 2-24: Subset Function 窗口。 

·  改变这一方框的大小和位置，以改变被选择的子集。 

3. 在 Subset Function 对话框，点击并按住方框一角，然后用鼠标左键拖曳到需要的位置。 

Subset Function 对话框列出该方框所限定的样本数和行数，该列表可以被编辑。 

4. 要确认该方框限定的子集，并返回到原先的 Spatial Subset 对话框，点击 “OK”。 

起始、结尾样本和行的坐标显示在标签为 “Samples” 和 “Lines” 的文本框中。 

·  对于已经地理坐标定位的图像，你可以通过地图坐标或纬度/经度坐标来选择子集： 

1. 点击 “Subset By Map” 按钮，打开 Spatial Subset By Map Coordinates 对话框。 

2. 在适当的文本框中，输入左上角和右下角坐标。 

3. 使用地图投影标签旁的箭头切换按钮，通过地图坐标选择子集。 

对于 UTM 投影，你必须通过选择适当按钮，指出选择的纬度是在赤道以北（N） 还是以南（S）；
该区域将被自动计算。对于其它的地图投影，输入纬度和经度值。在南半球时，纬度为负值；在西

半球时，经度为负值。输入 UTM 区域，为经度做一个适当标记。 

 

图 2-25: Map Subset Function 窗口。 

4. 点击“OK” ，把已选择的子集输入到 Spatial Subset 对话框。 

5. 点击 “OK” ，返回到文件选择对话框。 

标准ENVI波谱子集（Standardized ENVI Spectral Subsetting） 

在一些情况下，你可能不想把一个功能应用到一幅图像的所有波段。请使用这些波谱构造子集

的说明，它允许你来限定一个功能所应用的波段范围。 

1. 从文件选择对话框内，点击 “Spectral Subset” 按钮。 

出现 File Spectral Subset 对话框。该对话框的外观有所变化，视图像是否有一个坏波段列表而
定。处理中不包含坏波段（图 2-26）。 

 

图 2-26: 选择了三个波段的 Spectral Subset 对话框。 

可以选择的一个波段列表显示在对话框的中央。 

2. 通过点击所需要的波段，来选择其中包括的波段。 

·  要选择与一个含有相同波谱波段数的不同文件的原来的子集相同的波谱子集，点击 
“Previous” 按钮。 

·  要选择所有波段，点击 “Select All Items”。 

·  要取消选择的所有波段，点击 “Clear”。 

·  要选择特定范围的波段： 
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A. 在 “Add Range” 旁的两个文本框中，键入起始和结尾波段号。 

B. 点击 “Add Range”。 

·  要选择一组连续列出的波段，在该组的第一项点击，然后按住的同时，点击该组的最后一
项，来选择之间的所有波段，或者点击并拖曳到最后一项。 

·  要选择一组非连续列出的波段，先点击一项，按住 “Ctrl” 键的同时，点击其它所有需要
的项。 

·  对于有一个 “Bad Bands” 列表的图像，点击 “Apply BBL” 按钮，来应用 Band Bands List 
（参见第 130 页的 “Edit Ancillary Header Information”）。ENVI 自动地取消选择各个标有 “Bad” 的
波段。 

这些波段将不显示在输出图像中。 

3. 当完成选择所需要的波段，点击 “OK” 来返回文件选择对话框。 

标准 ENVI 掩膜（Standardized ENVI Masking） 

当你选择一个要应用某种功能的文件，你可能想把一个空间掩膜应用到图像的某个部分。ENVI 
不能把当前功能应用到被掩饰的图像部分。要建立一个掩膜，请参阅第 335 页的 “Masking”。 

只有某些 ENVI 功能允许在处理前进行空间掩膜。这些功能包括统计、分类、分离（unmixing）、
匹配滤波、连续删除（continuum removal）和波谱特征拟合（spectral feature fitting）。 

·  从文件选择对话框内，点击 “Mask Band”，然后选择包含掩膜的波段。 

·  要删除掩膜，选择 Options > Clear Mask Band. 

第三章：ENVI 交互功能 
主窗口 Functions 菜单 
要启动 ENVI 的许多交互功能，你必须使用 Main Image Display 菜单。通用信息如下：: 

·  在主图像窗口点击鼠标右键，显示一个带有 Functions 和 Cancel 选项的菜单栏。 

·  要再次隐藏菜单栏，在主图像窗口点击鼠标右键。 

·  要关闭显示窗口，点击 “Cancel”。 

Functions 选项 （自此向后指 “Display Functions Menu”） 允许你执行常用的显示操作。可使
用的操作包括链接窗口；X、Y、Z（波谱）和任意的剖面；对比度拉伸；彩色制图，诸如 ROI 选
择、光标位置和值、2维散点图、表面绘图（perspectives and draping）和极化信号等交互功能；，包
括注记、基于像元的和地理坐标定位的网格线、图像等高线，以及矢量层等各种覆盖图；图像动画，

改变显示窗口特征；以及产生输出图像 （PostScript，Image [RGB]，BMP，GIF，HDF，JPEG，PICT， 
SRF，TIFF 或 XWD 格式）。这些选项在以下几节有详细的描述。 

 

图 3-1: 主图像的功能。 

Administrator
第三章：ENVI 交互功能
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链接显示与动态覆盖 
图像链接允许对多幅图像进行同时的、同样的操作。通常只在图象大小相同时或当一幅图像是

另一幅图像的子集时，图像可被链接。然而，ENVI 允许你不顾图像间的关系，指定链接的像元。
要使用链接功能，你必须至少打开两个图像窗口。 

Functions 菜单下的 Link 菜单选项显示一个带有两个选项的子菜单（Link Displays and Dynamic 
Overlay） ，它允许你执行有关链接图像的操作。当只有一幅图像被显示时，该菜单选项是无效的。
Link Displays 子菜单允许多个图像被动态地“链接”到一起。 

Dynamic Overlays 选项允许实时地覆盖和切换（“flickering”） 多个灰阶或彩色图像。当两个或
更多窗口第一次被链接，动态覆盖自动被激活。有关细节，请参阅第 154 页的 “Multiple Dynamic 
Overlays”。 

注意 
你也可以通过 ENVI 主菜单选择 Basic Tools > Display Controls > Link Displays 来链接图像。 

Dynamic Overlay 子菜单在启动和关闭之间切换覆盖功能，并且仅当两个或更多图像被链接时有
效。 

链接图象 

当图像已经被链接，在一幅图像中的操作将反映到所有其它被链接的图像上。移动缩放框、滚

动框，改变缩放系数，或调整任何图像窗口的大小时，在被链接的窗口发生同样的操作。要把图像

链接在一起，请见下列步骤： 

1. 从主图像窗口内，选择 Functions > Link > Link Displays. 

2. 当出现一个 Link Displays 对话框时，用箭头切换按钮为每个现有显示选择 “Yes” 或 “No”，
完成从可利用的显示列表中选择。 

3. 通过指定 “Xoff”（x 偏移量） 和 “Yoff”（y 偏移量）参数，为每幅图像指定链接的像元。
这个参数从每幅图像的左上角（1，1）开始按像元测量。 

4. 通过从 “Link Size/Position” 菜单选择适当的显示，以确定用于链接的基图像。 

5. 点击 “OK” ，执行链接。 

所有其它图像的大小和位置将与基图像一致。 

·  若你链接了图像，并希望添加一幅新图像，使用 Link Displays 对话框中的箭头切换按钮，
来为该显示选择 “Yes”。 

·  要从链接中删除一个显示窗口，在该图像窗口中选择 Functions > Link >Unlink Displays 。其
它窗口将保持链接。 

·  要从链接中删除所有图像，在主图像窗口中选择 Functions > Link > Unlink Displays 。 

多重动态覆盖 

Dynamic Overlays 选项允许实时地覆盖和切换（“flickering”）多个灰阶或彩色图像。当两个或
更多窗口首次被链接，动态覆盖自动激活。多重覆盖在所有被链接的图像窗口和各个缩放窗口内是
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同时活动的。使用该选项的方法如下。 

1. 在主图像窗口，选择 Functions > Link > Dynamic Overlay. 

注意 
若你没有三按钮的鼠标，你必须用某种方式模拟多个鼠标点击。有关如何模拟鼠标按键的信息，

请见第 36 页的 “Mouse Button Emulation”。 

2. 从下列选项中选择，并当动态覆盖图开启时参阅表 3-1 的鼠标按键功能总结，当两幅图像被
链接但动态覆盖被关闭时参阅表 3-2的鼠标按键功能总结。 

·  要使另一个被链接图像（覆盖图）的一小部分显示在第一幅图像（基图）中，在任何被链接
的图像内点击鼠标左键。 

·  要使多重覆盖循环，在基图像上相继显示每个被链接的图像，按住鼠标左键，并同时点击鼠
标中键。 

·  在一个指定图象内部，移动覆盖，并比较两幅图像，点击并按住鼠标左键，然后在图像内移
动光标（表 3-1）。 

·  要改变覆盖图的大小，按鼠标中键，并拖曳覆盖图的一角到需要的位置然后释放按键。 

·  调整大小后，使用鼠标左键重新放置覆盖图。 

·  要快速比较图像，重复点击并释放鼠标左键来激活 “flickering” 效应。 

·  对于多幅图像，同时使用上述的鼠标左、中按键，来循环覆盖图。 

·  选择 Link > Dynamic Overlay Off ，关闭 “flickering” 特征（见表 3-1）。 

·  当显示被链接时，若光标在主图象窗口的缩放框轮廓线内，点击并拖曳鼠标左键，以对缩放
窗口重新定位（见表 3-2）。 

 

图 3-2: 一个动态覆盖图的例子。 

 

鼠标按键 操作 

左 点击并拖曳覆盖图 （例外-缩放框的功能显示在下面的 表 3-2 ） 

中 调整覆盖图的大小 

右 切换主图像子菜单关闭/开启 

左 + 中 循环多幅覆盖图 

表 3-1: 当 Dynamic Overlays 选项开启时鼠标按键的功能。 

鼠标按键 操作 

左 在缩放窗口方框内，点击并拖曳使被选的缩放窗口重新定位。当释放

时，显示在缩放窗口内的图像部分被更新。 

中 把当前像元放置在缩放窗口的中央 

右 切换主图像子菜单关闭/开启 

表 3-2: 被链接图像的鼠标按键功能。 
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剖面和波谱图（Profiles and Spectral Plots） 
ENVI 允许抽取水平的（X）、垂直的（Y）、波谱的（对每个像元为 Z ）以及任意的剖面图。
剖面图显示在单独的图表窗口，并且 X、Y 和 Z 剖面图可以同时是激活的。鼠标用来移动一个十
字准线并交互地选择剖面图。剖面图是标准的 ENVI 图。有关控件和选项描述，请看第 164 页的 
“Interactive Plot Functions”。 

ENVI 的 “Z”剖面图性能提供完整的波谱分析。波谱可以从任何多波谱数据集中被提取。这些
数据集包括 MSS、TM，以及诸如 GEOSCAN（24 波段）、GERIS （63 波段）、AVIRIS （224 波
段） 等超波谱数据。 

注意 
当绘制的剖面图显示如此完整的数据范围时，开启图表窗口内 Options 菜单下的 Auto Scale 

Y-Axis是非常有用的。 

详细的向导见以下几节。 

X 和 Y（水平的和垂直的）剖面 

要从你的图像中提取 X 或 Y 剖面，按照下列步骤。 

X剖面自动地提取沿着水平光标线的像元，而 Y剖面自动提取沿着垂直光标线的像元。 

若显示一幅彩色合成图，X和 Y剖面由三幅图像用相应的颜色（RGB）绘制。若只有一个波段
被显示，那么该波段的剖面图示为白色。一条垂直线被用来标记十字准线在相应的 X或 Y剖面图中
的当前行或样本位置。 

1. 在主图像窗口内，选择 Functions > Profiles > X Profile 或 Y Profile. 

在主窗口和缩放窗口的当前像元处出现一个十字准线。 

2. 在另一个像元处点击鼠标左键，抽取一个新剖面。 

·  通过在主图像窗口按住鼠标中间按键，并拖曳缩放框到所需要的位置，来完成连续的实时的
浏览。 

 

图 3-3: X 和 Y 剖面图。 

当前像元位置被移动时，水平、垂直和波谱剖面图被连续地更新。 

3. 一旦X或Y剖面图被提取，在剖面图内按住鼠标左键，并移动光标，用图象中的十字准线
标记剖面图上的当前位置。 

缩放框十字准线同时在滚动、主和缩放窗口上跟踪剖面图中的位置，并且主图像和缩放图

像将被更新，以与沿剖面图移动的光标位置相匹配。 

图象波谱图（Z 剖面） 

ENVI 的 “Z” 剖面用于交互地绘制光标处像元的波谱图（所有波段）。波谱可以从多波谱数据
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集中提取，这些数据集包括 MSS、TM，以及诸如 GEOSCAN（24 波段）、GERIS（63 波段）、AVIRIS 
（224 波段）等高波谱 dimension数据。 

Z Profile 窗口内的 Plot bars 表明了当前显示窗口显示的是哪个波段或 RGB 波段。通过移动 
Plot bars 到新的波段位置，可以交互地改变显示在显示窗口内的波段。 

对于少于 50 个波谱波段的数据集，波谱的提取和绘图速度很快，可以使用 BSQ 数据文件。
对于成像波谱仪数据等高波谱 demension数据集，使用 BIL 或 BIP 文件可以实时地提取波谱 （参
见第 373 页的 “Convert Data （BSQ， BIL， BIP）” ）。 

注意 
对于超波谱数据集，建议使用 BIL 数据格式，因为用这种格式出现了与 BIP 数据用于波谱绘
图和浏览相似的反应，且这种格式显示图像比 BIP 格式更快。 

1. 在主图像窗口内，选择 Functions > Profiles > Z Profile （Spectrum）. 

2. 在主图像窗口内或缩放窗口内选择一个像元，以便在图示窗口内为相应波谱绘图。 

图上的一条垂直线（plot bar） 标出当前显示波段的波长位置。若一幅彩色合成图像被显示，那
么将出现三条彩色线，每一条用波段相应的颜色（RGB） 来显示波段。 

 

图 3-4: Z （波谱）剖面图。左，Landsat TM；右，AVIRIS 。 

·  改变当前显示在图像窗口内的波段： 

1. 通过用鼠标左键点击并拖曳 plot bar（s），以改变 plot bar（s） 到需要的波段。 

2. 在 Z Profile 图示窗口，双击鼠标左键，把新的波段导入显示窗口。 

·  要执行波谱浏览，使用鼠标中键在缩放框上点击，并横跨图像拖曳缩放框。 

·  要从光标四周的一个像元框，来绘制一个均值波谱： 

1. 选择 Options > Set Z Profile Avg window. 

2. 在 “Window Size” 文本框内，输入所需要的方框大小（按像元）。 

均值方框大小也可以在文件头中设置（参见第 127 页的 “Edit ENVI Header”）。 

·  要在 Spectral Profile 窗口内绘制多个相互叠加的 Z 剖面图（波谱），选择 Options > Collect 
Spectra. 

·  要清除所有波谱，并只绘制当前 Z 剖面图，选择 Options > Replace Spectrum. 

其他有关绘图选项的描述，请参阅第 164 页的 “Interactive Plot Functions”。 

附加的 Z 剖面 

一个显示窗口中光标处像元的 Z 剖面，可以从一个附加文件中提取，并绘制在一个新的图表窗
口中。一旦选择一个附加剖面图输入文件，当你在显示窗口内浏览波谱时，波谱将被绘制，就像该

数据的 Z 剖面一样。关于 Z 剖面图交互的细节，请参阅第 159 页的 “Image Spectral Plots（Z 
Profiles）”。 

1. 在主图像窗口内，选择 Functions > Profiles > Additional Z Profile. 



 63

2. 为附加的 Z 剖面图选择所需要的输入文件名。 

3. 在主图像窗口或缩放窗口内选择一个像元，以便在一个新的图表窗口绘制附加文件的波谱。 

注意 
一个附加的 Z 剖面图文件名可以在数据头文件中设置，以便每次启动 Z profile 功能时，该数
据的 Z 剖面图和附加的 Z 剖面图都被绘制。其中一个图表窗口将显示在另一个上面，因此一个窗
口需要被移开。 

任意剖面（横断面） 

你可以在主图像显示、滚动或缩放窗口上指定横断面。任意的剖面图是沿着该横断面来绘制的。

支持多个同时发生的任意剖面图。这些在显示时将被编号，并用彩色编码。 

1. 在主图像窗口内，选择 Functions > Profiles > Arbitrary Profile （Transect）. 

2. 当出现 #N Spatial Profiler 对话框时，点击所需要窗口附近的按钮，以便为提取剖面图选择
合适的窗口、滚动条或缩放标签。 

3. 在图像内点击鼠标左键，来启动被选择窗口内的横断面。 

4. 在剖面图的每个新顶点，再次点击鼠标左键。 

·  要结束启动，点击鼠标中间按键，在完成之前删除整个横断面。 

5. 点击鼠标右键，来选择最后一个顶点并完成该横断面。 

一个把手（彩色菱形） 将被放置在刚绘出的横断面上。 

·  要移动该横断面，用鼠标左键点击并拖曳这个把手。 

·  要删除该横断面，点击鼠标中键。 

6. 要在图表窗口内提取并显示该剖面，点击鼠标右键。 

若该横断面是从一个三波段彩色合成图像中提取的，那么三个剖面图将显示在图表窗口内。红

波段剖面图将是一条实线（solid line），绿波段剖面图将是一条点线（dotted line），蓝波段剖面图将
是一条点划线（dash-dot line）。 

7. 在剖面图内点击鼠标左键，然后移动光标，用图象中的十字交叉（cross-hair）光标标记剖面
图上的当前位置。 

缩放框同时在跟踪滚动、主和缩放窗口上剖面图中的位置，并且主图像和缩放图像将被更新，

以与沿剖面图移动的光标位置相匹配。 

·  要定义另一个任意的剖面图，在图像中点击鼠标左键，定义新的顶点。 

新的剖面图将用一种新的颜色绘制在一个新的绘制窗口中。 

·  你可以将图像上绘制的任意剖面线保存到一个注记文件中： 

1. 在 Spatial Profiler 对话框，选择 File > Save Annotation. 

2. 当出现文件选择对话框时，输入一个文件名。 

·  要激活一个测量工具： 

1. 在 Spatial Profiler 对话框，选择 Options > Measurement Report. 
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当剖面图完成时，出现 Profile Measurement Report 对话框，并带有一个顶点间距离和总距离的
列表。 

2. 从四个下拉菜单的选项中选择，将测量信息保存到一个文件，改变用于记录距离的单位，并
选择是否记录片断距离或点坐标。更多细节，请参阅第 210 页的 “ROI –Measurement Tool”。 

交互式绘图功能 
图表窗口通常提供几种交互分析能力，包括在窗口间移动图表、数据输入和输出、图表输出、

编辑、注记及其它选项（见 表 3-3 一览表）。 

X-Y Cursor 

·  要显示一个 X-Y line-cursor，在图内用鼠标左键点击并按住。 

当多个图表被显示时，line cursor 将快速找取最近的数据点。该点的 X 和 Y 值将列在图表的
右下角，使用与选择的数据集相对应的颜色。 

·  要连续地显示 line-cursor、数据标记、数据值，按住鼠标左键的同时移动光标。 

显示图表数据标签 

·  要切换数据标签的关闭和开启，在图表内点击鼠标右键。 

·  要编辑图表数据标签，见第 174 页的 “Edit Data Values”。 

·  要从图表窗口中删除一个图表，在该数据标签上点击鼠标右键。 

注意 
你不能删除活动光标所在的图表，例如，它们各自窗口内的 X 剖面、Y 剖面或 Z 剖面。 

将图表移动到另外一个图表窗口 

·  要将图表标签和与之相应的数据标签从一个图表窗口移到另一个图表窗口，在图表名上点击
并按住鼠标左键，并将它拖曳到另一个图表窗口，然后释放鼠标按键。 

操作 鼠标

按键 
交互 位置 

显示line-cursor，数据点位置和 
X、Y值 

左 点击并按

住，拖曳 
图表窗口内部的数据图表

上 

调整图表窗口 左 点击并拖

曳 
图表窗口的角上 

移动图表到新窗口 左 点击并拖

曳到新窗口 
图表标签上 

重新调整X、Y 图表范围 中 点击并拖

曳 
从图表框内的任何一点沿

斜线到包含所需子集的表格框 

重新设置到原先的X、Y 图表
范围 

中 点击 图表窗口内部 
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设置Y轴为数据范围 中 点击 图表框左侧 

切换图表名标签 右 点击 图表窗口内部 

删除特定数据图表 右 点击 图表标签上 

表 3-3: 鼠标和剖面图及波谱的交互。 

 

重新调整图表大小（放大） 

·  要在图表内重新调整 X、Y 图表范围： 

1.通过在方框的一角按住鼠标中间按键来定义 “Magnify” 区域，从而选择新的区域在图表窗口
内显示。 

2. 拖曳这个角来定义方框（见 图 3-5）。 

 

图 3-5: 显示放大框的水平剖面图。 

3. 释放鼠标按键来重新绘制放大的剖面图子集。 

·  要设置剖面图到原来各自的区域，在图表内点击鼠标中间按键，从而返回原先的缩放比例。 

·  要设置 Y 图表范围，来包括所有被绘制数据的完整范围，点击鼠标中键到图表框的左侧。 

绘图 - File 下拉菜单 

File 下拉菜单的功能有：输入数据到图表窗口，从图表窗口输出数据，及输出图表。 

·  选择 File > Cancel 来关闭图表窗口。 

输入数据 
显示窗口内的 File 下拉菜单中的 Input Data 选项，允许输入 ASCII 数据或 ENVI 波谱库。

ENVI 将读取被逗号或空格隔开的多列 ASCII 数据；文件顶部以文本或分号开头的行将被忽略。 

·  导入 ASCII 波谱或其它 X，Y 数据，在图表窗口中绘图： 

1. 在图表窗口内，选择 File > Input Data > ASCII. 

2. 当出现 ASCII Plot Filename 对话框时，选择一个文件名。 

3. 当出现 Input ASCII File 对话框时，从下列选项中选择（图 3-6）： 

·  要选择 X 值读入到图表窗口，在标签为 “X Axis Column” 的文本框中输入包含 X 值的列
数（通常为一列）。要选择 “Select Y Axis Columns” 标签下列出的所有列，点击 “Select All Items”。 

·  要取消选择所有选项，点击 “Clear All Items”。 

·  要选择一组连续列出的列，在所需要的第一列点击，按住 “Shift” 键的同时，点击所需要的
最后一列，来突出两者之间所有列。 

·  要选择多个非连续列出的 Y 列，按住键盘上的 “Ctrl” 键的同时，点击各个所需要的列。 

图 3-6: Input ASCII File 和 Input Spectral Library 对话框。 
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·  要把一个比例系数应用到每个 X 或 Y 值，在标签为 “X Mult” 和/或 “Y Mult” 的文本框中
输入需要的倍数。 

4. 点击 “OK”，把波谱（或其它 X，Y 图表）导入到图表窗口中。 

一旦导入，可以使用其它的所有图表选项。 

·  要导入 ENVI 波谱库进行绘图： 

1. 选择 File > Input Data > Spectral Library. 

当出现标准的 ENVI 输入选择对话框时，你可以选择一个当前打开的波谱库文件或打开一个新
文件。 

2. 要打开所需要的波谱库，选择该波谱库名再点击 “OK”。 

3. 当出现 Input Spectral Library 对话框时（图 3-6），通过在波谱名上点击来选择所需要的波谱。 

·  要选择所有波谱，点击 “Select All Items”。 

·  要取消选择的所有波谱，点击 “Clear All Items”。 

·  要选择一组连续列出的波谱，点击所需要的第一个波谱，按住 “Shift” 键的同时，点击所需
要的最后一个波谱，来突出两者之间所有波谱。 

·  要选择多个非连续列出的波谱，按住键盘上的 “Ctrl” 键的同时，点击各个所需要的波谱。 

4. 点击 “OK”，把波谱导入到图表窗口中。 

输出数据 
使用 File 下拉菜单的 Output Data 选项，可以进行 ASCII 输出和 Spectral Library 输出。 

·  要把显示在选择的图表窗口内的数据保存为 ASCII 文件： 

1. 选择 File > Output Data > ASCII. 

2. 当出现 Output Plots to ASCII File 对话框时，在标签为 “Select Plots to Output” 的文本框内，
点击所需要的图表名，以选择要保存的数据。 

·  要选择所有波谱，点击 “Select All Items”。 

·  要取消选择的所有波谱，点击 “Clear All Items”。 

·  要选择一组连续列出的波谱，点击所需要的第一个波谱，按住 “Shift” 键的同时，点击所需
要的最后一个波谱，来突出两者之间所有波谱。 

·  要选择多个非连续列出的波谱，按住键盘上的 “Ctrl” 键的同时，点击各个所需要的波谱。 

3. 在标签为 “Enter Output Filename” 的文本框中，键入输出名或使用 “Choose”按钮。 

4. 点击 “OK” ，把所选择的波谱保存到 ASCII 文件。 

·  要把显示在选择的图表窗口内的图表保存为一个 ENVI Spectral Library 文件： 

1. 选择 File > Output Data > Spectral Library. 

使用该选项可以从剖面图和波谱图建立一个标准的 ENVI 波谱库文件（波谱库图像）。 

2. 当出现 Output Plots to Spectral Library 对话框时，点击波谱名来选择所需要的波谱。 



 67

·  要选择所有波谱，点击 “Select All Items”。 

·  要取消选择的所有波谱，点击 “Clear All Items”。 

·  要选择一组连续列出的波谱，点击所需要的第一个波谱，按住 “Shift” 键的同时，点击所需
要的最后一个波谱，来突出两者之间所有波谱。 

·  要选择多个非连续列出的波谱，按住键盘上的 “Ctrl” 键的同时，点击各个所需要的波谱。 

3. 选择 “File” 或 “Memory” 输出。 

·  若选择输出到  “File”，在  “Enter Output Filename” 文本框中键入输出文件名，或使用 
“Choose” 按钮，选择一个文件名。 

4. 点击 “OK” ，把选择的波谱保存到波谱库。 

·  要把图表数据导出到 IDL 命令行： 

1. 在 IDL 窗口内，ENVI 命令行上，定义 IDL 变量 （例如，若你想定义一个名为 “test” 的 
IDL 变量，你应该在命令行上输入 “test=0”）。 

2. 按键盘上的回车键，导入变量名。 

注意 
若在 IDL 窗口看不到 ENVI 命令行，选择 Window > Command Input. 

最初不必限定该变量正确的数据类型和大小。当数据导出到 IDL 变量时，ENVI 将指定它的值。 

3. 从图表窗口选择 File > Output Data > IDL Variable. 

出现 Export Plots to IDL Variable 对话框。 

4. 在图表名上点击选择它们。 

·  要选择一组连续列出的文件，在该组的第一个文件上点击，然后按住的同时，点击该组的最
后一个文件。或者，用鼠标左键点击和拖曳来选择所需要的组。 

·  要选择非连续列出的多个文件，按住 “Ctrl” 键的同时，在每个所需要的文件上点击。 

5. 点击数据要导出到的那个变量名。 

6. 选择 “X Data” 或 “Y Data” 复选框，来指定是否只导出一种类型数据或两种都导出。 

7. 点击 “OK”。 

被导出的数据将可以在 ENVI 命令行使用。若来自一个以上图表的数据被导出到一个变量，该
数据将被导出到一个包含每个图表的 x 和 y 值的二维数组。第一行，数组[ ，0]，包含第一个图表
的 x 值；第二行，数组 [，1]，包含第一个图表的 y 值；第三行，数组[，2]，包含第二个图表的 x 
值，等等。 

输出图 
Output Plot 选项允许将图表和与之相应的注记输出到 PostScript、Image 和其它图像格式文件

输出选项。输出选项在第 310 页的 “Display Output Options” 有所叙述。 

绘图 - Edit 下拉菜单 

Edit 下拉菜单提供对数据和图表参数的控制，并提供数据编辑能力。数据参数控制线的类型、
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颜色，及图表数据的其它属性。图表参数控制轴、标题，及数据绘制范围。 

数据参数（Data Parameters） 
以下描述了有关改变数据参数的选项： 

1. 在图表窗口，选择 Edit > Data Parameters. 

2. 当出现 Data Parameters 对话框时，点击图表名进行编辑，并从下列选项中选择： 

·  要改变数据标签名，在 “Name” 文本框中输入新名，然后按回车键。 

·  要改变绘图线的颜色，从 “Colors” 菜单中选择。 

·  要选择线条的类型（例如，点线、虚线、实线），从 “Line Style” 菜单中选择。 

·  要设置线条的宽度，使用 “Thick” 参数框，调整宽度值，或输入一个新值。 

·  要设置点的数目使得用数据绘图时在 X 方向平均（平滑），在标签为 “Nsum” 的文本框内
输入数值，然后按回车键。 

·  要选择符号类型，从 “Symbol” 菜单中选择。 

 

图 3-7:  Data Parameters 和 Plot Parameters 对话框。 

·  要控制被显示符号的大小，使用 “SymSize” 参数框。 

·  要显示沿着选择的符号的线条或只显示符号，使用箭头切换按钮 “Symbol & Line” 或 
“Symbol Only”。 

绘图参数 
以下描述了有关改变绘图参数的选项： 

1. 选择 Edit > Plot Parameters. 

2. 当出现 Plot Parameters 对话框时（图 3-7），从下列选项中选择，以控制图表轴和图表布局
的特征。 

3. 通过点击对话框右下角 “Auto Apply” 按钮旁的 “Yes” 或 “No”，按你的喜好设置是否立即
应用参数改变，还是仅当选择 “Apply” 按钮时才用。 

若选择 “Yes”，那么数据一旦输入，每次更改都将应用。若选择 “No”，你必须手工点击 “Apply” 
按钮应用参数的更改。 

4. 从下列选项中选择。 

·  要改变图表标题，在 “Plot Title” 文本框中编辑。 

·  要改变前景和背景颜色，从标签为 “Foregrd” 和 “Backgrd” 的菜单中选择一种颜色。 

·  要允许掩饰特定范围以外的 Y 值（对于掩饰坏数据点很有用），在对话框底部的 “Min Val” 
和 “Max Val” 文本框中输入数值。 

小于最小值和大于最大值的数不参与绘图。参数单独地控制每个轴，包括轴的宽度和标题、数

据范围，以及标记的分布和形状。 

5. 切换 “X-Axis” 和 “Y-Axis” 切换按钮，来选择起作用的轴。 
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6. 在 “Axis Title” 文本框内输入标题，并按回车键。 

7.从以下步骤中选择，以改变轴的参数： 

·  要改变宽度，在 “Thick” 文本框中输入一个新值（ “1” 是标准宽度） 。 

·  要把整个数据范围的最小值和最大值恰好放置在轴的端点，点击 Style “Exact” 复选框。 

·  要从轴的端点细微地偏移数值，点击 Style “Extend” 复选框。 

·  要关闭所有被选择的轴，点击 Style “Off ”复选框。 

·  要视选择哪个轴，决定关闭顶部的 X 轴或右边的 Y 轴，点击 Style “No Box” 复选框。 

·  要改变轴显示的数据范围，在标签为 “Range” 和 “To” 的文本框中分别输入最小值和最大值
（对于波谱图，Y 轴的图表范围也可以通过输入 “Z Plot Range” 参数值，设置在 .hdr 文件中。
参见第 797 页的 “ENVI Header Format”）。 

·  要在轴的内部或外部绘制刻度线，点击 Tick Style “In” 或 “Out”。 

·  要在每个主刻度线位置绘制一条连续的线段以横越整个图表，点击 Tick Style “Grid”。 

·  要关闭所有刻度线，点击 Tick Style “Off ”。 

·  当主刻度线出现时，要改变其长度，在标签为 “Len” 的参数框输入 0 到 0.5 之间的一个值，
并在 “Minor” 文本框中输入次刻度线的数目。 

该长度用标准化为 1.0 的轴长度的一个比率来衡量。例如，0.02 的长度值导致刻度线的长度为
整个轴长度的 2% 。0.5 的长度值导致线段横越图表的 50%，并在图表中间会合（等价于 grid 选
项）。 

·  要控制图表轴四周页边空白的大小，在 “Margin” 标签旁的两个参数框内输入页边空白大小
（按字符计算）。 

对于 X 轴，第一个框是左边空白，第二个框是右边空白。对于 Y 轴，第一个框是底部空白，
第二个框是顶部空白。 

·  选择 “Tick Marks” 标签附近的 “Auto” 或 “Fixed”。 

“Auto” 选项把预先定义的主、次刻度线放置在轴上。主刻度线被标注。“Fixed” 选项允许你输
入轴的参数。它包括主刻度线的起点和终点，主刻度间的刻度增量，以及主刻度间的次刻度数。 

8. 当所有参数被设置为所需要的值，点击 “Apply” 和 “Cancel” ，关闭所有图表窗口。 

编辑数据值 
Edit 菜单下的 Data Values 图表选项允许编辑图表 Y 数据值。 

1. 在图表窗口，选择 Edit > Data Values. 

2. 当 Select Which Plot to Edit 对话框出现（带有一个所有数据图表名的列表）时，选择所需要
的数据进行编辑。 

3. 当 Edit Plot 对话框出现（包含一个类似 “Xloc （x-value）:yvalue” 的所有 x 和 y 值的列
表）时，点击 y-value 进行编辑。 

它将显示在 “Edit Selected Item:” 文本框内。 

4. 改变 y-value 到所需要的值，然后按回车键来在列表中改变该值。 
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·  点击 “Reset” 来重新设置所有的数据点回到最初值。 

5. 点击 “OK” ，用新值更新图表。 

绘图 - Options 下拉菜单 

Options 菜单允许你创建新的图表窗口，在图表上放置注记，为连续删除（continuum removed）
的数据绘图，叠加数据图表，自动缩放 Y-轴，清除所有图表窗口，以及重新设置图表数据范围。 

新的绘图窗口 
·  要创建一个新的、空白窗口，选择 Options > New Window: Blank. 

·  要创建一个包括数据在内的当前图表窗口的备份，选择 Options > New Window: with Plots. 

·  要在窗口间转换图表： 

1. 通过在图表内点击鼠标右键，开启图表标签。 

2. 使用鼠标左键点住一个图表标签，并把标签名（图表也一样）从一个窗口拖曳到另一个窗口
（参见第 164 页的 “Interactive Plot Functions”）。 

新的图表窗口可以作为数据 “collectors” 被建立，以便从剖面图和其它图表窗口保留有用的图
表。 

注记图表 
Annotate Plot 选项允许注记 X、Y 和 Z 剖面图及其它图表。该注记功能与图像的注记功能相
似，但没有图像特有的注记对象，在别处有详细描述（第 250 页的 “Annotation”）。 

注意 
注意，在注记前，图表和图像窗口应当被重新调整到它们最终所需要的大小。若图表窗口是在

启动注记后被调整大小的，那么被注记的对象将与它们的正确位置有偏差。 

Stack Data 
·  要在窗口内 offset 所有图表，以便没有重叠的数据图表，选择 Options > Stack Data. 

·  要设置每个图表间的 offset 量： 

1. 选择 Options > Set Stack Offset. 

2. 按数据范围的百分比，在 “Plot Stack Offset” 文本框中输入所需要的值。 

·  不用 stacking 重新用数据绘图，选择 Options > Unstack Data. 

自动缩放Y-轴（Auto Scale Y-Axis） 
·  当添加或更新图表时，要自动地缩放 Y 轴，以适应数据的最小值和最大值，选择 Auto Scale 

Y-Axis On. 

·  要保留当前 Y 轴范围设置，选择 Options > Auto Scale Y-Axis Off. 

若自动缩放被关闭并且一个图表被添加在 y 轴范围设置之外，那么该图表将是不可见的，直到 
y 轴被重新调整比例为止。 

Clear Plot 
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用 ENVI 波谱库功能或用 New Window 选项创建的图表窗口，包含一个在该窗口内清除所
有被显示图表的选项。注意当剖面图包含当前像元的剖面时，它们不能被清除。 

重设图表范围 
·  要将 x 和 y 图表轴重新设置为系统默认的数据范围或最小和最大值，选择 Options > Reset 

Plot Range. 

即使已经用 Plot Parameters 选项设置，或使用鼠标中键缩放到图表的一部分，该选项仍然将范
围设置到它的最初值。 

·  图表范围也可以通过点击鼠标中键到 y-轴的左侧进行设置。 

设置 Z 剖面 Avg 窗口 
Z 剖面窗口有一个 Set Z Profile Avg Window 选项。要用光标周围的一个框绘制一幅计算出的均
值波谱： 

1. 选择 Options > Set Z Profile Avg Window. 

2. 在 “Window Size” 文本框中，输入所需要的方框大小（按像元）。 

均值框的大小也可以在 ENVI 文件头中设置（参见第 127页的 “Edit ENVI Header”）。 

Z 剖面 搜集/替代波谱 
·  要绘制多个 Z 剖面波谱图，选择 Options > Collect Spectra. 

·  要用新的剖面波谱代替当前的 Z 剖面图，选择 Options > Replace Spectrum. 

绘图 - Plot_Function 下拉菜单 

·  要在波长（or other unit）和波段号之间切换图表的 x 轴，选择 Plot_Function > X Axis:Band 
Number. 

·  要关闭 x 轴的切换功能，选择 Plot_Function > X Axis:Normal. 

·  用 continuum removed 重新为显示在窗口中的数据绘图， 选择 Plot_Function > Continuum 
Removed. 

continuum 是拟合在数据之上的凸面外壳，被分割成原始数据值，产生 continuum removed values 
（有关细节请见第 696 页的 “Continuum Removal”）。 

continuum 是通过使用显示在图表中的第一个和最后一个数据点计算的，因此对于被缩放过的
图表，continuum只以显示的数据范围为基础进行计算。 

·  要用二进制编码图来重新绘制显示在图表窗口中的数据（0s 和 1s），选择 Plot_Function > 
Binary Encoding. 

二进制编码把 0 和 1 作为一个波谱，重新为数据绘图。它计算数据的平均值并为每个值编码，
当值小于或等于平均值时为  0 ，当大于平均值时为  1 （有关细节请见第  558 页的  “Binary 
Encoding”）。 

·  要重新为原始数据值绘图，选择 Plot_Function > Normal. 

·  你可以通过把功能名输入到 ENVI 的 menu 子目录下的 useradd.txt 文件中，以实现将自己
的图表功能添加到该菜单中（参见 ENVI Programmer’s Guide 第 103 页的 “Plot Function”）。 



 72

彩色制图（Color Mapping） 
Color Mapping 菜单工具可以把颜色表应用于图像、创建交互式的密度分割图像、控制 RGB 图
像位面（planes），以及改变分类彩色制图。 

一旦通过使用下述的一个选项显示一幅彩色图像，就可以从  Functions 菜单选择  Output 
Display，将结果保存为一幅 RGB 彩色图像。 

ENVI 彩色表和密度分割 

ENVI Color Tables 选项允许对灰阶图像进行线性对比度拉伸和应用标准颜色表（密度分割）。你
可以使用 System > Edit Color Tables 功能创建你自己的彩色表（参见第 763 页的 “Edit Graphic 
Colors”）。 

1. 在主图像窗口中，选择 Functions > Color Mapping > ENVI Color Tables. 

出现 ENVI Color Tables 对话框，你可以使用系统默认的 IDL 颜色表来调整屏幕的颜色表（见 
图 3-8）。该对话框包括一个灰阶 wedge （或彩色 wedge，若使用颜色表） 和两个滑动块来控制对
比度拉伸。它也有两个下拉菜单：File 和 Options。 

2. 选择下列选项之一： 

·  要将颜色表的任何变化自动地应用到你的图像中，选择 Options > Auto Apply: On. 

·  要手动地将变化应用于图像： 

A. 选择 Options > Auto Apply: Off. 

B. 变化后，选择 Options > Apply. 

注意 
Auto Apply 选项自动地设置为 8 位颜色模式。 

3. 分别移动标签为 “Stretch Bottom” 和 “Stretch Top” 的 滑动块，来控制被显示的最小值和最
大值。 

向右移动 Stretch Bottom 滑动块，导致图像亮区域变暗；而向左移动 Stretch Top 滑动块，导致
图像暗区域变亮。 

把拉伸底部设置为最大值，拉伸顶部设置为最小值，拉伸可以被 “ inverted”。 

若 Auto Apply 是打开的，新的对比度拉伸将立即应用于图像。 

4. 通过在所需要的颜色表名上点击，把一个选定的颜色表应用到当前图像。 

IDL 提供许多预先保存好的颜色表。“B-W linear” 表提供一个灰阶图像。“RAINBOW” 颜色表
提供一个从“冷”到“热”的密度分割。其它颜色表选项允许你应用它们首选的颜色方案。 

·  要把颜色表保存为一个 ASCII 文件： 

A. 选择 File >Save Color Table to ASCII. 

B. 输入一个文件名，然后点击 “OK”。 

·  要重新设置为初始的颜色表和拉伸，选择 Options > Reset Color Table 
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·  要返回到主屏幕并保留被选择的颜色表，选择 File > Cancel. 

 

图 3-8: ENVI Color 表 s 和 Interactive Density Slicing 对话框。 

交互式密度分割 

交互式密度分割功能允许你选择数据范围和颜色以便突出灰阶图像中的区域。 

1. 在主图像窗口，选择 Functions > Color Mapping > Density Slice. 

将出现 #n Density Slice 对话框（其中 “#n” 是用于启动功能的显示号）（见 图 3-8），在 
“Defined Density Slice Ranges” 下列有八个系统默认范围。这些范围由滚动窗口计算的最小值和最大
值来限定，并显示在 “Min” 和 “Max” 文本框中。 

2. 在适当的文本框中输入所需要的最小和最大值，来改变密度分割的范围。 

·  要重新设置数据范围到初始值，点击 “Reset”。 

3. 通过选择对话框时底部 “Windows” 旁所需要的复选框，来选择是否将密度分割颜色应用到
图像窗口、滚动窗口或这两个窗口。 

4. 点击 “Apply” ，将系统默认的范围和颜色应用于图像上。 

·  要编辑数据范围： 

A. 选择一个数据范围，并点击 “Edit Range” 来改变范围值或颜色。 

B. 当出现 Edit Density Slice Range 对话框时，输入所需要的最小和最大值，并从 “Color” 菜单
中选择一种颜色。 

C. 点击 “OK” ，执行改变 “Defined Density Slice Ranges” 列表中的范围。 

D. 点击 “Apply” ，把新的范围和颜色应用到图像上。 

·  要从列表中删除一个范围，选择数据范围，然后点击 “Delete Range”。 

·  要清除密度分割范围列表，点击 “Clear Ranges”。 

File 下拉菜单 
File 下拉菜单中的选项可以保存所定义的密度分割范围，以及恢复原先保存的范围。 

·  要把当前密度分割范围和颜色保存到一个文件： 

1. 在 Density Slice 对话框，选择 File > Save Ranges. 

2. 为了保持一致，键入一个系统默认的扩展名为 .dsr 的输出文件名。 

·  要恢复以前保存的密度分割范围和颜色： 

1. 选择 File > Restore Ranges. 

2. 选择所需要的输入文件。 

·  要关闭密度分割对话框，并重新设置为初始颜色表，选择 File > Cancel. 
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Options 下拉菜单 
Options 菜单选项可以添加新范围，设置默认范围，以及设置系统要用到的默认范围数。 

·  要添加范围： 

1. 在 Density Slice 对话框内，选择 Options > Add New Ranges. 

2. 当出现 Add Density Slice Ranges 对话框时，在适当文本框内输入范围的起始值、末尾值，
及所需要的范围数。 

3. 从 “Colors” 菜单中选择起始颜色。 

多个范围的颜色将遵循图形颜色列表。 

4. 点击 “OK” ，返回到 Density Slice 对话框。 

已经判定的范围将列在对话框中，若需要可以进行编辑。 

5. 点击 “Apply” ，把密度分割颜色应用于图像。 

·  要输入所需要使用的系统默认范围数，选择 Options > Set Number of Default Ranges，然后
输入所需要的值。 

·  要重新设置 “Defined Density Slice Ranges” 列表为系统默认的范围和颜色，这些由 “Min” 
和 “Max” 值以及设置的系统默认范围数来决定： 

1. 选择 Options > Apply Default Ranges. 

2. 点击 “Apply” ，把这些范围和颜色应用于显示。 

控制 RGB 图象通道（Control RGB Image Planes） 

该工具用于控制一幅 RGB 或灰阶图像的单个颜色通道。一个标准的 RGB 图像使用显示装置
的红、绿和蓝色电子枪形成一种彩色合成显示。灰阶图像是一种特殊情况，这时三个电子枪被指定

为每个像元具有相同值。 

1. 选择 Functions > Color Mapping > Control RGB Image Planes. 

将出现 #n RGB Channels 对话框，其中 n 为用于启动功能的显示号。首次启动时，三个图像
颜色通道全是开启的。 

2. 选择一个或多个左边的箭头切换按钮，关闭/开启每个颜色位面。按钮名将改变，以反映颜色
位面设置（“On” 或 “Off ”）。 

·  要颠倒当前的拉伸（一个 low-to-high 拉伸变为一个 high-to-low 拉伸，反之亦然），选择一
个或多个右边的切换按钮。按钮名将改变，以反映图像位面设置（“Normal” 或 “Inverse”）。 

·  要把 RGB Channel 功能同时应用到所有颜色位面，选择 Options > Turn All Channels Off/On 
或 Invert All Channels. 

3. 选择 File > Cancel ，退出该功能。 

注意：退出前，颜色位面将保留设置。 

注意 
对于 24 位彩色显示器，颜色变化不能自动地应用。当一个 24 位彩色显示器用于显示颜色变
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化，选择 Options > Apply 。 

 

图 3-9: The RGB Channels 对话框。 

分类彩色制图（Class Color Mapping） 

在该对话框中，每个类别的分类图像颜色和类别名可以被更改，并且可以将更改保存到头文件

中。 

注意 
类别颜色的变化必须被保存，以便它们可以正确的显示在输出设备上。 

1. 在主图像窗口内，选择 Functions > Color Mapping > Class Color Mapping. 

2. 当出现 Class Color Mapping 对话框，从标签为 “Selected Classes” 的列表中选择要改变的区
域名。 

3. 一旦选定，在 “Class Name” 文本小部件中改变名称。 

4. 移动 RGB 颜色空间（三种颜色都为 0-255 ）中的三个标签为 Red、Green 和 Blue（三种
颜色都为 0-255 ）的滑动条（显示在 图 3-19 中），以改变类别颜色。 

·  你也可以通过从 System 下列菜单选择适当的系统，然后用 Hue、Saturation、Value 或 Hue、
Lightness、Saturation 滑动条调整，在 HSV 或 HLS 颜色空间中改变类别颜色（有关颜色空间的信
息，请参阅第 491 页的 “Color Transforms”）。 

5. 选择 File > Save Changes ，把更改的分类名和颜色保存到被分类图像的头文件中。 

·  要重新设置为初始的类别颜色和名称，选择 Options > Reset Color Mapping. 

注意 
在 24 位彩色显示器上的颜色变化，将不被自动地应用。要应用，选择 Options > Apply. 

 

图 3-10: Class Color Mapping 对话框。 

显示增强（Display Enhancements） 
Display Enhancements 菜单选项包括执行快速对比度拉伸、使用直方图执行交互式对比度拉伸，
以及应用快速滤波增强。该菜单下的所有选项只增强被显示的数据，并不应用到数据文件。 

Contrast Stretching 允许你调整一幅选定图像的颜色或灰阶范围。当一幅图像初次显示时，它由
系统默认的三种拉伸方式中的一种来决定。若以前保存过一个查找表，ENVI 查找表（LUT） 将自
动地应用于该数据（见第 190 页的 “Saving and Restoring LUTs”）。若当前显示的波段不存在 LUT，
那么将使用 .hdr 文件中定义的系统默认拉伸（见第 797 页的 “ENVI Header Format”）。若在 .hdr 
文件中没有定义系统默认的拉伸，那么将应用 envi.cfg 文件中定义的系统默认拉伸（见第 786 页
的 “Configuration File Details”）。ENVI 提供系统默认的快速拉伸和交互式拉伸。 
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默认（快速）拉伸选项（Default （Quick） Stretching Options） 

几种系统默认的拉伸选项被提供使用来自主图像窗口的数据，或者来自二次抽样的滚动窗口数

据，或来自从缩放窗口的数据。 

·  选择 Functions > Display Enhancements > Default（quick）Stretches，> Quick Linear，Quick 2%，
Quick Gaussian，Quick Equalization，或 Quick Square Root. 

这些选项中的任何一个使用系统默认的参数，提供基于主图像窗口数据 “[Image]”、二次抽样的
滚动窗口数据 “[Scroll]” 或缩放窗口 “[Zoom]” 数据的 “Quick” 拉伸，而不用用户交互。 

Quick Linear 拉伸使用数据的最小和最大值执行线性对比度拉伸（不裁剪）。这对于只有少数数
据值的图像特别有用，这时裁剪可以饱和所有的值。Quick 2% 选项提供线性拉伸时，在显示数据的
两端进行了 2% 裁剪。Quick Gaussian 使用 DN 127 的均值 和三个标准差，应用 Gaussian 拉伸。
Quick Equalization 拉伸应用被显示数据的直方图均衡化拉伸。Quick Square Root 拉伸取输入的直方
图的平方根，然后再应用线性拉伸。详细信息，请见以下小节。 

交互式拉伸（Interactive Stretching） 

从 Display Enhancements 子菜单选择 Interactive Stretching，出现一个新的对话框，它包含
输入和输出的直方图。若显示一幅 RGB 彩色图像，则出现三个直方图窗口，一个直方图对应
于一个波段。 

General 

1. 在主图像窗口，选择 Functions > Display Enhancements > Interactive stretching. 

首次被打开，显示的输入和输出直方图表明了当前的输入数据以及分别应用的拉伸。在对话框

顶部垂直的红线（最小值）和绿线（最大值）附近的值，表明了当前拉伸用到的最小和最大值。 

2. 选择下列选项之一： 

·  要把任何拉伸或直方图变化自动地应用于你的图像，选择 Options > Auto Apply: On. 

·  把任何变化应用于你的图像，只有点击 “Apply” 按钮，选择 Options > Auto Apply: Off. 

3. 从以下选项中选择，来把拉伸应用于你的图像。 

·  要调整对话框大小，用鼠标左键点击任何一角，然后拖曳到所需要的大小和/或形状。 

 

图 3-11: 交互式的对比度拉伸对话框。 

·  要更改最小和最大拉伸值，在红线和绿线上点击鼠标左键，然后拖曳到一个新位置。 

当选择任意一条线时，当前的 DN、像元数、该单位 DN 的像元百分比以及累积百分比，显示
在输入的直方图上。 

·  在对话框中央的红线（最小值）和绿线（最大值）附近的文本框中输入数值。 

当指定最小和最大值时，输入所需要的实际值（例如，最小值 37，最大值 68 ） 或数据的百
分比（例如，最小值 “2%”，最大值 “98%”）。 
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输入直方图中的 min/max 线移动，以与输入的值相匹配。输出直方图自动更新，以反映输入直
方图中的变化，并应用新的拉伸来显示数据的分布。 

·  要查看被拉伸数据当前的 DN、像元数、该单位 DN 的像元百分比及累积百分比，在直方图
内按住鼠标左键并拖曳随之产生的白色 cross-hair 光标。 

·  要改变直方图的垂直比例，在要缩放的图表内所需要的最大 Y 值处，点击鼠标中键。 

·  要重新设置垂直比例为原来的 Y 值，在要重新设置的图表的 X 轴下，点击鼠标中键。 

·  要控制显示的输入直方图的数据范围，在 “Min” 和 “Max” 文本框中输入数值。这些值被设
置为数据直方图源的最小和最大值，并随数据源变化而更新。 

可以选择实际数据范围之内或之外的值。输入直方图的最小和最大值将发生变化，且随后按直

方图百分比进行的分割将用新的最小和最大数据值考虑直方图（and any subsequent clipping using 
histogram percentages will consider the histogram using the new minimum and maximum data values）。 

·  要恢复原来的数据范围，在对话框内选择 Options > Reset Histogram. 

·  当选择 Options > Auto Reset Histogram On 或 Auto Reset Histogram Off装入新数据时，按照
你的意愿设置是否保留你输入的范围。 

4. 点击 “Apply” ，把当前的拉伸应用于显示窗口。 

·  要把任何直方图拖曳到一个新的图表窗口中，并应用输出和注记等图表功能（参见第 164 页
的 “Interactive Plot Functions”）： 

1. 从 ENVI 的主菜单，选择 Basic Tools > Display Controls > Start New Plot Window （参见第 
323 页 “Display Controls”）。 

2. 用鼠标左键点住图表顶部的 “Input Histogram” 或 “Output Histogram” 文本标签，并将名字
拖曳到新的图表窗口。 

File 下拉菜单 

File 下拉菜单允许输出直方图窗口、把已拉伸的数据导出到一个文件，以及保存和恢复拉伸查
找表（LUT）。 

·  要退出交互式的拉伸功能，选择 File > Cancel。 

输出（Output） 
·  要通过使用标准的 ENVI 输出选项，输出正在显示的输入和输出直方图（Image， PostScript，

BMP，GIF，HDF，JPEG，PICT，SRF，TIFF 和 XWD 格式），选择 File > Output. 

交互与输出图表相似，但是允许没有注记（有关细节，请见第 310 页的 “Display Output 
Options”）。 

导出（Export） 
除了将数据拉伸到指定范围外，Export 拉伸选项可进行从一种 ENVI 支持的数据类型到另一种
类型的可能的数据转换（例如，字节型到浮点型，整数型到字节型等）。 

要把当前显示的应用拉伸了的数据保存为一个输出文件： 

1. 选择 File > Export Stretch. 
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2. 当出现 Output Stretch Parameters 对话框时，选择一个空间子集（若有必要）。 

3. 从 “Output Data Type” 按钮菜单，选择所需要的输出数据类型。 

4. 在适当的文本框中键入输出数据范围（最小和最大值）。 

5. 点击 “File” 或 “Memory” ，选择输出到文件或内存。 

·  若选择输出到 “File”，键入一个输出文件名或使用 “Choose” 按钮。 

6. 点击 “OK”，启动拉伸。 

一个状态框将显示处理进程。 

存储和恢复 LUTs（Saving and Restoring LUTs） 
Stretch Look-up-Tables （LUTs） 可以保存为 ASCII 格式文件或 ENVI 格式文件。 

·  要保存 LUT，选择 File > Save Stretch to LUT > ASCII LUT 或 ENVI Default LUT. 

选择 ASCII LUT ，把颜色查找表作为一列 ASCII 数据保存到一个文件。在该文件的顶部有 
“Binsize” 和 “Data Min” 参数。数据列中的第一个值对应于输入数据最小值的 LUT 值。第二个值
是输入数据最小值的 LUT 值加 binsize，列中其余值按相同方式保存，直到输入数据的最大值为止。 

选择 ENVI Default LUT，把 LUT 保存为一个 ENVI 二进制格式文件。该文件用输入文件名和
一个 .lut 的扩展名自动地命名，并与输入文件保存在同一目录下（或在文件头目录下）。当数据波
段显示在 ENVI 中，该 LUT 将作为系统默认的拉伸自动地被应用。 

·  要恢复原先保存的 LUT，选择 File > Restore LUT Stretch. 

·  若不存在显示波段的系统默认的 .lut 文件，当标准的 ENVI 输入文件选择对话框时出现
时，选择一个 ENVI 二进制 LUT 文件或一个包含一列查找表数据的 ASCII LUT 文件。 

若在该文件中没有包含 “Binsize” 或 “Data Min” 参数，那么假设 binsize 等于 1 ， 数据最小
值为 0 。 

Stretch_Type 下拉菜单 

Interactive Contrast Stretching 对话框内的 Stretch_Type 菜单包含一个所有可以选择的交互式拉
伸类型的列表。每个菜单选项描述如下。 

线性对比度拉伸（Linear Contrast Stretch） 
线性对比度拉伸是系统默认的交互式拉伸。线性拉伸的最小和最大值分别设置为 0 和 255，两

者之间的所有其它值设置为中间的线性输出值。 

1. 从 Interactive Contrast Stretching 对话框内，选择 Stretch_Type > Linear Contrast Stretch. 

2. 要限定最小和最大输入值。使用鼠标左键，移动输入直方图上的红色（最小值）和绿色（最
大值）垂直线到所需要的位置，或在红色和绿色垂直线旁的文本框内输入所需要的 DN 值或一个数
据百分比（例如，最小值为 5%，最大值为 95% ），来输入最小和最大输入值。 

关于和直方图窗口交互的更全面信息，请见上述描述（参见第 187 页的 “General”）。 

3. 点击 “Apply” ，把拉伸应用于显示的数据。 

·  要重新显示原来的拉伸，选择 Options > Reset Stretch. 
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被选择的拉伸也可以永久地应用于显示的图像上，如第 190 页的 “Export”所述。 

分段线性对比度拉伸（Piecewise Linear Contrast Stretch） 
分段线性对比度拉伸可以通过使用鼠标在输入直方图中放置几个点进行交互地限定。当在点之

间提供线性拉伸时，线段在点处连接起来。 

1. 选择 Stretch_Type > Piecewise Linear. 

一个变换函数将被绘制在输入直方图上。 

2. 在转换函数的任何位置点击鼠标中键，绘制一个记号，用来标记被选择点 X、Y 坐标。 

绘制的线段将端点和绘制的记号连接起来。 

·  要移动一个点的位置，在记号上点击鼠标左键，然后把它拖曳到一个新位置。 

·  要删除点，用鼠标右键在记号上点击。 

·  要手动地键入输入和输出值，选择 Options > Edit Piecewise Linear. 

作为结果的直方图将在输出显示器上被绘制。输出的直方图表明应用新的拉伸后数据的分布。 

3. 点击 “Apply” ，将拉伸应用于显示的数据。 

关于和直方图窗口交互的更全面的信息，请见上述描述（参见第 187 页的 “General”）。 

高斯对比度拉伸（Gaussian Contrast Stretch） 
系统默认的 Gaussian 拉伸是围绕 DN平均值 127的三个标准差的数据分布（centered at a mean 

DN of 127 with the data distributed over a range of 3 standard deviations）。. 

1. 选择 Stretch_Type > Gaussian. 

2. 输入拉伸的最小和最大值。 

·  要手动地输入所需要的标准差值，选择 Options > Set Gaussian Stdv. 

输出直方图用一条红色曲线显示被选择的 Gaussian 函数。被拉伸数据的分布呈白色叠加显示在
红色 Gaussian 函数上。 

3. 点击 “Apply” ，把拉伸应用于显示的数据。 

关于和直方图窗口交互的更全面的信息，请见上述描述（参见第 187 页的 “General”）。 

直方图均衡化对比度拉伸（Histogram Equalization Contrast Stretch） 
要自动缩放数据以与每个直方图中 bin的 DN数均衡： 

1. 选择 Stretch_Type > Equalization. 

输入直方图显示未被修改的数据分布。输出直方图用一条红色曲线显示均衡化函数，被拉伸数

据的分布呈白色叠加显示。 

2. 点击 “Apply” ，将拉伸应用于显示的数据。 

关于和直方图窗口交互的更全面的信息，请见上述描述（参见第 187 页的 “General”）。 

平方根对比度拉伸（Square Root Contrast Stretch） 
计算输入直方图的平方根，然后应用线性拉伸： 



 80

1. 选择 Stretch_Type > Square Root. 

输入直方图显示未被修改的数据分布。输出直方图用一条红色曲线显示平方根函数，被拉伸数

据的分布呈白色叠加显示。 

2. 点击 “Apply” ，将拉伸应用于显示的数据。 

关于和直方图窗口交互的更全面的信息，请见上述描述（参见第 187 页的 “General”）。 

任意对比度拉伸和直方图匹配（Arbitrary Contrast Stretching and Histogram 
Matching） 

·  Arbitrary 选项允许你在输出直方图的顶部“任意地”绘制任何形状的直方图，或从另一个图
像匹配一个直方图。 

1. 选择 Stretch_Type > Arbitrary. 

输入直方图显示未被修改的数据分布。 

2. 通过点击或按住鼠标左键绘制输出直方图的线段，在 Output Histogram 窗口内绘制输出直方
图。 

任意的直方图将用绿色来显示。 

·  要删除直方图，点击鼠标中键。 

3. 点击鼠标右键，来接受输出直方图，并把数据的统计资料匹配到图中。 

输出直方图用红色显示你的直方图，匹配的数据函数用白色曲线。 

·  任意的对比度拉伸函数也可以用来把一幅图像的直方图匹配到另一幅的图象的直方图。 

A. 通过使用鼠标左键在图表顶部的 “Input Histogram” 或 “Output Histogram” 文本标签上点
击，以从一个图表中输入或输出直方图。 

B. 把名字拖曳到其它的任意输出直方图，然后释放按钮。 

被导入的直方图将用红色绘制，输出直方图将被拉伸，来与导入的直方图相匹配。 

4. 点击 “Apply” ，将拉伸应用于显示的数据。 

关于和直方图窗口交互的更全面的信息，请见上述描述（参见第 187 页的 “General”）。 

用户自定义的查找表（User Defined Look-Up-Tables） 
一个用户自定义的查找表把每个输入的 DN 拉伸到一个输出值。它可以恢复（见第 190 页的 

“Saving and Restoring LUTs”） 或交互地定义。 

·  要定义一个查找表（LUT） 或编辑 LUT： 

1. 选择 Stretch_Type > User Defined LUT. 

2. 选择 Options > Edit User Defined LUT （见 图 3-12）. 

当出现编辑对话框，输入的 DN 值和与之相应的输出拉伸值的一个列表将显示在 “Edit User 
Defined LUT” 标签下。这些值反映了当前的拉伸。 

3. 在值上点击进行编辑。 

4. 当它出现在 “Edit Selected Item:” 文本框中，输入所需要的值，然后按回车键。 
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·  当功能被启动，要重新设置查找表为原来的值，点击 “Reset”。 

5. 点击 “OK”。 

6. 点击 “Apply” ，将拉伸应用于显示的数据。 

Histogram_Source 下拉菜单 

输入直方图信息可以从主图像窗口、滚动窗口 （被二次抽样）、缩放窗口、整个图像波段 （数
据的所有像元）或一个用户自定义的感兴趣区（ROI）中抽取。 

1. 选择 Histogram_Source > 选择所需要的输入数据源。 

输出直方图以及由此引起的拉伸，基于输入直方图源而变化。 

·  当缩放窗口作为数据输入源而被选择，从下列选项中选择： 

·  通过在主图像窗口内移动缩放框，查看图像不同部分的直方图。 

·  通过在主图像窗口的缩放框内点击并按住鼠标中键，然后拖曳缩放框到一个新位置，来实时
地查看缩放窗口的直方图。当缩放框移动，输入和输出直方图将自动地更新。改变缩放框的大小，

以改变显示的像元，同时也改变了直方图。 

Options 下拉菜单 

Options 下拉菜单包含允许重新设置直方图和拉伸的选项，以及属于特定拉伸类型的选项。这些
选项中的大多数已经在以上的特定拉伸类型描述中被叙述。 

设置高斯标准差（Set Gaussian Stdv） 
Set Gaussian Stdv 选项允许为 Gaussian 拉伸类型的直方图分布输入所需要的标准差范围。 

重设拉伸和重设直方图（Reset Stretch and Reset Histogram） 
·  当启动对比度拉伸功能时，要把显示的拉伸重新设置为对比度拉伸功能最初应用的拉伸，选
择 Options > Reset Stretch. 

·  要把输入直方图范围重新设置为输入数据的最小和最大值，选择 Options > Reset Histogram. 

图 3-12: Edit User Defined LUT 对话框。 

编辑用户定义的 LUT 和线性分段（Edit User Defined LUT and Edit Piecewise 
Linear） 

·  要编辑用于这些拉伸的值，选择 Options > Edit User Defined LUT or Edit Piecewise Linear. 

更多的信息，请参阅第 194 页的 “User Defined Look-Up-Tables”和第 192 页的 “Piecewise 
Linear Contrast Stretch”。若相应的拉伸类型被选择，这些选项中的每个选项只在 Stretch_Type 菜单
下可获得。 

重设直方图的自动打开/关闭（Auto Reset Histogram On/Off） 
·  当新的数据被导入到输入直方图中，设置是保留输入的 “Min” 和 “Max” 范围（Off），还是

重新设置（On），选择 Options > Auto Reset Histogram On 或 Auto Reset Histogram Off. 
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自动应用 On/Off （Auto Apply On/Off） 
·  要把任何拉伸或直方图变化自动地应用到你的图像上，选择 Options > Auto Apply: On. 

·  要仅当你点击 “Apply” 按钮时，把任何变化应用到你的图像，选择 Options > Auto Apply: Off. 

滤波（Filter） 

Filter 菜单可以选择锐化、平滑、中值及边缘检测滤波。这些滤波只应用于显示的数据，对其进
行快速增强。增强显示的图像可以通过使用 Functions > Output Display 选项，输出到一个文件或打
印机。参阅第七章， “Filtering”，把滤波器应用到数据文件，以及获得更多关于滤波器的信息。 

·  要把一个滤波器应用到你显示的数据上，选择 Functions > Display Enhancements > Filter > 
滤波器类型。 

锐化（Sharpen） 
锐化滤波对图像显示窗口内（image、scroll 和 zoom）的数据执行高通卷积。可利用三种锐化

滤波器类型，每个后面添加一个不同的数据值。“Sharpen” 附近方括号内的数字是核的中心值。因此，
括号中数值较高的滤波在滤波以后，有较多的原始数据保留并附加到滤波图象上（the sharpening 
filters with higher numbers in the brackets have a larger amount of the original data added back to the 
filtered image）。 

平滑（Smooth） 
可使用两种平滑滤波器。“Smooth [3×3]” 滤波器使用一个大小为 3×3的核，“Smooth [5×5]” 滤
波器使用一个大小为 5×5的核。核越大，滤波后越平滑。 

中值（Median） 
可使用两种中值滤波器，核大小分别为 3×3 和 5×5。中值滤波器用核的中值来代替中央的像

元值。这些滤波器有助于减少盐点和胡椒粉类型的噪音或斑点。 

边缘检测测（Edge Detection） 
可使用两种边缘检测滤波器。Sobel 使用一个 3×3 的核，Roberts 使用一个 2×2 的核。 

直方图匹配（Histogram Matching） 

使用 Histogram Matching自动地把一幅显示图像的直方图匹配到另一幅上，从而使两幅图像的
亮度分布尽可能地接近。用该功能，在功能被启动的窗口中输入直方图发生变化，以与选择的图象

显示窗口的当前输出直方图相匹配。在灰阶和彩色图像上，你都可以使用该功能，你也可以为输入

直方图选择直方图源。 

注意 
要执行 Histogram Matching，你必须显示至少两幅图像。 

1. 从你想更改的那个直方图的图像显示中，选择 Functions > Display Enhancements > Histogram 
Matching. 

出现 Histogram Matching Input parameters 对话框。 

2. 在 “Match To” 列表中，选择你想匹配的直方图的图像显示号。 
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3. 在 “Input Histogram” 下面，通过选择适当的切换按钮： “Image”，“Scroll”（二次抽样数据），
“Zoom”，“Band”（所有像元） 或一个 “ROI”（感兴趣区），来选择输入直方图的来源。 

4. 点击 “OK”。 

5. 显示出拉伸发生变化，以与所选择的直方图相匹配。 

·  要查看直方图匹配得怎样，在你想应用直方图匹配的图像中，选择 Functions > Interactive 
Stretching. 

输出直方图用红色显示导入的直方图，用白色显示被匹配的输出直方图。 

感兴趣区（Region of Interest） 
你可以画出感兴趣区（ROIs），它们是选定图表中图象的子集。这些区域可以呈不规则的形状，
通常用来提取分类的统计信息、掩膜，及其它操作。ENVI 允许选择任意的多边形、点或矢量的组
合来作为一个感兴趣区。可以定义多个感兴趣区，并绘制到主图像、滚动或缩放窗口中的任何一个

中。感兴趣区可以根据指定的阈值扩展到邻近的像元。 

感兴趣区与它们所在图像的空间大小明显相关。因此，当 ROI Controls 窗口被 “Connected” 到
一个特定显示窗口，只有与显示窗口当前图像相同空间大小的图像中定义的感兴趣区被列在 
“Available Regions” 列表中。例如，若 Display #1 包含一幅 512×512 图像，Display #2 包含一幅 
768×1320 图像，当 ROI Controls 窗口被连接到 Display #1 （Display #1 是活动的显示），只有定
义在 512×512 图像中的现有感兴趣区将显示在“Available Regions” 列表中。通过在 Display # 文本
框中输入显示号，把 ROI Controls 连接到 Display #2，这将导致 Available Regions 列表发生变化，
并只列出定义在 768×1320 图像中的现有的感兴趣区。 

图 3-13: 感兴趣区（ROIs）. 

若 ROIs 可以恢复，但是与不同的空间大小有关。恢复的感兴趣区不会显示在 “Available 
Regions” 列表中。但是恢复的感兴趣区可以用在大小合适的图象中（The restored ROIs will， 
however，be available for use with appropriately sized images）。 

·  你也可以通过从 ENVI 主菜单中选择 Basic Tools > Region of Interest，来访问感兴趣区功能。 

定义感兴趣区（Defining Regions of Interest） 

要定义一个新的感兴趣区： 

1. 在主图像窗口中，选择 Functions > Region of Interest. 

2. 当出现 Region of Interest Controls 对话框时，确信用于定义感兴趣区的显示号被列在对话框
顶部的 “Display #” 文本框中。 

感兴趣区控制（ROI Controls） 

Region of Interest Controls 对话框控制感兴趣区功能，并包含下述的三个下拉菜单。 

Display #， Image， Scroll， Zoom， Off 
ROI 的限定默认在功能被启动的特定显示窗口，除非你从 Basic Tools 窗口启动它。 

1. 在 Region of Interest Controls 对话框，通过在 “Display” 文本区输入所需要的显示号，来改
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变用于感兴趣区定义的显示组。 

2. 通过选择 “Image”、“Scroll” 或 “Zoom” 切换按钮，来控制是否感兴趣区将定义在选择显示
的主图像窗口、滚动窗口或缩放窗口内。 

·  当 ROI Definition 功能被激活，诸如缩放、平移及其它操作不能被激活。要激活这些交互式
的鼠标操作功能，而不离开 ROI Definition： 

A. 选择 “Off ” 来使感兴趣区选项无效，或通过点击适当的切换按钮来取消选择所需要的窗口。 

B. 选择适当的 “Image”、“Scroll” 或 “Zoom” 按钮，来开启 ROI 选项控件。 

 

图 3-14: ROI Controls 对话框。 

新区域（New Region） 
由感兴趣区类型的任意组合构成的多个区域，可以被包含在一个感兴趣区中。 

·  要启动一个新的感兴趣区，在 Region of Interest Controls 对话框内，点击 “New Region”，一
个新名将出现在 “Available Regions of Interest” 列表中。 

新区域将使用图示颜色列表中系统默认的下一种颜色。通过使用下述的 “Edit” 按钮，可以改变
颜色。 

编辑（Edit） 
要改变当前列在 “Available Regions” 下的区域的名称、颜色及区域填充类型。 

1. 在 Region of Interest Controls 对话框内，点击 “Edit”。 

2. 当出现 Edit ROI Parameters 对话框，从列表中选择一个感兴趣区。 

3. 从下列选项中选择，编辑你的感兴趣区。 

·  要编辑名称，在 “Name:” 文本小部件中输入新的名称。 

·  要更改感兴趣区颜色，从 “Colors” 菜单中选择。 

·  要定义线条类型，从 “Fill” 菜单中选择 “Line”、“Dotted”、“Dashed”，或其它一种有效的线
条类型。 

·  要设置填充的方向和间隔，在 “Fill” 选项右边标签为 “Orien” 和 “Space” 的文本框中输入
所需要的值。按度数输入方向（从水平线逆时针），按英寸输入间隔。 

4. 点击 “OK” 来返回到 ROI Controls 对话框。 

擦除（Erase） 
·  要从已选定的图像中擦除被选择的感兴趣区覆盖图，在 Region of Interest Controls 对话框中

的感兴趣区名上点击，然后点击 “Erase”。 

注意当感兴趣区从屏幕上被擦除时，感兴趣区仍然被定义。 

·  要重新显示感兴趣区图像，再次点击感兴趣区名。 

删除（Delete） 
·  要删除一个感兴趣区，并从系统中删除它，点击感兴趣区名，然后点击 “Delete”。 
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一旦一个感兴趣区被删除，它不能被恢复，除非它已经被保存到一个文件中。 

转到（Goto） 
要把缩放窗口置于 ROI 中定义的第一个像元中央： 

1. 选择一个感兴趣区名，然后点击 “Goto”。 

2. 继续点击 “Goto”，来移动缩放窗口，越过感兴趣区中包含的每个像元。 

统计（Stats） 
·  要关于一个感兴趣区的各种各样的统计数字： 

1. 点击一个感兴趣区名，然后点击 “Stats”。 

出现 Average Spectrum 和 ROI Statistics 窗口。 

图 3-15: Average Spectrum 和 ROI Statistics 窗口。 

这些窗口通过从 ROI Controls 对话框中选择来被显示。 

Average Spectrum 图表窗口（图 3-15） 显示被显示图像相应文件的平均波谱（白色，被选择
的 ROI 的各波段平均值）。标准差波谱（每个波段的标准差）绘制在平均波谱的上下（绿色，+/- 1 标
准差）。最小和最大波谱（红色，各波段的最小和最大值） 绘制在标准差波谱的上下。包含统计数
字的图表窗口和用于 X、Y、Z 剖面图的图表窗口一样，所有交互也相同。 

ROI Statistics 窗口列出文件名、区域名和点号，以及每个波段的波段号、最小值、最大值、均
值和标准差。 

·  要把这些统计数字保存到一个文件： 

1. 点击 “Save”。 

2. 在 “Enter Output Filename” 文本框中输入一个文件名，然后点击 “OK”。 

均值（Mean） 
·  要显示各波段的一个感兴趣区均值图表（一个平均波谱），点击一个感兴趣区名，然后点击 

“Mean”。 

增长（Grow） 
感兴趣区可以使用一个特定的阈值来 “增长” 到邻域像元。阈值通过限定一个远离所画区域平
均值的标准差来判定。对于灰阶显示，使用显示的波段来计算阈值，彩色显示使用红波段来计算。

所有在标准差阈值内的邻域像元，将被包括在增长的区域中。 

你可以使用 4 或 8 邻域像元。 

注意 
所有增长的感兴趣区作为点来输出，而不管起初的感兴趣区类型。 

要增长一个感兴趣区： 

1. 点击感兴趣区名，以便在 Available Regions of Interest 列表中增长。 

2. 点击 “Grow” 按钮。 

新增长的感兴趣区将显示在显示窗口。ENVI 将询问你是否想保留所得到的增长的感兴趣区。 
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3. 选择 “Yes”，感兴趣区将包含所有被显示的点。选择 “No”，感兴趣区将返回到它原来的大
小。 

若选择 “No”， 出现 Region Growing 对话框。 

·  若有必要，更改标准差的系数值和邻域数，然后点击 “OK” ，用新的参数增长感兴趣区。 

·  在 Region Growing 对话框内，点击 “Cancel”，退出增长选项，而不改变原来的感兴趣区。 

像元（Pixel） 
你可以使用 “Pixel” 按钮，“Pixelate”（像元化） 多边形、椭圆、矩形及折线。被像元化的对象
变成一个可编辑点的集合。使用它，你可以从多边形、矩形等内部删除点。 

1. 画一个多边形或其它感兴趣区形状，或选择一个现有的感兴趣区来像元化。 

2. 点击 “Pixel” 按钮。 

3. 选择 ROI_Type > Point. 

4. 用鼠标中键在多边形内部的任何一处点击，一次删除一个点。 

注意 
你可能想在缩放窗口中查看小的感兴趣区。 

感兴趣区类型（ROI Types） 

感兴趣区有五种类型–––– “Polygon”、“Polyline”、“Point”、“Rectangle” 和 “Ellipse”。每种类型
都有一组不同的鼠标按键任务。一个区域可以包含这五种感兴趣区类型的任意组合。鼠标任务和绘

制选项的说明如下，并汇总在 表 3-4 中。 

多边形（Polygon） 
多边形模式是感兴趣区定义的系统默认方式。该模式允许你用连接的线段来勾绘轮廓。 

1. 在 ROI Controls 对话框内，选择 ROI_Type > Polygon. 

2. 在活动窗口内点击鼠标左键，建立轮廓线段的初始端点。 

当移动鼠标选择另一个端点时，显示出一条线段，准确地指示出当前线段的位置。 

3. 再次点击鼠标左键，来定义用所选颜色绘制的线段。 

·  对于连续的绘制，按住鼠标左键并移动光标。 

4. 按同样的方法选择其它的线段，直到整个感兴趣区的轮廓被勾绘。 

·  要在线段选择过程中擦除在任何点定义的前一条线段，点击鼠标中键。 

5. 点击鼠标右键，来绘制最后一条线段，并自动闭合多边形。 

6. 通过用鼠标左键点击菱形手柄并拖曳，把多边形移动到所需要的位置。 

7. 点击鼠标右键，接受该多边形。 

当多边形完成后，感兴趣区中包含的像元总数与感兴趣区名称一起被列在 “Available Regions of 
Interest” 列表中。 

你可以为每个感兴趣区绘制多个多边形。每个连续的多边形按上述绘制，它的像元被添加到整
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个区域中。当完成后，该多边形用系统默认的一种颜色填充。 

·  要更改多边形颜色和填充类型，点击 “Edit”，当出现对话框，做适当的更改。 

·  要任何时候从感兴趣区中删除整个多边形，当光标在所需要的多边形上，点击鼠标中键。 

8. 当你对新的感兴趣区感到满意，点击 “Cancel” 来离开 ROI Controls 对话框。 

或者： 

9. 点击 “New Region” 来创建另一个感兴趣区。 

折线（Polyline） 
折线模式与多边形模式相似，除了它是一个多线段矢量而不是一个闭合的多边形之外。完成后

所定义的线段包围的区域没有被选择和填充。只有组成线段的那些像元才被选择。 

1. 在 ROI Controls 对话框，选择 ROI_Type > Polyline. 

2. 采用多边形模式，点击鼠标左键，定义连接线段的端点。 

·  要删除先前的线段，点击鼠标中键。 

·  对于连续的绘制，绘制时按住鼠标左键。 

3. 点击鼠标右键，结束定义折线的过程。 

4.使用折线上的手柄，以移动线条。 

·  要擦除整条折线，在一条先前定义的折线的任何像元上点击鼠标中键。 

5. 点击鼠标右键，接受该折线。 

6. 当你对新的感兴趣区感到满意，点击 “Cancel” 离开 ROI Controls 对话框。 

或者： 

7. 再次点击 “New Region” ，创建另一个感兴趣区。 

点（Point） 
点模式允许用户选择或删除光标下的像元。若在缩放窗口使用，该模式效果最佳。 

1. 在 ROI Controls 对话框，选择 ROI_Type > Point. 

2. 点击鼠标左键，把当前光标下的像元添加到感兴趣区。 

·  要从感兴趣区中删除一个先前选择的像元（当前光标下），点击鼠标中键。 

·  要删除当前选择的点模式感兴趣区中的所有像元，点击鼠标右键。 

3. 当你对新的感兴趣区感到满意，点击 “Cancel” 来离开 ROI Controls 对话框。 

或者： 

4. 点击 “New Region” ，创建另一个感兴趣区。 

矩形和椭圆（Rectangle and Ellipse） 
Rectangle 和 Ellipse 模式允许你绘制矩形和椭圆感兴趣区。 

1. 在 ROI Controls 对话框，选择 ROI_Type > Rectangle 或 Ellipse. 
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2. 点击鼠标左键，并拖曳光标到所需要的矩形或椭圆大小。 

·  要画一个正方形或圆，点击并拖曳鼠标中键。 

3. 点住矩形或椭圆内的菱形手柄，并移动到所需要的位置。 

·  要删除该形状，在矩形或椭圆上点击鼠标中键。 

4. 点击鼠标右键，接受该形状到感兴趣区。 

5. 当你对新的感兴趣区感到满意，点击 “Cancel” 来离开 ROI Controls 对话框。 

或者： 

6. 点击 “New Region” ，创建另一个感兴趣区。 

 

感兴趣区模式 操作 鼠标

按键 
交互 

多边形，折线 定义端点 左 点击或按住并

拖曳 

多边形，折线 删除上一个端点 中 点击 

多边形，折线 闭合多边形；结束折

线 
右 点击 

多边形，折线 接受多边形或折线 右 点击 

多边形，折线 删除整个多边形/折
线 

中 在所定义的多

边形/折线上点击 

点 选择点 左 在像元上点击 

点 删除点 中 在像元上点击 

点 删除 ROI 中所有点 右 点击 

矩形，椭圆 定义形状 左 按住并拖曳 

矩形，椭圆 删除形状 中 在形状内点击 

矩形，椭圆 接受形状 右 点击 

 

表 3-4: 感兴趣区鼠标操作。 

从ASCII文件输入点（Input Points from ASCII） 
你可以输入 ASCII 数据点作为一个感兴趣区。用该选项，你可以把点输入到一个新的或现有的
感兴趣区中，选择感兴趣区类型，以及选择相应的地图投影信息，若有必要。 

·  若你想把点输入到一个新区域，在完成以下步骤前，点击 “New Region”。 

1. 选择 ROI_Type > Input Points from ASCII. 

2. 当出现 Enter ASCII Points FIlename 对话框时，选择一个输入 ASCII 文件名。 

3. 当出现 Input ASCII File 对话框时，输入 X 和 Y 点坐标的列号。 

4. 通过点击 “These points comprise” 标签附近的按钮菜单，选择定义的感兴趣区类型。 
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对于多边形和折线感兴趣区，ASCII 点将定义感兴趣区的顶点。 

5. 选择输入坐标是“Pixel Based” 或 “Map Based”。 

·  若你选择 “Map Based”，选择投影类型；若有必要，通过点击 “Zone...” 和 “Datum...” 按钮，
输入区域和基准点信息。 

6. 点击 “OK”。 

感兴趣区 - 测量工具（ROI - Measurement Tool） 

使用感兴趣区测量工具，来获得多边形或折线的点之间距离的一个记录，以及获得多边形、矩

形和椭圆的周长和面积大小。 

注意 
要不使用感兴趣区功能来测量一幅图像，参阅第 328 页的 “Measurement Tool”。 

1. 在 Region of Interest Controls 对话框，选择 Options > Measurement Report. 

出现 ROI Measurement Report 对话框，视活动的感兴趣区类型而定，记录的测量有所不同。 

2. 为特定感兴趣区类型绘制上述的感兴趣区。 

对于多边形模式，列出了顶点间的距离，当多边形闭合时，记录了周长和总面积。 

对于折线，列出了顶点间的距离，当折线被完成时，给出了总距离。 

点模式，不进行距离测量。 

矩形模式，记录边长、周长和总面积。 

 

图 3-16: ROI Measurement Report 对话框。 

椭圆模式，记录了圆周和总面积。 

ROI Measurement Report 对话框中的四个下拉菜单描述如下。 

File 下拉菜单 
使用 File 菜单，把感兴趣区测量记录保存到一个 ASCII 文件，并关闭对话框。 

·  要保存测量记录： 

1. 在 ROI Measurement Report 对话框，选择 File > Save Points to ASCII. 

2. 键入一个输出文件名。 

·  要关闭感兴趣区测量工具，选择 File > Cancel. 

Units 下拉菜单 
使用 Units 菜单，选择测量感兴趣区的单位。你可以选择 pixels（像元）、meters（米）、kilometers
（千米）、feet（英尺）、yards（码）、miles（英里） 和 nautical miles（海里）。 

·  选择 Units > 所需要的单位。 

若图像的像元大小没有保存在文件头中，你可以选择除 “Pixel” 之外的任何单位。 
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当出现 Input Display Pixel Size 对话框，完成这些步骤： 

A. 在 “Pixel Size” 和 “Pixel Size” 文本框中，键入你图像的像元大小。 

B. 从 “Units” 按钮菜单，选择单位类型。点击 “OK”。 

Area 下拉菜单 
使用 Area 菜单，按英亩或公顷来测量感兴趣区的面积。 

·  选择 Area > Acres or Hectares. 

Options 下拉菜单 
使用 Options 菜单，选择测量信息是记录线段（系统默认）还是点坐标。 

·  要获取一个顶点坐标的列表，选择 Options > Report as Points. 

坐标将作为一个像元的位置被记录（“Pixel （x，y）”）。 

·  要获取一个线段距离的列表，选择 Options > Report as Segments. 

·  对于地理坐标定位过的图像，通过选择 Options > Georef Map （x，y） 或 Georef （Lat/Lon），
你可以把坐标作为地图坐标或经纬度坐标列出来。 

·  要把点坐标的列表输出到一个文件，选择 File > Save Points to ASCII. 

ROI - Options 下拉菜单 

Region of Interest Controls 对话框内的 Options 菜单允许你选择下列选项：一个测量工具、一个
记录 ROIs 面积的选项，及用来导入、擦除、删除、获取统计信息、绘制平均值、合并区域、调和
感兴趣区等其它选项，以及为所有被定义的感兴趣区执行一个图像阈值。每个选项描述如下。 

测量报告（Measurement Report） 
选择该选项来启动 ROI Measurement Report 工具（有关细节，请见第 210 页的 “ROI – 

Measurement Tool”）。 

ROIs 的面积记录（Report Area of ROIs） 
·  要得到每个感兴趣区覆盖面积的一个记录（单位：米、千米、英尺、码、英里或海里），选

择 Options > Report Area of ROIs > Region of Interest Controls 对话框中需要的单位。 

·  若图像的像元大小没有保存在文件头中，将出现一个对话框。以米为单位输入 X 和 Y 像元
大小。 

出现 ROI Area Info 对话框，列出了每个感兴趣区的名称和相应的面积。 

·  要把这些信息保存到一个 ASCII 文件，选择 File > Save Text to ASCII ，然后输入一个文件
名。 

装载所有感兴趣区（Load All Regions） 
·  为所有具有相同空间维数的图象装载当前限定的所有区域，如同 “Display #” 区域内当前显

示的一样，选择 Options > Load All Regions. 

擦掉所有区域（Erase All Regions） 
·  要从当前显示中擦除所有感兴趣区覆盖图，选择 Options > Erase All Regions. 
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注意当感兴趣区从屏幕中被擦除，感兴趣区仍被定义。 

·  要重新显示感兴趣区，再次点击每个感兴趣区名，或选择 Options > Load All Regions. 

删除所有区域（Delete All Regions） 
·  要删除只与当前活动显示相关的所有感兴趣区，并从系统中删除它们，选择 Options > Delete 

All Regions. 

要删除当前在 ENVI 中的所有感兴趣区，使用 Basic Tools > Region of Interest > Delete ROIs 选
项。 

注意 
一旦感兴趣区被删除，它们不能被恢复，除非它们曾经保存到一个文件中。 

对所有区域的统计（Stats for All Regions） 
·  要显示所有定义的感兴趣区的统计资料，选择 Options > Stats For All Regions. 

将出现一个包含每个区域均值、标准差及最小和最大波谱的图表窗口。也将出现一个列有每个

区域统计资料的 “ROI Statistics” 窗口（见第 203 页的 “Stats”）。 

所有区域的平均值（Mean for All Regions） 
·  要显示所有区域所有波段的均值，选择 Options > Mean For All Regions. 

该均值将作为平均波谱，以所定义的感兴趣区颜色显示在一个图表窗口。 

合并区域（Merge Regions） 
要把所定义的多个感兴趣区合并为一个： 

1. 选择 Options > Merge Regions. 

2. 将出现 Merge ROIs 对话框，它包含两个所定义区域的列表。点击 “Choose Base ROI to 
Merge” 下的区域名。 

3. 选择区域名，合并到 “Choose Base ROI to Merge” 列表下的基区域（base region）。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要选择一组感兴趣区，点击列表中的第一个所需要的项，按住 “shift” 键，然后点击你想在
该组中包括的最后一个感兴趣区。 

·  要选择多个，但不是所有感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。 

·  要取消选择所有已选择的项，点击 “Clear All Items”。 

4. 点击 “Delete Merged ROIs” 旁的箭头切换按钮，选择是否保留你合并的区域。 

·  要在合并后删除单个的感兴趣区，选择 “Yes”。 

“其它”感兴趣区的颜色将变为“基”感兴趣区的颜色，其它的名将从 “Available Regions of 
Interest” 列表中被删除。 

·  在合并后，要允许保留单个的感兴趣区，选择 “No”。 

5. 点击 “OK”。 
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协调ROIs（Reconcile ROIs） 
Reconcile ROIs 功能允许你在不同大小的图像中使用按另一个图像大小定义的感兴趣区。 

1. 选择 Options > Reconcile ROIs. 

 

图 3-17: Reconcile ROIs Parameters 对话框。 

2. 当出现 Reconcile ROIs Parameters 对话框时，通过选择下列选项，确定要被调和的感兴趣区。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要选择一组感兴趣区，点击列表中的第一个所需要的项，按住 “shift” 键，然后点击你想在
该组中包括的最后一个感兴趣区。 

·  要选择多个，但不是所有感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。 

·  要取消选择已选择的项，点击 “Clear All Items”。 

3. 选择下列选项之一。 

·  要手动地指定新感兴趣区的空间大小： 

A. 把感兴趣区所在的图像的原点和新图像原点之间的像元差值输入到 “Xoffset” 和 “Yoffset” 
文本框中。 

B. 把新图像的样本数和行数输入到适当的文本框中。 

·  要让 ENVI 自动地计算 x 和 y 偏移量以及样本数和行数： 

A. 点击 “Set Values from Source/Destination Files”。 

B. 当出现文件选择对话框时，选择感兴趣区最初被绘制在的那个文件，然后点击 “OK”。 

C. 当出现下一个文件选择对话框时，选择感兴趣区的目标文件，然后点击 “OK”。 

D. 在 Reconcile ROIs Parameters 对话框内，点击 “OK”。 

该感兴趣区将被列在 ROI Controls 对话框内，并自动地被导入到新的图像上。 

通过地图协调ROIs（Reconcile ROIs via Map） 
该选项允许你在一幅重叠的地理坐标定位了的图像内使用另一幅定位了的图像中定义的感兴趣

区，而不顾两幅图像的图像或像元大小差异。 

1. 选择 Options > Reconcile ROIs via Map. 

2. 当出现 Reconcile ROIs via Map Pavameters 对话框时，通过在名字上点击，选择所需要的感
兴趣区。 

·  要选择一组感兴趣区，点击并拖曳到所需要的范围，或点击该组中的第一项，按住 “shift” 键，
然后点击最后一项，来选择之间的所有项。 

·  要选择多个，但不是连续列出的感兴趣区，按住 “Ctrl” 键的同时，点击所需要的项。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要清除所有项，点击 “Clear All Items”。 
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3. 点击 “OK”。 

4. 选择感兴趣区将被调和到的那个地理坐标定位了的文件，然后点击 “OK”。 

该感兴趣区将被列在 ROI Controls 对话框中，并自动地被导入到新的图像上。 

从图象阈值定义感兴趣区（Image Threshold to ROI） 
Image Threshold to ROI 选项允许你选择特定的图像值和值的范围，来定义感兴趣区。 

1. 选择 Options > Image Threshold to ROI. 

2. 当出现 Image Threshold to ROI Input Band 对话框时，选择要被限定阈值的波段。 

3. 当出现 Image Threshold to ROI Parameters 对话框时，从下列选项中选择。 

·  要使用大于或等于输入的最小值的那些像元来产生一个感兴趣区，只需输入 “Min Thresh 
Value”。 

·  要选择小于或等于输入的最大值的那些像元，只需输入 “Max Thresh Value”。 

·  要选择在一定范围值内的像元，输入一个最小和一个最大阈值。 

·  要指定一个感兴趣区的名称，编辑 “ROI Name” 文本输入项。 

·  要更改感兴趣区的颜色，从 “ROI Color” 菜单中选择所需要的颜色。 

4. 点击 “OK”，提取阈值内的像元。 

将出现一个警告对话框，并列出满足阈值标准的像元数。 

5. 点击 “OK” ，接受并导入感兴趣区。 

该区域将作为一个 “Thresh Bandname” 列在 ROI Controls 对话框中，其中波段名是用于提取感
兴趣区的那个波段名。区域中的像元数也将被列出。 

ROI - File 下拉菜单 

File 菜单允许使用一个 ENVI ROI 文件来保存和恢复感兴趣区信息，以及把感兴趣区导出到 
ENVI 矢量文件（.evf）。 

保存 ROIs （Save ROIs） 
要保存感兴趣区： 

1. 选择 File > Save ROIs 

2. 当出现 Save ROIs to File 对话框时，用鼠标左键在可滚动列表中点击所需要的感兴趣区名。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要取消选择的所有感兴趣区，点击 “Clear All Items”。 

·  要选择一组连续列出的感兴趣区，点击所需要的第一个感兴趣区，按住 “shift” 键，然后点
击最后一个所需要的感兴趣区，来突出显示两者之间所有的感兴趣区。 

·  要选择多个非连续列出的感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。 

3. 键入或选择一个输出文件名。 
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4. 点击 “OK” 来保存感兴趣区文件。 

恢复 ROIs （Restore ROIs） 
要恢复以前保存的感兴趣区文件： 

1. 选择 File > Restore ROIs. 

2. 当出现一个系统默认的列有所有 .roi 文件的文件选择对话框时，点击一个文件名导入该感
兴趣区文件。 

注意 
只有与当前显示中的那些图像大小相同的图像中定义的感兴趣区，才会显示在感兴趣区列表中。

其它大小的感兴趣区将保留在内存中。 

导出 ROIs 到 EVF（Export ROIs to EVF） 
感兴趣区可以被导出到 ENVI 矢量文件（.evf）。所有被选择的感兴趣区将作为独立的记录导出
到一个层。若感兴趣区相应的文件是经过地理坐标定位了的，那么矢量层将使用相同的投影。 

要把所选择的感兴趣区导出到一个 ENVI 矢量文件（.evf）： 

1. 选择 File > Export ROIs to EVF. 

2. 当出现 Export Regions to EVF 对话框时，通过在感兴趣区名上点击，选择所需要的感兴趣区
来导出。 

·  要选择所有的感兴趣区，点击 “Select All Items”。 

·  要取消选择所有的感兴趣区，点击 “Clear All Items”。 

·  要选择一组连续列出的感兴趣区，点击所需要的第一个感兴趣区，按住 “shift” 键，然后点
击最后一个所需要的感兴趣区，来突出显示两者之间所有的感兴趣区。 

·  要选择多个非连续列出的感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。再次点击取消选择一项。 

3. 选择应该如何处理感兴趣区的点，是把每个点作为一个单独的矢量记录，还是所有点作为一
个矢量记录。 

4. 在 “Layer Name” 文本框中，输入所需要的层名。 

5. 选择输出到 “File” 或 “Memory”，若有必要，键入一个输出文件名。 

输出 ROIs 到 ASCII（Export ROIs to ASCII） 
你可以把你的感兴趣区输出成一个 ASCII 文件。在所选择的感兴趣区中包含的每个像元的指针
将被输出到这个 ASCII 文件。该指针是文件中像元位置的一维地址，其中一个一维地址 ＝ 行号 ＋ 
样本数 ＋ 样本号。 

1. 选择 File > Export ROIs to ASCII. 

2. 当出现 Export Region to ASCII 对话框时，点击要导出的感兴趣区名。 

·  要选择所有的感兴趣区，点击 “Select All Items”。 

·  要取消选择的所有感兴趣区，点击 “Clear All Items”。 

·  要选择一组连续列出的感兴趣区，点击所需要的第一个感兴趣区，按住 “shift” 键，然后点
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击最后一个所需要的感兴趣区，来突出显示两者之间所有的感兴趣区，或点击并拖曳到所需要的范

围。 

·  要选择多个非连续列出的感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。再次点击来取消选择一项。 

3. 通过点击 “Values Per Line” 标签旁的箭头按钮，或在文本框中输入一个值，指定指针地址号
按行输出。 

4. 键入或选择一个输出文件名，然后点击 “OK”。 

取消（Cancel） 
·  要退出 Region of Interest Controls 对话框，选择 File > Cancel. 

注意：甚至离开 ROI Controls 对话框后，新创建的感兴趣区还保留在内存中（除非使用 “Delete” 
按钮特意将其删除）。 

恢复保存的 ROI 文件（Restore Saved ROI File） 

要恢复以前保存的感兴趣区文件： 

1. 选择 Functions > Region of Interest > Restore Saved ROIs to File. 

2. 当出现一个系统默认的列有所有 .roi 文件的文件选择对话框时，点击一个文件名来导入该
感兴趣区文件。 

保存 ROIs 到文件（Save ROIs to File） 

·  要把当前内存中的感兴趣区保存到一个文件，选择 Functions > Region of Interest > Save ROIs 
to File. 

将出现先前描述的 Save ROIs to File 对话框（见第 218 页的 “Save ROIs”）。 

删除 ROIs （Delete ROIs） 

要删除感兴趣区： 

1. 选择 Functions > Region of Interest > Delete ROIs. 

2. 当出现 Delete ROI’s 对话框时，点击你想删除的区域名。 

·  要删除所有的感兴趣区，点击 “Select All Items”。 

·  要取消选择的所有感兴趣区，点击 “Clear All Items”。 

·  要删除一组连续列出的感兴趣区，点击所需要的第一个感兴趣区，按住 “shift” 键，然后点
击最后一个所需要的感兴趣区，来突出显示两者之间所有的感兴趣区。 

·  要删除多个非连续列出的感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。再次点击来取消选择一项。 

3. 点击 “OK” ，永久地删除这些感兴趣区。 
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协调 ROIs （Reconcile ROIs） 

Reconcile ROIs 功能允许你在不同大小的图像中使用按另一个图像大小定义的感兴趣区。 

1. 选择 Options > Reconcile ROIs. 

2. 当出现 Reconcile ROIs Parameters 对话框时，通过选择下列选项，确定要被调和的感兴趣区。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要选择一组感兴趣区，点击列表中的第一个所需要的项，按住 “shift” 键，然后点击你想在
该组中包括的最后一个感兴趣区，或点击并拖曳来选择所需要的范围。 

·  要选择多个，但不是所有感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。 

·  要取消选择已选择的项，点击 “Clear All Items”。 

 

图 3-18: Reconcile ROIs Parameters 对话框。 

3. 选择下列选项之一。 

·  要手动地指定新感兴趣区的空间大小。 

A. 把感兴趣区所在的图像的原点和新图像原点之间的像元差值输入到 “Xoffset” 和 “Yoffset” 
文本框中。 

B. 把新图像的样本数和行数输入到适当的文本框中。 

·  要让 ENVI 自动地计算 x 和 y 偏移量以及样本数和行数： 

A. 点击 “Set Values from Source/Destination Files”。 

B. 当出现文件选择对话框时，选择感兴趣区最初被绘制在的那个文件，然后点击 “OK”。 

C. 当出现下一个文件选择对话框时，选择感兴趣区的目标文件，然后点击 “OK”。 

D. 在 Reconcile ROIs Parameters 对话框内，点击 “OK”。 

该感兴趣区将被列在 ROI Controls 对话框内，并自动地被导入到新的图像上。 

通过地图协调 ROIs（Reconcile ROIs via Map） 

该选项允许你在一幅重叠的地理坐标定位了的图像内使用另一幅定位了的图像中定义的感兴趣

区，而不顾两幅图像的图像或像元大小差异。 

1. 选择 Options > Reconcile ROIs via Map. 

2. 当出现 Reconcile ROIs via Map Parameters 对话框时，通过在名字上点击，选择所需要的感
兴趣区。 

·  要选择一组感兴趣区，点击并拖曳到所需要的范围，或点击该组中的第一项，按住 “shift” 键，
然后点击最后一项，来选择之间的所有项。 

·  要选择多个，但不是连续列出的感兴趣区，按住 “Ctrl” 键的同时，点击所需要的项。 
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·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要清除所有项，点击 “Clear All Items”。 

3. 点击 “OK”。 

4. 选择感兴趣区将被调和到的那个地理坐标定位了的文件，然后点击 “OK”。 

该感兴趣区将被列在 ROI Controls 对话框中，并自动地被导入到新的图像上。 

用图象阈值定义ROI（Image Threshold to ROI） 

Image Threshold to ROI 选项允许你选择特定的图像值和值的范围，变换感兴趣区。你也可以从 
Region of Interest Controls 对话框来访问该功能（更多详细的向导，见第 217 页的 “Image Threshold 
to ROI”）。 

1. 选择 Options > Image Threshold to ROI. 

2. 当出现 Image Threshold to ROI Input Band 对话框时，选择一个要被限定阈值的波段。 

3. 当出现 Image Threshold to ROI Parameters 对话框时，输入最小和最大阈值。 

4. 若有必要，编辑感兴趣区名称和颜色。 

5. 点击 “OK” ，提取阈值内的像元。 

将出现一个警告对话框，并列出满足阈值标准的像元数。 

6. 点击 “OK” ，接受并导入感兴趣区。 

若 ROI Controls 窗口显示在屏幕上，该区域将作为一个 “Thresh Bandname” 被列出，其中波段
名是用于提取感兴趣区的那个波段名。区域中的像元数也将被列出。 

若 ROI Controls 窗口没有显示在屏幕上，那么该阈值感兴趣区将在窗口下一次被启动时列出。 

交互式分析（Interactive Analysis） 
选择该菜单项，执行一般与特定显示或需要重要的用户交互相关的 ENVI 功能。交互式分析包
括：光标位置/值、像元定位器、波谱像元编辑器、感兴趣区（ROIs）、2-D 散点图、3-D 表面图，
及极化信号。细节如下。 

 

图 3-19: Interactive Analysis 层叠式菜单。 

光标位置/值（Cursor Location/Value） 

Cursor Location/Value 选项产生一个对话框，当光标在任何一个显示窗口（主图像、滚动或缩放
窗口）时，它显示光标的样本（水平的，X） 和行（垂直的，Y） 坐标，以及光标位置的像元数据
值（图 3-20）。在窗口内移动，位置将被连续更新。 

同样的 Cursor Location/Value 窗口应用于所有打开的显示。“Scrn:”（被拉伸的图像） 和 “Data:”
（原始数据） 值都被列出。若显示一幅 RGB 图像，那么三个波段的值都将被列出。若一幅图像是
地理坐标定位过的，那么正确的投影名和地图坐标，以及经纬度也被列出。当显示窗口被链接，Cursor 
Location/Value 对话框将显示包括链接在内的所有显示窗口当前像元的数据值。 
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按照下列向导，来访问 Cursor Location Value 显示窗口，及设置显示参数。 

·  在主图像窗口内，选择 Functions > Interactive Analysis > Cursor Location/Value. 

或者： 

·  从 ENVI 主菜单中，选择 Basic Tools > Cursor Location/Value. 

 

图 3-20: Cursor Location/Value 对话框。右边的对话框显示一幅地理坐标定位了的图像的光标
位置。UTM 坐标按东经、北纬列出。UTM 区域是 {12}。 

Options 下拉菜单 

Options 菜单允许你用整数或浮点数显示一个像元的分数，以记录缩放窗口中的光标位置，更改
经纬度信息的显示格式，以及设置记录数字的精度。像元的左上角是整个数字坐标的位置，X 和 Y 
值分别自该像元向右和向下增加。像元的分数与缩放系数成比例显示。例如，缩放 4 倍，像元被分
成四分之一。 

·  要查看缩放窗口中的浮点像元位置，选择 Options > Zoom: Floating Point Location. 

·  要查看缩放窗口中的整数像元位置，选择 Options > Zoom: Integer Location. 

·  要按数字式的度数查看经纬度信息，选择 Options > Lat/Lon: DD （对于地理坐标定位了的
数据集）。 

·  要按度、分、秒来查看经纬度信息，选择 Options > Lat/Lon: DMS （对于地理坐标定位了的
数据集）。 

·  要设置显示信息的数据精度（小数点后显示的数字位数）： 

1. 选择 Options > Set Report Precision. 

2. 在 Set Report Precision 对话框时，使用箭头增量按钮，设置地图、经纬度和数据显示所需要
的精度。 

·  要设置用于显示地图坐标的精度，输入所需要的精度，或使用 “Map Precision” 标签旁的箭
头增量按钮。 

·  当 Lat/Lon:DD 是地理坐标定位数据集所选择的选项时，要设置显示的精度，点击 “Lat/Lon 
Precision” 标签旁的箭头按钮。 

·  要设置用于显示浮点数据值的精度，点击 “Data Precision” 标签旁的箭头按钮。任何更改都
不影响字节型和整型数据的显示。 

·  要选择 “Scientific” 或 “Normal” 作为 “Floating Report” 格式，点击箭头切换按钮。 

一个常规的数字将按照十进制形式（例如，25.88），而一个科学记数法的数字将显示一个数字，
后面跟有一个小数和 “e”（指数的） 幂（例如，2.588e+001）。 

3. 点击 “OK”。 

像素定位器（Pixel Locator） 

 Pixel Locator 选项允许你手动地输入一个样本和行位置，定位在缩放窗口的中央。 
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1. 在主图像窗口，选择 Functions > Interactive Analysis > Pixel Locator. 

将出现从属于一个特定显示的 Pixel Locator 对话框。你可以为每个 ENVI 显示组提供一个像
元定位器。十字准线被显示在缩放窗口的中央像元上（drawn in the zoom window outlining the center 
pixel）。 

2. 把一个样本（水平的） 和行（垂直的） 位置输入到相应的文本框中。 

3. 点击 “Apply”，缩放框跳到指定的像元位置。 

·  要将缩放窗口的中心按箭头方向移动一个像元，在对话框的右下角内按箭头按钮。 

当地理坐标定位过的数据显示在图像窗口中，像元定位器可以使用像元或地图坐标为单位。 

·  要改变为 “Map Coord”，使用 “Pixel Coord” 标签旁的箭头切换按钮。 

 

图 3-21: 基于像元的图像和地理坐标定位图像的 Pixel Locator 对话框。 

·  要从 UTM 坐标转换到地理（纬度/经度）坐标： 

A. 使用 “UTM” 标签旁的箭头切换按钮。 

B. 输入所需要的东经和北纬（或纬度和经度），缩放窗口将居中（center on）于最近的像元上。 

提示 

当 ENVI 的图像-地图配准功能被激活，使用  Pixel Locator 对话框内的 “Export”按钮，把地
图坐标传递到该功能（参见第 602 页的 “Entry of Map GCPs from a Vector Window”）。 

若没有激活配准，点击 “Export”，ENVI 什么也不执行。 

空间像元编辑器（Spatial Pixel Editor） 

Spatial Pixel Editor 选项把像元值显示在一个表格中，并允许你交互式地更改有问题的像元值。
通过用户输入的值、数据均值，或通过周围像元、行或列的平均值，可以替代单个像元值或整行或

整列的值。更改可以保存到磁盘文件中。 

 

图 3-22: Spatial Pixel Editor 对话框。 

注意 
该功能只能操作 ENVI 格式文件： 

1. 在主图像窗口，选择 Functions > Interactive Analysis > Spatial Pixel Editor. 

出现 Spatial Pixel Editor 对话框，并带有一个显示缩放窗口像元值的表格。样本号和行号显示在
表格的顶部和侧面。表格中突出显示的像元位置，通过一个绿色方框显示在缩放窗口中。 

2. 使用下列选项，编辑所需要的像元。 

·  要更改显示在 Spatial Pixel Editor 表格中的像元，在图像窗口内，通过用鼠标左键点击一个 
dragging 来移动缩放窗口，或在一个像元上点击鼠标中键，来把它置于缩放窗口中央。 

·  要为一个像元输入一个新值，点击表格中的像元值，使用空格键删除当前值，输入所需要的
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值，然后按回车。 

·  要用 4 个或 8 个周围像元的平均值来替代一个像元的值，点击表格中的像元值，然后选择 
Options > Replace cell with 4 pixel average or Replace cell with 8 pixel average. 

·  要为一组像元输入一个新值，通过点击并拖曳，或通过点击一列或一行数字，选择表格中的
像元，然后选择 Options > Replace selected cells with value。输入所需要的值，并点击 “OK”。 

·  要用一组的均值来替代这组像元的值，通过点击并拖曳，或通过点击一列或一行数字，选择
表格中的像元，然后选择 Options > Replace selected cells with mean。 

·  要用周围列或行的平均值来替代一列或一行（越过整幅图像），点击表格周围的列号或行号，
然后选择 Options > Replace selected column/line with average. 

·  通过选择 Options > Set # of lines for averaging，设置用于计算平均值时选择的周围的列数或
行数。键入所需要的列数和行数，使用所选择的每边来计算平均值。 

·  要取消像元值的所有更改，选择 Options > Undo all changes. 

3. 通过选择 File > Save changes to file，把像元值更改保存到磁盘文件。 

4. 通过选择 File > Cancel，退出 Spatial Pixel Editor。 

波谱像元编辑器（Spectral Pixel Editor） 

Spectral Pixel Editor 选项允许你用周围像元的一个平均值或用通过图表窗口输入的其它波谱，
来替代多波谱或高波谱数据中所有波谱波段的当前像元。 

1. 在主图像窗口，选择 Functions > Interactive Analysis > Spectral Pixel Editor. 

出现一个空的图表窗口。 

2. 在 Spectral Pixel Editor 图表窗口，选择下列选项。 

·  要绘制当前波谱，选择 Pixel_Edit > Extract Current Spectrum. 

·  要绘制从当前像元周围 8 （4 或 2） 个像元计算得到的一个平均波谱，选择 Pixel_Edit > 
Extract 8 （4 or 2） pixel average. 

·  要从一个 ASCII 文件或波谱库中输入一个波谱，选择 File > Input. 

·  要从另一个窗口导入一个波谱，点击图表标签名，并拖曳到 Pixel Editor Spectrum 图表窗口
中。 

·  要选择一个波谱来替代当前像元的波谱，选择 Pixel_Edit > Substitute Spectrum. 

警告 

最后一步将彻底地替代数据文件中的当前波谱。 

动画（Animation） 

Animation 选项允许你通过使用一个或多个打开文件的图像，来创建一个“电影”。 

Administrator
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为动画选择波段（Select Bands for Animation） 
选择需要进行动画的波段： 

1. 从主图像窗口内，选择 Functions > Interactive Analysis > Animation. 

2. 当出现 Animation Input Parameters 对话框时，从下列步骤中选择，从打开的图像文件所包含
的所有波段的列表中选择波段。 

系统默认，当前显示图像的所有波段都用于动画。 

·  要从列表中清除一个已经选择的波段，按住你键盘上 “Ctrl” 键的同时，用鼠标左键点击所
需要的波段。 

·  要选择所有波段，点击 “Select All Items”。 

·  要取消选择所有波段，点击 “Clear All Items”。 

·  要选择一组连续列出的波段，点击第一个所需要的波段，按住 “shift” 键，然后点击最后一
个所需要的波段，来突出显示两者之间所有的波段。 

·  要选择多个非连续列出的波段，按住你键盘上 “Ctrl” 键的同时，点击所需要的项。再次点
击来取消选择一项。 

·  要使用标准的 ENVI 构造子集程序来减小动画图像的大小，点击 “Spatial Subset”。 

3. 要设置动画显示窗口所需要的大小，在 “Window Size” 文本标签旁的文本框中输入数值。 

注意 
注意，被选择的图像将自动地调整到所选择的窗口大小。减小进行动画的空间子集大小和/或动

画窗口的大小，都将提高动画速度。 

4. 点击 “OK” ，启动动画。 

5. 选择 “Cancel” ，退出。 

 

图 3-23: Animation Window 和 Animation Controls 对话框。 

控制动画窗口（Controlling the Animation Window） 
一旦动画被激活，被选择的每个波段自动地构造子集、二次采样，并导入到动画窗口。当每幅

图像被处理时，出现一个状态栏。 

·  通过点击状态窗口内的 “Cancel” 按钮，在任何时候取消动画进程。 

一旦所有已选择的图像全部被导入，动画将自动地启动。每个被选择的波段将按先后顺序显示。

当每一帧被显示时，“Frame Number” 发生变化。一旦导入完成，你可以指定动画的特性。 

1. 在 Animation Controls 对话框内，从以下适当的步骤中选择，来设置特性。 

·  要设置动画速度，使用标签为 “Animation Speed” 的滑动条，来选择从 0 到 100 的速度。 

·  点击 “Update On/Off ” 按钮，关闭和开启实时的 “Frame Number” 滑动条。 

·  要提供最大的动画性能，切换 “Update On/Off ”按钮，并设置动画速度为 100 。这将实时的 
“Frame Number” 滑动条切换为关闭。 
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·  要从最高帧到最低帧显示动画，点击 “<-” 按钮。 

·  要从最低帧到最高帧显示动画，点击 “->” 按钮。 

·  要允许动画从低帧到高帧再返回按顺序地进行，选择 “>-<” 按钮。 

·  要暂停动画，选择 “--” 按钮。 

2. 点击 “Cancel” 来结束动画。 

2-D 散点图（2-D Scatter Plots） 

该功能提供图像数据两个波段的交互式分类。若有必要，多个散点图可以同时被激活。2-D Scatter 
Plots 只使用主图像窗口中的数据，因此提供了快速的交互式应答。在散点图中可以选择感兴趣区，
并保存用于其它的全波段处理方法中。跳动的像元（Dancing Pixels）显示出方框在散点图和图像交
互式地移动时，方框下的像元分布如何变化。散点图的密度分布也可以被显示。 

 

图 3-24: Scatter Plot Band Choice 对话框。 

要在散点图和图象中的空间分布方面，比较两个选择波段的 DNs，按照以下几节的步骤进行（To 
compare the DNs in two selected bands as both a scatter plot and in terms of their spatial distribution in the 
image， proceed with the steps in the following sections.）. 

波段选择（Band Selection） 
1. 在主图像窗口，选择 Functions > Interactive Analysis > 2-D Scatter Plots. 

2. 当出现 Scatter Plot Band Choice 对话框时，通过在标签为 “Choose Band X:” 和 “Choose 
Band Y:” 的栏中点击所需要的波段，来选择散点图的 X 和 Y 轴（图 3-24）。 

3. 点击 “OK” ，从所选择的两个波段中提取二维散点图。 

视图像大小的情况而定，当 DN 值被提取和制成表格时，可能有一段简短的延迟。散点图一出
现，交互式的散点图功能就可以有效地使用。 

像素分布分析（Image Dancing Pixels） 
Image Dancing Pixels 提供一种交互式浏览方式，即浏览散点图中绘制的图像窗口内方框下的点
分布。当光标移动，图像上的相应像元的空间分布也相应地发生变化。 

 

图 3-25: 选择像元以突出显示在图像窗口（左），以及显示在图表窗口中的 “Dancing Pixels”
（右）。 

1. 在散点图内部的任何位置放置光标，然后点击鼠标中键，在散点图上绘制一个彩色的方框（图 
3-25）。 

同时，介于散点图方框中选择的 DN 范围内的图像上所有像元，在主图像窗口用彩色绘制。 

2. 当在散点图中移动光标时，按住鼠标中键，使实时的 “Dancing Pixels” 显示在主图像窗口。 

散点图Dancing像元（Scatter Plot Dancing Pixels） 
Scatter Plot Dancing Pixels 显示了散点图中位于图像窗口方框下的像元分布。 
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1. 在主图像窗口内部的任何一处放置光标，当散点图被显示时，点击鼠标左键，在散点图上用
彩色标记像元。 

这表明了落在与散点图中用到的一样大小的一个空间框中的像元的 DN 分布（见第 240 页的 
“Set Patch Size”）。由于速度因素，该方框没有绘制在主图像显示上。 

2. 当在主图像窗口中移动光标时，按住鼠标中键，把这些像元作为跳动像元实时地显示在散点
图中（图 3-25）。 

显示散点图密度分布（Displaying the Scatter Plot Density Distribution） 
许多图像的像元可以在各波段内有相同的 DN 值，这将在散点图中位于同一位置。散点图密度

分布通过使用彩条颜色表，从紫色到红色来进行彩色编码，其中紫色代表低密度。 

·  要显示散点图的密度分布，在散点图窗口内部点击鼠标右键。 

注意 
若有一个 Z 剖面图与散点图相关联，那么通过在散点图轴的外面点击鼠标右键，密度分布被显

示。 

在散点图上抽取 ROIs（Drawing ROIs on the Scatter Plot） 
可以在散点图中抽取感兴趣区，提供交互式的分类方法。 

·  要在散点图中抽取一个感兴趣区： 

1. 在散点图上，用鼠标左键点击包围所需要区域的多边形的顶点。 

2. 使用鼠标右键，闭合多边形并完成选择。 

当该区域被闭合时，散点图中所选择的 DN 范围内的图像中像元用彩色突出显示在主图像窗口
中。 

·  要在散点图中抽取多个感兴趣区或类型： 

1. 选择 Class > 从选项列表中选择另一种颜色。 

·  通过在白色多边形内取消选择感兴趣区的任何部分，使用白色类型来编辑当前类型。 

·  在散点图轴的外面点击鼠标中键，完全删除所选择的类型多边形。 

File 下拉菜单 

你可以使用散点图菜单栏上的 File 下拉菜单，选择控制 2-D 散点图的输入和输出功能。选项
包括输出散点图、导入保存的感兴趣区，以及取消散点图功能。 

输出图（Output Plot） 
·  要把散点图提供到标准的 ENVI 输出，选择 File > Output Plot. 

散点图窗口可以另存为 PostScript 输出、image 文件（RGB 二进制文件）、BMP、GIF、HDF、
JPEG、PICT、SRF、TIFF 和 XWD 输出（有关细节，请见第 310 页的 “Display Output Options”）。 

导入 ROIs（Import ROIs） 
要把原先保存的感兴趣区导入到散点图功能： 

1. 选择 File > Import ROIs. 
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2. 当出现 Import ROIs to Scatter Plot 对话框时，从现有的感兴趣区列表中选择。 

被选择的感兴趣区将绘制在图像窗口中，相应的点突出显示在散点图中。在同一散点图区

域内的其它像元将突出显示在图像窗口中。 

Class 下拉菜单 

Class 下拉菜单允许你更改散点图突出显示的颜色。通过为每种类型选择一种新颜色，定义多
个感兴趣区或类型。当前选择的类型对应于 Class 下拉菜单中选择的颜色。 

Options 下拉菜单 

你可以使用散点图菜单栏上的 Options 下拉菜单，选择那些控制 2-D 散点图操作的功能。选
项包括控制图像模式，清除和导出类型，计算平均波谱，链接散点图和一个 Z 剖面图窗口，更改用
于提取跳动像元的斑点大小，以及更改波段选择。 

图象 Dance（Image Dance） 
如上面的 “Scatter Plot Dancing Pixels” 一节所述，你可以链接鼠标在图像窗口内的移动，把相
应的像元作为“跳动像元”用所选择的斑点大小同时绘制在散点图中。 

·  选择 Options > Image Dance. 

图象 ROI（Image ROI） 
Image ROI 选项允许你通过使用第 206 页 “ROI Types” 描述的标准多边形感兴趣区步骤，在图
像窗口内绘制感兴趣区。感兴趣区的像元突出显示在散点图中，具有两个所选择波段相似波谱特征

的所有像元，作为一个覆盖图用彩色绘制在显示图像上。 

·  选择 Options > Image ROI. 

关闭（Off） 
·  要在图像窗口内关闭散点图鼠标按键功能，然后返回到它们标准的功能，选择 Options > Off. 

清除分类（Clearing Classes） 
·  对于所选择的类型颜色，要从散点图和图像窗口删除感兴趣区以及相应图像窗口突出显示的
像元，选择 Options > Clear Class. 

·  对于所有类型，要从散点图和图像窗口删除所有感兴趣区和相应图像窗口突出显示的像元，
选择 Options > Clear All. 

导出分类（Exporting Classes） 
对于所选择的类型颜色或所有类型，Exporting Classes 选项将允许你把突出显示的图像窗口像

元导出到一个标准的 ENVI 感兴趣区，以便在其它 ENVI 功能中使用。 

·  要导出一个所选择的类型，选择 Options > Export Class. 

若 ROI Controls 窗口显示在屏幕上，该区域将作为一个 “Scatter Plot Import” 被列出。区域中
的类型颜色和像元数也被列出。 

即使当 ROI Controls 窗口没有显示在屏幕上，该感兴趣区仍保留在内存中。当下一次启动时，
Scatter Plot Import 区域将列在感兴趣区窗口中。 
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·  要导出所有类型的突出显示的图像窗口像元，选择 Options > Export All. 

类平均（Class Means） 
对于所选择的类型或所有定义的类型，要计算平均波谱： 

1. 选择 Options > Mean Class or Options > Mean All. 

2. 当出现 Input File Associated with 2-D Scatter Plot 对话框时，选择相应的输入文件。 

平均波谱将被计算并显示在一个图表窗口中。若一个与散点图对应的 Z Profile 窗口被打开，同
样的数据将被用来计算平均波谱。 

Z剖面（Z Profile） 
要把一个 Z Profile 窗口（波谱图）和散点图相关联： 

1.选择 Options > Z Profile. 

2. 当出现 Input File Associated with 2-D Scatter Plot 对话框时，选择相应的输入文件。 

3. 在散点图内部点击鼠标右键，显示离光标最近的像元的波谱。 

关于使用 Z Profiles 的细节，请参阅第 159 页的 “Image Spectral Plots （Z Profiles）”。 

设置斑块大小（Set Patch Size） 
该选项允许你更改 “Patch Size”，它是用于图像和散点图内的“跳动像元” 选项的方框的大小。 

1. 选择 Options > Set Patch Size. 

2. 当出现 Scatter Plot Patch Size 对话框时，输入像元数用于斑块大小（一个正方形框），或使
用增量按钮来设置所需要的大小。 

例如，在图像中或散点图中，一个 “10” 斑块大小是指一个 10×10 像元的方框。 

改变波段（Change Bands） 
该选项允许你更改散点图中使用的斑点，以及在新的散点图中绘制原先定义的类型。相应的图

像窗口相应将被突出显示。 

1. 选择 Options >Change Bands. 

2. 当出现 Scatter Plot Band Choice 对话框时，通过按照上面的 “Band Selection” 一节所述点击
所需要的波段，为散点图选择新的 X 和 Y 轴。 

3-D 曲面图（3-D Surface Plots and Image Draping） 

你可以创建一个当前显示图像的三维表面图。这个 3-D 表面图可以用丝网（wire mesh）、灰阶
斜面（grayscale ramp）或其它灰阶图像等形式覆盖在 3-D 图上。这个 3-D 图可以输出到文件。 

提示 

通过使用 ENVI 的 3-D SurfaceView 功能，你可以对你的 3-D 数据进行飞行分析（fly-through）
（见第 347 页的 “3-D SurfaceView”）。 

1. 在主图像窗口中，选择 Functions > Interactive Analysis > 3-D Surface Plots. 
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提示 

通过使用标准的  ENVI 空间构造子集，在绘制前选择一个空间子集（见第  145 页的 
“Standardized ENVI Spatial Subsetting”）。 

2. 点击 “OK”。 

出现一个图表窗口，它显示当前显示图像的一个透视图。 

3. 点击 “OK” ，绘制 3-D 表面图。 

系统默认的设置是用没有边缘的丝网绘制表面（见 图 3-26）。一个菜单栏位于表面图窗口的顶
部，并提供控制表面图的参数。每个菜单选项描述如下。 

注意 
由于速度因素，当绘制 3-D 表面时，一个系统默认的缩放系数 0.1 被使用。通过使用 Edit > 

Plot Parameters 对话框，缩放系数可以被更改（见下）。 

 

图 3-26: 系统默认的表面图：没有边缘的丝网。 

File 下拉菜单 
你可以从 Surface Plot 窗口内的 File 中进行下列选择： 

·  要关闭窗口，选择 File > Cancel. 

·  要把文件输出到 Postscript、image 文件，或直接到打印机，选择 File > Output Plot. （有关
细节，请参见第 310 页的 “Display Output Options”）。 

Edit 下拉菜单 
通过使用 Edit 下拉菜单选项，你可以设置你的 3-D 表面图参数。 

1. 选择 Edit > Plot Parameters. 

2. 当出现 Surface Parameters 对话框时（图 3-27），按照以下步骤设置你所需要的参数。 

·  根据你的意愿，确定参数的更改是立即被应用，还是仅当 “Apply” 按钮被选择时应用。点击
对话框右下角 “Auto Apply” 按钮旁的 “Yes” 或 “No”。 

 

图 3-27: Surface Parameters 对话框。 

·  若选择 “Yes” 按钮，那么当每个参数发生变化时，表面图自动地更新。若 选择“No”，完成
所有的更改，然后通过点击 “Apply”，手动地应用它们。 

·  表面图的大多数参数与先前描述的图像剖面图的那些相同（见第  172 页的  “Plot 
Parameters”）。然而，注意对于表面图，为了操作表面添加了第三个轴––––Z 轴，并添加了 “AX” 和 
“AZ” 文本框，来控制透视图的视角。按照下列步骤来设置视角： 

A. 切换 “X” 切换按钮旁的箭头，指定 X 轴的旋转角，按度数朝向观察者。 

有效的 AX 值是大于 0 度且小于 90 度，并朝向观察者倾斜表面。 

B. 切换 “Z” 切换按钮旁的箭头，指定 Z 轴的逆时针方向旋转角的度数。 
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有效的 AZ 值是大于 0 度且小于 360 度，并控制观察方向。 

·  要再抽样栅格，在标签为 “Surface Resize” 的文本框中输入缩放系数。 

缩放系数为 1 ，指所有栅格单元都被用来绘图。较小的缩放系数对图像进行重采样，例如 0.1
（系统默认的） 的缩放系数导致使用十分之一的栅格单元来绘图。 

·  要控制显示的最小和最大 Z 值，在 Surface Parameters 窗口底部适当的文本框内输入所需要
的值。 

·  Surface Parameters 窗口也用于控制表面图的轴和布局特征。 

A. 切换“X-Axis”、“Y-Axis” 或 “Z-Axis” 切换按钮，选择要进行操作的轴。 

B. 在标签为 “Axis Title” 的文本框中输入轴的标题。 

C. 通过从下列步骤中选择，更改前景（轴和标签） 和背景颜色，X、Y 和 Z 轴特征，轴的宽
度，以及数据范围。 

·  要更改宽度，在 “Thick” 文本框中输入数值。 

·  要把整个数据范围的最小值和最大值恰好放置在轴的端点，选择标签为 “Exact” 的 Style 复
选框。 

·  要从轴的端点些微地偏移最大和最小值，选择 Style “Extend” 复选框。 

·  要关闭所有被选择的轴，选择 Style “Off ”复选框。 

·  要关闭顶部的 X 轴或右边的 Y 轴，点击 Style “No Box” 复选框。 

·  要改变轴显示的数据范围，在标签为 “Range” 和 “To” 的文本框中分别输入最小值和最大
值，然后按回车键。 

·  要在轴的内部绘制刻度线，点击 Tick Style “In” 。 

·  要在轴的外部绘制刻度线，点击 Tick Style “Out”。 

·  要从每个刻度线位置创建一个连续线段的网格来横越整幅图，点击 Tick Style “Grid”。 

·  要关闭所有的刻度线，点击 Tick Style “Off ”。 

D. 当刻度线出现时，通过在标签为 “Len” 的参数框输入 0 到 0.5 之间的一个值，并在 
“Minor” 文本框中输入次刻度线的数目，来改变它们的分布和外形。 

该长度用标准化为 1.0 的轴长度的一个比率来衡量。例如，0.02 的长度值导致刻度线的长度为
整个轴长度的 2% 。0.5 的长度值导致线段横越图表的 50%，并在图表中间会合（等价于 grid 选
项）。 

E. 选择标签 “Tick Marks” 附近的 “Auto” 或 “Fixed”。 

“Auto” 选项把预先定义的主、次刻度线放置在轴上。主刻度线被标注。“Fixed” 选项允许你输
入轴的参数。它包括主刻度线的起点和终点，主刻度间的刻度增量，以及主刻度间的次刻度数。 

F. 在标签为 “Min Val” 和 “Max Val” 的文本框中输入数值，为绘图设置参数的最小值和最大值
及 “Z” 截止值。 

设置这些值允许你忽略数据中的坏点。 

3. 当所有的参数被设置为所需要的值，点击 “Cancel” ，关闭 Surface Parameters 窗口。 
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Surface 下拉菜单 
使用 Surface 下拉菜单，更改表面图的类型。 

·  要从丝网图选项中选择： 

1. 从 Surface Plot 窗口内，选择 Surface > Wire Mesh. 

2. 选择一种绘制类型：Plain wire mesh w/skirt，Plain wire mesh w/o skirt，Scaled wire mesh w/skirt， 
或 Scaled wire mesh w/o skirt. 

·  要在表面覆盖任何相互配准的已显示的图像： 

1. 选择 Surface > Shaded Surface. 

若可利用一幅以上的这种特征，将出现 “Overlay Image and Surface” 对话框。 

2. 选择所需要的图像进行覆盖。 

该图像必须与表面有相同的空间大小，并且现在显示在一个当前主图像窗口中。这包括 “Plain” 
晕渲表面（在框架上用灰阶覆盖） 和使用另一幅图像作为一个覆盖在框架上的覆盖图的表面（见 图 
3-28 的例子）。若没有其它图像被显示，表面将使用当前显示的值来自动地晕渲。 

 

图 3-28: 绘图显示选项：带有边缘的丝网（上），覆盖的图像（下）。 

Options 下拉菜单 
在 Surface Plot 窗口的其它有效选项包括注记和构造空间子集。这些选项在 Options 下拉菜单
下可以得到。 

这两个选项都使用标准的 ENVI 功能（要获得详细的向导，请参见第 250 页的 “Annotation” 
和第 145 页的 “Standardized ENVI Spatial Subsetting”）。 

极化信号（Polarization Signatures） 

要从 quad-polarized 雷达数据（AIRSAR 和 SIR-C）的当前像元提取和显示极化信号： 

1. 从主图像窗口内，选择 Functions > Interactive Analysis > Polarization Signatures. > AIRSAR 或 
SIR-C. 

雷达数据不必被显示。任何相互配准的影像数据集都可用于像元定位。 

 

图 3-29: 当前像元的极化信号。 

2. 当出现 Input Stokes Matrix Files 对话框或 Input Scattering Matrix Files 对话框时，点击 
“Open File”，选择并打开适当的雷达数据文件。 

3. 点击 “OK”。 

4. 出现 Polarization Signature Viewer时，选择 Options > Extract Current Pixel，绘制当前像元的
极化信号。 

关于该浏览器的使用，在本手册的雷达章节有详细的描述（参见第 744 页的 “Mingle-Pixel 
Polarization Signatures for the Current Pixel” 和第 747 页的 “The Polarization Signature Viewer”）。 

Administrator
极化信号（Polarization Signatures）
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叠加（Overlays） 
要在一幅图像上叠置注记（文本、多边形、符号等）、像元和地图网格、等高线或矢量层，选择 

Functions > Overlays > 主图像窗口中所需要的功能。 

 

图 3-30: 一个 ENVI 显示组中的注记例子。 

注记（Annotation） 
ENVI 的注记功能允许用文本、符号、多边形、线（折线）、形状、地图信息及灰阶或彩色条纹

等来灵活的注记图像和图表。可以添加 Class keys，对图像分类。除了使用只在注记图像中有效的 
“Virtual Borders” 之外，注记的选项与图像、绘图或表面绘图的选项相似。你可以把注记保存到文件，
以及在输出选项中包括它们。 

注意 
在进行注记之前，应意识到： 

注记可以放置在图像中或虚拟边框中。通过从 Annotation 对话框内的 Options 菜单选择 Set 
Display Borders，虚拟边框也可以被添加到图像。 

·  要在注记前把一个虚拟边框附加到正被显示的图像上： 

1. 通过选择 Options > Set Display Borders，在 Available Bands 列表中输入边框值（见第 101 页
的 “The Options Pulldown Menu”）。 

2. 输入非零值，然后点击 “Load Band” 或 “Load RGB” 按钮，用指定的虚拟边框来重新导入
图像。 

注记 – 通用（Annotation – General） 
·  要对一幅图像加注记： 

1. 从主图像窗口内，选择 Functions > Overlays > Annotation. 

注记可以被放置在主图像窗口、滚动窗口或缩放窗口。通过从各自的 Options 菜单中选择 
Annotation，每种图表，包括 X、Y、Z 剖面图或表面图，可以被注记。 

2. 当出现 #n Annotation 对话框时（其中 “#n” 指正被注记的那个显示），选择 Object > 所需
要的注记的对象。 

注意 
该对话框最初是以文本注记模式启动的。通过下拉菜单在现有的注记选项中更改，选择一个不

同的对象。 

3. 在对话框内，按照这些步骤： 

·  要在主图像窗口、滚动窗口或缩放窗口内放置注记，在对话框的顶部选择适当的切换按钮。 

一旦选定后，在所选择的窗口内，其它所有的操作是无效的（在其它窗口内的常规鼠标操作是

有效的）。通过选择 “Off ” 切换按钮，注记可以被临时地暂停。在这种情况下，在所有窗口内的所
有常规鼠标操作又是有效的。所有注记对象都有一个小的彩色菱形 “handle”，它被用来决定位置。 

Administrator
叠加（Overlays）

Administrator
要在一幅图像上叠置注记（文本、多边形、符号等）、像元和地图网格、等高线或矢量层，选择
Functions > Overlays > 主图像窗口中所需要的功能。
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·  要把注记放置在所选择的图像窗口位置，无论文本还是其它图像对象，都按照 表 3-5 中概
括的标准步骤： 

操作 鼠标

按键 
交互 位置 

放置当前的注记 左 点击并释放 在所需要的位置 

移动当前的注记 左 点击，按住并拖曳

手柄 
整幅图像 

删除当前的注记 中 点击并释放 图像内任何位置 

“固定”当前注记并

进行下一个注记操作 
右 点击并释放 图像内任何位置 

准备重新选择固定注

记 
左 点击并把菜单往下

拉 
Object 菜单下的

Selection 选项 

重新选择注记 左 点击并拖曳来绘制

方框 
在注记对象周围 

暂停注记（所有常规

功能有效） 
左 点击 Off 切换按钮 

继续注记 左 点击 Image 、 Scroll 或
Zoom 切换按钮 

表 3-5: 注记的鼠标按键分配。 

 

一旦是激活的，可以使用以下几节描述的相应功能更改注记属性。 

注意 
Annotation 对话框顶部的文本框描述了当前注记模式下的鼠标按键功能。MB1 是鼠标左键，

MB2 是鼠标中键，MB3 是鼠标右键。 

·  要更改 snap factor，使用增量箭头，或在对话框右上角标签为 “Snap” 的文本小部件内手动
地输入所需要的值，然后按回车键。 

A “Snap”系数允许放置成行的文本和其它注记。snap factor causes any annotation located within the 
specified snap distance （in pixels） to snap to the same pixel location。一个默认的 snap 系数使得注
记恰好放置在选择的位置上。 

·  一旦注记被放置，要把它深印于一幅图像： 

1. 选择 “Off ” 切换按钮。 

2. 从主图像窗口内，选择  Functions > Output Display （见第  310 页的  “Display Output 
Options”）。 

注记 - File 下拉菜单 

File 下拉菜单提供的功能可以保存和恢复注记文件。 

·  要保存注记文件： 
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1. 选择 File > Save Annotation. 

2. 当出现新的对话框时，在文本框中键入输出文件名，或点击 “Choose”，然后当出现 ENVI 文
件选择对话框时后，输入一个文件名。 

3. 选择 “OK” ，把注记保存到一个输出文件。 

为了保持一致，注记文件应当用文件扩展名 .ann 保存，但也可以自行决定使用其它的扩展名
保存。 

 

图 3-31: Annotation 对话框。 

·  要 recall 一个存储的注记文件: 

1. 选择 File > Restore Annotation. 

2. 当出现文件选择窗口时，系统自动列出所有 .ann 文件，选择适当的注记文件。 

ENVI 导入并显示所选择的文件。 

·  要改变注记对话框，并从显示中删除所有注记对象，选择 File > Cancel. 

若该注记原先没有保存，一个 ENVI 询问对话框将出现，询问你是否想保存该文件。 

注记 - Object 下拉菜单 

Object 下拉菜单选项允许你选择对象类型。可以用文本、符号、形状、地图信息和颜色斜面（color 
ramp）来注记对象。每种对象有它自己的注记选项，更多细节描述如下。 

文本注记（Text Annotation） 
要把文本注记添加到一幅图像： 

1. 从 Annotation 对话框内，选择 Object > Text. 

2. 通过在窗口底部的文本框内键入，来输入文本。 

一次可以输入一行以上的文本。 

3. 通过在所需要的位置点击鼠标左键，来放置文本（见 表 3-5）。 

4. 通过选择以下特定选项，以更改特征。 

·  要更改文本颜色，点击 “Color” 按钮菜单，然后选择所需要的颜色。 

·  要把文本放置在实心的彩色背景上，使用 “Back” 按钮菜单选择一种颜色；要把文本直接放
置在图像上而不用背景，选择 “Off ”。 

·  要调整文本宽度，在 “Thick” 文本框中输入一个新宽度，或使用增量箭头来更改 “Thick” 参
数框内的值。 

·  要更改文本字体，点击 “Font” 按钮菜单，然后选择一种字体。 

·  要更改文本的大小（按像元），在 “Size” 参数框中更改数值，或使用箭头增量按钮。 

·  要更改屏幕上的文本方向（书写的角度），在 “Orien” 参数框中输入角度的度数值（相对于
水平线（ 0 度）逆时针方向），或切换箭头增量按钮。 
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·  要居中或者左对齐、右对齐文本，在 “Align” 按钮菜单下选择适当的选项。 

5. 一旦完成文本的样式后，按鼠标右键，确定文本的位置和特征。 

符号注记（Symbol Annotation） 
Symbol 选项允许符号的注记。符号特征与上述 “Text” 的那些可用特征相同，当选择 Symbol 
时，通过与 Annotation 对话框内显示的特定选项交互，可以被改变这些特征。 

可用的选项包括颜色、背景颜色、宽度、字体、大小和方向。要添加符号注记： 

1. 从 Annotation 对话框内，选择 Object > Symbol. 

可用的符号用对话框底部窗口内所选择的字体显示。通过使用 Symbol 选项，也可以选择文本
字体内的每个字符。 

2. 从 “Font” 菜单中，选择所需要的字体或符号。 

标签为 “Misc”、“Special” 和 “Math” 的字体显示一些 IDL 中有效的标准符号。 

3. 在所需要的符号上，点击鼠标左键。 

当符号被选择，将用红色突出显示。 

4. 放置符号注记，请按照上述步骤（表 3-5）。 

多边形注记（Polygon Annotation） 
Polygon 菜单选项允许你绘制形状不规则的多边形。 

1. 从 Annotation 对话框内，选择 Object > Polygon. 

2. 从下列方法中选择，以绘制多边形。 

·  使用鼠标左键（见 表 3-6），设置多边形的顶点。 

在所选择的点之间绘制线段（多边形的边）。 

·  你也可以通过在绘制时按住鼠标左键，绘制多边形。 

·  要删除上一次画的线段，点击鼠标中键。 

·  要闭合多边形，按鼠标右键，将出现一个手柄（一个小菱形）。 

3. 一旦一个多边形被绘制完并且闭合，参考 表 3-6放置位置、固定和删除多边形。 

4. 对于 Annotation 对话框中特定的选项，按照下列向导，更改或调整多边形的属性。 

·  要更改多边形的颜色，从 “Color” 菜单中选择。 

·  要更改多边形边界的宽度（和填充，若线型填充被选择），在 “Thick” 参数框中输入一个值。 

 

操作 鼠标按键 交互 位置 

选择多边形顶点 左 点击并释放 在所需要的位置 

删除多边形顶点（绘制

时） 
中 点击并释放 按先后顺序删除上

一条线段 

闭合多边形 右 点击并释放 选择最后一条线段

来闭合多边形 
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放置完成的多边形 左 点击并拖曳 在手柄上 

移动多边形顶点 左 点击并拖曳 顶点附近或顶点上 

删除多边形 中 点击并释放 图像内任何位置 

“固定”当前注记 右 点击并释放 图像内任何位置 

表 3-6: 多边形注记 

·  要设置填充属性和填充形状，点击 “Fill” 菜单。 

·  当选择 “None:”时，多边形不被填充。 

·  当选择 “Solid” 时，用多边形的颜色填充多边形。 

·  当选择 “line”、“dashed”、“dotted” 被时，多边形用相同间距的线条填充。 

·  要更改填充线条的方向，在 “Orien” 参数框中输入角度的度数值（相对于水平线（ 0 度）
逆时针方向）。 

·  要更改线条的间距，在 “Spc” 参数框中输入一个值。 

·  要更改边框的线条类型（实线、虚线、点线等），点击 “Line Style” 菜单，然后选择所需要
的类型。 

·  要更改屏幕上多边形的方向，在 “Rotation” 参数框中，输入要显示的多边形相对于水平线（ 0 
度）的角度度数（逆时针方向）。 

当更改完后，“Rotation” 值总是重新设置为 0 。 

5. 一旦完成多边形的样式后，按鼠标右键，确定多边形的位置和特征。 

折线注记（Polyline Annotation） 
Polyline 允许你绘制形状不规则的线条。 

1. 从 Annotation 对话框内，选择 Object > Polyline. 

2. 按照与多边形同样的方式绘制折线（见上）。 

3. 参照 表 3-6放置折线。 

4. 按照与多边形同样的样式更改折线的属性（见上）。 

颜色、线条类型、宽度和旋转选项是可用的。 

注意 
鼠标右键用来指示线条的完成，但没有把线段闭合为一个多边形。 

形状注记（Shape Annotation） 
Rectangle 或 Ellipse 选项允许用几何形状来注记。 

1. 从 Annotation 对话框内，选择 Object > Rectangle or Ellipse. 

2. 用鼠标左键点击并拖曳，绘制形状。 

·  要绘制一个圆，绘制椭圆时按住 “Ctrl” 键。 

·  要绘制一个正方形，绘制矩形时按住键盘上的 “Ctrl” 键。 
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·  要设置或更改形状的大小，点住一个角、一条边或一条轴的端点（椭圆），当拖曳到所需要
的大小时，按住鼠标左键。 

通过在标签为 “Xsize:” 和 “Ysize:” 的文本框中输入所需要的 X 和 Y 大小（按像元），可以
明确地更改大小。 

·  要删除形状，按鼠标中键。 

·  要固定对象，按照上面的 表 3-6 所述，按鼠标右键。 

3. 按照与多边形同样的方式，更改形状的其它属性（见上）。 

箭头注记（Arrow Annotation） 
Arrow 选项允许你绘制箭头。 

1. 从 Annotation 对话框内，选择 Object > Arrow. 

2. 从下列步骤中选择，绘制箭头。 

·  要绘制一个箭头，用鼠标左键点击并拖曳。 

·  要更改为所需要的大小和方向，点住一端，当拖曳到所需要的大小时，按住鼠标左键。 

通过在 “Head Size” 参数框中输入所需要的值，也可以更改箭头尖的大小。 

·  要删除箭头，按鼠标中键。 

·  要控制定义箭头尖的线段的角度（按度数），在 “Head Angle” 参数框中输入一个值。 

输入较小的角度产生一个较窄的箭头尖，较大的角度产生一个较宽的箭头尖。 

3. 按照与多边形同样的样式，更改箭头的其它属性（见上）。 

4. 一旦完成箭头的样式后，按鼠标右键，确定箭头的位置和特征。 

缩放条注记（Scale Bar Annotation） 
Scale Bar 选项允许你在图像上放置比例尺。比例尺可以用四种单位的任何组合来绘制：千米；

英里；米；英尺。 

1. 从 Annotation 对话框，选择 Object > Scale Bar. 

·  若数据没有地理坐标定位，Image Pixel Size 对话框提示你图像像元大小（米），输入一个值。 

2. 从下列步骤和选项中选择，以放置和更改比例尺。 

·  要在图像内放置比例尺，按鼠标左键。 

·  要删除比例尺，按鼠标中键。 

·  要选择绘制比例尺的单位，当所需要的单位显示在 “Scale” 下拉文本框中，设置箭头切换按
钮为 “On”。 

当一个以上的单位类型被设置为 “On”， 将绘制多个比例尺。 

·  要设置比例尺的高度（按像元），在 “Height” 参数框中输入所需要的值。 

·  要更改比例尺长度，按比例尺的单位，在 “Length” 参数框中输入所需要的长度。 

·  要更改显示在比例尺上的增量值，在 “Inc” 参数框中输入数值，在 “Sub Inc” 参数框中输入
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第一个主增量内的次增量值。 

长度、增量和次增量参数为每种类型的比例尺单独地设置样式。 

 

图 3-32: 一个比例尺注记。 

3. 按照与文本注记同样的样式，设置比例尺的文本属性（参见第 254 页的 “Text Annotation”）。 

4. 一旦完成比例尺的样式后，按鼠标右键，确定比例尺的位置和特征。 

彩色灰阶 和 单色灰阶 注记 
Color Ramp 选项允许你在图像上放置一个 “wedge” 或 “color 表”，以表示当前应用的 ENVI 

颜色表。对于一幅灰阶图像，颜色灰阶（color ramp） 只是一个从最小灰度值到最大灰度值的灰阶
楔形物。对于一幅彩色图像，颜色斜面显示所选择的彩色调色板的分布状态。 

1. 从 Annotation 对话框内，选择 Object > Color Ramp. 

2. 从下列步骤和选项中选择，以放置颜色斜面。 

·  要放置颜色斜面，在所需要的位置点击鼠标左键。 

·  要删除颜色斜面，按鼠标中键。 

·  要水平地或垂直地定位颜色斜面，通过点击最初标签为 “Hor ->” 的下拉菜单，选择下列
之一。 

·  对于水平方向，从低到高，选择 “Hor ->”（从左到右水平地从低值到高值），或从高到低，
选择 “Hor <-”（从左到右水平地从高值到低值）。 

·  对于垂直的选项，选择 “Ver <-”（从低部到顶部垂直地从高到低），或 “Ver ->”（从低
部到顶部垂直地从低到高）。 

 

图 3-33: 一个灰阶的颜色斜面注记。 

3. 通过选择下列适当的选项，更改颜色斜面的特征。 

·  要定义表的宽度和长度，在标签为 “Width” 和 “Len” 的参数框中输入所需要的值。 

·  要在颜色斜面上放置标签，在 “Min” 和 “Max” 参数框中输入最小值和最大值。 

·  要定义标签的增量（值）来放置在颜色斜面上，在 “Inc” 参数框中输入数值。 

·  要设置标签的精度（值的有效数字），在 “Precision” 参数框中输入数值。例如， .25 的
精度为 2 ，.3 的精度为 1 。 

标签放置在水平颜色斜面的底部，放置在垂直颜色斜面的右边，它们的属性可以按照与文

本注记同样的样式来更改。 

4.  一旦完成颜色斜面的位置和样式后，按鼠标右键来确定。 

Map Key，Class Key，和 Vector Key 注记 
A map key 由每幅地图的彩色方框和相应标签或分类图象中的类组成。Map keys可以交互式被
限定，象分类图象的 class keys 一样被自动建立。Vector keys被自动用合适的颜色创建，层名作为
标签。Vector keys显示点用到的矢量符号、折线用到的线以及多边形用到的方形轮廓。 
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图 3-34: The Edit Map Key Dialog. 

1. 从 Annotation 对话框内，选择 Object > Map Key. 

2. 在所需要的位置点击鼠标左键，来放置 map key. 

·  要删除 map key，按鼠标中键。 

3. 点击 “Edit Map Key Items” ，定义或更改 map key 中的选项。 

4. 当出现 Map Key Object Definition 对话框时，从 Key 选项列表中选择。 

·  要添加其它的选项到列表中，点击 “Add Item”。 

·  要删除一项，在列表中选择它，然后点击 “Delete Item”。 

·  要更改选项名，在 “Object Name” 文本框中，输入所需要的名称。 

·  要定义框的颜色，使用 “Color” 菜单选择所需要的颜色。 

·  要添加其它的颜色，在分别为红、绿、蓝的 “R”、“G”、“B” 文本框中输入 DN 值。 

新定义的颜色将以黑色显示在图像中，但将正确地被输出。 

·  要更改方框的填充类型，使用 “Fill” 菜单。 

·  要控制填充类型，使用 “Orien” 和 “Spc” 参数框。 

·  对于矢量 keys，一个 “Object Type” 下拉菜单包括多边形、折线和点选项。 

·  对于一个矢量多边形选项，一个 “Fill” 下拉菜单及 “Orien” 和 “Space” 参数框允许选择多
边形填充类型。 

·  对于一个矢量折线选项，一个 “Line Style” 下拉菜单允许选择不同的线条类型。 

·  对于一个矢量点选项，一个 “Symbol” 下拉菜单允许选择被显示在 key 中的符号类型。 

5. 按照这些步骤，来更改 Annotation 对话框内的其它参数。 

·  要设置背景颜色，从 Annotation 对话框中，选择 “Back” 下拉菜单。 

·  要更改 key 的文本字体、字符大小和宽度，在 Annotation 对话框中修改适当的特征（见第 
254 页的 “Text Annotation”）。 

·  关于更改类型颜色的详细向导，请参阅 第 184 页的 “Class Color Mapping”。 

6. 点击 “Save”。 

 

图 3-35: The Vector Key Annotation. 

ENVI 提示你输入一个输出文件名，并把 key 写入到一个文件。为保持一致，Map key 文件应
用扩展名 .key保存，但你也可以自行决定使用其它的扩展名保存。 

·  要恢复原先保存的 map key 文件，点击 “Restore”，然后选择所需要的输入文件。 

偏差图注记（Declination Diagram Annotation） 
Declination 选项允许你在图像上放置一个磁偏角图表。磁偏角图表包括指向真北（True North，
用星号显示）、坐标北（Grid North，GN）和磁北（Magnetic North，MN）的箭头的任意组合。 
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1. 从 Annotation 对话框内，选择 Object > Declination. 

2. 在所需要的位置点击鼠标左键，放置磁偏角图表。 

·  要删除磁偏角图表，按鼠标中键。 

3. 从下列步骤中选择，更改磁偏角图表的属性。 

·  要设置北箭头的角度，在 “True North”、“Grid North” 和 “Magnetic North”文本框中输入度数
值。 

ENVI 中真北通常为 0 度。角度没有按比例绘制，以便可以分开显示箭头。 

·  要设置所需要的箭头长度（像元），使用 “Length” 参数框。 

·  要更改磁偏角图表的颜色，从 “Color” 下拉菜单中选择。 

·  要设置背景颜色，从 “Back” 下拉菜单中选择。 

 

图 3-36: 一个磁偏角图表注记。 

 

·  要更改线条和文本的宽度，在 “Thick” 参数框中输入一个值。 

4. 一旦完成磁偏角图表的样式后，按鼠标右键，确定磁偏角图表的位置和特征。 

图象注记（Image Annotation） 
 Image 选项允许你在当前图像内放置另一幅图像。该选项不是打算做镶嵌（见第 619 页的 

“Image Mosaicking”），而是用于导入 logos 或二次抽样图像。注记需要在内存中保留图像的一个备
份，因此建议不使用大的图像。对于大图像，将出现一个警告消息。 

注意 
图像将作为一个标签为 “Gray Image” 或 “RGB Image”的红色框，按正确的大小显示在注记内。

它将正确地显示在输出上。 

1. 从 Annotation 对话框内，选择 Object > Image. 

·  要删除图像，点击鼠标中键。 

2. 点击 “Select New Image”。 

3. 当出现 Annotation Image Input Bands 对话框时，从对话框内的可利用波段列表中选择一个 
RGB 或灰阶文件。 

当一个文件被选择，“R”、“G”、“B” 文本框将被填写。 

·  要选择一幅灰阶图像，为三个波段点击同一个文件名。 

·  要选择一个空间子集，点击 “Spatial Subset”。 

·  要执行数据的空间重采样，在 “Resize Factor” 文本框内输入一个缩放系数。 

·  要清除“R”、“G”、“B” 文本框内的文件名，点击 “Reset”。 

4. 点击 “OK” ，返回 Annotation 对话框，并放置插入的图像。 



 118

5. 在所需要的位置点击鼠标左键，，放置图像。 

6. 点击鼠标右键，把图像固定在该位置。 

图像将作为一个标签为 “Gray Image” 或 “RGB Image”的红色框，按正确的大小显示在注记内。
按需要放置插入的图像，并将正确的用于输出显示。 

绘图注记（Plot Annotation） 
Plot 选项允许你在图像上覆盖一幅 ENVI 图。When “burned in” to the image，若你把该图表输
出到 postscript 或打印机 ，它将作为矢量保留。 

注意 
若输入到一个图像文件，图表对象将不会显示在图像中。 

1. 选择 Object > Plot. 

2. 点击 “Select New Plot”。 

若只有一个图表窗口是打开的，该图表将自动地被选择。 

3. 当出现 Select Plot 窗口时，在所需要的图表名上点击，选择它。 

若你有多个打开的同名图表窗口，它们将按打开的顺序依次显示。 

·  若有必要，在 Select Plot 窗口内输入或选择 xsize 和 ysize。 

4. 点击 “OK”。 

5. 通过用鼠标左键点击，并拖曳到所需要的位置，然后点击鼠标右键来“固定”注记，从而在
图像上放置图表。 

 

图 3-37: The appearance of an image Annotation. 

注记将作为一个标题为 “Plot”的红色框，按正确的大小显示在图像中，但将正确地显示在输出
中。 

·  要在一页上注记和输出多个图表： 

1. 选择 Utilities > File Utilities > Generate Test Image，然后创建一个空白的图像（更多细节，请
参见第 376 页的 “Generate Test Image”）。 

2. 通过使用标准的注记步骤，在空白的图像上放置图表注记。 

为了输出，图表颜色将自动地反转白色为黑色。 

选择模式（Selection Mode） 
Selection 选项允许移动固定在图像中的注记对象，以及更改它们的属性。 

1. 选择 Object > Selection/Edit. 

2. 选择 Options > Show Object Corners. 

3. 为了重新选择，用鼠标左键点击并拖曳，绘制一个围绕对象的“转角”的方框。 

4. 在手柄上点击鼠标左键，然后把对象拖曳到一个新的位置。 
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5. 通过在 Annotation 内输入新的参数，更改对象的属性。 

·  要一次选择多个对象，用鼠标左键按住并拖曳一个方框，围绕所有需要的对象。 

当一个以上的对象被选择，原先所选择的对象保持活动的。 

当许多对象被选择，使用一个手柄来移动一个对象，将移动所有的对象，更改属性也将更改所

有被选择对象的属性。 

·  要编辑所选择的矢量对象（矩形、椭圆、多边形、折线、箭头），在一个顶点上点击鼠标左
键，然后拖曳到所需要的位置。 

·  要取消选择一个对象，在所需要的对象的手柄上点击鼠标中键。 

·  要取消选择多个对象，用鼠标中键按住并拖曳，绘制一个围绕对象的方框。 

·  要取消选择图像内所有的注记对象，在图像内点击鼠标右键。 

·  要只选择那些对象，并取消选择原先活动的任何对象，用鼠标右键按住并拖曳，来绘制一个
围绕对象的方框。 

Selected 菜单下的其它选项可用于被选择的注记对象（参见第 268 页的 “Annotation - The 
Selected Pulldown Menu”）。 

注记 - Selected 下拉菜单 

Annotation 对话框内 Selected 下拉菜单的选项允许你合并多边形、交换重叠对象的位置，以及
复制或删除注记对象。也可用取消选项。 

合并多边形（Joining Polygons） 
Selected 菜单下的 Join 选项允许你合并两个多边形重叠的部分。 

1. 选择你想合并的两个多边形。 

2. 从 Annotation 对话框内，选择 Selected > Join. 

下面的多边形的顶点将改变，来与那些放在上面的多边形相匹配。 

对于那些有许多顶点的多边形，可以获得更好的效果（例如，按住鼠标左键时绘制的那些）。使

用 Swap 选项（见下），把所需要的多边形放到最上面。 

交换对象（Swap Objects） 
要把下面的对象放在最上面： 

1. 选择所需要的对象。 

2. 选择 Selected > Swap. 

复制和删除对象（Duplicate and Delete Objects） 
你可以复制现有的 Annotation 对象，而不是重新创建它们。 

1. 选择要复制的对象。 

2. 选择 Selected > Duplicate. 

3. 通过用鼠标左键拖曳手柄到所需要的位置，放置复制的对象。 
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删除对象（Delete Objects） 
·  要删除所选择的对象，选择 Selected > Delete. 

·  要删除图像内的所有注记对象，选择 Selected > Delete All. 

取消（Undo） 
·  要取消对一个被选择对象所做的更改，选择 Selected > Undo. 

一旦选择一个新的对象，取消就重新设置，并只取消选择对象后所做的更改。 

全选（Select All） 
·  要选择所有的注记对象，选择 Selected >Select All. 

Annotation - Options 下拉菜单 

Annotation 对话框内的 Options 下拉菜单允许添加一个虚拟边框到图像上，开启和关闭一个注
记的映射能力(mirroring ability)，以及显示或隐藏注记对象的转角。 

设置显示边界（Set Display Borders） 
Set Display Borders 选项允许把一个虚拟的边框附加到图像上。任何注记对象可以放置在该边框

中。 

1. 选择 Options > Display Borders. 

2. 当出现 Display Borders 对话框时，在文本框相应的位置中输入左、上、右和低部图像边框
所需要的边框宽度（按像元）。 

图像将用指定的虚拟边框来重新显示。通过使用可利用波段列表，可以获得同样的效果（参见

第 101 页的 “The Options Pulldown Menu”）。 

影射注记（Mirror Annotation） 
·  要围绕图像的中央“映射”形状和多边形，选择 Options > Turn Mirror On. 

该选项只应用于矩形、椭圆、多边形和折线。它最初被设计用于允许你创建自定义的 FFT（快
速傅里叶变换） 滤波器（参见第 534 页的 “Interactive FFT Filter Definition”）。 

·  要关闭映射，选择 Options > Turn Mirror Off. 

显示对象的拐角（Show Object Corners） 
·  对象的拐角可以围绕所有注记对象显示，除了矢量（矩形、椭圆、多边形、折线和箭头）。
当在 Selection 模式下，要使拐角更容易地包含在选择框中，选择 Options > Show Object Corners. 

对象的拐角用围绕注记对象的小星号绘制。 

·  要隐藏对象的拐角，选择 Options > Hide Object Corners. 

等高线（Contour Lines） 
使用 Contour Lines 选项在一幅图像上覆盖等高线。你可以显示一幅图像，并从该图像或另一
幅不同的图像生成等高线： 

1. 从主图像窗口内，选择 Functions > Overlays > Contour Lines. 

Administrator
等高线（Contour Lines）

Administrator
Set Display Borders 选项允许把一个虚拟的边框附加到图像上。任何注记对象可以放置在该边框

Administrator
中

Administrator
。

Administrator
使用Contour Lines 选项在一幅图像上覆盖等高线。你可以显示一幅图像，并从该图像或另一
幅不同的图像生成等高线：
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2. 当出现 Input Contour Band 对话框时，点击用于生成等高线的波段。 

一旦等高线源图像被定义， #n Contour Plot 对话框出现（其中 “#” 为源显示号）。八个系统默
认的等高层列在 “Defined Contour Levels”.下。这些等高层使用滚动窗口计算的最小和最大数据值来
定义，并显示在 “Min” 和 “Max” 文本框中。按照这些步骤来更改等高线的范围： 

3. 在适当的文本框中，输入所需要的最小和最大值。 

·  要把范围重新设置为初始值，点击 “Reset”。 

4. 在 “Window” 标签附近，选择 “Image” 和/或 “Scroll” 复选框，指定等高线将被绘制的窗口。 

5. 点击 “Apply”，绘制等高线。 

 

图 3-38: 覆盖在一幅 Landsat TM 图像上的 DEM 等高线例子。 

编辑等高线间距（Edit Contour Levels） 

要编辑每个等高线间距（要添加新的层或设置系统默认的层，参见第 275 页的 “The Options 
Pulldown Menu”）： 

1. 从 Contour Plot 对话框内，在 “Defined Contours Levels” 列表中点击一个特定的等高线。 

2. 点击 “Edit Level”。 

3. 通过在 “Level” 文本框中输入所需要的值，更改绘制等高线的值。 

4. 通过在 “Label” 文本框中输入所需要的文本，指定绘制等高线的标签。 

5. 通过选择所需要的参数和更改数值，指定所选择的等高线的颜色、线条类型和宽度。 

6. 点击 “OK” ，更改 “Defined Contour Levels” 列表中的等高层。 

7. 点击 “Apply”，在图像上重新绘制等高线。 

删除层（Delete Level（s）） 

·  要从 “Defined Contours List” 中删除一个等高层： 

1. 点击一个特定的等高层，选择它。 

2. 点击 “Delete Level”。 

3. 点击 “Apply” ，重新绘制等高线。 

·  要从 “Defined Contours List” 中删除所有等高层，点击 “Clear Levels”。 

 

图 3-39: Display Contour Plot 对话框。 

File 下拉菜单 

·  使用 File 菜单保存所定义的等高层，恢复以前保存的层，把等高线导出到 ENVI 矢量文件
（.evf），以及关闭对话框。 
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·  要把当前的等高层和属性列表保存到一个文件： 

1. 从 Contour Plot 对话框，选择 File > Save Levels. 

2. 为了保持一致性，键入一个系统默认的扩展名为 .lev 的输出文件名。 

·  要恢复原先保存的等高层： 

1. 选择 File > Restore Levels. 

2. 当出现标准的 ENVI 文件选择对话框，并列有系统默认扩展名为 .lev 的文件时，选择需要
的文件名。 

·  要把等高线输出到 ENVI 矢量文件（.evf）： 

1. 选择 File > Output Contours to EVFs. 

2. 出现 Output Contours to EVF Parameters 对话框。 

3. 点击 “Separate Layer for each Level” 切换按钮，并选择 “Yes” 或 “No”，来为每个等高层是
否指定一个单独的层。 

4. 选择 “File” 或 “Memory” 输出。 

·  若你选择 “File” 输出，在标签为 “Enter Output Filename:” 的文本框中，键入输出文件名，
或点击 “Choose” 按钮，选择一个文件名。 

5. 点击 “OK”。 

输出的 EVFs 显示在 Available Vectors List 中。 

注意 
若你的文件大于 tile 大小，那么它被二次抽样，以与单个 tile 拟合（见第 793 页的 “Image Tile 

Size”）。例如，若你的图像为 2048×2048 像元，tile 大小被设置为 1 Mb，那么图像被二次抽样为 
1024×1024 像元，等高线被计算，然后输出。因此，EVF 的输出分辨率可以不与等高层相同。 

·  要关闭 Contour Plot 对话框，并从图像中删除等高线，选择 File > Cancel. 

Options 下拉菜单 

Options 下拉菜单选项允许你添加新的等高层，设置系统默认的等高层，以及更改等高线波段。 

·  要添加等高层： 

1. 从 Contour Plot 对话框内，选择 Options > Add New Levels. 

2. 当出现 Add Contour Levels 对话框时，在 “Start Level” 文本框中指定一个值，输入单个等
高线或等高线范围。 

3. 在 “Level Inc” 参数框中输入一个值，指定等高线之间的增值。 

4. 在 “#” 参数框中输入一个值，指定等高线的数目。 

5. 从下列步骤中选择，设置等高线的属性。 

·  要更改宽度，从 “Thick” 菜单中选择。 

·  要更改线条类型，从 “Style” 菜单中选择。 
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·  要更改颜色，从 “Color” 菜单中选择。 

·  点击箭头切换按钮，从“Use same color for each level”（用相同的颜色绘制所有的等高线）到 
“Increment colors for each level”（用不同的颜色绘制每个等高层），更改等高线颜色。等高层的不同
颜色参照图形颜色列表。 

·  要在不添加新的等高线情况下退出，点击 “Cancel”。 

6. 点击 “OK”，把新的等高线输入到 “Defined Contour Levels” 列表中。 

7. 点击 “Apply” ，绘制等高线。 

 

图 3-40: Add Contour Levels 对话框。 

·  要选择一幅新的输入图像绘制等高线。 

1. 选择 Options > New Contour Band. 

2. 当出现标准的 ENVI 文件选择对话框时，选择所需要的文件名，来生成新的等高层。 

·  要输入需要使用的系统默认等高层数目： 

1. 选择 Options > Set Number of Default Levels. 

2. 输入所需要的默认的等高层数。 

·  要把 “Defined Contour Levels” 列表重新设置为由“Min”、“Max” 值以及同一颜色绘制的默
认的层数决定的默认层。 

1. 选择 Options > Apply Default Levels （same color）. 

2. 点击 “Apply” ，绘制等高线。 

·  要把 “Defined Contour Levels” 列表重新设置为由“Min”、“Max” 值以及用多种颜色绘制的
默认层数决定的默认层。 

1. 选择 Options > Apply Default Levels （multi color）. 

2. 点击 “Apply” ，绘制等高线。 

矢量层（Vector Layers） 
ENVI 的 Vector Windows 提供了浏览，诸如 USGS Digital Line Graphs （DLG）、USGS DLGs 空
间数据转换标准格式（SDTS）、DXF 文件、ARC/INFO Interchange 文件和 ArcView Shape 文件等
矢量数据的一种方式。你可以查看、编辑和查询与 ArcView Shape 文件相关的属性，也可以创建你
自己的矢量文件和属性。ENVI 的 Vector Windows 由一个矢量显示窗口或图像窗口和一个 Vector 
Window Parameters #N 对话框组成，该对话框控制矢量的外观以及和矢量属性的交互。每个图像显
示可以有它自己的矢量，显示在主图像、滚动和缩放窗口中。使用主菜单的 File 菜单上的 Open 
Vector File 选项，以从磁盘文件中读取数据 （参见第 83 页的 “Open Vector File”）。USGS DLG 文
件也可以从磁带上读取（参见第 405 页的 “SGS Digital Line Graphs （DLG）”）。 

警告 

目前，在 ENVI 中不支持多边形套多边形（多边形内部包含多边形）。ENVI 不能正确地处理
它们。这问题将来再解决。矢量窗口内光标和鼠标的功能与 ENVI 中通常的功能不同。请参阅下面

Administrator
矢量层（Vector Layers）
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的 “Cursor Functions in Vector Windows” 这一节。 

·  一个矢量窗口和它相应的参数框，从 Available Vectors 列表中被启动（有关细节，请见第 114 
页的 “Available Vectors List”）。 

·  通过选择 Functions > Overlays > Vector Layers 以及和 Vector Window Parameters 对话框的
交互，矢量被覆盖在一幅图像上（见下）。 

矢量窗口的光标功能（Cursor Functions in Vector Windows） 

矢量窗口内的光标功能随 Vector Display Parameters 对话框中选择的模式而变化。表 3-7 列出
了当 “Cursor Query” 模式激活且光标放置在一个矢量窗口内时，鼠标按键的功能。其它模式的光标
功能，请参阅第 285 页的 “The Mode Pulldown Menu”。关于这些功能的更多细节在以下可以找到。 

 

鼠标按键 功能 

左按钮（箭头

切换按钮“On”） 
在矢量窗口内抓取最近的矢量并跟踪地图坐标和经纬度。（坐

标列在 Vector Window Parameters 对话框中。） 

左按钮（箭头

切换按钮“Off ”） 
没有应用抓取。在矢量窗口内独立地跟踪地图坐标和经纬度。

（坐标列在 Vector Window Parameters 对话框中。） 

中间按钮 通过拖曳在窗口内形成一个缩放框，来增加缩放系数。在窗口

内部单击来减小缩放系数。 

通过在窗口的边缘单击平移显示，来围绕该点居中窗口显示。

表 3-7: 矢量窗口中的鼠标按键功能。 

 

在矢量窗口中缩放和 Panning（Zooming and Panning in Vector Windows） 
ENVI 允许你放大矢量窗口的一部分。 

1. 在一个限定 “Magnify” 区域的方框一角，按住鼠标中键，拖曳这个角使区域到所需要的大小。 

2. 释放鼠标中键。 

ENVI 在矢量窗口重新绘制扩大了的缩放区域。 

3. 要缩小，在缩放区域内部单击鼠标中键。 

矢量显示返回到原来的缩放水平。 

·  要在矢量窗口内平移另一个区域，在矢量窗口边缘附近点击鼠标中键。矢量窗口显示将居中
于该点。 

矢量窗口内光标跟踪（Cursor Tracking in Vector Windows） 
若你试图进行图像 - 地图的配准（见第 598 页的 “Image-to-Map Registration”），你将需要找到
光标的位置。若矢量显示在一个矢量窗口，而不是在一幅图像上，ENVI 在矢量窗口相应的 Vector 
Window Parameters 对话框内的 “Location” 文本框中，记录该窗口内光标的位置（见 图 3-41）。要
设置跟踪状态： 

1. 通过点击 Available Vector Layers 列表中的层名，选择一个层。 
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2. 点击箭头切换按钮，设置层 “On” 或 “Off ”。 

当开启时，矢量光标找取所选择层的最近矢量。当关闭时，不用找取，光标在窗口内任何位置

自由地跟踪位置。任一种情况下，在矢量窗口内使用鼠标左键点击并拖曳，导致光标位置的地图坐

标按 Easting、Northing、[Zone for UTM] 顺序列在 “Location” 文本标签附近。纬度和经度直接列在
地图坐标的下面。 

要继续图像 - 地图的配准，继续按照下面 “Export” 列出的步骤。 

Vector Window Parameters 对话框 

矢量数据经常由多个矢量数据层组成。例如，图 3-41 显示，可用的矢量层包括 “Cities”、
“Counties”、“Roads” 和 “States”。与矢量窗口同时出现的 Vector Window Parameters 对话框（图 
3-41），允许你控制矢量层的外观，添加新的矢量，导出矢量层坐标以用于图像到地图的配准，以及
查看、编辑和查询矢量属性。当矢量覆盖在一个图像显示上，它们可以被绘制在图像窗口和/或滚动
和缩放窗口。Vector Window Parameters 对话框有三个下拉菜单–––– File， Mode 和 Options，更多
细节描述如下。关于启动矢量窗口和 Vector Window Parameters 对话框的细节，请参阅第 114 页的 
“Available Vectors List”。 

 

图 3-41: 矢量窗口（左） 和相应的 Vector Window Parameters 对话框。 

可利用矢量层列表（Available Vector Layers List） 
对话框内的这个列表显示出当前可用于显示的矢量层。所有与矢量层的交互将通过这个列表。

层名旁的星号表示该层被开启，当点击 “Apply” 按钮时将被绘制。若一个层名附近没有星号，那么
该层是关闭的，当点击 “Apply” 按钮时不被绘制。 

·  用鼠标左键在一个层名上双击，关闭/开启绘制该层。 

当前层颜色（Current Layer Color） 
Vector Window Parameters 对话框内 “Current Layer” 附近显示的颜色，表示当前所选择的层的

颜色。通过使用 “Edit Layers” 按钮，可以更改颜色（见第 281 页的 “Edit Layers”）。 

当前突出的颜色（Current Highlight Color） 
通过在矢量属性表内点击选择（见第 290 页的 “Vector Attributes”），或当编辑一个现有的矢量

时（见 “The Mode Pulldown Menu”），“Current Highlight” 旁方框内显示的颜色，表示用于突出显示
矢量的颜色。通过用鼠标左键在颜色框内点击，当前突出显示的颜色可以更改为下一个可用的图形

颜色。在颜色框内点击鼠标中键，将把颜色设置为最初显示的颜色。 

导出（Export） 
当  ENVI 的图像-地图配准功能被激活，你可以使用  Vector Window Params 对话框内的 

“Export” 按钮，把矢量坐标传递到该功能（见第 602 页的 “Entry of Map GCPs from a Vector 
Window”）。 

1. 点击 “Export” 按钮，把当前矢量光标坐标导出到图像-地图配准功能。 

若没有激活配准，点击 “Export”，ENVI 什么也不执行。 
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删除层（Remove Layer） 
要从 Available Vectors Layers 中删除一个矢量层： 

1. 在层名上点击。 

2. 点击 “Remove Layer” 按钮。 

通过使用 Available Vectors List导入一个层，该层可以被添加到 Available Vector Layers 列表中
（见第 114 页的 “Available Vectors List”）。 

编辑层（Edit Layers） 
你可以为每个矢量层修改显示的每个参数，如颜色、线条类型和线条宽度。另外，你可以打开

和关闭一个显示层。要编辑层的外观： 

1. 从 Vector Window Parameters 对话框内，点击 “Edit Layers”。 

2. 当出现 Edit Vector Layers 对话框时，在列表中点击矢量名，选择要编辑的矢量。 

·  要告诉 ENVI显示哪些层，使用层名旁的箭头切换按钮，设置每层的显示 “On” 或 “Off ”。 

每层的系统默认值为 “On”，这意味着当 Vector Window Params 对话框内的 “Apply” 按钮被选
择时，所有层将被显示。点击一个层名，通过使用箭头切换按钮选择 “Off ”，来防止下一次点击 
“Apply” 时，该层被显示。类似地，点击一个层名，然后通过使用箭头切换按钮选择 “On”，导致下
一次选择 “Apply” 时，该层被显示。 

·  通过使用适当的按钮菜单更改所需要的参数，你可以编辑一个矢量层的颜色、线条类型和线
条宽度。 

·  通过使用 “Fill” 下拉菜单，可以更改多边形填充类型。 

通过使用 “Orien” 和 “Space” 文本框，可以更改填充线条的方向和间距。 

·  通过使用 “Symbol” 下拉菜单和 “Size” 文本框，可以选择用于绘制点的符号和大小。 

·  要用矢量点绘制属性名（见第 290 页的 “Vector Attributes”）： 

A. 选择点的层名，然后点击 Edit Vector Layers 对话框内的 “Advanced” 按钮。 

出现 Point Attribute Relationships 对话框。 

B. 在 “Associate attribute name with symbol” 复选框内点击。 

C. 使用 “Attribute” 下拉菜单，从属性表中选择需要的列名（column name）绘图。 

D. 使用适当的参数，选择左、中或右对齐，字体类型，文本大小和方向。 

E. 点击 “OK” ，返回到 Edit Vector Layers 对话框。 

·  要基于属性值，用不同的符号大小来绘制矢量点（见第 290 页的 “Vector Attributes”）： 

A. 选择点的层名，然后点击 Edit Vector Layers 对话框内的 “Advanced” 按钮。 

出现 Point Attribute Relationships 对话框。 

B. 在 “Associate attribute name with symbol” 复选框内点击。 

C. 使用 “Attribute” 下拉菜单，从包含用于缩放符号大小的数据的属性表里选择需要的栏名（或
列名 column name它必须包含数值）。 
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D. 选择要使用的最小和最大的符号大小。 

E. 点击 “OK” ，返回到 Edit Vector Layers 对话框。 

3. 点击 “OK” ，退出 Edit Vector Layers 对话框，然后点击 Vector Window Parameters 对话框
内的 “Apply”，把更改应用于矢量显示上。 

清除层（Clear Layers） 
·  要清除 Available Vector Layers 列表，点击 “Clear Layers”。 

 

图 3-42: Edit Vector Layers 对话框。 

窗口（Window） 
当矢量覆盖在一个图像显示上，它们可以被绘制在图像、缩放和/或滚动窗口中。你可以在这三

个显示窗口的任何一个内编辑或添加新的矢量。 

·  要选择哪个图像显示窗口绘制矢量，在对话框底部的 “Window” 参数旁点击所需要的复选
框。 

·  要选择哪个窗口用于编辑或添加矢量，点击对话框的顶部所需要的显示窗口类型旁的按钮。 

File 下拉菜单 
File 下拉菜单允许你打开新的矢量文件，保存和恢复矢量模板文件，把矢量层导出到感兴趣区
或一个 ArcView Shape 文件，以及输出矢量显示窗口。 

注意 
通过使用 Utilities > Vector Utilities > Convert EVF to DXF 功能，ENVI 矢量文件可以转换为 

DXF （见第 390 页的 “Convert EVF to DXF ”）。 

·  要打开其它的矢量文件： 

1. 从 Vector Window Parameters 对话框，选择 File > Open Vector File > 矢量文件类型。 

2. 当出现标准文件选择对话框时，选择矢量文件（有关细节，请参见第 83 页的 “Open Vector 
File”）。 

·  要把当前的矢量设置保存为一个模板文件，从 Vector Window Parameters 对话框： 

1. 选择 File > Save Layers to Template. 

2. 为了保持一致性，键入一个扩展名为 .vec 的输出模板文件名。 

ENVI 将把你当前的矢量设置，包括被导入的矢量、颜色、线条类型和宽度，保存到一个扩展
名为 .vec 的文件。 

·  要恢复一个原先保存的矢量设置模板： 

1. 选择 File > Restore Layers from Template. 

2. 若有必要，选择所需要的 .vec 文件，相应的矢量文件将被自动打开。 

注意 
只存在于内存中的矢量不能被保存和恢复。 



 128

·  要把一个矢量层导出到一个感兴趣区（ROI）： 

1. 通过在 Available Vector Layers 列表中点击矢量层名，选择要导出的矢量层。 

2. 选择 File > Export Layer to ROI. 

3. 当出现 Select Data File to Associate with new ROIs 对话框时，选择所需要的数据文件。 

4. 该感兴趣区将出现在 Region of Interest Controls 对话框中。 

警告 

这可以创建非常大的感兴趣区。 

·  要把一个矢量层导出到一个 ArcView 兼容的文件集，包括一个 shape 文件（.shp）、
一个索引文件（.shx） 和一个数据库文件（.dbf）： 

1. 在 Available Vector Layers 列表中，点击矢量层名，选择要导出的矢量层。 

2. 选择 File > Export Layer to ArcView. 

3. 当出现 Output Layer to ArcView Shape File 对话框时，键入所需要的输出文件名，然后点击 
“OK”。 

每个 ArcView 矢量文件只能包含一种矢量类型（多边形、点等），因此 ENVI 将使用一个基名
（base name），并为每种矢量类型在基名后附加扩展名。多边形使用一个 .pg 扩展名，折线使用 .pl 
扩展名，点使用 .pt 扩展名。 

警告 

被导出到 ArcView 的矢量层必须是正确的拓扑结构，否则在 ArcView 中的后果将无法预料。 

·  要输出矢量显示窗口，选择 File > Output Plot > Postscript， Image File， 或 Printer （见
第 310 页的 “Display Output Options”）。 

·  要关闭 Vector Window Parameters 对话框和相应的 Vector Window 显示，或从一个图像显
示中擦除矢量，选择 File > Cancel. 

Mode 下拉菜单 
Mode 下拉菜单控制矢量窗口内的光标模式。光标模式可以用来选择矢量并在属性表中突出显
示它们相应的属性，编辑现有矢量，添加新矢量，从一个 ASCII 文件输入矢量点，或删除矢量。通
过使用 Options > Undo Change 选项，可以取消对矢量的任何更改或添加新矢量（见第 288 页的 
“The Options Pulldown Menu”）。 

·  要使用光标选择一个矢量，并查看该矢量的相应属性信息： 

1. 在 Available Vector Layers 列表中，点击你想查看属性的那个矢量层。 

2. 选择 Options > Vector Information 或 Options > View/Edit Attributes. 

3. 选择 Mode > Cursor Query. 

4. 在矢量窗口，用鼠标左键点击所需要的矢量，相应的属性将显示在 Vector Information 对话
框中，或突出显示在矢量属性表中。 
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·  要编辑现有矢量： 

1. 在 Available Vector Layers 列表中，点击你想编辑的那个矢量层。 

2. 选择 Mode > Edit Existing Vectors. 

3. 用鼠标左键点击一个矢量，它将被突出显示（见第 281 页的 “Current Highlight Color”）。 

4. 通过使用鼠标左键，点击并拖曳菱形手柄，编辑矢量。 

·  点击鼠标中键，取消所有更改。 

·  双击鼠标左键，snap所选的矢量手柄到邻近矢量的最近点。 

5. 点击鼠标右键，结束编辑并“退出”更改。 

·  要添加一个新的矢量（多边形、折线、矩形、椭圆或点）： 

1. 在 Available Vector Layers 列表中，点击你想添加矢量的那个矢量层。 

2. 选择 Mode > Add New Polygon，Add New Polyline，Add New Rectangle，Add New Ellipse， 或 
Add New Point. 

3. 点击鼠标左键，定义点、多边形或折线顶点。 

点击并拖曳，绘制矩形或椭圆。 

·  点击鼠标中键，取消上一个点。 

4. 点击鼠标右键，出现一个菱形手柄，它可以用来移动矢量的位置。 

·  点击鼠标中键，删除矢量。 

·  双击鼠标左键，snap所选的矢量手柄到邻近矢量的最近点。 

5. 点击鼠标右键，“退出”新的矢量。 

·  要从一个 ASCII 文件中读取点（即 GPS 点），并把它们添加到一个矢量层： 

1. 在 Available Vector Layers 列表中，点击你想添加矢量的那个矢量层。 

2. 选择 Mode > Input Points from ASCII. 

3. 选择输入的 ASCII 文件。 

4. 当出现 Input ASCII file 对话框时，选择 x 和 y 列数。 

5. 使用下拉菜单选择点定义的矢量类型，多边形，折线，点组（作为一个矢量）或单个点。 

6. 点击 “OK”，把点添加到矢量层。 

·  要删除一个矢量： 

1. 从 Available Vector Layers 列表内，点击你想删除矢量的那个矢量层。 

2. 用鼠标左键点击要删除的那个矢量，它将被突出显示。 

3. 选择 Mode > Delete Vector. 

Options 下拉菜单 
Options 下拉菜单的选项可以导入其它的矢量层，排列层的覆盖顺序，在矢量窗口内放置注记，
更改绘图参数，获取矢量信息，与矢量属性交互（见第 290 页的 “Vector Attributes”），以及取消和
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保存对矢量的更改。 

·  要从 Available Vectors List 内已经打开的文件中导入其它的矢量： 

1. 从 Vector Window Parameters 对话框，选择 Options > Import Layers. 

2. 当出现 Import Vector Layers 对话框时，点击所需要的文件邻近的方框，选择你想导入的矢
量文件。 

·  要选择所有的文件，点击 “Select All Items”。 

·  要取消选择所有的文件，点击 “Clear All Items”。 

·  要选择一组连续列出的文件，点击第一个所需要的文件，然后按住 ”shift” 的同时，点击最
后一个所需要的文件，突出显示两者之间所有的文件。 

·  要选择非连续列出的多个文件，按住你键盘上 “Ctrl” 键的同时，在每个所需要的文件上点
击。再次点击，来取消选择一项。 

·  要中止选择过程，点击 “Cancel”。 

3. 点击 “OK” 按钮，返回到 Vector Window Parameters 对话框。你刚才选择的文件出现在对话
框中，可用于显示。 

·  要创建一个新的空层（只在一个显示上覆盖矢量时有效）： 

1. 选择 Options > Create New Layer. 

2. 当出现 New Vector Layer Parameters 对话框时，键入一个层名，然后选择输出到 “File” 或 
“Memory”。 

3. 点击 “OK”，该层名将显示在 Available Vector Layers 列表中。 

·  要更改矢量层的绘制顺序： 

矢量按照 Available Vector Layers 列表中列出的顺序绘制。 

1. 选择 Options > Arrange Layer Order. 

2. 当出现 Vector Layer Ordering 对话框时，点击一个层名，并把它拖曳到需要的绘制顺序。 

3. 点击 “OK”，然后点击 Vector Window Parameters 对话框内的 “Apply”，该矢量层将按新的
顺序来重新绘制。 

·  要把注记添加到矢量显示或添加一个矢量 key，选择 Options > Annotate Plot （见第 250 页
的 “Annotation”）。 

当在一个图像显示上绘制矢量时，通过在显示窗口内选择 Functions > Overlays > Annotation，
可以添加注记。 

·  要更改矢量窗口的大小（按投影坐标）： 

1. 选择 Options > Plot Parameters. 

2. 按数据的投影坐标，在 “X/Ymin” 和 “X/Ymax” 文本框中输入所需要的值。 

·  点击 “Reset Ranges”，把数据范围重新设置为边界框的大小。 

3. 点击 “Apply”，把新的数据范围应用到矢量窗口。 
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·  要把边框、刻度线和刻度标注添加到矢量窗口： 

1. 选择 Options > Plot Parameters. 

2. 在四个 “Plot Border Values” 文本框中，为窗口的顶部、右边、底部和左边键入需要的值（以
像元为单位）。 

3. 从 “Background” 下拉菜单中，选择背景颜色。 

4. 在适当的文本框中输入所需要的 X 和 Y 刻度的间隔值。 

刻度线将在所有边框内被绘制，标注（按矢量的投影单位） 将显示在左边和底边框。 

5. 点击 “Apply”，把边框和刻度应用到窗口。 

·  要在矢量窗口将绘图范围重新设置到边界框，选择 Options > Reset Plot Range. 

·  要查看、编辑、查询或添加矢量属性，从 Options 下拉菜单中选择适当的选项（见第 290 页
的 “Vector Attributes”）。 

·  要取消上一次编辑、添加或删除矢量，选择 Options > Undo Last Change. 

·  要取消所有的编辑、添加或删除矢量，选择 Options > Undo All Changes. 

·  要保存对矢量所作的更改，选择 Options > Save Changes to File. 

矢量属性（Vector Attributes） 

矢量层可以有它们相应的属性。ENVI 可以读取 ArcView Shape 文件和 MapInfo Interchange 文
件属性，并与它们交互。对于 ArcView，属性保存在一个 dBASE II 表（.dbf） 文件中；对于 MapInfo，
保存在一个 .mid 文件中。你可以使用光标选择矢量窗口内的矢量并突出显示相应的属性，或选择
一个属性并突出显示相应的矢量。你可以通过使用简单的数学和逻辑运算，进行矢量属性查询，用

所选择的属性来创建新的矢量层。ENVI 也允许你编辑现有的属性或者把新的属性添加到矢量。点
的属性名可以绘制在矢量窗口内，点的符号大小与属性值相关（见第 281 页的 “Edit Layers”）。 

·  要交互地查看所选择矢量的属性： 

1. 在 Available Vector Layers 列表中，点击你想查看属性的那个矢量层。 

2. 选择 Options > Vector Information. 

将出现 Vector Information 对话框。 

3. 在矢量窗口内，用鼠标左键点击需要的矢量，相应的属性将显示在 Vector Information 对话
框中。必须选上 Mode > Cursor Query。 

·  要通过使用一个简单的数学和逻辑属性查询表达式，建立一个新的矢量层： 

1. 在 Available Vector Layers 列表中，点击你想查询属性的那个矢量层。 

2. 选择 Options > Query Attributes. 

将出现 Layer Attribute Query 对话框。 

3. 点击 “Start” 按钮。 

将出现 Query Condition 对话框，允许你输入一个查询表达式。 

4. 使用属性名下拉菜单，选择要查询的属性项。 
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5. 从下拉菜单中选择下列数学表达式之一： 

“>” 大于 

“>=” 大于或等于 

“<” 小于 

“<=” 小于或等于 

“==” 等于 

“!=” 不等于 

6. 在文本框中输入一个查询值。视属性类型而定，这个值可以是一个字符串（区分大小写） 或
数值。 

7. 点击 “OK”，查询表达式将被添加到 Layer Attribute Query 对话框内的列表中。 

8. 要通过使用逻辑运算，建立一个更复杂的查询表达式，选择下列选项： 

·  点击 “AND”，按照步骤 4-7 ，进行一个满足输入所有数学表达式的查询。 

·  点击 “OR”，按照步骤 4-7 ，进行一个满足其中之一的输入数学表达式查询。 

·  点击 “Clear”，清除查询表达式。 

9. 在适当文本框中，输入一个查询层名。 

10. 选择输出到 “File” 或 “Memory”，若有必要，键入一个输出文件名。 

11. 点击 “OK”，新层将出现在 Available Vector Layers 列表中。 

·  要把属性添加到一个没有任何属性的矢量层： 

1. 在 Available Vector Layers 列表中，点击你想添加属性的那个矢量层。 

2. 选择 Options > Add Attributes. 

出现 Attribute Initialization 对话框，它带有一个被定义的字段。 

3. 使用下列选项，编辑、添加或删除字段参数。 

·  使用 “Name” 文本框更改字段名。 

·  从 “Type” 下拉菜单，选择字段类型。 

可用类型包括字符型（character）、数值型（numeric）、逻辑型（ logical）和日期型（date）。逻
辑型字段包含一个字符，Y 或 N，T 或 F，或者 ? 。 

·  在表中的 “Width” 框内，输入字段宽度。 

·  在 “Decimal Count” 框内，为一个数值型字段输入小数点右边的数字位数。 

·  点击 “Add Field”，把一个新的字段添加到 Defined Attribute Fields 列表中。 

·  从 Defined Attribute Fields 列表中选择一个字段名，然后点击 “Delete Field”，从列表中删除
该字段。 

4. 点击 “OK” ，启动一个属性表（见第 292 页的 “The Attributes 表”）。 

·  要在表中查看和/或编辑属性数据： 
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1. 在 Available Vector Layers 列表中，点击你想查看属性的那个矢量层。 

2. 选择 Options > View/Edit Attributes. 

将出现 ENVI 属性表。 

3. 在矢量窗口，用鼠标左键点击所需要的矢量，相应的属性将被突出显示在 ENVI Attributes 表
中。 

属性表（Attributes Table） 
ENVI 的属性表允许查看、编辑、排序和保存矢量属性数据。这个属性表在每列的顶部显示属
性名，在每行的左边显示属性记录号。该属性表有两个下拉菜单，File 和 Options。 

·  要把矢量显示窗口居中在与所选择的属性记录相对应的矢量上，点击所需要的属性记录号。 

相应的矢量将用彩色突出显示在 “Current Highlight”。 

·  要编辑单个属性值，用光标在所需要的属性字段内双击，然后输入新的值。 

 

图 3-43: 一个矢量属性表。 

·  要在表中添加一个新的属性列： 

1. 选择 Options > Add Record Columns. 

2. 在 Attribute Initialization 对话框内，输入新的属性信息（细节见上）。 

·  要从表中删除一个属性列： 

1. 点击列名，突出显示该列。 

2. 选择 Options > Delete Record Column. 

·  要通过使用一列中的数值或字符串，对属性表排序（按照正向、反向或初始顺序）： 

1. 点击列名，作为排序依据。 

2. 选择 Options > Sort by selected column forward，Sort by selected column reverse，或 Sort by 
original order. 

·  要用单个值代替属性表中突出显示的单元格（一列中的所有单元格）： 

1. 点击所需要的列名代替整列，或用光标点击并拖曳选择一列内的单元格。 

2. 选择 Options > Replace selected cells with value. 

3. 当出现 Replace Table Cells with Value 对话框时，输入所需要的字符串或数值，然后点击 
“OK”。 

·  用来自一个 ASCII 文件的值，代替属性表中突出显示的单元格（一列中的所有单元格）： 

1. 点击所需要的列名，代替整列，或用光标点击并拖曳选择一列内的单元格。 

2. 选择 Options > Replace selected cells with ASCII values. 

3. 选择要输入的 ASCII 文件名。 

4. 当出现 Input ASCII File 对话框时，选择所需要的列号（字符串型只能有一列） 和起始、结
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尾行号。 

5. 点击 “OK”，把数据输入到属性表中。 

·  把整个属性表保存为一个 ASCII 文件： 

1. 选择 File > Save Records to ASCII. 

2. 当出现 Output Records to ASCII 对话框时，键入一个输出文件名。 

·  保存对属性表所作的更改，选择 File > Save Changes. 

警告 

这将覆盖掉现有的属性文件。 

·  要关闭属性表，选择 File > Cancel. 

若对属性数据作了一些改动，ENVI 将询问你是否想保存更改。 

网格线（Grid Lines） 
Grid Lines 功能允许在一幅图像上覆盖一个或多个网格。网格可以基于像元或地图坐标和/或基

于经纬度（对于地理坐标定位的图像）。每个图像显示可以都有它自己的一套网格，显示在主图像、

滚动和缩放窗口。要激活该功能： 

·  从主图像窗口内，选择 Functions > Overlays > Grid Lines. 

浏览以下几节，来编辑和显示网格线。 

网格类型（Grid Types） 

以像元为基础的图象网格（Pixel-Based Image Grids） 
没有被配准到地图坐标的图像，只能有基于像元的网格。这时，网格间距以像元为单位被指定

（自左上角的（1， 1）起），网格线用像元坐标标注（图 3-44）。 

地理坐标定位的图象网格（Georeferenced Image Grids） 
地理坐标定位的图像拥有基于地图坐标或地理坐标（经纬度）的网格。在显示网格前，假定图

像已经是正确的地图投影。网格间距按投影单位指定（通常为米），基于图像头文件中给出的基准像

元。网格坐标用适当的地图坐标标注（图 3-38）。 

 

图 3-44: 一个基于像元图像网格的例子。 

网格线参数（Grid Line Parameters） 

要控制网格特征，以及在图像上绘制哪些网格： 

1. 选择 Functions > Overlays > Grid Lines. 

当你第一次选择该选项，若还没有应用，图像用一个虚拟边框重新显示。 

2. 当出现 Grid Line Parameters 对话框时，选择对话框底部 “Window” 标签旁所需要的复选框，
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在图像窗口和/或滚动窗口内绘制网格线。 

3. 要选择要显示的网格，点击 “Pixel Grid”、“Map Grid” 和 “Geographic Grid” 旁的 “On/Off ” 
箭头切换按钮。 

若图像没有被地理坐标定位，那么地图和地理坐标网格都不可用。 

若你的图像经过地理坐标定位，地图和地理网格最初都已经开启。 

 

图 3-45: 一幅地理坐标定位了的图像上的多个网格（像元、地图、地理）坐标例子。 

网格间距（Grid Spacing） 
选择下列选项，为指定的网格类型设置网格间距： 

·  对于像元和地图网格，在 Grid Line Parameters 对话框内标签为 “Grid Spacing” 的文本框
中输入所需要的值。 

对于基于像元的网格，网格间距为像元数；对于地图坐标网格，间距为米。 

·  对于地理网格： 

1. 点击 “DMS< - >DD” 按钮，来为地理网格在度－分－秒和小数的度数之间更改。 

2. 在 “Spacing” 文本框内，输入所需要的度－分－秒或小数的度数间距。 

3. 点击 “Apply”，在图像上绘制网格。 

Options 下拉菜单 

Options 菜单允许你更改三种网格的特征和显示的边框。 

·  要更改显示边框的大小和颜色： 

1. 选择 Options > Set Display Borders. 

2. 为左、上、右和下边输入所需要的边框大小（以像元为单位）。 

3. 从 “Border Color” 菜单中，选择所需要的颜色。 

·  要编辑网格特征： 

1. 在 Grid Line Parameters 对话框内，选择 Options > Edit Pixel/Map/Geographic Grid Attributes. 

2. 当出现 Edit Map Attributes 对话框时，选择下列步骤，更改标注、线条、方框和角的特征。 

·  要开启和关闭绘制在显示图像上的特定网格要素，切换每个要素名旁的 “On/Off ” 箭头切换
按钮。 

·  要在图像外虚拟边框内绘制网格标注，开启 “Labels”。 

刻度也将沿着图像的边缘，被放置在标注的附近。 

·  要更改颜色，点击 “Colors”，然后选择一种颜色。 

·  要更改标注的宽度，在 “Thick” 文本框中输入一个值。 

·  要更改标注的字体，从 “Font” 菜单中选择。 
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·  要更改大小，在 “Charsize” 文本框中输入一个值。 

·  要为每种网格类型，控制标注与图像边缘的距离，使用 “Dist” 参数。 

数值越大，离边缘越远。 

·  “X-axis Labels” 和 “Y-axis Labels” 箭头切换按钮，分别为 X 和 Y 网格轴在水平（H） 和
垂直（V） 标注显示之间切换。 

·  要绘制 X 和 Y 网格线，开启 “Lines” 选项。 

·  要绘制围绕图像的一个 “Neat Line” 方框，开启 “Box” 选项。 

·  要为每个网格交点绘制刻度线，开启 “Corners”。 

·  要为网格和方框线设置线条类型（实线、点线、虚线等），从 “Style” 选项中选择。 

·  要设置选项的宽度，在 “Thick” 参数框中输入所需要的值。 

3. 当根据需要设置好网格线属性后，点击 “OK”。 

4. 点击 “Apply”，在图像上绘制网格线。 

File 下拉菜单 

File 下拉菜单允许保存和恢复网格设置。 

·  要把网格参数设置保存到一个文件： 

1. 选择 File > Save Setup. 

2. 当出现 Output Grid Parameters 对话框时，键入一个输出文件名。 

为了保持一致，网格设置文件应该用扩展名 .grd 保存，但也可以使用其它的扩展名保存。 

·  要恢复以前保存的网格设置文件： 

1. 选择 File > Restore Setup. 

2. 当出现文件选择窗口（系统默认地列出所有扩展名为 .grd 的文件）时，选择所需要的文件，
然后点击 “OK”。 

输出网格线（Output Grid Lines） 

通过从图像显示的 Functions 菜单中使用 Output Display 选项，网格线可以“burned in”该图
像中（见第 310 页的 “Display Output Options”）。虚拟的边框被自动地添加到图像上，网格标注围
绕图像的外围被嵌入。 
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分类（Classification） 
使用 Classification 菜单选项，打开一个交互式的 post-classification 工具，它允许你在一个显示
窗口内把类覆盖在一幅灰阶或彩色图像上，控制显示哪些类，收集统计资料，编辑类的颜色和名称，

合并类，以及通过添加、删除或移动类间的像元对类进行编辑。可以保存对分类图像所作的更改。 

注意 
在使用该功能之前，必须生成一个分类图像（见第八章， “Classification”）。 

1. 在你想覆盖分类结果的那个图像的显示窗口内，选择 Functions > Overlays > Classification. 

Interactive Class Tool 对话框出现。它列出了所有的类，显示了它们的颜色和名称。对话框的顶
部显示出当前激活的类，这一类是应用任何操作（即统计、编辑等）的那一类。 

2. 从下列选项中选择，编辑和应用类到你的图像。 

·  要调整对话框的大小，在一个角上点击，然后拖曳。 

·  要更改活动的类，点击所需要类名旁的颜色框。 

·  要在图像上显示一个类，点击类名旁的 “On” 复选框。 

可以立即显示任何数量的类。 

·  要开启并显示单个类，而关闭所有其它类，用鼠标左键双击所需要类旁的颜色框。 

·  要再次关闭它，并显示所有其它类，用鼠标左键再次双击该类。 

·  要关闭所有类，在一个颜色框上点击鼠标右键。 

·  要开启所有类，用鼠标右键在任何颜色框上再次点击。 

·  若你正在编辑一个类，通过点击 Edit Window 旁所需要的窗口，决定绘制在哪个窗口（见 图 
3-46）。 

图 3-46: Interactive Class Tool 对话框。 

Edit 下拉菜单 

使用 Edit 菜单，通过添加、删除像元，或绘制多边形、矩形或椭圆来移动类间的像元，从而编
辑类型。 

注意 
确信你想选择编辑的类是活动的。当把像元移动到其它的类，你将看不到新类颜色的变化，直

到你开启了该类。 

·  要把鼠标按键功能设置为标准显示模式，选择 Edit > Mode: No Editing. 

·  要在所选择的图像内绘制多边形，并从多边形添加像元到所选择的类： 

1. 选择 Edit > Mode: Polygon Add to Class. 

2. 选择所需要的类，添加像元。 

3. 使用鼠标左键，在图像上绘制一个多边形。 
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·  要闭合多边形，点击鼠标右键。 

·  要接受多边形，再次点击鼠标右键。 

新的像元更改为活动类的颜色。 

·  要通过绘制多边形，来从活动的类中删除像元： 

1. 选择 Edit > Mode: Polygon Delete from Class. 

2. 选择 Edit > Set delete class value. 

3. 在对话框内，选择要删除像元的那个类。 

4. 在图像上绘制多边形，从活动的类中删除那些像元。 

·  要设置一个多边形的绘制颜色： 

1. 选择 Edit > Set polygon draw color. 

2. 从 Polygon Color 菜单按钮中，选择一种颜色。点击 “OK”。 

注意 
一旦颜色被设置，这种颜色只用于描绘多边形的轮廓，而不是用来填充多边形的颜色。填充颜

色是定义类的颜色。 

·  要选择你想绘制的多边形类型，选择 Edit > Polygon Type: 所需要的类型。 

·  要取消自上次保存后的所有更改： 

1. 选择 Edit > Undo Changes. 

2. 在询问对话框内，点击 “Yes”。 

提示 

经常保存你的更改，这样，若你出了错，你不必全部重做。 

Options 下拉菜单 

使用 Options 下拉菜单，获取类的统计信息，以及更改类的颜色和名称。 

·  要产生显示像元数和每个类的像元百分比的一个记录，选择 Options > Class distributions. 

这个记录被处理和显示在 Classification Distribution 窗口中。当编辑时，从类中添加或删除像元，
该记录自动被更新。 

·  要更改类颜色和/或类名，选择 Options > Edit class colors/names. 

出现  Class Color Map Editing 对话框。详细的向导，请参阅  第  184 页的  “Class Color 
Mapping”。 

·  要把一个或多个类合并到一个所选择的基类（base class）： 

1. 选择 Options > Merge classes. 

出现 Interactive Merge Classes 对话框。 

2. 通过点击所需要的类名，选择基类。 
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3. 通过点击所需要的类名，选择要合并到基类的类型。 

·  要选择一组连续列出的类，点击该组中的第一个文件，按住 “Shift” 键的同时，点击该组中
的最后一个类。或者，用鼠标左键点击并拖曳，选择所需要的组。 

·  要选择多个非连续列出的类，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的类型。 

4. 点击 “OK”。 

下一次你打开 Class Distributions 对话框时，它将被更新。 

·  要绘制活动类型的一个平均波谱： 

1. 在 Interactive Class Tool 对话框，选择活动的类。 

2. 选择 Options > Mean for active class. 

·  若出现 Input File Associated with Classification Image 对话框，选择要计算统计信息的那个输
入文件，然后点击 “OK”。只有当这个对话框原先没有被设置过，它才会出现。 

ENVI 计算统计信息，并在一个 Class Means 图表窗口内显示平均波谱。 

·  要绘制所有类型的平均波谱，选择 Options > Mean for all classes. 

ENVI 计算统计信息，并在一个 Class Means 图表窗口内显示平均波谱。 

·  要绘制活动类型的统计信息： 

1. 在 Interactive Class Tool 对话框，选择活动的类。 

2. 选择 Options > Stats for active class. 

·  若出现 Input File Associated with Classification Image 对话框，选择要计算统计信息的那个输
入文件。只有当这个对话框原先没有被设置过，它才会出现。 

ENVI 计算统计信息，并显示一个图表窗口。平均波谱为白色， +/- 标准差为绿色，最小和最
大波谱为红色。 

提示 

要获得一个文本记录和更多关于类的统计信息，选择 Classification > Post Classification > Class 
Statistics. 

·  要绘制所有类型的统计信息，选择 Options > Stats for all classes. 

ENVI 为每类计算统计信息，并显示一个 Class Means 图表窗口。 

·  要更改相应的统计数据文件： 

1. 选择 Options > Associated stats data file. 

2. 在 Input File Associated with Classification Image 对话框内，选择文件名。点击 “OK”。 

File 下拉菜单 

·  要保存对你的分类图像所作的更改： 

1. 选择 File > Save Changes to File. 
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警告 

选择 “Yes”，将覆盖现有的分类文件。 

2. 在询问对话框内，点击 “Yes”。 

当前的文件名被所更改的文件覆盖。 

·  要退出该更改，选择 File > Cancel. 

输出显示（Output the Display） 

·  要输出被覆盖的类的图像，选择 Functions > Output Display > 所需要的输出。 

注意 
只有那些被启动的类，将出现在输出中。 

分类覆盖图将作为 <Displayed Class Overlay>，列在 Graphics Overlay Selections 下。 

 

显示窗口特征（Display Characteristics） 
Display Characteristics 选项允许你修改基本的显示窗口参数。以下几节提供了详细的介绍。 

定位缩放和滚动窗口（Positioning the Zoom and Scroll Windows） 

Display Characteristics 菜单下的 Scroll/Zoom Location 选项，允许灵活地放置缩放和滚动窗口
（相对于主图像窗口的位置）。要设置位置，按照这些步骤： 

1. 从主图像窗口，选择 Functions > Display Characteristics > Scroll/Zoom Location > 所需要的位
置。 

·  选择 “Right”、“Left”、“Above” 或 “Below”，把窗口分别定位到主图像窗口的右边、左边、
上面或下面。 

·  选择 “Within”，把缩放和滚动窗口都放置在主图像窗口的图像区域内。 

·  选择 “Auto Placement Off ”，在屏幕的任何位置放置窗口，确保它们将停留在那儿，直到再
次被手动地移开。 

改变显示参数（Change Display Parameters） 

Change Display Parameters 选项允许你从一个对话框，更改主图像窗口、滚动窗口和缩放窗口
的特征。 

虚拟边框特征（Virtual Border Characteristics） 
Change Display Parameters 选项允许你为图像显示设置一个虚拟的边框。 

1. 从主图像窗口内，选择 Functions > Display Characteristics > Change Display Parameters. 

2. 当出现 Display Parameters 对话框时，若有必要，作出下列更改： 
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·  当每次导入一幅图像时，要使用系统默认的一个虚拟边框，在适当位置的文本框内按像元输
入边框的大小。 

左文本框控制左边框，右文本框控制右边框，上文本框控制上边框，下文本框控制下边框。 

·  要更改系统默认的边框颜色，从 “Border Color” 菜单，选择所需要的颜色。 

图象窗口滚动条（Image Window Scroll Bars） 
主图像窗口内的滚动条，允许你移动被显示的图像。当你使用滚动条时，滚动窗口内的图形框

移动，指示你在整幅图像的哪个部分。 

·  要开启或关闭一个特定主图像窗口的滚动条，使用鼠标右键双击缩放窗口的十字线方框，或
按照下列步骤。 

1. 在打开的显示内，选择 Functions > Display Characteristics > Change Display Parameters. 

2. 出现 Display Parameters 对话框。 

3. 点击 “Scroll Bars” 箭头切换按钮，选择 “Yes”。 

4. 点击 “OK”。 

控制窗口大小（Controlling Window Sizes） 
Change Display Parameters 选项也允许你控制图像、滚动和缩放显示窗口的大小。 

1. 从主图像窗口内，选择 Functions > Display Characteristics > Change Display Parameters. 

2. 从 Display Parameters 对话框内，选择下列选项，更改这三个窗口的特征： 

·  要更改大小，在标签为 “Xsize:” 和 “Ysize:” 的文本框中，为所需要的窗口输入所需要的值
（按像元）。 

·  你也可以通过用鼠标左键在窗口的一角点击，然后拖曳所需要的大小，以设置窗口大小。 

·  对于滚动窗口，你也可以通过在适当标签的方框内输入数值并按回车键，以输入一个新的二
次抽样系数（ “Resize Factor”）。 

A 调整大小系数为 1，导致滚动窗口按全分辨率显示。更小的调整大小系数导致二次抽样。例
如，调整大小系数为 0.25，将显示滚动窗口内的 1/4 的像元。 

·  相似地，要更改缩放系数，在标签为 “Zoom Factor:” 的框内输入数值，然后按回车键。缩放
系数为 1，按全分辨率显示图像。更大的缩放系数，将通过使用像元复制使图像被放大。 

·  要在缩放窗口内控制图形覆盖图的显示，在文本标签 “Show Graphics” 下，选择适当的切换
按钮。 

·  要为主图像窗口（在滚动窗口内）和缩放窗口（在主图像窗口内）设置轮廓框的颜色，从标
签为 “Zoom/Scroll Color” 的文本框中选择所需要的颜色。 

3. 点击 “OK”，把新的值应用到图像上。 

显示输出选项（Display Output Options） 
ENVI 的图像显示、图表或矢量窗口可以被输出到一个 postscript 文件、图象文件，或直接输

出到打印机。所有覆盖图（注记、网格线、矢量等）可以被包含在（嵌入）输出中。ENVI 提供三
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种输出选项： 

·  Postscript 文件 

·  Image 文件 

·  ENVI 文件（带有一个 ASCII 头文件的 RGB 二进制图像） 

·  BMP、GIF、HDF、JPEG、PICT、SRF （Sun 栅格文件）， TIFF （包括 GeoTIFF 和 TIFF 
World 文件 [.twf]），和 XWD （X-Windows Dump） 图像文件 

·  ERDAS （.lan）， ER Mapper， PCI （.pix）， 和 ArcView （.bil） 文件 

·  直接到一个系统打印机。 

所有输出类型的详细向导如下。 

Postscript 文件 
ENVI 的 postscript 输出允许你选择页面和图像大小，按横向或纵向输出，设置一个地图比例，

“嵌入”图形的覆盖图，输出一个压缩的 postscript 文件，以及选择其它的选项。 

·  要把一幅显示的图像输出到一个  postscript 文件，选择  Functions > Output Display > 
Postscript File. 

出现 Output Display to Postscript File 对话框时，你可以修改图像、图表，并进行矢量的输出（见 
图 3-47）。输出页面作为一个图表窗口简略地显示在对话框右上角。关于在该对话框内设置输出显
示参数的内容，见下列几小节。 

·  要把一个图表或矢量窗口输出到一个 postscript 文件，选择 File > Output Plot > Postscript. 

 

图 3-47: Display to PostScript Parameters 对话框。 

 

页面设置和输出图象的缩放（Page Setup and Output Image Scaling） 
在 envi.cfg文件中，页面大小和图像布局按照英寸或厘米被设置。当输出到 postscript时，可
以进行准确缩放和多页输出（multiple page output）。任何一幅 ENVI 图象都可以按照指定的地图比
例尺缩放，且图象大小自动地随图象像元的大小而变化。如果最终图象比 ”page” 文本框中定义的
单个页面大， ENVI 自动判断输出图象需要的页数，并在对话框的右上角绘图窗口中显示页数。多
页图象一旦形成，ENVI不能对其页面设置再进行更改（cannot be repositioned with respect to the page 
layout specified by ENVI）. 从下列选项中选择，以设置输出的页面大小和图像比例。 

·  要在文本框内设置页面大小和图像位置： 

1. 通过在标签为 “Page” 的文本框内输入所需要的大小，设置页面大小。 

2. 通过在标签为 “Xsize” 和 “Ysize”文本框内输入所需要的值，设置输出图像的大小。 

·  更改大小时，要保持 X 和 Y 的相对形态，选择“ Aspect” 复选框。 

3. 使用 “Xoff ” 和 “Yoff ” 参数，设置页面上的图像原点位置（相对于左下角）。 

一个在页面上显示图像相对大小和位置的略图，将显示在对话框右上角的绘图窗口内。 

·  要使用鼠标在输出页面上放置图像，在绘图窗口中的图像略图内部，点击并按住鼠标左键并
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把图像拖曳到一个新的位置。 

·  要使用鼠标在页面上居中图像略图，在输出页面上任何位置点击鼠标右键。 

4. 点击箭头切换按钮，选择 “Landscape” 或 “Portrait” 作为页面方向。 

5. 选择下列选项。 

·  要把一幅图像调整到一个指定的地图比例，在 “Map Scale 1:” 文本框中输入所需要的比例。 

“xsize” 和 “ysize” 值将基于图像像元大小自动地更改（若在文件头中没有像元大小，假定系统
默认大小为 30 米）。 

·  要开启或关闭颜色，选择或取消选择 “Color” 复选框。 

·  要选择压缩的 postscript 输出，点击 “Encapsulate” 复选框。 

·  要为 postscript 图像选择输出的位数，使用 “Bits” 下拉菜单。 

设置图表覆盖选项（Setting Graphics Overlay Options） 
Graphics 选项（注记、网格线、感兴趣区、矢量等） 可以被“嵌入到”（永久地合并到）保存
的 PostScript 文件。启动 Output to PostScript File 对话框，所有当前显示的有效的 ENVI 图表被自
动选择。若选择网格线，一个边框将自动放置在输出图像上。网格的文本标注放置在图像的外面。

注意，必须事先在显示内选择 Functions > Overlays > Grid Lines，将网格显示和配置在图像上， （见
第 295 页的“Grid Lines”）。 

·  要更改图形覆盖选项： 

1. 点击 “Change Graphic Overlay Selections” 按钮。 

将出现 Change Graphics Overlay Options 对话框，并带有一个当前显示的图形对象的列表。 

2. 使用下列选项，来更改图形覆盖图选项： 

·  要删除一个图形覆盖图，在 Currently Selected Options 列表中点击该名。 

·  要添加图形覆盖图，使用 “Add Graphics Option” 下拉菜单，选择所需要的覆盖图（除了注
记之外，这些覆盖图必须显示在你的图像或图表上）。 

·  要把一个当前没有显示的注记文件，添加到图形覆盖图上，从 “Add Graphics Option”下拉菜
单中选择 “Additional Annotation File”，然后选择所需要的注记文件名。 

3. 点击 “OK”，返回到 Output to Postscript File 对话框。 

·  当生成多个输出页面，要裁剪页面边缘所有的图形，选择 “Clip Graphics” 复选框。 

数据重采样（空间）（Spatial Subsetting and Resizing） 
·  要选择图像的一个空间子集输出，点击 “Spatial Subset” 按钮，执行典型的 ENVI 构造子集

（见第 145 页的 “Standardized ENVI Spatial Subsetting”）。 

·  要调整图像的大小，在 “Input Image Resize Factor” 文本框内，输入一个调整大小的系数（对
于二次抽样小于 1 ）。 

应用掩膜（Apply a Mask） 
你可以把一个预先定义的掩膜应用到你的输出图像上。这将节省了在选择输出选项以前不得不

对图象应用掩膜的步骤。 
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1. 点击 “Select Mask” 按钮。 

2. 为掩膜选择输入波段。 

3. 在 “Background”、“R”、“G” 和 “B” 文本框中，输入你想在掩膜屏蔽处要使用的颜色值。 

4. 点击 “OK”。 

·  要清除所选择的掩膜，并输出整幅图像，点击 “Clear Mask” 按钮。 

保存文件（Save the File） 
1. 键入输出文件名，或使用 “Choose” 按钮，选择输出文件名。 

2. 当所有选项已经设置正确，点击 “OK”。 

若你选择的参数导致多个页面输出，文件名将作为一个根文件名，用来指定在合成图像中多个

页面位置的数字被附加到文件名后。例如，一幅有 6 个页面的图像（ 3 列 2 行），使用根文件名 
“test”，创建输出文件 test_11、test_12、test_21、test_22、test_31 和 test_32，其
中第一个附加数字指列，第二个附加数字指行。 

图象文件（Image File） 

ENVI 有许多图像输出选项。它们包括输出为一个 ENVI 格式图像文件，输出为 BMP、GIF、
HDF、JPEG、PICT、SRF、TIFF （包括 GeoTIFF），和 XWD 文件。ENVI 也可以输出为多种图
像处理格式文件，包括 ERDAS （.lan）、ER Mapper、PCI （.pix），和 ArcView （.bil） 文件。 

·  要把一幅显示的图像输出到一个图像文件，选择 Functions > Output Display > Image File. 

出现 Output Display to Image File 对话框，带有的选项可用来选择输出文件类型、设置图形覆
盖图选项、选择一个空间子集、调整图像大小，以及更改边框大小。有关细节，请见下列几小节。 

·  要把有关图表或矢量窗口输出到一个图像文件，选择 File > Output Plot > Image File. 

输出的文件类型与分辨率（Output File Type and Resolution） 
ENVI 的输出的图像文件，支持许多不同的输出文件类型（如上所列）。每种文件类型有一个可

用的输出格式选项。这些输出格式（分辨率） 包括 8-bit灰阶、8-bit带有相应的颜色查找表，以及 
24-bit BSQ （波段顺序）、BIL （波段按行交叉） 和 BIP （波段按像元交叉） 格式。 

·  要选择所需要的输出文件类型，使用 “Output File Type” 按钮菜单。 

·  使用 “Resolution” 按钮菜单，选择所需要的输出格式。 

设置图表覆盖选项（Setting Graphics Overlay Options） 
Graphics 选项（注记、网格线、感兴趣区、矢量等） 可以被“嵌入到”（永久地合并到） 输出
图像文件。当启动 Output to Image File 对话框时，所有当前显示的有效 ENVI 图形对象将被自动选
择。若选择网格线，输出图像上将自动放置一个边框。网格的文本标注放置在图像的外面。注意，

必须事先使用 Display 菜单上的 “Grid Lines” 选项，将网格显示和配置在图像上。（见第 295 页的
“Grid Lines”）。 

·  要更改图形覆盖图选项： 

1. 点击 “Change Graphic Overlay Selections” 按钮。 

将出现 Change Graphics Overlay Options 对话框，并带有一个当前显示的图形对象的列表。 
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2. 使用下列选项，更改图形覆盖图选项： 

·  要删除一个图形覆盖图，在 Currently Selected Options 列表中点击该名。 

·  要添加图形覆盖图，使用 “Add Graphics Option” 下拉菜单，选择所需要的覆盖图（除了注
记之外，这些覆盖图必须显示在你的图像或图表上）。 

·  要把一个当前没有显示的注记文件，添加到图形覆盖图，从 “Add Graphics Option”下拉菜单
中选择 “Additional Annotation File”，然后选择所需要的注记文件名。 

3. 点击 “OK”，返回到 Output to Image File 对话框。 

·  要更改输出图像上的边框大小或颜色： 

1. 点击 “Change Image Border Size” 按钮。 

2. 当出现 Change Image Border Size 对话框时，在上、右、下和左文本框中输入所需要的边框
大小。 

3. 从下列菜单中选择所需要的边框颜色。 

相应的 RGB 值将显示在文本框中。 

4. 点击 “OK”，返回到 Output to Image File 对话框。 

空间子集（Spatial Subsetting） 
·  要选择图像的一个空间子集输出，点击 “Spatial Subset” 按钮，执行典型的 ENVI 构造子集

（见第 145 页的 “Standardized ENVI Spatial Subsetting”）。 

·  要调整图像的大小，在 “Input Image Resize Factor” 文本框内，输入一个调整大小的系数（对
于二次抽样小于 1 ）。 

应用掩膜（Apply a Mask） 

你可以选择把一个预先定义的掩膜应用到你的输出图像上。这将省去选择输出选项以前不得不

对图象应用掩膜的步骤。 

1. 点击 “Select Mask” 按钮。 

2. 为掩膜选择输入波段。 

3. 在 “Background”、“R”、“G” 和 “B” 文本框中，输入你想在掩膜屏蔽处要用到的颜色值。 

4. 点击 “OK”。 

·  要清除所选择的掩膜，并输出整幅图像，点击 “Clear Mask” 按钮。 

保存文件（Save the File） 
1. 键入输出文件名，或使用 “Choose” 按钮，选择输出文件名。 

2. 当所有选项都已正确设置，点击 “OK”。 

打印机（Printer） 

ENVI 允许把图像显示、图表和矢量窗口直接输出到系统打印机。通过内部的系统打印对话框，
可以输出到任何一个系统打印机或绘图仪。 
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要把一幅显示的图像输出到一个系统打印机，选择 Functions > Output Display > Printer. 

2. 当出现 Print setup 对话框时，为系统设置特定选项，然后点击 “OK”。 

3. 当出现 Output Display to Printer 对话框时，有几个你可以设置输出显示参数的选项。详细的
介绍，请见下列几小节。 

·  要把一个图表或矢量窗口输出到一个系统打印机，选择 File > Output Plot > Printer. 

输出打印的大小（Output Print Size） 
若一幅地理坐标定位的图像被显示，你可以设置输出 X 或 Y 打印大小，或设置所需要的输出

地图比例。当大小被设置，其它的参数大小将相应发生变化，以保持图像的相对比例。 

·  要在文本框内设置页面大小和图像位置： 

1. 通过在标签为 “Xsize” 和 “Ysize”文本框内输入所需要的值，来设置页面上的输出图像的大
小。 

·  当大小被更改时，要保持 X 和 Y 的相对形态，选择“ Aspect” 复选框。 

2. 使用 “Xoff ” 和 “Yoff ” 参数，设置页面上的图像原点位置（相对于左下角）。 

一个在页面上显示图像相对大小和位置的略图，将显示在对话框右上角的绘图窗口内。 

·  要通过使用鼠标在输出页面上放置图像，在绘图窗口的图像略图内部，点击并按住鼠标左键
并把图像拖曳到一个新的位置。 

·  要通过使用鼠标使图像略图居于页面中间，在输出页面上任何一处点击鼠标右键。 

3. 点击箭头切换按钮，选择 “Landscape” 或 “Portrait” 作为页面方向。 

4. 选择下列选项。 

·  要把一幅图像调整到一个指定的地图比例，在 “Map Scale 1:” 文本框中输入所需要的比例。 

“xsize” 和 “ysize” 值将基于图像像元大小自动地更改（若在文件头中没有像元大小，假定系统
默认大小为 30 米）。 

空间子集以及大小的调整（Spatial Subsetting and Resizing） 
·  要选择图像的一个空间子集输出，点击 “Spatial Subset” 按钮，执行典型的 ENVI 构造子集

（见第 145 页的 “Standardized ENVI Spatial Subsetting”）。 

·  要调整图像的大小，在 “Input Image Resize Factor” 文本框内，输入一个调整大小的系数（对
于二次抽样小于 1 ）。 

设置图表覆盖选项（Setting Graphics Overlay Options） 
Graphics 选项（注记、网格线、感兴趣区、矢量等） 可以被“嵌入到”（永久地合并到） 输出
图像文件。当启动 Output to Image File 对话框时，所有当前显示的有效 ENVI 图形对象将被自动选
择。若选择网格线，输出图像上将自动放置一个边框。网格的文本标注放置在图像的外面。注意，

必须事先使用 Display 菜单上的 “Grid Lines” 选项，将网格显示和配置在图像上。（见第 295 页的
“Grid Lines”）。 

·  要更改图形覆盖图选项： 

1. 点击 “Change Graphic Overlay Selections” 按钮。 
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将出现 Change Graphics Overlay Options 对话框，并带有一个当前显示的图形对象的列表。 

2. 使用下列选项，更改图形覆盖图选项： 

·  要删除一个图形覆盖图，在 Currently Selected Options 列表中点击该名。 

·  要添加图形覆盖图，使用 “Add Graphics Option” 下拉菜单，选择所需要的覆盖图（除了注
记之外，这些覆盖图必须显示在你的图像或图表上）。 

·  要把一个当前没有显示的注记文件，添加到图形覆盖图，从 “Add Graphics Option”下拉菜单
中选择 “Additional Annotation File”，然后选择所需要的注记文件名。 

3. 点击 “OK”，返回到 Output to Image File 对话框。 

应用掩膜（Apply a Mask） 
你可以把一个预先定义的掩膜应用到你的输出图像上。这将节省了在选择输出选项以前不得不

对图象应用掩膜的步骤。 

1. 点击 “Select Mask” 按钮。 

2. 为掩膜选择输入波段。 

3. 在 “Background”、“R”、“G” 和 “B” 文本框中，输入你想在掩膜屏蔽处要使用的颜色值。 

4. 点击 “OK”。 

·  要清除所选择的掩膜，并输出整幅图像，点击 “Clear Mask” 按钮。 

打印（Print） 
·  在 Output Display to Printer 对话框内，点击 “OK”，打印图像或图表。 

缩放窗口输出（Zoom Window Output） 
Output Zoom to Image 选项把缩放窗口中的图像输出到一个文件。 

1. 从主图像窗口内，选择 Functions > Output Zoom to Image. 

2. 选择 “3 Band RGB” 或 “1 Band Gray” 输出，把缩放窗口保存为 3 波段红、绿、蓝文件或
一个灰阶文件。 

3. 键入一个输出文件名，或选择输出到内存。 

4. 点击 “OK”。 
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第四章：基本工具 

Basic Tools 菜单提供对多种 ENVI 功能的访问。你会发现不管分析的图像数据是哪种指定类
型，Basic Tools 功能都是很有用的。如 Cursor Location 和 Regions of Interest 功能可以用于多重显
示，Band Math 功能用于对图像进行一般的处理。Stretch Data 功能是提供了进行文件到文件交互功
能的一个典范。 

 

图 4-1: ENVI 的 Basic Tools 菜单。 

显示控制（Display Controls） 
ENVI Basic Tools 菜单下的 Display Controls 菜单，控制 ENVI 显示和图表窗口的各个方面，
包括启动新的窗口、窗口最大化、链接显示窗口，以及关闭窗口。每个菜单项描述如下。 

启动新显示（Start New Display） 

·  要启动一个新的独立的图像显示窗口，选择 Basic Tools > Display Controls > Start New 
Display. 

每个已启动的窗口将按先后顺序，从 Display #1 开始被标号。通过使用 Available Bands List上
的 “New” 按钮，显示窗口也可以被启动 （见第 97 页的 “Available Bands List”）。 

启动新的矢量窗口（Start New Vector Window） 

·  要启动一个新的独立的矢量窗口，选择 Basic Tools > Display Controls > Start New Vector 
Window. 

每个窗口将按先后顺序，从 window #1 开始被标号。通过使用 Available Vectors List 上的 
“Load Vectors” 按钮，矢量窗口也可以被启动 （见第 114 页的 “Available Vectors List”）。 

启动新的绘图窗口（Start New Plot Window） 

·  为了从波谱库或其它图表窗口接收图表，要启动一个新的独立的图表窗口，选择 Basic Tools 
> Display Controls > Start New Plot Window. 

通过在任何一个图表窗口使用 Options 菜单下的 New Window 选项，也可以启动新的图表（见
第 175 页的 “Plots - The Options Pulldown Menu”）。 

打开显示最大化（Maximize Open Displays） 

·  要调整所有显示窗口的大小，使其与现有屏幕大小相吻合，选择 Basic Tools > Display 
Controls > Maximize Open Displays. 

例如，若打开四个显示，每个显示将被调整到现有屏幕的四分之一。 

Administrator
第四章：基本工具
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链接显示（Link Displays） 

多个显示可以被链接，在一个显示内的所有操作将反映在其它显示中。当显示被链接，动态的

覆盖图是活动的（第 154 页的 “Multiple Dynamic Overlays”）。 

·  要链接显示，选择 Basic Tools > Display Controls > Link Displays. 

通过在任何一个显示内使用 Functions 菜单上的 Link 选项，显示也可以被链接（见第 153 页
的 “Linking Images”）。 

关闭所有显示（Close All Displays） 

·  要关闭所有打开的图像显示，选择 Basic Tools > Display Controls > Close All Displays。 

关闭所有绘图窗口（Close All Plot Windows） 

·  要关闭所有打开的图表窗口，选择 Basic Tools > Display Controls > Close All Plot Windows。 

鼠标按键描述（Mouse Button Descriptions） 
鼠标按键的描述可以用窗口内的光标给出鼠标按键的信息。当光标在窗口之间移动时，鼠标按

键的描述被更新。显示的信息包括窗口类型（即显示、绘图等），光标控制的功能（即感兴趣区、动

态覆盖图等），以及每个鼠标按键的操作（MB1: 鼠标左键；MB2: 鼠标中键；MB3: 鼠标右键）。 

注意 
若鼠标按键没有按你期望的那样作出反应，显示鼠标按键的描述，核对光标控制的功能。 

·  要显示一个前后联系的灵敏的鼠标按键描述对话框，选择 Basic Tools > Mouse Button 
Descriptions. 

图 4-2: Mouse Button Descriptions. 

显示信息（Display Information） 
该功能提供光标所在的显示窗口的有关信息。当光标在当前打开的显示窗口间移动，Display 

Information 对话框被更新。显示的信息包括显示号、使用的颜色数、显示的波段列表、当前应用到
各波段的拉伸类型，以及图像、缩放和滚动窗口的大小与像元范围。 

·  要显示前后灵敏（context sensitive）的显示信息，选择 Basic Tools > Display Information. 

 

图 4-3: Display Information 

光标位置/值（Cursor Location/Value） 
Cursor Location/Value 功能启动一个窗口，这一窗口记录一个显示窗口内鼠标光标的坐标，显示
光标的行 line（垂直的） 和像元（水平的） 的坐标。它也记录光标所在的像元的数据值和地理坐
标（对于地理坐标定位的数据）。你也可以通过使用主显示的 Functions 菜单下的 Interactive Analysis 
菜单，启动 Cursor Location/Value 窗口（详细的介绍，请见第 225 页的 “Cursor Location/Value”）。 
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当光标在任何一个显示窗口内（主图像、滚动或缩放）移动时，位置被连续更新。 

·  要启动 Cursor Location Value 窗口，选择 Basic Tools > Cursor Location/Value. 

测量工具（Measurement Tool） 
使用测量工具，获得多边形或折线内的点之间距离的记录，以得到多边形、矩形和椭圆的周长

和面积测量。 

注意 
使用感兴趣区功能，测量感兴趣区，请参阅第 210 页的 “ROI - Measurement Tool”。 

1. 选择 Basic Tools > Measurement Tool. 

出现 Display Measurement Tool 对话框。 

2. 在 “Display” 文本框内，输入想测量的显示号。 

3. 选择适当的图像窗口切换按钮（图像、滚动、缩放）。 

·  要在任何时间禁用测量功能，选择 “Off ” 切换按钮。 

4. 选择 Type > 你想测量的区域形状。 

5. 选择 Units > 所需要的测量单位。 

若图像的像元大小没有保存在文件头中，当出现 Input Display Pixel Size 对话框时，选择除 
“Pixel” 之外的任何单位，完成这些步骤。 

A. 在 “X Pixel Size” 和 “Y Pixel Size” 文本框中，输入你图像的像元大小。 

B. 从 “Units” 按钮菜单，选择单位类型，点击 “OK”。 

6. 在图像显示内，通过用鼠标左键点击，绘制所需要的形状。 

·  在矩形或椭圆模式下，用鼠标左键点击并拖曳到所需要的形状大小。 

·  要绘制一个正方形或圆，在矩形或椭圆模式下，按住鼠标中键的同时，点击并拖曳。 

7. 通过点击鼠标右键，闭合多边形或完成线段。 

·  要擦除形状，再次点击鼠标右键。 

对于多边形模式，顶点间的距离被列出，当多边形闭合时，周长和总面积被记录。 

对于折线，列出了顶点间的距离，当折线完成时，给出总距离。 

在矩形模式下，边长、周长和总面积被记录。 

在椭圆模式下，圆周和总面积被记录。 

Display Measurement Tool 对话框内的五个下拉菜单描述如下。 

File 下拉菜单 
使用 File 菜单，把测量信息保存到一个 ASCII 文件，并关闭对话框。 

·  要保存测量信息： 

1. 在 Display Measurement Tool 对话框内，选择 File > Save Points to ASCII. 
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2. 在 Output Measurement Directory 对话框内，键入一个输出文件名。点击 “OK”。 

·  要关闭 Display Measurement Tool 对话框，选择 File > Cancel. 

图 4-4: Display Measurement Tool 对话框。 

Units 下拉菜单 
使用 Units 菜单，选择要记录的测量单位。这些选项包括像元、米、千米、英尺、码、英里和
海里。 

·  选择 Units > 所需要的单位。 

若图像的像元大小没有保存在文件头中，当出现 Input Display Pixel Size 对话框时，选择除 
“Pixel” 之外的任何单位，完成这些步骤。 

A. 在 “X Pixel Size” 和 “Y Pixel Size” 文本框中，输入图像的像元大小。 

B. 从 “Units” 按钮菜单，选择单位类型。点击 “OK”。 

Area 下拉菜单 
使用 Area 菜单，按英亩或公顷测量面积。 

·  选择 Area > Acres or Hectares. 

Options 下拉菜单 
使用 Options 菜单，选择测量信息是记录为线段（系统默认值）还是点的坐标。 

·  要获得一列顶点的坐标，选择 Options > Report as Points. 

坐标将作为一个像元的位置（“Pixel （x，y）”） 被记录。 

·  要获得一列线段距离，选择 Options > Report as Segments. 

·  对于地理坐标定位的图像，选择 Options > Georef Map（x，y） 或 Georef（Lat/Lon），可以
列出地图坐标或经纬度坐标。 

·  要把点坐标的列表输出到一个文件，选择 File > Save Points to ASCII. 

感兴趣区域（Region of Interest） 
通过从层叠式的 Basic Tools 菜单选择 Region of Interest 选项，也可以选择感兴趣区（ROIs，
详细描述见第 199 页的 “Region of Interest”）。子菜单选项描述如下。 

定义感兴趣区（Define Region of Interest） 

·  要开始定义一个新的感兴趣区，选择 Basic Tools > Region of Interest > Define Region of 
Interest （图 4-5）。 

出现  ROI Definition 对话框（关于定义感兴趣区的细节，请见第  199 页的  “Region of 
Interest”）。 

恢复保存的 ROI 文件（Restore Saved ROI File） 

·  要恢复原先保存的感兴趣区文件，选择 Basic Tools > Region of Interest > Restore Saved ROI 



 152

File，然后选择需要输入的文件。 

将 ROIs 保存到文件（Save ROIs to File） 

·  要把当前内存中的感兴趣区保存到一个文件，选择 Basic Tools > Region of Interest > Save 
ROIs to File，为保持一致，键入一个扩展名为 .roi 的输出文件名。 

 

图 4-5: Region of Interest 层叠式菜单。 

调整ROIs（Delete ROIs） 

要删除感兴趣区： 

1. 选择 Basic Tools > Region of Interest > Delete ROIs. 

2. 当出现 Delete Regions 对话框时，点击你想删除的那个感兴趣区名。 

3. 点击 “OK”，永久地删除这些感兴趣区。 

调整ROIs（Reconcile ROIs） 

Reconcile ROIs 功能允许你在不同大小的图像中使用按另一图像大小定义的感兴趣区。 

1. 选择 Options > Reconcile ROIs. 

2. 当出现 Reconcile ROIs Parameters 对话框时，从下列选项中选择，确定要被调和的感兴趣区。 

·  要选择所有感兴趣区，点击 “Select All Items”。 

·  要选择一组感兴趣区，点击列表中的第一个需要的项，按住 “shift” 键；然后点击你想在该
组中包括的最后一个感兴趣区。或者点击并拖曳选择所需要的范围。 

·  要选择多个，但不是所有感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个需要的感兴
趣区。 

·  要取消选择已选择的项，点击 “Clear All Items”。 

3. 选择下列选项之一。 

·  要手动地指定新感兴趣区的空间大小。 

A. 把感兴趣区所在的图像原点和新图像原点之间的像元差值输入到 “Xoffset” 和 “Yoffset” 文
本框中。 

B. 把新图像的样本数和行数输入到适当的文本框中。 

·  要让 ENVI 自动地计算 x 和 y 偏移量以及样本数和行数： 

A. 点击 “Set Values from Source/Destination Files”。 

B. 当出现文件选择对话框时，选择感兴趣区最初被绘制在的那个文件，然后点击 “OK”。 

C. 当出现下一个文件选择对话框时，选择感兴趣区的目标文件，然后点击 “OK”。 

D. 在 Reconcile ROIs Parameters 对话框内，点击 “OK”。 
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该感兴趣区将被列在 ROI Controls 对话框中。 

该功能在  Region of Interest Control 对话框中也是可用的。更多细节，请见第  214 页的 
“Reconcile ROIs”。 

 

图 4-6: Reconcile ROIs Parameters 对话框。 

通过地图调整 ROIs（Reconcile ROIs via Map） 

该选项允许你在一幅重叠的地理坐标定位了的图像内使用另一幅定位了的图像中定义的感兴趣

区。 

1. 选择 Basic Tools > Reconcile ROIs via Map. 

2. 当出现 Reconcile ROIs via Map Parameters 对话框，通过在名字上点击，选择所需要的感兴
趣区。 

3. 选择绘制了感兴趣区的那个源文件。 

4. 选择感兴趣区将被调和到的那个地理坐标定位了的文件，然后点击 “OK”。 

该感兴趣区将被列在 ROI Controls 对话框中，并自动地被导入到新的图像上。 

该功能在  Region of Interest Control 对话框中也是可用的。更多细节，请见第  216 页的 
“Reconcile ROIs via Map”。 

用图象阈值定义 ROI（Image Threshold to ROI） 

要通过选择特定的图像值和范围，创建一个感兴趣区。 

1. 选择 Basic Tools > Image Threshold to ROI. 

2. 当出现 Image Threshold to ROI Input Band 对话框时，选择要被限定阈值的波段。 

3. 在 “Min Thresh Value” 和 “Max Thresh Value” 文本框中或其中之一中，输入数值，选择大于
或等于输入的最小值的那些像元，和/或小于或等于输入的最大值的那些像元。 

4. 通过使用适当的按钮，指定感兴趣区的名称和颜色，然后点击 “OK”。 

更多细节，请见第 223 页的 “Image Threshold to ROI”。 
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掩膜（Masking） 
Masking 允许你创建和使用图像掩膜。一个掩膜是由 0 和 1 值组成的一个二进制图像。当一

个掩膜使用在一个正在处理的功能中，1 值区域被处理，被屏蔽的 0 值区域不包括在计算中。 

“Mask Band” 的选择可以用于 ENVI的多项功能，如统计、分类、分离（unmixing）、匹配滤波、
连续统一删除（continuum removal）和波谱特征拟合。 

在 Masking 菜单下的 Build Mask 项允许通过指定的数据值、范围值、感兴趣区或从注释文件
定义图象掩膜。使用 Masking 下拉菜单中的 Apply Mask 项，可以将一个掩膜永远地应用于一幅图
象。单个菜单介绍见下面。 

 

图 4-7: 使用一个数据范围和导入的感兴趣区创建的掩膜图像实例。 

建立掩膜（Build Mask） 

要选择用于定义掩膜的打开的显示窗口： 

1. 选择 Basic Tools > Masking > Build Mask. 

2. 选择一个显示号，或选择 “No Display”。 

将出现 #n Mask Definition 对话框，样本数、行数和波段名将自动地被输入到 “Samples”、
“Lines” 和 “Input Band” 参数中。 

·  若没有显示窗口被打开，或你选择了 “No Display”，Mask Definition 对话框将直接出现，你
必须输入所需要的用来定义掩膜图像大小的样本数和行数。 

掩膜图像从三种输入类型中定义：通过从所选择的输入波段中输入最小和/或最大数据值和/或数
据范围；通过使用所选择的感兴趣区（ROIs）；从所选择的注记。 

 

图 4-8: Mask Definition 对话框。 

Options 下拉菜单 
从 Mask Definition 对话框内，选择下列选项。 

·  要输入数据值和范围： 

1. 在 Mask Definition 对话框内，选择 Options > Import Band Data Range. 

2. 点击 “Input Band”，更改输入波段。 

3. 当出现一个标准的 ENVI 输入文件选择对话框时，选择一个文件名。 

4. 在 “Band Min Value” 和 ”Band Max Value” 文本框中输入最小值和/或最大值，这些数据范围
属于 “Input Band” 文本框中列出的输入波段。 

5. 点击 “OK”，把范围输入到掩膜定义列表中。 

若只输入了最小值或最大值并点击 “OK”，该数据实际的最大值或最小值将分别用作另一端值
（the other end value）。 
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·  要在掩膜中包含一个注记文件，选择 Options > Import Annotation，然后选择所需要的输入文
件： 

注意 
只有矩形、椭圆和多边形注记被导入到掩膜定义中。 

·  要在掩膜中包含感兴趣区： 

1. 选择 Options > Import ROIs. 

2. 当出现 Mask Definition Import ROI 对话框时，在感兴趣区名上点击，选择所需要的感兴趣
区。 

·  要选择所有的感兴趣区，点击 “Select All Items”。 

·  要选择一组感兴趣区，点击列表中的第一个所需要的项，按住 “shift” 键，然后点击你需要
的该组中最后一个感兴趣区。 

·  要选择多个，但不是所有感兴趣区，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的感
兴趣区。 

·  要取消选择所有已选择的项，点击 “Clear All Items”。 

3. 点击 “OK”。 

·  要在掩膜中包含 ENVI 矢量文件（EVFs）： 

1. 选择 Options > Import EVFs. 

2. 当出现 Mask Definition Input EVFs 对话框，通过点击文件名，选择所需要输入的矢量文件。 

·  要选择所有文件，点击 “Select All Items”。 

·  要选择一组文件，点击列表中的第一个所需要的项，按住 “shift” 键，然后点击你需要的该
组最后一个文件。 

·  要选择多个，但不是所有的文件，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的文件。 

·  要取消选择所有已选择的项，点击 “Clear All Items”。 

3. 点击 “OK”。 

·  要在掩膜中包含当前显示的注记形状，选择 Options > Import Displayed Annotation. 

·  要把掩膜中定义的区域设置为 1 （On） 或 0 （Off），选择 Options > Selected Areas 
“On”/“Off ”。 

掩膜通过使用数据范围、注记和感兴趣区之间的逻辑或（Logical OR） 或逻辑与（Logical AND） 
运算来建立。系统默认值，逻辑或，将使用所有定义的区域来生成掩膜。 

·  要只使用列出的数据范围、注记形状和/或感兴趣区重叠的那些区域，定义掩膜，选择 Options 
> Selected Attributes [Logical AND]. 

·  要使用所有定义的区域生成掩膜，选择 Options > Selected Attributes [Logical OR]. 

·  要删除一项并从掩膜中删除，点击该项名称，然后点击 “Delete Item”。 

·  要清除 “Selected Attributes for Mask” 列表，点击 “Clear All Items”。 
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·  要建立掩膜，键入或选择一个掩膜输出文件名，或把掩膜输出到内存，然后点击 “Apply”。 

·  要关闭 Mask Definition 对话框，点击 “Cancel”。 

通过使用 Masking 菜单下 Apply Mask 的选项，掩膜可以被永久地应用到一幅图像上（见下）。 

应用掩膜（Apply Mask） 

要把一个掩膜永久地应用于一个输入文件或波段： 

1. 选择 Basic Tools > Masking > Apply Mask. 

2. 当出现 Apply Mask Input File 对话框时，选择所需要的输入文件和任何空间或波谱子集。 

3. 点击 “Mask Band”。 

4. 从可用的波段列表中选择所需要的掩膜。 

只有与输入波段大小相同的那些掩膜图像是有效的。 

·  要清除所选择的掩膜波段，选择 Options > Clear Mask Band. 

5. 当所需要的输入被选择，点击 “OK”。 

6. 当出现 “Apply Mask Parameters” 对话框时，在 “Mask Value” 文本框中输入所需要的值。 

输入图像中掩膜值为 0 的所有区域，将被设置为这个掩膜值。 

7. 键入一个输出文件名或选择输出到内存。 

 

统计（Statistics） 
Basic Tools 菜单下的 Statistics 选项，允许你生成图像文件的统计记录，以及生成直方图、平均
波谱、特征值，和其它统计信息。基本的统计信息和/或表格的直方图信息（频率分布）可以用于单
波段或多波段图像计算。最小值、最大值和平均波谱只能用于多波段图像计算。相似地，协方差统

计信息（包括特征向量和一个相关矩阵） 也只能为多波段图像计算。统计信息按双精度计算。你可
以选择把统计信息输出到一个文件或屏幕上。选择下列选项之一，计算新的统计信息，或查看以前

生成的统计信息。 

计算统计（Compute Statistics） 

1. 选择 Basic Tools > Statistics > Compute Statistics. 

将出现 Calculate Statistics Input File 对话框。 

2. 通过点击标签为 “Select Input File” 的列表中的文件名，选择输入文件。 

文件特征的细节，显示在标签为 “File Information:” 的文本小部件中。 

3. 通过点击适当的子集按钮，选择按标准方式的空间或波谱构造子集。 

·  要在计算统计信息之前，把一个掩膜应用于数据，点击 Mask Band”，然后选择所需要的掩
膜图像。 

4. 一旦文件已经被选择，构造子集，并按需要掩膜，点击 “OK” ，继续。 
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将出现 Calculate Statistics Parameters 对话框。在该对话框中，你将选择要计算的统计信息类型，
和要生成的记录类型。 

 

图 4-9: Calculate Statistics Parameters 对话框。 

5. 选择你想生成的统计信息类型。要获得选择和设置选项的详细介绍，请参阅第 344 页的 
“Basic Statistics”，第 344 页的 “Histogram Statistics”，第 345 页的 “Covariance Statistics”。你可以
选择任何的单个选项或组合选项。 

6. 选择统计信息类型后，选择下列选项。 

·  在进行统计信息计算时，你可以使用一个调整大小系数的选项来提高性能。要设置调整大小
系数，在 “Samples/Lines Resize Factor” 文本框中输入所需要的调整大小系数（小于 1 的值将跳过
一些像元，即值“0.5”将告诉 ENVI 在计算统计信息时，使用每隔一个像元）。 

·  若你想把统计信息保存到一个 ENVI 格式的统计信息文件，以便以后用 ENVI 功能加快处
理。在 “Enter Output Stats Filename” 标签下输入或选择一个文件名。系统默认统计信息文件的扩展
名为 .sta 。 

7. 点击 “Report” 标签旁的 “Screen” 和/或 “File” 复选框。 

·  若你选择 “Screen” 选项，所有选择的统计信息的输出将在一个独立的窗口内用一个全文本
的记录显示。该记录可能很冗长，因此取消选择 “Calculate Histogram Statistics” 标签下的 “Text 
Report” 复选框，以减小记录的大小，这可能效果更佳。一旦记录显示在屏幕上，你可以选择 File > 
Save Text to ASCII，把记录保存到一个文本文件。 

·  若你选择 “File” 输出，为记录输入或选择一个文件名。系统默认 ENVI ASCII 文件的扩展名
为 .txt 。 

8. 要更改记录中显示的数据精度，点击对话框底部的 “Set Report Precision” 按钮。 

·  要设置小数点后显示的数字位数，使用 “Data Precision” 标签旁的箭头增量按钮。 

·  要为显示在 ASCII 记录中的数字指定格式，点击 “Floating Report” 标签旁的箭头切换按钮，
选择 “Scientific” 或 “Normal”。一个常规的数字将按照十进制形式（例如，25.88），而一个科学记
数法的数字将显示一个带小数点的数字和 “e”（指数的） 幂（例如，2.588e+001）。 

9. 点击 “OK”，启动统计信息的计算。 

将出现一个小窗口，并用一个滑动块从 0 到 100％，显示处理完成量的百分比。 

一旦统计信息被计算完，出现 File Statistics Report 窗口。 

·  通过点住一角并拖曳到所需要的大小，调整窗口的大小。 

如 图 4-9.所示，有三种记录类型。 

若只选择了基本的统计信息，那么每个所选择波段的最小值、最大值、均值和标准差将被列出。

若选择了直方图，一个记录将从频率分布被创建，若直方图内的二进制数是 256 或更小，在图像直
方图内为每个 DN 列出点数 “Npts”、“Total”（累积点数）、“Pct”（各二进制值的百分比） 和累积
百分比 “Acc Pct”。一个直方图也将被显示。整个频率分布将被打印到输出记录文件，但是考虑到内
存，大于 256 的二进制数的频率分布不被显示到屏幕记录上。若选择了协方差，记录显示每个波段
的协方差以及特征向量的相关矩阵。若三个选项都被选择，所有的统计信息将显示在一个 “File 
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Statistics Report” 中。 

 

图 4-10: 一个 File Statistics Report 。 

 

基本统计（Basic Statistics） 
基本统计信息包括所有波段的最小值、最大值、均值和标准差，若该文件是多波段的，还包括

特征值。从下列选项中选择任意一个或所有的基本统计信息。 

·  要在屏幕上查看基本统计文件，或把记录写到一个 ASCII 文件，若还没有核对，点击 “Text 
Report” 复选框。若你不选择该项，输出的将是一个 ENVI .sta 二进制文件。 

·  要为每个波段绘制最小值、最大值、均值和正或负标准差波谱，选择 “Min/Max/mean Plot” 旁
的复选框。该选项只对包含一个波段以上的图像有效，并且输出的将是一个图表。 

·  要绘制各波段内的标准差，点击 “Stdev Plot” 标签旁的复选框。该选项只对包含一个波段以
上的图像有效，并且输出的将是一个图表。 

注意 
要生成一个特征值图象，你必须先选择 “Calculate Covariance Statistics” 复选框，然后选择 

“Eigenvalue Plot” 标签旁的复选框。 

直方图统计（Histogram Statistics） 
要为你的输入波段生成统计的直方图，按照下列步骤。 

1. 点击 “Calculate Histogram Statistics” 复选框。 

2. 通过点击适当的复选框，选择你想把直方图输出到的绘图窗口，或一个文本记录，还是输出
到两者。 

·  若你选择 “Histogram Plots”，通过点击 “Histogram plots per window” 标签旁的箭头按钮，指
定每个图表窗口要绘制的输出直方图数目。例如，你有六个输入波段并选择了 “5”，那么前五个波
段将显示在第一个图表窗口内，最后一个波段将显示在一个单独的窗口内。 

 

图 4-11: 统计信息的直方图图表。 

协方差统计（Covariance Statistics） 
你只能为多个波段（一个波段以上）的输入文件，生成协方差统计信息。要记录协方差和相关

矩阵再加上特征值和特征向量，按照下列步骤。 

1. 选择 “Calculate Covariance Statistics” 复选框。 

2. 通过选中 “Covariance Image” 和/或 “Text Report” 复选框，选择你想把协方差、相关和特征
向量矩阵输出到图像，或一个文本记录，还是输出到两者。 

·  若你选择 “Covariance Image”，结果的图像将显示在可利用波段列表中。图像的大小将是波
段数乘以波段数。当你导入这些图像，它们将显示在一个缩放窗口中。你可以作为表面（as surfaces）
显示图像，以及使用 Cursor Location/Value 功能获取实际值（通过从 Functions 菜单中选择）。 
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·  若你选择 “Text Report”，协方差和相关矩阵将按文本形式显示。 

·  要生成一个基本的特征值输出图表，选择 “Basic Statistics” 下的 “EigenValue Plot” 复选框。 

浏览统计文件（View Statistics File） 

要通过 “Compute Statistics” 功能（作为 .sta 文件）或其它创建统计信息文件的功能（例如，
“Principal Components”），查看原先保存的统计信息。 

1. 选择 Basic Tools > Statistics > View Statistics File. 

2. 当出现标准的 ENVI 文件输入对话框时，选择一个有效的统计信息文件。 

将出现 View Statistics File 对话框。使用该对话框，选择要生成的记录类型。 

这些选项与上述 Calculate Statistics Parameters 对话框相似。 

注意 
在 View Statistics File 对话框中可用的选项，视初始文件计算得到的统计信息类型而定（例如，
若没有计算初始文件的协方差统计信息，那么协方差信息在 View Statistics File 对话框中是无效
的）。 

3-D 曲面飞行（3-D SurfaceView） 
ENVI 的 3-D SurfaceViewTM 功能允许你 “fly-through” 三维数据集。用一幅灰阶或彩色图像（如

一个线框架、规则网或点）覆盖在数据集上面，仍可以显示数据（The data can be displayed with a 
grayscale or color image draped over it,as a wire frame, ruled grid,or points）。你可以使用鼠标光标，实
时地旋转、平移及缩小和放大这个 3-d 表面。可以交互式限定或用 ENVI 的注记画出飞行路线。
飞行路线可以制成动画，形成数据的 3-d fly-throughs。垂直和水平视角可以被控制，你可以在表面
上空一个恒定高度或一个恒定的海拔高度飞行穿过你的数据。光标也被链接到覆盖的图像上，它允

许从 3-d 投影图中查看剖面图、光标位置和数值。 

注意 
若你正在一个 Windows 系统上运行 ENVI，你必须使用 16-bit 或 24-bit 彩色显示模式。 

要启动 ENVI 的 3-D SurfaceView 功能： 

1. 在一个显示窗口内，显示你想将其覆盖在你的 DEM（或其它 3-d 数据集）上的那幅灰阶或
彩色图像。 

整个被显示的图像作为覆盖图像使用在 DEM 上，除非你的图像和 DEM 文件都是地理坐标定
位了的。若这两个文件都定位了，那么只有与你的 DEM 重叠的图像部分被使用。若这个 DEM 是
个子集，那么地理坐标定位了的图像也使用子集来匹配。这两个文件的空间分辨率不必相同。 

2. 选择 Basic Tools > 3-D SurfaceView. 

3. 若有一幅以上的显示窗口被打开，选择包含所需要图像的那个显示窗口。 

4. 选择相应的数字高程模型（DEM） 输入文件（或其它 3-d 数据集），若有必要，执行任何
空间构造子集。 

将出现 3D SurfaceView Input Parameters 对话框。 
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5. 选择所需要的 DEM Resolution （像元数） 复选框，用于 3-d 图。DEM 将按照所选择的分
辨率被重采样。 

警告 

使用较高的 DEM 分辨率明显使显示速度减慢，并且只能使用在功能强大的平台上。 

可以选择一种以上的分辨率。典型地，当你正在确定最佳的飞行路线时，你将会使用最低的分

辨率（64）。然后你可以使用一个更高的分辨率，显示你最终的飞行序列。 

6. 若有必要，输入 DEM 的最小和最大绘图值。 低于最小值和高于最大值的 DEM 值，将不
被绘制在这个 3-d 图中。 

7. 输入垂直方向的放大系数。 

输入的值将使得垂直方向真正放大。值越高，放大越多。 

8. 选择 “Full” 或 “Other” 图像分辨率。若 “Other” 选择，图像将按输入的像元数被重采样。 

9. 点击 “Spatial Subset” 按钮，若有必要，选择图像的一个空间子集。 

DEM 的空间大小不必和图像的大小相同。这两个数据集的全部像元 full dimensions（或所选择
的子集） 都将被显示。 

10. 输入图像的 X 和 Y 像元大小。 

像元大小用于决定恰当的垂直放大系数，它们必须和 DEM 的单位相同。 

11. 点击 “OK”。 

将出现 3-D SurfaceView 图表和 3-D SurfaceView Controls 对话框（见 图 4-12）。 

3-D 曲面飞行中的光标功能（Cursor Functions in the 3-D SurfaceView 

Plot） 

鼠标光标和按钮用于交互式地旋转、平移和缩放表面。用鼠标左键点击并按水平方向拖曳，将

绕着 Z 轴旋转表面。用鼠标左键点击并按垂直方向拖曳，将绕着 Y 轴旋转表面。用鼠标中键点击
并拖曳，将按该方向平移（移动图像）。用鼠标右键点击并向右拖曳，将放大图像。用鼠标右键点击

并向左拖曳，将缩小图像。鼠标按键的功能列在 表 4-1 中。也可以从 3-D SurfaceView Controls 对
话框，控制旋转、平移和缩放（见下）。 

注意 
通过选择 3-D SurfaceView Controls 对话框内的 Options > Reset View，表面图可以被重新设置

到它以前的位置。 

当 Cursor Location/Value 功能被激活，光标位置和数值可以从 3-d 图中读取。X、Y 和 Z（高
程） 值从 3-d 模型中读取，并且是近似的。若你的覆盖图像是地理坐标定位了的，地图位置也被
记录。 

用鼠标左键在 3-d 图中的一个像元上双击，将把缩放窗口移动到显示窗口中包含覆盖图像的像
元上。若 X、Y 或 Z（波谱） 剖面图在显示窗口内是活动的，通过双击，剖面图可以被链接到 3-d 
光标位置。 
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图 4-12: 3D SurfaceView 显示和 3D SurfaceView Controls 对话框。 

 

鼠标按

键 
操作 

左 点击并拖曳旋转 X/Y 平面 

或双击定位到显示窗口内的像元 

中 点击并拖曳平移图像 

右 点击并向右拖曳放大 

点击并向左拖曳缩小 

表 4-1: 3-D SurfaceView 图表窗口内的光标功能。 

 

3-D SurfaceView Controls 对话框 

对于 “User Defined” 路径模式和 “Annotation” 路径模式，3-D SurfaceView Controls 对话框有
不同的参数，并有三个下拉菜单。“User Defined” 模式可以用来控制旋转、平移和缩放图表的位置，
定义一个飞行路线，以及播放飞越你图像的一个视图序列。“Annotation” 模式用来导入一个飞行路
线，它是通过在你的图像上使用注记折线或形状定义的。你可以控制垂直和水平视角，在 DEM 地
形上空一恒定的高度飞行，或在一恒定的海拔高度飞行。请参阅下面关于这两种模式的对话框参数

和下拉菜单的描述。 

User Defined Mode对话框 
当选择 “User Defined” 按钮时，User Defined 模式参数是有效的。 

·  要更改表面图的旋转度，点击 “Rotate” 旁的箭头。在 “Rotate” 文本框中，输入一个值（用
度数做单位），更改旋转度的增加量。 

·  点击 “Trans” 旁的箭头，按箭头显示的方向移动图像。在 “Trans” 文本框中输入一个值，更
改平移增加量。 

·  要放大和缩小图像，分别点击 “Zoom” 旁的加号和减号按钮。在 “Zoom” 文本框中输入一
个值，更改缩放的增量。 

飞行（Fly-Through） 
·  要定义一个飞行路线，并对你的数据进行飞行浏览： 

1. 使用鼠标或箭头按钮，选择起始位置。 

2. 在 User Defined Mode 对话框内，点击 “Add” 按钮，把该位置添加到飞行路线上。 

3. 使用鼠标或箭头按钮，选择另一个投影，然后点击 “Add” 按钮。 

飞行路线将在这两次位置之间进行平滑内插。 

4. 重复步骤 3，直到你选择了足够多的飞行位置（至少两个）. 
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·  要代替飞行路线列表中的某一次飞行位置，在路线的浏览号上点击，然后点击 “Replace”。 

·  要删除飞行路线列表中的某一个飞行位置，在路线的浏览号上点击，然后点击 “Delete”。 

·  要清除飞行路线列表，点击 “Clear”。 

5. 输入要在 “fly-through” 动画中使用的帧数。 

飞行路线将在所有的飞行位置之间进行平滑内插。 

6. 点击 “Play Sequence” 按钮，来播放飞行动画。 

·  使用 Options > Animate Sequence 选项，控制飞行的速度和方向（参见第 352 页的 “The 
SurfaceView Pulldown Menus”）。 

Annotation Mode 对话框 
选择 “Annotation” 按钮，在使用注记的显示窗口内的图像上绘制一个飞行路线（参见第 250 页

的 “Annotation”）。折线、多边形、矩形或椭圆注记对象，可用于定义飞行路线。也可以输入保存的
注记文件。 

·  要选择显示窗口内定义的注记对象，作为飞行路线使用，选择 File > Input Annotation from 
Display，然后选择所需要的注记对象。 

·  要从一个已保存的文件中选择注记对象，作为飞行路线使用，选择 File > Input Annotation 
from File，然后选择所需要的注记文件和对象。 

所选择的注记对象、节点数、点数显示在对话框的中间，飞行路线被绘制在表面上。 

·  通过使用沿着线条的点的移动平均，平滑飞行路线，在 “Smooth” 文本框中的平均值内，输
入需要使用的点数。 

·  要在表面上重新绘制飞行路线，点击 “Replot Trace” 按钮。 

·  要在 DEM 地形上空一恒定高度飞行，点击箭头切换按钮直到出现 “DEM Clearance”，然后
输入所需要的高度（与 DEM 的单位相同）。 

·  要在表面上空一恒定海拔高度飞行，点击箭头切换按钮直到出现 “Constant Elev”，然后输入
所需要的海平面以上的高度（与 DEM 的单位相同）。 

·  要调整垂直的视角，在适当的文本框中输入所需要的角度数。 

一个 –90 度的垂直视角，表示垂直表面向下观察。一个 0 度的视角，表示笔直向前观察（水
平的）。 

·  要调整水平视角，在适当的文本框中输入所需要的角度数（单位：度）。 

一个 –90 度的水平视角表示向左观察，一个 0 度的视角表示笔直向前观察，一个 90 度的视
角表示笔直向右观察。 

·  在 “Frames” 文本框中输入所需要的帧数，在播放数据的飞行动画时使用。 

·  点击 “Play Sequence” 按钮，播放飞行动画。 

使用 Options > Animate Sequence，控制飞行的速度和方向（参见第 352 页的 “The SurfaceView 
Pulldown Menus”）。 
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SurfaceView 下拉菜单 

3-D SurfaceView Controls 对话框有三个下拉菜单。File 下拉菜单允许保存和恢复飞行路线，注
记对象以及输出发射帧。Surface 下拉菜单控制表面图的类型和分辨率。Options 下拉菜单允许你重
新设置视图，选择一个位置并浏览全景，播放飞行动画，更改垂直的放大系数，平滑表面，以及其

它选项。 

File 下拉菜单 
·  要把当前的飞行类型保存到一个文件： 

1. 选择 File > Save path to file. 

2. 为了保持一致性，键入一个扩展名为 .pat 的输出文件名。 

·  要恢复一个原先保存的飞行路线，选择 File > Restore path from file，然后选择所需要的 .pat 
文件名。 

该选项只在 “User Defined” 模式下有效。 

·  从显示窗口内绘制的一个注记对象，输入飞行路线： 

1. 选择 File > Input Annotation from Display. 

2. 选择所需要的注记对象。 

该选项只在 “Annotation” 模式下有效。 

·  要从一个已保存的注记文件，输入飞行路线： 

1. 选择 File > Input Annotation from File. 

2. 选择所需要的注记文件和对象。 

该选项只在 “Annotation” 模式下有效。 

·  要输出当前的表面图，选择 File > Output Surface > Image File， Printer 或 VRML （参见
第 310 页的 “Display Output Options”）。 

VRML 选项把表面保存到一个 VRML 2.0 文件。 

·  要把一个飞行序列输出到一个 MPEG 文件，按照这些步骤： 

1. 定义所需要的路线序列。 

2. 选择 FIle > Output Sequence to MPEG. 

3. 从这个下拉菜单，选择所需要的 MPEG Frame Rate （帧频）。 

4. 输入所需要的 MPEG 压缩质量。 

这种压缩是有损压缩，其中 0 是最低质量，100 是最高质量（没有压缩）。输入一个小于 100 的
压缩质量系数，减小用于保存 MPEG 输出的磁盘空间。 

5. 若有必要，输入一个复制系数。 

这有助于使 MPEG 输出显得更平滑些。例如，复制系数为 2，将复制每帧，并且输出帧数加
倍。 
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6. 键入一个输出文件名，然后点击 “OK”。 

注意 
输出 MPEG 文件的写操作按照两个步骤进行，且第二步不能被取消，并且每帧可能占用

很多秒时间。 

·  要退出 3-D SurfaceView 功能，选择 File > Cancel. 

Surface 下拉菜单 
3-d 表面可以用一幅灰阶或 RGB 图像覆盖在上面，作为丝网（wire mesh）、直纹 XZ（ruled XZ）、
直纹 YZ（ruled YZ） 或点来绘制。 

·  要显示所需要的表面图类型，选择 Surface > Image，Wire，Ruled XZ，Ruled YZ，或 Point. 

若在 SurfaceView Input Parameters 对话框中选择了一个以上的 DEM 分辨率，你可以从中选择
一个用于绘图。 

·  要显示使用所选择分辨率的表面，选择 Surface > DEM 分辨率。 

Options 下拉菜单 
·  要把表面图重新设置为系统默认的视图，选择 Options > Reset View. 

·  要像你“站立”在图像中一样，浏览表面图全景： 

1. 选择 Options > Position View. 

将出现 SurfaceView Positioning 对话框。 

2. 通过点击箭头切换按钮，对于地理坐标定位了的图像选择 “Map Coord”，对于非地理坐标定
位的图像，用箭头切换按钮选择 “Pixel Coord” 。 

·  若你选择 “Pixel Coord”，输入你想站立的那个样本和行坐标，或使用箭头增量按钮选择坐标。 

注意 
若你的图像是一幅大图像的一个子集，通过点击 “Use Offset” 旁的箭头切换按钮选择 “Yes”，

你可以使用来自头文件的 X 和 Y 像元偏移量。 

·  若你选择 “Map Coord”，输入你想站立位置的地图坐标，然后点击 “Change Proj”更改投影（若
有必要）。 

3. 通过点击 “Auto Apply” 标签旁的 “Yes” 或 “No” 切换按钮，设置是否自动地应用更改。 

·  若你选择 “No”，更改任何参数后，点击 “Apply”。 

4. 从下列选项中选择，更改你在表面视图中的位置和视角。 

·  要更改你站立的位置，在图像内一点双击，自动移动到该位置。 

位置的更改在主显示和 3-D 表面图中都被反映。 

·  要更改方位角观察方向（正北为 0，角度按顺时针方向增加），使用 “Azimuth” 标签旁的滑
动条，或点击箭头增量按钮，环视全景 （要以 5 度的增量更改角度，用鼠标中键点击箭头）。 

·  要更改你观察的高度角，使用 “Elevation” 旁的滑动条 （要以 5 度的增量更改角度，用鼠
标中键点击箭头）。 
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一个 0 度的角度是水平的，一个负的角度是向下看。 

·  要更改图像上往下观察的高度，在 “Height Above Ground” 文本框中输入一个数字，或使用
箭头增量按钮更改高度。 

使用的单位必须和 DEM 的相同。 

·  要播放当前飞行路线的动画，选择 Options > Animate Sequence. 

3-D SurfaceView Controls 对话框将发生改变，显示动画控件。“Frame Number” 滑动条将指示正
被显示的帧数。前几次通过帧序列可能很慢，直到帧被输入到内存中。 

·  要更改动画速度，移动 “Animation Speed” 滑动条。 

·  要控制飞行路线方向，点击所需要的箭头按钮。 

·  要退出 Animate Sequence 功能，点击 “End Animation” 按钮。 

·  要更改垂直的夸大系数： 

1. 选择 Options > Change Vertical Exaggeration 

2. 在文本框中输入所需要的值，或使用箭头增量按钮。 

输入的值将使垂直方向真正地放大应用于 Z 轴，其中值越高，放大的倍数越大。 

·  当丝网或直纹曲面被显示时，要看透丝网线，选择 Options > Wire Lines:See Through. 

·  当显示一个丝网或直纹曲面时，使用隐藏的丝网线，选择 Options > Wire Lines:Hidden. 

注意 
该选项比使用 Wire Lines:See Through 选项要慢得多。 

·  要更改背景颜色，选择 Options > Background:Black 或 White. 

·  要关闭和开启注记飞行路线追踪，选择 Options > Annotation Trace:Off 或 On. 

·  要“平滑”放大时出现“像元化”的 3-D 表面视图，选择 Options > Interpolation:Bilinear. 

·  要关闭平滑效果，选择 Options > Interpolation:None. 

波段运算（Band Math） 
Band MathTM 功能允许你处理导致单个波段输出的复杂表达式。这些数学表达式也可以应用于一

个多波段文件中的所有波段，providing “File Math”。 

关于使用波段运算的更多信息，请参阅 ENVI Programmer’s Guide 第 29 页的 “Band Math 
Basics”。 

可利用波段运算功能（Available Band Math Functions） 

Band Math 功能为用户提供一个灵活的图像处理工具，其中许多功能是无法在任何其它的图像
处理系统中获得的。该功能的能力与 IDL 语言的能力直接相关。可用的函数包括但不仅限于 表 4-2 
中列出的数学表达式。 
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Series and Scalar 
数学 

三角函数 其它波段运算选项 

加 （+） 正弦 （sin（x）） 关系运算符 （EQ、NE、LE、
LT、GE、GT） 

减 （-） 余弦 （cos（x）） 逻辑运算符  （AND、OR、
XOR、NOT） 

乘 （*） 正切 （tan（x）） 类型转换函数（byte， fix， 
long， float， double， complex）

除 （/） 反正弦 （asin（x）） IDL 返回数组结果的函数 

最小运算符 （<） 反余弦 （acos（x）） IDL 返回数组结果的程序 

最大运算符 （>） 反正切 （atan（x）） User IDL 函数和程序 

绝对值 （abs（x）） 双曲正弦 （sinh（x））  

平方根 （sqrt（x）） 双曲余弦 （cosh（x））  

指数 （^） 双曲正切 （tanh（x））  

自然指数 （exp（x））   

自然对数 （alog（x））   

以 10为底的对数 
（alog10（x）） 

  

表 4-2: 一些可用的波段运算函数。 

 

注意 
一些有效的 IDL 表达式要求整个输入数组存在于内存中，它可以不必与 ENVI tiling 操作相兼

容。 

Band Math 对话框 

1. 选择 Basic Tools > Band Math. 

将出现 Band Math 对话框。假如运算结果是一个二维数组，它将接受任何有效的 IDL 数学表
达式、函数或程序。 

2. 在标签为 “Enter an expression:” 的文本框内，输入变量名（将被赋值到整个图像波段或可能
应用到一个多波段文件中的每个波段） 和所需要的数学运算符。 

变量名必须以字符 “b” 或 “B” 开头，后面跟着 5 个以内的数字字符。 

实例： 

若你想计算三个波段的平均值，数学方程式： 

（float（b1）+float（b2）+float（b3））/3.0 

可以输入到文本框中。该表达式中使用的三个变量，“b1” 是第一个变量，“b2” 是第二个变量，
“b3” 是第三个变量。注意，在本例中，IDL 的浮点型函数用来防止计算时出现字节溢出错误。 
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3. 一旦一个有效的表达式被输入，点击 “OK”处理。 

将出现 Variable/Band Name Pairings 对话框。请参见以下部分。 

·  要重新使用、保存或取消任何以前应用的数学表达式： 

1. 点击显示在 “Previous Expression:” 列表中的任何表达式，把它导入到 “Enter an expression:” 
文本区中。 

2. 一旦被导入，点击 “OK”，把该表达式应用到一组新的波段。 

将出现 Variable/Band Name Pairings 对话框。请见下列的详细向导。 

·  要把表达式保存到一个输出文件，点击 “Save”，然后当出现 Enter Output Filename 对话
框时，键入输出文件名。 

为了保持一致，输出文件名应该指定扩展名为 .exp 。 

·  要恢复原先保存的表达式，点击 “Restore”，然后选择适当的文件名。 

该表达式将显示在 “Previous Expression:” 列表中。 

·  要清除所有原先的表达式，点击 “Clear”。 

 

图 4-13: Band Math 对话框。 

Variable/Band Name Pairings 对话框 

Variable/Band Name Pairings 对话框允许你从一个输入波段列表中，把波段赋值给输入在 “Enter 
an expression:” 文本框中的变量。 

·  要把一个值赋给原先实例中的变量 “b1”： 

1. 在标签为 “Variables used in expression:” 的文本框内，点击表达式 “B1”。 

2. 在标签为 “可利用波段列表:” 的列表中，点击所需要的波段。 

注意，一旦第一个波段被选择，只有那些相同空间大小的波段被显示在波段列表中。 

3. 按照同种方法，为 “B2”、“B3” 等赋予一个值。 

·  要把一个多波段图像赋值给一个或所有变量： 

1. 点击 “Map variable to Input file”。 

2. 使用标准的 ENVI 文件选择步骤，选择一个文件（这可视为 “File Math”）。 

所选择的文件可以是波谱子集，但是若一个以上的文件被使用，它们必须有相同的波段数。 

通过数学表达式修改的文件数学（file math），一个多波段输出图像产生。 

3. 一旦所有变量被定义，标准的 ENVI 输出对话框显示在 Variable/Bands Pairings 对话框的底
部。 

·  要选择一个空间子集： 

1. 点击 “Spatial Subset”。 
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2. 将出现标准的  File Spatial Subset 对话框  （第  145 的  “Standardized ENVI Spatial 
Subsetting”）。系统默认值被设置为处理整个空间场景。 

·  要把结果输出到一个文件或内存，选择 “File” 或 “Memory” 切换按钮。 

·  若选择输出到一个文件，键入一个输出文件名，或使用 “Choose” 按钮选择一个文件名，然
后点击 “OK”。 

结果图像被显示在可利用波段列表中。 

运用 IDL 程序和波段运算功能 

由于 ENVI 为你提供对 IDL 性能的访问，你可以使用内置的 IDL 功能部件的能力、IDL 用
户函数，或书写你自己的程序执行自定义的操作。这些函数的唯一要求是它们接受一个或多个图像

阵列作为输入，并且它们输出一个单波段二维数组的计算结果。这些函数必须保存在 IDL 路径列表
内的一个目录下，以便它们将自动编译。通过使用 ENVI 主菜单 System 下拉菜单下的 Compile 
Module 选项（见 ENVI Programmer’s Guide 第 23 页的 “Incorporating New Routines”），也可以对
它们进行编译。以下是用户波段运算功能的一些简单的实例。要获得更多关于使用波段运算执行用

户自定义程序的信息，请参阅 ENVI Programmer’s Guide 第 29 页的 “Band Math Basics” 和 ENVI 
用户函数指南 。 

波段运算函数 1 
下面的实例是一个非常简单的自定义波段运算函数，它把两个波段相加。下面的程序文本可以

在一个文本编辑器中输入，并用文件名 user_bm1.pro 来保存： 

实例： 

FUNCTION user_bm1， b1， b2 

RETURN， b1+b2 

END 

要从 Band Math “Enter an expression:” 文本框中调用该函数，使用语法： 

user_bm1（b1，b2） 

波段运算函数 2 
下面的实例是一个自定义的波段运算函数，它把一个变量的数据类型转换为字节型，并将

数值倒置（inverts the values）。下面的程序文本可以在一个文本编辑器中输入，并用文件名 
user_bm2.pro保存： 

实例： 

FUNCTION user_bm2， b1 

lut = 255 - BINDGEN（256） 

b1 = BYTSCL（b1） 

b1 = lut（b1） 

RETURN， b1 

END 
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要从 Band Math “Enter an expression:” 文本框中调用该函数，使用语法： 

user_bm2（b1） 

波段运算函数 3 
下面的实例是一个自定义的波段运算函数，当 b1非零时，它用变量 b2 的值代替变量 b1。这
一函数对分类图象非常有用，它用于将另一幅图象的像元代替分类的像元。下面的程序文本可以在

一个文本编辑器中输入，并用文件名 user_bm3.pro 来保存： 

实例： 

FUNCTION user_bm3， b1， b2 

b1 = （b1 NE 0）*b2 

RETURN， b1 

END 

要从 Band Math “Enter an expression:” 文本框中调用该函数，使用语法： 

user_bm3（b1，b2） 

波段运算函数 4 
下面的实例是一个自定义的波段运算函数，它计算归一化差值植被指数（Normalized Difference 

Vegetation Index，NDVI），并把它缩放到字节数据范围。注意，“min” 和 “max” 关键字在函数中是
必需的，以确保同样的最小和最大值被用于缩放一个 tiled图像中所有的 tiles。 

对于变量 b1，应该使用一个 0.8 µm 附近的红外图像波段，而对于变量 b2，应该使用一个 0.6 
µm 附近的“红”波段。下面的程序文本可以在一个文本编辑器中输入，并保存为 user_bm4.pro： 

实例： 

FUNCTION user_bm4， b1，b2 

b1=bytscl （（float（b1） - b2） / （float（b1）+b2）， min=-1.0，max=1.0） 

RETURN， b1 

END 

要从 Band Math “Enter an expression:” 文本框中调用该函数，使用语法： 

user_bm4（b1，b2） 

拉伸数据（Stretch Data） 
Stretch Data 选项允许你执行文件-文件的对比度拉伸。数据拉伸功能是用于更改一个给定输入

文件数据范围的一种灵活方法。你可以完全控制输入和输出直方图，以及输出数据类型（字节型、

整型、浮点型等）。关于交互式拉伸的信息，请见第 187 页的 “Interactive Stretching”。 

1. 选择 Basic Tools > Stretch Data. 

出现 Data Stretching Input File 对话框。使用该对话框，通过使用标准的 ENVI 输入文件小部
件选择输入的数据文件。 

2. 从标签为 “Select Input File” 的列表中，选择一个文件名。 
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该文件特征的细节，显示在标签为 “File Information:” 的文本小部件内。 

3. 一旦被选择，你可以用标准方式点击适当的子集按钮，选择一个空间或波谱子集。 

4. 一旦文件被选择并按需要构造了子集，点击 “OK” ，继续。 

出现 Data Stretching 对话框。 

5. 在标签为 “Min” 和 “Max” 的文本框中，分别输入所需要的最小和最大值，控制输入数据的
范围。 

6. 使用窗口顶部的切换按钮，按百分比或按数值（by value）来选择数值。 

7. 通过选择适当的切换按钮，选择拉伸类型（“Linear”、“Equalize”（直方图均衡）、“Gaussian” 和 
“Square Root”）。 

8. 在 “Output Data” 标签下的 “Min” 和 “Max” 文本小部件内，设置输出数据范围。 

在这里输入的值必须和从 “Data Type” 菜单选择的数据类型的范围相匹配。若输入了溢出值，
低值将被自动地纠正到所选择数据类型的最小值，高值被自动地纠正到最大值。 

9. 从 “Data Type” 菜单，选择适当的数据类型（byte < 字节型 > ，integer < 整型 > ，unsigned 
integer < 无符号整型 > ，long integer < 长整型 > ，unsigned long integer < 无符号长整型 > ， 
floating point < 浮点型 > ， double precision < 双精度型 > ，complex < 复型 > 或 double complex 
< 双精度复型 >。 

 

图 4-14: Data Stretching 对话框。 

10. 在标签为 “Output Filename” 的文本小部件中，键入输出文件名，然后按回车键。 

11. 一旦所有的参数被正确地输入，点击 “OK” ，启动处理。 

若不存在所选择的输入文件的统计信息文件，在数据拉伸前，先计算图像的统计信息，并且当

一个滑动条从 0 到 100％ 移动时，一个标签为 “Image Statistics” 的小窗口显示处理完成量的百分
比。若一个统计信息文件已经存在（或一旦图像的统计信息已经被计算），另一个标签为 “Data 
Sretching” 的小窗口显示数据拉伸完成量的百分比。 

 

第五章：Utilities (工具) 
 

ENVI 的 Utilities 是通用的功能。这些功能包括：文件工具，例如图像的大小调整 (空间和波
谱子集) 和旋转，从独立的图像波段建立新的图像文件，生成测试数据集，镶嵌，查看数据；把矢
量文件转换成 DXF 格式的矢量工具；用来读取特定图像数据类型以及扫描和转储磁带的磁带工具；
转换数据类型的转换工具；同创建自定义的地图投影的通用化的功能一样，用来在特定地图投影坐

标和地理坐标之间转换的地图投影工具；用于诸如 Landsat MSS 和 TM 等数据类型的特有的预处
理功能；校准工具；对 ENVI 地形建模功能和彩色覆盖表面输出的访问；以及用户功能实例。所有
这些功能在 ENVI 主菜单上的 Utilities 下可以获得。 

 

Figure 5-1: Utilities 菜单。 

Administrator
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File Utilities (文件工具) 
使用 File Utilities，来建立和操作文件和元文件，调整图像大小（空间范围变化），进行图像旋

转，使文件格式在 BIP/BIL/BSQ 之间转换，生成测试图像，进行图幅镶嵌，以及浏览数据等。 

Resize Images(Spatial/Spectral) 

要在空间上调整一幅图像的大小，和/或执行图像的空间和波谱子集： 

1 点击 Utilities > File Utilities > Resize Images (Spatial/Spectral). 

出现输入文件的对话框。在 ENVI 中有许多功能用这一对话框打开与其操作相联系的空间或波
谱子集（详见 “File Selection”）。 

这几步是适宜于处理空间和波谱子集的 ENVI标准程序。 

2 在“Select Input File”栏里选择要输入的文件，然后点击。 

3 若有必要，点击“Open New File”按钮，打开一个新文件。 

在窗口的右边一栏显示有文件的信息，这些数据可用于直接的空间或波谱子集。下面介绍一些

详细内容。 

空间子集 
·从文件选择对话框里，抽取一幅图像的空间子集： 

1 在文件选择对话框里，点击“Spatial Subset”。 

出现 Spatial Subset 对话框，并在窗口最上方显示有文件信息。 

2 在标有“Samples”和“Lines”的文本框里，输入始末点的数值，或者分别在标有“NS”、
“NL”的文本框里输入需要的行数或象元数，以改变输出图像中的样本数和行数。 

在输入数据的文本框的斜下方将显示原始数据以及子集的大小。 

 

Figure 5-2: 文件选择对话框。 

 

·如果数据是地理坐标系的，则可以用地图坐标或经纬度来选择子集。 

·要交互式地从图像中选择空间子集： 

1 点击“Image Subset”。 

出现 Subset Function窗口，呈现一幅被选图像的子集。 

2 可以通过鼠标点击和拖曳红框的拐角，以调整子集的大小。 

对空间子集要知道更多信息，参见“Standardized ENVI Spatial Subsetting”。 

波谱子集 
·要抽取一幅图像的波谱子集： 
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1 在文件选择对话框里，点击“Spectral Subset”。 

出现标准的 File Spectral Subset对话框，同时在窗口的最上方显示有文件信息。 

2 在子集中点击波段名，以选择具体波段。 

·如果选择的一定范围的子集与以前用过的波谱波段数相同的不同名文件里的子集相同，点击

“Previous”按钮。 

·若选择所有波段，点击“Select All Items”。 

·若清除所有波段，点击“Clear”。 

·若选择波段的具体范围，则 

A 在靠近“Add Range”按钮的两个文本框里，键入始末波段数。 

B 点击“Add Range”。 

·若连续选择一定范围的波段，则点击这一范围的第一个，按住“shift”键，再一一点击要选
用的所有波段，直至最后一个，或者在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续波段，则点击其中一个，按住“ctrl”键，再点击其它的。 

调整文件大小的参数 
在文件选择对话框里，已经选好文件和空间或波谱子集以后： 

1 点击“OK”按钮，退出文件选择对话框。 

将出现 File Resize Parameters对话框，并且在对话框的顶部显示有输入文件的信息，由子集程序
限定的输出文件的维数也显示了出来。 

除了选择输入子集，调整大小还为建立一幅任意尺寸或纵横比的新图像提供了灵活的方法。 

 

Figure 5-3: File Resize Parameters 对话框。 

 

2 在相应文本框里，输入需要的样本数和行数；或在“xfac”和“yfac”文本框里键入放大或变
小的倍数，即 X和 Y的值。 

X和 Y的值能被独立控制。 

如果这时改变输出图像的大小，从“Resampling”按钮菜单里选择重采样方法。 

3 选用“File” 或 “Memory”输出。 

如果选用“File”输出，在标有“Enter Output File Name”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

4 一旦选好了需要的参数，点击“OK”开始运行 

屏幕上显示正在运行的窗口，并标有输出文件的名字，同时给出了已经完成的百分比。 

Convert Data（BSQ，BIL，BIP） 

Convert Data (BSQ, BIL, BIP) 选项允许你在通用的数据格式之间进行转换。这种转换对于运用
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特定的数据更为有效，譬如运用为了特殊处理或交互式分析而储存为某一特定格式的数据。连续波

段的数据可以生成十分清晰的图像，以像元为基元波段交叉的数据能快速抽取单个波谱和波谱平均

值，以行为单元的波段交叉数据则折衷了上述两种格式的优缺点。 

BSQ 格式里，每一个完整的空间波段之后紧跟着下一个完整波段。BIL 格式里，第一波段的第
一行之后紧跟着第二波段的第一行，然后是第三波段的第一行，直至所有波段的第一行。后来的每

一个波段的行也按照类似模式存储。BIP 格式里，每一个波段的第一个像元（或称像元）后紧跟着
第二个像元，向后依次类推。 

你还可以通过在  Utilities 菜单下的  Conversion Tools 菜单实现这一功能(见第  455 页的 
“Conversion Utilities”)。 

1 选择 Utilities > File Utilities > Convert Data (BSQ, BIL, BIP). 

2 在 File Convert Input File对话框里，用标准 ENVI文件选择程序选择要输入的文件。 

当整个图像的信息或空间的一定范围的子集已经进入时，出现 File Convert Parameters对话框；
在窗口顶部显示有输入文件的信息。 

3 点击 Output Interleave按钮，选择要转换成的格式。 

ENVI自动地判定输入文件的格式，并转换成需要的格式（限其余两种）。 

4 在“Convert in Place？”标签附近选择“YES”或“NO”。 

·若让新格式覆盖掉原来的文件，选择“YES”。 

这一选项将节省大量的磁盘空间，但是运行速度比存到另一个文件要慢。 

警告 

如果覆盖功能因某种原因失败，你的数据将被破坏，并且原始文件无法恢复。 

·若将转换后的文件存为另一个新文件，选择“NO”。 

5 键入要输出的文件名。 

6 点击“OK”按钮，开始转换。 

出现 File Conversion状态窗口，显示要输出的文件名以及完成的百分比。 

Rotae/Flip Images (旋转/镜像图像) 

ENVI的旋转工具可以执行几种“标准的”图像旋转。这些包括 0o，90 o，180 o或 270 o，也可以

指定你要旋转的任意角度。 

1 选择 Utilities > File Utilities > Rotate/Flip Images  

2 在 Rotation Input File对话框里，用标准 ENVI文件选择程序选择输入的文件（图像）和任意
子集（其中一部分）。 

3 选好输入文件以及需要的子集以后，点击“OK”。 

出现 Rotation Parameters对话框。这一对话框随着指定的旋转角度或是任意旋转角度而慢慢地变
化。 

最初，在对话框的右上角一些字母和数字按行显示出来。数量的倾向性示意性地表明了指定旋
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转角度后输出图像的先后顺序。 

4 选择下列旋转项。 

·若应用“标准旋转”（0o，90 o，180 o，270 o），点击相应的按钮； 

·若旋转图像的 X、Y坐标，点击“Transpose”附近的“Yes”。 

 

Figure 5-4: Rotation Parameters 对话框。 

左–––标准的 IDL旋转和转置。右–––任意角度的旋转。 

 

·指定要旋转的准确角度： 

A. 在“Angle”文本框里，键入角度值。 

角度是与水平线为轴顺时针方向量度的。 

B. 点击相应按钮选择再抽样算法以计算输出的图像（最近邻原则、双线性内插或立方体卷积）。 

5 选择输出到 “File” 或 “Memory”。 

·若选择输出到文件，键入输出的文件名或用 “Choose” 按钮选择一个输出的文件名。 

6 点击“OK”，开始进行旋转处理。 

当该功能处理数据时，将显示一个标有完成百分比的状态窗口。 

Mosaic Images (图像镶嵌) 

这一功能允许你将以像元为基础的图像或应用地理坐标系的图像镶嵌起来。你也可以通过用

ENVI主菜单里的 Register cascading菜单实现这一功能。 

1 选择Utilities > File Utilities > Mosaic Images > Pixel-based Images or Georeferenced Images. 

2 在 Image Mosaicking对话框的相应文本框里，键入镶嵌输出的维数（或尺寸）。 

3 从 Import菜单选择要镶嵌的图像。 

4 出现标准 ENVI文件选择对话框，选择需要的文件。 

所有图像文件都将显示在镶嵌对话框里，可以选种所有要参与镶嵌的文件。 

5 通过输入需要的左上方坐标或为每幅图像点击和拖曳出大致位置。 

6 点击“OK”，进行镶嵌。 

Generate Test Image (生成测试图像) 

Generate Test Image选项允许你建立各种测试图像，这对于证明或测试 ENVI特征有用。这些包
括恒定值图像、斜坡、服从标准正态分布的随机图像以及高斯分布图像。 

1 选择 Utilities > File Utilities > Generate Test Image. 

2 点击相应按钮，选择输出的图像类型。 
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3 出现 Generate Image Parameters对话框，选择输出样本数、行数与波段数以及输出的数据类型
（字节，整数，无符号的整数，长型，无符号长型，浮点型，双精度，复数，双复数）。 

4 选择输出到“File”或“Memory”。 

·如果选择输出到”File”，在“Enter Output Filename”文本框里键入文件名或用“Choose”按钮选择
输出的文件名。 

5 点击“OK”，开始这项功能。 

图像被处理时将出现一个状态框，处理完成后将在需要的波段范围内显示出新图像。 

 

Figure 5-5: 显示 Random Normal选项的 

Generate Image Parameters 对话框。 

 

恒定值图像 
生成一幅每个像元都具有一个恒定值的图像： 

1 在Generate Image Parameters，选择“Constant”按钮。 

2 在“Value”对话框，输入需要的 DN 值。 

水平或垂直灰阶 
生成一幅水平或垂直的线性灰阶图像： 

1 在Generate Image Parameters对话框，分别选择“Horiz Ramp” 或“Vert Ramp”按钮。 

2 分别在标有“Min Value”和“Max Value”的文本框里输入需要的RAMP的最小值和最大值。 

随机数图像 
生成一幅随机分布的图像： 

1 在 Generate Image Parameters 对话框中，选择 “Random (uniform)” 或 “Random (normal)” 按
钮。 

选择 “Random(normal)” 项，将出现一幅正态分布图像；选择 “Random (uniform)” 项，将出现
一幅数值均匀分布的图像。 

2 分别在标有 “Min Value” 和 “Max Value” 的文本框里输入要生成图像的最小值和最大值。 

3 在 “Seed” 文本框里输入一个“种子”值，作为随机数字生成器的初始值。 

如果没有输入“种子”值，系统时钟将用来设定初始值。 

高斯分布图像 
要生成一幅二维高斯分布图像： 

1 在 Generate Image Parameters 对话框中，选择 “Gaussian PSF” 按钮。 

2 分别在标有 “Min Value” 和 “Max Value” 的文本框里输入要生成图像的最小值和最大值。 

3 在 “Sigma” 文本框里，输入函数的标准差。 
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Data Viewer (数据浏览器) 

ENVI 数据浏览器提供了一种字节水平上检查数据文件的方式。能用来浏览文件结构、识别未
知文件类型，并且数据中显示出一幅图像的文件头时能判定数据的偏差。 

1 选择 Utilities > File Utilities > Data Viewer. 

2 出现 Data Viewer Input File 对话框时，选择一个文件。 

3 点击“OK”。 

出现 Data Viewer 对话框，在窗口文件头栏显示文件名和字节数，并在窗口里显示实际数据值
（默认的为16进制）。第一列显示字节值（显示行的起始字节），向后 16 列显示了数据的 16 个
字节，最后一列显示了 ASCII 值。 

如果数据中没有进一步的 ASCII 值，总体上将呈现随机状态。但是，有了ASCII值以后，文本
就变为可读的了。 

4 选择下列选项： 

·选择从文件中要看的起始字节，在 “Byte Offset” 文本框键入字节数。 

·浏览前一页或后一页，使用 “Next Page” 和 “Prev Page” 按钮。 

·如果你怀疑数据不是字节格式，则从 View_Forma t菜单里选择一种数据格式（16进制、字节
型、整型、长整型或浮点型）。 

数据值的列数与显示数据的方式将相应地发生变化。 

·Byte_Swap 菜单是用来评价 Intel 和 IEEE 格式之间字节存储的，它用于每值不仅仅一个字
节的数据类型（整型、长整型与浮点型）。选择下列选项之一：None (没有交换)，Short Word (为整
型存储两个字节) 或 Long Word(为长整型和浮点型数据存储字节对)。 

·打开并观看一个不同的文件，选择 File > Open New File. 

·退出这一功能，选择 File > Cancel. 

 

Figure 5-6: Data Viewer. 

 

Create New File (建立新文件) 

Create New File 工具允许你从列表中显示的波段中选择波段建立一个新的输出文件。你可以建
立一个“标准的(Standard)”磁盘文件或一个 ENVI “元文件(Meta File)”。 

新文件只有选用有相同空间维数的波段才能被建立。然而，构造整个空间的子集功能允许你选

择单个波段，并执行跳跃式空间子集的构建（详见第 369 页的 “Resize Images (Spatial/Spectral)”）。
一旦选好，在 “Selected ENVI Files for New File” 文本区域将列出输入的文件。 

标准的 (Standard) 
标准的磁盘文件包括 ENVI 文件、外部文件或内存数据项。 
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1 选择Utilities > File Utilities > Create New File > Standard. 

2 当 New File Builder 对话框出现时，点击 “Import File”。 

3 当 Create New File Input File 对话框出现时，运用下列选项来选择文件。 

·如果文件没有显示出来，点击 “Open Image File”，并选择需要输入的文件。 

·选择一个文件，点击文件名。 

·选择一组连续的同样大小的文件，点击这组中第一个文件，按住 “Shift” 键，点击最末一个
文件；或点击并拖曳鼠标左键选择需要的一组。 

·选择一组没有连续显示的一样大小的文件，按住“Ctrl”键，分别点击每一个需要的文件。 

提示 

如果一组文件大小相同，你可以空间上抽取一组文件的子集。这一子集将用于每一个文件。 

4 按需要构造该文件的空间或波谱子集。 

5 用 “Import ENVI File” 按钮，重复选择文件。 

·从 New File Builder 对话框列表中删除文件，点击文件名与“Delete”按钮。 

警告 

使用下列功能时，应特别小心。因为一不小心就有可能将文件从磁盘中删除。 

·如果正在建立一个标准文件，从波段列表中删除建立新文件的波段，以及选择 “Remove 
Superfluous Files” 标签旁边的按钮框时，务必小心。 

 

Figure 5-7: New File Build 对话框。 

 

警告 

如果内存数据项被转移到新文件，并选择了 “Remove Superfluous Files”，则新文件建立以后，
内存数据项将从记忆中消失。 

如果一个磁盘文件的所有波段被转移到新文件，并选择了 “Remove Superfluous Files”，则新文
件形成以后，原文件将被彻底删除。 

6 选择输出到“File” 或 “Memory”。 

如果选择输出到文件，在“Enter Output Filename” 文本框里键入文件名，或用“Choose”按钮选择
输出文件名。 

7 点击“OK”建立新文件。 

文件将用顺序波段式（BSQ）输出。 

指针文件 (Meta File) 
指针文件呈虚的文件结构，实际上没有新文件生成。然而，选用的文件或图像波段通过一个小

文本文件（包含了被当作虚拟文件处理的文件名）的应用联系起来。当这个文件后来被用作输入或

处理时，ENVI 从单个磁盘文件里得到图像数据，并对他们进行处理，就象他们实际上也是用于处
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理的输入文件一样。ENVI 元文件能包括不同数据类型的图像（字节，整型，浮点型等），因此允
许对各种数据集进行综合处理。不必要文件转换，也不创建过程处理文件。 

指针文件必须在磁盘上，以 ENVI 格式存储。输入到 ENVI 的外部文件（如GIF格式）或 ENVI 
内部内存数据项创建的文件/波段一定被存为ENVI磁盘文件，并优先包含在一个新元文件里。 

1 选择 Utilities > File Utilities > Create New File > Meta File. 

2 当 New File Builder 对话框出现时，点击 “Import File”。 

3 当 Create New File Input File 对话框出现时，从下列选项中选择一个文件或多个文件。 

如果内藏的文件没有在列表中显示出来，点击“Open Image File”，选择要输入的文件。 

·选择一个文件，点击文件名。 

·选择一组连续的同样大小的文件，点击这组中第一个文件，按住”SHIFT”键，点击最末一个文
件；或点击并拖曳鼠标左键选择需要的一组。 

·选择一组没有连续显示的一样大小的文件，按住“CTRL”键，分别点击每一个需要的文件。 

提示 

你可以构造一组文件（大小相同）的空间或波谱子集。子集将用于每一个文件。 

4 按需要构造该文件的空间或波谱子集。 

5 重复应用 “Import ENVI File” 按钮输入每一个新文件。 

·在 New File Builder 对话框里删除文件，点击文件名和激活“Delete”按钮。 

6 在“Enter Output Filename”对话框里，键入文件名或点击“Choose”按钮选择输出的文件。 

7 点击“OK”，建立新文件。 

元文件中的波段显示在可得到的波段中。实际上在磁盘上的元文件是一个文本文件，只包含了

输入文件的名字。 

Output Data to Extenal File (将数据输出到外部文件) 

ENVI 允许你将数据输出到各种图像处理格式的文件中，如  ArcView 栅格  (.bil)、PCI 
(.pix)、ER Mapper, 以及 ERDAS (.lan) 和 TIFF 文件（包括 GeoTIFF 和 TIFF world 文件
[.tfw]）。此外，你还可以将图像输出为下面要介绍的 ASCII (.txt) 格式。用法说明如下。 

输出为 ASCII (.txt) 文件 
ASCII 输出文件将包含每个像元的 DN 值；你可以选择 DN 值的输出格式（文件大小，包括

小数点、空格以及小数位的数目）。如果你输出多个波段，文件交叉格式(BSQ, BIL, BIP) 将与输入
文件相同。 

注意 

若你的输出文件中出现多个 “***”，则你的 ASCII 输出格式与你的 DN 值的数据类型不匹配。 

要将数据输出为 ASCII 文件： 

1 选择 Utilities > File Utilities > Output Data to External File > Output to ASCII. 

2 当出现 Output File to ASCII Input Filename 对话框时，选择要输出的文件，并根据需要构造
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空间或波谱子集。 

3 点击“OK”。 

4 当出现 Output to ASCII Parameters 对话框时，选择下列选项： 

·确定范围大小，在“Total Field Size”标签附近点击箭头切换按钮选择一个数字，或在文本框
里键入一个数字。 

·设置输出数据小数点后的位数，点击“Decimal Precision” 标签附近的箭头切换按钮选择一个
数字，或在文本框里键入一个数字。 

5 键入输出文件名，或点击“Choose”按钮选择文件名。 

6 点击“OK”按钮。 

将生成一个ASCII文件，在文本编辑器里能看到。 

输出为 ArcView Raster (.bil) 格式 
要将数据输出为 ArcView Raster (.bil) 格式（包括 .hdr 和 .stx 文件）： 

1 选择 Utilities > File Utilities > Output Data to External File > Output to ArcView Raster (.bil). 

2 当 Output ArcView Input Filename 对话框出现时，选择要输出的文件，并根据需要构造子集。 

3 当Output File to ArcView对话框出现时，键入输出的文件名，点击“OK”。 

ENVI 将创建 .bil、.hdr 和 .stx ArcView 栅格输出文件。 

输出为ER Mapper文件 
要将数据输出为 ER Mapper 格式文件： 

1 选择 Utilities > File Utilities > Output Data to External File > Output to ER Mapper File. 

2 当 Output ER Mapper Input Filename 对话框出现时，选择要输入的文件，并根据需要构造子
集。 

3 当 Output File to ER Mapper 对话框出现时，键入输出的文件名，点击“OK”。 

ENVI将建立一个 ER Mapper 输出文件。 

输出为 ERDAS (.lan) 文件 
要将数据输出为 ERDAS (.lan) 文件： 

1 选择Utilities > File Utilities > Output Data to External File > Output to ERDAS (.lan) File. 

2 当 Output ERDAS Input Filename 对话框出现时，选择要输入的文件，并根据需要构造子集。 

3 当 Output File to ERDAS 对话框出现时，键入输出的文件名，点击“OK”。 

ENVI 将建立一个 ERDAS（.lan）输出文件。 

输出为 PCI 文件 
要将数据输出为 PCI 文件： 

1 选择 Utilities > File Utilities > Output Data to External File > Output to PCI File. 

2 当 Output PCI Input Filename 对话框出现时，选择要输入的文件，并根据需要构造子集。 
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3 当 Output File to PCI 对话框出现时，键入输出的文件名，点击“OK”。 

ENVI 将建立一个 PCI（. pix）输出文件。 

输出为 TIFF 格式 
要输出为 TIFF 格式： 

1 选择 Utilities > File Utilities > Output Data to External File > Output to TIFF. 

2 当文件选择对话框出现时，选择要输入的文件名，并根据需要构造子集。 

3 当 Output File to TIFF 对话框出现时，键入输出的文件名，点击“OK”开始输出。 

ENVI 将建立一个 TIFF 输出文件。 

注意 

若你选用一个地理坐标文件作为输入文件，输出文件将是 GeoTIFF 文件和一个相关联的 TIFF 
world 文件（.tfw）。 
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Vector Utilities (矢量工具) 
Vector Utilities 菜单具有将栅格图像（包括分类图像）转换为 ENVI 矢量图层、栅格不规则点
的功能，它还可以将ENVI矢量文件（EVF）、注记文件（ANN）以及感兴趣区（ROI）转换为 DXF 
格式。 

Raster to Vector Conversion (栅格到矢量的转换) 

栅格图像（包括分类后的结果）能被转换为 ENVI 多边形矢量层（.evf文件）。分类图像对每
一个选定的类都将给出一个矢量层。栅格图像对每一个特定的 DN 轮廓行都给出一个矢量层。 

·对于分类图像： 

1 选择 Utilities > Vector Utilities > Raster to Vector Conversion. 

2 当 Raster to Vector Input Band 对话框出现时，选择需要输入的分类文件，并按需要构造子集。 

3 当Raster to Vector Parameters 对话框出现时，通过点击分类名选择需要的分类转换为矢量多
边形。 

·选择所有分类，点击“Select All Items”。 

·清除所有分类，点击“Clear All Items”。 

·若选择连续显示的分类，则点击这些分类的第一个，按住“shift”键，再点击最后一个，以
使两者之间的也都被选上。 

·若选择非连续显示的分类，则点击其中一个，按住“ctrl”键，再点击需要的每一个分类，再
点击删除一些不需要的分类。 

4 选择输出到 “File” 或 “Memory”，若有必要，键入一个输出文件的根文件名。 

5 点击“OK”，为每一种选择的分类建立一个多边形矢量层 

选择的每一种分类将被存为一个独立的矢量文件，其名字为跟文件名后跟 “_1”、“_2”,等等。 

·对于其它栅格图像： 

1 选择 Utilities > Vector Utilities > Raster to Vector Conversion. 

2 当 Raster to Vector Input Band 对话框出现时，选择要输入的文件名，并根据需要构造子集。 

3 当 Raster to Vector Parameters 对话框出现时，在 Contour Value 文本框键入需要的 DN 值，
作为一个等值行值（a contour value）。 

4 在相应文本框键入一个 ENVI 矢量文件图层名。 

5 选择输出到“File”或 “Memory”，若有必要键入一个输出文件的根文件名。 

6 点击“OK”，用键入的等值行值建立一个多边形矢量图层。 

Irregular Points to Grid (不规则点栅格化) 

ENVI 的栅格化功能用平面点的德洛内三角测量对不规则栅格数据进行插补。在不规则栅格数
据点已经被三角测量后，它们被填写到一个规则的网格上。选用线性或光滑的五次多项式进行内插。

Administrator
Vector Utilities (矢量工具)



 182

对三角形区域外的点的插补也可以使用外插方法。栅格点来自 ASCII 文件，输入和输出投影能得到
支持。 

·将一组不规则点栅格化： 

1 选择 Utilities > Vector Utilities > Irregular Points to Grid. 

2 当出现 Enter ASCII Grid Points Filename 对话框时，选择需要输入的ASCII文件。 

出现 Input Irregular Grid Points 对话框。 

3 输入包含 X、Y 位置和 Z 数据值的列数。 

4 从列表中选择输入的投影类型，若需要可以键入一个分区的数据。 

5 点击“OK”，出现 Gridding Projection Info 对话框。 

6 选择输出投影类型，若需要可以键入一个分区的数据 

7 用箭头切换按钮，选择内插类型，线性或五次多项式。 

8 用“Yes/No”箭头切换按钮选择是否外插边缘。 

注意 

如果选择外插，将用到五次多项式插补。 

9 输入 X 和 Y 输出像元的大小（用与你的投影类型相匹配的单位），从下拉菜单中选择输出
的数据类型。 

10 点击“OK”，开始栅格化。 

Convert ROI to DXF (将感兴趣区转换为 DXF ) 

将 ENVI 感兴趣区文件转换成 DXF 格式 

1 选择 Utilities > Vector Utilities > Convert ROI to DXF. 

2 当 Enter Input ROI Filename 对话框出现时，选择一个输入的感兴趣区文件。 

3 点击“OK”。 

4 当 Convert Region of Interest Files to DXF Files 对话框出现时（在 Selected Input Files 下方列
出了输入的文件），选择以下步骤。 

·在选择文件一列增加另外的文件，点击 Input Additional File 并选择需要的感兴趣区文件。 

·从列表中删除文件，点击文件名和“Delete”按钮。 

·若需要输出到地图坐标，用箭头切换按钮选择“Map Coordinates”。 

·若需要输出像元坐标，选择“Pixel Coordinates”。 

5 键入一个输出文件名或用“Choose”按钮选择一个输出文件名。 

6 点击“OK”，将感兴趣区文件转换成 DXF 格式。 

如果选择输出到地图坐标，在 Select File Containing Map Coordinates 对话框选择一个包含需要
的输出地图坐标的文件。完成后，点击“OK”。 



 183

Convert ANN to DXF (将 ANN 格式转换为 DXF 格式) 

将 ENVI 注记(Annotation) 文件转换为 DXF 格式： 

1 选择 Utilities > Vector Utilities > Convert ANN to DXF. 

只有矩形、椭圆、多边形和折行能被转换，其他的注记条目被忽略。 

2 当 Enter Input ANN Filename 对话框出现时，选择一个文件名。 

3 点击“OK”。 

4 当 Convert Annotation Files to DXF Files 对话框出现时（在 Selected Input Files 下方列出了输
入的文件），选择以下步骤： 

·在选择文件一列增加另外的文件，点击 Input Additional File 并选择需要的注记文件。 

·从列表中删除文件，点击文件名和“Delete”按钮。 

·若需要输出到地图坐标，用箭头切换按钮选择“Map Coordinates”。 

·若需要输出像元坐标，选择“Pixel Coordinates”。 

5 输入一个输出文件名或用“Choose”按钮选择一个输出文件名。 

6 点击“OK”，将注记文件转换成 DXF 格式。 

如果选择输出到地图坐标，在Select File Containing Map Coordinates对话框选择一个包含需要的
输出地图坐标的文件。完成后，点击“OK”。 

Convert EVF to DXF (将 EVF 格式转换为 DXF 格式) 

将 ENVI 矢量文件转换成 DXF 格式： 

1 选择 Utilities > Vector Utilities > Convert EVF to DXF. 

2 当 Enter Input EVF Filename 对话框出现时，选择一个文件名。 

3 点击“OK”。 

4 当 Convert ENVI Vector Files to DXF Files 对话框出现时（在 Selected Input Files 下方列出了
输入的文件），选择以下步骤： 

·在选择文件一列增加另外的文件，点击 Input Additional File 并选择需要的 EVF 文件。 

·从列表中删除文件，点击文件名和“Delete”按钮。 

·若需要输出到地图坐标，用箭头切换按钮选择“Map Coordinates”。 

·若需要输出像元坐标，选择“Pixel Coordinates”。 

5 输入一个输出文件名或用“Choose”按钮选择一个输出文件名。 

6 点击“OK”，将EVF文件转换成DXF格式。 
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Tape Utilities (磁带工具) 
ENVI 能从各种计算机兼容的磁带格式读取 MSS、TM、SPOT、AVHRR、NLAPS 和 CEOS 格

式雷达数据（包括 SIR-C/X-SAR、RADARSAT 和 ERS-1）。也支持美国地质考察采用的 DEMs 和 
DLGs（仅仅是可选的格式）。Tape 功能可以在 UNIX 平台和 Microsoft Windows 95 以及 Windows 
NT 下运行。灵活的磁带工具也允许输入其它的数据类型，甚至一种特定格式不被直接支持。Tape
的扫描和堆存工具被用来诊断磁带结构、建立常用磁带类型的信息以及将磁带存入磁盘。这些特征

允许直接从磁带上读取 BSQ、BIP 和 BIL 数据以及在文件和记录层次上SCSI磁带驱动器(9轨，8 
mm 和 4 mm 介质) 的控制。 

 

Figure 5-8: ENVI 的 Tape Utilities 层叠式菜单。 

Figure 5-9: 

 

此外，还提供了磁带输出工具，它保存了 ENVI 头信息和文件结构。一个相应的磁带输入工具
读取ENVI格式的磁带。 

磁带工具通过从层叠式菜单(Figure 5-8) 选择合适的磁带程序来运行。更多细节，请见下。 

选择 ENVI 主菜单里的 Utilities > Tape Utilities 可以访问 ENVI 的磁带工具。这些功能目前在
UNIX 平台和 PC 机上，Microsoft Windows 95 或 Windows NT 下都能实现。 

ENVI 中提供的磁带工具包括了阅读程序，它能读取 MSS、TM、SPOT、AVHRR、AVIRIS、
NLAPS、SIR-C、RADARSAT，以及各种计算机兼容的磁带格式 CEOS 数据。程序被用来读取 USGS 
DEM 和 DLG 文件。灵活的磁带工具也允许输入其它类型的，甚至一种特定格式不被直接支持。
Tape 的扫描和堆存工具被用来诊断磁带结构、建立常用磁带类型的信息以及将磁带存入磁盘。这些
特征允许直接从磁带上读取 BSQ、BIP 和 BIL 数据以及在文件和记录层次上SCSI磁带驱动器(9轨，
8 mm 和 4 mm 介质) 的控制。提供了磁带输出工具，它保存了 ENVI 头信息和文件结构。还提供
了一个相应的ENVI磁带输入工具。单个选项详见如下。 

磁带设备名字 

装有 Microsoft Windows 95 或 Windows NT 的 PC 机 
ENVI 使用一个基于适配器、目标和单位数的 PC 磁带设备名，并使用标准的 UNIX 磁带设备
命名约定（见下面）。PC 机上的磁带设备必须与 SCSI 磁带驱动器兼容的 ASPI。PC 机上磁带设
备的命名参见适配器号（a#），目标标识符(t#) 和逻辑单元 (l#)。大多数PC机只有一个适配器，磁
带的逻辑单元数是 0 。目标号是设备的SCSI 标识符。对于外部设备，标识符是在驱动器背后的轮
转(pinwheel) 设置。内部设备用跳线(jumpers) 来设置 SCSI 标识符。任何一种情况下，（BOOTUP）
启动时你的 SCSI 适配器都会显示出你的磁带设备的目标号。例如，一个SCSI 标识符为 4 的 “Tape 
device” 型磁带设备名为 “/dev/a0t4l0”（假定只有一个适配器）。若你的磁带设备连接到第二个 SCSI 
适配器上，则你的磁带设备名为 “/dev/a1t4l0”。 

UNIX 平台 
UNIX 平台上的磁带设备被指定为 /dev 目录下的磁带设备名。例如，在 /dev/rmt 目录下限



 185

定定义设备 Øb，用“/dev/rmt/Øb”作为 ENVI 磁带设备的名字。 

Read Known Tape Formats (读取已知的磁带格式) 

从 Tape Utilities 层叠式菜单选择选项，从磁带上读取标准的文件格式。出现一个支持磁带格式
的层叠式菜单，包括 Landsat MSS、Landsat TM、AVHRR、SPOT、AVIRIS、USGS DEM、USGS、
DLG、NLAPS、SIR-C CEOS、RADARSAT CEOS，和 Generic CEOS 格式。选项详述如下。 

ENVI支持几种标准的磁带格式；若得到其他格式也可以加进来。 

Landsat MSS 
这一选项识别和读取 Landsat MSS 磁带的两种类型。MSS CCT-X 格式以早期记录在 BIP2 格

式上的 MSS 数据为典型。这些数据由 MSS 数据带组成（所有四个 MSS 波段都用像对表示） 
Landsat MSS 数据自从 1979 年就以 MSS EDIPS 格式存储。ENVI 通过扫描磁带标签自动地识别 
MSS CCT-X 和 EDIPS 格式。这些数据可以直接从磁带上抽取子集。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > Landsat MSS. 

·当出现 Landsat MSS - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape 
Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2 点击“OK”，ENVI扫描磁带头。 

如果识别出是 MSS 格式数据，则将出现 MSS Tape Output Parameter 对话框。 

·你可以分别在标有 “Samples... To” 和 “Lines...To” 的文本框里，键入行或点的起点和终点以
构建出要读的图像子集。 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 选择输出到 “File” 或 “Memory”。 

如果选择输出到 “File”，需在 “Enter Output Filename” 文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你磁带格式以及处理进度。 

LandsatTM 

识别并读出这些格式的 Landsat TM 磁带：全景 “CCT-AT 和 CCT-PT” 数据, TIPS (Quad) 格
式, LGSOWG，和 “FAST” 格式。ENVI 通过扫描磁带头自动识别文件类型。“CCT-AT 和 CCT-PT” 
数据格式式全景格式，用于早期的 TM 数据（1984年以前），且有特色地放在两个（AT）或三个
（PT）6250 bpi 磁带上。TM TIPS 格式专门用于 1984-1991 年 BSQ 格式中记录的多数历史的 TM 
数据。这些数据由组织为“四方块”的 TM 数据组成（见 EROS 数据中心及其它处得来的 TM 文
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件）。当前 TM 数据用 FAST 格式存储。对于 FAST 格式中的 TM 数据（UTM投影），ENVI 能
从中读取所有需要的信息，并将其置于 ENVI 文件头中。能从磁带中直接构建图像子集。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > Landsat TM. 

·当出现 Landsat TM - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape 
Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2 点击“OK”，ENVI 扫描磁带头。 

·如果识别出是 TM 格式数据，则将出现 TM Tape Output Parameter 对话框。 

·你可以分别在标有 “Samples... To” 和 “Lines...To” 的文本框里，键入行或点的起点和终点以
构建出要读的图像子集。 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

 

Figure 5-11: Landsat TM Output Parameters 对话框。 

 

4 选择输出到 “File” 或 “Memory”。 

如果选择输出到 “File”，需在 “Enter Output Filename” 文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理 

一个状态窗口将会告诉你磁带格式以及处理进度。 

AVHRR 
这一工具能读取 NOAA 提供的 AVHRR LAC (HRPT) 和 GAC (Level 1b) 数据。这些数据能直
接从磁带中构建子集。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > AVHRR 

·当出现 AVHRR Format - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变
“Tape Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

 

Figure 5-12: AVHRR Tape Output Parameters 对话框。 
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2 在“File”文本框里，键入从磁带上读取的文件号，点击“OK”，ENVI 扫描磁带头。 

·如果识别出是 AVHRR 格式数据，则将出现 AVHRR Tape Output Parameter 对话框。 

·你可以分别在标有 “Samples... To” 和 “Lines...To” 的文本框里，键入行或点的起点和终点以
构建出要读的图像子集。 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 选择输出到 “File” 或 “Memory”。 

如果选择输出到 “File”，需在 “Enter Output Filename” 文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你磁带格式以及处理进度。 

SPOT 
ENVI自动读取两种类型的 SPOT 数据类型：SPOT 全色数据（PAN）和 SPOT 多波谱数据

（XS）。这些数据能直接从磁带上构建子集。 

1 选择Utilities > Tape Utilities > Read Known Tape Formats > Spot. 

·当出现 SPOT - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape Device”
以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2，点击“OK”，ENVI 扫描磁带头。 

·如果识别出是系统支持的一种 SPOT 数据格式，则将出现 SPOT Tape Output Parameter 对话
框。 

·你可以分别在标有 “Samples... To” 和 “Lines...To” 的文本框里，键入行或点的起点和终点以
构建出要读的图像子集。 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段。 

如果识别出是 SPOT PAN 数据，在 Select Output Bands 列表中就会显示一个波段。如果识别
出是 SPOT XS 数据，在 Select Output Bands 列表中就会显示三个波段。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 选择输出到 “File” 或 “Memory”。 
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如果选择输出到 “File”，需在 “Enter Output Filename” 文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你磁带格式以及处理进度。 

AVIRIS 
这一选项能识别和读取 1992-1996 年 NASA/JPL 航空可见光/红外成象波谱仪(AVIRIS) 数据

类型。这些磁带是“BIL”格式，有 1000 字节的文件头。ENVI能自动扫描识别这些数据并抽取图
像的重要参数。这些数据能直接从磁带上构建子集。 

提示 

1997 年 AVIRIS 磁带是 UNIX tar 格式，ENVI 不能直接读取他们。要读取 AVIRIS 数据，
先用 tar 转储磁带，然后使用 File > Open Image File 将数据读取到一个 ENVI 文件。 

要获得关于读取 AVITIS 数据磁带的帮助，请参见 http://www.envi-sw.com/envitech.htm 。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > AVIRIS. 

·当出现 AVIRIS - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape 
Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2，点击“OK”，ENVI读取AVIRIS波长文件，并扫描AVIRIS图像文件头 

·如果识别出是AVIRIS数据，则将出现AVIRIS Tape Output Parameter对话框。 

·你可以分别在标有“Samples... To”和“Lines...To”的文本框里，键入行或点的起点和终点以构建
出要读的图像子集 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段，以及与它们相对应的波长 

·在“Add Range”按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围 

·选择所有波段，点击“Select All” 

·清除以前的所有选择，点击“Clear.” 

4 选择输出到“File”或“Memory” 

如果选择输出到“File”，需在“Enter Output Filename”文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你磁带格式以及处理进度。 

USGS DEM（数字高程模型） 
这一选项能读取1:24,000 (7 1/2’) 和1:250,000 (3 arc second)标准USGS格式的数字高程模型。开
始这一功能之前，你必须知道磁带上哪些文件与需要的DEMs相匹配（这一信息通常在磁带的标签上
或USGS提供的磁带说明上）。从磁带和ENVI文件头里，能读到地理上的墨卡托投影或state平面投
影信息。多个DEMs能自动从磁带上镶嵌到一块。 

1 选择Utilities > Tape Utilities > Read Known Tape Formats > USGS DEM 
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2 当出现DEM Tape Reader Input Parameters对话框时，在Tape File文本框里，键入每一个DEM文
件号，按回车键 

在文本框的列表中将显示出输入的文件号。 

3 为DEM输出键入一个根文件名 

每一个单独输出的文件都被命名为“根文件名+文件号”。例如，若你定义的根文件名为”test”，
则第二个文件将被命名为”test_2”。 

·让ENVI自动将文件镶嵌到一块，变换核对无误按“Yes”按钮 

·变换核实点击“Delete temp files when done?”标签旁边的“Yes”按钮，镶嵌后系统创建的元文
件（暂时文件）将自动删除。 

4 点击“OK”，出现USGS DEM Format - Load Tape对话框 

· 你可以在相应文本框里键入需要的值改变“Tape Device”以及磁带的最大记录长度（Max 
Recsize） 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

5 点击“OK”，读取DEM数据 

ENVI扫描数据文件判定主要格式和位置信息，并自动识别读取数据。 

6 选择输出到“File”或“Memory” 

如果选择输出到“File”，需在“Enter Output Filename”文本框里键入要输出的文件名 

7 点击“OK”，开始磁带处理 

一个状态窗口将会告诉你磁带格式以及处理进度。 

USGS Digital Line Graphs (DLG) 
这一选项使得 ENVI 在 USGS 可选格式中能读取 1:24,000 (7 1/2’) 和1:100,000 DLG 的数
据。开始这一功能之前，你必须知道磁带上哪些文件与需要的 DLGs 相匹配（这一信息通常在磁带
的标签上或 USGS 提供的磁带说明上）。从磁带和 .evf 输出文件里里，能读到 UTM 投影信息和 
Albers 等积投影信息。这些信息能用作矢量投影。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > USGS DEM. 

2 当出现 DEM Tape Reader Input Parameters 对话框时，在 Tape File 文本框里，键入每一个 
DLG 文件号，按回车键。 

在文本框的列表中将显示出输入的文件号。 

3 为 DLG 输出键入一个根文件名。 

每一个单独输出的文件都被命名为“根文件名+文件号”。例如，若你定义的根文件名为 “test”，
则第二个文件将被命名为 “test_2”。 

4 点击“OK”继续。 

· 出现 USGS DLG Format - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变
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“Tape Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

5 点击“OK”，读取 DLG 数据。 

ENVI 扫描数据文件判定主要格式和位置信息，并自动识别读取数据，把它放入 Available 
Vectors 列表中。 

NLAPS 
这一选项使得 ENVI 读取 National Landsat Archive Production System（NLAPS，国家陆地卫星

存档产品系统）的磁带。ENVI只能从磁带上读取第一幅图像(TM, MSS, 或 DEM)，并且在一幅 TM 
或 MSS 图像后不能读取可选的 DEM。ENVI 目前从磁带头中只能读取 UTM 投影信息。这些数
据可以从磁带上直接被抽取构建子集。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > NLAPS. 

· 出现 NLAPS - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape Device”
以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2 点击“OK”，ENVI 扫描磁带头。 

·如果识别出是 NLAPS 格式数据，则将出现 Landsat NLAPS Tape Output Parameter 对话框。 

·你可以分别在标有 “Samples... To” 和 “Lines...To” 的文本框里，键入行或点的起点和终点以
构建出要读的图像子集。 

3 点击需要的波段名附近的箭头切换按钮选择要读的波段。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 选择输出到 “File” 或 “Memory”。 

如果选择输出到“File”，需在“Enter Output Filename”文本框里键入要输出的文件名。 

5 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你磁带格式以及处理进度。 

SIR-C CEOS 
ENVI（UNIX 和 PCs）能读取 SIR-C 磁带（CEOS 格式 JPL 分布），也支持 Single Look 

Complex (SLC)、Multilook Complex (MLC) 和 Multilook Ground Detected (MGD) 格式。为了不占大
量磁盘空间，你可以从磁带中读取任何数据类型的子集。此外，SLC 数据能从磁带上读出进行多视 
(mutilooking)（如整型或非整型）。开始磁带处理功能，参照如下操作。 
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1. 选择 Utilities > Tape Utilities > Read Known Tape Formats > SIR-C CEOS. 

· 出现 SIR-C Format - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape 
Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2. 点击“OK”，ENVI 扫描磁带（标准格式 SIR-C 数据）。 

磁带扫描结束，将出现 SIR-C Tape File Selection 对话框。在 “Select Output Files” 文本标签的
下方出现磁带上一系列 SIR-C 数据文件。 

3. 点击需要的波段名附近的箭头切换按钮选择要读的波段 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4. 点击“OK”，开始出现 SIR-C Tape Parameters 对话框。 

在前面对话框中显示的 SIR-C 数据集将在 “Selected SIR-C Tape Files” 列表中显示出来。若有
必要，下一步选择空间子集，为输出文件命名，并且有必要的话，从磁带上选择多视。每一个数据

集将被独立命名和处理。 

·运行空间子集的构建 

1 点击一个数据集。 

2 点击“Spatial Subset”，用标准ENVI构建子集程序抽取数据（注意：若这一阶段没有合成的图
像，则子集构建无法进行。 

·从磁带上读取数据进行多视： 

注意 

从磁带上读取进行多视要花很长时间，因为读取磁带期间，数据处理将导致磁带运转停止。若

没有足够的磁盘空间供读取整个数据集，只选上这项。磁盘上的多视是比较快的，并且是首选的处

理项。 

1 点击一个数据集。 

2 当现 SIR-C Multilook Parameters 对话框时，点击 “Multi-look”。 

可以通过选择距离(样本) 和方位(行) 方向所需要的视数(number of looks)，键入要输出的像元数
或键入输出像元的大小，来输入多视的参数。 

3 输入需要多视输出的大小参数。 

·在 “Looks” 文本框里，键入需要样本和行的视数。支持整型和浮点型数据。 

·作为选择，可以通过在 “Pixel” 文本框下键入样本数和行数，以确定输出图像的像元数。 

·你也可以在 “Pixel Size (m)” 文本框里输入样本数和行数，以限定输出图像的大小（单位：米）。 

这些参数中，一旦有一个确定，其它的自动计算匹配。例如，如果你输入像元大小为 30 米，



 192

则在相应的文本框，相应的像元数及视数就自动被计算出来。 

4 点击“OK”，返回到 SIR-C 磁带参数对话框。 

5 通过点击数据集名，随后键入多视参数为对话框中显示的每一个数据集，重复这一过程。 

·键入要输出的文件名 

1 在 SIR-C Tape Parameters 对话框中，标签为 “Selected SIR-C Tape Files” 的文本下方的列表
中，点击一个数据集名。 

2 在标签为 “Enter Output Filename [.cdp])” 的文本框中，键入需要输出的文件名。 

按照惯例，文件名应采用这种形式：filename_c.cdp 和 filename_l.cdp 。 

3 为对话框中显示的每一个数据集重复这一过程（点击数据集名，键入输出文件名）。 

ENVI 将为选择的每一个数据集建立一个压缩的散点矩阵输出文件。 

4 一旦所有的磁带读取参数被键入，点击“OK”，开始读取磁带和处理数据。 

磁带读取和处理少则需要不到一个小时，多则需几个小时才能完成。这依赖于数据类型、SIR-C 
数据的大小以及选择的数据集的数量。 

RADARSAT CEOS 
用这一功能将 RADARSAT CEOS 数据类型读到磁盘上。 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > RADARSAT CEOS. 

·出现 RADARSAT - Load Tape 对话框时，输入磁带设备名以及磁带的最大记录长度。 

2 点击“OK”，让 ENVI 扫描带有标准格式 RADARSAT 数据的磁带。 

磁带扫描结束，将出现 RADARSAT Tape File Selection 对话框。在 “Select Output Files” 文本
标签的下方出现磁带上一系列 RADARSAT 数据文件。 

3 点击需要的数据集附近的箭头切换按钮选择从磁带上要读取的数据。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 点击“OK”，开始出现 RADARSAT Tape Parameters 对话框。 

The RADARSAT Tape File Selection Dialog 
在  RADARSAT Tape File Selection 对话框里选择的  RADARSAT 数据集将在  “Selected 

RADARSAT Tape Files” 列表中显示出来。若需要，下一步选择空间子集，为输出文件命名。每一
个数据集将被独立命名和处理（详见如下）。 

·从磁带上构建空间子集： 

1 点击一个数据集。 

2 点击 “Spatial Subset”，用标准的 ENVI 子集构建程序抽取数据。 

3 点击“OK”，返回到 RADARSAT Tape Parameters 对话框。 
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4 为对话框中列出的每一个数据集重复这一过程（通过点击数据集名，随后为选择的数据集构
造子集）。 

·键入要输出的文件名： 

1 在 RADARSAT Tape Parameters 对话框中，标签为 “Selected RADARSAT Tape Files” 的文本
下方的列表中，点击一个数据集名。 

2 在标签为 “Enter Output Filename” 的文本框中，键入需要输出的文件名。 

按照惯例，文件名应采用这种形式：filename_c.cdp 和 filename_l.cdp 。 

3 为对话框中显示的每一个数据集重复这一过程（点击数据集名，键入输出文件名）。 

ENVI 将为选择的每一个数据集建立一个图像输出文件。 

4 一旦所有的磁带读取参数被键入，点击“OK”，开始读取磁带和处理数据。 

处理后的图像将在可以利用的波段列表中显示，可以用标准 ENVI 程序显示和处理。 

Generic CEOS 
ENVI 包括一个灵活的 CEOS 格式磁带阅读程序，这使你能用 CEOS 格式阅读各种 SAR 数

据磁带。如 ERS-1、ERS-2、JERS-1 和 X-SAR (MLD) 数据。CEOS 信息能直接使用户界面最小化，
简化浏览和分析时建立的文件。开始磁带处理功能： 

1 选择 Utilities > Tape Utilities > Read Known Tape Formats > Read Generic CEOS. 

·出现 CEOS Format - Load Tape 对话框时，输入磁带设备名以及磁带的最大记录长度。 

2 点击“OK”，让 ENVI 扫描带有标准格式 CEOS 数据的磁带。 

磁带扫描结束，将出现 RADARSAT Tape File Selection 对话框。在 “Select Output Files” 文本
标签的下方出现磁带上一系列 CEOS 数据文件。 

3 点击需要的数据集附近的箭头切换按钮选择从磁带上要读取的数据。 

·在 “Add Range” 按钮附近的文本框里键入始末波段，点击“Add Range”，就可以选择范围。 

·选择所有波段，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 点击“OK”，开始出现 CEOS Tape Parameters 对话框。 

The CEOS Tape File Selection Dialog 
在 CEOS Tape File Selection 对话框里选择的 CEOS 数据集将在 “Selected S CEOS Tape 

Files” 列表中显示出来。若需要，下一步选择空间子集，为输出文件命名。每一个数据集将被独立
命名和处理（详见如下）。 

·从磁带上构建空间子集： 

1 点击一个数据集。 

2 点击 “Spatial Subset”，用标准的 ENVI 子集构建程序来抽取数据子集。 

3 点击“OK”，返回到 CEOS Tape Parameters 对话框。 

4 为对话框中列出的每一个数据集重复这一过程（通过点击数据集名，随后为选择的数据集构
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件子集）。 

·键入要输出的文件名： 

1 在 CEOS Tape Parameters 对话框中，标签为 “Selected RADARSAT Tape Files” 的文本下方
的列表中，点击一个数据集名。 

2 在标签为 “Enter Output Filename” 的文本框中，键入需要输出的文件名。 

3 为对话框中显示的每一个数据集重复这一过程（点击数据集名，键入输出文件名）。 

ENVI 将为选择的每一个数据集建立一个图像输出文件。 

4 一旦所有的磁带读取参数被键入，点击“OK”，开始读取磁带和处理数据。 

处理后的图像将在可以利用的波段列表中显示，可以用标准 ENVI 程序显示和处理。 

Read/Write ENVI Tapes (读/写 ENVI 磁带) 

在 Tape Utilities 层叠式菜单的下面这一选项允许 ENVI 读/写 ENVI 格式的磁带。当保存
ENVI 文件结构和文件头配置时，ENVI 磁带输出工具将图像数据写到磁带上。一种相应的工具读
取这些磁带。 

ENVI 磁带格式信息 
为了维护图像文件头中所示的主要图像特征，ENVI 磁带被写为一种标准格式以简化读取图像
数据。结果 ENVI 格式用了几种文件头记录和文件。 

文件标

识符 
录 制 标

识符 
数据 类型信息 

1 1 ASC
II 

1024 字 节 , 标 识 符 字 符 串  “ENVI TAPE 
FORMAT”, 

和字符串 “NUM_ENVI_FILES= N” ( N 是磁带上
ENVI图像文件的总数)。 

 2 ASC
II 

1024 字节 ,关键字字符串包含了磁带上第一个
ENVI 图像文件所需求的信息。关键字是 NL(number of 
lines)、NS (number of samples)、NB (number of bands)、
INTERLEAVE (BSQ、BIL 或 BIP)、DATA TYPE (字节
型、整型、长整型、浮点型、双精度型、复数型)、
ENVI_TYPE (0 is ENVI 图像文件)、NAME (图像名)，和
DESCRIPT（图像描述字符串）。 

 3 ASC
II 

同上，第 2 个 ENVI 文件 

 4 至 
N+1 

ASC
II 

同上，第 3 至第 N 个 ENVI 文件 

2  ASC
II 

图像 1 的文件头（变量长度） 

3  BIN
ARY 

图像 1（记录长度是样本数） 

4  ASC
II 

图像 2 的文件头（变量长度） 
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5  BIN
ARY 

图像 2（记录长度是样本数） 

6 至 
N+1 

  成对的ASCII头文件和二进制图像文件，共N+1个，
在第一幅文件头记录中有说明 

读取 ENVI 磁带 
这一功能被用来读取 ENVI 格式的磁带（用 Write ENVI Tape 来写入）。 

1 选择 Utilities > Tape Utilities > Read/Write ENVI Tapes > Read ENVI Tape. 

·当出现 ENVI Format - Load Tape 对话框时，你可以在相应文本框里键入需要的值改变“Tape 
Device”以及磁带的最大记录长度（Max Recsize）。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

2 点击“OK”，ENVI 扫描磁带头。 

如果识别出数据是 ENVI 格式，则将出现 ENVI Tape Files 对话框。列表显示出磁带上 ENVI 
文件名。 

3 点击需要的文件名附近的箭头切换按钮选择要读取的文件。 

·在 “Add Range” 按钮附近的文本框里键入始末文件，点击“Add Range”，就可以选择范围。 

·选择所有文件，点击 “Select All”。 

·清除以前的所有选择，点击 “Clear”。 

4 点击“OK”，继续显示 ENVI Tape to Output File 对话框，直至读完选择的每一个文件。 

5 用对话框选择输出到 “File” 或 “Memory”。 

如果选择输出到 “File”，需在 “Enter Output Filename” 文本框里键入要输出的文件名。 

6 点击“OK”，开始磁带处理。 

一个状态窗口将会告诉你对每个图像文件磁带处理的处理进度。每一个文件在被读时，其波段

被添加到Available Bands List中。 

将ENVI文件写到磁带上 
这一功能用于在保存文件结构和头信息情况下，将 ENVI 格式文件写到磁带上。实施前要求 

ENVI 文件已经打开（即它们已在Available Bands List中显示出来）。若需要的文件没有打开，首先
用 File > Open Image File 打开。 

1 选择 Utilities > Tape Utilities > Read/Write ENVI Tapes > Write ENVI File to Tape. 

出现 Output ENVI Files to Tape 对话框。 

2 点击 “Import ENVI File”。 

3 出现选择标准输入文件对话框，点击一个文件名选上它，用 ENVI 的标准工具执行一些空间
上或波谱子集的构建。点击“OK”。 

4 用同样的方式选择其它文件写到磁带上。 
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被选择的文件将出现在 Output ENVI Files to Tape 窗口的 “Select ENVI Files to Tape” 列表里。 

·你可以在 “Tape Device” 文本框里键入需要的设备名，以改变磁带设备。 

注意 

如果在这个窗口磁带设备发生变化，你应该等上几秒钟，因为新的设备正式运行以前在操作系

统中注册要花一些时间。 

5 点击“OK”。 

·当出现 ENVI Format - Load Tape 窗口时，你可以在相应文本框里键入需要的值，再次改变磁
带设备和和磁带的最大记录长度（Max Recsize）。 

6 点击“OK”，使 ENVI 依次将选择的文件用标准 ENVI 磁带格式输出到磁带上。 

一个状态窗口显示出每个文件被写的进展状况。处理结束磁带被倒带（rewound）。 

Scan Tape and Customize Dump 

这一功能将扫描一个磁带，列出所发现的所有文件，并允许你选择要读到磁盘上的文件。扫描

建立一个描述磁带内容的 “Tape Script”，被编辑为合成特定的磁带记录或文件，以备将来用于同样
的磁带。 

1 选择 Utilities > Tape Utilities > Scan Tape and Customize Dump. 

当 ENVI Tape Dump Utility 对话框出现时，在窗口顶部 “Tape Device” 文本框里显示出默认的
磁带设备。 

·若改变当前的磁带设备，在文本框里键入相应的系统设备名。 

注意 

你应该等上几秒钟，因为新的设备正式运行以前在操作系统中注册要花一些时间。 

2 一个记录接一个记录地扫描磁带，选择 Options > Scan Tape. 

当磁带被扫描时，屏幕上将出现 ENVI Tape Information Scan 窗口。窗口里显示着当前磁带上
被扫描的文件号与总字节数。 

·无论什么时候，想中断磁带扫描，点击窗口底部的 “Interrupt Tape Scan”。 

当每个文件都被完成以后，ENVI Tape Dump Utility 对话框里滚动显示出磁带信息。若磁带扫
描被打断，将显示出终止处的信息，并且磁带自动倒带。任何一种情况下，文件名、记录数与每个

记录的字节数都被显示了出来。 

3 在 ENVI Tape Dump Utility 对话框，通过运用下面的选项，选择要存储的文件、记录和字节。 

·要改变和编辑这些值，在列表中点击要改动的条目。 

在列表下方相应的文本框里，将显示出数值。 

·要更改这些数值，点击需要的文本框，键入需要的数值，按回车键。 

这允许文件或记录合成，以及选择要读的部分字节。 

·向存储列表中增加新条目，在文本框里键入新值，点击 “Add Entry” 按钮。 

·从列表中删除已经进入的内容，点击列表中显示的输入项，按“Delete Entry”按钮 
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·清除列表，选择“Clear Entries” 

·从以前的扫描中调用数据，选择 Options > Restore Prev Scan. 

·将磁带脚本存为 ASCII 文本文件，选择 File > Save Format，并键入需要的文件名。 

默认的文件扩展名为 .fmt 。 

·要调用以前存储的磁带脚本，选择 File > Restore Format，并选择需要的文件。 

4 一旦需要的磁带脚本被装载上，选择 Options > Dump Tape 以读取磁带。 

出现 Tape Dump Output Parameters 对话框。 

5 点击按钮选择 “Dump tape records to a single output file” 或 “Dump each item to a separate 
output file”。 

6 键入一个输出文件名，点击“OK”。 

如果选择独立的输出文件，键入的输出文件名将被用作一个基文件名，被转储的文件号将被加

在基文件名后面。例如，如果输入的文件名是“test”，文件 2 和文件 3 被存储，他们将被输出为 
“test_2” 和 “test_3”。 

当磁带被转储以后，在 ENVI Dump Tape to Output File 窗口显示出了状态。 

·要中断磁带转储，点击 “Interrupt Tape Dump”。 

Dump Tape (转储磁带) 

进行二进制磁带到磁盘的转储： 

1 选择 Utilities > Tape Utilities > Dump Tape. 

2 出现 Dump Tape 对话框时，从下列选项中选择。 

在窗口顶部 “Tape Device” 文本框里显示出默认的磁带设备。 

·若改变当前的磁带设备，在文本框里键入相应的系统设备名。 

注意 

你应该等上几秒钟，因为新的设备正式运行以前在操作系统中注册要花一些时间。 

在 “Dump Files” 文本标签附近的文本框里显示着磁带里存储的始末文件号。 

·通过点击适当的切换按钮，这些文件可以被转储为单个输出文件，或多个独立的文件。 

3 键入输出文件名，点击“OK”开始磁带转储。 

如果选择独立的输出文件，键入的输出文件名将被用作一个基文件名，被转储的文件号将被加

在基文件名后面。例如，如果输入的文件名是“test”，文件2和文件3被存储，他们将被输出为 “test_2” 
和 “test_3”。 

当磁带被转储以后，在 ENVI Dump Tape to Output File 窗口显示出了状态。 

·要中断磁带转储，点击 “Interrupt Tape Dump”。 
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General Purpose Utilities (通用工具) 
在 General Purpose 子菜单下，可以见到几个最常用的工具，包括用平均值替代坏行，对数据
进行模糊减少（a dark subtraction）和去条带（destrip）。 

Replace Bad Lines (坏行修补) 

Replace Bad Lines 功能允许你替代图像数据中的坏数据行。在用ENVI光标确定使用这一功能之
前，务必先确定要替代的行的位置。要了解交互式修改坏行的方法，参见第 229 页的 “Spatial Pixel 
Editor” 部分。 

1 选择 Utilities > Preprocessing > General Purpose > Replace Bad Lines. 

2 当出现Bad Lines Input File对话框时，选择一个输入文件。若有必要，用标准ENVI文件选择程
序抽取输入文件的子集。 

3 点击“OK”。 

4 当出现Bad Lines Parameters对话框时，在标有“Enter Bad Line”的文本框里限定要替代的坏行，
按回车键。 

5 在“Selected Lines”列表中将显示出这些行。从列表中点击这些行，删除它们。 

·将行coordinates存到一个文件中，点击“Save”。 

·恢复以前存储的文件中的coordinates，点击“Restore”。 

·清除被恢复的行，点击“Clear”。 

6 在标有“Half Width to Average”的文本框里，键入要参与计算平均值的邻近行数。在要替代的
行周围数值应是对称的。例如，值为“2”意味着每边各有两行将参与平均值计算。 

7 点击“OK”。 

8 出现Bad Lines Output对话框时，选择输出到“File”或“Memory”。若需要，可以键入一个输出
文件名。 

9 点击“OK”，开始运行这一功能，用邻近行的平均置替代选择的坏行。 

Dark Subtraction (黑区调整) 

Dark Subtraction 功能允许对图像数据进行大气散射校正。从每一个波段减少的数字值，可以是
波段最小值，或者是用户定义的感兴趣区的平均值，或一个特定值。 

1 选择 Utilities > Preprocessing > General Purpose > Dark Subtract. 

2 当出现 Dark Subtract Input File 对话框时，选择一个输入文件。若需要，用标准 ENVI 文件
选择程序抽取输入文件的子集。 

3 点击“OK”。 

4 当出现 Dark Subtraction Values 对话框时，选择需要的模糊减少（dark subtraction）方法。 

·自动应用每一个波谱波段的最小 DN 值。 
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A 选择 “Band Minimum” 按钮。 

B 点击“OK”。 

将每一个波谱波段的感兴趣区平均值作为 dark subtraction 的数值（ROIs必须先被限定）： 

A 选择 “Region of Interest” 按钮。 

B 从可利用区域列表中选择合适的感兴趣区，点击“OK”。 

·输入一个用户定义值，让每个波段都减去它： 

A 选择 “User Value” 按钮。 

在 “Current Subtraction Values” 标签下，出现一个波段列表和一个默认的数值 0.0000。将 dark 
subtraction 值改变为所需要的值： 

B 点击其中一个波段名。 

C 在 “Edit Selected Item” 下面的文本框里键入需要减少的值，按回车键。 

D 按需要编辑其它波段值。 

E 点击“OK”。 

5 当出现 Dark Subtract Parameters 对话框时，选择输出到 “File” 或 “Memory”；若有必要，键
入一个输出文件名。 

6 点击“OK”，开始运行。 

Destripe Data (数据去条带) 

去数据条带功能允许消除图像数据中周期性的扫描行条带。这种条带在 Landsat MSS 数据中
经常见到（每 6 行出现一次），在 Landsat TM 数据中也有（每 16 行出现一次）。这一功能计
算每 n 行的平均值，并对每行标准化为各自的平均值。 

1 选择 Utilities > General Purpose Utilities > Destripe. 

2 当出现 Destriping Data Input File 对话框时，选择输入文件；若有必要，用标准 ENVI 文件
选择程序在空间上或波谱构建子集。 

3 点击“OK”。 

4 当出现 Destriping Parameters 对话框时，在标有 “Number of Detectors” 的文本框里键入探测
元件的数目（条带的周期；例如，对于 Landsat MSS，该值为“6”）。 

如果文件头栏里的文件类型已经设置好，则默认值自动确定。 

5 选择 “File” 或 “Memory” 输出。 

·若选择 “File”，在相应文本框里键入输出文件名，或用 “Choose” 按钮选择一个输出文件。 

·任何时候想返回主菜单，点击 “Cancel” 按钮。 

6 点击“OK”开始运行。 
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Cross-Track Illumination Correction (轨道照度修正) 

由于渐晕效应(vignetting effects)、仪器扫描或其它非均匀的光线照明效果，在交叉跟踪照明过程
中图像经常会发生偏差。ENVI 交叉跟踪照明校正功能可以用来消除这种改变。沿轨平均值 
(along-track mean value) 被计算出，并可以被绘制，来显示交叉轨道方向的平均偏差。按照用户定义
的顺序，一个多项式函数能用来消除这种改变。可以选择加法或乘法校正。 

进行轨道照度修正： 

1 选择Utilities > General Purpose Utilities > Cross-Track Illumination Correction. 

2 当出现 Cross Track Illumination Input File 对话框时，选择输入文件，如果有必要，执行任意
的空间或波谱构造子集或掩模。 

出现 Cross Track Illumination Correction Parameters 对话框。 

3 点击 “Samples” 或 “Lines” 附近的复选框，选择交叉跟踪方向。 

4 选择 “Additive” 或 “Multiplicative” 校正方法。 

5 输入需要的多项式阶数(order)，点击 “Plot Polynomial”，来显示一个红色的平均值图表，所选
择的多项式拟合用白色覆盖其上。 

·多项式的次数可以改变，若有必要，再用图示表示。 

最好用一个低次多项式，这样就不必再消去数据本身的误差。 

注意 

只有 Cross Track Illumination Correction Parameters 对话框用“OK”或“Cancel”按钮关闭，才
能激活 Cross Track Illumination Correction plot 下拉菜单。 

6 选择输出到 “File” 或 “Memory”。 

·若选择 “File”，在相应文本框里键入输出文件名。 

7 点击“OK”开始处理。 
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Data-Specific Utilities 

Display HDF Global Attributes (显示 HDF 整体属性) 

如果在一个 HDF 科学数据(SD) 文件里存有一些全球的整体属性值，你可以在一个文本记录中
显示它们。你可以将这一记录存为 ASCII 文本文件。 

1 选择 Utilities > Data-Specific Utilities > View HDF Global Attributes. 

2 出现文件选择对话框时，选择需要的 HDF SD 文件。 

在 HDF 文件里包含的全球属性将在屏幕上显示出来（存到一个文本记录中）。 

3 选择下列选项之一。 

·将记录存为一个 ASCII 文本文件： 

A 选择 File > Save Text to ASCII. 

B 键入或选择一个输出文件名，点击“OK”。 

·不保存信息推出记录，选择 File >Cancel. 

AVHRR Utilities 

AVHRR 工具包括从 AVHRR 文件头里阅读和显示信息，根据反射比率和亮度校准数据，计算
海面温度，运用数据信息做地理坐标定位(georeferencing)。在地理坐标定位之前进行校准和海面温度
的计算。详见如下参考书。 

Di, L. and D. C. Rundquist, 1994. A one-step algorithm for correction and calibration of AVHRR 
Level 1b data, Photogrammetric Engineering & Remote Sensing, Vol. 60, No. 2, pp. 165-171. 

NOAA 卫星信息系统网页： 

http://psbsgi1.nesdis.noaa.gov:8080/EBB/ml/nic00.html 

·使用 AVHRR 工具，选择 Utilities > Data Specific Utilities >AVHRR Utilities. 

Display Header Information (显示头信息) 
显示AVHRR中包含的头信息。 

1 选择 Utilities > Data Specific Utilities > AVHRR Utilities > Display Header Information. 

2 选择需要输入的 AVHRR 数据文件，点击“OK”。 

出现了显示头信息的 AVHRR File Information 对话框。 

·要将信息存储为一个 ASCII 文件，从 AVHRR File Information 对话框选择 File > Save Text to 
ASCII，并键入一个输出文件名。 

Calibrate Data (校准数据) 
这一功能被用来校准来自 NOAA 12，14 和 15 号卫星的 AVHRR 数据。波段 1 和 2 按反射
百分比校准，波段 3，4 和 5 按亮度温度校准（开氏温度）。要校准AVHRR数据，照以下操作： 
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1 选择 Utilities > Data Specific Utilities > AVHRR Utilities > Calibrate Data. 

2 选择需要输入的 AVHRR 数据文件，按需要构建空间或波谱子集。 

3 当出现 AVHRR Calibrate Parameters 对话框时，用 “Satellite” 下拉菜单选择卫星名，点击 
“File” 或 “Memory” 输出。 

·若你选择 “File” 输出，键入或选择一个输出文件名。 

4 点击“OK”，开始校准。 

波段 1 和 2 将按反射百分比输出，波段 3，4 和 5 将用亮度温度（单位：开尔文）输出。 

Georeference Data (地理坐标定位数据) 
AVHRR 数据、校对结果、海面温度图像可以用 AVHRR 自身的数据信息进行地理坐标定位。

每一个数据行有51个经纬度值可以用作地理坐标定位。一旦 AVHRR 原数据被地理坐标定位，计算
校对时用到的头信息以及海面温度将不在新的 ENVI 文件头里显示。所以应当在进行 AVHRR 校
对和海平面温度计算以后再做地理坐标定位。 

要地理坐标定位 AVHRR 数据： 

1 选择 Utilities > Data Specific Utilities > AVHRR Utilities > Georeference Data. 

2 选择需要输入的文件，按需要构建空间或波谱子集。 

·如果输入文件不是 AVHRR 的文件，再次出现输入文件对话框，供你选择 AVHRR 原文件。 

地理坐标定位信息是从 AVHRR 原文件中抽取的。 

3 当出现 Georeference AVHRR Parameters 对话框时，从列表中选择需要输出的地图投影。 

·如果你选择 “Arbitrary”，点击 “Coordinates” 标签附近的箭头切换按钮，选择 “Pixel Based” 或 
“Map Based”。 

“Pixel Based” 将图像的左上角作为原点，“Map Based” 以图像的左下角为原点。两种坐标都是
只影响 “y” 坐标。 

· 如果你选择 “Geographic Lat/Lon:”，点击 “Datum” 按钮，从 “Select Geographic Datum” 对
话框的列表中选择数据。 

数据转换是用 Molodensky 变换做的（见网页 http://www.connect.net/jbanta/）。 

·如果你选择“UTM”，在 “Zone” 文本框里键入一个数字，或点击 “Zone” 按钮从随后的对
话框列表中选择。 

·若你选择 “State Plane...” 中一个投影，键入或选择一个区域，并用箭头切换按钮选择 “Feet” 
或 “Meters”。 

4 在相应的 “X” 和 “Y” 文本框里，键入每一个点的 X 和 Y 值。 

直到 51 个点全部输入完才能地理坐标定位。如果输入的点较少，它们在图像中均匀分布。从
时间上考虑，建议使用少于 10×10 的点。 

·要将 x、y 对应的点存为一个 GCP 文件，输入或选择一个输出文件名。 

注意 

使用许多的纠正点，将显著地增加纠正处理时间。 
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5 点击“OK”。 

6 当出现标准 Registration Parameters 对话框时，选择纠正与重抽样方法，若有必要，再改变输
出的维数。 

提示 

三角测量方法产生的结果比较精确，但是它比多项式拟合速度稍慢一些。 

7 选择 “File” 或 “Memory” 输出，点击“OK”。 

·若选择 “File” 输出，键入或选择一个输出文件名。 

Compute Sea Surface Temperature (计算海面温度) 
当前一幅用摄氏度表示的海洋表面温度图像是用 AVHRR 波段 3，4，5 计算的。目前，ENVI 

在海洋表面温度计算中不使用云或土地掩模。海洋表面温度计算时用到的算法详见上述参考的网页。

可以用四种算法，一个用于白天的数据，另三个用于夜间的数据。它们分别是 Day MCSST Split; Night 
MCSST Split; Night MCSST Dual; 和 Night MCSST Triple。这些算法在用哪个波段校正大气上是不
同的，Split-窗口用波段 5 - 4，Dual-窗口用波段4 – 3，Triple-窗口用波段 5 – 3。用到的系数是基于
1995年3月全球漂流浮标和热带太平洋固定浮标共同确定的（matchups）。 

要计算一幅海面温度图像： 

1 选择 Utilities > Data Specific Utilities > AVHRR Utilities > Compute Sea Surface Temperature. 

2 选择需要输入的 AVHRR 数据文件，根据需要抽取一定空间子集。 

输入文件必须包含 AVHRR 波段 3，4 和 5 。 

3 出现 AVHRR Sea Surface Temperature Parameters 对话框，用 “Satellite” 下拉菜单选择卫星
名。 

4 用 “SST Algorithm” 下拉菜单选择需要的算法。 

5 选择 “File” 或 “Memory” 输出，点击“OK”。 

·若选择 “File” 输出，键入或选择一个输出文件名。 

输出的海平面温度图像是用摄氏度表示的。 

Digital Elevation (数字高程) 

数字高程工具包括一个地形建模函数和一个选项（彩色输出表面图）。运用主图像窗口功能菜

单的一个选项可以建立一个DEM文件的三维表面图。 

Topographic Modeling (地形模型) 
ENVI 能处理 USGS DEMs 和其它的数字高程数据，生成 lambertian (晕渲地形) 表面；提取参
数信息，包括坡度和方位。平面适于确定以每一个象素为中心的 3×3 的块，ENVI 计算平面的坡
度和方位。坡度用度测量，在水平面上为0度。ENVI 将正北方向的方位角设为 0 度，角度顺时针
增加。也产生一幅均方根 (root mean square，RMS) 误差图像，表征 9 个象素的平面性。 

注意 

地形建模工具作用于图像格式的数据，不是原始的 USGS 格式 DEM 数据。 
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在你的 DEM 数据基础上，运用 ENVI 的地形建模工具： 

用 DEM 磁带程序或 DEM 文件程序将轮廓数据转换为图像格式。 

1 选择 Utilities > Data-Specific Utilities > Digital Elevation > Topographic Modeling. 

2 出现 Topo Model Input DEM 对话框时，从文件列表中选择一幅 DEM 图像，构建一些空间
子集。 

·打开一个新的 DEM 图像，选择 File > Open New File. 

3 点击“OK”。 

4 当 Topo Model Parameters 对话框出现时，在 “Sun Elevation Angle” 和 “Sun Azimuth Angle” 
文本框处键入需要的值，为晕渲地形图像(shaded relief image) 指定太阳高度和方位角。 

·计算太阳高度值： 

A 点击 “Compute Elevation and Azimuth”，显示出 Compute Sun Angle 对话框； 

B 从 “Month” 按钮菜单里选择月，并在相应文本框里键入天，年和时间（GMT）； 

C 在相应文本框里键入需要的经纬度坐标； 

D 点击“OK”，进行计算。 

计算出的高度和方位角值自动地进入了 Topo Model Parameters 对话框。 

5 在  “Select Bands to Compute” 列表中点击图名左侧的小框，选择要计算的图像（坡度 
“Slope”、方位 “Aspect”、晕渲地形 “Shaded Relief”，以及RMS误差“RMS Error”） 

·点击 “Select All” 选择所有波段 

·点击 “Clear” 清除所有选项 

6 如果像元大小没有在文件头中设置，输入表示像元大小的 X 和 Y（单位：米）。 

7 点击相应按钮，选择 “File” 或 “Memory” 输出。 

·若选择 “File” 输出，在 “Enter Output Filename” 文本框键入一个输出文件名，或用 “Choose” 
按钮选择一个输出文件名。 

8 点击“OK”开始计算。 

处理完成以后，选择的图像被显示在Available Bands List中（供 ENVI 显示和处理用）。地形
建模工具输出的例子见 Figure 5-29 中所示。 

DEM Replace Bad Values (替代坏值) 
使用 DEM Replace Bad Values 是用一个表面拟合方法计算出的数值，在数字高程模型(DEMs) 
中填充坏值。坏像元值通常出现在干涉雷达产生的 DEMs 雷达阴影里。当你键入坏像元的 DN 值
或坏值区间时，坏像元的位置在 DEM 图像中被识别。你也可以为坏像元做一个掩模，并用它判定
需要被替代的像元位置(见第 335 页的 “Masking”)。表面适配将周围的好的高程值运用德洛内三角
测量方法计算填充坏像元。 

注意 

如果在数据集中有一些大洞，你可以用三角形填充它们。 

1 选择 Utilities > Data Specific Utilities > Digital Elevation > Replace Bad Values or Radar Tools 



 205

> TOPSAR Tools > DEM Replace Bad Values. 

2 当出现 DEM Input File 对话框时，选择 DEM 文件，抽出一些子集或掩饰。 

出现 Bad Data Parameters 对话框。 

3 在适当文本框里，输入坏像元值或坏值区间。 

注意 

如果你选择一个掩模波段，就不必输入值了。由于这一波段包含了坏像元的位置。 

4 点击相应按钮，选择 “File” 或 “Memory” 输出。 

·若选择 “File” 输出，键入或选择一个输出文件名。 

5 点击“OK”。 

输出文件出现在 Available Bands List 中。 

Landsat MSS 

在 Landsat MSS 子菜单下，可以得到专门用于 Landsat 多波谱扫描仪(MSS) 数据的去斜和纵横
比校正。 

Deskew (去斜) 
早在 1978 年，经过处理的 Landsat MSS 图像数据就包含了由于地球自转和扫描纠正而致的变

形。MSS 的去斜功能根据轨道特征和随纬度发生变化的地球自转特征之间的联系，偏移成组扫描行
减少纠正。运行这一功能，照以下步骤： 

1 选择Utilities > Data Specific Utilities > Landsat MSS > Deskew. 

2 出现 Deskewing Input File 对话框时，选择一个输入文件；若需要，用标准 ENVI 文件选择
程序构建空间上或波谱的子集。 

3 点击“OK”。 

4 当出现 Deskewing Parameters 对话框时，在标有 “Latitude Degrees”、“Latitude Minutes” 和 
“Latitude Seconds” 的文本框里键入 MSS 图像中心的纬度值。 

5 点击相应按钮，选择 “File” 或 “Memory” 输出。 

·若选择 “File” 输出，在合适的文本框里键入一个输出文件名，或用 “Choose” 按钮选择一个
输出文件名。 

·无论何时想关闭这一功能，点击 “Cancel”。 

6 点击“OK”，开始运行。 

出现一个状态窗口，显示着输出文件名和完成的百分比。 

MSS Aspect Ratio Correction (纵横比校正) 
Landsat MSS 图像数据特殊地包含了因扫描方向上重复取样所致的几何纠正。实际的像元大小
大约是 79m×79m，但是在扫描方向上工具每隔 57 米抽一次样。由于过采样(oversampling)，需要
根据系数 57/79=0.72 调整纵横比。MSS Aspect Ratio Correction 选项把最近邻重采样 (nearest 
neighbor resampling)应用到一个规则的网格，来调整纵横比。 
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1 选择 Utilities > Data-Specific Utilities > Landsat MSS > Aspect. 

2 出现 Aspect Correction Input File 对话框时，选择一个输入文件；若需要，用标准 ENVI 文
件选择程序构建空间上或波谱的子集。 

3 点击“OK”。 

4 当出现 Aspect Correction Parameters 对话框时，选择输出到 “File” 或 “Memory”，若需要，
键入一个文件名。 

5 点击“OK”开始运行。 

务必让其单独运行。状态窗口将显示出输出文件名，并给出已经完成的百分比。 

Landsat MSS Calibration 
这一项被用作将 Landsat MSS 数值转换成辐射率或外大气层反射系数（用已公开的 post-launch 
增益和偏移）。 

Landsat TM 

Landsat TM Calibration 
这一项被用作将 Landsat TM 数值转换成辐射率或外大气层反射系数（用已公开的 post-launch 
增益和偏移）。 

SeaWiFS Utilities 

SeaWiFS 工具包括的选项允许你为 HDF 和 CEOS 格式的 SeaWiFS 数据，计算几何信息和
地理坐标定位。你可以计算的几何信息包括纬度、经度、传感器方位角、传感器高度、太阳方位角、

太阳高度以及 UTC 时间。地理坐标定位选项根据一个完善的适于地球和卫星轨道的几何模型生成
了一个完全精确的地理编码，详见如下。 

Build Geometry File (建立几何文件) 
当你为 HDF 和 CEOS 格式的 SeaWiFS 数据选择 Build Geometry File 以后，ENVI 将提取头

信息，为每个像元计算几何值。你可以选择要计算的任何数值：纬度、经度、传感器方位角、传感

器高度、太阳方位角、太阳高度以及 UTC 时间。高度角是从每个像元到传感器或太阳的垂直角度，
方位角是从每一个像元到传感器或太阳的方位角度，正北方向角度为 0，顺时针增加（即正东方向
方位角 = 90 度）。 

1 选择 Utilities > Data-Specific Utilities > SeaWiFS Utilities > HDF Build Geometry File 或 
CEOS Build Geometry File. 

2 出现 SeaWiFS Input File 对话框时，选择一个图像文件，根据需要构建空间或一定范围的子
集。 

你输入的文件可以是 ENVI 文件。 

3 如果你输入的文件不是 HDF 格式，选择与 HDF 或 CEOS 相关的注记文件读取头信息。 

4 出现对话框时，点击以下选项，选择你要计算的数值： 

·选择单个数值，点击需要值附近的小空框。 
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·选择一个数值区间，在 “Add Range” 按钮附近的两个文本框里键入起始和终止值，点击 “Add 
Range”。 

·选择所有数值，点击 “Select All”。 

·清除选择的所有条目，点击 “Clear”。 

5 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入或选择一个输出文件名。 

6 在 “Output Data Type” 标签附近，选择 “Double” 或 “Floating Point” 作为输出文件的类型。 

7 点击“OK”。 

Georeference Data 
当你选择 Georeference Data 选项时，ENVI 为 HDF 和 CEOS 格式的 SeaWiFS 数据提取头

信息，并根据一个完善的适于地球和卫星轨道的几何模型生成一个精确的地理编码。 

1 选择 Utilities > Data-Specific Utilities > SeaWiFS Utilities > HDF Georeference Data 或 CEOS 
Georeference Data. 

2 出现 SeaWiFS Input File 对话框时，选择一个图像文件，根据需要构建空间或一定范围的子
集。 

你输入的文件可以是 ENVI 文件。 

3 如果你输入的文件不是 HDF 格式，选择与 HDF 或 CEOS 相关的注记文件读取头信息。 

4 出现 Georeference SeaWiFS Parameters 对话框时，从列表中选择要输出的地图投影。 

·如果你选择 “Arbitrary”，点击 “Coordinates” 标签附近的箭头切换按钮，选择 “Pixel Based” 或 
“Map Based”。 

“Pixel Based” 将图像的左上角作为原点，“Map Based” 以图像的左下角为原点。两种坐标都是
只影响 “y” 坐标。 

·如果你选择 “Geographic Lat/Lon:”，点击 “Datum” 按钮，从 “Select Geographic Datum” 对话
框的列表中选择数据。 

数据转换是用Molodensky 变换做的（见网页 http://www.connect.net/jbanta/）。 

·如果你选择“UTM”，在 “Zone” 文本框里键入一个数字，或点击 “Zone” 按钮从随后的对
话框列表中选择 

·若你选择“State Plane...”中一个投影，键入或选择一个区域，并用箭头切换按钮选择 “Feet” 或 
“Meters”。 

5 在相应的 “X” 和 “Y” 文本框里，键入每一个点的 X 和 Y 值。 

你可以在图像上选择许多纠正点，直至满足样本数和行数。如果输入的点较少，它们在图像中

均匀分布。然而，从时间上考虑，建议使用少于10×10的点。 

·要将 x、y 对应的点存为一个 GCP 文件，输入或选择一个输出文件名。 

注意 

使用许多的纠正点，将显著地增加纠正处理时间。 
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6 点击“OK”。 

7 当出现标准 Registration Parameters 对话框时，选择纠正与重抽样方法，若有必要，再改变输
出的维数。 

注意 

三角测量方法产生的结果最精确，但是它比多项式拟合速度稍慢一些。 

8 选择 “File” 或 “Memory” 输出，点击“OK”。 

·若选择 “File” 输出，键入或选择一个输出文件名。 

TIMS（热红外多波段扫描仪） 

用 TIMS Radiance Calibration 工具把来自 NASA Thermal Infrared Multispectral Scanner (TIMS) 
的原始数据校准到单位为 W/m2/µm/sr 的辐射率。来自平台上的(on-board) 黑体和两个内部参照源
的数据，被储存在每个图像行的前 60 个字节。参照数据可以被平滑。用普朗克辐射定律和参考数
据计算每一幅 TIMS 波谱波段的增加和偏移值，从而用于校对辐射的原始 DN 值。详见如下。 

Palluconi, F. D. and Meeks, G. R., 1985. “Thermal Infrared Multispectral Scanner (TIMS): An 
Investigator’s Guide to TIMS Data,” JPL Publication 85-32, p. 14. 

1 选择Utilities > Data-Specific Utilities > TIMS > Radiance Calibration，或 Utilities > Calibration 
Utilities > TIMS Radiance. 

2 选择需要的 TIMS 输入文件（每行包含参考信息的 60 个字节）。 

出现 TIMS Calibration Parameters 对话框。 

3 键入要平滑的参照数据的行数，并键入一个输出文件名，点击“OK”。 

作为结果的波段出现在 Available Bands List 中，包含了辐射值 (W/m 2 /µm/sr) 。 

用 Thermal IR 计算发射率 

用 Thermal IR 工具把数据集从辐射率转换到发射率和温度。有三个 Thermal IR 工具：参考通
道(Reference Channel)，发射率标准化(Emissivity Normalization) 和 α残余(Alpha Resiuals)。 

从一个表面发出的热红外辐射是表面温度和发射率的函数。发射率与地表成分有关，且常被用

来制作地表成分图。ENVI有三个技术，可以被用来分离热红外传感器测量的辐射数据中的发射率和
温度信息。参考通道和发射率标准化方法都假定一个固定的发射率值，并生成发射率和温度输出。

α 残余方法不提供温度信息。要了解详细信息，请参看下列参考书： 

Hook, S. J., A. R. Gabell, A. A. Green, and P. S. Kealy, 1992. A comparison of techniques for 
extracting emissivity information from thermal infrared data for geologic studies. Remote Sensing of 
Environment, Vol. 42, pp. 123-135. 

Kealy, P. S. and S. J. Hook, 1993., Separating temperature and emissivity in thermal infrared 
multispectral scanner data: Implications for recovering land surface temperatures. IEEE Transactions on 
Geoscience and Remote Sensing, Vol. 31, No. 6, pp.1155-1164. 

Reference Channel Emissivity (参照频道发射率) 
这一工具可以计算出热红外辐射数据的发射率和温度值。参照频道发射率技术假定热红外数据
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的一个频道（波段）中的所有像元有一个恒定的发射率。用这一恒定的发射率，可以计算出一幅温

度图像，这些温度可以用于普朗克函数计算其它波段的辐射率值。你可以选择保持恒定值的波段，

并为这一波段键入需要的发射率值。详见上述参考书。 

1 选择 Utilities > Data-Specific Utilities > Thermal IR > Reference Channel Emissivity or Utilities 
> Calibration Utilities > Calculate Emissivity > Reference Channel. 

2 选择要输入的辐射数据文件，按需要构建一些子集。 

出现 Calculate Emissivity parameters 对话框。 

3 若需要，键入一个数据比例系数，将辐射值的单位统一成 W/m 2 /µm/sr 。 

4 若需要，键入一个波长比例系数，将波长的单位（从文件头中读取）统一成 µm 。 

5 从 “Emissivity Band” 下拉列表中，选择一个波段采用恒定发射率值。 

6 在 “Assumed Emissivity Value” 文本框里，为恒定值波段键入需要的发射率值。 

7 点击 “Output Temperature Image?” 箭头切换按钮，选择是否输出一幅温度图像。若需要，键
入一个输出文件名。 

8 为辐射数据键入一个输出文件名，点击“OK”。 

温度图像(单波段) 和发射率数据立方体(与输入的辐射数据波段相同) 出现在 Available Bands 
List 中。 

Emissivity Normalization (发射率标准化) 
这一工具用来计算热红外辐射数据的发射率和温度值。发射率标准化方法用一个固定的发射率

值计算每一个像元和波段的温度值。在每一个像元的最高温度被用于普朗克函数计算发射率值。你

可以输入固定的发射率值。了解详细信息，见上述参考书： 

1 选择 Utilities > Data-Specific Utilities > Thermal IR > Emissivity Normalization，或 Utilities > 
Calibration Utilities > Calculate Emissivity > Emissivity Normalization. 

2 选择要输入的辐射数据文件，按需要构建一些子集。 

出现 Calculate Emissivity parameters 对话框。 

3 若需要，键入一个数据比例系数，将辐射值的单位统一成 W/m 2 /µm/sr 。 

4 若需要，键入一个波长比例系数，将波长的单位（从文件头中读取）统一成 µm 。 

5 在 “Assumed Emissivity Value” 文本框里，为键入需要的固定发射率值，以用于计算温度。 

6 点击 “Output Temperature Image?” 箭头切换按钮，选择是否输出一幅温度图像。若需要，键
入一个输出文件名。 

7 为辐射数据键入一个输出文件名，点击“OK”。 

单一波段的温度图像和与输入的辐射数据波段相同的发射数据立方体出现在 Available Bands 
List 中。 

Alpha Residuals 
这一工具用于生成 α 残余波谱（范围），它接近于热红外辐射数据的发射波谱的形状。用到
了普朗克函数的 Wien’s 估计，因此对数方程可以线性化。温度和发射区间被分开，这些手段被用
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于截掉温度区间的外部。 

α 残余波谱仅仅是一个发射率的函数，与发射波谱有一个相似的形状，但是平均值为 0 。所
以发射率波谱要与 α 残余波谱直接对照，必须按比例改变其大小。发射波谱可以由α残余波谱用
经验数据计算出来（1993年在Kealy提到）。 

1 选择  Utilities > Data-Specific Utilities > Thermal IR > Alpha Residuals 或  Utilities > 
Calibration Utilities > Calculate Emissivity > Alpha Residuals. 

2 选择要输入的辐射数据文件，按需要构建一些子集。 

出现 Calculate Emissivity parameters 对话框。 

3 若需要，键入一个数据比例系数，将辐射值的单位统一成 W/m 2 /µm/sr 。 

4 若需要，键入一个波长比例系数，将波长的单位（从文件头中读取）统一成 µm 。 

5 键入一个输出文件名，点击“OK”。 

α 残余数据立方体出现在 Available Bands List 中。 

Convert Complex Data (转换复数型数据) 

你可以用这种工具将复数型数据计算出要输出的图像。图像类型包括“Real” (数据的实部), 
“Imaginary” (数据的虚部), “Power” (以10为底的对数), “Magnitude” (实部与虚部平方和的平方根), 和 
“Phase” (实部除以虚部得到的正切值)。 

1 选择Utilities > Data-Specific Utilities > Convert Complex Data. 

2 选择一个输入的数据文件，点击“OK”。 

3 当出现 Convert Complex Parameters 对话框时，在函数名附近的小框里点击选择输出波段函
数。 

4 选择输出到 “File” 或 “Memory”。 

如果选择输出到“File”，键入一个输出文件名，或点击 “Choose” 选择一个文件名。 

5 点击“OK”。 

计算出的图像将出现在 Available Bands List 中。 
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Calibration Utilities (校准工具) 
校准工具包括将校准系数应用到 AVHRR、MSS 和 TM 数据，以及用 Flat Field、Internal 

Average Relative Reflectance 和 Empirical Line 校准技术。 

AVHRR 

这一功能用来校准来自 NOAA 12 和 14 卫星的 AVHRR 数据。波段 1 和 2 主要被校准反射
百分比，波段 3、4 和 5 被校准亮度温度（单位：开尔文）。 

Landsat MSS Calibration 

用已经公开的 post-launch 增益和偏移(gains and offsets)，将 Landsat MSS 数字值转换成辐射或
外大气层反射。 

1 选择 Utilities > Calibration Utilities > Landsat MSS. 

2 当出现 MSS Calibration Input File 对话框时，选择输入文件；若需要，用标准 ENVI 文件构
建空间或波谱子集。 

3 点击“OK”。 

4 当出现 MSS Calibration Parameters 对话框时，键入描述待校正的 Landsat 数据的参数。 

5 从 “Satellite” 菜单里，选择卫星类型。 

6 在适当的文本框里，键入获得数据的时间（月、日、年）和太阳高度。 

7 点击 “Radiance” 和 “Reflectance” 按钮，选择要输出的类型。 

8 选择输出到 “File” 或 “Memory”。 

·如果选择输出到“File”，在适当的文本框里键入一个输出文件名，或点击 “Choose” 选择一
个文件名。 

9 点击“OK”，开始运行。 

出现 MSS 校准状态窗口，显示着输出文件名以及已经完成的百分比。 

Landsat TM Calibration 

用已经公开的 post-launch 增益和偏移，将 Landsat TM 数字值转换成辐射或外大气层反射。 

波段 6 将被转变为温度。如果输入波段 7，则第 6 个波段被假定为热红外波段。如果只有波
段 6 输入，则就没有热红外波段。 

1 选择 Utilities > Calibration Utilities > Landsat TM. 

2 当出现 TM Calibration Input File 对话框时，选择输入文件；若需要，用标准 ENVI 文件构
建空间或波谱子集。 

3 点击“OK”。 

4 当出现 TM Calibration Parameters 对话框时，从 “Satellite” 菜单里，选择卫星类型。 
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5 在合适文本框里，键入获得数据的时间（月、日、年）和太阳高度。 

6 点击 “Radiance” 和 “Reflectance” 按钮，选择要输出的类型。 

7 选择输出到 “File” 或 “Memory”。 

·如果选择输出到“File”，在合适文本框里键入一个输出文件名。 

9 点击“OK”，开始运行。 

出现 TM 校准状态窗口，显示着输出文件名以及已经完成的百分比。 

Flat Field Calibration (平面场校准) 

平面场校准方法用于将图像标准化成一个已知的“平面”反射区域。这对于将图像分光计数据

减小到“相对反射率”非常有效。这一方法需要你在实施以前选择一个感兴趣区（ROI）。来自感
兴趣区的平均波谱被用作参照波谱，然后被分成图像中每一个像元的波谱。 

1 在波谱平面区域定义一个感兴趣区(见第 200 页的 “Define Regions of Interest”)。 

2 选择 Utilities > Calibration Utilities > Flat Field. 

3 出现 Flat Field Calibration Input File 对话框时，选择输入文件，若需要，用标准 ENVI 文件
选择程序构建空间或波谱子集。 

4 点击“OK”。 

5 出现 Flat Field Calibration Parameters 对话框时，在标有 “Select Calibration from Regions” 一
栏里，点击需要的 ROI 名字，选择用于平面场校准的平均波谱。 

选择的 ROI 名字将出现在标有 “Selected Item:” 的文本框里窗口底部。 

6 选择输出到 “File” 或 “Memory”。 

·如果选择输出到“File”，在合适文本框里键入一个输出文件名，或点击 “Choose” 选择一个
文件名。 

7 点击“OK”，开始校准。 

Internal Average Relative (IAR) Reflectance Calibration 

IARR 校准方法用于将图像标准化成一景平均波谱。这对于在没有地面测量的鲜为人知的区域，
将图像分光计数据减小到“相对反射率”特别有效。这种方法对于没有植被的干旱区域效果很好。

从整个景区计算出平均波谱，并将它作为参照波谱，然后被分成图像中每一个像元的波谱。 

1 选择 Utilities > Calibration Utilities > IAR Reflectance. 

2 出现 Calibration Input File 对话框时，选择输入文件，若需要，用标准 ENVI 文件选择程序
构建空间或波谱子集。 

3 点击“OK”。 

4 出现 IARR Calibration Parameters 对话框时，选择输出到 “File” 或 “Memory”。 

·如果选择输出到“File”，在标有 “Output File Name” 文本框里键入一个输出文件名，或点击 
“Choose” 选择一个文件名。 
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7 点击“OK”，开始运行。 

务必让其单独运行。 

如果不存在统计文件，当统计信息被计算时，将出现一个运行状态出口；当校准完成时，会出

现另外一个状态窗口。校准完毕，校准后的数据将被加在 Available Bands List 中。 

Empirical Line Calibration (经验行校准) 

经验行校准技术被用来将图像数据与选择区域的反射波谱相匹配。线性回归被用在每一个波段

中使 DN 值和反射率相等。这对于消除太阳光晕和大气通道辐射同样具有意义。ENVI 经验行校准
至少需要一个区域（作为实验），或其它参照波谱；这些可以来自波谱剖面或波谱图、波谱库、感

兴趣区、统计表或来自 ASCII 文件。输入的波谱将自动被重采样，以与选择的图像波谱相匹配。如
果不只用了一个波谱，则对一个波段的回归将通过穿越所有波谱的回归行计算。如果只用到一个波

谱，则假定回归行只穿越原始区域（0 反射率等于 0 DN）。可以用已经存在的系数对数据进行校
准。 

Compute Factor and Calibrate (计算系数并校准) 
特别地，你应在经验行校准时，选择一个暗区和一个亮区应用（假定在这些区域参照波谱是可

以得到的）。 

1 选择 Utilities > Calibration Utilities > Empirical Line > Compute Factors and Calibrate。 

2 当出现 Empirical Line Input File 对话框时，选择输入文件。用标准 ENVI 文件选择程序构建
空间或波谱子集。 

3 点击“OK”。 

4 当出现 Empirical Line Spectra 对话框时，选择成对的区域或其它参照波谱以及他们相应的图
像或数据波谱。 

5 在 “Data Spectra:” 标签附近，点击 “Import Spectra” 按钮。 

6 出现 Data Spectra Collection 对话框。 

这一对话框的作用通过点击 Import 下拉菜单聚集图像波谱（未校准波谱），它来自波谱图或
波谱剖面、波谱库、感兴趣区或 ASCII 波谱。 

注意到对话框顶部的黑色绘制小部件，能被用来聚集波谱（在波谱图上拖曳）。 

7 一旦选上数据波谱，点击 “Apply” 向 Empirical Line Spectra 对话框里输入波谱名。关闭 Data 
Spectra Collection 对话框，点击 “Cancel”。 

8 在 “Field Spectra” 标签附近，点击 “Import Spectra” 按钮，选择相应区域的波谱。 

9 当出现 Field Spectra Collection 对话框时，从一个波谱图或剖面、波谱库、感兴趣区或 ASCII 
波谱里选择波谱。 

10 点击 “Apply”，键入波谱名；点击 “Cancel” 关闭对话框。 

下面几步描述怎样将成对数据和区域波谱用于回归。 

11 在顶部列表中，点击数据波谱名选择数据波谱。 

12 在列表底部点击相应区域波谱名，选择区域波谱。 
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13 点击 “Enter Pair”，使两个波谱相联系。 

14 在 “Selected Pairs” 文本框里，将列出成对的波谱。 

15 根据需要，重复选择足够的数据和区域波谱对。 

16 点击“OK”。 

17 当出现 Empirical Line Calibration Parameters 对话框时，选择 “File”或 “Memory” 输出。 

·如果选择输出到“File”，在标有 “Output File Name” 文本框里键入一个输出文件名，或点击 
“Choose” 按钮选择一个文件名。 

·要在 ASCII 文件里存储校准系数，在 “Output Calibration Filename” 文本框里键入第二个文
件名。 

校正系数文件默认扩展名是 .cff 。 

18 点击 “OK” 开始校准。 

校准正在进行时，会出现一个处理状态窗口。当校准完成以后，校准系数将显示在一个标准 
ENVI 绘图窗口。校准以后的图像数据将被添加在 Available Bands List 里。 

Calibrate Using Existing Factors (用现有的系数校准) 
经验行校准可以用另一个校准部分存储的校正系数。 

1 选择 Utilities > Calibration Utilities > Empirical Line > Calibrate Using Existing Factors。 

2 选择输入文件或用标准 ENVI 文件选择程序构造的一些空间上或波谱子集。 

3 点击“OK”。 

4 出现 Enter Calibration Factors Filename 对话框时，从前面经验行校准部分建立的文件里
（.cff），选择一个校准系数。 

5 点击“OK”。 

6 出现 Empirical Line Calibration Parameters 对话框时，选择 “File” 或 “Memory” 输出。 

·如果选择输出到“File”，在标有 “Output File Name” 文本框里键入一个输出文件名。 

7 点击“OK”开始校准。 

TIMS Radiance 

要知详细信息，请参阅第 442 页的 “TIMS”。 

Calculate Emissivity 

要知详细信息，请参阅第 443 页的 “Calculate Emissivity from Thermal IR”。 
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Conversion Utilities (转换工具) 
ENVI 中可以利用的转换工具包括将数据在 BSQ、BIL 和 BIP 格式之间转换，将 VAX 浮点

型数据转换成 IEEE 浮点型数据。 

Convert Data（BSQ、BIL、BIP） 

通常，这种功能对于将存储在特定格式下的图像数据用于特定操作或交互式分析特别有用。例

如波段顺序格式数据（BSQ）可以进行高效的图像显示，波段按像元交叉格式数据 (BIP) 能很快地
提取单个波谱与波谱平均值，行交叉式波段格式集中了上述两者的优缺点。 

在 BSQ、BIP 和 BI L格式之间转换数据遵循以下步骤： 

1 选择 Utilities > Conversion Utilities > Convert Data (BSQ, BIL, BIP)。 

2 出现 File Convert Input File 对话框时，用标准 ENVI 文件选择程序选择和构造子集（若需
要）。 

当输入整幅图像的信息或空间上和波谱的子集时，出现 File Convert Parameters 对话框。输入
文件的信息在窗口顶部显示出来。 

3 从 “Output Interleave” 箭头切换按钮，选择需要的转换格式。 

ENVI 自动地判定输入文件的格式，并提供到另外两种格式的转换。 

4 选择 “Convert in Place?” 标签附近的 “Yes” 或 “No” 按钮。 

·让新的数据格式覆盖已经存在的文件，选择 “Yes”。 

这一选项能节省大量的存储空间，但是处理速度比写到另外一个文件要慢一些。 

警告 

若由于某种原因(即由于停电)，覆盖功能出错，你的数据将被破坏，且原始文件将无法恢复。 

·将转换后的文件存到一个新文件中，选择“NO”。 

5 键入输出文件名。 

6 点击“OK”按钮，开始转换。 

出现文件转换状态窗口，显示有输出文件名，并给出已经完成的百分比。 

VAX 到 IEEE 数据转换 

多数计算机支持浮点数的 IEEE 标准表示法。然而，DEC VAX 计算机仍用它们自己的内部浮
点表示法，一些图像数据仍用这种格式存储。VAX 数据转换功能将 VAX 浮点图像转换成 IEEE 标
准浮点图。要将 VAX 浮点数据转换成 IEEE 的格式，参照以下步骤： 

1 选择 Utilities > Conversion Utilities > VAX to IEEE Converter。 

2 当出现 VAX Floating Point Input File 对话框时，从可得到的文件列表中选择要被转换的文
件。 

3 点击“OK”。 
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4 当出现 VAX to IEEE Parameters 对话框时，键入 VAX 文件头大小（字节）。 

5 选择 “Copy Header” 附近的 “Yes” 按钮，将头信息复制到输出文件里，并作为嵌入的 ENVI 
文件头。选择“NO”仅仅复制数据。 

6 键入输出文件名。 

7 点击“OK”转换文件。 
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Map Projection Utilities (地图投影工具) 
地图投影工具包括一个地图和经纬度转换器，为用户建立投影的方法，投影之间转换以及转换 

ASCII 坐标。 

Map Coordinate Converter (地图坐标转换器) 

将 Map Coordinate Converter 作为一个“计算器”转换经纬度以及相应的地区投影坐标。 

1 选择 Utilities > Map Projection Utilities > Map Coordinate Converter。 

出现 Map Coordinate Converter 对话框。 

2 在对话框的 “First Coordinate” 部分，键入已知点的坐标。 

·如果已知点的坐标是经纬度的，在合适文本框里键入坐标。 

·点击合适的按钮，键入经纬度的度、分、秒（DMS）或用十进制度数表示。 

·如果已知点是另一种投影，点击 “Proj: Geographic Lat/Lon” 标签附近的按钮，并照以下操作。 

A 点击“Change Proj.”。 

B 出现 Projection Selection 对话框时，通过点击选择需要的投影名。 

C 按照投影类型，选择下列选项。 

·改变投影单位，点击 “Units” 按钮，选择需要的单位。 

·改变数据，点击 “Datum” 按钮，选择需要的数据。 

·计算 UTM 投影的区域号，选择“N”或“S”按钮，并点击 “Set Zone” 按钮。键入经纬度
值。 

·为 State Plane 投影选择一个区域号，点击 “Set Zone” 按钮，选择需要的带名。在带名附近
显示了NOS和 USGS 区域号。 

D 点击“OK”。 

3 在对话框的 “Second Coordinate” 部分，点击 “Change Proj” 按钮选择输出的投影。 

4 根据在已知点的投影类型的描述，选择投影参数。 

5 选择下列选项之一： 

·要将第一坐标投影的点转换成第二坐标投影类型，点击 “Forword” 按钮。 

·要将第二坐标投影的点转换成第一坐标投影类型，点击 “Reverse”按钮。 

·要清除坐标，点击 “Reset” 按钮。 

6 点击 “Cancel”，关闭功能。 

Build Customized Map Projection (建立自定义的地图投影) 

ENVI 包括几种“标准“地图投影，如墨卡托投影（UTM）、高斯－克吕格投影（Gauss-Kruger）
等。Build Customized Map Projection 项允许你输入其它的已知地图投影，也可以建立你自己定制的
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地图投影。你可以完全控制所有的地图投影参数，如投影类型、椭圆体、数据、人为指定方向（东、

北）等。具体地图投影的细节参见 Snyder（1982），USGS Bulletin 1532, “Map Projections Used by the 
U. S. Geological Survey”。数据细节能在下面的网页找到： 

http://www.utexas.edu/depts/grg/gcraft/notes/datum/datum.html 和 

http://www.connect.net/jbanta/. 

ENVI 中的 UTM 投影用到了 1927 年北美的数据和 1866 Clarke 椭圆体。用其它数据或椭圆
体建立 UTM 投影，照以下步骤： 

1 选择 Utilities > Map Projection Utilities > Build Customized Map Projection。 

2 当出现 Customized Map Projection Definition 对话框时，或键入一个新的投影名和参数，或点
击 Projection > Load Existing Projection，从 ENVI 目录结构中的“map_proj.txt”文件中包含的
标准投影列表中选择。 

一旦装上，所有的参数都可以被编辑。 

3 在 “Projection Name:” 文本框里，键入或更改投影名。 

4 从支持的投影列表中选择投影类型。 

5 点击箭头切换按钮，选择 “Projection Ellipsoid:” 或 “Projection Datum”，并选择下列选项： 

·若需要不同的椭圆体： 

A 从列表中选择 “User Defined”。 

B 键入需要的“A”和“B”值，定义椭圆体。 

·更改基准点(datum)： 

A 从滚动列表中选择需要的基准点。 

在 “Ellipsoid” 标签附近，显示出与选择的基准点相对应的椭圆体。 

B 返回 “Projection Ellipsoid” 列表，选择椭圆体。 

·若需要人为确定东、北方向，在相应文本框里键入数值。 

6 键入 “Projection Origin” 经纬度，用度、分、秒表示；或选择 Options > DMS< - >DD，并用
十进制度数键入经纬度值。 

7 在对话框的右边可用的文本框里，键入投影类型的具体参数 

参数随选择的投影不同而改变。例如墨卡托投影，中央子午行和基本纬度要求符合一个比例常

数。多圆锥要求投影源。Lamberts 等角圆锥(Conformal Conic) 和 Albers 等积投影需要投影源和两
个标准的平行行。倾斜的墨卡托 A 和 B，以及 Stereographic 投影需要略微不同的参数（详见 
Snyder，1982 ）。 

8 一旦所有参数都被正确输入，选择 Projection > Add New Projection 将投影添加到 ENVI 用
的投影列表中。 

当你关闭对话框时，可利用的投影将根据当前的 ENVI 设置发生改变。系统将提问你是否将这
一投影存到 “map_proj.txt” 文件中。 

要存储新的或更改过的投影信息，选择 File > Save Projections 。 
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在 ENVI 目录结构中的 “map_proj.txt” 文件将发生改变，包含新的投影。这一文件也能用
一些编辑器进行编辑达到上述改变定义的效果。 

9 选择 File > Cancel 退出这一功能。 

Convert Map Projection (转换地图投影) 

用这一功能转换地理坐标定位的文件，用配准功能纠正文件，来自动进行这一转换。 

1 选择 Utilities > Map Projection Utilities > Convert Map Projection。 

2 选择输入文件。 

Convert Map Projection Parameters 对话框出现，在对话框顶部显示出输入的投影；在 “Select 
Output Map Projection” 下方列表中，显示了来自 map_proj.txt 文件的可以利用的输出投影。 

3 选择需要的输出地图投影，若需要，键入区域号。 

·如果你选择 “Arbitrary”，点击 “Coordinates” 标签附近的箭头切换按钮，选择 “Pixel Based” 或 
“Map Based”。 

“Pixel Based” 将图像的左上角作为原点，“Map Based” 以图像的左下角为原点。两种坐标都是
只影响 “y” 坐标。 

· 如果你选择 “Geographic Lat/Lon:”，点击 “Datum” 按钮从 “Select Geographic Datum” 对话
框的列表中选择数据。 

数据转换是用 Molodensky 变换做的（见网页 http://www.connect.net/jbanta/）。 

·如果你选择“UTM”，在 “Zone” 文本框里键入一个数字，或点击 “Zone” 按钮从随后的对
话框列表中选择 

·若你选择 “State Plane...” 中一个投影，键入或选择一个区域，并用箭头切换按钮选择 “Feet” 
或 “Meters”。 

4 在 “Number of Warp Points X/Y” 文本框里，限定用于 X 和 Y 方向上的控制点数。用一组
控制点纠正文件。 

从时间上考虑，建议使用少于10×10的点。 

5 点击“OK”。 

Convert Map Projection 功能用标准的配准参数将图像改变成新的投影。 

6 当出现 Registration Parameters 对话框时，选择纠正方法：RST，多项式或三角测量。 

7 选择重采样方法：最近邻，双线性，或立方体卷积。 

8 键入一个输出文件名。 

9 点击“OK”，开始地图投影转换。 

ASCII Coordinate Conversions (坐标转换) 

这一功能用于将一种投影的 ASCII 坐标和数据转换为另外一种。输入的 ASCII 文件必须包含 
X、Y 坐标栏，以及可选的 Z 值（高度）。如果在输入的坐标中不包括高度值，则假定高度值为 0。
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输出文件在新选择的投影里，就也包含 X、Y（Z）栏。如果需要，你可以将坐标输出到一个 ENVI 
地面控制点文件中。 

1 选择 Utilities > Map Projection Utilities > ASCII Coordinate Conversions。 

2 选择输入的 ASCII 坐标文件。 

·向 “Selected Input Files” 列表中添加一个文件，点击 “Input Additional File”。 

·从列表中删除文件，在 “Selected Input Files” 列表中选择一个文件名，点击 “Delete”。 

3 键入一个输出文件名，或用 “Choose” 按钮选择一个输出文件名。 

4 点击“OK”继续。 

5 当出现 ASCII Coordinate Conversion 对话框时，从 “Select Input Projection” 列表中点击合适
的投影名选择输入投影的类型。 

·如果你选择 “Arbitrary”，点击 “Coordinates” 标签附近的箭头切换按钮，选择 “Pixel Based” 或 
“Map Based”。 

“Pixel Based” 将图像的左上角作为原点，“Map Based” 以图像的左下角为原点。两种坐标都是
只影响 “y” 坐标。 

· 如果你选择 “Geographic Lat/Lon:”，点击 “Datum” 按钮从 “Select Geographic Datum” 对话
框的列表中选择数据。 

数据转换是用Molodensky 变换做的（见网页 http://www.connect.net/jbanta/）。 

·如果你选择“UTM”，在 “Zone” 文本框里键入一个数字，或点击 “Zone” 按钮从随后的对
话框列表中选择 

·若你选择 “State Plane...” 中一个投影，键入或选择一个带，并用箭头切换按钮选择 “Feet” 或 
“Meters”。 

6 在 “Select Output Projection” 列表里，点击投影名作为输出的投影类型，选择 “Coordinates”、
“Datum” 和 “Zone” 键入你需要的内容。 

7 通过在合适标签附近的框里，键入数值或用箭头增加按钮，输入包含地图信息的栏数、Z高度
值以及图像值（如果你输入的文件是 ENVI GCP 格式）。 

8 用箭头增加按钮或在 “Precision” 标签附近的框里键入数字，为输出的数据选择精度。 

9 选择下列选项之一： 

·输出你的转换后的坐标以及数据中所有未改变的输入栏，用 “Output” 标签附近的箭头切换按
钮选择 “All Input Columns”。 

·将转换后的坐标和图像值输出到一个 ENVI GCP 文件（地面控制点），用箭头切换按钮选择 
“ENVI GCP File”。 

10 点击“OK”，转换坐标，并存到一个新的包含已经转换坐标的 ASCII 文件中。 

Merge Old Projection File (合并旧的投影文件) 

你可以用这种功能将一个旧的 “map_proj.txt” 文件和一个已经存在的投影数据库结合起来。这
以为着你在前述操作中添加的投影将与一个新的投影数据库结合起来。 
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1 选择 Utilities > Map Projection Utilities > Merge old “map_proj.txt” File。 

2 当出现 Enter Old “map_proj.txt” Filename 选择对话框时，选择输入 .txt 文件。 

出现一条提示信息，告诉你投影被添加到了数据库中。 

3 点击 “YES”，将更改存储到 “map_proj.txt” 文件中。 

4 选择一个新的输出文件名，点击“OK”。 
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Running Included User Functions (运行内含的用户函数) 
用户自定义的算法可以通过编写 ENVI 用户函数实现。这些用户函数是用 IDL、C 或 Fortran 

语言编写的，且能用专门的 ENVI 函数调用。几个典型的用户函数被包括在了 ENVI 中，并且被
放到了 ENVI 的主菜单里。包括在里面的有：正向和反向孟塞尔颜色变换、一个增益和偏移程序实
例，以及一个建立三维图像的工具。这些函数都是用IDL编写的，被包含在了ENVI销售目录里，作
为展示怎样写用户函数的例子。这部分仅仅描述怎样得到，并运行这些程序。关于内含的用户函数

的详细信息，请参阅 ENVI Programmer’s Guide 的 Chapter 3, “User Functions” 。 

Munsell Color Transforms (孟塞尔彩色变换) 

这一功能用于将一幅彩色图像变换成孟塞尔彩色空间，或由孟塞尔空间变换而来。孟塞尔彩色

系统是土壤和地质科学家用来表示彩色土壤和岩石特征的。这一函数（“MUNSELL.PRO”）的 IDL 编
码包含在了 ENVI 销售说明中的 “lib” 目录里，显示了怎样建立一个用户函数和孟塞尔算法。关于
这种算法的其它细节参见 “USGS Munsell RGB to HSV” 部分。 

·开始正向或反向的孟塞尔变换： 

1 选择 Utilities > User Functions > Munsell RGB to HSV 或 Munsell HSV to RGB。 

文件选择对话框出现，在 Available Bands List 中显示出了所有波段。 

2 通过在列表中连续点击三个波段（按照 RGB 或 HSV 顺序），选择 RGB 合成(HSV 用于
分解）。 

3 如果没必要将整幅图像进行处理，则点击 “Spatial Subset” 按钮选择一个空间子集。 

4 点击“OK”，选择输出到 “File” 或 “Memory”。 

·如果输出到 “File”，键入一个输出文件名。 

变换了的波段将出现在 Available Bands List 中。 

Gain and Offset Program (增益和偏移程序) 

另一个 ENVI 用户函数的例子是增益和偏移程序，它使用小部件和 ENVI tiling。这一功能通过
让选择的波段与一个输入的增益相乘，再加上偏移量，进行一次简单的增益和偏移校正。 

这一功能目的在于显示三个波段型（BSQ、BIL、BIP）的 tile 处理。这一函数（“GAINOFF.PRO”）
的 IDL 代码被包括在了 ENVI 说明书中，展示了怎样建立一个用户函数。程序的细节请参阅 ENVI 
Programmer’s Guide 的 Chapter 3, “User Functions” 。 

1 选择 Utilities > User Functions > Gain and Offset。 

2 选择一个输入文件，并用标准 ENVI 程序构建子集，点击“OK” 

3 出现 User Selected Gain and Offset 对话框，在 “Gain Value” 标签下方的列表中点击一个波段
名，选择要指定一个增益值的那个波段。 

4 在 “Edit Selected Item:” 标签斜下方的文本框里键入需要的值。 

5 在 “Offset Value” 标签的下方列表里点击波段名，并在 “Edit Selected Item” 标签的斜下方文
本框里键入需要的偏移值。 
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6 为参与处理的每个波段重复这样的选择和指定数值。 

·如果你想将所有的设置重设为它们的原始值，点击 “Reset”。 

·返回主菜单，点击 “Cancel”。 

7 点击“OK”，选择输出到 “File” 或 “Memory”。 

如果输出到 “File”，键入一个输出文件名。 

3-D Image Cube (三维图像立方体) 

这一功能用于获取一个多波谱文件，并用透视图中最上行以及最右列波谱创建一幅 RGB 图像。
波谱部分被拉伸，并且用到用户选择的一张颜色表。最终图像是一幅 “3D” RGB 彩色合成图像立方
体。所有中间处理是发生在文件与文件之间的，或是在内存中根据用户选择的最终输出文件而定（临

时性文件被用完以后即被删除）。这一函数 “CUBE_3D.PRO” 的 IDL 代码被包括在了 ENVI 说明
书中，展示了怎样合成程序以及建立一个用户函数的方法。程序的细节请参阅 ENVI Programmer’s 
Guide 的 Chapter 3, “User Functions” 。 

1 选择 Utilities > User Functions > Build 3-D Cube。 

2 选择一个输入文件，并用标准 ENVI 程序构建子集，点击“OK”。 

3 出现 3D Cube RGB Face Input Bands 对话框，点击需要的波段，以便置于图像立方体表面。 

4 点击“OK”，完成选择。 

5 出现 3D Cube Parameters 对话框时，从标准 ENVI/IDL 颜色表中通过点击需要的选择，以确
定 3D 立方体的旁侧和顶部的颜色表。 

6 为 “Spectral Scale” 键入一个数值，用于旁侧和顶部像元维数的乘法器。 

一个大于 1.0 的系数将用于复制波谱剖面放大旁侧和顶部的维数。这对于包含小数量波谱波段
的图像立方体特别有用。 

7 键入一个边缘值，以调整输出图像周围的背景像元数。 

8 选用 “File” 或 “Memory” 输出。 

·如果选用 “File” 输出，在标有“Enter Output File Name”的文本框里键入要输出的文件名；
或用“Choose”按钮选择一个输出文件名。 

·要停止，点击 “Cancel”。 

9 点击“OK”开始运行。 

函数将建立临时性文件，在处理过程中它们将显示在 Available Bands List 中。当处理结束，这
些文件将被删除，随而代之的是处理后的 3-D 图像立方体。 
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第六章：Transforms (变换) 
变换是将数据变为另外一种数据格式的图像处理方法，通常应用一个线性函数来实现。大多数

变换的目的是提高信息的表达。变换后的图像通常比原始图像更易于解译。ENVI 允许你从 ENVI 
主菜单里选择 Transform 下拉菜单，对图像进行变换。 

Band Ratios (波段比) 
波段比特别地用于增强波段之间的波谱差异，减少地形的影响。用一个波段除以另一个波段生

成了一幅能提供相对波段强度的图像。这一图像增强了波段之间的波谱差异。ENVI 能用浮点型数
据格式或字节型数据格式输出波段比，默认的是浮点型数据格式。你可以将三个比率合成为一幅彩

色比率合成图像(CRC)，判定每个像元波谱的大致形状。 

要计算波段比，你必须输入一个“分子”波段和一个“分母”波段，波段比是分子与分母的比

值。ENVI变换核查分母为0的错误，并将他们设置为 0 。ENVI 也允许你计算多项比率，并在一个
文件中将它们输出为多个波段。 

1 选择 Transforms > Band Ratios。 

2 出现 Band Ratio Entry 对话框时，从 Available Bands List 中选择你的分子和分母波段。你点
击的第一个波段将作为“分子”波段，点击的第二个作为“分母”波段。 

·要改变你已经选择的波段，点击 “Clear”，ENVI 将把分子和分母波段都删除掉。 

3 一旦你已经选择了两个输入波段，点击 “Enter Pair” 建立一个新的波段对，列表显示在 
“Selected Ratio Pairs” 中。 

一旦你已经选择了第一对，在 Available Bands List 中将只显示空间上大小相同的波段。 

你可以通过键入另外的波段对，建立需要的那么多的波段比进行合成。在 “Selected Ratio Pairs” 
下方所有的比率列表将被输出到一个文件中。 

4 点击“OK”继续，显示 Band Ratios Parameters 对话框。 

5 一旦出现 Band Ratios Parameters 对话框，选择下列合适的选项。 

·选择一个空间子集，点击 “Spatial Subset”，并用标准 ENVI 空间子集构建程序。 

·将比率值以字节形式输出，用 “Output Data Type” 按钮菜单选择 “Byte”。 

ENVI 将按照在 “Min” 和 “Max”文本框里键入的数值（0~255），进行拉伸输出比率值。 

·要改变字节拉伸比率数据范围，键入新的 “Min” 和 “Max” 值。 

6 选用 “File” 或 “Memory” 输出。在标有“Enter Output Filename”的文本框里键入要输出的
文件名；或用“Choose”按钮选择一个输出文件名。 

7 点击“OK”开始计算比值。计算每一个比值时，屏幕上将出现一个状态窗口。 

当比率计算已经结束，ENVI 将把比率波段名显示到 Available Bands List 中。你可以用标准
ENVI 灰阶或 RGB 彩色合成方法显示它们。 

Creating Complex Band Ratios (建立复合波段比率) 
在一些情况下，你也许想将波段比率本身用作第二轮波段比率计算。 
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1 如上所述，计算单一的波段比率。 

2 再选择 Transforms > Band Ratios。 

在新的波段比率中，你可以用到以前计算的比率值。例如，如果你用 Landsat TM 数据，你可
以首先计算波段 5 与波段 7 的比值以及波段 3 和波段 1 的比值。ENVI 允许你在 Available 
Bands List 中选择波段 5 与波段 7 的比值作为分子波段，选择波段 3 和波段 1 的比值作为分母
波段，计算它们的比值作为波段 5 和 7 与波段 3 和 1 的复合比值。 

3 选择一个新的分子和分母，点击 “Enter Pair” 和 “OK” 计算新的复合比率值。 

新的结果被导入 Available Bands List 中。你也可以用波段计算函数计算这些比率。 
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Principal Component Analysis (主成分分析) 
主成分分析（PCA）用多波段数据的一个线性变换，变换数据到一个新的坐标系统，以使数据
的差异达到最大。这一技术对于增强信息含量、隔离噪声、减少数据维数非常有用。ENVI 能完成
正向的和逆向的 PC 旋转。详见以下参考书。 

Richards, J.A., 1994. Remote Sensing Digital Image Analysis: An Introduction, Springer-Verlag, 
Berlin, Germany, p. 340. 

Forward PC Rotation (正向的 PC 旋转) 

正向的 PC 旋转用一个线性变换使数据差异达到最大。当你运用正向的 PC 旋转时，ENVI 允
许你计算新的统计值，或将已经存在的统计项进行旋转。输出值可以存为字节型、浮点型、整型、

长整型或双精度型。你也可以基于特征值抽取PC旋转输出的部分内容，生成只有你需要的PC波段的
输出。 

一旦旋转完成，将会出现PC特征值图。显示出每一个输出的 PC 波段的差异量。PC 波段将显
示在 Available Bands List 中。 

Compute New Statistics and Rotate (计算新的统计值和旋转) 
这一选项用于计算数据特征值、协方差或相关系数以及 PC 正向的旋转。 

1 选择 Transforms > Principal Components > Forward PC Rotation > Compute New Statistics and 
Rotate. 

2 出现 Principal Components Input File 对话框时，选择输入文件或用标准 ENVI 选择程序建立
子集。 

3 出现 Forward PC Rotation Parameters 对话框时，在 “Stats X/Y Resize Factor” 文本框键入小
于 1 的调整系数，对计算统计值的数据进行二次抽样。 

键入一个小于 1 的调整系数，以提高统计计算的速度。例如，在统计计算时，用一个 0.1 的
调整系数将只用到十分之一的像元。 

4 若需要，键入一个输出统计文件名。 

5 点击按钮，选择是否计算 “Covariance Matrix”。 

计算主成分时，有代表性地要用到协方差矩阵。当波段之间数据范围差异较大时，要用到相关

系数矩阵，并且需要标准化。 

6 选用 “File” 或 “Memory” 输出。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

7 从 “Output Data Type” 菜单里，选择需要的输出类型（字节型，整型，无符号整型，长整型，
无符号长整型，浮点型，双精度型）。 

8 用下列选项，选择输出 PC 波段数。 

·限定输出 PC 波段数，键入需要的数字，或用 “Number of Output PC Bands” 标签附近的按
钮确定输出的 PC 波段数。 

Administrator
主成分分析（PCA）用多波段数据的一个线性变换，变换数据到一个新的坐标系统，以使数据
的差异达到最大。这一技术对于增强信息含量、隔离噪声、减少数据维数非常有用。ENVI 能完成
正向的和逆向的PC 旋转



 227

默认的输出波段数等于输入的波段数。 

·通过检查特征值，选择输出的 PC 波段数。 

A 点击 “Select Subset from Eigenvalues” 标签附近的按钮，选择“YES”。 

特征值将被计算，出现 Select Output PC Bands 对话框，列表显示着每一个波段和其相应的特
征值。同时也为所有波段显示出每个波段中包含的数据变化的累积百分比。 

B 在 “Number of Output PC Bands” 文本框里，键入一个数字或点击按钮，确定输出的波段数。 

特征值大的 PC 波段包含最大量的数据差异。较小的特征值包含较少的数据信息和较多的噪
声。有时，为存储磁盘空间，最好仅仅输出特征值大的那些波段。 

C 在 Select Output PC Bands 对话框里，点击“OK”。 

输出的 PC 旋转将只包含你选择的波段数。例如，如果你选择“4”作为输出的波段数，则只
有前 4 个波段会出现在你的输出文件里。 

9 选择上面一个选项以后，在 Forward PC Rotation Parameters 对话框里，点击“OK”为选择
的输入文件计算协方差或相关系数和特征值，并进行正向的 PC 旋转。当 ENVI 已经处理完毕，将
出现 PC EigenValues 绘图窗口，PC 波段将被导入 Available Bands List 中，你可以从列表中选择
显示。想了解特征值绘图窗口中有关编辑以及其它选项的信息，参见 “Interactive Plot Functions” 部
分。 

PC Rotation from Existing Stats 
如果你已经计算出协方差和特征值，你可以将它们输入到 PC 旋转里。你可以用 PC 旋转（包
含与你输入的数据具有相同波段数的协方差和特征值）中的一些统计文件（也许你已经用 Basic 
Tools > Compute Statistics 选项，或以前的 PV 旋转中计算出了这些统计值）。 

1 选择 Transforms > Principal Components > Forward PC Rotation > PC Rotation from Existing 
Stats. 

2 当出现标准 ENVI 选择文件或子集对话框时，选择你的输入文件，并用标准ENVI文件选择
程序建立需要的子集。 

出现另一个文件选择对话框，在当前输入数据目录中，列表显示出了已经存在的统计文件（默

认扩展名为 .sta ）。 

3 用标准 ENVI 文件选择程序选择统计文件。 

4 选用 “File” 或 “Memory” 输出。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

5 从 “Output Data Type” 下拉菜单里，选择一个数据类型作为输出文件的数据类型。 

6 选择下列选项之一： 

·限定输出 PC 波段数，键入需要的数字，或用 “Number of Output PC Bands” 标签附近的按
钮确定输出的 PC 波段数。 

默认的输出波段数等于输入的波段数。 

·通过检查特征值，选择输出的 PC 波段数。 
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A 点击 “Select Subset from Eigenvalues” 标签附近的按钮，选择“YES”。 

特征值将被计算，出现 Select Output PC Bands 对话框，列表显示着每一个波段和其相应的特
征值。同时也为所有波段显示出每个波段中包含的数据变化的累积百分比。 

B 在 “Number of Output PC Bands” 文本框里，键入一个数字或点击按钮，确定输出的波段数。 

特征值大的 PC 波段包含最大量的数据差异。较小的特征值包含较少的数据信息和较多的噪
声。有时，为存储磁盘空间，最好仅仅输出特征值大的那些波段。 

C 在 Select Output PC Bands 对话框里，点击“OK”。 

输出的 PC 旋转将只包含你选择的波段数。例如，如果你选择“4”作为输出的波段数，则只
有前四个波段会出现在你的输出文件里。 

7 选择上面一个选项以后，在 Forward PC Rotation Parameters 对话框里，点击“OK”为选择
的输入文件计算协方差或相关系数和特征值，并进行正向的PC旋转。当 ENVI 已经处理完毕，将出
现PC EigenValues绘图窗口，PC波段将被导入Available Bands List中，你可以从列表中选择显示。想
了解特征值绘图窗口中有关编辑以及其它选项的信息，参见第 164 页的 “Interactive Plot Functions” 
部分。 

Inverse PC Rotation (反向 PC 旋转) 

将主成分图像变换回到它们的原始数据空间： 

1 选择 Transforms > Principal Components > Inverse PC Rotation. 

2 当出现标准 ENVI 选择文件或子集对话框时，选择你的输入文件，并用标准 ENVI 文件选
择程序建立需要的子集。 

出现另一个文件选择对话框，在当前输入数据目录中，列表显示出了已经存在的统计文件（默

认扩展名为 .sta ）。 

3 用标准 ENVI 文件选择程序选择前面在正向 PC 旋转中存储的统计文件。 

注意 

在选择反向 PC 旋转之前，统计文件必须已经存在。 

4 在 “Calculate using” 标签附近，选择 “Covariance Matrix” 或 “Correlation Matrix”。 

5 选用 “File” 或 “Memory” 输出。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名，或
用“Choose”按钮选择一个输出文件名。 

6 从 “Output Data Type” 下拉菜单里，选择一个数据类型，作为输出文件的数据类型。 

7 点击“OK”运行反向变换。 

当 ENVI 已经处理完毕，PC 波段将被导入 Available Bands List 中，你可以从列表中选择显示
（用标准灰阶或 RGB 彩色合成方法）。 
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Minimum Noise Fraction Rotation (最低噪声分离旋转) 
最低噪声分数变换（MNF）被用于判定图像数据内在的维数，隔离数据中的噪声，减少随后处
理计算的需求（见 Boardman and Kruse, 1994）。Green等（1988）年对 MNF 进行了修改，然后在 ENVI 
中得到应用。MNF 本质上是两次层叠的主成分变换。第一次变换（基于估计的噪声协方差矩阵）用
于分离和重新调节数据中的噪声。第一步产生的变换数据中噪声有单位变化，没有波段-波段间的相
关。第二步是一次噪声白化数据的标准主成分变换。为了进一步波谱处理，数据内在的维数由检查

最终特征值和相关图像来判定。数据空间可以被分为两部分：一部分与大的特征值和相对应的特征

图像相关，其余部分与相差不大的特征值以及噪声占主导地位的图像联系在一起。仅仅用相关部分，

就可以将噪声从数据中分离。于是提高波谱处理的效果（详见下面的参考书目）。 

MNF 变换也可以被用来从数据中消除噪声。主要通过运行正向的变换，判定哪些波段包含相关
图像，用波谱子集（只包括“好”波段，或反转前平滑噪声）进行一次反向的 MNF 变换。 

你也可以基于特征值抽取 MNF 旋转输出的子集。如果你正在用高波谱数据，这意味着当你仅
仅需要十几个波段时，你不必生成上百波段的立方体输出。 

一旦旋转结束，将显示一个 MNF 特征值的图示，表明每一个MNF输出波段的变化量，并且 
MNF 波段将显示在 Available Bands List 中。 

ENVI 也可以将 MNF 变换应用到单个波谱中。这一功能被用来将末端波谱变换为 MNF 空
间，以输入到 Mixture Tuned Matched Filtering (见第 692 页的 “Results of Matched Filtering ”)。 

Green, A. A., Berman, M., Switzer, P, and Craig, M. D., 1988, A transformation for ordering 
multispectral data in terms of image quality with implications for noise removal: IEEE Transactions on 
Geoscience and Remote Sensing, v. 26, no. 1, p. 65-74. 

Boardman, J. W., and Kruse, F. A., 1994, Automated spectral analysis: a geological example using 
AVIRIS data, north Grapevine Mountains, Nevada: in Proceedings, ERIM Tenth Thematic Conference on 
Geologic Remote Sensing, Environmental Research Institute of Michigan, Ann Arbor, MI, p. I-407 - I-418. 

Forward MNF Transform (正向的 MNF 变换) 

正向的 MNF 变换有三个选项，用于估计第一次旋转中用到的噪声统计。三个选项包括从输入
的数据中估计噪声，运用以前计算的噪声统计，或用与数据集相关的“暗色图像”计算噪声统计。 

Estimate Noise Statistics from the Data (由数据估计噪声统计) 
当你没有当前的暗色图像时，用这种方法估计噪声（通常是这样）。ENVI 假定每一个像元都

包含信号和噪声，且紧邻的像元包含同样的信号，但是具有不同的噪声。对数据进行  “shift 
difference”，就把临近的像元区分开来，并把结果平均指定为每个正被处理的像元的“噪声”值。最
好的噪声估计是对一个类似的区域进行 shift-difference 统计聚集的，而不是对整个图像进行。ENVI
允许你选择统计抽取的子集。 

1 选择 Transforms > MNF Rotation > Forward MNF > Estimate Noise Statistics From Data。 

2 出现标准 ENVI 文件选择和子集构建对话框时，用标准 ENVI 文件选择程序选择和输入文
件以及子集。 

·选择一个类似区域进行噪声统计，点击 “Spatial Subset” 按钮，用 ENVI 的标准空间子集程
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序或者手工键入一个子集或用图表显示用于统计抽取的区域。 

3 当出现 Forward MNF Transform Parameters 对话框时，在标有 “Enter Output Noise Stats 
Filename [.sta]” 的文本框里键入一个用于噪声统计的文件名。 

4 在标有 “Enter Output Stats Filename [.sta]” 的文本框里，键入一个用于 MNF 统计的输出文
件名。 

警告 

MNF 与噪声统计的文件务必采用不同的名字。 

5 选用 “File” 或 “Memory” 输出。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

6 运用下列选项，选择输出 MNF 的波段数。 

·通过检查特征值，选择输出的 MNF 波段数： 

A 点击 “Select Subset from Eigenvalues” 标签附近的按钮，选择 “Yes”。 

B 点击“OK”计算噪声统计和第一次旋转。 

统计被计算，出现 Select Output MNF Bands 对话框，列表中显示的每一个波段都有其相应的特
征值。每一个 MNF 波段包含的数据方差的累积百分比也被显示出。 

C 点击 “Number of Output MNF Bands” 标签附近的箭头切换按钮，设置你需要输出的波段数，
或向文本框里键入数值。 

为了节省磁盘空间，最好只输出特征值高的波段——特征值接近于1的图像多数是噪声。 

D 在 Select Output MNF Bands 对话框里，点击“OK”完成旋转。 

·要在不选择特征值子集的情况下，限定输出的 MNF 波段数。键入需要的数字，或用 “Number 
of Output MNF Bands” 标签附近的按钮确定输出的波段数。 

7 点击“OK”开始处理。 

当 ENVI 已经完成处理时，MNF 波段将被导入 Available Bands List，显示 MNF 绘图窗口。
输出的仅包含你选择输出的波段数。例如，如果你输入的数据包含 224 个波段，但是你仅选择了 50 
个波段用于输出，则输出的将只包含你输入文件的前 50 个波段。 

特征值大（>1）的波段包含数据，特征值接近于 1 的波段包含噪声。显示 Available Bands List 
中的特征图像（MNF 波段），并与 MNF 特征值图示相比较，判定哪些波段包含数据，哪些波段
主要包含噪声。在随后的图像处理中，抽取 MNF 波段的子集只包括那些图像在空间上呈现一致的
波段，特征值超过了 MNF 图斜坡的转折处（break in slope of the MNF plot）。在图6-4显示的例子
中，你应该只包括前十个到十二个 MNF 波段。 

Previous Noise Statistics (以前的噪声统计) 
这一选项用到了前面 MNF 变换时计算出的噪声统计。这允许你运用来自一幅图像和第二幅图
像的噪声统计。 

1 选择 Transforms > MNF Rotation > Forward MNF > Previous Noise Statistics。 

2 出现标准 ENVI 文件选择和子集构建对话框时，用标准ENVI文件选择程序选择和输入文件
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以及子集。 

出现另一个文件选择对话框，在当前输入数据目录里，显示所有存在的统计文件（默认扩展名

为 .sta）。 

3 从以前MNF变换处理部分，选择一个噪声统计文件。 

4 出现 Forward MNF Transform Parameters 对话框时，在标有“Enter Output MNF Stats Filename 
[.sta]”的文本框里，键入用于MNF统计的一个输出文件名。 

5 选用 “File” 或 “Memory” 输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

6 运用下列选项，选择输出MNF的波段数。 

·通过检查特征值，选择输出的MNF波段数： 

A 点击 “Select Subset from Eigenvalues” 标签附近的按钮，选择 “Yes”。 

B 点击“OK”计算噪声统计和第一次旋转。 

统计被计算，出现 Select Output MNF Bands 对话框，列表中显示的每一个波段都有其相应的特
征值。每一个波段相对于所有波段数据变化的累积百分比也被显示了出来。 

C 点击 “Number of Output MNF Bands” 标签附近的箭头切换按钮，设置你需要输出的波段数，
或向文本框里键入数值。 

为了节省磁盘空间，最好只输出特征值高的波段——特征值接近于1的图像多数是噪声。 

D 在 Select Output MNF Bands 对话框里，点击“OK”完成旋转。 

·要在不选择特征值子集的情况下，限定输出的 MNF 波段数。键入需要的数字，或用 “Number 
of Output MNF Bands” 标签附近的按钮确定输出的波段数。 

E 点击“OK”开始处理。 

当 ENVI 已经完成处理时，MNF 波段将被导入 Available Bands List，显示MNF绘图窗口。输
出的仅包含你选择输出的波段数。例如，如果你输入的数据包含224个波段，但是你仅选择了50个波
段用于输出，则输出的将只包含你输入文件的前50个波段。 

特征值大（>1）的波段包含数据，特征值接近于1的波段包含噪声。显示 Available Bands List 中
的特征图像（MNF波段），并与 MNF 特征值图示相比较，判定哪些波段包含数据，哪些波段主要
包含噪声。在随后的图像处理中，抽取 MNF 波段的子集只包括那些图像在空间上呈现一致的波段，
特征值超过了 MNF 图斜坡的转折处（break in slope of the MNF plot）。在图6-4显示的例子中，你
应该只包括前十个到十二个 MNF 波段。 

Noise Statistics from Dark Image (来自暗色图像的噪声统计) 

一些工具收集一幅“暗色图像”作为数据校准或收集的部分。暗色图像相当于一张镜头上的照

片。在电子仪器里，有一种信号实际上是仪器的噪声。暗色图像能被用来反映仪器噪声的特征。 

1 选择Transforms > MNF Rotation > Forward MNF > Noise Statistics from Dark Image。 

2 出现标准ENVI文件选择和子集构建对话框时，用标准ENVI文件选择程序选择和输入文件以
及子集。 
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3 出现 Dark Current Input File 对话框时，选择当前的暗色文件，运行需要的空间子集。 

噪声统计将用当前输入的暗色文件计算。 

4 当出现 Forward MNF Transform Parameters 对话框时，在标有 “Enter Output Noise Stats 
Filename [.sta]” 的文本框里键入一个用于噪声统计的输出文件名。 

5 在标有 “Enter Output Stats Filename [.sta]” 的文本框里，键入一个用于 MNF 统计的输出文
件名。 

警告 

MNF与噪声统计的文件务必采用不同的名字。 

6选用 “File” 或 “Memory” 输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 运用下列选项，选择输出MNF的波段数。 

·通过检查特征值，选择输出的MNF波段数： 

A 点击 “Select Subset from Eigenvalues” 标签附近的按钮，选择“Yes.” 

B 点击“OK”计算噪声统计和第一次旋转。 

统计被计算，出现 Select Output MNF Bands 对话框，列表中显示的每一个波段都有其相应的特
征值。每一个波段相对于所有波段数据变化的累积百分比也被显示了出来（the cumulative percentage 
of data variance contained in eachMNF band for all bands）。 

C 点击 “Number of Output MNF Bands” 标签附近的箭头切换按钮，设置你需要输出的波段数，
或向文本框里键入数值。 

为了节省磁盘空间，最好只输出特征值高的波段——特征值接近于 1 的图像多数是噪声。 

D 在 Select Output MNF Bands 对话框里，点击“OK”完成旋转。 

·要在不选择特征值子集的情况下，限定输出的 MNF 波段数。键入需要的数字，或用 “Number 
of Output MNF Bands” 标签附近的按钮确定输出的波段数。 

E 点击“OK”开始处理。 

当ENVI已经完成处理时，MNF 波段将被导入 Available Bands List，显示MNF绘图窗口。输出
的仅包含你选择输出的波段数。例如，如果你输入的数据包含224个波段，但是你仅选择了50个波段
用于输出，则输出的将只包含你输入文件的前 50 个波段。 

特征值大（>1）的波段包含数据，特征值接近于 1 的波段包含噪声。显示 Available Bands List 
中的特征图像（MNF波段），并与 MNF 特征值图示相比较，判定哪些波段包含数据，哪些波段主
要包含噪声。在随后的图像处理中，抽取 MNF 波段的子集只包括那些图像在空间上呈现一致的波
段，特征值超过了 MNF 图斜坡的转折处（break in slope of the MNF plot）。在图6-4显示的例子中，
你应该只包括前十个到十二个MNF波段。 

Inverse MNF Transform (反向的MNF变换) 

用这一选项将MNF波段变换为它们的原始数据空间。 
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代表性地，以噪声为主导的图像（高波段数）在运行反向变换之前先被平滑，或在反向期间用

波谱子集排除掉。平滑或消除这些噪声波段将减少原始数据空间中的噪声。 

1 选择 Transforms > MNF Rotation> Inverse MNF Transform。 

2 出现标准 ENVI 文件和子集选择对话框时，用标准 ENVI 文件选择程序选择并抽取正向 
MNF 变换图像计算的子集。 

代表性地，根据正向 MNF 变换部分描述的程序，波谱子集被用来消除来自反向变换的以噪声
为主的图像。 

3 出现 Enter Forward MNF Stats Filename 对话框时，键入正向的MNF统计文件的名字，点击
“OK”。 

4 出现 Inverse MNF Transform Parameters 对话框时，选择 “File” 或 “Memory” 输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

5 从“Output Data Type”菜单，选择需要的数据类型（字节，整型，无符号整型，长整型，无符
号长整型，浮点型，双精度型）。 

6 点击“OK”开始处理。 

处理完成时，ENVI 将把 MNF 结果导入 Available Bands List 中。 

Apply Forward MNF to Spectra (把正向的MNF应用到波谱) 

用这一选项将末端波谱变换为 MNF 空间用于 Mixture Tuned Matched Filtering 。来自 Mixture 
Tuned Matched Filtering 输入数据文件的 MNF 统计被用作变换。被变换的波谱能用一个类似于末端
聚集的对话框，从绘图窗口、波谱库、ASCII 文件、感兴趣区和统计文件中聚集。 

1 选择 Transforms > MNF Rotation> Apply Forward MNF to Spectra。 

2 当出现 Forward MNF Statistics Filename 对话框时，选择 Mixture Tuned Matched Filtering 输
入数据文件计算的MNF统计文件名。 

3 出现 Forward MNF Convert Spectra 对话框时，用 Import 菜单选项将波谱输入到对话框，或
将波谱拖曳到对话框顶部的黑色的绘制小部件中。 

4 从对话框中删除波谱，点击波谱选中，点击 “Delete Spectrum”。 

5 点击 “Apply”。 

变换后的波谱将出现在 Forward MNF Spectra 绘图窗口里，且能输入到 Mixture Tuned Matched 
Filtering Endmember Collection 对话框。 

·将变换后的波谱存到一个波谱库或一个 ASCII 文件中，在 MNF 图示出口中，选择 File > 
Output Data。 

Apply Inverse MNF to Spectra (将反向的MNF应用到波谱) 

用这一选项将 MNF 波谱变换到原始数据空间。来自一个数据文件的正向的 MNF 统计被用作
变换。将被变换的波谱能用用一个类似于末端聚集的对话框，从绘图窗口、波谱库、ASCII 文件、
ROIs和统计文件中聚集。 
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1 选择 Transforms > MNF Rotation > Apply Inverse MNF to Spectra。 

2 当出现 Forward MNF Statistics Filename 对话框时，选择需要的正向的 MNF 统计文件名。 

3 出现 Inverse MNF Convert Spectra 对话框时，用 Import 菜单选项将波谱输入到对话框，或
将波谱拖曳到对话框顶部的黑色的绘制小部件中。 

4 点击 “Apply”。 

变换后的波谱将出现在 Inverse MNF Spectra 绘图窗口里。 

·将变换后的波谱存到一个波谱库或一个 ASCII 文件中，在 MNF 图表输出中，选择File > 
Output Data. 



 235

Color Transfroms (颜色变换) 
颜色变换将3-波段红、绿、蓝图像变换成一个特定颜色的空间，并且从能从选择的色彩空间转
回到 RGB。两次变换之间，通过用对比度拉伸，你可以生成一个色彩增强的彩色合成图像。此外，
亮度波段值可以被另一个波段代替（通常比较高的空间分辨率），生成一幅合成图像（将一幅图像

的色彩特征与另一幅图像的空间特征相结合）。这可以由 IHS 尖锐化自动完成。 

由 ENVI 支持的彩色空间包括“色调，饱和度，数值（HSV）”变换，“（色调，亮度，饱和
度（HLS）”变换和“USGS Munsell”变换（作为一个用户函数）。 

Munsell 颜色系统被土壤科学家和地质学家用于描述土壤和岩石的颜色特征。这套颜色系统已
经被美国地址勘察部门作了修订，以描绘数字图像的颜色。变换将 RGB 坐标变成了色彩坐标色调、
饱和度和数值。色调变化范围 0~360，这里 0 与 360 代表蓝，120 代表绿，240 代表红。饱和度
变化范围是 0~208，值越高代表颜色越纯。值的变化范围大致是 0~512，较高的数代表较亮的颜色。
欲知详细信息，请参阅： 

Kruse and Raines, A technique for enhancing digital color images by contrast stretching in Munsell 
color space, in Proceedings of the ERIM Third Thematic Conference, Environmental Research Institute of 
Michigan, Ann Arbor, MI, 1994: 755-760. 

Munsell 彩色变换被编入到了 ENVI 用户函数中，代码作为一个例子被包括了进去（见 ENVI 
库目录里的 munsell.pro）。 

注意 

色彩变换需要输入三个波段。这些波段应该被拉伸为字节数据，或能从一个开放的色彩显示中

选择。 

Forward - to Color Space (向前到彩色空间) 

RGB to HSV 
这一变换类型允许你将一幅 RGB 图像变换为 HSV 彩色空间。生成的 RGB 值是字节数据，

其范围为 0 到 255。运行这一功能必须先打开一个至少包含3个波段的输入文件，或一个彩色显示
能用于输入。在彩色显示中用到的拉伸将被用到输入数据。这一功能产生范围为 0~360 度的色调（红
是 0 度，绿是 120 度，蓝是 240 度）、饱和度和值的范围是 0~1（浮点型）。 

1 选择 Transforms > Color Transforms > Forward to Color Space > RGB to HSV。 

2 出现 RGB to HSV Input 对话框时，从一个显示的彩色图像或 Available Bands List 中选择三
个波段进行变换。 

·从一幅彩色显示中选择你的波段，运用已经显示的拉伸数据。从 RGB 到 HSV 输入列表中
选择一个显示，如 “Display #1”。 

出现 RGB to HSV Parameters 对话框时，ENVI 自动地从已经选择的窗口里运用 RGB 波段，
并在标有 “Input RGB Bands” 的文本下方列表显示。 

·你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

·从 Available Bands List 中选择你的波段。 
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注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 从 RGB to HSV 输入对话框里，选择 “Available Bands List”。 

B 出现 RGB to HSV Input Bands 对话框时，从 Available Bands List 中，点击三个需要的波段
名，以用在正向的变换中。 

·你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

·重新设置选项，点击 “Reset”。 

C 点击“OK”，出现 RGB to HSV Parameters 对话框。 

3 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

4 点击“OK”开始处理。 

出现一个状态窗口。当向前变换全部完成时，HSV 名字将被存入 Available Bands List 中，在
那里可以用标准 ENVI 灰阶或 RGB 彩色合成方法显示。 

RGB to HLS 
这一项允许你将 RGB 图像变换成 HLS（色调，亮度，饱和度）彩色空间。这一功能生成的色

调范围是 0~360 度（红为 0 度，绿为 20 度，蓝是 240 度），亮度和饱和度范围为 0~1（浮点型）。
运行这一功能必须先打开一个至少包含 3 个波段的输入文件，或一个能用于输入的彩色显示。生成
的 RGB 值是字节数据，其范围为 0 到 255 。 

1 选择 Transforms > Color Transforms > Forward to Color Space > RGB to HLS。 

2 出现 RGB to HLS Input 对话框时，从一个显示的彩色图像或 Available Bands List 中选择三
个波段进行变换。 

·从一幅彩色显示中选择你的波段，运用已经显示的拉伸数据。从 RGB 到 HLS 输入列表中
选择一个显示，如 “Display #1”。 

出现 RGB to HLS Parameters 对话框时，ENVI 自动地从已经选择的窗口里运用 RGB 波段，
并在标有 “Input RGB Bands” 的文本下方列表显示。 

·你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

·从 Available Bands List 中选择你的波段。 

注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 从 RGB to HLS Input 对话框里，选择 “Available Bands List”。 

B 出现 RGB to HLS Input Bands 对话框时，从 Available Bands List 中，点击三个需要的波段
名（若需要，可以运用一些空间子集），以用在正向的变换中。 

·你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

·重新设置选项，点击 “Reset”。 
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C 点击“OK”，出现 RGB to HLS Parameters 对话框。 

3 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

4 点击“OK”开始处理。 

出现一个状态窗口。当向前变换全部完成时，HLS 名字将被存入 Available Bands List 中，在
那里可以用标准 ENVI 灰阶或 RGB 彩色合成方法显示。 

USGS Munsell RGB to HSV 
1 选择 Transforms > Color Transforms > Forward -to Color Space > USGS Munsell RGB to HSV。 

ENVI 用户函数 “MUNSELL.PRO” 将自动被装载和运行。 

2 出现 USGS Munsell RGB to HSV Input File 对话框时，顺序点击三个波段装上，作为 RGB 。 

·可以用标准 ENV I程序，选择空间子集。 

·重新设置选项，点击 “Reset”。 

3 点击“OK”继续。 

4 出现 Munsell HSV Output 对话框时，选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名。 

5 点击“OK”开始处理。 

当变换全部完成时，波段将被存入 Available Bands List 中。 

Reverse - to RGB (反向到RGB) 

HSV to RGB 
这一项允许你将一幅 HSV 图像变换成 RGB 彩色空间。生成的 RGB 值是字节型数据，范围
为 0~255 。 

1 选择 Transforms > Color Transforms > Reverse to RGB > HSV to RGB。 

2 出现 HSV to RGB Input 对话框时，从整个 Available Bands List 中，点击合适的波段名，选
择参与变换的波段。 

波段名将出现在标有“H”，“S”，“V”（分别代表色调，饱和度和值）的文本框里。 

·若需要，用标准 ENVI 构建子集程序建立你的数据子集。 

3 点击“OK”继续。 

4 出现 HSV to RGB Parameters 对话框时，选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名。 

5 点击“OK”开始处理，出现一个状态窗口。 

当反向变换全部完成时，RGB 名字将被存入 Available Bands List 中，在那里可以用标准 ENVI 
灰阶或 RGB 彩色合成方法显示。 
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HLS to RGB 
这一项允许你将一幅 HLS（色调、亮度、饱和度）图像转变回 RGB 彩色空间。产生的 RGB 值

是字节型数据，范围是 0~255 。 

1 选择 Transforms > Color Transforms > Reverse to RGB > HLS to RGB。 

2 出现 HLS to RGB Input 对话框时，点击合适的波段名，选择参与变换的波段。 

波段名将出现在标有“H”，“L”，“S”（分别代表色调，亮度和饱和度）的文本框里。 

·若需要，用标准ENVI构建子集程序建立你的数据子集。 

3 点击“OK”继续。 

4 出现 HLS to RGB Parameters 对话框时，选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名，或点击 “Choose” 按钮，选择一个文件名 

5 点击“OK”开始处理，出现一个状态窗口。 

当反向变换全部完成时，RGB 名字将被存入 Available Bands List 中，在那里可以用标准 ENVI 
显示方法显示。 

USGS Munsell HSV to RGB 
这一项允许你将 USGS Munsell HSV 图像变换成 RGB 彩色空间。 

1 选择 Transforms > Color Transforms > Reverse –to RGB Space > USGS Munsell HSV to RGB. 

ENVI 用户函数 “MUNSELL.PRO”将自动被装载和运行。 

2 出现 USGS Munsell HSV to RGB Input 对话框时，顺序点击三个波段名，作为 HSV 。 

·若需要，用标准 ENVI 程序选择数据子集。 

·重新设置选项，点击 “Reset”。 

3 点击“OK”继续。 

4 出现 Munsell RGB Output 对话框时，选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名，或点击 “Choose” 按钮，选择一个文件名。 

5 点击“OK”开始处理。 

当变换全部完成时，波段将被显示在 Available Bands List 中。 
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Image Sharpening (图像锐化) 
图像锐化自动地将一幅低分辨率的彩色图像与一幅高分辨率的灰阶图像结合在一起，再抽样成

高分辨率像元大小。ENVI 有两种图像尖锐化技术，用一个 HIS 变换，以及用一个彩色标准化变换。
图像必须是地理坐标定位了的或有同样的维数。图像尖锐化需要输入三个波段。这些波段应该是拉

伸过的字节型数据，或从一个开放的彩色显示中选择。 

HIS Sharpening 

这一功能进行 RGB 到 HIS 的变换，用高分辨率的图像代替亮度波段，自动地用最近邻、双线
性的或立方体卷积技术再抽出色调和饱和度波段用到高分辨率像元大小中，变换成 RGB 彩色空间。
输出的 RGB 图像中将有输入的高分辨率数据的像元大小。 

1 选择 Transforms > Image Sharpening > HIS。 

2 从一个打开的彩色图像或 Available Bands List 中选择三个波段进行变换。 

·从一幅彩色显示中选择你的波段，运用已经显示的拉伸数据。从 Select Input RGB 列表中选
择一个显示号，如 “Display #1”。 

出现 IHS Sharpening Parameters 对话框时，ENVI 自动地从已经选择的窗口里运用 RGB 波段，
并在标有 “Input RGB Bands” 的文本下方列表显示。 

·从 Available Bands List 中选择你的波段。 

注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 从 Select Input RGB 对话框里，选择 “Available Bands List”。 

B 出现 Select Input RGB Input Bands 对话框时，从 Available Bands List 中，点击三个需要的
波段名，以用在正向的变换中。 

·若需要，你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

C 点击“OK”。 

3 出现 High Resolution Input File 对话框时，选择高分辨率输入图像，并用标准 ENVI 文件选
择方法建立空间子集。 

4 点击“OK”继续。 

5 出现 IHS Sharpening Parameters 对话框时，从 “Resampling” 下拉菜单选择重抽样方法。 

6 选择输出到 “File” 或 “Memory”，如果文件输出，提供一个文件名  

·若选择输出到 “File”，键入要输出的文件名。 

7 点击“OK”开始处理。 

输出波段将出现在 Available Bands List 中，可以用标准 ENVI 显示方法显示。 
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Color Normalized (Brovey) Sharpening (彩色标准化锐化) 

彩色标准化尖锐化方法对彩色图像和高分辨率数据进行数学合成，以使图像尖锐化。过程中，

彩色图像的每一个波段乘以高分辨率数据与彩色波段总和的比值。函数自动地用最近邻、双线性的

或立方体卷积技术，再抽出三个彩色波段用到高分辨率像元大小中。输出的 RGB 图像将包含输入
的高分辨率数据像元的大小。详见下面的参考书。 

Vrabel, Jim, 1996. Multispectral Imagery Band Sharpening Study, Photogrammetric Engineering & 
Remote Sensing, Vol. 62, No. 9, pp. 1075-1083. 

1. 选择 Transforms > Image Sharpening > Color Normalized (Brovey)。 

2 从一个打开的彩色图像或 Available Bands List 中选择三个波段进行变换。 

·从一幅彩色显示中选择你的波段，运用已经显示的拉伸数据。从 Select Input RGB 列表中选
择一个显示号，如 “Display #1”。 

出现 IHS Sharpening Parameters 对话框时，ENVI 自动地从已经选择的窗口里运用 RGB 波段，
并在标有 “Input RGB Bands” 的文本下方列表显示。 

·从 Available Bands List 中选择你的波段 

注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 从 Select Input RGB 对话框里，选择 “Available Bands List”。 

B 出现 Select Input RGB Input Bands 对话框时，从 Available Bands List 中，点击三个需要的
波段名，以用在正向的变换中。 

·若需要，你可以用标准 ENVI 构建子集程序，选择一个空间子集。 

C 点击“OK”。 

3 出现 High Resolution Input File 对话框时，选择高分辨率输入图像，并用标准 ENVI 文件选
择技术建立空间子集。 

4 点击“OK”继续。 

5 出现 Color Normalized Sharpening Parameters 对话框时，从 “Resampling” 下拉菜单选择重抽
样方法。 

6 选择输出到 “File” 或 “Memory”，如果文件输出，提供一个文件名。 

·若选择输出到 “File”，键入要输出的文件名。 

7 点击“OK”开始处理。 

输出波段将出现在 Available Bands List 中，可以用标准 ENVI 显示方法显示。 
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Decorrelation Stretch (去相关拉伸) 
RGB 彩色合成时，波段被显示在一起，高度相关的多波谱数据集经常生成十分柔和的彩色图像。
去相关提供了一种消除这些数据中高度相关部分的一种手段。注意到，当 ENVI 提供一种具体的去
相关程序时，类似的结果还可以用一个正向 PCA、反差拉伸和反向 PCA 变换序列得到。去相关拉
伸需要输入三个波段。这些波段应该为拉伸的字节型，或从一个打开的彩色显示中选择。 

1 选择 Transforms > Decorrelation Stretch 

2 出现 Decorrelation Stretch Input 对话框时，从一个打开的彩色图像或 Available Bands List 中
选择三个波段进行变换。 

·选择来自彩色显示的波段，用已经显示的拉伸，点击需要打开的显示号，用标准ENVI程序建
立空间子集。 

ENVI 自动地用 Decorrelation Stretch Parameters 对话框中显示的 RGB 波段。 

·从 Available Bands List 中选择你的三个波段。 

注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 从 Select Input RGB 对话框里，选择 “Available Bands List”。 

B 出现 Decorrelation Stretch Input Bands 对话框时，顺序点击三个需要的波段名，用标准 ENVI 
程序运行空间子集。 

C 点击“OK”，显示 Decorrelation Stretch Parameters 对话框，它显示出了你已经选择的用于
去相关的波段。 

3 选择输出到 “File” 或 “Memory”，如果文件输出，提供一个文件名。 

·若选择输出到 “File”，键入要输出的文件名。 

4 点击“OK”开始去相关处理。 

在屏幕上将出现一条状态信息，表明正处于计算中的每一个波段。完成以后，ENVI 将去相关
拉伸名输入到 Available Bands List 中，在那里图像可以用标准 ENVI 灰阶或 RGB 彩色合成方法
显示。 
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Saturation Stretch (饱和度拉伸) 
饱和度拉伸变换对输入的一个三波段图像进行彩色增强。输入的数据由红、绿、蓝变换成色调、

饱和度和颜色值。对饱和度波段进行了高斯拉伸，因此数据填满了整个饱和度范围。然后，HSV 数
据自动被变换回 RGB 空间。这一功能生成的输出波段包含有较饱和的色彩。 

饱和度拉伸需要输入三个波段。这些波段应被拉伸成字节型数据，或能从打开的彩色显示中选

择。 

1 选择 Transforms > Saturation Stretch。 

2 出现 Saturation Stretch Input 对话框时，从一个打开的彩色图像或 Available Bands List 中选
择三个波段进行变换 

·从一幅彩色显示中选择你的波段，运用已经显示的拉伸数据。点击需要的显示号，用标准 ENVI 
程序构建空间子集。 

ENVI 自动地用显示在 Saturation Stretch Parameters 对话框中的 RGB 波段。 

·从 Available Bands List 中选择你的三个波段。 

注意 

用这一项时，不用拉伸，所有数据都是字节型的。 

A 点击 “Available Bands List”。 

B 出现 Saturation Stretch Input Bands 对话框时，依次点击三个需要的波段名，用标准ENVI程
序构建空间子集。 

C 点击“OK”出现 Saturation Stretch Parameters 对话框，显示出你已经选择的用于去相关的波
段 

3 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名。 

4 点击“OK”开始拉伸处理。 

当每个波段正参与计算时，屏幕上将出现一条状态信息。完成以后，ENVI 将饱和拉伸名输入
到 Available Bands List 中，在那里图像可以用标准 ENVI 灰阶或 RGB 彩色合成方法显示。 
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Synthetic Color Image (合成彩色图像) 
用 Synthetic Color Image 变换选项，你可以将一幅灰阶图像变换成一幅彩色合成图像。ENVI 通

过对图像进行高通和低通滤波，将高频和低频信息分开，使灰阶图像变换成彩色图像。低频信息被

赋予色调，高频信息被赋予强度或颜色值，也用到了一个恒定的饱和度值。这些色调、饱和度和颜

色值（HSV）数据被变换为红、绿、蓝（RGB）空间，生成一幅彩色图像。 

这一变换经常被用于雷达数据在保留好的细节情况下，改善精确的大比例尺特征。它非常适于

中低地貌。在雷达图像里，由于来自小比例尺地形的高频特征的存在，要看清低频的变化（差异）

通常较困难。低频信息通常是由于来自岩石或植被的表面散射差异形成的。详见下面参考书。 

Daily, M., 1983 Hue-saturation-intensity split-spectrum processing of Seasat radar imagery, 
Photogrammetric Engineering and Remote Sensing, Vol. 49, No. 3, pp. 349- 355. 

1 选择 Transforms > Synthetic Color Image。 

2 出现文件选择对话框时，选择输入文件，需要的话，运行空间子集。 

3 出现 Synthetic Color Parameters 对话框时，在 “High Pass Kernel Size” 和 “Low Pass Kernel 
Size” 标签附近，用下拉按钮选择高通滤波和低通滤波的变换核（kernel）的大小。 

高通变换核的大小应是与高频坡度决定的散射相对应的像元的数量。 

低通变换核的大小应是与低频漫射相对应的像元的数量。 

4 键入一个饱和度值（0~1）。 

较高的饱和度值产生较饱和的或“纯”的颜色。 

5 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名，或选择输出文件名。 

6 点击“OK”开始变换。 

在 Synthetic Color Processing 对话框中显示着变换的过程。作为结果的合成彩色图像将从 
Available Bands List 中显示。 
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NDVI（归一化植被指数） 
NDVI(Normalized Difference Vegetation Index) 是一个普遍应用的植被指数，将多波谱数据变换
成唯一的图像波段显示植被分布。NDVI 值指示着像元中绿色植被的数量，较高的NDVI值预示着较
多的绿色植被。NDVI 变换可以用于 AVHRR、Landsat MSS、Landsat TM、SPOT 或 AVIRIS 数据，
也可以输入其他数据类型的波段来使用。 

更多的信息，请参阅下列参考书： 

Jensen, J. R., 1986. Introductory Digital Image Processing, Prentice-Hall, New Jersey, 379 p. 

1 选择 Transforms > NDVI (Vegetation Index)。 

2 出现 NDVI Calculation Input File 窗口时，选择输入文件。（若需要）用标准 ENVI 文件选
择程序输入文件或空间子集。 

3 点击“OK”。 

4 通过点击 “Input File Type” 下拉菜单，用 NDVI Calculation Parameters 对话框，说明你已经
输入的文件类型（TM, MSS, AVHRR 等）。 

用于计算 NDVI的波段将自动输入到 “Red” 和 “Near IR” 文本框。 

·要计算下拉菜单中没有列出的传感器类型的 NDVI，在 “Red” 和 “Near IR” 文本框里输入需
要的波段数。 

5 用 “Output Data Type” 下拉菜单选择输出类型（字节型或浮点型）。 

6 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

7 点击“OK”开始计算 NDVI 变换。 

变换正在进行时，屏幕上出现一条状态信息。完成时，ENVI 将 NDVI 波段名输入到 Available 
Bands List 中，在那里可以用标准 ENVI 方法显示。 
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Tasseled Cap (缨帽变换) 
缨帽变换是一种通用的植被指数，可以被用于 Landsat MMS 或 Landsat TM 数据。对于 

Landsat MMS 数据，缨帽变换将原始数据进行正交变换，变成四维空间（包括土壤亮度指数 SBI、
绿色植被指数 GVI、黄色成分（stuff）指数 YVI，以及与大气影响密切相关的 non-such 指数 NSI）。
对于 Landsat TM 数据，穗帽植被指数由三个因子组成——“亮度”、“绿度”与“第三”（Third）。
其中的亮度和绿度相当于 MSS 缨帽的 SBI 和 GVI，第三种分量与土壤特征有关，包括水分状况。 

详见下面的参考书： 

Jensen, J. R., 1986. Introductory Digital Image Processing, Prentice-Hall, New Jersey, 379 p. 

1 选择 Transforms > Tassled Cap。 

2 出现 Tasseled Cap Transformation Input File 对话框时，选择输入文件。（若需要）用标准 
ENVI 文件选择程序输入文件或空间子集。 

3 点击“OK”继续，显示 Tasseled Cap Transform Parameters 对话框。 

4 用下拉菜单，选择 “Input File Type”（ Landsat TM 或 Landsat MSS）。 

5 选择输出到 “File” 或 “Memory”  

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名 

6 点击“OK”开始计算穗帽变换，变换进行时，屏幕上出现一条状态信息。 

完成时，ENVI 将穗帽波段名输入到 Available Bands List 中，在那里可以用标准 ENVI 灰阶
或 RGB 彩色合成方法显示。 
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第七章：Filetering (滤波) 
ENVI 支持一种滤波类型：Convolution、Morphological、Texture、Adaptive 和 FFT 滤波，它

们都可以经过 ENVI 主菜单的 Filters 菜单得到。 

Convolution Filtering (卷积滤波) 
卷积是一种滤波方法，它产生一幅输出图像（图像上，一个给定像元的亮度值是其周围像元亮

度值加权平均的函数）。用户选择变换核用于图像列卷积生成一个新的空间滤波图像。下面将介绍

进行卷积需要的一般配置以及每一种滤波类型的详细情况。 

使用卷积滤波 

用于滤波的文件选择对话框，不象其它 ENVI 文件选择对话框，它包括一个 “File/Band” 箭头
切换按钮，这一按钮可以让你选择输入一个文件或输入一个独立的波段。 

·选择一个用于卷积滤波处理的文件： 

1 选择 Filter > Convolutions > 一种滤波类型。 

2 出现 Convolution Input File 对话框时，选择一个输入文件名，若需要可以输入一个空间子集。 

·处理单个波段： 

1 选择 Filter > Convolutions > 一种滤波类型。 

2 点击 “Select By” 附近的箭头按钮，选择 “Band”。 

这时，在窗口的左边一栏 “Select Input Band” 文本框里出现所有可利用波段的列表。 

3 通过点击波段名选择需要的波段。 

一旦选择了，你还可以选择一个空间子集。 

设置卷积参数 

卷积滤波需要选择一个变换核的大小。多数滤波变换核呈正方形，默认的变换核大小是 3×3 。
原始图像卷积结果中 “Adding back” 部分有助于保持空间联系，代表性地被处理成尖锐化的图像。 

在文件选择对话框里，选择好数据以后： 

1 点击“OK”。 

2 出现 Convolution Parameters 对话框时，在 “Size” 文本框里键入一个变换核的大小。 

注意 

一些特别的滤波（如 Sobel 和 Roberts）有自己的默认值，是不能改变的。选择这些滤波时，
不会出现变换核大小的选项。 

3 对原始图像的 “Add Back” 部分，在 “Add Back” 文本框里，键入一个 0.0 与 1.0 之间的数
（与原始图像的 0 到 100% 相对应）。 

·编辑选择的变换核，改变权重值，在对话框低部附近点击 “Edit Kernel”。 

出现 Kernel Edit 对话框。在每个可编辑的文本框里，显示出变换核的值。选择下列选项。 
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·改变数值，点击要改变的数值，键入新值。 

·重新设置为原始值，点击 “Reset”。 

·要存储编辑过的变换核，点击 “Save Kernel”，在合适文本框里键入输出文件名。 

·要在 Convolution Parameters 对话框里记起以前存储的变换核，点击 “Restore Kernel”，从文
件选择对话框里，选择需要的文件名。 

4 点击“OK”。 

5 在第二个 Convolution Parameters 对话框里，选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

6 点击“OK”，开始卷积滤波。 

出现一条状态信息，显示操作的进行过程。对于图像tiling需要的一些滤波操作，状态窗口显示
不是渐渐地进展的，而是稍微等上一会儿，突然从 0 跳到 100%（因为它是整个图像一次性操作的）。
完成以后，滤波后的图像被添加到 Available Bands List 的顶部，且能用标准 ENVI 程序显示。 

High Pass Filter (高通滤波器) 

高通滤波在保持高频信息的同时，消除了图像中的低频成分。它可以用来增强不同区域之间的

边缘，犹如使图像尖锐化。通过运用一个具有高中心值的变换核来完成（典型地周围是负值权重）。

ENVI 默认的高通滤波用到的变换核是 3×3 的（中心值为“8”，外部像元值为“-1”）。高通滤
波变换核的大小必须是奇数。 

·实现这一功能，选择 Filters > Convolutions > High Pass。 

Low Pass Filter (低通滤波器) 

低频滤波保存了图像中的低频成分。ENVI 的低通滤波是通过对选择的图像运用  IDL
“SMOOTH”函数进行的。这一函数用到了 boxcar 平均，盒子的大小由变换核的大小决定，默认
的变换核的大小是3x3。 

·实现这一功能，选择 Filters > Convolutions > Low Pass. 

Laplacian Filter (拉普拉斯滤波器) 

拉普拉斯滤波是第二个派生的边缘增强滤波，它的运行不用考虑边缘的方向。拉普拉斯滤波强

调图像中的最大值，它用到的变换核的南北向与东西向权重均为负值，中心为“0”。ENVI 中默认
的拉普拉斯滤波用的是一个大小为3x3的，中心值为“4”，南北向和东西向均为“-1”的变换核。
所有的拉普拉斯滤波变换核的大小都必须是奇数。 

Directional (直通滤波) 

直通滤波是第一个派生的边缘增强滤波，它选择性地增强有特定方向成分的图像特征。直通滤

波变换核元素的总和是零。结果在输出的图像中有相同像元值的区域均为0，不同像元值的区域呈现
为亮的边缘。 
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实现直通滤波： 

1 选择 Filters > Convolutions > Directional. 

2 除了 Convolution Parameters 对话框中的标准的滤波调整项目以外，ENVI 直通滤波需要你在
标有 “Angle” 的文本框里键入需要的方向（单位是度）。 

正北方是 0 度，其他角度按逆时针方矢量度。 

Gaussian Filter (高斯滤波器) 

高斯滤波通过一个指定大小的高斯卷积函数对图像进行滤波。默认的变换核大小是3×3，且变
换核的大小必须是奇数。 

1 选择 Filters > Convolution > Gaussian。 

2 除了 Convolution Parameters 对话框中的标准滤波调整项目以外，选择 “High Pass” 或 “Low 
Pass” 滤波。 

Median Filter (中值滤波器) 

中值滤波在保留比变换核大的边缘的同时，平滑图像。ENVI 的中值滤波用一个滤波器大小限
定的邻近区的中值（不要与平均值混淆）代替每一个中心像元值。默认的变换核大小是3x3。 

·实现这一功能，选择Filters > Convolutions > Median。 

Sobel 滤波器 

Sobel 滤波器是非线性边缘增强，它特别地用到了 Sobel 函数的近似值，是一个预先设置了3
×3的，非线性边缘增强的算子。滤波器的大小不能更改，也无法编辑变换核的大小。 

·实现这一功能，选择 Filters > Convolutions > Sobel。 

Roberts 滤波器 

罗伯特滤波器是一个类似于 Sobel 的边缘探测器滤波。是一种特殊的滤波，运用 Roberts 函数
预先设置的2×2的近似值。是一个简单的两维空间的差分方法，用于边缘尖锐化和隔离。滤波器的
大小不能被更改，也不能编辑变换核的大小。 

·实现这一功能，选择 Filters > Convolutions > Roberts。 

User Defined Convolution Filters (用户自定义的卷积滤波) 

你可以通过选择和编辑一个用户变换核，定义习惯上用到的卷积变换核。 

1 选择 Filters > Convolutions > User Defined。 

除了 Convolution Parameters 对话框中的标准的滤波调整项目以外，Kernel Selection 对话框中
出现的标有 “Cols”、“Rows”、和 “Bands” 的文本框中有一个默认的 3×3×1 低通变换核，作为当
前变换核。 

用户定义的卷积变换核可以是 n×m×k 维的。 
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2 在合适文本框里，键入需要的数值，以改变变换核的维数。 

注意 

当前波段数只能设置为 1 。 

3 选择 “Edit Kernel” 按钮，交互式地编辑默认值，改变个别滤波器的权重。 
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Morphological Filtering 
数学形态学是一种基于形状的非线性处理数字图像的方法。它的主要目的是几何结构的量化。

这一论题的深入讨论超出了本手册的范围。参见以下参考书。 

Haralick, Sternberg, and Zhuang, Image Analysis Using Mathematical Morphology, IEEE 
Transactions on Pattern Analysis and Machine Intelligence, Vol. PAMI-9, No. 4, July 1987, p. 532-550. 

1 选择 Filters > Morphology。 

2 选择形态学滤波的一种类型：Dilate, Erode, Opening, 或 Closing。 

使用形态学滤波 

需要有几个事先定义的形态学变换核。这儿用到的形态学变换核仅仅是结构要素，不能与卷积

变换核相混淆。 

1 选择 Filters > Morphology > 一种滤波类型。 

2 出现Morphology Input File对话框时，选择要处理的数据。 

文件选择程序与卷积滤波中的一样。 

选择形态学参数 
在文件选择对话框里，选择好输入数据以后： 

1 点击“OK”。 

2 出现 Morphology Parameters 对话框时，在标有 “Cols” 和 “Rows” 的文本框里键入变换核的
大小。 

·编辑变换核： 

A 点击 “Edit Kernel”。 

B 出现 Kernel Edit 对话框时，每一个变换核的值显示在各自的可编辑的文本框里，选择下列
选项。 

·改变任何数值，点击要改变的值，键入新值。 

·重新设置原始值，点击 “Reset”。 

·保存编辑过的变换核，点击 “Save Kernel”，在合适文本框里键入输出文件名。 

·恢复到以前存储的变换核，点击 “Restore Kernel”，选择需要的变换核文件。 

3 点击“OK”。 

4 第二次出现 Morphology Parameters 对话框，在 “Cycles” 文本框里，键入需要的值，以确定
重复滤波的循环数。 

5 选择一种滤波器类型—— “Binary”（二值的）、“Gray”（灰阶）, 或 “Value”。 

选择 “Binary”，则输出的像元或呈黑色，或呈白色。“Gray” 表示保留了梯度。“Value”表示
允许已选像元的变换核值增加或减少。 
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6 选择 “File” 或 “Memory”输出。 

·如果选择输出到 “File”，键入一个输出文件名。 

7 点击“OK”，执行滤波。 

出现一条显示操作完成过程的状态信息。如果不需要图像tiling，状态窗口显示不是渐渐地进展
的，而是稍微等上一会儿，突然从 0 跳到 100%（因为它是整个图像一次性操作的）。完成以后，
滤波后的图像被添加到 Available Bands List 的顶部，且能用标准 ENVI 程序显示。 

Dilate (扩大) 

Dilate 功能，一般地称“填充”、“膨胀”或“生长”，是用来在二值或灰阶图像中填充比结
构元素（变换核）小的孔。 

Erode (侵蚀) 

Erode 功能，常称做“皱缩”或“减小”，是用来在二值或灰阶图像中消除比结构元素（变换
核）小的像元岛的。 

·实现这一功能，选择 Filters > Morphology > Erode。 

Opening (开放) 

一幅图像的开放被定义为图像侵蚀后，紧跟着是用同样的结构元素扩大。开放图像平滑轮廓，

打破窄窄的地峡，消除小岛，使峰和岬更趋尖锐。用侵蚀，随后再扩大，可以达到同样的效果。 

·实现这一功能，选择 Filters > Morphology > Opening。 

Closing (封闭) 

图像的封闭被定义为图像扩大后，紧跟着用同样的结构元素进行侵蚀。封闭图像平滑轮廓，融

合窄缝和长而细的海湾，消除小孔，并用轮廓填充间隙。用扩大，随后再侵蚀也可以达到同样的效

果。 

·实现这一功能，选择 Filters > Morphology > Closing。 
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Texture 滤波器 
许多图像包含的区域以亮度变化为特征，而不单单限于亮度值。纹理指图像色调作为等级函数

在空间上的改变。被定义为纹理清楚的区域，灰度等级相对于不同纹理的地区一定是比较接近的。

ENVI支持几种基于概率统计或二阶概率统计的纹理滤波。 

Occurrence Measures（概率统计） 

ENVI有五个不同的基于概率统计的纹理滤波。概率统计运用处理窗口中每一个灰阶出现的次数
作为纹理计算。概率统计滤波可以利用的是数据范围、平均值、变化、熵和偏移(skewness)。详情见
下面参考书。 

Anys, H., A. Bannari, D. C. He, and D. Morin, 1994. Texture analysis for the mapping of urban areas 
using airborne MEIS-II images, in Proceedings of the First International Airborne Remote Sensing 
Conference and Exhibition, Strasbourg, France, Vol. 3, pp. 231-245. 

1 选择 Filters > Texture > Occurrence Measures。 

2 出现 Texture Input File 对话框时，选择输入文件，若需要，可以用空间子集。 

文件选择程序与卷积滤波的一样。 

3 选好输入数据以后，点击“OK”。 

4 出现 Occurrence Texture Parameters 对话框时，在对话框的 “Textures to Compute” 部分需要
的选项附近点击文本框选择要创建的纹理图像。 

5 在 “Rows” (Y)和“Cols” (X)文本框里，键入处理窗口的大小，设定用于纹理评价的区域。 

6 选用 “File” 或 “Memory” 输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 点击“OK”，开始处理。 

完成以后，选择的纹理图像将计算出来，被放在 Available Bands List 中。 

Co-occurrence Measures（二阶概率统计） 

二阶概率统计用一个灰色调空间相关性矩阵（gray-tone spatial dependence matrix）计算纹理值。
这是一个相对频率矩阵，像元值出现在两个邻近的由特定的距离和方向分开的处理窗口中。显示了

一个像元和它的特定邻域之间关系的发生数（the number of occurrences of the relationship between a 
pixel and its specified neighbor）。例如，下面所示的co-occurrence 矩阵是在一个3x3的窗口中，由每
一个像元和它的水平方向的邻居生成的（shift value x=1,y=0）。一个3×3基窗口中的像元与被一个
像元变换（was shifted by 1 pixel）的3×3窗口的像元被用来生成co-occurrence 矩阵。 

ENVI 有八个基于co-occurrence 矩阵的纹理滤波。这些滤波包括平均值、变异、协同性、对比
度、相异性、熵、二阶矩和相关。详情见下面的参考书。 

Haralick, R. M., Shanmugan, K., and Dinstein, I., 1973, “Textural Features for Image Classification”: 
IEEE Transactions on Systems, Man, and Cybernetics, Vol. 3, No. 6, pp. 610-621. 
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ENVI支持几种基于概率统计或二阶概率统计的纹理滤波。
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Anys, H., A. Bannari, D. C. He, and D. Morin, 1994. Texture analysis for the mapping of urban areas 
using airborne MEIS-II images, in Proceedings of the First International Airborne Remote Sensing 
Conference and Exhibition, Strasbourg, France, Vol. 3, pp. 231-245. 

要访问实现基于二阶概率统计的纹理滤波： 

1 选择 Filters > Texture > Co-occurrence Measures。 

2 出现 Texture Input File 对话框时，选择输入文件，有必要时，选择子集。 

文件选择程序与卷积滤波用的一样。 

3 选择好输入数据以后，点击“OK”。 

4 出现 Co-occurrence Texture Parameters 对话框，在对话框的“Textures to Compute”部分需要的
选项附近点击文本框，选择要创建的纹理图像。 

5 在 “Rows” (Y)和 “Cols” (X) 文本框里，键入处理窗口的大小。 

6 键入X、Y变换值，用来计算 co-occurrence 矩阵。 

7 选用 “File” 或 “Memory” 输出。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

8 点击“OK”，开始处理。 

完成以后，选择的纹理图像将被计算出来，放在 Available Bands List 中。 
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Adaptive Filtering (自适应滤波) 

自适应滤波运用围绕每个像元的小框里的那些像元的标准差来计算一个新的像元值。特别是，

原始的像元值由基于周围有效像元（那些符合标准差标准的像元）计算的新值代替。不同于典型的

低通平滑滤波，自适应滤波器在压制噪声的同时保留了图像的尖锐和细节。 

·ENVI 提供了六个滤波器，可以通过选择 Filters > Adaptive Filters 得到。 

注意 

这些滤波器运行起来速度较慢。 

Lee 滤波器 

Lee 滤波器是一个基于标准差的滤波器，用于平滑强度跟图像景象密切相关的噪声数据，但是
含有附加的成分。它对基于独立滤波窗口中计算的统计图数据进行滤波。不象典型的低通平滑滤波

器，Lee 滤波器和其它类似的 σ 滤波器在压制噪声的同时，保留了图像的尖锐和细节。被滤掉的
像元将用周围像元计算的值代替。详情见下面的参考书。 

Lee, Jong-Sen, “Digital Image Enhancement and Noise Filtering by Use of Local Statistics,” IEEE 
Transactions on Pattern Analysis and Machine Intelligence, Vol PAMI-2, No.2, March 1980, pp. 165-168 

1. 选择Filters > Adaptive > Lee. 

2 出现标准ENVI文件选择对话框时，选择一个文件名或波段名和空间子集。 

3 点击“OK”。 

4 出现 Lee Filter Parameters 对话框时，在 “Filter Size” 文本框里键入需要的滤波器大小。 

5 用 “Additive”, “Multiplicative”, 和 “Both”标签附近的按钮，选择需要的噪声模型。 

特别指出，雷达图像的噪声是倍增的(斑点)。 

6 若需要，在相应文本框里键入数值，以改变 “Additive Noise Mean” 和 “Multiplicative Noise 
Mean” 的默认值 0.0 和 1.0 。 

较大的噪声平均值将产生较少的平滑。 

7 若需要，改变 “Noise Variance” 值。 

当选择 “Additive” 和 “Both” 噪声模型时，“Noise Variance” 参数被设置成附加噪声变化量。
当选择 “Multiplicative” 噪声模型时，设置为倍增的噪声。 

噪声变化量的估计可以通过计算图像中平坦区域（如湖泊等）的数据差异得到。对于雷达数据

中的倍增的噪声，噪声变化量可以通过“1/观察次数”来估计。 

8 选用 “File” 或 “Memory” 输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

9 点击“OK”，开始处理。 
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Frost 滤波器 

Frost 滤波器用于雷达图像中保留边缘的情况下，减少斑点。它是按指数规律阻尼循环的均衡滤
波，用于局部统计。参与滤波的像元由到滤波器中心的距离、阻尼系数和局部变化计算的值来代替。

详情见下面的参考书。 

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters,” Proceedings of IGRASS 
94, August 8-12, 1994, pp. 2129-2133. 

1 选择Filters > Adaptive > Frost。 

2 出现文件选择对话框时，选择一个文件或波段以及需要的空间子集。 

3 点击“OK” 

4 出现Frost Filter Parameters对话框时，在“Filter Size”文本框里键入需要的滤波器大小 

5 在“Damping Factor”文本框里，键入需要的值 

Damping Factor决定了按指数规律阻尼的数量，默认值为1对于多数雷达图像时足够的。阻尼值
越大，保留的边缘越好，但是平滑越少；反过来，阻尼值小时，平滑较多。阻尼值为0时，得到的结
果与低通滤波输出的结果一样。 

6 选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 点击“OK”，进行滤波。 

出现一条状态信息，显示已经完成了多少操作。 

Gamma 滤波器 

γ 滤波器用于雷达图像中保留边缘信息时，减少斑点。它类似于 Kuan 滤波器，但是假定数据
呈 γ 分布。参与滤波的像元由局部统计计算的值代替。详情见下列参考书。 

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters,” Proceedings of IGRASS 
94, August 8-12, 1994, pp. 2129-2133. 

1 选择Filters > Adaptive > Gamma 

2 出现文件选择对话框时，选择一个文件或波段以及需要的空间子集。 

3 点击“OK”。 

4 出现Gamma Filter Parameters对话框时，在“Filter Size”文本框里键入需要的滤波器大小。 

5 在合适文本框里键入观察次数。 

观察次数用于通过“1/观察次数”计算噪声的变化。 

6 选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 
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7 点击“OK”，进行滤波。 

出现一条状态信息，显示已经完成了多少操作。 

Kuan 滤波器 

Kuan 滤波器用于雷达图像中保留边缘的情况下，减少斑点。它将倍增的噪声模型变换为一个附
加的噪声模型。这一滤波器类似于Lee 滤波器，但是有一个不同的权重函数。参与滤波的像元由局
部统计计算的值代替。详情见下列参考书。 

Zhenghao Shi and Ko B. Fung, “A Comparison of Digital Speckle Filters,” Proceedings of IGRASS 
94, August 8-12, 1994, pp. 2129-2133. 

1. Select Filters > Adaptive > Kuan. 

2 出现标准ENVI文件选择对话框时，选择一个文件或波段以及需要的空间子集。 

3 点击“OK”。 

4 出现Kuan Filter Parameters对话框时，在“Filter Size”文本框里键入需要的滤波器大小。 

5 在合适文本框里键入观察次数。 

观察次数用于通过“1/观察次数”计算噪声的变化。 

6 选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 点击“OK”，进行滤波。 

出现一条状态信息，显示已经完成了多少操作。 

Local Sigma 滤波器 

局部 Σ 滤波器运用为滤波器盒计算的局部标准差，判定在滤波器窗口内的有效像元。它只用

滤波器盒里的有效像元计算出的平均值代替参与滤波的像元。这一滤波甚至在对比度低的区域，也

能很好地保留细节和有效地减少斑点噪声。详情见下列参考书。 

Eliason, Eric M. and McEwen, Alfred S., “Adaptive Box Filters for Removal of Random Noise from 
Digital Images,” Photogrammetric Engineering & Remote Sensing, April, 1990, V56 No. 4, p.453 

1 选择Filters > Adaptive > Local Sigma. 

2 出现标准ENVI文件选择对话框时，选择一个文件或波段以及需要的空间子集。 

3 点击“OK”。 

4 出现Localized Sigma Filter Parameters对话框时，键入滤波器大小。 

5 在“Sigma Factor”文本框里，键入考虑有效值的标准差的值。 

Sigma Factor被用来判定哪些像元是合法的。是通过由键入的标准差的值与局部统计值计算的像
元值的最小值和最大值来判定的。 

参与滤波的像元将由其周围有效像元的平均值代替。 
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6 选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 点击“OK”，进行滤波。 

出现一条状态信息，显示已经完成了多少操作。 

Bit Error 滤波器 

Bit Error (比特误差) 噪声通常是图像中孤立像元（有与图像场景不相关的极值）导致的数据中
的“spikes”的结果。这使得图像呈现“椒盐”的外观。ENVI中比特误差的消除是通过用周围像元
的平均值代替“spikes”像元的算法实现的。滤波器盒里的局部统计（平均值和标准差）被用来为有
效像元设置一个极限。详情见下列参考书。 

Eliason, Eric M. and McEwen, Alfred S., “Adaptive Box Filters for Removal of Random Noise from 
Digital Images,” Photogrammetric Engineering & Remote Sensing, April, 1990, V56 No. 4, p.453 

1 选择Filters > Adaptive > Bit Errors. 

2 出现标准ENVI文件选择对话框时，选择一个文件或波段以及需要的空间子集。 

3 点击“OK”。 

4 出现Bit Error Removal Parameters对话框时，键入像元中滤波器的大小。 

5 在“Sigma Factor”文本框里，键入用于判定有效像元的标准差的值。 

6 键入一个容许度（数值型）。 

如果像元值超过了容许度，则这像元值被认为是“坏”的。当一个像元的值减去滤波器盒子的

平均值得到的数值大于局部标准差的γ倍，且超过了容许度时，这一像元被认为是一个比特误差。

系统默认，“坏”的像元将由其周围有效像元值的平均代替。 

7 在“Zero Bit Errors?”文本框标签附近，点击“Yes”，即将坏像元设为0，而不是用其周围的像
元值的平均代替。 

8 在“Valid Data Min”和“Valid Data Max”文本框里，随意地键入用于一般判断有效数据的最小值
和最大值。 

9 选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

7 点击“OK”，进行滤波。 

出现一条状态信息，显示已经完成了多少操作。 
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Frequency Filtering (频率域滤波，FFTs) 
傅立叶分析是一种将图像分成空间上各种频率成分的数学方法。实际上，快速的傅立叶变换被

原来将数据变换成一个复杂的强调频率分布的图像。ENVI 中 FFT 滤波（从 Filters 下拉菜单中选
择）包括图像正向的 FFT、频率滤波器的交互式建立、滤波器的应用，以及 FFT 向原始数据空间
的逆变换。当前，FFT 处理没有用到 ENVI tiling 程序，因此能被处理的图像大小受到系统可利用
内存的限制。FFT 图像是“复数”数据类型，它占用了类似大小的字节图像的 8 倍内存。 

Forward FFT (正向的FFT) 

正向的 FFT 生成的图像能显示水平和垂直空间上的频率成分。图像（零频率分量，zero 
frequency component）的平均亮度值显示在变换后图像的中心。远离中心的像元代表图像中增加的
空间频率成分。这一滤波能被设计为消除特殊的频率成分，并能进行逆向变换。 

注意 

如果你的输入数据呈奇数（样本和行），正向的FFT输出将不包括折叠频率，这意味着不能准
确反向。 

1 选择Filters > FFT Filtering > Forward FFT。 

2 出现Forward FFT Input File对话框时，选择要被处理的数据，需要时，可以用子集。 

文件选择程序与卷积滤波中用到的一样。 

3 点击“OK”。 

4 出现 Forward FFT Parameters对话框，选用“File” 或 “Memory”输出。 

·若选择输出到“File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或用
“Choose”按钮选择一个输出文件名。 

注意 

输出文件的选项已被设定好。 

5 点击“OK”开始 FFT计算。 

出现一个状态窗口，显示出函数处理数据完成的百分比。目前，完整的 FFT是不进行 tiling的，
因此处理受到系统内存的限制，状态会由 0突然跳到 100%。当变换完成以后，输入文件中的所有波
段被加在了 Available Bands List中。可以用标准 ENVI程序显示结果图像。 

Interactive FFT Filter Definition (交互式FFT滤波器的定义) 

FFT滤波能直接被限定或作为一幅显示的正向变换的图像。滤波类型包括circular pass and cut，
bad pass and cut 以及 user-drawn pass and cut。用户定义的滤波器用 ENVI 的注记功能描述。建立自
定义的 FFT 滤波器： 

1 选择Filters > FFT Filtering > Filter Definition。 

·选择好以后，如果显示出一幅FFT图像，你应迅速选择包含FFT图像的显示数（号），或指出
滤波器不与一次特殊显示相关。 
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·如果没有显示图像，在Filter Definition对话框的顶部，“Samples”和“Lines”标签附近的文本框
里键入数值，以限定滤波器的大小。 

2 从Filter_Type下拉菜单下方的滤波列表里，选择一种滤波类型，并设置需要的参数。 

“Filter:type”参数随选择的滤波类型不同而改变。 

·当选择上“Circular Pass”或“Circular Cut”滤波器时（分别是低通和高通滤波），出现“Radius”
文本框，需要输入滤波半径（范围，用像元表示）。 

·当选择上“Band Pass”或“Band Cut”滤波器时，出现“Inner Radius”和“Outer Radius”文本框，在
相应位置上键入需要的数值（用像元表示）。 

·选择User Defined Pass和User Defined Cut滤波菜单项时，允许将ENVI的注记（只有多边形等
形状）导入滤波器。 

默认值是用当前显示（尤其FFT图像）的注记建立滤波器。 

·用ENVI“注记”功能，建立用户定义的滤波器： 

A 显示FFT图像，在显示的图像中点击鼠标右键。 

B 从图像窗口，选择Functions > Overlays > Annotation 

C 在FFT图像上（概括了出现的特定噪声，如亮斑、行或楔等），画一个多边形或其他形状 

D 建立一个适中的系统FFT滤波器，在注记窗口，选择Options > Turn Mirror On 

显示的注记将在滤波器定义中用到。 

·从前面存储的注记文件中恢复一个滤波器，点击“Ann File”，选择一个注记文件输入。 

3 用“Number of Border Pixels”参数控制用于taper滤波器（平滑滤波边缘）的像元数。零值代表
没有平滑。 

4 选择输出到“File” or “Memory”，若需要，选择一个输出文件名。 

5 点击 “Apply” 建立 FFT 滤波器。 

6 点击 “Cancel” 关闭 Filter Definition 对话框。 

滤波器是限定维数的单一波段图像，它将显示在 Available Bands List 中，可以在应用到图像之
前，用标准 ENVI 程序显示。 

注意 

由于滤波器 DN 值的范围有限（0或1），必须在没有直方图裁剪时，进行反差拉伸(例如，一
个使用所有数据值的快速线性拉伸)，以便恰当地显示滤波图像。 

Inverse FFT 变换 

ENVI反向 FFT 程序实际上是两部操作，不但能用于FFT范围的滤波，而且可以将FFT图像反向
为原始的数据空间。 

1 选择Filters > FFT Filtering > Inverse FFT。 

2 出现Inverse FFT Input File对话框时，选择要处理的正向的FFT数据。 

选择的图像必须是一次正向的FFT操作的结果。文件选择程序与卷积滤波中用到的一样。 
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3 点击“OK”。 

4 出现Inverse FFT Filter File对话框，选择应用的滤波图像。 

滤波图像必须是以前用上面描述的滤波定义程序生成的。 

5 点击“OK”。 

6 出现 Inverse FFT Parameters 窗口时，伴随显示的输入文件特征列表，选择输出到 “File” 或 
“Memory”。 

·若输出到 “File”，键入文件名；或用 “Choose” 按钮，选择一个输出文件名。 

7 从适当的下拉菜单里，选择输出数据的类型（字节型，整型，浮点型等）。 

8 点击“OK”处理图像。 

FFT滤波后的图像可以用标准ENVI程序显示。 
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第八章：Classification (分类) 
Classification 下拉菜单提供访问 ENVI 的监督分类和非监督分类。工具也提供了收集终端单
元、对以前 RULE 图像的分类、计算分级统计信息、计算混淆矩阵、成块或筛选分类、合成分类、
对灰阶图像的叠置分类以对矢量层的输出分类。监督技术将 Endmember Collection 工具用于输入训
练分类波谱，或将 ENVI 的感兴趣区(ROI) 选择工具用于交互式定义训练分类。感兴趣区选择程序
允许从若干不规则多边形、矢量或单个像元中提取训练统计信息。 

Endmember Collection (收集终端单元) 
用 Endmember Collection 从许多来源中选择终端单元波谱，用于分类和高级波谱分析技术。

Endmember Collection 对话框中，所有的监督分类技术以及许多先进的波谱技术都可以运行。这一
功能通过在Algorithm下拉菜单中变换需要的技术，同时对几种分类进行终端单元或分类练习。 

1 选择 Classification > Endmember Collection。 

2 出现 Classification Input File 对话框时，选择需要的文件，子集和/或掩模。 

3 点击“OK”，出现 Endmember Collection 对话框，详情见下面所述。 

Endmember Collection 对话框 

选择好输入文件以后，出现 Endmember Collection 对话框，用这一对话框从各种来源中选择终
端单元波谱。 

The Draw Widget 
窗口顶部可以拖曳的黑色小器具用于从 Z 剖面或波谱图中收集波谱。 

·从这些图中移动波谱，用ENVI标准程序点击鼠标右键选上波谱名，再在名字上点击并按住左
键，将波谱拖动到 Endmember Collection 对话框顶部的黑色可移动器具处，释放按钮。 

波谱名被加在了可选择波谱列表中。 

删除波谱 
·从“Selected Endmember Spectra”列表中，删除终端单元波谱，则选中终端单元名，点击“Delete 

Spectrum”。 

File 下拉菜单 
在Endmember Collection对话框中，File菜单允许将终端单元波谱输出到ASCII文件或作为一个波

谱库。 

·输出到ASCII文件： 

1 选择File > Output Spectra > ASCII. 

2 出现Output Plots to ASCII File对话框，键入输出文件名，或用”Choose”按钮选择一个输出文件
名。 

·由endmember波谱建立一个标准ENVI波谱库文件： 

1 选择File > Output Spectra > Spectral Library。 

Administrator
第八章：Classification (分类)
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2 出现Output Plots to Spectral Library对话框时，键入输出文件名，或用”Choose”按钮选择一个
输出文件名。 

·选择File > Cancel关闭Endmember Collection对话框。 

Import 下拉菜单 
用这一菜单项从其它来源（如ASCII文件、ROI平均值、波谱库或统计文件）输入波谱。也可以

象上面描述的那样，从绘图窗口中拖曳到可移动器具处输入。 

注意 

当应用马氏（Mahalanobis）距离或最大似然分类器时，终端单元波谱只能从 ROIs 或统计文件
中输入，因为这些分类用到了终端单元协方差统计。 

·从 ASCII 文件中输入波谱： 

1 在 Endmember Collection 对话框, 选择Import > from ASCII File。 

2 出现文件选择对话框时，从ASCII文件中选择输入的文件。 

·若选择连续显示的同一格式的一组文件，则点击这一组的第一个，按住“shift”键，再点击
最后一个，或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的同种格式的多个文件，则按住“ctrl”键，再一一点击它们。 

如果选择一个有效文件（即 ASCII 文件中至少包含一列数值型数据），则出现 ASCII Input 对
话框，显示出一个行列数列表和每一栏数据中的前几个数据。 

3 在 “X Axis Column” 文本框里，键入包含 X 轴数据的栏数。 

4 点击需要的栏名，选择终端单元波谱。 

·选择连续显示的一定范围的波谱，在需要的范围内点击和拖曳，或点击这一范围的第一个，

按住“shift”键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

·选择所有波谱，点击 “Select All Items”。 

·删除所有波谱，点击 “Clear All Items”。 

5 如果需要，在 “X Data Multiplier”和“Y Data Multiplier” 文本框里，键入 X 和 Y 放大系数，
以便与图像数据匹配。 

6 点击“OK”将选择的终端单元波谱输入到 Endmember Collection 对话框的列表中。 

·运用前面 Input ASCII File 对话框中限定的参数，再选择一个 ASCII 文件，读取数据： 

1 选择 Import > from ASCII file (previous template)。 

2 选择 ASCII 文件的文件名。 

数据将被直接读到 endmember collection 窗口里，中间不再需要参数对话框。 

·从波谱库文件输入波谱： 

1 选择 Import > from Spectral Library. 

2 出现 Spectral Library Input File 对话框时，选择波谱库名，点击“OK”打开库。 
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·如果需要的波谱库以前没有打开过，在Library Input File对话框中选择 File>Open Spectral 
Library。 

3 出现Input Spectral Library 对话框时，通过点击需要的波谱名选择终端单元波谱。 

·选择连续显示的一定范围的波谱，在需要的范围内点击和拖曳，或点击这一范围的第一个，

按住“shift”键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

·选择所有波谱，点击 “Select All Items”。 

·删除所有波谱，点击 “Clear All Items”。 

4 键入X、Y数据放大系数，以改变数据比例尺。 

5 点击“OK”，将需要的波谱输入 Endmember Spectral 列表。 

·从前面定义的感兴趣区中输入波谱： 

1 选择 Import > from ROI from Input File。 

2 出现 Input Regions of Interest 对话框时，点击需要的 ROI 名，选择终端单元波谱（ROI平均
值）。 

只有前面定义的 ROIs，才会出现对话框。 

·选择所有 ROIs，点击 “Select All Items.” 

·删除所有 ROIs，点击 “Clear All Items.” 

·选择连续显示的 ROIs，在需要的范围内点击和拖曳，或点击这一范围的第一个，按住“shift”
键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

3 点击“OK”将 ROI 的平均值输入到 Endmember Spectral 列表中。 

·从与另一个文件相联系的感兴趣区输入波谱： 

1 选择 Import > from ROI from Other File。 

2 从 Input File of associated ROI 对话框中选择需要输入的文件。 

3 出现 Input Regions of Interest 对话框时，点击需要的 ROI 名，选择终端单元波谱（ROI平均
值） 

只有前面定义的 ROIs，才会出现对话框。 

·选择所有 ROIs，点击“Select All Items.” 

·删除所有 ROIs，点击“Clear All Items.” 

·选择连续显示的 ROIs，在需要的范围内点击和拖曳，或点击这一范围的第一个，按住“shift”
键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

4 点击“OK”将 ROI 的平均值输入到 Endmember Spectral 列表中。 

·从一个统计文件中输入一个平均波谱： 
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1 选择 Import > from Stats file。 

2 出现 Enter Statistics Filename 对话框时，选择要输入的统计文件。 

来自统计文件的平均波谱将被输入到  Endmember Collection 对话框列表中。这一项能用 
Classification > Class Statistics 从以前计算的分类结果中输入平均波谱。 

Algorithm 下拉菜单 
Algorithm 菜单允许你选择需要的分类，或用 Endmember Collection 对话框中的 “Apply” 按钮

使用高级波谱处理技术。在分类方法中，可以应用平行六面体、最短距离、马氏距离、最大似然、

波谱角度制图仪以及二进制编码方法。 

注意 

当用马氏距离或最大似然分类器时，终端单元波谱只能从ROIs或统计文件中输入，因为这些分
类用到了终端单元协方差统计。 

从Algorithm菜单下也可以选择高级波谱处理技术线性波谱不相容、匹配滤波、混合曲调匹配滤
波和波谱特征装配。 

1 从Algorithm下拉菜单中，选择需要的分类方法。 

2 点击“Apply”，将与选择的分类算法对应的参数调出来。 

·分类算法也可以运用Classification >Supervised实现，高级波谱处理技术可以用Spectral Tools
菜单运行。 

Options 下拉菜单 

Endmember Collection对话框中的Options下拉菜单允许编辑终端单元名，作出终端单元图，和清
除终端单元。 

·编辑终端单元名： 

1 选择Options > Edit Endmember Names。 

2 出现Endmember Name Editing对话框时，在“Current Endmember Names”列表中，点击名字，
选择要编辑的终端单元。 

3 选择下列选项： 

·手工改动名字，在“Edit Selected Item”文本框里，点击它，按需要修改，按回车键。 

·从ASCII文件输入终端单元名，点击“Import ASCII”，并选择输入的ASCII文件。 

ASCII文件必须包含与对话框中终端单元波谱同样数量的名字——在ASCII文件中，每个名字在
一条行上。 

·重新将终端单元设置为它们的原始名，点击“Reset”。 

4 点击“OK”。 

·将所有终端单元波谱做成图，选择 Options > Plot Endmembers. 

·选择Options > Clear Endmembers，从“Selected Endmember Spectra”列表中清除所有的终端单
元波谱。 
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Apply (应用) 

1 一旦选择上所有需要的终端单元波谱和选项，点击“Apply”开始选择算法。 

2 出现Algorithm Parameters对话框时，输入选择的算法所需要的参数。 
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Supervised Classification (监督分类) 
监督分类用于在数据集中按照用户定义的训练分类器收集像元。监督分类技术需要你在执行以

前事先定义训练分类器（training classes）。这些可以用两种方式定义，用 Endmember Collection 对
话框选择波谱，或从Region of Interest菜单里选用Define Region of Interest项。收集终端单元函数允许
你从许多来源中选择波谱和需要的分类算法。Endmember Collection项允许你几种分类使用同样的训
练分类器或终端单元（不用再装），因此简化了分类结果的对比。用终端单元选择是没法进行最大

似然和马氏距离分类的，因为他们需要另外的统计项。直接从Supervised菜单里选择那些分类。 

训练分类器也可以用 ENVI 感兴趣区（ROI）函数限定。这些练习处可以被定义为多重不规则
多边形、矢量或单个象素。 

所有监督分类都有一个输出”rule”图像的选项。规则图像在最后分类执行以前，就能显示出分类
结果。例如，运用最小距离分类的规则图像（每类一个）是分类与未知像元之间的距离。在规则分

类器中，这些规则图像可以被用于调整阈值，产生新的分类图像。 

用下面程序实现ENVI的监督分类技术（包括平行六面体、最短距离、马氏距离、最大似然、波
谱角度制图仪以及二进制编码方法）： 

1 用Endmember Collection对话框，或感兴趣区定义训练分类器。 

2 选择Classification > Supervised > 需要的分类方法，或从Endmember Collection对话框中对分
类初始化。 

3 出现Classification Input File对话框时，执行标准 ENVI 文件选择程序，选择文件、子集和/
或掩模。 

Classification Parameters 对话框 
每一种分类方法都有它自己的分类方法参数对话框，一旦选择好输入文件，对话框就会出现。

实际的分类类型将代替对话框文件头中的 “Classification Method” 文本。许多分类参数对话框中通
用的选项包括：ROIs的选择（用于打开的 ROI 列表中的分类），分类图像的磁盘文件或内存输出，
与规则图像的计算（文件或内存输出）。单个对话框以及与每个分类类型相对应的参数被描述在对

每一种分类方法的描述下面。 

选择感兴趣区 (ROIs) 
·训练分类器时选择感兴趣区，在 “Select Classes from Regions:” 列出的可利用ROIs列表中，
点击需要的 ROI 名。 

·选择所有 ROIs,，点击“Select All Items.” 

·删除所有 ROIs,，点击“Clear All Items.” 

·选择连续显示的几个 ROIs,，在需要的范围内点击和拖曳，或点击这一范围的第一个，按住
“shift”键，再点击最后一个。 

·选择非连续显示的多个 ROIs，则按住“ctrl”键，再一一点击它们。 

规则图像 (Rule Images) 
规则图像是中间结果图像，它在分类最终完成以前，就能显示分类结果。例如，用于最大似然

分类的规则图像将是图像本身的几率；分类中每一个输入的 ROI 都有一个中间图像。最终的分类
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图像将有最大几率的规则结果（以像元到像元（pixel-by-pixel）为基础），作为像元值只包含最大可
能的 ROI数。可能值本身只保留在规则图像中，而不在分类后的图像中。 

·计算一幅随意的规则输出图像（或图像——每类一个），在“Enter Output Rule Filename”文本
框里，键入一个文件名。如果没有键入输出名，规则图像将不被保存。 

分类结束，图像将出现在 Available Bands List 中，可以在任何显示窗口中显示（或链接/覆盖），
并可以使用 ENVI 的像元位置/值功能来查询。 

这些规则图像也可以以后用在 Rule Classifier 函数中，不必再重新计算整个分类情况下，建立
一幅新的分类图像。 

文件/内存运行（Execution） 
·在 “Output Result to” 标签的右边，点击合适的按钮选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，在 “Output File Name” 文本框里，键入输出文件名，或用 “Choose” 
按钮选择输出的文件名。 

Parallelepiped (平行六面体) 

平行六面体用一条简单的判定规则对多波谱数据进行分类。判定边界在图像数据空间中，形成

了一个 N 维平行六面体。平行六面体的维数由来自每一种选择的分类的平均值的标准差的阈值确
定。如果像元值位于 N 个被分类波段的低阈值与高阈值之间，则它归属于这一类。如果像元值落
在多个类里，那么 ENVI 将这一像元归到最后一个匹配的类里。没有落在平行六面体的任何一类里
的区域被称为无类别的。详情见： 

J.A.Richards, 1994, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, p.340. 

要开始运用平行六面体技术，选择下列选项之一： 

·从Classification菜单： 

1 选择Classification > Supervised > Parallelepiped 

2 出现Classification Input File对话框时，进行标准文件选择，或任何一个子集，和掩模。 

·在Endmember Collection对话框里，选择Algorithm > Parallelepiped (见第 541 页的 

“Endmember Collection”) 

Parallelepiped Parameters 对话框 
选择好输入文件以后，出现 Parallelepiped Parameters 对话框。 

1 输入一般的分类参数（分类参数对话框中列出的那些）。 

这一对话框包含了一个额外的参数——标准差数，用于ROI平均值周围。 

·在“Max stdev from Mean”文本框里，键入一个数值。 

标准差的默认值3被自动输入到这一文本框里。 

2 点击“OK”开始分类。 

出现一条状态信息，显示操作被完成的进程。作为结果的规则图像的像元值范围是从0到n（n
是波段数），像元值代表了符合平行六面体标准的波段数。这儿有一幅规则图像用于每个选择的分

类。对于一种分类，匹配所有波段的区域被当作分类后的区域输入到分类后的图像中。如果出现不
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只一种匹配，则计算的最后一类将把它转运到分类后的图像中。 

Minimum Distance (最小距离) 

最短距离技术用到每一个终端单元的均值矢量，计算每一个未知像元到每一类均值矢量的欧几

里德距离。所有像元都被归为最近的一类，除非限定了标准差和距离的极限（这时，会出现一些像

元因不满足选择的标准，而成为“无类别”）。详情见 J.A.Richards, 1994,Remote Sensing Digital Image 
Analysis, Springer-Verlag, Berlin, p.340. 

开始运用最短距离分类技术，选择下列选项之一： 

·从 Classification 菜单： 

1 选择 Classification > Supervised > Minimum Distance. 

2 出现 Classification Input File 对话框时，进行标准文件选择，或任何一个子集和掩模。 

·在 Endmember Collection 对话框中，选择 Algorithm > Minimum Distance。 

Minimum Distance Parameters 对话框 

选择一个输入文件以后，出现 Minimum Distance Parameters 对话框。 

1 输入一般的分类参数（分类参数对话框中列出的那些） 

·在 “Max Stdev From Mean:” 和 “Max Distance Error:” 文本框里，分别随意地键入要用到的标
准差值（在终端单元的均值左右）和允许的最大距离误差。如果这些参数都已输入，分类就用两者

中的较小的一个判定哪些像元将参与分类。如果没有输入任何一个参数，则所有像元都将参与分类。 

2 点击“OK”开始分类。 

出现一条状态信息，显示已经完成了多少操作。如果选择，像元值等于它到分类均值的欧氏距

离时，分类就会建立一幅规则图像。符合最短距离标准的区域被添加到分类后的图像中。 

Mahalanobis Distance (马氏距离) 

马氏距离分类是一个方向灵敏的距离分类器，分类时用到了统计。它与最大似然分类有些类似，

但是假定所有类的协方差相等，所以是一种较快的方法。所有像元都被归到最临近的ROI类，除非
用户限定了一个距离阈值（这时，如果一些像元不在阈值内，就会被划为无类别）。详情见：J.A.Richards, 
1994, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, p.340. 

开始运用马氏距离分类技术，选择下列选项之一： 

·从 Classification 菜单： 

1 选择Classification > Supervised > Mahalanobis Distance. 

2 出现Classification Input File对话框时，进行标准文件选择，或任何一个子集，和掩模。 

·在Endmember Collection对话框中，选择Algorithm > Mahalanobis Distance。 

注意 

在选择Mahalanobis作为分类方法以后，在Endmember Collection对话框里输入（或再输入）终端
单元。 
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Mahalanobis Distance Parameters 对话框 
选择一个输入文件以后，出现 Mahalanobis Distance Parameters 对话框。 

1 输入一般的分类参数（分类参数对话框中列出的那些）。 

·若需要，在 “Max Distance Error:” 文本框里，键入允许的最大距离误差。 

如果输入了选择的参数，距离超过所有类的这个参数的像元将被归为“无类别”。如果没有输

入最大距离误差值，则所有像元都将参与分类。 

2 点击“OK”开始分类。 

出现一条状态信息，显示已经完成了多少操作。如果选择，像元值等于它到分类均值的距离时，

分类就会建立一幅规则图像。符合最短距离标准的区域被添加到分类后的图像中。 

Maximum Likelihood (最大似然分类) 

最大似然分类假定每个波段每一类统计呈均匀分布，并计算给定像元属于一特定类别的可能性。

除非选择一个可能性阈值，所有像元都将参与分类。每一个像元被归到可能性最大的那一类里。详

情见：J.A.Richards, 1994, Remote Sensing Digital Image Analysis, Springer-Verlag, Berlin, p.340. 

开始运用马氏距离分类技术，选择下列选项之一： 

·从Classification菜单： 

1 选择Classification > Supervised > Maximum Likelihood 

2 出现Classification Input File对话框时，进行标准文件选择，或任何一个子集，和掩模。 

·在Endmember Collection对话框中，选择Algorithm > Maximum Likelihood。 

注意 

在选择 Maximum Likelihood 作为分类方法以后，在 Endmember Collection 对话框里输入（或
再输入）终端单元。 

Maximum Likelihood Parameters 对话框 

选择一个输入文件以后，出现 Maximum Likelihood Parameters 对话框。 

1 输入一般的分类参数（分类参数对话框中列出的那些）。 

·若需要，在 Probability Threshold” 文本框里，键入一个阈值（0~1）。 

选项参数被用来控制像元准确分类的可能性。如果像元的可能性低于所有类的阈值，则它被归

为“无类别”。 

2 点击“OK”开始分类。 

出现一条状态信息，显示已经完成了多少操作。规则图像的像元值（每类一幅图像）象征着与

类别匹配的可能性。最后的分类将每一个像元都归到可能性最大的类里。 

Spectral Angle Mapper (波谱角度映射表) 

波谱角度映射表（SAM）是一个基于自身的波谱分类，它是用n维角度将像元与参照波谱匹配。
这一算法是通过计算波谱间的角度（将它们处理为具有维数等于波段数的空间矢量），判定两个波
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谱间的类似度。这一技术用于校准反射数据时，对照明和反照率的影响相对不灵敏。SAM 用到的终
端单元波谱可以来自 ASCII 文件、波谱库或直接从图像中抽取（作为ROI平均波谱）。SAM 将终
端单元波谱矢量和每一个像元矢量放在n维空间比较角度。较小的角度代表与参照波谱匹配紧密。远
离指定的弧度阈值最大角度的像元被认为无法分类。详情见： 

Kruse, F. A., Lefkoff, A. B., Boardman, J. B., Heidebrecht, K. B., Shapiro, A. T.,Barloon, P. J., and 
Goetz, A. F. H., 1993, The Spectral Image Processing System (SIPS) - Interactive Visualization and 
Analysis of Imaging spectrometer Data: Remote Sensing of Environment, v. 44, p. 145 - 163. 

开始运用波谱角度制图仪分类技术时，选择下列选项之一： 

·从Classification菜单： 

1 选择 Classification > Supervised > Spectral Angle Mapper。 

2 出现 Classification Input File对话框时，进行标准文件选择，或任何一个子集和掩模。 

·在Endmember Collection对话框中，选择Algorithm > Spectral Angle Mapper 

Endmember Collection (收集终端单元) 对话框 
选择一个输入文件以后，出现 Endmember Collection: SAM 对话框。 

波谱可以从 ASCII 文件、波谱库、ROI 均值或统计文件中输入。 

1 从 Import_Spectra 菜单下提供的不同来源中，选择终端单元波谱。 

·波谱可以从其它图示中拖曳到对话框顶部的小黑器具里。 

·若需要，改变波谱名，为波谱绘图。 

2 点击“Apply”，一旦选择了所有需要的终端单元波谱，就出现波谱角度制图仪参数对话框。 

Spectral Angle Mapper Parameters 对话框 
1 输入一般的分类参数（分类参数对话框中列出的那些）。 

·用 “Maximum Angle (radians):” 参数框，改变波谱矢量间的最大角度阈值。 

这是终端单元波谱矢量与像元矢量之间的最大可接受的“角度”（在“#波段”维数空间）。角度
小于阈值的像元将参与分类。默认值是0.1（弧度）。 

2 点击“OK”开始 SAM 分类。 

出现一条状态信息，显示已经完成了多少操作。规则图像的像元值代表距离每一类参照波谱的

波谱角度。较小的波谱角度表示与终端单元波谱匹配的较好。符合选择的阈值标准的区域被输入到

分类后的图像中。 

Binary Encoding (二进制编码) 

二进制编码分类技术将数据和终端单元波谱编码为0和1（基于波段是低于波谱平均值，还是高
于波谱平均值）。“异或”逻辑函数用于对每一种编码的参照波谱和编码的数据波谱进行比较，生

成一幅分类图像。所有像元被分类到与其匹配波段最多的终端单元一类里，除非指定了一个最小匹

配阈值（这时，如果一些像元不符合标准，它们将不参与分类）。详情参见： 

Mazer, A. S, Martin, M., Lee, M., and Solomon, J. E., 1988, Image Processing Software for Imaging 
Spectrometry Analysis: Remote Sensing of Environment, v. 24, no. 1, p. 201 - 210. 
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开始运用二进制编码分类技术时，选择下列选项之一： 

·从 Classification 菜单： 

1 选择 Classification > Supervised > Binary Encoding。 

2 出现 Classification Input File 对话框时，进行标准文件选择，或任何一个子集和掩模。 

·在 Endmember Collection 对话框中，选择 Algorithm > Binary Encoding。 

Binary Encoding Parameters 对话框 
选择好输入文件以后，出现 Binary Encoding Parameters 对话框。 

1 输入一般的分类参数（分类参数对话框中列出的那些）。 

·若需要，在 “Minimum Encoding Threshold” 文本框里，输入必须匹配的波段数的十进制最小
百分比（0~1）。 

·若没有输入最小值，所有像元都参与分类。 

2 点击“OK”开始分类。 

出现一条状态信息，显示已经完成了多少操作。若选择，为每一类（像元值等于与类匹配的波

段数的百分比）将建立一幅规则图像。满足最小阈值的区域将被输入到分类后的图像中。 
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Unsupervised Classification (非监督分类) 
非监督分类仅仅用统计方法对数据集中的像元进行分类，它不需要用户定义任何训练分类器。

Unsupervised Classification 菜单为你提供了 ENVI 的 Isodata 和 K-Means 非监督分类技术。单个
菜单具体内容如下所述。 

Isodata 

Isodata 非监督分类计算数据空间中均匀分布的类均值，然后用最小距离技术将剩余像元迭代聚
集。每次迭代重新计算了均值，且用这一新的均值对像元进行再分类。重复分类是分割、融合和删

除是基于输入的阈值参数的。除非限定了标准差和距离的阈值（这时，如果一些像元不满足选择的

标准，他们就无法参与分类），所有像元都被归到与其最临近的一类里。这一过程持续到每一类的

像元数变化少于选择的像元变化阈值或已经到了迭代的最多次数。详情参见：Tou, J. T. and R. C. 
Gonzalez, 1974. Pattern Recognition Principles, Addison-Wesley Publishing Company, Reading, 
Massachusetts. 

执行 Isodata（独立数据）非监督分类： 

1 选择 Classification > Unsupervised > Isodata. 

2 出现 Classification Input File 对话框，进行标准文件选择或输入文件的子集和掩模。 

3 点击“OK”，显示 ISODATA Parameters 对话框。 

ISODATA Parameters 对话框 
在 ISODATA Parameters 对话框中可以利用的选项包括：即将被限定的分类数的范围输入，像
元变化阈值（0~100%），被用来对数据进行分类的最多迭代次数，分割、合并和删除分类阈值以
及可选的距离阈值。 

1 输入被限定的类数范围（最小值和最大值）。 

用到类数范围是由于独立数据算法是基于输入的阈值进行拆分与合并的，并不遵循一个固定的

类数。 

2 在合适文本框里，输入迭代次数的最大值和一个变化阈值（0~100%）。 

当每一类的像元数变化小于阈值时，用变化阈值来结束迭代过程。当达到阈值或迭代达到了最

多次数时，分类结束。 

3 在合适文本框里，键入形成一类需要的最少像元数。 

如果一类中的像元数小于构成一类的最少像元数，则这一类就要被删除，其中的像元被归到距

离最近的类里。 

4 在“Maximum Class Stdv”文本框里，键入最大分类标准差（用十进制）。 

如果一类的标准差比这一阈值大，则这一类将被拆分成两类。 

5 在合适文本框里，键入类均值之间的最小距离和合并成对的最多数。 

如果类均值之间的距离小于输入的最小值，则这一类就会被合并。被合并后的成对类的最大数

由合并成对的菜蔬最大值设定。 
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6 随意设置类均值左右的标准差和最大允许距离误差，分别在 “Maximum Stdev From Mean:” 
和 “Maximum Distance Error:” 文本框里，键入数值。 

如果这些可选参数的数值都已经输入，分类就用两者中较小的一个判定将参与分类的像元。如

果两个参数都没有输入，则所有像元都将被分类。 

7 选用 “File” 或 “Memory” 输出。 

如果选用 “File” 输出，在标有“Enter Output File Name”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

8 点击“OK”，开始进行独立数据分类。 

图像中每一个波段将计算统计值，屏幕上出现一条状态信息，显示操作的进展过程。这一信息

随着分类器的每一次迭代在 0 到 100% 之间循环。 

K-Means 

K-Means 非监督分类计算数据空间上均匀分布的最初类均值，然后用最短距离技术重复地把像
元聚集到最近的类里。每次迭代重新计算了均值，且用这一新的均值对像元进行再分类。除非限定

了标准差和距离的阈值（这时，如果一些像元不满足选择的标准，他们就无法参与分类），所有像

元都被归到与其最临近的一类里。这一过程持续到每一类的像元数变化少于选择的像元变化阈值或

已经到了迭代的最多次数。详情参见： 

For technical details, see: Tou, J. T. and R. C. Gonzalez, 1974. Pattern Recognition Principles, 
Addison-Wesley Publishing Company, Reading, Massachusetts. 

执行 K-Means 非监督分类： 

1 选择 Classification > Unsupervised > K-Means。 

2 出现 Classification Input File 对话框时，进行标准文件选择或输入文件的子集和掩模。 

3 点击“OK”，显示 K-Means Parameters 对话框。 

K-Means Parameters 对话框 
在 K-Means 参数对话框里的可选项包括：由聚类程序限定的分类数的选择，像元变化阈值

（0~100%），用于分类的迭代最多次数以及可选项距离阈值。 

1 在相应文本框里，键入分类数以及迭代的最多次数。 

2 键入一个变化阈值（0~100%），用于当每一类像元数变化小于阈值时结束迭代过程。达到阈
值或迭代达到最多次数时分类结束。 

3 随意设置类均值左右的标准差和最大允许距离误差（用十进制），分别在 “Maximum Stdev 
From Mean:” 和 “Maximum Distance Error:” 文本框里，键入数值。 

如果这些可选参数的数值都已经输入，分类就用两者中较小的一个判定将参与分类的像元。如

果两个参数都没有输入，则所有像元都将被分类。 

4 选用 “File” 或 “Memory” 输出。 

如果选用 “File” 输出，在标有“Enter Output File Name”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 
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5 点击“OK”，开始进行 K-Means 分类。 

图像的每一个波段将进行计算统计，出现一条状态信息，显示操作处理进度。这些信息在分类

器每次迭代时循环显示。 
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Post Classification 
ENVI 有许多 post 分类选项，包括一个规则图像分类器，计算分类统计，和混淆矩阵，clumping、
筛选和合成分类，在一幅图像上将类叠置，输出类到矢量层。 

Rule Calssifier (规则分类器) 

运行分类程序所需要的时间由分类方法计算的时间决定。分类本身实际上不需要大量计算。

ENVI的“规则分类器”允许你运用以前存储的规则图像，而且这一分类器包含了用不同阈值生成新
分类图像的分类方法，如匹配数、距离方法以及可能性等。 

1 首先，象“监督分类”中描述的那样生成规则图像。 

2 选择 Classification > Post Classification > Rule Classifier. 

3 从 Rule Image Classifier 输入对话框中，选择规则图像。若需要，抽取空间子集。 

4 出现 Rule Image Classifier Parameters 对话框时，用 “Classify by” 按钮选择 “Minimum 
Value” 或 “Maximum Value”，以控制规则分类器进行分类用到的方法。 

·选择最小值使得分类器在规则图像中选择最小的像元值输出到分类后的图像中。只有那些小

于阈值的像元参与分类。 

·选择最大值使得分类器在规则图像中选择最大的像元值输出到分类后的图像中。只有那些大

于阈值的像元参与分类。 

5 在 “Thres Value” 文本框里，输入需要的阈值。 

6 选用 “File” 或 “Memory” 输出。 

·如果选用“File”输出，在标有“Enter Output File Name”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

7 点击“OK”开始处理。 

结果是一幅新分类的图像，可以用标准 ENVI 显示程序显示。 

Class Statistics (分类统计) 

统计可以基于与任何相关输入文件的分类结果进行计算。基本统计包括在一个类中的点数、最

小值、最大值、平均值以及类中每个波段的标准差等。每类中，最小值、最大值、平均值以及标准

差可以作成图显示。可以看到每类的直方图，以及计算出的协方差矩阵、相关矩阵、特征值和特征

矢量。对所有分类的描述也可以看到。 

1 选择 Classification > Post Classification > Class Statistics。 

2 出现 Classification Input File 对话框时，选择一幅分类图像。 

只有分类后的图像可以选择（根据图像文件头中的文件类型描述判断）。 

3 点击“OK”继续。 

4 出现 Statistics Input File 对话框时，选择一个输入文件，由此返回统计，并用标准 ENVI 文
件选择程序抽取空间或波谱子集。 
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为分类图像中确定的区域，选择用于计算分类统计的文件（通常是数据文件）。 

5 选好输入数据以后，点击“OK”。 

出现 Class Selection 对话框。 

6 在列表中点击分类名，选择你想计算统计的分类。 

·若选择所有分类，点击“Select All Items”。 

·若清除所有分类，点击“Clear”。 

·若选择连续显示的分类，则点击这一范围的第一个，按住“shift”键，再点击最后一个，或
者在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续波段，则按住“ctrl”键，一一点击它们，最后将多余的选项再去掉。 

7 点击“OK”。 

出现 Compute Statistics Parameter 对话框。 

8 在检查框里点击，选择需要的统计项。详情见 “Compute Statistics” 部分。 

最终输出将是每类分开的统计报告和图示以及所有类的总结报告。 

Confusion(Contingency) Matrix (混淆矩阵) 

分类结果的精度显示在一个混淆矩阵里（用于比较分类结果和地表真实信息）。记录了总体精

度、制造者以及用户的准确度、Kappa 系数、混淆矩阵以及代理和冗长误差。ENVI 能用一幅地表
真实图像或地表真实感兴趣区（ROIs）计算混淆矩阵。当用一幅地表真实图像时，也可以输出每类
图像中没有被正确分类的那些像元隐含的误差图像。详情见以下信息。 

J. R. Jensen, 1986, Introductory Digital Image Processing, Prentice-Hall, Englewood Cliffs, New 
Jersey, p. 379. 

Ground Truth Image (地表真实图像) 
用一幅地表真实图像显示混淆矩阵中的记录： 

1 选择 Classification > Post Classification > Confusion Matrix > Using Ground Truth Image。 

2 在 Classification Input File 对话框，选择分类图像，如需要抽取空间子集。 

3 从 Ground Truth Input File 对话框，选择地表真实图像，运行空间子集。 

4 出现 Match Classes Parameters 对话框时，在两个列表中选择匹配的名字，再点击 “Add 
Combination” 按钮，使地表真实类别与最终分类结果相匹配。 

在对话框低部列表中显示出类之间的结合。如果地表真实图像中的类别与分类图像中的类名字

相同，它们将自动匹配。 

·从列表中删除一个用于匹配的类，点击合成后的名字，在对话框顶部列表中就会重新出现两

类的名字。 

5 当所有需要的类合成以后，点击 “OK”。 

出现 Confusion Matrix Parameters 对话框。 

6 在 “Output Confusion Matrix in” 标签附近，选择 “Pixels” 和/或 “Percent” 复选框。 
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如果两者都选，则它们将被记录在同一窗口里。 

7 在 “Report Accuracy Assessment”标签附近 ，选择 “Yes” 或 “No” 按钮。 

8 在 “Output Error Images” 标签附近，点击箭头箭头切换按钮，选择 “Yes” 或 “No”。 

输出的误差图像被掩模，每类一幅，在这些图像中，所有被正确分类的像元被赋予“0”，未正
确分类的像元被赋予“1”。最后的误差图像波段为整个合成的分类显示出所有未被正确分类的像元。 

9 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名 

10 点击“OK”，显示混淆矩阵中的记录以及相关的统计 

记录显示了总体精度、Kappa 系数、混淆矩阵、commission 误差（每类中额外像元占的百分比）、
冗长误差（类左边的像元占的百分比）、生产者（制造者）精度以及每类中用户使用的精度。生产

者精度是指假定地表真实类是X ，分类图像中像元被分到 X 类的可能性。用户精度是指假定分类
图像中一个像元被归到 X 类，则地表真实类别是X的可能性。混淆矩阵的输出显示了这些准确估价
是怎样被计算的。 

Ground Truth ROIs (地表真实感兴趣区) 
用地表真实感兴趣区显示一个混淆矩阵的记录。 

1 选择Classification > Post Classification > Confusion Matrix > Using Ground Truth ROIs. 

2 在Classification Input File对话框，选择分类图像，若需要，抽取空间子集。 

地表真实感兴趣区必须是已经打开的，且与分类输出图像大小相同的一幅图像相关。感兴趣区

将被自动装到Match Classes Parameters对话框。 

注意 

如果地表真实感兴趣区被定义在大小不同的一幅图像上，你可以用 Basic Tools > Region of 
Interest > Reconcile ROIs，使它们与你的分类图像兼容。 

3 出现 Match Classes Parameters 对话框时，可以在两个列表中选择匹配的名字，点击 “Add 
Combination”，将地表真实感兴趣区与分类结果相匹配。 

分类合成显示在对话框低部的列表里。如果地表真实的类与分类图像中的类名字相同，它们将

自动匹配。 

·从列表中删除一个进行匹配的类，点击合成的名字。两类的名字将重新出现在对话框顶部的

列表里。 

4 当所有需要的类合成以后，点击 “OK”。 

出现 Confusion Matrix Parameters 对话框。 

5 在 “Output Confusion Matrix in” 标签附近，选择 “Pixels” 和/或 “Percent” 复选框。 

如果两者都选，则它们将被记录在同一窗口里。 

6 在 “Report Accuracy Assessment” 标签附近 ，选择 “Yes” 或 “No” 按钮。 

7 点击“OK”，显示混淆矩阵中的记录以及相关的统计。 
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记录显示了总体精度、Kappa 系数、混淆矩阵、commission 误差（每类中额外像元占的百分比）、
冗长误差（类左边的像元占的百分比）、生产者（制造者）精度以及每类中用户使用的精度。生产

者精度是指假定地表真实类是 X，分类图像中像元被分到 X 类的可能性。用户精度是指假定分类
图像中一个像元被归到 X 类，则地表真实类别是 X 的可能性。混淆矩阵的输出显示了这些准确估
价是怎样被计算的。有关细节请看下面例子。 

混淆矩阵举例 

下面的例子说明了用于混淆矩阵计算的条目，包括总体精度、Kappa 系数、混淆矩阵（可能性）、
commission 误差（每类中额外像元占的百分比）、冗长误差（类左边的像元占的百分比）、生产者
（制造者）精度以及用户精度。ENVI能用一幅地表真实图像或地表真实感兴趣区计算一个混淆矩阵，
两者都产生一幅类似于下面例子的输出。 

 

混淆矩阵: {M6} (640x400x1) 

 

总体精度 = (131003/256000) 51.1730% 

Kappa 系数= 0.2648 

 

地表真实 (像元) 

类别 未分类 草地 森林 沼泽 合计 

未分类 43689 26949 40 18001 88679 

草地 32835 64516 1741 3329 102421 

森林 8202 7277 4096 654 20229 

沼泽 15227 10742 0 18702 44671 

合计 99953 109484 5877 40686 256000 

 

地表真实 (百分比) 

类别 未分类 草地 森林 沼泽 合计 

未分类 43.71 24.61 0.68 44.24 34.64 

草地 32.85 58.93 29.62 8.18 40.01 

森林 8.21 6.65 69.70 1.61 7.90 

沼泽 15.23 9.81 0.00 45.97 17.45 

合计 100.00 100.00 100.00 100.00 100.00 

 

Class Commissio
n 

(百分比) 

Omission 

(百分比) 

Commissio
n 

(像元数) 

Omission 

(像元数) 
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未分类 45.01 56.29 44990/999
53 

56264/999
53 

草地 34.62 41.07 37905/109
48 

44968/109
44 

森林 274.51 30.30 6133/5877 1781/5877 

沼泽 63.83 54.03 25969/406
86 

21984/406
86 

 

Class Prod. Acc.

(百分比) 

User Acc. 

(百分比) 

Prod. Acc. 

(像元数) 

User Acc. 

(像元数) 

未分类 43.71 49.27 43689/999
53 

43689/886
79 

草地 58.93 62.99 64516/109
484 

64516/102
421 

森林 69.70 20.25 4096/5877 4096/2022
9 

沼泽 45.97 41.87 18702/406
86 

18702/446
71 

 

 

Overall Accuracy (总体精度) 
总体精度由被正确分类的像元总和除以总像元数计算。地表真实图像或地表真实感兴趣区限定

了像元的真正分类。被正确分类的像元沿着混淆矩阵的对角行分布，它显示出被分类到正确地表真

实分类的像元数。像元总数是所有参与地表真实分类的像元总和。 

Kappa Coefficient 
Kappa 系数是另外一种计算分类精度的方法。它是通过所有地表真实分类中的像元总数乘以混

淆矩阵对角行的和，再减去一类中地表真实像元的总和与这一类中被分类的像元总数与所有分类总

数的比的积，再除以总的像元数的平方减去这一类中地表真实像元与这一类被分类的像元总数的积

与所有类的这些因子的比得到的。 

混淆矩阵（像元数） 
混淆矩阵是通过将每个地表真实像元的位置和分类与分类图像中的相应位置和分类相比较计算

的。混淆矩阵的每一栏代表了一个地表真实分类，并且每一栏中的数值与地表真实像元中分类图像

的标签相对应。例如，看前面的地表真实（像元）表中，森林类的地表真实栏里。 

在这一类地表真实值显示5877像元。分类能将4096个像元适当进行分类，但是有40个像元是

未参加分类的，1740被归为草地。 

混淆矩阵（百分比） 
地表真实（百分比）表显示了每个地表真实分类中类分布的百分比。数值通过每个地表真实栏

里的像元数除以一个给定地表真实类中的像元总数得到。例如，在森林类里，被准确分类的像元数

占的百分比是 4,096/5,877=.697 或 69.7%. 
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Commission 
Commission 误差代表了被标注为属于兴趣类，实际属于另一类的像元。Commission 误差被显

示在混淆矩阵的行里。在混淆矩阵例子里，草地类共有地表真实像元 109484 个，其中 64516 个像
元分类是正确的，37905 个是其它像元被误认为草地的（37905 是混淆矩阵中草地一行其它类的总
和）。在地表真实分类中，分类不正确的像元数占参与分类的像元总数的比例形成了 Commission 误
差。对于草地分类 Commission 误差为 37,905/109,484=34.6%. 

Omission (冗长) 
冗长误差代表了属于地表真实分类的像元，但是分类技术很难将它们分到合适的类里。冗长误

差显示在混淆矩阵的列里。在混淆矩阵例子里，草地类一共有地表真实像元 109,484个，其中64516
个像元是分类正确的，其余的 44968 个都是误被分为草地真实像元的（在混淆矩阵中草地一列，其
它类的总和是 44968）。被误分类的像元占地表真实分类像元总数的比例被称为冗长误差。对于草
地类，冗长误差为 44,968/109,484=41.1%。 

Producer Accuracy (发生器精度) 
发生器精度是指假定地表真实为 A 类，分类器能将一幅图像的像元归为 A 类的可能性。在混
淆矩阵例子里，草地类共有109484个地表真实像元，其中 64516 个像元是正确分类得到的。生产者
精度是 64,516/109,484 =58.9%. 

User Accuracy (用户精度) 
用户精度是指假定分类器将像元归到A类，则相应的地表真实类别是 A 的可能性。在混淆矩阵

例子中，分类器将 102421 个像元归到草地一类中，但是只有 64516 个像元是正确归类的。用户精
度是 64,516/102,421=63.0%. 

Changing Class Colors (改变类颜色) 

·当一个分类后的图像被导入一个显示窗口时，每一类自动呈现不同的颜色。每类的颜色与监

督分类中选择的感兴趣区的颜色或非监督分类中预先选择的每类颜色相对应。未分类区域在图像中

呈黑色。一旦分类图像显示出来，你可以改变每类的颜色： 

1 在 Main Image 窗口，选择 Functions > Color Mapping > Class Color Mapping。 

2. 出现 Classification Mapping 对话框时，选择下列选项： 

这一对话框允许你改变每一类的颜色以及名称。 

·改变类的颜色，从 “Selected Classes” 列表中，选择要改变颜色的类的名字，打开颜色调整滑
动条。 

·用 System 下拉菜单，选择 RGB、HLS 和 HSV 颜色系统。 

·改变选择的类的名字，在 “Class Name” 文本框里编辑。 

·将颜色和名字重新设置为它们的原始值，选择 Options >Reset Color Mapping. 

3 当你已经完成对颜色的修改以后，选择 File > Save Changes 保存新的颜色。 

4 选择 File > Cancel 关闭对话框。 
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ROC Curves 

Receiver Operating Characteristic (ROC) Curves 是一种为了选择合适的判定阈值，观看分类器性
能的一种方法。ROC 曲线将一系列不同阈值的规则图像分类结果与地表真实信息进行比较。对每个
选择的类探测的可能性（Pd）相对于假预报的可能性（Pfa）曲线和 Pd 相对于阈值的曲线被记录。

ENVI 能用地表真实图像或地表真实感兴趣区计算一条 ROC 曲线。详情见下面参考书。 

A. P. Bradley, 1997, The use of the area under the ROC Curve in the evaluation of machine learning 
algorithms, Pattern Recognition, V. 30, No.7, pp 1145-1159. 

Ground Truth Image (地表真实图像) 
用地表真实图像显示一条 ROC 曲线。 

1 选择 Classification > Post Classification > ROC Curves > Using Ground Truth Image. 

2 从 Rule Input File 对话框，选择分类规则图像，或抽取空间波谱子集  

图像中选择的每个波段将被用于生成一条 ROC 曲线。每一个规则波段影射一种地表真实分类。 

3 从 Ground Truth Input File 对话框，选择地表真实图像，或空间子集。 

4 出现  Match Classes Parameters 对话框时，在两个列表中选择匹配的名字，点击  “Add 
Combination”，将地表真实分类与规则图像分类相匹配。 

在对话框底部列表中显示出类之间的结合。如果地表真实图像中的类别与分类图像中的类名字

相同，它们将自动匹配。 

·从列表中删除一个用于匹配的类，点击合成后的名字，在对话框顶部列表中就会重新出现两

类的名字。 

5 当所有需要的类合成以后，点击 “OK”。 

出现 ROC Curve Parameters 对话框。 

6 点击 “Classify by” 按钮，选择是否用最小值和最大值对规则图像进行分类。 

例如，如果你的规则图像来自于最短距离或 SAM 分类器，用最小值进行分类。如果你的规则
图像来自于最大似然分类器，用最大值进行分类。 

7 在 “Min” 和 “Max” 参数文本框里，为 ROC 曲线阈值范围键入最小值和最大值。 

规则图像按照最小值和最大值之间（包括端点）的 N 份等区间阈值进行分类。这些分类中的
每一个与地表真实相对比，成为 ROI 曲线上的一个单一点。例如，如果你的规则图像来自最大似
然分类器，最好选择键入的最小值为“0”，最大值为“1”。 

8 在 “Points per ROC Curve” 文本框里，键入 ROC 曲线上的点数。 

9 在 “ROC curve plots per window” 文本框里，键入每个窗口图示的数量。 

10 选择“Yes”或“No”复选框，确定是否输出探测相对于阈值图示的可能性。 

11 点击“OK”。 

在绘图窗口中，出现 ROC 曲线盒探测曲线的可能性。 
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Ground Truth ROIs (地表真实感兴趣区) 

用地表真实感兴趣区显示一条 ROC 曲线： 

1 选择 Classification > Post Classification > ROC Curves > Using Ground Truth ROIs. 

2 从 Rule Input File 对话框，选择分类规则图像或抽取空间或波谱子集。 

规则图像中选择的每个波段将被用作生成一条 ROC 曲线。 

每个波段对应一个地表真实感兴趣区。地表真实感兴趣区必须先打开，且与选择的规则图像大

小相同的一幅图像相联系。ROIs 将被自动装到 Match Classes Parameters 对话框。 

注意 

如果地表真实图像被定义在一幅大小不同的图像上，你可以用 Basic Tools > Region of Interest > 
Reconcile ROIs 使它们与你的规则图像相匹配，见 Reconcile ROIs. 

3 出现 Match Classes Parameters 对话框时，在两个列表中选择匹配的名字，再点击 “Add 
Combination” 按钮，使地表真实类别与规则图像分类相匹配。 

在对话框底部列表中显示出类之间的结合。如果地表真实图像中的类别与分类图像中的类名字

相同，它们将自动匹配。 

·从列表中删除一个用于匹配的类，点击合成后的名字，在对话框顶部列表中就会重新出现两

类的名字。 

4 当所有需要的类合成以后，点击 “OK”。 

出现 ROC Curve Parameters 对话框。 

5 点击 “Classify by” 按钮，选择是否用最小值和最大值对规则图像进行分类。 

例如，如果你的规则图像来自于最短距离或 SAM 分类器，用最小值进行分类。如果你的规则
图像来自于最大似然分类器，用最大值进行分类。 

6 在 “Min” 和 “Max” 参数文本框里，为 ROC 曲线阈值范围键入最小值和最大值。 

规则图像按照最小值和最大值之间（包括端点）的N份等区间阈值进行分类。这些分类中的每
一个与地表真实相对比，成为 ROI 曲线上的一个单一点。例如，如果你的规则图像来自最大似然
分类器，最好选择键入的最小值为“0”，最大值为“1”。 

7 在 “Points per ROC Curve” 文本框里，键入 ROC 曲线上的点数。 

8 在 “ROC curve plots per window” 文本框里，键入每个窗口图示的数量。 

9 选择 “Yes” 或 “No” 复选框，确定是否输出探测相对于阈值图示的可能性。 

10 点击“OK”。 

在绘图窗口中，出现 ROC 曲线和探测曲线的可能性。 

Clump Classes（类别集群） 

分类图像经常缺少空间相关性（分类区域中斑点或洞的存在）。低通滤波可以用来平滑这些图

像，然而，一个类信息常常被临近类的代码干扰。Clump Classes选项运用形态学算子将临近的类似
的分类区域合并成块解决了这个问题。被选的分类首先用一个扩大的操作合并到一块，然后用参数
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对话框中指定了大小的变换核对分类图像进行侵蚀操作。 

1 选择 Classification > Post Classification > Clump Classes。 

2 出现 Classification Input File 对话框时，选择一个分类图像，若需要，选择一个空间或波谱子
集。 

只有分类后的图像才能被选上（基于图像文件头中描述的文件类型）。 

3 点击 “OK”。 

出现 Clump Parameters 对话框，在 “Select Classes” 文本标签下方的列表中，显示出图像中可
见到的类。   

4 点击列表中显示的类的名字，选择用于运行成块（clumping）的类。 

·选择所有类，点击 “Select All Items”。 

·清除所有类，点击 “Clear All Items”。 

·若选择连续显示的类，则点击这些类的第一个，按住“shift”键，再点击最后一个，以使两
者之间的也都被选上。 

·若选择非连续显示的类，则按住“ctrl”键，再一一点击每个类，最后删除一些不需要的类。 

注意 

没被选上用于聚块（clumping）的类，将毫无变化地出现在输出图像上。 

5 在“Rows”和“Cols”文本框里键入需要的形态学算子大小。 

6 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，在标有“Enter Output Filename”的文本框里键入要输出的文件名；或
用“Choose”按钮选择一个输出文件名。 

10 点击“OK”，开始处理。 

Sieve Classes (筛选类) 

与上面描述类似的一个问题是分类图像中孤岛的出现。再次，低通滤波或其它类型的滤波能被

用来消除这些区域，然而，分类信息将会被临近的分类代码干扰。Sieve Classes 选项通过用斑点分
组消除这些隔离的被分类的像元。这一方法需要观察周围的4个或8个像元，判定一个像元是否与周
围的同类。如果一类中被分组的像元数少于你输入的值，那些像元就会被从类中删除。当用筛选从

一类中删除像元时，将剩下黑像元（未被分类的）。筛选以后，你可以用成块分类功能代替黑色像

元。要筛选分类结果： 

1 选择 Classification > Post Classification > Sieve Classes。 

2 出现 Classification Input File 对话框时，选择一个分类图像，若需要，选择一个空间或波谱子
集。 

只有分类后的图像才能被选上（基于图像文件头中描述的文件类型）。 

3 点击 “OK”。 

出现 Sieve Parameters 对话框，在 “Select Classes” 文本标签下方的列表中，显示出图像中可见
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到的类。 

4 点击列表中显示的类的名字，选择用于筛选的类。 

·选择所有类，点击 “Select All Items”。 

·清除所有类，点击 “Clear All Items”。 

·若选择连续显示的类，则点击这些类的第一个，按住“shift”键，再点击最后一个，以使两
者之间的也都被选上。 

·若选择非连续显示的类，则按住“ctrl”键，再一一点击每个类，最后删除一些不需要的类。 

注意 

没被选上的类，将毫不改变地出现在输出图像上。 

5 在 “Group Min Threshold” 文本框里，输入一类组需要包含的最少像元数。 

任何一组小于这一数值的像元将从类中被删除。 

6 当判定一个类组中像元数时，用按钮选择要观察的邻域像元数（4或8）。 

一个像元周围的 4-邻域由它邻近的两个水平邻域和两个垂直邻域组成。一个像元周围的8-邻域
由与其相邻近的所有元素组成。 

7 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入要输出的文件名。 

8 点击“OK”，开始处理。 

Combine Classes (结合并类) 

结合分类用于在已经分类了的图像中选择性地进行类的结合。你也可以用交互式的Functions菜
单进行类的合并。 

注记结合分类或消除“未被分类”的类有效地删除了那些单个类。 

1 选择 Classification > Post Classification > Combine Classes。 

2 出现 Classification Combine Classes 对话框时，选择一个分类后的图像，或用 ENVI 程序抽
取空间子集。 

3 选择好输入分类的数据以后，点击 “OK”。 

出现 Combine Classes Parameters 对话框。 

Combine Classes Parameters 对话框 

将一个输入类的内容与输出类结合： 

1. 在 Combine Classes Parameters 对话框里，点击 “Input Classes” 列表中的名字，用作一个输
入的类。 

已经选择的类名出现在标有 “Input Class” 斜下方的文本框里。 

2 在 “Output Classes” 列表中点击一个类名作为一个输出的类。 

3 一旦输入类和输出类都已经选好，点击 “Add Combination” 结束选择。 



 285

新的已经合成的类将显示在对话框底部的 “Combined Classes” 列表里。例如，选择 1 区作为
输入，3 区作为输出。则在 “Combined Classes” 列表里就会出现字符串 1区->3区。 

·删除合成后的分类，在 “Combined Classes” 列表里，点击名字，删除合成的类。 

4 点击 “OK” 将输入类的内容与输出类的内容相结合。 

5 出现 Combine Classes Output 对话框时，选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，键入输出文件名。 

类被处理时，出现一个状态窗口，新被分类的图像名将被加在 Available Bands List 中，在那儿
可以用标准 ENVI 程序显示。 

Overlay Classes (叠置类) 

这一功能用一幅彩色合成图或灰阶背景图像生成一幅影像地图，并且类的颜色叠置在一起。它

输出一幅 3-波段的 RGB 图像（可以用标准 ENVI 程序显示）。 

你也可以用 Functions 菜单进行类的叠置。 

注意 

如果你用 8 位彩色，由于颜色量化，分类覆盖图可能显示不正确。然而，若输出，则是正确的。 

1 选择 Classification > Post Classification > Overlay Classes. 

2 出现 Classification Input File 对话框时，选择需要分类的图像，或用ENVI程序抽取空间子集。 

3 出现 Input Background RGB Input Bands 对话框时，顺序点击用于背景图像的红、绿、蓝波段。 

·如果需要一个灰阶背景，为RGB输入点击同样的波谱波段。 

输入文件必须是字节型图像（即文件包含的数值在 0 到 255 之间）。 

4 点击 “OK” 继续。 

5 出现 Class Overlay to RGB Parameters 对话框时，通过点击与列表中显示的类名相联系的按
钮，选择需要叠置在背景图像上的类。 

6 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，键入一个输出文件名。 

7 点击 “OK” 创建类叠置图像。 

Classses To Vector Layers (类到矢量层) 

将选择的类输出到矢量层： 

1 选择 Classification > Post Classification > Classes to Vector Layers。 

2 出现 Raster to Vector Input Band 对话框时，选择需要输入的分类文件，或需要的空间子集。 

3 出现 Raster to Vector Parameters 对话框时，通过点击类名选择需要将其变换为矢量多边形的
类名。 

·选择所有类，点击 “Select All Items”。 
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·清除所有类，点击 “Clear All Items”。 

·若选择连续显示的类，则点击这些类的第一个，按住“shift”键，再点击最后一个，以使两
者之间的也都被选上。 

·若选择非连续显示的类，则按住“ctrl”键，再一一点击每个类，最后删除一些不需要的类。 

4 选择输出到 “File” 或 “Memory” ，若选择输出到 “File”，键入要输出的文件名。 

5 点击“OK”，为每一个选择的类建立一个多边形矢量层。 

每个被选择的类将被存储到独立矢量文件中，这些文件的名字后为 “_1”、“_2” 等，附属于同
一个根文件名。 
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第九章：配准和镶嵌 
ENVI 的图像配准与几何校正工具允许你将图像定位到地理坐标上，并校正它们使其与基图像
几何形状相匹配。图像可以用 Rotate/Flip Data 菜单项在配准以前进行旋转。通过使用全分辨率(主
图像) 和缩放窗口选择地面控制点（GCPs），来进行图像－图像和图像－地图的配准。基图像和未
校正图像的GCPs 的坐标被显示，伴随有特定纠正算法计算的误差项。 

纠正用重采样、缩放和平移，多项式函数或德洛内三角测量（RST）实现。支持的重采样方法
包括最近邻、双线性和立方体卷积。用 ENVI 的多个动态覆盖能力，对基图像和纠正图像进行比较，
可以快速估价配准精度。参阅 ENVI Tutorial Image Georeferencing and Registration 中有关图像配准
的详细描述。镶嵌允许多个图像插入到一个用户定义了大小和坐标的基图像中。独立图像或多波段

图像文件被输入，且放到图像或地图坐标中或用鼠标确定位置。输出的镶嵌特征可以用图幅显示，

且能进行交互式调整。用 ENVI 可以进行虚拟镶嵌，这使你不必将数据的两个副本存到磁盘上。羽
化技术能用于混合图像边界，进行无缝镶嵌。镶嵌模板可以被存储，用于其它图像。 

ENVI 配准、校正和镶嵌功能可以从 ENVI 的主菜单中的 Register 菜单里选择。 

Select Ground Control Points (选择地面控制点) 
在菜单 Register 里的Select Ground Control Points菜单项允许交互式选择地面控制点（GCPs），
并对单一波段图像或多波段文件纠正。这一工具允许对不同控制点和纠正项进行原形恢复和检验。

支持图像 -图像和图像 -地图的配准。详细步骤参见  ENVI Tutorial Image Georeferencing and 
Registration 中的图像配准例子。 

Image-to-Image Registration (图像-图像的配准) 

图像-图像配准需要两幅图像均打开。用每一个显示的缩放窗口选择地面控制点。可以选择
Subpixel (小数的)坐标。一旦已经选择了足够用于定义一个纠正多项式的控制点，就能预测纠正图像
中的 GCP 位置。GCPs 可以被存储或从文件中恢复，彩色标签与 GCP 标记的顺序可以更改（有
关纠正方法的描述，参见“Warping and Resampling Options”部分）。 

1 用 Available Bands List 打开基图像和纠正图像文件，并在两个窗口显示它们。 

2 一旦两幅图像都已经显示，选择 Register > Select Ground Control Points > Image to Image。 

3 出现Image to Image Registration对话框时，在“Base Image:”下面点击需要显示的名字，选择基
图像（参照图像）。 

4 在 “Warp Image:” 下方点击需要显示的名字，选择被纠正的图像。 

5 点击 “OK”， 出现 Ground Control Points Selection 对话框。 

·改变对话框的大小，用鼠标左键点击任何一个角处，拖曳到需要的大小和形状。 

参见 ENVI Tutorial “Image Georeferencing and Registration” 中对图像配准的描述。 

选择地面控制点 
选择地面控制点（GCP 或 Tie Point），通过在缩放窗口定位十字准线，在基图像和纠正图像中
选择像元。像元的左上方是整个数字坐标的原点，自这点向右和向下对应的X值和Y值不断增加。在
缩放窗口中，可得到的像元fraction与缩放系数是成比例的。例如，缩放系数为4x，像元将被分成4
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个亚区。缩放系数为10x时，定位可能只有1/10像元。GCP 标记被放在缩放窗口中，显示出亚像元
(subpixel) 的位置。 

在选择 GCPs 时，亚像元被用于提高准确度。 

·在基础和纠正图像中，选择 GCP 的位置。 

1 为每幅图像移动缩放窗口到需要的 GCP 区域。 

2. 在缩放窗口的一个特定像元上点击鼠标左键，把光标定位在该像元或像元的一部分上。 

注意 

从图像窗口，点击 Functions > Pixel Locator 选择像元位置，并提供整数的 GCP 坐标(见第 227 
页的 “Pixel Locator”)。 

在 Ground Control Points Selection 对话框，被选择处的坐标按 sample、line 顺序分别显示在标
签为 “Base X, Y” 和 “Warp X, Y” 文本区中。 

在缩放窗口处，定位提供了亚像元坐标，因此对话框中显示浮点坐标值。 

3 一旦两幅图像都选择了需要的像元，在 Ground Control Points Selection 对话框中点击“Add 
Point”，将选择的 GCPs 添加到已经选择的X、Y（样本，行）坐标对列表里。 

他们将按基图像(第一个圆括号)、纠正图像(第二个圆括号) 顺序被列出。 

当已经选择了四个或更多个 GCPs，对选择的纠正预测的 X、Y 坐标将显示在第三组圆括号中，
X、Y 的误差被列表显示在第四组圆括号中，RMS 误差列表显示在最后一组圆括号中。 

当 GCPs 已经被添加到列表中时，在两幅图像的缩放窗口里选择的像元（或亚像元）处画一个
标记。选择的 GCP 数将出现在标记附近。标记中心（在十字准线下面）显示了实际的 GCP 位置。 

4 用同样的方法添加其它的 GCPs 。 

使 RMS Error 最小化 
在 Ground Control Points Selection 对话框里，选择的 GCPs 数被显示在文本标签 “Pairs” 旁的

文本框里。一旦选择了足够的 GCPs，运行一次多项式纠正，像元中的X、Y RMS 误差项按照 sample, 
line 顺序列表显示在第四组圆括号中。所有点的总 RMS 误差列表显示在标签为“RMS误差”的文
本框里。为了最好的配准，试图使 RMS 误差最小化。 

用于计算误差的多项式的次数显示在对话框顶部“Degree”的附近，当已经选择了足够的GCPs数
时，多项式的次数可以改变。 

·对于一次多项式，你可以选择 RST (Rotation, Scaling, and Translation) 计算误差。点击“YES” 
切换按钮，选择 RST。 

地面控制点选项 
地表控制点选项与 GCP 列表相互作用，包括编辑和更新位置、开启或关闭点、删除所选择的
点，以及预测点的位置。这些按钮排列在 Ground Control Points Selection 对话框底部。 

·重新移动缩放窗口到任何一个选择的 GCPs 处，在列表上点击需要的GCP，点击“Goto”。 

描述选择的 GCP 轮廓的标记，将被定位在基图像和纠正图像缩放窗口的中心。 

·手动地编辑 GCP 位置： 
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1 在 Ground Control Points 列表中选择要编辑的 GCP，点击“Edit”。 

当前的 X 和 Y 值将出现在 “GCP Edit Point” 对话框里。 

2 在合适文本框里，点击并手工输入需要的数值，以编辑基图像和纠正图像的 X 和 Y 值。 

3 点击 “OK”，在 Ground Control Points Selection 对话框里改变它们。 

如果已经选择了几个 GCPs，将会延迟一段时间，由于 GCPs 需要被重新画上，误差也需重新
计算。 

·配准过程中，有选择性地忽视控制点，选择“On/Off”按钮，点击准备忽略的点 

不用已经选择的点重新计算 RMS 误差和空间转换。在选择的“OFF”点的左边将出现一个星
号，GCP 标记的颜色将发生改变。 

再次打开 GCP，点击列表中的点，再次选择 “On/Off” 按钮。 

·从列表中永久性删除一些单个控制点，点击要被删除的 GCP，点击“Delete.” 

·交互式改变一些特定 GCP 的位置： 

1 在 Ground Control Points Selection 对话框，点击要更新的 GCP。 

2 在基图像与纠正图像中重新定位缩放窗口。 

3 点击“更新”。 

在两个缩放窗口里，以前的 GCP 将被编辑过的 GCP 代替，GCP 的标记位置将被移到当前像
元位置处。 

·用由当前的 GCPs 和选择的多项式次数决定的纠正，预测在纠正图像中一个 GCP 的位置 

1 在基图像中将缩放窗口定位到一个像元处。 

2 点击“预测”。 

纠正图像缩放窗口将被移到预测的像元处。 

3 在纠正图像中选择正确的像元以使预测值更精确。 

4 点击 “Add Point”，输入G CP。 

File 下拉菜单 
在 Ground Control Points Selection 对话框中，File 菜单包括存储和恢复地面控制点文件选项。  

· 退出 Ground Control Points Selection 对话框，选择 File > Cancel. 

如果当前的点还没有存储到一个文件中，用户可以选择退出时保存它们。 

·将GCPs存储到一个ASCII输出文件中： 

1 选择 File > Save GCPs to ASCII. 

2 键入一个扩展名为 .pts 的输出文件，用 “Choose” 按钮选择一个输出文件，点击 “OK” 保
存文件。 

·恢复以前存储的GCPs: 

1 选择 File > Restore GCPs from ASCII. 
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2 输入需要的GCP .pts 文件名。 

·存储到 GCPs，误差输出到一个 ASCII 文件： 

1 选择 File > Save Points w/RMS to ASCII. 

2 输入一个输出文件名，点击 “OK”。 

GCPs 下拉菜单 
在 Ground Control Points Selection 对话框中的 GCPs 菜单，控制了地面控制点的标签、颜色、
顺序，并允许基础和纠正图像翻转。地面控制点用一个十字准线，圆圈和数字被标注在图像上。 

·将关闭/开启标签, 在 GCPs 菜单下，点击 “Label GCPs Off” 或 “Label GCPs On” 旁的切
换按钮。 

·选择 GCP 对是否通过它们的索引 “ID#” 或 “Error”，显示在列表中，点击 “Order GCPs by 
Index” 或 “Order GCPs by Error” 附近的按钮。 

索引 ID 顺序是它们被选择的顺序。误差顺序按照从高到低的顺序列出。 

·删除列表中所有 GCPs，选择 GCPs > Clear GCPs. 

·改变 GCP 标记标签的颜色： 

1 选择 GCPs > Set GCP Colors。 

2 出现 GCP Colors 对话框时，用初始标签为 “Red”（与 “GCPs which are “Off”紧邻）的按钮
菜单（next to the “GCPs which are “On” label），选择 GCP 标记的颜色。 

3 用初始标签为 “Green”（紧邻“GCPs which are “Off”）的下拉菜单，控制 GCPs的标记颜色
（which are turned off） 

· 翻转基础和纠正图像中的GCPs位置，选择GCPs >Reverse Base/Warp. 

这允许纠正基图像，并与纠正图像匹配。 

Options 下拉菜单 
在 Ground Control Points Selection 对话框中的Options菜单，允许从当前显示的波段纠正或从一
个文件纠正。如果你的基图像是地理坐标的，你可以选择图像-地图型纠正。允许你改变输出像元的
大小以及纠正图像中使用的投影类型。 

·用GCPs进行一个标准的配准, 选择Options >Warp Displayed Band 或Warp File. 

·选择图像-地图型纠正，如果基图像是地理坐标系的，选择Options > Warp Displayed Band (as 
Image to Map)或Warp File (作为图像-地图型). 

出现 Registration Parameters 对话框。ENVI 中可利用的各个纠正项细节将在 “Warping and 
Resampling Options” 部分讨论。 

Image-to-Map Registration (图像-地图配准) 

图像-地图配准要求至少由一幅图像是打开的。图像中地面控制点(GCPs)由缩放窗口中的光标选
择。也可以选择亚像元坐标。相应的地图坐标被手工输入或从矢量窗口输入。一旦选择了足够的点

定义一个纠正多项式，在纠正图像中的GCP位置就能预测。GCPs可以被存储和从文件中恢复，GCP
标记的颜色表示和顺序可以改变，详细描述见“Warping and Resampling Options”部分。 
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1 打开一幅图像，显示需要的波段 

2 选择Register > Select Ground Control Points > Image to Map. 

出现Image to Map Registration对话框。 

3 点击对话框中显示的名字，选择要与地图配准的图像。 

注意到如果只打开了一幅图像，则它会自动被选上。 

4 在 “Select Registration Projection” 列表中，点击类型选择要输出的投影。 

·对于 UTM，在标有 “Zone” 的文本框里输入区域号，或点击“Set Zone”按钮，输入经纬度值
计算区域号。 

·对于 State Plane 投影，输入一个区域号或点击“Set Zone”按钮，从列表中（列表显示的有 NOS 
和USGS 区域号）选择区域号。 

·对于那些需要定义数据的投影类型，选择 “Datum” 按钮，并从列表中选择。 

·改变投影单位，点击 “Units” 按钮，并选择需要的单位。 

5 分别在 “X Pixel Size” 和 “Y Pixel Size” 文本框里，输入 X 和 Y 输出像元的大小（用与投
影相对应的单位）。 

6 点击 “OK”。 

出现 Ground Control Points Selection 对话框（见 Basic ENVI Tutorial #2 - Registration (Using 
ENVI) 对图像-地图配准的详细描述）。 

选择地面控制点 
地面控制点（或 Tie Points）的选择类似于图像-图像配准。 

1 像图像-图像的步骤一样，通过移动缩放窗口到需要的图像区域选择 GCPs. 

2 在缩放窗口里特定像元上，点击鼠标左键，定位在指向像元的光标处。 

在 Ground Control Points Selection 对话框里，标签为 “Image X” 和 “Image Y” 的框里出现选
择处的坐标。亚像元坐标用于提高选择 GCPs 的精度。 

3 在地图和图像里选择一般的参考特征（例如在图像和地图中都能看到的道路交叉口），手工
从地图上抽取向东和向北方向或经纬度坐标。 

4 分别在标有“E”和“N”的文本框里，点击适当的位置，手工键入选择的GCPs的地图坐标 

·点击地图投影名附近的按钮，在 “Latitude” 和 “Longitude” 文本框里，输入地图上 GCP 位
置（用经纬度）。 

·在度、分、秒与十进制度数之间变换经纬度值，点击 “DMS< - >DD” 按钮。 

·用负(-)的经度代表西半球，负(-)的纬度代表南半球。 

·恢复地图投影坐标，点击 “Geographic Coordinates” 文本标签附近的按钮。 

·相应的地图投影坐标将自动被计算出来。 

·用矢量数据自动输入地图坐标，见 “Entry of Map GCPs from a Vector Window”部分。 

·用GPS位置自动输入地图坐标，见“GPS-Link”。 
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5 一旦选择完图像中需要的像元，且地图坐标已经输入，点击 Ground Control Points Selection 对
话框中的 “Add Point” 按钮，将点添加到 GCPs 的列表里。 

被选择的位置处坐标显示在 Ground Control Points Selection 对话框的中心，顺序为 “Map X, Y” 
(第一个圆括号), “Image X, Y” (第二个圆括号) 。一旦已经选择了足够的点，对选择的纠正预测的X，
Y坐标显示在第三组圆括号里。X,Y误差和 RMS 误差将被显示在第四和第五个圆括号里。当 GCPs 
已经被添加在列表里，在图像缩放窗口里选择的像元周围将出现一个标记。已经选择的GCP 数将出
现在标记周围。在标记中心（在十字准线的下方）的像元表明了实际的GCP位置。 

6 用同样的方法添加另外的GCPs. 

选择的GCPs数出现在文本标签 “Selected X, Y Pairs:.” 附近。一旦选择了足够的 GCPs 运行一
次多项式纠正，像元中的X、Y RMS 误差项按照 sample, line顺序列表显示在第四组圆括号中。合成
的 RMS 误差显示在最后一个圆括号里。要得到最好的配准，试图使 RMS 误差降至最小。有关编
辑和定位 GCPs的详细信息，见 “Ground Control Points Options” 部分。想了解对 File、GCPs 和 
Options 下拉菜单的描述，见“The File Pulldown Menu”部分。 

从一个矢量窗口，输入地图GCPs 
如果你有一个区域的矢量文件要被地图配准，则地图坐标可以直接从矢量数据抽取到 Ground 

Control Points Selection 对话框。 

1 过程与前述从显示的图像中选择的 GCPs 被纠正是一样的。 

2 不用手工从地图上选择 UTM 控制点，而是将矢量导入一个矢量窗口，用矢量光标定位能力
（鼠标左键）对与图像上选择的特征相对应的一个特征进行定位。 

3 在 Vector Window Params 对话框的底部，点击 “Export” 输入矢量光标的地图坐标，直接到 
Ground Control Points Selection 对话框。 

4 点击 “Add Point” 将选择的点输入到配准。 

纠正图像 
·用 GCPs 运行一个标准的配准，选择 Ground control points selection 对话框中的 Options > 

Warp Displayed Band or Warp File。 

出现Registration Parameters对话框。ENVI 中可利用的各个纠正项细节在  “Warping and 
Resampling Options” 部分有详细阐述。 
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Warping 和 Resampling 选项 
ENVI 提供三个纠正选项：RST(旋转、缩放和平移)、多项式和德洛内三角测量。RST 纠正是
最简单的方法，需要三个或更多的 GCPs 运行图像的旋转、缩放和平移。可以得到 1 次到 n 次多
项式纠正。可以得到的次数依赖于选择的 GCPs 数，这里 #GCPs > (次数+1)2。德洛内三角测量适
于三角到不规则空间 GCPs 和内插数值到输出格网中。 

可利用的重采样方法包括最近邻、双线性和立方体卷积。最近邻重采样运用没有解译的像元建

立纠正图像。双线性重采样用四个像元进行线性内插，以对纠正图像进行重采样。立方体卷积通过

三次多项式对图像进行重采样，用 16 个像元近似正弦函数。值得注意的是立方体卷积重采样比其
它方法速度慢。详情参见下面的参考书。 

Richards, J. A., 1994, Remote Sensing Digital Image Analysis, Springer-Verlag, 

Berlin, p. 340. 

一旦为图像-图像或图像-地图配准选择好 GCPs，用下列步骤指定纠正和重采样方法： 

1 在 Ground Control Points Selection 对话框，选择 Options > 需要的纠正方法。 

2 出现 Registration Parameters 对话框时，从与 “Warp Method” 邻近的下拉菜单中，选择需要
的纠正方法。可以使用 RST (旋转、缩放和平移) 多项式和三角测量纠正方法。 

· 对于多项式纠正，在 “Degree” 文本框里输入需要的次数。可以利用的次数依赖于定义的 
GCPs 数。 

·选择你是否想在三角测量纠正数据的边缘，用单个像元的背景颜色作边界。在 “Zero Edge” 标
签附近，选择“YES”按钮。 

通过选择这一项，你将避免一个“托影(smearing)”效果，它也许出现在纠正图像的边缘，且通
常可以用 ENV I 的特定数据地理坐标定位功能看到。 

3 从 “Resampling” 标签附近的下拉菜单里，选择需要的重采样方法。 

4 在 “Background Value” 文本框里，输入 DN 值，设定背景值（在纠正图像里，DN 值用于
填充没有图像数据显示的区域）。 

输出图像维数按照包含纠正输入图像的边界矩形大小自动设定。所以，输出的纠正图像大小通

常与基图像的大小不一样。输出大小的坐标由基图像坐标决定。所以，左上方拐角处的值典型地不

是（0，0），而是显示的从基图像左上角原点计算的X和Y值。这些偏移值被储存在文件头里，并允
许基图像和纠正图像的动态覆盖（叠置），尽管它们的大小不同。 

5 不考虑输出维数，点击 “Change Output Parameters”，将需要的数值输入到 “Output Image Size” 
文本框里，用于图像-图像配准。 

·对图像-地图配准, 通过点击 “Change Output Parameters” 输入需要的值，改变地图坐标或为
了左上方坐标、像元大小以及图像大小而改变经纬度信息。“Geographic” 投影中，地理坐标用米或
度表示，“Change Projection” 按钮只是输入左上方坐标改变投影。选择地面控制点时，输出图像的
投影就已经设置好。 

注意 

如果你的输出投影是 “Geographic”, 则用 “Change Output Parameters” 对话框，将输出的像元和
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图像大小单位变换成度。 

6 选择输出到 “File” 或 “Memory”. 

·若选择输出到 “File”, 输入一个输出文件名，用 “Choose” 按钮选择一个文件名。 

当纠正被计算时，出现一个状态框。完成以后，纠正图像将出现在 Available Bands 列表中。通
过使用 Open Files List 中的 File > Save Selected File to Disk 选项，一幅纠正图像也从内存中被保
存。 

评价配准精度 

要评价配准精度： 

1 用 Available Bands List，将纠正图像装到一个新的显示窗口。 

2 将显示与基图像窗口链接起来(Functions > Link)，使用动态覆盖图，在基图像和纠正图像之间
闪烁(flicker) (见 “Multiple Dynamic Overlays” 部分)。 
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Warp from Pre-existing GCPs（用已存地面控制点纠正影像） 

Image-to-Image （图像－ 图像） 

·用以前选择的 GCPs，对输入文件进行图像-图像配准： 

1 选择 Register > Warp from Pre-existing GCPs > Image to Image. 

注意 

图像必须是已经打开的。 

2 出现文件选择对话框时，输入 GCP 文件名或从列表中选择合适的GCP输入文件。 

3 出现 Input Warp Image 对话框时，用标准 ENVI 程序选择被纠正的图像，或空间或波谱子
集。 

4 点击“OK”。 

5 出现 Input Base Image 对话框时，选择输入的基图像。 

6 点击“OK”。 

7 出现 Registration Parameters 对话框时，按照前面讲述的去做(见 “Warping and Resampling 
Options” )。 

Image-to-Map（图像－地图） 

·进行图像-地图配准： 

1 选择 Register > Warp from Pre-existing GCPs > Image to Map。 

2 当地面控制点已被选好，且输入了 X、Y 像元值，选择要用的投影类型。 

3 点击“OK”。 

4 出现 Enter GCP Filename 对话框时，选择 .pts 文件和要被纠正的图像。 

5 出现 Input Warp Image 对话框时，用标准 ENVI 程序，选择要被纠正的图像以及空间或波
谱子集。 

6 点击“OK”。 

这时，地图的地理坐标作为基准，而不是图像的像元位置。 

7 出现 Registration Parameters 对话框时，按照前面讲述的步骤进行操作(见“Warping and 
Resampling Options”)。 
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Orthorectification (正射投影纠正) 
ENVI 的正射投影纠正功能允许用一个数字高程模型（DEM）纠正航空像片和 SPOT 数据。正

射投影运用几何投影生成几何上的纠正图像，用于制图和测量。详情见下面参考书： Wolf, R., 1974. 
Elements of Photogrammetry (2nd ed.), McGraw-Hill Inc., New York. 

航空像片正射投影纠正 

航空像片正射投影纠正引进了照相的几何原理、视角和地形学，用单张照片切割术纠正纠正。

正射投影纠正由三步完成。第一步用照相模型、基准标记和图像结点确立内部方位。第二步用地面

控制点、地图坐标和高程确立外部方位，用于将图像和地球表面联结到一起。最后一步由内、外部

方位和一个 DEM 文件进行正射投影纠正。 

Build Interior Orientation (确立内定向) 
确立内部方位使照相模型与航空像片建立了联系。在航空像片、照相基准标记（至少三个）与

照相焦距之间用了结点。航空像片必须显示在图像窗口，用于选择基准标记位置。 

确立内部方位： 

1 显示航空像片图像。 

2 选择 Register > Orthorectification > Build Air Photo Interior Orientation。 

3 如果不只显示一幅图像，选择包含航空像片的显示数。 

出现 Ortho: Build Interior Orientation 对话框。 

·要调整对话框大小，用鼠标左键点击任何一个角落，拖曳到需要的大小和形状。 

4 确定缩放窗口的中心位置（其上方的十字准线），选择一个基准标记位置。在“Fiducial X” 和 
“Fiducial Y” 文本框里，输入基准位置（用成像单位：毫米）。 

5 点击“Add Point”，将位置添加到结点列表里。 

6 继续选择基准标记位置，直到已经输入了三个或更多。 

对话框中列出了结点，显示出结点的 ID#、基准位置、像元位置和误差。总的RMS误差显示在 
“RMS Error”文本框里。误差是基于一个适于点的一次多项式（a first order polynomial）计算的，它
的大小表明了点是否正确输入（如果误差较大，你可能需要编排基准位置）。在对话框底部的按钮

允许你进行编辑、删除以及像配准那样turn on和off点(见“Ground Control Points Options” 部分)。下拉
菜单允许你存储到ASCII文件中，也可以从ASCII文件中恢复。允许你将点的标签打开或关上，以及
改变标签的顺序和颜色(见 “The File Pulldown Menu” 与 “The GCPs Pulldown Menu” 部分)。 

7 从 Ortho: Build Interior Orientation 对话框中，选择 Options > Build Interior Orientation。 

8 输入照相机焦距（单位：毫米），为了保持一致性，键入一个扩展名为 .ort 的输出文件名。 

扩展名为 .ort 的文件包含基准结点的位置, 以及用于成像坐标到图像像元和由图像像元到成
像坐标的仿射转换系数（affine transformation coefficients）。 

Build Exterior Orientation (确立外定向) 
外部方位用于连结航空像片上的点、以及它们已经确定的地图坐标和高程。它是通过选择地面
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控制点、输入相应的地图坐标确立的（类似于图像-地图的配准）。航空像片必须显示在图像窗口，
用于选择地面控制点的位置。 

要确立外部方位： 

1 显示航空像片图像。 

2 选择Register > Orthorectification > Build Air Photo Exterior Orientation。 

3 如果不只显示一幅图像，选择显示数（包含航空像片）。 

4 选择需要的投影，若需要，输入一个区域号。 

选择的投影将被用于正射投影纠正的输出投影，它不必与DEM文件的投影相同。 

·对于 UTM 或 State Plane 投影，点击 “Zone” 按钮，用经纬度计算区域号或从一个列表中选
择。 

·对于 UTM 或地理投影，点击 “Datum” 按钮，改变用到的数据。 

出现Ortho: Build Exterior Orientation对话框。这一对话框类似于图像-地图配准的Ground Control 
Points Selection对话框。 

·重新调整对话框大小，用鼠标左键点击任何一角，拖曳到需要的大小和形状。 

5 确定缩放窗口（十字准线 over航空相片图像中的一个像元）的中心，在合适文本框里输入相
应的地图坐标，选择一个地面控制点(GCP)。 

6 在 “Elev” 文本框里，为选择的像元输入一个高程值。 

7 点击 “Add Point”，将位置添加到 GCPs 列表里。 

8 继续选择地面控制点，直至输入了三个或更多。 

注意 

为了得到最好的结果，建议你用尽可能多的散布在图像上的GCPs。 

对话框中列出了 GCPs，显示出 GCPs 的 ID#、地图位置、像元位置和误差。总的 RMS 误差
显示在 “RMS Error” 文本框里。误差是基于一个适于点的一次多项式计算的。在对话框底部的按钮
允许你进行编辑、删除以及像配准那样开启和关闭点(见 “Ground Control Points Options” 部分)。下
拉菜单允许你存储到 ASCII 文件中，也可以从 ASCII 文件中恢复；允许你将点的标签打开或关上，
以及改变标签的顺序和颜色(见 “The File Pulldown Menu” 与 “The GCPs Pulldown Menu” 部分)。 

9 从 Ortho: Build Exterior Orientation 对话框中，选择 Options > Build Exterior Orientation。 

10 选择确立内部方位时建立的扩展名为 .ort 的参数文件。 

选择的 .ort 文件有附加的地面控制点。 

Orthorectify Air Photo (正射投影纠正航空像片) 
这一步运用上述步骤中生成的方位文件和一个数字高程模型（DEM）进行航空像片的正射投影
纠正。 

1 选择 Register > Orthorectification > Orthorectify Air Photo。 

2 选择输入的航空相片文件名，若需要，选用空间子集。 

3 选择输入数字高程模型(DEM) 文件名。 
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4 用上面描述的步骤选择定位参数文件名(.ort)。 

5 出现 Orthorectification Bounds 对话框时，输入或计算 DEM 文件中包含的最小值。 

·重新调整对话框，用鼠标左键点击图像一角，拖曳到需要的大小和形状。 

·计算 DEM 文件中的最小值： 

A 忽略（跃过）像元，以加快统计计算的速度，在 “Stats X/Y Resize Factor” 文本框里，输入
一个小于1.0的值。 

B 如果你的 DEM 为丢失的数据有一个填充值，将这个值输入到 “DEM Value to Ignore” 文本
框里。 

C 点击 “Calculate Value From File” 按钮。 

将会出现 Calculating Data Min/Max 和 Computing Statistics 状态对话框。一旦统计被计算，
DEM 的最小值将被输入到 “Minimum DEM Value” 文本框。 

最小值只用于判定限制框坐标输出图像的大小（determining the output image size bounding box 
coordinates）。如果默认值是 0，你的 DEM 最小值偏大，则输出的图像就会比输入合适值时有一
个较大的黑边。 

6 点击 “OK”。 

出现 Orthorectification Parameters 对话框。当前，只有最近邻抽样才可以使用。 

7 在合适文本框里，键入 DEM 图像中要被忽略的值。 

8 在 “Background Value” 文本框里，输入 DN 值，设定 “Background Value” (DN 值用于填充
纠正图像中没有图像数据的区域)。 

输出图像维数自动根据包括纠正输入图像的限制矩形设定。所以，输出的纠正图像大小也许与 
DEM 图像大小不同。输出尺寸坐标由外部方位投影坐标决定。 

9 通过点击 “Change Output Parameters”，输入需要的数值，将地图坐标或经纬度信息改变成左
上方坐标，还可以改变像元大小或图像大小。 

注意 

既然当前只能进行最近邻重采样，建议像元大小设置为照片被扫描时的分辨率。“Change 
Projection” 按钮用于改变投影，只输入左上方坐标。图像的输出投影用 Build Exterior Orientation 功
能确定。 

10 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，输入一个输出文件名或用 “Choose” 按钮选择一个文件名。 

11 点击 “OK” 开始正射投影纠正。 

SPOT 正射投影纠正 

SPOT 1A 和 1B 数据可以用数字高程模型进行正射投影纠正。正射投影纠正由两部来完成。第
一步用地面控制点确立内部方位。正射投影纠正用来自SPOT导向文件的卫星ephemeris信息生成初始
轨道和视几何模型。地面控制点(GCPs)用于使轨道模型最优化（通过进行非线性反向）。卫星位置
与SPOT数据中每条行的共线性方程被计算，储存在一个.sot文件中。第二步用轨道模型和一个DEM
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文件进行正射投影纠正，一个像元一个像元地纠正SPOT图像。详情见下面参考书。 

Westin, Torbjorn, 1990. Precision rectification of SPOT imagery, Photogrammetric 

Engineering & Remote Sensing, Vol. 56, No. 2, pp. 247-253. 

Build Exterior Orientation (确立外定向) 
外部定位通过使 SPOT 图像中的点与它们的已知地图坐标和高程连结起来使卫星轨道模型最

优化。类似于图像-地图配准，外部定位是通过选择地面控制点和输入相应地图坐标确立的。SPOT 图
像必须被显示在图像窗口，用于选择地面控制点的位置。 

1 显示 SPOT 图像。 

2 选择 Register > Orthorectification > Build SPOT Exterior Orientation。 

3 如果打开了不只一幅图像，选择显示的数目（包括已打开的 SPOT 图像） 

4 如果需要选择需要的投影，并键入一个区域号。 

选择的投影将被用于正射投影纠正以后的输出投影，不一定与DEM文件中用到的相同。 

·对于 UTM 或 State Plane 投影，点击 “Zone” 按钮，由经纬度计算区域号，或从一个列表中
选择它。 

·对于 UTM 或 Geographic 投影，点击 “Datum” 按钮，编辑用到的数据。 

出现 Ortho: Build Exterior Orientation 对话框。这一对话框类似于图像-地图配准的 Ground 
Control Points Selection 对话框。 

·重新调整对话框大小，用鼠标左键点击任何一个角处，拖曳到需要的大小和形状。 

5 使缩放窗口十字准线定位在 SPOT 图像中的一个像元上，在合适文本框里输入相应的地图坐
标，选择一个地面控制点(GCP)。 

6 在 “Elev” 文本框里，为选择的像元输入一个高程值。 

7 点击 “Add Point”，将位置添加到GCPs列表里。 

8 继续选择地面控制点，直至输入了三个或更多。 

注意 

为了稳定卫星轨道的偏转（inversion），建议你使用尽可能多的GCPs(几十个)散布在图像上的。
尽管正射投影纠正只有三个GCPs就能运行，在卫星轨道偏转中，它也许不稳定。对话框中列出了 
GCPs，显示出 GCPs 的 ID#、地图位置、像元位置和误差。总的 RMS 误差显示在 “RMS Error” 文
本框里。误差是基于一个适于点的一次多项式计算的。在对话框底部的按钮允许你进行编辑、删除

以及像配准那样开启和关闭点(见 “Ground Control Points Options” 部分)。下拉菜单允许你存储到 
ASCII 文件中，也可以从 ASCII 文件中恢复；允许你将点的标签打开或关上，以及改变标签的顺
序和颜色(见 “The File Pulldown Menu” 与 “The GCPs Pulldown Menu” 部分)。 

9 从 Ortho: Build Exterior Orientation 对话框中，选择 Options > Build Exterior Orientation。 

10 选择 SPOT 头文件，通常是 lead_xx.dat 文件，其中 xx 是景数。 

11 为了连贯性，键入一个扩展名为 .sot 的输出文件名。 

.sot 文件是二进制格式，包含了卫星位置以及 SPOT 图像中每条行的共线性方程。这一文件在
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以后步骤中会用到。 

Orthorectify SPOT Image (正射投影纠正 SPOT 图像) 
这一步用上面生成的 .sot 参数文件和一个数字高程模型（DEM）对 SPOT 图像进行正射投影

纠正。 

1 选择 Register > Orthorectification > Orthorectify SPOT Image。 

2 选择输入的 SPOT 图像文件名，若需要，抽取空间子集。 

3 选择输入数字高程模型(DEM) 文件名。 

4 选择前面建立的垂直参数文件名(.sot)。 

5 选择 SPOT 头文件名。 

6 出现 Orthorectification Bounds 对话框时，输入或计算 DEM 文件中包含的近似最小值。 

·计算来自 DEM 文件的最小值： 

A 忽略（跃过）像元，以加快统计计算的速度，在 “Stats X/Y Resize Factor” 文本框里，输入
一个小于 1.0 的值。 

B 如果你的 DEM 为丢失的数据有一个填充值，将这个值输入到 “DEM Value to Ignore” 文本
框里。 

C 点击 “Calculate Value From File” 按钮。 

将会出现 Calculating Data Min/Max and Computing Statistics 状态对话框。一旦统计被计算，
DEM 的最小值将被输入到 “Minimum DEM Value” 文本框。 

最小值只用于判定限制框坐标输出图像的大小（determining the output image size bounding box 
coordinates）。如果默认值是0，你的DEM最小值偏大，则输出的图像就会比输入合适值时有一个较
大的黑边。 

7 点击 “OK”。 

出现 Orthorectification Parameters 对话框。当前，只有最近邻抽样才可以使用。 

8 在合适文本框里，键入 DEM 图像中要被忽略的值 

9 在 “Background Value” 文本框里，输入 DN 值，设定 “Background Value” (DN 值用于填充
纠正图像中没有图像数据的区域)。 

输出图像维数自动根据包括纠正输入图像的限制矩形设定。所以，输出的纠正图像大小也许与 
DEM 图像大小不同。输出尺寸坐标由外部方位投影坐标决定。 

10 通过点击 “Change Output Parameters”，输入需要的数值，将地图坐标或经纬度信息改变成左
上方坐标，还可以改变像元大小或图像大小。 

注意 

既然当前只能进行最近邻重采样，建议像元大小设置为它的原始格式分辨率（即10或20米，在 
SPOT 图像中）。 

“Change Projection” 按钮用于改变投影，只输入左上方坐标。图像的输出投影用 Build Exterior 
Orientation 功能确定。 
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11 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，输入一个输出文件名或用 “Choose” 按钮选择一个文件名。 

12 点击 “OK” 开始正射投影纠正。 
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Rotate/Flip Data (旋转/镜像数据) 
在配准以前，将图像旋转或翻转到近似的同一方向通常是比较容易的。这简化了地面控制点的

选择。 

1 选择 Register > Rotate/Flip Data。 

2 出现标准输入文件对话框时，用标准 ENVI 程序选择文件或抽取任何空间波谱子集 

3 出现 Rotation Parameters 对话框时，选择 “standard rotation” (0, 90, 180,或270度)和/或转置
（transpose）或键入确切的旋转角度，选择一个重采样算法 

在对话框的右边黑色托动器具里的字母和数字将显示出选择的旋转。 

4 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”, 键入一个输出文件名。 

5 在 “Background Value” 文本框里，键入需要的背景值（用十进制）。 

6 点击 “OK” 进行旋转。 

这一功能也可以从 Utilities 菜单启动。详情见 “Rotate/Flip Images” 部分。 
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Image Mosaicking (图像镶嵌) 
镶嵌可以被用于叠置两个或多个有重叠区域（尤其是地理坐标）的图像或将不同的非重叠图像

镶嵌在一起再图示输出（尤其是以像元为基础的）。单个波段或整个文件可以被镶嵌。在镶嵌时，

图像基于像元或地图坐标或用鼠标放置。Feather 技术可以被用于结合图像边缘。镶嵌过的图像可以
被存为一个虚拟的镶嵌图，以避免将数据的额外副本存储到磁盘文件中。镶嵌模版可以被存储，以

及从其它输入的文件中恢复。 

在 Register 菜单下，Mosaic Images 菜单项产生 Image Mosaicking 对话框。选择 Pixel Based 
Images 或 Georeferenced Images可以得到略微的差异。 

Pixel-Based Mosaics (基于像元的镶嵌) 

进行基于像元的镶嵌： 

1 选择 Register > Mosaic Images > Pixel Based Images。 

·若出现 Mosaic Input File 对话框，见下面的“Import Images”程序。 

2 出现 Pixel Based Image Mosaicking 对话框，在 “X Size” 和 “Y Size” 文本框里，键入需要输
出的图像大小（用像元）。X 代表样本（像元），Y 代表图像的行。 

输入图像 
用 Import 下拉菜单选择用于镶嵌的输入波段。 

1 在 Pixel Based Image Mosaicking 对话框，选择 Import > Import file with Feathering 或 Import 
file without Feathering. 

2 出现 Mosaic Input File 对话框时，选择文件或任意部分子集。 

·若选择连续显示的一组文件，则点击这些文件的第一个，按住“shift”键，再点击最后一个，
以使两者之间的也都被选上。 

·若选择非连续显示的文件，则按住“ctrl”键，一一点击需要的文件，再点击删除一些不需要
的文件。 

注意 

独立波段或整个文件都可以进行镶嵌。 

·在 Mosaic Input File 对话框，通过点击 Options > Select by Band 选择独立波段。 

·如果用到了 Import file with Feathering 项，出现具有 Feathering 选项的 Mosaic Entry Input 
Parameters 对话框(见 “Feathering” 部分)。 

一旦你选择了用于镶嵌的第一个输入文件，象征输入图像大小的彩色图表将出现再对话框右边

的拖曳小器具里。 

3 输入需要的其它文件。 

图名、图表颜色以及图像左上角的坐标被显示在对话框的中心。 
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图像定位 
输入图像的左上角坐标显示在对话框中央的图名附近的园括号中。在文件头中有 “x start”（x 起

始值）和 “y start”（y 起始值）的图像自动被放置在镶嵌板上（伴随限定的偏移量）。 

在 Pixel Based Image Mosaicking 对话框中，选择下列选项： 

·将新的条目最初放在镶嵌图中坐标为(1, 1,)处，选择 Options > Do Not Use Image Offset。 

·对位置坐标进行编辑，点击任何一个显示的图像，在标有 “X0” 和 “Y0” 的文本框里输入需
要的左上方坐标。 

当前选择的图像数将被显示在标有 “#” 的文本框里。对 “X0” 和 “Y0” 值的任何更改都将起作
用。 

·图像可以在镶嵌图中移动位置，通过点击合适的图像边缘，用鼠标左键拖曳到需要的位置。 

·将图像恰切地镶嵌，使它们 ”snap” 到一个指定大小的经纬网中，在对话框右上角设定 “snap” 
系数。 

例如，”snap” 系数为”5”，将使5个像元镶嵌到同一位置。”snap” 系数为 “1”，则不进行镶嵌。 

Options 下拉菜单 
用选项菜单选择图像放置项、编辑镶嵌参数，删除图像。 

·为放置图像设定一个 snap 值： 

1 选择Options > Set Snap Value。 

2 在 Mosaic Window Snap Value 对话框，点击箭头增量按钮，选择一个数值。 

3 点击 “OK”。 

一个snap值使图像被均匀放置更加容易，Snap 值指定为屏幕 snap 值，这意味着其单位对话框
屏幕用到的，而不是图像像元。所以，一个 20 的 snap 值并不意味着输入的图像将置于每 20 个
像元的间隔中。 

·镶嵌过程中，将一幅图像置于其它图像的前面： 

1 在图像列表中，点击需要的图像。 

2 选择 Options > Percolate Entry。 

·或用鼠标的中间按钮点击一幅图像的拖曳小器具，以将它置于其它图像的最前面。 

·在输出的镶嵌图中，将当前显示的图像置于中央（作为一组），用鼠标左键选择 Options > Center 
Entries 或在图形轮廓的外面双击。 

每个图像不是单独地置于中央的，但是打开的镶嵌区域内布局处于中央位置。 

·编辑镶嵌参数，控制羽化参数： 

1 点击图像名，选择 Options > Edit Entry. 

出现 Mosaic Entry Input Parameters 对话框，在这里你可以输入一个要忽略的背景数据值，编辑
偏移值和羽化选项。 

2 选择下列步骤： 
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·使图像中具有背景值的像元清晰地显示在下面的图像（用于常数 DN 值边缘镶嵌），在 
“Background Data Value to Ignore” 文本框里键入需要的数值。 

·为选择的图像改变偏移量，在 “Image Offset X0/Y0” 文本框键入需要的值。 

·关于羽化的详细信息，请参见 “Feathering” 部分 。 

·用同样大小的图像代替当前图像： 

1 点击图像名，选择 Options > Replace Entry。 

2 选择新的图像文件名，点击 “OK”。 

新图像被放在与原始图像一样的位置。 

·根据输入的边缘像元，设定镶嵌的大小： 

1 选择Options > Reset Mosaic Size。 

2 在Mosaic Reset Size对话框，点击箭头增量按钮，选择重设边缘的值 

边缘值是将要被加在镶嵌的边缘的像元数。 

3 点击“OK”。 

·将你的输入进行组合，将他们锁在一起，选择 Options > Lock All Entries: On. 

锁定的输入可以作为一个统一体移动。 

·解开组合或取消组合，选择 Options > Lock All Entries: Off。 

提示 

要切换自动跟踪特性开启和关闭，用鼠标右键点击图像区域的任何一处。 

·从镶嵌中删除图像，在列表中点击图像名，选择Options > Delete Entry. 

在文件头中具有 “x start” 和 “y start” 值的图像被自动放到限定了偏移量的镶嵌图中。 

·在右上角使图像置于最初位置，选择 Options > Do Not Use Image Offset。 

·用文件头偏移量放置图像，选择 Options > Use Image Offset. 

File 下拉菜单 
File菜单允许你应用选项存储和恢复镶嵌模版，建立一个虚拟镶嵌文件。 

·将镶嵌设置存为ASCII文件： 

1 选择 File > Save Template。 

2 在 Output Mosaic Template 对话框，键入一个输出文件名，为保持一致，用扩展名 .mos 。 

文件将包含镶嵌大小、文件名、用到的波段、数据维数和镶嵌信息。“Info”文本框有 X 和 Y 偏
移量、边缘羽化距离、cutline 羽化距离以及要忽略的数据值。这一模板文件是一个虚拟的镶嵌文件。 

模板文件中参与镶嵌的文件以及用到的波段都可以被编辑修改。 

·恢复以前存储的模板： 

1 选择File > Restore Template 

2 出现ENVI文件选择对话框，对话框中有默认的扩展名为 .mos 的文件列表，选择需要装载的
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模板和镶嵌的文件。 

·用新图像代替文件，用 Options > Replace Entry或在 ASCII .mos 文件中编辑文件名。 

·退出图像镶嵌，选择 File > Cancel。 

虚拟镶嵌 
除非用到羽化，没必要将镶嵌存到一个输出文件中。ENVI 运用象一个图像文件一样的虚拟镶

嵌文件（被存为虚拟的模板）。当打开一个虚拟的镶嵌模板时，它打开构成镶嵌的独立图像文件，

并on-the-fly地将它们镶嵌到一块。然而，不能on-the-fly.地进行羽化。镶嵌的模板文件，象其它图像
一样，可以在 ENVI 中显示、注记、拉伸等。用一个虚拟的镶嵌就不必为同一图像存储两个副本，
从而节省磁盘空间。 

·建立一个虚拟的模板： 

1 选择File > Save Template，键入一个输出文件名。 

2 通过点击File > Open Image File ，选择 .mos 文件，打开虚拟镶嵌。 

在 Available Bands List 中，将会出现镶嵌模板文件，可以被用于处理功能的输入。 

建立镶嵌 
 

注意 

除非用到羽化，没必要将镶嵌存到一个输出文件中。镶嵌可以被存为虚拟镶嵌，从而节省时间

和磁盘空间。 

当所有用于镶嵌的图像都被放好以后： 

1 选择File > Apply. 

出现Mosaic Parameters对话框。 

2 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，输入一个输出文件名。 

3 为输出镶嵌选择一个需要的背景值（DN 值用于没有图像的区域）。 

4 点击 “OK” 开始镶嵌操作。 

出现一个状态窗口，显示完成的百分比。当镶嵌的建立已经完成时，镶嵌名将出现在 Available 
Bands List 中。 

Georeferenced 镶嵌 

地理坐标定位的（Georeferenced）镶嵌被用于自动叠置多幅地理坐标图像。 

多分辨率地理坐标图像可以被镶嵌，羽化过去常常用于结合图像边缘，输入的地理坐标的图像

与非地理坐标的图像可以进行同一次镶嵌。如果没有用羽化和多重分辨率图像，镶嵌模板可以被存

储和恢复，以及建立一个虚拟的镶嵌。 

·用地理坐标图像建立镶嵌，选择 Register > Mosaic Images > Georeferenced Images。 

出现 Georeferenced Image Mosaicking 对话框，允许你设定输出的镶嵌参数，选择镶嵌图像。 
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输入图像 
第一个输入的图像必定是一幅地理坐标的图像，镶嵌大小将随图像大小设定。选择用于镶嵌的

输入波段： 

1 在 Georeferenced Image Mosaicking 对话框，选择 Import > Import file with Feathering or 
Import file without Feathering。 

2 出现Mosaic Input File时，选择一个文件或多个文件，运行需要的空间子集。 

·若选择连续显示的一组文件，则点击这些文件的第一个，按住“shift”键，再点击最后一个，
以使两者之间的也都被选上。 

·若选择非连续显示的文件，则按住“ctrl”键，一一点击需要的文件，再点击删除一些不需要
的文件。 

注意 

单个波段或整个文件都可以进行镶嵌。 

·如果用到了 Import file with Feathering 项，出现具有羽化选项的 Mosaic Entry Input Parameters 
对话框(见 “Feathering” 部分)。 

一旦你选择了用于镶嵌的第一个输入文件，象征输入图像大小的彩色图表将出现再对话框右边

的拖曳小器具里。 

3 根据需要输入另外一个用于镶嵌的地理坐标图像 

地理坐标图像将自动被放置在输出的镶嵌中（根据它们的地理坐标）。 

新的图像将被放置在其它图像前面，镶嵌大小自动地调整到适应新图像。如果输入一个合适的

地理坐标图像（在当前镶嵌的图像范围之外标有地图坐标），镶嵌大小将自动被改变到包括新的图

像位置。 

不允许编辑或转换地图坐标。 

对于多分辨率镶嵌，输出像元大小被输入（the output pixel size is entered on output），ENVI 自
动对要匹配的低分辨率图像进行重采样。 

4 根据需要输入参与镶嵌的另外的非地理坐标图像。 

·出现 Mosaic Entry Input Parameters 对话框时，若需要，输入要被忽略的背景值以及图像偏移
值（用地理坐标单位，即米）。 

图像位置不能运用图表盒象以像元为基础的镶嵌一样进行调整。 

每幅图像被列表显示在对话框（具有彩色图表盒与羽化参数）中央。 

Options 下拉菜单 
在 Georeferenced Image Mosaicking 对话框中的 Options 菜单允许编辑镶嵌参数盒删除图像： 

·控制羽化参数，输入要被忽略掉的背景数据值以及非地理坐标图像的偏移量。  

1 点击图像名，选择 Options > Edit Entry. 

2 出现 Mosaic Entry Input Parameters 对话框时，在 “Background Data Value to Ignore” 文本框
里输入需要的值，以使图像中具有背景值的像元清晰地显示在下面的图像（用于镶嵌具有常数 DN 
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值边缘的图像）。 

3 对于非地理坐标图像，用地理单位（米）输入图像偏移值 X 和 Y 。 

·用同样大小的一幅新图像代替当前图像： 

1 点击列表中一个图像名，选择 Options > Replace Entry。 

2 选择一个新的图像文件名，点击 “OK”。 

新图像被放在与原始图像一样的位置。 

·从镶嵌中删除图像，点击列表中图像名，选择 Options > Delete Entry。 

·从镶嵌对话框中删除所有图像，选择 Options > Clear All Entries. 

File 下拉菜单 
File 菜单允许你应用你的选项存储和恢复镶嵌模板，并建立一个新的虚拟镶嵌文件。 

·将镶嵌设置存为 ASCII 文件： 

1 选择 File > Save Template。 

2 在 Output Mosaic Template 对话框，输入一个输出文件名，为保持一致，用扩展名 .mos 。 

文件将包含镶嵌大小、文件名、用到的波段、数据维数和镶嵌信息。“Info”文本框有 X 和 Y 偏
移量、边缘羽化距离、cutline 羽化距离以及要忽略的数据值。这一模板文件是一个虚拟的镶嵌文件。
模板文件中参与镶嵌的文件以及用到的波段都可以被编辑修改。 

·恢复以前存储的模板： 

1 选择 File > Restore Template。 

2 出现 ENVI 文件选择对话框，对话框中有默认的扩展名为.mos的文件列表，选择需要装载的
模板和镶嵌的文件 

·用新图像代替文件，用 Options > Replace Entry或在 ASCII .mos 文件中编辑文件名。 

·退出图像镶嵌，选择 File > Cancel。 

虚拟镶嵌 
除非用到羽化，没必要将镶嵌存到一个输出文件中。ENVI运用象一个图像文件一样的虚拟镶嵌

文件（被存为虚拟的模板）。当打开一个虚拟的镶嵌模板时，它打开构成镶嵌的独立图像文件，并

on-the-fly地将它们镶嵌到一块。然而，不能on-the-fly地进行羽化或多分辨率重采样。镶嵌的模板文
件，象其它图像一样，可以在ENVI中显示、注记、伸展（stretched）等。用一个虚拟的镶嵌就不必
为同一图像存储两个副本，从而节省磁盘空间。 

·建立一个虚拟的模板： 

1 选择File > Save Template，键入一个输出文件名 

2 通过点击 File > Open Image File ，选择 .mos 文件，打开虚拟镶嵌。 

在 Available Bands List 中，将会出现镶嵌模板文件，可以被用于处理功能的输入。 

建立镶嵌 
除非用到羽化或多分辨率数据，没必要将镶嵌存到一个输出文件中。镶嵌可以被存为虚拟镶嵌，
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从而节省时间和磁盘空间。 

当所有用于镶嵌的图像都已选好且参数也已经设定以后： 

1 选择 File > Apply. 

出现 Mosaic Parameters 对话框，输出像元大小默认的是输入图像的最高分辨率。ENVI 将自动
对要匹配的较低分辨率的图像进行重采样。镶嵌中，非地理坐标的图像将不被重采样。 

·改变输出像元大小，在合适文本框里输入需要的大小（用地理单位：米、度等）。 

2 从 “Resampling” 菜单里，选择多分辨率重采样类型、最近邻、双线性或立方体卷积。 

建议采用最近邻重采样。 

3 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，输入一个输出文件名。 

4 为输出镶嵌选择一个需要的背景 DN 值。 

5 点击“OK”开始镶嵌操作 

出现一个状态窗口，显示完成的百分比。当镶嵌建立已经完成时，镶嵌名将出现在 Available 
Bands List 中。 

Feathering (羽化) 

无论是基于像元的，还是基于地理坐标的镶嵌都有羽化输入图像的叠置区域边界的项。羽化通

过在用户限定的距离内边缘羽化或cutline羽化将叠置区域的边缘相结合。  

·镶嵌图像时运用羽化。输入没有羽化的底部图像，用羽化输入叠置的图像，根据需要选择边

缘羽化或cutline羽化。 

Edge Feathering (边缘羽化) 
边缘羽化用一个指定的距离将一个上部图像的边缘与其下面的图像的边缘相结合。指定的距离

用于建立一个线性斜坡，它将平分两幅图像穿过指定距离。例如，如果指定距离是20个像元，边缘
处上面图像的0%用于结合，下面图像的100%用于输出图像。当指定距离从边缘处输入到图像中时，
上面图像的100%用于输出图像，下面图像用到了0%，每幅图像的50%用于从边缘处输出（每幅图像
10个像元）。 

1 在 Image Mosaicking 对话框，选择Import > Import file with Feathering或Options > Edit Entry. 

2 在 Mosaic Entry Input Parameters 对话框，在结合图像边界的文本框里，指定“Edge feathering 
distance (pixels)”. 

Cutline Feathering 
Cutline 羽化运用用户定义的cutline将两个叠置的图像边缘结合在一起。指定的距离被用于沿着

cutline结合图像。 

注意 

镶嵌以前，必须用注记工具限定Cutlines。 

注记文件必须包含一条限定cutline的折行（从边缘到边缘画的）和一个标志图像区域被切断的
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符号。指定的距离用于建立一个线性斜坡，它从cutline向外穿过距离，平分两幅图像（create a linear 
ramp that averages the two images across that distance from the cutline outwards）。例如，如果指定距离
是20个像元，在cutline处结合用到了上面图像的100%，下面图像的0%用于输出图像。在远离cutline
的指定距离内，上面图像的0%用于输出图像，下面图像用到了100%，每幅图像的50%用于从cutline
处输出（每幅图像10个像元）。 

1 在 Image Mosaicking 对话框，选择 Import > Import file with Feathering 或Options > Edit 
Entry。 

2 出现 Mosaic Entry Input Parameters 对话框时，点击 “Ann File” 按钮，选择一个注记文件。
在 “Cutline feathering distance (pixels)” 文本框里，指定结合图像边界的距离。 
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GPS-Link（GPS 接口） 
ENVI 支持 PCs（Microsoft Windows 95, Windows 98 或 Windows NT）上的 GPS-链接。ENVI 
可以从一个 GPS 单位直接读取国家海洋电子协会（National Marine Electronics Association）0183 数
据格式。GPS 必须手工设定这一模式。 

在用户设定的一个时间间隔内，ENVI 能自动收集 GPS 的位置，收集单个位置，并自动跟踪
一幅显示的图像上的位置。GPS 点能被存为 ASCII 文件、ENVI 矢量文件(.evf)、或输出到配准
的 Ground Control Points Selection 对话框。 

1 选择 Register > GPS-Link。 

出现 GPS-Link Serial Parameters 对话框。 

2 从 “Serial Port” 按钮菜单，选择 GPS 接收器被关闭的一系列端口。 

3 从相应按钮菜单中，选择合适的 GPS 波特率、数据比特、停止位、奇偶类型以及奇偶校验
许可。 

4 点击 “Select GPS Datum.”。 

5 在 Select Datum 对话框，选择数据类型（你的 GPS 单位用于收集数据的），点击 “OK”。 

6 在 GPS-Link Serial Parameters 对话框，点击“OK” 

出现 ENVI GPS-Link 对话框。 

7 点击 “Get Location” 搜索当前的位置。 

经纬度和搜索时间出现在对话框里。 

8 点击 “Get Location” 按钮，再次搜索其它位置。 

出现在对话框列表里。 

9 选择下列选项： 

·输入一个特定点的文本： 

A 在位置列表中，点击一个位置，点击 “Edit”。 

B 在出现的对话框里，输入信息，点击 “OK”。 

当点被保存到一个 ASCII 文件时，文本和点一起被输出。 

·去与显示图像相联系的某一点处，在列表中点击需要的点，点击 “Goto”。 

·将一个特定点输出到一个打开的图像-地图配准的 Ground Control Points Selection 对话框，在
列表中点击需要的特定点，点击 “Export”。 

特定点的位置出现在配准对话框里。 

·从列表中删除已经选择的特定点，点击需要的位置点，点击 “Delete”。 

Options 下拉菜单 
你可以将 GPS-Link 与一个包含一幅地理坐标图像的显示窗口联系起来。窗口中光标位置跟随
着 GPS 位置。 
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·将GPS –Link与一个显示窗口连接起来： 

注意 

显示的图像一定是一幅地理坐标的图像。. 

1 选择 Options > Attach to display。 

出现 Attach GPS-Link to Display 对话框。 

2 选择需要显示的数量，点击 “OK”。 

当 GPS 位置被更新时，缩放窗口的中心像元移动到它们的位置处。 

·删除列表中所有点，选择 Options > Clear Points。 

·将“设定的时间间隔内自动收集点”功能打开或关上，选择 Options > Auto Update:On/Off。 

·设定自动聚集点的时间间隔，选择 Options > Set Retrieval Rate. 输入需要的时间间隔（单位：
秒）。 

·将“收集点”功能打开或关上，选择 Options > Collect Points:On/Off。 

·当用自动更新模式时，选择 Collect Points: On/Off 停止搜索点。 

·显示收集到的位置（用十进制度数或度、分、秒式），选择Options > Display Points:DD/DMS。 

File 下拉菜单 
File菜单下，选择下列选项： 

·将已经收集到的 GPS 位置存储为一个 ASCII 文件: 

1 选择File > Save Points to ASCII 

2 键入或选择一个输出文件名 

ASCII文件包括经纬度、Julian 时间和一些用 “Edit” 按钮键入的文本。 

·将收集到的 GPS 位置存储为一个 ENVI 矢量文件： 

1 选择File > Save Points to EVF 

出现 Save GPS Points to EVF 对话框。 

2 选择合适的按钮，将每个点存为一条独立的记录、将所有点存为一个记录或将所有点存成一
条折线。 

3 输入一个层名。 

4 选择输出到 “File” 或 “Memory”，点击 “OK”。 

·退出GPS-Link, 选择File > Cancel.  
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Convert Map Projection (转换地图投影) 
用这一功能对地理坐标定位的文件进行地图投影转换。这一转换通过运用配准功能纠正文件来

完成（详情见 “Convert Map Projection” 部分）。 

1 选择 Register > Convert Map Projection or Utilities > Map Projection Tools > Convert Map 
Projection。 

2 选择输入的地理坐标图像，点击 “OK”。 

出现 Convert Map Projection Parameters 对话框，输入的投影显示在对话框顶部，在 “Select 
Output Map Projection” 下方，列表显示出来自 map_proj.txt 文件的可利用的输出投影(见 “ENVI 
Map Projections File” 部分)。 

3 在 “Select Output Map Projection” 列表里，点击需要的类型，选择输出投影。 

·对于 UTM，在标有“Zone”的文本框里，输入区域号，或点击 “Set Zone” 按钮，键入经纬
度值，计算出区域号。 

·对于 State Plane 投影，输入一个区域号或点击 “Set Zone” 按钮，从列表中选择需要的带名。
在带名附近显示了 NOS 和 USGS 区域号。 

·对于那些需要定义一个数据的投影类型，选择 “Datum” 按钮，并从列表中选择。 

4 点击 “Units” 按钮。 

5 在Select Projection Units对话框中，选择需要的单位，点击“OK” 

地图投影通过用一个经纬网的控制点纠正文件得到转换。 

6 在 “Number of Warp Points X/Y” 文本框里，输入数值，以限定在X和Y方向上要用到的控制
点数。 

7 点击 “OK”。 

8 出现标准 Registration Parameters 对话框，选择纠正方法(RST、Polynomial 或 Triangulation)、
重采样方法(Nearest Neighbor、Bilinear 或 Cubic Convolution)，键入输出文件名（见 “Warping and 
Resampling Options” 部分） 

9 点击 “OK” 开始地图投影转换。 
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Georeference AVHRR Data 
AVHRR 数据、校准结果以及海平面温度图像能用来自 AVHRR 数据本身的信息进行地理坐标

定位。每行数据有 51 个经纬度值，它们用于地理坐标定位。一旦原始的AVHRR数据被地理坐标定
位，需要计算校准和海平面温度的头信息将不在新的 ENVI 文件头中。所以，应当在AVHRR校准
和海平面温度被计算以后进行地理坐标定位。 

地理坐标定位 AVHRR数据： 

1 选择 Register > Georeference AVHRR Data。 

2 选择需要输入的数据文件，根据需要可以用空间和波谱子集 

·如果输入的数据文件没有 AVHRR 的文件类型，就会出现另外一个输入文件对话框，用于选
择原始的 AVHRR 文件。 

地理坐标定位信息从原始的 AVHRR 文件中抽取。 

3 出现 Georeference AVHRR Parameters 对话框时，从列表中选择需要的输出地图投影。 

·对于 UTM，在标有“Zone”的文本框里，输入区域号，或点击 “Set Zone” 按钮，键入经纬
度值，计算出区域号。 

·对于 State Plane 投影，输入一个区域号或点击 “Set Zone” 按钮，从列表中选择需要的带名。
在带名附近显示了 NOS 和 USGS 区域号。 

·对于那些需要定义一个数据的投影类型，选择 “Datum” 按钮，并从列表中选择。 

4 点击 “Units” 按钮。 

5 在 Select Projection Units 对话框，选择需要的单位，点击 “OK”。 

6 在相应的 “X” 和 “Y” 文本框里，输入 X 和 Y 纠正点数。 

X 方向上直到 51 个点，Y 方向上直到等于行数，才能进行地理坐标定位。如果输入的纠正点
较少，它们均匀地散布在整个图像中。从时间上考虑，建议使用不超过10x10个点。 

注意 

使用许多的纠正点，将显著地增加纠正处理时间。 

7 点击“OK”。 

8 出现标准 Registration Parameters 对话框，它允许你选择纠正和重采样的方法，以及改变输出
的维数（见 “Warping and Resampling Options” 部分）。 

9 选择输出到 “File” 或 “Memory”，点击 “OK”。 

·如果选择输出到 “File”，在合适文本框里，键入输出文件名，或用 “Choose” 按钮选择一个
输出文件名。 
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Georeference SeaWiFS Data 
ENVI允许你地理坐标定位 SeaWiFS 数据（包括CEOS和HDF格式）。ENVI 为CEOS 或 HDF 格

式的 SeaWiFS 数据抽取头信息，并基于地球和卫星轨道的完全的几何模型对数据进行精确的地理
编码。 

1 选择 Register > Georeference HDF SeaWiFS 或 Register > Georeference CEOS SeaWiFS. 

2 出现 SeaWiFS Input File 对话框时，选择一个图像文件，根据需要确定空间或波谱子集。 

你的输入文件可以是 ENVI 文件。 

3 如果你的输入文件不是 HDF 格式，选择相关的 HDF 或 CEOS 注记文件，从中读取头信息。 

4 出现 Georeference SeaWiFS Parameters 对话框时，从列表中选择需要的输出地图投影。 

·对于 UTM，在标有“Zone”的文本框里，输入区域号；或点击 “Set Zone” 按钮，键入经纬
度值，计算出区域号。 

·对于 State Plane 投影，输入一个区域号，或点击 “Set Zone” 按钮从列表中选择需要的区域
名。在带名附近显示了 NOS 和 USGS 区域号。 

·对于那些需要定义一个数据的投影类型，选择 “Datum” 按钮，并从列表中选择。 

·变换投影单位，点击 “Units” 按钮，选择需要的单位。 

5 在相应的 “X” 和 “Y” 文本框里，输入 X 和 Y 纠正点数。 

你可以选择纠正点，直到等于你图像中的样本数和行数。如果你选择的纠正点较少，它们将均

匀地散布在整个图像中。考虑到时间因素，建议使用不超过10x10个点。 

·将纠正点存为 GCP 文件，输入或选择一个输出文件名。 

注意 

运用较多的纠正点能大大增加用于纠正的时间。 

6 点击 “OK”。 

7 出现标准 Registration Parameters 对话框，若需要，选择纠正和重采样方法，以及改变输出维
数（见 “Warping and Resampling Options” 部分）。 

注意 

普遍认为：三角测量能生成最精确的结果，但是它的速度要比多项式纠正慢得多。 

8 选择输出到 “File” 或 “Memory”，点击 “OK”。 

·如果选择输出到 “File”，在合适文本框里，键入或选择输出文件名。 

详情见 “SeaWiFS Utilities” 部分。 
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第十章：Spectral Tools (波谱工具) 
ENVI 为分析多波谱的和高波谱的图像以及其它的波谱数据类型提供了几种专用工具。这些工
具包括进行重采样、查看波谱库、抽取波谱片段、运行波谱数学、判定波谱终端单元、可视化 N 维
波谱数据、波谱分类、线性波谱分类（unmixing）、匹配滤波、闭联集消除（continuum removal）以
及波谱特征拟合。这些可以用 ENVI 主菜单中 Spectral Tools 菜单来实现。运用 ENVI 的一些波谱
工具，参见 ENVI Hyperspectral Tutorials 中详细描述。 

Spectral Libraries (波谱谱库) 
ENVI包括许多公共用的波谱库以及跟它们在一起的工具。波谱库是在喷气推进实验室（Jet 

Propulsion Laboratory）建立的。它包括三种不同粒径的从 0.4 到 2.5 微米的 160 种“纯”矿物的
波谱。公共领域美国地质勘察波谱库包括近500个质优矿物波谱和几个植被波谱。这些数据由ENVI
提供，范围是0.4~2.5微米。来自 Johns Hopkins University 的波谱库包含 0.4~14 微米的矿物波谱。
IGCP 264 波谱库是1990 年间作为 IGCP 项目 264 的一个部分被收集的。它们由五个波谱库组成，
这些波谱库是通过五个不同的用于26个质优样品的波谱仪测量得到。植被波谱的波谱库由 Chris 
Elvidge, DRI 提供，范围是 0.4~2.5 微米。详情见附录C，“ENVI Spectral Libraries”以及 ENVI 中可
得到的有关波谱库的介绍。 

ENVI 波谱库被储存为 ENVI 图像格式，图像中的每条行与一个独立波谱相对应，图像中的每
一个样本与一个特定波长的独立波谱测量相对应(见 “ENVI Spectral Library Files” 部分)。ENVI 波
谱库可以用 ENVI 图像显示和分析程序进行显示和增强。 

·运用 ENVI 的波谱库工具和处理程序，选择 Spectral Tools > Spectral Libraries 。 

出现一个层叠式菜单，包含波谱库浏览、重采样和建立函数。个别菜单条目将在下面描述。 

Spectarl Library Viewer (波谱库浏览) 

浏览波谱库： 

1 选择Spectral Tools > Spectral Libraries > Spectral Library Viewer。 

出现 Spectral Library Input File 对话框，允许你选择一个库用于浏览。如果以前已经打开过一
个波谱库，它将显示在 “Select Input File” 标签的下方。 

2 选择一个波谱库，点击其名字，点击 “OK”。 

·如果对话框中没有列出输入的文件，打开一个新文件。 

A 在 Spectral Library Input File 对话框，选择 File > Open Spectral Library. 

B 出现文件选择对话框时，选择一个波谱库文件名，它将在 Spectral Library Input Fil e对话框中
供你选择利用。 

Spectral Library Viewer 对话框将出现，供你选择个别的库波谱，并用于图示。详细说面见下面。 

Spectral Library Viewer 对话框 
·在 Spectral Library Viewer 绘图窗口，用图显示一个波谱，在 Spectral Library Viewer 对

话框中点击一个独立的波谱名。 

Administrator
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将出现一个显示有波谱图的窗口。 

·同时图示多个波谱，点击多个波谱名。 

每一个新波谱将以一种新颜色出现在同一个绘图窗口。 

在绘图窗口内，点击鼠标右键，显示被图示波谱的名字和颜色。 

·以与图像数据同样的比例尺图示库波谱，在 “Mult Factor” 文本框里输入一个数值，用于波谱
库中波谱的放大倍数。 

·伴随着波谱库的引入，为从其它绘图窗口得到的波谱绘图： 

1 在绘图窗口中，点击鼠标右键显示图示名 

2 在图示名上，点击并按住鼠标左键将其拖曳到 Spectral Library Viewer 绘图窗口，释放鼠标
左键。(见“Moving Plots to Another Plot Window”部分) 

推出波谱库浏览器对话框，选择File > Cance.l 。 

Spectral Library Viewer 绘图窗口菜单 

Spectral Library Viewer 绘图窗口有三个下拉菜单，它们提供了许多图示选项。这些选项包括图
示值到 ASCII 文件或波谱库的输入和输出、设置数据图示特征（如线条颜色与类型等）、改变图表
特征（如数据范围和文件头等）、叠加数据图表、编辑数据值、建立 ASCII 文件与 PostScript 输
出、注记能力以及连续波谱消除（continuum removal）。 

·开辟一个新的绘图窗口，显示不同组的波谱，在 Spectral Library Viewer 绘图窗口中，选择 
Options > New Window。 

对于个别菜单选项的详细描述，见 “Interactive Plot Functions” 部分。 

Spectral Library Resampling (波谱库重采样) 

ENVI 波谱库可以被重采样，以便与一种已知的仪器（如TM, MSS, AVIRIS等）或用户定义的
滤波函数相匹配（一个具有或不具有full width half maximum [FWHM]信息的 ASCII 波长文件，或一
个特定图像输入文件的波长）。重采样方法依赖于输入的信息。如果只是提供了波长（波段中心），

ENVI 采用临界抽样，用一个 FWHM 等于波段间距的高斯模型。如果提供有波长和 FWHM 信息，
将用一个 FWHM 间隔的高斯模型。如果提供一个滤波函数， ENVI 将用它进行重采样。 

对整个波谱库进行重采样： 

1 选择 Spectral Tools > Spectral Libraries > Spectral Library Resampling。 

2 出现 Spectral Resampling Input File 对话框时，点击一个波谱库的名字和“OK”按钮，选择
要被重采样的波谱库。 

如果一个波谱库已经被打开，它的名字就会被显示在 “Select Input File” 文本框里。 

·如果对话框中没有列表显示出要输入的文件，打开一个新文件： 

A 点击 “Open Spectral Library” 按钮； 

B 出现文件选择对话框，选择一个文件名，它可以在 Spectral Library Input File 对话框中选择
得到。 

出现 Spectral Library Resampling Parameters 对话框，见下面。 
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Spectral Library Resampling 对话框 
用这一对话框选择要进行重采样的类型。点击“OK”后出现的不同对话框依赖于选择的重采样

类型。每种重采样类型的细节将在下面具体描述。 

1 通过点击 “Resample Wavelength to” 标签下方所需要的切换按钮，来选择要执行的重采样类
型。 

2 在 “Set Bad Values to” 文本框里，输入一个数值。当读到一个坏数据值时，将会用到这一数
值。 

3 选择输出到 “File” 或 “Memory”。 

·若选择输出到 “File”，键入一个输出文件名，或用 “Choose” 按钮选择一个文件名。 

4 点击“OK” 

将出现另外的对话框，这依赖于选择的重采样类型。 

来自数据文件的重采样 
如果你在 Spectral Resampling Parameters 对话框里，选择 “Input Data File” 作为重采样方法，
按照下列步骤： 

1 出现 File Containing Output Wavelength 对话框时，点击需要的文件名。 

2 点击 “OK” 开始重采样过程。 

数据文件在它的相关文件头中，必须包含用于重采样的波长数值。如果在文件头中，出现 FWHM 
值，它们也将用于重采样。 

在 Available Bands List 中出现作为结果的库（the resulting library）。 

来自ASCII文件的重采样 
如果你在 Spectral Resampling Parameters 对话框里，选择 “Input ASCII File” 作为重采样方法，
按照下列步骤： 

1 出现文件输入选择对话框，选择一个 ASCII 波长文件。 

2 出现 Input ASCII File 对话框时，选择波长数据栏。 

·为缩放波长指定一个放大系数，在“Multiply Factor”文本框，输入需要的数值。 

·如果 ASCII 文件也包括full-width-half-maximum (FWHM)值，输入FWHM栏数。 

3 点击 “OK” 开始重采样。 

在 Available Bands List 中出现合成的库。 

来自一个用户定义的滤波函数的重采样 
如果你在 Spectral Resampling Parameters 对话框里，选择 “User Defined Filter Function” 作为重

采样方法，按照下列步骤： 

1 出现 Input Filter Function Spectral Library 对话框，选择需要的滤波函数。 

2 点击 “OK”。 

在 Available Bands List 中出现合成的库。 
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来自预定义的滤波函数的重采样 
用户定义的滤波函数必须采取 ENVI 波谱库的形式，库中图像的每个样本代表一个波长值，每
条行代表一个独立的滤波函数。每处波长数值一定有一个 0~1 之间的权重，它在用于被重采样的库
中时，担任放大系数。例如在一个滤波函数文件的例子中，打开一个 Landsat TM 文件（“tm_fsli”，
在 ENVI 波谱库目录下）, 作为一个波谱库文件，并图示滤波函数。 

如果你在 Spectral Resampling Parameters 对话框里，选择 “Pre-Defined Filter Function” 作为重
采样方法，按照下面步骤：  

1 从 “Sensor” 按钮菜单下方的支持的光标列表中，选择一个光标类型（即ASTER，AVHRR) 

在 Available Bands List 中出现合成的库。 

Spectral Resampling (波谱重采样) 

除了可以对波谱库进行重采样以外，在 ENVI 中，你还可以对波谱数据文件进行重采样。数据
文件可以被重采样以便与一种已知的仪器（如TM, MSS, AVIRIS等）或用户定义的滤波函数（一个
具有或不具有full width half maximum [FWHM]信息的 ASCII 波长文件，或一个特定图像输入文件的
波长）。重采样方法依赖于输入的信息。如果只是提供了波长（波段中心），ENVI 采用边界抽样，
用一个 FWHM 等于波段间距的高斯模型。如果提供有波长和 FWHM信息，将用一个 FWHM 间
隔的高斯模型。如果提供一个滤波函数， ENVI将用它进行重采样。 

1 选择 Spectral Tools >Spectral Resampling。 

2 出现 Spectral Resampling Input File 对话框时，选择你的输入文件，并点击“OK”按钮。 

·如果对话框中没有列表显示出要输入的文件，打开一个新文件。： 

A 点击 “Open Image File” 按钮； 

B 出现文件选择对话框，选择一个文件名，它可以在 Spectral Resampling Input File 对话框中选
择得到。 

出现 Spectral Resampling Parameters 对话框。参见 “The Spectral Resampling Parameters Dialog” 
部分以及下面的各种重采样类型的说明。 

Spectral Library Builder (创建波谱库) 

ENVI波谱库来自于各种波谱源，包括 ASCII 文件、其它波谱库、ROI 平均值以及波谱剖面和
图示。如果可能，用full-width-half-maximum (FWHM)信息，聚集的波谱自动被重采样到一个输入的
波长空间。 

1 选择 Spectral Tools > Spectral Libraries > Spectral Library Builder。 

2 出现 Spectral Library Builder 对话框时，从 “Input Data File” (ENVI 图像文件)或 “Input 
ASCII File” 中，为新库选择波长设置。 

3 出现 File Containing Output Wavelength 对话框时，用标准选择程序选择包含波长和可选项
FWHM值的输入文件。 

·当采用 “Input Data File”，波长和 FWHM 值（若存在）从 ENVI 头文件中读取。 

·当采用 “Input ASCII File”, 必须选上包含波长值与 FWHM (若存在)的列。 
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4 点击 “OK”。 

出现 Spectral Library Builder 对话框，允许选择波谱库。 

Spectral Library Builder 对话框 
运用这一对话框（图10-3）从各种数据源中收集终端单元波谱。 

所有波谱自动被重采样到选择的波长空间。这一对话框的个别部分见下面描述（也可参见 “The 
Endmember Collection Dialog” 部分）。 

黑色拖曳小器具 
在 Spectral Library Builder 对话框顶部的黑色拖曳小器具用于从 Z 剖面或波谱图中收集波谱。 

1 用标准 ENVI 程序从这些图中移动波谱。 

在波谱图内点击鼠标右键选上波谱名，在波谱名上点击并按住鼠标左键，将波谱名拖曳到 
“Spectral Library Builder” 对话框顶部的黑色小器具里，松开按钮（参见 “Moving Plots to Another Plot 
Window” 与 “The Endmember Collection Dialog”）。 

2 波谱名将被添加到选择的波谱列表中。 

Import 下拉菜单 
用这一菜单项从其它来源（如 ASCII 文件、ROI 平均值、波谱库或统计文件）输入波谱。 

·从 ASCII 文件中输入波谱： 

1 选择 Import > from ASCII File。 

2 出现文件选择对话框时，从 ASCII 文件中选择输入的文件。 

如果选择的是一个有效文件（即 ASCII文件中至少包含一列数值型数据），则出现 ASCII Input 
对话框，显示出一个行列数列表和每一栏数据中的前几个数据。 

3 点击需要的名字，选择波谱。 

·若选择连续显示的一组波谱，则点击这一组的第一个，按住“shift”键，再点击最后一个，
或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。最后再将一些不需要的
删除。 

·选择所有波谱，点击 “Select All Items”。 

·删除所有波谱，点击 “Clear All Items”。 

4 点击 “OK” 将选择的终端单元波谱输入到 Spectral Library Builder 对话框的列表中 

·运用前面 Input ASCII File 对话框中限定的参数，再选择一个 ASCII 文件，读取数据，选
择 Import > from ASCII file (以前的模板)。 

这一项不通过中间的参数对话框，直接将数据读到 Spectral Library Builder 窗口。 

·从波谱库文件输入波谱： 

1 选择 Import > from Spectral Library. 

2 出现 Spectral Library Input File 对话框时，选择波谱库名，点击“OK”打开库。 
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3 出现 Input Spectral Library 对话框时，通过点击需要的波谱名选择终端单元波谱 

·选择连续显示的一定范围的波谱，在需要的范围内点击和拖曳，或点击这一范围的第一个，

按住“shift”键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

·选择所有波谱，点击 “Select All Items”。 

·删除所有波谱，点击 “Clear All Items”。 

4 键入 X、Y 数据放大系数，以改变数据比例尺。 

5 点击“OK”，将需要的波谱库输入到 Spectral Library Builder 对话框。 

·从前面定义的感兴趣区中输入波谱： 

1 选择 Import > from ROI Mean。 

2 出现 Input File for ROI 对话框时，选择需要输入的数据。 

只有与前面定义的输入文件相应的 ROIs，才会出现 Input ROI Means 对话框。 

3 点击需要的 ROI 名，选择波谱(ROI平均值)。 

·选择连续显示的一定范围的波谱，在需要的范围内点击和拖曳，或点击这一范围的第一个，

按住“shift”键，再点击最后一个。 

·选择非连续显示的多个波谱，则按住“ctrl”键，再一一点击它们。 

·选择所有波谱，点击 “Select All Items”。 

·删除所有波谱，点击 “Clear All Items”。 

4 点击 “OK”，将选择的 ROI 平均波谱添加到 Spectral Library Builder 对话框中。 

·从一个统计文件中输入一个平均波谱： 

1 选择 Import > from Stats file。 

2 出现 Enter Statistics Filename 对话框时，选择要输入的统计文件 

来自统计文件的平均波谱将被输入到 Spectral Library Builder 对话框列表中。 

这一项能用 Classification > Class Statistic 功能选择被输出的统计文件，从以前计算的分类结果
中输入平均波谱。 

Options 下拉菜单 

·编辑波谱名： 

1 选择 Options > Edit Endmember Names。 

2 出现 Endmember Name Editing 对话框时，在 “Current Endmember Names” 列表中，点击名
字，选择要编辑的终端单元。 

3 根据需要编辑名字，按回车键。 

·重新将终端单元设置为它们的原始名，点击 “Reset”。 

·图示所有终端单元波谱，选择 Options > Plot Endmembers。 
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·从 “Selected Endmember Spectra” 列表中，删除所有终端单元波谱，选择 Options > Clear 
Endmembers 。 

File 下拉菜单 
File 菜单允许将聚集的波谱输出到 ASCII 文件或作为一个波谱库。 

·输出到 ASCII 文件： 

1 选择 File > Output Spectra > ASCII. 

2 出现 Output Plots to ASCII File 对话框，键入输出文件名，或用 “Choose” 按钮选择一个输出
文件名。 

·由选择的波谱建立一个标准ENVI波谱库文件。 

1 选择 File > Output Spectra > Spectral Library。 

2 出现 Output Plots to Spectral Library 对话框时，键入输出文件名。 

·关闭 Spectral Library Builder 对话框，选择 File > Cancel。 

删除波谱 
无论何时从新库中删除波谱，在 Spectral Library Builder 对话框中，点击一个列表显示的波谱

名，点击 “Delete Spectrum”。 

建立波谱库 
·一旦所有需要的波谱都已经被选上，建立一个包含所有波谱的 ASCII 文件，在 Spectral Library 

Builder 对话框顶部，选择 File > Output Spectra > ASCII。 

·建立一个 ENVI 波谱库，或作为文件输出，或存入内存，选择 File > Output Spectra > Spectral 
Library (见前面的 “The File Pulldown Menu” 部分)。 



 323

Spectral Slices (波谱分割) 
波谱切片是通过一幅多波段图像合成的一个空间的/波谱的剖面。ENVI 中的片段被存为灰阶图
像，行的方向(Y)与图像被切片 (“水平的”,“垂直的”, 或“任意的”)的空间维数相对应，采样方向(X)
与波谱维数（切片图像中的波段数）相对应，灰阶（DN level）显示依赖于数据校准的波谱强度（反
射、辐射等）。 

图像可以被sliced沿水平方向（图像中的一条行都用到所有波段），沿垂直方向图像一个像元列
用到所有波段）或沿任意方向，由你根据选用的ROI折行来决定（见“ROI Types”部分）。最终的切
片是一幅 ENVI 图像，其中样本数等于波谱波段数，行数等于抽样数（沿水平方向的切片），样本
数等于行数（沿垂直方向的切片），或样本数等于像元总数（沿 ROI 折行，任意方向的切片）。 

Horizontal Slice (水平切片) 

水平波谱的切片图像表明了波谱对输入图像数据的一条行上的所有像元的反应（所有波段）。

切片需要的位置可以提前用图像窗口中的光标位置/值功能来确定（见“Cursor Location/Value”部分）。 

1 选择 Spectral Tools > Spectral Slice s > Horizontal Slice。 

2 出现 Spectral Slice Input File 对话框时，选择一个输入文件和需要的波谱子集 

3 出现 Spectral Slice Parameters 对话框时，在标有 “Line” 的文本框里键入用于水平切片的行
数 

4 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，输入一个输出文件名，或用 “Choose” 按钮选择一个输出文件名。 

5 一旦所有参数都已经输入，点击 “OK” 继续。 

水平波谱切片图像将被添加到 Available Bands List 中，可以用标准 ENVI 功能显示和处理。 

Vertical Slice (垂直切片) 

一幅垂直的波谱切片图像表明波谱对输入图像数据的单独一列的响应（所有波段）。切片需要

的位置可以提前用图像窗口中的光标位置/值功能来确定（见 “Cursor Location/Value” 部分） 

1 选择 Spectral Tools > Spectral Slice > Vertical Slice。 

2 出现 Spectral Slice Input File 对话框时，选择一个输入文件和需要的波谱子集。 

3 出现 Spectral Slice Parameters 对话框时，在标有 “Sample” 的文本框里，为垂直切片键入一
个样本数。 

4 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，输入一个输出文件名，或用 “Choose” 按钮选择一个输出文件名。 

5 一旦所有参数都已经输入，点击 “OK” 继续。 

垂直波谱切片图像将被添加到 Available Bands List 中，可以用标准 ENVI 功能显示和处理。 
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Arbitrary Slice (任意方向的切片) 

任意方向切片图像表明波谱对用户定义的感兴趣区的响应（所有波段）。ROIs必须在进行任意
方向的切片操作之前，用 ENVI 的标准 ROI 选择步骤定义。通常地，任意方向的切片将用定义感
兴趣区的 “Polyline” 选项来限定（见 “Polyline” 部分）。然而，也可以用多边形或点。ROI 中包括
的所有像元将参与波谱的切片。 

1 选择 Spectral Tools > Spectral Slice > Arbitrary Slice。 

2 出现 Spectral Slice Input File 对话框时，选择一个输入文件和需要的波谱子集。 

出现 Spectral Slice Parameters 对话框，列出了文件特征和可用于处理的选项。 

·如果当前只有一个 ROI 被定义，它将自动地用于任意方向的切片。 

·如果不只一个 ROI 存在，你可以通过在 “Select Region for Spectral Slice” 列表中，点击需要
的区域名，以选择用于切片的 ROI 。 

3 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，输入一个输出文件名，或用 “Choose” 按钮选择一个输出文件名。 

4 一旦所有参数都已经输入，点击 “OK” 继续。 

任意方向的波谱切片图像将被添加到 Available Bands List 中，可以用标准的 ENVI 功能显示
和处理。 
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Spectral Math (波谱运算) 
Spectral MathTM 功能是一种灵活的波谱处理工具，它允许用数学公式或 IDL 程序处理波谱（以
及选择的多波段图像）。要运行这一函数，必须至少打开一个波谱，且显示在绘图窗口中。每个被

处理的波谱必须被显示。波谱可以来自一幅多波段图像（即一个Z剖面）、一个波谱库或一个 ASCII 
文件（见 “Image Spectral Plots (Z Profiles)”，“Spectral Library Viewer” 和 “The Import Pulldown 
Menu”）。如果已经打开了一幅或更多的图像，且波段数与其中一个显示的波谱的频道数匹配，这
些图像也可以被处理。如果波段数和波谱频道数相匹配，波谱数学也可以将数学公式用于多波段图

像的所有波段。 

Spectral Math 对话框 

·将数学公式应用于波谱或波谱之间，选择 Spectral Tools > Spectral Math。 

出现 Spectral Math 对话框。如果你正在处理波谱或你正在处理图像的一个二维数组，假定结果
可以表达为一个矢量（一个一维数组），则对话框允许应用任何有效的 IDL 数学表达式、函数或程
序。 

表 10-1 列出了函数类型以及能用于波谱数学表达式的算子。至于怎样在波谱数学中应用你自
己的程序和函数，请参阅 “Using IDL Procedures and Functions in Spectral Math”。下面更具体地介绍
了波谱数学对话框。 

表 10-1 在波谱数学中用到的函数和运算（括号中所示） 

Series and Scalar 
Math 

三角函数 其它的波谱数学选项 

加法（+） 正弦（sin(x)） 关系运算（EQ，NE，LE，LT，GE，
GT） 

减法（-） 余弦（cos(x)） 布尔运算（AND，OR，XOR，NOT）

乘法（*） 正切（tan(x)） 类型转换函数（字节型，fix ，长型，
浮点型，双精度型，复合型） 

除法（/） 反正弦（atan(x)） 返回数组结果的 IDL 函数 

小于（<） 反余弦（acos(x)） 返回数组结果的 IDL 程序 

大于（>） 反正切（atan(x)） 用户定义的IDL函数和程序 

绝对值（abs(x)） 双曲正弦（sinh(x)）  

平方根（sqrt(x)） 双曲余弦（cosh(x)）  

指数（^） 双曲正切（tanh(x)）  

自然指数（exp(x)）   

自然对数 

（alog(x)） 
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变量与 Enter an Expression 文本框 
键入一个新的波谱数学公式： 

1 在标有 “Enter an expression” 的文本框里，键入需要的数学公式，包括变量名（它们将用于
整个波谱或图像），然后按回车键。 

变量名必须以字母 “s” 或 “S” 开头，后面跟 5 个以内的数字字符。例如，如果你想计算六个
波谱的平均值，数学公式为： 

举例： 

(s1+s2+s3+s4+s5+s6)/6. 

可以被输入到文本框里，在这里 “s1” 是一个波谱，“s2” 是第二个波谱，“s3” 为第三个波谱，
等等。也可以从磁盘上打开以前存储的公式。 

2 一旦输入了一个有效公式，点击 “OK” 继续。 

出现 Variable/Spectra Pairings 对话框（见“Assigning Variables: The Variable/Spectra Pairings 
Dialog” 部分）。 

Previous Expressions 列表 
你可以再利用、存储或打开以前用过的数学公式。 

1 将一个公式导入标有 “Enter an expression” 的文本框，在 “Previous Expression:” 列表中，点
击需要的公式。 

2 一旦装好，点击“OK”，按照“Assigning Variables: The Variable/Spectra Pairings Dialog”下面
描述的程序执行，公式可以被用于一套新的波谱 

·点击“Save”按钮，可以将公式存储到一个输出文件中。在“Enter Output Filename”窗口，键入
输出文件名，点击“OK.” 

输出文件名的扩展名应是.exp (波段运算（Band Math）与波谱数学函数都可以用这些扩展名
为 .exp的文件)。 

·恢复以前存储的公式，点击“Restore”，选择需要的文件名。 

·清楚以前所有的公式，点击“Clear”。 

为变量赋值: Variable/Spectra Pairings 对话框 

Variable/Spectra Pairings对话框用于从可利用输入波谱列表中将波谱赋值给变量名（在“Enter an 
expression:”文本框里输入的）。 

继续我们的举例，等式： 

举例： 

(s1+s2+s3+s4+s5+s6)/6. 

被输入： 

1 在标有“Variables used in expression”的文本框里，点击符号“S1”，且在标有“Available Spectra 
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List:”的列表中，点击需要的波谱，将波谱赋值给变量“s1”。  

2 在标有 “Variables used in expression” 的文本框里，点击符号“S2”，且在标有“Available Spectra 
List:” 的列表中，点击需要的波谱，将波谱赋值给变量“s2”。  

3 用同样的方式选择其它的变量和波谱，为变量赋值。 

·清楚成对的变量/波谱, 点击“Clear”。 

4 一旦所有变量都被赋予了它们代表的波谱，你可以选择将结果用图表显示到同一绘图窗口，
或点击“Output Result to:”右边的按钮将结果输出到一个新的绘图窗口 

如果用了两个绘图窗口中的波谱，并选择了输出到同一窗口，则结果将在同一窗口中用图表显

示，且用到的是第一个赋予的波谱。 

5 开始计算，点击“OK” 

完成时，波谱数学作为结果的波谱将被图示在选择的绘图窗口中。它可以用于另外的处理，或

用图示下拉菜单里的标准图示功能存储到一个输出文件中（见“Interactive Plot Functions”部分）。 

地图变量到输入文件 
当选上Variable/Spectrum Pairing窗口时，如果可得到一个图像文件或图像内存条目（image 

memory item），则出现一个标有“Map Variable to Input File”的文本框。 

1 选择一个在波谱数学中用到的单波段或多波段图像，点击一个变量名，然后点击 “Map 
Variable to Input File”。 

2 选择需要的输入文件和空间或波谱子集 

3 选择输出到“File”或“Memory” 

·如果选择输出到“File”，输入一个输出文件名。 

4 点击“OK”开始处理 

在一幅图像用于波谱数学时，输出的将是另外一幅具有相同空间和波谱维数的图像。这一功能

可以对一幅图像的所有波段同时进行数学操作。 

在波谱数学中运用 IDL 程序和函数 

由于 ENVI 提供了 IDL 的性能（除非你正使用 ENVI-RT），你可以使用内置的 IDL 特征、
IDL 用户函数，或编写你自己的波谱数学表达式，以执行自定义的操作。对这些函数的唯一要求是
他们能输入一个或多个矢量（波谱），且能输出一个矢量结果。这些函数需要存储在IDL路径列表中，
以便它们能自动进行编译。它们也可以用 ENVI 主菜单中的 system下拉菜单中的 Compile Module 
选项进行编译（见“Compile Module”部分）。下面的简单例子显示了自定义波谱数学函数的建立和
应用（见 ENVI 用户向导中“Spectral Math Basics” 部分）。 

波谱数学用户函数 1 
下面的例子是用于添加两个波谱的简单自定义波谱数学函数。下面的程序文本可以输入到一个

文本编辑器，存为 user_sm1.pro: 

举例： 

FUNCTION user_sm1, s1, s2 
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RETURN, s1+s2 

END 

从 “Enter an expression:” 文本框，调用这一函数，用语法： 

user_sm1(s1,s2) 

波谱数学用户函数 2 
下面的例子是用于计算 6 个波谱平均值的简单自定义波谱数学函数。下面的程序文本可以输入
到一个文本编辑器，存为 user_sm2.pro: 

举例： 

FUNCTION user_sm2, s1, s2, s3, s4, s5, s6 

average = (s1+s2+s3+s4+s5+s6)/6. 

RETURN, average 

END 

从“Enter an expression:”文本框，调用这一函数，用语法： 

user_sm2(s1,s2,s3,s4,s5,s6) 
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Pixel Purity Index (纯净像元指数) 
纯净像元指数TM (PPITM )是一种在多波谱和高波谱图像中寻找波谱最纯的像元的方法。 波谱最
纯像元典型地与混合的终端单元相对应。纯净像元指数通过迭代将 N 维散点图影射为一个随机单
位向量来计算。每次影射的极值像元被记录下来，并且每个像元被标记为极值的总次数也记下来。

一幅“像元纯度图像”被建立，在这幅图像上，每个像元的 DN 值与像元被标记为极值的次数相对
应。详情见“Spectral Tools References”部分。有关运用PPI结果的例子，请看 ENVI Tutorial 中的 
Advanced Hyperspectral Analysis 。 

纯净像元指数函数可以建立一个新的输出波段，或继续反复地将结果添加到一个已经存在的输

出波段里。PPI 通常执行排除了噪声波段的最小噪声分数(MNF) 变换结果。见 “Minimum Noise 
Fraction Rotation” 部分。PPI 的结果通常用作 ENVI n-维观察仪的输入（见 “The n-Dimensional 
Visualizer” 部分）。 

FAST Pixel Purity Index (快速纯净像元指数) 

ENVI有一种FAST PPI方法，这种方法将图像数据置于内存，并在内存中进行计算。这一方法比
基于磁盘的PPI方法运算速度更快，但是需要将数据导入内存。用数据的空间和波谱子集或用一个比
较稀疏（a sparser array）的数组（二次抽样的分辨率）有助于将数据导入内存。ENVI将告诉你关于
运行快速PPI需要的内存大小，并提示你继续。快速PPI还有一个选项，让你建立一个新的输出文件，
并将其添加到已经存在的输出波段里。 

New Output Band (新的输出波段) 

在纯净像元指数函数运行时，首先你要用到 New Output Band 项。一个包含每个像元被认为是
极值的次数的输出波段被建立，用作 ENVI 的 n-维观察仪的输入。 

1 选择 Spectral Tools > Pixel Purity Index > New Output Band 或 [FAST] New Output Band. 

2 出现 Pixel Purity Index Input File 对话框时，选择一个输入文件或用标准ENVI波谱和空间子
集程序选择子集 

特别地，PPI 运行 MNF转换结果，波谱子集项根据特征图像和特征值图示排除噪声波段 (见 
“Forward MNF Transform” 部分)。 

3 点击 “OK” 继续。出现 Pixel Purity Index Parameters 对话框。 

Number of Iterations (迭代次数) 
·在 Pixel Purity Index Parameters 对话框，键入迭代次数以设定数据被影射到随机向量的次数。

迭代次数越多，ENVI 越能发现极值的像元。由于 CPU 和系统配置不同，每次迭代都要占用一些
时间，因此要迭代多少次，根据可利用时间而定。特别是为分光计数据制图（成像波谱仪数据），

需要上百次的重复。运行的迭代次数被显示在图像头文件的描述行里。 

注意 

PPI可以用Existing Output Band菜单项随时中止，然后再继续。 

Threshold Factor (阈值系数) 

·为选择极值像元，用数据单位键入一个阈值。 
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例如，阈值为“2”，则只有大于两位数的像元才有可能被标为极值。刚开始是在影射向量的末端
选择像元。阈值应是数据噪声的 2-3 倍。例如，对于 TM 数据，它的噪声通常超过 1 DN ，阈值
用 2 或 3 就可以了。当用标准化噪声的 MNF 数据时，DN 等于一个标准差，另需阈值为 2 或 3 
就可以了。较大的域值将使得 PPI 寻找更多的极值像元，但是它们不可能是“纯”的终端单元。 

快速：X 和 Y 调整系数 
·对数据进行二次抽样，以使其与内存匹配，键入一个小于 1（即 0.5 的调整系数表示使用每
隔一个像元）的 X 和 Y 调整系数。二次抽样也不期望键入值小于 0.25（每第四个像元），因为
这样有可能将极值像元也剔除了。 

开始处理 
1 选择输出到 “File” 或 “Memory”。 

·如果选择输出到 “File”，键入一个输出文件名。 

2 点击 “OK”，开始处理。 

如果运用快速 PPI，将会出现一个显示需要内存大小的窗口，如果内存容量满足，将提示你继
续。 

出现一个正在处理的状态窗口，伴随着出现纯净像元指数图。这图显示了 PPI 作为迭代次数的
函数进行处理中发现的满足初始标准的极值像元的总数。当所有极值像元都已经找到以后，它应接

近于一条水平线。 

·中断 PPI 处理，在处理状态窗口中，点击 “Cancel” 按钮。 

·在同一地方重新开始，选择 Spectral Tools > Pixel Purity Index > Existing Output Band (见下面)。 

Existing Output Band (现有的输出波段) 

如果处理过程中你点击 “Cancel” 项，PPI 被中断；然后又想对 PPI 的结果继续进行另外的重
复，请用这项。 

继续处理前面的 PPI 结果： 

1 选择 Spectral Tools > Pixel Purity Index > Existing Output Band 或 [FAST] Existing Output 
Band. 

2 选择一个输入文件（MNF 的波谱子集也可以）。 

3 点击 “OK”。 

4 出现 Pixel Purity Index Previous Result 对话框时，选择一个以前的 PPI 图像，作为输入文件，
点击 “OK”。 

5 出现 Pixel Purity Index Parameters 对话框时，象上面描述的那样选择重复次数和域值。 

·对于快速 PPI, 若需要，键入一个 X 和 Y 调整系数。 

6 点击 “OK”，开始处理。 

出现一个状态窗口和纯净像元指数图。 
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用PPI图像进行终端单元（Endmember）选择 

处理完成以后，PPI 图像将出现在 Available Bands List 里。 

1 用标准 ENVI 显示程序显示图像 

比较亮的像元表示采用的波谱极值较多，波谱比较纯。较暗的像元表示波谱纯度较低。 

2 在  ENVI 主菜单上，选择  Basic Tools > Cursor Location/Value 或在显示窗口处选择 
Functions > Interactive Analysis > Cursor Location/Value 以判定图像中值的范围。 

·用交互式密度切片对高值进行较好的表达。 

3 选择 Functions > Interactive Analysis > Region of Interest > Image。 

Threshold to ROI 生成了一个只包含 PPI 高值的像元（见“Image Threshold to ROI”）。 

特别指出，只用到最小的初始值。例如，键入一个最小值 10，将选择所有大于 10 的 PPI 值
的像元作为 ROI 中包括的像元。如果在 PPI 图像中存在坏值区，则会用到最小和最大两个域值。 

一旦一个包含 PPI 高值的 ROI 形成，n-Dimensional Visualizer 菜单项就可以被用于交互式地
限定图像的终端单元（见下面）。 
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n-Dimensional Visualizer (n维观察仪） 
波谱可以被认为是 n-维散点图中的点（其中 n 是波段数）。n-维空间中的点坐标由 n 个值组
成，它们只是一个给定像元的每个波段中波谱辐射或反射值。这些点在 n-维空间中的分布可以用来
估计波谱的终端单元数以及它们的纯波谱信号数。n-维观察仪（Visualizer）为 n-维空间中选择终端
单元提供了一个交互式工具。 n-维观察仪（Visualizer）TM 用于连接最小噪声部分转换(MNF)和要
定位、识别的纯净像元指数，并收集数据集中最纯的像元和极值波谱反应(见“Spectral Tools 
References”部分)。见 ENVI Tutorial 中 Advanced Hyperspectral Analysis 有关应用 n-维观察仪
（Visualizer）的例子。 

n-维观察仪（Visualizer）允许数据在 n-维空间中交互式旋转，选择像元组进行分类，以及聚集
类，使其它类的选择更容易。选择的类可以输出到感兴趣区(ROIs) ，并用作分类、不混溶和匹配的
滤波技术的输入。 

启动 n-D Visualizer 

n-维Visualizer通常用于最小噪声部分(MNF)的数据，它们是只用纯净像元指数判定的最纯的像
元抽取的空间子集。启动 n-维 Visualizer： 

1 选择 Spectral Tools > n-Dimensional Visualizer > Visualize with New Data. 

·恢复到一个保存过的状态，选择 Spectral Tools > n-Dimensional Visualizer > Visualize with 
Previously Saved Data (见“The File Pulldown Menu”部分)。 

2 出现 n-D Visualizer Input File 对话框，选择一个要从中抽取 n-维散点图的图像（通常是一个 
MNF 文件）。 

3 检查特征图像和特征值图表，并由此将 MNF 数据的波谱子集，排除噪声波段 (见 “Minimum 
Noise Fraction Rotation”部分)。 

4 点击“OK”，打开文件，启用功能。 

一个运用来自PPI结果的初始值限定的ROI被用于限制输入到n-维Visualizer的像元数（for speed 
and clarity）。如果输入图像中只有一个ROI，那么它将自动被用作n-D Visualizer的输入。然而，若
不只打开了一个ROI，则将出现 n-D Visualizer Input ROI 对话框。 

5 点击 n-Dimensional Visualizer 中用到的 ROI 。 

当导入 ROI 以后，出现一个状态框。 

n-D Visualizer 绘图窗口 

n-D Visualizer是一个显示可视化选定数据的n-维散点图的窗口。它是一个n维数据到2维平面的
影射。 

·n-维 Visualizer可以包括数据（图示为白色像元）、轴，以及以颜色为代码的分类，这依赖于
下面的 n-D Controls 对话框中的选项。 

用 ENVI 的多边形绘图程序将单个像元和像元组突出显示，并编组到一个感兴趣区中。  

·一旦选择了图示的波段，用鼠标左键点击窗口开始画多边形，用鼠标左键在多边形的每个顶
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点上点击，用鼠标右键使多边形封闭。 

·可以在“n”维空间内旋转多边形，以孤立出特定的像元组。 

n-D Controls 对话框 

一旦来自PPI图像的ROI初始值已经装上，就会出现显示有n-D观察仪的n-D控制对话框。 n-D控
制对话框包含了文件选择期间选择的所有波段。这些以数字盒的形式显示在对话框顶部、文本标签 
“n-D Selected Bands” 的下方。这些最初显示为黑色。 

·在 n-D 观察仪（Visualizer）中，点击单个框，将其变成白色；并切换开启相应波段像元数据
的显示，作为 n-维散点图的部分（要看一个散点图，至少需选择两个波段）。 

·再次点击同一波段，将小框再次变黑，并切换关闭 n 维散点图中的波段数据。 

·用这种方式选择两个波段，生成一个二维散点图；点击三个波段，生成一个三维散点图，依

次类推。立刻可以选择任何数量的波段组合。 

·你可以用鼠标左键点击任何一角，将其拉到需要的大小和形状。 

选择维数和旋转 
在random projection views之间，旋转数据点。你可以随时控制速度和停止旋转。你可以向前或
向后一步步地移动穿过projection views, 过去以后，还可以再回到需要的projection view处。 

·当N维观察仪（n-D Visualizer）中需要多个波段（维数）用于投影时，点击显示要选择波段的
框。 

·如果选择二维，可能没有旋转。 

·如果选择三个以上维数，则只有自动随机旋转可用。 

·如果选择三维，则你可以选择 “driving” 轴，或初始化自动旋转。 

A 选择 Options > 3D:Drive Axes。 

B 在 N 维窗口，用鼠标左键点击与拖曳，手工旋转三维散点图的轴。 

·显示轴本身，选择 Options > Axes:On。 

·开始或停止旋转，点击 “Start” 或 “Stop”。 

·控制旋转速度，在 “Speed” 文本框里键入一个数值，或用箭头增量按钮增加或减小速度。值
越高，views之间旋转越快（Higher values cause faster rotation with fewer steps between views）。 

在“View”状态框中的信息告诉你在随机投影views之间移动的步骤。 

·一步步移动穿过投影views, 点击 “<-” 按钮后退， “->”按钮前进。 

·显示一个新的随机投影view, 点击 “New” 按钮。 

限定分类 
特别地，分类是将旋转过程中呆在一起的，明显地与其它像元相分离的归为一类。多重分类可

以被马上限定。借助于Z-剖面选项（见“The Options Pulldown Menu”），限定分类： 

1 当n-维观察仪中一组像元明显地与像元主体象分离时，用“Stop”按钮停止旋转，或用箭头按钮
进入到一个特殊的投影view 
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2 点击“Class” 下拉菜单，为每类选择颜色。 

·对下个ROI自动应用下一个可利用的分类颜色，选择Class > New. 

3 用标准ENVI多边形选择程序，突出n-D Visualizer中需要的像元（左按钮设置顶点，右按钮关
闭多边形） 

·如果选择一个三维投影，一定选择Options > 3D: ROI Definition. 

4 用“Start”按钮旋转散点图，直到另外的像元组被分离，重复分类的限定过程。每类选用不同
的颜色 

n-D Class Controls (n 维分类控制) 
n-维分类控制对话框用于与个别分类相互作用。它显示出每个定义类中的点数，显示出颜色，
允许你改变采用的符号，将单个类打开或关上，分类失败时，选择要用到的类别。你可以用图表示

每类的最小值、最大值、平均值和标准差波谱，单独为一类的平均值做图，或一类中所有波谱做图。

此外，你可以清楚一类，或将一类输出到一个ROI。 

1 在 n-D Controls 对话框，选择 Options > Class Controls。 

对话框中将出现所有定义的类。白色的一类包含所有没被聚类或未分配的点。每类中点数显示

在颜色区附近的文本框里。 

在 n-D Visualizer 窗口，关掉一类，点击这类的“On” 复选框。再次点击将它恢复原状。 

·在n-D Visualizer窗口，除一类外，将其它的都关掉。在你想保留显示的颜色框里，双击。 

再次双击就又将其它类选上。 

2 用鼠标左键点击与需要的类相对应的颜色框，选择一类作为 active 类。 

颜色将出现在 “Active Class” 标签附近，对话框中需要的任何函数都将影响到类。注意必须是选择
作为活动类的类，即使它还没在 n-D Visualizer 中打开。 

3 选择下面选项，改变显示符号，生成波谱图，输出活动类。 

·改变活动类的图示符号, 从“Symbol”按钮菜单中选择需要的符号。 

·为活动类生成波谱图。 

A 点击“Stats”、“Mean” 或 “Plot” 按钮。 

B 出现文件选择对话框时，选择你想从中计算波谱的输入文件。 

C 如果你选择一个具有不同空间维数的文件，而不是用作 n-D visualizer，输入的文件。出现提
示时，为 n-维空间子集键入 X 和 Y 的偏移值。 

注意 

如果你为一个包含上百个点的类选择 “Plot”，所有点的波谱都被绘制，得到的图可能是不可读
的。 

·从一类中删除所有点，点击 “Clear”。 

·将点输出到一个 ROI, 点击 “Export”。 

·当 collapsing 分类时，打开一类，点击需要的类附近的 “Clp” 复选框。如果你处于 collapsed 
状态，数据将用你点击的任何一个 “Clp” 复选框选择的类进行recollapsed。 
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Collapse Classes 
当数据集的维数高于4或5时，交互式地识别和限定许多类通常是比较困难的。n-D Visualizer有
两种class collapsing方法，使得限定分类更容易些。它们是Options下拉菜单下的Collapse Classes by 
Mean和Collapse Classes by Variance。两种方法都涉及到基于分类定义的数据云的重复collapsing。
collapse数据，需要根据类平均值或协方差计算投影， 以使得已经定义的类之间距离达到最小或隐
藏，增强数据集中仍保留的变化，使其达到最大。数据屈从于这种特殊的投影，在n-D Visualizer中
代替了原始的数据。此外，一幅特征值的图显示出来，表明了collapsed数据中残留的波谱维数。
Collapsed类将形成牢固的一组，剩余像元更易于被检查。每次collapse，数据维数都要降低（如特征
值图中所示）。 

1 选择Options > Collapse Classes by Means or Collapse Classes by Variance. 

将显示出一幅特征值图，暗含着需要定义的其余类数。 The “n-D Selected Bands” 器具颜色变为
红色，表明collapsed数据可以在n-D Visualizer中看到。 

2 用数值低的波段进行旋转，选择另外的类 

3 再次选择Options > Collapse Classes by Means或Collapse Classes by Variance， collapses所有已
经定义的类。 

4 重复上述步骤，直到所有需要的分类都已经.被选上。 

数据随时都可以被 “Uncollapsed” 到原始数据。 

Collapse Classes by Means 
·运用已定义类的平均波谱，计算collapse, 选择 Options > Collapse Classes by Means. 

运用这种collapsing方法之前，必须先至少定义两个类。每类波谱平均值的空间间隔来自一个修
改了的 Gramm-Schmidt 过程。补充的或无效（零空间null）空间也需被计算。数据集被投影到 null 
空间，正好将类平均值collapse到同一个点上。一次标准主成分转换被执行，将剩余的未解释的协方
差装到collapsed数据的数值低的波段中。每次重复collapsing，用所有已知类重复这一过程。特征值
图表明了转换后的数据维数，暗示了需要限定的剩余类数。 

Collapse Classes by Variance 
·运用已经定义的类的波谱协方差矩阵计算collapse，选择 Options > Collapse Classes by 

Variance. 

将计算出已经定义类的 band-by-band 协方差矩阵、特征向量和特征值。整个数据集被投影
（projected）到分类了的像元的特征向量。每个被projected的波段将要被相关特征值的平方根整除。
这将分类的数据转换到一个没有协方差和标准差的空间。一次标准主成分转换被执行，将剩余的未

解释的协方差装到collapsed数据的数值低的波段中。每次重复collapsing，用所有已知类重复这一过
程。特征值图表明了转换后的数据维数，暗示了需要限定的剩余类数。 

UnCollapse 
·uncollapse数据，并转回到原始数据集，选择 Options > UnCollapse. 

所有定义的分类将显示在 n-D Visualizer绘图窗口，“n-D Selected Bands”小器具将重新变成白
色。 
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输出类 
一旦所有需要的类已经被定义，它们的图像像元位置可以输出到感兴趣区 (ROIs)。这些 ROIs 

可以被输入到分类、分离（unmixing）、匹配的滤波或其它技术中。 

·将已经定义的类输出到 ROIs, 选择 Options > Export All (见下面的 Options 下拉菜单)。 

File 下拉菜单 
在 n-D Controls 对话框中的 File 下拉菜单允许存储和恢复 n-D Visualizer 的状态，包括突出
的像元组。 

·将n-D Visualizer显示输出到 Postscript、图像或打印机上，选择File > Output Plot > Postscript, 
Image 或 Printer (见“Zoom Window Output”)。 

·存储这一状况，选择File > Save State，为保持一致，输如一个扩展名为.ndv的文件名。  

·恢复以前存储的状态，选择 File > Restore State 以及合适的文件。 

·恢复以前存储的状态，也可选择 Spectral Tools > n-Dimensional Visualizer > Visualize with 
Previously Saved Data。 

·退出 n-D Visualizer, 选择 File > Cancel。 

Options 下拉菜单 
Options 下拉菜单包括用于accessing the n-D Class Controls对话框、注记n-D visualizer、启动一个

Z-剖面绘图窗口、输入波谱库、collapsing classes、清楚、将类输出到ROIs、计算平均波谱，以及将
轴图表（axes graphics）打开或关上等选项。 

·To access the n-D Class Controls对话框，选择Options > Class Controls 

(见“n-D Class Controls”中对话框的详细描述)。 

· 为 n-D visualizer 窗口添加一个注记，选择 Options > Annotate Plot. 你不能将边界也加到
n-D Visualizer窗口中（见“Annotation”）。 

·打开一个绘图窗口，显示n-D Visualizer 选择点的波谱图： 

1 选择 Options > Z Profile。 

2 出现文件选择对话框时，选择与n-D data相关的数据文件。 

特别地，文件时反射的（reflectance）或原始数据。 

·如果你选择一个具有不同空间维数的文件，而不是用作n-D visualizer,输入的文件。出现提示
时，为n-维空间子集键入X和Y的偏移值。 

·为距离光标最近的点作一个Z剖面图，在n-D绘图窗口点击鼠标中间的按钮。 

将n-D Visualizer绘图窗口中的图添加到Z剖面绘图窗口。在n-D绘图窗口中点击鼠标右键。打开
Z剖面绘图窗口时，若选择Options > Mean Class or Mean All，已经选择的文件将自动用于计算平均
波谱。 

·从其它来源中输入波谱，如波谱库： 

1 选择Options > Import Library Spectra。 

输入波谱必须与n-维输入数据有相同的空间（即，MNF空间）。 
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将波谱转换成MNF, 用Transforms > MNF Rotation > Apply Forward MNF to Spectra 函数，以及
你用原始数据运行MNF时选择的统计（见“Minimum Noise Fraction Rotation”）。  

2 出现n-D Visualizer Import Spectra对话框时，用Import下拉菜单将波谱拖曳到黑色小器具里或
直接从一个波谱库、ROI或ASCII文件输入（见“Endmember Collection”或“The Unmixing Endmember 
Collection Dialog”）。 

3 点击“Apply.” 

4 出现Import Spectra Parameters对话框时，选择下列选项，设置波谱参数。 

·编辑波谱名，在“Name”文本框点击波谱名，并进行修改。 

·编辑波谱颜色，点击波谱名，从“Color” 按钮菜单中选择一种颜色。 

·在n-D Visualizer绘图窗口，作波谱图，点击“Show Spectrum” 复选框。 

5 点击 “OK”。 

波谱将出现在n-D Visualizer绘图窗口，在其附近有星状名字标签。注意：一些波谱也许会落在
当前投影之外，并且看不到，直到你旋转数据。 

·从n-D Visualizer 中删除输入的波谱库： 

1 选择Options > Delete Library Spectra。 

2 选择要删除的波谱，点击“OK”。 

·改变输入的波谱库的颜色或名字，在n-D Visualizer上，打开或关闭波谱： 

1 选择Options > Edit Library Spectra 

2 在Import Spectra Parameters对话框，点击名字，选择要编辑的波谱 

3 根据需要对个别波谱编辑颜色，改变名字，将“Show Spectrum” 复选框打开或关上 

·将已经定义的类collapse到一个单独的组，选择Options > Collapse Classes by Means或Options > 
Collapse Classes by Variance (见“Collapse Classes”) 

·返回到原始数据投影，选择Options > UnCollapse. 

·在n-D Visualizer中，清除当前选择的类，选择Options > Clear Class. 

·将当前的类输出到一个ROI, 选择 Options > Export Class. 

一个感兴趣区将要形成，并与相应图像像元的空间位置相匹配。这些可以用于原始的反射图像

抽取终端单元和分类。 

·为当前类作一个均值波谱，选择 Options > Mean Class. 

出现一个文件选择对话框，用于选择计算均值的文件。特别地，这个文件是反射率数据。 

·清除n-D Visualizer 中的所有类，选择 Options > Clear All. 

·将n-D Visualizer中定义的所有类输出到ROIs, 选择Options > Export All. 

·为所有定义的类均值波谱作图，选择 Options > Mean All. 

出现一个选择反射率文件的对话框。 

如果一个 Z 剖面窗口是打开的，则均值波谱将自动从打开的Z剖面中抽取文件。 
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·将 n-D Visualizer 中的轴打开或关上, 选择Options > Axes:On或Axes:Off. 

·在三维空间旋转时，改变  n-D Visualizer中的活动的鼠标功能，选择Options > 3D:ROI 
Definition 或 3D:Drive Axes. 
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Endmember Collection (收集终端单元) 
收集终端单元提供了一种从用于波谱处理技术中的各种来源搜索波谱终端单元的工具。终端单

元可以从ASCII文件、波谱库、统计文件或ROI均值输入。收集终端单元函数也允许从对话框中选择
一种分类算法或高级的波谱处理技术。 

1 选择 Spectral Tools > Endmember Collection. 

2 出现 Classification Input File对话框时，进行输入文件的选择或抽取空间和波谱子集，以及掩
模。 

3 出现Endmember Collection: Algorithm对话框时，用Import下拉菜单输入波谱终端单元 详情见
“Endmember Collection”或“The Unmixing Endmember Collection Dialog”。 
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Mapping Methods (制图方法) 
ENVI有许多波谱制图方法，除了传统的分类技术以外，还包括二进制编码、波谱角度映射表
（spectral angle mapper）、线性波段预测器(LS-Fit)、线性波谱分离、匹配滤波协调混合的匹配滤波、
连续波谱消除，以及波谱特征适配。这些方法见下面描述。 

Binary Encoding (二进制编码) 

二进制编码分类技术根据一个波段的值落在波谱平均值的下方或上方，将数据和终端单元分别

遍为0和1。高级的（exclusive）OR函数用于比较在编码数据范围内的每个编码参照波谱和生成的分
类图像。所有像元被分类到与其匹配波段数最多的终端单元，除非用户指定了一个最小匹配值，这

时如果有一些像元不满足标准，它们也许就不参与分类。 

·选择Spectral Tools > Mapping Methods > Binary Encoding，开始进行二进制编码分类。 对分
类对话框的详细介绍见“Binary Encoding”。 

Spectral Angle Mapper (波谱角度制图仪) 

波谱角度制图仪(SAM)是一种基于自身的（physically-based）波谱分类方法，这种方法将图像波
谱与参照波谱在N-维空间进行匹配。SAM用到的参照终端单元波谱可以来自于ASCII文件、波谱库、
统计文件或直接从图像中抽取（如ROI平均波谱）。SAM将终端单元波谱（被认为是一个N维向量，
N是波段数）之间的角度与N维空间中的每个像元向量进行比较。角度越小，表示和与之匹配的参照
波谱越接近。这一技术用于校准数据时，对照明和反照率的影响相对不敏感。 

·选择Spectral Tools > Mapping Methods > Spectral Angle Mapper，开始SAM分类。有关分类对
话框的详细介绍见“Spectral Angle Mapper”。 

LS-Fit (线性波段预测) 

LS-Fit用一个最小方快适配技术运行线性波段预测。它可以用于找出数据集中的反常波谱响应
区。计算出输入数据的协方差，用它对选择的波段进行预测，表示为波段的线性组合加上一个偏移

值。过程中计算了实际波段和模型波段之间的残差，并输出为一幅图像。残差大的像元（无论正负）

表示出现了不可预测的迹象（即一个吸收波段）。模型的波段图像也包括在输出中。预测的波段可

以用现有统计或新的统计方法进行计算。 

Predict with new Statistic (用新的统计信息进行预测) 
用新统计信息进行预测： 

1 选择Spectral Tools > Mapping Methods > LS-Fit (Linear Band Prediction)> Predict with new 
Statistics. 

2 选择输入文件，根据需要抽取空间子集 

出现LS-Fit Parameters对话框。 

3 点击需要的波段名，选择要用作预测的波段（used as predictor bands） 

·若选择连续显示的波段，则点击这些波段的第一个，按住“shift”键，再点击最后一个，或
者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 
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·若选择非连续显示的多个波段，则按住“ctrl”键，再一一点击它们。最后再将一些不需要的
删除。 

·选择所有波段，点击“Select All Items.” 

·删除所有波段，点击“Clear All Items.” 

4 在“Select the Model Band”列表中，点击需要的波段名选择要预测的波段（band to predict） 

如果这个波段已经被选为用作预测的波段，它将不被再次选用。 

5 计算统计时，对数据进行二次抽样，在“Stats X/Y Resize Factor”文本框里，键入一个小于1的
调整系数 

6 若需要，键入一个输出统计文件名 

7 选择输出到“Memory”或“File” 

·如果输出到“File”，键入一个文件名，或用“Choose”按钮选择一个输出文件名。 

输出包含两个波段，被模拟的波段（modeled band）和残差图像。可以用动态覆盖对实际波段和
被模拟的波段进行比较（见“Multiple Dynamic Overlays”）。残差图像中，值较大的像元，无论正负，
都表明了在那儿实际波段和被模拟的波段具有差异。当函数完成，这些作为结果的波段出现在

Available Bands List中。 

Predict from Existing Stats (用现有的统计信息进行预测) 
这一函数预测波段时运用现有的统计文件。统计文件中，只能选择具有协方差值的波段作为预

测器或模拟波段（predictor or model bands）。 

用现有统计预测波段： 

1 选择Spectral Tools > Mapping Methods > LS-Fit (Linear Band Prediction) > Predict from 
Existing Stats. 

2 选择输入文件，根据需要抽取空间子集 

3 选择与输入的数据文件相对应的统计文件 

出现LS-Fit Parameters对话框，只有统计计算中用到的波段才可以被选作预测器或模拟波段
（predictor or model bands）。 

4 点击需要的波段名，选择要用作预测的波段（used as predictor bands） 

·若选择连续显示的波段，则点击这些波段的第一个，按住“shift”键，再点击最后一个，或
者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个波段，则按住“ctrl”键，再一一点击它们。最后再将一些不需要的
删除。 

·选择所有波段，点击“Select All Items.” 

·删除所有波段，点击“Clear All Items.” 

5 在“Select the Model Band”列表中，点击需要的波段名选择要预测的波段（band to predict） 

如果这个波段已经被选为用作预测的波段，它将不被再次选用。 

6 选择输出到“Memory”或“File” 
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·如果输出到“File”，键入一个文件名，或用“Choose”按钮选择一个输出文件名。 

输出包含两个波段，被模拟的波段（modeled band）和残差图像。可以用动态覆盖对实际波段和
被模拟的波段进行比较（见“Multiple Dynamic Overlays”）。残差图像中，值较大的像元，无论正负，
都表明了在那儿实际波段和被模拟的波段具有差异。当函数完成，这些作为结果的波段出现在

Available Bands List中。 

Linear Spectral Unmixing (线性波谱分离) 

线性波谱分离是一种根据材料的波谱特征判定多波谱图像中材料（原料）相对丰度的一种方法。

假定图像中每个像元的反射系数是在这一像元点上每种材料（或终端单元）的反射系数的线性组合。

终端单元数必须少于波谱波段数，必须用到图像中的所有终端单元。波谱分离的结果高度依赖于输

入的终端单元，且随终端单元的改变而改变。详情见“Spectral Tools References”和“Results of Spectral 
Unmixing”。 

ENVI线性波谱分离有两个约束项：完全不约束或部分约束分离。用完全不约束方法，丰度可以
假定为负值，不受约束到（not constrained to）sum to unity (one)。ENVI现在支持一种线性混合算法
中的随意的、权重可变的、unit-sum约束。This was implemented to allow for user-defined weighting of a 
sum-to-unity constraint on the abundance fractions. 也允许具有0-值波段的MNF-转换数据的适当分离。
用户选择一个权重系数（默认值为1）用于其它的约束方程。这个具有权重的unit-sum约束条件被添
加到分离倒置过程的联立方程中。较大的权重值将导致the unmixing to honor the unit-sum constraint 
more closely. 

注意 

如果不是所有的终端单元都是已知的，或你只是想为几个终端单元制图，用Matched Filtering或
Mixture Tuned Matched Filtering (见“Matched Filtering”和“Mixture Tuned Matched Filtering”)。 

对一幅多波谱图像进行线性波谱分离： 

1 选择Spectral Tools > Mapping Methods > Linear Spectral Unmixing. 

2 出现Unmixing Input File对话框，选择一个输入文件，（若需要）用标准ENVI波谱和空间子集
以及掩模程序抽取空间子集或用一个掩模。 

3 点击“OK”继续。 

出现Unmixing Endmember Collection对话框(图10-12). 

Unmixing Endmember Collection 对话框 

这一对话框允许你从各种来源（ASCII文件、波谱库、波谱图、统计文件、感兴趣区）选择终端
单元波谱。来自各种来源的波谱将自动被重采样，以于被混合的多波段图像的波长相匹配。 

Endmember Collection:Unmixing对话框以及相关的子对话框与“The Endmember Collection 
Dialog”中的类似。 

终端单元可以用描述的程序，从ASCII文件、波谱库、统计文件或感兴趣区中选择。它们也可以
从“Moving Plots to Another Plot Window”和“The Endmember Collection Dialog” 中描述的图示中选
择。 

1 从Import菜单，为终端单元波谱选择来源。 
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·图示终端单元波谱，选择Options > Plot Endmembers. 

·编辑终端单元名，选择Options > Edit Endmember Names. 

·清除终端单元名，选择Options > Clear Endmembers. 

2 当所有需要的终端单元都已经选上以后，点击Endmember Collection:Unmixing对话框底部的
“Apply”按钮。 

3 如果你想在分离中运用a unit sum约束，用箭头切换按钮选择“Yes”。 

·如果选择了“Yes”，在合适文本框里键入一个权重。 

这一权重被添加在分离倒置过程中的联立方程里。较大的权重将导致the unmixing to honor the 
unit-sum constraint more closely. 

4 选择输出到“Memory”或“File”。 

·如果选择输出到“File”，键入一个文件名。 

5 点击“OK”，开始波谱分离。 

出现一个显示处理状态的窗口。 

混合波谱分离的结果 

波谱分离的结果将以一系列灰阶图像的形式出现，每幅灰阶图像加上一个平方根误差图像对应

于一个终端单元。较高的丰裕度（RMS误差图像的较大误差）对应较亮的像元（较大的浮点数）。
例如，在图10-14中，较亮的像元代表了用一个ROI波谱和线性波谱不混合技术得到的与其它成分不
混合的耕作植被的丰裕度高。分离技术将有一个0~1的数据范围（代表了终端单元的丰裕度）。然而，
有可能出现负值和大于1的值。不可行的（Infeasible）丰裕度象征着不正确的终端单元。结果由输入
的终端单元决定，且随终端单元的变化而变化。观察RMS误差图像有助于判定丢失区或不正确的终
端单元。 

匹配滤波 

匹配滤波进行局部的不混合——寻找用户定义的终端单元的丰裕度。并不是图像中所有的终端

单元都必须是已知的。这项技术使已知终端单元的响应达到最大，并抑制了未知背景合成的反应，

因此“匹配”了已知信号。它提供了一种根据到库或图像终端单元波谱的匹配快速探测特定材料的

方法，不需要知道图像中所有终端单元的知识。这项技术可以找到一些稀有材料的“假阳性(false 
positives)”。Mixture Tuned Matched Filtering (见下面) 可以用来减少false positives的数目。其它信息
参看“Spectral Tools References”和“Results of Matched Filtering”。 

1 选择Spectral Tools > Mapping Methods > Matched Filtering。 

2 出现Matched Filter Input File selection对话框，选择输入文件，或根据需要抽取空间和波谱子
集。 

3 点击“OK”，出现Endmember Collection:Matched Filter对话框。 

4 用Import_Spectra下拉菜单，输入要被匹配的波谱。 

有关“Endmember Collection”对话框的详细描述，参看“The Unmixing Endmember Collection 
Dialog”。 
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5 当所有需要的波谱都被选上，点击“Apply”，出现Matched Filter Parameters对话框。 

6 用箭头切换按钮，选择“Compute New Covariance Stats”，键入一个输出统计文件名；或切换
到“Use Existing Stats File”。 

7 选择输出到“Memory”或“File”。 

·如果选择输出到“File”，键入一个输出文件名。 

8 从“Output Data Type”菜单，选择一个输出文件的类型（浮点型）和字节。 

·如果选择输出到“Byte”，键入一个最小和最大数据值，以拉伸字节范围。 

9 点击“OK”，开始处理。 

·如果选择“Use Existing Stats File”，将出现一个文件选择对话框。选择一个与输入的数据文件
相对应的统计文件。 

出现一个状态窗口，显示处理进度。 

匹配滤波的结果 

匹配滤波的结果将以一系列灰阶图像的形式出现，一幅图像对应一个选择的终端单元。浮点型

结果提供了一种估计与参照波谱相对匹配程度以及亚像元丰度的方法。1.0 表示完全匹配。 

·当结果被导入一幅显示的图像时，它们应当用 “Interactive Stretching” 拉伸(见“Interactive 
Stretching”)。 

背景材料的数据直方图以 0 为中心，目标（终端单元）出现在直方图的 upper tail (见图10-14)。
所以直方图 upper tail 的数据应当被拉伸超过 0.1~0.65 的范围，只显示目标材料的像元。以 0 为
中心，对称的直方图分布的图像值是背景区域。 

·如果选择输出为字节型，则直方图 upper tail 的数据将用 “Interactive Stretching.” 拉伸。 

注意 

在输出文件头中，可以设置一个默认的拉伸范围，以便每次显示时，数据不必再拉伸。 

Mixture Tuned Matched Filtering（混合匹配滤波） 

Mixture Tuned Matched Filtering TM (MTMF TM )运行匹配的滤波，但是也把输出的“不可实行
的”（“Infeasiblility”）图像添加到结果中。Infeasibility图像用于减少有时用匹配滤波出现“false 
positives”的次数。Infeasibility高的像元易于be matched filter false positives. 被准确制图的像元有一个
高的匹配滤波分数和一个低的infeasibility值。Infeasibility值用的使噪声σ（sigma）单位。它在与匹
配的滤波分数按DN比例变化（见图10-15）。其它信息，参看“Results of Mixture Tuned Matched 
Filtering”。 

注意 

输入的数据和要匹配的波谱必须在MNF转换空间（见“Apply Forward MNF to Spectra”）。 

1 选择Spectral Tools > Mapping Methods > Mixture Tuned Matched Filtering 

2 出现Mixture Tuned Matched Filter Input File selection对话框时，根据需要选择输入MNF文件或
其空间和波谱子集。Mixture Tuned Matched Filter需要一个由输入文件转换的最小噪声部分，或其它
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的isotropic数据，单位变化噪声。 

3 点击“OK”，出现Endmember Collection:Mixture Tuned Matched Filter对话框。 

有关细节，请看“The Unmixing Endmember Collection Dialog”部分。 

4 用Import_Spectra下拉菜单输入要被匹配的波谱（MNF空间）或将MNF波谱拖入对话框顶部的
小器具里。 

这些波谱必须是MNF空间。它们可以由来自MNF输入文件的ROIs或转换成MNF空间的波谱得到
（见“Apply Forward MNF to Spectra”部分）。 

警告 

输入波谱必须是纯的，用于混合调整匹配滤波的极端终端单元（mixture tuned matched filtering）
必须是可解译的。这些类型的终端单元可以用ENVI’s PPI和n-D Visualizer找到 (见ENVI高级高波谱
分析指南)。 

5 当所有需要的波谱都已选好，点击“Apply”，出现Mixture Tuned Matched Filter Parameters对话
框 

6 用箭头切换按钮选择“Compute New Covariance Stats”，键入一个输出统计文件名，或切换到 
“Use Existing Stats File” 

7 选择输出到“Memory”或“File” 

·如果选择输出到“File”，键入一个输出文件名。 

8 从“Output Data Type”菜单，选择一种输出的数据类型——浮点型或字节型  

·如果选择输出“Byte”，键入一个最小和最大值，以拉伸字节范围。 

9 点击“OK”，开始处理 

·如果选择“Use Existing Stats File”，将出现一个文件选择对话框。选择与输入的数据文件相对
应的统计文件。 

出现一个状态窗口，显示了处理进度。 

Mixture Tuned Matched Filtering 的结果 

mixture tuned matched filtering的结果将以一系列灰阶图像的形式出现，两幅图像对应一个选择
的波谱。匹配滤波浮点型结果提供了一种估计与参照波谱相对匹配程度以及亚像元丰裕度的的方式，

1.0表示完全匹配。The infeasibility结果用的是噪声 σ 单位，表示了匹配滤波结果的可线性。正确
制图的像元匹配滤波分数高，不可线性值低。具有高的匹配滤波结果和高的不可线性的像元是“false 
positive”像元，并不与目标匹配。你可以用二维散点图识别具有不可线性低、匹配滤波分数高的像元
（见“2-D Scatter Plots”）。当观看匹配滤波的结果波段以便只显示包含目标材料的像元时，应当对
直方图的upper tail进行交互式拉伸(见“Results of Matched Filtering”)。 

Continuum Removal (闭联集去除) 

闭联集去除是将反射波谱标准化的一种方法，它允许从通用的基线对每个吸收特征进行比较。

连续波谱消除是一个在波谱顶部的凸起的外壳拟合，它用直线段连接局部的波谱最大值。第一个和

最后一个波谱数据值在外壳上，因此在输出的连续波谱消除的数据文件中的首末波段将等于 1.0 。 
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注意 

用不同的波谱子集将得到不同的结果，因此你应当抽取包含感兴趣区的吸收特征的地方作为子

集。连续统一体通过被分成对应图像每个像元的实际波谱而被消失。最终图像中，在连续波谱和匹

配波谱处，波谱等于1.0，出现吸收特征的地方波谱小于1.0。连续波谱消除可以对数据文件进行或对
绘图窗口的单个波谱（见“Interactive Plot Functions”）。 更多细节，参看“Spectral Tools References”。 

1 选择Spectral Tools > Mapping Methods > Continuum Removal 

2 出现Continuum Removal Input File对话框时，选择输入文件，抽取空间或波谱子集或掩模。 

为得到最好的结果，应当在包含感兴趣的吸收特征的地区抽取波谱子集。 

3 点击“OK”。 

4 出现Continuum Removal Parameters对话框，选择输出到“Memory”或“File”。 

·如果选择输出到“File”，键入一个输出文件名。 

5 点击“OK”，开始处理。 

出现一个状态窗口，显示处理的进度。最终结果将出现在Available Bands List里。 

Spectral Feature Fitting (波谱特征拟合) 

Spectral Feature FittingTM (SFFTM )是一种基于吸收特征的方法，使用最小方块技术将图像波谱的
适配比作选择的参照波谱。在从数据集中进行连续波谱消除以后，参照波谱被缩放到与图像波谱相

匹配。一个比例（scale）图像对应一个参照波谱输出，它是一种量度与材料丰裕度相关的吸收特征
深度的方法。在一个小方块范围内，每个选择的波长处对图像和参照波谱进行比较，并为每个参照

波谱判定平方根误差。详情见“Spectral Tools References”和“Results of Spectral Feature Fitting”。 

1 选择Spectral Tools > Mapping Methods > Spectral Feature Fitting 

2 出现Spectral Feature Fitting Input File对话框，选择连续波谱消除的输入文件和空间/波谱子集
或掩模 

如果选择的输入文件不是连续波谱消除的, ENVI将on-the-fly地消除连续波谱，然而这将使该功
能的执行速度大大减慢。 

为得到最好结果，应在包含感兴趣的吸收特征区域周围抽取波谱子集。 

选择了输入文件以后，或根据需要确定了子集，出现Endmember Collection:Feature Fitting对话框。 

3 用Import_Spectra菜单，输入需要的参照波谱。见  “The Unmixing Endmember Collection 
Dialog”。 

4 点击“Apply”。 

5 出现Spectral Feature Fitting Parameters对话框，用箭头切换按钮选择“Output separate Scale and 
RMS Images”或“Output Combined (Scale/RMS) Image” (见下面)。 

6 选择输出到“Memory”或“File”。 

·如果选择输出到“File”，键入一个输出文件名。 

出现一个状态窗口，显示处理的处理进度。最终输出波段将出现在Available Bands List里。 
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波谱特征拟合的结果 

为每个参照波谱输出一幅比例图像和rms图像或一幅合成的“拟合”图像(Scale/RMS) 。具有一
定比例的图像是一种量度与材料丰裕度相关的吸收特征深度的方法。所以在比例图像中，较亮的像

元表明与那些像元（RMS误差低的区域）中参照材料匹配较好。然而，如果输入了不正确的参照终
端单元或用了不正确的波长范围，就会出现一个远远大于1的比例值。在一个小方块范围内，每个波
长处对图像和参照波谱进行比较，并为每个参照波谱判定平方根误差。在rms误差图像中暗像元代表
了误差值低，能与比例图像的结果相结合用作定位与参照波谱最匹配的区域。 

·在一幅图像中观察与参照波谱匹配最好的区域，为rms和scale做出二维散点图。在散点图中，
划出rms值低、scale值高的区域作为感兴趣区，以突出与参照波谱匹配最好的像元。 

另外一种生成结果（显示参照材料分布）的方式是运用“拟合”图像(Scale/RMS)。较高的拟合
值表明与参照波谱匹配较好。 

·生成一幅输出的类分类（classification-like）结果图像，在ENVI主菜单中，选择Classification > 
Rule Classifier用最大初始值为输出图像初始化。 
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Spectral Analyst (波谱分析) 
ENVI的波谱分析TM有利于根据材料的波谱特征识别它们。它运用ENVI技术，如二进制编码、
波谱角度制图仪以及波谱特征拟合等，对波谱库中的未知波谱与材料的匹配进行排序（见see“Binary 
Encoding”，“Spectral Angle Mapper”和“Spectral Feature Fitting”中对于方法的详细描述）。你也可以
限定你自己的波谱类似(spectral similarity)技术，并将它们添加到波谱分析中（见ENVI程序指南中的
“Spectral Analyst Functions”）。波谱分析的输出是一张输入的波谱库列表，匹配的顺序由最好依次
到最差。记录了一个总体的类似度“得分”和每个方法中个别的0~1得分。详情见“Tips For Successful 
Use of the Spectral Analyst”。 

警告 

这一函数并不识别波谱，仅仅为识别推荐可能的侯选者。当用到类似的方法或改变了权重时，

结果也许会改变。进行实际的识别主要还在于你。 

运用波谱分析： 

1 选择Spectral Tools > Spectral Analyst 

2 出现Spectrum Analyst Input Spectral Library对话框，选择用于比较的波谱库，点击 “OK” 

出现Edit Identify Methods Weighting对话框。 

3 在“Weight”文本框，为每种类似（近似）方法键入需要的权重系数 

权重系数可以为任何值，到波谱库的完全匹配将有一个输出的权重总和的“得分”。一个推荐

的起始点是在波谱特征拟合TM中用一个1.0的权重。 

4 如果需要，为每种方法编辑“Min”和“Max”系数。 

“Min”和“Max”系数用于表明什么数值被认为是完全匹配（通过将它们缩放到0与1之间）。 

对于波谱角度制图仪(SAM)方法，到波谱库的类似（接近）由角度（弧度）来衡量，键入的最
小值和最大值都用弧度表示。 

对于波谱特征拟合(SFF)方法，类似度由RMS拟合误差以及键入的最小值和最大值（用RMS误差
单位）衡量。 

对于二进制编码方法，最小值和最大值是正确匹配的波段百分比(0-1)。 

若SAM或SFF的结果小于或等于最小值，表示进行了完美的匹配，得分为1。若SAM或SFF的结
果大于或等于最大值，得分将等于0。如果二进制编码的结果小于或等于最小值，得分将等于0，若
二进制编码的结果大于或等于最大值，得分将等于1。见“Binary Encoding”，“Spectral Angle Mapper”
和“Spectral Feature Fitting”中有关方法的描述。 

5 在Edit Identify Methods Weighting对话框，点击“OK” 。 

Spectral Analyst 对话框 

波谱分析对话框显示了类似度（近似度）测量的结果。它有两个下拉菜单：File 和 Options, 允
许你打开一个新的波谱库，编辑权重、最小值和最大值，输入x、y放大系数，从一幅Z剖面图中得到
输入波谱。当显示一个波谱时，波谱分析就会检查显示的要进行分析的图示范围。你可以用鼠标左

键点击对话框的任何一角，将其拖曳到需要的大小和形状。 



 349

1 出现Spectral Analyst对话框时，点击“Apply”输入一个波谱。 

·如果打开了一个波谱图，则这个波谱将被自动输入到波谱分析中。 

·如果不只一个波谱被图示，选择需要的波谱名。 

·波谱也可直接从一个Z-剖面窗口中输入（见下面）。 

ENVI将对波谱库进行重采样，以便与输入波谱的分辨率相匹配。 

2 选择下列选项： 

·使用一个特定的波长范围，用鼠标中键将图幅窗口缩放到需要的波长范围，在Spectral Analyst
对话框中，点击“Apply”。 

·在Spectral Analyst列表中的波谱库名上，双击鼠标左键，显示一幅具有输入波谱和一个选定的
波谱库的图（经过连续波谱消除的）。 

·打开一个新的波谱库文件，以便于在比较中应用： 

A 选择File > New Spectral Library File. 

B 出现Spectral Analyst Input Spectral Library对话框时，选择用于比较的波谱库。 

·编辑方法中用到的权重系数，以及最小值和最大值： 

A 选择Options > Edit Method Weights. 

B 出现Edit Identify Methods Weighting对话框时，根据需要编辑权重系数，以及最小值和最大值。 

·键入或编辑用于缩放输入波谱，使其与波谱库具有相同空间的 X 和 Y 缩放系数： 

A 选择Options > Edit (x,y) Scale Factors. 

B 出现Edit (x,y) Scale Factors对话框时，键入需要的X和Y缩放系数。 

·直接从一个Z-剖面窗口中键入波谱： 

A 选择Options > Auto Input via Z-profile. 

B 在图像内或缩放窗口里点击，抽取需要的Z-剖面(见“Image Spectral Plots (Z Profiles)”)。 

信息将出现在 Spectral Analyst 窗口中。当你将缩放框移如主显示窗口（Main display）， Spectral 
Analyst信息将随之发生变化。 

提示 

如果你显示了两幅图像，在用 Spectral Analyst 第二次显示之前，必须选择 Options > Clear Auto 
Inputs。 

波谱分析的输出 

波谱分析的输出是输入波谱库中的每种材料的得分排序或赋有权重的得分。最高得分表示匹配

最好，波谱相似度（近似度）的可信度高。类似的材料也许得分相对较高，但是不相关的材料得分

较低。 
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对成功应用波谱分析的提示 

波谱分析建立在波谱匹配技术（对成功运作有具体的要求）的应用上。下面的条目总结了控制

性能有效使用所考虑的事项。 

波长范围 
许多材料在一个波长范围内是类似的，但是在其它范围具有很大差异。包含诊断吸收特征的波

长范围将产生最好的结果。当显示一个波谱时，Spectral Analyst将检查图示中显示的被分析的范围。
如果需要一个亚范围，在图中用鼠标中键放大需要的波长范围（用于分析），然后点击Spectral Analyst
中的“Apply”。 

特征的出现 
判定材料是否有吸收特征。如果它们有，最好用波谱特征拟合。此外，波谱角度制图仪和二进

制编码也能得到较好的结果。 

库中材料的出现(与其它材料的类似) 
不在参照波谱库中的材料将不被识别。这时，类似的材料也许得分值相对较高。 

多重材料（混合物） 
多重材料的高分也许表明是混合物，尤其对于在波谱的不同部分有吸收特征的矿物（材料）。

Spectral Analyst功能对于判定终端单元（“纯”的终端单元波谱）效果是最好的。  

得分巨大与得分分离 
较高的得分预示着较大的可信度，因为满足的规则较多。在临近得分之间存在的较大分离预示

着在相似度（近似度）方面可信度较高。例如，一种材料0.98的得分后面是另一种材料0.96的得分，
这预示着未知材料与设置的规则非常相似。然而，一种材料0.98的得分后面是另一种材料0.50的得分，
这便预示着波谱更可能代表第一种材料。 

多重匹配（得分相同） 
许多情况下，波谱分析在规则基础上可以对不同材料显示多个相同的得分。这预示着这种分析

在用于识别时不能区别两种材料。或者尝试不同的波长范围，或用不同权重的方法生成唯一的答案。 

不匹配（0分） 
有时，波谱分析对库中的材料全部显示 0 分（不匹配）。这巧妙地预示了材料不在用到的波谱
库中，也不与库中的其它材料相类似。 

上下文（Context） 
最后，在图像设置的上下文和已知信息中检查波谱顺序。如果已知信息暗含出识别的结果好象

是假的，那么它有可能就是不正确的。 

波谱分析作为一个起点 
这一工具不是完全有把握的。这意味着仅仅作为一个起点让你继续做进一步的判断。恰当地应

用，一个好的波谱库可以为识别提供极其有用的暗示。盲目地应用，很可能产生整体错误的结果。 
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第十一章：Radar Tools (雷达工具) 
ENVI为分析探测的雷达图像以及高级的SAR系统（如JPL的完全极化测定的AIRSAR与SIR-C系

统等）提供了标准的和高级的工具。ENVI可以处理ERS-1、JERS-1、RADARSAT、SIR-C、X-SAR
和AIRSAR数据以及其它方式探测到的SAR数据集。此外， ENVI是为处理CEOS格式的雷达数据而
设计的，它应该也能处理上面没有提到的来自其它雷达系统的数据（也呈CEOS格式）。 

多数标准ENVI处理函数本身就有对雷达数据的处理能力，如所有的显示功能、拉伸、颜色处理、
分类、配准、滤波、几何纠正等。还有另外的专门工具能分析极化测定的雷达数据。雷达专用工具

可以从Radar Tools菜单里选择。个别菜单项也有特别使用于雷达数据处理的。这些也可以从ENVI
主菜单的功能项里得到。见ENVI SAR 指南中运用一些雷达函数的例子。 

Review CEOS Header (浏览CEOS文件头) 
这以功能将 CEOS 头信息输出到屏幕上，用于一般的CEOS数据型(即ERS-1, JERS-1, SIR-C, 

X-SAR)或RADARSAT文件头。 

1 选择Radar Tools > Review CEOS Header > Generic 或 RADARSAT. 

2 出现一个标准ENVI文件选择对话框，选择需要的CEOS文件，头信息将从中读取。 

有关头信息的记录显示在屏幕上。 

·将记录存储到一个输出文件，选择File > Save Text to ASCII，并键入一个输出文件名。 

读取 CEOS 数据 
ENVI能读取SIR-C、RADARSAT、一般的CEOS数据型以及RADARSAT CD-ROM数据。 为节
省磁盘空间，你可以直接从磁带中抽取数据子集。 

读取 SIR-C CEOS 磁带 

ENVI (用于UNIX、Windows 95或Windows NT) 包含有读取SIR-C磁带（JPL的CEOS格式分布）
的程序。支持Single Look Complex (SLC)、Multilook Complex (MLC)和Multilook Ground Detected 
(MGD)格式。 

为节省磁盘空间，你可以直接从磁带上抽取部分SIR-C数据（或称抽取SIR-C数据子集）。此外，
SLC数据集可以从磁带上被多视，呈整型或非整型形式。开始磁带处理功能： 

1 选择Radar Tools > Read CEOS Data > Read SIR-C CEOS Tape。 

2 出现SIR-C Format - Load Tape对话框时，键入磁带设备名以及磁带上预期的最多记录数。 

3 点击“OK”，开始读取磁带。 

当ENVI扫描磁带，转换为标准的SIR-C格式时，出现一个状态窗口。扫描磁带完成以后，将出
现SIR-C Tape File Selection对话框，在对话框中“Select Output Files”文本标签下方，显示出磁带上
SIR-C数据文件的一个列表。 

4 点击需要的数据集，选择从磁带上要读取的数据。 

·若选择连续显示的一组数据集，则点击这一组的第一个，按住“shift”键，再点击最后一个，

Administrator
第十一章：Radar Tools (雷达工具)

Administrator
ENVI为分析探测的雷达图像以及高级的SAR系统（如JPL的完全极化测定的AIRSAR与SIR-C系
统等）提供了标准的和高级的工具。ENVI可以处理ERS-1、JERS-1、RADARSAT、SIR-C、X-SAR
和AIRSAR数据以及其它方式探测到的SAR数据集。此外， ENVI是为处理CEOS格式的雷达数据而
设计的，它应该也能处理上面没有提到的来自其它雷达系统的数据（也呈CEOS格式）。
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或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个数据集，则按住“ctrl”键，再一一点击它们。最后再将一些不需要
的删除。 

·选择所有数据集，点击 “Select All Items”。 

·删除所有数据集，点击 “Clear All Items”。 

5 点击 “OK”，启动 SIR-C Tape Parameters 对话框。 

SIR-C Tape Parameters 对话框 
选择的 SIR-C 数据集将被显示在 “Selected SIR-C Tape Files:” 列表里。下一步是根据需要选择

空间子集，指定输出文件名，并根据需要从磁带上选择多视。每个数据集将被独立命名和处理。 

从磁带上读取空间子集： 

1 点击数据集名； 

2 点击“Spatial Subset”，用标准ENVI建立子集程序抽取数据子集（注意：由于这一阶段中没有
合成图像，所以是无法得到“图像”子集的）； 

3 点击“OK”，返回SIR-C Parameters对话框； 

4 重复上述过程选择对话框中列出的每个数据集。 

·从磁带上多视(multilook) 数据： 

注意 

从磁带中多视需要的时间较长，是因为磁带读取之间处理数据所致的启停式磁带传送（start-stop 
tape movement）。如果磁盘空间不够，只有选择这项才可以读取整个数据集。在磁盘上多视是比较
快的，这是处理时首选的项(见“Multilook Compressed Data”)。 

1 点击数据集名，点击“Multi-look”； 

出现SIR-C Multilook Parameters对话框。多视参数可以通过选择范围中需要显示的数目、方位角
方向、键入需要输出的像元数或键入输出像元的大小（用米为单位）来确定。当这些参数中一个被

输入，其它的将自动被计算与之相匹配。例如，如果你键入的像元大小是30米，则相应的像元数、
显示的数目将被计算，并在相应文本框里自动改变数值。 

2 键入需要的多视输出大小参数； 

·在”Looks”文本框里，键入需要显示的样本数与行数。 

支持整型和浮点型的显示数。 

·作为选择，可以在“Pixels”文本标签下方的文本框里，键入样本数和行数，以便确定输出图像
中需要的像元数。 

·最后，你可以在“Pixel Size (m)”文本框里，键入样本数和行数，以指定需要输出的像元大小（单
位：米）。 

3 点击“OK”，返回到SIR-C Tape Parameters对话框； 

4 为对话框中列出的每个数据集重复上述过程。 

·键入输出的文件名： 
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1 在SIR-C Tape Parameters对话框中，“Selected SIR-C Tape Files”文本标签下的列表中，点击一
个数据集名； 

2 在标有“Enter Output Filename [.cdp]”)的文本框里，键入需要输出的文件名；. 

按照惯例，文件名应采用下列形式：filename_c.cdp和filename_l.cdp. 

3 为对话框中列出的每个数据集重复上述过程。 

一个压缩的散射矩阵输出文件将为每个选择的数据集而建立。 

4 一旦所有的磁带读取参数都已经输入，点击“OK”，开始读取磁带，并处理数据。 

磁带读取和完成处理需用的时间从不到一个小时到几个小时不等。这依赖于SIR-C数据的类型、
大小以及选择的数据集数。 

读取 Generic CEOS 磁带 

ENVI 包括了一个灵活的 CEOS 格式磁带读取程序，可用于 UNIX、Windows 95、和 Windows 
NT，它允许你读取 CEOS 格式的各种 SAR 数据磁带。运用这一程序可以读取 ERS-1、JERS-1 和 
X-SAR (MLD) 数据。CEOS 信息直接用于使用户界面最小化，简化 ENVI 显示和分析文件的建立。
为节省磁盘空间，你可以直接从磁带上读取数据子集。 

1 选择 Radar Tools > Read CEOS Data > Read Generic CEOS Tape，启动磁带处理功能； 

2 出现 CEOS Format - Load Tape 对话框时，键入磁带设备名以及期待的磁带上最大记录数，
点击 “OK”，开始读取磁带； 

当 ENVI 将磁带扫描为标准 CEOS 格式时，出现一个状态窗口。扫描结束，将出现 CEOS Tape 
File Selection 对话框。 

3 在CEOS-格式数据文件列表里（“Select Output Files”文本标签下方）点击需要的数据集，以确
定从磁带上要读取的数据； 

·若选择连续显示的一组数据集，则点击这一组的第一个，按住“shift”键，再点击最后一个，
或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个数据集，则按住“ctrl”键，再一一点击它们。最后再将一些不需要
的删除。 

·选择所有数据集，点击“Select All Items”。 

·删除所有数据集，点击“Clear All Items”。 

4 点击 “OK”，启动 CEOS Tape Parameters 对话框。 

CEOS Tape Parameters 对话框 
在  CEOS Tape File Selection 对话框里选择的  CEOS 数据集将列表显示在  CEOS Tape 

Parameters 对话框的 “Selected CEOS Tape Files:” 列表里。下一步是根据需要选择空间子集，指定
输出文件名。每个数据集将被独立命名和处理。具体做法见下面。 

空间构造子集 
从磁带上读取空间子集： 

1 点击一个数据集名； 
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2 点击 “Spatial Subset”，用标准 ENVI 建立子集程序。 

3 点击 “OK”，返回 CEOS Tape Parameters 对话框 

4 为对话框中列出的每个数据集重复上述过程。 

·键入输出文件名： 

1 在 CEOS Tape Parameters 对话框中，“Selected CEOS Tape Files” 文本标签的下方的列表中，
点击每一个需要的数据集名； 

2 在 “Enter Output Filename” 文本框里，键入需要的输出文件名。 

3 为对话框中列出的每个数据集重复上述过程。 

将为选择的每个数据集建立一个图像输出文件。 

4 一旦所有的磁带读取参数都已经输入，点击“OK”，开始读磁带和处理数据。 

被处理的图像将出现在 Available Bands List 中，并且能用标准 ENVI 程序显示和处理。 

读取 RADARSAT CEOS 磁带 

如果在 UNIX、Windows 95 或 Windows NT 平台上运行 ENVI，用这一功能将 RADARSAT 
CEOS 从磁带读取到磁盘上。为节省磁盘空间，你可以直接从磁带上抽取 RADARSAT 数据子集。 

1 选择 Radar Tools > Read CEOS Data > Read RADARSAT CEOS Tape，启动磁带处理功能； 

2 出现 RADARSAT - Load Tape 对话框时，输入磁带设备名和期待的磁带上最大记录数，开始
读磁带； 

当ENVI将磁带扫描为标准 RADARSAT 数据格式时，出现一个状态窗口。扫描结束，将出现 
RADARSAT Tape File Selection 对话框。 

3 在 RADARSAT 数据文件列表里（“Select Output Files”文本标签下方）点击需要的数据集，
以确定从磁带上要读取的数据； 

·若选择连续显示的一组数据集，则点击这一组的第一个，按住“shift”键，再点击最后一个，
或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个数据集，则按住“ctrl”键，再一一点击它们。最后再将一些不需要
的删除。 

·选择所有数据集，点击 “Select All Items”。 

·删除所有数据集，点击 “Clear All Items”。 

4 点击“OK”，启动 RADARSAT Tape Parameters 对话框。 

RADARSAT Tape Parameters 对话框 
在 RADARSAT Tape File Selection 对话框里选择的 RADARSAT 数据集，将列表显示在 

RADARSAT Tape Parameters 对话框的 “Selected RADARSAT Tape Files:” 列表里。这些文件可以用
来抽取空间子集，和指定输出文件名。每个数据集将被单独命名和处理。具体做法见下面。 

从磁带上读取空间子集： 

1 点击一个数据集名； 
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2 点击 “Spatial Subset”，用标准 ENVI 建立子集程序。 

3 点击 “OK”，返回 RADARSAT Tape Parameters 对话框。 

4 为对话框中列出的每个数据集重复上述过程。 

·键入输出文件名： 

1 在 RADARSAT Tape Parameters 对话框中，“Selected RADARSAT Tape Files” 文本标签的下
方的列表中，点击每一个需要的数据集名； 

2 在 “Enter Output Filename” 文本框里，键入需要的输出文件名。 

3 为对话框中列出的每个数据集重复上述过程。 

将为选择的每个数据集建立一个图像输出文件。 

4 一旦所有的磁带读取参数都已经输入，点击 “OK”，开始读磁带和处理数据。 

被处理的图像将出现在 Available Bands List 中，并且能用标准 ENVI 程序显示和处理。 

从 CD 或磁盘上读取 RADARSAT CEOS 数据 

·将字节型RADARSAT数据文件读到ENVI: 

1 选择 Radar Tools > Read CEOS Data > Read RADARSAT Data. 

2 选择需要的数据文件，ENVI 将自动抽取需要的头信息，并将图像波段输入到 Available Bands 
List 里。 

·将整型RADARSAT数据文件读到ENVI: 

1 选择 Radar Tools > Read CEOS Data > Read RADARSAT Data. 

2 选择需要的数据文件，ENVI 将自动抽取需要的头信息，并将图像波段输入到 Available Bands 
List 里。 

3 出现 RADARSAT File Import 对话框时，从 “Import Data Type” 标签附近的按钮下拉菜单
里，选择 “Scale to Byte” 或 “Unsigned Integer”。 

·如果选择了缩放字节，输入要缩放的最小和最大数据值。“Min” 和 “Max” 值将按照（若能
找到）CEOS 文件头中的直方图的2%点自动输入。 

·如果无法找到 CEOS 文件头，你必须键入这些值。 

4 点击 “OK”，开始读数据。 

图像波段将被输入到 Available Bands List 中。 

·将复合型RADARSAT数据文件读到ENVI: 

1 选择 Radar Tools > Read CEOS Data > Read RADARSAT Data. 

2 选择需要的数据文件，ENVI 将自动抽取需要的头信息，将  Q 和  I 图像波段输入到 
Available Bands List 里。 

复数型 RADARSAT 数据将被读入 ENVI，字节 Q 和 I Stokes Parameters用于原始(RAW) 产
品类型，integer*2 Q 和 I 用于 SLC 产品。 
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Antenna Pattern Correction (天线阵列校正) 
由于仪器的天线接受阵列，雷达图像在垂直于行程方向有明显的畸变。ENVI 的天线阵列校正

函数可以用来消除这种畸变。计算出方位角平均值，并做图显示行程方向上的平均变化。由用户限

定次数的一个多项式函数可以用来消除接受时产生的畸变。可以选择加法或乘法校正。情见以下参

考书： 

Ulaby, F. T., R. K. Moore, and A. K. Fung, 1982. Microwave Remote Sensing Active and Passive, 
Volume II, Artech House, Inc., Norwood, MA, 1064 p. 

·进行天线阵列校正： 

1 选择 Radar Tools > Antenna Pattern Correction； 

2 出现 Antenna Pattern Input File 对话框时，选择输入文件，并根据需要抽取空间或波谱子集； 

出现 Antenna Pattern Correction Parameters 对话框。 

3 在 “Samples” 或 “Lines” 附近的复选框里，点击选择行程方向。 

4 选择 “Additive” 或 “Multiplicative” 校正方法。 

特别地，乘法校正被用做雷达天线阵列畸变。 

5 键入需要的多项式次数，点击 “Plot Polynomial”，显示出一张红色平均值图，上面叠置着白
色的选择的多项式的拟和。 

·多项式的最高次数可以根据需要改变，并再次做图。 

最好用一个低次多项式，以便不消除后向散射信号中的局部改变。 

注意 

只有用 “OK” 或“Cancel” 按钮关闭 Antenna Pattern Correction Parameters 对话框时，才能激活 
Antenna Pattern Correction 图表的下拉菜单。 

6 选择输出到 “Memory” 或 “File”； 

·如果选择输出到 “File”，键入一个输出文件名。 

7 点击 “OK”，开始处理。 
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Slant to Ground Range (斜距校正) 
雷达装置测量到平台一侧的距离(倾斜距离)，它导致了真实地面制图中的纠正(地面距离)。假定

地形是平坦的，到地面倾斜范围的函数按照地面范围内像元大小对倾斜的雷达图像进行重采样（The 
slant-to-ground range function resamples slant range radar images to ground range pixel sizes assuming flat 
terrain）。 

AIRSAR、RADARSAT 与 SIR-C 

Slant-to-Ground Range 函数用到 AIRSAR、SIR-C和RADARSAT 数据类型的头信息。键入几个
需要的参数，这个函数也可用于其它的雷达数据集。 

·运用来自AIRSAR、RADARSAT或SIR-C数据型的头信息： 

1 选择 Radar Tools > Slant to Ground Range > AIRSAR, RADARSAT 或 SIR-C； 

2 出现一个标准ENVI输入文件对话框时，根据需要选择输入文件或任何空间和波谱子集； 

3 点击 “OK”，出现 Slant to Ground Range Correction 对话框； 

4 键入需要输出的像元大小，选择需要的重采样方法以及输出到内存或文件； 

5 点击 “OK”，开始处理。 

Generic 

·运用来自其它数据类型的头信息： 

1 选择 Radar Tools > Slant to Ground Range > Generic； 

2 出现一个标准 ENVI 输入文件对话框时，根据需要选择输入文件或任何空间和波谱子集； 

3 点击 “OK”，出现 Slant to Ground Range Correction 对话框； 

4 键入仪器高度、近距离、倾斜距离像元大小，以及需要输出的像元大小； 

5 为行程方向选择 “Samples” 或 “Lines”，“right”或“left”表示看的方向，选择需要重采样的方
法。 

关于重采样方法的具体介绍，请看“Warping and Resampling Options”。 

6 选择输出到 “Memory” 或 “File”； 

·若选择输出到 “File”，键入一个输出文件名。 

7 点击 “OK”，开始处理。 
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Synthetic Color Image(合成彩色图像) 
你可以用 Synthetic Color Image 项将一幅灰阶图像转换成一幅彩色合成图像。这个转换通常用
于将大比例尺雷达数据在保留有用细节情况下增强其中细微特征的显示。 

·选择 Radar Tools > Synthetic Color Image。 

具体内容，见 “Synthetic Color Image”。 
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Incidence Angle Image (入射角图像) 
一幅入射角图像可以由  AIRSAR (与  TOPSAR 数据集相关的  AIRSAR 数据除外 )、

RADARSAT、SIR-C 和一般的雷达数据生成。假定地形平坦，入射角基于近距离角(near range angle) 
和远距离角(far range angle) 计算。 

AIRSAR、RADARSAT 与 SIR-C 

·由 AIRSAR (与 TOPSAR 数据集相关的 AIRSAR 数据除外)、RADARSAT 或 SIR-C 生成
一幅入射角图像： 

1 选择 Radar Tools > Incidence Angle Image > 输入的雷达数据类型； 

2 选择需要的输入文件，点击“OK”； 

需要的信息将自动从头文件中读取。如果没有找到所有需要的参数，在合适文本框里键入丢失

的数值。 

3 出现 Incidence Angle Parameters 对话框，选择要输出的入射角（单位：弧度或度）； 

4 选择输出到 “File” 或 “Memory”； 

·如果选择输出到 “File”，键入一个输出文件名。 

5 点击 “OK”，开始处理。 

Generic 

·运用其它数据类型生成入射角图像： 

1 Radar Tools > Incidence Angle Image > Generic。 

2 出现 Incidence Angle Information 对话框时，在合适文本框里，键入输出的样本数和行数，以
及近距离和远距离角（单位：度）； 

3 用 “Sample” 或 “Line” 切换按钮，选择射程方向，并用 “Right” 或 “Left” 切换按钮，选择
观察方向； 

4 一旦输入了所有需要的信息，点击 “OK”； 

5 出现 Incidence Angle Parameters 对话框时，选择要输出的入射角（单位：弧度或度）。 

6 选择输出到 “Memory” 或 “File”； 

·若选择输出到 “File”，键入一个输出文件名。 

7 点击 “OK”，开始处理。 
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Adaptive Filters (自适应滤波器) 
ENVI 包括几个自适应滤波器，它们可以用于 SAR 处理。这些滤波器包括 Lee、Frost、Gamma、

Kuan、用于减少图像斑点的局部 σ 滤波器，以及消除坏像元的比特误差滤波器（Bit Errors filter）。 

·选择一个滤波器，点击Radar Tools > Adaptive Filters > Filters。 

这些也可以从ENVI主菜单上的Filters菜单里调用，具体描述见前面的“Adaptive Filtering”。 
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Texture Filters (纹理滤波器) 
ENVI 包括几个纹理滤波器，它们允许从 SAR 或其它数据类型中抽取纹理信息。这些包括基

于数据范围、RMS、数据的一阶矩和二阶矩滤波。 

·选择一个滤波器，点击 Radar Tools > Texture > 需要的滤波器。 

这些也可以从 ENVI 主菜单上的 Filters 菜单里调用，具体描述见前面的“Texture Filters”。 
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Polarimetric Tools (极化工具) 
ENVI 有一套用于 NASA/JPL AIRSAR、TOPSAR 和 SIR-C 数据型的极化测定的雷达分析工
具。这些极化测定的雷达数据被存储为一种压缩的Stokes或散射矩阵格式（scattering matrix format），
所以这些数据不能直接看到，它们需要专用工具。ENVI 中极化测定的工具包括浏览文件头、解压
（decompress）和合成图像、多视(multilook) SIR-C 压缩数据、计算相位和消隐脉冲高度图像、进行 
AIRSAR 散射分类技术，以及抽取极化信号。 

浏览 AIRSAR/TOPSAR 文件头 

浏览 AIRSAR 和 TOPSAR 数据文件的 ASCII 文件头： 

1 选择 Radar Tools > TOPSAR Tools > View AIRSAR/TOPSAR Header. 

2 选择需要的数据文件。 

头信息将被显示在一个记录窗口中。将这些信息存为一个 ASCII 文件，选择File > Save Text to 
ASCII，键入一个输出文件名。 

解压-合成图像（Decompress-Synthesize Images） 

特殊地，极化测定的雷达数据以一种压缩的散射矩阵格式存在，这种格式对于大多数图像处理

软件都无法浏览。ENVI 的合成功能为直接由  JPL AIRSAR 压缩的  Stokes 矩阵数据（以及 
TOPSAR 数据集的 AIRSAR 部分）或 SIR-C 分散矩阵（scattering matrix）压缩的数据生成发射/
接收的极化图像的合成提供了一种易于使用和灵活的方法。这包括每个频率的标准HH、VV、HV和
总功率（Total Power）图像。其它的发射/接收联合可以通过键入需要的椭圆率和方位角合成。压缩
的数据用于生成浮点型图像（可以在ENVI标准图像处理函数中应用）。当不需要进行定量分析时，
这个增强的合成功能还允许生成字节型图像，以节省磁盘空间。 

合成 JPL AIRSAR 图像 
使用合成功能时，AIRSAR 数据必须用 JPL stokes 矩阵格式（AIRSAR – 标准文件扩展名为 

“.stk”）。JPL AIRSAR数据通常用压缩的 Stokes 矩阵格式，以三个独立的文件传送到 9-轨、8mm 或 
4mm 的磁带上。详情见关于 JPL AIRSAR 的文件描述。 

用标准的系统化磁带工具或 ENVI “Dump Tape” 程序将这些文件传输到你的当地磁盘上（见
“Dump Tape”）。为了处理方便，你应当按照下面惯例为三个文件命名：filename_p.stk，
filename_l.stk和filename_c.stk。文件头中有丢失或呈非标准形式时，AIRSAR 数据也可
以用 ENVI 的解压/合成功能，但是需在合适文本框里手工键入数据参数。合成 AIRSAR 图像项允
许你用压缩的 Stokes 文件合成标准的和特定的发射/接收极化和总功率图像。在 AIRSAR 图像用于 
ENVI 标准处理程序之前，必须先被合成。所有的合成的波段被放在一个单独文件中。关于用 
AIRSAR 数据解压和合成图像的具体信息，请看下面的参考书。 

van Zyl, J.J., H.A. Zebker, and C. Elachi: Imaging radar polarization signatures: theory and 
observation. Radio Science 22(4):529-543, 1987. 

Zebker, H.A., J.J. van Zyl, and D.N. Held. Imaging radar polarimetry from wave synthesis. Journal of 
Geophysical Research 92(31):683-701, 1987. 
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·合成 AIRSAR 图像： 

1 选择 Radar Tools > Polarimetric Tools > Decompress-Synthesize Images > Synthesize AIRSAR 
Images； 

出现 Input Stokes Matrix Files 对话框。 

注意 

用这一对话框读取压缩的 Stokes 矩阵文件— Stokes 矩阵文件不能用 ENVI 标准的 File 菜单
项打开。 

2 点击 “Open File”，显示一个标准文件选择对话框； 

3 选择一个 Stokes 矩阵文件名。 

如果文件有一个合法的 AIRSAR 文件头，且具有所有需要的参数，文件名将显示在 Input 
Stokes Matrix File 对话框的其中一个 “Selected Files” 文本框里，依赖于是 P-、L-、或C-波段的数
据。如果你选择了提示的常规文件名，另外两个相应的文件名将自动被输入到合适的文本框里。否

则，必须为每个波段重复文件选择程序。 

·如果文件没有一个合法（有效）的 AIRSAR 文件头，或一些数值从文件头中丢失，则将出现 
AIRSAR Header Parameters 对话框，允许输入数值。 

所有已知参数都显示在对话框里。 

A 变换核实这些参数，并根据需要改变或添加数值。 

由于 JPL 为特殊处理器形式（particular processor version）改变了文件头参数，所以对话框总是
出现（开着）。特别地，“COMP SCALE FACTOR”(也称作“GENFAC”) 或 “Band” 也可能从文件头
中丢失(多数情况下比较时，用1.0的比例系数)。 

B 键入需要的数值，点击 “OK”，返回到 Stokes Matrix Input File 对话框。 

·无论何时，要清除在 Stokes Matrix Input File 对话框中的文件名，点击 “Reset” 或点击 
“Cancel” 终止。 

4 点击 “OK”，认可文件名，显示 Synthesize Parameters 对话框。 

选择合成参数 
对话框允许选择特定的发射和接收极化组合，将其合成为 ENVI 图像。“标准的”极化(H=水

平，V=垂直) “HH”、“VV”、“HV”和一幅总功率(TP) 图像默认地为三个频率（波段）中的每一个生
成。这些被显示在 “Select Bands to Synthesize:” 文本框里。 

·切换标准的波段开启或关闭，点击波段名左边的小框。 

·为直接由 Stokes 矩阵数据合成的图像构建空间子集，点击“Spatial Subset” ，运用 ENVI 标
准空间子集程序（见 “Standardized ENVI Spatial Subsetting”） 

“Image” 中的构建子集项是无法使用的，因为它需要图像格式的数据，而不是压缩的数据。 

·选择另外的发射和接收极化： 

1 在 “Transmit Ellip/Orien” 和 “Receive Ellip/Orien” 文本框里，键入需要的发射和接收椭圆率
与方位角，点击 “Add Combination” 按钮； 

椭圆率值的范围是从 –45 度到 45 度，椭圆值为 0 表示形成线性极化。方位角数值范围是 0 
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到 180 度，0 代表水平极化，90 度代表垂直极化。 

2 在波段名左边的小框里，选择需要的波段——C、L 或 P； 

3 点击 “Add Combination”。 

选择的图像将被显示在 “Additional Images:” 文本框里。 

·输出图像或将它们转换为 dB (分贝), 选择 “Output in dB?” 文本标签附近的 “Yes” 切换按
钮；如果选择了 “No”，图像将以浮点型数值输出。 

·另外，不需要定量分析时，可以选择 “Output Data Type” 按钮下拉菜单中的 “Byte”，以输出
字节型图像。 

当选择字节型数据时，你必须输入标准差乘数（multiplier），用于为缩放到标签为 “Std Multiplier” 
的文本框计算一个最小值和一个最大值。对多数 AIRSAR 图像，默认值是 1.5 。但是，如果需要，
可以由用户自己改变。 

·屏蔽坏的数据值, 在 “Intensity Min” 和 “Max” 文本框里，键入要用到的最小和最大数据值，
用强度（intensity）单位。 

当输出 dB 格式的图像时，最小值和最大值仍被键入（以强度为单位）。由于计算 dB 以前，
输出要由这些数值约束（例如，如果你将数据限制到 0 与 1 之间，则dB图像将被限制到 -Inf to 0）。 

小于最小值的合成值将被设定为 0 ，大于最大值的合成值将被设定为1。 

合成图像 
所有选择的图像被放在一个单独的输出文件中。 

1 选择输出到 “File” 或 “Memory”； 

·如果选择输出到 “File”，在 “Enter Output Filename” 文本框里键入一个输出文件名；或用 
“Choose” 按钮选择一个输出文件名。 

2 点击 “OK”，开始处理。 

一旦合成完毕，图像将被添加在 Available Bands List 中，能用 ENVI 标准图像处理功能进行
处理。 

合成 SIR-C 图像 
ENVI 中，SIR-C 数据是用于合成功能的压缩数据产品格式( SIR-C 标准文件扩展名为 .cdp )。
为确保 SIR-C 数据是正确的压缩数据产品格式，应当用 SIR-C 磁带程序将它们读到磁盘上。他们
应按照惯例命名为：filename_c.cdp 和 filename_l.cdp 。没有用 ENVI 从磁带上读取的 SIR-C 数据
也可以用 ENVI 解压/合成（Decompress/Synthesize）功能，这样数据参数就必须手工键入到合适文
本框里。 

这项允许你由 SIR-C 压缩散射矩阵文件合成标准和特定的发射和接收极化与总功率（TP）图
像。SIR-C Single Look Complex (SLC) 和 Multi-Look Complex (MLC) 图像在用于 ENVI 标准处理
程序之前，必须先被合成。所有合成后的波段被存入一个单独的输出文件中。详情见 “Synthesize JPL 
AIRSAR Images” 部分列出的参考书。 

·合成 SIR-C 图像： 

1 选择 Radar Tools > Polarimetric Tools > Decompress-Synthesize Images > Synthesize SIR-C 
Images； 
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出现 Input Data Products Files 对话框。用这一对话框读取 SIR-C 压缩的散射矩阵文件。 

注意 

散射矩阵文件不能用 ENVI 标准的 File 菜单选择打开。 

2 点击 “Open File”，显示一个标准文件选择对话框； 

3 从列表中选择一个 SIR-C 散射矩阵(.cdp) 文件名。 

如果文件是一个合法的 ENVI 压缩数据文件，且具有所有需要的参数，文件名将显示在 Input 
Data Product File 对话框的其中一个 “Selected Files” 文本框里，依赖于是 L- 或 C-波段的数据。如
果你选择了提示的常规文件名，另外一个文件名将自动被输入到合适的文本框里。否则，必须为每

个波段重复进行文件选择。 

注意 

·如果文件不是一个合法（有效）的 ENVI 压缩数据文件，则将出现 SIR-C Header Parameters 
对话框，允许输入数值。当 ENVI 不被用于读取 SIR-C 数据时，对话框将会出现。需要的信息可
以从具有数据的 JPL 提供的打印预览中得到，或通过打印或浏览一个 ASCII CEOS 头文件（在 
SIR-C 存储的磁带上）得到。  

所有已知参数都显示在对话框里。 

·输入自身说明的 “Samples” 和 “Lines” 参数。 

·“Width (km):” 参数对应于行程方向的相应图像大小（单位：公里）。 

·“Length (km):” 参数是方位角方向的景象大小（单位：公里）。 

·“Offset:” 是为到达压缩的 SIR-C 起点数据而跳过的任何嵌入的文件头出现的字节偏移。  

·点击合适的切换按钮，选择 “C” 或 “L” 波段。 

·在 “SAR Channel Type?” 文本标签下方供选择的列表中，选择 SIR-C 数据类型。 

·选择 “Strip Line Header?” 文本标签附近的 “Yes” 按钮，从输入数据中读取这些，然后从输
出图像中排除它们。 

如果数据直接从磁带上以 CEOS 格式转储（dump），它们在每一行的开始将有另外的 12 个
字节。 

4 当所有参数都已经输入，点击 “OK”，返回到 Data Products Input File 对话框； 

·无论何时要清除 Data Products Input File 对话框中的文件名，点击 “Reset” 或 “Cancel” 终止
处理。 

5 点击 “OK”，认可文件名，出现 Synthesize Parameters 对话框。 

选择合成参数 
对话框允许选择特定的发射和接收极化组合，将其合成为 ENVI 图像。“标准的”极化

(H=horizontal, V=vertical) “HH”、“VV”、“HV”和一幅总功率(TP)图像默认地为三个频率（波段）中
的每一个生成。这些被显示在 “Select Bands to Synthesize:” 文本框里。 

·要切换标准的波段开启或关闭，点击波段名左边的小框。 

·为直接由 Stokes 矩阵数据合成的图像执行空间子集，点击 “Spatial Subset”，运用 ENVI 标
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准空间子集程序（见 “Standardized ENVI Spatial Subsetting”） 

“Image” 中的构建子集项是无法使用的，因为它需要图像格式的数据，而不是压缩的数据。 

·选择另外的发射和接收极化： 

1 在 “Transmit Ellip/Orien” 和 “Receive Ellip/Orien” 文本框里，键入需要的发射和接收椭圆率
与方位角，点击 “Add Combination” 按钮； 

椭圆率值的范围是从 –45 度到 45 度，椭圆值为 0 表示形成线性极化。方位角数值范围是 0 
到 180 度，0 代表水平极化，90 度代表垂直极化。 

2 在波段名左边的小框里，选择需要的波段——C、L 或 P； 

3 点击 “Add Combination”。 

选择的图像将被显示在 “Additional Images:” 文本框里。 

·输出图像或将它们转换为 dB (分贝), 选择 “Output in dB?” 文本标签附近的“Yes” 切换按钮；
如果选择了“No”，图像将以浮点型数值输出。 

·另外，不需要定量分析时，可以选择“Output Data Type”按钮下拉菜单中的“Byte”，以输出字
节型图像。 

当选择字节型数据时，你必须输入标准差乘数（multiplier），用于为缩放到标签为 “Std Multiplier” 
的文本框计算一个最小值和一个最大值。对多数 AIRSAR 图像，默认值是 1.5 。但是，如果需要，
可以由用户自己改变。 

·隐藏坏的数据值, 在 “Intensity Min” 和 “Max” 文本框里，键入要用到的最小和最大数据值，
用强度（intensity）单位。 

当输出 dB 格式的图像时，最小值和最大值仍被键入（用强度单位）。由于计算 dB 以前，输
出要由这些数值约束（例如，如果你将数据限制到0与1之间，则 dB 图像将被限制到 -Inf to 0）。 

小于最小值的合成值将被设定为 0，大于最大值的合成值将被设定为 1 。 

合成图像 
所有选择的图像被放在一个单独的输出文件中。 

1 选择输出到 “File” 或 “Memory”； 

·如果选择输出到 “File”，在 “Enter Output Filename” 文本框里键入一个输出文件名；或用 
“Choose” 按钮选择一个输出文件名。 

2 点击 “OK”，开始处理。 

一旦合成完毕，图像将被添加在 Available Bands List 中，能用 ENVI 标准图像处理功能进行
处理。 

Multilook Compressed Data (多视压缩数据) 

SIR-C Multi-Look 
多视是一种减少 SAR 数据中斑点噪声的方法。磁盘上的 SIR-C 数据可以被多视为指定的视
数、行数和样本数、或方位角和行程分辨率。对压缩数据进行多视，执行如下： 

Administrator
所有选择的图像被放在一个单独的输出文件中。

Administrator
合成图像
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1 选择 Radar Tools > Polarimetric Tools > Multilook Compressed Data > SIR-C Multilook； 

2 出现 Input Data Product File 对话框时，（见图11-5），用 “Synthesize JPL AIRSAR Images” 部
分描述的程序选择一个压缩的输入文件。 

3 出现 SIR-C Multi-look Parameters 对话框时，在 “Select Files to Multilook:” 列表中，点击文
件名，选择要进行多视的文件。 

·若选择连续显示的一组数据集，则点击这一组的第一个，按住“shift”键，再点击最后一个，
或者按住鼠标左键，在要选择的范围内点击并拖曳到最后一个。 

·若选择非连续显示的多个数据集，则按住“ctrl”键，再一一点击它们。最后再将一些不需要
的删除。 

·选择所有数据集，点击 “Select All Items”。 

·删除所有数据集，点击 “Clear All Items”。 

4 在 “Samples (Range)” 和 “Lines (azimuth)” 处，键入需要显示的数目；. 

支持整型和浮点型的显示数。 

·作为选择，可以在 “Pixels” 文本标签下方的文本框里，键入样本数和行数，以便确定输出图
像中需要的像元数。 

·你也可以在 “Pixel Size (m)” 文本框里，键入样本数和行数，以指定需要输出的像元大小（单
位：米）。 

当这些参数中有一个被输入，其它的将自动被计算与之匹配。例如，如果你输入的像元大小是 30 
米，则相应的像元数和显示数将被计算，在相应的文本框里自动改变。 

5 点击 “Spatial Subset”，用 ENVI 标准程序抽取数据子集； 

6 在标有 “Enter Base Name” 的文本框里，键入一个根名（base name）。 

这一名字将用作多个文件名的根名，每个选择的频率对应一个。例如，如果你键入 “sirc” 作为
根名，且 C-波段和 L-波段都被处理，则两个输出文件将被建立，其名分别为 “sirc_c.cdp” 和 
“sirc_l.cdp”。 

7 点击 “OK”，进行数据多视。 

用合成功能将输出的多视压缩数据生成图像数据，见“Synthesize SIR-C Images”部分。 

Phase Image (相位图像) 
一幅 AIRSAR 或 SIR-C 数据的相位图像可以被生成，它提供对水平和垂直极化之间相位差的
测量。相位差按弧度或度来衡量，范围从 -π  到 π 或从 –180 度到 180 度。把 -π  和 π  设置为 0 、
0 弧度设置为 255 的分段线性拉伸，如果有必要，将按相同的电平绘制正、负角度。波段运算也可
以用来计算该结果的绝对值 (使用 abs(b1)) (见第 357 页的 “Band Math”)。 

1. 选择 Radar Tools > Polarimetric Tools > Phase Image > AIRSAR 或 SIR-C. 

2. 使用 “Open File” 按钮，然后点击 “OK”，来选择所需要的输入压缩数据文件。 

3. 当出现 Phase Image Parameters 对话框，用复选框选择所需要的波段，来计算相位图像，选
择弧度或度，如果有必要，选择一个空间子集。 

4. 选择 “Memory” 或 “File” 输出。 



 371

· 如果输出到 “File” 被选择，键入一个输出文件名。 

5. 点击 “OK”，来启动处理。 

Pedestal Height Image (幅度图像) 

可以为 AIRSAR 或 SIR-C 数据生成一幅幅度图像，并提供对每个像元的雷达波多次散射总量
的测量 (消隐脉冲高度的平均值越高，多次散射越大)。消隐脉冲高度是 0 以上的极化信号的高度，
该值通过求下列四个极化组合的平均来被计算：方位(Orientation) 0 度，椭圆率(Ellipticity) –45 度；
方位 90 度，椭圆率 -45 度；方位 0 度，椭圆率 45 度；方位 90 度，椭圆率 45 度。要获得更
多关于消隐脉冲高度的信息，请参阅第 744 页的 “Extract Polarization Signatures”。 

1. 选择 Radar Tools > Polarimetric Tools > Pedestal Height Image > AIRSAR 

或 SIR-C. 

2. 选择所需要的输入压缩数据文件，然后点击 “OK”。 

3. 当出现 Pedestal Height Image Parameters 对话框，用复选框选择所需要的波段，来生成一幅
消隐脉冲高度图像，如果有必要，选择一个空间子集。 

4. 选择 “Memory” 或 “File” 输出。 

· 如果输出到 “File” 被选择，键入一个输出文件名。 

5. 点击 “OK”，来启动处理。 

AIRSAR Scattering Classification (散射机理分类) 

该分类例程使用完全极化测定的 AIRSAR 数据，来决定图幅内每个像元的雷达散射机制的特
性。尤其注意的是植被的真实感和特性。一幅分类图像被生成，它可以区分无植被区域、低和中等

植被覆盖区域、森林覆盖区域和城市区域。单幅的散射机制图像 (单回波 odd bounce，双回波 double 
bounce，散射量 volume scattering) 也被生成。(这是一个 IDL 程序实现，它和 JPL 的 Dr. Tony 
Freeman 开发的 “MAPVEG” 程序相似)。必须为这个分类输入所有三个 (P、L 和 C-band) stokes 矩
阵文件。通过使用标准的 ENVI 显示和分析例程，分类图像和散射机制图像可以被显示和分析。 

1. 选择 Radar Tools > Polarimetric Tools > AIRSAR Scattering Classification. 

2. 当出现 Input Stokes Matrix Files 对话框，选择 AIRSAR compressed Stokes 矩阵文件，来用
于分类。 

3. 点击 “Open File”，来显示一个标准的文件选择对话框。 

4. 从列表中选择一个 Stokes 矩阵文件名。 

如果这个文件有一个包含所有必需参数的有效的 AIRSAR 文件头，视该文件是 P-、L- 还是 
C-band 数据而定，它将被列在 Input Stokes Matrix File 对话框内的一个 “Selected Files” 文本框中。
如果你遵循先前叙述的建议的文件命名约定，其它两个文件的正确的文件名将被自动地输入到适当

的文本框中。否则，文件选择过程必须为每个波段重复。 

· 如果该文件没有一个有效的 AIRSAR 文件头，或一些数值从文件头中丢失，那么 AIRSAR 
Header Parameters 对话框将出现，来允许输入数值。 

所有已知的参数被列在该对话框中。 
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A. 校验这些参数，当需要时更改或添加数值。 

B. 点击 “OK”，来返回到 Stokes Matrix Input File 对话框。 

· 要在任何时候清除 Stokes Matrix Input File 对话框中的文件名，点击 “Reset” 或 “Cancel”，
来退出而不进行处理。 

5. 点击 “OK”，来接受文件名，并显示 AIRSAR Scatter Classification 对话框。 

6. 输入变换核的大小，用来决定散射机制判定 (scattering mechanism determination) 中使用的平
均值。 

7. 如果有必要，通过点击 “Spatial Subset” 按钮，使用标准化的 ENVI 空间构造子集的步骤，
来选择一个空间子集。 

8. 为分类图像和判决图像 (散射机制图像)，选择 “File” 或 “Memory” 输出。 

· 如果输出到 “File” 被选择，键入一个输出文件名。 

9. 点击 “OK”，来启动分类。 

在处理过程中，一个状态窗口将出现。当完成后，分类和判定(rule) 图像将显示在 Available 
Bands List 中。 

Extract Polarization Signatures（提取极化信号） 

极化信号是单个像元或一个感兴趣区平均值的全部散射特性的 3D 表现。这些是从 AIRSAR 
数据的 Stokes Matrix 或从 SIR-C 数据的压缩散射矩阵中提取的。它们可以基于一幅被显示图像的
当前像元位置来提取，或通过使用 ENVI 标准化的感兴趣区定义步骤来提取所定义的感兴趣区。co- 
和正交极化信号都被提取，并可以作为标准的 ENVI 图像被查看和处理，或可以显示在一个 
Polarization Signature Viewer 中 (见第 747 页的 “The Polarization Signature Viewer”)。要获得更多关
于极化信号的信息，请参阅下列的参考文献。 

van Zyl, J.J., H.A. Zebker, and C. Elachi: Imaging radar polarization signatures: theory and 
observation. Radio Science 22(4):529-543, 1987. 

van Zyl, J. J., 1989, Unsupervised classification of scattering behavior using radar polarimetry data, 
IEEE Trans. Geosci. Remote Sensing, vol. 27, no. 1, pp. 36-45. 

Zebker, H.A., J.J. van Zyl, and D.N. Held. Imaging radar polarimetry from wave synthesis. Journal of 
Geophysical Research 92(31):683-701, 1987. 

当前像元的单像元极化信号 

每个像元的极化信号可以从一个显示窗口，从压缩的 quad-polarized AIRSAR Stokes 矩阵数据，
或从 SIR-C quad-polarized 压缩散射矩阵数据中，直接被提取。 

1. 显示合成图像或其它相互配准的图像。 

2. 通过在缩放窗口内所需要的像元上点击鼠标中键，来交互式地设置显示图像内要被提取的像
元 (见第 110 页的 “The Zoom Window”)。 

3. 在显示窗口内点击鼠标右键，使该显示的 Functions 菜单突然出现，然后选择 Functions > 
Interactive Analysis > Polarization Signatures > AIRSAR 或 SIR-C. 
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视选择的是 AIRSAR 还是 SIR-C 数据的情况而定，将出现 Input Stokes Matrix Files 对话框，
或 Input Data Products 对话框。 

4. 按第 729 页 “Synthesize JPL AIRSAR Images” 所描述的，输入 Stokes Matrix 或 Scattering 
Matrix 文件名。 

5. 当出现 #n Current Pixel Polarization Signature Viewer，选择 Options > Extract Current Pixel，
为缩放窗口内十字准行下的当前像元，提取和绘制一个极化信号。 

你可以设置或控制特定的参数。完整的描述，请见第 747 页的 “The Polarization Signature 
Viewer”。 

从感兴趣区提取极化信号 

选择该选项，来计算感兴趣区 (ROI) 的极化信号。这些信号从 AIRSAR Compressed Stokes 
Matrix 文件或 SIR-C 散射矩阵文件中直接提取，并可以显示在极化信号浏览器或作为图像显示在
标准的 ENVI 显示窗口中。 co- 和 cross-polarized 信号都被提取，并保存到一个多波段输出文件
中。每个信号有 91 样本 (-45 到 45 度椭圆率角度) 和 181 行 (0 到 180 度方位角)。 

1. 在选择该选项之前，显示一幅合成图像或其它相互配准的数据集，并为提取极化信号定义感
兴趣区 (见第 199 页的 “Region of Interest” 或第 200 页的 “Defining Regions of Interest”)。 

2. 选择 Radar Tools > Polarimetric Tools > Extract Polarization Signatures > AIRSAR 或 SIR-C. 

视选择的是 AIRSAR 还是 SIR-C 数据的情况而定，将出现 Input Stokes Matrix Files 对话框，
或 Input Data Products 对话框。 

3. 按第 729 页 “Synthesize JPL AIRSAR Images” 所描述的，输入 Stokes Matrix 或 Scattering 
Matrix 文件名。 

4. 点击 “OK”，来接受文件名，并显示 Polsig Parameters 对话框。 

Polsig Parameters 对话框 
所有可用的感兴趣区，列在 “Select Polsig Images:” 文本框中。一个条目列出了每个 P-、L- 和 

C-band 图像 (AIRSAR) 或 L- 和 C-band 图像 (SIR-C)。 

1. 点击感兴趣区名，来选择所需要的极化信号。 

· 要选择一组连续列出的信号，点击并拖曳到所需要的范围，或点击第一个所需要的信号，按
住 “Shift” 键，然后点击最后所需要的信号，来突出显示两者之间的所有信号。 

· 要选择多个非连续列出的信号，按住你键盘上 “Ctrl” 键的同时，点击每个所需要的信号。再
次点击来取消选择一项。 

· 要选择所有的信号，点击 “Select All Items”。 

· 要取消选择所有的信号，点击 “Clear All Items”。 

2. 选择按浮点强度、归一化强度 (使用最大图像值归一化) 或分贝(dB)，来计算极化信号。 

通过用信号除以信号的最大值，来计算从 0 到 1 的归一化强度。 

3. 通过点击 “Output” 文本标签旁相应的切换按钮，来选择所需要的输出。 
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Figure 11-11: Polsig Parameters 对话框。 

 

4. 选择标准的 “File” 或 “Memory” 输出。 

· 如果 “File” 输出被选择，在 “Enter Output Filename” 文本框中键入输出文件名，或使用 
“Choose” 按钮来选择一个输出文件名。 

极化信号 (co- 或 cross-polarized) 将另存为一个多波段图像，其中图像的每个波段是所选择频
率之一的一个独立的 91 样本 (-45 到 45 度椭圆率角度) 乘以 181 行 (0 到 180 度方位角) 的极
化信号，用强度表示 Z 轴 (强度、归一化强度或分贝)。 

5. 点击 “Yes” 按钮，来把每个提取后的信号导入到各个的 Polarization Signature Viewer 中。 

注意 

自动地导入这些信号，可能潜在地创建许多窗口，并使用大量的资源。首选的方案是选择 “No”，
并使用 Polarization Signature Viewer 功能来查看每个信号 (见下面的 “The Polarization Signature 
Viewer”)。 

6. 点击 “OK”，来启动极化信号的提取。 

每个所选择感兴趣区的 co-polarized 和 cross-polarized 信号都被计算。当完成时，信号列在 
Available Bands 列表中，可以通过 ENVI 显示和处理程序来使用。它们也可以在各自的 Polarization 
Signature Viewers 中被分析 (见下面的 “The Polarization Signature Viewer”)。 

Polarization Signature Viewer 

Polarization Signature Viewer 允许交互式的查看和分析从 AIRSAR 和 SIR-C 数据中提取的极
化信号。极化信号被显示为浮点、2-D 图像和 3-D 表面图 (wire mesh、scaled wire mesh 或 gray 
scale)。X 和 Y 轴分别表示椭圆率和方位，而垂直的轴可以选择绘制为强度、分贝或归一化强度。
该图表可以为所有可用的频率，在 co- 和 cross-polarized 信号之间切换显示。可以获得信号的统计
信息，颜色表可以应用到图表。信号可用被注记和输出。 

· 启动 Polarization Signature Viewer，有三种方法： 

当一个极化信号从当前像元被提取时  ，它被自动地启动  (见第  744 页的  “Single-Pixel 
Polarization Signatures for the Current Pixel”)。 

当极化信号从感兴趣区中被提取时，通过选择 Polsig Parameters 对话框内的 “Yes”，它也可以
被启动 (见第 745 页的 “Extract Polarization Signatures from ROIs”)。 

最后，它可以通过选择 Radar Tools > Polarimetric Tools > Extract Polarization Signatures > View 
Saved Signatures 被启动。 

当被选择时，一个 Polarization Signature Viewer 将出现。 

最初，一个 3-D 丝网表面显示在左边，信号的一个 2-D 灰阶图像显示右边。 

极化图像内的一个交互式的光标，驱动表面图上的一个 3-D 光标。方位和椭圆率角度以及代表
每个像元的雷达后向散射的像元值，跟踪 3-D 光标。这些值按照椭圆率、方位角、Z 值顺序，列在 
3-D 图的左下角。 

 



 375

Figure 11-12: Polarization Signature Viewer. 

 

· 要在 2-D 和 3-D 图上都绘制十字准行，用鼠标左键在 2-D 图像内点击并拖曳光标。 

· 要作为一个 3-D 丝网表面显示信号，其中丝网的值与信号的强度成比例，用鼠标左键在 3-D 
信号内点击一次。 

· 要作为一个灰阶的 3-D shaded 表面显示信号，用鼠标左键第二次在 3-D 图上点击。 

· 要返回到初始的 3-D 丝网图，用鼠标左键再次点击信号。 

File 下拉菜单 
File 下拉菜单用来输出极化信号，以及打开其它输入的压缩数据文件。 

· 要只把 3-D 信号及任何其它注记，输出到 Postscript、RGB 图像、BMP、GIF、HDF、JPEG、
PICT、SRF、TIFF 或 XWD 格式，选择 File > Output Plot > 输出类型。 

· 要更改当前用于计算极化信号的 Stokes 文件，选择 File > Stokes Matrix Filename (只在 
Current Pixel Polarization Viewer 窗口内有效)，然后选择一个新的输入文件。 

· 要关闭 Polarization Signature Viewer，选择 File > Cancel. 

· 要关闭所有打开的 Polarization Signature Viewers，选择 File > Cancel All. 

Polsig_Data 下拉菜单 
Polsig_Data 下拉菜单用来更改 Z 轴的比例，以及选择查看 co- 或 cross-polarized 信号。 

· 通过选择 Polsig_Data > 所需要的选项，极化信号的垂直轴可以选择用强度、分贝(dB) 或归
一化强度(强度除以最大强度的一个 0 到 1 的数据范围) 来绘制。 

· 通过选择 Polsig_Data> Co-Pol 或 Cross-Pol，co-polarized 和 cross-polarized 信号都可以绘制
在 Polarization Signature Viewer 中。 

Frequency 下拉菜单 
通过从当前像元提取，当 Polarization Viewer 被启动时，一个带有波段名 (对于 AIRSAR 为 P、

L 和 C，对于 SIR-C 为 L 和 C ) 的 Frequency 下拉菜单将被显示。 

· 要为一个波段绘制极化信号，从下拉菜单选择该波段名。只有与当前打开的压缩数据文件对
应的频率 (波段) 是有效的。 

· 要打开其它的数据文件，选择 File > Stokes Matrix Filename. 

Options 下拉菜单 
· Options 下拉菜单用来导入一个极化信号，显示信号的统计信息，注记信号并拷贝到另一个窗

口，以及把颜色表应用到信号。要显示当前像元的一个极化信号，或显示先前保存的一个极化信号，

分别选择 Options > Extract Current Pixel 或 Load New Polsig. 

· 当使用 Load New Polsig，从列表中选择所需要的输入信号。 

将出现 New Polsig Bandname 对话框。 

· 要显示极化信号的统计信息，更改表面的绘制类型、透视角和 Z 轴精度： 

1. 选择 Options > Show Statistics. 
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将出现 Polsig Stats 对话框，它显示极化信号的统计信息，包括 HH、VV、HV 极化值和 HH/VV 
比率，以及极化最小值 (消隐脉冲高度) 和最大值。 

2. 设置参数，并按照以下作出选择。 

· 要选择 3-D 图类型、丝网、scaled surface 或 shaded surface，从 “Plot” 下拉按钮菜单中选择。 

· 要控制用于绘制 3-D 表面的透视角，按度数设置 AX 和 AZ 参数。 

· 要设置 Z 轴值的精度的位数，使用 “Z-Prec” 文本框。 

 

Figure 11-13: Polarization Signature Statistics 对话框(左) 

和 Polsig Color Tables 对话框(右)。 

 

3. 点击 “Apply”，来把更改应用到 3-D 图。 

· 要把注记放置在 3-D 极化信号上(见第 250 页的 “Annotation”)，选择 Options > Annotate 
Polsig，来启动标准的 ENVI Annotation 对话框。 

· 要把当前的极化信号拷贝到一个新的 Polarization Signature Viewer，选择 Options > Copy 
Polsig. 

· 要把 ENVI 一个的标准颜色表应用到 3-D 图和 2-D 图像(见第 179 页的 “ENVI Color 
Tables and Density Slicing”)： 

1. 选择 Options > Color Tables. 

2. 从 Polsig Color Tables 对话框内的列表中，选择所需要的颜色表。 

该颜色表将应用到所有被显示的 Polarization Signature Viewers 中。 

按图像和表面图显示极化信号 

通过使用标准的 ENVI 图像处理功能，从感兴趣区创建的极化信号 (图像) 可以被显示和操作。
通过使用主图像显示菜单的 Functions > Surface Plot 选项，可以生成 3-D 表示法。该选项提供比 
Polarization Signature Viewer 更多的对绘图参数的控制。 

· 要把所需要的信号导入到一个显示中，使用 Available Bands List (见第 97 页的 “Available 
Bands List”)。 

该信号用一个 180 度的方位角和一个 -45 度的椭圆率，显示在图像的左上角。这些图像应当
总是用 !order=1 显示 (见第 786 页的 “Configuration File Details” 或第 761 页的 “Edit Current 
Configuration”)。 

 

Figure 11-14: 2D 和 3D (Mesh Surface) 极化信号实例。 

(被注记，以阐明 2D 和 3D 图之间的关系。) 

 

· 要使用标准的 ENVI Surface Plot 功能，它提供显示 3-D 极化信号的一种方法，显示极化信
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号图像，然后选择主显示窗口内的 Functions > Interactive Analysis > 3-D Surface Plots (见第 240 页
的 “3-D Surface Plots and Image Draping”)。 

你可以控制丝网或shaded 表面特征，查看几何图形、注记和输出选项。Figure 11-14 显示被注
记的图像和图表，来阐明图像和缺省方位的 3-D 极化信号之间的关系。 
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TOPSAR Tools 
ENVI 有专门的工具，来读取综合的 TOPSAR 数据、查看文件头，以及把综合的 TOPSAR 文

件转换为实际单位。综合的 TOPSAR 数据通常包括一个数字高程模型 (DEM)、C-band VV 数据、
入射角、相关性图像，以及 L- 和 P-band 极化的 AIRSAR 数据。其它的分析工具，参见第 729 页
的 “Polarimetric Tools”。更多关于综合的 TOPSAR 数据的信息，请参阅下面的参考文献。 

AIRSAR Integrated Processor Documentation, Data Formats, Version 0.01, May 3, 1995, JPL 
Publication, Jet Propulsion Laboratory, Pasadena, CA. 

View AIRSAR/TOPSAR Header 

要查看 AIRSAR 和 TOPSAR 数据文件的 ASCII 文件头： 

1. 选择 Radar Tools > TOPSAR Tools > View AIRSAR/TOPSAR Header. 

2. 选择所需要的数据文件。 

文件头信息将显示在一个报告窗口中。要把该信息保存到一个 ASCII 文件，选择 File > Save 
Text to ASCII，然后键入一个输出文件名。 

Open TOPSAR File 

要读取原始的 TOPSAR 格式数据文件 (Cvv、入射角、相关性图像 或 DEM)： 

1. 选择 Radar Tools > TOPSAR Tools > Open TOPSAR File. 

2. 当出现文件选择对话框，选择需要读取的文件。 

ENVI 自动地提取必要的文件头信息，并把图像波段放置在 Available Bands List 中。 

注意 

要读取所有的 TOPSAR 文件，并自动地把它们转换为实际单位，参见第 755 页的 “Convert 
TOPSAR Data”。要合成 AIRSAR 图像，参见第 729 页的 “Decompress-Synthesize Images”。 

Convert TOPSAR Data 

使用该功能，读取和转换原始 TOPSAR 格式数据文件为实际单位(浮点数据)。Cvv 文件被转换
为 sigma zero 。入射角文件被转换为 0-180 度角。相关性文件被转换为 0-1 值。DEM 被转换为
米。 

要读取和转换 TOPSAR 数据文件： 

1. 选择 Radar Tools > TOPSAR Tools > Convert TOPSAR Data. 

2. 当出现文件选择对话框，选择一个数据文件。 

3. 当出现 TOPSAR Conversion Parameters 对话框，通过点击文件名旁的复选框，来选择要转换
的那些文件。 

4. 如果有必要，通过点击 “Spatial Subset” 按钮，然后使用标准的 ENVI 构造子集，来选择一
个空间子集。 
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5. 选择输出到 “File” 或 “Memory”，如果有必要，键入一个输出文件名。 

ENVI 将为每个输入文件，用单个波段来代替所有要转换为单个输出文件的多个文件。 

Topographic Modeling 

ENVI 提供处理数字高程数据 (DEM) 的工具，来生成 (消除阴影的) 全散射面 (lambertian 
surface)，以及提取包括斜率和方位在内的参数信息。有关细节，请见第 434 页的 “Topographic 
Modeling”。 

1. 选择 Radar Tools > TOPSAR > Topographic Modeling. 

2. 当出现文件选择对话框，选择 TOPSAR DEM 文件。 

出现 Topo Model Parameters 对话框。有关细节，参见第 434 页的 “Topographic Modeling”。 

DEM Replace Bad Values 

使用 DEM Replace Bad Values，通过使用表面拟合方法计算得到的数值，来填充数字高程模型
(DEMs) 中的坏数值。坏像元经常出现在干涉雷达生成的 DEM 的雷达阴影中。当你输入坏像元的 
DN 值或一个坏数值范围，DEM 图像中的坏像元位置被确定了。你也可以生成坏像元的一个掩模，
并使用它来定位需要被替代的像元 (见第 335 页的 “Masking”)。表面拟合使用 Delaunay 三角网，
用周围好的高程值计算得到的三角形，来填充坏像元。 

注意 

如果数据集中有大的孔，你可以看见用来填充它们的三角形。 

1. 选择 Utilities > Data Specific Utilities > Digital Elevation > Replace Bad Values 或 Radar Tools 
> TOPSAR Tools > DEM Replace Bad Values. 

2. 当出现 DEM Input File 对话框，选择 DEM 文件，然后执行任意的构造子集或掩模。 

出现 Replace Bad Data Parameters 对话框。 

3. 在适当的文本框中，输入一个坏的数据值或一个坏数据值范围。 

注意 

如果你选择一个包含坏像元位置的掩模波段，不需要输入任何值。 

4. 选择 “File” 或 “Memory” 输出。 

· 如果你选择 “Memory” 输出，键入或选择一个输出文件名。 

5. 点击 “OK”。 

输出显示在 Available Bands List 中。 



 380

第十二章：System 功能 
 

System 下拉菜单提供对 ENVI 在行帮助和控制 ENVI 环境的许多功能的访问。系统功能允许
你控制 ENVI 窗口和显示，显示鼠标按钮信息，获取高速缓冲存储器信息，编辑 ENVI 配置，编
辑图形颜色，切换一个调试工具开启和关闭，编译 ENVI 用户代码，以及显示普通的 ENVI 信息。
每个菜单项的详细描述如下。 

 

Figure 12-1: System 下拉菜单。 

Administrator
第十二章：System 功能
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ENVI Online Help 
ENVI User’s Guide 的整个原文是可以在行获得的。这个在行帮助系统是一个可检索的超文本数
据库，其中超文本链接用绿色显示。通过点击在行帮助窗口内的任何绿色的文本，你可以跟踪链接。

帮助窗口顶部的下拉菜单，提供导航工具以及控制流程 (flow path) 的按钮。 

1. 选择 System > ENVI Online Help. 

2. 要使用帮助来获得更多信息，在 ENVI Online Help 工具内，选择 Help > How to Use Help. 
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Widget Controller List 
Widget Controller List 按照它们被创建的顺序，显示主要的活动的 ENVI 窗口和对话框的名称。
这个列表包括显示组(main, scroll, zoom)，图表窗口，散点图，感兴趣区定义窗口等。 

点击 Widget Controller List 内的一个窗口名，把该窗口带到显示器的前台。 

要使用 Widget Controller List 来查找一个窗口： 

1. 选择 System > Widget Controller List. 

· 要把一个窗口调用到显示器的前台，点击 Widget Controller List 内的窗口名。 

· 点击一个特定显示号名，使主图形窗口和它相应的滚动和缩放窗口显示在最前面。 

· 点击任何其它窗口名，把该窗口带到最前面。 

如果把一个 ENVI 窗口带到前面，使它被覆盖，Widget Controller List 总是弹出到显示器的最
前面。 

· 如果 Widget Controller List 在其它窗口后面不被注意，选择 System > Widget Controller List，
来把它再次带到最前面。 

2. 通过选择 File > Cancel，来关闭 widget controller list 。 

 

Figure 12-2: Widget Controller List. 
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Edit Current Configuration 
Edit Configuration Values 对话框提供 ENVI 当前配置的有关信息，列出 envi.cfg 文件中所

有包含的值。尽管附录 A 包含各参数完整的说明，大多数条目是不需加以说明的 (见第 786 页的 
“The ENVI Configuration File”)。 

要检查或更改当前的 ENVI 配置： 

1. 选择 System > Edit Current Configuration. 

2. 将出现 Edit System Preferences 对话框，并带有一个 System Preference Categories 列表。在
包含你想更改参数的种类按钮上点击。 

· “Default Directories” 类目(category) 被用来设置数据、临时、输出波谱库、交互式文件头以
及 save_add 的缺省目录。 

 

Figure 12-3: Edit Configuration Values 对话框。 

 

· “User Defined Files” 类目包括设置图形颜色文件、菜单文件、地图投影文件、磁带设备名、
先前文件的文件名、启动脚本文件名，以及用户自定义的移动程序。 

· “Display Defaults” 类目包括设置显示顺序和保留值，设置缺省的拉伸，显示窗口大小、缩放
系数增量、窗口位置以及磁带和边框大小等参数。 

· “8-bit Color Division” 类目用来设置显示中使用的 RGB 和灰阶颜色的数目。 

· “Postscript Output” 类目包含用来设置缺省输出页面大小和以英寸或厘米为单位的偏移量的
参数。 

· “Memory Usage” 类目用来设置高速缓存的大小和图像tile的大小。 

· “Previous Files List” 类目允许你把文件标记为 “sticky”。 

“sticky” 文件将保持在 Previous Files List 的顶部，并且不会降到列表的底部。 

· “Misc. System Preferences” 类目用来设置配置名、主菜单方向、开启和关闭 IDL 命令行
blocking，设置退出 ENVI 时是否退出 IDL，为输入显示一个状态窗口，以及设置多个列表项的最
大值，直方图bins，下拉菜单选项，以及内存中的顶点。 

要获得各参数的一个完整的描述，见第 786 页的 “The ENVI Configuration File”。 

3. 点击适当的切换按钮，或输入一个文本值，接着按回车，然后点击 “OK”，来为当前的 ENVI 
会话执行更改。 

· 要通过把更改保存到 ENVI 的 .cfg 文件，来进行永久的改动，在 Edit System Preferences 
对话框内选择 File > Save Configuration 。 

· 要关闭 Edit System Preferences 对话框，选择 File > Cancel. 
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Edit Graphic Colors 
ENVI 从 menu 目录下的 “colors.txt” ASCII 文件中读取它的图形颜色，除非一个缺省的图形颜
色文件被输入到 envi.cfg 文件中。通过使用 Edit Graphic Colors 功能，当前的颜色可以被更改。
通过使用一个文本编辑器，把颜色添加到图形颜色文件的结尾，新的颜色被添加到该文件 (见第 800 
页的 “ENVI Graphic Colors File”)。 

注意 

不建议更改前 5 种颜色的任何一种(黑、白、红、绿、蓝)，因为它们使用于 ENVI 系统中。更
改图形颜色可以影响原先保存的图形覆盖图。 

1. 选择 System > Edit Graphics Colors. 

2. 当出现 Edit Graphic Colors 对话框，通过在 “Graphic Colors:” 列表中点击一种颜色，来选择
它。 

· 要更改颜色名，在 “Color Name” 文本框中输入名称。 

 

Figure 12-4: 两个 Edit Configuration Items 对话框。 

 

· 要更改颜色，使用 “Red‘、“Green” 和 “Blue” 滑动条。通过从 “System” 下拉菜单选择所
需要的系统，可以按 “RGB”、“HLS” 或 “HSV” 颜色系统来选择颜色。 

· 要把所有的颜色重新设置为初始值，点击 “Reset”。 

· 要退出该功能，且不应用更改，点击 “Cancel”。 

3. 选择 “OK”，来更改图形颜色。 

4. 一个对话框将出现，来询问你是否想把更改保存到文件。 

· 要永久地应用颜色更改，选择 “Yes”。 

· 要只更改当前 ENVI 会话的颜色，选择 “No”。 
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Display Information 
该功能提供光标所在的显示窗口的有关信息。当光标在当前打开的显示窗口之间移动时，Display 

Information 对话框被更新。显示的信息包括显示号、使用的颜色数、已显示波段的列表，以及图像、
缩放和滚动窗口的大小和像元范围。 

· 要显示上下文相关的显示信息，选择 System > Display Information. 
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Mouse Button Descriptions 
鼠标按钮描述可以显示光标所在窗口内的鼠标操作的有关信息。当光标从一个窗口移动到另一

个窗口，鼠标按钮描述被更新。显示的信息包括窗口类型(例如，display、plot)，光标控制的功能(例
如，ROIs、Dynamic Overlay)，以及每个鼠标按钮的操作(MB1: 鼠标左键；MB2: 鼠标中键；MB3: 鼠
标右键)。 

注意 

如果鼠标按钮没有按你所期望的那样作出反应，显示鼠标按钮的描述，来变换核对光标控制哪

个功能。 

· 要显示一个上下文相关的鼠标按钮描述对话框，选择 System > Mouse Button Descriptions. 

 

Figure 12-5: Mouse Button Descriptions. 
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Execute Startup Script 
ENVI 的启动脚本允许你当启动 ENVI 时，打开图像文件、把波段导入显示、打开矢量文件，
以及打开感兴趣区文件。如果一个文件名在 envi.cfg 文件中被设置，当 ENVI 启动时该脚本被
自动地执行。通过使用该功能，它也可以在任何时候被执行。第 792 页的 “ENVI Startup Script” 提
供了 ENVI 启动脚本命令的说明。 

要执行一个 ENVI 启动脚本： 

1. 选择 System > Execute Startup Script. 

2. 选择所需要的启动脚本文件名，然后点击 “OK”。 
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Save Session to Script 
该选项允许你把当前打开的图像文件和打开的图像显示以及它们的波段，保存到一个 ENVI 启
动脚本。要执行该脚本文件，请参阅第 767 页的 “Execute Startup Script”。要把你当前的会话保存
到一个启动脚本文件： 

1. 选择 System > Save Session to Script. 

2. 当出现  Output ENVI Script Filename 对话框，输入所需要的启动文件名(通常扩展名
为 .ini)。 
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Import IDL Variables 
该选项允许你导入任何在 IDL 命令行中定义的 IDL 变量。一维变量将放置在图表窗口，二维
和三维变量将作为内存数据项显示在 Available Band List 中。要把 IDL 变量导入到 ENVI 中： 

1. 选择 System > Import IDL Variables. 

2. 将出现 Import IDL Variables 对话框，它带有所有被定义变量的一个列表。 

3. 选择所需要的变量名，通过点击变量名旁的复选框来导入。 

· 要添加一组变量名，输入起始和结尾变量号，然后点击 “Add Range”。 

· 要选择所有变量名，点击 “Select All”。 

· 要清除所选择的变量名，点击 “Clear” 按钮。 

4. 要把数据的一个备份保存到 IDL 中，使用箭头切换按钮，来选择 “Yes”。如果 “No” 被选
择，那么数据将被导入到 ENVI 中，并从 IDL 中删除。 

5. 点击 “OK”，来导入所选择的变量。 

一维变量将放置在图表窗口，二维和三维变量将作为内存数据项显示在 Available Band List 中。 
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ENVI Log Manager 
该功能允许你保存所有文件到文件处理的一个 ASCII 日志。该日志文件包含所有的功能参数和

被使用的文件名，并且可以选择开启和关闭。 

1. 选择 System > ENVI Log Manager. 

2. 当出现 ENVI Log Manager 对话框，选择 “On” 按钮，来启动事件记录。 

· 要关闭事件记录，选择 “Off ” 按钮。 

3. 键入输出日志文件名，或使用 “Choose” 按钮来选择一个文件名。 

如果使用与原先文件名相同的文件名，那么该日志将添加在这个文件的底部。 

4. 点击 “OK” 来启动事件记录。 
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Change Output Directory 
要更改输出的缺省目录： 

1. 选择 System > Change Output Directory. 

2. 当出现 “Change Output Directory” 对话框，键入你想把 ENVI 输出到的那个目录的完整路
径。 

3. 点击 “OK” 来把当前输出目录更改为新的路径。 
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Compile Module 
如果你为了在 ENVI 中使用，书写了你自己的 IDL 代码，每当你更改代码时，你将必须编译
它，除非它保存在 save-add 目录下，并重新启动 ENVI 。要编译你的 ENVI 代码： 

1. 选择 System > Compile Module. 

2. 当出现 Enter Module Filename 文件选择对话框，选择你的模块文件名，然后点击 “OK”。 

任何编译错误将显示在主 IDL 窗口中。 



 393

Cache Info 
Cache Information 窗口提供 ENVI 高速缓冲存储器的有关信息，包括 envi.cfg 文件中设置
的总缓存大小、使用中的总缓存、“in memory” 数据项(内存计算和图像) 使用的内存大小，以及空
闲的高速缓冲存储器的剩余总量。 

要查看该窗口： 

1. 选择 System > Cache Info. 

2. 选择 File > Cancel，来退出 Cache Information 窗口。 

 

Figure 12-6: Cache Information 窗口。 
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Toggle Catch 
ENVI 提供一个 CATCH (捕获) 调试工具，当在 ENVI 内调试你自己的 IDL 代码时，你可以
使用该工具。缺省地，捕获被切换为开启，因此任何程序错误将被捕获，而且一个错误消息将显示

在一个窗口中。当关闭错误窗口后，控制权返回到 ENVI 。切换捕获工具为关闭，当在 ENVI IDL 代
码中存在错误时，来中断执行，并把控制权返回到 IDL 窗口。通过允许你检查 IDL 窗口内的变量，
这有助于调试代码。 

· 选择 System > Toggle Catch. 

CATCH 装置的状态显示在主 IDL 窗口中。 
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About ENVI 
该窗口显示 ENVI 的版权标志，提供 ENVI 支持的 Research Systems, Inc. 的 contact numbers，
以及提供 ENVI 主页的 URL： 

1. 选择 System > About ENVI. 

2. 点击 “Cancel” 来退出 About ENVI 窗口。 
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