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Notice
OMRON products are manufactured for use according to proper procedures by a qualified operator and
only for the purposes described in this manual.

The following conventions are used to indicate and classify precautions in this manual.  Always heed the
information provided in them.  Failure to heed precautions can result in injury to people or damage to
the product.

DANGER! Indicates information that, if not heeded, is likely to result in loss of life or
serious injury.

WARNING Indicates information that, if not heeded, could possibly result in loss of life
or serious injury.

Caution Indicates information that, if not heeded, could result in relatively serious or
minor injury, damage to the product, or faulty operation.

OMRON Product References
All OMRON products are capitalised in this manual.  The word “Unit” is also capitalised when it refers
to an OMRON product, regardless of whether or not it appears in the proper name of the product.

The abbreviation “PLC” means Programmable Logic Controller and is not used as an abbreviation for
anything else.
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Visual Aids
The following headings appear in the left column of the manual to help you locate different types of
information.

Indicates information of particular interest for efficient and convenient operation of the product.
1, 2, 3… Indicates lists of one sort or another, such as procedures, checklists etc.

Represents a shortcut on the Toolbar to one of the options available on the menu of the same
window.

Other manual conventions are as follows:

•  Windows-based applications provide users with a number of different ways to perform one
operation.  These are normally: from the application menu bar; using icons on a Toolbar; using
keyboard shortcuts; using the right-mouse button to display a context-sensitive menu; dragging and
dropping.  Whilst recognising this, the manual provides user instructions employing the Toolbar and
right-mouse button only.  Use of the application menu bar or keyboard shortcuts are only included
if no such alternatives exist.

•  Access to the CX-Server middleware is normally via other software applications, such as CX-
Programmer or CX-Protocol.  This is noted in the manual by the term “invoking application”.

•  This manual refers to two distinct types of project: CX-Server projects and application projects.  A
CX-Server project is defined in this manual.  An application project is defined by the software
application invoking CX-Server.

  OMRON, 2001
All rights reserved.  No part of this publication may be reproduced, stored in a retrieval system, or
transmitted, in any form, or by any means, mechanical, electronic, photocopying, recording, or otherwise,
without the prior written permission of OMRON.

All copyright and trademarks acknowledged.

No patent liability is assumed with respect to the use of the information contained herein.  Moreover,
because OMRON is constantly striving to improve its high-quality products, the information contained
in this manual is subject to change without notice.  Every precaution has been taken in the preparation
of this manual.  Nevertheless, OMRON assumes no responsibility for errors or omissions.  Neither is any
liability assumed for damages resulting from the use of the information contained in this publication.
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About this Manual
This manual describes the CX-Server application and its ability to control and monitor a range of
OMRON PLCs.  It does not provide detailed information concerning the PLCs themselves, for this
information the commercial manual for the device must be consulted.

This manual contains the following chapters:

♦  Chapter 1 Technical Specification.  This chapter describes CX-Server in general terms and
introduces the user to the relationship between CX-Server and associated products.  It also provides
details of the operating environment, minimum configuration and installation procedures necessary
for the satisfactory operation of CX-Server.

♦  Chapter 2 PLC Memory Component.  This chapter describes the PLC Memory Component and its
ability to allow the user to view, edit and monitor PLC Data Areas, bits and symbols.

♦  Chapter 3 IO Table Component.  This chapter describes the IO Table Component and its ability to
edit PLC IO Table and SIOU Settings on a PLC..

♦  Chapter 4 PLC Setup Component.  This chapter describes the PLC Setup Component and the
procedures involved in the configuration of PLC settings.

♦  Chapter 5 Data Trace/Time Chart Monitor Component.  This chapter describes the Data
Trace/Time Chart Monitor Component and the procedures involved when viewing Data Trace and
Time Chart Monitoring information in either Histogram or Trend Graph mode.

♦  Chapter 6 PLC Error Component.  This chapter describes the PLC Error Component and the
procedures involved in reading and clearing PLC CPU errors, error log entries and messages.

♦  Chapter 7 Memory Card Component.  This chapter describes the Memory Card Component and
the procedures required to format, access and edit a PLCs memory card/compact flash and to transfer
data between the computer or PLC and memory card/compact flash.

♦  Chapter 8 CX-Net Network Configuration Tool.  This chapter describes the procedures for
establishing communications between PLCs across a network and ensuring that information is routed
correctly to the target devices.

♦  Chapter 9 PLC Clock Tool.  This chapter describes the PLC Clock Tool and the procedures involved
when adjusting the PLC clock.

♦  Chapter 10 Data Link Editor.  This chapter describes how the Data Link Editor enables a PLC to
be configured so that it can participate in one, or more automatic data sharing schemes, over
SYSMAC LINK and Controller Link networks, without the need for special programming.

♦  Chapter 11 Routing Tables.  This chapter describes how Routing tables allow networked PLCs to
be configured so that they can communicate with each other via gateways; across remote networks.

♦  Appendix A Network Availability.  The tables in this appendice indicate the network available to
each PLC device group. FinGateway has no network availability and is not described.
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•  Appendix B PLC Memory Area.  The tables in this appendice provide memory area details for
each device group.

•  Appendix C Toolbars and Keyboard Shortcuts.  The tables in theis appendice summarise the
toolbars and keyboard shortcuts available from each component tool.

A Glossary of Terms and Index are also provided.

W
arning: Failure to read and understand the information provided in this manual
may result in personal injury or death, damage to the product, or
product failure.  Please read each chapter in its entirety and be sure
you understand the information provided in the chapter and related
chapters before attempting any of the procedures or operations given.
Page 5
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CHAPTER 1
Technical Specification

This chapter describes the CX-Server PLC Tools software in general terms and introduces the user to the
relationship between CX-Server PLC Tools and the associated products.  It also provides details of the
operating environment, minimum configuration and installation procedures necessary for the satisfactory
operation of CX-Server PC Tools.

CX-Server PLC Tools Software
PLC Tools are a collection of utilities and programs that provide configuration and control for Omron
PLCs and Networks.

CX-Server PLC Tools consists of the following components:

♦  PLC Memory component.  This component allows the user to view, edit and monitor either
channels (words) or individual bits in areas of the PLC.

♦  IO Table component.  This component retrieves and configures PLC rack and address data.
♦  PLC Setup component.  This component retrieves and configures PLC setting data.
♦  Data Trace/Time Chart Monitor component.  This component records and displays data obtained

from the PLC’s memory areas during program execution.
♦  PLC Error component.  This component displays and manages PLC errors.
♦  Memory Card component.  This component manages the file storage to and from PLC memory

cards.
♦  PLC-Clock component.  This component configures and displays the PLC clock.
♦  Routing Table component. This component manages the routing tables, which allow PLC internode

communications.
♦  DataLink Editor component. This component allows configuration and modification of  the

datalink tables, which allows data to be transferred between PLCs without any other programming.
♦  CX-Net Network Configuration tool.  This tool consists of a suite of programs allowing the

management of Networks for OMRON PLCs.
CX-Server runs within the Microsoft Windows environment (Microsoft Windows 95 or greater, or
Microsoft Windows NT 4.0 or greater) on standard IBM and compatible Pentium-based desktop PCs.

CX-Server PLC Tools utilities form part of other CX-Automation suite applications (CX-Programmer,
CX-Server).

CX-Server PLC Tools have a close relationship with CX-Server Runtime which is the communications
middleware software for Omron PLCs.  For further information see CX-Server Runtime manual.
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About this Manual
This User Manual acts as a reference for CX-Server PLC Tools by describing its various concepts and
abilities, and provides the basics of using its dialogues and supplied utilities.

Caution This manual is referred to from other software applications that utilise CX-
Server, for instance, CX-Programmer, CX-Protocol or SYSMAC-SCS.
Subsequently, some topics contained in this user manual may not be relevant.

The CX-Server PLC Tools come with a context-sensitive online help system which is designed to
complement this manual and to provide a quick reference at any point while using CX-Server PLC Tools
when the manual is not to hand.  This general help system uses a fast hypertext system which allows
progressively detailed information about any topic to be obtained by selecting keywords within the
descriptive text.

Throughout this manual it is assumed that the reader has a working knowledge of Microsoft Windows,
and knows how to:

♦  use the keyboard and mouse;
♦  select options from Microsoft Windows menus;
♦  operate dialogue boxes;
♦  locate, open and save data files;
♦  edit, cut and paste text;
♦  use the Microsoft Windows desktop environment.
If Microsoft Windows has not been used before, it is recommended that the reader spends some time
working with it using the Microsoft documentation before using the CX-Server PLC Tools.

CX-Server 1.6 PLC Tools: New Features
This version of the CX-Server PLC Tools offers significant functionality for communication with
OMRON PLCs and management of their associated settings information.

The following list describes important features that are present in CX-Server 1.6 PLC Tools.

♦  The PLC Tools run under Microsoft Windows 95, 98, Millennium or 2000 and NT4.0 with Service
Pack 5 or later.

♦  The PLC Tools have support for the following communications connections:
♦  SYSMAC WAY,  Toolbus (Peripheral port connection),  Ethernet, Controller Link,

SYSMAC LINK,  SYSMAC NET (for Microsoft Windows NT only) and FinsGateway.
New PLC support includes CS1-H and CSJ-H PLCs.
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System Requirements
The CX-Server PLC Tools operate on IBM compatible personal computers with Pentium II or better
central processor.  It runs in a Microsoft Windows environment (Microsoft Windows 95, 98, Millennium
or 2000 and NT4.0 with Service Pack 5 or later).

Note: CX-Server is not guaranteed to be compatible with computers running Windows
emulation (for example, Apple Macintosh).

The following configuration is the minimum system requirements for running CX-Server in Microsoft
Windows 95, 98 and NT4.0 (Service Pack 5 or later,).

♦  IBM PC-AT compatible or NEC PC-98 compatible computer;
♦  Pentium class CPU operating at 133 Megahertz (MHz) or faster;
♦  Minimum 32 Megabytes (Mb) Random Access Memory (RAM);
♦  Hard disk storage with at least 100 Mb free space;
♦  800 × 600 SVGA or higher resolution display system is recommended.
The following configuration is the minimum system requirements for running CX-Server in Microsoft
Windows 2000 and Millennium edition.

♦  IBM PC-AT compatible or NEC PC-98 compatible computer;
♦  Pentium class CPU operating at 150 Megahertz (MHz) or faster;
♦  Minimum 64 Megabytes (Mb) Random Access Memory (RAM);
♦  Hard disk storage with at least 100 Mb free space;
♦  800 × 600 SVGA or higher resolution display system is recommended.

The following is the recommended minimum system environment.

♦  IBM PC-AT compatible or NEC PC-98 compatible computer;
♦  Pentium class CPU operating at 200 Megahertz (MHz) or faster;
♦  64 Megabytes (Mb) Random Access Memory (RAM);
♦  A minimum of 150 Mb free hard disk space;
♦  1024 × 786 SVGA or higher resolution display.
Use of a mouse is highly recommended, although all operations can be performed using the keyboard.
Refer to the on-line help or the User Manual for a list of keyboard shortcut commands.

The amount of RAM and hard disk space used depends upon the size of the PLC programs written –
approximately 1K per step.
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Communications Requirements
In order to use serial communication types SYSMAC WAY and Toolbus the following is required:

♦  RS232 connection via a standard serial port on the PC (COM1 etc.) or RS422 connection to a 422
serial board.

♦  In order to use SYSMAC LINK directly from the PC a SYSMAC LINK Network Service Board and
FinsGateway Version 3 is required.

♦  In order to use SYSMAC NET directly from the PC a SYSMAC NET Network Service Board and
FinsGateway Version 3 are required.  (Windows NT4 only)

♦  In order to use Controller Link, Controller Link Network Service Board (wired or optical) and
FinsGateway Version 3 are required.

♦  In order to use Ethernet, an Ethernet card, Windows Sockets software and TCP/IP installed and
correctly configured are required.

Refer to the appropriate hardware system manuals for full information about connecting and configuring
these devices for the environment.

In order to use FINSGateway with the CLK/SLK PCI board in the Windows 98 or 2000 operating system
the appropriate drivers must be installed.  These drivers can be found on the CX-Server CD under:
CX-Server\WDM\CLK  (PCI)\   or   CX-Server\WDM\SLK  (PIC)\

Installation
This chapter describes the procedures involved in the installation of CX-Server and the PLC Tools on
a standard workstation running under Microsoft Windows 95 or Microsoft Windows NT 4.0.

The software is supplied on CD-ROM and is installed easily from within Microsoft Windows.  The
installation can be terminated at any point during the installation process.

1, 2, 3… 1. Insert the CD-ROM in the appropriate drive and select the Run option from the
Start pushbutton on the taskbar.

2. Click the Browse pushbutton to select the CX-Server executable file from the CD-
ROM drive.

3. Click the OK pushbutton to initiate the installation.  Follow the on-screen
instructions.

Starting CX-Server PLC Tools
CX-Server PLC Tools components are normally accessed from the invoking application.  However, a
number of tools can be accessed stand-alone from the Start pushbutton on the Microsoft Windows
taskbar.

CX-Net Network Configuration tool.
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Help and How to Access it
The CX-Server PLC Tools come with a detailed context-sensitive help system.  At any time while using
the software, it is possible to get help on the particular point that is currently being worked on, or on
general aspects of the CX-Server PLC Tools.  This system is intended to complement the manual, by
providing online reference to specific functions of the software and how to use them.  The manual is
designed to provide more tutorial information and discuss the various facilities offered by the CX-
ServerPLC Tools.

♦  Context-sensitive help;
♦  Help Index (available on the Help menu);
♦  Help Contents (available on the Help menu);
♦  About (available on the Help menu);
♦  Status Bar.

Help Topics
For any of the PLC Tools select the Help Contents option on the Help menu.  The Help system provides
a standard look-up dialogue under the Contents tab showing the contents of the PLC Tools Help file.
Click on an item to read the associated information.

Index
Use the following procedure to retrieve online help from the Index tab of the Help Topics dialogue.

1, 2, 3… 1. Select the Help Index option from the Help menu.
2. Enter a text query into the first step field.  The second step field is refreshed

according to the query entered in the first step field.
3. Select an entry in the second step field and select the Display pushbutton, or

double-click on the index entry.
4. If an entry is linked to two or more topics, the names of the topics are displayed

in the Topics Found dialogue.  Select a topic and choose the Display pushbutton
or double-click on the topic.

Find
Use the following procedure to retrieve on-line help from the Find tab of the Help Topics dialogue.

1, 2, 3… 1. Select the Help Index option from the Help menu.
2. Select the Find tab.
3. Enter a text query into the first step field.  The second step field is refreshed

according to the query entered in the first step field.  Previous text queries can be
retrieved by selecting from the drop-down list in the first step field.
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4. Select a word that matches the query – some words may be automatically selected.
More than one word can be selected by pressing Shift and selecting another word
to extend the selection, or by pressing Ctrl and selecting another word to add to
the selection.  The third step field is refreshed according to the word or words
selected.  The number of topics found are shown at the bottom of the dialogue.

5. Select a topic from the third step field and select the Display pushbutton, or
double-click on the topic from the third step field.  Select the Clear pushbutton
to restart the find operation.

The Find operation can be enhanced by the use of the Options pushbutton and Rebuild push-button.
Refer to Microsoft Windows 95 documentation for further information.

Context-sensitive Help
The CX-Server PLC Tools support the use of context-sensitive help.  The relevant online help topic is
provided automatically by selecting the current area of the display responsible for carrying out those
actions.  Select the F1 function key to retrieve context-sensitive help.  Some dialogues include a Help
pushbutton when F1 cannot be accessed.

About CX-Server PLC Tools
Each CX-Server PLC Tools dialogue contains an About option on the Help menu.  The About dialogue
supplies technical reference information about that dialogue such as version and copyright information.
It also contains essential version number information that is required for obtaining technical support.

Use the following procedure to view the About CX-Server dialogue.

1, 2, 3… 1. Select About from the Help menu.
2. The About box is displayed.  It provides a copyright statement and version number

of the component or tool within CX-Server.

Status Bar
The Status Bar is displayed at the bottom of many of the CX-Server dialogue and PLC Tool windows.
It provides several helpful pieces of information while programming:

♦  Instant Help.  A brief message appears in the Status Bar as menu commands and buttons are
selected.

♦  Online Status.  The online or offline status of the PLC. (i.e. connected to PLC or not).
♦  PLC Mode.  When connected to a PLC, this shows the current PLC mode.  Connection errors are

also displayed here.
♦  Connected PLC and CPU Type.  The currently connected PLC and associated CPU can always be

referenced in the status bar.
The Status Bar can be enabled and disabled from many components and tools by selecting the Status Bar
option from the View menu.
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Technical Support
If the installation instructions for this application have been followed (refer to Installation in this
Chapter), no difficulties should be encountered.  However, if there is a problem, contact Customer
Services.

If a problem occurs, check that it does not relate to a fault outside CX-Server or the PLC Tools.  Check
the following:

♦  The PC is working correctly.
♦  The PLC is working correctly.
♦  The communications system is set up correctly.
♦  The errors are cleared in the PLC.
When Customer Services need to be contacted, keep the details shown in the following table to hand.  A
clear and concise description of the problem is required, together with the exact text of any error
messages.

Note: Use the About box to obtain the version number of the component.
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Customer Services Required Information Table

Version number of CX-Server
component or tool:
Serial number of the software:
Operating system and version
number:
Language of operating system:
PLC type, model and CPU
details:
Type of communications in use:
Serial
SYSMAC LINK
SYSMAC NET
Controller Link
Ethernet
Toolbus
Nature of the problem:

Steps taken to reproduce
problem:

Other comments:
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CHAPTER 2
PLC Memory Component

This chapter describes the PLC Memory component and its ability to allow the user to view, edit and
monitor either channels (words) or individual bits in areas of the PLC.

The PLC Memory component allows viewing, editing and monitoring of PLC memory areas, monitoring
and forcing of bit addresses and symbols and forced status information.

The PLC Memory component displays the values of the memory area being accessed within the PLC.
Areas to be monitored are selected from the memory area workspace.  The address workspace shows
individual bits, individual channels symbols and forced status information by selecting or entering
specific PLC addresses or symbol names.  The current values of these areas are displayed in the PLC
Memory component.  There are no values displayed when the PLC is offline.

The PLC Memory component can be forced to stay as the top window by selecting Always on top from
the View menu.

For moving, resizing, tiling, maximising, minimising and closing windows, refer to Microsoft Windows
online help for further information.

Access to the PLC Memory component is from the invoking application.

To close the PLC Memory dialogue, select the Close button in the title bar.

The left pane, known as the Data Area Workspace, displays the current PLC in terms of its data areas and
addresses.  The data areas that form part of the PLC memory differ depending on the PLC type.  The
status bar provides instant help, displays the PLC and CPU type and describes the operating mode of the
PLC.
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To expand the hierarchy in the left pane, select this icon.

To collapse the hierarchy in the left pane, select this icon.

    To view the content of a particular branch in the hierarchy, double-click on the item in
the Data Area Workspace: a window is displayed within the PLC memory component.
The associated icon in the Data Area Workspace changes to denote that a window has
been opened.  Multiple windows can be opened at the same time.
Select the Close button in the window’s title bar to close the window.

Columns can be resized using the Resize Column button from the toolbar to fit the
visible display area.  This options are useful when changing data format, for instance
to Binary.

The display of the Data Area Workspace can be controlled from the display by selecting Data Area
Workspace from the View menu.

The toolbar and status bar can both be turned on or off.  Select Status Bar from the View menu to control
the display of the status bar.  Select Toolbar from the View menu to control the display of the PLC
Memory toolbar.

PLC Data Area
The Memory tab of the PLC Memory component allows monitoring and editing of complete memory
areas as channel data.
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When the content of a memory area is opened, a window is displayed.  It is possible
to Zoom in and out of the window by selecting the Zoom In button or Zoom Out
button from the toolbar.  Select the Restore Zoom/Zoom to Fit button from the
toolbar to return the window to the original zoom setting.

Editing Data
Data can be entered or amended in the data area displayed provided the associated PLC or memory area
allows read/write operations.  Use the following procedure to edit data in the Memory tab.

1, 2, 3… 1. Double-click on the required data area name in the Memory tab of the Data Area
Workspace to open it.  A window containing a grid representing that data area is
opened.

2. Select an appropriate format for the data to be entered from the associated button
from the toolbar: Binary, Binary Coded Decimal, Decimal, Signed Decimal,
Floating Point, Hexadecimal, Double Floating Point or Text.

3. Type in valid values directly into the cells and press Return.

Note Once a format has been selected a keyboard filter is applied so that non-valid
keystrokes are ignored.

When in either Debug mode (for CV-series PLCs only) or Monitor mode: it is not possible to edit a read-
only value.

PC to PLC Communications
The PLC Memory component permits the transfer of data to and from the PLC and allows comparisons
to be made between data stored on the computer and the PLC.  Use the following procedure to retrieve
data from the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Open a data area by double-clicking a data area from the Data Area Workspace in

the Memory tab.
3. Select the Transfer from PLC button from the toolbar to read information from

the PLC.
4. The Transfer from PLC dialogue is displayed.  Transfer can be performed on the

memory areas that have been opened in the PLC Memory component.  Select the
associated setting to monitor that area.

5. Select the Visible Area Only option to transfer the area visible to the window, the
Selection option to transfer the area highlighted by the cursor or the All option to
transfer all of the selected memory area from the PLC.  Alternatively, use the
Select All pushbutton to transfer all opened memory areas from the PLC.

6. Select the Upload pushbutton to accept the settings or the Cancel pushbutton to
abort the operation.
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Note By clicking an associated data area’s settings in its greyed state, the PLC
Memory component automatically identifies the data area words to be
monitored.

Use the following procedure to write data back to the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Open a data area by double-clicking a data area from the Data Area Workspace in

the Memory tab.
3. Select the Transfer to PLC button from the toolbar to transfer information to the

PLC.
4. The Transfer to PLC dialogue is displayed.  Transfer can be performed on the

memory areas that have been opened in the PLC Memory component.  Select the
associated setting to monitor that area.

5. Select the Visible Area Only option to transfer the area visible to the window, the
Selection option to transfer the area highlighted by the cursor or the All option to
transfer all of the selected memory area to the PLC.  Alternatively, use the Select
All pushbutton to transfer all opened memory areas to the PLC.

6. Select the Download pushbutton to accept the settings or the Cancel pushbutton
to abort the operation.

Note By clicking an associated data area’s settings in its greyed state, the PLC
Memory component automatically identifies the data area words to be
monitored.

The PLC Memory component allows the values stored on the PLC and the current displayed values to
be compared.  Use the following procedure to compare PLC and PC values.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Select the Compare with PLC button from the toolbar to compare information

between the PC and the PLC.
3. The Compare with PLC dialogue is displayed.  Comparisons can be performed on

the memory areas that have been opened in the PLC Memory component.  Select
the associated setting to compare that area.

4. Select the Visible Area Only option to compare the area visible to the window, the
Selection option to compare the area highlighted by the cursor, or the All option to
compare all of the selected memory area to the PLC.  Alternatively, use the Select
All pushbutton to compare all opened memory areas.

5. Select the Compare pushbutton to accept the settings or the Cancel pushbutton to
abort the operation.

Whilst comparing, all values resident on the PLC that are different to those on the PC are annotated in
brackets.  Further editing to the data area causes further differences between PC and PLC versions, and
these are also annotated.
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Monitoring Data
Use the following procedure to monitor the data in PLC memory:

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Select the Monitor button from the toolbar to monitor the PLC.

3. The Monitor dialogue is displayed.  Monitoring can be performed on the memory
areas that have been opened in the PLC Memory component.  Select the associated
setting to monitor that area.

4. Select the Visible Area Only option to monitor the area visible to the window or the
Selection option to monitor the area highlighted by the cursor.

5. Select the Monitor pushbutton to accept the settings or the Cancel pushbutton to
abort the operation.

Once monitoring, all changes to the data area are viewed.  By navigating around the data area window,
the visible area of the monitoring set by the Visible Area Only option changes to compensate.

Clearing and Filling Data Areas
A whole data area can be cleared by clicking on the Clear Data Area button from the toolbar.

A whole data area can be populated with a particular value.  Use the following procedure to fill a data
area with a single value.

1, 2, 3… 1. Open a data area by double-clicking a data area from the Data Area Workspace in
the Memory tab.

2. Select the Fill Data Area button from the toolbar.  The Fill Data Area dialogue
is displayed.

3. The Fill operation can be performed on the memory areas that have been opened
in the PLC Memory component.  Select the associated setting to fill that area.

4. Supply the value in the Value field.
5. Select the appropriate Fill Range option, either All, Visible Area Only or the

selection currently highlighted by the cursor.
6. Select a Value option, either Binary, Binary Coded Decimal, Decimal, Signed

Decimal or Hexadecimal.
7. If required, select a Set Status Value setting and the appropriate On or Off option.
8. Select the Fill pushbutton to accept the settings or the Cancel pushbutton to abort

the operation.
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PLC Address Area
The Address tab of the PLC Memory dialogue allows monitoring and forcing the status of individual bits.

Monitoring
Use the following to monitor an address or a symbol from an invoking application.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Click on the Address tab of the PLC Memory component.
3. Open the Monitor area by double-clicking the Monitor branch from the Data Area

Workspace in the Address tab.
4. Enter an address in the Address field or select a Symbol to be retained from the

invoking application:
•  In a Symbol field, type in a Symbol name or select the Browse button to select

a Symbol to be retained from the invoking application.  The corresponding
Address field automatically detects and contains the address associated with the
Symbol.

•  If a Symbol has not been selected, in an Address field, type in a direct word or
bit address to monitor.

Note Address notation for CS1-series PLCs and CV-series PLCs is, for instance
‘D0’, ‘0’, ‘E0.0’ to monitor a word, ‘0.0’, ‘cf100’ to monitor bits.
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When monitoring starts, data from the PLC is displayed in the Value field, in the format
specified in the Format field.  The display format of the address or symbol to be
monitored can be changed by selecting an appropriate button from the toolbar: Binary,
Binary Coded Decimal, Decimal, Signed Decimal, Hexadecimal or Text.

Any special address information is shown in the Attribute field.  The attribute of a bit can be forced.  It
is not possible to force bit addresses that are read-only.  Use the following procedure to apply a forced
setting.

1, 2, 3… 1. Ensure a bit is currently being monitored and is not read-only.
2. Select the Attributes setting for the bit.
3. Select the forced state of the bit.  A bit can be forced on by selecting the Force On

button from the toolbar.  A bit can be forced off by selecting the Force Off button
from the toolbar.  Forced settings can be cancelled by selecting the Force Cancel
button from the toolbar.  Select the Set Value button from the toolbar to set a value
to the attribute.

Refer to Chapter 2 – PLC Memory Component for further information.

The update rate is shown in the Properties field.

Further rows can be inserted into the Address Monitor window by selecting Insert from the Address
menu.  Rows can be removed by selecting Remove from the Address menu.  All rows can be removed
by selecting Remove All from the Address menu.

Forced Settings
It is possible to specify the state of an address regardless of its actual (physical) state, this is particularly
useful for testing certain conditions or rungs in a ladder program.

Once scanned, the Forced Status window displays the address, value and attributes for all forced bits.

It is not possible to force bit addresses that are read-only.

Displaying Forced Status
The forced status of bits can be retrieved from the PLC.  Use the following procedure to retrieve the
forced status of bits from the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Click on the Address tab of the PLC Memory component.
3. Click the right-mouse button on the Forced Status branch and select Scan Forced

Status.  All bit areas in the PLC are scanned to find all forced bits (Forced On and
Forced Off).  The Forced Status window is displayed showing all forced bits and
their associated value and attributes.
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Copying a Forced Bit
A forced bit can be copied from the Force Status window to the Address Monitor window.  Use the
following procedure to copy a forced bit.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Click on the Address tab of the PLC Memory component.
3. Open the Forced Status area by double-clicking the Forced Status branch from the

Data Area Workspace in the Address tab.
4. Select the address to be copied with the right-mouse button in the Forced Status

window and select Copy to Symbol Monitor Address.

Clearing Forced Bits
All forced bits can be cleared.  Use the following procedure to clear forced bits.

Caution This operation will clear all forced bits in the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Click on the Address tab of the PLC Memory component.
3. Open the Forced Status area by double-clicking the Forced Status branch from the

Data Area Workspace in the Address tab.
4. Click the right-mouse button in the Forced Status window and select Clear All

Forced Addresses.
5. Select the Yes pushbutton to confirm the operation.

Updating the Forced Status Window
Use the following procedure to refresh the Force Status window.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Memory component.
2. Click on the Address tab of the PLC Memory component.
3. Open the Forced Status area by double-clicking the Forced Status branch from the

Data Area Workspace in the Address tab.
4. Click the right-mouse button in the Forced Status window and select Refresh.

PLC Memory Management
A number of features of the PLC Memory Component are common to both the Memory tab and Address
tab.

PLC Memory component files can be saved to the CX-Server project.  Use the following procedure to
save PLC Memory component details to the CX-Server project.
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1, 2, 3… 1. Select the Save in Project button from the toolbar.  The Save dialogue is
displayed.

2. Select the required data areas to include in the file from the Areas to Save: field.
3. Enter a comment in the File Comment field.
4. Select the OK pushbutton to proceed.

PLC Memory component files can be saved via a standard File Save dialogue.  Use the following
procedure to save a PLC Memory component file.

1, 2, 3… 1. Select Save to File from the File menu.  The Save dialogue is displayed.
2. The Save dialogue is displayed.  Select the required data areas to include in the file

from the Areas to Save: field.
3. Enter a comment in the File Comment field.
4. Select the OK pushbutton to proceed.
5. A standard File Save dialogue is displayed.  Enter a file name in the File name field

and select the Save pushbutton.  PLC Memory files have a .MEM extension.
Information saved to a file can be supplemented with header information set as a preference.  Refer to
Chapter 2 - PLC Memory Component for details of setting header information to a file.

PLC Memory component files can be retrieved via a standard File Open dialogue.  Use the following
procedure to open a PLC Memory component file.

1, 2, 3… 1. Select the Open File button from the toolbar to open a PLC Memory component
file.  A confirmation message box may appear if the file is already open.  Select the
Yes pushbutton to save the currently open details.  Select the No pushbutton to
discard the currently open details.  Select the Cancel pushbutton to abort the
operation.

2. A standard File Open dialogue is displayed.  Select a file from the Open PLC
Memory File dialogue, followed by the Open pushbutton.  PLC Memory files have
a .MEM extension.

PLC Memory component data can be printed.  Use the following procedure to print details.

1, 2, 3… 1. Open the Address Monitor window from the Address tab or a data area window
from the Memory tab.

2. Select the Print Preview button from the toolbar.  A preview window is displayed.

3. Select the appropriate pushbutton to view the printout.
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♦  Select the Next Page pushbutton to view the next page of the printout;

♦  Select the Prev Page pushbutton to view the next page of the printout;

♦  Select the Two Page pushbutton to view two pages of the printout at once;

♦  Select the Zoom In pushbutton to zoom in to the page;

♦  Select the Zoom Out pushbutton to zoom out from the page;

♦  Select the Print pushbutton to print from the preview.

♦  Select the Close pushbutton to close the preview window.
4. Select the Print button from the toolbar.  A standard Print dialogue is displayed.

5. Set up the required printer settings.  Select the OK pushbutton to print the PLC
Memory details or the Cancel pushbutton to abort the operation.

Note Printer specific settings can be applied prior to printing the PLC Memory
details, by selecting Print Setup from the File menu.

Use the following procedure to copy or move information from or in the PLC Memory component.

1, 2, 3… 1. Select an item or items in a window.
2. Select the Copy button from the toolbar to copy the item, or the Cut button from

the toolbar to move the item.
3. Select an area to move the items to, for instance copying data area values into

another data area.
4. Select the Paste button from the toolbar to paste the item.  A Paste operation can

be performed several times without copying again.

PLC Memory Preferences
PLC Memory component preferences permits the setting of display properties for data monitoring.

The Display tab defines the preferred display format.  Use the following procedure to change the display
format preference:

1, 2, 3… 1. Select the Preferences option from the View menu.
2. Select the appropriate word display format option, either Binary, Binary Coded

Decimal, Decimal, Signed Decimal, Floating Point, Hexadecimal, Double Floating
Point or Text.

3. Select the appropriate bit display format option, either Text or Numeric.
4. If required, select the appropriate font using the Change Font pushbutton.
5. Select the OK pushbutton to accept the settings or the Cancel pushbutton to abort

the operation.
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The Monitoring tab allows the monitor update interval preference to be amended.  Use the following
procedure to change the monitor update interval preference.

1, 2, 3… 1. Select the Preferences option from the View menu.
2. Select the Monitoring tab.
3. Select a Monitor Update Interval and an associated Unit from the fields.
4. Select the OK pushbutton to accept the settings or the Cancel pushbutton to abort

the operation.
The General tab permits the setting of general preferences.  Use the following procedure to change the
general preferences.

1, 2, 3… 1. Select the Preferences option from the View menu.
2. Select the General tab.
3. Select the Automatically Resize Column Widths option to ensure that all values

remain visible within the data area window irrespective of their display format.  It
is best practise for this option to be set OFF when monitoring large data areas.

4. Select the Prompt Before Closing an Active Monitor Window option if
confirmation is required before closing a data area window that is being monitored.

5. Select the Beep on Invalid Input option to receive an audible beep when an invalid
input to the PLC Memory component has been made.

6. Select the Fast Window Update option to reduce the affect of flickering when
monitoring.

7. Select the OK pushbutton to accept the settings or the Cancel pushbutton to abort
the operation.

The File tab permits the setting of header information into PLC memory component files.  Use the
following procedure to change the file information.

1, 2, 3… 1. Select the Preferences option from the View menu.
2. Select the File tab.
3. Insert a file name in the File Name field.
4. Insert a comment in the Comment field.
5. Select the OK pushbutton to accept the settings or the Cancel pushbutton to abort

the operation.
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CHAPTER 3
IO Table Component

This chapter describes the IO Table component available to C-series, CV-series, CS1-series and CS2
series including CJ1 PLCs and its ability to create, retrieve and edit a configured PLC’s rack and address
data.

The IO Table component allows configuration of racks, slots and units within a PLC, using available
hardware as reference.  Within a PLC there are three versions of an IO Table, all of which should ideally
have the same contents.  IO Table component editing allows manipulation of the internal version of the
table, and modification of the PLC’s view of how the hardware is configured.  The three versions are:

♦  Actual IO Table.  The real hardware configuration of the PLC units and slots on power-up.
♦  Registered IO Table.  The internal PLC table: this is the one used by the PLC when running,

regardless of the state of the actual hardware.  It can be read and, for C2000 PLCs, CV-series PLCs
and CS-series PLCs, written to by the CX-Server software.

♦  CX-Server IO Table.  The IO configuration understood by CX-Server.  It can be created and
modified directly, independently from the PLC, and can be transferred with a program (for CV-
series and CS1-series PLCs).

The Registered Table and CX-Server’s table can be changed from the PC, but the actual configuration
requires the physical manipulation of the PLC hardware.  It is only possible to transfer the Registered
IO Table in C2000, CV and CS1-series PLCs to the PLC.  Editing of individual IO units in the Registered
IO Table is only available in C1000H, C2000H, CS1-series and CV-series PLCs.

The IO Table component is displayed as a hierarchical structure.  The IO Table view can be expanded
to show entries for all Remote Terminals (RTs) and the IO.  All possible racks and unit numbers for the
active PLC are displayed although these may not all be in use.  An address and IO string are displayed
against each rack slot or unit; this is used to indicate the input and output characteristics of the unit.

The status bar displays the selected PLC and CPU type, and the current operating mode of the PLC.

When a Remote Terminal (RT) is added, it can be expanded to provide the Terminals view, showing
entries for all slots on that remote rack.

Icons to the left of a rack indicate units fitted to expansion racks, SYSBUS/SYSBUS2 remote racks or
IO Terminals.  To view the content of the IO Table, double-click on a rack.  The unit address is displayed
in brackets for each slot.
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This icon represents an empty rack.

This icon represents a unit or empty slot.

This icon represents a rack that contains units.

To expand the IO Table, select this icon.

To collapse the IO Table, select this icon.

For CV-series PLCs, SIOU units are shown on the IO Table tree as a separate rack.  For CS1-series
PLCs, SIOU units are all integrated into the main rack.

Whilst in online mode operations can be selected that affect the PLC, for instance creating an IO Table.
These options are only available when the PLC is in the correct mode of operation for programming.

The IO Table component can be forced to be displayed in focus by selecting Always on top from the
Options menu.

For moving, resizing, maximising, minimising and closing windows, refer to Microsoft Windows online
help for further information.

Access to the IO Table component is from the invoking application or via the CX-Net Network
Configuration Tool.  Refer to Chapter 8 - CX-Net Network Configuration Tool for further details.

To close the IO Table dialogue, select the Close button in the title bar.
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Unit Settings

Creating an IO Table
Creation of an IO Table whilst connected to a PLC causes the Actual IO Table in the hardware to be
written to the Registered IO Table.  An IO Table can also be edited offline and stored to file, this method
is usually employed when designing a PLC’s IO Table.

To create an IO Table, Select Create from the Options menu.

Slot Allocation
Use the following procedure to allocate a unit to a slot.

1, 2, 3… 1. Select an empty slot in the IO Table component.
2. Click the right-mouse button and select a unit.  For Single and Multiple IO Units

a secondary selection is required from the right-mouse button menu.  The type of
PLC series and individual rack configurations determine the units that can be
installed and therefore the content of the right-mouse button menu.  The types of
unit that can be selected are described in following paragraphs.

Slots can also be allocated by transferring the rack information from the PLC.  Refer to IO Table
Component in this chapter for information regarding transferring IO Table information from the PLC.

For CS1-series PLCs, the IO fields for racks, slots and units information can be edited directly in the IO
Table tree.

Only those units in the Registered IO Table for CS1-series PLCs, C200H (including C200HS/X/G/E)
PLCs and CV/CVM1-series PLCs can be edited.

Caution Any slots allocated must be verified to ensure that the Real IO Table is set up
correctly.  Refer to IO Table Component in this chapter for further
information.

Single and Multiple Units
Points with an IO Type of Input, Output or Input/Output can be applied to the IO Table component.  Each
point contains a name and an address indicating its position in PLC memory.  The information contained
within a point can be read or updated by the controlling system and its status and content stored in the
system’s database.  An application accesses this point data by establishing a link between the application
and the database.  A point can have the same address as another and any comment entered against this
address applies to all points at that location.

All PLC series support 8-point, 16-point, 32-point and 64-point Units.  CV-series PLCs and CS1-series
PLCs also support 128-point and 256-point Units.

Refer to the Run Time manual for an introduction to points.
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Counters, Position Controller, Numerical Control and ASCII Units
Use the following procedure to apply unit settings to Counters, Position Controllers, Numerical Control
and ASCII units.

1, 2, 3… 1. Allocate a slot to be a Counter unit, Position Controller unit, Numerical Control
unit or ASCII unit.  The Enter SIOU Details dialogue is displayed.

2. Enter valid settings for the Unit Number field, Address per Unit field, Input Words
field and Output Words field.  Valid settings exclude those settings that have
already been used.

3. Select the OK pushbutton to complete the operation or the Cancel pushbutton to
abort the operation.

Additionally for Counters, Numerical Control and ASCII units, for CV-series PLCs and CS1-series
PLCs, the CIO and DM Address range need to be specified; refer to Chapter 3 - Software Switches for
further information.

Interrupt Units
Interrupt units are automatically assigned until the maximum number of units has been reached.

Sysmac-Bus Master Unit and Remote Terminals
If the Sysmac-Bus Master option is selected from the context menu, the hierarchy in the IO Table
component can be further expanded to expose the Remote Terminals and IO Terminals that form part
of the SYSMAC-BUS option.  Use the following procedure to apply unit settings to Sysmac-Bus Master.

1, 2, 3… 1. Allocate a slot to be a Sysmac-Bus Master unit.  The Enter RM Number dialogue
is displayed.

2. Select a unit number from the Unit Number field, either 0 or 1.
3. Select the OK pushbutton to complete the operation or the Cancel pushbutton to

abort the operation.
The Sysmac-Bus Master unit provides two types of slave units that can be applied to the slave rack in
the same manner as a normal rack:

♦  C500H Remote Terminal (RT);
♦  C200H Remote Terminal (RT).
Any units on the slave racks or other Remote IO Units connected to the master are allocated IO words
according to the slot where the master is located.

For C1000H and C2000H PLCs, Word multipliers are required to set the base address of IO Terminals
on each SYSMAC-BUS Remote Master.

SIOU/Communications Units
SIOU/Communications Units can only be set up for CV-series PLCs and CS1-series PLCs.
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For CV-series PLCs SIOU/Communications Units the following Unit Setup and Software Switches setup
can be performed:

♦  Basic (Software Switches setup only);
♦  CompoBus/D Master (Software Switches setup only);
♦  Controller Link;
♦  Ethernet;
♦  Host Link;
♦  ISA Board Unit (Software Switches setup only);
♦  ME-Net (Software Switches setup only);
♦  Mini-map (Software Switches setup only);
♦  M-Net (Software Switches setup only);
♦  Motion Controller (Software Switches setup only);
♦  PC (Software Switches setup only);
♦  Syslink;
♦  Sysmac-Bus Master;
♦  SysNet.
For CS1-series PLCs SIOU/Communications Units the following Unit Setup and Software Switches
setup can be performed:

♦  Controller Link Unit;
♦  Device Net and Open Network controllers;
♦  
♦  Ethernet Unit;
♦  Serial Communications Unit (Software Switches setup only).
Most of the settings for SIOU/Communications Units should have been set via the PLC setup component.
Refer to Chapter 4 - PLC Setup component for further details.

Refer to Chapter 3 - Unit Setup and Software Switches for further information.

Caution Setup to SIOUs that have already been registered should be applied carefully.

Verifying Correct Configuration
If a change is made to the IO configuration that affects a type of IO word or the number of words
required by a unit, for instance adding or removing units, an IO verification error occurs.  Select Verify
from the Options menu to ensure that an IO verification error has not occurred.  If an error has occurred,
use the procedures explained in Chapter 3 - Creating an IO Table, Chapter 3 - Slot Allocation and
Chapter 3 - Transfer an IO Table to rectify any error.
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Unit Setup
The Unit Setup for a selected rack IO option can be edited for CV-series and CS1-series PLCs only.  For
C-series PLCs, refer to Chapter 8 - CX-Net Network Configuration Tool.  Use the following procedure
to edit the Unit Setup.

1, 2, 3… 1. Highlight the rack/unit in the IO Table tree.
2. Click the right-mouse button and select Unit Setup.
3. Set the required unit setup options for the specified rack/unit.

Note The availability of the Unit Setup option depends on the rack/unit selected.
The SIOUs attached to a PLC are shown in the IO Table component.

The PLC Communications Unit Setup dialogue allows both the system and software switch memory
areas associated with a mounted Special Input/Output unit (SIOU) to be configured.

Software Switches
The Software Switch settings for a selected rack IO option can be edited for CV-series and CS1-series
PLCs.

For CV-series PLCs, the Software Switch settings appear in the IO Table tree as SIOU Units.  For CS1-
series PLCs, the Software Switch settings appear in the IO Table tree as part of the Main Rack
information.

The dialogue which is presented for software switch setup depends upon the type of the SIOU and allows
the software switch memory area associated with a mounted SIOU to be configured.  Software switches
provide status information on each SIO unit on the PLC.

Note It is also possible to edit the Inner Board software switches for the CS1-series
PLC if fitted by selecting Inner Board Software Switches option from the
PLC’s context menu.

The Software Switch dialogue is displayed allowing the network unit system memory area to be
configured and transferred to the PLC.  Software switches can be defined for the following:

♦  SYSMAC LINK.  Allows set up of Data Link (on/off) and Internode Test (on/off) and setting of
response monitor time;

♦  SYSMAC NET.  Allows set up of Data Link (on/off) and Internode Test; (on/off);
♦  Ethernet.  Allows set up of Internode Test (on/off) and setting of response monitor time.
♦  Controller Link.  Allows the polling status of the node to be set (whether it is a polling or polled unit)

and whether to clear the Controller Link unit EPROM.
Use the following procedure to edit the Software Switch Setup.

1, 2, 3… 1. Highlight the rack/unit in the IO Table tree.
2. Click the right-mouse button and select Software Switches.
3. Set the required software switch setup options for the specified rack/unit.
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General
The General tab of the Software Switches dialogue provides the complete software switches settings for
a Basic unit, PC unit, Mini-map unit, Host Link unit, Motion Control unit, ME-Net unit, CompoBus/D
Master unit and ISO Baud unit.  It also serves as partial software switches settings for other units.

1, 2, 3… 1. Access the Software Switch dialogue for an appropriate rack/unit.
2. Set the required CIO and DM area address in the CIO Address field and DM

Address field.

Data Link Area
The Data Link tab is used to control whether Data Link is generated automatically or by a specific Data
Link table for SYSMAC LINK, SYSMAC NET and Controller Link.  This setup is only used if the Node
Type is Master.  The list box at the bottom of the chapter is only used when Data Link is set to one of
the automatic options (i.e.  not specific).

1, 2, 3… 1. Select Transfer from PLC from the Options menu to transfer the current system
area settings from the unit.

2. Select the required unit and click the right-mouse button.  Select the Software
Switches setting.

3. Adjust the settings as required.
4. Select Transfer to PLC from the Options menu to transfer the network parameters

to the unit.
5. Select the Reset Unit setting to restart the unit - the written settings are activated

in the unit.
Note If the unit which is being set is the one on which the current communication

to the PLC is being made, the PLC needs to be closed and opened before
communications can continue.

Ethernet
The Ethernet setup differs from SYSMAC LINK, SYSMAC NET and Controller Link by not having a
Data Link Area setup and by having two further dialogue boxes, the IP Address Table and IP Router
Table.  This particular interface requires that each device attached to the network has an IP address, and
that routing information for directing data across the network is also included (where necessary); such
address information ensures that data is transmitted correctly between two nodes.

Note Table information is only used if the IP Address Conv.  Method radio button
is not set to Auto.

The File Transfer Protocol (FTP) allows access to a file card on the PLC.  If a FTP login name and
password are entered then these are used to start an FTP session.  For more information, refer to the
Ethernet User’s Manual.

The IP Address Table dialogue allows the IP address of a network node to be entered.
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1, 2, 3… 1. Select the Ethernet Unit from the IO Table and click the right-mouse button.
2. Select the Unit Setup option.
3. Click on the Insert pushbutton.
4. Enter the IP Address for the node in the IP Address field; each of the four fields

must take a value in the range 0 to 255.
5. Select the OK pushbutton to proceed.
6. Click on the Delete pushbutton to remove the address from the table.
7. Select Transfer from PLC from the Options menu to write the changes back to the

table.
The IP Router Table establishes communications between different networks by maintaining the IP
address for each interface and is created by clicking on the Insert pushbutton above the IP Router table
dialogue.  Procedures are the same as for the IP Address Table described above.

Syslink Unit and Controller Link Specific Settings
A Syslink unit Software Switches dialogue includes a General tab and Data Link tab described
previously.

The Error Information tab provides read-only information regarding the errors that the PLC can detect
and raise an error flag.

The Network Status tab provides network status information.  It also activates the PLC to perform
internode tests.  Select the Start option to set the PLC to check for errors and report them.  Select the Stop
option to stop the PLC from detecting errors.  The Network Node List field lists the network nodes and
whether they are participating in the network operations.

Sysmac-Bus2 Unit Specific Settings
A Sysmac-Bus2 unit Software Switches dialogue includes a General tab described previously.

The Slave tab provides specific status information to the Sysmac-Bus2 unit.  There are various types of
slave that may be connected to a Remote IO Master unit.  These slaves include IO Terminals,
Programmable Displays and Remote IO Slave units.

To view the slaves connected for a group, select the Group required from the field at the top of the Slaves
tab.  The remainder of the Slaves tab displays the Node and Status for each category.

If the hierarchy of the IO Table has been expanded, the three groups can be populated with other units:

♦  Group 1.  16-point and 32-point IO units.
♦  Group 2.  16-point, 32-point, 64-point and 128-point IO units and 256-point dummy.
♦  Group 3.  58M Remote Terminal, 54MH Remote Terminal and 122M Remote Terminal.
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Serial Communications Unit Specific Settings
Serial Communications unit specific software switches settings can only be set for CS1-series PLCs.

A Serial Communications unit Software Switches dialogue includes a General tab described previously.

The Port 1 tab and Port 2 tab are identical.  Settings can be specified for the Format field, Mode field
and Hardware field.

IO Table Management
Changes made to an IO Table can be done by simply editing particular fields in the table.  Basic
information can be changed by displaying the configuration, selecting the rack or unit that needs to be
changed and editing or selecting the new IO address or configuration information.

All slot allocations in the IO Table can be cleared.  Select Clear from the Options menu.

An IO Table unit in the PLC’s Registered IO Table in the PLC can be deleted.  Use the following
procedure to delete an IO Table Unit.

1, 2, 3… 1. Highlight the rack/unit in the IO Table to be deleted.
2. Click the right-mouse button and select Delete.

The CX-Server IO Table component can be examined to determine if it has a valid configuration.  To
check an IO Table, select the Check option from the Options menu.  A message is displayed indicating
whether the operation was successful or not.

The CX-Server IO Table component can compare the local IO Table on the PC with the CX-Server
project settings and displays any differences or errors.  Select the Compare with Project option from the
Options menu.

PC to PLC Communications
The IO Table component permits the transferring of data to and from the PLC and allows comparisons
to be made between data stored on the PC and the PLC.

Transfer an IO Table from a PLC
The Transfer from PLC option loads the Registered Table into the CX-Server IO Table, replacing the
currently displayed setup.  The IO Table can also be part of a general transfer which may, for example,
include transferring program and memory data from the PLC.  Use the following procedure to transfer
an IO Table from the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the IO Table component.
2. Select Transfer from PLC from the Options menu to transfer an IO Table from the

PLC.
The IO Table component is refreshed with the details from the PLC.
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Transfer an IO Table to a PLC
The Transfer to PLC option loads the CX-Server IO Table into the Registered Table: this is only
available to C2000, CV and CS1-series PLCs.  The table can be transferred to the PLC at any time (when
the PLC is online) but the operation can be delayed until other configuration settings have been made and
then the complete configuration can be transferred to the PLC via the PLC Setup component.  Use the
following procedure to transfer an IO Table to the PLC.

1, 2, 3… 1. Ensure the PLC is online before activating the IO Table component.
2. Select Transfer to PLC from the Options menu to transfer an IO Table to the PLC.

Note If the PLC Setup area is either written to the PLC or to the IO Table area the
PLC may need to be powered down and powered up in order for settings take
effect.  If the settings need to be changed without switching off the PLC, write
the PLC Setup data first, then either generate or write the IO Table.  Refer to
Chapter 4 - PLC Setup Component.

Comparing an IO Table
The Registered IO Table can be compared with the CX-Server IO Table and displays any differences.
This option is helpful to confirm that a table that has been set up in CX-Server and has been transferred
to the PLC, agrees with how the hardware is set up.  Use the following procedure to compare a
Registered IO Table with the CX-Server IO Table.

1, 2, 3… 1. Ensure the PLC is online before activating the IO Table component.
2. Select Compare with PLC from the Options menu.

Any differences (if any) are displayed in the IO Table component.

PLC Specific Features
A number of features specific to types of PLC are described in the following paragraphs.

Hot Swapping
Hot swapping is permitted for C1000H/C2000H PLCs and allows modules to be changed without having
to power down.  The modules swapped must be identical.  To Hot Swap, select the Hot Swap option from
the Options menu.

Setting Rack Start Addresses
This option is only available to CV-series PLCs and CS1-series PLCs.  Use the following procedure to
set Rack Start Addresses.

1, 2, 3… 1. Select Rack Start Addresses from the Option menu.  The Rack Start Addresses
dialogue box is displayed.

2. Enter the addresses for each rack as required.  Select the OK pushbutton to accept
the settings or select the Cancel pushbutton to abort the operation.
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Units Profile Information
For CS1-series PLCs, SIOU’s, CPU SIOU’s and other units, unit manufacturing information can be
retrieved, the data read and comments saved against each unit to a Compact Flash disk when fitted.  Use
the following procedure to view the unit manufacturing details:

1, 2, 3… 1. Highlight the PLC name and click the right-mouse button.
2. Select Unit Manufacturing Information and then either CPU Unit or Inner Board

Note:   An error is displayed if the unit does not support manufacting
information.
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CHAPTER 4
PLC Setup Component

This chapter describes the PLC Setup component and the procedures involved in changing a PLC’s
settings both offline and online.

The PLC Setup component allows the PLC settings to be entered for individual C-series PLCs, CV-series
PLCs or CS1-series PLCs.  More than one PLC Setup component can be opened at any one time allowing
a number of PLCs to be configured simultaneously.

Once a PLC has been defined in a project in terms of name, device type and network type, changing
various settings allows the PLC behaviour to be altered.  Options can also be selected to check the PLC
is functioning correctly.

The tabbed PLC settings component shows only options available for the selected PLC.  Some options
will be greyed out in instances where they are not applicable to the PLCs current state.

The status bar displays the PLC and CPU type and the operational mode of the PLC.

Note When configuring a PLC it is advisable to have the PLC operational manual
available for reference.  A warning is displayed before any changes are made
to a PLC’s current state.  This gives the option of cancelling the procedure.

Note The information provided in this chapter is not definitive because of the wide
variety of PLCs and their differing nature - even within the same PLC series.
Consult the relevant PLC operating manual for specific PLC settings
information.

The PLC Setup component can be forced to stay as the top window by selecting the Always on top option
from the Options menu.

For Moving, resizing, maximising, minimising and closing windows, refer to Microsoft Windows online
help.

Access to the PLC Setup component is from the invoking application and also via the CX-Net Network
Configuration Tool, refer to Chapter 8 - CX-Net Network Configuration Tool for further information.

To close the PLC Setup dialogue, select the Close button in the title bar.

CS1-Series PLC Settings
The following paragraphs describe the features of the PLC Setup component associated with CS1-series
PLCs.  Refer to Chapter 4 - PL to PLC Communications for details of transferring PLC setup information
to and from the PLC.

The common Set Default option resets PLC Setup component values to the default settings.
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PLC Startup
The PLC Startup tab of the PLC Setup component allows certain PLC settings to be made which always
take effect on startup (until they are explicitly altered).  Use the following procedure to apply settings
in the PLC Startup tab.

Startup Hold
The Hold area in the PLC’s Work Area Memory retains the status when either the operating mode is
changed, power is interrupted or the PLC operation is stopped. You can select one or all the following
options for the hold area to retain.

1, 2, 3… 1. Force Status Hold Bit - Specifies that the status of the forced status hold bit  is to
be maintained (ticked) or reset to OFF when power is next turned on.

2. IOM Hold Bit - Specifies that the status of the IOM hold bit  is to be maintained
(ticked) or reset to OFF when power is next turned on.

Mode
This selects the default PLC operation mode when the PLC is powered on:

•  Program  - Select this for online programming when the PLC is powered on.
•  Monitor - Select this to start monitoring the running program when the PLC is powered on.
•  Run - Select this to run the PLC’s program when the PLC is powered on.
•  Use Programming Console - This is the default setting that allows you to select the operating mode

when online.
In addition to the above, the following settings are available for CJ1-H and CS1-H PLCs

Execution Settings
For the CJ1-H and CS1-H PLCs series PLCs set the Execution Setting options as oppropiate.

1, 2, 3… 1. Run program when initialize unit/board.  Check the tick box to select this option.
2. Service for units when Inner Board recognition. Check the tick box to select this

option.

Settings
The Settings tab of the PLC Setup component allows execution processes and controls to be defined and
EM allocation to be enabled.

Note:   For CS1-H and CJ1-H PLCs only, this tab is called CPU Settings

Execute Process
Use the following procedure to apply Execute Process settings.

1, 2, 3… 1. Low Battery Enabled - Select (tick) this option to flag when CPU Unit battery
errors are detected.
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2. Interrupt Task Enabled - When this option is selected interrupt task errors will be
detected.

3. Stop CPU Error Enabled - Select this option to determine if instruction errors
(instruction processing errors (ER) and illegal access errors (AER)) are to treated
as non-fatal or fatal errors.

4. Don't register FAL to error log -  Select this option (tick) to stop registering FAL
to error log.

Memory Allocation
CS1-series PLCs can select either Memory Card or EM (Expansion Memory) specified file area.  Each
time EM is selected, the EM is reformatted automatically.

To use EM rather than Memory Card, select the EM File Setting enabled setting and enter the EM Start
File No.  CS1-series PLCs can use EM as file memory, either as or as well as Compact Flash disk.  When
transferred to the PLC, EM is formatted.

In addition to the above, the following settings are available for CJ1-H and CS1-H PLCs

Background Execution
1, 2, 3… 1. Table data process instructions.  Check the tick box enable Table date process

instructions.
2. String data process instructions - Select (tick) this option to enable String data

process instructions.
3. Data shift process instructions - Select (tick) this option to enable Data shift

process instructions.
4. Com port number - Enter a number between 1 and 7 inclusive, to set the Com

port you wish to connect by.
Caution:  entering a com port number higher than the number of ports actually
available will prevent future connections to that PLC.

Timings
The PLC Timings tab of the PLC Setup component allows cycle, interrupt and event timings to be
defined.  Use the following procedure when applying settings in the PLC Timings tab for standard CS1
PLCs.  When setting the timings for other PLC types follow the on-screen instructions.

1, 2, 3… 1. Check the Watch Cycle Time setting and set the watch cycle time if enabled for the
PLC; the default is 0 ms.

2. Deselect the Set Time to all Events setting to enter a time period for all event
processes; this is entered as a percentage of the total cycle time.

3. Check the Power Off Interrupt setting, and set if enabled for the PLC; the default
is 0ms.

4. Set the Cycle Time setting to define the time interval for cycles.



OMRON CHAPTER 4 – PLC Setup Component

Revision 1.6 Page 36

5. Set the Scheduled Interrupt Interval setting to schedule interrupts to occur at
regular intervals; either every 10ms or a specific value can be set.

SIOU Refresh
The SIOU Refresh tab of the PLC Setup component allows SIOU Status to be enabled.  Check the
required Enable SIOU Status setting for each SIOU in the field.

Unit Settings
The Unit Settings tab of the PLC Setup component allows timings for the individual rack slots associated
with the PLC to be set.  Select the required slot(s) from the rack field and the required unit setting; the
default is 8 ms.

Host Link Port
The Host Link Port tab of the PLC Setup component defines the protocol which allows the transferral
of data between the PLC and the host PC.  The default settings may be used or an alternative
communications protocol defined.  Some of the options may not be applicable depending on the device
type selected.  Use the following procedure to apply settings in the Host Link Port tab.

1, 2, 3… 1. The Port Settings default is 9,600 bps, 1 start bit, 7-bit data, 2 stop bits and Even
parity.  Customised port settings can be entered by deselecting the Default setting.

2. Select the CTS Control setting to enable use of CTS.
3. Set the Unit Number setting for the selected PLC.
4. Set the Delay value; a pre-set transmission delay in the range 0000 to 9999 (for

BCD this is in 10ms units).
The following entries cannot be amended:

♦  Link Words.  These word addresses are fixed at LR00 to LR63 (or bit addresses from LR0000 to
LR6315).

♦  Start Code and End Code.  The message start and end codes.
♦  NT Link Max.

Peripheral Port
The Peripheral Port tab of the PLC Setup component defines the connection between the PC and PLC.
The default settings may be used or an alternative communications protocol defined.  Use the following
procedure to apply settings in the Peripheral Port tab.

1, 2, 3… 1. The Port Settings default to 9600 bps, 1 start bit, 7-bit data, 2 stop bits and Even
parity.  Customised port settings can be entered by deselecting the Default setting.

2. Set the Unit Number setting for the selected PLC.
The NT Link Max setting cannot be amended.
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Peripheral Service
Note that his tab is only available for the CS1-H and CJ1-H PLCs (CS1G-H, CS1H-H, CJ1G-H and
CJ1H-H).

The tabbed dialog is split into three sections as follows:

Sync/Async Comms
Execution Mode - The default for this option is Not Specified, and as such means that all other parts are
disabled except for Set time to all events.
Select one option from the list to set the execution mode.  Choosing Not Specified will disable all the
options within the Peripheral Service dialog, except for 'Set time to all events'.  Not Specified is the only
way of setting the Peripheral Service Execution Time to zero.
If Peripheral Service is chosen, editing Peripheral Service Execution Time is possible, and the system
sets the default to 0.1.  See also Instruction Processing (Peripheral Service Execution Time).
Specifying Asynchronous will disable the same options as Not Specified, and set the Execution mode
to Asynchronous processing.  Synchronous likewise sets the Execution Mode to Synchronous processing

Instruction Processing
Instruction Execution Time - A value within and including the range of 5 to 255 or 0 can be entered as
a valid setting.
Peripheral Service Execution Time - A value within and including 0.1 to 25.5 can be entered as a valid
setting.  For more information on when this option is available, see Sync/Async Comms, Execution
Mode, above.
Target Unit (1, 2, 3, 4, 5) and SIOU - The default for this setting is Not Specified.  There are five possible
options for this setting.  After Not Specified, the next option is CPU SIOU.  If this option is selected, the
SIOU number should be entered in the box to the right marked 'SIOU'. The next option is SIOU, and
likewise with the CPU SIOU option, the SIOU number should be entered in the box to the right marked
'SIOU'.  The three remaining options allow either the Inner Board, Host Link Port or Peripheral Port to
be set as the 'Target Unit'.

Set time to all events
Set time to all events (default 4%) - By ticking the checkbox, the default as stated above will be set.  If
the checkbox is not ticked, then a value between 0 and 255 inclusive can be entered, effecting a
maximum setting of 25.5 (255 *0.1).  This option is found in the Timings tab for all other CS1 PLCs.

CV-Series PLC Settings
The following paragraphs describe the features of the PLC Setup component associated with CV-series
PLCs.  Refer to Chapter 4 - PC to PLC Communications for details of transferring PLC setup information
to and from the PLC.

The common Set Default option resets PLC Setup component values to the default settings.
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PLC Startup
The PLC Startup tab of the PLC Setup component allows certain PLC settings to be made which always
takes effect on startup (until they are explicitly altered).  Some of the options may not be applicable
depending on the device type selected.  Use the following procedure to apply settings in the PLC Startup
tab.

1, 2, 3… 1. The status of the Force Status Hold setting, IOM Hold Bit setting and Restart
Continuation Bit setting in the Startup Hold area of the PLC’s Work Area memory
can be set so that they are either maintained or reset to OFF on power up.

2. When power is restored after an interruption, the IO Bits setting and Power-On
Status setting must be selected and the PLC startup mode must be set to Run or
Monitor.

3. Set the Mode setting to either Program, Monitor, Run, Debug or Use Programming
Console.  The default mode is Program.

4. Set the Display Mode setting.  The 7-segment display of the IO Interface units, IO
Control unit and SYSMAC BUS/2 Remote IO Slave units can be set to one of three
modes.  The mode is indicated by the position of the decimal point.

♦  Mode 1.  Displays the first IO word allocated to the rack (000 indicates an
error).  This is the default mode.

♦  Mode 2.  Displays the CPU operating status (A or -) and error status
(E, F or -), peripheral connection and rack number.

♦  Mode 3.  Displays a 4-character message when the IODP (189) instruction is
executed in the unit’s program.

5. Check the Automatically Transfer User Program setting to automatically transfer
the user program from one of the PLCs memory cards when the PLC starts-up.

6. Check the Display modes at startup setting to display all selected modes on startup.

Error Log
The Error Log tab permits certain settings to be applied to error logging.  Either Data Memory (DM) or
Extended Memory (EM) areas can be selected to hold the PLC’s Error Log.  Refer to Chapter 6 - PLC
Error Component for a description of the Error Log.  Use the following procedure to apply settings in
the Error Log tab.

1, 2, 3… 1. Check the Enable Error Log setting to enable error logging.  If this is not selected,
the default log auxiliary memory is assigned.

2. Enter the Start Address setting for the error log.  This is only enabled if the Enable
Error Log setting has been selected.

3. Enter the EM Bank Number setting if the Error Log is to be stored on an installed
Extended Memory Card.  The Start Address setting needs to be set to the relevant
area of EM.  This is only enabled if the Enable Error Log setting has been selected.
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4. Enter the Number of Records setting for the number of records to be held in the
PLC Error component.

Note An Error Log in the Auxiliary Area (words A100-A199 for CV1000) can
contain up to 20 error records.  To increase the size of the log (to 2047
records),  move it to either the DM or EM areas.

Execution Controls
Instructions can be executed and peripheral servicing performed by either using:

♦  Event driven (asynchronous) processing mode.  The peripheral servicing process interrupts the
execution process cycle by sending IO refresh requests.

or
♦  Synchronised processing mode.  The execution and peripheral servicing processes wait for each

other to complete the task in hand.

Consult the PLC operational manual for details when defining the execution controls.  Use the following
procedure to apply settings in the Execution Controls  tab.

1, 2, 3… 1. An operand can be indirectly addressed via the DM area in either Binary or BCD.
Select the Binary setting or the BCD setting as required.

2. Set the Step Timer setting for the SFC step instructions.  The default is 0.1s.
Note For CV1000, CV2000 and CVM1/CPU21-EV2 PLCs, EM can be used for

indirect addressing of an operand.

Note The Step Timer setting is not available to CVM1 PLCs.

Execution Controls 1
Use the following procedure to apply settings.

1, 2, 3… 1. Check the Measure CPU-Bus Unit Cycle setting for the CPU to measure the
service cycle.

2. Check the Detect Low Battery setting to flag PLC and Memory Card low battery.
3. Check the CPU standby on initialisation of bus units setting to ensure the CPU

remains in standby until SYSMAC BUS/2 terminators are detected.  If this is not
checked, PLC operation begins regardless of the presence of terminators.

4. Check the Error on power off interrupts setting to ignore a momentary power
interruption (and not generate an error) or leave unchecked to generate an error on
power off.

Execution Controls 2
Check the following settings as required.

♦  The Duplication action error setting.
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♦  The Multiple JMP000 use setting.

♦  The Run program on IO verify error setting.

♦  The Startup trace setting.

♦  The Nest IO interrupts setting.

♦  The IO Interrupt setting.

Host Link Port
The Host Link Port tab of the PLC Setup component defines the protocol which allows the transferral
of data between the PLC and the host PC.  The default settings may be used or an alternative
communications protocol defined.

Use the following procedure to apply settings in the Host Link Port tab.

1, 2, 3… 1. The Port Settings default to 9600 bps, 1 start bit, 7-bit data, 2 stop bits and Even
parity.

2. Select a Unit Number setting for the Host Link port setting.  This has a maximum
value of 31.

IO Refresh
The IO Refresh tab of the PLC Setup component allows the specification of refreshes and their definition
as either timed or immediate refreshes.  Some of the options may not be applicable depending on the
device type selected.  Use the following procedure to apply settings in the IO Refresh tab.

1, 2, 3… 1. Check the Zero-cross setting to ensure output devices accurately switch on/off high
power devices when minimum current is flowing (when the AC power supply
crosses zero).

2. Check the Cyclic setting to generate a cyclic refresh at the end of program
execution.

3. Check the Scheduled setting to specify a time interval between interrupt refreshes.
This is in the range 0ms to 120ms.

4. Check the Immediate Refresh setting to allow program instructions to be set to
interrupt for immediate refreshing.  The Scheduled refresh setting must be set to
00ms.

Note Scheduled refreshing is not available if the PLC is set for synchronous
operation.

Address Enable
The Address Enable tab of the PLC Setup component allows addresses to be entered for selected local
racks.  Some of the options may not be applicable depending on the device type selected.  Use the
following procedure to apply settings in the Address Enable tab.
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1, 2, 3… 1. Enter an address for each required Local rack setting.  The first word can be set
between 0 and 511.  Word allocations must not overlap.  The default for the CPU
rack is zero.  If word allocations overlap, they are ignored and the address returns
to zero.  Racks selected without a designated first word is allocated words
automatically beginning from CIO 0000.

2. Enter the Group 1 and Group 2 values.  This is the first word between CIO 0000
and CIO 0999 for each SYSMAC BUS/2 Group 1 and 2 Masters.

3. Enter the Group 3 values.  These are the first word for each SYSMAC BUS/2
Group 3 Slave between CIO 0000 and CIO 0999 for each SYSMAC BUS/2 Group
1 and 2 Masters and the first word for each SYSMAC BUS/2 Slave rack between
CIO 0000 and CIO 2555.

4. Enter the RT Terminals, SIOU and IO terminals addresses as required.
Note Each group (Group 1, 2 and 3) has pre-set values assigned as a default.  Group

1 and Group 2 supports 32 and 16 IO units respectively.  Group 3 is reserved
for racks and supports eight racks, each of which supports eleven slots.

PLC Timings
The PLC Timings tab of the PLC Setup component allows cycle, interrupt and event times to be set.  Use
the following procedure to apply settings in the PLC Timings tab.

1, 2, 3… 1. Check the Watch Cycle Time setting and set the watch cycle time if enabled for the
PLC; the default is 1000ms.

2. Check the Power Off Interrupt setting, and set if enabled for the PLC; the default
is 0ms.

3. Set the Cycle Time setting to define the time interval for cycles.
4. Set the Scheduled Interrupt Interval setting to schedule interrupts to occur at

regular intervals; either every 10ms or a specific value can be set.

Hold
The Hold tab of the PLC Setup component allows the Hold area of the PLC’s Work Area memory to be
defined.  Use the following procedure to apply settings in the Hold tab.

1, 2, 3… 1. Check the Enable Hold Area setting to enable the Hold area and select its Start and
End Address settings.

2. Check the required racks from the CPU field.
3. Check the required Sysbus/2 remote master from the Sysbus/2 Remote Master field.
4. Check the required Sysbus remote master from the Sysbus Remote Master field.



OMRON CHAPTER 4 – PLC Setup Component

Revision 1.6 Page 42

C-Series PLC Settings
The following paragraphs describe the features of the PLC Setup component associated with C-series
PLCs.  Refer to Chapter 4 - PC to PLC Communications for details of transferring PLC setup information
to and from the PLC.

The common Set Default option resets PLC Setup component values to the default settings.

PLC Startup
The PLC Startup tab of the PLC Setup component allows certain PLC settings to be made which always
takes effect on startup (until they are explicitly altered).  Use the following procedure to apply settings
in the PLC Startup tab.

Mode
This option selects the default PLC operation mode when the PLC is powered on.

1, 2, 3… 1. Program – Select this for online programming when the PLC is powered on.
2. Monitor – Select this to start monitoring the running program when the PLC is

powered on.
3. Run – Select this to run the PLC’s program when the PLC is powered on.
4. Pre-Powerdown mode – In this mode the PLC uses the operating mode last used

before the power was turned off.
5. Use Programming Console – This is the default setting that allows you to select the

operating mode when online.

SIOU
The SIOU Area DM settings are highly PLC specific and are dependent upon PLC selected and the SIOU
mode.  Refer to the online help for detailed information.

IOM
This option specifies that the status of the IOM hold bit is to be reset to OFF (ticked) or maintained when
power is next  turned on.

Forced Status
This option specifies that the status of the forced status hold bit is to be reset to OFF (ticked) or
maintained when power is next  turned on.

Console Language
Select the Console language to either English or Japanese as appropriate (CPM1/1A only).

Expansion Instructions
Set to either Default or User Settings.  This option is only available for SRM1, CPM2* PLCs.
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CompoBus/S Devices (CPM2*-S*)
Select the Maximum number of CompoBus and S Devices to either 16 or 32.

Communications Mode (CPM2*-S*)
Sets the communications mode to either High-Speed or Long-distance.

Memory Error on Capacitor Failure
Select this option if a memory error on capacitor failure is to be recorded.

Cycle Time
The Cycle Time tab of the PLC Setup component allows the total cycle time to be for the CPU unit to be
defined.  This period is the time taken to complete monitoring, program execution and IO port servicing.
Use the following procedure to apply settings in the Cycle Time tab.

1, 2, 3… 1. Cycle Monitor Time setting.  This option sets the time allowed for the CPU unit to
cycle through the type of operations indicated above.  If it is exceeded, an error is
generated and the CPU unit is stopped.

2. Cycle Time setting.  Use this option to define a minimum cycle time by selecting
a time period in the range 1 to 9,999ms.  The default is Variable (with the CPU
calculating the cycle time in each cycle).

3. Servicing Time setting.  This option allows the percentage of the defined cycle time
which can be used to service a port to be set.  It can be set for the Peripheral Port,
RS232C Port, Comms Port A and Comms Port B.

Note The Cycle Time setting is ignored if the Cycle Monitor Time setting is longer
and vice versa (provided a minimum time has been defined).  The CPU unit
waits until the longer of the two time periods has elapsed before starting the
next cycle.

Interrupt/Refresh
The Interrupt/Refresh tab of the PLC Setup component allows certain PLCs to interrupt the main
program by input and scheduled interrupts in order to call a subroutine.  Use the following procedure to
apply settings in the Interrupt/Refresh tab.

1, 2, 3… 1. Interrupt Responce - Set the interrupt mode to High Speed to interrupt immediately
or to Normal to wait for the current process to complete.

2. SIOU Refresh setting - This option must be set to Disable Refresh when the
Interrupt Response setting is set to High Speed (if the Disable Refresh setting has
been set and the Interrupt Response is set to Normal, the Disable Refresh setting
is ignored).

3. Schedule Interrupt Unit setting - These are interrupts for which you can select
regular intervals of either a fixed 10ms duration or Set in increments of 1ms.
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4. SIOU Cyclic Refresh setting - Set the SIOU Cyclic Refresh setting if required.  An
SIOU Cyclic Refresh Unit(s) must be specified if an SIOU refresh setting has been
made.

The CQM1 PLCs support input and scheduled interrupts to stop the main program to run a subroutine.

The following Interrupt/Refresh options are available with the CQM1H.

5. Interrupt Enable – This option allows you to set the various IR value interrupts to
either: Normal (default), Interrupt or Quick.

6. Input Constant  - This option allows you to set the input constant of IR000 Bits.
Select the value in milliseconds as appropriate.

7. Pulse Output 0/1 Unit – Set the output pulse 0 and 1 to either Relative or Absolute.

Port Settings
The Peripheral Port, Comms Board A, Comms Board B and Host Link Port tabs of the PLC Setup
component defines the settings for the connection between the PC and PLC.  The default settings may
be used or an alternative communications protocol defined.  Use the following procedure to apply
settings.

1, 2, 3… 1. The Port Settings are set to 9600 bps, 1 start bit, 7-bit data, 2 stop bits and Even
parity.  Customised port settings can be entered by deselecting the Default setting.
The Mode setting can be set to one of the following connection types:
♦  PC.
♦  Hostlink 1 to n.  Multiple PLC RS422/485 connections to the PC.
♦  RS232C.  Single PLC RS232 connection to a printer or from a reader.
♦  1-to-1 Link Slave.  Sets PLC as slave in an RS232 PLC to PLC connection.
♦  1-to-1 Link Master.  Sets PLC as master in an RS232 PLC to PLC connection.
♦  NT Link 1:1.  For using NT link commands in an RS232 PLC to PT

(Programmable Terminal) connection.
♦  NT Link 1:n.   For using NT link commands in an PLC to RS422/485 multi-PT

connection.
♦  Protocol Macro 1:1.  Single PLC RS232 to device connection.
♦  Protocol Macro 1:n.  PLC to RS422/485 multi-device connections.

2. Select the CTS Control setting to enable use of the CTS line on the PLC.
3. Set the Unit Number setting for the selected PLC.
4. Set the Delay setting; a pre-set transmission delay in the range 0000 to 9999 (for

BCD this is in 10ms units).
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The following entries cannot be amended:

♦  Link Words.  These word addresses are fixed at LR00 to LR63 (or bit addresses from LR0000 to
LR6315).

♦  Start Code and End Code.  The message start and end codes.
♦  NT Link Max.

Error Settings
The Error Settings tab of the PLC Setup component defaults to the detection and reporting of long cycle
times, interrupt errors and low battery condition.  Use the following procedure to apply settings in the
Error Settings tab.

1, 2, 3… 1. Cycle Time - Check the Do not detect long cycles option to stop detection and
reporting of long cycles.

2. Styles - Check the Do not store records option if records are not to be stored.
3. Battery - Check the Do not detect low battery option if low battery condition is not

to be reported on.

High Speed Counters
The CQM1H-CTB41 high-speed counter board is an Inner Board applicable to units CPU51 and CPU61.
A maximum of two boards can be mounted simultaneously in slots 1 & 2 of the PLC.   The high-speed
counter board counts high-speed pulses from 50 to 500kHz entering through ports 1 to 4.  It performs
tasks according to the number of pulses counted.

When the present value of the high-speed counter matches a specified target value or lies within a
specified range, the bit pattern specified in the comparison table is stored in internal output bits and
external output bits.  A bit pattern can be set for each comparison result and the external output bits can
be output through an external output terminal.

Up to four external outputs can be produced when either the target value is matched or a range
comparison condition is satisfied.  The high-speed counter board does not provide high-speed counter
interrupts, it simply compares the present value to target values or comparison ranges and produces
internal and external bit outputs.

CPM1/CPM1A PLCs have a high-speed counter function that can be used in incrementing mode or
up/down mode.  The high-speed counter can be combined with input interrupts to perform target value
control or zone comparison control that is not affected by the PLCs cycle time.   High-speed counter
signals can be input to CPU bits 00000 through 00002.  In incrementing mode, input 00001 can be used
as a regular input.

High Speed Counter/Synchronised Pulse Control
Select the appropriate option to determine the parameters of the high speed counter.  If the option ‘Don’t
use either function’ is selected the counter is disabled and the Counter Reset and Counter Mode option
are disabled.
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Counter Reset
Select the counter reset mode of operation, either Z phase and software reset or Software reset only.

Counter Mode
Select the appropriate opion to determine the counters mode of operation.

Device Net
I/O Link Refresh Area
Note:   This tab is only available for the CPM2*-S* PLC.

1, 2, 3… 1. Standard - Select this button to set the standard/default settings for the I/O Refresh
Area.

2. Custom - Select this button to make your own settings.
3. Write:  These setting are the same as Read, but without the option of selecting the

'AR' memory area.
♦  Area - This option defaults to IR area 1, but can be set to IR area 2, DM area,

LR area or HR area.
♦  Address - This is the beginning address number.
♦  Size - The default is 0.  However, if the size is 0 for Write, then the size for

Read must be 1, or vice versa.  Any custom setting's maximum value is
determined by what the Area and Address values before it were set to.  For
example, if IR area 1 is selected, and the maximum address is specified (in this
case max = 49), then the maximum size is 1.  (The size value is specified in
Words).

4. Read:  These setting are the same as Write, but with the additional option of being
able to selecting the 'AR' memory area for reading.
♦  Area - This option defaults to IR area 1, but can be set to IR area 2, DM area,

LR area or HR area.
♦  Address - This is the beginning address number.
♦  Size - The default is 0.  However, if the size is 0 for Write, then the size for

Read must be 1, or vice versa.  Any custom setting's maximum value is
determined by what the Area and Address values before it were set to.  For
example, if IR area 1 is selected, and the maximum address is specified (in this
case max = 49), then the maximum size is 1.  (The size value is specified in
Words).
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PLC Status
These options determine the status of the PLC.

Append PLC Status on top of IN data - Select this button to Append PLC Status on top of IN data, or
choose 'Do not append PLC Status'.

Do not append PLC Status - Select this button to not append PLC Status on top of IN data, or choose
'Append PLC Status on top of IN data'.

PC to PLC Communications
The PLC Setup component permits the transferring of data to and from the PLC and allows comparisons
to be made between data stored on the PC and the PLC.

Uploading PLC Settings
The Transfer from PLC option loads the settings from the PLC into the PLC Setup component.  Use the
following procedure to upload PLC settings.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Setup component.
2. Select Transfer from PLC from the Options menu.  A confirmatory dialogue is

displayed.
The PLC Setup component is refreshed with the details from the PLC.

Downloading PLC Settings
The Transfer to PLC option loads the settings to the PLC.  Use the following procedure to download an
IO Table.

1, 2, 3… 1. Ensure the PLC is online before activating the PLC Setup component.
2. Select Transfer to PLC from the Options menu.  A confirmatory dialogue is

displayed.

Comparing PLC Settings
The Verify option compares the settings on the PLC with those on the PLC.  This option is helpful to
confirm that a table that has been set up in CX-Server and has been downloaded to the PLC, agrees with
how the hardware is set up.  Use the following procedure to compare PLC settings.

1, 2, 3… 1. Ensure the PLC is online before activating the IO Table component.
2. Select Verify from the Options menu.

Any differences (if any) are displayed in the PLC Setup component.
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CHAPTER 5
Data Trace/Time Chart Monitor Component

This chapter describes the Data Trace/Time Chart Monitor component and its ability to display either the
PLCs uploaded data trace buffer or monitored data obtained from the PLC’s memory areas during
program execution.

Data held in a PLC’s memory areas can be monitored and traced during program execution.  When
displayed, this information provides a valuable tool for analysing the program’s performance.

The Data Trace/Time Chart Monitor component has two separate modes of operation:

♦  Data Trace.  The PLC can be configured to trace a number of channels and bits and can sample these
when a trigger condition is activated.  When the PLC trace buffer is full or the user stops the trace,
the trace buffer can be uploaded and viewed – the trace however, is complete.  Values do not change
on the screen, all sampling is achieved in the PLC and displayed when finished.

♦  Time Chart Monitor.  A number of channels and bits can be configured and monitored online.  The
changing values are displayed in the monitoring view as either a trend graph or histogram.  A trigger
condition can also be set which resets the sampled amount of data.  Monitoring continues until
stopped by the user.

The status bar provides instant help, the PLC and CPU type, the current operating mode of the PLC and
the status of the Data Trace/Time Chart Monitor component.

The Toolbar and status bar can both be turned on or off.  Select Status Bar from the View menu to control
the display of the status bar.  Select Toolbar from the View menu to control the display of the Data
Trace/Time Chart Monitor toolbar.
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The Data Trace/Time Chart Monitor component can be forced to stay as the top window by selecting the
Always on top option from the Options menu.

For moving, resizing, maximising, minimising and closing windows, refer to Microsoft Windows online
help.

Access to the Data Trace/Time Chart Monitor dialogue is from the invoking application.

To close the Data Trace/Time Chart Monitor dialogue, select the Close button in the title bar.

Sampling Ranges
The following paragraphs discuss sampling ranges specific to PLC series.

CS1-series PLC Sampling Range
The CS1-series PLC can trace a maximum of 31 bits and 6 words and performs data tracing using one
of the following methods:

♦  Setting a timer interval.  The trace can be performed in increments of 5ms during a 5-2550ms cycle.
To sample data only once each cycle, set the interval to 0ms.

♦  Including the TRSM (170) instruction in the PLC’s program.  This instruction identifies the points
in program execution where specified data is to be stored in Trace Memory.  The timer interval must
be set to ‘TRSM’.

Note The buffer for Data Trace is 4K words.

CV-series PLC Sampling Range
The CV-series PLC can trace a maximum of 12 bits and 3 words and performs data tracing using one of
the following methods:

♦  Setting a timer interval.  The trace can be performed in increments of 5ms during a 5-2550ms cycle.
♦  Including the TRSM(170) instruction in the PLC’s program.  This instruction identifies the points

in program execution where specified data is to be stored in Trace Memory.  The timer interval must
be set to ‘TRSM’.

C-series PLC Sampling Range
The C-series PLC can trace a maximum of 12 bits and 3 words and performs data tracing using one of
the following methods:

♦  Setting a timer interval.  A Data Trace can be performed at regular, independent intervals by setting
a timer interval from the peripheral device.

♦  Including the TRSM(45) instruction in the PLC’s program.  This instruction identifies the points in
program execution where specified data is to be stored in Trace Memory.

Note Data Tracing cannot be performed from a Programming Console.
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Setting Monitoring Conditions
The Data Trace or Time Chart Monitor must be activated before the settings can be configured.  To select
Data Trace or Time Chart Monitoring mode, select the Mode option from the Operation menu followed
by either Data Trace or Time Chart Monitor.

Note The mode of the Data Trace/Time Chart monitor component is identified prior
to activation from the invoking application.

The Time Chart Monitor/Data Trace Configuration dialogue allows the conditions for the Data Trace or
Time Chart Monitor to be set, i.e.  specifying the data to be monitored, the intervals at which this is to
occur and the trigger conditions.

Use the following procedure to set conditions for the Data Trace or Time Chart Monitor modes.

1, 2, 3… 1. Select the Configure Trace/Time Chart button from the toolbar.
2. Set the trigger condition that causes the data trace to start by selecting a

Symbol/Address and Value on the Trigger tab.  Use the Browse pushbutton to
insert a known symbol from the invoking application.  If a bit address is selected,
the trigger is based on a falling or rising edge as opposed to a particular value for
a word address: the Value field changes to the Edge field.

3. For Time Chart Monitor only, establish the sampling time and Buffer Size on the
Sampling tab.

4. Apply a delay value in the Delay field.  A negative value in this field advances the
start of the trace before the trigger condition by the supplied interval value.  A
positive value in this field delays the trace after the trigger condition by the
supplied value in sampling.

5. Select the Word Addresses field on the Word Addresses tab and/or Bit Addresses
on the Bit Addresses tab) to be monitored.

6. Once all conditions have been set as required, click the OK pushbutton.  Select the
Cancel pushbutton to abort the configuration operation.
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Use the following procedure to select the Word addresses or Bit addresses.  It is possible to set only word
addresses, bit addresses, or a mix of both.

1, 2, 3… 1. Select a free area in the Address or Symbol columns with the right-mouse button
and click New.  The Address Selection dialogue is displayed.

2. Insert an address in the Address/Symbol field, or select the Browse pushbutton to
locate a symbol from the invoking application.

3. Click the OK pushbutton in the Address Selection dialogue to accept the settings
or select the Cancel pushbutton to abort the operation.  The address or symbol is
displayed in the Data Trace Configuration dialogue.  Multiple addresses or
symbols can be applied.

4. To delete an existing address or symbol, select an address or symbol with the right-
mouse button and click Delete.

When in the Data Trace mode of operation, the data trace configuration in the PLC can be uploaded and
viewed/edited for re-use.  Select the Upload pushbutton from the Data Trace Configuration dialogue.

Managing the Data Trace/Time Chart Monitor
Use the following functions to manage the Data Trace or Time Chart Monitor.

Select the Execute button from the toolbar to execute a data trace/time chart monitor.

Select the Trigger button from the toolbar to set the trigger condition so that execution
will end normally.
Select the Stop button from the toolbar to stop a data trace/time chart monitor.

Select the Read button from the toolbar to upload the data trace.  This may take a few
moments; the status of the Read function can be verified by the information supplied
in the status bar.  The Read button is not used for the Time Chart Monitor mode of
operation.
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Saving Data Trace Settings
Data Trace settings can be stored on file together with the results of the Data Trace via a standard File
Save dialogue.  Use the following procedure to save Data Trace settings.

1, 2, 3… 1. Select the Save button from the toolbar.  The Save dialogue is displayed.
2. A standard File Save dialogue is displayed.  Enter a file name in the File name field

and select the Save pushbutton.  Data Trace files have a .CDT extension.

Retrieving Data Trace/Time Monitor Settings
Data Traces can be stored on file and retrieved for later analysis.  Settings may be retrieved from a
project from an invoking application.  Select the Open option from the File menu.  A standard open
window is displayed.

Data Trace/Time Chart Monitoring component files can be retrieved via a standard File Open dialogue.
Use the following procedure to open a Data Trace/Time Chart Monitoring component file.

1, 2, 3… 1. Select the Open File button from the toolbar to open a Data Trace file.
2. A standard File Open dialogue is displayed.  Select a file from the Open dialogue,

followed by the Open pushbutton.  PLC Memory files have a .CDT extension.
Note It is possible to open a file type that is not applicable to the current mode, e.g.

opening a Data Trace file when in Time Chart Mode.
To close a currently open file, select the Close button from the file’s title bar.  Recently
opened files can be directly selected for opening via the File menu.
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Displaying a Data Trace/Time Chart
Once uploaded, the Data Trace/Time Chart Monitor component is populated with the required details.

The top graph illustrates the word addresses or symbols.  The bottom graph illustrates the bit addresses
or symbols.  Each word address is colour coded.  The word and bit addresses are listed in the left pane;
the splitter bar can be moved by placing the mouse cursor over the splitter bar and dragging it to its new
position to show more or less of the displayed numbers.

The slider position, used to analyse the data returned by the data trace, can be moved
by placing the mouse cursor over the graph slider and dragging it to its new position.
Both sliders can be moved together by selecting Synchronise Cursors from the View
menu.  When moving the slider, it snaps to the sampled intervals.  Moving and holding
the slider left and right scrolls the view window left and right
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The Data Trace/Time Chart Monitor component permits the zooming and scaling of the Data Trace/Time
Chart view.  Use the following procedure to zoom and scale the Data Trace/Time Chart view.

Select the Zoom In button from the toolbar to zoom in on the word graph.

Select the Zoom Out button from the toolbar to zoom out from the word graph.

Select the Restore Zoom button from the toolbar to return the graph to the original
view.

Select the Scale In button from the toolbar to zoom in on a particular graph against the
vertical axis.

Select the Scale Out button from the toolbar to zoom out from a particular graph
against the vertical axis.

Select the Restore Scale button from the toolbar to return the graph to the original
scale.

This can be modified to switch between Histogram and Trend Graph when in Word Display Mode or to
switch between Outline and Block when in Bit Display Mode.  Use the following procedure to switch
display modes.

1, 2, 3… 1. Select the Word Display Mode option or the Bit Display Mode option from the
Options menu.

2. For Word Display Mode, select either Histogram or Trend Graph.
3. For Bit Display Mode, select either Block or Outline.

The Word values shown on the screen can be displayed in one of four formats:

♦  Binary.
♦  Decimal;
♦  Signed Decimal;
♦  Hexadecimal;
Use the following procedure to select a Bit value format.

1, 2, 3… 1. Select Word Value Format from the Options menu.
2. Select either Binary, Decimal, Signed Decimal or Hexadecimal.

The Bit values shown on the screen can be displayed in one of two formats:

♦  Boolean (1 or 0);
♦  Text (On or Off).
Use the following procedure to select a Bit value format.

1, 2, 3… 1. Select Bit Value Format from the Options menu.
2. Select either Boolean or Text.
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The Data Trace/Time Chart view can be toggled to display either PLC addresses or symbol names.
Select the Options menu and then Show Symbol Names.  If a symbol name is not available then the PLC
address is shown.

The colours associated with the Data Trace/Time Chart view can be customised.  Use the following
procedure to change the colours on the Data Trace/Time Chart view.

1, 2, 3… 1. Select Colours from the Options menu.  The Trace Colour Selection dialogue is
displayed.

2. Select a Change pushbutton associated with a colour to be applied to a Word or
Bit address.  A standard Microsoft Windows Colour dialogue is displayed.

3. Select a colour from the Colour dialogue and click the OK pushbutton.  Select the
Cancel pushbutton from the Colour dialogue to abort the operation.

4. If required, Select a Change pushbutton for another colour and repeat step 3.
5. Select the Apply pushbutton from the Trace Colour Selection dialogue to apply the

change colour settings.  Select the OK pushbutton to apply the change colour
settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

The display of the Data Trace or Time Chart Monitor can be further refined by displaying a grid over the
window.  Select Grid from the Options menu to control the display of the grid.

Any symbol names inherited from the invoking application can be displayed on Data Trace or Time
Chart Monitor by selecting Show Symbol Names from the Options menu.

SYSWIN Data Trace and Time Chart Monitor Files
SYSWIN 3.x Data Trace Files (*.SDT) and Time Chart monitoring files (*.STC) can be opened directly
into CX-Server.  Use the following procedure to import these files:

1, 2, 3… 1. Select the Open button from the toolbar.  The Open dialogue is displayed.
2. Select an alternative file type from the Files of Type field, either SYSWIN version

3 Data Trace Files (.SDT) or SYSWIN version 3 Time Chart Monitor Files (.SDC).
3. Select a file to open.
4. Select the Open pushbutton to import the file.  Select the Cancel pushbutton to

abort the operation.
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CHAPTER 6
PLC Error Component

This chapter describes the PLC Error component and its ability to display and clear PLC errors, the PLC
Error Log and messages.

The PLC Error component is only available when the PLC is online.

The PLC Error component provides a view of current errors occurring in the PLC’s CPU and allows them
to be cleared when the cause of the PLC error has been removed (providing the PLC is in the correct
mode).  Errors occurring are also written to the PLC Error Log and displayed in the PLC Error
component automatically although, if set to Manual Refresh, the error history is only updated when the
Refresh button is selected.

Messages are displayed when a user-defined MSG instruction in the ladder program is encountered; these
messages may have been defined as part of an error trap or to provide more general information.
Messages may also be generated by the system in certain circumstances.

When a number of errors have occurred on the PLC, the most serious error is displayed automatically.
For detailed information concerning a PLC error, refer to the relevant PLC manual.

The status bar displays the connected device and PLC mode and the PLC Clock (if one is present and
clock monitoring has been enabled from the Options menu).

♦  The Error Log is always available for CV and CS1-series PLCs but can be selectively enabled or
disabled for C-series PLCs.

The PLC Error component can be forced to stay as the top window by selecting the Settings option from
the Options menu and checking the Always on Top setting on the General tab.

Access to the PLC Error component is from the invoking application.  If a serious error has occurred, the
PLC Error component is displayed automatically.

To close the PLC Errors dialogue, select the Close button in the title bar.
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Errors
The Errors tab of the PLC Error component displays the current error status of the PLC, when an error
is detected in the PLC it is shown with the item identifier, code position, error status level and error
details.  The icon next to the item number indicates the type of error detected and reflects the error status
in the Status column.

Errors may be cleared but this is dependent upon removal of the cause of the error in the PLC and the
PLC’s operating mode.

When the PLC is in Program Mode, all errors can be cleared; when in Monitor mode, only the last error
can be cleared.  It is not always possible to clear an error when the PLC is in Run mode; in this instance,
a dialogue is displayed which allows an attempt to be made at clearing the error.  Providing the cause of
the error has been rectified, the error can be cleared, although the PLC mode may need to be switched
to achieve this.

Use the following procedure to clear errors.

1, 2, 3… 1. Select the Errors tab in the PLC Error component.
2. Select the Clear All pushbutton.

There are three types of errors that can be recorded.

Fatal error:  Program execution is halted and the PLC error indicator is constantly
illuminated.

Warning error (non-fatal):  The PLC error indicator flashes.

No errors:  PLC is operating normally.

Error Log
The Error Log tab of the PLC Error component displays the error history of the associated PLC including
entry number, date and time of occurrence (if date and time stamping is supported by the PLC), code
position and error details.  The icon shown against the Entry number indicates the error status (unlike the
Errors tab, there is no Status column).

Use the following procedure to clear the Error Log.

1, 2, 3… 1. Select the Error Log tab in the PLC Error component.
2. Select the Clear All pushbutton.

Note The Error Log cannot be cleared in Run mode.
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There are three types of Error Log entries recorded.

Fatal Error Log entry.  Program execution is halted by this error occurrence.

Warning Error Log (non-fatal) entry.

No Error Log entries.

The maximum number of Error Log entries allowed by the PLC is displayed beneath the Error Log.

Messages
The Messages tab of the PLC Error component displays the messages set by a ladder program.  These
are user-defined messages which have been inserted into the PLC program, they do not have to be error
messages.  Messages can either be selectively cleared or all cleared at the same time.

Use the following procedure to clear a message.

1, 2, 3… 1. Select the Messages tab in the PLC Error component.
2. Highlight the message to be cleared and select the Clear pushbutton.

Alternatively, select the Clear All pushbutton or remove a selection by keeping the
[SHIFT] key depressed when highlighting messages.

Error Log Settings
The Error Log Options dialogue allows the Error Log to be activated, time monitoring to be set and
automatic update of the Error Log to be performed.  When the component is initially opened, it activates
settings saved previously.

Time Monitoring
Some PLC types support a clock which can also be monitored.  Use the following procedure to invoke
time monitoring against the PLC Clock.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the Clock tab.
3. Check the Monitor the PLC Clock setting.  The current clock time from the PLC

is then displayed in the status bar so the user can verify the current time against the
error log entries.

4. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to
apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Note Where PLCs do not support a clock, ‘No Clock’ is displayed in the Status Bar
and the information on the Clock tab is greyed-out.
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Manually Updating the Error Log
Manual refresh of the Error Log is useful if it is desired to prevent other users from clearing the displayed
error history.  Use the following procedure to enable manual refresh of the error log.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the Error Log tab.
3. Check the Update Error Log Entries Automatically setting.  If not checked, a

Refresh pushbutton is displayed next to the Clear pushbutton to manually refresh
the Error Log content (in the PLC Error component).

4. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to
apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Use the following procedure to refresh the Error Log automatically.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the Error Log tab.
3. Deselect the Update Error Log Entries Automatically setting.
4. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to

apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Customising the Layout of the Error Log
Some PLCs do not support time stamps, date stamps or clocks.  The layout of the Error Log can be
changed to remove the time and date columns as necessary and make the display more relevant to the
PLC.  Use the following procedure to customise the layout of the PLC Error component.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the Error Log tab.
3. Error Log time and date information can be hidden from view by checking the Hide

Error Log Time Column and the Hide Error Log Date Column settings.
4. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to

apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Enabling and Disabling the Error Log
For C-series PLCs only, the error log can be enabled and disabled as required.  Use the following
procedure to enable or disable the error log.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the Error Log tab.
3. Check the Error Log Enabled setting to manually monitor errors.
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4. Deselect the Error Log Enabled setting to stop monitoring errors
5. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to

apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Overwriting Error Log Entries
For C-series PLCs only, the overwrite mode depends upon the CPU type.  It may either overwrite the last
entry in the Error Log each time or cycle through the Error Log and start to overwrite it from the
beginning.  Overwriting is only performed when the maximum number of records in the Error Log has
been reached.  Again this is PLC dependent.

1, 2, 3… 1. Select the Settings option from the Options menu
2. Select the Error Log tab.
3. Check the Error Log Overwrite Mode setting to allow the PLC to overwrite Error

Log entries.
4. Select the Apply pushbutton to activate the settings.  Select the OK pushbutton to

apply the settings and close the dialogue.  Select the Cancel pushbutton to abort the
operation.

Displaying the Error Log
The PLC Error component can be set so that it is only activated when an error in the PLC actually occurs
(providing it is already open); for example, if the PLC Error component has been minimised it
automatically returns to full size as the top window when an error is generated in the PLC.

1, 2, 3… 1. Select the Settings option from the Options menu.
2. Select the General tab.
3. Check the Activate only when Error detected setting.
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CHAPTER 7
Memory Card Component

This chapter describes the Memory Card component available to CV-series PLCs and CS1-series PLCs
and its ability to store and transfer data.  File storage is achieved by a File memory card for a CV-series
PLC and a Compact Flash or EM memory configured as ‘file memory’ for a CS1-series PLC.
Information can be transferred from the PLC to the memory card or from the memory card to the PLC.
A saved program can be transferred from the memory card to the program area during operation.
Extended PLC setup and program files can be automatically transferred at PLC startup if they are named
autoexec.std and autoexec.obj respectively.
It is possible to run the Memory Card component whilst the PLC is offline.
The Memory Card component can be forced to be displayed in focus by selecting the Always on top
option from the Options menu.
For moving, resizing, maximising, minimising and closing windows, refer to Microsoft Windows online
help for further information.
Access to the Memory Card component is from the invoking application.

Memory Card Operation
The appearance and behaviour of the Memory Card component is similar to Microsoft Windows
Explorer.  Differences between the Microsoft Windows Explorer exist within the Memory Card
component when certain functions are accessed.  Refer to Microsoft Windows Explorer help, part of the
standard Microsoft Windows documentation for options and functions not described in this chapter but
available within the Memory Card component.

Caution Memory cards must be formatted prior to use.
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The status bar provides instant help, the PLC and CPU type, and quick reference information describing
how much space is available on a particular device for the selection in the left pane.

In addition to the devices and folders supported by the PC, the Memory Card component also displays
the connected PLC device.  In terms of the device/folder structure of Microsoft Windows Explorer, the
PLC contains a Memory Card folder if available (i.e.  if fitted), Program Area, IO Memory Area and
Parameter Area.  For a CS1-series PLC, a Memory Card folder can contain subfolders.

Note In order to view or execute on the PLC a file from the memory card, the file
must be copied back to the PC folder.  Double clicking on the files in the list
has no action associated with it since files cannot be opened across the
communications connected to the PLC.

A memory card can be displayed for each connected PLC and allows their contents to be moved between
destinations.  The operation is aborted if there is not enough space.  Snapshots of PLC Memory areas can
be taken by transferring information from the Program Area, IO Memory Area or Parameter area to the
Memory Card folder.

For CV-series PLCs memory cards can be either RAM, EPROM, or EEPROM.  EPROM and EEPROM
cards can only be written to using the Memory Card Writer.

For CS1-series PLCs memory cards can be either Compact Flash disk or configured EM memory.

There are three ways in which memory cards can be accessed:

♦  They can be read from/written to during an online operation using programming software;
♦  By instruction via a program in the PLC;
♦  Using the Memory Card component;
Refer to the associated PLC manual for further information.

The Memory Card component automatically detects whether the memory card is in place or not.  An
error message is displayed if it is detected that the memory card has been removed whilst the Memory
Card component is active.

Files held on the memory card can be compared with data in the PLC.  File formats can be one of four
types:

♦  .LDP indicates partial program area files;
♦  .OBJ indicates full program area files;
♦  .STD indicates PLC setup area files;
♦  .IOM indicates any other type of file.
The CS1-series PLC also supports the configuration of EM memory as file memory.  Providing the EM
Table Setting Enabled option from the Settings menu is set within the PLC Setup component whilst in
Program mode.  Refer to Chapter 4 - PLC Setup Component for further details.
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A fitted memory card on CV-series PLCs or Compact Flash card on CS1-series PLCs must be formatted
to be used as a file storage device.  Setting a CS1-series PLC as file memory in the PLC Setup component
automatically formats EM file memory for use in the Memory Card component.

Memory Card Display
The Memory Card component can be manipulated in the same manner as most Microsoft Windows
displays to control what is displayed; for example, expansion of the file storage hierarchy.

The left pane displays the content, in terms of Devices, Networks and Points.

To expand the hierarchy in the left pane, select this icon.

To collapse the hierarchy in the left pane, select this icon.
To view the content of a particular branch in the hierarchy, double-click on the item in
the left pane.
Select the Large Icons button from the toolbar to display the content of the right pane
as large icons.
Select the Small Icons button from the toolbar to display the content of the right pane
as small icons.
Select the List button from the toolbar to display the content of the right pane as a list.

Select the Details button from the toolbar to display the content of the right pane with
associated details.

Use the following procedure to copy or move information from or in the PLC Memory
component.

1, 2, 3… 1. Select an item, or items, in a window.  More than one item can be selected by
pressing Shift and selecting another item to extend the selection, or by pressing Ctrl
and selecting another item to add to the selection.

2. Select the Copy button from the toolbar to copy the item, or the Cut button from
the toolbar to move the item.

3. Select an area to move the items to, for instance copying data area values into
another data area.

4. Select the Paste button from the toolbar to paste the item.  A Paste operation can
be performed several times without copying again.

A file or label (if at top level) can be renamed.  Use the following procedure to rename memory card
data.

1, 2, 3… 1. Highlight the required document or folder.
2. Select the Rename button from the toolbar.  The document/folder name can now

accept input.  Enter the new name and press Return.
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A file or folder can be deleted.  Use the following procedure to delete a file or folder.

1, 2, 3… 1. Highlight the required document or folder.
2. Select the Delete button from the toolbar.  A Confirm Folder Delete dialogue is

displayed.
3. Select the Yes pushbutton to continue with the deletion or the No pushbutton to

abort the operation.
The Toolbar and status bar can both be turned on or off.  Select Status Bar from the View menu to control
the display of the status bar.  Select Toolbar from the View menu to control the display of the PLC
Memory toolbar.

If the display of a PLC device takes a few moments to refresh, ensure the Auto Refresh PLC View option
from the Options menu is turned off.  This then allows the PLC to be refreshed manually by selecting
Refresh from the View menu.

Extended PLC setup and program files can be transferred to the Memory Card as autoexec files so they
can be automatically transferred at PLC startup.  Select the Transfer as AutoExec Files from the Options
menu.

Memory Card Properties
Use the following procedure to view memory card properties.

1, 2, 3… 1. Highlight the required document or folder.  Multiple devices, folders and files can
be selected if required.

2. Select the Properties button from the toolbar.
3. View the details.  Some options may be amended, for instance the read-only

attribute for a file; in this instance, amend settings as appropriate.  Select the OK
pushbutton to complete the operation or the Cancel pushbutton to abort the
operation.

Transferring Data between the PLC and Memory Card
Use the following procedure to transfer data between the PLC and memory card.

1, 2, 3… 1. Select the Files on the PLC to be copied and click the right-mouse button.
2. Select Transfer To option followed by either Memory Card or EM File Area.

Possible Memory Card Errors
The following list provides a brief overview of the possible errors that could arise with the memory card
when operating in Program Mode.  Refer to the associated PLC manual for further information.

♦  The PLC Program is protected and cannot be written to;
♦  The file card does not contain enough free space to transfer the PLC data required;
♦  The source file name specified to transfer data from does not exist;
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♦  The file on device already exists;
♦  The file device is read only and cannot be written to;
♦  The file device does not exist, insert the memory card;
♦  Cannot transfer data from the file device to the PLC’s area when the PLC is in Run mode;
♦  To transfer data from the file device to the PLC’s IO area, the PLC must be in Program mode;
♦  The data cannot be transferred to the PLC as the PLC is password protected or access rights have

not been granted.
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CHAPTER 8
CX-Net Network Configuration Tool

This chapter describes the CX-Net Network Configuration tool, the procedures for establishing
communications to PLCs for direct and gateway connections. The Network Configuration Tool hosts
tools that assist in the creation and editing of local and network Routing Tables and the creation and
editing of Data Link Tables.

To successfully establish communications between CX-Server and a network PLC, the necessary PLC
has to contain a valid Routing table to allow the correct routing of packets.  The CX-Net Network
Configuration tool allows communications to PLCs with a CX-Server project and configuration of the
PLC.  The CX-Net Network Configuration tool allows the following:

♦  Hosts the Routing Table editor to provide routing table support at a network level, enabling PLCs
to act as gateways across networks;

♦  Hosts the Data Link table editor to provide Data Link table support at a network level;
♦  Setup of PLC devices and their communication units;
♦  Network diagnostics;
♦  Control of Data Link operation.

Note The availability, format and content of the facilities within the CX-Net
Network Configuration tool depend upon the device type of the PLC being
considered (C-series, CS1-series or CV-series) and the network to which that
PLC is connected (SYSMAC LINK, SYSMAC NET, Ethernet or Controller
Link).

Refer to the specific OMRON System and Operation manuals for details of the operation of the various
network units and their available settings and options.
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The status bar provides instant help, the status of the current connection and the operating mode of the
PLC.

When the CX-Net is initially loaded, the Project Devices field is empty.  Opening or creating a CX-
Server project populates the Project Devices list with all the devices in that CX-Server project.  Selecting
each device in turn causes the right-hand side of the dialogue to display a graphical representation of that
connection (either direct or through a gateway connection), together with node and network information.

Note Offline connections are shown as a red line whilst for online connections this
changes to green.  Other aspects also change when online, refer to Chapter
8 - Opening a PLC for further information.

Any operations (e.g.  network unit setup, Data Link and routing table editing) which are carried out affect
the physical connection PLC which is currently connected, not the CX-Server project PLC.

Routing Tables contain the information necessary to allow communications between different networks
including local and remote network address details; they are held in a specific area of PLC memory.
Refer to Chapter 10 - for information regarding Routing Tables.

CS1-series PLCs linked to either a Controller Link or Ethernet network also use FINS routing tables.

CV-series PLCs also have routing tables which, unlike the C-series, are not dependent upon the networks
(SYSMAC LINK, SYSMAC NET or Ethernet or Controller Link) to which they are connected.  These
tables are known as FINS routing tables.  A direct connection is known as a Local Routing Table.  A
network connection is known as a Network Routing Table.

C-series PLCs linked to a SYSMAC LINK network are unable to communicate with a different network
and therefore do not have a routing table; however, C-series PLCs linked to a SYSMAC NET or
Controller Link network do have this capability and so have an associated routing table.  These tables
are known as SYSMAC NET and FINS routing tables respectively.

Data Link Tables provide a means of allowing a network of devices to share information.  The manner
in which this information is distributed in a system depends upon the network to which the table relates.
The SYSMAC NET network contains one node acting as the ‘parent’ node or Data Link server
(containing the Data Link table), unlike the SYSMAC LINK network where a copy of the Data Link
table is sent to all nodes on that network.  The Controller Link network operates in a similar manner to
SYSMAC LINK except that the network is split into two areas with each node being associated with one
or other of these areas.  Data is then copied to each node in the related area.  Refer to Chapter 11 - Data
Link for further information regarding Data Link Tables.

For moving, resizing, maximising, minimising and closing windows, refer to Microsoft Windows online
help for further information.

Access to the CX-Net Network Configuration tool is either from the invoking application or from the
Start pushbutton on the Microsoft Windows taskbar.

To close the CX-Net Network Configuration tool, select the Close button in the title
bar.
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CX-Net and CX-Server Projects
All device information is contained within a CX-Server project file.  Once the file has been opened, the
PLCs listed in that CX-Server project can be opened and the devices on their networks manipulated.  CX-
Server projects can be manipulated from the CX-Net Network Configuration tool.

Creating a New CX-Server Project
A new CX-Server project can be created from the CX-Net Network Configuration tool.  Use the
following procedure to create a new CX-Server project.

1, 2, 3… 1. Select New from the Project Menu.  The Create Project dialogue is displayed.
2. The CX-Server project must be saved before it can be edited.  Enter a file name in

the File name field.  An existing CX-Server project can be overwritten by selecting
a .CDM file displayed in the Create project dialogue.

3. Select the Save pushbutton to save the new project or the Cancel pushbutton to
abort the operation.  CX-Server files have a .CDM extension.

Opening an Existing CX-Server Project
CX-Server project files can be retrieved using a standard File Open dialogue.  To close a currently open
file, open a new CX-Server project or select Close from the Project menu.

Use the following procedure to open a CX-Server project file.

1, 2, 3… 1. Select the Open button from the toolbar to open a CX-Server project file.
2. A standard File Open dialogue is displayed.  Select a file from the Open dialogue,

followed by the Open pushbutton.  PLC Memory files have a .CDM extension.
A list of the most recently opened CX-Server project files is displayed in the Project menu.

Adding a Device
To add a device to a CX-Server project, select the Add Device option from the Project menu.  The Add
PLC dialogue is displayed.  The Add PLC dialogue is identical to the Change PLC dialogue.

To change a device within a CX-Server project, select the Change Device option from the Project menu.
The Change PLC dialogue is displayed.

Editing a Device List
The Device List dialogue, (see Runtime User manual) can be used to change the settings of the PLCs in
the currently opened CX-Server project, and to add new PLCs.

The CX-Server project Device List can only be edited when a device is not currently open – the option
is disabled when a connection is active.

Select the Edit Project button from the toolbar to edit a CX-Server project, or select
the Edit option from the Project menu.
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PLC Settings
The PLC menu contains options that operate on a single PLC device within the open CX-Server project,
including the setup of its units.  It also contains the options for opening and closing a PLC device.

Opening a PLC
A PLC can be opened for communications once the associated CX-Server project file has been opened.
Use the following procedure to open a PLC.

1, 2, 3… 1. Select a device from the PLC Devices list.  If required, add a device to the CX-
Server project by selecting Add Device from the Project menu and edit the CX-
Server project by selecting the Edit Project button from the toolbar.

2. Select the Open / Project Device button from the toolbar.

Note The Open option does not become available until a device name has been
selected from the Project Devices list.

It may take several seconds to establish a connection.  If a connection cannot be made with the PLC's
settings, then a message appears showing this.  In this case it may be necessary to change the PLC's
settings before trying again, or checking that the physical connection (e.g.  wiring) is possible.

For SYSMAC LINK end connections a new SYSMAC LINK menu is added allowing specific SYSMAC
LINK network operation.

For Controller Link end connections a new Controller Link menu is added allowing specific Controller
Link network operation.

When a physical connection has been made the status of the PLC in the status bar changes to Online with
the current mode of the PLC.  The connection lines change colour to green to also denote the PLC is
online.  In addition, the actual values for Node and Network are displayed, together with details of the
device actually connected (rather than what is defined in the CX-Server project for that setting).  When
a connection is made to an Ethernet network the Node box changes to a drop-down list, allowing the node
to be changed in order to connect to a new PLC.  If a node is selected but  there is nothing there, then no
information is shown.  Returning to offline operation causes a return to the original (CX-Server project)
configuration settings in the Node and Network fields.

Upon connection, certain menu options are made available, depending upon the connection type.

The current operating mode (Run) of the connected PLC is shown in the status bar of the tool – when
making a connection, or when a connection is broken, the mode indicator shows Unknown.  The indicator
shows Run, Stop or Monitor when a connection is properly completed.  CV-series PLCs also support a
Debug mode.  This mode indicator changes whenever a change is made in the operating mode of the
PLC.

Note The mode in which the PLC runs on startup is set in the PLC Setup
Component, refer to PLC Setup Component.
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Closing a PLC
The Open / Project Device button on the toolbar acts as a toggle switch.  To close a
device, simply reselect the Open / Project Device button on the toolbar (i.e.  when the
menu option shows a tick against it and the toolbar button is depressed).

When the device is closed, the details displayed in the Connection part of the CX-Net Network
Configuration tool are removed.

Configuring a PLC’s System Settings
The PLC Setup Component can be selected to define the settings which govern the
PLC’s behaviour; for example, connection mode.  Select the Configure PLC System
Settings button from the toolbar.  Refer to Chapter 4 - PLC Setup Component for
further information.  Alternatively, select PLC Setup from the PLC menu.

Scanning for PLC Connections
A serial scan can be performed which searches all PC COM ports to see if there are any currently
attached PLCs and, if found, what communication settings are being employed by those PLCs.  This
procedure is useful when the configuration of the PLCs communication settings (i.e.  baud rate) are
unknown.  Device information from the results of the scan can then be copied into the CX-Server project,
if required.  Refer to Chapter 8 - Dragging Device Information into a CX-Server Project.

When the Scan Serial Ports for PLCs dialogue is first displayed, it shows the results of the last scan to
be performed until the Refresh pushbutton has been clicked.  Use the following procedure to scan for
PLC connections.

1, 2, 3… 1. Open a CX-Server project by selecting the Open button from the toolbar or create
a new project.  If required, add a device to the CX-Server project by selecting Add
Device from the Project menu and edit the CX-Server project by selecting the Edit
Project button from the toolbar.

2. Select Scan Serial Ports for PLCs from the Project menu.  The Scan Serial Ports
for PLCs dialogue is displayed.

3. Select either individual ports or select the Select All pushbutton to scan all ports
from the Available Ports field.

4. Select either individual baud rates or select the Select All pushbutton to scan all
baud rates from the Baud Rates field.

5. Select either individual cable types or select the Select All pushbutton to scan all
cable types from the Cable types field.

6. Select the Next pushbutton; the Scan Serial Ports For PLCs dialogue starts the
scan.  The Status field indicates the current progress.  On completion, all currently
connected PLCs are listed in the Drag and Drop Device Units field.

Note If changes are made to PLC connections after a scan has been made, select the
Refresh pushbutton to update the displayed list.
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Dragging Device Information into a CX-Server Project
The scan operation described in Chapter 8 - Scanning for PLC Connections, picks up device information
from the physically connected serial port devices.  Once a scan has been performed, the Scan Serial Ports
for PLCs dialogue can remain open alongside the CX-Net Network Configuration tool.  Dragging a
device or network unit from the Drag & Drop Device Units field into the Project Device field in the CX-
Net Network Configuration tool allows this device information to be added into the CX-Server project.

Use the following procedure to utilise a convenient shortcut for entering PLC details into a CX-Server
project.

1, 2, 3… 1. Open a CX-Server project by selecting the Open button from the toolbar or create
a new project.  If required, add a device to the CX-Server project by selecting Add
Device from the Project menu and edit the CX-Server project by selecting the Edit
Project button from the toolbar.

2. Perform a scan by selecting Scan Serial Ports for PLCs from the Project menu.
3. Select the required device in the Drag and Drop Device Units field.
4. Drag the device across to the Project Devices field in the CX-Net Network

Configuration tool.

Displaying PLC Device Information
The PLC Device Information dialogue displays the selected CX-Server project PLC’s
device and connection details.  To display PLC device information, select the Display
PLC Information button from the toolbar, or select the Information command from
the PLC menu.

Setting the PLC Mode
The main window of the CX-Net Network Configuration tool shows the current operating mode of the
connected PLC.  The PLC Set Mode dialogue allows this to be changed.  The run modes available to a
PLC depend upon the PLC device type.  Use the following procedure to set the PLC Mode.

1, 2, 3… 1. Open a CX-Server project by selecting the Open button from the toolbar or create
a new project.  If required, add a device to the CX-Server project by selecting Add
Device from the Project menu and edit the CX-Server project by selecting the Edit
Project button from the toolbar.

2. Select the Open / Project Device button from the toolbar to open connections to
the device.

3. Select the Set PLC Operating Mode button from the toolbar or select the Set
Mode command from the PLc menu.

4. Click on the required Operating Mode setting.  Select the Set pushbutton.  A
confirmation dialogue appears – confirm the operation.

5. Select the Close pushbutton to remove the dialogue.
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Clearing PLC Errors
Errors, error logs and messages generated by a PLC can be examined and cleared (if
possible) via the PLC Error Component.  Select the Display PLC Error Status button
on the toolbar or, select the PLC Error Status command from the PLC menu.  Refer to
Chapter 6 - PLC Error Component for more information.

Creating an IO Table
The PLCs IO Table can also be manipulated by the CX-Net Network Configuration tool
by activating the IO Table component.  The IO Table allows Unit Setup and Software
Switch setup of SIOU units as well as IO configuration and creation.  Before editing the
PLCs IO Table it must be transferred from the PLC into the IO Table component.
Select the Configure IO Table button from the toolbar or select the I/O table Setup
commend from the PLC menu.  Refer to Chapter 3 - IO Table Component for further
details.  Use the following procedure to activate the IO Table component.

Displaying the PLC Unit Status
The Unit Status option is only available for those nodes where the end connection to the PLC is either
SYSMAC LINK, SYSMAC NET, Ethernet or Controller Link; in each instance the type of information
displayed differs but the pushbuttons available are identical.

♦  SYSMAC LINK.  Displays Communications Test, Line Status, Data Link Status, Controller Errors,
Backup Status Errors, Error Status, Error Log, Status, Error Details;

♦  SYSMAC NET.  Displays Data Link Status, Operating Status, Errors;
♦  Ethernet.  Displays General Status, Error Flags and Error Logs;
♦  Controller Link.  Displays Data Link Status, nodes, Errors and Error Logs.
The information displayed is for viewing only.  However, the Error Log can be cleared.  Use the
following procedure to display the PLC Unit Status.

1, 2, 3… 1. Open a CX-Server project by selecting the Open button from the toolbar or create
a new project.  If required, add a device to the CX-Server project by selecting Add
Device from the Project menu and edit the CX-Server project by selecting the Edit
Project button from the toolbar.

2. Select the Open/Close Project Device PLC button from the toolbar to open
connections to the device.

3. Select the Show Unit Status button from the toolbar or select Unit Status from the
PLC menu.

4. Select the Clear Log pushbutton to delete the entries in the error log.

5. Select the Close pushbutton to remove the dialogue.
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Testing the Network Connection
Once network connections have been created, the network should be tested to ensure that all nodes are
responding properly.  The following tests are available:

♦  Internode Echo-Back Test.  This test checks the condition of a number of specific network and node
address and whether communications can be established;

♦  Broadcast Nodes Test.  This test examines all nodes on the network and is available for Ethernet,
Controller Link and SYSMAC LINK only.  This test may take some time for an Ethernet network
which is not subject to the same size restrictions as Controller Link and SYSMAC LINK.  The
results show all nodes found and the PLC type if possible;

♦  Ping Node Test.  Allows echo testing of a specific TCP IP address.
Select the required test from the associated button in the toolbar, either the Echo Back
Test button, the Broadcast Test button or the Ping Test button.

Communications Unit Setup
The Configure Communications Unit button from the toolbar is used for SYSMAC
LINK, SYSMAC NET and Controller Link setup options on SIOU units for C-series
PLCs.  These options only describe settings that cannot be accessed via the IO Table
component.

For CS1-series PLCs and CV-series PLCs, the setup allows SYSMAC NET, SYSMAC LINK and
Controller Link setup.  This information is defined via the IO Table component; refer to Chapter 3 - IO
Table Component for further information.

Select a unit type from the Unit Type field.  If provided, select the Setup pushbutton to further configure
communications setup.  Select the Close pushbutton to close the dialogue.

SYSMAC LINK Settings
The SYSMAC LINK menu only appears when the end connection is the SYSMAC LINK network.  It
allows settings specific to a SYSMAC LINK network to be made.

Network Status
The SYSMAC LINK Network Status dialogue shows the nodes present on the network.  It also indicates
the controlling server node.  Use the following procedure to setup SYSMAC LINK Network Status
settings.

1, 2, 3… 1. Select the Network Status option from the SYSMAC LINK menu.
2. Select the Close pushbutton to remove the dialogue.
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Network Settings
The Network Settings dialogue allows parameter settings for a SYSMAC LINK network to be defined;
this includes the maximum number of nodes on a network, the maximum number of polling units per
communications cycle, and the maximum number of frames per communications cycle.

On entry, this dialogue displays the last parameters entered for a selected network.  Use the following
procedure to setup SYSMAC LINK Network Settings.

1, 2, 3… 1. Select the Network Setup option from the SYSMAC LINK menu.
2. Adjust the settings as required (or select the New pushbutton to return to the default

values for the network).
3. Select the Write pushbutton to download the network parameters to the SYSMAC

LINK network controller.  Note that this is only possible when the connected node
is the polling (server) node – otherwise the Write pushbutton is disabled.  The
status display indicates whether the write operation was successful.

4. Select the Close pushbutton to remove the dialogue.

Controller Link Settings
The Controller Link menu only appears when the end connection is the Controller Link network.  It
allows settings specific to a Controller Link network to be made.

Network Status
The Controller Link Network Status dialogue shows the nodes present on the network.  It also indicates
the controlling server node.  Use the following procedure to setup Controller Link Network Status
settings.

1, 2, 3… 1. Select the Network Status option from the Controller Link menu.
2. Select the Close pushbutton to remove the dialogue.

Network Settings
The Network Setup dialogue allows parameter settings for a Controller Link network to be defined; this
includes the maximum number of nodes on a network, the maximum number of polling units per
communications cycle, and the maximum number of frames per communications cycle.

On entry, this dialogue displays the last parameters entered for a selected network.  Use the following
procedure to setup Controller Link Network Setup settings.

1, 2, 3… 1. Select the Network Setup option from the Controller Link menu.
2. Adjust the settings as required (or select the New pushbutton to return to the default

values for the network).
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3. Select the Write pushbutton to download the network parameters to the SYSMAC
LINK network controller.  Note that this is only possible when the connected node
is the polling (server) node – otherwise the Write pushbutton is disabled.  The
status display indicates whether the write operation was successful.

4. Select the Close pushbutton to remove the dialogue.

Routing Tables
Routing tables allow networked PLCs to be configured so that they can communicate with each other
via gateways; across remote networks.  These tables contain the network and unit number information
required.  It is only necessary to set up routing tables if the end connection PLC is not a direct
connection, i.e.  using another PLC as a gateway connection.  The routing table is held within the PLC(s)
which acts as the gateway device.  Different types of PLC and networks have different capabilities for
routing.

For details about using routing tables refer to Chapter 11 – Routing Table Editor.

Data Link
Data Link tables allow a PLC to be configured so that it can participate in one or more automatic data
sharing schemes, over SYSMAC LINK, SYSMAC NET and Controller Link networks, without the need
for special programming.  Words of IO and DM can be set aside for use as data link words, which are
allocated to various nodes in the network.  Limits on the amount of data and number of nodes varies with
the type of network and the type of PLC.  The allocation of words to nodes is defined by two or more
Data Link tables.

Data can only be shared on a single physical network.  A gateway cannot be used to pass information
from one network to another.

SYSMAC NET data links can be configured so that both C-Series and CV-Series PLCs can share data.
However, it is a limitation that in these mixed configurations, the master must be a C-Series PLC.  There
are no such restrictions on a SYSMAC LINK or Controller Link network.

The Data Link menu includes options to setup the SYSMAC NET, SYSMAC LINK and Controller Link
Data Links.

The DataLinks Editor is used to configure SYSMAC LINK and Controller Link data links, Refer to
Chapter 10 – Data Link Editor.

A separate datalink editor is utilised for configuration of SYSMAC NET datalinks, Refer to Chapter 8
- Offline SYSMAC NET Data Link Editor  for further details.

Data Link Setup
The Data Link Setup dialogue varies in title and content according to the type of network connected to
the current PLC; however, the pushbutton functions on each dialogue are the same.
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The dialogue lists the contents of the Data Link table associated with the PLC; initially the Data Link
table displayed is empty, or set to zero, until a table has been opened or read.

SYSMAC NET Data Link Setup
The setup dialogue first needs to know whether the Data Link table is written for CV-Series or C-Series
PLC type SYSMAC NET this information is requested using the SYSMAC NET Table Type dialogue.

Use the following procedure to setup the SYSMAC NET Data Link.

1, 2, 3… 1. Select the Online Edit Data Link button from the toolbar.
2. Select a setting to indicate the type of SYSMAC NET which is used in the Data

Link.
3. Select the OK pushbutton to continue (the Data Link Setup dialogue is displayed),

or the Cancel pushbutton to abort the operation.

Opening a Table
Use the following procedure to open a table.

1, 2, 3… 1. Select the Open pushbutton to open a Data Link table from disk (alternatively
select the Read pushbutton to view the table in the PLC).

2. Select the appropriate table and select the OK pushbutton.
3. The Data Link Setup dialogue is now populated with the contents of the Data Link

file.
4. Select the Write pushbutton to transfer the table to the PLC.
5. Select the Verify pushbutton to compare the contents in the dialogue with those

in the PLC.
Note Data Link tables have a ‘.SL3’ (SYSMAC LINK), ‘.SN3’  (SYSMAC NET)

or ‘.CL3’ (Controller Link) filename extension.

Editing a Table
To edit the displayed Data Link table, click on the Edit pushbutton; the associated offline table editor
is used, refer to Chapter 10 – for SYSMAC LINK / Controller Link Data Link Editor and Chapter 8 -
Offline SYSMAC NET Data Link Editor  for further details.

Updating Table Status
After an editing session using the offline editor (i.e. after pressing the Edit pushbutton), the dialogue can
be updated using the Update pushbutton.

Saving a Table
The Save As dialogue allows the displayed table to be saved to disk with a given name.  Use the
following procedure to save a table.



OMRON CHAPTER 8 – CX-Net Network Configuration Tool

Revision 1.6 Page 80

1, 2, 3… 1. Click on the Save As pushbutton in the Data Link Setup dialogue.  The Save As
dialogue is displayed.

2. Enter the new file name for the data link table (ensure that the file type is correct)
in the File name field.

3. Either select the Save pushbutton to save the new file and return to the previous
dialogue or select the Cancel to abort the operation.

Deleting a Table in a PLC
The current Data Link table held in the PLC can be deleted by selecting the Delete pushbutton.

Viewing Table Information
The Table Information dialogue displays basic information relating to the selected Data Link table
indicating the author, associated network and file name.  The information displayed on this screen cannot
be edited whilst online.  Use the following procedure to view table information.

1, 2, 3… 1. Select the Info pushbutton on the Data Link Setup dialogue.
2. Select the Close pushbutton to remove the dialogue from the screen.  The Data

Link Table dialogue is redisplayed.
Select the New pushbutton in the dialogue to clear the dialogue information.

Offline SYSMAC NET Data Link Editor
The SYSMAC NET Data Link Table Editor is available to both CV-series and C-series PLCs linked to
a SYSMAC NET unit.

The status bar provides instant help.
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Access to the SYSMAC NET Data Link Editor dialogue is achieved in a number of
ways:
•  From the CX-Net Network Configuration tool.  Select Editor from the Data Link

menu.  The Select New File type dialogue is displayed.  Select the SYSMAC NET
file type from the File Type field and select the OK pushbutton.

•  From the Data Link Setup dialogue.  Select the Edit pushbutton.
•  From the Start pushbutton in the Microsoft Windows taskbar.  The Select New File

type dialogue is displayed.  Select the SYSMAC NET file type from the File Type
field and select the OK pushbutton.

Creating and Editing a SYSMAC NET Data Link Table Item
Use the following procedure to creates SYSMAC NET Data Link Table Item.

1, 2, 3… 1. Select the New button from the toolbar in the SYSMAC NET Data Link Table
Editor dialogue.

2. Select the Insert Table Item option from the Table menu.  Address information can
also be edited by double-clicking on the required node.

The Add SYSMAC NET Data Link Table Item dialogue allows the memory area at the node to be
configured.  Use the following procedure to configure the node.

1, 2, 3… 1. Enter the node number in the Node No field; this must be in the range 1 to 126.
/verify where

2. Enter the memory size; this must be in the range 0 to 127.
3. Select the OK pushbutton to redisplay the Data Link Table Editor.

Note The above example applies to CV-Series, but C-Series operates in exactly the
same manner although the information displayed differs slightly.

To edit a Data Link table, double-click on a table item or select the Edit Table Item
button from the toolbar; the Edit Data Link Table dialogue is displayed (this is identical
to the Add Data Link Table Item dialogue shown above).

Deleting an Item from the SYSMAC NET Data Link Table
Use the following procedure to delete an item from the SYSMAC NET Data Link Table.

1, 2, 3… 1. Select the node to delete an item and select the Delete Item button from the
toolbar.

2. A confirmation dialogue is displayed.  Select the Yes pushbutton to confirm the
deletion of the item.  Select the No pushbutton to abort the operation.

Opening an Existing SYSMAC NET Data Link Table
Use the following procedure to open an existing SYSMAC NET Data Link Table.
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1, 2, 3… 1. To open a table from disk, select the Open button from the toolbar in the Data
Link Editor dialogue.  A standard File Open dialogue is displayed.

2. Select a file from the Open dialogue and select the Open pushbutton.  The
SYSMAC NET Data Link Table Editor is automatically populated with the
contents of the selected file.

Note SYSMAC NET Data Link table files are identified by the ‘.SM3’ extension.

Logical Error Checking
The SYSMAC NET Data Link Table Check dialogue displays any errors resulting from
validation of the address details entered in the table; it is identical in appearance to the
SYSMAC LINK Data Link Table Check dialogue shown earlier and is obtained in the
same way.

Old Format Tables
Data Link tables were previously held in ‘.SNT’ and ‘.SN2’ file format.  The File Open dialogue allows
these file types to be opened in the CX-Net Network Configuration tool.  Use the following procedure
to open ‘.SNT’ and ‘.SN2’ formatted files.

1, 2, 3… 1. Select the Add (old) option from the Table menu in the SYSMAC NET Data Link
Table Editor dialogue.

2. Select a file from the Open dialogue and select the Open pushbutton.

Table Information
The Data Link Table Information dialogue allows the recording of comments against
a particular table and is the same both in operation and appearance, as that for the
routing table comments described earlier.
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CHAPTER 9
PLC Clock Tool

The PLC Clock tool provides a facility to monitor and set the PLC Clock and synchronise the PLC clock
to the PC clock.

The PLC Clock tool dialogue can be set so that it remains ‘on top’  and is not obscured by other windows
by clicking the right mouse button in the task bar and selecting the Always on Top option.

To close the PLC Clock dialogue, select the Close button in the title bar.

The PLC Clock tool displays two clock images that represent the time for the computer (PC) on the left
and the PLC on the right.  The time and date are also represented in a digital format for both the computer
and the PLC.

The times for both the Computer and the PLC are updated once a second.

A synchronise button is located centrally between between the two clock images.  This button once
pressed, will synchronise the PLC clock to the computer clock.  The same effect can also be evoked from
the Options – Synchronise Clocks menu.

The File menu allows the PLC Clock tool to be closed by use of the Exit menu item.

The Options – Set PLC Clock allows the time and date within the PLC to be set.

If the PLC Clock window is minimised the PLC clock time will be displayed in digital format in the task
bar
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CHAPTER 10
Data Link Editor

The Datalink table allows a PLC to be configured so that it can participate in one, or more automatic data
sharing schemes, over SYSMAC LINK and Controller Link networks, without the need for special
programming.  Words of IO and DM can be set aside for use as data link words, which are allocated to
various nodes in the network.  Limits on the amount of data and number of nodes varies with the type
network and the type of PLC.  The allocation of words to nodes is defined by two or more Data Link
tables.

Data can only be shared on a single physical network.  A gateway cannot be used to pass information
from one network to another.

Data Link Editor - General
The Data Link editor is divided into two screens:

♦  Graphical overview screen – This is the upper screen, which displays a representation of the nodes
and their data link areas participating in the data link function.

♦  Node entry screen – This is the lower screen, which allows the configuration of the data links for
each individual node.
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Graphical overview screen
This comprises of a number of nodes, each drawn vertically and inline with its neighbour horizontally.

The top section of each node contains the node number and the Area 1 and Area 2 memory types.  The
lower section of the nodes displays the data links as a series of shapes.  An oval indicates a source for
the DataLink and a rectangle the target (or read area).  If a node does not form part of a Data Link, no
shape is displayed.  Each of the DataLink source and target(s) are displayed horizontally across each of
the participating nodes.  Different data links are displayed in different colours.

Node entry screen
The lower section, node entry screen allows a single node at a time to be configured to participate in the
data link mechanism.  The information about the node currently selected in the Graphical Overview
screen is displayed.

This screen is comprised of two sections:

♦  The node configuration (Left hand side).
♦  The data link configuration (Right hand side).
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The node configuration area allows the node number to be selected from the list of currently
participating nodes and for this node, allows the following to be configured:

♦  PLC family type – CS1, CV or C series PLC. (Set to CS1 Series in the example).
♦  Area 1 memory type and start address – the memory type and valid start address is dependant on the

PLC type.  The memory type is a predefined section of PLC memory that is to be utilised for the data
link function.(Set to CIO in the example)  The Start address is an offset from the base address that
the data link area is to start from.(Set to 0in the example).

♦  Area 2 memory type and start address – the memory type and valid start address is dependant on the
PLC type.

♦  Status memory type and start address – the memory type and valid start address is dependant on the
PLC type.

♦  Source Area Destination Nodes – other nodes that are to have destination (read) areas from this node
can be configured.  The ‘Set’ button allows any modifications to the list of destination nodes for this
node source to be entered.

The data link configuration area displays in a ‘list’ format, the data link source information and the data
link read (destination) areas information for the selected node.

The data link list will display the information for either the Area 1 or Area 2 by selecting one of the two
radio buttons above the list.

The left-hand column depicts the area type and can be one of the three options:

♦      Status Area –  This is necessary for the data link to function

♦      Source Node xx – This is the area of memory that will be read by other nodes participating in
the data link.  Double clicking this will display the area specify dialogue that can be used to
configure the memory size.

♦      From Node xx – This is a destination area of memory that is being read from another node.
Double clicking this will display the area specify dialogue that can be used to configure the memory
size and offset address.(SYSMAC Link only allows size to be specified).

The second column displays the PLC memory area type within the current node, for the data link area.
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The last three columns display the Start address, Finish address and the Size of each data link area within
the current node.

In addition, the data link configuration area also allows the refresh order to be adjusted by use of the Up
and Down buttons situated above the list area.  To alter the refresh node order, select the node to be
adjusted and click the Up or Down buttons as required until the node is positioned correctly.

The Add and Del buttons allow new destination nodes to be added or existing destination nodes to be
deleted.

Use the following procedure to add or delete destination nodes.

1, 2, 3… To add a Node
1. Click the Add button.  A dialogue will then display a list of possible destination

nodes that can be added.
2. Select the destination node of interest and click Ok.  The destination node will

then be added to the data link list.
To delete a Node

3. Select the destination area to be deleted and click on the Del button.  The
destination area will be removed from the data links list.

When each of the destination areas in the data links list are selected, information about the size and offset
that is being read from the source node is displayed as ‘Properties’ below the data links list.

Creating a New Data Link Table

Using the Table Wizard.
Use the following procedure to create a new Data Link table using the Table Wizard.  This is the
recommended method for creating new data link tables.

1, 2, 3… 1. In the toolbar click on the Wizard button.  This will open the Data Link Table
Wizard.
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2. Enter the nodes participating in the data link table.  Node entries must be comma
or hyphen separated.  For example: 1,4,6,9-12 will create nodes for 1, 4, 6 and 9,
10, 11 and 12.

3. Select or Deselect the Fast Default Table Generation.  If the box is checked the
data link table is created with the nodes entered and default PLC types, which can
be edited by selecting the Defaults button.  If the box is not checked then
information can be entered for each of the nodes.  Click Next.

4. If the Fast Default Table Generation box is not checked then for each node
entered, enter the appropriate values for the Status Area, Source Area 1 and 2 and
Destination Nodes.  Click Next.

Using the toolbar buttons.
Use the following procedure to create a new Data Link table using the toolbar buttons.

1, 2, 3… 1. From the toolbar, select Add Source Link.
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2. In the Node Configuration dialogue enter the PLC Node number and type and the
values for Memory Areas 1 and 2.  Click OK

3. Repeat steps two and three for each new node.

Using the drop down menus.
Use the following procedure to create a new Data Link table using the Drop Down menus.

1, 2, 3… 1. From the menu Table option select Add Source Link.
2. In the Node Configuration dialogue enter the PLC Node number and type and the

values for Memory Areas 1 and 2.  Click OK
3. Repeat steps two and three for each new node.

Editing the Data Link Table

Adding Nodes
Use the following procedure to add a new Node to a Data Link table.

1, 2, 3… 1. From the toolbar click the Add  Source Link button or from the Table menu option
select Add Source Link.

2. In the Node Configuration dialogue enter the PLC Node number and type and the
values for Memory Areas 1 and 2 then Click OK..  The new Node will appear in
the Graphical Overview screen.

3. Note that the Cycle Time options are only available when using  the SYSMAC
Link network type.

Adding Data Link Destination areas using Graphical Overview
Use the following procedure to add a new Data Link destination to a table.

1, 2, 3… 1. From the toolbar click the Add Destination button or from the Table menu option
select Add Destination.

2. Position the cursor in the appropriate node in the same row as the source to be
added from, then click the left mouse button.  The new destination point will be
positioned in the selected node.

3. Note that the Cycle Time options are only available when using SYSMAC Link
network type

Adding Data Link Destination areas using Node Entry screen
Use the following procedure to add a new Data Link destination to a table.

1, 2, 3… 1. Select the node number in the Node Entry screen from the drop down list. The list
of currently configured data link destinations appear in the data link list.
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2. Select the Add button from above the data link list. The Add Node Area dialogue
will display a list of destination areas available to be added to this node.

3. Select the destination area of interest. The new destination area will be added to the
data link list and also to the graphical overview for the current node.

Editing a Node Status Area.
Use the following procedure to edit the Status Area of a Node.

1, 2, 3… 1. Select the node to be configured from the node number drop down list.
2. Edit the Status configuration fields in the Node Entry screen. This is the Memory

type and start address for the Status area.
3. This allows selection from the options CIO, D, E0, E1, E2, E3, E4, E5, E6, E7 and

L.

Editing the Start Address Data
Use the following procedure to edit the Start Address Data of a source.

1, 2, 3… 1. Select the node to be configured from the node number drop down list.
2. Edit the Area 1 and Area 2 configuration fields in the Node Entry screen. This is

the Memory type and start address for the data link areas.

Editing Source or Link Areas
Use the following procedure to edit a source or destination area.

1, 2, 3… 1. Select the node to be configured from the node number drop down list.
2. From the data link list, Double click on the source or destination of interest. The

Area Specify dialogue will be displayed.
3. Enter the area size (SYSMAC Link destination area only) and the offset address.

Click Ok.

Editing Data Link  Destination Areas
Data link destination areas can be moved from one position to another on the Graphical Overview screen
by selecting the appropriate link then dragging and dropping it at the new position.  If the link is moved
to a row of a different colour it’s colour will automatically change to match that of the new row.

Deleting a Data Link Destination Area
Use the following procedure to delete a Data Link destination area from a node.

1, 2, 3… 1. In the Graphical Overview screen, Click on the Data Link destination area
(Coloured rectangle) to be deleted and check that the selection markers appear.

2. From the toolbar click the Delete button or from the Table Menu select Delete.
3. OR, Right mouse click and select Delete from the pop-up menu.
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4. Alternatively, Select the node number in the Node Entry screen, then select the
destination to be deleted from the data links list. Click ‘Del’ button.

Deleting a Node
Use the following procedure to delete a node from a Data Link table.

1, 2, 3… 1. Click in the top section of the node to be deleted and check that the selection
markers appear.

2. From the toolbar click the Delete button or from the menu select Table / Delete.

Saving a new Data Link Table
Use the following procedure to save a new Data Link table.

1, 2, 3… 1. From the File menu option select Save or select Save As from the toolbar.  This
will open the Save As dialogue.

2. In the Save As dialogue enter an appropriate file name and select the file type from
the drop down list.
Controller Link files have the extension.  .cl3
Earlier versions using the DOS format have the extension  .clk

3. Navigate to the folder in which the file is to be saved and click Save.

Loading a Data Link Table from disk
Use the following procedure to load a  previously saved Data Link table.

1, 2, 3… 1. From the File option select Open or select Open from the toolbar.  This will show
the Open dialogue.

2. In the Open dialogue, navigate to the folder from which the file is to be loaded.

3. Select the file type from the drop down list and select the file name.

Controller Link files have the extension.  .cl3
Earlier versions using the DOS format have the extension  .clk

4. Click the Open button.

Online Functions
Once the data link table has been created it must be transferred to the PLCs in order for the data link
function to operate. Ensure any table created off line is saved to disk.
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Connecting Online
Use the following procedure to connect to a PLC online.

1, 2, 3… 1. Set up a CX-Net project for connection online. (See CX-Net – Chapter 8 for more
details about the Network Configuration Tool).

2. From CX-Net menu, select Data Link | Set up.

3. Select the File | New menu command, or the New toolbar button.  A transfer dialog
will open and the datalink table will be transferred from the PLC’s.  On completion
the error check list dialog will display the status of the reading process from each
of the nodes.  Click OK.

4. The graphical overview will display the table and the Node entry screen will
display the details of the first node.

Note: The  File | New command only displays nodes which contain a valid
datalink table.  To display all nodes in the network, even if they do not
contain a datalink table, select Online | Show All Network Nodes instead
of File | New.

Transfer Data Links table to all nodes
Use the following procedure to transfer data link tables to all PLCs in a network.

1, 2, 3… 1. Ensure Online to PLC.
2. Ensure the Network Operation button is selected (pressed in).  This will ensure the

whole network will be operated on and not just a single node.
3. From the toolbar click the Transfer to PLC  button or from the menu select Online

| Transfer to PLC.
Note: In the case of transfer to PLC, if the configured PLC is different from the actual PLC

type a warning message will be displayed showing the differences.

Transfer Data Links table from all nodes
Use the following procedure to transfer data link tables from all PLCs in a network.

1, 2, 3… 1. Ensure Online to PLC.
2. Ensure the Network Operation button is selected (pressed in).  This will ensure the

whole network will be operated on and not just a single node.
3. From the toolbar click the Transfer from PLC button or from the menu select

Online / Transfer from PLC.
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Verify Data Links tables in all nodes
Use the following procedure to verify the data link tables in all PLCs in a network.

1, 2, 3… 1. Ensure Online to PLC.
2. Ensure the Network Operation button is selected (pressed in). This will ensure the

whole network will be operated on and not just a single node.
3. From the toolbar click the Verify node button or from the menu select Online /

Verify Node.
Note:  In order to verify the data link table within the PLC with the data link table in the editor, it may
be necessary to change the data within the PLC. If this is required, a warning message will be displayed.

Delete all Nodes in a Data Link
Use the following procedure to delete all the nodes participating in the data Link.

1, 2, 3… 1. Ensure Online to PLC.
2. Ensure the Network Operation button is selected (pressed in). This will ensure the

whole network will be operated on and not just a single node.
3. From the toolbar click the Delete button or from the menu select Online / Delete.
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CHAPTER 11
Routing Tables

Routing tables allow networked PLCs to be configured so that they can communicate with each other
via gateways; across remote networks.  The routing tables contain the network, unit number information
required.  It is only necessary to set up routing tables if the end connection PLC is not a direct
connection, i.e. using another PLC as a gateway connection.  The routing table is held within the PLC(s)
which acts as the gateway device.  Different types of PLC and networks have different capabilities for
routing.

PLC Network Routing Table

C-series SYSMAC LINK N/A

C-series SYSMAC NET C-SYSMAC NET

C-series Controller Link FINS

C-series Ethernet N/A

CV-series SYSMAC LINK, SYSMAC NET,
Ethernet or Controller Link

FINS

CS1-series Controller Link or Ethernet FINS

The Routing Table menus are accessed from the PLC Network Configuration Tool dialogue and contain
options allowing the editing and setup of routing tables both offline and online.  The routing tables which
are being used in a network, can be viewed online.

Different online Routing Table Setup dialogues are used, depending upon the protocol associated with
the routing table.  The way in which they are displayed and operate is similar in each case.

The PLC Network Configuration Tool dialogue, visually displays the structure of the routing table
associated with the PLC (including the destination node and network gateway employed in directing data
across the network). Initially the visual representation of the routing table is empty, or set to zero, until
a routing table file has been opened.  An overview of the routing table can also be viewed and edited in
a graphical or tabular format.

Opening an existing Routing Table
Use the following procedure to open an existing routing table in a project.

1, 2, 3… 1. Open the PLC Network Configuration Tool dialogue and from the Routing Table
menu select Editor and then the type of table.

2. From the Routing Table File menu select Open Routing Table File.

3. From the list of possible files, select the file to be opened.
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The following procedure can also be used as a shortcut to opening an existing routing table.

1, 2, 3… 1. Open the PLC Network Configuration Tool dialogue and from the Project menu
options select Open.

2. In the Open Project dialogue select the File Type as All Files(*.*)

3. In the Open Project dialogue select the appropriate device type and click the Open
button.

4. From the list in the Project Devices window select the network to be opened.

5. From the Routing Table menu, select Editor and then the required network type.

Note: Routing tables have an ‘.RT2’ (SYSMAC NET), ‘.RTG’ for FinsLocal or ‘.RT3’
(FINS) Network  filename extension.

Creating a new Routing Table
Use the following procedure to create a new routing table within a project.

1, 2, 3… 1. Open the PLC Network Configuration Tool dialogue and from the Project menu
options select New.

2. In the Create Project dialogue enter a file name for the new table, navigate to the
folder where the file is to be saved and click the Save button.

3. From the PLC Network Configuration Tool Project menu select Add Device.

4. In the Add PLC dialogue Enter a Device Name and select a Device Type and
Network Type from the dropdown menu.  And click OK.

5. From the PLC Network Configuration Tool click on the device name in the
Project Device window.

6. From the Routing Table menu, select Editor and then the required network type.

Adding a Local Network
Use the following procedure to add a local network to a routing table.

1, 2, 3… 1. Open the PLC Routing Table dialogue and select the SIOU tab in the left hand
pane and the Main View tab in the right hand pane.



OMRON CHAPTER 11 – Routing Tables

Revision 1.6 Page 97

2. Select the Unit from the SIOU list to which the local network is to be added then
right click on the that unit and select the Insert CPU SIOU option.

3. From the Enter SIOU Details dialogue enter the:

Local Network Number.  This is the ID number that uniquely identifies the local
network in the routing table.  Each new network must be given a unique ID
number in the range 1 to 127.
Local Network Type.  Select the type of local network from the drop down
menu.  The network type selected will be displayed in the diagram.

4. Click OK to close the SIOU dialogue and add the local network to the selected
unit.

Adding a Remote Network
Use the following procedure to add a remote connection to a local network.

1, 2, 3… 1. Open the PLC Routing Table dialogue and select the SIOU tab in the left hand
pane and the Main View tab in the right hand pane.

2. With the courser positioned over the local network click the right mouse button.



OMRON CHAPTER 11 – Routing Tables

Revision 1.6 Page 98

3. From the pop up menu select the Add connection to Remote Network option.
(selecting the Change Local Network option enables the local network number to
be changed).

4. In the Enter Relay Node Details dialogue enter the:
Relay node number.  This is the ID number of the relay node.  Relay Nodes can
be given any ID number in the range 1 to 126.
Remote Network number.  This is the ID number that will uniquely identify the
remote connection.  Each new remote connection must be given a unique ID
number in the range 1 to 127.
Note that a remote network can not be given the same ID number as an existing
Local Network.

5. Click OK.  This will add the remote connection with the specified ID number
(shown in red) to the Local Network.  A maximum of 20 nodes can be added to
a network.

6. Finally from the Options menu check the table for Errors
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Editing the Routing Table
Open the appropriate routing table from the Network Configuration Tool dialogue then use the following
procedure to edit the table.

1, 2, 3… 1. Local Network:
♦  In the Routing Table dialogue right click on the Unit to be edited and select the

appropriate option from the pop up menu.

♦  To save the changes select the Save option from the File menu
2. Relay Node:

♦  Right click on the Relay node and select the appropriate option from the pop up
menu.

3. Remote Network:
♦  Right click on the Relay node and select the appropriate option from the pop up

menu.



OMRON CHAPTER 11 – Routing Tables

Revision 1.6 Page 100

Error Checking
Use the following procedure to view any validation errors.

1, 2, 3… 1. Either:

♦  Select Check routing table for errors from the Edit menu in the Routing Table
Editor dialogue box.

Or

♦  Click the ! in the toolbar.  A message box will be displayed indicating success or
failure.

Additional Features

The Network View Screen
The Network tree view is used to display the nodes on the locally connected network and is only
available when the local connection network is an Omron proprietary network, such as a Controller Link,
Sysmac link, Sysmac Net or SYSWAY.

This icon is used to indicate that a node is present at this node number.
This icon is used to indicate that node is not present at this node number.
This icon is used to represent the currently selected node.
This icon is used to indicate that a node is present at this node number but there are
errors reading the routing table.
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The Overview Screen
Selecting the Overview tab will show all the routing tables in an graphical format.  The relay node
numbers are shown in the whites boxes and the remote network numbers in the red boxes.  The numbers
on the right are the Local Network numbers.

Note that the tables can not be edited in this view.

Table View Screen
The Table View screen provides a method of setting the routing table by means of a tabular view.
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The screen is comprised of two main sections:

♦  The local settings (Left hand side)
♦  The remote settings (right hand side)
The local settings section allows a series of entries for the SIOU (Special Input/Output Unit) and it’s
corresponding Local Network number.

The remote settings section allows a series of entries for the Remote Network number, it’s corresponding
Relay Network number and  it’s corresponding Relay Node number.

The slider control to the right of each section can be used to bring any more than the eight entries into
view if so required.

Each of the data entry fields have their own individual set of spin buttons, which when pressed will
increment or decrement the value. The number can also be entered normally using the number keypad
on the user keyboard.

Three control buttons can be found at the bottom of the screen:

♦  Ok button: Once all data entry has been completed, selecting the ‘Ok’ button will check the table
entries for errors. If the check fails, an error description dialogue will be displayed. If the check does
not detect any errors the Main Screen will be displayed.

♦  Restore button: If during data entry, the user wished to revert back to the table state that was in
effect before the Table View was displayed; The user should select the Restore button.

♦  Cancel button: This button will cancel any changes made whilst the Table View was being displayed
and then display the Main View screen.

Transferring a Routing table to a PLC
Once a routing table has been created or edited, the routing table may be transferred to the PLC using
the following steps:

1, 2, 3… 1. If the Network Configuration Tool is ‘on-line’ to a PLC, skip to 4.
2. Save the current routing table using the Routing Table Edit menu: File – Save

Routing Table. (Add Author and comment if required).
3. Go ‘on-line’ to the PLC. See section 10 – The Network Configuration Tool for

details of this operation.
4. From the CX-Net menu select: Routing Table - Setup
5. From the Routing Table menu select: File – Open Routing Table.
6. Select the previously created filename and select open. Or, alternatively the

routing table can be created.
7. From the Routing Table Editor menu select: Options – Transfer to PLC.
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Transferring a Routing table from a PLC
The routing table held within a PLC may be transferred from the PLC using the following steps:

1, 2, 3… 1. Go ‘on-line’ to the PLC. See section 10 – The Network Configuration Tool for
details of this operation.

2. From the CX-Net menu select: Routing Table - Setup
3. From the Routing Table Editor menu select: Options – Transfer from PLC.
4. The routing table may then be saved to file by: From the Routing Table menu

select: File – Save Routing Table.
5. Enter a suitable filename and select Save.
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APPENDIX A
Network Availability

The following tables indicate the network available to each PLC device group.  FinsGateway has no
network availability and is not described.

Note Modem connection is also available by Toolbus or SYSMAC WAY if a
Modem device has been configured in Microsoft Windows.  Any device
supporting Toolbus or SYSMAC WAY also supports Modem connections.
Refer to standard Microsoft Windows documentation for details on
configuring a Modem device.

C**H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C20H Yes - - - - - -

C28H Yes - - - - - -

C40H Yes - - - - - -

C60H Yes - - - - - -

C**K Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C20K Yes - - - - - -

C28K Yes - - - - - -

C40K Yes - - - - - -

C60K Yes - - - - - -

C**P Device Group
Device Type SYSMAC WAY CV-

Toolbus
SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C20P Yes - - - - - -

C28P Yes - - - - - -

C40P Yes - - - - - -

C60P Yes - - - - - -
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C1000H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes - Yes Yes - - -

C20 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C20 Yes - - - - - -

C2000H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes - Yes Yes - - -

C2000 Yes - Yes - - - -

C200H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes - - - - - -

CPU02 Yes - - - - - -

CPU03 Yes - - - - - -

CPU21 Yes - - - - - -

CPU21 Yes - - - - - -

CPU22 Yes - - - - - -

CPU23 Yes - - - - - -

CPU11 Yes - Yes Yes - - -

CPU31 Yes - Yes Yes - - -

C200HE Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU11 - Yes - - - - -

CPU32 - Yes Yes Yes Yes Yes -

CPU42 Yes Yes Yes Yes Yes Yes -
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C200HE-Z Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU11 Yes Yes - - - - -

CPU32 Yes Yes Yes Yes Yes Yes -

CPU42 Yes Yes Yes Yes Yes Yes -

C200HG Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU33 - Yes Yes Yes Yes Yes -

CPU43 Yes Yes Yes Yes Yes Yes -

CPU53 - Yes Yes Yes Yes Yes -

CPU63 Yes Yes Yes Yes Yes Yes -

C200HG-Z Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU33 Yes Yes Yes Yes Yes Yes -

CPU43 Yes Yes Yes Yes Yes Yes -

CPU53 Yes Yes Yes Yes Yes Yes -

CPU63 Yes Yes Yes Yes Yes Yes -

C200HS Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes - - - - -

CPU03 Yes Yes - - - - -

CPU11 Yes Yes Yes Yes - - -

CPU13 Yes Yes Yes Yes - - -

C200HX Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU34 - Yes Yes Yes Yes Yes -

CPU44 Yes Yes Yes Yes Yes Yes -

CPU54 - Yes Yes Yes Yes Yes -

CPU64 Yes Yes Yes Yes Yes Yes -
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C200HX-Z Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU34 Yes Yes Yes Yes Yes Yes -

CPU44 Yes Yes Yes Yes Yes Yes -

CPU54 Yes Yes Yes Yes Yes Yes -

CPU64 Yes Yes Yes Yes Yes Yes -

C500 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C500 Yes - Yes - - - -

C250 Yes - - - - - -

C120 Yes - - - - - -

C50 Yes - - - - - -

CJ1G Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU44 Yes Yes - - Yes Yes -

CPU45 Yes Yes - - Yes Yes -

CJ1G-H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU42 Yes Yes - Yes Yes Yes -

CPU43 Yes Yes - Yes Yes Yes -

CPU44 Yes Yes - Yes Yes Yes -

CPU45 Yes Yes - Yes Yes Yes -

CJ1H-H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU65 Yes Yes - Yes Yes Yes -

CPU66 Yes Yes - Yes Yes Yes -
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CPM1 (CPM1A/CPM2*/CPM2*-S*) Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU10 Yes Yes - - - - -

CPU20 Yes Yes - - - - -

CPU30 Yes Yes - - - - -

CQM1 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU11 Yes Yes - - - - -

CPU21 Yes Yes - - - - -

CPU41 Yes Yes - - - - -

CPU42 Yes Yes - - - - -

CPU43 Yes Yes - - - - -

CPU44 Yes Yes - - - - -

CQM1H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU11 Yes Yes - - - - -

CPU21 Yes Yes - - - - -

CPU51 Yes Yes - - Yes - -

CPU61 Yes Yes - - Yes - -

CS1G/CS1G-H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU42 Yes Yes - Yes Yes Yes -

CPU43 Yes Yes - Yes Yes Yes -

CPU44 Yes Yes - Yes Yes Yes -

CPU45 Yes Yes - Yes Yes Yes -
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CS1H/CS1H-H Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU63 Yes Yes - Yes Yes Yes -

CPU64 Yes Yes - Yes Yes Yes -

CPU65 Yes Yes - Yes Yes Yes -

CPU66 Yes Yes - Yes Yes Yes -

CPU67 Yes Yes - Yes Yes Yes -

IDSC Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C01 Yes Yes - - - - -

C02 Yes Yes - - - - -

SRM1/SRM1 V2 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

C01 Yes Yes - - - - -

C02 Yes Yes - - - - -

CV1000 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes Yes Yes Yes Yes -

CV2000 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes Yes Yes Yes Yes -

CV500 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes Yes Yes Yes Yes -
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CVM1 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes Yes Yes Yes Yes -

CPU11 Yes Yes Yes Yes Yes Yes -

CVM1-V2 Device Group
Device Type SYSMAC WAY Toolbus SYSMAC NET SYSMAC LINK Controller Link Ethernet Highlink

CPU01 Yes Yes Yes Yes Yes Yes -

CPU11 Yes Yes Yes Yes Yes Yes -

CPU21 Yes Yes Yes Yes Yes Yes -
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APPENDIX B
PLC Memory Areas

The following tables provide memory area details for each device group.

Some tables indicate special addresses.  These can be as follows:

♦  CLOCK.  This allows reading/writing of a PLC's real-time clock.
♦  BANKNO.  This allows reading/writing of a PLC's extended memory bank number.
♦  MODE.  This allows reading/writing of a PLC's run-mode.

C**H Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

DM 0 1999 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 252 Yes Yes Yes F C

IR (opt) 253 255 (bit 7) Yes Yes No

LR 0 63 Yes Yes Yes F C

SR (opt) 247 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

Special addresses CLOCK, MODE.

C**K Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

TC 0 47 Present Value Status Yes F C

DM 0 63 Yes No Yes

HR 0 9 Yes Yes Yes F C

IR (opt) 0 18 (bit 7) Yes Yes Yes F C

SR (opt) 18 (bit 8) 19 (bit 7) No Yes No

TR 0 0 (bit 7) No Yes No



OMRON APPENDIX B – PLC Memory Areas

Revision 1.6 Page 114

C**P Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

TC 0 47 Present Value Status Yes F C

DM 0 63 Yes No Yes

HR 0 9 Yes Yes Yes F C

IR (opt) 0 18 (bit 7) Yes Yes Yes F C

SR (opt) 18 (bit 8) 19 (bit 7) No Yes No

TR 0 0 (bit 7) No Yes No

C1000H Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

DM 0 4095 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 236 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 237 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

Special addresses: MODE.

C20 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

TC 0 47 Present Value Status Yes F C

HR 0 9 Yes Yes Yes F C

IR (opt) 0 18 (bit 7) Yes Yes Yes F C

SR (opt) 18 (bit 8) 19 (bit 7) No Yes No

TR 0 0 (bit 7) No Yes No
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C2000H Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 236 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 237 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

Special addresses: MODE.

C200H Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 1999 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

Special addresses: CLOCK, MODE.
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C200HE Device Group

General Memory Areas
Memory Areas for any CPU.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 4095 Yes No Yes

DM 6000 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes FC

TR 0 0 (bit 7) No Yes No

SR (opt) 256 299 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

CPU 32/42 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 4096 5999 Yes No Yes

Special addresses: CLOCK, MODE.
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C200HE-Z Device Group

General Memory Areas
Memory Areas for any CPU.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 4095 Yes No Yes

DM 6000 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes FC

TR 0 0 (bit 7) No Yes No

SR (opt) 256 299 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

CPU 32/42 Device Group
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 4096 5999 Yes No Yes

Special addresses: CLOCK, MODE.
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C200HG Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes F C

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

EM 0 6143 * 1 Yes No Yes -n

Special addresses: CLOCK, MODE, BANKNO.

C200HG-Z Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes F C

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

EM 0 6143 * 1 Yes No Yes -n

Special addresses: CLOCK, MODE, BANKNO.
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C200HS Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes F C

TC 0 511 Present Value Status Yes F C

TR 0 0 (bit 7) No Yes No

Special addresses: CLOCK, MODE.

C200HX Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes F C

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

EM 0 6143 * 3 Yes No Yes -n

Special addresses: CLOCK, MODE, BANKNO.
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C200HX-Z Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 235 Yes Yes Yes F C

IR (opt) 300 511 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 236 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

SR (opt) 256 299 Yes Yes Yes F C

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

EM 0 6143 * 3 Yes No Yes -n

CPU 65 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

EM 0 6143 * 8 Yes No Yes -n

CPU 85 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

EM 0 6143 * 16 Yes No Yes -n

Special addresses: CLOCK, MODE, BANKNO.
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C500 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

TC 0 127 Present Value Status Yes F C

DM 0 511 Yes No Yes

HR 0 31 Yes Yes Yes F C

IR (opt) 0 57 Yes Yes Yes F C

LR 0 31 Yes Yes Yes F C

SR (opt) 58 60 Yes Yes Yes F C

SR (opt) 61 63 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

CJ1G Device Group

General Memory Areas
General Memory Areas for all CPUs 44 and 45.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

IR 0 15 Yes (double) No Yes

DR 0 15 Yes No Yes f c

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes f c

H 0 511 Yes Yes Yes

W 0 511 Yes Yes Yes

CIO(opt) 0 6143 Yes Yes Yes f c

T 0 4095 Present Value Status Yes f.c

C 0 4095 Present Value Status Yes f.c

D 0 32767 Yes No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No
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CPU 44 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 1 Yes No Yes -n

CPU 45 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 3 Yes No Yes -n

Special addresses: (all CPUs):
(CPU 44/45):

CLOCK, MODE.
BANKNO.

CJ1G-H Device Group

General Memory Areas
General Memory Areas for all CPUs 42, 43, 44 and 45.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

CIO(opt) 0 6143 Yes Yes Yes F C

DR 0 15 Yes No Yes F C

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes F C

H 0 511 Yes Yes Yes F C

W 0 511 Yes Yes Yes

T 0 4095 Present Value Status Yes F C

C 0 4095 Present Value Status Yes F C

D 0 32767 Yes No Yes

IR 0 15 Yes (double) No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No
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CPU 42 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 43 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 44 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 45 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32765*3 Yes No Yes -n
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CJ1H-H Device Group

General Memory Areas
General Memory Areas for all CPUs 65 and 66.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

CIO(opt) 0 6143 Yes Yes Yes F C

DR 0 15 Yes No Yes F C

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes F C

H 0 511 Yes Yes Yes F C

W 0 511 Yes Yes Yes

T 0 4095 Present Value Status Yes F C

C 0 4095 Present Value Status Yes F C

D 0 32767 Yes No Yes

IR 0 15 Yes (double) No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No

CPU 65 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 3 Yes No Yes -n

CPU 66 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 7 Yes No Yes -n
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CPM1 (CPM1A) Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 15 Yes Yes Yes F C

DM 0 1023 Yes No Yes

DM 6144 6655 Yes No Yes

HR 0 19 Yes Yes Yes F C

IR (opt) 0 19 Yes Yes Yes F C

IR (opt) 200 231 Yes Yes Yes F C

LR 0 15 Yes Yes Yes F C

SR (opt) 232 252 Yes Yes Yes F C

TR 0 0 (bit 7) No Yes No

TC 0 127 Present Value Status Yes F C

Special addresses: MODE.

CPM2*/CPM2*-S* Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 23 Yes Yes Yes F C

DM 0 2047 Yes No Yes

DM 6144 6599 Yes No Yes

DM 6600 6655 Yes No No

HR 0 19 Yes Yes Yes F C

IR (opt) 0 49 Yes Yes Yes F C

IR (opt) 200 227 Yes Yes Yes F C

LR 0 15 Yes Yes Yes F C

SR (opt) 228 252 Yes Yes Yes F C

SR(opt) 253 255 Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 127 Present Value Status Yes F C

Special addresses: MODE.
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CQM1 Device Group

Memory Areas
Memory Areas for all CPUs.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 1023 Yes No Yes

DM 6144 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 243 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 244 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

CPU 41/42/43/44/45 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 1024 6143 Yes No Yes

Special addresses: CLOCK, MODE.

CQM1H Device Group

Memory Areas
Memory Areas for all CPUs.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

HR 0 99 Yes Yes Yes F C

IR (opt) 0 243 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C
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Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

SR (opt) 244 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

CPU 11/21 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 0 3071 Yes No Yes

DM 6144 6655 Yes No Yes

Special addresses: CLOCK, MODE.

CPU 51 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 0 6655 Yes No Yes

Special addresses: CLOCK, MODE.

CPU 61 Memory Areas
Memory Areas in addition to general memory areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

DM 0 6655 Yes No Yes

EM 0 6143 * 1 Yes No Yes

Special addresses: CLOCK, MODE.
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CS1G Device Group

General Memory Areas
General Memory Areas for all CPUs 42 43 44 and 45.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

IR 0 15 Yes (double) No Yes

DR 0 15 Yes No Yes f c

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes f c

H 0 511 Yes Yes Yes

W 0 511 Yes Yes Yes

CIO(opt) 0 6143 Yes Yes Yes f c

T 0 4095 Present Value Status Yes f.c

C 0 4095 Present Value Status Yes f.c

D 0 32767 Yes No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No

CPU 42 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 43 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n



OMRON APPENDIX B – PLC Memory Areas

Revision 1.6 Page 129

CPU 44 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 1 Yes No Yes -n

CPU 45 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 3 Yes No Yes -n

Special addresses: (all CPUs):
(CPU 44/45):

CLOCK, MODE.
BANKNO.

CS1G-H Device Group

General Memory Areas
General Memory Areas for all CPUs 42, 43, 44 and 45.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

CIO(opt) 0 6143 Yes Yes Yes F C

DR 0 15 Yes No Yes F C

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes F C

H 0 511 Yes Yes Yes F C

W 0 511 Yes Yes Yes

T 0 4095 Present Value Status Yes F C

C 0 4095 Present Value Status Yes F C

D 0 32767 Yes No Yes

IR 0 15 Yes (double) No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No
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CPU 42 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 43 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 44 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 45 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32765*3 Yes No Yes -n

CS1H Device Group

General Memory Areas
General Memory Areas for all CPUs 63, 64, 65, 66 and 67.

Prefix Start
Channel

End
Channel

Word
 Addressing

Bit
Addressing

Read
Write

Modifiers

IR 0 15 Yes (double) No Yes

DR 0 15 Yes No Yes F C

TK 0 31 Status Yes No

A 0 447 Yes Yes No
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Prefix Start
Channel

End
Channel

Word
 Addressing

Bit
Addressing

Read
Write

Modifiers

A 448 959 Yes Yes Yes F C

H 0 511 Yes Yes Yes F C

W 0 511 Yes Yes Yes

CIO(opt) 0 6143 Yes Yes Yes F C

T 0 4095 Present Value Status Yes F C

C 0 4095 Present Value Status Yes F C

D 0 32767 Yes No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No

CPU 63 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767*1 Yes No Yes -n

CPU 64 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
 Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 1 Yes No Yes -n

CPU 65 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 3 Yes No Yes -n
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CPU 66 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 7 Yes No Yes -n

CPU 67 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32765 * 13 Yes No Yes -n

Special
addresses:

(all CPUs):
(CPU 64/65/66/67):

CLOCK, MODE.
BANKNO.

CS1H-H Device Group

General Memory Areas
General Memory Areas for all CPUs 63, 64, 65, 66 and 67.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

CIO(opt) 0 6143 Yes Yes Yes F C

DR 0 15 Yes No Yes F C

TK 0 31 Status Yes No

A 0 447 Yes Yes No

A 448 959 Yes Yes Yes F C

H 0 511 Yes Yes Yes F C

W 0 511 Yes Yes Yes

T 0 4095 Present Value Status Yes F C

C 0 4095 Present Value Status Yes F C

D 0 32767 Yes No Yes

IR 0 15 Yes (double) No Yes

CF 0 11 No Yes No

CF 100 104 No Yes No

CF 113 114 No Yes No
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CPU 63 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 1 Yes No Yes -n

CPU 64 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 1 Yes No Yes -n

CPU 65 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 3 Yes No Yes -n

CPU 66 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32767 * 7 Yes No Yes -n

CPU 67 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

E 0 32765 * 13 Yes No Yes -n
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IDSC Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 27 Yes Yes Yes F C

DM 0 1023 Yes No Yes

DM 6144 6655 Yes No Yes

HR 0 99 Yes Yes Yes F C

IR (opt) 0 243 Yes Yes Yes F C

LR 0 63 Yes Yes Yes F C

SR (opt) 244 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 511 Present Value Status Yes F C

Special addresses: CLOCK, MODE.

SRM1 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 15 Yes Yes Yes F C

DM 0 2047 Yes No Yes

DM 6144 6655 Yes No Yes

HR 0 19 Yes Yes Yes F C

IR (opt) 0 23 Yes Yes Yes F C

IR (opt) 200 252 Yes Yes Yes F C

LR 0 15 Yes Yes Yes F C

SR (opt) 232 252 Yes Yes Yes F C

SR (opt) 253 255 (bit 7) Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 127 Present Value Status Yes F C

Special addresses: MODE.



OMRON APPENDIX B – PLC Memory Areas

Revision 1.6 Page 135

SRM1 V2 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

AR 0 15 Yes Yes Yes F C

C 0 127 Yes Yes Yes F C

DM 0 2047 Yes No Yes

DM 6144 6655 Yes No Yes

HR 0 19 Yes Yes Yes F C

IR 0 23 Yes Yes Yes F C

IR 200 239 Yes Yes Yes F C

LR 0 15 Yes Yes Yes F C

SR 240 253 Yes Yes Yes F C

SR 253 254 Yes Yes No

SR 254 255 Yes Yes No

TR 0 0 (bit 7) No Yes No

TC 0 127 Present Value Status Yes F C

Special addresses: MODE.

CV1000 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

A 0 255 Yes Yes Yes F C
A 256 511 Yes Yes No

AC 0 2047 No Yes No
C 0 1023 Present Value Status Yes F C

CIO (opt) 0 2555 Yes Yes Yes F C
D 0 24575 Yes No Yes

DR 0 2 Yes No Yes
G 0 255 Yes Yes Yes F C
IR 0 2 Yes No Yes
ST 0 1023 Yes Yes Yes
T 0 1023 Present Value Status Yes F C

TN 0 1023 No Yes Yes F C
TR 0 0 (bit 7) No Yes Yes F C
E 0 32765 * 2/4/8 Yes No Yes - n

Special addresses: BANKNO, CLOCK, MODE.
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CV2000 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

A 0 255 Yes Yes Yes F C
A 256 511 Yes Yes No

AC 0 2047 No Yes No
C 0 1023 Present Value Status Yes F C

CIO (opt) 0 2555 Yes Yes Yes F C
D 0 24575 Yes No Yes

DR 0 2 Yes No Yes
G 0 255 Yes Yes Yes F C
IR 0 2 Yes No Yes
ST 0 1023 Yes Yes Yes
T 0 1023 Present Value Status Yes F C

TN 0 1023 No Yes Yes F C
TR 0 0 (bit 7) No Yes Yes F C
E 0 32765 * 2/4/8 Yes No Yes - n

Special addresses: BANKNO, CLOCK, MODE.

CV500 Device Group
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

A 0 255 Yes Yes Yes F C

A 256 511 Yes Yes No

AC 0 1023 No Yes No

C 0 511 Present Value Status Yes F C

CIO (opt) 0 2555 Yes Yes Yes F C

D 0 8191 Yes No Yes

DR 0 2 Yes No Yes

G 0 255 Yes Yes Yes F C

IR 0 2 Yes No Yes

ST 0 511 Yes Yes Yes F C

T 0 511 Present Value Status Yes F C

TN 0 511 No Yes Yes F C

TR 0 0 (bit 7) No Yes Yes F C

Special addresses: MODE, CLOCK
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CVM1 Device Group

General Memory Areas
Memory Areas for any CPU.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

A 0 255 Yes Yes Yes F C

A 256 511 Yes Yes No

DR 0 2 Yes No Yes

CIO (opt) 0 2555 Yes Yes Yes F C

G 0 255 Yes Yes Yes F C

IR 0 2 Yes No Yes

TR 0 0 (bit 7) No Yes Yes F C

CPU 01 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

C 0 511 Present Value Status Yes F C

D 0 8191 Yes No Yes

T 0 511 Present Value Status Yes F C

CPU 11 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

C 0 1023 Present Value Status Yes F C

D 0 24575 Yes No Yes

T 0 1023 Present Value Status Yes F C

Special addresses: (all CPUs):  CLOCK, MODE.
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CVM1-V2 Device Group

General Memory Areas
Memory Areas for any CPU.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

A 0 255 Yes Yes Yes F C

A 256 511 Yes Yes No

DR 0 2 Yes No Yes

CIO (opt) 0 2555 Yes Yes Yes F C

G 0 255 Yes Yes Yes F C

IR 0 2 Yes No Yes

TR 0 0 (bit 7) No Yes Yes F C

CPU 01 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

C 0 511 Present Value Status Yes F C

D 0 8191 Yes No Yes

T 0 511 Present Value Status Yes F C

CPU 11 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

C 0 1023 Present Value Status Yes F C

D 0 24575 Yes No Yes

T 0 1023 Present Value Status Yes F C
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CPU 21 Memory Areas
Memory Areas in addition to General Memory Areas.

Prefix Start
Channel

End
Channel

Word
Addressing

Bit
Addressing

Read
Write

Modifiers

C 0 1023 Present Value Status Yes F C

D 0 24575 Yes No Yes

T 0 1023 Present Value Status Yes F C

E 0 32765 * 2/4/8 Yes No Yes -n

Special
addresses:

(all CPUs):
(CPU 21):

CLOCK,
MODE.

BANKNO.

FinsGateway CPU Unit
Prefix Start

Channel
End

Channel
Word

Addressing
Bit

Addressing
Read
Write

Modifiers

CIO(opt) 0 32767 Yes Yes Yes

D 0 32767 Yes No Yes



OMRON APPENDIX B – PLC Memory Areas

Revision 1.6 Page 140



OMRON APPENDIX C – Toolbars and Keyboard Shortcuts

Revision 1.6 Page 141

APPENDIX C
Toolbars and Keyboard Shortcuts

The following tables summarise the toolbars and keyboard shortcuts available from each component and
tool.  The F1 function key is common across all components and tools and provides context help.

PLC Memory Component

Toolbars

Open

Open File

Save in Project

Print

Print Preview

Cut

Copy

Past

Fill Data Area

Clear Data Area

Transfer to PLC

Transfer from PLC

Compare with PLC

Monitor

Binary

Binary Coded Decimal

Decimal

Signed Decimal

Floating Point

Hexadecimal

Text

LReal

Resize Column

Zoom Out

Restore Zoom

Zoom In

Set Value

Force On

Force Off

Force Cancel
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Keyboard Shortcuts

Ctrl+O……….. Open Alt+B………… Binary
Ctrl+S……….. Save in Project Alt+C………… Binary Coded Decimal
Ctrl+P……….. Print Alt+D………… Decimal
Ctrl+X……….. Cut Alt+S………… Signed Decimal
Ctrl+C……….. Copy Alt+P………… Floatinf Point
Ctrl+V……….. Paste Alt+H………… Hexadecimal
Ctrl+PgUp….. Zoom In Alt+T………… Text
Ctrl+PgDn….. Zoom Out Alt+L………… Lreal

Data Trace/Time Chart Monitor Component

Toolbars Keyboard Shortcuts

Open

Save

Configure Trace/Time Chart

Zoom Out

Restore Zoom

Zoom In

Scale Out

Restore Scale

Scale In

Stop Trace/Time Chart

Trigger the Trace/Time Chart

Execute Trace/Time Chart

Read Trace/Time Chart

About

Help

Ctrl+O ............   Open
Ctrl+PgUp ......   Zoom In
Ctrl+PgDn ......   Zoom Out
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Memory Card Component

Toolbars Keyboard Shortcuts

Cut

Copy

Paste

Delete

Rename

Properties

Large Icons

Small Icons

List

Details

Ctrl+X.............   Cut
Ctrl+C.............   Copy
Ctrl+V.............   Paste
Ctrl+A.............   Select All
F5...................   Refresh device
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CX-Net Network Configuration Tool

Toolbars Keyboard Shortcuts

Open Project

Edit Project

Open/Close Project Device PLC

Display PLC Information

Set PLC Operating Mode

Display PLC Error Status

Show Unit Status

Configure PLC System Settings

Configure IO Table

Configure C-Series Comms. Units

Online Edit Routing Table

Online Edit Data Link

Echo Back Test

Broadcast Test

Ping Test

About

Ctrl+N.............   New
Ctrl+O ............   Open
Ctrl+S.............   Save
Return ............   Edit Item
Insert ..............   Insert Item
Delete ............   Delete Item
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Import/Export Tool

Toolbars Keyboard shortcuts

New

Open

Edit Project

Import CVSS

Import LSS

Import Text

Import Tagged Database

Export Text

Export to FinsServer TagDB

Clear Screen

Print Screen

About

Ctrl+N.............   New
Ctrl+O ............   Open
Ctrl+E.............   Edit Project
Ctrl+C.............   Import VCSS
Ctrl+L .............   Import LSS
Ctrl+T .............   Import Text
Ctrl+V.............   Import from FinsGateway
Alt+T ..............   Export Text
Alt+V ..............   Export to FinsGateway TagDB
Ctrl+R.............   Clear screen
Ctrl+P.............   Print screen
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Data Link Editor

Toolbars Keyboard Shortcuts

New

Show All Network Nodes

Open

Save

Toggle Network/Single Node operation

Transfer to PLC

Transfer from PLC

Delete

Verify Node

Status

Automatic Datalink Setup

Validate Table

Wizard

Add source link

Add Destination

Set properties

Delete link destination service area

Zoom in

Zoom out

Zoom original

Print

About Datalink Component

Ctrl+N.............   New
Ctrl+O ............   Open
Ctrl+S.............   Save
Ctrl+P.............   Print
Ctrl+<space....   Change Window
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Routing Table Editor

Toolbars Keyboard Shortcuts

New

Open

Save

Print

Print Preview

Aways on top

Transfer to PLC

Transfer from PLC

Check routing table

Activate C-Series Control Link
routing Table

Ctrl+P.............   Print
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GLOSSARY OF TERMS
Actual IO Table The real hardware configuration of the PLC units and slots on power-up.
Address A location in memory where data or programs are stored.  It can also identify

a location of a node on a network.
Application A software program that accomplishes a specific task.  Examples of

applications are CX-Server, CX-Programmer, CX-Protocol and Microsoft
Excel.

ASCII American Standard Code for Information Interchange.
Auxiliary Area An area of PLC memory which normally contains transmission Counters, flags

and control bits.  It also retains the status of the device during power failure.
Baud rate The speed of data transmission in terms of the number of bits per second that

are being sent.
BCD Binary Coded Decimal.
Binary Coded Decimal A data format supported by CX-Server.
Binary A data format supported by CX-Server.  A number system format to the base

2, i.e.  employing the digits 0 and 1.
Bit A digit used in binary notation which can take the value 0 or 1.  The value of

a bit, or combination of bits, can represent the status of a device or can be
used in programming.

Boolean A type of point or symbol where the value can be one of two states.  Essentially
the two states are ‘0’ and ‘1’, but these states can be assigned a meaningful
designation.

Bridge A device connecting local area networks of similar architectures together.
Broadcast address An address held in common by all nodes on a network to which the same data

is transmitted simultaneously.
Bus A communications path along which data can be transmitted or received

between the units connected to it.
Central Processing Unit The part of the PLC which can store programs and data, execute the

instructions in program, and process input and output signals in order to
communicate with other, external, devices.

Clipboard An area within the windows environment where data can be stored temporarily
or transferred between applications.

Command modifier An optional part of an address string indicating the modification to be
performed on the data at that address (within PLC memory) when it is
accessed.

Common link parameter The common words used by all PLCs in a Data Link (within a SYSMAC LINK
system).
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Compact Flash A type of memory card fitted to a PLC.
Components CX-Server is made up of six components accessible from an invoking

application.
Control bit A bit assigned a controlling role in the functioning of a device; its status is set

via a program to achieve this function.
Controller Link A network that can send and receive large data packets flexibly and easily

among the OMRON PLCs.
Counter area An area of PLC memory containing program counters and their related

completion flags.
Counter An area of memory reserved for the purposes of counting the number of times

an event has occurred.
CPU bus link area An area of PLC memory allocated to the CPU bus unit.
CPU type The type of CPU available to a specific device, the amount of memory

available to a PLC varies according to the CPU involved.
CPU Central Processing Unit.
CS1-series Indicates either a CS1G PLC or a CS1H PLC type PLC.
CS2-series Indicates either a CS1G-H or CS1H-H type PLC.
CJ1-series Indicates either a CJ1G or CJ1H type PLC.
CJ2-series Indicates either a CJ1G-H or CJ1H-H type PLC.
C-Series Indicates any one of the following types of PLC: C2000H, C200H, C200HE,

C200HE-Z, C200HG, C200HE-Z, C200HS, C200HX,  C200HX-Z, C1000H,
C**H, C**K, C**P, CQM1, C500, C120, C20, CPM1 (CPM1A/CPM2*).

CV-Series Indicates any one of the following types of PLC: CVM1, CVM1-V2, CV500,
CV1000 or CV2000.  When using SYSMAC NET, CV series PLCs can
operate in either CV mode (where the datagrams contain FINS commands)
or C mode (where the datagrams contain C SYSNET commands).

CVSS A file format supported by the CX-Server Import tool.  CVSS has several file
types which have different information contained in them.

CX-Net Network Configuration tool
This CX-Server tool consists of a suite of programs allowing the
management of Routing Tables and Data Link Tables in OMRON PLCs.

CX-Server An advanced communications management system for OMRON PLCs
providing facilities for software to maintain PLC device and address
information and to communicate with OMRON PLCs and their supported
network types.

CX-Server Project A definition of an OMRON PLC network configuration.  It identifies all
devices and networks within a particular configuration including the areas of
PLC memory (points) that can be read from or written to.
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Cycle time The time interval between read/write cycles at a network node.
Data area An area of PLC memory allocated to the storage of data (not programs).
Data bits Bits representing each character to be transmitted.
Data link A software connection establishing common data areas between PLCs on a

network allowing data to be between these devices.
Data link table A table of the common data memory areas used by the PLCs in a Data Link.
Data location An area of memory identified by an address.
Data memory An area of PLC memory holding only word data.
Data Trace/Time Chart Monitor component

This CX-Server component displays data obtained from the PLC’s
memory areas during program execution.

Datagram A packet of information which can be transmitted across a network containing
routing information plus data.

DDE Dynamic Data Exchange.  A channel through which correctly prepared
programs can actively exchange data and control other applications within
Microsoft Windows.  CX-Server, through the use of the DDE Manager tool,
allows extensive use of DDE functionality.
See also Item, Server, server application and Topic.

DDE management library A dynamic link library within Windows which allows dynamic data exchange
to be employed.

DDE Manager tool A CX-Server tool for allowing transferral of data between PLCs and a client
application using DDE, for example Microsoft Excel.

DDEML Dynamic Data Exchange Management Library.
Debug mode A mode of PLC operation during which any errors arising from the currently

active program will be flagged.  For CV-series PLC only.
Decimal A data format supported by CX-Server.
Default A value automatically set by a program in the absence of user input or on initial

entry to an application; such values can be overwritten.
Destination network address The address of the network to which data is directed.
Destination node number The number identifying the destination node.
Destination node The node (and therefore device) where transmitted data is to be placed.
Device group A class of devices which share similar properties, each group can be sub-

divided into device types.
Device type A type of OMRON PLC.
Device A type of OMRON automation device, either a PLC, Temperature Controller,

Memory Card Writer or PROM Writer.
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Dialogue A window asking for some form of response from the user, usually in the form
of either entering requested information, selecting displayed data, or
confirming an operation.

DLL Dynamic Link Library.  A program file that although cannot be run stand-alone
as an executable, can be utilised by one or more applications or programs as
a common service.  DLL files have a *.DLL extension.  DLL’s comprise a
number of stand-alone functions.

Download Refer to Transfer to PLC.
Drag The act of moving an item on the screen by selecting it with the mouse, and

keeping the mouse button depressed, moving the mouse until the item has
reached the required location.  The mouse button is then released.

Driver The software which controls the communications between a computer and
PLC, translating any information passed between them into a format that the
receiving Device can understand.

Dynamic Data Exchange The method of transferral of data (and possibly instructions) between
applications via the establishment of reference links between them.

Echo test The reflection of a signal along a communications channel in order to check
the accuracy of data transmission by comparing the received data against the
original data at the sending end.

EEPROM Electrically Erasable Programmable Read Only Memory.
Elements The number of address units which start at a specified data location.
End Connection The final communication link between computer and PLC, or in the case of

a Network configuration, gateway PLC to PLC.
End network address The address of the destination network to which communications are directed.
Error status An indication of an error condition found in a system.
Ethernet A 10 MB baseband local area network with each Device attached to the

network having equal status and therefore the ability to transmit as, and when,
required (provided the line isn’t busy).

Even parity The number of 1s in a data transmission is even.
Event frame A structure, predetermined by a protocol, containing specific fields for the

transmission of data.
Exclusive mode PLC mode which allows an application exclusive access to the Device.
Expansion memory The memory available to a CPU in addition to conventional memory.
File memory An area of CPU memory allocated to the storage of data.
File Transfer Protocol Protocol for transferring files between host computers.
FINS Factory Intelligent Network Service.
FinsGateway An OMRON communication type supported by CX-Server.
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Flag An indicator representing the condition of a process, data area or Device.
Floating Point A data format supported by CX-Server.
Folder A structure which organises the files in computer memory or on disk.  Also

known as a ‘directory’.
Frame length The waiting time before data is transmitted across the network
FTP File Protocol Transfer.
Gateway device A Device connecting two networks of different architectures together.
Gateway network address The address of a network acting as a gateway.
Gateway PLC A PLC which acts as a link to another network.
Group A sub-directory within a CX-Server project hierarchy which contains points

and/or further (subsidiary) groups.
GUI Graphical User Interface.  Part of a program that interacts with the user and

takes full advantage of the graphics displays of computers.  A GUI employs
pull-down menus and dialogue boxes for ease of use.  Like all Microsoft
Windows based applications, CX-Server has a GUI for each component and
tool.

Hard disk A disk permanently mounted on its drive.
Hexadecimal A data format supported by CX-Server.
Hierarchy The structure of a CX-Server project from the root directory down through any

sub-directories (groups) to individual points contained within those groups.
High Link A network driver.
Host computer A computer responsible for data management and for overall control of the

system.  Programs and data are downloaded to a PLC from the host computer.
Host link system A system comprising one or more host computers connected to one or more

PLCs by host link units; these units facilitate the transfer of data between the
PLC(s) and the host computer.

Host link unit The interface between a PLC and a host computer.
Icon Pictorial representations of computer resources and functions.  Many icons are

used by CX-Server components and tools as part of the GUI.
IDSC device type An OMRON PLC device supported by CX-Server.
Import tool This CX-Server tool is used for addresses and PLCs defined using the CVSS

and LSS products.
Input bit data area An area of PLC memory containing the status of an input Device.
Input bit The location within memory indicating the status of an input.
Input device A Device which sends signals to a PLC.
Input The signal sent to a PLC from an external device.
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Instruction A statement indicating an operation to be performed and identifies any data
involved in this operation.

Intel Hex A PLC device also known as a PROM Writer.
Interface Hardware or software employed to link the elements within a system, including

networks, programs and computers.
Internal data type The format of the data held at an address in PLC memory; for example, bit or

signed character binary.
Internode test An echo test performed to check the condition of a PLC on a network node.
Invoking application An application such as CX-Programmer and CX-Protocol that utilises

components and tools belonging to CX-Server.
IO bit A bit which can hold data entered into, or received from, the system.
IO Table component This CX-Server component retrieves configured PLCs rack and address data.
IO type Input /Output type.  An attribute of a point or symbol that defines the origin

and destination of the data for that point or symbol.  The data can originate
(be input from) and is destined (is output to) to the internal computer memory,
PLC or DDE target application.

IO Input /Output.
IP address table A table containing the IP addresses for all the devices on the Ethernet.
IP address An address for a device on the Ethernet.
IP router table A table containing the addresses for each interface on a network.
IP Internet Protocol.
Item A unique name for a data item within a topic.
LAN Local Area Network.
Link Relay Area A common data area allowing the transfer of data between PLCs connected

by a Data Link; the information held in this area in the memory of each PLC
is identical.

Link system A system that links PLCs together.
Link unit A unit which connects a device to the network.
Link A connection between two units established either by software or a hardware

device.
Load Placing a program or data into an area of computer or PLC memory.
Local area network A network located within a limited area (normally the user’s premises).
Local network address The address of the network to which a PLC is connected.
Local network number The number of the unit connecting the PLC to the network.
Local table A table containing the details of the networks to which a PLC belongs.
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LSS A file format supported by the CX-Server Import tool.
Mailbox A communications protocol.
Mark parity The parity bit is always set to 1.
Master A controlling device which sends data and/or instructions to a slave device.
Mb Megabites – A means of defining computer memory size.
Memory area Addressable area of storage space in a device.
Memory Card component This CX-Server component manages the file storage to and from PLC memory

cards.
Memory Card Writer A device which writes data to a memory card.
Memory card A data storage medium which can hold both programs and data.
MHz Megaherts.
Micro host link A link to a ‘micro’ device acting as a host.
Microsoft Excel A spreadsheet application.
Microsoft Windows Explorer A file handling application part of the Microsoft Windows suite.
Microsoft Windows A windowing environment that is noted for its GUI, and for features such as

multiple typefaces, desk accessories (such as a clock, calculator, calendar and
notepad), and the capability of moving text and graphics from one application
to another via a clipboard.
CX-Server runs only under Microsoft Windows.  DDE functions
communicating with other applications supported by CX-Server use
Microsoft Windows as a basis.

Modem A device with the ability to convert digital data from a computer into analogue
form and transmit it over a telecommunications line and also to convert
received analogue signals into digital form.

Monitor mode A PLC operational mode which allows the device, during normal execution,
to review the condition of the Data Link (including the PLCs/nodes on that
link).

n A variable number.
Native data format The format in which data is handled by a communications protocol; for

example, ASCII or binary.
Network bridge A unit that connects two or more networks together.
Network parameters Network settings including information such as the maximum number of nodes

permitted on a network and the waiting times between transmissions.
Network Service Board An interface which connects devices (not PLCs) to the network.
Network 1. Part of the PLC configuration, based on the device type.  The number of

Networks available is dependant on the device type.
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2. A number of computers linked together with a central processing point
known as a Server which is accessible to all computers.  Networks affect
CX-Server in that further Network associated options are available if the
computer is Network connected.

Node number Number identifying the device located at a particular node on the network.  The
number can be between 1 and 126, the maximum number of nodes available
on an OMRON network.

Node A position at which a device can be located on the network, consisting of a link
unit mounted to a device or PLC which in turn interfaces with a peripheral
device or a computer.

NSB Network Service Board.
Odd parity The number of 1s in a data transmission is odd.
Offline The status of a device when it is not being controlled by a computer (although

it may be physically connected to it).
OLE Object Linking and Embedding.  Used to transfer and share information

between Microsoft Windows based applications and accessories.
Online The status of a device when it is under the direct control of a computer.
Output Bit data area An area of PLC memory reserved for output bits.
Output bit The location within memory indicating the status of an output device.
Output device A device which receives signals from a PLC.
Output The signal sent from a PLC to an external device.
Packet A unit of information transmitted across the network containing source and

destination address information together with the actual data.
Parity bit A bit transmitted with a packet of data indicating the type of parity check to

be performed.
Parity A type of validation check performed on transmitted information; data can be

tested for either even, odd, none, mark or space parity.  The type of parity
check involved is indicated by the status of the parity bit.

Path The location of a file including the drive, directory name plus any
subdirectories and the file name together with its associated extension.

Peripheral A device which aids system operation rather than being central to its
functioning.

Performance Monitor tool A CX-Server tool for monitoring communications throughput and for
displaying CX-Server’s current performance level (i.e.  a check to see if
CX-Server is becoming overloaded).

Ping test A standard Ethenet communications test.
PLC Error component This CX-Server component displays and manages PLC errors.
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PLC Memory component This CX-Server component allows the user to view, edit and monitor either
channels (words) or individual bits in areas of the PLC.

PLC Setup component This CX-Server component permits the configuration of PLC settings.
PLC Programmable Logic Controller.
Point A point is used to hold a value of a predefined type - Boolean, Integer, Text,

etc.  The contents of a point may be controlled by an object or I/O mechanism
such as DDE.  The contents of a point may control the action or appearance
of an object, or be used for output via an I/O mechanism.

Polling Interrogating a device to check its operational status or whether it is ready to
send or receive data.

Port A device connection point allowing data entry and exit.
Program A set of instructions which are performed by a computer or PLC.
Program memory An area of PLC memory reserved for the storage of programs.
Program mode PLC mode of operation during which the device can be programmed.
Programmable Read Only Memory

An area of memory which can be updated with programs and data only
once after manufacture; once this area has been written to, it can only be
read, not modified.

Project OMRON configuration file inherited from the invoking application.
Refer also to CX-Server Project.

PROM writer A device which writes the programs and data into PROM.
PROM Programmable Read Only Memory.
Protocol A set of rules governing the transmission of data.
PSTN Public Switched Telephone Network.
Public Switched Telephone Network

A communications network carrying voice and data communications over
switched lines.

Rack The apparatus to which a unit is fixed.
RAM Random Access Memory.
Read mode PLC mode which allows data from the PLC to be read but not modified.
Read/write mode PLC mode which allows data to be read from and written to the device.
Refresh parameter table A table identifying the words in a Data Link to be refreshed for an individual

PLC.
Registered IO Table The internal PLC table: this is the one used by the PLC when running,

regardless of the state of the actual hardware.  It can be read and, for CV-
series PLCs, written to by the CX-Server software.
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Relay network address The end network address which a PLC communicates.
Relay node number The number of the network node through which a transmission must pass to

reach another network.
Relay table A table containing the relay network addresses, node numbers and end network

addresses used within a FINS system.
Remote network A network beyond the LAN to which access must be gained through a gateway

or bridge.
Remote Terminals Further units that can be supported by CX-Server via the Sysmac-Bus Master

unit
Reset Turning a bit or signal OFF or changing it to its set value or to zero.
Root The highest level of a directory.
Root group The highest level group in a CX-Server project.
Rotary switch Indicates the method of calling a device by generating a series of pulses.
Routing table A table containing the information necessary to allow communications between

different networks including local and gateway network address details.
Routing The direction of data across a network from its source to its destination.
RS232 Industrial interface standard for serial communications.
RS422 Industrial interface standard for serial communications employing balanced

line circuits.
RTs Remote Terminals.
Run Mode PLC mode of operation during which device information is typically read-only.
Serial Connection A direct connection between computer and PLC.
Server application An application that can be used to view or interact with.

Refer also to DDE and OLE.
Server 1. Server is used in DDE functions to contain a link to an outside application.

Using DDE functions, CX-Server allows the manipulation of an outside
application as specified as the Server.
Refer also to Server application.

2. A Server is the central processing point of a Network which is accessible
to all computers.  Networks affect CX-Server in that further associated
options are available if the computer Network is connected.

Signed Decimal A data format supported by CX-Server.
SIOU Special Input /Output Unit.
Slave A device which receives data or instructions from a master device.
Slots Free areas within a rack to which units can be fixed.
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Software switches Areas of memory employed by an SIO unit used to set operating parameters
(similar in manner to a hardware switch).

Space parity The parity bit is always set to 0.
Special Input /Output Unit A unit designed for a specific purpose.
SRM1 device type An OMRON PLC device supported by CX-Server.
Step Area An area of PLC memory containing a flag indicating the status of steps used

within a program.
Stop bits Bits indicating the end of transmission of each set of data bits; normally one

or two bits, they indicate the delay time between sending successive
characters down the line.

Symbol An address that has been given a name to make the address information more
flexible.  Symbols are inherited by CX-Server by the invoking application.

SYSMAC LINK OMRON high speed industrial network (either co-axial or fibre optic).
SYSMAC NET OMRON high speed optical LAN which can be of type C SYSMAC NET or

CV SYSMAC NET.
SYSMAC WAY OMRON network.
System area An area of memory used for controlling and managing a unit.
System configuration An arrangement of units, for example network, computers and PLCs.
Tagged database A file format supported by the CX-Server Import tool.  The Tagged database

is also an export format of the CX-Server Import tool.
TAPI Telephony Application Programming Interface.
Target PLC The PLC to which information or instructions are directed.
Taskbar An integral part of Microsoft Windows which allows Microsoft Windows

based applications to be started.  CX-Server tools are run from the Taskbar.
TCP/IP Transmission Control Protocol/Internet Protocol.
Temperature Controller An OMRON device.
Temporary Relay Area An area of PLC memory containing instructions which can be loaded at a later

point for use with other instructions.
Text 1. A file format supported by the CX-Server Import tool.  The Text is also

an export format of the CX-Server Import tool.
2. A data format supported by CX-Server.

Timer area An area of PLC memory containing program timers and their related
completion flags.

Toolbus A network, either C-Toolbus or CV-Toolbus, allowing communications with
a device via the serial COM port of a personal computer (in a similar manner
to SYSMAC WAY).  Data is transmitted along the network in binary format.
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Tools CX-Server is made up of four tools.
Topic The name of an aspect of a service application which identifies where a

reference link is to be incorporated; for example, within Excel the topic would
be the name of the worksheet to be used.

Transceiver A device which can receive and transmit data.
Transfer from PLC The transfer of a program or data to a host (either a computer or a programming

device) from a lower-level (or slave) device.
Transfer to PLC The transfer of a program or data from a host (either a computer or a

programming device) to a lower-level (or slave) device.
Transition Area Contains flags indicating when a transition is ON or OFF
Transmitter A device which sends out signals.
UDP User Datagram Protocol.
Unit number A number identifying an individual component of an OMRON PLC system

configuration.
Units A component of an OMRON PLC system configuration.
Unknown The operating mode of a PLC that cannot be connected to.
Upload See Transfer from PLC.
User Datagram Protocol Protocol which directs information across a network to port numbers rather

than to IP addresses.
Word A 16 bit unit of data memory.
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