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GFI FAXmaker - an overview

Introduction to GFI FAXmaker

GFI FAXmaker is a fax server that enables you to send and receive
faxes via your email infrastructure. GFI FAXmaker for
Exchange/SMTP integrates with Microsoft Exchange Server
2000/2003/2007/2010/5.5, Lotus Notes and with most popular
SMTP/POP3 Mail servers and consists of:

 A Fax Server service which handles the sending and receiving of
faxes via the fax hardware.

 An Email2Fax gateway service that retrieves the faxes to be sent
via a sink or pop3 and sends inbound faxes and fax transmission
reports via SMTP.

 A fax printer driver and a fax message form which allow users to
send faxes via their email client.

The fax message form integrates with the email architecture: It does
not have any direct links with the GFI FAXmaker Fax server software.

How to deploy GFI FAXmaker for Exchange/SMTP 14

GFI FAXmaker has a very flexible SMTP based architecture enabling
you to deploy the fax server in a way that best suits your network and
type of mail server. You can also choose whether you want to install
GFI FAXmaker on your mail server or whether you want to install it on
a dedicated machine.

NOTE 1: For Microsoft Exchange Server 5.5, you must always deploy
GFI FAXmaker on a dedicated machine.

NOTE 2: Since GFI FAXmaker does not require a lot of resources it
can run in the background on your mail server machine. It is however
often considered good practice to separate your mail server from fax
device hardware such as Brooktrout cards or ISDN cards. The choice
will probably depend on the size of your network.

It is recommended that for smaller networks, GFI FAXmaker is
deployed on the mail server, whilst for larger networks GFI FAXmaker
should be deployed on a dedicated machine. This separate machine
does not need to be exclusive to GFI FAXmaker.

How GFI FAXmaker works with Exchange
2000/2003/2007/2010

If you have Exchange 2000, 2003, 2007 or 2010 as your mail server
you can choose to install GFI FAXmaker on the mail server machine
itself or on a separate machine.



2  GFI FAXmaker - an overview GFI FAXmaker 14.3 for Exchange/Lotus/SMTP

Figure 1 - GFI FAXmaker installed on the Exchange 2000/2003/2007/2010 server

When installed directly on mail servers running Microsoft Exchange
2007/2010, GFI FAXmaker will automatically setup ‘Foreign’ and
‘Receive’ connectors to capture fax requests. When installed directly
on mail servers running MS Exchange Server 2000/2003, GFI
FAXmaker uses a ‘sink’ to capture fax requests.

Following the installation, no further configuration is required. The
connectors and sinks will automatically forward all fax messages to
GFI FAXmaker.

Figure 2 - GFI FAXmaker installed on a dedicated server

GFI FAXmaker can also be installed on a dedicated machine which is
not running MS Exchange Server. To achieve this in environments
where mail servers are running on Exchange server 2000 and 2003
you must:
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1. Install GFI FAXmaker on the fax server machine (which will require
the IIS SMTP service to be installed). The fax server software and a
sink for the IIS SMTP service will be automatically installed.

2. Run the GFI FAXmaker set-up again this time on the Exchange
server. This will create a standard SMTP connector, which will forward
fax requests to the GFI FAXmaker fax server. Alternately, you can
create an Exchange SMTP connector manually as described in ‘The
Exchange 2000/2003 SMTP connector’ chapter.

To install GFI FAXmaker on a dedicated machine (i.e. machine which
is not running MS Exchange Server software) in an environment
where email services are handled through Exchange Server
2007/2010:

1. Install GFI FAXmaker on the target machine.

2. On your Exchange Server 2007/2010 manually setup the ‘Send’
and ‘Receive’ connectors which will relay fax queries to GFI
FAXmaker. For more information on how to achieve this refer to ‘The
Exchange 2007/2010 connectors’ chapter.

Installing GFI FAXmaker on a dedicated machine retains Microsoft
Exchange Server standard setup - no changes to active directory are
made and no custom software will be running on Exchange server.

How it works at the client side

All faxes sent by users from the GFI FAXmaker Fax Message form or
the New Message form of Microsoft Outlook are sent via Microsoft
Outlook using the MAPI format [FAX:<number>]. The standard SMTP
connector (which is created by GFI FAXmaker during set-up and is a
completely standard Exchange connector) forwards the faxes via
SMTP to the GFI FAXmaker Fax server.

How GFI FAXmaker works with Exchange 5.5

Figure 3 - GFI FAXmaker installed on a dedicated machine if using Exchange Server 5.5

GFI FAXmaker should be installed on a dedicated machine in
installations where Microsoft Exchange Server 5.5 is being used. This
dedicated machine must be running Windows 2000 or higher and the
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IIS SMTP service. You must also create a routing rule to forward all
mail sent to the domains faxmaker.com and smsmaker.com to the
GFI FAXmaker Fax server. For information on how to create this rule
refer to the ‘Configuring Exchange Server 5.5 for faxing’ chapter.

The GFI FAXmaker fax server receives the faxes via SMTP. Through
the use of a sink it captures the fax, converts it to fax format and
faxes it. Subsequently, it will mail back a delivery report to the user.
The same principle applies to SMS messages.

NOTE: If Active Directory is being used, you must ensure that the
email address of each GFI FAXmaker user is provided in Active
Directory. Exchange Server 5.5 does not do this automatically. If you
don’t use Active Directory you have to configure the name and email
address of the GFI FAXmaker users.

How it works at the client side

All faxes sent by users from the GFI FAXmaker Fax Message form
are sent via Microsoft Outlook using the SMTP format
number@faxmaker.com. If the user wants to send a fax using the
New Message form of Microsoft Outlook, the user has to address the
email to number@faxmaker.com. Exchange 5.5 is then configured to
forward mails sent to the faxmaker.com domain to the GFI FAXmaker
fax server via SMTP.

How GFI FAXmaker works with Lotus Notes/Domino

If you have Lotus Notes or Domino you can choose to install GFI
FAXmaker on the mail server machine itself or on a dedicated
machine.

Figure 4 - GFI FAXmaker installed on the Lotus Notes machine

In either case GFI FAXmaker retrieves faxes via a dedicated POP3
mailbox. You will need to create a dedicated mailbox and configure
GFI FAXmaker to retrieve the faxes from that mailbox. For more
information refer to ‘Configuring GFI FAXmaker for Lotus Notes’
chapter.
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Figure 5 - GFI FAXmaker installed on a separate machine

If Active Directory is in use, you must ensure that the email address of
each GFI FAXmaker user is supplied in Active Directory. If you don’t
use Active Directory you have to configure the name and email
address of the GFI FAXmaker users.

How it works on the client side

All faxes sent by users from the GFI FAXmaker Fax Message form
are sent via the email client to the dedicated fax mailbox. If the user
wants to send a fax using the new message form of the Lotus Notes
client, the user has to address the email to number@FAX. Lotus
Notes will forward the mail to a POP3 mailbox. This “fax mailbox”
must be dedicated to the fax server. GFI FAXmaker will download the
email, convert it to fax format and fax it. Then it will mail back a
delivery report to the user. The same principle is applied to SMS
messages.

How GFI FAXmaker works with an SMTP/POP3 server

If you have an SMTP/POP3 server such as VPOP3 or Mdaemon you
have to choose if you want GFI FAXmaker to collect faxes to be faxed
via POP3 or if you want to configure your mail server to forward the
faxes via SMTP to the GFI FAXmaker server.

If you choose to forward the faxes via SMTP then GFI FAXmaker
must be installed on a separate machine (see figure 3). If you use an
SMTP/POP3 server you can install GFI FAXmaker on the mail server
machine it self (See figure 4). This however does not allow users to
send faxes directly from their email client.

If Active Directory is in use, ensure that the email address of each GFI
FAXmaker user is provided in Active Directory. If you don’t use Active
Directory you have to configure the name and email address of the
GFI FAXmaker users.

How it works on the client side

If GFI FAXmaker is configured to retrieve faxes via POP3, all faxes
sent by users from the GFI FAXmaker Fax Message form are sent via
the email client to the dedicated fax mailbox. GFI FAXmaker will
download the email, convert it to fax format and fax it. Then it will mail
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back a delivery report to the user. The same principle is applied to
SMS messages.

If you have configured your mail server to forward all faxes via SMTP
to the separately installed GFI FAXmaker fax server, then all faxes
sent by users from the GFI FAXmaker Fax Message form will be sent
via the email client using the SMTP format number@faxmaker.com. If
the user wants to send a fax from their email client, then address the
email to number@faxmaker.com. The SMTP/POP3 mail server is
then configured to forward mails sent to the faxmaker.com domain to
the GFI FAXmaker fax server via SMTP. The GFI FAXmaker fax
server receives the faxes via SMTP and using a sink captures the fax,
converts it to fax format and faxes it out. Then it will mail back a
delivery report to the user. The same principle is applied to SMS
messages.

How GFI FAXmaker works with multiple mail servers

Figure 6 - GFI FAXmaker with multiple mail servers

If you have a large network with multiple mail servers that are
independent from each other, you can configure your mail servers to
forward faxes from all mail servers via SMTP (using the same
methods as described above for each type of mail server). This
enables you to provide fax services to users on several mail servers
with a single GFI FAXmaker server.
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How GFI FAXmaker works with an ISP hosted mail server

Figure 7 - GFI FAXmaker with hosted mail server

If you have a small network and don’t run your own mail server or
have a hosted mail server setup, you can still deploy GFI FAXmaker.
You however need to install the IIS SMTP service on the GFI
FAXmaker server. The GFI FAXmaker client software will forward all
faxes directly to the GFI FAXmaker Fax server via SMTP.

The GFI FAXmaker fax server receives the faxes via SMTP. Through
the user of a sink, the fax is captured, converted it to fax format and
faxes out. The same principle is applied to SMS messages. Delivery
reports and inbound faxes will be forwarded to the user’s email
address at the ISP mail server. Because of the small size of faxes
files and relatively small amount of email traffic created by GFI
FAXmaker, this will not pose a significant overhead on your internet
link.

How it works on the client side

All faxes sent by users from the GFI FAXmaker client will be sent to
the SMTP format number@faxmaker.com. The GFI FAXmaker client
will know the name of the fax server machine and submit the fax
directly to the GFI FAXmaker server. The user cannot send a fax from
his email client.
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How users send a fax

The user can send a fax in the following ways:

Screenshot 1 - The GFI FAXmaker Fax Message form

1. Create or open a document in any Windows application and print it
to the ’GFI FAXmaker printer’. This will convert the document to fax
format and activate the GFI FAXmaker Fax Message form in which a
fax number and other options can be specified

2. Send directly from the GFI FAXmaker Fax Message form from the
GFI FAXmaker program group.

3. Open an email client, create a new message, enter the text to
send, add attachments if needed and address the fax to
number@faxmaker.com, or if the user is on Exchange Server, select
the recipient from the Microsoft Outlook Contacts.

4. From any Microsoft Office application, Use the Send To command,
which can be found in the file menu. This will attach the document
created to a new mail message after which the fax can be sent as per
option 3.
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Screenshot 2 - For each fax or sms, a transmission report is sent to the user

How users view received faxes

All received faxes are forwarded to the user via email. The email will
contain a fax report and the fax file included with the email as an
attachment.
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Screenshot 3 - Faxes are received in the inbox

Faxes can be attached in several formats, of which the GFI
FAXmaker fax format or the adobe PDF format are the recommended
options. If using the GFI FAXmaker fax format, the fax viewer is used
to view the fax. If using PDF, the fax can be opened in any PDF
viewer.

Screenshot 4 - Viewing a fax in the Adobe PDF reader
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Installing GFI FAXmaker

System Requirements

Before you install GFI FAXmaker, please ensure that the following
requirements are met.

GFI FAXmaker FAX Server:

 A Windows 2000, 2003, 2008 (including R2) server or Windows
XP Professional machine with at least 256 MB of RAM and a
1Ghz processor.

NOTE: For the Brooktrout SR140 FOIP solution the minimum
specifications are 512 MB of RAM and a 2.6Ghz processor.

 A professional fax device: A Brooktrout TR 114, TR 1034 or
Trufax fax board, an EICON DIVA PRO/SERVER fax card or an
AVM active fax card. You can use class 2 or 2.0 fax modems
using either the Microsoft or the GFI fax modem drivers, although
we strongly recommend using one of the fax devices listed above.
For a complete list of supported devices go to
http://kbase.gfi.com/showarticle.asp?id=KBID001220.

NOTE: For more information related to the installation of fax devices
refer to the Fax Device installation manual available from the GFI
website.

 If you are installing GFI FAXmaker on a separate machine other
than the mail server, the IIS SMTP service is required. The IIS
SMTP service is included in every Windows distribution. To verify
the Installation of the SMTP Service: From: Control Panel ► 
Add/Remove Programs ► Add/Remove Windows
Components ► Internet Information Services (IIS) component
► Details. Verify that the SMTP Service check box is selected. If
not selected, click to select it, click OK, and follow the installation
directions that are displayed.

 If you are using Microsoft Exchange Server, and are not installing
the fax server on the Exchange server machine, you must install
Microsoft Exchange Server MAPI Client and Collaboration Data
Objects 1.2.1 is required to be installed on the GFI FAXmaker
machine. Download the Microsoft Exchange Server MAPI Client
and Collaboration Data Objects 1.2.1 from:

http://www.microsoft.com/downloads/details.aspx?FamilyID=e17e
7f31-079a-43a9-bff2-0a110307611e&DisplayLang=en

 If you are using Microsoft Exchange Server 2007/2010, ensure
that Hub Transport role and Microsoft Messaging API and
Collaboration Data Objects version 1.2.1 are installed.

http://kbase.gfi.com/showarticle.asp?id=KBID001220
http://www.microsoft.com/downloads/details.aspx?FamilyID=e17e7f31-079a-43a9-bff2-0a110307611e&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=e17e7f31-079a-43a9-bff2-0a110307611e&DisplayLang=en
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 If using Windows 2000, ensure you have Service Pack 3 or later
installed.

 If you will be using HTML cover pages, ensure that you have
Internet Explorer 6 installed.

 Disable anti-virus software from scanning the GFI FAXmaker &
other relevant directories both during installation and GFI
FAXmaker operation. AV products are known to both interfere with
normal operation as well as slow down any software which
requires file access. In fact Microsoft does not recommend
running file based anti virus software on the Exchange Server. For
more information:
http://kbase.gfi.com/showarticle.asp?id=KBID001523.

 Make sure that backup software is not backing up any of the GFI
FAXmaker directories at any point.

GFI FAXmaker client:

 Windows 7/Vista/XP/2000/2003

 If using Windows 2000, ensure you have Service Pack 3 or later
installed.

Installing the GFI FAXmaker server software

NOTE: Before installing GFI FAXmaker, ensure that you are logged
on as Administrator and that all the other Windows application are
closed.

1. Run GFI FAXmaker set-up by double-clicking on the installation file.
Click Next to start installation.

2. Select the language in which you want GFI FAXmaker to install and
click OK. A welcome dialog will appear. Click Next to continue setup.

3. In the License agreement dialog box, review the license agreement
and click Yes to continue the installation.

4. Enter your name, company name and License key. If you are
evaluating the product, leave the default ‘Evaluation’ key. Click Next.

http://kbase.gfi.com/showarticle.asp?id=KBID001523
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Screenshot 5 - Selecting what components to install

5. Set-up will ask you which components you want to install. If you are
installing GFI FAXmaker on the Exchange 2000/2003/2007/2010:
server machine, you will need to tick both the GFI FAXmaker Fax
server component and the Exchange 2000/2003 SMTP connector
component. If you are installing it on a separate machine, or are not
using Exchange 2000/2003/2007/2010: just install the GFI FAXmaker
Fax server component. (Afterwards re-run set-up on the Exchange
server machine to install just the Exchange connector)

Screenshot 6 - Account name for services
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6. Provide an administrator account and password to install the GFI
FAXmaker services.

NOTE: If you change your password after installing GFI FAXmaker,
you must update the password for the GFI FAXmaker services from
the Services Control Panel as well; otherwise the GFI FAXmaker
services will no longer start

7. Choose the destination location for the Fax server modules and
click Next.

NOTE: GFI FAXmaker will need approximately 40 MB of free hard
disk space. In addition to this you must reserve approximately 200-
300 MB for fax data storage during operation. The actual disk space
used depends on the quantity of faxes being sent.

Screenshot 7 - Restart the IIS SMTP service

8. Set-up will need to restart the IIS/Exchange SMTP service. Click
Next.

9. Set-up will now copy the files to the GFI FAXmaker destination
folder. After the files have been copied, set-up will confirm the
installation of the GFI FAXmaker and NetprintQueue2fax printer
driver. Click Next to proceed.



GFI FAXmaker 14.3 for Exchange/Lotus/SMTP Installing GFI FAXmaker  15

Screenshot 8 - Confirm printer driver installation

10. Windows will confirm installation of uncertified drivers (Almost no
vendors certify them because it’s a very time intensive and
bureaucratic process). Click Continue Anyway to proceed.

After this, you have the option of running the GFI FAXmaker
configuration wizard, which will guide you through the elementary
steps of setting up GFI FAXmaker. Click Finish to launch the GFI
FAXmaker Configuration Wizard.
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Installing the GFI FAXmaker server software on 64-bit (x64)
computers

Installing GFI FAXmaker on x64 systems installs the
NetPrintQueue2FAX printer driver for 64-bit operating systems. In this
case, for 32-bit clients to use the NetPrintQueue2Fax driver the 32-bit
version of the same drivers must be also stored on the 64-bit
machine. The 32-bit clients will then be able to retrieve the 32-bit
drivers from the 64-bit machine on their first use of the
NetPrintQueue2FAX printer driver.

1. To install GFI FAXmaker on x64 systems, follow the installation
procedure specified in the ‘Installing the GFI FAXmaker server
software’ section in this chapter.

Screenshot 9 - Installing printer drivers for 32 bit computers on a 64 bit server

2. When prompted select whether you want to install also the 32-bit
version of the GFI NetPrintQueue2FAX printer driver for faxing
through 32 bit machines.

3. Click Next to continue.

NOTE 1: During 32-bit driver installation, GFI FAXmaker will prompt
you to insert the Microsoft Windows Server 2003 CD (32-bit version).
This is required to install 32-bit Windows Kernel Drivers.

NOTE 2: If Windows Server 2003 CD is not available, unselect the
‘Install 32-bit drivers for GFI NetPrintQueue2FAX’ option. GFI
FAXmaker will automatically copy the GFI NetPrintQueue2FAX 32-bit
drivers in “<product_folder>\NetPrintQueue2Fax_Drivers” for future
use.
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Running the GFI FAXmaker configuration wizard

Screenshot 10 - The GFI FAXmaker configuration wizard

The GFI FAXmaker Configuration Wizard assists you through the
basic steps of configuring GFI FAXmaker. Click Next to start the
wizard.

Step 1: Setting up the sending options

Screenshot 11 - Setting up the sending options
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When GFI FAXmaker is not installed on the same machine running
Microsoft Exchange 2000/2003/2007/2010, setup will prompt you to
configure the sending options.

If the mail server is configured to forward faxes and SMSs to the
machine where GFI FAXmaker is installed, then select My email
server will forward faxes and SMSs to this GFI FAXmaker
machine. For this option, the mail server must be configured to relay
all mail addressed to <number>@faxmaker.com and
<number>@smsmaker.com to the machine where GFI FAXmaker is
installed.

If you want to set-up GFI FAXmaker to download faxes and SMSs
from a POP3 mailbox, then select GFI FAXmaker will download
faxes and SMSs from a POP3 mailbox. In this case, you have to
enter the POP3 server name and the Account and password
accordingly.

Screenshot 12 - The wizard will prompt you for a mail server name

After you have configured the mail server, click Next. The wizard will
connect to the specified mail server to ensure the mailserver responds
at the IP address provided

NOTE: Authentication settings are only tested at the end.

For more information how GFI FAXmaker integrates with each type of
mail server, refer to ‘How to deploy GFI FAXmaker for
Exchange/SMTP’ chapter.
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Step 2: Configuring the fax devices

Screenshot 13 - Selecting the type of fax hardware to be used with GFI FAXmaker

The configuration wizard will now prompt you for fax device (s) you
want to use with GFI FAXmaker.

If you use Fax modems:

GFI FAXmaker will attempt to detect modems already installed on
your machine. GFI FAXmaker will first try to detect any Microsoft Fax
drivers that are installed.

Screenshot 14 - Detecting modems present on your machine
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If you use ISDN or Brooktrout cards

NOTE: If you use ISDN or Brooktrout fax cards, ensure that you have
properly installed the cards first. You will have to configure the fax
lines manually. Click ‘Configure lines’ and configure the fax line(s).

Screenshot 15 - Configuring lines if you are using Brooktrout or ISDN fax cards

Step 3: Specifying the fax administrator and users

After you have installed and configured the fax devices you have to
specify the fax users.

NOTE: This can be changed but you at this point you must specify at
least one fax user.

GFI FAXmaker is licensed based on the number of users that receive
or send faxes. The procedure is different depending on whether you
have Active Directory or not:

If you have Active Directory

If you use Active Directory on your network (i.e. you have one or more
Windows Server 2000 machines or higher), GFI FAXmaker will
connect to Active Directory and allow you to specify GFI FAXmaker
users and user based rules. This is done by selecting users from
Active Directory.

GFI FAXmaker relies on the email address specified for each user in
active directory. If you use Microsoft Exchange 2000/2003/2007/2010,
or any Active Directory integrated mail server (including Windows
2003 POP services) this email address is automatically filled in
correctly.

NOTE: If you use Exchange 5.5 or a non active directory integrated
mail server, you are required to provide a correct email address for
each user that you want to ‘fax-enable’ in the Email field of the user
properties. This can be done from Active Directory Users and
Computers.
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Screenshot 16 - Selecting administrator and users from Active Directory

The GFI FAXmaker wizard will load the standard ‘Select Users or
Groups’ dialog and allow you to specify a fax user.

Screenshot 17 - Specifying users

After this, the GFI FAXmaker wizard will show the selected user. You
can proceed to specify additional fax users by clicking on the Add
users button. You can also specify users later on in the GFI
FAXmaker configuration.

If you don’t have Active Directory

If you don’t have a Windows 2000 Server or higher (therefore no
Active Directory), you will have to configure the GFI FAXmaker users
by importing the users from a Windows machine, from a CSV list or
by creating them manually. The latter can only be done from the
configuration after you have completed the GFI FAXmaker
configuration wizard. To import the users from a Windows machine:
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1. GFI FAXmaker will default to the domain controller machine and list
all available users. You can enter a different server name and click
‘list users’ if you want to import users from another machine.

Screenshot 18 - Importing GFI FAXmaker users from Windows NT or local user database

2. All retrieved users will be listed in the ‘Users on server list’. Select
which users can use GFI FAXmaker and click on the Select button.

3. GFI FAXmaker requires a valid email address for each GFI
FAXmaker user. GFI FAXmaker can automatically append your
domain name to each user that you import, using the ‘Append domain
name’ function at the bottom of the GFI FAXmaker user import dialog.
This function will append your domain to the windows logon name. If
your email addresses do not follow this convention, you will have to
specify the correct email address in the User’s personal tab. To do
this, double-click on the user name, select the personal tab, and
specify the email address in the Email address edit box.

4. Click OK to proceed with the import.

NOTE: GFI FAXmaker will automatically configure default settings for
each user.
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Step 4: Test the mail server connection and start services

Screenshot 19 - The GFI FAXmaker configuration wizard will start the GFI FAXmaker services

After you have configured the fax lines and the GFI FAXmaker users,
GFI FAXmaker will start the GFI FAXmaker fax service and the GFI
FAXmaker MTA (Message Transfer Agent). Click Next to continue.

Screenshot 20 - Testing your mail server connection - a successful test

The wizard will now test the mail server connection. It attempts to
send a mail via your mail server to the configured fax administrator.
You will need to check if the mail actually arrived in the fax
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administrator mailbox. The test’s success or failure is displayed in the
dialog box.

Screenshot 21 - Mail server test failed

If the test fails, the error condition will be displayed in the dialog. The
screenshot shows an example error highlighted. The most common
errors and their resolution are:

 CDO Error: “The transport failed to connect to the server.”

o Solution: SSL has to be used but the server is not configured
for use with SSL. Disable SSL or configure SSL on the mail
server. Also occurs if the IP address of the mail server has not
been configured correctly, the connection is being blocked by
a firewall or by the mail server. Check firewall settings and if
incoming connections from the GFI FAXmaker server are
allowed.

 CDO Error: “The server rejected one or more recipient addresses.
The server response was: 550 5.7.1 Unable to relay for <email
address>”

o Solution: Mail server refused the domain of the recipients
address following a successful GFI FAXmaker server
connection. Occurs because relaying is not allowed from the
GFI FAXmaker server. Configure the SMTP server to accept
relaying from the GFI FAXmaker machine's IP or allow
relaying for the internal email domain only.

 CDO Error: “The server rejected the sender address. The server
response was: 530 5.7.3 Client was not authenticated.”

o Solution: Authentication details missing. Configure
authentication details from the SMTP server configuration
dialog in the GFI FAXmaker Configuration Wizard. You can
also configure the SMTP server to accept anonymous SMTP
connections (if the mail server is only available to the intranet).
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 CDO Error: “The message could not be sent to the SMTP server.
The transport error code was 0x80040217. The server response
was not available”

o Solution: Authentication details invalid. Configure
authentication details from the SMTP server configuration
dialog in the GFI FAXmaker Configuration Wizard.

If the mail server test was successful, you can now check if the fax
server is up and running from the GFI FAXmaker monitor node in the
GFI FAXmaker configuration. Start up the GFI FAXmaker
configuration and check the fax server status.

Screenshot 22 - GFI FAXmaker FAX Server monitor with services running

NOTE 1: You can configure GFI FAXmaker in more detail using the
GFI FAXmaker configuration program.

NOTE 2: If an administrator account or password is not provided the
service will not start. Reconfigure the service user in the services
control panel (under administrative tools) and attempt to restart the
service.

Step 5: After running the GFI FAXmaker wizard

After you completed the GFI FAXmaker wizard and verified that the
fax server is running:

 If you have installed GFI FAXmaker on a Microsoft Exchange
2000/2003/2007/2010 server machine, go to the chapter ‘Installing
the clients’.

 If you have not installed it on the Exchange Server
2000/2003/2007/2010 machine, you must go to the paragraph
‘Installing the connector on a remote Exchange server machine’.
After this you can proceed to install the clients.

 If you have an Exchange 5.5 server go to the chapter ‘Configuring
Exchange Server 5.5 for faxing’. After this you can proceed to
install the clients.

 If you have Lotus Notes go to the chapter ‘Configuring GFI
FAXmaker for Lotus Notes’. After this you can proceed to install
the clients.
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 If you have a SMTP/POP3 server go to the chapter ‘Configuring
an SMTP/POP3 server for faxing’. After this you can proceed to
install the clients.

Installing the connector on a remote Exchange server machine

If you are running Exchange Server or 2003 but opted to install and
run GFI FAXmaker on another machine, then you must also launch
the GFI FAXmaker installation on your Exchange server machine.
This is required to automatically create a sink and install an SMTP
connector through which fax requests will be relayed to GFI
FAXmaker.

When GFI FAXmaker installation is launched on the Exchange server,
you will be prompted to specify which GFI FAXmaker components to
install. Select only the option ‘Exchange 2000/2003 SMTP connector.

Screenshot 23 - Installing only the Exchange connector

NOTE: You can also opt to manually create the connector instead of
launching GFI FAXmaker setup on Exchange server. For a detailed
description of how to do this, refer to ‘The Exchange 2000/2003
SMTP connector’ chapter.

Upgrading from earlier GFI FAXmaker versions

To upgrade a GFI FAXmaker installation to the latest version while
retaining all settings, launch the installation file and follow the
instructions in Installing the GFI FAXmaker server software. The
setup will automatically uninstall the old installation and install the
latest version.

NOTE: This is supported only for versions 12 or higher. For earlier
versions, it is recommended to uninstall and reconfigure GFI
FAXmaker.
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Entering your License key after installation

If you have purchased GFI FAXmaker, you can enter your License
key in the General ► Licensing node.

During evaluation all features within GFI FAXmaker are available. The
initial evaluation license provides a 10-day evaluation period. This can
be extended to 30 days by entering a 30-day evaluation license key.
This license key is emailed to the address specified when
downloading GFI FAXmaker from the GFI website. Upon expiry, a
license key must be purchased to be able to once again access GFI
FAXmaker features. GFI FAXmaker does not need to be uninstalled
and reinstalled when entering a purchased license key.

NOTE: You must license GFI FAXmaker for the number of users that
will send and receive faxes.
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Installing clients

Introduction to the GFI FAXmaker client software

After installing the Fax server, you can already send faxes by
addressing and sending an email correctly. If users however are
required to send faxes by printing to the GFI FAXmaker printer driver,
they must install the GFI FAXmaker client.

The GFI FAXmaker client software consists of a fax printer driver, fax
viewer and the optional GFI FAXmaker Fax message form. The GFI
FAXmaker Fax message form offers an easy way for users to specify
fax options. During installation, you can choose whether the Outlook
New Message form should appear when the user prints to the GFI
FAXmaker printer driver, or the GFI FAXmaker Fax message form.
The GFI FAXmaker Fax message form also retrieves the company
name of the recipient, so the cover page always has the company
name filled in. If using the Outlook new message form, the company
name will only be filled in if the GFI FAXmaker fax server could
retrieve the company name of the recipient via a configured public
contact list.

The GFI FAXmaker Fax message form submits the fax via SMTP to
the GFI FAXmaker fax server, so it should know the mail server name
as well as the email address of the user. No communication takes
place between client and the fax server (mail is delivered via your mail
server), so there are no scalability issues.

NOTE: For more information on how to use the GFI FAXmaker client
software please refer to the FAXmaker client software user manual
available at: http://www.gfi.com/fax/fax14usermanual.pdf.

http://www.gfi.com/fax/fax14usermanual.pdf
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Installing the client software

NOTE: GFI FAXmaker Client software installation requires that you
are logged on with administrative privileges.

1. Launch the installation file on the client machine.

Screenshot 24 - Choosing the language

2. Select the GFI FAXmaker language.

NOTE: Setup remains in English however if you select a different
language the GFI FAXmaker Fax Message form will appear in the
selected language after installation.
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Screenshot 25 - Which Message form

3. You will be prompted whether you want the Outlook New message
form or the GFI FAXmaker New Fax form to appear after a user prints
to the GFI FAXmaker printer driver. You can also choose both - in this
case the Outlook New Message form will appear when the user prints
to the GFI FAXmaker printer driver, however the GFI FAXmaker New
Message forms will be accessible from the GFI FAXmaker program
group. The user can then use this form in case he wants to set
particular options which are more difficult to do from the Outlook New
Message form.

Click on Next to proceed with setup.
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Screenshot 26 - Specifying mail server

4. If you selected the GFI FAXmaker New Message form or both, set-
up will prompt you for the type and name of your Mail Server. If you
select Lotus Notes or SMTP/POP3 Mail server, you will also have to
enter the name of the fax mailbox. If required, tick the ‘My mail server
requires authentication’ tick box to configure authentication options.

Click on Next to proceed with setup.

Screenshot 27 - Optional authentication

5. Enable SSL if you want to use SSL certificates (does not require
authentication to be enabled). If you want to authenticate against the
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mail server, enable ‘Use SMTP Authentication’. Enable ‘Logon using
Secure Password Authentication (SPA)’ to have the GFI FAXmaker
Fax Message form use the current Windows account name and
password credentials. Note that SPA requires that your mail server
supports SPA. If your mail server does not support SPA specify
account name and password to use.

NOTE 1: Only configure authentication if your mail server requires it
and if you are familiar with the settings.

6. Select the installation location and click Next. Set-up copies the
files to the GFI FAXmaker destination folder.

7. Set-up will now confirm the installation of the GFI FAXmaker printer
driver. Click ‘Next’ to proceed.

Screenshot 28 - Confirm printer driver installation

8. Windows will confirm installation of uncertified drivers (Almost no
vendors certify them because it’s a very time intensive and
bureaucratic process). Click Continue Anyway to proceed. There will
be short delay during this installation.

GFI FAXmaker client is now installed.

Specifying email address

The first time the user starts the GFI FAXmaker Fax Message form,
the GFI FAXmaker client will retrieve the email address of the
currently logged on user from Active Directory.

It will use this email address to send transmission reports. If another
user logs on to the machine, then GFI FAXmaker will query Active
Directory again: The system is fully compatible with a multi user
environment (e.g. on a Terminal Server.)
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Screenshot 29- Specifying the email address

If Active Directory is not present, or GFI FAXmaker fails to obtain the
email address, the user will be prompted for his/her email address.

Set-up Command line options

If you want to run the GFI FAXmaker client set-up in unattended
mode, you can specify the following options on the command line of
the MSI file. MSI files can be run from the command line with the
following command: msiexec /i "<full path to client MSI file>"

‘SILENTPRINTERDRIVER=1’: Installs the printer driver silently. Note
that an older driver is installed, in order to bypass the windows
uncertified driver install dialog. If using the parameter, make sure that
the policy to prevent Kernel mode printer drivers is not set.

‘USEOUTLOOKFORM=1’: Configures the Outlook New Message
form to pop up instead of the GFI FAXmaker New Message Form,
after a user prints to the GFI FAXmaker printer driver.

‘LANGUAGE=<language:<insert language> >’: Specifies the
language of the client to be installed.

If using an SMTP routing rule (sink mode, i.e. with Exchange
2000/2003/2007/2010/5.5 or another mail server), you just have to
specify the mail server machine name, using the following command
line parameter:

MAILSERVER=<mail server IP or machine name>

If using an SMTP/POP3 server or an ISP hosted mail server, you
must specify the GFI FAXmaker fax server. In this case the faxes are
delivered directly to the GFI FAXmaker machine, not via the mail
server:

FAXSERVER=<fax server IP or machine name>

If you are using the POP3 connector to collect the faxes (mailbox
mode, i.e. Lotus Notes or an SMTP/POP3 mail server, you have to
specify the mail server name and fax mailbox, using the following
command line parameters:

MAILSERVER=<mail server IP or machine name>

FAXMAILBOX=<email address of fax server mailbox>

NOTE: The faxserver and mailserver command line options are
mutually exclusive. The fax mailbox command line option requires the
mailserver command line.
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MAILAUTHENTICATION=<0 or 1>: if the mail server requires
authentication set this value to 1 and specify the following
authentication parameters:

 USESSL=<0 or 1>: Enables SSL.

 USEAUTH=<0 or 1>: Enables SMTP authentication.

 USESPA=<0 or 1>: Enables Secure Password Authentication,
which uses the credentials of the currently logged on user to
authenticate against the mail server. Ensure that your mail server
supports this. (Ignored if USEAUTH=0)

 SMTPACCOUNT=<account string>: This account name is used
for SMTP authentication. (Ignored if USEAUTH=0)

 SMTPPASSWORD=<password string>: The password required
for the account above. (Ignored if USEAUTH=0)

Examples

To run msi with command lines, use the following command in the
command prompt:

msiexec /i "<full path to client MSI file>" MAILSERVER=mailsrv
FAXMAILBOX=fax@myinternaldomain.com
LANGUAGE=<language:german>

GFI FAXmaker client user manual

The GFI FAXmaker user manual can be downloaded separately and
distributed to GFI FAXmaker users via email. The GFI FAXmaker
client installation also includes the manual as a help file.

You can download the GFI FAXmaker user manual from the page:
http://www.gfi.com/faxmaker.

Installing the GFI FAXmaker client on Terminal server clients

If you are using Terminal server, and you wish to deploy the GFI
FAXmaker client to all terminal server users, you can use the normal
GFI FAXmaker SMTP or MAPI client. To install the GFI FAXmaker
client on your terminal server:

1. Run the client install directly on the Terminal server machine itself.

NOTE: Setup must not be run from a remote terminal session
window.

2. Launch the setup msi from explorer. Do not run the installation from
Control Panel > 'Add/Remove Programs' since the GFI FAXmaker
client installation is 'Terminal Services aware'. The 'Add/Remove
Programs' should only be used for installations that do not support
Terminal Services.

3. It will detect Terminal server and install the GFI FAXmaker client
accordingly.

http://www.gfi.com/faxmaker.
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Configuring Fax lines

Configuring a fax line

A fax line is a physical telephone line and is linked to a fax device (i.e.
a modem or an ISDN/fax card). Since many fax devices support
multiple lines, and you probably want to set different options per fax
line, you have to set up each fax line individually, and associate a fax
device to each line.

Fax lines are configured from the lines/devices node in the GFI
FAXmaker configuration program. Right-click on the ‘Lines/Devices’
node and select properties to bring up the Lines/Devices dialog. This
dialog shows all installed fax lines and to which device they are
associated.

Screenshot 30 - The Line/Devices dialog

To add a fax line, click Add. The process of adding a fax line is
slightly different depending on whether the fax line is associated to an
ISDN card, a Brooktrout card, XCAPI or a fax modem. Therefore the
process is described in separate paragraphs below. Line options and
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Advanced options are identical for each fax line, independent of what
fax device you are using and these are described at the end of this
chapter.

Setting up fax lines for an ISDN card

Screenshot 31 - Adding an ISDN channel

1. Select the first available fax line number.

2. Select your device type. If you have a 2, 4 or 8 channel ISDN card,
select ‘ISDN BRI CAPI 2.0 devices’. If you have a 30 channel card
select ‘ISDN PRI CAPI 2.0 devices’.

3. In the Physical fax port box, select the channel/port of the device
that you want to use for this fax line.

For example, if you are using an ISDN BRI card, you can select two
channels for each card. If you want to use channel 1, select ISDN1B1.
If you want to use channel 2, select ISDN1B2. (If you are using more
than one ISDN card, you can select ISDN2B1 and ISDN2B2 for the
second card, and so on.) If you wish to copy the settings for a line you
have already configured, tick ‘Copy settings from’ and select the line
from the drop down list.

4. Click OK to proceed with installation.
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Screenshot 32 - GFI FAXmaker Lines/Devices Configuration - Adding ISDN1B1 to the
configuration.

4. Select the ISDN card that you are using in the ISDN type list box.

5. In the MSN/DID numbers list box add the number(s) to be
answered by GFI FAXmaker. You can enter either a full number entry
(i.e. 82733099) or a prefix number. An example of a prefix number
would be entering ‘827330’. In this scenario GFI FAXmaker would
answer all numbers in the range ‘82733000-8273099’. Alternatively
click the Answer All button which will cause GFI FAXmaker to answer
all incoming calls on the ISDN channel.

NOTE: If you do key in any numbers, GFI FAXmaker will not answer
incoming calls

6. If you plan to do DID routing on this channel, go to the advanced
tab and tick the ‘Number of DID/MSN digits to capture’ checkbox. The
number of digits should be set to the size of the range of numbers you
will be capturing. (i.e. For range of 0-99 you should capture two digits.
For a range of 0000-5000 would capture 4 digits).

7. Configure Line options and Advanced options from the Line options
and Advanced tabs. More information on these options can be found
further on in this manual. Click OK to add the line.

8. You should then add any additional lines you wish to use with GFI
FAXmaker to the Lines/Devices configuration. An Eicon Diva Server
BRI-2M (1 ISDN line) should have 2 channels added to the
Lines/Devices configuration (ISDN1B1, ISDNB2). An Eicon Diva
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Server 4BRI (4 ISDN Lines) should have 8 channels in the
configuration (ISD1NB1 - ISDN4B2).

NOTE: After making any changes to the GFI FAXmaker
Lines/Devices configuration make sure to restart the GFI FAXmaker
FAX Server service for the changes to take effect. Then check the
Fax Server Monitor to make sure that the lines have been initialized.

Finding out the exact MSN numbers

A frequent error is that the MSN number on which GFI FAXmaker
should answer is specified incorrectly. The exact MSN number that
you should enter depends on the ISDN configuration. The best way to
determine the number that you need to enter is the following:

1. Go to the GFI FAXmaker monitor node in the GFI FAXmaker
configuration.

2. Send a fax to GFI FAXmaker, dialing the number that you want GFI
FAXmaker to answer.

3. In the FAX Server Monitor, take note of how the number is being
displayed.

4. Enter this number in the Msn number list in the Device tab. After
you have entered the number and restarted the GFI FAXmaker fax
service/application, GFI FAXmaker will now answer the call.

NOTE: If you want GFI FAXmaker to answer a whole range of
numbers (for example, if you are using DID routing), just enter the
starting number of the range of numbers. For example: to instruct GFI
FAXmaker to answer all numbers 35922410 up to 35922419, enter
3592241.

Setting up fax lines for XCAPI

NOTE: The ‘TE-SYSTEM XCAPI’ ISDN is only available if the license
key provided in GFI FAXmaker has a valid software maintenance
agreement or running the evaluation of GFI FAXmaker.

Screenshot 33 - Select ISDN PRI/IP CAPI 2.0 devices
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1. Select the first available fax line number.

2. From the Device type list select ‘ISDN PRI/IP CAPI 2.0 devices’.

3. In the Physical line/port box, select the channel/port of the device
that you want to use for this fax line

4. Click OK to proceed with installation.

Screenshot 34 - Select TE-SYSTEMS XCAPI in ISDN type

5. From the Device tab, select “‘TE-SYSTEMS XCAPI’”

6. Click OK to finalize setup.
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Setting up fax lines for a Brooktrout fax card

Screenshot 35 - Adding a Brooktrout channel

1. Select the first available fax line number.

2. Select your device type. Select the Brooktrout entry with the
number of lines that your card has.

3. In the Physical line/port box, select the channel/port that you want
to use for this fax line. For example, if you are using a 2 line card, you
can select two channels for each card. If you want to use channel 1,
select ‘Brooktrout channel 1 (BROOKTROUT1)’.
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Screenshot 36 - Brooktrout device options

4. Select the Brooktrout card that you are using in the Card type list
box.

5. Select the correct ‘Line Capabilities’ option for your card. For ISDN
DID fax routing choose DID/ISDN. For Analogue DTMF routing
choose DTMF.

6. If you plan to use fax routing to route faxes individual users based
on the DID number go to the Advanced tab and tick the ‘Number of
DTMF/DID digits to capture checkbox. The number of digits should be
set to the size of the range of numbers you will be capturing. (i.e. For
a range of 0-99 you should capture two digits. For a range of 0000-
5000 you would capture 4 digits). Click OK.

7. Configure ‘Line options’ and ‘Advanced options’ from the Line
options and Advanced tabs. A description of these options can be
found further on in this manual. Click OK to add the line.

8. You should then add any additional lines you wish to use with GFI
FAXmaker to the Lines/Devices configuration.

NOTE: After making any changes to the GFI FAXmaker
Lines/Devices configuration make sure to restart the GFI FAXmaker
FAX Server service for the changes to take effect. Then Check the
Fax Server Monitor to make sure that the lines have been initialized.
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Setting up fax lines for the Brooktrout SR140

Screenshot 37 - Adding a Brooktrout channel

1. From the Available fax lines list select the first available fax line
number.

2. From the Device type list select the Brooktrout entry with the
number of channels you licensed from Cantata Technology.

3. In the Physical line/port list, select the channel that you want to
use with this fax line. For example, if you want to use channel 1 select
Brooktrout channel 1 (BROOKTROUT1).

4. Click OK to display the device/line properties dialog box.

5. Select Brooktrout SR140 from the Card type list.
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Screenshot 38 - Brooktrout device options

6. Select the correct line capabilities option for your card. For ISDN
DID fax routing choose DID/ISDN. For Analogue DTMF routing
choose DTMF.

7. If you plan to use fax routing to route faxes to individual users
based on the DID number, click on the Advanced tab and then select
the Number of DTMF/DID digits to capture check box. The number
of digits should be set to the size of the range of numbers you will be
capturing. (i.e. For a range of 0-99 you should capture two digits. For
a range of 0000-5000 you would capture 4 digits).

8. Configure ‘Line options’ and ‘Advanced options’ from the Line
options and Advanced tabs. A description of these options can be
found further on in this manual. Click OK to add the line.

10. Repeat the above steps to add any additional lines you wish to
use with GFI FAXmaker.

NOTE: After making any changes to the GFI FAXmaker
Lines/Devices configuration make sure to restart the GFI FAXmaker
FAX Server service for the changes to take effect. Then check the
Fax Server Monitor to make sure that the lines have been initialized.
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Setting up fax lines for a fax modem

Screenshot 39 - Adding a modem channel

1. Select the first available fax line number.

NOTE 1: If you have added new fax modems since installing GFI
FAXmaker, you can click ‘Detect’ in the Lines/Devices dialog to find
new modems. GFI FAXmaker will detect any modems connected to
your PC and list them in the Lines dialog. Then tick the checkbox of
each modem that you wish to use.

NOTE 2: If you are using Windows 2000/2003, GFI FAXmaker will
also detect any modems connected to Microsoft Fax. You must
however ensure that the Microsoft Fax service is started.

2. Select your device type.

NOTE: Select either ‘GFI Fax modem driver’ or ‘Microsoft fax modem
driver’.

3. If you selected ‘GFI Fax modem driver’ select the com port on
which the modem is connected in the Physical port box. If you
selected ‘Microsoft fax modem driver’, select ‘Microsoft Fax Service’ in
the Physical port box.

NOTE: If you chose to use a modem via the Microsoft Fax driver,
don’t select the same modem twice, i.e. once using the Microsoft fax
driver and another time using the GFI modem driver.
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Screenshot 40 - The modem device tab

4. If you selected to use the Microsoft Windows fax drivers, there are
no options to configure: you have to configure all modem options from
Microsoft Fax. If you chose to use the GFI fax modem drivers, select
your modem type from the modem type list box. If your modem does
not appear in the list, select the generic class driver for your modem.

5. Configure the Initialization string, Rings until answer, Tone dialing,
Wait for dial tone, Check for busy tone, Speaker mode and Speaker
volume options.

6. If you are familiar with modem configuration, you can click on
‘Advanced Modem Options’. This allows you to change the modem
settings of the driver. More information about the different settings can
be found in the Chapter ‘Advanced use’.

NOTE: Only advanced users should change modem settings.

7. Configure ‘Line options’ and ‘Advanced options’ from the Line
options and Advanced tabs. A description of these options can be
found further on in this manual. Click OK to add the line.

8. You should then add any additional lines you wish to use with GFI
FAXmaker to the Lines/Devices configuration.

NOTE: After making any changes to the GFI FAXmaker
Lines/Devices configuration make sure to restart the GFI FAXmaker
FAX Server service for the changes to take effect. Then Check the
Fax Server Monitor to make sure that the lines have been initialized.
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Line options

Screenshot 41 - The line options tab

The line options tab allows you to specify various options, including
Maximum resolution, Maximum Speed and Local fax ID. (The local fax
ID is given to the receiving fax machine as part of the transmission
process. Usually a fax number is entered as the local fax id). Other
options include:

 Receive incoming faxes: Tick this option to receive faxes on this
fax line.

 Send outgoing faxes: Tick this option to send faxes on this fax
line.

 Dial prefix: If your lines are located behind a PBX, you can
specify a dial prefix.

 Do not dial prefix if fax number is: Allows you to configure when
GFI FAXmaker should add a prefix. You cannot add a prefix if the
fax number is less than or equal to a certain number of digits. This
can be useful if you are using different providers for local, national
or international faxes.

 Fax header: The fax header is a text, for example a company
name that is stamped on top of each fax.

 Number of retries: Sets the number of times GFI FAXmaker will
try to re-send a fax.
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 Retry delay: This option allows you to set a delay between retries
in seconds.

Users

Screenshot 42 - The users tab

The users tab enables you to configure which users/groups of users
can send faxes through the fax line being configured or set up. Using
this feature enables you to assign users/groups of users to subsets of
fax lines configured within GFI FAXmaker.

By default all users/groups of users can send faxes through lines
configured. To reserve lines specifically for users/groups of users:

1. Select the Listed users/groups can send on this line option and
click Add.
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Screenshot 43 - select GFI FAXmaker users/groups

2. Select all the users/groups of users who can use this line and click
OK.

3. Select Reserve line only for listed users/groups checkbox if you
want this line to be exclusively reserved for selected users/groups.

4. Click OK to save changes or select another tab to continue
configuring this line.
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Advanced options

Screenshot 44 - The advanced line/device options

This tab allows you to configure auto print, backup location and format
options and number of DID/MSN digits to capture.
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Screenshot 45 - Auto print set-up

The auto print option enables you to automatically print faxes received
on this line. Optionally, you can setup a different printer for different
fax sizes (A4, Letter or Legal). To select the printer(s) click on ‘Set-up
printers’. If you want your faxes to be auto-fitted, select ‘Nearest Size,
otherwise select a specific paper size. If you have chosen ‘Nearest
Size’, you must set up a printer (this can be the same printer) for each
page format. If you have chosen one page size only, you must set up
a printer for that format.

NOTE: Printing of outgoing faxes is configured in the Sending options
node.

Backing up faxes

 Backup faxes received on this line: Creates a copy of all
incoming faxes in a directory of your choice.

 Backup faxes sent on this line: Creates a copy all outgoing
faxes in a directory of your choice.

DTMF/DID routing options

Through the DTMF/DID routing options you can set-up routing
options specific to this fax line.

NOTE 1: The main routing configuration is done from the routing
node.

NOTE 2: Some of these options are grayed out depending on what
device you are using.

NOTE 3: Standard fax modems have no routing capabilities.
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Number of DTMF/DID digits to capture: Length of DTMF
string/number that caller or PBX must generate. For example, if you
are going to use from 1-9 only, enter 1; up to 99, use 2 digits; up to
999, use 3; and so on. Be aware that if you enter a certain amount of
digits, the sender must enter all the digits for the fax to be routed
correctly. For example, if the digits are set to 3, and the DTMF
number is 6, the sender must enter 006 not just 6. Another option
would be to enter 6# (the # implies number complete).

Generate beep before capture: Specifies that the fax device should
give a beep when it answers the call as a signal to the user to enter
the DTMF number. It is recommended that this option is always
selected. The tone of the beep may be selected from the drop down
box. The tone can be a DTMF tone or a frequency from the selected
range.

Flash after DTMF capture and before tone: This option is used only
for Multitech modems. When this option is enabled, after successfully
detecting tone, the fax server goes 500ms on hook (flash) and then
start receiving the fax.
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Configuring Fax routing

Introduction to fax routing

An important ability for Network fax packages is the ability to
determine the right recipient of an incoming fax. GFI FAXmaker
supports several ways of achieving this with each method having its
advantages and disadvantages. Generally DID routing is
recommended for larger installations, while MSN and Line routing are
recommended for smaller installations.

DID routing (ISDN)

With DID routing your telecommunications provider allocates you a
range of virtual numbers, which will allow individual
users/printers/public folders to have their own fax numbers, without
requiring a physical fax line for each. If you already have ISDN you
can choose to use available lines from your PBX. Upon answering the
fax call, the ISDN protocol will pass the number on which the call is
being answered to GFI FAXmaker.

Ordering a new ISDN line

If you wish to use a new fax number range with GFI FAXmaker you
will need to contact your telecommunications provider to install an
ISDN service. You will need to let them know that you wish to use the
service for faxing, how many ISDN lines you want installed and how
large a range of numbers you wish to have assigned to service. The
telecommunications provider will then install a port (or a network
termination device depending on your region) at your location to
connect to the ISDN card in the GFI FAXmaker server.

NOTE: One ISDN Basic Rate Interface (BRI) consists of 2 ISDN
channels. i.e. 4BRI will give eight lines for faxing. One ISDN Primary
Rate Interface (PRI) will give 24/30 lines depending on your region.

Using available ISDN lines behind a PBX

If you want to use numbers from an existing number range for routing
faxes to individual users please contact your telecommunications
provider for an ‘s-bus extension’ and a port for the ISDN card to be
configured as an ‘s-bus device’. The PABX will then need to be
reconfigured to present the DID numbers from the specified fax
number range to the ‘s-bus device’. Your PABX may require either
spare digital ports or an expansion card for this capability.
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GFI FAXmaker configured for DID behind a PABX

NOTE: Check with your telecommunications provider to ensure that
your PABX is compatible with an ISDN fax solution before purchasing
any ISDN hardware. Sample PABX configurations can be found on
the Cantata Technology website (Knowledge Base Article #1457).

Requirements for DID routing (ISDN):

 A separate ISDN Line or spare ISDN extension

 An active ISDN CAPI 2.0 card such as an EICON Server BRI
(approx. cost $300-$500).

DID routing (analog/digital)

If ISDN is not available in your area, a DID trunk from your
telecommunications provider can also be used. These are either
analog or digital, depending on your provider. You will be allocated a
range of virtual numbers, which will allow individual
users/printers/public folders to have their own fax numbers, without
requiring a physical fax line for each.

Ordering a new DID trunk

You can choose to order a new DID trunk, which you will dedicate to
GFI FAXmaker. This requires that you buy a DID card from Cantata
Technology.

Using extra DID lines via your PBX

If you already have a DID trunk for your PBX, you can choose to use
available lines from your PBX. Effectively you will configure your PBX
to ‘forward’ the DID number on which the call was received to GFI
FAXmaker via a DTMF tone.

NOTE: DTMF (Dual Tone Multi Frequency) tones are the tones you
hear when you press a number on your phone. DTMF uses two tones
to represent each key on the touch pad. When any key is pressed, the
tone of the column and the tone of the row are generated, hence dual
tone. As an example, pressing the '5' button generates the tones
770Hz and 1336Hz. These tones are then recognized by the
hardware and passed on to GFI FAXmaker.

Requirements for DID routing (analog/digital):

 A DID line with X amount of numbers or spare extensions on your
PBX.

 If using a separate DID trunk: A Brooktrout TR114 TR 1034 DID
card.

 If using DID lines from your PBX: any Brooktrout TR 114 or TR
1034 card. Ensure that they support your PBX and that you have a
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knowledgeable phone technician who is able to configure this for
you.

For more information contact Cantata Technology.

MSN routing (ISDN only)

This method is similar to DID routing; it however uses the available
MSN numbers instead of dedicated DID numbers (ISDN only). Each
ISDN line has 1 or more MSN numbers (usually 9) assigned to it. If
your ISDN line has 9 MSN numbers, you can have 9 different routes
for a fax. The number of lines assigned to each ISDN line is different
for each telecommunications provider. Contact your
telecommunications provider for the exact number.

Requirements for DID routing (ISDN):

 A separate ISDN Line with spare MSN numbers.

 An active ISDN CAPI 2.0 card such as an EICON Server BRI
(approx. cost $300-$500).

OCR Routing

OCR (Optical Character Recognition) routing allows you to forward
incoming faxes depending on its text content. First the fax pages are
converted to text using OCR technology. Then the text is searched for
the user's first and last name and/or configurable text phrases. The
fax server will then forward the incoming fax to the respective user.

Requirements for OCR routing:

 Separately downloadable OCR module.

 OCR license.

Line routing

Line routing allows you to assign a physical fax line to a user. For
example, if your office had 4 fax machines in each department prior to
purchase of GFI FAXmaker, you could use those 4 fax lines with a 4
port fax device to route the faxes to each department based on the
number on which it was received.

Requirements:

Two or more physical fax lines.

Routing to a public folder or to an individual user

You can also choose to route to an individual’s mailbox or a public
folder/shared mailbox. In this case, faxes are manually routed by a
single person or group of persons.

CSID routing

CSID (Caller Sender Identification) routing relies on the FAX ID, which
each FAX machine/FAX card displays when sending a fax. Since it
rarely changes, it can be used to identify the sender and thus the
corresponding recipient.

NOTE: Use of this feature is no longer recommended and is provided
for backward compatibility.
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General routing options

Notwithstanding the routing method used, general routing options
must be set-up.

Screenshot 46 - Routing properties - specifying default fax routers

Specifying default routers

1. Right-click Routing node ► Properties.

2. To configure users that should receive all faxes, click the ‘Receive
all faxes’ tab. Click Add and specify the user/mailbox that should
receive all faxes.

3. To configure users that must route inbound faxes, click the ‘default
routers’ tab. Click Add and specify the user/mailbox that should
receive all faxes.

NOTE 1: The difference between a user that is a default router and a
user that is configured to receive all faxes is that the default router will
ONLY receive faxes that have not been routed. For example, if you
use DID routing, but receive a fax on a DID number that is not set-up
in GFI FAXmaker, then the default router will receive the fax. This
would be the case for a general fax line. Users specified in the
‘Receive all faxes’ tab will receive ALL faxes, whether they have been
routed or not.

NOTE 2: Use the “Receive all faxes” feature to create an exchange
store/public mailbox of all inbound faxes.



GFI FAXmaker 14.3 for Exchange/Lotus/SMTP Configuring Fax routing  59

Creating printers to route to

Screenshot 47 - Creating a printer to be used in routes

You can also specify that a fax received on a particular line or route is
printed on a particular printer. If you wish to do this, you must define
the printers that you wish to use in inbound routes centrally. This
allows you to change the printer without having to reconfigure all the
routes. To define printers which you wish to use in routes:

1. In the GFI FAXmaker configuration, right-click Advanced ►
Printers node and select New. Key in a name for the printer.
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Screenshot 48 - Configuring printers

2. Double-click on the printer in the right-hand pane. In the general
properties dialog configure what printer or printer cassette to use
based on the size of the fax received. For example, you can specify to
print legal size faxes on a printer set up to print legal pages. You can
also force that all faxes, independent of their size be printed on a
particular paper size.

 To print all faxes on the same printer with the same settings,
select A4 only, Letter only or legal only. Then specify the printer
and its settings in the corresponding printer settings, by clicking on
the button, located besides the selected paper size.

 To print all faxes on different printers or with different printer
settings depending on the paper size, select ‘Nearest size’ and
configure the printer settings for all 3 paper formats.

After you have created the printer, you will be able to select it when
creating an inbound fax route.



GFI FAXmaker 14.3 for Exchange/Lotus/SMTP Configuring Fax routing  61

Using Backup2Folder to route to folder

You can specify that a fax received on a particular line or route is
backed up in a particular folder. If you wish to do this you have to
enable the Backup2Folder feature on a per-route basis by opening the
route's properties and selecting the Backup2Folder tab. For each
route you can specify the folder in which to backup the received fax
into, and the preferred file format for the attachment.

Screenshot 49 - Setting up the Backup2Folder feature

Using this feature, each fax received will have a time-stamped file
name which is used for all backed-up files related to the particular
received fax. For example, if a fax is received and it satisfies two
routing rules which have different Backup2Folder destinations, the
same time-stamped file name is used in both folders. If a fax is
received and it satisfies two routing rules which have the same
Backup2Folder destination, there will be no file duplicates of the same
fax in that particular folder.

NOTE: This feature requires that the target folder can handle 'long file
names'. Hard-disk partition formats that handle long file names
include NTFS and FAT32.
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Configuring DID/DTMF Routing (ISDN/Analog/Digital)

For DID/DTMF routing, following the installation of a suitable fax
device, you will need to:

1. In the GFI FAXmaker configuration go to the Lines/Devices node.
Double-click on each installed fax line, go to the advanced tab and
enable the option to ‘Number of DID/MSN digits to capture’. The
number of digits should be set to the size of the range of numbers you
will be capturing. (I.e. For a range of 0-99 you should capture two
digits. For a range of 0000-5000 you would capture 4 digits).

2. Associate the DID numbers with the users. This is called a DID
route.

NOTE 1: Do not enable DTMF/DID routing unless you have a
DTMF/DID capable fax device, otherwise the fax server will generate
an error while receiving.

NOTE 2: If you are using DTMF routing behind a PBX in combination
with a Brooktrout card, ensure that you have setup the Brooktrout
card correctly. Please visit the Cantata Technology website for more
information how to configure your card correctly for a particular PBX.

Adding DID/DTMF routes

1. Right-click on the Routing ► DTMF/DID node, and select 'New
DTMF/DID route'.

Screenshot 50 - Creating a new DID route

2. Provide the users’ routing number (or virtual fax number). For
example, if you have a 4 digit DID, you enter the 4 last numbers in this
dialog and click OK. The DID number will appear in the right pane of
the GFI FAXmaker configuration. You can also enter a range of DID
numbers.
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Screenshot 51 - Specifying to which user the fax must be routed

Optionally you can specify 'Force number to have this amount of digits
- this will cause a range of, for example, 1- 100 to be noted as 0001-
0100 (if you specify 4)

NOTE: You can also import a list of users and DTMF numbers using
the import function

3. Double-click on the DID number in the right pane. This will bring up
the DID route properties. In the users tab, select to which user(s) the
fax must be routed if the fax is received on this DID extension
number.
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Screenshot 52 - Selecting a printer to auto print a fax on

4. You can also specify that any faxes received on this route should
be printed on a particular printer. To do this, select the printers tab,
enable ‘Automatically print faxes routed through this rule’ and select
the printer in the printer list box.

NOTE: You must configure any printers you wish to use in an
inbound route in the printer’s node. If you do not have any printers
configured, this tab will appear grayed out. For information on how to
configure printers, see the previous paragraph ‘general routing
options’.

Importing/Exporting a range of DID routes

If you have a large number of users, it might be easier to prepare a
list of DID numbers and associate user names in another application
like Excel.

To import or export a range of DID numbers:

1. In the GFI FAXmaker configuration, right-click on the Routing ►
DTMF/DID node.

2. From the menu, select either import or export DTMF/DID range. A
file dialog will appear asking you to specify a text file with the data to
be imported. The data must be in the following CSV format:

"did/dtmf number", "user1", "user2", "user3", …

E.g.
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"1234", "John J, Doe", "Bill Smith", "Roger Brown", "Joe Bloggs"

Specify the user name as either the Active Directory display name, or
the SMTP email address.

NOTE: The configuration will link the user name specified to either the
user's display name or any of the user's SMTP email addresses. All
the user accounts to be imported must be in the Licensed Users list.
On Export, the configuration will use the user's display name for the
user fields.

Configuring MSN routing

Before you can add MSN routes, you have to enter the MSN numbers
in the ISDN card Device tab. To do this:

1. Right-click Devices\Lines Configuration node ► Properties. A
dialog with the available lines will appear.

2. Select the lines associated with the ISDN card and double-click to
bring up the Device properties dialog. In the Device tab, enter the
MSN numbers that you want to be answered.

Screenshot 53 - Add MSN numbers to the device first

You have to enter all the MSN numbers, otherwise the ISDN card will
not pick up any incoming phone calls. If you use the ISDN line only for
the fax server, you can enter all the MSN numbers available on the
ISDN line, so as to create the maximum possible MSN routes.
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Adding MSN routes

1. Right-click Routing ►MSN node, and select 'New MSN route'

Screenshot 54 - Creating a new MSN route

2. Select from the list of available MSN numbers and click OK. The
MSN number will appear in the right pane of the GFI FAXmaker
configuration.

3. Double-click on the MSN number in the right pane. This will bring
up the MSN route properties. In the users tab, select to which user(s)
the fax must be routed if the fax is received on this MSN number.

4. Optionally configure a printer on which the fax must be auto printed
if received on this route. To do this, select the appropriate printer in
the printer’s tab. (Note that you must have configured the printer first
in the printer’s node)
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Configuring OCR routing

If you have installed the optional OCR module, have a valid OCR
license and wish to routing incoming faxes based on the text content
of the received fax image, you will need to do the following:

1. In the GFI FAXmaker Configuration, right-click on the Advanced ►
OCR node, and select 'Properties' to set up the OCR engine options.
This allows you to set up if you want to have the OCR text in the fax
report, the maximum number of pages to convert and to set up
language, spelling and correction options.

Screenshot 55 - OCR Engine Configuration - Specifying fax report and language options

2. Right-click Routing ► OCR node, and select 'Properties' to set up
the OCR routing text matching engine options.
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Screenshot 56 - General OCR Configuration - Specifying matching ratio and intelligent routing
option

Matching ratio: The matching ratio is the confidence that GFI
FAXmaker needs to have before matching the keyword or name to a
recipient. The recommended matching ratio is between 60 and 80%, it
should not be 100%.

The matching ratio is dependent on the quality of the fax. If the fax is
of bad quality, OCR will not recognize all the letters on the fax. In this
case a lower matching ration is required; otherwise the fax will not be
routed. On the other hand, a low ratio may lead to faxes being
forwarded to users who should not receive the fax. If the matching
ratio is too low, some words, which are similar to the phrases, will be
considered as being the phrases, e.g., with 60% ratio Jones and
Jonen will be considered to be the same.

Intelligently route faxes based on user's first and last names:
This option allows you to automatically route a fax if it finds a users
name in the fax. You don't have to configure the user’s names, since
GFI FAXmaker will retrieve the user names from Active Directory or
the Exchange 5.5 directory automatically. Use this option if you have
many users and don't want to configure custom search phrases for
each user.

Adding an OCR route

1. Right-click Routing ► OCR node, and select 'New...'
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Screenshot 57 - New search phrase - Creating a new OCR search phrase

2. Key in the phrase that you wish the OCR routing engine to look for
and click OK. The OCR search phrase will appear in the right pane of
the GFI FAXmaker Configuration.

3. The search phrase options should come up automatically but if this
is not the case double-click on the newly created search phrase. In
the users tab, select to which user(s) the fax must be routed if the
search phrase has been successfully matched.

4. Optionally configure a printer on which the fax must be auto printed
if received in this route. To do this, select the appropriate printer in the
printers tab.

NOTE: First configure the printer in the Advanced ► Printers node
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Routing to a public folder in Exchange

To make the incoming faxes arrive in a public folder follow the
following steps, depending whether you have Exchange 2000/2003 or
Exchange 5.5:

For Exchange 2000/2003

1. Create the public folder in Exchange System manager.

Screenshot 58 - Setting of Public Folder Permissions

2. Set the necessary permissions to the public folder created, by right-
clicking on the Public Folder ► Properties ► Permissions ►
Client Permissions.

NOTE: It is important that the Anonymous and Default permissions be
set to at least Contributor. This allows GFI FAXmaker to deliver faxes
to the Public Folder. You should also set required permissions to each
User / Group that will require access to this folder.
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Screenshot 59 - Email address assigned to the public folder.

3. Right-click on the public folder, and select All tasks ► Mail
Enable. An email address will now be assigned to the public folder.
Right-click on the Public folder ► Properties. The new email
address will be listed in the tab ‘email addresses’. You can change the
address if required.
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Screenshot 60 - Getting Public Folder visible in Address Lists.

4. From the Exchange Advanced tab un-check the ‘Hidden from
Exchange address lists’ check box and click OK.

5. Create an Exchange mail enabled user using Active Directory
Users and Computers.
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Screenshot 61 - Set AD user to have mails delivered to the Public Folder.

6. Once the user is created, right-click on the User name and select
Properties ► Exchange General tab, click on ‘Delivery Option’s and
in the Forwarding address frame, select the public folder using the
Modify button.

7. In GFI FAXmaker configuration ► Licensed Users/Groups, add
the newly created user as a GFI FAXmaker user.

8. In GFI FAXmaker configuration ► Routing ► Properties node
set the required routing so that faxes will be received by the newly
created user.

For Exchange 5.5

1. Create the Public Folder to which Faxes should be forwarded from
Microsoft Outlook.
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Screenshot 62 - Open up the public folder properties

2. From the Exchange Administrator open the properties of the public
folder you just created.

Screenshot 63 - Folder properties

3. Select the Advanced tab and make sure that ‘Hide from address
book’ check box is cleared.
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4. Now create a new mailbox from Exchange Administrator File ►
New Mailbox…

5. In the Mailbox properties select ‘Delivery Options’ tab.

Screenshot 64 - User delivery options

6. Specify an Alternate Recipient by setting the Radio button as
shown below and click on the Modify… button.
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Screenshot 65 - Mailbox Fax user

7. In the dialog that opens select the Public Folder item created in
Step 1 from the Global Address list and click OK.

8. Save changes for the newly created mailbox.

9. Now configure the newly created email address as a GFI
FAXmaker user. Right-click on the licensed user node and select New
Licensed user/group. Key in the email address or mailbox name and
select OK to add the public folder/email address to the list of GFI
FAXmaker users. You can now select this user for any of the routing
methods available. The faxes will be routed to the public folder.

Configuring Line routing

Line routing allows you to route faxes based on which fax line they
were received on.

Adding a line route

To add a line route:

1. Right-click on the Routing ► Line node, and select 'New Line
route'

Screenshot 66 - Creating a new Line route
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2. You can now select from the lists of available PHYSICAL fax lines.
Select a line and click OK. The new line route will appear in the right
pane of the GFI FAXmaker configuration.

3. Double-click on the line route in the right pane, click on the users
tab and select to which user(s) the fax must be routed if the fax is
received on this physical line.

4. Optionally configure a printer on which the fax must be auto printed
if received on this route by selecting the appropriate printer in the
printers tab.

NOTE: First configure the printer in the Advanced ► Printers node

Configuring CSID routing

You can set up CSID routing by adding CSID’s (FAX IDs) and
associating one or more users to that CSID. GFI FAXmaker will then
route incoming faxes with that particular CSID to that user. Add FAX
IDs to the user's CSID list by clicking Add and entering the fax
numbers.

Adding CSID routes

1. Right-click on the Routing ► CSID node, and select 'New CSID
route'

Screenshot 67 - Creating a new CSID route

2. Key in a CSID number and click OK. The CSID number/phrase will
appear in the right pane of the GFI FAXmaker configuration.

3. Double-click on the CSID number/phrase in the right pane. In the
users tab, select to which user(s) the fax must be routed if the fax has
that CSID number.

4. Optionally configure a printer on which the fax must be auto printed
if received on this route. To do this, select the appropriate printer in
the printers tab.

NOTE: First configure the printer in the Advanced ► Printers node
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Configuring Fax server options

Document Conversion configuration

GFI FAXmaker can automatically convert Microsoft Office, rtf, txt, gif,
jpg, HTML and PDF attachments at server level. GFI FAXmaker
includes a built in conversion engine for PDF, HTML, PNG, GIF, JPG,
RTF, TXT documents.

NOTE 1: To convert Microsoft Office attachments you need to have
Microsoft 97 or higher installed on the FAX Server computer.

NOTE 2: It is not recommended to install Microsoft Outlook on the
same computer where Microsoft Exchange Server 2000 or 2003 is
installed. Installing Microsoft Outlook on Microsoft Exchange Server
2007/2010 is allowed.

Screenshot 68 -Document conversion options

To configure document conversion, right-click on the Advanced ►
Document conversion node and select properties. You can
configure the following options:
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 Ignore extensions: Enter the extensions that you want to ignore
e.g., p7s, vcf, etc. GFI FAXmaker will not ignore the standard GFI
FAXmaker extensions: fax, txt, rtf and fmk.

 'Print to' shortcut set-up: You can also configure a custom
document format. To do this you must install the application that
can print the document and also set up a 'print to' shortcut for that
format. Test that you can print the document via windows explorer.
Then enter the extension of the format (e.g. 'doc' for Word) and
the Application Command that is able to print the format. In most
cases this is 'Print'. Then click Add.

Troubleshooting Microsoft Office document conversion

1. Ensure that Microsoft Office was installed using the same account
that is being used for the GFI FAXmaker fax server services. If this is
not the case, re-install Microsoft Office using the account used for GFI
FAXmaker.

2. Ensure that you have made a full installation of Microsoft Office.

3. Ensure that that the account used for installing GFI FAXmaker and
Microsoft Office has administrator rights.

4. After installing Microsoft Office, run Word and/or Excel to get rid of
any messages displayed the first time the programs are run.

5. Ensure that the GFI FAXmaker printer driver is set as the default
printer for the machine.

6. Re-start the fax server machine to ensure that changes will take
effect.

Configuring Licensed users

GFI FAXmaker is licensed based on the number of users that receive
OR send faxes. You must specify all users that send or receive faxes
in the licensed users/groups node.

To add licensed users:

1. Right-click Licensed Users node ► New Licensed User or
Group.

2. Select Users or Groups from Active Directory. You can select
individual windows users or groups of users.

NOTE: We recommend creating a ‘GFI FAXmaker users’ group in
Active directory so that you can manage all GFI FAXmaker users
directly in Active Directory.

Importing GFI FAXmaker users from a text file:

If you have a list of users with their correct email addresses or if your
server is not running Windows, you can import users from a CSV
(Comma Separated Values) file.

1. Right-click Licensed users ► Import users from file.

2. Select the text file with the user information. Make sure that the text
is formatted as follows:

"first name", "last name", "company", "department", "fax number",
"voice number", "email address", "display name", "internet email
address"
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Example:

"Joe","Bloggs","ABC Ltd","Sales","+1 555 12345678","+1 555
87654321","JoeBloggs@ABC.com ","Joe Bloggs"

Field information

 First name: can be empty

 Last name: can be empty

 Company: can be empty

 Department: can be empty

 Fax number: can be empty

 Voice number: can be empty

 Email address: required - must be unique.

 Display name: required; cannot be empty

 Internet email address: can be empty

NOTE: After importing GFI FAXmaker users, you must restart the
GFI FAXmaker Message Transfer Agent service.

Configuring the Email2Fax gateway

The Email2Fax gateway is configured during installation. If you want
to change the settings after installation;

1. In the GFI FAXmaker configuration, right-click Email2Fax Gateway
► Properties.

Screenshot 69 - Email2Fax Gateway setup
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2. Specify your mail server name and the SMTP port.

3. If your mail server requires authentication, specify authentication
details.

POP3 connector

Screenshot 70 - The POP3 connector

If you have Lotus Notes/Domino or an SMTP/POP3 server, then there
will also be a POP3 connector tab in the Email2Fax gateway
properties dialog. This allows you to collect faxes via a dedicated
POP3 mailbox. For more information see the first chapter. To
configure the POP3 connector:

1. Tick ‘Enable POP3 connector’ to enable collection of faxes and
SMS via POP3.

2. Specify the mail server name and port.

3. Specify the POP3 mailbox account name and password. You can
also specify the Login method.

4. Specify the full email address of the fax mailbox. This address will
be used as the ‘reply to’ address.
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Sending and receiving options

To configure fax sending and receiving options, right-click Receiving
options node ► Properties. You can configure the following options:

Screenshot 71 - Sending options

 Enhance fax image when sending normal resolution faxes: By
enabling this option, the quality of low-resolution faxes is
improved.

 Send fax report attachments in the following format: You can
choose that the fax files included in sent fax reports are sent in a
different format then the standard fax format. You can select TIF,
PDF, GIF, JPG or PNG format.

 Auto print outgoing faxes if successful: This option
automatically prints all outgoing faxes that are sent successfully.
The fax will be printed exactly as it was sent.

 Auto print if failed: This option automatically prints all outgoing
faxes that fail. The fax will be printed exactly as it was sent.

 Auto print fax report if successful: If this option is activated,
GFI FAXmaker will print a transmission report and a miniature of
the fax after successfully sending a fax. GFI FAXmaker will
include 6 fax pages on one printer page (except for the first page
as this includes a transmission report and 5 fax pages).
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 Auto print report if failed: If you select this option, GFI
FAXmaker will print a transmission report and a miniature of the
fax after an outgoing fax has failed.

NOTE: When you check one of these Auto print check boxes, the
auto print set-up dialog will automatically pop up:

 Auto-fit: If you want your faxes to be auto-fitted, select Nearest
Size. If you are sure you are only going to receive one fax
format/size, you can select that format: A4 only, Letter only or
Legal only. If you have chosen Nearest Size, you must set up a
printer (this can be the same printer) for each format. If you have
chosen one format only, you must set up a printer for that format.

Screenshot 72 - Auto print set-up dialog
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Receiving options

Screenshot 73 - Receiving options

 Cut long faxes to standard page size: If a page is longer than
1.5 times the selected page size, the page is cut to the selected
size, using an intelligent page-cutting algorithm.

 Paper size threshold: Select the paper size you wish to receive
faxes in. If an incoming fax is more than 1.5 times the paper size,
it will automatically be cut to the size you select here.

 Route incoming faxes in the following attachment format:
Here you can select the format in which received fax files should
be stored/forwarded. You can select the default *.fax format, the
*.tif format, the *.jpg, *.png, *.gif format or the *.pdf format. This
way faxes will be associated with a default tif or PDF viewer and
there will be no need to install the GFI FAXmaker viewer on the
user’s machine. (Note that the user will not be able to annotate the
fax)
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Configuring Fax administrators

A Fax administrator is the person who monitors and manages the fax
server. If certain critical conditions occur, the fax administrator will be
notified by email. In the Fax administrator node you can specify one or
more fax administrators. To specify a fax administrator:

1. In the GFI FAXmaker configuration click on Advanced ► Fax
Administrators node, right-click and select 'New administrator".

2. Select one or more users who will be fax administrators. Click OK.
These users will now be notified of critical conditions in the fax server.

Dialing Options

The dialing options allow you to configure ‘dialing intelligence’. This
way, you can set up GFI FAXmaker to accommodate multiple local
area codes and other special dialing procedures. It processes the fax
number in a structured manner and dials out in the correct format for
the phone system.

To configure the dialing logic, right-click on the Advanced ► Dialing
node in the GFI FAXmaker configuration and select Properties.

The dialing logic is split into 2 parts: International dialing (country
code), and National Dialing for local area codes and exchange
settings.

Screenshot 74 - Dialing options
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First, you must enter your country code and area code. The country
code must be entered without the dial prefix. The dial prefixes are the
numbers that are placed in front of the country code when dialing an
international number. This may vary per country, but the most
common are 00 and 011.

It is important to remember that the dial prefix of a country is the
number the user in that country must dial to make an international call
(sometimes defined as a + in front of the country code). The country
code is the number that the user in another country must dial in order
to call the country with that country code. For example, in the United
Kingdom the dial prefix is 00; thus, to dial the United States (which
has 1 as its country code), the user must dial 001 and then the
number. In the United States, the dial prefix is 011, thus to dial the
United Kingdom (country code 44) the user must dial 01144 and then
the number.

International dialing

In this section you must enter the settings for international dialing.
When the fax server detects a + in front of the number, this section is
used to modify the first part of the number. The user may select the
option to remove the country code if it matches the one in the ‘Where
am I?’ section.

If this option is not selected, the country code will remain as is. If the
option is selected, it enables 2 other options. One is the option to
attach a prefix if the country code matches and is removed. The other
is the option to replace the + with the international dial prefix when
selected.

This logic will allow you to use the following number notation in your
fax number entry:

+44-(020)-2282666

GFI FAXmaker will then determine in which country you are and if you
are in the same country, GFI FAXmaker will strip off the 44 and
optionally put a prefix in front of the number, for example 0.

If you are not in the same country, GFI FAXmaker can replace the +
with the international dialing prefix, for example 00 or 011.

National dialing

This option is especially important if you are based in North America.
Using this option you can enter your area code and ask GFI
FAXmaker to remove it if you are faxing to a number with the same
area code. In addition, you can add a prefix to the number. If the
number is not your local area code, you can set up GFI FAXmaker to
automatically add 1 as prefix.

NOTE: The area code in the fax number must be included in round
parentheses. If this is not done, the fax server cannot determine which
part of the number is the area code.
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Screenshot 75 - The dialing exceptions dialog

Exceptions

Because some dialing procedures can be very complex (Especially
those in the US), you can set up a number of exceptions, which can
for example handle multiple local area codes.

The Exceptions dialog allows you to specify the different area codes
and exchanges for each number. It allows you to remove the area
code and add a prefix if needed. Since one area code may have
hundreds of exchanges, to avoid entering a lot of numbers with the
same area codes and different exchanges, you may enter a wild card
(*) in the exchange section, which will handle all the related exchange
numbers. Thus if you enter area code 342 and exchange *, it will
process all the numbers starting with area code 342 (342 456, 342
123, 342 789…).

To add an exception: Click on the Exceptions button, and key in the
area code affected into the Area Code field.

If the settings pertain to a particular exchange within the area code
(i.e., the three digits of the phone number following the area code),
enter them into the Exchange field.

NOTE: You can use commas to add a delay between numbers if your
system requires it. Each comma represents approximately a two
second delay.

If the telephone number requires a prefix for distance dialing, for
example a 1, then check the box “Dial a prefix before the area code”
and enter the 1.

If you do not need to dial the area code for this number then check
the box “Do not dial the area code”.

Click on the Add to add it to the list of telephone entries.
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To remove an exception: Select the telephone entry to be removed
and click on Remove.

Notes for Users / inputting the fax number

The dialing options will only work if the user keys in the fax numbers
correctly. If this is not the case, GFI FAXmaker will not be able to
process the fax number.

The fax number should be inputted in the following format:

+<country code> (<area code>) <fax number>

E.g.,

+44 (171) 226 4788

+1 (716) 265 1016

+356 382 419

Transmission reports

GFI FAXmaker will send a transmission report to the user after a fax
has been sent. This transmission report will show whether the fax was
sent successfully or not.

Access transmission report options from the Advanced ►
Transmission reports node. Right-click Reports node ►
Properties. The following options are available:

Screenshot 76 - Transmission report options
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 Report successful outgoing FAX transmissions: Tick this
option if you want GFI FAXmaker to send a transmission report if
a fax is sent successfully.

 Include attachments with success reports: Tick this option if
you want the fax file to be included with the transmission report.

 Report failed outgoing FAX transmissions: Select this option if
you wish GFI FAXmaker to send a transmission report when a fax
has failed.

 Include attachments with failure reports: Tick this option if you
wish GFI FAXmaker to include the fax file that failed in the
transmission report.

 Append original message body: Tick this option if you want the
original fax message body to be included in the transmission
report. This option is recommended since it allows users to easily
re-submit faxes and to find sent faxes.

NOTE: In the GFI FAXmaker Fax Message form, sent faxes are not
stored in the sent items folder, so the only way for users to retrieve
faxes sent via the GFI FAXmaker Fax Message form is via the
transmission reports.
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Header/Footer/Stamping options

The Header/Footer/Stamping options node allows you to specify a
header and/or footer text for all outgoing faxes as well as ‘stamp’
incoming faxes with similar information. The header/footer options can
be set in the Header/Footer tab, whereas the stamping options can be
set in the Stamping tab. The dialogs are identical. The following
options are available:

Screenshot 77 - Header/Footer/Stamping properties dialog

 Font: Select font, size and alignment that you wish the
header/footer to be formatted in.

NOTE: Formatting options can be different for the header and the
footer. To have different formatting for the header or footer, simply
select the header or the footer field - then select the appropriate
formatting options.

 Render this header on all outgoing faxes (incoming faxes in
the case of stamping): Tick this option if you want a header to
appear on each outgoing fax.

NOTE: You can customize the fax header by inserting fields. To insert
a field, place your cursor where you want the field to be and click on
Insert fields. Then select the field you want to insert. You can
separate fields by inserting a separator. To set your header to the
default fields, click Set to Default.

Available fields:
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Screenshot 78 - Fields dialog

o Default From <def_from> Global fax header specified in the
fax line options.

o Default To <def_to> This field is replaced by the company
name of the recipient. If you did not specify a company name,
but did specify a name, the name will show in this field. If you
did not specify a name or company, this field will include the
recipient's fax number.

o Time, date & pages Information is taken from your machine
settings.

o Sender fields Details are taken from the user’s properties.

o Recipient fields Details are retrieved from the recipient details.

 Render this footer text on all outgoing faxes (incoming in the
case of stamping): Tick this option if you want a footer to appear
on each page. You can insert fields in the text by clicking on
Fields.

NOTE: You can not change the footer in an evaluation version of GFI
FAXmaker!
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Junk Fax filter

Screenshot 79 - The junk fax filter options

GFI FAXmaker provides you with the ability to auto delete faxes from
certain senders. This junk fax filter works on the basis of the FAX ID
of the sender.

When you receive a junk fax, enter the senders FAX ID in the Junk
fax filter list. This will cause GFI FAXmaker to delete the fax
automatically, and not route it.

Most senders will rarely change a fax ID, especially if it is
programmed into a fax machine, and therefore it’s an easy and pretty
reliable way of eliminating future faxes from the sender.

To black list a fax sender/fax ID:

1. Right-click Advanced ► Junk Fax filter node, and select
'Properties'. This will bring up the junk fax filter dialog.

2. Enable the ‘Delete faxes received from these FAX CSID’s’ option,
and click Add to enter the CSID of the junk fax sender.

You are provided with 2 options:

 Delete faxes received from fax machines with an empty CSID:
If you wish to be very stringent you can refuse all faxes with empty
CSID's. Note that there is a big chance that valid faxes will be
marked as junk faxes.
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 Keep a copy of junk faxes: This option will store all junk faxes in
a folder, so that you can review the junk faxes before deleting
them.

Call blocking

Screenshot 80 - A call block rule

Call blocking allows you to exercise control over the fax numbers that
users can send faxes to. GFI FAXmaker checks the call block rules
before each fax transmission, and will not send any faxes starting with
numbers listed in the call-blocking list.

This means that if you want to prevent certain users from making
international fax transmissions, you only need to insert the
international dial-out number (for example 00, 09 or 011).
Alternatively, you can block specific fax numbers.

To create a call blocking rule:

1. In the GFI FAXmaker configuration, Advanced ► Call blocking
node, right-click and select ‘New’.

Screenshot 81 - New call block entry

2. Key in the number that you want to block and click OK.

3. Select which users you wish to apply the rule to.

4. Click OK to create the rule.
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OCR

The OCR feature enables you to convert incoming faxes to text and
insert the converted text into the body of the received fax report or as
a separate text attachment. The converted text is then used for OCR
routing depending on your configuration. Searching for incoming
faxes becomes much easier, because you can use the search
features in your email client or in your email archiving solution to
retrieve past faxes quickly. Without OCR, the actual text in the fax can
not be searched because it is stored as an image.

1. Click Advanced ► OCR node in the GFI FAXmaker configuration.

Screenshot 82 - OCR properties

The following OCR options are available:

 Append OCR output text below fax report: This option inserts
the text of the fax in the body after the fax report: This allows you
to easily search for faxes using your email client’s search function.

 Attach OCR output text file with fax report: This option allows
you to specify whether the OCR output must be attached to the
incoming fax.

 Maximum pages to convert: The number of pages that GFI
FAXmaker should convert to text.

 Preferred language: If you specify auto then the OCR engine will
not assume any particular language. Specifying a default
language will improve the accuracy on the language specified.



96  Configuring Fax server options GFI FAXmaker 14.3 for Exchange/Lotus/SMTP

 Enable spell checking and correction: If you enable this option,
the OCR engine can improve the accuracy by spell checking the
text.

Miscellaneous options

Screenshot 83- Advanced options

The miscellaneous options node can be found under the advanced
node. It contains the following options:

Unlimited user options

 Allow non-AD users to send faxes - this option does not check
whether the sender is actually in Active Directory. It just sends the
fax.

 Only allow users in the Licensed user list to send faxes - this
option only allows a user to send faxes if he/she is listed in the
Licensed user list.

NOTE 1: These options are only applicable to the unlimited user
version of GFI FAXmaker.

NOTE 2: The above options are mutually exclusive.
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Performance options

 Allow multi-processor usage - this option will instruct GFI
FAXmaker to use all available processors.

 Do not cache users on startup - If you have a lot of users (more
then 2000), you can speed up the startup time by disabling the
cache user feature. The cache user feature is not recommended
for large networks.

 Disable batch processing - if you are using an intelligent fax
board, you can speed up the fax send process by disabling batch
processing. This is not required because the faxing process is off
loaded from the host processor.

Auto-print options

 Force 1:1 printing - this option does not scale the fax at all. This
might mean that some faxes are not completely printed because
the received fax is larger then the paper in the printer.

Troubleshooting options

 Enable debug mode - If you enable debug mode, GFI FAXmaker
will create log files with extended debug in the logs directory.

Fax server options

 Do not store sent fax attachments for resending - This option
will disable the feature that stores faxes on the fax server, allowing
users to resend faxes by hitting the reply button on a transmission
report. By default the fax server will store a copy of each fax for 2
days.

 Do not store failed fax attachments for resending - This option
will disable the feature that allows a user to resend a failed fax by
hitting the reply button. The failed fax will be retrieved by the fax
server and resent. By default the fax server will store a copy of
failed faxes for 1 week.

Public contacts

If users use the Outlook New Message form to send a fax and your
cover page includes a company field, then the company name of the
fax recipient is not displayed on the cover page.

Microsoft Outlook only retrieves the name and the fax number of the
recipient from the contacts list and does not include the company
name in the mail that is sent to the GFI FAXmaker server. Therefore
GFI FAXmaker has no way of knowing the company name of the
recipient and cannot display it in the company field on the cover page.

The easiest way to resolve this is to use the GFI FAXmaker Fax
Message form, since this form retrieves the company name together
with the fax number of the recipient. You can also remove the
company name field from the cover page.

Alternatively, you can instruct users to use a public contacts list,
located on the server, to which GFI FAXmaker has access as well.
This way, GFI FAXmaker can query the public contacts folder for the
company name of the recipient. A public contacts folder is often used
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anyway, in order to share customer details amongst employees. You
can specify multiple public contacts folders to query.

Screenshot 84- Public contacts node

To enable retrieval of the company name from one or more public
contacts folders:

1. Ensure that you have a working profile, configured as the default
profile, to connect to your Exchange Server. If you have installed GFI
FAXmaker on a separate machine, you have already configured a
profile for Microsoft Outlook. If you have installed GFI FAXmaker on
the Exchange Server, then you will probably need to create a profile.
You can do this from the Windows control panel. Ensure that the
user/mailbox you specify in the profile has access to the public
contact lists you want GFI FAXmaker to query.

2. In the GFI FAXmaker configuration, go to the Advanced ► Public
contacts node. Right-click on the Properties node for the property
options. Tick the Enable Exchange public contacts retrieval.

3. Click Add to add a public contacts list. Enter the name of the public
contacts folder (public contacts are essentially a public folder with
contacts items rather then mail items) which contains the public
contacts. For example, if you have created a public folder 'Company
contacts', you should enter: Company contacts. If you have created
your Public Contacts List in a subfolder, then you must indicate the
folder structure. For example, if the folder ‘Company contacts’ is
located directly under a folder ‘Phonebooks', then you should enter
the following: Phonebooks\Company contacts.
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4. You can specify multiple public contact lists. Remember though that
querying a contact list can take a second or so, depending on the
speed of your exchange server.

5. After you have keyed in the list of your public contacts folders, click
on Test. GFI FAXmaker will query the listed public contacts folders. If
a test is successful, click OK. If it is not successful, the default profile
has not been created or does not have permission to access the
contacts folders. Ensure that the account you use during creation of
the profile has access to the public contacts list.

Screenshot 85 - Creating a profile

6. If GFI FAXmaker does not find a profile at all, it will automatically
launch Microsoft‘s profile creation wizard. You will have to specify the
Exchange Server name and the mailbox name, and whether you
travel with the computer or not. Click No, assuming you don’t take
your exchange server with you when you travel. Click Finish to create
the profile.

7. Re-test whether GFI FAXmaker can query the contacts list.

General

Under the general node you will find general information regarding
GFI FAXmaker:

Licensing

Use this node to view current licensing information and to enter your
License key number.
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Screenshot 86 - Viewing current licensing information

Clicking on the License Product link in the licensing node displays the
current license information screen. This screen, amongst others,
provides you with information related to License type, License status,
Licensed users limit, licensed SMS users limit and Licensed fax lines
limit, etc.

Screenshot 87 - Entering a license key

Clicking in the Enter License Key enables you to enter or amend your
GFI FAXmaker license key. The GFI FAXmaker License key is
requested during installation, however, if you wish to change it
afterwards, (for example to upgrade the number of users, or to
upgrade from an evaluation version to a full version) you can do so
through this dialog box. GFI FAXmaker is licensed based on number
of users who wish to send and receive faxes.
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Version Information

This node shows the exact version of GFI FAXmaker that you are
running. You can also check if a newer version is available on the GFI
web site.

Screenshot 88 - Checking whether a newer build is available

Click on the Check for on-line updates… to connect to the GFI web
site and check for a newer build of GFI FAXmaker.

GFI MailEssentials

This node links to the main web page of GFI MailEssentials. GFI
MailEssentials for Exchange/SMTP offers spam protection at server
level and eliminates the need to install and update anti-spam software
on each desktop. Click on the GFI MailEssentials node for more
information on how to further protect your messaging requirements.

GFI support

This node links to the GFI FAXmaker support page, which also has a
knowledge base.
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Configuring fax archiving

The archiving feature archives all in- and outbound faxes, enabling
you to store a history of your fax communications. GFI FAXmaker
supports 2 methods of archiving: through the sending of fax copies to
an email archiving solution (via email) or by archiving directly to a
database. The advantage of archiving to an email archiving solution is
that you can allow users to search for faxes in the same way as they
retrieve emails.

Archiving to an email archiving solution

To archive via mail:

Screenshot 89 - Archiving to an email archiving package

1. Right-click Archiving ► Properties.

2. In the Mail Archiving tab tick the faxes that you want to archive. You
can archive received, sent and failed faxes.

3. Specify the email address to which all faxes should be sent. The
email body will include the transmission report and the fax as
attachment. If you have the OCR module installed, received faxes will
include the OCR output in the body. For sent faxes, the text converted
into the cover page will be included with the transmission report. This
allows for easy searching of faxes.
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NOTE: The email address specified should be of one of the licensed
users in GFI FAXmaker. If you have an unlimited user’s license, you
can specify any email address you want.

4. Specify in which format you want the faxes to be archived. PDF is
the recommended format, since most users have a PDF viewer
installed. Click OK.

Archiving directly to a database

Screenshot 90 - Archiving properties

To archive faxes to a database:

1. Right-click Archiving ► Properties.

2. In the database archiving tab, tick ’Enable archiving’ to switch on
archiving of faxes.

NOTE: Archiving to database consumes substantial disk space.
Monitor disk space usage regularly to avoid running out of disk space.
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Screenshot 91 - Database configuration

3. Click on ‘Setup Database’ to configure the database where faxes
should be stored. In the Database configuration dialog, choose
between Microsoft SQL or Microsoft Access.

NOTE: GFI FAXmaker archiving requires mixed mode authentication
to be enabled on the SQL server.

4. If you select Microsoft Access, specify a file name and location.

NOTE: Archiving to database consumes substantial disk space.
Monitor disk space usage regularly to avoid running out of disk space.

5. If you select SQL/MSDE, specify server name and credentials. GFI
FAXmaker will automatically create a database called GFI FAXmaker
Archive under which a set of tables will be created.

NOTE: If you select MSDE there is a database limit of 2 gigabyte.
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Configuring Cover pages

Introduction to cover pages

Cover pages are used to format the fax message text. Whenever a
user writes a message in the fax message form or in an email client,
GFI FAXmaker will format the message body on to a cover page.
There are 2 types of cover pages in GFI FAXmaker:

 Coverpage: Includes the message text and/or recipient/sender
details.

 Front covernotes: An additional cover page, which only includes
sender/recipient details in front of the cover page described
above. This can be compared to a 'With Compliments’ slip.

You can set-up multiple cover pages and cover notes for users For
example, you could create a cover page for the support department
and associate the support users group to it. Then you can create a
different cover page for the sales department.

Adding Cover Pages/Front Covernotes

By default, GFI FAXmaker includes a generic cover page, which is
assigned to all fax users. To change the format of this cover page,
double-click on the cover page entry in the right pane and click edit.
Custom cover pages can also be created.

Adding a coverpage/covernote

To add a cover page/covernote:

1. Choose the Coverpages node and right-click Cover page ► New
or right-click Front Covernotes ► New

Screenshot 92 - Creating a new cover page
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2. Provide a display name for the cover page and select a cover page
file from the list of available cover page files. If you have designed a
custom cover page file, click Add from file to add it to the file list.

3. Double-click on the cover page entry in the right pane, click on the
users tab and select to which user(s) this cover page will be assigned.
In the options tab you can change the cover page name or associate
a different cover page file to the cover page.

Specifying a default coverpage/front covernote

When a user has not been specifically assigned a coverpage or a
front covernote, then the default cover page will be used. Right-click
the Coverpage entry in the right hand pane and select 'Set as default
cover page' to specify a default coverpage.

Screenshot 93 - Configuring cover pages

NOTE: The default cover page option will be overridden for a
particular user, as soon as you associate a cover page with that user
or to group of users to which that user belongs.
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General cover page options

Choose the Coverpages node and right-click Cover pages ►
Properties to configure general cover pages.

Screenshot 94 - Coverpage options

The following options can be configured for cover pages:

 Send coverpages: Include a cover page with each fax.

 Only if message text is present: Include a coverpage with each
fax only if message text is exists.

NOTE 1: A signature constitutes message text; in case users have an
automatic signature they have to delete it otherwise a fax cover page
will be generated.

NOTE 2: Disabling coverpages from the Coverpages properties dialog
box also disables Front Covernotes.

 Use this coverpage when no default coverpage is associated
with a user: Select default cover page in case where user has not
been specifically assigned a cover page.

 Rendering: Choose this tab to set the margins for the cover
pages.
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Front covernote options

Choose the Coverpages node and right-click Front covernotes ►
Properties to configure general cover pages.

Screenshot 95 - Cover page/ Front cover note options

You can configure the following options for front cover notes:

 Use front coverpage: Use and select the default front covernote
for users with no assigned default front covernote.

 Rendering: Use the rendering tab to set the margins for the front
covernotes.

NOTE: Disabling coverpages from the Coverpages properties dialog
box also disables Front Covernotes.

Designing cover pages

Cover pages are in HTML format. To design a cover page in HTML
format:

1. Create a new HTML file.

2. Add text and message fields such as such as [R_Name] and
[R_Company] (for supported merge fields, see next paragraph). For
example, a very simple cover page with recipient name and company
could be created as follows:

To: [r_name]

Company: [r_company]
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<message>

3. Add it by creating a new cover page, and specifying the file in the
Add from file, located in the New Cover page dialog.

4. It is recommended that the HTML encoding for your designed cover
page is set to UTF-8. This is necessary if you wish to use international
characters.

Supported merge-fields

NOTE: Ensure that the field names are all lower case

The following merge-fields may be used in a cover page:

Sender fields:
Address Fields Merge code (HTML)

Last name [s_last_name]

First name [s_first_name]

First name-Last name [s_name_fl]

Last name-First name [s_name_lf]

Company [s_company]

Department [s_department]

Fax no. [s_fax]

Voice no. [s_voice]

Email [s_e-mail]

Recipient fields:
Address Fields Merge code (HTML)

Company [r_company]

Department [r_department]

First name [r_first_name]

Last name [r_last_name]

First name-Last name [r_name_fl]

Last name-First name [r_name_lf]

Fax [r_fax]

Voice no. [r_voice]

Email [r_e-mail]

General fields

These fields are for general information:

Message text: HTML [message]

This field inserts the email body text into the cover page. Be sure to
leave enough space for it in the html file.

Current time: HTML [time]

Current date: HTML [date]

Current Long date: HTML [longdate]

These fields insert the date and time of fax transmission. The fax
server machine’s date and time will be used.

Subject: HTML [subject]

This field inserts the subject line of the message.

Total Pages: HTML [total_pages]
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This field inserts the total number of pages in the fax being sent,
including the cover page.
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Fax server monitoring

The GFI FAXmaker monitor

Screenshot 96 - The GFI FAXmaker monitor

The GFI FAXmaker monitor can be started from the GFI FAXmaker
program group and can be run on the fax server machine itself or
remotely. The GFI FAXmaker monitor enables you to:

 Monitor status of each fax line

 Monitor status of fax devices

 View the queue of faxes

 View the status of the Message transfer agent.

Viewing the fax line and device status

You can monitor the status of fax lines and devices from the from the
Fax Server node. Clicking on the node will show all the available fax
lines, the fax devices and their status. Depending on the fax device
used, you can initialize, abort or debug a particular fax device. You
can also restart the fax server from this node.
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Viewing the fax queue

Screenshot 97 - Queued faxes in GFI FAXmaker monitor

The Queued faxes node shows you all faxes that are waiting to be
sent. You can delete faxed from the queue that you wish to cancel.

Viewing the Message Transfer Agent status

Screenshot 98 - GFI FAXmaker Message Transfer agent status

To view the status of the Message Transfer Agent click on its node.
The following information is available:

 Email2Fax Gateway: Shows activity of a number of threads that
perform POP3 down loading, fax preparation, SMTP sending etc.

 Inbound Queue: Shows the number of faxes prepared for
sending to SMTP clients.

 Inbound transfer thread: Shows activity of the process that
sends faxes to SMTP clients.
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 Last file: Shows the last file being processed.

 Outbound Queue: Shows the number of faxes collected by the
POP3 connector for queuing to fax server.

 Outbound transfer thread: Shows activity of process that
downloads POP3 mail from POP3 mailbox.

 Last address: Last email address or SMS number used by
Message Transfer agent.

 SMS transfer thread: Shows status of thread that prepares and
transfers messages to SMS server.

Installing the GFI FAXmaker monitor remotely

To be able to monitor the fax server remotely, you must first install the
GFI FAXmaker monitor on the machine that you wish to monitor the
fax server from. To do this:

1. Run the installation file on the machine that you want to setup the
remote monitoring tools from.

2. Set-up will ask you what components you with to install. Select -
‘GFI FAXmaker Remote Monitor’ only.

3. Key in the name of the GFI FAXmaker server. Set-up will copy the
files and create a program group.

NOTE: By default only administrators have access to the remote
monitor and configuration tools. If you add additional users, you have
to give users access to the fmserver$ share. For more information on
how to do this, see the paragraph remote administration permissions
in this chapter.

Configuring the GFI FAXmaker server remotely

In GFI FAXmaker 14, we recommend using Microsoft Terminal
services to configure GFI FAXmaker remotely.

Switching to another fax server to monitor

If you have multiple GFI FAXmaker fax servers in your network, you
can monitor them from the same monitor. To switch to another server:

1. Right-click on the root node, GFI FAXmaker configuration, and
select 'Connect to another computer'.

Screenshot 99 - Switch to another fax server to configure or monitor
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2. Key in computer name and click OK.

Remote monitoring permissions

By default, only administrators will be able to monitor the GFI
FAXmaker fax server remotely. If you want additional users to be able
to monitor GFI FAXmaker, you must give them either Read rights (to
monitor the fax server) or Full Control rights (to monitor and delete
faxes) to the ‘fmserver$’ share on the GFI FAXmaker server
machine. To give users the necessary rights:

1. Open Windows Explorer on the fax server machine.

2. Right-click the GFI FAXmaker directory and choose Sharing.

3. In the Share Name box, click on the down arrow and select
fmserver$.

Screenshot 100 - Sharing Tab

4. Click on Permissions.
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Screenshot 101 - Share permissions dialog

5. To add more users or groups to the Permissions tab, click Add.

6. Select the user or group you wish to give permission and select the
Type of Access you wish to give:

 Read: if you only wish the user to be able to view the Fax server
monitor and fax queue.

 Full Control: if you also wish the user to be able to delete faxes
from the fax queue.

7. Click OK to close the Tab.
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NetPrintQueue2FAX

Introduction to Netprintqueue2FAX

The Netprintqueue2FAX feature allows you to embed the fax number
in the document to fax. Through it you can print to fax from almost any
application, from anywhere in the network, without having to enter the
fax number separately in the GFI FAXmaker fax form or Outlook.

Simply through the embedding of a fax number in the document (for
example an invoice) a fax can be sent. No application integration or
development is required.

All that is needed is that the fax number is preceded by a
recognizable string, for example Fax: Faxes can be submitted to GFI
FAXmaker from anywhere in the network, because the
Netprintqueue2FAX printer driver is a network printer driver.

GFI FAXmaker will pick up the fax job, search for fax number,
recipient name and recipient company name, fax out the document
and notify the user who submitted the fax job whether the fax was
sent successfully or not.
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Configuring the Netprintqueue2FAX feature

Screenshot 102 - NetPrintQueue2FAX configuration

Access NetPrintQueue2FAX configuration by right-clicking
Configuration ► Properties.

Configuring search fields

You must specify the search fields, or strings that will precede the
recipient name, company and fax number strings. GFI FAXmaker will
search for these fields. For example if you specify To:, GFI FAXmaker
will look for the string 'To:', and when it finds it, take the text after the
string and assume this is the name of the recipient. Likewise for the
Company name and Fax number.

Configuring a delimiter

After GFI FAXmaker has found the search field and retrieved the
string that comes after the search string, it needs to know where the
end of the search string is. For example, if you enter a name 'John
Doe’ and more text follows on the same line, it needs to know that it
should 'stop' after the name ‘John Doe’. There are 2 ways in which
you can indicate this:

 By not putting any more text on that line. GFI FAXmaker will take
the end of line as the delimiter.

 By adding a delimiter; a character which identifies that this is the
end of the search string. Such a character can be # for example.
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You can configure which character you wish to use as a delimiter.

Installing the printer driver on clients’ machines

To use the NetPrintQueue2FAX feature from a client machine, the
printer driver must be installed on the client machine. This procedure
is the same as adding any other Windows network printer driver.

Windows Vista/7

1. On the client machine, from Control Panel select Hardware and
Sound ► Devices and Printers ► Add Printer ► Add a network,
wireless or Bluetooth printer and click Next.

2. Select NetPrintQueue2Fax printer from the list of found printers, or
click The printer that I want isn’t listed to manually type the path of
NetPrintQueue2Fax using the format
\\FaxServerName\NetPrintQueue2Fax.

NOTE: If GFI FAXmaker server uses a 64-bit infrastructure, the
NetPrintQueue2Fax printer driver needs to be installed. To do this:

a. Click OK in the ‘No driver found’ dialog to locate the driver
manually.

b. Browse to the GFI FAXmaker server and open shared folder
NetPrintQueue2Fax_Drivers.

c. Select npqf.inf and click Open to install the driver.

d. Windows will verify the publisher of the driver software. Click
Install this driver software anyway to proceed.

3. Click Finish to add the NetPrintQueue2Fax printer to the list of
printers.

Windows XP

1. On the client machine, select Start ► Printers and Faxes ► Add
a Printer and click Next.

2. Select A network printer… and click Next.

3. Select Find a printer in the directory to select
NetPrintQueue2Fax printer from the ‘Find Printers’ dialog.

4. If NetPrintQueue2Fax is not automatically found, close ‘Find
Printers’ dialog, select Connect to this printer and type the path of
NetPrintQueue2Fax using the format
\\FaxServerName\NetPrintQueue2Fax. Click Next to continue.

NOTE: When GFI FAXmaker server is installed in a 64-bit
environment, the printer driver of NetPrintQueue2Fax must be
installed. To do this:

a. In the ‘Connect to a Printer’ dialog click OK to locate the driver
manually.

b. Windows will verify the compatibility of the printer with Windows
XP. Click Continue anyway to proceed.

c. In the ‘Insert Disk’ dialog click OK to browse for the printer
driver.
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d. Browse to the GFI FAXmaker server and open shared folder
NetPrintQueue2Fax_Drivers.

e. Select npqf.inf and click Open to install the driver.

5. Click Finish to add the NetPrintQueue2Fax printer to the list of
printers.

Windows 2000/2003

1. On the client machine, from Control Panel select Printers ► Add
Printer ► Network printer and click Next.

2. Select Type the printer name… and either:

 type the printer path using the format
\\FaxServerName\NetPrintQueue2Fax, or

 click Next to browse for shared printers on the network and select
NetPrintQueue2Fax from the fax mail server.

3. Click Next to add the NetPrintQueue2Fax printer to the list of
printers.

Using the NetPrintQueue2FAX feature

Using the NetPrintQueue2FAX is no different from printing to a
network printer. Simply print from the application to the
NetPrintQueue2FAX printer driver. Your fax will be automatically
submitted to GFI FAXmaker and sent.

NOTE: You must include the search fields, and after the search fields
you must have entered the recipient fax number. The recipient fax
number is required. Other fields are optional.

If GFI FAXmaker fails to find the search fields in the document, it will
send an error report to the user. Otherwise, it will fax the document
and report back to the user as normal.

NOTE: User must be a GFI FAXmaker user.

Screenshot 103 - A document ready to be printed toNetPrintQueue2FAX
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Sending a fax broadcast using NetprintQueue2FAX

The NetPrintQueue2FAX feature can also be used to send out fax
broadcasts. Setup your mail merge in Microsoft Word, ensure that the
recipient information is included in each page and include at the end
of a document a fax separator. To send a fax broadcast using the
Microsoft Mail merge feature:

1. Create a database or file with recipient information, including. fax
number (required), Company name (Optional) and Recipient name
(Optional). You can either use an existing data file or create a new
one. For more information about this, consult the Microsoft Mail Merge
help/documentation.

2. Create the document that you want to fax broadcast. Include the
fax number, company name and recipient name fax fields in the
merge document.

3. Include the search fields that GFI FAXmaker has to search for in
front of the mail merge fields. After the mail merge fields, include the
delimiter character.

4. At the end of the document to be merged include the @#
characters at the beginning of a line. Ensure that the line after these
characters is empty. These 2 characters are referred to as the fax
separator characters, and indicate to GFI FAXmaker that the next
page is a new fax.

Why the fax separator is needed

When you create a mail merge to be fax broadcasted, you must
indicate the end of the merge letter, in the mail merge document. This
is because Microsoft Word will create one big print job out of the mail
merge, and GFI FAXmaker needs to be able to separate each merge
letter to individual faxes. When you create a mail merge, at the end of
the merge letter you therefore must add the fax separator characters.

5. When your merge is set-up, merge to the printer. After the mail
merge is created, print to the NetPrintQueue2FAX printer. GFI
FAXmaker will pick up the job, separate out the print job to individual
fax transmissions and send out the broadcast.

Use Text API commands

In addition to embedding recipient information in the document, you
can also add further commands at the top of the document to
schedule a fax, specify resolution etc. This works in the same way as
the Text API. Simply enter your commands at the top of the
document. GFI FAXmaker will remove these commands
automatically.

For more information regarding the Text API commands refer to the
GFI FAXmaker API manual available from
http://www.gfi.com/fax/fax14apimanual.pdf .

http://www.gfi.com/fax/fax14apimanual.pdf
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The SMS gateway

Introduction to the SMS gateway

GFI FAXmaker includes an email to SMS/texting gateway, enabling
users to send SMS/text messages from Outlook. SMS is very popular,
and is increasingly used for business purposes as well.

What is SMS?

The Short Message Service (SMS) is the ability to send and receive
text messages to and from mobile telephones. The text can comprise
of words or numbers or an alphanumeric combination. SMS was
created as part of the GSM Phase 1 standard. The first short
message is believed to have been sent in December 1992 from a
Personal Computer (PC) to a mobile phone on the Vodafone GSM
network in the UK. Each short message is up to 160 characters is
length when Latin alphabets are used, and 70 characters in length
when non-Latin alphabets such as Arabic and Chinese are used.

Why use an SMS gateway?

SMS messages can be sent from any GSM mobile phone, as well as
from several Internet based service providers. Using a central
company SMS gateway however have many advantages:

 Sending of messages from Outlook is much faster then from the
mobile phone.

 Sending of messages from Outlook allows you to use the outlook
contacts list.

 Sending of messages from Outlook allows you to keep a copy of
SMS messages sent.

 A web based SMS provider means additional administration costs
and means users will have to login to the service with their user
account. Additional steps for the user and additional administration
for the administrator.

 Because all SMS messages will be logged on the server, you can
ensure that sending of SMS messages will be used for business
purposes only

 Users will not use SMS to communicate with colleagues or
customers if they have to use their own mobile, because of the
charges involved.
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Requirements of the SMS gateway

To use the SMS gateway, you need to:

 Use a supported GSM modem connected to the GFI FAXmaker
fax server machine.

Or

 Subscribe to a supported web based SMS provider

We recommend using a GSM SMS modem, since then you can send
messages even when your internet connection is down. Furthermore
you can also receive messages, which is not possible using a
web2SMS service.

Supported mobile phones/GSM devices

For the latest list of supported mobile phones and GSM devices,
please see the following GFI knowledge base article at:

http://kbase.gfi.com/showarticle.asp?id=KBID001914

Web based SMS providers

If you want GFI FAXmaker to send the SMS’s via a web based service
provider, you can:

Use Clickatell, an SMS provider which has been preconfigured for use
with GFI FAXmaker. This is a web based SMS service which sends
SMS messages worldwide. The cost is about 4 Euro cents per
message. You can subscribe to the Clickatell service at:
http://www.clickatell.com/central/campaigns/redir.php?cid=870

Use a custom service that allows for SMS messages to be submitted
via SMTP.

Configuring the GFI FAXmaker SMS gateway

Once you have decided whether you want to use a mobile phone or a
web based SMS service to send out messages, you can configure the
SMS gateway. To do this:

1. Go to SMS ►SMS users node.

2. Right-click on the SMS user’s node and select ‘new SMS user’. In
the Active Directory user picker, select a single user, multiple users or
a group of users. Click OK. The users are now added to the SMS
user’s node.

http://kbase.gfi.com/showarticle.asp?id=KBID001914
http://www.clickatell.com/central/campaigns/redir.php?cid=870
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Screenshot 104 - Configuring SMS users

3. Right-click on the SMS node and select properties. Click on ‘Enable
SMS gateway’. Select from:

 Inbuilt SMS server (Requires compatible mobile)

 Generic SMS service provider template

 Clickatell Web2SMS service.
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Screenshot 105 - SMS options

4. In the SMS options tab you can configure:

 Send multiple SMS messages - Select this option if you want
messages that are longer then the allowed length to be split up
into multiple SMS messages. If chosen, then you must specify a
maximum of SMS messages allowed.

 Append user information to outgoing SMS message - This
option allows you to add one of the following sender information
fields either before or after the SMS message:

 Display Name, Name, Surname, Company or Department.

 Detect and remove personal signature - Some users forget to
delete their signature. GFI FAXmaker can detect this by only
sending the text before the first blank line.

 Enable automatic routing of incoming SMS messages - This
will enable automatic routing of SMS messages according to the
logic below.

If you chose using the inbuilt SMS server, go to ‘Configure the SMS
server’. If you chose a web service, go to ‘Configure the web2sms
service’.

Configure the Web2SMS service

Configuring a custom SMS service

Right-click SMS ► Properties and tick the ‘Enable SMS gateway’
option. Select Generic email SMS template. This template allows you
to configure how the SMS message is forwarded via email to your
SMS service provider.

You can control how the message and number will be inserted into
the body of the mail, and through which SMTP server and to which
email address the email has to be sent.
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Screenshot 106 - Configuring an SMS service provider

The following options have to be configured:

 SMTP server: Specify either your own mail server, or the mail
server of the service provider

 SMTP port: Specify the port number

 From: Specify what the from address should be

 To: Specify to which email address it should be sent. You can
specify the [smsnumber] in the email address, for example
[smsnumber]@yourprovider.com

 CC: Specify if you want a copy of the message sent to another
email address. Leave empty if you don’t want a CC to be sent.

 Subject: This allows you to specify a subject. You can include the
number variable if you want [smsnumber]

 Body line 1 - X: In each of the message body lines you can
specify 2 variables: [smsnumber] and [smstext]. The [smsnumber]
variable will be replaced by the recipient mobile number and the
[smstext] variable will be replaced by the SMS text to be sent.

In the preconfigured example, the number is sent via the subject, and
the body contains a number of lines including the message, the
credentials etc. Check with your SMS service provider how the SMS
will have to be forwarded and with what characters or strings you have
to identify the number and message text.
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Configuring the Clickatell service

Right-click on the SMS ► Properties and tick the ‘Enable SMS
gateway’ option. Select ‘Clickatell Web2SMS service’.

Screenshot 107 - Configuring the Clickatell service

The following fields have to be completed:

 API Identifier: This ID is assigned to you by Clickatell upon sign
up.

 From: Specify the sender of an SMS message, for example
‘Company’.

 User name: Assigned to you by Clickatell

 Password: Assigned to you by Clickatell

NOTE 1: This data will be provided to you when you sign up for the
service at www.clickatell.com. To sign up, simply click on the ‘Sign up’
button.

NOTE 2: When using the Clickatell SMS service, remember that the
country code must be included. The Clickatell service is located in
South Africa, and therefore it needs to know the country to which you
wish to send the SMS. You will also require making your network
users aware of this.
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Configuring the SMS server

If you have selected to use a GSM device, rather then a web based
service, you have to set-up the SMS server, which communicates
directly with the GSM devices to send and receive SMS messages.

There are two engines that can be used to use GSM hardware
directly; The GFI simple inbuilt GSM server and the inbuilt GSM
server. The former is developed and maintained by GFI and the latter
uses a third-party engine and is only recommended as a second
choice.

Configuring the GFI Simple Inbuilt SMS server

Right-click SMS node ► Properties. Tick the 'Enable SMS gateway'
option and select 'GFI Simple Inbuilt SMS server (Requires
compatible mobile)'.

Screenshot 108 - Configuring the GFI Simple Inbuilt SMS server

The following fields have to be filled in:

Service Center Number: This is the Service Center Number (SMSC)
given to you by your GSM network/SIM card provider. This field can
be left empty if you do not know this number since most GSM devices
can get this number directly from the SIM card.

 COM Port: This should be set to a single numeric value ranging
from 1 to 32. For example, if you connected your GSM device to
COM 1, you have to set this field to '1'.
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 Baud Rate: This is the speed in bits-per-second (bps) at which
your PC and GSM device talk to each other. This should be set to
a single numeric value. Valid values are 2400, 4800, 9600, 19200,
38400 and 57600. Make sure to check with the device
manufacturer for the best baud rate that the device can be used.
Some devices can only communicate at a set speed for example
9600bps.

 Initialization String: This is an optional field that only needs to be
set in case of a problem.

Configuring the Inbuilt SMS server

Right-click SMS node ► Properties and tick the 'Enable SMS
gateway'.

Screenshot 109 - Configure SMS server

1. Select ‘Use inbuilt SMS server (Requires compatible mobile)’

2. Configure the SMS server by clicking on the Configure SMS
Server… If no mobiles have been set-up yet, the "Add new mobile"
dialog will show up. In this dialog, select on which COM port you have
attached the mobile device. If this is not the first mobile being
specified, you can copy the mobile information from one of the
installed mobiles by using the “Copy settings from installed mobile:”
option. Once the COM port is selected, press OK.
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Screenshot 110 - General GSM Mobile Phone Properties

3. The GSM Mobile Phone Properties dialog will be shown. In this
dialog, the following options have to be configured:

 Mobile model: Check if the mobile that you are using is specified
in this list and if yes, select it. This will automatically set the
Advanced options of the GSM mobile phone. If your mobile
number is not listed, select "Generic Mobile (AT+C command
set)". Also specify:

o SMS Service Center Number: Mobile network provider's SMS
Center Number. This number is provided to you by your
mobile provider.

o Own number: Mobile phone number.

o Country code: Local country code number.
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Screenshot 111 - Advanced GSM Mobile Phone Properties

4. If you have selected a "Generic Mobile (AT+C command set)"
mobile, go to the Advanced tab to set up the mobile configuration. In
the Advanced tab, the following options have to be configured:

 Initialization string: Input the Initialization string for the mobile
device.

 Baud rate: Enables you to select how fast you want information
transferred through the port.

 Data bits: Enables you to select the number of data bits you want
to use for each character (in most cases 7 or 8).

 Parity: Enables you to select a method for error checking.

 Stop bits: Enables you to select a number of time units between
the transmitted characters.

NOTE: Only the mobiles listed under system requirements are
supported. If you are not able to configure a mobile using the settings
above, you will need to acquire a supported mobile.
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Screenshot 112 - In-built SMS Server Options

5. Once the mobile is set up, the "In-built SMS Server Properties"
dialog will be displayed. The GSM Devices tab contains the list of
configured GSM mobiles. The Options tab contains the following
options:

 Send outgoing SMS messages: Enable this option to send SMS
messages.

 Receive incoming SMS messages: Enable this option to receive
SMS messages. If this option is not enabled, the SMS messages
will remain in the mobile phone.

 Polling interval in seconds: Configures the interval for checking
for incoming messages: The greater the interval the more priority
is given to sending of messages.

Troubleshooting GSM SMS modems

Check the following issues:

 Check you have not configured GFI FAXmaker to use that port as
a fax modem.

 Check if the GSM modem is not installed as a modem in control
panel, this frequently causes other Microsoft applications such as
RAS or Microsoft Fax to attempt to take control of the modem.

 Test the SIM card with your mobile and ensure there is reception,
no pin number has been set, you have enough credits etc.
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Routing received SMS messages

The SMS gateway can receive and route SMS messages as well. This
option is only available if you are using a mobile phone to send and
receive SMS messages. To switch on receiving of SMS messages,
enable receive messages in the SMS server options dialog. Optionally
SMS messages can be routed according to the logic described below.
SMS routing can be switched on from the SMS properties dialog, SMS
options tab (right-click on the SMS properties node).

Screenshot 113 - SMS routing properties

GFI FAXmaker will route an inbound SMS message as follows:

1. SMS messages are routed to the person who recently sent a
message to that number. Outgoing SMS message recipients are
stored and associated with the user who sent the SMS. If an SMS
message is received, it will be assumed that the SMS is an answer to
the SMS the user sent, and therefore the SMS will be routed to that
user. See below for more information about the routing logic.

2. Any un-routed messages, i.e. messages with whom no user is
associated, are sent to the Default SMS router(s). The default SMS
router(s) can be configured from SMS routing properties dialog, which
can be accessed by right-clicking on the SMS ► routing node.

3. Optionally, all SMS messages, whether un-routed or not, can be
sent to 1 or more users configured in the ‘Receive all SMS messages
tab’.

Inbound routing rules/notes:
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1. The recipient's mobile is associated with the sender and a default
expiry date of 5 hours is given to the association. The association will
not expire if the mobile number is only assigned to one sender. Any
received SMS messages from the associated mobile number will be
routed to the original sender.

2. In the case where a second person sends an SMS message to an
already associated mobile number, the system makes a second
association to this sender based on the same rules. Any received
SMS messages from the associated number will be routed to both
senders.

NOTE: There is an exception where if the other associations of the
same mobile number are expired, the expired associations will be
removed from the associations’ database and the SMS is sent only to
the most recent sender.

3. For multiple associations, the system makes frequent checks for
the older-but-not-yet-expired associations, in which case, if expired,
they will be removed and only the latest association is kept.

NOTE: The association will be renewed (including expiry time) for
every SMS message a sender sends to the same mobile number.

Configuring SMS archiving

Refer to the 'Archiving directly to a database' section of the
‘Configuring fax archiving' chapter for more information on how to set
up database archiving.

NOTE: All inbound and outbound SMS messages are archived in the
same database as the fax archives when database archiving is
enabled.

SMS log files

To control SMS usage, GFI FAXmaker includes SMS log files which
show you when, where and what was sent via the SMS gateway. The
SMS log files are located in the server directory along with the fax log
files. The log files are called 'sms_sent.log' and 'sms_recv.log' for
sending and receiving respectively.

The log files are in CSV format as follows:

Date,Time,Sender,Recipient,Status,Message,Details

For example:

"4/29/2003","17:13:34","joebloggs@gfi.com","+4490092239","Succes
s","SMS: Hello SMS World!","Success". SMS posted to destination."

Sending an SMS

Directly from Outlook

To send an SMS from Microsoft Outlook, simply send the mail to
<number>@smsmaker.com

NOTE: Remove any email signature as this will be included with your
SMS message!
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Using the GFI FAXmaker SMS form

You can also use the GFI FAXmaker SMS form. This form will save
you having to type in an SMS number. When you select a recipient,
GFI FAXmaker will automatically retrieve the mobile number of the
contact.

NOTE: Ensure that the recipient’s mobile number field is keyed in.
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Billing

Enforcing Billing

GFI FAXmaker enables you to enforce the use of billing codes when
sending faxes. When the use of billing codes is enforced, faxes
without billing codes are not sent to the recipient.

To enforce billing codes:

1. Right click Billing ► Properties

Screenshot 114 - Enforcing billing options

2. Check ‘Every fax sent must include a billing code’ option to enforce
billing codes.

NOTE: For more information on how to specify and use billing codes
in Text or XML API refer to the GFI FAXmaker API manual available
from: http://www.gfi.com/fax/fax14apimanual.pdf

http://www.gfi.com/fax/fax14apimanual.pdf
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Advanced use

Installing GFI FAXmaker in a Microsoft Exchange cluster
environment

To install GFI FAXmaker in a Microsoft Exchange cluster
environment:

1. Install GFI FAXmaker on a machine that does not form part of the
cluster.

NOTE: The Microsoft Exchange cluster can either be Active/Active or
Active/Passive.

2. On each cluster node you will need to setup an Exchange SMTP
connector as described in the 'Installing the connector on a remote
Exchange server machine' section of the 'Installing GFI FAXmaker '
chapter.

The send log and receive log file

GFI FAXmaker logs all incoming and outgoing faxes in the following
two files: Sendlog.txt and Rcvlog.txt. The files are located in the GFI
FAXmaker ‘System’ directory. By loading these files in Microsoft
Excel, you can easily access this information.

Send log file

The following information is stored for each outgoing fax:

Date,Time,SenderEmail,SenderName,BillingCode,RemoteId,Recipien
tName,RecipientCompany,RecipientNumber,CallDuration,PagesTrans
ferred,Result,Info,Port,FilesInArchiveDir.

For example:

"22/12/96","22:18:16","nick@gfitest","nick","","88888888","nick","gfi","
nick_gfi_23 <fax@gfitest>","00:30","1","SUCCESS","Fax has been
sent successfully","COM2",""

Receive log file

The following information is stored for each incoming fax:

Date, Time, RemoteID, CallDuration, PagesReceived, Result, Info,
Port, FileInArchiveDir, RoutedTo.

For example:

"21/12/96","20:14:03","88888888","00:39","1","SUCCESS","Fax
received","COM2","","nick@gfitest,alexm@gfitest,bart@gfitest"
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The GFI FAXmaker Call accounting module/Log viewer

The Log view utility enables you to track of all outgoing faxes and
manage the costing for each fax, user, or recipient. The log view utility
is not included in the GFI FAXmaker set-up; it is downloaded
separately from the GFI website.

Setting up the Call accounting/Log viewer module

1. Set up ODBC to enable the export of the log file to an Access
database:

Screenshot 115 - Choosing the Microsoft Access Driver

a. From the Control Panel, Open ODBC and select the System DSN
tab. Click on the Add button and in the Create New Data Source
dialog, select Microsoft Access Driver. Click Finish.
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Screenshot 116 - ODBC Microsoft Access Set-up

From set-up dialog enter callacc as the data source name and enter
a description. In the Database section click Select, and locate the file
CallAcc.mdb found in the GFI FAXmaker directory. Click on OK and
save settings. You will now be able to start up the Log viewer from the
GFI FAXmaker program group.

Using the Call accounting/Log viewer module

In the Log viewer you will see an overview of each outgoing fax,
including information on who sent the fax, on which date, at what time,
recipient details, billing code used, call duration, number of pages, fax
line it was sent on, cost, and whether the fax failed or was successful.

You can customize the cost calculation tables by clicking Options and
choosing ‘Edit International Cost Table’, ‘Edit Long Distance Cost
table, and ‘Edit Local Cost table’. Customize your international dial out
code by choosing Options and ‘Edit Int. Dial Out code’.

You can export the log file by clicking Options ► Export.

Screenshot 117 - The GFI FAXmaker log view utility
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HP Digital Sender integration

GFI FAXmaker can support the use of an HP Digital sender. This
device is a scanner/copier, which allows you to send faxes directly
from the Digital sender device, simply by entering the document in the
tray and entering the fax number. This device eliminates the need for
traditional fax machines. The fax will still be sent via GFI FAXmaker
and the user will receive a confirmation in his mailbox.

Currently both HP Digital Sender 9100C and HP Digital Sender 8100C
are supported.

NOTE: HP Digital Sender 8100C requires a LAN fax firmware
upgrade to be used with GFI FAXmaker.

Screenshot 118 - HP Digital sender set-up

To enable faxes to be sent from an HP Digital sender:

1. In the HP Digital sender link applet, go to the Inbox page(tab). In
‘Path to receive inbox', provide a directory where the HP Digital
Sender will pick up the fax information files. Make sure that you check
the 'enable receive' option.
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Screenshot 119 - Configuring the Digital Sender

2. In the GFI FAXmaker configuration program click on advanced ►
HPDS node and right-click to display properties. Enable the Scan
folder for HPDS files option and enter the directory you specified in
the HP Digital sender app, and a subdirectory named '\HPFSCAN' to
the path. For example, if you have set a directory 'c:\hpdsfaxes' in the
HP Digital sender link applet, you would specify
'c:\hpdsfaxes\HPFSCAN' in the GFI FAXmaker configuration.

3. Go to HP Digital sender JetAdmin utility and 'Modify' your HP Digital
Sender to enable fax. Choose 'Other vendors with notification support'
as Network Fax Server.

Customizing transmission reports

GFI FAXmaker includes the possibility to customize transmission
reports. The default transmission reports can be edited in the
following way:

1. Open one of the following files in the ProgramFiles\GFI FAXmaker
directory: error.fbt (error transmission reports), recv.fbt (incoming fax
report) and sent.fbt (sent fax report).

2. Delete or add fields as required. The following fields are supported:

Status: <status>

Date: <date>

Time: <time>

Date/Time: <date_time>

Speed: <speed>
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Connection time: <connection_time>

Pages: <pages>

Total pages: <total_pages>

Resolution: <resolution>

Remote ID: <remote_id>

Local ID: <local_id>

Line number: <line>

Retries: <retries>

Description: <description>

DTMF/DID: <dtmf_did>

Subject: <subject>

Billing code: <billing_code>

Recipient last name: <r_last_name>

Recipient first name: <r_first_name>

Recipient name: <r_name>

Recipient company: <r_company>

Recipient department: <r_department>

Recipient email address: <r_email>

Recipient fax number: <r_fax>

Recipient phone number: <r_voice>

Sender last name: <s_last_name>

Sender first name: <s_first_name>

Sender name: <s_name>

Sender company: <s_company>

Sender department: <s_department>

Sender email address: <s_email>

Sender fax number: <s_fax>

Sender phone number: <s_voice>

Remember that not all fields are supported for each report!
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The Exchange 2000/2003 SMTP
connector

About the Exchange 2000/2003 SMTP connector

An SMTP connector for GFI FAXmaker is automatically configured
during setup. This SMTP connector is a standard Exchange SMTP
connector, pre-configured with the options required by GFI FAXmaker
to operate properly. In fact the connector can easily be created
manually as described further on in this chapter.

To access the connector do as follows:

NOTE: The exact path to connector properties may differ depending
on how you have configured Exchange Server.

Exchange Server 2000

1. Launch Exchange System Manager

2. Navigate to: Administrative Groups ► First Administrative 
Group ► Routing Group ► First Routing Group ►Connectors

3. Right click on GFI FAXmaker SMTP connector and select
Properties

Exchange Server 2003

1. Launch Exchange System Manager and expand the Connectors
node

2. Right click on GFI FAXmaker SMTP connector and select
Properties

Connector scope

An important setting is the connector scope. To access this option,
access the address space tab of the GFI FAXmaker SMTP connector
properties. By default, the GFI FAXmaker is configured to send out
faxes for its routing group only.

The connector scope controls which messages can travel through this
connector and determines the connector's availability to other servers
within your organization.

If you select Entire organization then all fax messages from your
entire company will go through this connector and will therefore be
sent out by the GFI FAXmaker server connected to this connector.
Select this option if you have multiple Exchange Servers in your
network but want all faxes to be sent by a single GFI FAXmaker
server.
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If you have an enterprise network with more then 1 Exchange Server
in multiple geographical locations, you probably will require several
fax servers, and you would use a routing group to control which faxes
are sent by this fax server. In this case, select ‘Routing group’ to
restrict the connector's use to this routing group.

Manually creating the connector

It is possible to manually create the GFI FAXmaker SMTP connector,
rather then have set-up do it automatically for you. A requirement of
this setup is that the GFI FAXmaker server must be installed on a
separate machine, i.e. not on the Exchange Server itself.

Exchange server must have an SMTP connector which routes to GFI
FAXmaker server, all emails addressed to faxmaker.com,
smsmaker.com and fax.:

To create this SMTP connector:

1. Launch Exchange System Manager and navigate to the
Connectors node as follows:

 In Exchange 2000 go to Administrative Groups ► First 
Administrative Group ► Routing Group ► First Routing 
Group ► Connectors.

 In Exchange 2003 go directly to the Connectors node.

2. Right-click on the Connectors Node, select ‘New->SMTP
Connector’ and provide it with a name: ‘GFIFAXmaker SMTP
connector’.
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Screenshot 120 - Specifying IP/Name of GFI FAXmaker machine

3. Select the option "Forward all mail through this connector to the
following smart host", and type in the IP of the GFI FAXmaker server
enclosed within square brackets [ ] (e.g.: [100.130.130.10]. You can
also specify the GFI FAXmaker server name if you wish.

Screenshot 121 - Adding a bridgehead
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4. Click on the ‘Add’ button in the local bridgeheads section, and
select the default virtual SMTP Server instance.

Screenshot 122 - Adding SMTP as address space

5. From the Address Space tab click Add, select ‘Other’ and click OK.
The Other Address Space properties dialog will appear.

Screenshot 123 - Specifying FAX as an address space

6. Key in ‘FAX’ in the type edit box. Leave ‘Cost’ and ‘Address’ as they
are. This will forward all mails addressed to fax: (the default MAPI
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addressing format for fax) to the GFI FAXmaker server. Click OK.
Repeat this process for SMS as well.

Screenshot 124 - Adding SMTP as an address type

7. To enable users to send faxes and messages using the SMTP
format <number>@faxmaker.com and <number>@smsmaker.com
(for sending sms/text messages), 2 other Address Spaces will be
added. From the Address Space tab click Add. In the Add address
space dialog, Select SMTP and click OK. The Internet Address Space
properties dialog will appear.

Screenshot 125 - Specifying GFI FAXmaker .com
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8. Specify the faxmaker.com domain by entering ‘*faxmaker.com’.
This forwards all mail for faxmaker.com to the GFI FAXmaker server.
Repeat for the smsmaker.com domain too. Click OK.

Screenshot 126 - The address space tab

9. In the connector scope section, select ‘Routing group’ to limit this
connector to a particular routing group. Click OK to create connector.

Screenshot 127 - Exchange system manager with the custom connector
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The custom connector routes all mail sent to the MAPI [fax:] address
and mail sent to faxmaker.com or smsmaker.com to the fax server.
Users can now send faxes from Microsoft Outlook in 2 ways:

 Using the MAPI fax: & SMS: format (which outlook uses when you
select a Business Fax recipient).

 By sending the mail to <number>@faxmaker.com or in the case of
SMS/text messages to <number@smsmaker.com>.
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The Exchange 2007/2010 connectors

About the Exchange 2007/2010 connectors

Connectors for Exchange 2007/2010 are created automatically when
GFI FAXmaker is installed on the same machine as Exchange
2007/2010. In case where GFI FAXmaker is not installed on the same
machine as Exchange 2007/2010, the receive connector needs to be
manually created through PowerShell commandlets. In addition, a
Send connector to Exchange 2007/2010 for address spaces
faxmaker.com and smsmaker.com also needs to be created.

Manually installing or removing receive connectors

Receive connectors enable GFI FAXmaker to send messages
(Transmission reports and administration messages) to users via
Microsoft Exchange Server 2007/2010.

To create or remove a receive connector for GFI FAXmaker in
Microsoft Exchange 2007/2010:

1. Launch “Exchange Management Shell” from Start Menu:

 To create - Run the following command "new-receiveconnector -
name "GFIFaxmaker" -Bindings "0.0.0.0:25" -RemoteIPRanges
"127.0.0.1" -AuthMechanism "ExternalAuthoritative" -
PermissionGroups "ExchangeServers" -fqdn "faxmaker.com""

 To remove - Run the following command "remove-
receiveconnector -Identity "GFIFaxmaker" -confirm:$false"

Configuring a send connector for Exchange 2007/2010

GFI FAXmaker requires a "Send" connector which handles two SMTP
address spaces (faxmaker.com and smsmaker.com) and two non-
SMTP address spaces (FAX: and SMS:).

1. From the Exchange management console select Organization
Configuration ► Hub Transport ► Send Connectors ► New
SMTP Send Connector.



154  The Exchange 2007/2010 connectors GFI FAXmaker 14.3 for Exchange/Lotus/SMTP

Screenshot 128 - New SMTP Send Connector

2. Provide a name for the new connector and choose “Custom” as the
intended use for this connector. Click Next to continue configuration.

Screenshot 129 - Add new address space
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3. Click on the Add button to add “faxmaker.com” and
“smsmaker.com” as address spaces. Click Next to continue
configuration.

4. In the Network settings screen choose ‘Route mail through the
following smart host’ option and key in the IP address of the machine
where GFI FAXmaker is installed. Click on Next to continue
configuration.

5. If required, in the Configure smart host authentication screen set
the authentication for the smart host. Click on Next to continue
configuration.

Screenshot 130 - Set source server

6. Set the Hub Transport Server for which the connector will be
associated with and click to finalize configuration.

Screenshot 131 - Exchange management shell

7. Launch Exchange Management shell console and key in the
following PowerShell commandlets:

 “new-sendConnector <name of connector> -
DnsRoutingEnabled:$false -Smarthosts:<IP of machine where GFI
FAXmaker is installed>”
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 AddressSpaces[0]: FAX:*

 AddressSpaces[1]: SMS:*

 AddressSpaces[2]:

Manually installing or removing foreign connectors

Foreign connectors are automatically created during installation of
GFI FAXmaker on Exchange 2007/2010 Hub Transport role. It
enables Microsoft Exchange 2007/2010 to intercept messages sent
by GFI FAXmaker to GFI FAXmaker domains (faxmaker.com,
smsmaker.com, etc). Intercepted messages are saved to the drop
folder in GFI FAXmaker installation where they are retrieved and
processed.

NOTE: When GFI FAXmaker is not installed on the same machine as
Exchange, this connector is not required and a Send connector will
have to be configured instead.

To manually create or remove a Foreign Connector for GFI
FAXmaker in Microsoft Exchange 2007/2010:

1. From command prompt, change directory to folder where GFI
FAXmaker is installed.

2. Use the following commands:

 To create - "fcadmin.exe -c -name "GFIFaxmaker" -
AddressSpaces
"SMTP:faxmaker.com,SMTP:smsmaker.com,FAX:*,SMS:*" -
DropFolderPath "<FAXmaker Folder>\SinkDrop""

 To remove - Run: "fcadmin.exe -d -name "GFIFAXmaker"
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Configuring Exchange Server 5.5 for
faxing

Introduction

GFI FAXmaker enables faxes and SMS to be sent and received by all
users on legacy Exchange 5.5 servers. To enable users to do this, the
Exchange 5.5 server must be configured to forward all mails sent to
the faxmaker.com and the smsmaker.com domains to the GFI
FAXmaker server. For more information on how GFI FAXmaker
integrates with Exchange 5.5 please see the chapter ‘GFI FAXmaker -
an overview’.

If Active Directory is used, you must ensure that the email address of
each GFI FAXmaker user has been entered in Active Directory. This
is not done automatically by Exchange 5.5. If you don’t use Active
Directory you have to configure the name and email address of the
GFI FAXmaker users. For more information, please see the
paragraph ‘Step 3: Specifying the fax administrator & users’ of
chapter ‘Installing GFI FAXmaker ’.
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Configuring Microsoft Exchange 5.5

1. From the Exchange Administrator Open the IMS connector object.

Screenshot 132 - The Exchange 5.5 connector properties

2. Select the ‘Connections’ tab.

Screenshot 133 - The email domains dialog
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3. In the ‘Message Delivery’ section click on the Email Domain…

Screenshot 134 - Edit email domain dialog

4. Click Add… to load the ‘Edit Email Domain’ dialog. Set the Email
Domain field to faxmaker.com.

5. Select the ‘Forward all messages for this domain to host’ option
and in the edit box underneath it enter the IP address for the machine
hosting the GFI FAXmaker fax server. Click OK and repeat the same
process for smsmaker.com if you are using the SMS gateway.

6. The ‘Email Domains’ dialog shows the domains configured and the
servers to which mail for those domains will be forwarded. Click OK to
exit the dialog.

7. In the main IMS connector properties dialog select the Address
Space tab and click on New…

Screenshot 135 - New address space

8. In the ‘New Address Space’ dialog select SMTP and click on OK.
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Screenshot 136 - Configuring SMTP address space

9. In the SMTP Properties dialog fill the fields under the General tab
as follows:

 Email domain: *

 Cost: 1

Click OK to confirm changes.

Screenshot 137 - The Internet Mail Connector configured for GFI FAXmaker
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10. Click OK to save all changes. Restart the IMS service from the
control panel for the new settings to take effect. The connector is now
configured to forward all mails to faxmaker.com and smsmaker.com
to the GFI FAXmaker fax server.

Disabling RTF for the faxmaker.com and smsmaker.com domains

After you have configured the domains, you must ensure that the
mails are forwarded as text and not as rtf. To do this:

Screenshot 138- Internet Mail Service properties

1. From the Exchange Administrator Open the IMS connector object.
Select the ‘Internet Mail’ tab. Click the ‘Email Domain…’ button.
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Screenshot 139 - Email domain

2. In the ‘Email Domain’ dialog that opens click on ‘Add…’

Screenshot 140 - Add Email domain

3. In the ‘Add Email Domain’ dialog enter the ‘Email Domain:’ as
faxmaker.com. Click on ‘Advanced options…’ button.
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Screenshot 141 - Advanced options

4. In the ‘Advanced options…’ dialog set the ‘Send Microsoft
Exchange rich text formatting:’ to Never. Click OK to confirm changes
in ‘Advanced options…’. Click OK to confirm changes in ‘Add Email
Domain’.

5. Repeat this process for the smsmaker.com domain.

6. Now click OK to save all changes. Restart the IMS service from the
control panel for the new settings to take effect.

Configuring the GFI FAXmaker users

After you have configured the Exchange 5.5 server, ensure that you
have configured all fax users as licensed GFI FAXmaker users and
entered their email address in Active Directory, or if you don’t have
active directory in the GFI FAXmaker user database. For more
information, please see the paragraph ‘Step 3: Specifying the fax
administrator & users’ of chapter ‘Installing GFI FAXmaker ’.
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Configuring GFI FAXmaker for Lotus
Notes

Introduction

GFI FAXmaker can be used as an Email2Fax gateway for Lotus
Notes, allowing users to address faxes using the @FAX method and
store fax recipients in their Lotus Notes address book.

In order to set this up, you must create a dedicated Notes mailbox
which will be used by GFI FAXmaker to receive faxes which GFI
FAXmaker must send out. Then you must configure a fax domain in
Lotus Notes, after which you can proceed to configure the GFI
FAXmaker Email2Fax gateway.

If you are configuring a Lotus Notes/Domino v6.5 server, you can
achieve the same result simply by configuring a foreign SMTP domain
on the Lotus server, to relay email to the GFI FAXmaker server.

The configuration of Lotus Notes/Domino is described in 3 separate
paragraphs, depending on whether you have Lotus Domino/Notes
v6.5, Lotus Domino/Notes v6, or Lotus Notes v4/5. The last paragraph
describes how to configure the GFI FAXmaker Email2Fax gateway.

If using Active Directory, you must ensure that the email address of
each GFI FAXmaker user has been entered in Active Directory. If you
don’t use Active Directory you have to configure the name and email
address of the GFI FAXmaker users. For more information, please
see the paragraph ‘Step 3: Specifying the fax administrator & users’ of
chapter ‘Installing GFI FAXmaker ’.

Configuring Lotus Domino/Notes server 6.5

Step 1: Allow mail relay from Lotus Domino/Notes server

1. On the GFI FAXmaker server, load the Internet Information
Services console.

2. Right-click on the Default SMTP Virtual Server node and select
Properties from the context menu.

3. Select the Access tab in the Default SMTP Virtual Server
Properties dialog, and click the Relay… button in the Relay
Restrictions group.
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Screenshot 142 - SMTP virtual server properties dialog

4. Select the Only the list below option.

Screenshot 143 - Relay restrictions dialog
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5. Click the Add… button to display the Computer dialog. Select the
Single computer option and specify the IP of the Lotus
Domino/Notes Server in the IP address field. Click the OK button.

6. Click the OK button to close the Relay Restrictions dialog.

7. Click the OK button to close the Default SMTP Virtual Server
Properties dialog.

Step 2: Add a foreign SMTP domain on the Lotus server

1. From the Domino Administrator select the Configuration tab.

2. Click on the Messaging ► Domains node.

Screenshot 144 - Adding a new domain

3. Click the Add Domain button.

4. From the New Domain page, select the Basics tab. Set the
Domain type to Foreign SMTP Domain.



168  Configuring GFI FAXmaker for Lotus Notes GFI FAXmaker 14.3 for Exchange/Lotus/SMTP

Screenshot 145 - Configuring the domain type

5. Select the Routing tab.

6. Under the Messages Addressed to section, set the Internet
Domain to: faxmaker.com,smsmaker.com

7. Under the Should be Routed to section, set the Internet host to
either the hostname of the GFI FAXmaker server or to the IP of the
GFI FAXmaker server enclosed in square brackets, for example
[192.168.1.2]

Screenshot 146 - Configure the routing settings
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8. Save and close the Foreign SMTP Domain entry and reload the
Domino router from the Domino server console with the following
commands:

tell router stop

tell router start

Configuring Lotus Domino/Notes server 6

Step 1: Create a mailbox database on the Domino server

Screenshot 147 - Creating a new database

1. From the Domino Administrator menu bar, Select File ► Database
► New

2. Select your Domino Server, select the mail directory and enter
GFIFAXmaker.nsf as the filename.

3. Click OK to create the database. The GFI FAXmaker mailbox
should then open in the Domino Administrator.

Step 2: Configure the Person for the GFI FAXmaker Domino
database

1. Using Domino Administrator, Click Add Person to add a domino
person to the domain.
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Screenshot 148 - Add a person

2. Fill in the following fields:

 Firstname = GFI FAXmaker

 Lastname = Mailbox

 Username = GFI FAXmaker

 Short name/UserID = GFI FAXmaker

 Internet Password (Will change to the encrypted password after
you enter it) = Choose a POP3 password.

 Mail System = POP or IMAP

 MailServer = Domino Server name

 Internet Address = The email address which will be able to
receive email on the server.

3. Click Save and Close.

Step 3: Give the GFI FAXmaker Person permission on the
GFI FAXmaker database

1. Using Domino Administrator open the GFI FAXmaker database.
File ► Database ► Open. Select the server and browse to the GFI
FAXmaker database created in Step 1. Click Open.
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Screenshot 149 - Open the GFI FAXmaker database

2. Using the Menu bar select File ► Database ► Access Control.

Screenshot 150 - Configuring permissions

3. Click Add and Add the GFIFAXmaker user created in Step 2.

4. Select the GFIFAXmaker Person.

5. On the Attributes section select User type: Person, Access:
Manager.

6. Tick the Delete Documents permission checkbox.

7. Click OK.
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Step 4: Remove default $POP3 View

Faxes delivered to the GFI FAXmaker database with by Foreign
Domain (i.e. 123@fax) will automatically be routed to the sent items
folder of the Mailbox. Therefore no items appear to be in the mailbox
(via POP3) unless you change the default POP3 view for the
database.

1. Load Lotus Domino Designer. From the menu bar select File ►
Database ► Open

2. Select Server to be your Domino server, select the mail directory
and select GFIFAXmaker.nsf

3. Select Views and then find the $POP view

Screenshot 151 - Removing the default POP3 view

4. Double-click the $POP3 View. Click OK to the warning prompt.

5. Select the following two lines and delete them from the $POP view
object.

DEFAULT DeliveredDate := “”;

SELECT DeliveredDate != “”

Screenshot 152 - Delete lines from $POP view

6. Save the changes and exit Domino Designer.
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Step 5: Add the FAX Foreign Domain

1. Load Domino Administrator.

2. Select the Configuration tab.

3. Select Messaging\Domains.

4. Click Add Domain.

5. Select Foreign Domain for Domain Type.

6. Enter fax as the Foreign Domain Name.

7. Select the Mail Information tab.

8. Enter the Domino server name (i.e. server/GfiAP) as the Gateway
server name.

9. Enter the mail\GFI FAXmaker .nsf as the Gateway Mail File Name.

NOTE: The fax number appears twice when GFI FAXmaker sends
the fax, if RFC822 phrase handling is enabled on outbound email. To
resolve this perform the following from Notes Administrator:

1. Select the Configuration Tab ► Messaging ► Configurations.

2. Click Edit Configuration on the server with the GFI FAXmaker
mailbox.

3. Select the MIME tab ► Advanced Tab ► Advanced Outbound
Message Options Tab.

4. Set RFC822 Phrase Handling to Do not add phrase.
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Configuring Lotus Notes 4 and 5

Step 1: Setting up a Fax database in Lotus Notes

In order to be able to use GFI FAXmaker with Lotus notes you must
set up a Notes mailbox which will be used by GFI FAXmaker to
receive faxes which GFI FAXmaker must send out. This mailbox must
be dedicated to GFI FAXmaker. To do this in Lotus Notes, you must
first create a database for the mailbox and then set up the mailbox. To
create the database you need to do the following:

Screenshot 153 - Creating a Notes Fax database

1. In the Notes Workspace select File ► Database ► New. The New
database dialog will now pop up.

2. In the server field select ‘local’.

3. Set the Title to ‘GFI FAXmaker ’.

4. The file name should display a path to the GFI FAXmaker database
file to be created.

5. The template server option must be set to ‘local’ and the template
selected must be Mail (R5.0/6.0).

6. Click on OK. The database is now created and shown on the
Workspace.

7. Right-click on the database just created on the Workspace and
select ‘Access Control’.

8. Ensure that manager rights with the option delete document
enabled have been given to the database.

Step 2: Define the database as a POP Mailbox

To define the Notes fax database as a POP mailbox:

1. Open the Notes Workspace.
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2. On the Server, open the server Address book.

3. Click on Add Person.

4. In the Basics Tab, in the ‘Name’ section enter a name and
password for the Mailbox and set the user name as ‘fax’. Keep note of
the password entered.

5. In the ‘Mail’ Tab, set the Mail system to be ‘POP or IMAP’.

6. The Domain and mail server in the mail section should be entered
according to the Notes system while the Mail file entry should be the
path and name of the files specified for the database in step 2 of how
to create the database above.

7. The Internet message storage option in the ‘Mail’ section must be
set to ‘Notes and Internet Mail’.

8. Click on the Save and Close.

Screenshot 154 - Setting up the POP mailbox for GFI FAXmaker

Step 3: Setting up of forwarding of the domain

1. From the workspace, open the address book.

2. In the address book select server, domains.
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Screenshot 155 - Setting up a Foreign Domain in Lotus Notes

3. Click on Add domain.

4. When the new domain window is displayed, go to the basics
section and select the Domain type to be ‘Foreign Domain’.

5. In the Foreign Domain name field enter the name of the domain
you want to set up (e.g. fax).

6. In the ‘Mail information’ Tab key in your server name (the server
where the GFI FAXmaker mailbox is found) in the ‘Gateway server
name’ (e.g. fax\gfi).

7. In the same tab enter the name of the GFI FAXmaker mail file (of
the GFI FAXmaker mailbox) in the ‘Gateway mail file name’ field (e.g.
mail\GFI FAXmaker .nsf).

Screenshot 156 - Foreign Domain options



GFI FAXmaker 14.3 for Exchange/Lotus/SMTP Configuring GFI FAXmaker for Lotus Notes  177

8. Click on Save and close.

Now all mails with the domain @fax will be forwarded to the GFI
FAXmaker mailbox.

Step 4: Modifying the GFI FAXmaker notes mailbox views

After configuring domain forwarding you would need to set up the GFI
FAXmaker mailbox views to allow the GFI FAXmaker MTA to see the
forwarded mail. This may be done as follows:

1. Log on the GFI FAXmaker mailbox client from a notes client.

2. Select design, Views.

3. Select ($POP3) and double click on it to open the view.

Screenshot 157 - Modifying the mailbox views: Selecting Design->Views->($POP3)

4. When the view setup is displayed, delete all the entries in the script
windows (lower window).

5. Save the view and close.
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Screenshot 158 - The ($POP3) view

Configuring the Email2Fax gateway in GFI FAXmaker

After configuring Lotus Notes/Domino, you are required to set-up the
Email2Fax gateway in GFI FAXmaker and ensure that each fax user
is configured as a user in GFI FAXmaker.

1. In the GFI FAXmaker configuration, right-click on the Email2Fax
gateway node and select properties.

2. In the General tab specify the name or IP of your Notes/Domino
server. This entry will be used to send inbound faxes and delivery
reports. If you are configuring GFI FAXmaker to work with a Lotus
Notes/Domino v6.5 server using mail relaying, you can skip to step 7.
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Screenshot 159 - The POP3 connector

3. Switch to the POP3 connector tab. Enter your mail server name or
IP and the POP3 port (usually 110).

4. Enter the mailbox name and password of the fax mailbox you
created on your Lotus Notes server (fax).

5. Specify the Fax server ‘Sender’ email address: Enter the email
address of the POP3 mailbox that is used for the fax server.

6. Specify PASS as login method.

7. Click OK and restart the GFI FAXmaker MTA service.

Configuring the GFI FAXmaker users

After configuring Lotus Notes server, ensure that configured all fax
users as licensed GFI FAXmaker users and entered their email
address in Active Directory, or if you don’t have Active Directory in the
GFI FAXmaker user database. For more information, refer to
paragraph ‘Step 3: Specifying the fax administrator & users’ of the
chapter ‘Installing GFI FAXmaker ’.
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Configuring an SMTP/POP3 server for
faxing

Introduction

If you are using an SMTP/POP3 server, there are 2 ways of setting up
the Email2Fax gateway for these mail servers:

1. Create a routing rule on your mail server which routes all messages
sent to the faxmaker.com and smsmaker.com domain to the GFI
FAXmaker Fax server machine. You will also need to install and
enable the IIS SMTP server on the GFI FAXmaker fax server
machine. This is the preferred option but requires that GFI FAXmaker
is not installed on the mail server machine itself.

2. Create a dedicated mailbox for GFI FAXmaker on your mail server,
which GFI FAXmaker will use to send and receive faxes, e.g.
fax@company.com. This option enables you to install GFI FAXmaker
on the mail server machine.

If Active Directory is being used, you have to ensure that the email
address of each GFI FAXmaker user have been entered in Active
Directory. If you don’t use Active Directory you have to configure the
name and email address of the GFI FAXmaker users. For more
information, refer to paragraph ‘Step 3: Specifying the fax
administrator & users’ of the chapter ‘Installing GFI FAXmaker ’.

Configuring the Email2Fax Gateway

After configuring your mail server to route mail either to the GFI
FAXmaker fax server or to a dedicated mailbox:

1. Right-click Email2Fax gateway ► properties.

2. From the General tab specify the name or IP of your mail server. If
your mail server requires authentication, specify authentication
details. This entry will be used to send inbound faxes and delivery
reports.

mailto:fax@company.com
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Screenshot 160 - Email2Fax Gateway setup

3. If forwarding all mail via a domain routing rule to (Option 1), no
further configuration is required.
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Screenshot 161 - The POP3 connector

4. If you chose to dedicate a mailbox (Option 2), switch to the POP3
connector tab. Enter your mail server name or IP and the POP3 port
(usually 110).

5. Key in the mailbox name and password of the fax mailbox you
created on your mail server.

6. Specify the Fax server ‘Sender’ email address: Enter the email
address of the POP3 mailbox that is used for the fax server.

7. Specify a login method, click OK and restart the GFI FAXmaker
MTA service.

Configuring the GFI FAXmaker users

After configuring the SMTP/POP3 server, ensure that you have
configured all fax users as licensed GFI FAXmaker users and entered
their email address in Active Directory, or if you don’t have Active
Directory in the GFI FAXmaker user database. For more information,
refer to ‘Step 3: Specifying the fax administrator & users’ of the
chapter ‘Installing GFI FAXmaker ’.
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Configuring SAP 4.7 for faxing

Introduction

GFI FAXmaker 14.1 natively supports the processing of fax requests
sent from SAP R/3 (Enterprise Release 4.7) suite of enterprise
software. This is achieved by directly configuring the ‘FAX Telefax’
parameters of SAP 4.7 to forward data for faxing to the server on
which GFI FAXmaker is running.

Configuring GFI FAXmaker as fax device for SAP 4.7

Very few parameters need to be configured in order to set GFI
FAXmaker as the faxing device for SAP 4.7. Parameter configuration
is handled entirely via the FAX Telefax ► SMTP node in SAP 4.7.
Paramters to be specified include:

 Mail Host - i.e. the name of the server on which GFI FAXmaker is
running

 Domain - which should be set to ‘FAXMAKER.COM’.

For a detailed guide on how to configure the above mentioned SAP
4.7 faxing parameters refer to
http://kbase.gfi.com/showarticle.asp?id=KBID003295.

.

http://kbase.gfi.com/showarticle.asp?id=KBID003295
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Troubleshooting

Introduction

The troubleshooting chapter explains how you should go about
resolving issues you have. The main sources of information available
to users are:

 The manual - most issues can be solved by reading the manual.

 The GFI Knowledge Base - accessible from the GFI website.

 The GFI technical support site.

 Contacting the GFI technical support team by email at
support@gfi.com.

 Contacting the GFI technical support team using our live support
service at http://support.gfi.com/livesupport.asp.

 Contacting our technical support team by telephone.

Knowledge Base

GFI maintains a Knowledge Base, which includes answers to the most
common problems. If you have a problem, please consult the
Knowledge Base first. The Knowledge Base always has the most up-
to-date listing of support questions and patches.

The Knowledge Base can be found on http://kbase.gfi.com/.

Request technical support via email

If, after using the Knowledge Base and this manual, you have any
problems that you cannot solve, you can contact the GFI technical
support team. The best way to do this is via email, since you can
include vital information as an attachment that will enable us to solve
the issues you have more quickly.

The Troubleshooter, included in the program group, automatically
generates a series of files needed for GFI to give you technical
support. The files would include the configuration settings, debugging
log files and so on. To generate these files, start the troubleshooter
wizard and follow the instructions in the application.

In addition to collecting all the information, you will be asked a number
of questions. Please take your time to answer these questions
accurately. Without the proper information, it will not be possible to
diagnose your problem.

Then click the troubleshooter\support folder, located under the main
program directory, compress the files in ZIP format, and send the
generated ZIP file to support@gfi.com.

mailto:support@gfi.com
http://support.gfi.com/livesupport.asp
http://kbase.gfi.com/
mailto:support@gfi.com
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Ensure that you have registered your product on our website first, at
http://customers.gfi.com.

We will answer your query within 24 hours or less, depending on your
time zone.

Request technical support via phone

You can also contact GFI by phone for technical support. Please
check our website for the correct numbers to call, depending on
where you are located, and for our opening times.

Technical support website:

http://support.gfi.com.

Ensure that you have registered your product on our website first, at
http://customers.gfi.com.

Web Forum

User to user technical support is available via the web forum. The
forum can be found at:

http://forums.gfi.com/.

Build notifications

We strongly suggest that you subscribe to our build notifications list.
This way, you will be immediately notified about new product builds.
To subscribe to our build notifications, go to:

http://support.gfi.com.

http://customers.gfi.com/
http://support.gfi.com/
http://customers.gfi.com/
http://forums.gfi.com/
http://support.gfi.com/
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