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Introduction

Cisco Supervisor Desktop for Cisco Unified Contact Center Enterprise (Unified CCE) is 
a robust computer telephony integration solution for single-site and multi-site 
IP-based contact centers that is easy to deploy, configure, and manage. It provides 
supervisors with powerful tools to increase productivity and improve customer 
satisfaction. 

The features of Supervisor Desktop allow you to view real-time statistics, monitor and 
coach agents, and barge-in, intercept, and record active agent calls when necessary, 
enabling effective management of agent resources.

Intended Audience

This document is written for contact center supervisors who use Supervisor Desktop 
on their computers.

What’s New in This Release

Cisco Agent Desktop 7.5 includes these new features:

■ Integration with Cisco Unified Presence Server

■ Multiple tabs in integrated browser

■ Additional keyboard shortcuts for improved accessibility

■ User interface now also localized in Canadian French and Norwegian

■ User documentation now also localized in Canadian French
July 2008 5
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Supervisor Desktop Feature Levels

There are three feature levels of Cisco Supervisor Desktop: Standard, Enhanced, and 
Premium.

The following table lists the features that are available in each feature level of 
Supervisor Desktop. Features that are not listed here are in all three feature levels.

Table 1. Supervisor Desktop features 

Feature Standard Enhanced Premium

Barge-in ● ● ●

Cisco Mobile Agent support ● ● ●

Cisco Unified Presence Server integration ● ● ●

Integrated browser ● ● ●

Intercept ● ● ●

Real-time displays (charts) ●

Real-time displays (text) ● ● ●

Recording ● ●

Silent monitoring ● ● ●

Skill statistics ● ● ●

Supervisor work flows—all actions except 
threshold alerts for tree control actions only

●

Supervisor work flows—threshold alerts for 
tree control actions only

● ●

Team messages ● ● ●

Web page push to agents ●
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n

Logging into Supervisor Desktop

NOTE:  If you want to use all of the functionality of Supervisor 
Desktop, you must first log into Agent Desktop. For more information, 
see the Cisco Agent Desktop User Guide.

To start Supervisor Desktop:

1. Choose Start > Programs > Cisco > Desktop > Supervisor. The Supervisor 
Login window appears (Figure 1).

2. Enter your Supervisor Desktop login name/ID and password in the 
appropriate fields, then click OK or press Enter. Supervisor Desktop starts.

NOTE:  After you log in, the application does not show any data and 
the status bar displays “No Service”. You must select a team from the 
Team drop-down list to display data.

NOTE:  The first time you log into Supervisor Desktop, the password is 
empty by default—all you need to enter is your Login ID. After you’ve 
logged in, create a password using the Change Password function.

NOTE:  The first time you log into Supervisor Desktop, the Login 
Name/ID field is empty. The next time you log in, the Login Name/ID 
field is automatically filled with the information you entered before. If 
you share a computer with another supervisor, verify that this field 
has your information and not the other supervisor’s information.

Figure 1. Supervisor Login window

NOTE: The 
Supervisor Login 
window prompts for 
either your name or 
your ID, depending 
on the method that 
your administrator 
configured.
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NOTE:  The first time you log into Supervisor Desktop, it may take 
some time for Supervisor Desktop to start because default report 
data must be generated.

Changing Your Password

Do not share your password with others. If someone else learns your password, 
complete the following steps to change it.

To change your password:

1. From the menu bar, choose Tools > Change Password. The Change Password 
dialog box appears (Figure 2).

2. Type your old password, your new password, and your new password again. If 
your old password was empty (blank), leave the Old password field empty.

NOTE: Passwords are a maximum of 32 alphanumeric characters.

3. Click OK. Your password is changed.

Access Through a VPN From Behind a NAT Firewall or 
Router

When a desktop is using network address translation (NAT) due to a firewall or router, 
then virtual private network (VPN) software must be used on the desktop to ensure 
full bi-directional network connectivity between the contact center servers and the 
desktop. Failure to use VPN software will result in connectivity issues and a loss in 
functionality such as silent monitoring failures and missing information in the agent 
tree.

NOTE:  Using a VPN is recommended in order to provide a more 
secure connection when using Supervisor Desktop outside the 
contact center.

Figure 2. Change Supervisor Password dialog box
8 July 2008



Logging into Supervisor Desktop
The VPN connection must be established before starting Supervisor Desktop. If the 
VPN connection is lost during a session, you must restart Supervisor Desktop after the 
connection is reestablished.

If Supervisor Desktop can log into all services except the Chat service, you must 
restart Supervisor Desktop after the Chat service comes back online. 

It has been verified that Cisco VPN 3000 Concentrator and Cisco VPN Client work 
properly with Supervisor Desktop, and are supported for access. VPN solutions from 
other vendors may work correctly, but since they have not been formally verified, they 
are not supported. If you want an alternative solution to be verified, please contact 
your Cisco distributor.
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Automated Updates

CAD enables your system administrator to update all instances of Supervisor Desktop 
automatically to a newer version.

Every time you launch Supervisor Desktop, the software checks to see if there is an 
updated version available, or if there was a system configuration change that requires 
a Windows registry change. If either of these conditions are true, the software 
automatically runs the update process.

When the update process runs, a dialog box appears, stating that your copy of 
Supervisor Desktop will be updated. Click OK and then follow the instructions in the 
series of dialog boxes that follows.

After the update finishes, a final dialog box appears, stating that your update is 
complete. Click OK, restart Supervisor Desktop, and log in as you usually do.

NOTE:  To ensure that automated updates function correctly, you 
must configure Internet Explorer so that it checks for newer versions 
of stored pages. To configure this setting, launch Internet Explorer 
and choose Tools > Internet Options. In the Browsing history section 
on the General tab, click Settings. Select the option labeled Every 
time I visit the webpage.

NOTE:  If the automated update fails, contact your administrator.
10 July 2008
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The Supervisor Desktop Window

The Supervisor Desktop window is divided into 5 areas:

■ The skill group tree, which lists all of the skill groups associated with the team 
you choose from the team drop-down list

■ The agent tree, which lists all of the agents and supervisors on the team

■ Tabular/graphical real time displays of skill group information

■ Tabular/graphical real time displays of agent and team information

■ Integrated browser (if enabled)

The Supervisor Desktop interface is highly configurable. By default, the browser is not 
enabled and the panes are not dockable. However, you can add or remove real time 
displays, enable the integrated browser, and enable all panes to act as dockable 
windows (so you can move them and resize them independently). You can also change 
the size of the toolbar icons from the default 16 × 16 pixels to 32 × 32 pixels.

The specific panes that are displayed depends on the nodes that you select in the skill 
group and agent trees. If you choose to enable the integrated browser, the real time 
displays and the browser appear on two tabs in the right pane. Figure 3 shows 
Supervisor Desktop with the integrated browser enabled and the default real time 
displays (Team Skill Statistics, Team Agent Statistics, and Team Agent State).

When Supervisor Desktop is in default layout (movable windows are disabled), Skill 
Groups real time displays occupy approximately the top half of the right pane, and the 
Agents real time displays occupy approximately the lower half of the right pane. The 

Figure 3. Supervisor Desktop interface

Skill group 
tree

Agent tree

Team 
selection

Status bar
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tree panes and real time display panes can all be resized by dragging the horizontal 
splitters up and down and the vertical splitters left and right.

If you choose to enable movable windows (see "Setting Preferences" on page 13), all 
of the real time display panes can be resized and moved anywhere on your desktop. 
However, each type of display can only dock to another display of its own type. In other 
words, Skill Group displays dock to other Skill Group displays and Agent displays dock 
to other Agent displays. For example, you cannot separate one Agent display from 
another Agent display, although they can be resized in relationship to each another 
(Figure 4).

Real time display panes are identified as containing information related to skill groups 
or agents by the text in their title bars (Figure 5). For more information about all of the 
available real time displays, see "Real Time Displays" on page 21.

Figure 4. Example of rearranged and resized displays

Figure 5. Identifying real time displays

These displays contain Skill 
Groups information and 
Agents information.

These displays are in 
“movable windows” mode: 
able to be resized and moved 
anywhere on the desktop of 
your computer.
12 July 2008



The Supervisor Desktop Window
Setting Preferences

The Preferences window controls the information that is displayed in the real time 
display panes and the behavior of those panes. Table 2 summarizes the parameters 
you can configure for skill groups, skills, teams, agents, and calls, using the 
Preferences window. 

Table 2. Configurable elements of Supervisor Desktop

Tree Control 
Node Available Real Time Displays

Configure
Columns?

Configure
Graphs?

Configure
Refresh? 

Skill Groups Team Skill Statistics Yes Yes Yes

Skill Skill Summary Statistics Yes No Yes

Skill Agent State Yes Yes No

Team Team Agent Statistics Yes Yes Yes

Team Agent State Yes Yes No

Agent Agent vs. Team Statistics Yes Yes Yes

Logs Agent Call Log Yes No No

Agent ACD State Log Yes No No

Calls Agent Active Call Yes No No

Enterprise Data Yes No No

Call History Yes No No
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To set your interface preferences:

1. Choose View > Preferences. The Preferences window appears (Figure 6).

2. In the left pane, select a node. The right pane displays that node’s settings. 

NOTE: If a display element is grayed out, it cannot be configured.

3. If you want to configure the columns that are displayed, complete the 
following steps.

a. Select Columns and click the ellipsis (…). The Configure Columns 
dialog box appears.

b. Select the columns you wish to appear in the display. Use the up and 
down arrows to set the order in which you want them to appear.

c. Click OK when done.

4. If you want to configure the chart that is displayed, complete the following 
steps.

a. Select Graphical displays and click the ellipsis (…). The Select charts 
dialog box appears.

b. Select the chart you wish to appear in the display, then click OK. You 
can select only one chart for each real time display. 

Figure 6. Preferences window
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5. If you want to configure the refresh rate, select Refresh rate in seconds and 
adjust the rate.

6. If you want to be able to rearrange the real time display panes, select the 
Enable movable windows check box.

7. If you want the toolbar icons to be 32 × 32 pixels instead of the default 
16 × 16 pixels, select the Enable Large Toolbar Icons check box.

8. If you want to have access to the integrated browser in Supervisor Desktop, 
select the Enable Integrated Browser check box.

■ To configure a home page that is different from the default of 
www.cisco.com, select the Browser node in the left pane. Enter a URL in 
the Browser home page field in the right pane, then click OK.

■ If you want to have access to more than one browser tab, complete the 
following steps.

a. Select the Browser node in the left pane. 

b. Select a number from 1 to 10 in the Number of Browser Tabs field in 
the right pane. 

c. For each additional browser tab, select the tab from the Browser Tab 
field, then enter a URL in the Browser home page field. If you do not 
enter a home page, the tab will not display.

9. If you want to have access to the Unified Presence server, select the Enable 
Cisco Unified Presence check box.

10. Click OK to save your configuration.

Agent Tree

The Agent tree displays all agents and supervisors on the selected team who are 
currently logged in. The icon next to the agent’s name indicates the agent’s current 
state. 

NOTE:  CAD-BE agents may close CAD-BE without logging out. If this 
happens, they will continue to appear in the Agent tree for 
approximately 1 minute. After 1 minute they are logged out 
automatically by the system if they were in a non-Talking agent state 
when they closed CAD-BE. If they were in the Talking state, they will 
not be logged out but will continue to appear in the Agent tree.

Formatting Agent Names in the Agent Tree

The Preferences window also enables you to control how agent names are displayed 
in the Agent tree.

An agent can be identified by one or all of the following:
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■ Name

■ Extension

■ Application used by the agent (CAD, CAD-BE, or IPPA)

■ Type of agent (mobile)

At least one of these must be selected to identify an agent in the Agent tree. 

If all options are selected, the information in the Agent tree appears as follows:

Jane Smith x1500 CAD-BE 
John Doe x1000 CAD 6125551234 (Mobile)

In this example:

■ Jane Smith is a CAD-BE agent. The number displayed is her extension. 

■ John Doe is a mobile agent. The number displayed as the extension is the CTI 
port that the agent connects to when logging in. The 10-digit phone number is 
the number of the phone device that the agent is using to handle calls. 

To format agent names in the Agent tree:

1. Choose View > Preferences, and then select the Agents node.

2. In the Format node text grid, check the elements you want to use to identify 
an agent. You must select at least one element. A sample of what the name 
will look like appears on the Sample line.

3. Click OK.

Restoring the Interface Default Layout

To restore your Supervisor Desktop to its default layout, open the Preferences window 
(choose View > Preferences), then click Restore default layout.

Clicking this button makes the following changes:

■ In the Real Time Displays pane, moves displays to their default positions:

— the Team Skill Statistics Display to the top

— the Team Agent Statistics Display to the middle

— the Team Agent State Display to the bottom

■ Disables the integrated browser

■ Disables movable windows

■ Disables any graphical real time displays you selected previously
16 July 2008



The Supervisor Desktop Window
Clicking this button does not make any of the following changes listed below. You must 
manually resize the columns yourself and reset the other two elements to their default 
settings in the Preferences window (see "Setting Preferences" on page 13).

■ Resize columns to their default widths

■ Restore columns to real time displays that you removed previously

■ Reset the report font size to the default (15)

Toolbar Buttons and Shortcut Keys

The following tables list the toolbar buttons and shortcut keys that you can use to 
navigate Supervisor Desktop.

Table 3 lists the toolbar buttons and shortcut keys for refreshing the data display.

Table 4 lists the toolbar buttons and shortcut keys for changing an agent’s state.

Table 5 lists the toolbar buttons and shortcut keys for call handling.

Table 3. Refreshing the data display toolbar buttons and shortcut keys

Icon Name Shortcut Description

Refresh Ctrl-F Refreshes the information in the data view pane.

Table 4. Agent state toolbar buttons and shortcut keys

Icon Name Shortcut Description

Logout Ctrl-L Logs the selected agent out of the ACD.

Ready Ctrl-E Changes the selected agent’s state to Ready.

Not Ready Ctrl-N Changes the selected agent’s state to Not Ready.

Work Ready Ctrl-D Changes the selected agent’s state to Work 
Ready.

Work Not 
Ready

Ctrl-Y Changes the selected agent’s state to Work Not 
Ready.

Table 5. Call handling toolbar buttons and shortcut keys

Icon Name Shortcut Description

Barge-in Ctrl-B Enables you to join an agent’s phone conversation.
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Table 6 lists the toolbar buttons and shortcut keys for communicating with your team 
and other supervisors.

Table 7 lists the toolbar buttons and shortcut keys for recording calls.

Table 8 lists the toolbar buttons and shortcut keys for monitoring agents.

Table 9 lists the shortcut keys for keyboard accessibility.

Intercept Ctrl-I Enables you to intercept a call while disconnecting 
the agent from the call.

Table 6. Team communication toolbar buttons and shortcut keys

Icon Name Shortcut Description

Chat Ctrl-J Opens the Chat Selection window.

Team Message Ctrl-X Opens the Team Message window.

Table 7. Recording toolbar buttons and shortcut keys

Icon Name Shortcut Description

Start Record Ctrl-R (Enhanced/Premium only). Starts recording the 
selected call.

Stop Record Ctrl-S (Enhanced/Premium only). Stops recording the 
selected call. 

Table 8. Voice monitoring toolbar buttons and shortcut keys

Icon Name Shortcut Description

Start Voice Monitor Ctrl-A Starts monitoring the selected agent.

Stop Voice Monitor Ctrl-P Stops monitoring the selected agent.

Voice monitor volume Ctrl-V Opens a volume slider control.

Table 9. Accessibility shortcut keys

Shortcut Description

Ctrl-Shift-S Selects the Skill Groups node in the Skill Groups tree.

Table 5. Call handling toolbar buttons and shortcut keys

Icon Name Shortcut Description
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Once you have set focus to the skill group tree, the agent tree, or the team node in the 
agent tree, you can use the tab key to navigate to the real time display panes. Once 
your focus is in a real time display pane, you can use the arrow keys to navigate 
around the display grid.

NOTE:  The tab key will move you among the real time display panes, 
but the order in which you access them will not necessarily be in sync 
with the physical arrangement of the display panes on your desktop.

Integrated Browser Pane

The integrated browser pane allows you to view internet and intranet web pages to 
help you assist agents and customers. The integrated browser has from 1 to 10 tabs, 
each of which can display a different web page. You configure each tab to display a 
specific website as your home page.

For more information about this pane, see "Using the Integrated Browser" on page 47.

Status Bar

The status bar displays current information about Supervisor Desktop (Figure 7).

In the event of a service failure, the Current Status section changes from “In Service” 
to “Partial Service” or “No Service.” To learn what features are affected by the service 
outage, double-click the Current Status section of the status bar to view a popup 
window that displays which features are active or inactive.

Ctrl-Shift-A Selects the Agents node in the Agents tree.

Ctrl-Shift-T Selects the Team node in the Agents tree.

Ctrl-H Selects and drops down the Team Selection List.

Table 9. Accessibility shortcut keys

Shortcut Description

Figure 7. Status bar

Current system time in 24-hour format
Current status of Supervisor Desktop features

User ID or name, as entered when logging in

User name
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For more information on the Current Status popup window and service auto-recovery, 
see "Service Autorecovery" on page 69.
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Real Time Displays

The real time displays contain the information you need to manage your teams and 
agents. Real time displays include the following:

■ Team Skill Statistics on page 21

■ Skill Summary Statistics on page 23

■ Skill Agent State on page 24

■ Team Agent Statistics on page 25

■ Team Agent State on page 26

■ Agent vs. Team Statistics on page 27

■ Agent Call Log on page 30

■ Agent ACD State Log on page 31

■ Enterprise Data on page 33

■ Call History on page 33

There are two types of displays: tabular and graphical.

■ Tabular displays present skill group, team, and agent information in a grid. 
Tabular information can be sorted in ascending/descending order by clicking 
any column header in the grid. You can sort by one column only.

■ Graphical displays present the same information as bar charts, except for 
Agent vs. Team Statistics, which is presented as two pie charts.

NOTE:  Graphical displays are available at the Premium level only.

Team Skill Statistics

The Team Skill Statistics Display is available when you select the Skill Groups node in 
the Skill Groups tree (Figure 8).

This display presents the details of each individual skill group, regardless of whether 
or not an agent with that skill is logged in. By default, the data displayed is sorted in 
ascending order by skill name. The data is obtained from the CTI server unless 

Figure 8. Team Skill Statistics Display
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otherwise noted, and is for the current day starting at midnight. The data refresh rate 
is configurable. By default it is every 15 seconds. The minimum rate is 5 seconds, and 
the maximum rate is 60 seconds.

Graphical displays of this information consist of bar charts with the skill name on the Y 
axis and any of the available statistics listed in the table below on the X axis, 
expressed in either an integer (0, 1, 2…) or time duration (hh:mm:ss).

Table 10. Team Skill Statistics Display data 

Name Description

Skill 
Name

The skill group identifier, as set up in Cisco Unified CCE. This column is 
required and cannot be disabled.

Agents The number of agents logged in.

Calls 
Waiting

The number of calls currently in queue waiting for an agent.

Current 
Oldest

The time of the oldest call in queue.

ASA Average speed of answer. The average time a caller waits in queue for 
an agent, calculated by dividing the skill group wait time by the number 
of calls answered by the skill group.

NOTE: This statistic is calculated from the columns PeripheralNumber, 
AnswerWaitTimeTo5, and CallsAnsweredTo5 in the tables t_skill_group 
and t_skill_group_real_time in the Cisco Unified CCE Admin Workstation 
(AW) HDS database, not from the CTI server. 

Calls 
Handled

The number of calls presented, answered, and completed by agents.

Talk 
Average

The average amount of time agents in the skill group spend in the 
Talking state.
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Skill Summary Statistics

The Skill Summary Statistics Display is available when you select a specific skill from 
the Skill Groups tree (Figure 9).

This display presents a summary of a specific skill group’s statistics. These statistics 
are from the entire contact center, not just from members of the selected team.

The data is obtained from the CTI server unless otherwise noted, and are for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
60 seconds.

There is no graphical display available for these statistics.

Figure 9. Skill Summary Statistics Display

Table 11. Skill Summary Statistics Display data 

Name Description

Skill Name The skill group identifier, as set up in Cisco Unified CCE. This 
column is required and cannot be disabled.

Agents The number of agents assigned to the skill group who are logged 
in.

Calls Waiting The number of calls currently in queue waiting for an agent.

Current Oldest The time of the oldest call in queue.

ASA Average speed of answer. The average amount of time a caller 
waits in queue for an agent, calculated by dividing the skill group 
wait time by the number of calls answered by the skill group. The 
data for this statistic comes from the AW HDS database, not from 
the CTI server. 

Calls Handled The number of calls presented, answered, and completed by 
agents.

Talk Average The average amount of time agents in the skill group spend in the 
Talking state.
July 2008 23



Cisco Supervisor Desktop User Guide
Skill Agent State

The Skill Agent State Display is available when you select a specific skill from the Skill 
Groups tree (Figure 10).

This display presents information about each agent logged into the ACD and assigned 
to the selected skill group. By default, the data displayed is sorted in ascending order 
by agent name.

The data is obtained from the Cisco Chat Service, and are for the current day starting 
at midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of this information consists of a bar chart with the ACD states on 
the Y axis and the number of agents on the X axis. 

Figure 10. Skill Agent State Display

Table 12. Skill Agent State Display data 

Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.

Skill Group The skill group ID of the ACD call the agent is currently servicing 
(in Talking state). If there is no call, or if the call is a non-ACD call, 
this field is blank.

State Duration The amount of time, in seconds, that the agent has been in the 
current ACD state.

Reason Code The reason why the agent is in the current ACD state. Reason 
codes are available for the Not Ready and Logout states only. 
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Team Agent Statistics

The Team Agent Statistics Display is available when you select the Team node or 
Agents node in the Agents tree (Figure 11).

This display presents the real time state of the agents on the selected team who are 
currently logged into the ACD. By default, the data displayed is sorted in ascending 
order by agent name.

The data is obtained from the CAD Recording & Statistics service, and is for the 
current day starting at midnight. The data refresh rate is configurable. By default it is 
every 15 seconds. The minimum rate is 5 seconds, and the maximum rate is 
30 seconds.

Graphical displays of the information consist of bar charts with agent names on the 
Y axis and the average amount of time (hh:mm:ss) the agent spent in a selected ACD 
state.

Figure 11. Team Agent Statistics Display

Table 13. Team Agent Statistics Display data 

Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Logon Time The total time the agent has been logged into the ACD today.

Calls Presented The number of inbound calls (ACD and non-ACD) presented to 
the agent today.

Calls Handled The number of inbound calls (ACD and non-ACD) presented to 
and answered by the agent today.

Max Talking The longest talk time of all calls handled today.

Avg Talking The average talk time and hold time of all calls handled today.

Total Talking The total talk time and hold time of all calls handled today.

Max Ready The longest time the agent spent in the Ready state today.

Avg Ready The average time the agent spent in the Ready state today.

Total Ready The total time the agent spent in the Ready state today.
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Team Agent State

The Team Agent State Display is available when you select the Team node or Agents 
node in the Agents tree (Figure 12). 

This display presents the performance details for each agent on the team. By default, 
the data displayed is sorted in ascending order by agent name.

The data is obtained from the Cisco Chat Service, and is for the current day starting at 
midnight. The data refresh rate is 1 second, and is not configurable.

The graphical display of the information consists of a bar chart with ACD states on the 
Y axis and the number of agents currently in each ACD state. 

Max Not Ready The longest time the agent spent in the Not Ready state today.

Avg Not Ready The average time the agent spent in the Not Ready state today.

Total Not Ready The total time the agent spent in the Not Ready state today.

Max After Call  
Work

The longest time the agent spent in the Work Ready or Work Not 
Ready states today.

Avg After Call  
Work

The average time the agent spent in the Work Ready and Work 
Not Ready states today.

Total After Call  
Work

The total time the agent spent in the Work Ready and Work Not 
Ready states today.

Other Time The total time the agent spent in states other than Talking, 
Ready, Not Ready, Work Ready, or Work Not Ready today.

Table 13. Team Agent Statistics Display data (continued)

Name Description

Figure 12. Team Agent State Display

Table 14. Team Agent State real time display data 

Name Description

Agent Name The agent’s name.

Agent ID The agent’s ID.

Current State The agent’s current ACD state.
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Agent vs. Team Statistics

The Agent vs. Team Statistics Display is available when you select a specific agent in 
the Agents tree (Figure 13).

This display presents the performance details for the agent and compares them to the 
performance details of the team. The data is obtained from the Cisco Recording & 
Statistics service, and is for the current day starting at midnight. The data refresh rate 
is configurable. By default it is every 15 seconds. The minimum rate is 5 seconds, and 
the maximum rate is 30 seconds.

Skill Group The skill group ID of the call the agent is currently servicing (in 
Talking state). If there is no call, or if the call is a non-ACD call, 
this field is blank.

Skill Name The skill group identifier, as set up in Cisco Unified CCE. 

State Duration The amount of time, in seconds, that the agent has been in the 
current ACD state.

Reason Code The reason why the agent is in the current ACD state. Reason 
codes are available for the Not Ready and Logout states only. 

Table 14. Team Agent State real time display data (continued)

Name Description

Figure 13. Agent vs. Team Statistics Display
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The graphical display consists of two pie charts, which show the percentage of time a 
specific agent spends in various ACD states compared to the percentages spent by 
the team as a whole (Figure 14).

The ACD states compared are:

■ Ready

■ Not Ready

■ Talking

■ After Call Work (Work Ready and Work Not Ready)

■ Other (all other ACD states not listed here)

Figure 14. Agent vs. Team Percent Time in State Display

Table 15. Agent vs. Team Statistics Display data 

Name Description

ID Identifies the statistics as for the selected agent or the team.

Logon 
Time

The amount of time the agent and team have been logged into Agent 
Desktop.

Calls 
Presented

Agent: The number of inbound calls (ACD and non-ACD) presented to 
the agent today.

Team: The total number of inbound calls (ACD and non-ACD) 
presented to all members of the team today.
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Calls 
Handled

Agent: The number of inbound calls (ACD and non-ACD) presented to 
and answered by the agent today.

Team: The number of inbound calls (ACD and non-ACD) presented to 
and answered by all members of the team today.

Max 
Talking

Agent: The longest talk time of all calls handled today.

Team: The longest talk time of all calls handled by any member of the 
team today.

Avg 
Talking

Agent: The average talk and hold time of all calls handled today.

Team: The average talk and hold time of all calls handled by all 
members of the team today.

Total 
Talking

Agent: The total talk and hold time of all calls handled today.

Team: The total talk and hold time of all calls handled by all members 
of the team today.

Max 
Ready

Agent: The longest time the agent spent in the Ready state today.

Team: The longest time any member of the team spent in the Ready 
state today.

Avg 
Ready

Agent: The average time the agent spent in the Ready state today.

Team: The average time all members of the team spent in the Ready 
state today.

Total 
Ready

Agent: The total time the agent spent in the Ready state today.

Team: The total time all members of the team spent in the Ready 
state today.

Max 
Not Ready

Agent: The longest time the agent spent in the Not Ready state today.

Team: The longest time any member of the team spent in the Not 
Ready state today

Avg 
Not Ready

Agent: The average time the agent spent in the Not Ready state today.

Team: The average time all members of the team spent in the Not 
Ready state today.

Total 
Not Ready

Agent: The total time the agent spent in the Not Ready state today.

Team: The total time all members of the team spent in the Not Ready 
state today.

Table 15. Agent vs. Team Statistics Display data (continued)

Name Description
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Agent Call Log

The Agent Call Log Display is available when you select the Logs node under a specific 
agent’s name in the Agents tree (Figure 15).

This display presents a history of the calls made and received by the agent during the 
current session. By default, the data displayed is sorted in ascending order by time of 

Max 
After Call 
Work

Agent: The longest time the agent spent in the Work Ready or Work 
Not Ready state today.

Team: The longest time any member of the team spent in the Work 
Ready or Work Not Ready state today.

Avg 
After Call 
Work

Agent: The average time the agent spent in the Work Ready and Work 
Not Ready states today.

Team: The average time all members of the team spent in the Work 
Ready and Work Not Ready states today.

Total 
After Call 
Work

Agent: The total time the agent spent in the Work Ready and Work Not 
Ready states today.

Team: The total time all members of the team spent in the Work 
Ready and Work Not Ready states today.

Other 
Time

Agent: The total time the agent spent in states other than Talking, 
Ready, Not Ready, Work Ready, and Work Not Ready today.

Team: The total time all members of the team spent in states other 
than Talking, Ready, Not Ready, Work Ready, and Work Not Ready 
today.

Table 15. Agent vs. Team Statistics Display data (continued)

Name Description

Figure 15. Agent Call Log Display
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day. The data in the report must be refreshed manually by clicking the Refresh button 
on the toolbar.

Agent ACD State Log

The Agent ACD State Log Display is available when you select the Logs node under a 
specific agent’s name in the Agents tree (Figure 16).

This display presents a history of the ACD states the agent transitioned through during 
the current session. By default, the data displayed is sorted in ascending order by time 

Table 16. Agent Call Log Display data 

Name Description

Start Time The time the call was answered.

Direction Inbound or outbound call.

Answered (Yes/No) Answered or unanswered call.

Calling Party The originating phone number.

Called Party The recipient phone number.

Call Duration The length of the call.

Figure 16. Agent ACD State Log Ddisplay
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of day. The data in the report must be refreshed manually by clicking the Refresh 
button on the toolbar.

Agent Active Call

The Agent Active Call Display is available when you select an active call under a 
specific agent’s name in the Agents tree (Figure 17).

This display presents information about each party in the current active call. 

Table 17. Agent ACD State Log Display data 

Name Description

State Start Time The time the agent state was initiated.

Agent State The ACD agent state.

Wrap-up Data Any wrap-up data the agent entered, if the agent state 
transitioned to is After Call Work (Work Ready or Work Not 
Ready).

Reason Code Any reason code the agent entered, if the agent state 
transitioned to is Not Ready or Logout (if required).

State Duration The length of time the agent was in the agent state.

Figure 17. Agent Active Call Display

Table 18. Agent Active Call real time display data 

Name Description

Name Name of the parties in the call, if known. If this data is not known, 
<Unavailable> is displayed.

Number The party’s phone number.

Call Status Hook state of the party (Active or Held).

Duration The length of time the party has been in the call.

Skill Group The skill group ID the called was queued to, if applicable.
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Enterprise Data

The Enterprise Data Display is available when you select an active call under a specific 
agent’s name in the Agents tree (Figure 18). The specific data that is displayed is 
configured by your administrator.

Call History

The Call History real time display is available when you select an active call under a 
specific agent’s name in the Agent’s tree (Figure 19). 

This display presents a history of the call’s presence in the contact center.

Figure 18. Enterprise Data Display

Figure 19. Call History Display

Table 19. Call History real time display data 

Name Description

Threshold The acceptable length of time that a call can stay at a specifc device 
or contact center. The administrator may assign caution and warning 
thresholds to each device type, as well as a total threshold for a call.

If a call remains at a device longer than the defined caution and 
warning thresholds, a caution or warning icon appears in this field.

Device A device that the call has passed through.

Type The type of device the call has passed through.

Description Description of the device.

Duration The amount of time the call spends at a device.

Total The sum of all the durations listed.
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Monitoring Agents

If your system configuration uses Cisco CallManager 4.x or Cisco Unified 
Communications Manager 5.x (Unified CM), CAD supports one kind of monitoring: 
CAD-based (agent-based) monitoring. 

If your system configuration uses Unified CM 6.0 or 7.0, CAD supports two kinds of 
monitoring: CAD-based monitoring and Unified CM-based (call-based) monitoring. 

The type of monitoring that is used is determined when the Cisco components of your 
system are installed. CAD uses either Unified CM-based or CAD-based monitoring, not 
both. Supervisor Desktop automatically determines which kind of monitoring is used 
when it is launched.

CAD-Based Monitoring

CAD-based monitoring is available whenever an agent is logged in to Agent Desktop. It 
is not available when:

■ You are a participant in a phone call (you cannot monitor yourself)

■ You use the Barge-In or Intercept function

NOTE:  Only one supervisor at a time can monitor a mobile agent.

When you use CAD-based monitoring, the monitored call is audible through your PC 
speakers. The volume slide on the Supervisor Desktop toolbar enables you to control 
the volume when monitoring an agent’s phone conversation. The system remembers 
your last volume setting and uses it the next time you log in.

In CAD-based monitoring, you can record while monitoring an agent.

To start monitoring an agent using CAD-based monitoring:

1. Choose an agent in the Agents tree.

2. Click the Start Voice Monitor button, or choose Intervention > Start Voice 
Monitor.

To stop monitoring an agent using CAD-based monitoring:

■ Click the Stop Voice Monitor button, or choose Intervention > Stop Voice 
Monitor.
34 July 2008



Monitoring Agents
Unified CM-Based Monitoring

Unified CM-based monitoring is available when an agent is logged into Agent Desktop 
and is on an active call. You must also be logged into Agent Desktop, and in the Not 
Ready agent state. It is not available when any ofthe following conditions are true:

■ You are a participant in a phone call.

■ The agent you want to monitor is not on a call or has a call on hold.

■ The agent being monitored is logged in as a mobile agent.

In Unified CM-based monitoring, when you start monitoring an agent’s call, a new call 
is directed to your IP phone and answered automatically. The phone does not ring. You 
can listen to the phone call through a headset, speaker, or handset. The new call on 
your IP phone, or your “monitoring call”, appears in Agent Desktop as an outbound call 
and also in the Supervisor Desktop tree control as an active call.

While you are monitoring a call, you cannot use the Barge-In, Intercept, Conference, or 
Transfer functions. You must stop monitoring to use one of these functions.

NOTE:  You cannot monitor an agent who is using IP Communicator.

NOTE:  Recording is not supported in Unified CM-based monitoring.

NOTE:  Unified CM-based monitoring is supported only on certain IP 
phone models. For a complete list of IP phone models that support 
Unified CM-based monitoring, see the Cisco CAD Installation Guide.

Your monitoring call does not end if the agent conferences in another party or if the 
agent closes Agent Desktop—Browser Edition. Your monitoring call (on your IP phone) 
ends when one of the following events occurs:

■ When the agent transfers or ends the monitored call

■ When you stop monitoring or exit Supervisor Desktop

■ When you or the agent exit Agent Desktop

To start monitoring a call using Unified CM-based monitoring:

1. Select a call under an agent in the Agents tree.

2. Click Start Voice Monitor or choose Intervention > Start Voice Monitor. The call 
is sent to your IP phone and answered automatically. The phone does not ring.

To stop monitoring a call using Unified CM-based monitoring:

■ Click Stop Voice Monitor, choose Intervention > Stop Voice Monitor, or end the 
call on your IP phone.
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Pushing a Web Page to an Agent

You can coach an agent by pushing a web page to that agent’s Agent Desktop 
integrated browser. 

To push a web page to an agent:

1. Select the agent in the Agent tree, and then choose Intervention > Coach by 
pushing a page. The Push URL to Agents dialog box appears (Figure 20).

2. Enter the URL of the web page you want the agent to see, then click Push to 
send the web page to the agent. The web page you pushed to the agent is 
displayed in the first tab of the agent’s integrated browser. This tab is 
reserved for pushed web pages.

NOTE:  There are no restrictions on what you can enter as a URL (for 
example, you are not required to prefix the URL with “http://”) as long 
as the URL can be resolved by a browser. Some sites require that 
“http” or “https” be part of the URL.

NOTE:  If the integrated browser is not enabled for the selected agent, 
this operation will fail, but no error message will appear.

Figure 20. Push URL to Agents dialog box
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Barging In on Calls

The Barge-In feature enables you to join an agent’s phone conversation. When you 
click the Barge-In button, you are automatically added to the phone call. It is a forced 
conference.

If notification is enabled, the agent sees a message that you are attempting to join the 
call, then sees a message that you have successfully joined it.

When you use the Barge-In feature, voice monitoring is disabled. You can, however, 
record calls.

You cannot barge in if any of the following conditions are true:

■ The agent is on hold

■ The agent is on two calls

■ The agent is in a conference call

■ You are already on another call

■ You are running CAD-BE

To barge in:

1. Select an agent call in the team view pane.

2. Click Barge-In or choose Intervention > Barge-In. You are added to the call.

NOTE:  At any time during the conference call, you may click Intercept 
to disconnect the agent whose call is selected from the conference 
call and continue talking with the remaining parties yourself.

To drop the barged-in call:

■ In Cisco Agent Desktop, select the conference call from the contact 
appearance pane, then click Drop.
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Intercepting Calls

The Intercept feature enables you to intercept a phone call while disconnecting the 
agent from that phone call. It is a forced transfer.

NOTE:  You can intercept a call only once per supervisor.

If notification is enabled, the agent sees a message that you are attempting to 
intercept the phone call, then sees a further message when the interception is 
successful.

When you use the Intercept feature, voice monitoring is disabled. You can, however, 
record calls.

You cannot intercept if any of the following conditions are true: 

■ The agent is on hold

■ The agent is on two calls

■ You are already on another call

To intercept a phone call:

1. Select an agent call in the team view pane.

2. Click Intercept or choose Intervention > Intercept. The call is transferred to 
you.

NOTE:  If you are intercepting a conference call you are on, the agent 
call you selected in the team view pane is dropped from the 
conference call, and all other participants in the conference call 
remain connected.

To drop the intercepted call:

■ In Agent Desktop, select the intercepted call from the contact appearance 
pane, then click Drop.
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Recording Calls

You can use Supervisor Desktop to record, save, and play back calls handled by 
agents on your team. Multiple recordings can be in progress at the same time, 
although only one recording may be made per agent at any one time. You use the 
Supervisor Record Viewer to review recorded calls. You can use the Barge-In, 
Intercept, and Voice Monitor features while recording. 

When recording a call, keep in mind the following considerations.

■ The recording feature is not intended to record every call. It is an on-demand 
solution only.

■ When you select a specific call from the Team View pane to record, all voice 
activity to and from that particular agent is recorded. The recording is not 
limited to the call you selected. For instance, if the agent puts the selected 
call on hold and switches to another call, both calls will be recorded.

■ The recording will end when the selected call terminates, or when you 
manually stop recording, whichever comes first.

■ Agents may be configured so that they can start and stop recording calls. 
However, agents cannot stop recordings started by supervisors. If an agent 
attempts to do so, their Agent Desktop or IP Phone Agent interface indicates 
that the recording is stopped. However, the recording is not stopped, and 
Supervisor Desktop displays an icon indicating that recording is proceeding.

■ You can stop a recording initiated by an agent.

■ If notification is off, agents have no way of knowing if you are recording their 
calls. If an agent attempts to start recording a call that you are already 
recording, the agent will see a recording icon on the call, although the agent is 
not in control of the recording.

■ When you or an agent record a call, a recording license is used. The license is 
released when the recording stops. If all recording licenses are in use when 
you attempt to start a recording, the recording will not start.

To record a call:

1. Choose the call you wish to record from the Agents tree.

2. Click Start Record, or choose Intervention > Call/Agent Start Recording.

3. When you are finished, click Stop Record, or choose Intervention > Call/Agent 
Stop Recording. The call is archived to the Recording service database, where 
it is automatically saved for seven days. 

NOTE:  If you want to save the recording for a longer period, you may 
do so for up to 30 days, after which it is deleted. For more information 
on playing and saving recordings, see "Using Supervisor Record 
Viewer" on page 65.
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Changing Agents’ ACD States

You can use Supervisor Desktop to change the ACD state of an agent on your team, 
including logging an agent out. 

NOTE:  If you log a CAD agent out, that agent will continue to appear in 
the agent tree and will be able to chat and receive team messages. If 
you log out a CAD-BE or IP Phone agent, that agent disappears from 
the agent tree.

To change an agent’s agent state:

1. From the Agents tree, select the agent whose state you want to change.

2. On the toolbar, click the appropriate agent state button.

NOTE:  There is a delay of about 2 to 3 seconds before the command 
to change agent state takes effect. To ensure you set the desired 
agent state, allow enough time between clicking Agent State buttons 
for the command to take effect.

NOTE:  If an agent state change fails, you will not see any failure 
message. You will know that an agent state change succeeds if the 
icon next to the agent’s name in the team view pane changes to the 
current agent state icon.
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Using Chat

Chat enables you to send instant messages to agents on your teams and other 
supervisors. In addition, if your configuration includes Cisco Unified Presence Server, 
you may be able to send instant messages to non-agents who are using Unified 
Presence Client.

With the integration of Cisco Unified Presence Server in CAD 7.5, the Chat Selection 
window has changed in the following ways.

■ Subject matter experts (non-agents) are now accessible from this window

■ Additional information about ACD state includes: 

— Icons representing ACD states appear to the left of agent names

— ACD state names appear to the right of agent names (for example, 
Not Ready)

■ Additional information about Unified Presence status includes: 

— Icons representing Unified Presence status appear to the left of 
agent names

— Unified Presence status labels are displayed to the right of 
non-agent names

In addition, the Chat Selection window also provides menu access to the following call 
handling functions:

■ Making a call

■ Transferring a call

■ Initiating a conference call

NOTE:  You cannot chat with Cisco Agent Desktop—Browser Edition 
(CAD-BE) agents or IP Phone agents.

Some Chat features include:

■ You can send the same chat message to multiple recipients (their replies, if 
any, appear in separate chat windows, one for each person).

■ You can participate in multiple concurrent chat sessions.

■ The title bar of the Chat window displays the name of the person with whom 
you are chatting.

■ If you flag a chat message as high priority, the Chat window will pop on the 
other person’s screen so the message will be noticed immediately. 
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■ If the priority of a chat message is normal (the default), the Chat window will 
remain in its current state (open or minimized) and the corresponding icon 
will flash on your Windows task bar.

■ A log of the chat messages sent between you and your chat partner (chat 
history) is available as long as the Chat window is open. After you close the 
Chat window, the log is lost.

■ Chat history is in chronological order, with the oldest messages at the top of 
the log pane.

■ You can chat with agents who are logged out of the ACD as long as they still 
have Agent Desktop open.
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To initiate a chat session:

1. On the toolbar, click Chat. The Chat Selection window appears (Figure 21).

NOTE: The window lists the names and status of people with whom you can 
chat: members of your team, other supervisors, and members of your contact 
lists (if you are logged into Unified Presence).

Figure 21. Chat Selection window

This Chat Selection window 
displays four contact lists, 
named Agents, Supervisors, 
contact list, and contact list 1. 
The first two contact lists are 
defaults and are always 
available. The last two contact 
lists are customizable and are 
available only when you are 
logged into Unified Presence. 
Note that the last contact list is 
closed (the members are not 
visible).
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2. To chat with one person, double-click that person’s name. To chat with several 
people, select their names and choose Actions > Chat. A Chat window opens 
and a session begins with the people you selected (Figure 22).

3. Type your message in the text entry field.

4. If you want your message to be noticed immediately by popping on the 
recipient’s screen, select the High priority check box.

Figure 22. Chat Session window

Chat history pane

Text entry field
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5. Click Send or press Enter. Your message is sent to your chat partner and 
logged in the chat log pane.

NOTE:  Replies from recipients of a group message appear in 
individual chat windows. They cannot reply to the group, they can 
reply only to you.

To terminate a chat session:

■ Choose File > Close or click Close in the upper right corner of the Chat 
window.

Predefined High-Priority Chat Messages

Agents may have a task button in Agent Desktop and CAD-BE configured to send a 
predefined high-priority chat message to their supervisor(s). This predefined message 
(for instance, “Please barge in on my call”) is configured by the administrator. It 
behaves just like a chat message that is flagged as high priority—it pops up on your 
screen on top of all other windows for your immediate attention.

Figure 23. Chat window
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NOTE:  Although a CAD-BE agent can send you a high-priority chat 
message using a task button, you cannot send a chat message back 
to that agent. CAD-BE agents do not have regular chat capability.
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Using the Integrated Browser

The integrated browser feature is available in the CAD Premium and Enhanced 
packages. The integrated browser allows you to view intranet and internet web pages 
from within Supervisor Desktop. By default, the browser is not enabled. For 
instructions on enabling the browser and configuring a home page, see "Setting 
Preferences" on page 13.

When enabled, the integrated browser appears as one or more tabs in the real time 
display pane, with up to 20 characters of the name of the current webpage displayed 
on the tab. The real time displays appear on another tab in that pane (the default 
position is the first tab). The integrated browser can display up to 10 tabs, each 
containing a different web page. The Address drop-down list contains the URLs of the 
last 10 websites visited for quick access to frequently-visited websites.

NOTE:  Internet Explorer must be installed on your PC for the 
integrated browser to function.

NOTE:  The tabbed browsing feature of Internet Explorer 7 is not 
available in the integrated browser.

NOTE:  Running Cisco Agent Desktop—Browser Edition (CAD-BE) in the 
integrated browser is not supported.

NOTE:  The integrated browser supports only one web session at a 
time for web applications that use cookies for session management. 
For example, you cannot log into a web application that uses cookies 
in one tab as User A and then log into the same web application in 
another tab as User B. However, multiple web sessions are supported 
for web applications that use URL-based session management.

Browser Toolbar

The browser toolbar is the basic Internet Explorer toolbar. It allows you to navigate 
among web pages you view, refresh a current page, and return to your home page.

Table 20. Browser toolbar buttons and shortcut keys 

Icon Name Shortcut Description

Back Alt+left arrow Returns you to the last page you viewed.

Forward Alt+right arrow Takes you to the page you viewed before 
clicking the Back button.

Stop Esc Stops the browser from loading a web page.
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Refresh F5 Refreshes the current web page.

Home Alt+Home Returns you to your predefined home page.

Table 20. Browser toolbar buttons and shortcut keys (continued)

Icon Name Shortcut Description
48 July 2008



Sending Team Messages
Sending Team Messages

You can send a team message to all agents on a team, whether or not the agent is 
logged into the ACD. As long as Agent Desktop is open, an agent can view a team 
message.

NOTE:  You cannot send team messages to CAD-BE and IP Phone 
agents.

The Team Message window (Figure 24) stores the last 10 team messages you 
broadcast. You can select any one of these messages to broadcast again. If you send 
more than 10 team messages, the oldest one drops off the stored list. You cannot 
designate any particular team message for permanent storage.

NOTE:  By default, the team message scrolls across the Team 
Message pane of Agent Desktop. Individual agents can set their 
preference in Agent Desktop to view team messages as stationary. A 
stationary message is more compatible with screen readers, which 
are often used by vision-impaired agents. 

The Current Message field displays the message that is currently being sent to your 
team.

To send a team message to all agents on a team:

1. From the team selection list, choose the team to which you want to send the 
message. Then click View > Team Messages or click Team Messages.

Figure 24. Team Message window
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2. Type your message in the text box. The message can be up to 255 characters 
long.

NOTE:  You must type a message before choosing an expiration time.

3. In the Expires at field, choose a specific time for the message to expire. 

By default, the message runs for 30 minutes. 

If you set a time earlier than the current time, the message will run until that 
time the next day. For example, if it is 10:15 AM and you set the expiration 
time to be 10:00 AM, the message will run until 10:00 AM tomorrow.

4. Click Start or press Enter. The message is sent to the team for the length of 
time you chose. The text of the message you sent is logged in the current 
team performance message field. 

To cancel a team message:

■ In the Team Message dialog box, click Stop.
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Creating Supervisor Work Flows

Using the Supervisor Work Flow Administrator feature, you can configure your desktop 
to perform certain actions based on queue statistics for calls waiting and calls in 
queue for specified skill groups. 

These work flows apply only to you, not to any other supervisors, and are available to 
you no matter where you log into Supervisor Desktop. They are tied to your login 
information.

In general, work flows consist of events, rules, and actions. 

■ The event that triggers an action is a skill groups queue statistics update. 
Queue statistics are updated once every 5 seconds.

■ The rule the event must meet is one or both of the following:

— The number of calls waiting is below, within, or above specified limits

— The oldest call in queue is below, within, or above specified time 
durations

■ The actions triggered by meeting the rules can be:

— Change the color of the skill group name in the tree control and/or add a 
message next to it

— Highlight data in the tabular real time display

— Display a popup message on your desktop

— Play a *.wav file on your desktop

— Send an email to selected recipients

For example, you can set up a work flow so that when there are more than 10 calls 
waiting in the queue for Skill Group 6500, the skill group name in the Skill Groups tree 
turns red and an audible warning sounds every 15 seconds. 

To set up a supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator. The Supervisor Work 
Flow List dialog box appears.

2. Click Add. The Add New Work Flow dialog box appears.

3. Enter a name for your new work flow, and then click OK. The Skill Group 
Selection dialog box appears.
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4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished. The Supervisor Work Flow Setup 
window appears (Figure 25).

NOTE: A skill group may be a part of only one work flow per supervisor.

5. Set up the parameters for the work flow:

a. Specify the upper and lower limits for the Call Waiting and/or Current 
Oldest threshold. 

NOTE: When you select both Calls Waiting and Current Oldest, the highest 
threshold crossed takes precedence.

b. Select Above from the Thresholds pane. 

c. Click Add, and from the resulting Action Type Selection dialog box, select 
the action you want to be triggered when the Calls Waiting and/or Current 
Oldest statistic is above the upper limit you set, and then click OK. See 
"Work Flow Actions" on page 56 for information on the types of actions 
available.

Figure 25. Supervisor Work Flow Setup window
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d. Repeat for the Within and Below thresholds.

6. When you have finished, click OK to enable the work flow.

Example: Setting Up a Supervisor Work Flow

The following is a step-by-step illustration of setting up a supervisor work flow. This 
work flow:

■ Changes the skill group name color to green and displays “Below” next to it in 
the Skill Groups tree control when there are less than 2 calls waiting, or if the 
current oldest call is less than 1 minute old

■ Changes the skill group name color to blue and displays “Caution” when there 
are 2 to 5 calls waiting, or if the current oldest call is between 1 and 5 
minutes old

■ Changes the skill group name color to red and displays “Warning” when there 
are more than 5 calls waiting, or if the current oldest call is more than 5 
minutes old 

To set up the example supervisor work flow:

1. Choose Tools > Supervisor Work Flow Administrator. The Supervisor Work 
Flow List dialog box appears.

2. Click Add. The Add New Work Flow dialog box appears.

3. Enter the name Customer Management, and then click OK. The Skill Group 
Selection dialog box appears.
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4. Select the skill groups you want your work flow to apply to from the Available 
Skill Groups pane and use the arrows to move them to the Selected Skill 
Groups pane. Click OK when finished. The Supervisor Work Flow Setup 
window appears (Figure 26).

5. Select the Calls Waiting check box and set the lower limit to 2 and the upper 
limit to 5. 

6. Select the Current Oldest check box and set the lower limit to 1 minute and 
the upper limit to 5 minutes.

Figure 26. Supervisor Work Flow Setup window
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7. Select Below in the Thresholds pane and then click Add under the Actions 
pane. The Action Type Selection dialog box appears (Figure 27).

8. Select Tree Control Node Action and then click OK. The Tree Control Action 
window appears (Figure 27).

9. Check Display Text and enter Below in the field. 

10. Check Change Text Color, click Set Color, choose green from the color palette 
displayed, and then click OK.

11. Repeat steps 7 through 10 for the Above and Within thresholds. For Above, 
select “Warning” as the display text and set the color to red. For Within, select 
“Caution” as the display text and set the color to blue.

Figure 27. Action Type Selection

Figure 28. Tree Control Action window
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12. When you are finished, click OK to enable the work flow. The skill group 
names will now be color-coded with text displayed (Figure 29).

Work Flow Actions

The work flow actions that can be triggered by threshold rules are:

■ Audible Alert Action (page 56)

■ Message Box Action (page 58)

■ Report Action (page 58)

■ Report Action (page 58)

■ Tree Control Action (page 59)

■ Email Alert Action (page 60)

Audible Alert Action

The Audible Alert action plays a *.wav file on your desktop whenever the threshold 
rules are met. By default, the file plays once, but you can also configure it so that it 
plays repeatedly at specified intervals. 

NOTE:  You can turn off audible alerts that are configured to repeat at 
intervals by choosing Actions > Supervisor Work Flow — Audio Off 
from the menu.

Your computer most likely has system *.wav files available that are used to signal 
standard Windows events. These files are a good source of sounds. 

NOTE:  Any *.wav file you select must be 50K or smaller.

Figure 29. Color-coded skill groups
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To set up an audible alert, in the Audible Alert Action dialog box (Figure 30) click Add 
New and then browse to the location of your selected *.wav file. If desired, set up a 
repeat interval, and then click OK.

Figure 30. Audible Alert Action dialog box
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Message Box Action

The Message Box action pops a message box containing a customized message on 
your desktop whenever the threshold rules are met. The message box is cleared by 
clicking OK.

To set up a message box, in the Message Box Action dialog box (Figure 31) type your 
message in the Message Text field, select the appropriate message icon, and then 
click OK.

Report Action

The Report action highlights in color the Calls Waiting and Current Oldest cells in the 
tabular Team Skill Statistics real time display when the data in the cell exceeds the 
threshold rules. 

To set up a Report action, In the Report Action dialog box (Figure 32) click Set Color to 
select the color to use for highlighting the display cells, and then click OK. 

If you select the Show Team Skill Statistics Report check box, then whenever a 
statistic changes that triggers a Report action, Supervisor Desktop automatically 

Figure 31. Message Box Action dialog box
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changes its focus to display the Team Skill Statistics report so that you will see the 
current report with the cells highlighted.

Tree Control Action

The Tree Control action enables you to select a color to apply to a skill group name 
and/or a message to display beside the skill group name in the Skill Groups tree 
control whenever the threshold rules are met.

To set up a Tree Control action, in the Tree Control Action dialog box (Figure 33) check 
the effect(s) you want applied to the skill group name. Click Set Color to select a text 
color, enter your own message or select from the drop-down list a predefined message 
(Caution or Warning) to appear next to the skill group name, and then click OK.

Figure 32. Report Action dialog box

Figure 33. Tree Control Action dialog box
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Email Alert Action

The Email Alert action enables you to send an email to specified people whenever the 
threshold rules are not met. 

The email messages have predefined subject lines, depending on what threshold rule 
is met. They are:

■ Skill: <skill group name>, Number of Calls Waiting is above upper limit

■ Skill: <skill group name>, Number of Calls Waiting is below lower limit

■ Skill: <skill group name>, Number of Calls Waiting is within upper and lower 
limits

■ Skill: <skill group name>, Oldest Call in Queue is above upper limit

■ Skill: <skill group name>, Oldest Call in Queue is below lower limit

■ Skill: <skill group name>, Oldest Call in Queue is within upper and lower limits

The email messages sent can consist only of the Subject line; a message in the body 
of the email is optional.

Figure 34. Email Alert Action Setup dialog box
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To set up an email alert action, complete the Email Alert Action Setup dialog box 
(Figure 34) as follows:

Use the Test button to check if the email alert action is configured correctly. When you 
click Test, a test email is sent to the email addresses in the To and BCC fields.

If the test email is successful, “Mail Sent Successfully” appears in the field next to the 
test button. If it is unsuccessful, “Mail Send Failed” appears. In that event, check your 
entries in the To, BCC, and Mail Server fields for accuracy and test it again.

Table 21. Email Alert Action Setup dialog box fields 

Field Description

From: Required. Enter your email address. The first time this dialog box 
is displayed the field is blank; thereafter it is automatically filled 
with what you previously entered.

To: Required. Enter the email addresses of the recipients, separated 
by a semicolon. The first time this dialog is displayed the field is 
blank; thereafter it is automatically filled with what you previously 
entered.

Mail Server: Required. The SMTP IP address or host name of the email server 
used to send the email. The first time this dialog is displayed the 
field is blank; thereafter it is automatically filled with what you 
previously entered.

BCC: Optional. Enter the email addresses of the recipients you want 
copied in on the email message. The first time this dialog is 
displayed the field is blank; thereafter it is automatically filled 
with what you previously entered.

Subject: The subject line is automatically generated by the action.

High Priority Select the check box if you want the email to be delivered with 
high priority. Leave it unselected for normal email delivery.

Message Pane 
(not labeled)

Optional. Enter a message to appear in the body of the email. 
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Re-skilling Agents

The Agent Re-skilling tool is a browser-based application that enables you to change 
the skill group designations of agents on your team, and quickly view skill group 
members and details on individual agents. Changes made to an agent's skill group 
membership take place immediately without need for the agent to log out and log in 
again.

The Agent Re-skilling tool can run in your integrated browser if the browser is enabled.

Re-skilling can be done on the agent level and on the skill group level. You can add 
and remove skill groups from an agent, or you can add or remove agents from a skill 
group. 

NOTE:  The new skill group shows up in the agent’s reports 
immediately. If it is a new skill group, it may take up to 19 minutes for 
skill group data to show up in Supervisor Desktop. To display data 
immediately, you can ask the system administrator to perform a 
manual Directory Services sync, or you can select another team in 
Supervisor Desktop and then return to the team to which you added 
the new skill group.

To add or remove skill groups from an agent:

1. From the menu, choose Tools > Agent Re-skilling > Site 1. The supervisor login 
window for the Agent Re-skilling tool appears (Figure 35).

NOTE: Your menu may display Site 1 only, or Site 1 and Site 2 only. The 
number of sites depends on the configuration of your system. These sites 
represent the servers on which the Agent Re-skilling tool is located. If you 
receive an error when you try to access a site, try another site until you find 
the site that is active.

Figure 35. Supervisor Login window
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2. Enter your Supervisor Desktop login name and password, and then click 
Login. The Agents window appears (Figure 36).

3. Use the search fields at the top of the window to locate the agent you want to 
re-skill. 

4. Select the agent by clicking the agent’s login name. The Edit Agent window 
appears (Figure 37).

5. In the Skill Groups pane you can:

■ Assign a new skill group to the agent. Click Add, and in the resulting 
Select Skill Groups for Agent window, check the skill group you wish to 
add, and then click OK.

■ Delete a skill group from the agent. Select the skill group you want to 
delete, and then click Remove.

Figure 36. Agents window

Figure 37. Edit Agent window
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■ Remove all skill groups from the agent. Click Remove All to delete all skill 
groups. Note that an agent must be assigned to at least one skill group.

6. Click Save to save your changes. At the top of the window a message appears, 
stating that the agent was saved successfully.

To add and remove agents from a skill group:

1. From the menu, choose Tools > Agent Re-skilling > Site 1. The supervisor login 
window for the Agent Re-skilling tool appears (Figure 35 on page 62).

NOTE: Your menu may display Site 1 only, or more sites (Site 2, Site 3, etc.). 
This depends on the configuration of your system. These sites represent the 
servers on which the Cisco Unified CCE Agent Re-skilling Tool is located. If you 
receive an error when you try to access a site, try another site until you find 
the site that is active.

2. Enter your Supervisor Desktop login name and password, then click Login. 
The Agents window appears (Figure 36 on page 63).

3. Click Skill Groups at the left side of the window to change the view to a list of 
skill groups.

4. Select the desired skill group from the list by clicking on its name, or use the 
search fields at the top of the window to locate the skill group. The Edit Skill 
Group window appears.

5. In the Agents in your team(s) pane you can:

■ Assign a new agent to the skill group. Click Add, and in the resulting 
Select Agents for Skill Group window, check the agents you wish to add, 
and then click OK.

■ Delete an agent from the skill group. Select the agent you want to delete, 
and then click Remove.

■ Remove all agents from the skill group. Click Remove All to delete all skill 
groups. A skill group with no agents assigned to it will not show up in 
Supervisor Desktop.

■ View an agent’s properties. Select an agent, and then click Open to view 
that agent’s record. You can only view this record, not edit it.

6. Click Save to save your changes. At the top of the window a message appears, 
stating that the skill group was saved successfully.
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Using Supervisor Record Viewer

The Supervisor Record Viewer (Figure 38 on page 66) displays all recordings made by 
your team over the last seven days as well as those you tag for 30-day extended 
lifetime. 

NOTE:  A license is used whenever you open the Supervisor Record 
Viewer, and is released when you close it. If no licenses are available, 
Supervisor Record Viewer will start but no recordings will be listed 
and the error message, “Licensing error” will be displayed. You must 
wait until a license is released and available for you to use in order to 
review any recordings. For this reason, it is important to close 
Supervisor Record Viewer after you are finished using it.

The recordings are archived as raw voice data packets; they can only be played back 
using the Supervisor Record Viewer. However, if you wish to save selected recordings 
as *.wav files, you can use the “Play and Save” button and save the recording to a 
folder in *.wav format.

Unless recordings are tagged for an extended lifetime, they are automatically deleted 
after seven days. 
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If a recording is tagged for the 30-day extended lifetime, it will not be deleted until that 
30-day period expires. If you delete it manually before the 30-day period expires, it is 
deleted during the next folder cleanup—cleanups run daily at midnight. 

The Supervisor Record Viewer displays the following information:

Figure 38. Supervisor Record Viewer

Figure 39. Supervisor Record Viewer toolbar

Table 22. Supervisor Record Viewer fields 

Column Name Description

Agent The agent whose call is recorded.

Play
Play & Save

Stop
Set Extended Lifetime

Set Normal Lifetime
Delete

Volume Control

Pause
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To start Supervisor Record Viewer:

1. From the Supervisor Desktop menu bar, choose Tools > Recorded Files. 
Supervisor Record Viewer starts with no day selected.

2. From the Day Select section, click one of the radio buttons to view the 
recordings made by your team on that date.

To listen to a recording:

1. From the Day Select section of Supervisor Record Viewer, click the radio 
button for the date of the recording you want to review.

You can also click the Extended Lifetime radio button to view a list of all 
recordings that have been tagged for extended 30-day archiving. 

2. Select the recording you want to review.

3. Click the Play button, or choose Recording > Play from the menu bar.

Use the Pause or Stop buttons to control the recording playback, and the 
volume slider to control the playback volume.

There is a progress bar at the bottom of the screen that shows where you are 
within the recording. You can click the progress bar and drag it backwards or 
forwards to rewind or fast forward the recording. You must click Play again 
after you reposition the progress bar to restart the playback.

NOTE:  Playing a recording while you are monitoring a call is not 
supported.

To save a recording:

1. Select the recording you want to save.

2. Click the Play and Save button, or choose Recording > Play and Save from the 
menu bar. The Save As dialog box appears.

Team The team to which the agent belongs.

Time The time the recording was made.

Duration The length of the recording in hh:mm:ss format.

Lifetime The length of time the recording is archived: Normal is 7 days, 
Extended is 30 days.

Date Recorded (Appears only when “Extended Lifetime” is selected in Day 
Select) The date the recording was made.

Table 22. Supervisor Record Viewer fields (continued)

Column Name Description
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3. Select a folder to save the recording to, enter a file name for the recording, 
then click Save. The recording plays and simultaneously is saved as a wav file 
to the location you selected.

To tag a recording for extended archiving:

1. Select the recording you want to archive for 30 days.

2. Click the Set Extended Lifetime button, or choose File > Set Extended Lifetime 
from the menu bar. The recording is tagged to be archived for 30 days from 
the date of recording.
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Service Autorecovery

The service autorecovery feature allows Supervisor Desktop to automatically recover 
its connection to the CAD services in the event of a service restart or a network 
outage.

When Supervisor Desktop detects that it is unable to communicate with a service 
(generally within three minutes of the service failure), the status bar displays “Partial 
Service” or “No Service” to indicate some or all of the services have failed.

When Supervisor Desktop detects that the service is again available (usually within 
one minute of service recovery), the status bar displays “In Service” to indicate that 
the services have recovered.

To learn more about the features that are affected by a service failure, double-click 
the status message on the status bar. Supervisor Desktop displays a popup box that 
lists Supervisor Desktop features and indicates if that feature is available or not due 
to the service outage (Figure 40).

Figure 40. Service Status popup window
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