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This guide contains information to install and use the MassHunter 
Quantitative Analysis Compliance Software.

What is MassHunter Quantitative Analysis Compliance 
Software?

21 CFR Part 11 is a result of the efforts of the US Food and Drug 
Administration (FDA) and members of the pharmaceutical industry to 
establish a uniform and enforceable standard by which the FDA will consider 
electronic records equivalent to paper records and electronic signatures 
equivalent to traditional handwritten signatures. For more information, see 
www.fda.gov/ora/compliance_ref/part11/frs/background/11cfr-fr.htm.

MassHunter Quantitative Analysis Compliance Software includes the 
following features which support 21 CFR Part 11 compliance:

• Security (tamper detection) of data, batches, and results

• Quant Audit Trail

• Roles that restrict actions to certain users

See the online help for more information on these features.
Agilent Technologies
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Getting Started Roadmap
Getting Started Roadmap

The following diagram shows the steps for administrators and other users to 
get started with MassHunter Quantitative Analysis Compliance Software. This 
guide and the online help explain these steps.

Install MassHunter 
Compliance Software

See page 3

Document roles and the 
actions (commands) 
that require each role

See pages 5-7Check integrity of batch files, 
which checks: 

• acquired data

• analysis results

• reporting results

Temporarily lock the 
application while you are 
away from the computer

See page 8
View Audit Trail

Protect reports using 
features of Excel

Normal Operation

Do you prefer to use 
existing Windows users 

and groups for roles?

Set up Windows users for 
default roles provided with 

Compliance Software

Set up Audit Trail Map with 
different Groups/Roles

See page 12

See page 14

Yes

See page 4Log in

Setting up Roles
(not required for routine operation)

Installation

See pages 15-17

See page 18
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Installation
Installation

Use the following procedure to install Compliance software. This installation 
procedure will install and enable Compliance software for Data Acquisition 
and Quantitative Analysis if those are present on the computer where you are 
installing Compliance.

1 Put the Compliance setup CD in the drive.

2 Double-click on the setup.vbs file on the CD.

For Data
Acquisition

3 These steps apply to the installation of Compliance for Data Acquisition 
only:

a When the confirmation message appears, click OK to start the 
installation.

b When complete, you will see the message: "Compliance installation for 
MassHunter Workstation Acquisition software is successful". If the 
Acquisition Compliance installation fails, you are given a chance to view 
the log file.

Successful install If installation for all components present on the computer is successful, the 
following message appears: "Compliance Installation Finished".

Failed install If installation for any component present on the computer is unsuccessful, 
then following message appears: "Compliance Installation Failed".

NOTE You must have the following minimum version numbers of MassHunter 
Workstation software components installed or Compliance installation is skipped 
for those components:

• Data Acquisition B.01.03

• Quantitative Analysis B.01.03

NOTE Once Acquisition Compliance is installed, it can only be uninstalled by uninstalling 
MassHunter Workstation software.
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Normal Operation
Log on to MassHunter Quantitative Analysis Compliance Software
Normal Operation

This section describes using MassHunter Quantitative Analysis Compliance 
Software.

Log on to MassHunter Quantitative Analysis Compliance 
Software

1 Double-click the Quantitative Analysis program icon on your desktop or 
select Programs > Agilent > MassHunter Workstation > Quantitative 
Analysis from the Windows Start menu.

2 Depending on how the MassHunter Quantitative Analysis Compliance 
Software is configured, you may be prompted for your user name and 
password. If your account is in a domain, enter your user name and domain 
into the User field in the format user@DNS_domain_name. To configure the 
login option, see “Change global settings” on page 19.

User Validation and Reason

If your Compliance system has been customized with roles, some 
commands in the Quantitative Analysis software may not be available to 
you. Other actions may require you to reenter your logon information or 
supply a reason. Some examples of this might be manually integrating a 
peak or disabling a calibration point. In that case, the following dialog box 
will be displayed when you initiate the command:

For more information on configuring these options, see:

• “Assign users to the appropriate user groups/roles” on page 16

• “Customize roles” on page 18
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Normal Operation
Check integrity of batch files
Check integrity of batch files

Use this procedure to check whether any files in a batch have been tampered 
with. This tool checks all files that are in a selected folder, such as batches 
(*.batch.xml files), acquired data (*.d files), report results (*.report.results.xml 
files). Checksum values (Hash codes) are checked for all file types. In addition, 
Audit Trail values are checked for batch and results files.

1 Select Programs > Agilent > MassHunter Workstation > Quant Tools > 
Check Batch Files from the Windows Start menu.

2 Select Select Folders from the File menu in the Check Batch Files window.

3 Click the Add button in the Check Batch Files Folder dialog box.

4 Select the folder of interest in the Browse For Folder dialog box. Often you 
will select the MassHunter Workstation Data folder or a subfolder as shown 
below.

5 Click OK on the Browse For Folder dialog box, then click OK on the Check 
Batch Files Folder dialog box.
MassHunter Quantitative Analysis Compliance Quick Start Guide 5



Normal Operation
Check integrity of batch files
6 Click the Run button  in the toolbar or select Start Check Batch from 
the CheckBatch menu to start checking files in the selected folder.

7 Review the results displayed in a table in the Check Batch File window. 
Files that have a security problem are indicated with an exclamation mark 
(!) in a red circle in the first column of the table. If a problem was detected 
with either the Hash Code (Checksum) or the linked Audit Trail for that 
file, an exclamation mark (!) in a red circle also appears in those columns as 
shown in the example below.

8 (optional) Select Show Error Records Only from the View menu to display 
only the rows (files) that have error conditions. Select the menu item again 
to return to the full display of data.

9 (optional) To copy the entire table to another application:

a Select Select All from the Edit menu.

b Select Copy from the Edit menu.

c The data can then be pasted into a word processing or spreadsheet 
application.

d To “deselect” the entire table, select other cells, rows, or columns with 
the mouse.
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Normal Operation
Check integrity of batch files
10 (optional) To copy selected data to another application:

a Drag the mouse to select the cells, rows, or columns of interest.

b Select Copy from the Edit menu.

c The data can then be pasted into a word processing or spreadsheet 
application.

11 (optional) To save the results in a file:

a Select Export from the File menu.

b Select a location for the export file.

c Enter a name for the export file.

d Select the format for the export file: .CSV, Tab-delimited (.TXT), or .XML.

e Click the Save button.

12 When you have finished checking files, select Exit from the File menu to 
close the Check Batch Files window.
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Normal Operation
View Audit Trail
View Audit Trail

Use this procedure to check audit trail entries for a batch. Audit trail 
information is available for all batches that were created with the Enable 
Audit Trail checkbox selected on the New Batch dialog box.

1 If not already open, open the batch of interest by selecting Open Batch from 
the File menu.

2 If the batch has not yet been analyzed, select Analyze Batch from the 
Analyze menu.

3 Select Audit Trail from the Tools menu in the Quant application window to 
open the Audit Trail dialog box. An example is shown below:

4 You can change or add entries in the Comment column for actions that 
were performed in the current session. Actions from the current session are 
indicated by a marked checkbox in the InSession column for their row.
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Normal Operation
View Audit Trail
Filter by Name 5 Audit information can be filtered to make it easier to review as shown in 
the following example.

a Click on the Filter icon in the Name column heading to open a list of 
commands:

b If you select CmdManuallyIntegratePeak, then only the manual 
integration actions will appear in the Audit Trail table:

c To return to the full display, click on the Filter icon in the Name column 
heading and select All from the list of commands.
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Normal Operation
View Audit Trail
Group by
Command

6 Audit information can be grouped by command as shown in the following 
example.

a Right-click in the Name column, and select Group by Name from the 
shortcut menu, which results in a list of commands:

b To view the actions for a particular command, click on the + icon next to 
the command name of interest, as shown for manual integration below:

c Click on the - icon to close the list.

d To return to the regular display, right-click in the Name column, and 
deselect Group by Name from the shortcut menu.

Sort Table 7 To sort the actions in the audit trail table, click on the column heading that 
you want to use for sorting.

Export Table 8 Right-click in the table and select Export from the shortcut menu.

a On the Export dialog box, select the folder and enter a File name for the 
export file.

b Select the Type for the export file (Excel .xls, CSV .csv, Tab Delimited 
.txt, or XML .xml).

c Click the Save button.
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Normal Operation
View Audit Trail
Print or
Preview Table

9 Right-click in the table and select Print or Print Preview from the shortcut 
menu.

Custom
Filtering

10 You can select other criteria for filtering audit trail information as follows:

a Click on the Filter icon in the column heading of interest to open a list of 
commands, as shown for the Command Name column below:

b Select Custom to open the Filter Criteria dialog box.

c Open the list of Operators and select one, such as Equals, Does not 
equal, Less than, and Greater than.

d Open the list of Operands and select one. The items in the list depend on 
which column you select in step a).

e (optional) To add more criteria to the filter, click the Add a condition 
button. Select either And conditions or Or conditions for the filter.

f Click OK to filter the Audit Trail table using the specified criteria.

g To return to the full display, click on the Filter icon in the column 
heading and select All from the list of commands.
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Normal Operation
Protect reports
Protect reports

Reports generated by MassHunter Workstation Quantitative Analysis software 
as Excel worksheets (.xls files) are not intended to be edited. The following 
features help ensure that these report files are not tampered with after they 
are generated.

1 The templates used to generate the reports can be customized to use 
password protection. This causes an error message to be displayed when a 
user tries to edit any cell in the worksheet. This option can be set in the 
Options section of the template.

2 The reports can be reviewed with the Excel Viewer, which does not allow 
files to be edited. Another benefit of using the Excel Viewer, in addition to 
security, is that it loads more quickly than the full Excel product.

3 You can visually compare Excel reports to detect changes as follows:

a Open both reports in Excel and select the Calibration tab in each report.

b Mark the Compare Side by Side option on the Excel Window menu and 
visually compare the two reports, such as calibration curves, final 
concentrations, etc.

c Click the Synchronized Scrolling icon shown below to facilitate 
reviewing and comparing the two documents.

4 You can use a third-party tool to compare two Excel documents, such as the 
one available from Formula Software, Inc. This tool allows you to compare 
all sheets that have the same names in two workbooks and is most useful 
for Quant reports that have been generated with the same template. You can 
specify that deleted, added, and changed data be reported on separate 
worksheets, and that the compared sheets be replicated into a new report 
workbook for easy review.
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Normal Operation
Lock your computer screen when unattended
5 You can generate PDF files of your reports as follows:

a Install Adobe Acrobat and specify a folder to store the generated PDF 
files.

b Analyze your batch with MassHunter Workstation Quantitative Analysis 
software.

c Select Report > Generate to open the Report dialog box. Select the 
reports to be generated, assign unique output file names, and specify 
Adobe PDF as the printer for each report. Click OK to begin processing 
the reports.

d Open the Queue Viewer from the Report menu to monitor the progress 
of report generation.

e The PDF report files (.pdf) that are generated can have signatures, 
approval workflows, comments, and password-protection features 
enabled. 

Lock your computer screen when unattended

When you are going to be away from your computer for awhile, use the 
following procedure to lock your computer so that it can’t be accessed by 
others.

1 Press Ctrl+Alt+Delete.

2 Click Lock Computer.

To unlock your computer on your return, press Ctrl+Alt+Delete, type in your 
password and click OK.
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What are roles?
Using Roles to Restrict Actions

What are roles?

Roles are groups that users can be assigned to that establish the actions (or 
commands) that users can perform in MassHunter Quantitative Analysis 
Compliance Software. The software defaults to four roles: 
QuantBatchAnalyzer, QuantBatchReviewer, QuantMethodDeveloper, and 
QuantReportGenerator, which are automatically installed with the 
Compliance software. If desired, roles can be set up using your own Windows 
group names as described in “Set up roles using existing Windows groups”, 
and roles can be customized as described in “Customize roles” later in this 
section.

Set up Windows user groups for Quantitation Compliance 
roles

Use the following procedure to create user groups for the above four roles on 
the computer where you are running MassHunter Quantitative Analysis 
Compliance Software.

1 Open Computer Management.

a Select Administrative Tools from the Control Panel.

b Select Computer Management.

NOTE Skip this section if you prefer to set up roles using your own Windows groups 
instead.
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Using Roles to Restrict Actions
Set up Windows user groups for Quantitation Compliance roles
2 In the Computer Management window, select System Tools > Local Users 
and Groups > Groups from the navigation pane on the left side of the 
window.

3 Select New Group from the Action menu to open the New Group dialog box.

4 Type in a name for the new group (i.e. QuantBatchAnalyzer, 
QuantBatchReviewer, QuantMethodDeveloper, or 
QuantReportGenerator).
MassHunter Quantitative Analysis Compliance Quick Start Guide 15



Using Roles to Restrict Actions
Assign users to the appropriate user groups/roles
5 (optional) Type in a description of the group.

6 (optional) Click the Add button to add users to the group at this time. This 
can also be done later as described in “Assign users to the appropriate user 
groups/roles” on the following page.

7 Click the Create button.

8 Repeat Steps 3-7 for the other three groups.

Assign users to the appropriate user groups/roles

Use this procedure to add users to the appropriate user groups, keeping in 
mind the privileges and restrictions of each role in MassHunter Quantitative 
Analysis Compliance Software described on the previous page.

1 Open Computer Management as follows:

a Select Administrative Tools from the Control Panel.

b Select Computer Management.

2 In the Computer Management window, select System Tools > Local Users 
and Groups > Groups from the navigation pane on the left side of the 
window.

3 Right-click on the group of interest (i.e. QuantBatchAnalyzer, 
QuantBatchReviewer, QuantMethodDeveloper, or 
QuantReportGenerator) and select Properties from the shortcut menu.

4 Click the Add button on the Group Properties dialog.

5 On the Select Users dialog box, type in the user names in the text box that 
you want to add to the group, then click the Check Names button. The 
complete computer name and user name will be filled in for each user.

6 Click OK to complete the process.

Alternate method If you are adding a single user to a group, it may be easier to access User 
Accounts as follows:

1 Select User Accounts from the Control Panel.

2 Select the user you want to add to the group on the Users tab in the User 
Accounts window, then click the Properties button to assign that member 
to one of the Quantitation Compliance groups.

3 If the user you want to add to the group does not already exist on the local 
machine, click the Add button to add them to the local machine and to the 
desired Quantitation Compliance group.
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Using Roles to Restrict Actions
Set up roles using existing Windows groups
Set up roles using existing Windows groups

Instead of using the roles provided with MassHunter Quantitative Analysis 
Compliance Software, you can use existing Windows groups or create new 
ones as follows.

1 Set up Windows user groups, using your own names.

2 “Assign users to the appropriate user groups/roles”, as described above.

3 Open the Audit Trail Map (ATM) Configuration window by clicking the 
program icon on the desktop or by selecting Programs > Agilent > 
MassHunter Workstation > Quant Tools > ATM Configuration from the 
Windows Start button.

4 Log in using the appropriate account name and password.

5 Delete the existing roles (i.e. QuantBatchAnalyzer, QuantBatchReviewer, 
QuantMethodDeveloper, or QuantReportGenerator) as follows:

a Right-click on the role in the Required User Role pane and select Remove 
User Role from the shortcut menu. Click Yes to confirm the deletion.

b Repeat Step 5a) for all the roles you want to remove.

6 Create new roles using the Windows user groups you created in Step 1 as 
follows:

a Right-click on a role in the Required User Role pane and select Add User 
Role from the shortcut menu.

b Repeat Step 6a) for all the roles you want to add.

7 Customize roles as described below.

NOTE You must be a member of a group called QuantAdministrators in order to open the 
ATM Configuration window. If this group does not already exist, you must create it 
and add a user account to it before you proceed.
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Using Roles to Restrict Actions
Customize roles
Customize roles

Use this procedure to assign the roles are required for various actions or 
commands in the MassHunter Quantitative Analysis Software. Assigning a role 
to an action or command means that a user must be a member of that role in 
order to run that action or command.

1 If the Audit Trail Map (ATM) Configuration window is not already 
displayed, open it by clicking the program icon on the desktop or by 
selecting Programs > Agilent > MassHunter Workstation > Quant Tools > 
ATM Configuration from the Windows Start menu. Log in using the 
appropriate account name and password.

2 Select a command from one of the four command groups (Batch Analysis, 
Batch Review, Method Development, or Report) on the left side of the 
ATM Configuration window.

3 Mark a Required User Role for the command in the upper right part of the 
window.

4 (optional) Mark the Requires Command Reason option in the lower right 
part of the window to optionally require that a user enter a reason when 
they run the selected command.

5 (optional) Mark the Requires User Validation option in the lower right part 
of the window to optionally require that a user enter their user name and 
password when they try to run the selected command.

6 Repeat Steps 2 - 5 for all actions or commands that you want to assign to 
roles.

7 (optional) Add new command groups by right-clicking on Command 
Groups and selecting Add Command Group from the shortcut menu. Type 
in the name of the new group and click OK.

NOTE You must be a member of a group called QuantAdministrators in order to open the 
ATM Configuration window. If this group does not already exist, you must create it 
and add a user account to it before you proceed.

NOTE If no Required User Role is selected for an action or command, then that action or 
command can be run by all users.
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Using Roles to Restrict Actions
Change global settings
8 (optional) You can drag commands to move them from one group to 
another. A command can only be in one group. Be sure to mark the 
appropriate Required User Role for commands that you move.

9 When you have finished customizing ATM, select Save from the File menu.

Change global settings

Use this procedure to set certain global settings for MassHunter Quantitative 
Analysis Software.

1 If the Audit Trail Map (ATM) Configuration window is not already 
displayed, open it by clicking the program icon on the desktop or by 
selecting Programs > Agilent > MassHunter Workstation > Quant Tools > 
ATM Configuration from the Windows Start button. Log in using the 
appropriate account name and password.

2 Click Settings on the left side of the ATM Configuration window. The global 
settings window appears in the right pane.

3 Mark the Require Logon at application start time option if you want to 
require users to log in with a Windows user account in order to start the 
MassHunter Quantitative Analysis Software. This user account is used for 
Audit Trail, User Validation, and Role-based command security. If not 
marked, then the user session account is used. This option is useful if you 
are running Quantitative Analysis on the same computer that is used to 
acquire data from the instrument. In that case, a different user can perform 
Quantitative Analysis while data is being acquired, and both users will be 
identified.

4 Mark the Always Enable Audit Trail when creating a new Batch option if 
you want to create audit trails for all batches. When marked, the Enable 
Audit Trail checkbox at the bottom of the New Batch dialog box will be 
unavailable at all times. 

NOTE You must be a member of a group called QuantAdministrators in order to open the 
ATM Configuration window. If this group does not already exist, you must create it 
and add a user account to it before you proceed.
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Using Roles to Restrict Actions
Change global settings
If the Always Enable Audit Trail when creating a new Batch option is not 
marked, then users can choose to turn audit trails on or off when creating a 
new batch file as shown below.

5 Mark the Load settings from option if you want to load an ATM 
Configuration from a specified path name. This is useful for larger labs that 
may want to maintain a central ATM configuration file for use on all 
systems and not have to configure settings on individual computers.

6 Select Save from the File menu.
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Agilent Web Site
Where to Find More Information

You can access more information about MassHunter Quantitative Analysis 
Compliance Software as follows.

Agilent Web Site

To view support information for MassHunter Quantitative Analysis 
Compliance Software and other Agilent products, see: 
http://www.agilent.com/chem and access the Mass Spectrometry products page.

MassHunter Workstation Software Online Help

You can access MassHunter Workstation online help from the Help menu in 
the software or by pressing F1 in the MassHunter Workstation dialog boxes.
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In This Book

This guide contains 
information to install and use 
the MassHunter Quantitative 
Analysis Compliance 
Software.
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