
© KEYENCE CORPORATION, 2003 C NKVS-UM-4-0602 Printed in Japan

本手册的结构:
Visual KV 系列产品用户手册由 3 个单独的手册组成；1-安装，2-支
持软件， 3-编程。
请根据您的用途阅读各手册。
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安全预防措施

本使用手册介绍了 KV 系列 PLC (可编程逻辑控制器) 的操作与功能。请仔细阅读本
手册以确保使用安全和最大限度地发挥产品的性能。

标志

以下标志为重要信息的警示符，请仔细阅读这些信息。

不遵守这些指示，可能导致人员伤害（电击、灼伤等）。

不遵守这些指示，可能导致产品损坏。

为确保正确操作而提供的附加说明。

约定

本手册介绍了所有 KEYENCE KV 系列 PLC (可编程逻辑控制器) 的操作与功能。
在使用过程中，请注意下列约定：

一般预防措施

• 在启动和操作过程中，应检查 KV 系列 PLC (可编程逻辑控制器) 功能和性能是否
正常。

• 我们建议采取切实的安全预防措施，以避免发生故障时造成任何损坏。

• 不得拆开或对 KV 系列 PLC (可编程逻辑控制器) 进行改造，也不得违反规格进行使用。

• 当 KV 系列 PLC (可编程逻辑控制器) 与其它仪器组合使用时，因使用条件，环境
等不同，有时不能充分发挥出其应有的功能与性能，降低了它的使用性能。

• 不得将 KV 系列 PLC (可编程逻辑控制器) 用于人体保护的目的。

注： 首次开机时，接通 KV 系列产品的供电电源，内置显示器会显示错误信息 “Error
40”（错误 40）。按显示器周围的任意键，可取消该信息。
如未载入任何程序，Visual KV 系列也会显示该信息。

警告

小心

注：

(1)

Visual KV（系列） KV-10AR/AT/DR/DT KV-16AR/AT/DR/DT
KV-10xx, 16xx, 24xx, 40xx KV-24AR/AT/DR/DT KV-40AR/AT/DR/DT
常规 KV（系列） KV-10R（W）/T（W） KV-16R（W）/T（W）
KV-300（系列） KV-24R（W）/T（W） KV-40R（W）/T（W）
KV-10/80（系列） KV-80R（W）/T（W）

KV-300
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用户提示

需要在下列条件或环境下使用 Visual KV 系列产品时，请预留充足的定额和功能余
量，并适当采取安全措施，如安装自动防护故障装置等。如有任何问题，请与我们的
销售人员联系。

• 在本手册规定以外的条件或环境下使用。

• 用于核能控制、铁路设施、航空设施、车辆、燃烧装置、医疗设备、娱乐机械、安
全设备等。

• 特别是使用在对人身和财产安全预计将产生严重影响的场所。

取得 CE 标志的要求

■ 符合 EMC 指令的要求

• 使用继电器输出型模组 (型号名称以字母 R 结尾) 时，将耐负载压性能的消弧器连
接到输出端与触点平行 (继电器触点断开时，模组会发生放电现象，从而导致噪声
的产生)。在试验过程中，我们使用了下列型号的消弧器：

XEB0101 0.1 µF-10 Ω，由 OKAYA DENKI SANGYO 制造。

在 KV-40AR/T 和 KV-24AR/T 的交流电源输入电路以及 KV-40DR/T 直流电源
输入电路中增加了下列单圈铁芯。

ZCAT3035-1330，由 TDK 制造。

注： 上述要求本身并不能保证依此制造的整机符合 EMC 指令的要求。

用户必须自行确定整机是否符合 EMC 指令的要求。整机的符合性会因机内
部件的配置、布线以及安装位置的不同而发生变化。

■ 符合低压指令（IEC-1010-1）的要求

• 使用绝缘型压接接线端子。

• 布线采用外皮厚度超过 0.4 毫米的导线。

• Visual KV 系列产品只允许采用立式安装（不提供扩展模组隔片）。

• 请在控制面板内使用 Visual KV 系列产品。

(2)
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Visual KV 系列产品的特性

● 体积小

Visual KV 系列产品是世界上最小的安装有螺丝接线板的交流型 PLC，节省安装空间。

● 速度快

最小扫描时间为 140 µs，最小指令执行时间为 0.7 µs，在同级产品中实现了最快
速度的控制。

● 新增内置式交流电源

新增内置式交流电源模组。该款产品可用于无法安装开关式电源模组的狭小空间。

● 性能卓越的接入窗口

各种型号均采用了双色背光接入窗口，便于修改和监控设备数据。无需任何手持编
程器， Visual KV 系列模组可直接在“RUN (运行)”和“PROGRAM (编程)”
模式之间进行切换，在发生错误时，可直接检查错误代码。
常规 KV 系列产品常用的模拟微调器实现了数字化，能够进行更详尽的设置 [Digital
trimmers]（数字微调器）。

● 具有用户信息设置功能

接入窗口可显示 256 条不同的用户信息，可用于向生产线发布工作指令，指出设
备异常等。

● 可在 RUN (运行) 模式下进行程序写入操作

在系统运行过程中，可直接修改梯形图程序。

● 设有 2 个串行端口

Visual KV 系列基本模组设有 2 个串行端口，用于连接外围模组，改善调试环
境。（KV-10xx 只有 1 个串行端口）

● 简单易行的斜坡控制功能

该单轴电机控制功能与高速计数器分别提供，从而可实现反馈控制。

● 具有 2 个 24 位高速 30 kHz 的 2 相计数器

Visual KV 系列产品设有 2 个高速计数器，分别具有 2 点比较器输出功能，可实
现高速编码器输入。

● 具有特定频率脉冲输出功能

高速计数器可充当脉冲振荡器使用，最大频率 50 kHz，设置简单，不产生复杂的
梯形图程序。

● 具有频率计数功能

高速计数器可充当频率计数器使用，设置简单，不产生复杂的梯形图程序。

● 具有凸轮转换开关功能

高速计数器可充当凸轮转换开关使用，设置简单，不产生复杂的梯形图程序。

(3)
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● 具有中断功能

Visual KV 系列产品安装有 4 个高速中断输入，最大 10 µs。

● 具有修改输入时间常数的功能

时间常数可在 10 µs 至 10 ms 之间进行7级设置。

● 具有双内存备份功能

除常规的 SRAM（静态存储器）电源备份功能外，Visual KV 系列产品还设有
EEPROM 备份功能。

与常规 KV 系列产品外围模组的兼容

Visual KV 系列产品为常规 KV 系列产品的高端兼容型产品，常规 KV 系列产品的外
围模组，如：梯形图支持软件“KV IncrediWare （DOS）”，“KV 梯形建筑者”以
及手持编程器 KV-P3E（01），作为 Visual KV 系列产品的部件仍可使用。
不过，需要注意的是，下列内容有所改变：

• 高速计数器内部时钟的周期有 3 种：1 µs，10 µs 和 100 µs。

• HSP 指令所规定的输入继电器时间常数为 10 µs。

• 模拟微调器功能通过基本模组的内置接入窗口进行设置。

• TMIN 指令所规定的可用设备设置范围为 0 到 65535。[手持编程器 KV-P3E（01）
的显示范围为 0 至 9999]。

• 基本模组前面板的接入窗口设有 RUN/PROGRAM LED (运行/编程液晶显示器)。

• 晶体管输出端为非独立式，是共用。

• 晶体管型产品的输出端子在布局上有所不同。

• 晶体管输出端（编号 500 至 502）的输出电流规格为 100 mA。

• 常规 KV 系列产品的扩展模组不可用作 Visual KV 系列产品的扩展模组。

• 不提供扩展模组频道设置开关。频道取决于连接顺序。

• 扩展 I/O (输入/输出) 模组的扫描与 Visual KV 系列产品基本模组的扫描时间并不
同步。

• 特种继电器的分配已部分改变。

• 数据存储器（编号 DM1000 至 DM1999）用作特别数据存储。

(4)
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使用梯形图支持软件以往版本的注意事项

使用梯形图支持软件时必须注意以下几点：

• 使用梯形图支持软件“KV IncrediWare（DOS）”或“KV 梯形建筑者 1.0x
版”时，请将型号设置为“KV-300”。

• 只有 DM0 至 DM1999 可用。

如果使用了“KV 梯形建筑者 1.0x 版”，请不要使用监控器的 Change All (全部改
变) 功能。如果使用“全部改变”功能，可能会对基本模组造成损坏。切勿使用
Change All (全部改变) 功能。

与 Visual KV 系列产品不兼容的外围模组及其他模组

常规 KV 系列产品的下列外围模组以及其他模组与 Visual KV 系列产品不兼容：

• 常规 KV 系列产品的扩展 I/O (输入/输出) 模组：KV-8ER/8ET/8EX/16EX/
8EYR/8EYT/16EYR/16EYT

• 常规 KV 系列产品的模拟 I/O (输入/输出) 模组：KV-AD4/DA4

使用串行端口的注意事项

KV-16xx/24xx/40xx 模组设有 2 个用于串行通信的 RJ-11 模块式插座。
使用过程中需要注意以下几点：

• 可利用通信端口 A 或 B 传递、监控程序。但不得同时将梯形图软件和手持编程器
连接到 2 个端口上。

• KV-D20 操作接口面板可连接到通信端口 A 或 B。但单个基本模组只能连接 1 个
KV-D20 模组。

• 请勿长时间保持 KV-D20 操作接口面板和 KV-P3E（01）手持编程器同时处于通
电状态。

小心

(5)
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RUN (运行) 模式下进行写入操作的注意事项

• 在 Visual KV 系列产品中，即使是程序正在运行当中，也可利用梯形图支持软件
“KV 梯形建筑者”对程序进行修改。

• 在 RUN (运行) 模式下进行写入操作时须特别注意安全。

• 根据 PLC (可编程逻辑控制器) 连接的控制器设备的状态或者使用的程序，情况可
能会变得极度危险。

在运行模式下进行写入操作时的各项功能：

注 1： 梯形图程序在运行过程中进行的修改，不是保存在 EEPROM 中，而是保存
在 SRAM (静态存储器) 中，要在下次开机时才会存入 EEPROM。梯形图程
序在 RUN (运行) 模式下进行修改后，如果在 25°C 条件下关机 2 个月或以上
(KV-10xx 为 25°C 条件下关机 20 天或以上)，修改的梯形图程序会损坏。为
防止发生不一致的情况，须开机一次，将修改后的程序存入 EEPROM。

注 2： 在 RUN (运行) 模式下进行程序写入操作时，如果 Visual KV 系列产品基本
模组发生错误，Visual KV 系列基本模组将转入 PROGRAM (程序) 模式，
当前正在进行写入操作的程序将可能被删除。如果出现这种情况，请重新传送
程序。

警告

删除已使用者

KV 功能 在“运行”模式下 写入操作后

所有未用者
 已初始化

转换后，为微分指令获取继往数值。本例中发生改变的继电器无
法通过微分加以检测。

高速计数器 • 高速
计数器比较器

改变已使用高速计数
器比较器的设置值　

当高速计数器比较器的设置值发生改
变时，由于 KV-P3E (01) 手持编程器
执行了 FUN70，高速计数器的当前
值也以相同的方式发生改变。

已初始化

➮ 参见“改变计时器/计数器的设置值：


  FUN70”(第 1-222 页)

内部辅助继电器/专
用辅助继电器

简便易行的斜坡控制
功能

凸轮转换开关功能

频率计数器功能

微分指令的继
往数值

特定频率脉冲输出功能

无改变 保持当前状态

暂停

继续操作至完成当前输出

继续操作

继续操作

继续操作
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手册结构

Visual KV 系列产品用户手册包括 3 个单独的手册：1 安装；2 支持软件；3 编
程。请根据需要阅读相关手册。

 1 安装

    第一章 配置与规格 [适用于 Visual KV 系列产品]
介绍了 Visual KV 系列产品的系统配置、零件名称与功能以及相关规格。

    第二章 系统的安装 [适用于 Visual KV 系列产品]
介绍了 Visual KV 系列产品各模组的安装、连接以及系统的保养。

    第三章 接入窗口 [适用于 Visual KV 系列产品]
介绍了用于修改和监控数据的接入窗口。

    第四章 KV-D20 操作接口面板 [适用于 Visual KV 系列产品]
介绍了作于修改、监控以及显示内部继电器、计时器、计数器和数据存储器状态的 KV-
D20 操作接口面板。

    第五章 KV-300、KV-10/80 的硬件 [适用于 KV-300、KV-10/80 系列产品]
介绍了 KV-300、KV-10/80 系列产品的硬件配置与布线。

    第六章 手持编程器

介绍了手持编程器和存储卡的使用方法。

    第七章 KV-L2 串行接口模块 [适用于 KV-300 系列产品]
介绍了用于 KV-300 系列产品的串行接口模块。

    第八章 KV-AN6 模拟 I/O (输入/输出) 模块 [适用于 KV-300 系列产品]
介绍了用于 KV-300 系列产品的可选模拟 I/O (输入/输出) 模块。

    第九章 KV-AD4/DA4 模拟 I/O (输入/输出) 模组 [适用于 KV-10/80 系列产品]
介绍了用于 KV-10/80 系列产品的可选模拟 I/O (输入/输出) 模组。

    第十章 故障诊断

本章介绍了错误代码表、故障解决方案以及各模组的错误显示。

附录

附录包括梯形图程序应用和索引清单。

 2 支持软件

    第一章 简介

介绍了产品包装清单、产品简介、个人电脑的连接方式、安装方式等。



C KV-H6WE2-UM (8)

    第二章 编辑器

介绍了编辑器模式下的操作程序。

    第三章 模拟器

介绍了模拟器模式下的操作程序。

    第四章 监控器

介绍了监控器模式下的操作程序。

附录

包括指令清单、设备清单、范例程序清单以及主要操作和快捷方式的速查表。

 3 编程

    第一章 编程

介绍基本知识，包括程序的生成过程、设备配置、继电器的分配、设置和确认 Visual KV
系列产品操作的特殊功能，以及扩展的梯形图。生成程序前，请全面了解有关内容。

    第二章 指令

介绍了 KV 系列产品有关指令的具体使用方法。

有关中断指令的详细内容，参见“第三章 中断”（第 3-183 页）。

有关应用指令中高速计数器的详细内容，参见“第四章 高速计数器”（第 3-195页）。

    第三章 中断 [适用于 Visual KV 系列产品]
在 KV 运行过程中，如遇到来自高速计数器比较器（中断因素）的外部输入或请求，中断
处理功能将执行中断程序。
本章介绍中断因素的类型以及中断处理过程中遇到的输入和输出。

    第四章 高速计数器 [适用于 Visual KV 系列产品]
介绍了高速计数器和高速计数器比较器，允许在扫描时间之外进行高速脉冲测量和脉冲
输出。

    第五章 定位控制 [适用于 Visual KV 系列产品]
介绍了步进电机和伺服电机的斜坡控制。

    第六章 中断、高速计数器、定位控制 [适用于 KV-300、KV-10/80 系列产品]
介绍了步进电机和伺服电机的斜坡控制。

    第七章 串行通信

KV 系列产品可能过 RS-232C 接口连接外部设备，从而建立通信。
本章介绍通信规范，KV 系列产品与外部设备的连接，以及通信方法。

    第八章 编程示例

介绍了 KV-10/80 系列产品典型的编程示例。这些程序可用于 Visual KV 系列产品。但
在使用前须注意 I/O 选址的兼容性问题。
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1.1 产品包装清单

在 KV 梯形建筑者包装中含以下物品。确认是否已提供所有物品。

● KV 梯形建筑者 # 1 母盘和 # 2 母盘

“KV 梯形建筑者”程序和安装程序保存在这些盘上。安装程序后将其储存在安全
位置。

注： 建议您对母盘作备份副本，以防磁盘意外损坏。

● 连接电缆

➮ 见 2-7 页。

3 1/2" 软盘 (1.44 MB) x 2

#1 #2
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1.2 概述 KV 梯形建筑者

本节描述了 KV 梯形建筑者的操作环境、系统配置、特征和功能等。在使用 KV 梯形
建筑者之前务必要阅读本节内容。

1.2.1 操作环境和系统配置

运行 KV 梯形建筑者需要以下操作环境。
确保您的系统满足以下条件，并提供需要设备。

■ 支持个人电脑

支持 Windows 3.1 或更新版本的机型（装有 RS-232C 接口）

IBM PC 机和 PC/AT 或兼容机

■ CPU 存储容量

i486D×2 或更高（建议为 Pentium 90 MHz 或更高）
8 MB RAM（建议为 16 MB 或更高）

■ 兼容操作系统

• Windows 3.1
� • Windows 95

■ 需要字体（务必安装）

• MS Sans Serif
� • Small fonts
� • Arial

在 Windows 95 中上面几种字体均作为标准字体提供。

■ 硬盘自由空间

4.5 MB 或更多

■ KV 和各模组

将需要模组如 KV 连接到个人电脑以使用监控功能并通过 KV 梯形建筑者传输程序。

➮ 请参考 2-7 页的“1.3 编程准备事项”

注： KV 梯形建筑者不支持长文件名。

打印机可以连接到个人电脑并
支持 Windows （300 dpi 或
更高）

打印机

显示
分辨率：640×480 或更高

KV 系列 PLC



第一章 简介

2-4

1

C KV-H6WE2-UM

1.2.2 KV 梯形建筑者的特性和功能

KV 梯形建筑者是一种能让您创建顺序程序的软件程序。它具有卓越的功能性以及先进
的编程处理能力。

KV 梯形建筑者的特性

■ 多文件编辑功能和简单的鼠标操作提高了工作效率。

因为可以同时编辑两个或多个文件，可以在不同文件之间剪切和粘贴图表块。使用
鼠标可以容易地复制和移动符号和连接线。各个功能都可以通过按工具栏上的按钮
进行启动，从而提高了操作效率。

■  从列表中选择指令词和设备确保正确输入符号。

因为指令词和设备可以从每种型号的列表中进行选择，故符号输入错误率很少。也
可以通过键入相应的指令词直接输入符号，以方便快速编程。

■  梯形图数据可以与 KV IncrediWare (DOS) 共享。

因为用 KV IncrediWare (DOS) 创建的梯形图数据可以按原样进行使用，至今所创
建的梯形图特性仍可以有效地使用。用 KV 梯形建筑者创建的梯形图数据也可以用
于 KV IncrediWare (DOS)。
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■  通过从梯形图进行拖放操作可以快速选择要监控的设备。

通过从梯形图表中施出和放开的操作可以方便且快速选择要监控的设备。

■  可以快速确认梯形图表、触点和时序图。

三个窗口都可以位于屏幕的任何位置，让您可以同时监控并模拟程序的操作。这三
个窗口是显示梯形图的 Ladder Monitor（梯形图）窗口、显示设备列表的 Monitor
All（全监控）窗口、让您可以检查定时图中触点动作的 Registration Monitor（注
册监控）窗口。

■ 即使在未连接 PLC 时也可以使用模拟器功能。

即使未连接 PLC 时，您也可以监控并模拟程序操作。由于无需将程序传输至 PLC
就可以检查程序操作，从而改善了调试效率。另外，对扫描执行和步 PLC 就可以
检查程序操作，从而改善了调试效率。另外，对扫描执行和步骤执行都提供了反向
步进执行功能。

■ 对不同的应用程序提供了 5 种不同的屏幕尺寸。

根据不同应用程序的需要，可以选择 5 种不同的屏幕显示尺寸。例如，可以选择小
尺寸以确认整个流程，选择大尺寸以编辑每个触点。
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 KV 梯形建筑者的功能

在 KV 梯形建筑者中提供以下功能。

■ 编辑器功能

• 使用梯形语言的多种指令词以创建梯形图。
• 在触点上加注。注释可以传输至 Visual KV 或 KV-300 (除 KV-10/80 系列之外)。
• 将梯形图转换为机器代码。
• 在屏幕上显示梯形图、助记符列表、标签注释以及设备使用状态等，并打印至打

印机。

■ 模拟器功能

• 即使 Visual KV 或常规 KV 未连接，也可模拟梯形图操作，并允许进行调试程序。
• 提供连续扫描执行模式、一次扫描执行模式、单步执行模式等，以准确查找错误。
• 启用一次或连续反向步进。

■ 监控功能

• 使用创建的梯形图实时联线监控触点的 ON/OFF 状态。
• 显示时序图，并将程序传输至 Visual KV 或常规 KV。
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1.3 编程准备事项

个人电脑应该连接到 Visual KV 或常规 KV 以将程序传输至 Visual KV 或常规的 KV
并使用显示屏功能。

应备机器

编程前您必须准备以下机器。

■ PC
• 将其连接到 D 型 9 针型串行端口。

连接电缆： OP-26487
D 型 9 针型转换连接器： OP-26486

ᥱ彆 Visual KV 麼都寞腔 KV 昫諉善跺ᥕ萇齟腔湖荂儂傷諳ㄛ寀跺ᥕ萇齟﹜價掛耀
郪麼 CPU 耀郪褫夔囷輓﹝昢斛輝氘﹝

注： 务必使用专用电缆。如果使用其它电缆，则模组操作可能不正常。

标准电缆 当个人电脑带有 25 针连接器

连接到 RJ-11 模式
插座

小心

OP-26486

OP-26487

连接到 RS-
232C 连接器

PC（个人电脑）

KV 系列 PLC (可编程逻辑控制器)

3
5

4

2
3
4
5
6
7
8

SD
RD

SG

RJ-11 模块式
插座

D 型 9 针连接器

3
5

4

2
3
4
5
6
20
7

SD
RD

SG

SD
KV PC (DTE)

RD
RS
CS
DR
ER
SG

D 型 25 针连接器

KV PC
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1.3.1 与 KV IncrediWare (DOS) 的区别

因为 KV 梯形建筑者是 Windows 应用程序，其规格与用于 MS-DOS 操作系统的 KV
IncrediWare (DOS) 稍有不同，列示如下。

• 一些指定为键盘功能的键不同。

➮ 请参考 2-180 页的“附录 G 快速参考”。

• 在注册监控窗口显示时序图模拟器和时序图监控。

• 未提供在时序图显示屏上设置触发器的功能。

• 未提供内存卡操作功能。

• 未提供时序图保存／读取功能。

• 未提供“扩展梯形 ➞ 一般梯形”转换功能。

1.3.2 与 KV 梯形建筑者版本 1.0 的区别

从 KV 梯形建筑者版本 1.5 开始，规格和功能有以下更改和添加内容。

• 编辑器功能允许所选内容显示／隐藏触点注释。

• 您可以一边在显示屏上检查设备使用状态列表，一边编辑梯形图。

• 在十进制 (#) 和十六进制 ($) 编号系统之间进行切换的操作可以通过快捷键 [Ctrl]+[E]
进行。

• Visual KV 系列模组是最近的支持产品。
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1.4 软件安装

本节描述如何在个人电脑硬盘上安装 KV 梯形建筑者。

1.4.1 安装准备

安装软件前应确认以下要点。

■ 硬盘的自由空间

KV 梯形建筑者必须安装在硬盘上。必要自由空间为 4.5 MB。应保证此自由空间。

■ 在 Windows 环境下安装

KV 梯形建筑者在 Windows 环境下运行，且必须自 Windows 进行安装。
确保您的个人电脑已安装 Windows 3.1 或 Windows 95 且运行正常。

■ RS-232C（串行端口）

在将程序传输到 Visual KV 或常规 KV 以及使用 KV 梯形建筑者达到 KV 监控功能之
前，个人电脑的 RS-232C（串行端口）应该准备就绪。
有关安装步骤，请参考个人电脑的使用手册。

注 1： 在安装 KV 梯形建筑者程序后，串行端口也必须在此程序下设置。

➮ 请参考 2-136 页的“设置串行端口”。

注 2： 建议您对母盘作备份，以防磁盘意外损坏。
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1.4.2 安装程序

本节描述如何安装软件。
根据使用的 Windows 的不同版本，安装程序有所不同。请参考适用您的操作环境的
适当章节。

在 Windows 95 中安装（➮ 见下述内容）
在 Windows 3.1 中安装（➮ 2-12 页）

在 Windows 95 中安装

作为示例，本节描述如何使用以下驱动器配置在 Windows 95 中安装此软件。
驱动器 C：硬盘驱动器
驱动器 A：软盘驱动器

启动 Windows 并备好提供的两张母盘。

注： 关闭所有应用程序后再开始安装。

1. 将 KV 梯形建筑者 1 号母盘插入软驱。

2. 单击“Start”（开始）菜单上的“Run”（运行）。

3. 在“Open”（打开）中输入“a:\setup”并单击 [OK] 按钮。
或单击 [Browse] (浏览) 按钮，并从“Browse”(浏览) 对话框选择需要的文件
名称。

➮ 请参考 2-11 页。

• 从“Browse”（浏览）对话框选择文件名：

2. 单击“setup.exe”。

1. 选择“3 1/2" FD”。

3. 单击 [Open]
（打开） 按钮。
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4. 将显示此图，开始安装准备。

5. 当显示以下屏幕时，单击 [Next]（下一步）按钮。取消安装时，单击 [Cancel]（取
消）按钮。

6. 确认软件要安装的驱动器名称和文件夹（目录）名称。
默认路径是“C:\KEYENCE\Lbk”。为将软件安装到此位置，单击 [NEXT]（下一
步）按钮。
更改安装位置时，单击 [Reference]（参考）按钮然后指定驱动器名称和文件夹（目
录）名称。

7. 文件复制状态图将显示在屏幕上。
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8. 当提示您插入新盘时，请插入 KV 梯形建筑者 # 2 母盘，然后单击 [OK] 按钮。

9. 未包含在此手册的新信息保存在 README 文件中。单击 [Yes] 按钮以阅读此文件。

10.现在安装已完成。单击 [OK] 按钮。

在 Windows 3.1 中安装

作为示例，本节描述如何使用以下驱动器配置在 DOS 机器运行的 Windows 3.1 系统
中安装此软件。

驱动器 C：硬盘驱动器
驱动器 A：软盘驱动器

启动 Windows 并备好提供的两张母盘。

1. 将 KV 梯形建筑者 # 1 母盘插入软驱。

2. 从程序管理器菜单选择“Run”（运行）和“Command Line”（指令行）。

3. 在“Command Line”（指令行）中输入“a:\setup”并单击 [OK] 按钮。
或单击 [Reference]（参考）按钮，并从“Browse”（浏览）对话框选择需要的文
件名称。

安装程序的其它步骤与“在 Windows 95 中安装”（➮ 2-11 页）的第 4 至 10 步相同。
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1.5 使用注意事项

本节描述使用 KV 梯形建筑者的注意事项。务必要阅读本节。

■ 使用笔记本个人电脑时

当使用笔记本个人电脑时，应确保已安装 RS-232C。否则，在监控器操作正在进行
时将出现错误，而且监视器操作可能异常。
有关安装步骤，请参考个人电脑使用手册。

■  显示屏工作期间

切勿关闭 Visual KV 或常规的 KV 的电源，或在显示屏工作时拔掉连接线。这样将导
致通信错误，而且显示屏将被强制终止。

■  梯形图更改后的显示屏

务必要从菜单选择“Convert ➞ Transfer ➞ Monitor”（转换 ➞ 传输 ➞ 显示屏）并
在更改梯形图后当显示屏工作时将程序传输到 PLC (可编程逻辑控制器)。

■  屏幕分辨率

应确保屏幕的分辨率至少为 640 × 480。建议使用尽可能高的分辨率以确保操作舒适。
（建议 1,024 × 768 或更高的分辨率。）

■  长文件名

KV 梯形建筑者按 Windows 95 运行，但不支持长文件名。文件名只能最多由 8 个
半宽字符以及文件扩展名（3 个字符）组成。
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1.6 基本操作

本节描述内容为是使用 KV 梯形建筑者前应该了解的知识，比如编程流程、可用模
式、软件启动步骤以及软件终止步骤。

1.6.1 程序创建流程和可用模式

KV 梯形建筑者有三种可用模式。它们是编辑器、监控器和模拟器模式。实际的编程步
骤、每个步骤所使用的模式以及每种模式下的主要可用功能描述如下。

1. 创建梯形图

根据设计图创建梯形图，此图指明 PLC（可编程逻辑控制器）要执行的操作内容。

编辑器 ➮ 2-25 页
• 以原 LDR 格式或其他种格式保存并读取文件。

• 保存并读取助记符列表和注释。

• 输入和删除符号。

• 输入和删除连接线条。

• 输入和删除线条。

• 移动和复制梯形。

• 编辑触点／线条的注释／标签。

• 更改屏幕的显示颜色。

• 撤消功能。

• 跳转

• 搜索指令词／操作数。

• 替换操作数。

• 转换 a／b 触点。

• 编辑列表。

• 设备使用状态。

• 设置自动保存功能。

• 创建宏。

• 打印梯形图等。

2. 编译梯形图

将梯形图编译为 Visual KV 或常规 KV 可读的机器码。尽管编译在显示屏启动时自动
进行（只有当选择了“Transfer Program to PLC”（将程序传输到 PLC）时），但进行
编译工作的同时不能执行其它工作。

编辑器 ➮ 2-25 页
• 将程序传输到 PLC（可编程逻辑控制器）。

在更改到监控器时选择此功能。

• 模拟器
更改至模拟器时选择此功能。

• 编译
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3. 调试程序

阅读编辑器所创建的机器码，并确认操作状态，包括更改设备。这样可检测错误并相应地更改
梯形图。

• 您可在调试程序时使用模拟器或监控器。使用监控器时，您可以模拟 Visual KV 或常规 KV
所连接的状态。在使用监控器时，您实际上连接了 Visual KV 或常规 KV 并将程序写入。

• 通过调试程序可以从梯形图监控、全监控和注册监控中显示设备状态；可以从对话栏设置
当前值／预设值／属性、可以在模拟器和显示屏之间共享打印注册监控的内容，但某些功
能除外。
这些方法在模拟器节中有叙述。

未接 CPU 模组时：模拟器 ➮ 2-83 页
• 设置中断条件、等待时间、扫描时间等。

• 连续执行扫描或执行扫描一次。

• 连续执行一个步骤、反向连续执行某步进、执行某步进一次或反向执行某步进一次。

• 更改时序图大小。

• 显示助记符列表。

• 搜索设备。

连接 CPU 模组时：监控器 ➮ 2-133 页
• 串行端口设置。

• 启动和停止监控器，并重建记录。

• 设置 PLC 模式。

• 禁用输入刷新，禁用输出（Visual KV 系列和 KV-300）。
• 传输程序（从编辑器选择菜单并执行时，将把程序传输到监控器）。

• 搜索设备。

模拟器和监控器

• 保存并读取梯形图监控、全监控、和注册监控。

➮ 2-88 页、2-108 页、2-118 页
• 显示梯形图监控、全监控和注册监控的工作状态。

➮ 2-88 页、2-108 页、2-118 页
• 显示时序图（在注册监控上）。

• 设置当前值／预设值／属性。 ➮ 2-117 页
• 打印注册监控。 ➮ 2-131 页

4. 使用梯形图调试程序并传输程序

除使用监控器或模拟器进行调试，也可以使用编辑器更改梯形图。可以读取传输到基本模组或
CPU 模组的程序（机器代码），然后可以显示梯形图。

编辑器 ➮ 2-25 页
当调试完成且程序运行正常，将完成的程序（机器代码）传输到 Visual KV 或常规 KV 并
写入。
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1.6.2 软件的启动和退出

KV 梯形建筑者的启动和退出描述如下。

启动软件

■ 在 Windows 95 下
从 Start（开始）菜单选择“Program”（程序）、“KEYENCE Applications”

（KEYENCE 应用程序）和“LADDER BUILDER for KV”(KV 梯形建筑者)”。

■ 在 Windows 3.1 下
在程序管理器的 KEYENCE 应用程序组双击 Ladder Builder for KV (KV 梯形建筑
者) 图标。

• 梯形图软件将启动。

■ 退出软件时

执行以下步骤之一即可退出。

• 从菜单选择“File”（文件）和“Exit”（退出）。
• 同时按 Alt 和 F4 键。
• 在 Windows 95 下，单击标题栏右端的关闭按钮。
• 在 Windows 3.1 下，双击标题栏左端的控制菜单框。
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设置和更改使用型号
File (文件) ➔ Change Models (更改型号)

当新文件创建后，将显示出设置模式的对话框。

选择所连接的 PLC 型号，然后单击 [OK] 按钮。

要在 KV 梯形建筑者运行时更改型号，从“File”（文件）菜单选择 “Change
Models”（更改型号）。

• 如果所连接的 PLC (可编程逻辑控制器) 型号设置不正确，将在与 KV 系列 PLC
(可编程逻辑控制器) 通信时显示出错误信息“Unmatched model”（型号不匹
配）。同时将禁传程序到 PLC 和监控器功能。如果型号设置不正确，将出现故障。

• 如果型号指定为“KV-10(16)A/D”或“KV-24(40)A/D”，则创建的梯形图不能
用 KV 梯形建筑者版本 1.0 或 KV IncrediWare (DOS) 打开。若通过上述程序
之一种使用梯形图，应将型号指定为“KV-300”。

小心
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1.6.3 屏幕

各个模式下的窗口

在各个模式下 KV 梯形建筑者的屏幕互相相关，如下所示。

各个窗口的名称和功能在以下页面描述。

编辑器  ➮ 2-25 页
模拟器  ➮ 2-83 页
监控器  ➮ 2-133 页

当前窗口

当前选择的活动窗口称为“当前窗口”。
在各种模式下当有两个或更多窗口显示于屏幕时，使用以下方法之一以选择某个窗
口。（当前窗口标题栏的颜色与其它窗口标题栏的颜色显著不同。）

• 单击您要选择为当前窗口的窗口标题栏。

• 选择“Window”（窗口）菜单以查看当前打开的所有窗口列表。选择您要选择为
当前窗口的窗口标题。

模拟器 监控器

编辑器

编辑器

模拟器 变为监控器

▲
▲▲

程序传输到
PLC → 监控器

编辑器

▲ ▲

清除设备后的编辑器
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显示 / 隐藏工具栏、状态栏和对话栏

工具栏、状态栏和对话栏的显示状态可以更改。

从编辑器的菜单栏中选择“View”（视图）。

当复选标记可见时：显示模式
当复选标记不可见时：隐藏模式

默认情况下，每个栏前出现复选标记。每次单击复选标记，显示状态将在显示模式和
隐藏模式之间进行切换。
* 编辑器中没有对话栏。

显示模式  

屏幕显示可以在 5 种不同尺寸下查看。
在编辑器中，您可以设置对各个屏幕是否显示标签和注释。

■  更改显示尺寸

可以用五种不同尺寸显示梯形图。软件启动时，默认为选择“100% ”。使用以下方法
更改显示尺寸。（在编辑器中，尺寸可以在“Display Mode Setup”（显示模式设置）
对话框设置。）

“View”(查看) ➔“Zoom In”(放大) Ctrl + PageDown 键：选择较高模式。
“View”(查看) ➔“Zoom out”(缩小) Ctrl + PageUp 键：选择较低模式。

■   更改显示尺寸（仅对编辑器）

可以使用以下步骤在“Display Mode Setup”（显示模式设置）对话框中设置显示
尺寸。

1. 从编辑器的菜单栏上的“View ”（查看）菜单选择  “Display Mode” （显示模

式），或单击  按钮。

将出现“Display Mode Setup”（显示模式设置）对话框。

复选标记

工具栏

对话栏

状态栏
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2. 设置每一项目，然后单击 [OK] 按钮。
若要取消所作更改并关闭对话框，单击 [CANCEL]（取消）按钮。

200% 以标准尺寸的两倍显示梯形图。此尺寸在字符很小难于
阅读时很有用。

150% 以标准尺寸的 1.5 倍显示梯形图。

120% 以标准尺寸的 1.2 倍显示梯形图。

100%（常规） 以标准尺寸显示梯形图。

80% 以最小的尺寸显示梯形图。此尺寸在检查整个工作情况
时很有用，因为可以在屏幕上显示最多的单元。

Show in XYM (以 XYM 显示) 使用“X”、“Y”和“M”在梯形图中显示设备名称。

Show Deicmal Constant with 在梯形图中以符号显示十进制常数。
sign (以符号显示十进制常数)
Show Device Label (显示设备标签) 显示梯形图中每个设备的标签名称。

Show Comment (显示注释) 在梯形图中显示注释。

Comment Comment (注释) 1 显示注释 1 [完全与 KV IncrediWare (DOS) 共享]
type Comment (注释) 2 显示注释 2 (不能传输到 PLC (可编程逻辑控制器))
(注释类型) Comment (注释) 3 显示注释 3 (不能传输到 PLC (可编程逻辑控制器))

Current Edit Screen 显示编辑屏幕的设置
(当前编辑屏幕) （当前窗口）。

Current Reference 显示参考屏幕的设置
Screen (当前参考屏幕)（当前窗口）。

Current Screens 显示编辑屏幕和参考屏幕（两个当前窗口）的设置。
(当前屏幕)
All Windows 显示所有窗口的设置。
(所有窗口)

Display
Size (显示
尺寸)

Mode
Setting
Range
(模式设置
范围)

* 当前窗口指当前选择的活动窗口。
* 线条注释不能传输。
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显示／隐藏注释  
可以选择在编辑器屏幕显示或隐藏触点注释。
显示“注释 1”。

1.6.4 鼠标操作和键盘操作

KV 梯形建筑者可以用鼠标进行操作，除非需要输入字符。这将提高创建梯形图和调试
的效率。
可使用键盘指令 (快捷键) 执行工作，甚至效率更高。

如何执行各功能（指令）

常用的功能已被赋予工具栏和功能键操作。从菜单选择的指令也可以使用快捷键和通
过右键单击显示的快捷菜单来快速执行。

• 在本手册中，各个功能可用的菜单、按钮和键在每个标题的右端有说明以进行快速
参考。

• 快捷键在软件中各菜单的右侧被指明。

范例

可以用以下两种方法输入连接线。

• 按键或单击图标

F8 和 /（前斜杠）或   : 从光标位置向下绘制连接线。

F9 和 -（连字符键）或  : 在光标右侧绘制连接线。

• 在连接线编辑模式使用鼠标和光标控制键
若要使用鼠标绘制连接线，首先要更改输入模式。
可以使用以下四种方法更改模式。

• 从右键单击所显示的菜单选择“Edit Connection Line”（编辑连接线）。

• 从“Edit”（编辑）菜单选择“Edit Connection Line”（编辑连接线）。

• 同时按 Ctrl 和 K 键。

• 按 \ 键。

有几种方法以供选择，从而可以选择效率最高的操作。

隐藏注释

单击

显示注释

(ON) 开

0001

0000

0001

0000

▲

▲
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1. 按住此按钮时，

2. 移动鼠标。

3. 松开此按钮。

基本鼠标操作

鼠标的使用描述如下。如果您熟悉使用 Windows，您可以跳过本节。

■ 什么是“点击”？

● 左键双击

左键双击表示快速连续按左按钮两次。这用于在梯形图窗口打开“Enter Instruction
Word”（输入指令词）对话框。在本手册中此类型的点击称为双击。

● 左键单击

左键单击表示按左按钮一次。这用于点击屏幕上的按钮或将光标与文本输入框汇总的
输入位置对齐。在本手册中此类型的点击简单地称为单击。

● 右键单击

右键单击表示按右按钮一次。用于显示需要的快捷菜单以便更快速操作。例如，通过
右键单击梯形图窗口，可以执行各个功能（指令）如“cut”（剪切）、“copy”（复
制）、“paste”（粘贴）以及“edit connection line”（编辑连接线）。

■ 什么是“拖放”？

拖动表示在选择开始位置按左按钮，在按住左按钮的同时移动鼠标光标，然后在选择
结束位置松开按钮。
拖动用于选择一个范围或绘制连接线。
拖放表示移动选定项至不同的位置或窗口然后松开按钮。
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1.6.5 在线帮助

KV 梯形建筑者包含联机求助。

如果您对某个功能不确定，请单击工具栏上的  按钮或从菜单栏选择“Help”（帮

助）以打开求助窗口。

操作求助窗口

指令词求助窗口
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2.1 编辑器功能概述

本节概述编辑器中可用的各个功能。有关各功能的详细描述，请参考相应页码。

编辑器使您可以创建梯形图，并提供编辑功能（包括输入指令词和记录注释）。

编辑器提供以下功能。

• 使用梯形图语言的多种指令以创建梯形图。

• 执行编辑功能，包括复制和移动。

• 为触点加注并将其传输到 Visual KV 或常规 KV。

• 转换梯形图，并将转换的图传输到 PLC (可编程逻辑控制器)。

• 打印出梯形图、助记符列表、标签注释、设备状态列表等。

2.1.1 编辑梯形图程序注意事项

可编辑的最大行数为 9,999。
KV 梯形建筑者的一个梯形图程序窗口可编辑的最多行数为 9,999。一个图块的最大
尺寸为 100 行。
切记不能创建超过 9,999 行的梯形图程序。

当程序慢速运行时

当许多应用程序同时运行在内存容量低的个人电脑上时，内存和资源将不足。结果，
交换文件将被频繁访问且运行速度降低。如果发生此情况，应关闭其它程序以降低系
统上的负载。
增加内存也是有效的方法。
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2.2 编辑屏幕

本节描述编辑器中所显示的屏幕的配置和功能。

2.2.1 屏幕各部分的名称和功能

当 KV 梯形建筑者启动时，最初不显示梯形图程序窗口。若要创建新的梯形图程序，
从“File”（文件）菜单选择“New”（新建）以打开新窗口，然后对其进行编辑。

若要打开现有的梯形图程序，从“File”（文件）菜单选择“Open”（打开），然后指
定需要的梯形图程序。

屏幕各部分的名称和功能描述如下。
编辑器中有一般模式和连接线编辑模式。

➮ 2.4.5 输入／删除连接线（2-44 页）

注： 当设置了自动读取功能，在软件启动时将自动读取并显示选定文件。

➮ 设置自动文件读取功能（2-30 页）

范例

使用文件“SAMP*.LDR”的一般编辑模式屏幕

连接线

主窗口
标题栏
显示当前窗口所编辑
的文件名。

菜单栏
显示菜单以执行
指令。

工具栏
提供按钮以执行指令。
只有常用的指令作为
按钮提供。
可以通过单击相应按
钮一次以执行各指令。

状态指示栏
指示当前选定的功能和关键状态。

主窗口
整个编辑器屏幕。

梯形图程序窗口
在一个窗口中显示各梯形
图程序。

功能菜单
显示各功能键所指令的功
能。
因为各个功能在菜单中都
显示为图标，所以可以通
过单击相应按钮一次以执
行各指令。

梯形图行号
显示梯形图中的一行的编号。

标题栏
显示正在编辑的文件名称。

步骤编号
指明梯形图中的步骤号。
步骤号仅在转换后显示，并且在梯形
图更改后删除。

梯形图符号
输入的指令词等将被
显示。

光标
允许选择设备等，且可以在垂直和水平移动。
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2.2.2 梯形图程序窗口屏幕

• 使用滚动条或光标控制键（[向左]、[向右]、[向上]、[向下]）以查看隐藏（未显示）
的部分。

■ 移动光标

向左/向右/向上/向下 键 :沿相应方向移动光标。
Pageup/PageDown 键 :将光标向上或向下移动一页

（屏幕）。
Ctrl + 向上/向下 键 :光标移动一个图块。
Home 键 :光标移动至第一行。
End 键 :光标移动至最后一行。

■ 当将屏幕分成两个窗口时

当指针放置于滚动条底部和窗口框之间时，指针将变成“   ”。（当指针形状为“  ”
时，窗口尺寸可以更改但屏幕不能分割。）
在此状态下按住左键并向上移动时，屏幕被分为上窗口和下窗口。每个窗口可以显示
不同的内容。
当选择“Edit”（编辑）菜单并单击“Link Screens”（链接屏幕）以添加复选标记
时，这两个窗口可以在互锁的条件下滚动。在一次查看一个较长的梯形图行时，此功
能很方便。

若要在上下窗口之间切换活动窗口，应在需要的窗口上单击鼠标或同时按 Shift (转换)
和 F6 键。

触点

行号

步骤号

光标

滚动条

注： 当指针形状为“  ”时，窗口尺寸可以更改但屏幕不能分割。
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2.3 文件管理

本节描述如何创建新的梯形图程序以及如何读取／保存梯形图程序文件、代码文件、
注释文件和助记符列表文件。

2.3.1 创建新文件  
File（文件）➔ New（新建）

当创建新的梯形图程序时，首先创建一个新的文件。
当 KV 梯形建筑者首次启动时，最初不显示梯形图程序窗口。
当创建新的梯形图程序时，应执行以下步骤。

从“File”（文件）菜单选择“New”（新建），或单击 。
• 选择要创建的梯形图程序的目标物型号。

• 将打开一个新的梯形图程序窗口。

注 1： 当您完成编辑新创建的文件时，确保要进行保存。

注 2： 如果型号指定为“KV-10(16)A/D”或“KV-24(40)A/D”，则创建的梯形图
不能用 KV 梯形建筑者版本 1.0 或 KV IncrediWare (DOS) 打开。若要这些
程序都能使用梯形图，应将型号指定为“KV-300”。

■ 梯形图程序的文件名

梯形图程序文件名在 KV 梯形建筑者中是唯一的。
文件扩展名是“ldr”。

梯形图程序可以与 KV IncrediWare (DOS) 共享。
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2.3.2 设置自动文件读取功能

File（文件） ➔ Auto Read（自动读取）

指定软件启动时自动读取的文件。当启动时总是需要读取相同的文件时，这个功能很
方便。
最多有 16 个文件可以指定用于自动读取功能。

设置和取消步骤描述如下。

■ 设置自动文件读取功能

1. 设置梯形图程序窗口自动读取作为当前窗口。

2. 从“File”（文件）菜单选择“Auto Read”（自动读取）。

3. 将会显示信息“Set this file to auto read?”（将此文件设置为自动读取?）。若要
将其设置为文件自动读取功能，应单击 [Yes] 按钮。

指定的文件设置了自动文件读取功能。下次启动 KV 梯形建筑者时，此文件将自
动读取。

4. 要指定其它文件，请重复上面的步骤 1 至 3。

■ 取消自动文件读取功能

1. 将设置了自动读取功能的文件设置为当前窗口。从“File”（文件）菜单选择 “Auto
Read”（自动读取）。

2. 将会显示信息“Cancel auto read?”（取消自动读取?）。若要取消文件自动读取
功能设置，应单击 [Yes] 按钮。

注 1： 不能选择仍未保存的文件用于自动文件读取功能。保存文件后再选择此文件。

注 2： 当指定自动文件读取功能的文件数超过 16 时，将显示警告信息。
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2.3.3 设置自动文件保存功能

File（文件）➔ Set Auto Save（设置自动保存）

当您处理文件时，梯形图、注释和标签的临时副本将以恒定的时间间隔自动保存。
当设置了自动文件保存功能时，文件将以指定的时间间隔自动复制进行临时保存。这
将使您在保存文件之前发生的断电或其它意外所造成的损害降到最低。

设置和取消步骤描述如下。

■ 设置自动文件保存功能

1. 从“File”（文件）菜单选择“Set Auto Save”（设置自动保存）。

2. 将打开“Set Auto Save”（设置自动保存）对话框。单击“Auto Save”（自动
保存）以添加复选标记，然后输入自动保存时间间隔。

• 默认情况下，自动文件保存功能设置为每 5 分钟。

3. 单击 [OK] 按钮。

■  取消自动保存功能

1. 从“File”（文件）菜单选择“Set Auto Save”（设置自动保存）。

2. 将打开“Set Auto Save”（设置自动保存）对话框。删除“Auto Save”（自动
保存）旁边的复选标记，然后单击 [OK] 按钮。

注 1： 此处设置的自动文件保存功能适用于当前打开的所有梯形图程序文件。

注 2： 当 KV 梯形建筑者正常关闭时，文件自动保存将自动取消。如果 KV 梯形建筑
者非正常关闭，当下次 KV 梯形建筑者启动时将自动读取自动保存的文件。
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2.3.4 保存和读取文件

保存文件  
File（文件）➔ Save（保存），File（文件）➔ Save As（另存为）

当您完成处理梯形图程序时，请保存文件。
有两种方法保存文件：“保存（覆盖重写）”和“另存为（以不同的名称保存）”。选择
任何一种。

当单击  ，则选择了“Save”（保存）。

Save（保存） : 以当前文件名保存文件。
Save As（另存为） : 以新名称保存文件。

注 1： 每次创建新文件时，将会在文件名的扩展名“ldw”之后自动加上一个数字，
如“ldw1.ldr”、“ldw2.ldr”、“ldw3.ldr”等。

注 2： 当对新文件执行“Save”（保存）时，将自动执行“Save As”（另存为）。

范例

以新名称保存文件时

1. 从“File”（文件）菜单选择“Save As”（另存为）。

2. 将显示“Change File Comment”（更改文件注释）对话框。输入文件注释，然
后单击 [OK] 按钮。当不需要文件注释时，请单击 [X] 按钮。

显示“Save Ladder Diagram”（保存梯形图）对话框。

当在 KV-Ladder（DOS 版本）中选择文件时，也将显示文件注释。

3. 指定要保存文件的文件夹（目录），然后输入文件名。

4. 单击 [OK] 按钮。

文件将以指定的文件名保存。

Folder (directory) 选择要保存文件的文件夹（目录）。

(文件夹 (目录)) 默认情况下选择当前文件夹（目录）。

File Name 输入包含最多 8 个字符的文件名。扩展名设置为“ldr”。一定不要
(文件名) 更改扩展名。

File Type (文件类型) 选择“梯形图 (*.ldr)”。不要更改此设置。



第二章 编辑器

2-33

12

C KV-H6WE2-UM

读取文件  
File（文件）➔ Open（打开）

当编辑现有文件时，选择并读取要编辑的文件。

1. 从“File”（文件）菜单选择“Open”（打开）。
显示“Open”（打开）对话框。

2. 指定保存要读取文件的文件夹（目录），然后选择文件名。

3. 单击 [OK] 按钮。
将读取指定的文件，而且梯形图程序窗口将打开。

2.3.5 读取和保存另一种格式的文件

本节描述用于保存和读取非“ldr”格式文件的方法，如助记符列表文件、其它文件中
的注释、文本格式的注释文件等。

注： 只有当选择梯形图程序窗口时才可以选择此功能。

通过从“File”（文件）菜单选择“New”（新建）以显示梯形图程序窗口，然
后选择“Other Format”（其它格式）。

保存和读取助记符列表

File（文件）➔ Other Format（其它格式）➔ Save Mnemonic List（保存助记符列表）,  File（文件）➔ Other
Format（其它格式）➔ Read Mnemonic List（读取助记符列表）

创建的梯形图可以保存为助记符列表（文本格式）。
可以读取保存的助记符列表（文本格式）。
在“Save As”（另存为）或“Open”（打开）对话框指定需要的助记符列表文件。

注： 当执行读取时，指定的助记符列表文件在当前窗口读取。在此情况下，当前窗
口中的梯形图将被擦除。当需要当前窗口中的梯形图时，应在读取助记符列表
之前将其保存到文件中。

■ 助记符列表的文件名

助记符列表文件采用常用的文本格式。
助记符文件的扩展名是“mnm”。

Folder (directory) 选择保存要读取文件的文件夹（目录）。
(文件夹 (目录)) 默认情况下选择当前文件夹（目录）。

File Name (文件名) 指定要读取的文件名。扩展名是“ldr”。
File Type (文件类型) 选择“梯形图（*.ldr）”。不要更改此设置。
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读取其它文件中的注释

File（文件）➔ Other Format（其它格式）➔ Read Other File Comment（读取其它文件注释）

从其它梯形图程序文件中只能读取注释。
在“Open”（打开）对话框中，指定要读取的注释所保存于的文件。

注 1： 当执行读取时，指定的注释在当前窗口读取。在此情况下，当前窗口中的注释
将被覆盖重写。当需要当前窗口中的注释时，应将其保存到文件中之后再从另
一个文件中读取注释。

注 2： 此功能只从梯形图中提取注释。此功能不读取整个梯形图。

■ 触点注释文件的文件名

每个注释文件的扩展名如下所示。
Comment 1: rcm
Comment 2: cm2
Comment 3: cm3
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以文本格式保存和读取注释

File（文件）➔ Other Format（其它格式）➔ Save Comment in Text Forma（以文本格式保存注释），File（文
件）➔ Other Format（其它格式）➔ Read Comment in Text Format（读取文本格式的注释）

创建的梯形图程序中的标签和注释能够以文本格式保存。也可以读取以文本格式保存
的注释文件。
在“Save As”（另存为）或“Open”（打开）对话框指定需要的注释文件。

注 1： 当执行读取时，指定的注释在当前窗口读取。在此情况下，当前窗口中的注释
将被重写。当需要当前窗口中的注释时，应在读取指定的注释之前将其保存到
文件中。

注 2： 如果执行读取时文本格式有不同，将显示出错信息。

■ 文本格式中注释文件的格式

注释文件采用常用的文本格式，如下所示。
注释文件的扩展名为“txt”。
设备名 标签名 注释 1 注释 2 注释 3

最多 5 位 最多 8 位 最多 32 位 最多 32 位 最多 32 位
   逗号

• 每个元素以逗号分隔。当字符串短时，即使在说明中省略了不必要的部分，也可以
进行读取。

• 当文件保存后，字符串的长度是固定的，如上所示。

• 下表显示了字符类型和字符数。

■ 当使用其它软件读取/保存数据时

以文本格式保存的注释可以用电子制表软件和数据库软件读取。注释也可以用电子制
表软件和数据库软件编辑，保存于文件，然后用 KV 梯形建筑者读取。
在用以上所述软件读取或保存数据时，应指定为 CSV 格式（在此格式中每一项以逗
号隔开）。

范例

当使用 Microsoft Excel 版本 5.0 电子制表软件时

• 读取数据时
在“Open File”（打开文件）对话框的“File Type”（文件类型）中选择一个文本文
件（*.prn、*.txt 或 *.csv）。
然后，在“Text File Wizard”（文本文件向导）中的“Data Format”（数据格式）中
选择“Data delimited into each field by delimiters such as comma and tab”（数
据用分隔符如逗号和制表符分隔为字段）。在“String Delimiter”（字符串分隔符）中
选择“Comma”（逗号）。在“Character String Quotation Mark”（字符串引号）
中选择“No”。

• 保存数据时
在“Save As”（另存为）对话框中的“File Type”（文件类型）中选择“CSV （delimited
with comma）”（CSV（以逗号分隔））。
选择可以由 KV 梯形图缓冲区读取的“*.txt”作为文件的扩展名。

标签名 字母最多 8 个字符。
不能输入空格和逗号。

注释 1
注释 2 最多 32 个字符

注释 3

, , , , ,
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2.3.6 以文本格式保存梯形图

File（文件）➔ Other Format（其它格式）➔ Save Ladder Diagram in Text Format（以文本格式保存梯形图）

创建的梯形图可以以文本格式保存。
当“Save As”（另存为）对话框打开时，输入文件名并保存。

范例

这在将以文本格式保存的梯形图读取到文字处理软件，然后重定格式时很重要。使用
作为 WINDOWS 附件的“Notepad”（记事本）。

2.3.7 校验文件

File（文件）➔ File-Verify File（文件－校验文件）

可以对编辑器中的梯形图在个人电脑上保存的梯形图程序内容进行校验。要进行校
验，请执行以下步骤。

1. 从“File”（文件）菜单选择“File-Verify File”（文件－校验文件）。
将显示“Open File”（打开文件）对话框。

2. 选择校验源文件，然后单击 [OK] 按钮。

3. 如果检测到有差异，则显示信息“Verification error”（校验出错）。单击 [OK] 按
钮。将显示错误列表。

4. 选择校验错误，然后单击 [JUMP]（跳转）按钮。光标将移到编辑器中的梯形图中
出现错误的位置。
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2.4 输入／删除符号和连接线

本节描述如何在梯形图中输入／删除符号和连接线。

2.4.1 输入符号

当指定指令词时，梯形图符号将自动输入。
可以使用以下两种方法输入指令词。
第一种方法，从“Enter Instruction Word”（输入指令词）窗口选择需要的指令词
类型和指令词代码。第二种方法，可以在输入所需指令词的第一个字符时所显示的对
话框种直接输入需要的指令词。

或者可以在当前光标位置输入 a (N.O.) (常开) 触点、b (N.C.) (常闭) 触点、 a (N.O.)
(常开) 触点 OR、b (N.C.) (常闭) 触点 OR 或者线圈。

➮ 直接输入触点/线圈（2-42 页）

• 选择性输入

• 直接输入 ➮ 2-41 页
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通过选择输入符号

Edit（编辑）➔ Symbol Input（符号输入）➔ Symbol Selective Input (Tab)（符号选择性输入（制表符））

当在“Enter Instruction Word”（输入指令词）窗口选择了需要的指令词类型时，可
以从列表中选择所选指令词的指令代码。另外，可以对每个操作数指定设备。如果您
不熟悉创建梯形图和处理指令词，建议您从“Enter Instruction Word”（输入指令
词）窗口输入符号，以确保正确。

要打开“Enter Instruction Word”（输入指令词）窗口，请从菜单选择“Edit”（编
辑），“Symbol Input”（符号输入）和“Symbol Selective Input”（符号选择性输
入）。另外，还有以下两种方法。这两种方法提供较快捷的操作。

将鼠标光标放在梯形图中您要输入指令词的单元格中，然后双击。

使用向左、向右、向上和向下键选择需要的单元格，然后按 Tab (制表符) 键。

注： 当指令词在选定的单元格中输入后，将在编辑模式打开。

■ 设置“Enter Instruction Word”（输入指令词）

单选按钮

顺序选择



第二章 编辑器

2-39

12

C KV-H6WE2-UM

1. 从窗口右部的“Instruction Type”（指令类型）选择所需的指令词类型。

单击所需的单选按钮。

2. 从“Instruction Word”（指令词）列表选择所需指令词。

当选择在 ON (开) 信号时仅执行一次的指令词时，请单击“Execute Once at
ON”（在 ON (开) 时执行一次）复选框以添加复选标记，然后选择需要的指令词。

指令词及其类型

Instruction word type 指令词

(指令词类型) 在 ON 信号时仅执行一次

Basic Instructions LD, LDB, AND, ANB, OR,
(基本指令) ORB, ANL, ORL, OUT. OUB,

SET, RES, TMR, TMH, TMS,
C, UDC, DIFU, DIFD, KEEP,
SFT, HSP, MC, MCR, MEMSW,
END, ENDH

Application Instructions W-ON, W-OFF, W-UE, W-DE,
(应用程序指令) STG, JMP, ENDS, STP, SET,

ITVL, CTH, CTC, CALL, SBN,
RET, FOR, NEXT, HKEY

Arithmetic Instructions DW, TMIN, LDA, STA, CMP, @TMIN, @LDA, @STA,
(运算指令) ADD, SUB, MUL, DIV, ANDA, @CMP, @ADD, @SUB,

ORA, EORA, SRA, SLA, RRA, @MUL, @DIV, @ANDA,
RLA, COM, INC, DEC, MPX, @ORA, @EORA, @SRA,
DMX, TBCD, TBIN, ASC, @SLA, @RRA, @RLA,
RASC, ROOT @COM, @INC, @DEC,

@MPX, @DMX, @TBCD,
@TBIN, @ASC, @RASC,
@ROOT

Interrupt Instructions DI, EI, INT, RETI
(中断指令)
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3. 为每个操作数指定一个设备。

单击       按钮以显示设备类型列表。从列表中选择需要的设备类型，并直接输入
相应的编号。

4. 完成设置后，单击 [OK] 或 [Insert]（插入）按钮。
[OK] ：覆盖重写梯形图符号。
[Insert]（插入） ：在光标位置插入梯形图符号。
[Cancel]（取消）：取消输入的设置，并关闭窗口。

5. 输入选定的梯形图符号。当已有符号在此位置输入，将用新选定的符号替代。

范例

当输入继电器 2008。

LD

继电器 2008

▲
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直接输入符号

Edit（编辑）➔ Symbol Input（符号输入）➔ Symbol Direct Input（符号直接输入）（Enter）

指令词也可以直接输入。
当您熟悉了梯形图程序创建和指令词处理，建议进行直接输入，因为比通过“Enter
Instruction Word”（输入指令词）窗口输入快捷、效率高。

要打开对话框以便直接输入指令词，请从菜单选择“Edit”（编辑），“Symbol Input”
（符号输入）和“Direct Symbol Input”（直接符号输入）。以下两种方法也可以用于
快速操作。

使用向左、向右、向上和向下键选择需要的单元格，然后输入要输入的指令词的第一
个字符。您也可以在更改现有输入时按下 ENTER (输入) 键。

对话框将打开，其中显示第一个字符。

示例

输入“A”时。

■ 在直接输入对话框输入符号

1. 从键盘直接输入指令词至文本框。

注 1： 输入助记符格式的指令词，然后在指令词和设备名之间输入空格。

LD 0001

注 2： 对于 LD 和 LDB，可以分别用“A”和“B”代替输入。
LD 0001 → A 0001
LDB 0001 → B 0001

2. 完成输入后，单击 [OK] 或 [Ins]（插入）按钮。
[OK] ：覆盖重写现有梯形图符号。
[Ins]（插入） ：在光标位置插入梯形图符号。
[Cancel]（取消）：取消输入的设置，并关闭窗口。

3. 输入梯形图符号。

→
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2.4.2 删除符号

Edit（编辑）➔ Symbol Input（符号输入）➔ Delete Symbol（Delete）（删除符号（删除））

要删除符号，将光标放在要删除的符号处，单击然后执行以下任一项操作。（此步骤
与字符删除步骤在原理上是相同的。）

• 按空格键。
• 按 Delete (删除) 键。
（当按下 Backspace (退格) 键之后，将删除光标之前的符号。）

2.4.3 直接输入触点／线圈

在当前光标位置直接输入触点或线圈。

输入 a/b 触点  
Edit (编辑) ➔ Symbol Input (符号输入) ➔ a (N.O. (常开)) 触点输入 (F5)

➔ b (N.C. (常闭)) 触点输入 (Shift + F5)
➔ a (N.O. (常开)) 触点 OR 输入 (F4)
➔ b (N.C. (常闭)) 触点 OR 输入 (Shift + F4)

要输入触点，请执行以下步骤：

1. 将光标放置于输入位置。

2. 从“Edit”（编辑）菜单中选择“Symbol Input”（符号输入），然后从子菜单选择
要输入的触点类型。
也可以按相应的功能键或单击相应的图标。

• 显示“Change Device”（更改设备）对话框。

输入 a 触点时：

a (N.O. (常开)) 触点输入 F5 键  按钮

输入 b 触点时：

b (N.C. (常闭)) 触点输入 Shift + F5 键  按钮

输入 a 触点 OR 时
a (N.O. (常开)) 触点 OR 输入 F4 键  按钮

输入 b 触点 OR 时
b (N.C. (常闭)) 触点 OR 输入 Shift + F4 键  按钮

3. 从键盘直接输入设备名至文本框。

4. 完成输入后，单击 [OK]。
单击 [Cancel] (取消) 按钮时，输入的设置将取消且对话框关闭。

5. 输入梯形图符号。
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输入线圈  
Edit（编辑）➔ Symbol Input（符号输入）➔ Coil Input（线圈输入）（F7）

                                     ➔ b（N.C.）触点线圈输入（Shift + F7）

要输入线圈，请执行以下步骤：

1. 将光标放置于输入行。

2. 从“Edit”（编辑）菜单选择“Symbol Input”（符号输入），然后从子菜单选择要
输入的线圈类型。
也可以按相应的功能键或单击相应的图标。

• 将显示“Change Device”（更改设备）对话框。

输入线圈时 : 线圈输入 F7 键  按钮

当输入 b 触点线圈时 : 线圈输入 Shift + F7 键  按钮

3. 从键盘直接输入设备名至文本框。

4. 完成输入后，单击 [OK]。
单击 [Cancel] (取消) 按钮时，输入的设置将取消且对话框关闭。

5. 输入梯形图符号。

2.4.4 在当前光标位置更改设备

Edit（编辑）➔ Change Device at Cursor Position (Esc) (光标位置更改设备 (退出)) ★ 单击右键

要在当前光标位置更改设备，请执行以下步骤。

1. 将光标放置在要更改的设备中。

2. 从“Edit”（编辑）菜单选择“Change Device at Current Position”（在当前位
置更改设备），或右键单击菜单，或按 Esc (退出) 键。
将显示“Change Device”（更改设备）对话框。

3. 从键盘直接输入设备名至文本框。

4. 完成输入后，单击 [OK]。
单击 [Cancel] (取消) 按钮时，输入的设置将取消且对话框关闭。

5. 设备已更改。
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2.4.5 输入／删除连接线

Edit（编辑）➔ Edit Connection Line（编辑连接线）（Ctrl + K + \）

输入连接线 

可以用以下两种方法输入连接线。

■ 按键或单击图标

F8 + /（斜杠键）或 : 从光标位置向下绘制连接线。

F9 + -（减号键）或 : 在光标右侧绘制连接线。

■ 在连接线编辑模式使用鼠标和光标控制键

若要使用鼠标绘制连接线，首先要更改输入模式。
可以使用以下四种方法更改模式。
• 从右键单击所显示的菜单中选择“Edit Connection Line”（编辑连接线）。

• 从“Edit”（编辑）菜单中选择“Edit Connection Line”（编辑连接线）。

• 同时按 Ctrl 和 K 键。

• 按 \ 键。

当选择了连接线编辑模式，光标变为如下形状：

要返回正常编辑模式，应再次执行此步骤。

1. 将鼠标光标放置于需要的连接线起点。使用键盘时，按 ENTER (输入) 键。

2. 当按住鼠标左键时，以希望的方向移动鼠标光标（拖动）。使用键盘时，按向左、
向右、向上或向下键之中的任意键。

3. 在希望的连接线终端位置释放按钮。使用键盘时，再次按 ENTER (输入) 键。（如
果按下 Delete (删除) 键，连接线将删除。）
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删除连接线  

要删除连接线，在连接线编辑模式下拖动要删除的连接线时按 Delete (删除) 键。

以下步骤也可以用于删除连接线。

■ 删除垂直连接线时

• 同时按 Shift (转换) 和 F8 键。

• 当在连接线编辑模式拖动要删除的连接线时，按 Shift 键并同时释放鼠标左键。

• 单击  按钮。

■ 删除水平连接线时

• 按空格键。

• 按 Backspace (退格) 键。（光标之前的连接线将删除。）

• 按 Delete (删除) 键。

• 当在连接线编辑模式拖动要删除的连接线时，按 Shift 键并同时释放鼠标左键。

• 单击  按钮。

2.4.6 取消编辑操作

取消编辑操作（UNDO）（撤消） 
Edit（编辑）➔ Undo（撤消）（Ctrl + Z）

最近执行的编辑操作（输入、移动或复制符号）可以取消，先前的状态可以恢复。
当最近的编辑操作是不可恢复的且撤消操作被禁用，则选择项“Undo”（撤消）将以
较淡的颜色显示以表明此选项是禁用的。

■ 不可恢复的操作

• 替换操作数

• 转换 N.O.(常开)/N.C.(常闭)触点

• 读取／保存程序、助记符文件等。

• 更改标签或注释

• 输入宏

取消撤消操作（REDO）（恢复）  
Edit（编辑）➔ Redo（恢复）（Ctrl + Y）

进行的最后取消操作可以取消。
当最近的撤消操作不可取消，则选择项“Redo”（恢复）将以较淡的颜色显示以表明
此选项是禁用的。
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2.5 输入注释／标签

本节描述如何向触点输入注释／标签，如何更改这些注释／标签，以及如何更改行注释。

2.5.1 编辑注释／标签

可以为触点输入标签名称、注释 1、注释 2 和注释 3。
输入注释使得在编辑梯形图时可以容易地推断出触点内容。注释显示于梯形图监控、
模拟器和监控器上。

处理“Edit Comment/Label”（编辑注释／标签）对话框。对每个设备类型均将显
示此对话框，让您一次可以编辑两个或更多注释。
标签名称和注释也可以通过在梯形图中选择要更改的设备而进行更改。

➮ 直接在梯形图中作更改（2-49 页）

注释／标签编辑方法描述如下。

注： 注释 2 和注释 3 文件是专用于 KV 梯形建筑者的。当注释要与 KV IncrediWare
(DOS) 共享时，应使用注释 1。

编辑每个设备的列表  
Comment（注释）➔ Edit Comment/Label（编辑注释／标签） (Ctrl + F7)

1. 从“Comment”（注释）菜单选择“Edit Comment/Label”（编辑注释／标

签），然后单击  按钮。

将显示“Edit Comment/Label”（编辑注释／标签）对话框。
默认情况下显示继电器 0000 至 0415。

梯形图中使用设备的旁边显示 “*”符号。

2. 在“Reading Device”（读取设备）区域选择要编辑的设备。

3. 在“Device Range”（设备范围）区域指定要在列表中显示的设备范围。

读取设备选择区域

标签／注释输入区域

设备列表显示区域
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4. 单击并选择要编辑标签／注释的设备，然后单击 [Edit]（编辑）按钮。（或者单击
并选择列表中显示的所需设备。）
使用键盘时，使用向上和向下键选择需要的设备，然后按 ENTER（输入）键。

光标显示于标签／注释输入区域的“Label Name”（标签名称）中，这样可以输
入字符。

5. 输入或更改标签／注释。标签／注释可以从另一个设备复制或与其交换。

• 下表显示了可用的字符类型和最大的允许字符数。

要注册基本继电器，应在“Edit Comment/ Label”（编辑注释／标签）对话框单击
[Register Basic Relay]（注册基本继电器）按钮，然后将使用的基本继电器型号输
入注释 1。

6. 完成输入后，单击 [Write]（写入）。
要关闭“Edit Comment/Label”（编辑注释／标签）对话框，请单击 [Exit]（退
出）按钮。

输入标签／注释。

要显示标签／注释，请选择“View”（视图）菜单。当显示子菜单时，选择“Show
Label”（显示标签）或“Show Comment”（显示注释）。

➮ 有关指定要显示的注释的方法，请参考显示模式（2-19 页）。

注： 可以在输入、搜索或替换符号时使用标签名称代替设备名称。

例如，当标签“SW1”赋予设备“0000”，可以写程序如下。
代替“0000” : SW1
代替“LD0000”LD : SW1

不能在指令选择窗口输入标签。

Label name 字母。最多 8 个字符。
(标签名) 不能输入空格和逗号。

Comment 最多 32 个字符
(注释) 1 （此注释与 KV IncrediWare（DOS）继电器注释兼容。）

Comment 最多 32 个字符
(注释) 2
Comment 最多 32 个字符
(注释) 3
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■ 当在列表中选择要显示的设备时

可以通过选取以下项以选择列表中要显示的设备。

仅显示已注册的设备：显示已注册标签／注释的设备。
仅显示使用的设备：显示梯形图中使用的设备。

如果两项都未选，则显示所有设备。

■ 当从另一个设备复制标签／注释时

1. 将光标放置在复制源设备，然后单击 [Copy]（复制）按钮。

2. 将光标放置在复制目标设备，然后单击 [Write]（写入）按钮。
当单击 [Exchange]（交换）按钮而不是 [Write]（写入）按钮时，则输入区域的
内容将与所选设备的注释进行交换。

■ 当删除注册的标签／注释时

要仅删除所选设备，将光标放在要删除的设备中，并按 Delete (删除) 键或单击
[Delete Selected Line]（删除选定行）按钮。

要删除所有设备，请单击 [Delete All]（删除所有）按钮。

■ 当从其它设备复制注释块时

1. 在设备列表显示区域中选择要作为块进行复制的设备注释范围。

➮ 选择范围（2-52 页）

2. 单击 [Block Edit]（块编辑）按钮。
将显示“Block Edit”（块编辑）对话框。

3. 通过选择相应的单选按钮选择要复制的注释类型。

4. 单击 [Copy]（复制）按钮。

5. 在设备列表显示区域中复制目标设备范围中指定起始设备。

6. 单击 [Block Edit]（块编辑）按钮。
将显示“Block Edit”（块编辑）对话框。

7. 单击 [Paste]（粘贴）按钮。
如果在第 1 步中指定的设备范围包含设备号，则在设备范围内的触点注释从第 5
步所选择的设备号开始将被复制。

单选按钮
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■ 当从其它设备移动注释块时

执行以上步骤 1 至 7。但是，在第 4 步时应单击 [Cut]（剪切）而不是 [Copy]（复
制）按钮。
通过此步骤，可以移动所选设备的注释块。

■ 当从其它设备删除注释块时

执行步骤 1 至 4。但在第 4 步单击 [Cut]（剪切）按钮。
通过此步骤，可以删除所选设备的注释块。

直接在梯形图中作更改

Comment（注释）➔ Change Label Name of Current Device（更改当前设备的标签名称）（Ctrl + B）
              ➔ Change Comment of Current Device（更改当前设备的注释）（Ctrl + M）

在梯形图中输入标签名称或注释时执行以下步骤。

1. 将光标放置在要输入的设备中。

2. 在输入标签名称时，从“Comment”（注释）菜单选择“Change Label Name
of Current Device Ctrl + B”（更改当前设备标签名称）。

在输入注释时，从“Comment”（注释）菜单选择“Change Comment Name
of Current Device Ctrl + M”（更改当前设备注释名称）。

将显示“Change Label”（更改标签）或“Change Comment X”（更改注释 X）
对话框。

用于更改注释的对话框的名称根据在“Display Mode”（显示模式）的“Comment
Type”（注释类型）中选择的注释类型而变化。

当已有标签名称或注释在设备中注册，将显示注册的字符串。

3. 输入需要的字符串。
可以输入在“Display Mode”（显示模式）下的“Comment Type”（注释类型）
中选择的注释。

➮ 显示模式（2-19 页）

4. 当单击了 [OK] 按钮时，将输入显示的字符串。
要取消输入，单击 [Cancel]（取消）按钮。

*   范例：当在“Comment Type”（注释类型）中显示“Comment 2”（注释 2）时
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2.5.2 编辑行注释  
Comment（注释）➔ Edit Line Comment（编辑行注释）（Ctrl + Enter)

行注释可以在梯形图的每一行进行描述。
输入行注释使得在编辑梯形图时可以容易地推断出电路块的内容。行注释显示于梯形
图监控、模拟器和监控器上。

要输入行注释或更改注释，请执行以下步骤。

1. 将光标放在行注释要输入／更改的行中。
在更改已经输入的注释时，双击此注释。将显示“Enter Line Comment”（输入
行注释）对话框。

2. 从“Comment”（注释）菜单选择“Edit Line Comment”（编辑行注释），然后

单击  按钮。将显示“Enter Line Comment”（输入行注释）对话框。

3. 输入或更改注释。
最多可以输入 70 个字符。

4. 当单击 [Insert]（插入）按钮时，将插入一个新行。
当单击 [Overwrite]（覆盖重写）按钮时，新行将重写当前行。
若要取消，单击 [Cancel]（取消）按钮。

输入的注释将显示于梯形图。

注 1： 当单击 [Overwrite]（覆盖重写）按钮时，位于光标行的梯形图部分将被删
除。确认要删除梯形图的相应部分后再单击 [Overwrite]（覆盖重写）按钮。

注 2： 行注释不能传输到 PLC （可编程逻辑控制器）。相应地，从 PLC (可编程逻
辑控制器) 中读取的程序中也不包含行注释。

行注释
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2.5.3 将梯形图行更改为注释

Comment（注释）➔ Change Ladder Line into Comment（将梯形图行更改为注释）➔ Settings（设置）
           （Ctrl + Q）★  单击右键

              ➔ Change Ladder Line into Comment（将梯形图行更改为注释）➔ Cancel（取消）
（Ctrl + W）★  单击右键

当您指定将梯形图行作为注释时，在转换过程中只有此指定部分将忽略。当您不希望
转换某个部分时，暂时设置此功能。
要设置将梯形图行更改为注释或相反设置，请执行以下步骤。

1. 选择要更改为注释的梯形图行范围，或反向执行此设置的范围。

➮ 选择范围（2-52 页）

2. 要设置将行更改为注释，请从菜单或右键菜单选择“Comment”（注释）、“Change
Ladder Line into Comment and Settings Ctrl + Q” (将梯形图更改为注释和设置)。
要取消设置，从子菜单选择“Cancel Ctrl + W”（取消）。

3. 选定的行范围将更改为注释。
当取消设置时，则指定的范围可以进行转换。

注 1： 设定为要更改为注释的梯形图行不能传输至 PLC (可编程逻辑控制器)。相应
的，设定为要更改为注释的梯形图行也不包含于从 PLC (可编程逻辑控制器)
读取的程序中。

注 2： 设定为要更改为注释的梯形图行不能通过 KV IncrediWare (DOS) 读取。相应
的，当通过 KV IncrediWare (DOS) 读取程序并且以相同的名称保存，则设置
为要更改为注释的梯形图行将被删除。
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2.6 编辑和布置

本节描述了梯形图编辑步骤，比如复制／移动／删除在梯形图中选择的范围、插入／
删除行、如何更改列数、电路布置等。

2.6.1 复制、移动和删除

复制、移动或删除在梯形图中选定的范围。
要复制、移动或删除选定范围，应使用“cut & paste”（剪切和粘贴）方法，这是标
准的 Windows 编辑程序。

选择范围

要复制、移动或删除数据，首先要选择范围。可以使用鼠标或键盘选择范围。

注： 在连接线编辑模式下不能执行复制、移动和删除功能。如果选择了连接线编辑
模式，请从“Edit”（编辑）菜单选择“Edit Connection Line”（编辑连接线），
并选择正常编辑模式（不添加复选标记）。

■ 使用鼠标选择范围

1. 将鼠标指针放在选择的开始位置，然后单击。
将显示光标。
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2. 按住鼠标左键的同时，将指针移动到选择的结束位置（拖动）。

选定的范围以黄色显示。

• 以单元格单位选择范围

在拖动鼠标指针时，水平移动指针至目标单元格，直到选择了希望的范围。

• 以行单位选择范围

在拖动鼠标指针时，垂直移动指针至目标行，直到选择了希望的范围。

注： 不能选择包含两行或更多行的单元格部分。

3. 在选择结束位置释放鼠标左键。
要取消选择，单击梯形图中的任何位置。

■ 使用键盘选择范围

1. 使用向左、向右、向上和向下键将光标放在选择开始位置。

2. 按住 Shift (转换) 键的同时，按向左、向右、向上和向下键，将光标移动到选择结
束位置。

选定的范围以黄色显示。

注： 不能选择包含两行或更多行的单元格部分。

3. 在选择结束位置释放 Shift (转换) 键。

要取消选择，再次按向左、向右、向上或向下键。

注： 如果范围是从右至左以单元格单位进行的选择，则不能选择左侧的单元格。如
果范围是向上方向以行单位进行的选择，则不能选择顶部的行。
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复制／移动／删除操作  
Edit（编辑） ➔ Cut（剪切）（Ctrl + X）★ 单击右键

➔ Copy（复制）（Ctrl + C） ★ 单击右键
➔ Paste（粘贴）（Ctrl + V） ★ 单击右键

1. 在选择了需要的范围后，执行以下步骤。

■ 当复制数据时

执行以下任意一项操作。

• 从工具栏上的“Edit”（编辑）菜单选择“Copy”（复制），或从右键菜单选择
“Copy”（复制）。

• 单击  按钮。

• 按住 Ctrl 键的同时，按 C 键。

当从另一个文件复制数据时

当打开两个或更多窗口时，可以在另一个文件窗口选择需要的范围，然后复制或移动
到当前窗口。

1. 单击复制的源窗口以将其设置为当前窗口。

2. 选择需要的范围并复制。

3. 单击复制的目标窗口以将其设置为当前窗口。

4. 执行粘贴操作。

➮ 2-56 页的步骤 3。
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■ 当移动／删除数据时

执行以下任意一项操作。

• 从工具栏上的“Edit”（编辑）菜单选择“Cut”（剪切），或从通过右键单击所显
示的快捷菜单中选择“Cut”（剪切）。

• 单击  按钮。

• 按住 Ctrl 键的同时，按 X 键。

2. 在复制或移动数据时执行以下步骤。

■ 在粘贴数据至梯形图时

将鼠标指针放在复制目标或移动目标处，然后单击。您也可以使用向左、向右、向上
和向下键将光标移动至复制目标或移动目标处。
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3. 执行以下任意一项操作。
• 从工具栏上的“Edit”（编辑）菜单选择“Paste”（粘贴），或从通过右键单击所

显示的快捷菜单中选择“Paste”（粘贴）。

• 单击  按钮。

• 按住 Ctrl 键的同时，按 V 键。

• 按住 Shift (转换) 键的同时，按 Insert (插入) 键。

将粘贴选定的范围。

注 1： 剪切部分暂时复制到剪切缓冲区中。因此，即使此部分被剪切以删除，通过执
行上面的第 3 步仍可以再次粘贴。

注 2： 当复制的单元格数量大于粘贴的目标空间时，将显示“Can’t write at current
position”（不能在当前位置写入），而且将只粘贴相当于粘贴目标空间的单元
格。其它单元格将不粘贴。



第二章 编辑器

2-57

12

C KV-H6WE2-UM

2.6.2 插入和删除行

要将行插入梯形图或删除当前行，请执行以下步骤。

插入空行

Edit（编辑） ➔ Insert Empty Line（插入空行）（Shift + Enter）★  单击右键

1. 将光标放置于空行要插入的位置。

要一次插入两个或更多空行，首先要选择插入范围。然后，将一次插入所有选定的
空行。

2. 从“Edit”（编辑）菜单或右键菜单选择“Insert Empty Line”（插入空行），或者
在按住 Shift (转换) 键同时按 ENTER (输入) 键。

空行将插入于光标之上。

删除行

Edit（编辑）➔ Delete Line（删除行）（Shift + Delete）

1. 将光标放置在要删除的行中。

要一次删除两行或更多，首先要选择删除范围。

2. 从“Edit”（编辑）菜单选择“Delete Line”（删除行），或者在按住 Shift (转换)
键同时按 Delete (删除) 键。

指定的行将被删除。
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2.7 跳转、搜索和替换

本节描述如何跳转至梯形图中的任何位置，搜索指令词／操作数，以及替换操作数或
N.O. (常开)/N.C. (常闭) 触点。

2.7.1 跳转

编辑控制可以通过指定程序需要的行号或步进号以跳转至任何位置。编辑控制也可以
跳转值第一或最后一行。使用跳转功能以快速更改编辑位置。

跳转至指定的行／步骤

Edit（编辑）➔ Jump（跳转）➔ Line/Step No.（行／步进号）

要通过指定梯形图程序需要的行号或步进号从而跳转至另一个位置，请执行以下步骤。

1. 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Line/Step No”（行／步进
号）。也可以从键盘直接输入行号或步进号。

将显示“Jump to Specified Line”（跳转至指定行）对话框。

2. 指定行号或步进号作为跳转目标。
当在第 1 步从键盘输入了行号或步进号，则已经指定好。

3. 当要通过指定行号进行跳转编辑控制，请单击 [Line]（行）按钮。
当要通过指定步进号进行跳转编辑控制，请单击 [Step]（步进）按钮。
单击 [Cancel] （取消）按钮以取消跳转。

将显示指定的行或步进，而且光标移动到指定的行或步进。

注： 如果选择了大于最后一行或步进号，则显示最后一行或步进。
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跳转至第一/最后一行

Edit（编辑）➔ Jump（跳转）➔  Top（顶部）（Ctrl + Home）
➔  Bottom（低部）（Ctrl + End）

要跳转至梯形图的第一行或最后一行，请执行以下步骤。

■ 跳转至第一行时

从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Top”（顶部）。

■ 跳转至最后一行时

从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Bottom”（底部）。

跳转到注册的行

Edit（编辑）➔ Jump（跳转）➔ Line Registration（行注册）（Ctrl + L）
➔ Registered Line（注册行）（Ctrl + J）

需要的行可以暂时与注释一起注册，编辑控制可以通过从注册行列表指定跳转目标进
行跳转。
当跳转至同一行需进行多次，或者行号不能帮助您识别此行时，此功能很有用。

■ 注册行

通过以下步骤注册行。

1. 将光标放置在要注册的行中。

2. 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Line Registration”（行注册）。

将显示“Line Registration”（行注册）对话框。

3. 必要时为要注册的行将需要的注释输入“Comment”（注释）。
当为另一个文件注册相同的注释时，将“Line No.”（行号）更改为要注册的行号。

最多可以输入 70 个字符。
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4. 在记录指定的行时单击 [Register]（注册）按钮。
单击 [Cancel]（取消）按钮以取消注册。

将记录指定的行。

注： 最多可以记录 32 行。当记录的行数超过 32 时，将从最早的行开始删除行。

■ 跳转到注册的行

要跳转到注册的行，请执行以下步骤。

1. 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Registered Line”（注册行）。

将显示“Jump to Registered Line”（跳转至注册行）对话框。

2. 将指针定位到所显示的行号／注释列表中的跳转目标行，然后单击。双击它将立即
跳转。

3. 单击 [Jump]（跳转）按钮。
若要取消跳转，单击 [Cancel]（取消）按钮。

将显示指定的行，而且光标移动到指定的行。

■ 删除注册行

在“Jump to Registered Line”（跳转到注册行）对话框将光标定位于要删除的行
中，然后单击 [Delete Registration]（删除注册）按钮。将删除指定的行。

注 1： 对每一个梯形图程序窗口设置注册。

注 2： 当文件保存时，注册行的数据也将保存。

注 3： 如果数据由 KV IncrediWare (DOS) 进行保存，则注册将无效。
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跳转至下一个／上一个块

Edit（编辑）➔ Jump（跳转）➔ Next Block（下一个块）（Ctrl + 向下）
➔ Previous Block（上一个块）（Ctrl + 向上）

要从当前光标位置跳转至下一个或上一个电路块，请执行以下步骤。

■ 跳转至下一个电路块

• 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Next Block”（下一个块）。
• 在按住 Ctrl 键的同时按向下键。

注： 从一个注释行跳转到下一个电路块是禁用的。

■ 跳转至上一个电路块

• 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Previous Block”（上一个块）。
• 在按住 Ctrl 键的同时按向上键。

跳转至行的开头/结尾

Edit（编辑）➔ Jump（跳转）➔ Beginning of Line（行的开头）（Home）
➔ End of Line（行的结尾）（End ）

要跳转至光标所在行的开头或结尾，请执行以下步骤。

■  跳转至行的开头

• 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“Beginning of Line”（行的开头）。

• 按 Home 键。

■  跳转至行的结尾

• 从菜单选择“Edit”（编辑）、“Jump”（跳转）和“End of Line”（行的结尾）。

• 按 End 键。
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2.7.2 搜索指令词／操作数  
Edit（编辑）➔ Find（查找）（Ctrl + F）

要通过指定指令词或操作数在程序中搜索某个指令和设备，请执行以下步骤。

1. 从菜单选择“Edit”（编辑）和“Find”（查找）。或单击  按钮。

将显示“Find Instruction”（查找指令）对话框。

2. 将要查找的指令词输入到“Instruction Word”（指令词）文本框。将要查找的操
作数输入到“Operand”（操作数）文本框。
也可以单独搜索指令词或操作数。

注 1： 当搜索计时器指令、计数器指令或高速计数器指令时，指定“TMR”、“CTC”
等来寻找指令词，“T0”、“C0”等来寻找操作数。

注 2： 当使用两个或更多操作数时，要查找的指令和操作数都应指定。

3. 选择搜索方向。
向前：从当前光标位置向前搜索。
向后：从当前光标位置向后搜索。

4. 单击 [Search Next]（搜索下一处）按钮。

搜索开始，将显示包含指令或操作数的第一个块。

如果未查找到指定的指令词或操作数，将显示信息“Can't find specified
symbol.”（找不到指定的符号）。

5. 要继续搜索，请单击 [Search Next]（搜索下一处）按钮。
若要停止搜索，单击 [Cancel]（取消）按钮。

注 1： 可以打开两个或更多搜索窗口。

注 2： 搜索对当前梯形图窗口执行。因为即使在当前梯形图窗口更改了以后，搜索条
件仍将保持有效，所以相同的搜索条件可以用于搜索不同的梯形图窗口。
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2.7.3 在光标位置搜索设备

Edit（编辑）➔ Find Device at Cursor Position in Ladder（在梯形图中光标位置查找设备）
➔ Search Backward（向后搜索）（U）（F2）
➔ Search Forward（向前搜索）（F3）
➔ Search for OUT Backward（向后搜索 OUT）（Shift + F2）
➔ Search for OUT Forward（向前搜索 OUT）（Shift + F3）

要搜索与当前光标位置设备相同的设备，请执行以下步骤。

1. 将光标放置在要查找的设备中。

2. 从“Edit”（编辑）菜单中选择“Find Device at Cursor Position in Ladder”
（在梯形图中查找光标位置的设备）。

3. 选择搜索方向。
向后搜索 ：从当前光标位置向后搜索。
向前搜索 ：从当前光标位置向前搜索。
向后搜索 OUT：从当前光标位置向后搜索 OUT。
向前搜索 OUT：从当前光标位置向前搜索 OUT。

4. 搜索开始，将显示查找到的第一个设备。

5. 要继续搜索，重复上面的步骤 2 至 4。
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2.7.4 替换操作数  
Edit（编辑）➔ Replace Operand（替换操作数）（Ctrl + R）

要通过指定替换范围和替换宽度来替换操作数，请执行以下步骤。

1. 从“Edit”（编辑）菜单选择“Replace Operand”（替换操作数），然后单击 
按钮。

将显“Replace Operand”（替换操作数）对话框。

2. 在替换之前将操作数输入“Before Replacement”（替换之前）文本框。
在替换之后将操作数输入“After Replacement”（替换之后）文本框。

3. 输入替换宽度。

什么是替换宽度？
替换宽度表明将作为替换目标的操作数数量。
例如，当用“0500”替换“3000”时设置“3”，“3000”至“3002”将被
“0500”至“0502”替换。

4. 使用行数指定替换范围。默认情况下，替换所有行（从第一行至最后一行）。

5. 指定替换方法。通过单击向需要的方法添加复选标记。

6. 若要执行替换，单击 [OK] 按钮。若要取消替换，单击 [Cancel]（取消）按钮。

“Before Replacement”（替换之前）文本框中设置的操作数以灰色光标指示，
而且将显示确认信息“Replace this operand?”（替换此操作数?）。

Replace All without Check 不显示确认执行替换的信息。

(不经过检查替换全部)
Show Can’’’’’t Replace Message 对于不能替换的操作数，显示此信息。

(显示不能替换信息)
Move Comment and Label 附加于替换前操作标上的注释和标签将附加在替换
(移动注释和标签) 后的操作数上。
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7. 单击 [Yes] 按钮以执行替换。
单击 [No] 按钮不执行替换。
单击 [Cancel]（取消）按钮以取消替换。

以褐色光标指示的操作数将被在“After Replacement”（替换之后）文本框中设
置的操作数替换。

注 1： 当选择了“Replace All without Check”（不经过检查替换全部），将不显示
确认信息。

注 2： 当选择了“Move Comment and Label”（移动注释和标签），将替换设置范
围内的设备的所有注释。例如，如果用“0010”替换“0000”，“0000”注
释将被删除，“0010”注释将替换它。

8. 当完成了所有替换，将显示替换的操作数数量。
单击 [OK] 按钮。

2.7.5 转换 a/b 触点。

Edit（编辑）➔ Convert  (转换) a-b (N.O.-N.C.) Contacts ((常开-常闭) 触点) (Ctrl + A)

要将 a (N.O.) (常开) 触点转换为 b (N.C.) (常闭) 触点，或将 b (N.C.) (常闭) 触点
转换为 a (N.O.) (常开) 触点，请执行以下步骤。

1. 从 “Edit”（编辑）菜单选择“Convert a-b (N.O-N.C) Contacs” (转换 a-b (常
开-常闭) 触点)。

将显示“Convert a-b (N.O-N.C) Contacs” (转换 a-b (常开-常闭) 触点)。对话框。

2. 输入要转换的操作数。单“Convert All without Check”（不经过检查转换全
部）以添加复选标记，使确认执行转换操作的信息不显示。
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3. 若要执行转换，单击 [OK] 按钮。
若要取消转换，单击 [Cancel]（取消）按钮。

指定的操作数以灰色光标指示，且显示确认信息“Convert this contact?”（转换
此触点?）。

注： 当选择了“Convert All without Check”（不经过检查转换全部），将不显示
确认信息。

4. 单击 [Yes] 按钮以执行转换。
单击 [No] 按钮不执行转换。
单击 [Cancel]（取消）按钮以取消转换。

a (N.O.) (常开) 触点将转换为 b (N.C.) (常闭) 触点。b 触点转换为 a 触点。

5. 当完成了所有转换，将显示转换的触点数量。
单击 [OK] 按钮。
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2.8 编辑助记符列表

本节描述了如何将梯形图中的各电路块显示为助记符列表，以及如何直接编辑助记语言。

2.8.1 显示和终止助记符列表

显示助记符列表  
Edit（编辑）➔ Edit List（编辑列表）

要通过指定块显示助记符列表，和通过编辑助记符列表输入符号，请执行以下步骤。

1. 将光标放在要显示助记符列表的块中，或助记符列表的编辑内容将进行插入／替换
的块中。

对于插入的情况，编辑内容将插入到光标行之上。

2. 从“Edit”（编辑）菜单选择“Edit List”（编辑列表），然后单击  按钮。

光标位置处的块的助记符列表将在列表编辑窗口显示。

助记语言可以直接在屏幕上编辑。
对于编译过的块，将显示步进号。
当输入新助记符时，不一定要输入步进号和注释。

➮ 有关编译步骤，请参考第 2-75 页的“2.12 编译”。



第二章 编辑器

2-68

2

C KV-H6WE2-UM

终止助记符列表

■ 将编辑过的助记符列表插入到光标位置，然后终止编辑

完成编辑后，单击 [Insert]（插入）按钮。

列表编辑窗口将关闭，且编辑内容将插入到梯形图的光标位置。

■ 用编辑的助记符列表替换光标位置的块，然后终止编辑

完成编辑后，单击 [Replace Blocks]（替换块）按钮。

列表编辑窗口将关闭，且编辑内容将覆写梯形图中光标位置的块。

助记符列表的格式

助记符列表使用以下格式。
请切记，如果格式不同，编辑将禁用。

;

步进号 助记符

2 个空格 2 个空格

操作数

2 个空格

分号

注释

注 1： 注释不能在助记符列表编辑。

注 2： 在编辑助记符列表时，不一定要输入步骤号和注释。
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2.8.2 复制、移动和删除

可以使用“cut & paste”(剪切和粘贴) 操作在助记符列表执行复制、移动和删除操
作，与在梯形图中的操作相同。

1. 将光标放置在复制／移动／删除范围的起始位置处。

2. 在按住 Shift (转换) 键的同时，使用向上和向下键移动光标至范围的结束位置。

选定的范围以蓝色显示。

3. 在结束位置释放键。

取消选择时，按向上或向下键，而无需按住 Shift (转换) 键。

4. 使用快捷键执行剪切、复制或粘贴操作。

➮ 复制／移动／删除操作（2-54 页）

剪切 Ctrl + X ：剪切所选范围。
复制 Ctrl + C ：复制所选范围。
粘贴 Ctrl + V ：粘贴剪切或复制的范围。

注： 在 Windows 95 下，可以用鼠标（右键单击）代替键。
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2.9 显示使用状态

本节描述如何显示在编辑梯形图时程序所用的继电器、计时器、计数器、比较器、数
据存储和暂时存储的列表。

2.9.1 显示使用状态列表

显示使用状态 
Edit（编辑）➔ Usage Information（使用信息）

要显示在编辑梯形图时程序所用的继电器、计时器、计数器、比较器、数据存储和暂
时存储的列表，请执行以下步骤。

1. 从“Edit”（编辑）菜单选择“Usage Information”（使用信息），然后单击 
按钮。

将显示“Usage Information”（使用信息）对话框。

2. 选择要从“Type”（类型）进行检查的项目。将显示使用状态列表。

3. 您可以一边在显示器上检查设备使用状态列表，一边编辑梯形图。要反映正在创建
的梯形图的最新使用状态，请单击 [Update(U)]（更新）按钮。

4. 要关闭使用状态列表，请单击 [Close(C)]（关闭）按钮。
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2.10 设置系统

本节描述了如何设置自动保存功能所使用的目录，以及如何选择解编译错误检查。

2.10.1 设置系统

Edit（文件）➔ System Settings（系统设置）

要设置自动保存功能所使用的目录，以及选择解编译错误检查，请执行以下步骤。

1. 从“Edit”（编辑）菜单选择“System Settings”（系统设置）。

将显示“System Settings”（系统设置）对话框。

■ 在为自动保存功能设置工作目录时

使用完整路径指定自动保存功能所用的目录（文件夹），称为“Work Directory”
（工作目录）。

■ 当选择解编译错误检查时

单击“Code Check”（代码检查）复选框以添加复选标记。当梯形图程序编译完
后，将自动检查解编译错误。
当检测到错误时，在编译完成时将显示信息“Reverse Compile Error”（反编译
错误）。

➮ H.3  不能解编译的程序（附录 2-203 页）

默认情况下指定代码检查。
当不需要解编译错误检查时，删除复选标记。

注： 当指定代码检查时，编译时间将较长，因为在程序从 KV 主机传输至个人电
脑时，将检查这个程序在解编译时错误和传输时的中断情况。
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2.11 输入和开发宏

KV 梯形建筑者具有宏功能。通过使用宏，相同步骤重复多次的程序和具有扩展指令
的程序就可有效地输入。标准情况下，KV 梯形建筑者带有宏文件，以输入频繁使用
的电路。

2.11.1 创建宏文件

要使用宏，首先要创建宏文件，将要处理的内容保存到宏中。
要创建宏，请执行以下步骤。

1. 从“File”（文件）菜单中选择“New”（新建），然后根据型号打开新的梯形图程序。

2. 将光标放置于第一行。 从“Comment”（注释）菜单选择“Edit Line Comment”
（编辑行注释）。

将显示“Enter Line Comment”（输入行注释）对话框。

3. 在第一行，按以下格式输入宏名称、自变量数和注释，作为宏的起始说明行。

@ 宏名称、自变量数、注释

在开头加“@”。

@TEST.4.test macro

自变量数

宏名称 输入最多 8 个字符。不要输入空格。

自变量数 输入变化的设备数量。包含于梯形图中的临时设备（如下所
示）可以用任意设备（最多 10 个设备）替换。

注释 输入对变元的注释等。

→

用逗号（,）分隔各项。

注释
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4. 在宏的起始说明行下，输入宏要处理的符号。此时，将要作为自变量处理的设备描
述为临时设备。

什么是临时设备？
临时设备表明在实际设备还未确定时描述为临时的设备。可以描述最多 1,000 个
临时设备，从“@0”至“@999”。当宏开发以后，每个临时设备将自动替换。

注： 每个宏中最多可使用 10 个设备，从“@0”至“@9”。使用时，应确保从
“@0”开始按顺序指定临时设备。

5. 在最后一行，从“Edit Line Comment”（编辑行注释）输入两个“@”符号，作
为宏的终止说明行。

范例

在三个继电器启动时，写数据（恒量）至 DM0000 的宏。（使用四个自变量）

6. 在一个宏文件中可以描述两个或更多宏。在描述另一个宏时，请重复上面的步骤 3
至 5。

注： 确保在宏的起始说明行和终止说明行之间描述各个宏。

7. 从“File”（文件）菜单选择“Save As”（另存为），并用需要的宏文件名保存文
件。文件的扩展名是“ldr”，与梯形图的扩展名相同。

现在创建宏文件完成了。
KV 梯形建筑者带有宏文件“IMACRO.LDR”，以输入频繁使用的电路。在输入电路
时使用此文件。

注 1： 宏的起始说明行是作为行注释输入的。输入最多 70 个字符。

注 2： 计时器／计数器指令不能使用临时设备。

宏起始
说明行

宏

宏终止
说明行
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2.11.2 输入和开发宏

Edi（编辑）➔ Macro Input（宏输入）➔ Develop（开发）（Shift + F1）

要使用宏，必须输入宏指令。

1. 打开要输入的宏所保存于的宏文件。

对自动文件读取功能指定频繁使用的宏。

2. 将宏要输入的梯形图程序窗口作为当前窗口。

3. 从“Edit”（编辑）菜单选择“Macro Input → Develop”（宏输入→开发）

将显示“Macro Input”（宏输入）对话框。

4. 在“Macro Name”（宏名称）文本框选择要输入的宏名称。
在宏起始说明行所描述的宏名称将在此显示。

5. 输入宏操作数为“@0”、“@1”. . .

您可以输入与在宏文件中指定的自变量数一样多的宏操作数。

在宏起始说明行描述的注释显示于“Comment”（注释）列。

6. 完成输入后，单击 [OK]。
若要取消输入，单击 [Cancel]（取消）按钮。

宏已输入。

注： 更改过的宏不能恢复到原始状态。
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2.12 编译

本节描述如何编译使用编辑器创建的梯形图程序。

2.12.1 执行编译  
Compile（编译）➔ Compile（编译）（Ctrl + F9）

使用编辑器创建的梯形图程序不能传输到 PLC (或编程逻辑控制器)。必须编译为机
器码。

要编译梯形图程序，应执行以下步骤。

1. 将要编译的梯形图程序设置为当前窗口。

2. 从“Compile”（编译）菜单选择“Compile”（编译），或单击  按钮。

将执行编译过程。

3. 如果程序正确编译，将显示信息“Compilation successful.”（编译成功）。单击
[OK] 按钮。
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2.12.2 错误显示  
Compile（编译）➔ Show Error（显示错误）（Ctrl + F10）

当在编译过程中出错时，将显示信息，您可以确认错误内容。

1. 当出现错误时，将显示信息“Compilation Error”（编译错误）。

2. 单击 [OK] 按钮。

将显示错误窗口。

3. 要在程序中跳转至错误位置，应指定要查看的错误并单击 [Jump]（跳转）按钮。

将显示错误位置。

4. 要再次显示错误表，请从“Compile”（编译）菜单选择“Show Error”（显示错

误），或单击  按钮。

2.12.3 双线圈检查

双线圈检查

Compile（编译）➔ Check Double Coil（检查双线圈）

可以检查梯形图程序中的双线圈位置。（在编译时双线圈位置将不检测为错误。）

从菜单中选择“Check Double Coil”（检查双线圈）。将检测双线圈。

注： 双线圈检查使用三个指令词：OUT、DIFU 和 DIFD。

即使双线圈位置未被双线圈检查检测到，根据梯形图电路装配，它也可以起到
双线圈的作用。

错误代码 内容
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2.13 打印功能

本节描述如何打印梯形图、助记符列表、标签／注释／参考、设备使用状态以及参数。

2.13.1 打印  
File（文件）➔ Print（打印）（Ctrl + P）

在开始打印之前将个人电脑连接至打印机。

必须在开始打印之前设置要打印的内容。

1. 从“File”（文件）菜单选择“Print”（打印），或单击  按钮。

将显示“Print Setup”（打印设置）对话框。

2. 您可以选择是否打印各个项目。单击“Yes” 将打印项目，单击“No” 将不打印项目。
默认情况下，仅对梯形图选择“Yes”。

可以打印以下四个项目。
• Ladder diagrams (梯形图)
• Mnemonic lists (助记符列表)
• Labels/comments/references (标签／注释／参考)
• Device use status (设备使用状态)

3. 可以对各个项目设置打印范围。在单击 [Detail]（详细）按钮时显示的对话框中设
置范围。

➮ 对于各个项目的设置步骤，请参考 2-78 页。

4. 单击 [OK] 按钮以开始打印。
单击 [Cancel]（取消）按钮以取消打印。

注 1： 如果更改了设置，则单击 [Cancel]（取消）按钮时不保存更改。

注 2： 如果在显示模式下选择“Show in XYM”（以 XYM 显示）和“Show Decimal
Constant with Sign”（以符号显示），则根据设置进行打印。

➮ 显示模式（2-19 页）
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■ 梯形图（详细）

打印范例

■ 助记符列表（详细）

打印范例

项目 设置内容（输入范围） 初始值

Print Start Line No. 打印开始的行号 1
(打印开始行号)
Print Finish Line No. 打印结束的行号 编辑屏幕的最后
(打印结束行号) 一行

No. of Lines in Page 一页打印的行数（5 至 50） 20
(一页的行数)
Print Comment (打印注释) Comment (注释) 1、Comment (注释) 2、No (无)

Comment (注释) 3 或 No (无)
Print Device (打印设备) Device Name (设备名称) 或 Device Name

Label Name (标签名称) (设备名称)
Divide Block (分隔块) Consider (考虑) (分隔) 或 Ignore Consider

(忽略) (不分隔) (考虑)

0000

0001 ** **

0002

0003

0004

0005

T 000

L0002 (A)
L0006 (A)

L0005 (%)

L0006 (A)
L0007 (A)

L0008 (%)

L0007 (A)

$00024

T000
T 001

$00020

T001
T 002

$00054

0000 T000

Name : SAMP01.LDR (KV10) LADDER Date : 1997/09/06 Page (1/1)

0000
0001
0002
0003
0004
0005
0006
0007
0008
0009
00010
00011
00012
    •
00013

LD
MPS
CTC
CON
CTC
CON
CTH
MPP
CTC
CON
CTC
CON
CTH

LD

2002

1

0

0

2

3

1

2008

#020

#255

2101

#65535

#65535

0500

** **

** **

Name : TRST02 LDR (KV01) LIST Date : 1997/08/22 Page (1/3)
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项目 设置内容（输入范围） 初始值

No. of Lines in Page (一页的行数) 一页打印的行数 (30 至 120) 70
Print References (打印参考) Yes 或 No No

项目  输入范围（初始值）

Relay (继电器) 根据型号而定的可用范围

Timer (计时器)
Counter (计数器)
High-Speed Counter (高速计数器) —

Comparator (比较器) —

Data Memory (数据存储) 根据型号而定的可用范围

Temporary Memory (临时存储) —

<     >
<N0.> <Label> <Comment1> <Comment2> <Comment2>
0000 : SWO SWITCH SWITCH

L002(A) L0006(A)

0500 : OUTPUT 500
L006(OUT)

0501 : OUTPUT 501
L008(OUT)

0502 : OUTPUT 502
L007(OUT)

Name : SAMP01.LDR (KV10) Date : 1997/09/06 Page (1/1)Label

■ 标签／注释／参考（详细）

向要打印的设备添加复选标记，并设置打印范围。
默认情况下，选择所有设备且指定整个范围。

打印范例

项目 设置内容（输入范围） 初始值

Print Start Step 打印开始的步进号 0
(打印开始步骤)
Print Finish Step 打印结束的步进号 65534
(打印结束步骤)
No. of Lines in Page 一页打印的行数 (30 至 120) 60
(一页的行数)
Print Comment Comment (注释) 1、Comment (注释)  2、 No (无)
(打印注释) Comment (注释)  3 或 No (无)
Print Device Device Name (设备名称) 或 Device Name
(打印设备) Label Name (标签名称) (设备名称)
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[     ]

0123456789ABCDEF 0123456789ABCDEF 0123456789ABCDEF 0123456789ABCDEF 0123456789ABCDEF

0000–– 0415: X
0500–– 0915: XXX
1000–– 1415:
1500–– 1915:
2000–– 2415:
2500–– 0915:

Name : SAMP01.LDR (KV10) Date : 1997/09/11 Page (1/5)

■ 设备使用状态

向要打印的设备添加复选标记，并设置打印范围。
默认情况下，选择所有设备进行打印。

打印范例（继电器）
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2.13.2 预览显示

File（文件）（F）➔ Print Preview（打印预览）（V）

要在屏幕上预览要打印的内容，请执行以下步骤。

1. 从“File”(文件) 菜单选择“Print Preview” (打印预览)。
将显示“Print Setup”(打印设置) 对话框。

2. 设置要打印的内容。

➮ 对于设置步骤，请参考 2-77 页。

3. 单击 [Execute]（执行）按钮。
将显示实际要打印的图像。

可以在此屏幕单击 [Print]（打印）按钮，以打印显示的内容。
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2.14 更改屏幕上的显示颜色

在梯形建筑者，可以更改屏幕的颜色布局。本节描述如何更改屏幕上的显示颜色。

2.14.1 更改屏幕上的显示颜色

View（视图）➔ Change Ladder Diagram Color（更改梯形图颜色）

此功能设置梯形建筑者屏幕的颜色布局。
设置步骤描述如下。

1. 从“View”（视图）菜单选择“Change Ladder Diagram Color”（更改梯形图
颜色）。
将显示“Change Ladder Diagram Color”（更改梯形图颜色）对话框。

每个项目侧面的“Color”（颜色）框表明了当前颜色设置。

2. 在“Section to be Specified”（要指定的部分）文本框选择要更改颜色的项目，
然后单击      “Color”（颜色）按钮。
也可以在对象屏幕的图中单击需要的位置，以设置“Section to be Specified”
（要指定的部分）文本框。

将显示“Color Setup”（颜色设置）对话框。

选择需要的颜色，然后单击 [OK] 按钮。

可以通过单击 [Create Color]（创建颜色）按钮创建中间颜色。
要确定创建的中间颜色，请单击 [Add Color]（添加颜色）按钮。

3. 完成更改后，单击 [OK]。
单击 [OK] 按钮以确认设置。单击 [Cancel]（取消）按钮以取消设置。

要将屏幕颜色恢复为默认设置，请单击 [Back to Initial Setting]（恢复为初始设
置）按钮。

注： 当屏幕上的显示颜色数设置为 256 或更低，有些颜色将不能正常显示。

对象屏幕

设置颜色色调。

设置亮度。
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3.1 模拟器功能概述

本节简单介绍了模拟器的功能及使用时的注意事项。

3.1.1 功能概述

无须将模拟器连接到 PLC（可编程逻辑控制器）上即可模拟编辑器创建的梯形图的
动作。

模拟器具有以下功能：

• 利用梯形图监控、注册监控（时间表）和 Monitor All（全监控）实时确认程序的
运行状态。

• 利用连续扫描、连续步进、单步和一次性扫描等多种执行方法实现模拟。

• 由于逆向执行单步和逆向执行连续步进的撤消功能启动高效调试。

• 易于调整计时器、计数器和设备的预置值和当前值以及提供触点说明。

• 强行设置和重置触点。

3.1.2 模拟器的限制

• 启动专用继电器 2002 至 2012 和 2206，但未启动其它专用继电器。

• 未启动高速计数器。

• 直接时钟脉冲功能无效。

• 定位控制功能无效。

• 运行中断程序时有如下限制：

• 如果使用外部数据输入，不能启动数据存储器。
KV-10 至 80: DM700 至 DM799
KV-300: DM9000 至 DM9299, DM9407 和 DM9517

• 因为在视窗内实现模拟，因此扫描时间比实际要求的时间要长；小心注意时间设置。

• 不同的计算机机型，若周期时间指示也稍有不同；即使使用同样的梯形图程序也会
发生这种情况，因为个人计算机内部模拟类似 KV 主机的操作。

INT CTC* 未被执行。

INT 0000 至 INT 0003 在扫描的早期执行。

INT 0003 当 2206 开/关时，可以改变计时边；这时，CTH1 的当前值
并不赋值于 TM30。
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■ 支持专用继电器

下表列出模拟器能处理的专用继电器。

• 专用继电器

当选择传统的 KV 系列时：

当选择 Visual KV 系列时：

■ 重置操作

• 继电器被 MEMSW 重置，未被 MEMSW 规定锁存的继电器都被清除。

当清除所有规定锁存的继电器后，执行下列操作：
“Execute”(执行) ➔“Device All Clear”(清除所有设备) ➔“Latching Relay
All Clear”(清除所有自锁继电器)

当清除所有规定锁存的数据存储器后，执行下列操作：
“Execute”(执行) ➔“Device All Clear”(清除所有设备) ➔“DM All Clear”
(清除所有 DM)
➮ 清除所有设备 (p. 2-108)

• 清除所有临时数据存储器（TM00 至 TM31）和所有计时器

• 根据 MEMSW 规定清除所有计数器和高速计数器

• 保持微调器的状态

继电器编号 功能

2002 总处于“开启”状态

2003 总处于“关闭”状态

2004 0.01 秒时钟脉冲 (负载 = 50%)
2005 0.1 秒时钟脉冲 (负载 = 50%)
2006 1.0 秒时钟脉冲 (负载 = 50%)
2007 开始运行时只为一次性扫描“关闭”

2008 开始运行时只为一次性扫描“开启”

2009 当运算结果为负或出现上溢（<）时“开启”

2010 当运算结果为 0 (=)时“开启”

2011 当运算结果为正数（>）时“开启”

2012 当运算出现错误时“开启”

2206 选择 INT3 边 (开启：“下”边；关闭：“上”边)

2402/2403: INT0 极性中断

2402 OFF (关)ON 上升沿 OFF 下降沿 ON 两边
2403 OFF OFF ON ON

2404/2405: INT1 极性中断

2404 OFF ON 上升沿 OFF 下降沿 ON 两边
2405 OFF OFF ON ON

2410/2411: INT2 极性中断

2410 OFF ON 上升沿 OFF 下降沿 ON 两边
2411 OFF OFF ON ON

2412/2413: INT3 极性中断

2412 OFF ON 上升沿 OFF 下降沿 ON 两边
2413 OFF OFF ON ON
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3.2 启动和退出模拟器

本节讲述模拟器的启动方法、屏幕布局和模拟器功能等。

3.2.1 启动和退出的操作程序

启动程序  
File (文件) ➔ Simulator (模拟器) (Ctrl + F2)

打开编辑器创建的梯形图程序即可启动模拟器。
执行编辑器里的下列程序：

1. 在编辑器里设置梯形图程序的窗口模拟当前窗口。

2. 选择“File”(文件) 菜单里的“Simulator”(模拟器) 项。

• 选择模拟器模式，显示梯形图监控窗口，显示方式同编辑器模式。

• 若前面模拟的梯形图程序相同时，窗口显示的内容与其前面最后一次模拟的内容
相同。

注： 当出现编辑错误时，模拟无效。

纠正错误以正确编辑，然后重新进行模拟。
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退出程序  
File (文件) ➔ Editor (编辑器) (Ctrl + F1)

➔ Clear Device and Go to Editor (清除设备并回到编辑器) (Ctrl + F2)

通过以下两种方法可退出模拟器回到编辑器：

■ 未清除设备值即回到编辑器

选择“File”(文件) 菜单的“Editor”(编辑器)项。

注： 执行这步操作即可清除信息通路等上面的信息。因此当从编辑器模式变回到模
拟器模式且执行了模拟，不同类型的指令等可导致意想不到的运行结果。

■ 清除设备值后回到编辑器

选择“File”(文件) 菜单的“Clear Device and Go to Editor”(清除设备回到编辑器) 项。

注： 当处于模拟器模式时，您不能退出梯形图软件本身；要退出梯形图软件，须回
到编辑器并选择“File”(文件) 菜单的“Exit”(退出) 项。
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3.2.2 屏幕各部分的名称和功能

启动模拟器时，显示最后编辑的梯形图程序的梯形图监控窗口；如果此前已经显示全
监控窗口和注册监控窗口，启动模拟器时它们照样显示。此外，从菜单里选择它们，
可以观看记忆列标窗口和中止条件窗口。

屏幕示例

➮ 屏幕各部分的名称和功能载于以下页面：

•  梯形图监控窗口 2-90 页
•  Monitor All（全监控）窗口 2-113 页
•  注册监控窗口 2-122 页

主窗标题栏
显示当前被模拟的梯形
图文件的文件名。

菜单栏
显示执行指令的菜单。

工具栏
提供执行指令的按钮。
只有常用的指令才有按
钮。单击按钮即可执行
对应的指令。 主窗口

模拟器的整个
屏幕。

梯形图监控窗口
➮ 2-90 页

全监控窗口
➮ 2-113 页

注册监控窗口
➮ 2-122 页

对话栏
允许用户注册设备、为设备赋值和
预置值以及清除计时器和计数器。

状态指示栏
显示当前选择的功能及
监控的运行状态。
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3.3 梯形图监控

本节描述了当模拟器运行时显示的梯形图监控窗口、扫描/步进执行程序及当前/预置
值改变程序等。

3.3.1 梯形图监控概述

梯形图监控具以下功能：

• 执行梯形图扫描。

• 执行记忆步进。

• 打开/关闭位设备。

• 通过对话栏改变当前值。

• 显示所有注册说明。

• 设置中止条件。

• 设置扫描时间。

• 设置看门狗计时器。

3.3.2 执行扫描

以下是有关执行扫描的说明。

执行扫描功能概述

“To execute a scan”(执行扫描) 是指在初始化过程中启动程序，一直运行到结
束；这是一个扫描周期。
执行扫描分两种：“execution of continuous scan”(执行连续扫描) 和
“execution of one scan”(执行一次性扫描)；“Execution of continuous scan”
(执行连续扫描) 相当于在监控里“RUN”(运行)。
可设置一次性扫描的时间和看门狗计时器；并可改变当前值和预置值。

显示梯形图监控窗口  
File (文件) ➔ Ladder Monitor (梯形图监控)

如果显示的梯形图关闭，选择“File”(文件) 菜单的“Ladder Monitor”(梯形图监

控) 项重新显示或单击  按钮。

注 1： 一般不需要这步操作，因为从编辑器里启动模拟器后，便一直显示梯形监控窗口。

注 2： 一次只能打开一个梯形图监控窗口。
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梯形图监控窗口

• 借助于滚动条或光标控制键 (向左/向右/向上/向下) 观看隐藏（未显示）部分。

• 当执行扫描或步进后，设备值和开/关指示根据运行速度发生持续变化。

• 执行步进后，当前位置根据运行速度滚动（仅限于上窗口），光标在执行行移动；
显示记忆列表窗口表示执行的步进。

■ 移动光标

向左/向右/向上/向下键 : 沿相应方向移动光标。

Pageup (向上一页)/PageDown (向下一页) 键 : 移动光标至（屏幕）上一页

或下一页。

Ctrl + 向上/向下键 : 将光标移动一控制块。

Home (返回) 键 : 移动光标至第一行。

End (结束) 键 : 移动光标至最后一行。

■ 当将屏幕分成两个窗口时

当将指针光标置于滚动条底部和窗框之间时，指针光标变成“      ”（当指针光标是
“   ”形时，表示可改变窗口大小但不能拆分屏幕）。
按住“向左”按键并上移动，屏幕被分成上下两个窗口；每个窗口都可显示不同的内
容，但是当执行步进时，只有上窗口可以上卷。（下屏幕不能上卷。）

要在上下两个窗口间切换活动窗口，用鼠标单击目标窗口或同时按 Shift 和 F6 键
即可。

光标

触点

行号

步进号

滚动条
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■ 执行时的状态显示

当执行扫描或步进时，主窗口的状态显示区里显示当前的运行状态和扫描时间。

注： 当执行连续扫描操作时，显示“Execute Scan”（执行扫描）字样。当执行
连续步进操作时，显示“Execute Step”（执行步进）字样。

■ 改变显示尺寸和显示方法

有五种显示提醒图的不同尺寸；梯形图监控窗口可以一直在其它窗口下面显示。

• 当改变显示尺寸时
可选择以下五种显示尺寸：

200% : 以标准尺寸的两倍显示梯形图；当字很小难于阅读时，这种尺寸非常有用。

150% : 以标准尺寸的 1.5 倍显示梯形图。

120% : 以标准尺寸的1.2 倍显示梯形图。

100% (正常): 以标准尺寸显示梯形图。

80% : 以最小的尺寸显示梯形图；当检查整体运作时，这种尺寸很有用，因为屏幕
上可以显示最多数目的表格。

执行以下程序设置显示模式：

选择上部模式：“View”（查看） ➔ “Zoom In”（放大） (Ctrl + PageDown)
选择下部模式：“View”（查看） ➔ “Zoom Out”（宿小） (Ctrl + PageUp)

• 当梯形图监控窗口显示在底部时
梯形图监控窗口总可以在记忆列表窗口和其它窗口下面显示，因此，即使注册监控窗
口和 Monitor All（全监控）窗口被置于梯形图监控窗口顶部，也可以通过拖动和下
拉将每个设备注册到每个监控器上。

执行以下程序在屏幕底部显示梯形图监控窗口。
重复同样的操作使显示状态返回到前一设置。

“View”（查看） ➔ “Move Ladder to Bottom”（将梯形图移动至底部 ）

执行的步进号 状态（运行、停止或暂停）

执行的运行模式 扫描时间
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执行连续扫描  
Execute (执行) ➔ Execute Continuous Scan (执行连续扫描) (F5)

可持续运行一个程序。

选择“Execute”(执行) 菜单的“Execute Continuous Scan”(执行连续扫描) 项
或单击  按钮持续运行程序。

梯形图监控窗口上显示运行状态。

➮ 梯形图监控窗口 (2-90 页)

重复一次扫描。

运行程序

一次扫描

结束程序
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执行一次扫描  
Execute (执行) ➔ Execute One Scan (执行一次扫描) (F9)

一个程序可以只运行一次；连续执行扫描时当只执行一次扫描或只执行单步，运行中止。

选择“Execute”(执行) 菜单的“Execute One Scan”(执行一次扫描) 项或单击

 按钮只运行一次程序。

➮ 梯形图监控窗口 (2-90 页)

注 1: 如果执行步进时只执行一次扫描，则程序从当前步运行到“END（结束）” 或
“ENDH”。

注 2: 如果执行一次扫描，则无法逆向执行行步。

结束程序

一次扫描

运行程序
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选择设备

在梯形图监控窗口上可改变选定设备的当前值和预置值。执行下列程序选择设备。

■ 用鼠标选择设备

将鼠标指针置于要选择的设备上并单击。

光标变灰表示选中。

■ 用键盘选择设备

当光标为绿色时，通过向左、向右、向上和向下键将光标置于设备上并按 ENTER
（输入）键。

光标变灰表示选中。

■ 改变当前值等

一旦选定设备，即可利用对话栏改变当前值等。

➮ 有关使用对话栏改变当前值和预置值等的程序，参考“改变当前值/预置值/属性”一节 (2-96 页)。

注： 当光标显示灰色时，梯形图监控窗口上的所有键操作都失效；如欲通过 [向左]、
[向右]、[向上] 及 [向下] 键移动鼠标或通过空格键打开/关闭设备，可按 Esc
（退出）一次将光标变回绿色，再执行预期操作。

0000 0000
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开启/关闭位设备

执行下列程序开启/关闭位设备。

■ 用鼠标开启/关闭位设备

将鼠标置于要开启/关闭的设备上并双击。

• 如果触点颜色发生改变则表示开/关状态已切换。

• 当用鼠标操作时，双击后马上选择光标。

■ 用键盘开启/关闭位设备

当光标显示绿色时，通过向左、向右、向上及向下键将光标置于要开启/关闭的设备
上，然后按空格键。

• 如果触点颜色发生改变则表示开/关状态已切换。

“开启”状态

当使用鼠标时 当操作光标时

“关闭”状态

当使用鼠标时 当操作光标时

注 1: 当光标显示灰色时，梯形图监控窗口上的所有键操作都失效；如欲通过向左、向
右、向上及向下键移动鼠标或通过空格键开启/关闭设备，可按 Esc （退出）一
次将光标变回绿色，再执行预期操作。

注 2: 不能开启/关闭计时器/计数器的触点。

0000 0000

0000 0000
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改变当前值/预置值/属性

通过对话栏改变选定设备的当前值、预置值或属性（基数和注释）。

对话栏显示在屏幕底部，允许用户在 Moitor All（全监控）窗口和注册监控窗口上注
册设备。执行下列程序改变前值、预置值或属性（基数和注释）。

➮ 有关注册设备，请参考第 2-109 页的“Monitor All”（全监控）部分和第 2-119 页的“注册监控”部分。

1. 在梯形图监控窗口里选择要更改的设备。

➮ 选择设备 (2-94 页)

分别在当前值框和预置值框（仅限计时器/计数器）里显示选定设备的对应值。

2. 利用对话栏改变基数、注释、当前值和预置值。

使用 Tab 键（正向）和 Tab + Shift（反向）可向任一方向移动光标。

按 ENTER（输入）键执行下列操作：
当光标置于“Type” (类型) 或“No.” (编号) 上时：注册新数值。
当光标置于“Bit”(位)、“Radix”(基数) 或“Comment”(注释) 上时：输入现有设
备的数值。

注 1: 只有当 Monitor All（全监控）和注册监控都活跃时，对话栏里才显示属性（注
释）框。

当梯形图监控活跃时，步显示属性（注释）框。
选择“View”(查看) 菜单的“Show Mode”(显示模式) 项改变显示的注释类
型。
➮ 显示模式 (2-19 页)

注 2: 当输入不能设置的数据时，会显示“Current value is unacceptable.”(当前
值不被接受) 的信息。

注释

基数

当前值输入按钮

预置值输入按钮

预置值输入框
当前值输入框
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3. 单击 [Write Current Value] (当前值输入) 按钮或 [Write Preset Value] (预置值
输入) 按钮。

• 当前值或预置值改变。

设置项目和有效的内容/数值

注 1： 位长设置优先于基数设置（比如，如果位长从原先的“16”变为“1”而基数
以前的设置是“十进制”，则基数会自动变为“二进制”）。

注 2： 32 位和 16 位的数值只能在相应的位置注册。

注 3： 当位长为“32”时，低 16 位只能分到较小的设备编号，而高 16 位则分到较
大的设备编号。

■ 取消设置

单击 [Cancel] (取消) 按钮。

■ 计时器/计数器设置恢复到默认值

单击 [Reset] (复位) 按钮（只有设置计时器/计数器时这个按钮才显示）。

■ 快捷键

快捷键 Ctrl + E 负责改变记数制的操作；每次按 Ctrl + E 键，十进制（#）和十六进
制（$）就会发生切换。

有效值

项目 内容 梯形图 全监控/注册监控
监控

类型 选择设备类型 — 继电器、计时器、计数器、计数器比较
器、高速计数器、数据存储器、临时数
数据存储器和调整器。

编号 输入设备编号 — 不同设备的有效编号。

编号 位 选择数据位长度 — 1*1, 16 和 32*2

*1: “1”仅在继电器里有效。
*2: “32”仅在继电器、数据存储器、

临时数据存储器和调整器编号里
有效。

基数 选择设备当前值 十进制 二进制 *1, 十进制, 十进制 *2 和十六进制
/预置值的显示方法 和十六

进制

*1: 当位长度设置为“32”时，“2”无效。
*2: 带标记的二进制（2 的补码）。

* 当位长设置为“1”时，基数固定为“2”。

* 基数变化反映在整个窗口上。

* 当基数发生变化时，当前值就会被清除。

说明 选择显示 说明 1、说明 2、说明 3 或无
说明的类型

当前值 输入当前值 不超过 17 位的数值有效。

预置值 输入预置值 只能输入计时器/计数器的预置值。
输入的数值不得超过 7 位。
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设置中止条件  
Settings (设置) ➔ Set Break Condition (设置中止条件) ➔ Break Condition (中止条件)

➔ OR condition (或条件)  ★ 单击右键

中止条件就是重复执行一次扫描或步进时中止程序的条件。每种设备都可规定中止条
件；使用中止条件确认局部操作状态或检测缺陷位置。
当结合步进功能使用中止条件时，确认操作的时间更短。
执行以下程序设置中止条件。

1. 选择菜单中的“Settings”(设置)、“Set Break Condition”(设置中止条件) 及
“Break Condition”(中止条件) 项或单击  按钮。

显示“Register Break Condition”(注册中止条件) 对话框和中止条件窗口。

可以设置 AND 条件和 OR 条件；默认为 OR 条件；设置 AND 条件时，首先选
择“OR Condition”(OR 条件) 以删除选中标记。
单击右键中止条件窗口并显示快捷菜单，通过快捷菜单在 AND 条件和 OR 条件
间切换。

2. 当要设置条件的设备是位设备时，选择“Bit”；当要设置条件的设备是字设备时选
择“Word”。

3. 确定设备名称和条件。
使用比较算术确定字设备的条件。

位设备

字设备

Device name (设备名称) 确定一个设备名称。

Condition (条件) ON 设定 “contact ON” (触点开启) 为条件。

OFF 设定 “contact OFF” (触点关闭) 为条件。

Device name (设备名称) 确定两个设备名称。

Comparison arithmetic < 设定“Right is larger than left。” (右比左大) 为条件。

(比较算术) = 设定“Left is equivalent to right。”(右左相等) 为条件。

> 设定“Left is larger than right。”(左比右大) 为条件。

< 设定“Right is larger than or equivalent to left。”(右大
于或等于左) 为条件。

> 设定“Left is larger than or equivalent to right。”(左大
于或等于右) 为条件。

=

=
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4. 单击 [Register] (注册) 按钮。

注册设定的条件，在中止条件窗口中显示内容。

5.  如果要注册两或多个条件，重复步骤 2 至 4。

6. 如果要注册所有条件，单击 [Exit] (退出) 按钮。
“Register Break Condition”(注册中止条件) 对话框关闭。

当中止条件使程序中止时，如果为 OR 条件，则满足条件行为红色显示；否则如果为
AND 条件，则所有行都是红色显示。

更改和删除注册内容

中止条件窗口显示所有注册的条件。
可在该窗口更改或删除注册的条件。

■ 更改注册内容

将光标置于要更改的条件上并双击；接着显示“Register/Change Break Condition”
（注册/更改中止条件对话框）（见上图）。
设置新的中止条件并单击 [Change] (更改) 按钮，则光标所在行的中止条件发生更
改。
如果是第一次注册条件，单击 [Register] (注册) 按钮。

■ 删除注册内容

可用以下三个方法删除注册内容。

• 将光标置于要更改的条件上，接着选择“Edit”(编辑) 菜单的“Delete Break
Condition”(删除中止条件) 项。

• 将光标置于要更改的条件上并单击右键，接着从显示的菜单中选择“Delete”(删
除) 项。

• 将光标置于要更改的条件上并按 Delete (删除) 键。
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设置扫描时间

Settings (设置) ➔ Scan Time (扫描时间)

设置执行一次性扫描或单步的时间。执行一次性扫描有两个时间设置：测量值表示实
际时间和有效固定值（固定扫描）。（执行单步只能设置有效固定值。）

1. 选择“Settings”(设置) 菜单的“Scan Time”(扫描时间) 项。
显示“Set Scan Time”(设置扫描时间) 对话框。

2. 设置固定扫描时，单击“Set Fixed Scan”(设置固定扫描) 添加复选标记。

3. 将扫描时间设置在 0 至 5,000 msec (毫秒) 之间；如果运行单步，设定默认值为
“10 msec”(毫秒)；如果运行扫描，设定实际需要的时间为默认值。

4. 单击 [OK] 按钮保存显示的数值；单击 [Cancel] (取消) 按钮取消设置。

■ 固定扫描

当模拟器处于运行状态时，扫描时间的长度通常取决于个人电脑的处理速度。当选择
固定扫描模式时，运行模拟的扫描时间相当于在 PLC 侧作实际处理的时间。使用该
功能模拟重视扫描时间的程序。

设置看门狗计时器

Settings (设置) ➔ Set Watch Dog Timer (设置看门狗计时器)

看门狗计时器可探测程序运行周期中的异常延迟；这些延迟可能由于程序设计错误（即
无限循环）或可能导致程序完成时间延迟的任何其它条件；默认值为“3,000 msec(=
3 sec)”(3,000 毫秒 (= 3 秒))。

如果扫描时间超过看门狗计时器的预置值加等待时间，看门狗计时器就会出错。
执行以下程序设置看门狗计时器。

1. 选择“Settings”(设置)菜单的“Set Watch Dog Timer”(设置看门狗计时器)项。
显示“Set Watch Dog Timer”(设置看门狗计时器) 对话框。

2. 在看门狗计时器内输入介于“500 msec (0.5 sec) 至 5,000 msec (5 sec)”范
围内的值。
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3.3.3 执行步进

有关执行步进的描述载于下文。

步进执行功能概述

“To execute a step”（执行能步进）指每次模拟一个程序指令。当执行步进（一个
指令）时，会显示记忆列表并可检验当前运行。

当中止条件规定或断点设置结合时，从规定输入到规定输出的程序的运行状态在每步
都会受到检查，因此可以快速检查出不一致的位置。

共有五种有效的步进执行方法：“executing a step continuously”(连续执行步进)、
“executing a step once”(执行单进)、“executing steps at a high speed”(高速
执行步进)、“executing a step continuously in the reverse direction”(逆向连续执
行步进) 和“executing a step once in the reverse direction”(逆向执行单步)。

记忆列表窗口

当执行步进时，显示的设备值和 ON/OFF（开/关）状态根据运行速度在梯形图监控
窗口里持续发生改变。当前位置页会根据运行速度上卷。
此外，记忆列表窗口开启，并突出当前运行的记忆列表。

当运行行光标于断点光标重
合时，其显示为红色。

行号 记忆 操作数

当前光标位置
显示当前光标
所处的位置。

运行行光标
突出当前运行
行。

断点光标
双击显示断点。

蓝色

黄色
(当改变设置时)

滚动条
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执行单步  
Execute (执行) ➔ Execute One Step (执行单步) (F8)

程序运行中一次只能执行一步；如果扫描过程中只执行单步，则执行停止。

选择“Execute”(执行) 菜单的“Execute One Step”(执行一步) 项或单击  按
钮执行一步。

显示记忆列表窗口，加亮当前执行行。

➮ 记忆列表窗口 (2-101 页)

连续执行单步方式  
Execute (执行) ➔ Execute Continuous Step (连续执行单步方式) (Shift + F8)

可连续执行程序中的单步。

选择“Execute”(执行) 菜单的“Execute Continuous Step”(连续执行单步方式)
项或单击  按钮连续执行单步方式。

显示记忆列表窗口，当前执行行加亮。

➮ 记忆列表窗口 (2-101 页)

当前执行部分根据运行速度在梯形图监控窗口上卷。

➮ 梯形图监控窗口 (2-90 页)

选择“执行”菜单的“执
行连续单步方式”项或单
击按钮连续执行单步方式。

▲

▲

每单击  一次执
行一步（指令）。

▲

▲
▲
▲
▲
▲
▲

当执行到达
“ENDH”时，
光标返回顶部。

1 步 = 1 个指令

当运行到达“ENDH”
时，光标回到顶部。连
续执行单步方式（指
令）。
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注 1： 只有上部窗口随运行速度上卷；用下部屏幕确认特定部分的运行。

注 2： 如果速度太快，则等待时间会相应增加。

高速执行单步方式  
Execute (执行) ➔ Execute High-speed Step (执行高速单步方式) (Shift + F9)

您可规定程序在某一步停止运行；这样程序将快速运行，不会在每一步都显示进度；
当程序到达规定步时将停止运行。
如果在规定的范围内发出转移指令，则执行将在规定行后停止。
当要模拟的部分接近长程序末端时，这类执行非常有用。

执行下列程序可高速执行单步方式：

1. 选择“Execute”(执行) 菜单的“Execute High-speed Step”(高速执行单步方

式) 项或单击  按钮。

显示“高速执行单步方式”对话框。

2. 确定要运行的程序的步号，然后单击 [OK] 按钮；单击 [Cancel] (取消) 按钮取消
运行。

程序执行到规定步。

▲
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逆向执行一次一步方式  
Execute (执行) ➔ Execute One Step in Reverse (逆向执行单步方式) (F7)

执行一次一步或连续执行单步方式或高速执行单步方式后，它们还会分别逆向重新运
行一次。

选择“Execute”(执行) 菜单的“Execute One Step in Reverse”(逆向执行单步)
项或单击  按钮可以逆向执行一次单步方式。

逆向连续执行单步方式  
Execute (执行) ➔ Execute Continuous Step in Reverse (逆向执行连续单步方式) (Shift + F7)

执行一次一步方式或连续执行单步方式或高速执行单步方式后，它们还会分别逆向重
新连续执行。

选择“Execute”(执行) 菜单的“Execute Continuous Step in Reverse”(逆向执
行连续单步方式) 项或单击  按钮可以逆向执行连续单步方式。

■ 逆向执行单步方式

当逆向执行单步方式时，由于程序执行导致的所有选项都会回到初始状态，包括设备
值和总线状况。

利用这个功能可以进行高效调试，因为梯形图程序的操作（触点开/关及输入的字设备
值引起的运行变化），可以根据每次指令加于恢复，然后确认。

当执行到达顶部时，
光标回到“ENDH”。

▲

▲

每单击  按钮一次都会

执行一步（指令）。

▲

当执行到达顶部时，光
标回到“ENDH”。

▲
▲
▲
▲
▲
▲

每单击一次按钮，逆向执行
单步方式（指令）。
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规定断点

断点就是程序中止的位置。如果先规定断点，则连续执行单步时程序就会在规定的位
置自动中止。

将光标置于待规定的行然后双击或按空格键即可规定断点。

断点光标显示黄色。当规定当前运行行的光标位置时，光标变为红色；当程序在断点
处停止运行时，光标颜色变为红色（当将系统设置为标准窗口颜色设置时，使用这些
光标颜色）。

可以规定两个或多个断点。

将光标置于规定行然后双击或按空格键即可取消断点设置。

此点光标被删除。

3.3.4 转移和搜索

通过规定程序中的行号或步号，模拟控制可以转移到不同的位置；当将指令字和操作
数设置为关键字时，可以查找指令和设备；可以从当前位置开始执行对照搜索。

转移至规定行/步
Edit (编辑) ➔ Jump in Ladder Monitor (在梯形图监控内转移)

执行下列程序，通过规定行号或步进号转移至不同位置。

1. 选择“Edit”(编辑) 菜单的“Jump in Ladder Monitor”(在梯形图监控内转移) 项。
显示“Jump to Specified Line”(转移至规定行) 对话框。

2. 确定一个行号或步进号作为转移目的地。

当规定当前运行行的光标位置时
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3. 转移到规定目的地的行号时单击 [Line] (行) 按钮；转移到规定目的地的步进号时
单击 [Step] (步进) 按钮；取消转移时单击 [Cancel] (取消) 按钮。

显示规定行或规定步进，光标移至规定行或规定步进。

注 1： 如果规定的数字大于最后的行号/步进号，则显示最后的行号/步进号。

注 2： 只有当梯形图监控活跃时，才能转移置规定行/步进。

通过规定指令字/操作数进行搜索

Edit (编辑) ➔ Search in Ladder Monitor (在梯形图监控里搜索)

执行下列程序，通过规定指令字和操作数查找程序指令和设备。

注： 只有当模拟停止且梯形图监控激活时才能进行搜索。

1. 选择“Edit”(编辑) 菜单的“Search in Ladder Monitor”(在梯形图监控里搜索) 项。
显示“Find Instruction/Device”(查找指令/设备) 对话框。

2. 将要查找的指令字输入“Instruction Word”(指令字) 文本框；将要查找的操作
数输入“Operand”(操作数) 文本框；只有在规定指令字或操作数的情况下，才
能执行搜索。

3. 选择搜索方向。
向前：从光标所在位置向前搜索；
向后：从光标所在位置向后搜索。

4. 单击 [Next] (下一个) 按钮。

开始搜索，显示第一个含有指令字或操作数的单元。

如果没发现规定的指令或操作数，则会显示“Can’t find specified symbol”(无
法找到规定符号) 的信息。

5. 单击 [Next] (下一个) 按钮继续搜索；单击 [Cancel] (取消) 按钮，停止搜索。
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对照搜索

Edit (编辑) ➔ Find Device at Cursor Position on Ladder Monitor (在梯形图监控的光标位置查找设备)
➔ Search Backward (向后搜索) (F2)   ★ 单击右键
➔ Search Forward (向前搜索) (F3)   ★ 单击右键
➔ Search for OUT Backward (向后搜索 OUT) (Shift + F2)   ★ 单击右键
➔ Search for OUT Forward (向前搜索 OUT) (Shift + F3)   ★ 单击右键

执行对照搜索意味着搜索与光标当前位置处的设备相当的设备或将设备设置到范围以
外的指令。
有以下四种搜索方法：

向后搜索
Search (搜索) ➔ Backward (向后) (F2) ★ 单击右键
在光标位置以前的区域内搜索与当前位置处的设备相当的设备。

向前搜索
Search (搜索) ➔ Forward (向前) (F3) ★ 单击右键

在光标位置后面的区域内搜索与当前位置处的设备相当的设备。

向后搜索 OUT
Search (搜索)  ➔ OUT Backward (向后的 OUT) (Shift + F2) ★ 单击右键

搜索一个指令，该指令将当前光标处的设备设置到当前位置前面以外的区域。

向前搜索 OUT
Search (搜索)  ➔ OUT forward (向前的  OUT) (Shift + F3) ★ 单击右键
搜索一个指令，该指令将当前光标处的设备设置到当前位置后面以外的区域。

注 1： 当搜索到最后一行或第一行时，会显示“Searched to end (beginning) of
program”(搜索至程序结束 (开始)) 的信息。

注 2： 只有当梯形图监控激活时，对照搜索才有效。
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3.3.5 停止/复位和清除所有设备

执行下列程序以停止/复原扫描或单步运行或清除所有设备。

停止/暂停运行 
Execute (执行) ➔ Stop (停止) (Shift + F5)

➔ Pause (暂停) (F4)

可以停止或暂停运行。

选择“Execute”(执行) 菜单的“Stop”(停止) 或“Pause”(暂停) 项，或单击 
或  按钮。

• 规定“Stop”(停止) 时，会停止所有类型的运行并清除 Y 输出。

• 当规定“Pause”(暂停) 时，所有类型的运行都暂时停止。

注： 当停止运行时，无法逆向执行单步方式；要在停止运行后执行逆向单步方式必
须重新执行单步方式；当暂停运行时，可以逆向执行单步方式。

复位 
Execute (执行) ➔ Reset (复位) (F10)

当前值可以恢复到默认值。

选择“Execute”(执行) 菜单的“Reset”(复位) 项或单击  按钮。

• 如果运行时执行这一程序，则程序终止。

• 系统的反应就好象 PLC 电源被关闭然后又被重新开启一样。

清除所有设备

Execute (执行) ➔ Device All Clear (清除所有设备) ➔ DM All Clear (清除所有 DM)
➔ Latching Relay All Clear (清除所有自锁继电器)
➔ Counter All Clear (清除所有计数器)

通过“Device All Clear”(清除所有设备) 功能可以将一些设备的当前值初始化。
有以下三种初始化方法：

清除所有数据存储器
Execute (执行) ➔ Device All Clear (清除所有设备) ➔ DM All Clear (清除所有
DM)

清除所有锁存继电器
Execute (执行) ➔ Device All Clear (清除所有设备) ➔ Latching Relay All
Clear (清除所有锁存继电器)

清除所有计数器
Execute (执行) ➔ Device All Clear (清除所有设备) ➔ Counter All Clear (清除
所有计数器)

• 如果运行时执行“Device All Clear”(清除所有设备) 的操作，则运行终止。
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3.4 Monitor All（全监控）

Monitor All（全监控）显示所有设备的当前值、触点的开/关状态和每种设备类型的
注册说明。本节描述 Monitor All（全监控）的有效操作。

3.4.1 Monitor All（全监控）概述

Monitor All（全监控）具以下功能：

• Monitor All（全监控）显示所有设备的当前值和预置值、触点的开/关状态及和每
种设备类型的绕组。

• 显示所有注册说明。

• 开启/关闭位设备。

• 使用对话栏更改当前值等。

• 设置中止条件。

• 设置扫描时间。

• 设置看门狗计时器。

3.4.2 显示、保存和读取 Monitor All（全监控）窗口

要显示 Monitor All（全监控）窗口，必须在梯形图监控窗口选择一种设备；可以保
存每种设备类型注册到 Monitor All（全监控）窗口上的内容供以后读取。

显示 Monitor All（全监控）窗口  
File (文件) ➔ Monitor All (全监控)

显示 Monitor All（全监控）窗口的方法取决于你是打开一个新窗口还是修改当前窗
口的内容。

■ 当显示新窗口时

执行下列程序以第一次显示 Monitor All（全监控）窗口或在另一个窗口显示：

1. 在梯形图监控窗口，选择要显示的设备。

单击设备时，设备的颜色改变表示选中。
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2. 选择“File”（文件）菜单的“Monitor All”（全监控）项或单击  按钮。

• 打开 Monitor All（全监控）窗口。
• 窗口显示列表，选中的设备在最上部。
• 选定设备所在的行变亮表示其被选中。

注： 每次执行该程序就会打开一个新窗口。

■ 当修改当前窗口显示的内容时

如果 Monitor All（全监控）窗口已经打开且你想修改它上面的内容，则须执行下列
程序。更多细节参阅相应章节。

• 从梯形图监控窗口拖动和下拉以注册设备。

➮ 从梯形图监控窗口拖动注册设备 (2-114 页)

• 在对话栏里标明设备类型和编号以注册设备。

➮ 通过对话栏标明条件注册设备 (2-115 页)
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保存 Monitor All (全监控) 窗口  
File (文件) ➔ Save Window As (将窗口保存为)

执行下列程序以保存 Monitor All（全监控）窗口：

1. 选择要保存为当前窗口的 Monitor All（全监控）窗口；

2. 选择“File”(文件) 菜单的“Save Window As”(将窗口保存为) 项或单击 
按钮；
 • 显示“将窗口保存为”对话框。

3. 确定要保存文件的文件夹（目录）和文件名。

注 1： 当进行持续扫描时无法保存 Monitor All（全监控）窗口。

注 2： 不能保存当前值/预置值。

读取全 Monitor All (全监控) 文件

File (文件) ➔ Open Window (打开窗口)

执行下列程序以读取 Monitor All（全监控）文件：

1. 选择“File”(文件) 菜单的“Open Window”(打开窗口)。
• 显示“打开窗口”对话框

2. 单击“文件类型”按钮  并选择“Monitor All（*.kal）”（全监控 *.kal）。

3. 选择要读取的文件所在的文件夹和文件名。

Folder (directory) 选择要保存文件的文件夹（目录）。
(文件夹 (目录)) 默认当前文件夹（目录）。

File Name 输入 8 位（包括 8 位）以内的字母或数字作文件名。
(文件名) 扩展名设置为“kal”，不得改变。�
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4 单击 [OK] 按钮。

• 读取确定的文件，Monitor All（全监控）窗口打开。

Folder (directory) 选择要读取的文件所在的文件夹 (目录)。
(文件夹 (目录)) 默认当前文件夹 (目录)。
File Name (文件名) 确定要读取的文件名。

File Type 选择要读取的文件的类型
(文件类型) “Registration Monitor (*.kre)” (注册监控（*.kre）) 和 “Monitor All

(*.kal)” (全监控 (*.kal)) 有效。
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3.4.3 Monitor All（全监控）窗口

• 用滚动条或 [PageUp] (向上一页) 和 [PageDown] (向下一页) 键观看隐藏 （未
显示）部分；

• 使用 [向左] [向右] [向上] 和 [向下] 键移动滚动条

• 当模拟器运行时，当前值相应改变。

当前值显示格式

B: 位
O: 字节
D: 无标记二进制
d:  标记二进制
H:  十六进制
A:  ASCII

3.4.4 注册设备

要用 Monitor All（全监控）窗口运行模拟，必须注册一种设备。有三种注册设备的
方法。

在梯形图监控窗口选择和注册设备

File (文件) ➔  Monitor All (全监控)

1. 在梯形图监控里选择要显示的设备。

• 单击设备时，设备颜色改变表示选中。

显示格式 位 基数 标记

B1 1 2 无

B16 16 2 无

O16 16 8 无

O32 32 8 无

D16 16 10 无

D32 32 10 无

d16 16 10 有

d32 32 10 有

H16 16 16 无

H32 32 16 无

A16 16 ASC –

A32 32 ASC –

滚动条

触点状态

设备号 当前值 预置值 注释

光标
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2. 选择“File”(文件) 菜单的“Monitor All”(全监控) 项或单击  按钮。

• 打开 Monitor All (全监控) 窗口。
• 窗口显示列表，选中的设备在最上部。
• 选定设备所在的行变亮表示其被选中。

从梯形图监控窗口拖动注册设备

拖动和下拉 Monitor All (全监控) 窗口里的设备，将其注册到 Monitor All (全监控)
窗口或注册监控窗口。
在这种情况下，建议选择“View”(观看) 菜单的“Move Ladder to Bottom”(移动

梯形图至底部) 项或单击  按钮以在底部显示梯形图窗口。这样的话，即使注册目

的窗口被置于梯形图监控窗口上面，也可执行拖动和注册操作。

1. 选择设备时，按住鼠标左键。

光标形状改变。

2. 按住鼠标左键时，移动光标至 Monitor All (全监控) 窗口（拖动）。



第三章  模拟器

2-115

13

C KV-H6WE2-UM

3. 释放左键（下拉）

• Monitor All  (全监控) 窗口显示一列与选定设备类型相当的设备。
选定设备所在行变亮表现其被选中。

通过对话栏标明条件注册设备

对话栏是梯形图监控窗口、Monitor All (全监控) 窗口和注册监控窗口共有的工具；
通过它可以注册新设备及改变选定设备的设置。

用对话栏可以设置下列项目：

• 设备类型

• 设备号

• 位计数

• 基数

• 说明的显示方法 *1.

• 当前值

• 预置值（仅限计时器/计数器）

*1. 当梯形图监控窗口活跃时，它不会显示。

➮ 改变当前值/预置值/属性：注意 (2-96 页)

1. 当注册设备时，首先执行下列程序：

■ 当注册目的窗口没打开时

通过对话栏确定要注册的设备，然后选择要注册设备的监控器。

■ 当注册目的窗口打开时

将要注册设备的监控窗口设置为当前窗口，然后用对话栏设置要注册的设备。
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2. 用对话栏设置要注册的设备。

➮ 有关改变设置的项目、内容和主要事项，参考第 2-96 页的“改变当前值/预置值/属性”部分。

3. 单击 [Register] (注册) 按钮。

• 满足内容设置的设备被注册到各个监控器。

■ 取消输入设置

单击 [Cancel] (取消) 按钮。

3.4.5 选择和更改设备

可以在 Monitor All (全监控) 窗口选择设备，然后修改位设备的开/关状态和当前值。

选择设备

执行下列程序以选择设备：

■ 使用鼠标选择设备

将光标置于要选择的设备上并单击。

• 光标变为灰色表示设备被选中。

■ 使用键盘选择设备

当光标颜色与标题栏的颜色相同时，通过向上和向下键将光标置于要选择的设备上并
按 ENTER (输入) 键。

• 光标变为灰色表示设备被选中。

当前值输入框

选中设备的状态

基数

注释
预置值输入按钮

当前值输入按钮

预置值输入框
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■ 修改当前值等

一旦选中设备即可通过对话栏修改当前值等内容。

➮ 通过对话栏修改当前值和预置值等内容的程序，参考第 2-118 页的“修改当前值/预置值/属性”部分。

开启/关闭位设备

执行下列程序以开启/关闭位设备。

■ 用鼠标开启/关闭位设备

将光标置于要开启/关闭的设备上并双击。

• 开启/关闭显示切换。

■ 用鼠标开启/关闭位设备

当光标颜色与标题栏的颜色相同时，通过向上和向下键将光标置于要开启/关闭的设备
上并按空格键。

• 开启/关闭显示切换。

■ 使用位光标开启/关闭位设备

如果一个位设备由 16 位构成且被设置为二进制，则显示位光标。
将光标置于要开启/关闭的设备上并双击，或当光标颜色与标题栏的颜色相同时，通过
向左和向右键将光标置于要开启/关闭的设备上并按空格键；显示在 “0”和“1”间切
换，并可在每个位里单独开启/关闭。

“关闭”状态

7015 – – B01
7100 B01
7101 – – B01

7015 – – B01
7100 – – B01
7101 – – B01

7000 0000000000000000 B16
7100 0000001000000000 B16
7200 0000000000000000 B16

“开启”状态
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修改当前值/预置值/属性

对话栏是梯形图监控窗口、Monitor All（全监控）窗口和注册监控窗口共有的工具；
通过它可以注册新设备及改变选定设备的设置。

用对话栏可以设置下列项目：

• 设备类型

• 设备号

• 位计数

• 基数

• 说明的显示方法

• 当前值

• 预置值（仅限计时器/计数器）

■ 设置程序

1 将要更改设备的监控器窗口选择为当前窗口，将光标置于要更改的设备上并单击。

2 通过对话栏修改当前值/预置值/属性。

➮ 有关改变设置的项目、内容和主要事项，参考第 2-96 页的“改变当前值/预置值/属性”部分。

3 单击 [Write Current Value] (输入当前值) 或 [Write Preset Value] (输入预置值)
按钮。

• 通过对话栏设置的内容被输入到选中的设备里。

■ 取消输入设置

单击 [Cancel] (取消) 按钮。

■ 将计时器/计数器的设置恢复到默认值。

单击 [Reset] (复位) 按钮（只有设置计时器/计数器时才显示此按钮）。

注： 当运行停止时，即使位设备被开启/关闭或当前值/预置值被修改，当重新开始
运行时，这些设置仍会复原。

暂停运行，修改设备状态。

复位设备

Edit (编辑) ➔ Reset Device in Monitor All/Registration Monitor (复位全监控 / 注册监控里的设备)

执行下列程序以复位选定设备到默认值。

选择“Edit”(编辑) 菜单的“Reset Device in Monitor All/Registration Monitor”
(复位全监控 /注册监控里的设备)。

• 选定设备的当前值被恢复到默认值。

说明

基数 当前值输入按钮

预置值输入按钮

当前值输入框 预置值输入框
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3.5 注册监控

注册监控显示注册设备的时序图；当执行步进时，实时显示当前状态以确认程序运
行。本节讲述如何查看和操作注册监控。

3.5.1 注册监控概述

注册监控有如下功能：

• 注册多达 40 种设备。

• 更改注册设备的位置。

• 显示注册设备的时序图（位设备和字设备）。

• 显示位设备的开/关状态和说明。

• 开启/关闭位设备。

• 使用对话栏修改当前值等内容。

• 设置中止条件。

• 设置扫描时间。

• 设置看门狗计时器。

3.5.2 显示、保存和读取注册监控

注册监控注册设备并显示时序图。
可将注册设备的注册监控保存在文件里。

显示注册监控  
File (文件) ➔ Registration Monitor (注册监控)

第一次显示注册监控时，显示注册监控窗口，然后通过从梯形图监控拖动和下拉或利
用对话栏注册设备。

➮ 有关在对话栏确定类型和编号注册设备的程序，参考第 2-118 页的“修改当前值/预置值/属性”部分。
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如果要用从梯形图监控窗口拖动和下拉的方法注册设备，须执行以下程序：

1. 选择“File”(文件) 菜单的“Registration Monitor”(注册监控) 项或单击  按钮。

• 打开注册监控窗口。

注： 每次执行这步操作都打开一个新窗口。

2. 在梯形图监控窗口，选择要注册的设备并按住鼠标左键。

• 光标形状改变。

• 当在梯形图监控窗口上按住 Ctrl（控制）键时单击鼠标左键，将选中梯形图监控
窗口里显示的所有设备。

3. 按住鼠标左键时，键光标移动至注册监控窗口（拖动）并释放左键。

• 注册监控窗口显示选中的设备。

• 默认显示时序图；如要显示说明，通过用对话栏里的“说明”项选择说明类型。

保存注册监控  
File (文件) ➔ Save Window As (将窗口保存为)

执行以下程序保存注册监控窗口。

1. 选择要保存为当前窗口的注册监控。

[Ctrl] +
拖动

当注册一件设备时

拖动

当注册屏幕上显示的所有设备时

▼
▼
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2. 选择“File”(文件) 菜单的“Save Window As”(将窗口保存为) 项或单击 
按钮。

• 显示“将窗口保存为”对话框。

3 确定要保存文件的文件夹（目录）和文件名。

读取 Monitor All (全监控) 文件  
File (文件) ➔ Open Window (打开窗口)

执行下列程序以读取注册监控文件：

1. 选择“File”(文件) 菜单的“Open Window”(打开窗口)。

• 显示“Open Window”(打开窗口) 对话框。

2. 选择要读取的文件所在的文件夹和文件名。

3. 单击 [OK] 按钮。

• 读取确定的文件，注册监控窗口打开。

Folder (directory) 选择要保存文件的文件夹（目录）。
(文件夹 (目录)) 默认当前文件夹（目录）。

File Name 输入 8 位（包括 8 位）以内的字母或数字作文件名。
(文件名) 扩展名设置为“kre”，不得改变。

Folder (directory) 选择要读取的文件所在的文件夹（目录）。
(文件夹 (目录)) 默认当前文件夹（目录）。

File Name (文件名) 确定要读取的文件名；扩展名设置为“kre”。

File Type 选择要读取的文件的类型。
(文件类型) “Registration Monitor (*.kre)”(注册监控（*.kre）) 和“Monitor All

（*.kal）”(全监控 (*.kal))有效。
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3.5.3 注册监控窗口

在注册监控窗口，时序图和说明随同设备数据、当前值和预置值一起显示。

• 如果要注册许多设备，建议你打开两个或多个窗口以方便浏览。

• 可以使用 向左/向右/向上/向下 键移动光标。

• 当模拟器运行时，当前值根据运行速度持续改变。

■ 显示说明或时序图

无论是否要显示时序图或注释，都可以通过对话栏上的“Comment”（注释） 项设置
每件设备的时序图或注释。

No: 显示时序图。
注释 1、注释 2 或注释 3：显示注释 （如果是计时器/计数器，其随同预置值一起显示）。

3.5.4 注册设备

要用 Monitor All（全监控）窗口运行模拟，必须注册一种设备。有两种注册设备的
方法：

从梯形图监控中拖动注册设备

➮ 注册程序同前面 Monitor All（全监控）程序的步骤  2；参考 P2-114。

通过对话栏标明条件注册设备

➮ 注册程序同前面 Monitor All（全监控）描述的程序；参考 P2-115。

设备号 位设备状态 纵向光标

光标 当前值 预置值 注释 时序图
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3.5.5 选择和更改设备

可以在 Monitor All（全监控）窗口选择设备，然后修改位设备的开/关状态和当前值。

注： 使用注册监控前必须先注册设备。

设备注册程序载于“3.5.2 显示、保存和读取注册监控”(➮ 2-119 页)

选择设备

执行下列程序以选择设备：

■ 使用鼠标选择设备

将光标置于要选择的设备上并单击。

• 光标变为灰色表示设备被选中。

■ 使用键盘选择设备

当光标颜色与标题栏的颜色相同时，通过向上和向下键将光标置于要选择的设备上并
按 ENTER（输入）键。

• 光标变为灰色表示设备被选中。

选中设备的状态
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开启/关闭位设备

执行下列程序以开启/关闭位设备。

■ 用鼠标开启/关闭位设备

将光标置于要开启/关闭的设备上并双击。

• 开启/关闭的显示之间互相切换。

■ 用键盘开启/关闭位设备

当光标颜色与标题栏的颜色相同时，通过向上和向下键将光标置于要开启/关闭的设备
上并按空格键。

• 开启/关闭的显示之间互相切换。

修改当前值/预置值/属性

通过对话栏可以修改设备的类型、编号 、属性、当前值和预置值。

➮ 修改程序同 Monitor All（全监控）的修改程序；参考第 2-118 页的“修改当前值/预置值/属性”。

注： 当运行停止时，即使位设备被开启/关闭或当前值/预置值被修改，当重新开始
运行时，这些设置仍会复原。

暂停运行，修改设备状态。

“关闭”状态

7015 – – B01
7100 B01
7101 – – B01

7015 – – B01
7100 – – B01
7101 – – B01

“开启”状态
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复制设备属性

Edit (编辑) ➔ Copy Device Attribute in Registration Monitor (注册监控窗口中复制设备属性)  ★ 单击右键
(Copy Attribute)（复制属性）

只能复制其它设备的设备属性（位计数、基数和说明类型）；此功能只可用于复制其
它设备的属性（当保留设备类型和设备号时）。

1. 用鼠标右键单击复制源设备。

2. 将光标置于复制目的设备上并单击右键；当显示菜单时，选择“Copy Attribute”
(复制属性)。

• 属性被复制。

注 1： 指定复制目的设备时不要单击鼠标左键；单击鼠标左键指定复制源设备。

注 2： 可按 Esc（退出）键执行步骤 2，使光标颜色同标题栏颜色；通过向上和向
右键将光标置于复制目的设备上，然后选择“Edit”（编辑）菜单的“Copy
Device Attribute in Registration Monitor”（在注册监控窗口中复制设备属
性）项。

▼
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移动设备

通过拖动和下拉改变设备顺序可以将光标处的设别移动到另一个位置。执行下列程序
移动设备：

1. 将光标置于要移动的设备上。

2. 按住鼠标右键，并将光标移动至目的设备下面的设备上（拖动）。

3. 释放鼠标左键（下拉）。
• 设备嵌入光标所在位置。



第三章  模拟器

2-127

13

C KV-H6WE2-UM

删除设备

Edit (编辑) ➔ Delete Devices in Registration Monitor (删除注册监控窗口中的设备) ★ 单击右键 (Delete) （删除）

执行下列程序删除光标处的设备。

选择“Edit”(编辑) 菜单的“Delete Devices in Registration Monitor”(删除注册
监控窗口中的设备) 项

• 删除选中的设备；

• 选中删除设备下面的设备。

设备分类

Edit (编辑) ➔ Sort Devices in Registration Monitor (对注册监控窗口中的设备进行分类) ★ 单击右键 (Sort)（分类）

执行以下程序，按类型或编号对设备进行分类：

选择“Edit”(编辑) 菜单中的“Sort Devices in Registration Monitor”(对注册监
控窗口中的设备进行分类) 项。

• 按对话栏里的“Type”(类型) 对设备进行分类。

复位设备

Edit (编辑) ➔ Reset Device in Monitor All/Registration Monitor (复原全监控/注册监控窗口里设备) ★ 单击右
键 (Reset)（复位）

执行下列程序以复原选定设备到默认值：

选择“Edit”(编辑) 菜单的“Reset Device in Monitor All/Registration Monitor”
(复原全监控/注册监控窗口里设备)。

• 选定设备的当前值恢复为默认值。

注： 这步操作只复原光标所在行的设备；如要复原显示的所有设备，须选择
“Execute”(执行) 菜单的“Reset”(复位) 项；在监控器中不能复原设备。

删除后

删除前
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3.5.6 操作时序图

本节描述注册监控中显示的时序图。

执行单步方式时，实时显示时序图反映数值的历史记录；你可以确认程序运行状态，
如每件注册设备触点开/关状态切换的时间选择等。

如果执行连续单步方式后再执行逆向单步方式，则显示对称时序图。

但执行高速单步方式时，不会显示每个单步的进度，且每个时序图只有一个数值范
围；相应地，即使执行逆向单步方式，显示的时序图也不是对称的。

■ 如何理解时序图

屏幕显示所有注册设备的时序图。形状决定触点的开/关状态；数值变化决定字设备的
开/关状态。

时序图地时间基数从右到左排列，越往右离当前时间就越近。
时序图上的光标表示当前模拟部分，光标位置可以移动。

时序图的标度取决于执行的是扫描方式还是单步方式（只有模拟器才会有此不同，监
控器没有不同）。监控器里的标度表示监控器内部的计时，与 PLC 扫描无关。

当进行扫描时：一个标度表示一次扫描；
当进行单步方式时：一个标度表示一个指令。

切换执行方法时，时序图的颜色随之发生改变。

■ 移动纵向光标

单击标度显示纵向光标；执行以下任一程序即可移动光标：

• 在光标位置处按住鼠标左键，并移动到目的地位置，然后释放左键。

• 按 Esc (退出) 键使设置上的光标变为蓝色，然后使用向左和向右键移动光标。

• 按 Tab 键可改变纵向光标的活跃状态。
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注 1： 当前值表示纵向光标所在位置的数值；即使被复原，纵向光标所在处的数值仍
然显示当前值。如果没有纵向光标，则显示的当前值表示实际当前值；没显示
纵向光标时可以输入实际当前值。在监控器中，只有当监控器停止运行时才能
操作纵向光标。

注 2： 可以使用纵向光标修改触点的开/关状态、设备的当前值和预置值。

设置时序图的标度数目  
Settings (设置) ➔ Set No. of Scales for Timing Chart (设置时序图的标度数目)

标度在时序图的顶部；执行扫描时一个标度表示一次扫描，而执行单步方式时一个标
度表示一个指令。

屏幕默认显示 32 个标度；标度数目可设置在 1 和 511 之间。
有时调整标度数目会更易于浏览时序图，比如在开关间隔时间很短的情况下。
执行下列程序设置标度数目：

1. 选择“Settings”(设置) 菜单的“Set No. of Scales for Timing Chart”(设置

时序图的标度数目) 项或单击  按钮；

• 显示“设置时序图的标度数目”对话框。

2. 在 1 和 511 之间设置数值，默认值为 32。

注： 当因标度太多致使窗口无法显示时，会显示“无法显示标度”的信息；如果出
现这种情况，则须使窗口加宽或减少标度的数目。

• 时序图的标度数目变为输入值。

当输入“100”时

当输入“32”时
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设置等待时间  
Settings (设置) ➔ Wait Time (等待时间)

可以设置扫描等待时间。
等待时间适用于模拟器的所有操作。如果运行速度太快或太慢，则相应调整等待时间
值；不能在监控器内设置等待时间。
执行下列程序设置等待时间。

1. 选择“Settings”(设置) 菜单的“Wait Time”(等待时间) 项或单击  按钮。

• 显示“设置等待时间”对话框。

2. 在 0 和 10000 毫秒间设置等待时间，默认值为 90 毫秒。

3. 单击 [OK] 按钮注册输入的数值；单击 [Cancel] (取消) 按钮取消设置。
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3.5.7 打印注册监控

可以打印注册监控的内容。本节讲述有关打印程序。

只有注册监控才能打印。
首先将要打印的注册监控选为当前窗口 。

注： 执行打印前先确认以下方面：

• 应正确连接打印机；

• 应选择“File”(文件) 菜单的“Printer Setup”(打印机设置) 项正确设置打
印机。

如果打印机设置不正确，则须根据实际要求修改设置。

浏览显示

File (文件) ➔ Print Preview (打印预览)

执行下列程序确认预览屏幕上要打印的内容。

1. 将要打印的注册监控设置为当前窗口；

2. 选择“File”(文件) 菜单的“Print Preview”(打印预览) 项。

• 屏幕显示要打印的图像；

• 可以单击屏幕上的 [Print] (打印) 按钮打印显示的图像。
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执行打印

File (文件) ➔ Print (打印)

执行下列程序进行打印：

1. 将要打印的注册监控设置为当前窗口。

2. 选择“File”(文件) 菜单的“Print”(打印) 项。

• 显示“打印”对话框。

3. 选择“Print Range”(打印范围) 项的“All”(全部) 并单击 [OK] 按钮。

•   执行打印。

注： 如果未能正确执行打印，则须确认打印机的设置和连接状态。
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4.1 监控器功能概述

本节概述监控器功能和使用注意事项。

4.1.1 功能概述

监控器编译（转换）编辑器创制的梯形图程序，将转换的程序传输至 PLC（Visual
KV 或常规 KV），并予执行以确认操作状态。
同样，当前连接的 PLC 中保存的程序也可传输至个人电脑，编译并予以执行以确认
操作状态。

监控器有以下功能：

• 允许你使用梯形图监控、实时图表等来确认一个实时程序的操作状态。

• 改变 PLC 的操作模式。

• 允许你通过禁用输入更新和输出来操作监控器画面的输入触点。（仅适用于 Visual
KV 和 KV-300）

• 容易改变计时器、计数器和设备的预置值和当前值。

• 通过规定范围一次改变所有设备的当前值。

• 将有些设备返回至默认值。

4.1.2 监控器中的限制

• 监控器停止后，显示监控窗口时不要断开该 PLC 并连接另一个 PLC。否则，监
控上梯形图监控的内容可能与 PLC 的梯形图程序的内容不同，且该程序可能不能
正确操作。

• 当一个程序在运行时，在 KV-10R（W）/T（W），KV-16R（W）/T（W）， KV-
24R（W）/T（W），和 KV-40R（W）/T（W）/80R（W）/T（W）中禁止写入。

• 最小化的窗口不能监控。(如果有许多设备要监控，则操作速度变慢。要防止这
个，建议你将不需要监控的窗口最小化或关闭)

• 当整个监控器窗口最小化后，监控被停止。当再次进行监控时，在菜单中选择

“Start Monitor”（启动监控）或单击  该按钮。

• 注册监控中的计时图表不能由一个 PLC 侧的扫描来启动。

• 可传输多至 1000 个注释。（仅适用于 Visual  KV 和 KV-300）

• 当指定“Transfer comment”（传输注释）时，即使该程序没有改变，也会始终
传输注释。（仅适用于 Visual  KV 和 KV-300）
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4.1.3 通信的注意事项

• 使用连接电缆将 PLC 连接至个人电脑，并在启动监控前确认监控器的串行端口已
正确连接。
如果设置不正确，在启动监控时显示错误信息“Check connection cable with
the PLC.”（检查与 PLC 的连接电缆），且监控被禁用。
串行端口的初始预置值为“COM port: No. 1”（串行通信端口：No.1）和 “Baud
rate:AUTO”（波特率：自动）。当使用其他设置时，阅读“4.2 使用 PLC 进行通
信”（➮ 2-136 页）中的说明，然后改变该设置。

• 当监控在执行时，不要将 PLC 的连接电缆断开。否则，可能发生一个通信错误或
系统可能被重设。

• 不要在有过多杂波的地方进行通信。否则可能发生通信错误。

• 当一个程序在被写入时，不要断开连接电缆或中断通信，否则，Visual KV 或常
规 KV 中保存的程序会被删除。

• 如果经常发生通信错误，将波特率（通信速度）设置为一个较低的值。
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COM Port 选择连接至电缆的串行通信端口号。初始值为“COM1”。“COM port”（串
(串行通信端口) 行通信端口）属于串行端口，通信使用 RS-232C 接口。有些个人电脑可能

只提供一个串行通信端口。

Baud Rate 从“AUTO”（自动）、“9600”、 “19200”和“38400" (有些在某些个人电
(波特率) 脑中可能没有)中选择波特率。默认值为“AUTO (自动)”。“Baud rate”（波

特率）指通信速度，表示可在一秒传输的位号。 随着波特率变大，按更高的
速度进行通信。通常应选择“AUTO”（自动）。

4.2 使用 PLC 进行通信

本节说明如何将编辑器创立的梯形图程序传输至 PLC，以及如何从 PLC 传输程序。

4.2.1 设置 PLC 通信参数

File（文件）➔ Communication Setup（通信设置）➔ Set PLC Communication Parameters（设置 PLC 通
信参数）

在使用 PLC 进行通信之前，应在连接至 PLC 的个人电脑上设置串行通信端口和波
特率（通信速度）。
要设置这些参数，从编辑器打开监控器。

1. 从编辑器画面的菜单上选择“File”（文件）、“Communication Setup”（通信设
置）和“Set PLC Communication Parameters”（设置 PLC 通信参数）。

• 显示出监控器。

2. 从监控器的“Settings”（设置）菜单中选择“Serial Port”（串行端口）。

• 显示出“Set Communication Parameters”（设置通信参数）对话框。
关于设置程序，参阅下文“设置串行端口”。

3. 在设置通信端口后，自动选择监控器模式。要继续编辑，从“File”（文件）菜单

选择“Editor”（编辑器）或单击  该按钮。

设置串行端口

Settings（设置）➔ Serial Port（串行端口）

要设置串行端口，在监控停止时（没有进行通信）完成下列程序。

1. 从“Settings”（设置）菜单中选择“Serial Port”（串行端口）。

• 显示出“Set Communication Parameters”（设置通信参数）对话框。

2. 设置要使用的串行通信端口和波特率（通信速度）

3. 单击 [OK] 按钮记录该设置。如要取消该设置，单击 [Cancel]（取消）按钮。
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设置机器号

Set（设置）➔ Set Machine Number（设置机器号）

KV 梯形建筑者程序可以规定多点法连接两个或更多 KV-L2 单位的站号，使一个个
人电脑能按两个或更多 KV300 单位传输程序和监控程序。
要设置机器编号，在监控停止时（没有进行通信）完成下列程序。

1. 在“Settings”（设置）菜单中选择“Set Machine Number”（设置机器号）。

• 显示出“Set Machine Number”（设置机器号）对话框。

2. 设置通信目的地 KV-L2 的机器号。

• 机器号指由在 KV-L2 单位上的站号设置开关设置的号。

➮ 参阅 1-239 页“第 7 章 KV-L2 串行接口模块”。

3. 单击 [OK] 按钮记录该设置。要取消该设置，单击 [Cancel]（取消）按钮。

端口 1：RS-232C

KV 梯形建筑者站号
F（使用端口 1 时）
0（使用端口 2 时）

端口 2：RS-422A RS-232C/RS-422A
转换器

仅适用于 KV-300 系列
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4.2.2 设置注释传输
File（文件）➔ Communication Setup（通信设置）➔ Set Comment Transfer（设置注释传输）

设置要传输至 PLC 的注释范围。

注 1： 确认设置注释与程序一起传输至 PLC 的注释范围。

注 2： 注释仅能传输至 KV-300 和 Visual KV 系列。注释不能传输至 KV-10R(W)/
T(W), KV-16R(W)/T(W), KV-24R(W)/T(W) 和KV-40R(W)/T(W)/80R(W)/
T(W)。

注 3： 可传输多至 1000 个注释。当设置多于 1000 个注释时，则传输设备清单上
部的 1000 个注释。

要设置需传输的注释范围，完成下列程序。

1. 选择“File”（文件）、“Communication Setup”（通信设置）和“Set Com-
ment Transfer”（设置注释传输）。

• 显示出“Set Comment Write Range”（设置注释写入范围）对话框。

2. 输入每个设备要传输的范围。

• 单击 [Auto Setup]（自动设置）按钮，选择所有记录的注释。

3. 要记录该设置和关闭对话框，单击 [OK] 按钮。要取消该设置，单击 [Cancel] (取消)
按钮。

KV-300 和 Visual KV 系列
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4.3 启动和退出监控器

本节说明如何启动监控器，如何查看显示的画面以及如何使用监控器功能。

4.3.1 启动和退出的操作程序

从 PLC 传输程序和启动  
File（文件）➔ Monitor（监控器）➔ PLC Monitor（PLC 监控器）（Ctrl + F1）

可创立一个新的窗口，可将保存在 PLC 中的一个梯形图程序传输至个人电脑并再转
换，然后可显示一个梯形图解并被监控。
确认 PLC 正确连接，然后使用编辑器完成下列程序。

注： 第一次使用监控器时，确认 PLC 通信参数设置正确。

➮ 参阅 2-136 页“4.2.1 设置 PLC 通信参数”。

要从 PLC 传输一个程序和启动监控器，完成下列程序：

1. 在编辑器菜单中选择“File”（文件）、“Monitor”（监控器）和“Monitor PLC”
（监控 PLC）。

2. 将 PLC 程序传输的状态显示在图表上。

3. 当一个传输正常结束时，监控器自动启动。

传输程序  
File（文件）➔ Monitor（监控器）➔ Compile（编译）➔ Transfer（传输）➔ Monitor（监控器）（Ctrl + F8）

使用编辑器创立的程序可编译入机器代码，然后传输至 PLC 的程序存储区。
在开始传输前将 PLC 连接至个人电脑。
要传输一个程序，完成下列程序。

1. 在当前窗口选择要传输的程序梯形图解。
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2. 在菜单中选择“File”（文件）、“Monitor”（监控器）和“Convert → Transfer →
Monitor”（转换 → 传输 → 监控器），或单击  该按钮。

• 由编辑器创立的梯形图被转换。
• 显示出监控器窗口。
• 显示出“Transfer Program”（传输程序）对话框。

注 1： 当 PLC 保存的程序与传输的程序没有不同时，不进行写入。

注 2： 如果转换没有正常进行，则显示出信息“Conversion error exists. Data
can be transferred.”（存在转换错误，数据不能传输）。在单击 [OK] 按钮
后，显示出错误目录。纠正错误原因，然后再次传输该程序。

注 3： 当指定代码检验时，含有再转换错误的梯形图显示出信息“Reverse conver
sion error”（反向转换错误）。在单击 [OK] 按钮后，该梯形图传输至 PLC。
但是，传输的程序不能读出。纠正错误原因，然后重新传输该程序。

➮ H-3 不能解编译的程序（2-203 页）

如果在运行时写入一个程序，根据连接至 PLC 的控制设备的状态可能会产生严重的
危害。应小心注意。

3. 程序传输至 PLC，写入状态显示在图表上。

4. 当传输正常结束时，监控器自动启动。

警告
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读取程序  
File（文件）➔ Monitor（监控器）➔ Read Program from PLC（从 PLC 读取程序）

传输至 PLC 的程序可以被编译，然后在编辑器中读出。
在开始读取前，将 PLC 连接至个人电脑。
要读取一个程序，完成下列程序。

1. 选择 PLC 程序要从中读取的窗口，该窗口为编辑器画面的当前窗口。

2. 从菜单中选择“File”（文件）、“Monitor”（监控器）和“Read Program from
PLC”（从 PLC 读取程序），或单击  该按钮。

• 该程序被编译。

3. 从 PLC 传输程序的状态显示在图表上。

• 从 PLC 中读取该程序。
• 当从 KV-300 传输接触注释时，也被读出。

根据 PLC 程序校验

File（文件）➔ Monitor（监控器）➔ Verify against PLC Program（根据 PLC 程序校验）

编辑器中的程序可根据 PLC 存储中当前保存的程序进行校验。
在开始校验前连接 PLC 至个人电脑。
要进行校验，完成下列程序。

1. 在编辑器画面的菜单上选择“File”（文件）、“Monitor”（监控器）和“Verify
against PLC Program”（根据 PLC 程序校验）。

• 显示出监控器画面，当前保存在 PLC 中的程序被传输，然后编辑器画面自动重新
显示。

2. 在校验期间没有检测出不同时，显示出“Verify completed.”（校验完成）。

• 单击 [OK] 按钮。

3. 在校验期间检测出不同时，显示出“Verify error”（校验错误）。

• 单击 [OK] 按钮显示错误目录。
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在脱机模式中的编辑设备

File（文件）➔ Monitor（监控器）➔ Edit Offline Device（编辑脱机设备）

通过指定范围可从 PLC 一次读出所有的指定设备，然后可编辑。

1. 从编辑器菜单选择“File”（文件）、“Monitor”（监控器）和“Edit Offline
Device”（编辑脱机设备）。

• 监控器在设备设置模式中启动。

2. 在监控器的“File”（文件）菜单选择“Change All”（改变所有）。

• 打开改变所有窗口。

➮ 参阅“4.6.2  一次改变所有当前值” (2-150 页）。

注： 当监控器以设备设置模式打开时，梯形图监控、注册监控和全监控都不
能打开。

退出程序  
File（文件）➔ Editor（编辑器）

你可以从监控器退出和返回编辑器。
当使用相同程序再次切换至监控器时，从编辑器菜单选择“File”（文件），“Monitor”

（监控器）和“Compile → Transfer → Monitor”（编译 → 传输 → 监控器）。

• 当程序与 PLC 保存的相同时，在没有传输程序时再次选择监控器。

在“File”（文件）菜单选择“Editor”（编辑器），或单击  该按钮。

注： KV 梯形建筑者程序自己不能从监控器直接终止。要从 KV 梯形建筑者程序退
出，返回该编辑器，然后从编辑器的“File”（文件）菜单中选择“Exit”（退出）。
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4.3.2 画面各部分的名称和功能

当监控器启动后，显示最后编辑的梯形图程序的梯形图监控窗口。如果全监控窗口和
注册监控窗口之前已显示，他们在监控器启动后也显示出来。

样品画面

➮ 各窗口的各部分的名称和功能在下列页码中予以说明。

•  梯形图监控窗口 2-90 页
•  全监控窗口 2-113 页
•  注册监控窗口 2-122 页

主窗口标题栏
显示当前被监控的梯形图程序的文件名称。

菜单栏
显示菜单以执行指令。

工具栏
提供按钮执行指令只有
通常使用的指令被提供
为按钮。各指令可通过
单击相应的按钮来执
行。

对话栏
允许你注册设备，指定设备值
和预设值，以及重设定时器和
计数器。

主窗口标题栏
整个模拟画面。

梯形图监
控窗口
➮ 2-90 页

全监控窗口
➮ 2-113 页

注册监控
窗口
➮ 2-122 页

状态指示栏
显示当前选择的功能和监控器的
操作状态。
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4.4 梯形图监控

本节说明监控器启动/停止程序，监控器运行时显示的画面，PLC 模式设置等。

4.4.1 梯形图监控的概述

梯形监控器将梯形图程序传输至 PLC，实时显示实际 PLC 的操作，提供下列功能。

• 启动和停止监控器。

• 改变操作模式（RUN or STOP）（运行或停止）。

• 显示记录的注释。

• 使用对话栏改变当前值等。

4.4.2 显示梯形图监控窗口  
File（文件）➔ Ladder Monitor（梯形图监控）

如果关闭一个显示的梯形图程序，在“File”（文件）菜单中选择“Ladder Monitor”
（梯形图监控）使其再次显示，或单击  该按钮。

注 1： 由于从编辑器中启动模拟器后梯形图监控窗口始终显示，该操作不是典型要求。

注 2： 一次只能打开一个梯形图监控窗口。

注 3： 当梯形图窗口已经打开时，该功能禁用。

4.4.3 PLC 错误检验

当监控器在运行时，始终进行 PLC 错误检验。
当 PLC 发生错误时，显示一个错误信息。

➮ 关于错误信息和处理措施，参阅 2-156 页“附录 A  错误信息目录”。
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4.4.4 启动监控器  
Monitor（监控器）➔ Start Monitor（启动监控器）[F4]

可启动使用 PLC 的通信，PLC 的操作状态可显示在各窗口上。
要启动监控器，完成下列程序。

注 1： 如果出现一个转换错误，监控器不能启动。在启动监控器前确认梯形程序编译
（转换）正确。

注 2： 当第一次启动监控器时，监控器自动启动。

在“Monitor”（监控器）菜单中选择“Start Monitor”（启动监控器），或单击 
该按钮（绿色）。

在监控器运行时不要断开至 PLC 的连接电缆。否则，会发生通信错误或个人电脑可
能被重设。

4.4.5 停止监控器  
Monitor（监控器）➔ Stop Monitor（停止监控器）(F5)

可停止使用 PLC 的通信。
要停止监控器，完成下列程序。

在“Monitor”（监控器）菜单中选择“Stop Monitor”（停止监控），或单击  该
按钮（红色）。

• 监控被停止。

• 当整个监控器窗口被最小化时，监控自动停止。

小心
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4.4.6 监控器运行时显示的画面

当监控器启动后，各窗口显示操作状态。在监控器画面底部的状态栏显示当前执行的
操作模式等状态。

状态指示

当监控器在运行时或数据在记录重建模式下重新构建时，监控器窗口状态显示区显示
PLC 模式、扫描时间等。

监控器记录消耗量的注意事项

当整个监控器的记录消耗量较小时，监控器速度变快。
如果监控器速度低，最小化不需要的窗口。

状态显示区

通信指示灯
通信时转动。

PLC 模式
表示PLC的操作模式。

记录消耗量
表示现行窗口监控器的记录
消耗量。

整个监控器的记录消耗量
表示整个监控器模式监控器的记录
消耗量。

扫描时间
表示扫描时间增加 0.1 毫秒。
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4.4.7 设置 PLC 操作模式

设置常规 KV 的操作模式。
第一次启动监控器时，选择 PLC 模式。
要改变 PLC 模式，在菜单上的“PLC Mode”（PLC 模式）中选择需要的模式或单
击该按钮。

操作（RUN mode）（运行模式）  
PLC Mode（PLC 模式）➔ Run（运行）（Shift + F7）

在该模式下，程序正常操作。

停止（STOP mode）（停止模式） 
PLC Mode（PLC 模式）➔ Stop（停止）（Shift + F8）

在该模式下，停止执行程序。
所有输出关闭。
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4.5 全监控和注册监控

本节概要说明全监控和注册监控的功能。详细情况，请参阅 2-83 页“第三章 模拟器”。

4.5.1 全监控窗口的功能

全监控有下列功能。

• 显示所有设备的当前值和预设值，以及接触的 ON/OFF（开/关）状态和各设备型
号的线圈。

• 显示所有记录的注释。

• 打开/关闭位设备。

• 使用对话栏改变当前值等。

➮ 关于全监控窗口的执行和操作程序，参阅 2-109 页“3.4 全监控”。

4.5.2 注册监控的功能

注册监控有以下功能。

• 记录多至 40 个设备。

• 改变注册设备的位置。

• 显示注册设备的当前值，和位设备的 ON/OFF（开/关）状态以及注释。

• 显示所注册的设备的定时图表（位设备和字设备）。

• 打开/关闭位设备。

• 使用对话栏改变当前值等。

➮ 关于注册监控窗口的执行和操作程序，参阅 2-119 页“3.5 注册监控”。

注： PLC 侧的扫描不能启动定时图表。

定时图表上只显示一个垂直光标。
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4.6 监控器功能

本节说明可由监控器执行的功能，如禁用输入更新/禁用输出，改变所有当前值，清除
所有设备等。

4.6.1 禁用输入更新/禁用输出

一个 Visual KV 和 KV-300 配有输入更新禁用功能和输出更新禁用功能。

禁用输入更新

Monitor（监控器）➔ Disable Input Refresh（禁用输入更新）

当禁用输入更新时，PLC 的输入继电器读取（输入更新）停止，从监控器写入启动。

要设置输入更新功能，在监控器打开时从“Monitor”（监控器）菜单选择“Disable
Input Refresh”（禁用输入更新）。

• 当选择该功能后，加入一个复选标记。
• 当再次选择该功能时，设置被重设，复选标记被删除。

如果输入更新被禁用，PLC 的输入继电器读取（输入更新）停止，从监控器写入启
动。设置状态保存在 PLC 中。但是，当 PLC 操作模式从 STOP（停止）改变为
RUN（运行）或当电源关闭后再打开，则设置没有保存。

禁用输出

Monitor（监控器）➔ Disable Output（禁用输出）

当禁用输出时，即使执行一个程序输出状态也不更新。在不需要从输出继电器输出时
选择该功能。

要设置输出更新禁用功能，当监控器启动后在“Monitor”（监控器）菜单选择 “Disable
Output”（禁用输出）。

• 在选择该功能后，增加一个复选标记。
• 当再次选择该功能时，设置被重设，复选标记被删除。

如果输出更新被禁用，PLC 的输出继电器写入（输出）被禁用。但是，当 PLC 操作
模式从 STOP（停止）改变为 RUN（运行）或当电源关闭后再打开，则设置没有保存。

复选标记

复选标记

仅适用于 Visual KV 和 KV-300
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4.6.2 一次改变所有当前值  
File（文件）➔  Change All（全部改变）

通过从 PLC 中指定范围可一次读取所有指定的设备。然后当前值可被改变并可写入
PLC。此外，读取设备的设置可被保存，所保存的设备的设置可被读取。

改变所有可在“File”（文件）菜单中选择“Change All”（全部改变）后在所显示的
全部改变窗口上进行。可显示两个或更多的全部改变窗口。
当使用对话栏指定要读取的设备或单击 [Register]（记录）按钮后，所有指定的设备
读取至全部改变窗口。

• 可使用 Tab 键（前进方向）或 Tab + Shift 键（反向方向）在各项之间移动光标。

• 当单击位于窗口右上角的 [X] 按钮时，关闭全部改变窗口。

• 当输入一个超出可接受范围的当前值时，显示出“NG (不良)”。

注 1： 一个窗口只能读取一个连续范围。分散的范围不能读取至一个窗口。当读取分
散的范围时，在“File”（文件）菜单中选择“Change All”（全部改变），打
开一个新的全部改变窗口，使用对话栏指定并记录所需的范围，然后读取。

注 2： 计时器/计数器只能处理当前值。

注 3： 写入 PLC 比从 PLC 读取需要更长的时间。

改变所有窗口

设备范围 指定要读取的设备范围。

值 输入一个值

[Partial Change] 改变所选择设备范围的所有内容。
（部分改变）按钮

[File Read] 读取所有改变保存的设备内容的文本文件。
（文件读取）按钮

[File Write] 将所选择范围的设备的内容保存至文本文件。
（文件写入）按钮

PLC [Write] 将所选择范围的设备的内容写入 PLC。
（写入）按钮

PLC [Read] 从PLC 中读取设备的内容。
（读取）按钮

设备 显示设备型号和设备编号。

当前值 显示一个设备的当前值。

注释 显示一个被记录的注释。
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从 PLC 读取设备

1. 将要读取的设备范围输入“Device Range”（设备范围），或通过鼠标拖动指定范围。

2. 单击 PLC [Read]（读取）按钮。

• 指定的设备数据从 PLC 中读出，并在窗口中显示。

• 在该状态下，可使用对话栏改变属性（根、位计数、注释）。

➮ 参阅 2-118 页“改变当前值/预设置值/属性”。

写入设备至 PLC
1. 将要写入的设备范围输入“Device Range”（设备范围），或通过鼠标拖动指定范围。

2. 单击 PLC [Write]（写入）按钮。

• 指定的设备数据写入 PLC。

注： 一次只能写入一个连续范围。分散的范围不能同时写入。

保存/读取设备

从 PLC 上读取的设备设置能保存于一个文件中。保存于一个文件的设备的设置可以
读取。

■ 保存设备至一个文件

1. 将要保存的全部窗口选择为当前窗口。

2. 在“File”（文件）菜单中选择“Save Window As”（将窗口保存为），或单击

 该按钮。

• 显示出“Save Window As”（将窗口保存为）对话框。



第四章 监控器

2-152

4

C KV-H6WE2-UM

3. 指定要保存数据的文件夹（目录）和文件名。

注： 当数据已经保存于一个文件，你想在同一个文件名中保存新的数据时，在 “File”
（文件）菜单中选择“Save”（保存）。如果你这样做，原有数据将擦去，因为
现有文件被新文件重写。

■ 如何打印设备内容清单

要打印设备内容，完成下列程序。

1. 在改变所有窗口指定要打印的设备范围。单击 [File Read]（文件读取）按钮。
显示出“Save”（保存）对话框。输入文件名。

2. 使用视窗备忘录、编辑器或文字处理软件读取步骤 1 保存的要打印的改变所有文
本文件（*.txt）。
（该文件保存为文本格式。确认在文字处理软件中打开文件时要选择文本格式。)

3. 从读取文件所使用的软件中打印该文件。

• 打印出一个设备清单。

Folder (directory) 选择要保存文件的文件夹（目录）。
(文件夹 (目录)) 当前文件夹（目录）选择为默认值。

File Name 使用多至 8 个字母和数字输入文件名。
(文件名) 扩展名设置为“kdv”，不能改变。
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■ 从文件中读取设备

1. 在“File”（文件）菜单中选择“Open Window”（打开窗口）。

• 显示出“Open”（打开）对话框。

2. 单击       “File Type”（文件类型）按钮，并选择“Change All (*.kdv)”（全部
改变）。

3. 指定文件夹（目录）和文件名以保存要读取的文件。

Folder (directory) 选择文件夹（目录）以保存要读取的文件。
文件夹 (目录) 当前文件夹（目录）选择为默认值。

File Name (文件名) 输入要读取的文件名。

File Type (文件类型) 选择“Change All (*.kdv)”（全部改变）作为要读取的文件类型。

4. 单击 [OK] 按钮。

• 读取指定的文件，全部改变窗口被打开。
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4.6.3 设备全清除

PLC 上的设备可初始化。

初始化设备

Settings（设置）➔ Device All Clear（设备全清除） ➔ DM All Clear（DM全清除）
➔ Latching Relay All Clear（锁存继电器全清除）
➔ Counter All Clear（计数器全清除）

要初始化设备设置，完成下列程序。

1. 在“Settings”（设置）菜单选择“Device All Clear”（设备全清除），然后指定
要初始化的设备。

2. 显示一个要确认清除的信息。
要清除数据存储，单击 [Yes] 按钮。要取消执行清除，单击 [No] 按钮。

• 如果PLC操作模式设置为“RUN”（运行），当清除数据存储以外的设备时，显示
“Set STOP and execute?”（设置停止并执行?）信息。

➮ 当 PLC 设置为 RUN（运行）模式而执行“All Clear”（全清除）时（下文）。

■ 当 PLC 设置为 RUN（运行）模式而执行“All Clear”（全清除）时

如果 PLC 操作模式设置为“RUN”（运行），当清除数据存储以外的设备时，显示
“Set STOP and execute?”（设置停止并执行?）信息。

要选择 STOP（停止）模式然后执行全清除，单击 [Yes] 按钮。要取消执行全清除，
单击 [No] 按钮。
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附录 A 错误信息目录

本节说明操作期间显示的错误信息以及当一个错误信息被显示时的处理措施。

A-1 系统错误

当整个系统（包括窗口）不稳定时，显示一个系统错误信息。

当显示一个系统错误信息时，立即保存需要的文件，从 KV 梯形建筑者编码程序中退
出，然后重新启动窗口。如果系统错误信息经常发生，与我们的销售代表联系。

A-2 存储器错误

当窗口没有足够的内存时，显示一个存储器错误信息。

当显示一个存储错器误信息时，从其他打开的应用中退出，或增加存储量。

错误信息 错误信息

Can’t open document. Can’t release machine code memory.
(不能打开文件。) (不能释放机器代码存储器。)
Can’t obtain font. (不能获得字体。) Jump failed. (转移失败。)
Can’t create window. (不能创立窗口。) ClrList execution error. (清除目录执行错误。)
Start up from Editor. (从编辑器启动。) AddlList execution error. (增加目录执行错误。)
Can’t open window which should exist. GetList execution error.
(不能打开应该存在的窗口。) (获得目录执行错误。)
Initialize window failed. (初始化窗口失败。) Program is empty. (程序是空的。)
Can’t obtain information on window. Specification of list type is illegal.
(不能获得窗口上的信息。) (目录类型的规范是非法的。)
Monitor handle not registered. Position of writing line is illegal.
(监控器标识值没有记录。) (写入线位置是非法的。)
Simulator handle not registered. Position of writing row is illegal.
(模拟器标识值没有记录。) (写入行位置是非法的。)
Can’t obtain information on symbol. Data on starting line of display is abnormal.
(不能获得符号上的信息。) (显示开始行的数据不正常。)
Ladder data error. Can’t find program to be deleted.
(梯形图数据错误。) (不能发现要删除的程序。)
Write cell data failed. Contents of line cut buffer is abnormal.
(写入单元数据失败。) (行删除缓冲区内容不正常。)
Read cell data failed. Error obtaining Program Information.
(读取单元数据失败。) (获得程序信息错误。)
Content of LDKPRG.DLL is illegal. Reverse conversion failed.
(LDKPRG.DLL 内容非法。) (反向转换失败。)
Content of LCK.DLL is illegal. Change failed.
(LCK.DLL 内容非法。) (改变失败。)
Content of KVCOM.DLL is illegal. Obtain comment failed.
(KVCOM.DLL 内容非法。) (获得注释失败。)
Obtain device context failed. Invalid comment area.
(获得设备文本失败。) (无效注释区。)
Write device failed. Not enough memory for macro information.
(写入设备失败。) (大量信息没有足够的内存。)
Device information list access error. Illegal Element.
(设备信息目录存取错误。) (非法元件。)
Obtain machine code failed.
(获得机器编码失败。)

错误信息 错误信息

Not enough memory. (内存不够。) Not Enough Memory.  (内存不够。)
Error Obtaining Memory. Quit other applications and restart.
(错误获得内存。) (退出其他应用并重新启动。)
Global Ladder Line Replication Error Can’t register new program with LDKPRG.DLL.
(全局梯形图行应用错误。) (不能用 LDKPRG.DLL 记录新的程序。)
Can’t allocate memory. （不能分配内存。)
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A-3 文件错误

当一个文件损坏时显示一个文件错误。

当显示一个文件错误时，使用“SCANDISK”（磁盘检查工具）检查磁盘，如果检测
出一个错误则恢复该文件。重新安装 KV 梯形建筑者程序。

在编辑器上显示的错误信息表示如下。

A-4 安装错误

当目标文件不存在于适当位置时，显示一个安装错误。目标文件可能已被从安装目的
地文件夹（目录）中删除。

当显示一个安装错误信息时，重新安装 KV 梯形图建筑者程序。

错误信息 错误信息

Error [file name]: Read ladder diagram file failed. Can’t open ladder diagram file.
(错误 (文件名): 读取梯形图程序文件失败。) (不能打开梯形图程序文件。)
Error [file name]: Read file failed. Can’t open text file.
(错误 (文件名): 读取文件失败。) (不能打开文本文件。)
Error [file name]: Write file failed. Can’t open comment file.
(错误 (文件名): 写入文件失败。) (不能打开注释文件。)
Error [file name]: Read text file failed. Content of LDKPRG.DLL is illegal.
(错误 (文件名): 读取文本文件失败。) (LDKPRG.DLL 是内容非法的。)

Content of LCK.DLL is illegal.
(LCK.DLL 内容是非法的。)

Error [file name]: Write text file failed. Content of KVCOM.DLL is illegal.
(错误 (文件名): 写入文本文件失败。) (KVCOM.DLL 内容是非法的。)
Error [file name]: Read comment file failed.
(错误 (文件名): 读取注释文件失败。)

错误信息 错误信息

Can’t Load LDKPRG.DLL. Error LBK.KSU: Read text file failed.
(不能载入 LDKPRG.DLL。) (错误 LBK.KSU: 读取文本文件失败。)
Can’t Load LCK.DLL. (不能载入 LCK.DLL。)
Can’t Load KVCOM.DLL. Error LBK.EMS: Read text file failed.
(不能载入 KVCOM.DLL。) (错误LBK.EMS: 读取文本文件失败。)
Monitor startup failed. (监控器启动失败。)
Simulator startup failed. (模拟器启动失败。)
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A-5 在编辑器中发生的错误
在编辑器中显示的错误信息表示如下。

错误信息 原因 处理措施

在 从 KV 读取一个程序并转换至一
个梯形图程序，或在选择代码检验
系统设置时转换一个梯形图程序时
发生的一个文法错误。

Reverse Compi-
lation Error.
(反向编译错误。)

显示错误目录 [ ➮  错误显示 ( 2-76
页) ]，确认错误内容，然后纠正程
序 (➮ H-3 不能解编译的程序 (2-
203 页))。

Compilation Error.
(编译错误。)

当编辑终止时发生的一个文法
错误。

显示错误目录 (➮ 错误显示 (2-76 页)
确认错误内容，然后纠正该程序。

Specified label
already used.
(指定标签已使用。)

指定标签已被分配至另一个设
备。

每个设备指定一个不同的标签。

Write/Develop
macro failed.
(写入/开发宏失败。)

当写入和开发一个宏时发生一个
错误。

确认临时设备的内容。确认写入和
开发宏时编辑器的范围能满足。

Program is too large.
(程序太大。)

程序太大而不能编辑。 一个梯形图程序里允许的行的最大
数是 9999。

No. of instruction word
or operand is illegal.
(指令文字数或操作
数是非法的。)

已输入太多或太少的操作数。

Contact name is illegal.
(联系名称是非法的。)

指定了一个被拒绝的设备。

使用手册或帮助功能确认相应指令
的格式。

Temporary device
can’t be used for
TMR, TMH and TMS.
TMR, TMH 和TMS
(不能使用临时设备。)

这些设备不能用作临时设备。 不要把它们用作临时设备。

Temporary device
can’t be used for C.
(临时设备不能用于 C。)
Temporary device
can’t be used for CTH.
(临时设备不能用于 CTH。)
Temporary device
can’t be used for CTC.
(临时设备不能用于 CTC。)
Temporary device
can’t be used for UDC.
(临时设备不能用于 UDC。)
Illegal operand.
(非法操作数。)
Illegal first operand.
(非法第一操作数。)
Illegal second operand.
(非法第二操作数。)

一个指令文字的助记不正确。 使用手册或求助功能确认指令的规
格。

Can’t overwrite on
comment ladder line.
(不能在注释梯形图行上重写。)

一个文件可能损坏 使用“SCANDISK”（磁盘检查工
具）检查磁盘错误。

Illegal file format.
(非法文件格式。)

Illegal Comment File.
(非法注释文件。)

Cancel reading.
(取消读取。)
This file is not found in
[File Names]. Check for
directory and file name
and input correct name.
(在（文件名）中没有发现
该文件。检查目录和文件
名，并输入正确的名称。)

没有发现在自动文件读取功能设
置的文件。

检查相应的文件是否存在于显示的
位置，并重新设置。
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A-6 在监控器/模拟器中发生的错误

在监控器/模拟器中显示的错误信息在下表中表示。

A-7 通信错误 (显示在监控器中)
用 PLC 进行通信期间显示的错误信息在下表中表示。

错误信息  原因 处理措施

Can’t  write scales.
Widen the width of
registration monitor
window.
(不能写入数值范围。
加宽了注册监控器
窗口的宽度。)

因为注册监控器的宽度太窄，
指定的数值范围数不能提取。

增加注册监控器窗口的宽度。

确认个人电脑的 RS-232C 端口
正确地连接于 PLC。确认通信
(COM1/2) 端口和波特率在“设
置”“串行端口”中设置正确。

Unregistered
program
(未记录程序)

尽管 KV 主单位里没有程序。
确认进行该尝试以执行 PLC 监
视 CPU 中的程序，

在进行这些尝试前传输一个呼叫
或程序至 KV。

错误信息 原因 处理措施

Communication
error occurred.
Check for commu-
nication setting and
connection lines.
(发生的通信错
误。检查通讯设置
和连接线。)

通信期间发生的一个错误。
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A-8 PLC 错误

当一个 Visual KV 或一个常规 KV 发生故障时显示的错误信息在下表中表示。

错误信息 原因 处理措施

Analysis Dis-
abled Error
(分析禁用错误)

在 KV 主单位发生一个意外的错
误。

切断至 KV 主单元的电源，然后同
样的再打开。如果经常发生同样的
错误，与最近的 KEYENCE（基恩
士）公司办事处联系。

当 KV 主单元里没有程序时选择
了 RUN 运行模式。

传输一个程序至 KV 主单位，然后
选择 RUN（运行）模式。

周期时间错误周期时间已超过
208 ms。(KV-300 为 300 ms)。

改变该程序使周期时间变短。

KV 主单位内存的内容已被擦
除。

重设该错误，然后选择 RUN（运
行）模式。

子程序中的嵌套数量超过 4。 当执行该程序时发生的错误。检查
该程序并纠正该错误。

FOR - NEXT 指令中的嵌套数
量已超过 8。

MPS - MPP 指令中的嵌套数量
已超过 8。

一次发生五次或更多中断。 纠正该程序使一次只发生一次中
断。

System Error
(系统错误)
Run Time Error
(运行时间错误)
Divided by 0
(除以 0)
Address Error
(地址错误)
Illegal Instruc-
tion Error
(非法指令错误)
Watchdog Timer
Error
(监视时钟错误)
Program Error
(程序错误)
Cycle Time Error
(周期时间错误)
Memory Error
(存储器错误)

CALL Instruction
Nest Error
(呼叫指令嵌套错误)
FOR Instruction
Nest Error
(FOR 指令嵌套错误)

MPS Instruction
Nest Error
(MPS (多用图形
显示系统) 指令嵌
套错误)

INI Instruction
Nest Error
(INI 指令嵌套错误)
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A-9 编译期间发生的错误

编译期间显示的错误信息在下表中表示。
当显示该类型错误信息时，消除错误原因，然后重新进行编译。

错误信息 原因 处理措施

Not enough memory.
Abort conversion.
(内存不足，中止转换)

First operand is unnecessary.
(第一个操作数不需要。)
Second operand is unnecessary.
(第二个操作数不需要。)
Third operand is unnecessary.
(第三个操作数不需要。)
First operand form is illegal.
(第一个操作数格式为非法。)
Second operand form is illegal.
(第二 个操作数格式为非法。)
Third operand form is illegal.
(第三个操作数格式为非法。)
First operand value is illegal.
(第一个操作数值为非法。)
Second operand value is illegal.
(第二个操作数值为非法。)
Third operand value is illegal.
(第三个操作数值为非法。)
First operand is not found.
(第一个操作数没有发现。)
Second operand is not found.
(第二个操作数没有发现。)
Third operand is not found.
(第三个操作数没有发现。)
Instruction is repeatedly used.
(指令被重复使用。)
Operand is repeatedly used.
(操作数被重复使用。)

内存不足不能完成编译

由于编译期间发生 100 个或更
多错误，编译被中断。

指令文字的助记不正确。( 当文
件由商用编辑器创立或文字处
理软件打开编辑助记目录时，
经常发生这个错误)。

确认有足够的内存和硬盘空间。

纠正每个错误。

使用手册或帮助功能以确认指令的
规格。

一个只能使用一次的指令被使
用了两次或更多。

Unusable in interrupt program.
(在中断程序里不能用。)

Usage of paired
instruction is incorrect.
(配对指令的使用不正确。)

Instruction position error.
(指令位置错误。)
Nested levels in subroutine is
too many.
(子程序里的嵌套级太多。)
Undefined subroutine exists.
(存在未定义的子程序。)

Too many errors.
Abort conversion.
(太多错误，中止转换)

Subroutine No. is
repeatedly used.
(子程序号被重复使用。)
Nested levels of paired
instruction is too many.
(配对指令的嵌套级太多。)

Parallel connection is used
in STG instruction.
(STG 指令使用了并行连接。)
END instruction is not found.
(没有发现 END 指令。)
ENDH instruction is not found.
(没有发现 ENDH 指令。)
STG instruction position error.
(STG 指令位置错误。)
SFT instruction operand error.
(SFT 指令操作数错误。)

一个只能使用一次的操作数被
使用了两次或更多。

一个不能用的指令被用于中断
程序。

在 END（结束）指令前描述了
一个子程序或一个中断程序。

子程序里的嵌套级数超过 4

该程序在没有定义一个被调子
程序时被终止。

两个或更多子程序被定义相同
的编号。

配对指令的嵌套级数超过最大
数。

用于配对的指令没有用作配
对。

STG 指令含有一个 OR（并
行）连接块。

在 ENDH 指令前没有在程序中
发现 END 指令。

在程序的最后一行没有发现
ENDH 指令。
STG 指令没有出现在一个块的
标题里。

SFT 指令操作数在可用范围之
外。

该指令只使用一次。

该操作数只使用一次。

在 END 指令和 ENDH 指令之间
描述该程序。

改变该程序以使用另一个方法。

改变该程序使嵌套级数为 4 或更
少。

在 END 指令和 ENDH 指令之间
描述该子程序。

每个子程序分配的编号应不同。
改变该程序

改变该程序使嵌套级数在最大数
内。

改变该程序使其用作一个配对。

在 STG 指令中不要使用一个 OR
(并行)连接。

在 ENDH 指令前在程序里包含
END 指令。

在程序的最后一行包含 ENDH 指
令。
在块的标题里包含 STG 指令。

在可用的范围包含 SFT 指令。
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错误信息 原因 处理措施

Corresponding CTH
instruction is not found.
(没有发现相应的 CTH 指令。)

Termination element not
connected to output line.
(终止元件没有连接至输出线。)
Block has too long parallel connection.
(块并行连接太长。)
Lines in block exceeds
maximum number.
(块中的行数超过最大数。)
No connection.
(没有连接。)
Illegal short-circuiting.
(非法短路。)
Illegal parallel connection.
(非法并行连接。)
Illegal connection.
(非法连接。)

Corresponding instruction
is undefined.
(相应指令没有定义。)
Unusable in subroutine.
(子程序里不能用。)
Model code is incorrect.
(模型编码不正确。)
First line is illegal.
(第一行是非法的。)
Mnemonic is illegal.
(助记是非法的。)
First operand is illegal.
(第一个操作数是非法的。)
Second operand is illegal.
(第二个操作数是非法的。)
Third operand is illegal.
(第三个操作数是非法的。)
After mnemonic is unnecessary.
(事后助记不需要。)
After first operand is unnecessary.
(事后第一操作数不需要。)
After second operand is unnecessary.
(事后第二操作数不需要。)
After third operand is unnecessary.
(事后第三操作数不需要。)
Code file was not generated.
(没有产生编码文件。)

Number of instructions is too large.
(指令数太大。)

Instructions are not paired.
(指令没有配对。)
Usage of CON
instruction is incorrect.
(CON 指令的使用不正确。)
Connection of multiple input
elements is illegal.
(多重输入元件的连接是非法的。)
Output elements can’ t be
connected in parallel.
(输出元件不能并行连接。)
Input element connected to output line.
(输入元件连接至输出线。)

尽管使用了 CTC 指令，相应
的 CTH 指令没有包含在程序
内。

尽管使用了计时器和计数器接
点，相应的指令没有出现在程
序里。

子程序里包含不能用的指令。

指令文字的助记不正确。(当文
件由商用编辑器创立或文字处
理软件打开编辑助记目录时，
经常发生这个错误)

由于指令分类不正确，它们不
能编译至梯形图解。

Ladder diagram can’t be drawn.
(不能绘制梯形图解。)

由于一个并行连接块里有太多
指令，不能编译入梯形图解。

Output element connected to bus.
(输出元件连接至总线。)

梯形图解中的块超过 100 行。

总线间的路径中不存在一个指
令符号。

不应短路的两点发生短路。

块没有正确并行连接。

指令符号连接方法不正确。

改变电路以减少并行连接块中的指
令数。

改变该程序使每块包含的行少于
100。

在总线间的路径上包含一个指令符
号。

不要使它们短路。

改变电路使其正确并行连接。

改变电路使符号正确连接。

确认指令规格，并纠正该程序。

在 END 指令前将相应的 CTH 指
令包含在程序内。

在 END 指令前将相应的指令包含
在程序内。

改变该程序并使用另一个方法。

使用手册或帮助功能确认指令的规
格。

Previous connecting block is not found.
(没有发现先前的连接块。)
Following connecting
block is not found.
(没有发现其后的连接块。)
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附录 B 指令目录

该附录包含指令目录及其作用的概述。详细情况参阅 3-33 页第 2 章 “指令”。

B-1 基本指令

指令名称 助记 进程概述

Load LD 连接 N.O. 接点至总线。

Load Bar LDB 连接 N.C. 接点至总线。

Out OUT 至继电器线圈输入的输出 ON/OFF 状态。

Out Bar OUB 至继电器线圈输入的输出转换 ON/OFF 状态。

And AND 串联连接 N.O. 接点。

And Bar ANB 串联连接 N.C. 接点。

Or OR 并联连接 N.O. 接点。

Or Bar ORB 并联连接 N.C. 接点。

And Load ANL 串联连接块一个或更多接点。

Or Load ORL 并联连接块一个或更多接点。

Set SET 强制接通指定的继电器,并使其保持接通。

Reset RES 强制关闭指定的继电器。

Timer TMR 设置按 0.1s 计数的倒数延迟计时器。

High-Speed Timer TMH 设置按 0.01s 计数的倒数延迟计时器。

High-Speed 1-ms TMS 设置按 0.001s 计数的倒数延迟计时器。
Timer

Counter C 设置一个正数计数器。

Up-Down Counter UDC 设置一个正-倒数计数器。

Differentiate Up DIFU 检测输入信号的上升沿，并仅为第一次扫描时间接通
ON 指定的继电器。

Differentiate Down DIFD 检测输入信号的下降沿，并仅为第一次扫描时间接通
ON 指定的继电器。

Keep KEEP 当 SET (设置) 输入继电器接通 ON 时接通指定的继
电器,并使该继电器保持 ON。当 RESET (复位) 输入
继电器接通时关闭指定的继电器。

Shift SFT 设置一个移位记录器。

High Speed HSP 缩短指定输入继电器的时间常数准备用于高速度。

Master Control MC 在 MCR 指令前选择继电器、计时器或计数器设置的
ON/OFF 状态。

Master Control MCR 结束 MC 指令的执行。
Reset

Memory Switch MEMSW 设置存储器开关。

No Operation NOP 不进行操作。

End END 指示程序中各例行程序的结束。

End Hi ENDH 指示整个程序的结束。
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B-2 应用指令

指令名称 助记 进程概述

Wait ON W-ON 当输入操作数继电器/计时器/计数器接通时，接通输出
操作数继电器。

Wait OFF W-OFF 当输入操作数继电器/计时器/计数器关闭时，接通输出
操作数继电器。

Wait Up Edge W-UE 在输入操作数继电器/计时器/计数器上升沿接通输出操
作数继电器。

Wait Down Edge W-DE 在输入操作数继电器/计时器/计数器下降沿接通输出操
作数继电器。

Stage STG 当操作数继电器接通时在 STG 块中执行指令。

Connect CON 在输出状态后表示串联连接。

Push MPS 储存输入状态和算术标记状态。

Read MRD 读取用 Push（MPS）存储的输入状态和算术标记状态。

Pop MPP 读取用 Push（MPS）存储的输入状态和算术标记状
态，并清空内存。

Jump JMP 关闭当前阶段，然后传输执行至另一个阶段。

End Stage ENDS 关闭当前阶段的继电器。

Step STP 当操作数继电器接通时在 STP 和 STE 之间执行指令。

Step End STE STP 用作一个配对制作一个程序步骤。

Interval Timer ITVL 在指定模式测量脉冲-脉冲间隔或脉冲宽度。

8-bit (16-bit) High CTH 用作通用高速计数器，其反应频率为 10 kHz。
Speed Counter

8-bit (16-bit) High CTC 比较器：用 CTHO 当前值比较预设值，当它们相同时
Speed Counter 接通。也用作一个中断源。

Subroutine Call CALL 用指定的号执行子程序。

Subroutine Entry SBN 表示子程序的开始。

Subroutine Return RET 表示子程序的结束。

Repeat Start FOR 根据操作数指定的时间数执行 FOR 和 NEXT 之间的
程序范围。

Repeat End NEXT 表示重复的结束。

16-Key Input HKEY 读取时间分配基础上的十六进制按键数据，并将这些数
据输出至特殊实用继电器 2900 至 2915。
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指令名称 助记 作用概述

Data Memory Write DW 直接将常数写入数据存储器。

Trimmer Setting TMIN 将剪裁器旋转角转换成 0-249 之间的数，并输回到内
@TMIN 部寄存器。

Load A LDA 将操作数指定的值输入到内部寄存器。
@LDA * 当计时器/计数器由操作数指定时，将当前值输入到

内部寄存器。

Store A STA 将内部寄存器的内容传输到操作数指定的目的地。
@STA * 当定时器/计数器由操作数指定时，预设值被改变。

Compare CMP 用操作数指定的值比较内部寄存器的内容，并输出结
@CMP 果到 2009-2011。

Add ADD 将操作数指定的值加上到内部寄存器的内容中，并将
@ADD 结果输回到相同内部寄存器。

Subtract SUB 从内部寄存器的内容里减去操作数指定的值，并将结
@SUB 果输回到相同内部寄存器。

Multiply MUL 将内部寄存器的内容乘以操作数指定的值，并将结果
@MUL 输回到相同内部记录器。

Divide DIV 将内部寄存器的内容除以操作数指定的值，并将结果
@DIV 输回到相同内部寄存器。

And A ANDA 将内部寄存器的内容和操作数指定的值各 16 位“与”
@ANDA 运算，并将结果输回到相同内部寄存器。

Or A ORA 将内部寄存器的内容和操作数指定的值各 16 位“或”
@ORA 运算，并将结果输回到相同内部寄存器。

Exclusive Or A EORA 将内部寄存器的内容和操作数指定的值各16位“异”
@EORA 运算，并将结果输回到相同内部寄存器。

Shift Right A SRA 将内部寄存器的内容按操作数指定的值连续右移。
@SRA

Shift Left A SLA 将内部寄存器的内容按操作数指定的值连续左移。
@SLA

Rotate Right A RRA 将内部寄存器的内容按操作数指定的值顺时针旋转。
@RRA

Rotate Left A RLA 将内部寄存器的内容按操作数指定的值逆时针旋转。
@RLA

Complement COM 转化内部寄存器各位的内容。
@COM

Increment Memory INC 操作数指定的数据存储器的内容增加 1。
@INC

Decrement DEC 操作数指定的数据存储器的内容减去 1。
Memory @DEC

Multiplexer MPX 将操作数指定的内部寄存器的一位数据转换成 16 位
@MPX 数据。

Demultiplexer DMX 转换成内部寄存器最有效位的位置的值。
@DMX

B-3 算术指令
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指令名称 助记 作用概述

Transfer BCD TBCD 将内部寄存器的内容转换成 4 位 BCD 数据。
@TBCD

Transfer BIN TBIN 将内部寄存器的内容转换成 16 位二进制数据。
@TBIN

ASCII Convert ASC 将内部寄存器低次序字节的内容（2 位数）转换成 2
@ASC 位 ASCII 编码。

Reverse ASCII RASC 将 2 位 ASCII 编码转换成 1 字节数据，表示 2 位数。
Convert @RASC

Square Root ROOT 取 32 位数据的平方根（TM00：较高次序字节，内
@ROOT 部寄存器：较低次序字节），并将结果输回到相同内

部寄存器。

Differentiation @xxxx 仅在输入至输入继电器的上升沿执行指令。

指令名称 助记 作用概述

Interrupt Disabled DI 禁用各种中断程序。

Interrupt Enabled EI 启用各种中断程序。

Interrupt INT 在输入 0000-0002 的上升沿执行 INT 和 RETI 之间
的中断。

在输入 0003 的上升沿或下降沿（上升沿或下降沿可
由 2206 的 ON/OFF 选择）执行 INT 和 RETI 之间
的中断。

当比较结果与比较器相称，执行直至 RETI 的中断。

Return Interrupt RETI 表示中断结束。

B-4 中断指令
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KV-10 KV-16 KV-24 KV-40/80 KV-300 KV-10 (16) KV-24 (40)
R(W)/T(W) R(W)/T(W) R(W)/T(W) R(W)/T(W) AR/AT/DR/DT AR/AT/DR/DT

基本输入继电器 0000 至 0005 0000 至 0009 0000 至 0015 KV-40 0000 至 0009 KV-10 KV-24
R(W)/T(W): AR/AT/DR/DT: AR/AT/DR/DT:
0000 至 0107 0000 至 0005 0000 至 0015
KV-80 KV-16 KV-40
R(W)/T(W): AR/AT/DR/DT: AR/AT/DR/DT:
0000 至 0125 0000 至 0009 0000 至 0107

延长输入继电器 0100 至 0415 0100 至 0415 0100 至 0415 KV-40 0100 至 0415 KV-24
  R(W)/T(W): AR/AT/DR/DT:
0200 至 0415 0100 至 0415
KV-80R KV-40
  (W)/T(W): AR/AT/DR/DT:
0300 至 0415 0200 至 0415

基本输出继电器 0500 至 0503 0500 至 0505 0500 至 0507 KV-40 0500 至 0503 KV-10 KV-24
  R(W)/T(W): AR/AT/DR/DT: AR/AT/DR/DT:
0500 至 0507 0500 至 0503 0500 至 0507
0600 至 0607 KV-16 KV-40
KV-80 AR/AT/DR/DT: AR/AT/DR/DT:
  R(W)/T(W): 0500 至 0505 0500 至 0515
0500 至 0615

延长输出继电器 0600 至 0915 0600 至 0915 0600 至 0915 0700 至 0915 — 0600 至 0915 0600 至 0915

内部实用继电器 1000 至 1915 1000 至 1915 1000 至 1915 1000 至 1915 1000 至 1915 1000 至 1915 1000 至 1915
3000 至 6915 3000 至 6915 3000 至 6915 3000 至 15915 3000 至 15915

特殊实用继电器 2000 至 2915 2000 至 2915 2000 至 2915 2000 至 2915 2000 至 2915 2000 至 2915 2000 至 2915

外部 I/O 继电器 — — — — 7000 至 17915 — —

计时器/计数器 T/C000 至 063 T/C000 至 063 T/C000 至 119 T/C000 至 119 T/C000 至 249 T/C000 至 249 T/C000 至 249

高速 CTH0 至 1 CTH0 至 1 CTH0 至 1 CTH0 至 1 CTH0 至 1 CTH0 至 1 CTH0 至 1
计时器/计数器

高速比较器 CTC0 至 3 CTC0 至 3 CTC0 至 3 CTC0 至 3 CTC0 至 3 CTC0 至 3 CTC0 至 3

数据存储器 DM0 至 0999 DM0 至 0999 DM0 至 1999 DM0 至 1999 DM0 至 9999 DM0 至 1999 DM0 至 1999

临时存储器 TM0 至 31 TM0 至 31 TM0 至 31 TM0 至 31 TM0 至 31 TM0 至 31 TM0 至 31

附录 C 继电器编号目录

C-1 各型号的继电器、计时器、计数器和存储器号
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附录 D 特殊实用继电器目录

D-1 特殊继电器和算术操作标记

* 只读继电器。

D-2 用于高速计数器的特殊实用继电器 (0)

* 只读继电器。

注： 切勿使用以上未列出的特殊实用继电器。

号编器电继 能功

*0012 于用仅钟时部内 )sµ1(0HTC

*1012 于用仅钟时部内 )sµ01(0HTC

*2012 于用仅钟时部内 )sµ001(0HTC

3012
器较比当 0CTC 开打 NO ，时 0HTC 除清动自 :NO 除清已

:FFO 除清未

4012 器较比当 0CTC 开打 NO 止禁，时 / 至出输接直许允
0050 。

:NO 止禁
:FFO 许允

5012 器较比当 0CTC 开打 NO 至出输接直，时 0050 置设
为 FFO 。

:NO 为置设 FFO
:FFO 为置设未 FFO

6012 器较比当 0CTC 开打 NO 至出输接直，时 0050 置设
为 NO 。

:NO 为置设 NO
:FFO 为置设未 NO

7012 器较比次每 0CTC 至出输，开打 0050 的 FFO/NO 状
。倒颠被态

:NO 倒颠
:FFO 倒颠未

8012
器较比当 1CTC 开打 NO 止禁，时 / 至出输接直许允

0050 。
:NO 止禁
:FFO 许允

9012 器较比当 1CTC 开打 NO 至出输接直，时 0050 置设
为 FFO 。

:NO 为置设 FFO
:FFO 为置设未 FFO

0112 器较比当 1CTC 开打 NO 至出输接直，时 0050 置设
为 NO 。

:NO 为置设 NO
:FF 为置设未 NO

1112 器较比次每 1CTC 至出输，开打 0050 的 FFO/NO 状
。倒颠被态

:NO 倒颠
:FFO 倒颠未

2112
器较比当 1CTC 开打 NO ，时 0HTC 除清动自 :NO 除清已

:FFO 除清未

3112 器较比于用式模法乘择选 0HTC 。
FFO NO FFO NO

1:FFO 冲脉 2:NO4x:NO2x:FFO 冲脉4112

式模法乘 1 冲脉 2x 4x 2 冲脉

3112 FFO NO FFO NO

4112 FFO FFO NO NO

仅用于 Visual KV 系列

号编器电继 能功

*2002 终始 (NO 开)

*3002 终始 (FFO 关)

*4002 s10.0 冲脉钟时 ( 度空占 )%05:

*5002 s1.0 冲脉钟时 ( 度空占 )%05:

*6002 s0.1 冲脉钟时 ( 度空占 )%05:

*7002 持保间期描扫次一第后动启 FFO 。

*8002 持保间期描扫次一第后动启 NO 。

*9002 开打时出溢生产当或数负是果结的作操术算当 NO 。

*0102 是果结的作操术算当 0 开打时 NO 。

*1102 开打时数正是果结的作操术算当 NO 。

*2102 开打时误错生发果结的作操术算当 NO 。
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D-3 用于高速计数器的特殊实用继电器 (1)

* 只读继电器。

注： 不要使用未列出的特殊实用继电器。

号编器电继 能功

*0022 于用仅钟时部内 )sµ1(1HTC

*1022 于用仅钟时部内 )sµ01(1HTC

*2022 于用仅钟时部内 )sµ001(1HTC

3022
器较比当 2CTC 开打 NO ，时 1HTC 。除清动自 :NO 除清已

:FFO 除清未

4022
器较比当 2CTC 开打 NO 止禁，时 / 至出输接直许允

1050 。
:NO 止禁
:FFO 许允

5022 器较比当 2CTC 开打 NO 至出输接直，时 1050 置设
为 FFO 。

:NO 为置设 FFO
:FFO 为置设未 FFO

6022 器较比当 2CTC 开打 NO 至出输接直，时 1050 置设
为 NO 。

:NO 为置设 NO
:FFO 为置设未 NO

7022 器较比次每 2CTC 至出输，开打 1050 的 FFO/NO 状
。倒颠被态

:NO 倒颠
:FFO 倒颠未

8022
器较比当 3CTC 开打 NO 止禁，时 / 至出输接直许允

1050 。
:NO 止禁
:FFO 许允

9022 器较比当 3CTC 开打 NO 至出输接直，时 1050 置设
为 FFO 。

:NO 为置设 FFO
:FFO 为置设未 FFO

0122 器较比当 3CTC 开打 NO 至出输接直，时 1050 置设
为 NO 。

:NO 为置设 NO
:FFO 为置设未 NO

1122 器较比次每 3CTC 至出输，开打 1050 的 FFO/NO 状
。倒颠被态

:NO 倒颠
:FFO 倒颠未

2122
器较比当 3CTC 开打 NO ，时 1HTC 除清动自 :NO 除清已

:FFO 除清未

3122 器较比于用式模法乘择选 1HTC 。
NOFFONOFFO

1:FFO 冲脉 2:NO4x:NO2x:FFO 冲脉4122

式模法乘 1 冲脉 2x 4x 2 冲脉

3122 FFO NO FFO NO

4122 FFO FFO NO NO

D-4 其他特殊实用继电器

号编器电继 能功

0032
用禁出输部外

( 出输 0050 至 )5190
:NO 用禁
:FFO 用禁未

1032
用禁入输新更部外

( 入输 0000 至 )5140
:NO 用禁
:FFO 用禁未

3032
式模间时描扫数常

(在 92MT 值设预入写中 )
:NO 用启
:FFO 用禁

4032 持保描扫个一，时间时描扫数常设预过超间时描扫当 NO 。

5032 。记标始开作操器数计率频

6032 出输冲脉率频定指
:NO 用启
:FFO 用禁

7032 记标误错出输冲脉率频定指

8032 至通接当 NO 。器动驱机电止停时

9032 至通接时作操器动驱机电当 NO 。器动驱机电止停急紧时闭关令指断中由当。

0132 至通接当 (NO 测检沿升上在 ) 。器动驱机电动启时

4132 。记标始开的作操关开换转轮凸

5132 至通接时误错生发作操关开换转轮凸当 NO 。
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号编器电继 能功

0042
0HTC 时计号信部外

FFO 设预部外 FFO
沿降下在

NO
沿升上在

NO
数级

1042 FFO 用使未 NO FFO NO

2042
TNI 性极断中
FFO

沿升上在
FFO

沿降下在
NO

沿升上在
NO

边个两在
3042 FFO NO FFO NO

4042
1TNI 性极断中

FFO
沿升上在

FFO
沿降下在

NO
沿升上在

NO
边个两在

5042 FFO NO FFO NO

6042 0HTC 器数计形环为置设 :NO 置设 :FFO 置设未

7042
当 0HTC 位相视忽时式模法乘无为置设 B 。入输

:NO 位相视忽 B 。数计终始并入输
:FFO 位相用使常照 B 。入输

8042
1HTC 时计设预部外

FFO 设预部外 FFO
沿降下在

NO
沿升上在

NO
数级

9042 FFO 用使未 NO FFO NO

0142
2TNI 性极断中

FFO
沿升上在

FFO
沿降下在

NO
沿升上在

NO
边个两在

1142 FFO NO FFO NO

2142
3TNI 性极断中

FFO
沿升上在

FFO
沿降下在

NO
沿升上在

NO
边个两在

3142 FFO NO FFO NO

4142 1HTC 器数计形环为置设 :NO 置设 :FFO 置设未

5142
当 1HTC 位相视忽时式模法乘无为置设 B 。入输

:NO 位相视忽 B 。数计终始并入输
:FFO 位相用使常照 B 。入输

0052 在配分 02D-VK 关开义定自的上板面口接员作操 ]1F[ 。

1052 在配分 02D-VK 关开义定自的上板面口接员作操 ]2F[ 。

2052 在配分 02D-VK 关开义定自的上板面口接员作操 ]3F[ 。

3052 在配分 02D-VK 关开义定自的上板面口接员作操 ]4F[ 。

4052 在配分 02D-VK 灯示指义定自的上板面口接员作操 1。
5052 在配分 02D-VK 灯示指义定自的上板面口接员作操 2。
6052 在配分 02D-VK 灯示指义定自的上板面口接员作操 3。
7052 在配分 02D-VK 灯示指义定自的上板面口接员作操 4。

8052
02D-VK 式模员作操上板面口接员作操

。变改许允间之式模备设与
:NO 许允 :FFO 许允不

9052 许允 02D-VK 员作操在板面口接员作操
换切间之式模统系与式模

:NO 许允 O :FF 许允不

0152 定指 02D-VK 语示显的板面口接员作操
。言

:NO 语日 :FFO 语英

1152 置设 02D-VK 示提的板面口接员作操
。音

:NO 用使 :FFO 用使不

2152 。统系于用留保

3152 。统系于用留保

5152
息信户用个一示显口窗取获在

0591MD( 容内的 )
:NO 息信示显 :FFO 息信示显不
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注： 不要使用表上未列出的特殊实用继电器。

号编器电继 能功

9062
器电继 0010.oN 至 5110 常间时入输的元单展扩入输

数
sm01:FFO

sµ01:NO

0162
器电继 0020.oN 至 5120 常间时入输的元单展扩入输

数
sm01:FFO

sµ01:NO

1162 器电继 00300.oN 至 5130 间时入输的元单展扩入输
数常

sm01:FFO
sµ01:NO

2162 器电继 0040.oN 至 5140 常间时入输的元单展扩入输
数

sm01:FFO
sµ01:NO

3162 除清的入输开断展扩
:FFO 除清

:NO 除清未

2172
误错开断 :FFO 常正

:NO 开断位单接连在

从式模作操使即
MARGORP ( 序程 )

为变改 NUR ( 行运 )
时闭关源电或 ( 受不

WSMEM 影令指
响) 储被也域区该，

用实了动启使即。存
在是但除清全器电继
情序程个一录记有没
会就除清全行执下况

。域区该除清

4172
用使的路电正纠入输速高

:NO 用使 :FFO 用使未

5172 于处时作操关开机相 NO 态状

0082 口端信通至送发号信断中 A ( 持保时送发 NO 态状 )。

1082 口端信通收接 A 在仅时据数本文收接在，据数本文的 1 持保间期描扫 NO 状
。态

2082
口端信通 A 器电继而据数本文收接当。误错收接据数本文 1082 或 3082 于处

NO 在仅，时置位 1 描扫 NO 持保时 NO 。态状

3082 口端信通 A 在仅，时误错收接据数本文个一生发当。误错收接据数本文 1 扫
持保内间期描 NO 。态状

4082 口端信通 A 始开送发据数本文 ( 持保间期送发 NO 态状 )。

5082 口端信通至送发号信断中 B ( 持保间期送发 NO )。

6082 口端信通收接 B 在仅时据数本文收接在，据数本文的 1 持保间期描扫 NO 状
。态

7082 口端信通 B 器电继而据数本文收接当。误错收接据数本文 6082 或 8082 于处
NO 在仅，时置位 1 描扫 NO 持保时 NO 。态状

8082 口端信通 B 在仅，时误错收接据数本文个一生发当。误错收接据数本文 1 扫
持保内间期描 NO 。态状

9082 口端信通 B 始开送发据数本文 ( 持保间期送发 NO 态状 )。

2182 通接，时常正不生发池电份备当 NO 。置位

3182
数常间时入输置设入输有所的中块模本基在 (除 PSH 入输的用使令指 )。

:FFO 至数常间时入输置设 sm01 。
:NO 考参 0491MD 。数常间时入输定确后然，值的存储中

4182 YEKH 令指 : 。键按重多止禁

5182 YEKH 令指 : 。成完描扫

5192ot0092 YEKH 令指 : 。域区存储
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D-6 特殊存储器目录
■ 临时存储器

属性 R: 读取, W: 写入

■ 通信数据存储器

D-5 存储器开关

bit0 当电源处于 ON 位置时取消错误。 1: 保持
0: 清除它们并开始操作

bit1 当数据存储器/计数器中的值或锁存设置 1: 存储器错误
删除时取消错误信息“MEMORY ERASED” 0: 清除错误并继续操作
(存储器删除)。

bit2 使用内部实用继电器 1000 至 1915 的锁存功能。 1: 是 0: 否

bit3 使用内部实用继电器 3000 至 3915 的锁存功能。 1: 是 0: 否

bit4 使用内部实用继电器 4000 至 4915 的锁存功能。 1: 是 0: 否

bit5 使用内部实用继电器 5000 至 5915 的锁存功能。 1: 是 0: 否

bit6 使用内部实用继电器 6000 至 6915 的锁存功能。 1: 是 0: 否

bit9 在电源接通时清除 DM0000 至 DM0999。 1: 清除 0: 保持

bit10 在电源接通时清除 DM1000 至 DM1899。 1: 清除 0: 保持

bit11 为 CTH0 在 24 和16 位比较器之间切换。 1: 24 位 0: 16 位

bit12 为 CTH1 在 24 和16 位比较器之间切换。 1: 24 位 0: 16 位

bit13 清除计数器、CTH 和 CTC 的值。 1: 清除 0: 保持

bit14 在 KV PLC 中写保护程序。 1: 是 0: 否

bit15 在 KV PLC 中读取保护程序。 1: 是 0: 否

DM1000 至 DM1099 储存接收的文本 (PORT A) (端口 A)

DM1100 至 DM1199 储存要传输的文本 (PORT A) (端口 A)

DM1200 至 DM1299 储存接收的文本 (PORT B) (端口 B)

DM1300 至 DM1399 储存要传输的文本 (PORT B) (端口 B)

TM00 用于算术操作 (DIV/MUL) 属性: R/W

TM01 用于算术操作 (DIV) 属性: R/W

TM02 至 TM27 可由用户使用 属性: R/W

TM28 当进行常数扫描时间操作时储存高于设置值的扫描时间。 属性: R

TM29 储存常数扫描时间操作的设置值。 属性: R/W

TM30 当给出 INT3 中断时储存 CTC0 值。 属性: R

TM31 储存测量扫描时间 (每 10 个扫描的平均值) 属性: R
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DM1485 X #65536 + DM1484
(输出脉冲)

DM1481
(操作)

频率 (Hz)

DM1480
(启动)

0 DM1482 DM1482 时间 (ms)
(加速时间) (减速时间)

设置内容 设置范围

DM1480 上下倾斜控制启动频率 (Hz) 200 至 50000

DM1481 上下倾斜控制操作频率 (Hz) 200 至 50000
(大于启动频率的值 )

DM1482 上下倾斜控制加速/减速时间 (ms) 0 至 4000

DM1484 输出脉冲数 (低16 位) 0 至 65535
(当 DM1485 为 0
时为 2 或更多)

DM1485 输出脉冲数 (高16 位) 0 至 65535

DM1486 设置值错误编码 当一个错误发生时，
储存一个相应的错
误编码 11 至 17。

■ 电机驱动的数据存储器
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附录 E 用于 KV-10R(W)/T(W) 至 80R(W)/T(W)，
KV-300 的设备

E-1 特殊实用继电器

■ 特殊继电器和算术标记编号

■ 用于高速计数器的实用继电器 (0)

*   仅 KV-300 有效。

■ 用于高速计数器的实用继电器 (1)

继电器编号 功能

2100 内部时钟 (KV-300 中 0.8 µs/1 µs) 用于 CTH0
2101 内部时钟 (KV-300 中 6.4 µs/10 µs) 用于 CTH0
2102 内部时钟 (KV-300 中 102.4 µs/100 µs) 用于 CTH0
2103 当比较器 CTC0 为 ON 时，自动清除 CTC0。 1：是 0：否

2104 直接输出至 0500 1：禁用 0：启用

2105 关闭输出至 0500 1：是 0：否

2106 接通输出至 0500 1：是 0：否

2107 反向 (双态) 输出至 0500 1：是 0：否

2108 直接输出至 0500 1：禁用 0：启用

2109 关闭输出至 0500 1：是 0：否

2110 接通输出至 0500 1：是 0：否

2111 反向 (双态) 输出至 0500 1：是 0：否

*2112 当比较器 CTC1 为 ON 时，自动清除 CTC0 1：是 0：否

*2113 在乘法模式中使用 CTH0 1：是 0：否

*2114 为 CTH0 选择乘法模式 1：×4 0：×2
*2115 启用 CTH0 外部重设 1：是 0：否

由比较器
CTC0 (任一
个为 ON 状
态) 直接输
出至 0500
的级数。

由比较器
CTC1 (任一
个为 ON状
态) 直接输
出至 0500
的级数。

继电器编号 功能

2200 内部时钟（KV-300中0.8 µs/1 µs）用于CTH1
2201 内部时钟（KV-300中6.4 µs/10 µs）用于CTH1
2202 内部时钟（KV-300中102.4 µs/100 µs）用于CTH1
2203 当比较器 CTC2 为 ON 时，自动清除 CTC1 1：是 0：否

2204 由比较器 CTC2 直接输出至 0501 1：是 0：否

2205 由比较器 CTC2 直接输出至 0501 的级数 1：ON 0：OFF

继电器编号 功能

2000 未确定

2001 未确定

2002 始终位于 ON

2003 始终位于 OFF

2004 0.01 s 时钟脉冲 (负载循环: 50%)。

2005 0.1 s 时钟脉冲 (负载循环: 50%)。

2006 1.0 s 时钟脉冲 (负载循环: 50%)。

2007 启动时第一次扫描时间为 OFF。
2008 启动时第一次扫描时间为 ON。

2009 当算术操作为负值或产生溢出时为 ON。

2010 当算术操作结果为 0 时为 ON。

2011 当算术操作结果为正值时为 ON。

2012 当算术操作产生一个错误时为 ON。
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继电器编号 功能

2206 选择 INT3 的边。 0：上升沿 1：下降沿

*2207 由比较器 0501 反向（双态）输出至 0501。 1：ON 0：OFF
*2208 直接输出至 0501。 1：禁用 0：启用

*2209 关闭输出至 0501。 1：是 0：否

*2210 接通输出至 0501。 1：是 0：否

*2211 反向 (双态) 输出至 0501。 1：是 0：否

*2212 当比较器 CTC3 为 ON 时，自动清除  CTC1。 1：是 0：否

*2213 在乘法模式中使用 CTH1。 1：是 0：否

*2214 为 CTH1 选择乘法模式。 1：×4 0：×2
*2215 启用 CTH1 外部重设。 1：是 0：否

继电器编号 功能

*2300 禁用输出至所有继电器 (500 至 515, 7000 至 17915) 1：是 0：否

*2301 禁用输入至所有继电器。 1：是 0：否

*2302 停止用户程序的执行 (不停止中断)。 1：停止 0：运行

*2304 常数扫描时间模式 (TM29 中的预设值)。 1：有效 0：无效

*2305 当常数扫描时间超过时仅第一次扫描保持 ON (用 MEMSW 初始化
DM/TM/TMR/C 实用继电器，高速计数器除外)。 1：是 0：否

*2306 遥控断开时接通，当操作启动时清除 (参考 DM9500 至 DM9517)。
*2308 停止 X 轴电机驱动器。

*2309 当 X 轴电机驱动器操作时或处于紧急停止状态时保持 ON。

*2310 开始 X 轴电机驱动器的操作 (通过检测上升沿)。
*2311 停止 Y 轴电机驱动器。

*2312 当Y轴电机驱动器操作时或处于紧急停止状态时保持 ON。

*2313 开始 Y 轴电机驱动器的操作 (通过检测上升沿)。
*2314 转换 ASCII 字符串为 BIN (32位) (通过检测上升沿)。
*2315 转换 BIN (32位) 为 ASCII 字符串 (通过检测上升沿)。
2600-2608 用于转换扩展梯形图为标准梯形图。

*2803 发送中断信号 (ON 期间)。
2804 文本数据接收继电器。当接收文本数据时一个扫描保持 ON。

2805 文本数据溢出。当接收文本数据不正确时一个扫描保持 ON。

2806 文本数据通信错误。当发生文本数据通信错误时一个扫描保持 ON。

*2807 开始文本数据传输。传输期间保持 ON。

*2812 电源错误。

*2813 0108 至 0215 (KV-80) 的输入时间常数设置为 25 µs。 1：是 0：否

0000 至 0009 (KV-300) 的输入时间常数设置为 10 µs。 1：是 0：否

2814 HKEY 指令期间禁用其他按键输入。

2815 终止 HKEY 指令扫描。

2900 - 2915 储存 HKEY 指令按键信息。

由比较器
CTC3 (任一
个为 ON 状
态) 直接输
出至 0501
的级数

* 仅 KV-300 有效。

■ 其它特殊实用继电器

* 仅 KV-300 有效。
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E-3 特殊存储器目录
■ 临时存储器

■ 通信数据存储器

■ A/D 单位和 D/A 单位的存储器 (仅在 KV-300 中有效)

E-2 存储器开关

TM00 存储较高次序产品的 16 位 (MUL 指令），被除数和商 (DIV 指令)。
TM01 存储余数 (DIV指令)。
TM29 不使用。

TM30 当 INT3 执行时立即存储传输的 CTH1 当前值 (仅读)。
TM31 按 0.1 ms 为单位存储当前扫描时间 (仅读)。

DM9000 至 DN9029 存储 A/D单位或 D/A 单位数据 (多至 5 个单位)。

bit0 当电源处于 ON 位置处理所有错误标记。 1：保持
0：清除它们并开始操作

bit1 当 RAM 被清除时进行处理。 1：存储器错误
0：清除错误并继续操作

bit2 保持实用继电器 1000 至 1915。 1：是 0：否

bit3 保持实用继电器 3000 至 3915。 1：是 0：否

bit4 保持实用继电器 4000 至 4915。 1：是 0：否

bit5 保持实用继电器 5000 至 5915。 1：是 0：否

bit6 保持实用继电器 6000 至 6915。 1：是 0：否

bit7 不使用（KV-300：通过 MPS 指令用作继电器 1：无 MPS
2009 至 2011）。 0：有 MPS

bit8 不使用。

bit9 不使用 (KV-300：当操作开始时处理 DM0000 1：清除 0：保持
至 DM4999)。

bit10 不使用 (KV-300：当操作开始时处理 DM5000 1：清除 0：保持
至 DM8999)。

bit11 当操作开始时处理 DM (KV-300：当操作开始 1：清除 0：保持
时处理 DM9000 至 DM9999）。

bit12 当操作开始时重设计数器。 1：是 0：否

bit13 当操作开始时重设高速计数器。 1：是 0：否

bit14 在 KV PLC 中写入保护程序。 1：是 0：否

bit15 在 KV PLC 中读取保护程序。 1：是 0：否

DM0700 至 DM0799 接收文本 (仅在KV-10R(W)/T(W)/16R(W)/T(W)/24R(W)/T(W)/
40R(W)/T(W)/80R(W)/T(W) 中有效)。

DM9200 至 DM9299 接收文本 (仅在 KV-300 中有效)。
DM9300 至 DM9399 接收文本 (仅在 KV-300 中有效)。
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■ I/O 模块错误信息 (仅在 KV-300 中有效)

■ 电机驱动的数据存储器 (仅在 KV-300 中有效)

■ 数据存储器转换 ASCII 字符串为 BIN 值 (32 位)

■ 数据存储器转换 BIN 值 (32 位) 为 ASCII 字符串

DM9500 错误发生的槽号

DM9501 发生错误的槽内通道号

DM9507 至 DM9517 I/O 模块连接信息映象

设置项目 允许设置范围

DM9407 预设置值错误编码 11 至 7
DM9408 X 轴启动频率 (Hz) 153 至 50000
DM9409 X 轴操作频率（Hz） 153 至 50000
DM9410 X 轴加速/减速时间 (ms) 0 至 4096
DM9411 X 轴输出脉冲 (较高次序 16 位) 0 至 65535
DM9412 X 轴输出脉冲 (较低次序 16 位) 2 至 65535
DM9413 Y 轴启动频率 (Hz) 153 至 50000
DM9414 Y 轴操作频率 (Hz) 153 至 50000
DM9415 Y 轴加速/减速时间 (ms) 0 至 4096
DM9416 Y 轴输出脉冲 (较高次序 16 位) 0 至 65535
DM9417 Y 轴输出脉冲 (较低次序 16 位) 2 至 65535

DM9600 存储 ASCII 编码的第一个 DM 号
DM9601 写入 BIN 值要转换成的第一个 DM 号

DM9602 写入 ASCII 编码要转换成的第一个 DM 号
DM9603 存储 BIN 值的第一个 DM 号

DM1485 X #65536 + DM1484
(输出脉冲)

DM1481
(操作)

频率 (Hz)

DM1480
(启动)

0 DM1482 DM1482 时间 (ms)
(加速时间) (减速时间)
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附录 F 采样程序目录

本附录说明默认的采样梯形图程序。采样程序保存于“\LBK\SAMPLE”。

F-1 采样梯形图程序的说明

■ Samp01.ldr
继电器顺序旋转 ON
适用型号 :所有 KV 系列型号 (程序中使用 KV-10。)
说明 :当电源开关接通时，指示器逐个旋转至 ON。

■ Samp02.ldr
指示器自动闪亮
适用型号 :所有 KV 系列型号 (程序中使用KV-10)
说明 :当程序执行时，指示器自动闪亮。

闪亮速度可由 KV 单元内的内置模拟剪裁器设置。

■ Samp03.ldr
理想的紧急停止电路
适用型号 :所有 KV 系列型号 (程序中使用 KV-10)
说明 : 使用 MC 和 MCR 指令提供一个紧急停止电路。

■ Samp04.ldr
KV-AD4 中模拟输入平均值的计算
适用型号 : KV 系列 (KV-300 除外) 和 KV-AD4 (程序中使用 KV-10。)
说明 : 获得 KV-AD4 接收的模拟输入值的平均值。

■ Samp05.ldr
控制汽缸
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 :当工作件到达时，汽缸开始移动，在到达冲程末端时返回。

■ Samp06.ldr
直接时钟脉冲
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 : 高速计数器的基本用法。

■ Samp07.ldr
上/下倾斜程序
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 :该程序用于控制步进电机运动和位置。当达到指定的频率时，电

机缓慢开始旋转并保持运动。在指定的期间逐渐停止。

■ Samp08.ldr
高速输入
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 : 使用 HSP 指令，可稳定检测一个快速输入信号并保持至重设。
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■ Samp09.ldr
各种计时器电路
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 :显示三种典型的计时器电路：延迟、不延迟和单击计时器。

■ Samp10.ldr
单击计时器，使用模拟计时器可调整设置值
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 :该单击计时器的设置值可使用 KV PLC 上的模拟计时器进行调

整。

■ Samp11.ldr
使用 BCD 数字开关设置内部计数器的值
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 :计数器的设置值可使用外部 BCD 数字开关来改变。

■ Samp12.ldr
在 KV-300 CPU 中的定位控制 (带返回起始功能)
适用型号 : KV-300
说明 : 使用内置于 KV-300 单元的定位控制功能进行梯形控制并返回

起始位置。

■ Samp13.ldr
指导 KV-L2 单元之间的直接存储器分享
适用型号 : KV-300 和 KV-L2
说明 : 设置一个 KV-L2 为主台(无程序协议)，设置其他 KV-L2 为子台

(KV 模式)，并在子台上反映主单元上改变的 DM 值。

■ Samp14.ldr
测量脉冲-脉冲间隔的快捷指令
适用型号 : 所有 KV 系列型号 (程序中使用 KV-10)
说明 : 使用 ITVL 指令测量脉冲-脉冲间隔。

■ Samp15.ldr
KV-AN6 中模拟输入平均值的计算
适用型号 : KV-300 和 KV-AN6
说明 : 获得 KV-AN6 接收的模拟输入值的平均值。
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附录 G 快速参考

本附录提供各功能的简略说明以及指令目录 (菜单按钮) 和用于执行这些功能的工具栏。

G-1 编辑器

■ 功能目录和菜单

一个用于执行下列功能的功能和指令（菜单按钮）的简略说明。
详细说明，参阅相应的参考页码。

创立/读取/保存一个文件

创立一个新的梯形图程序 File ➔ New 2-29

创立一个新的梯形图程序。

读取一个梯形图程序 File ➔ Open 2-33

读取一个保存的梯形图程序。

保存一个梯形图程序 File ➔ Save 2-32
➔ Save As

重写一个现有梯形图程序或用一个新的名称保存一个新文件。

在另一种格式读取和保存一个文件 File ➔ Other Format 2-33
保存/读取一个助记目录。
保存/读取另一个 LDR 文件中的注释。
按文本格式保存一个梯形图程序。

校验一个梯形图程序 File ➔ File-Verify File 2-36

在编辑器中以/按一个保存的程序比较/校验一个程序。

输入/删除符号和连接线

输入/删除符号
Edit ➔  Symbol Input ➔  Symbol Selective Input 2-38

➔  Symbol Direct Input 2-41
➔  Delete Symbol 2-42

输入/删除梯形图符号。
可用两个输入方法。第一个方法中，可在指令选择窗口指定一个指
令文字型和一个指令文字编码。在第二个方法中，当输入一个指令
文字的第一个字符后可在显示的直接输入窗口直接输入。

输入 “a 接点”/“b 接点”/线圈

Edit ➔  Symbol Input ➔  a (N.O.) Contact Input 2-42

➔  b (N.C.) Contact Input

➔ a (N.O.) Contact OR Input

➔ b (N.C.) Contact OR Input

➔ Coil Input 2-43

➔ b (N.C.) Contact Coil Input

指定一个设备，并输入一个 a 接点/b 接点/线圈，或删除一个现有的
a 接点/b 接点。

改为连接线编辑模式 Edit ➔  Edit Connection Line 2-44
改为连接线编辑模式，可以输入或删除连接线。在选择连接线编辑模式
后再选择则改为正常编辑模式。(在正常编辑模式中，不能输入或删除
连接线)。“编辑连接线”也可以从右击显示的上托菜单中选择。
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输入/删除符号和连接线

输入/删除连接线
Edit ➔ Symbol Input ➔ Vertical Connection Line 2-44

➔ Horizontal Connection Line

➔ Delete Vertical Connection Line 2-45

➔ Delete Horizontal Connection Line

➔ Horizontal Connection Line to End of Line
输入或删除一个连接线。该操作在使用鼠标或键盘时可更快地进行。

在当前位置改变一个设备

在当前位置改变一个设备
Edit ➔ Change Device at Cursor Position 2-43

在光标位置改变一个设备。

编辑操作

撤消最后一个编辑操作 Edit ➔ Undo 2-45

取消最后一个编辑操作。

重新进行最后一个取消的编辑操作 Edit ➔ Redo 2-45

重新进行最后一个取消的操作。

插入/删除行

输入/删除连接行 Edit ➔ Insert Empty Line 2-57
➔ Delete Line

在当前光标位置插入一个空行，或在当前光标位置删除行。

编辑注释/标签

编辑注释/标签
Comment ➔ Edit Comment/Label 2-46

从设备目录输入/删除/改变注释/标签。

改变标签名称/当前设备的注释
Comment ➔ Change Label Name of Current Device 2-49

➔ Change Comment of Current Device
在当前光标位置改变设备的标签名称或注释。
编辑线注释

Comment ➔ Edit Line Comment 2-50
将线注释输入一个程序。

改变注释内的梯形图线
Comment ➔ Change Ladder Line into Comment 2-51

将梯形图线作为注释。转化期间忽视改变注释内的梯形图线。

复制/移动/删除

复制/移动/删除一个选择的范围 Edit ➔ Cut 2-54

➔ Copy

➔ Paste

复制/移动/删除一个选择的范围。

系统设置

系统设置 Edit ➔ System Settings 2-71

设置自动文件保存功能、反向转换错误校验等的目录。
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转移/查找/更换

转移 Edit ➔ Jump 2-58
移动光标至指定的线、指定的步数、程序的上部、程序的底部等。
光标也可以由记录线来移动。

查找指令文字/操作数 Edit ➔ Find 2-62

查找指定的指令文字/操作数。

更换操作数 Edit ➔ Replace Operand 2-64
通过指定更换宽度用另一个操作数更换一个现有的操作数。
转换 a-b 接点 Edit ➔ Convert a-b (N.O.-N.C.) Contacts 2-65
通过指定一个操作数将一个 a 接点转换为一个 b 接点或一个 b 接点转
换为一个 a 接点。

连接屏面

连接上屏面和下屏面 Edit ➔ Link Screens 2-28

滚动上屏面时滚动下屏面。

编辑目录

编辑助记目录 Edit ➔ Edit List 2-67

使用一个助记目录按电路快单位编辑一个梯形图解。

显示使用状态

显示使用状态 Edit ➔ Usage Information 2-70
显示继电器、计时器/计数器、比较器/高速计数器、数据存储器和临时
数据存储器的使用状态。

输入和开发宏

创立宏文件 File ➔ New 2-72

创立一个新的宏文件。

输入和开发宏文件 File ➔ Macro Input ➔Develop 2-74

开发一个宏。

编译和错误显示

编译 Compile ➔ Compile 2-75

编译梯形图程序进入机器编码。

错误显示 Compile ➔ Show Error 2-76

显示编译期间产生的错误编码。

双线圈校验 Compile ➔ Check Double Coil 2-76

校验双线圈部分。
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用 PLC 通信

设置 PLC 通信参数
File ➔ Communication Setup ➔ Set PLC Communication Parameters 2-136

设置用 PLC 通信需要的参数。

传输、读取和校验程序
File ➔ Monitor ➔ Compile  ➔ Transfer ➔ Monitor 2-139

 ➔ Read Program from PLC 2-141
 ➔ Verify against PLC Program

传输编译的梯形图程序至 PLC，并切换至监控器模式。读取从 PLC
传输的程序。根据编辑器上的一个程序校验 PLC 的一个程序。

脱机时编辑设备
File ➔ Monitor ➔ Edit Offline Device 2-142

在监控器模式中脱机时编辑设备。

改变模式

监控器
File ➔ Monitor ➔ PLC Monitor 2-139

 ➔ Compile ➔ Transfer ➔ Monitor
改变为监控器。注意如果出现编译错误监控器不能启动。

模拟器 File ➔ Simulator 2-86
改变为模拟器。如果梯形图程序还没有编译，在模拟器启动时编译。

改变显示模式

设置显示模式和改变范围
View     ➔ Display Mode 2-19

➔ Zoom In
➔ Zoom Out
➔ Show Label
➔ Show Comment

设置标签/注释的显示尺寸和显示状态。
设置显示模式设置有效的范围。 2-21

改变梯形图解的颜色

改变梯形图解的颜色
View ➔ Change Ladder Diagram Color 2-82

设置梯形图解的颜色布置。

设置/改变型号

设置和改变型号 File ➔ Change Models 2-17

设置/改变连接的 PLC 的型号。

打印输出

打印输出和打印预览 File ➔ Print 2-132
       ➔ Print Preview 2-131

打印出梯形图解、助记目录、标签/注释/参考和设备使用状态。打印输
出范围可以精确指定。

从一个程序退出

从一个程序退出 File ➔ Exit

从一个程序退出。
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■ 工具栏目录

New (新建) 创立一个新的梯形图程序。

Open file (打开文件) 打开一个保存的梯形图程序。

Save file (保存文件) 保存 (重写) 一个现有梯形图程序。

Cut (剪切) 剪切指定的范围 (和复制到剪贴板)。

Copy (复制) 复制指定的范围 (到剪贴板)。

Paste (粘贴)  粘贴剪切或复制的范围 (从剪贴板)。

Print (打印) 打印出梯形图解、助记目录等 (打开打印输出设置对
话栏)。

Undo (撤消) 取消最后的编辑操作。

Redo (恢复) 重新进行 UNDO （撤消） 功能取消的最后的编辑操作。

Edit Comment/Label 编辑注释/标签（显示注释/标签编辑对话框）
(编辑注释标签)

Edit Line Comment 输入线注释。(显示线注释输入对话框)
(编辑线注释)

Show/hide comment 指定是否显示或隐藏注释。
(显示或隐藏注释)

Jump to specified 转移到指定的线/步进。
line/step (跳转到指
定的线/步进)

Find (寻找) 指定要查找的指令文字/操作数。

Replace Operand 指定要更换的操作数。
(更换操作数)

Usage Information 显示设备使用状态。
(使用状态)

Edit List (编辑目录) 编辑助记目录。

Compile (编译) 执行编译。

Show Error (显示错误) 显示编译期间发生的错误目录。

Transfer to PLC 传输程序至 PLC，并改变为监控器模式。
(传输程序至 PLC)

Read from PLC 从 PLC 读取程序。
(从 PLC 读取)

PLC Monitor 从 PLC 读取程序，并改变为监控器模式。
(PLC 监控器)

Simulator (摸拟器) 改变为模拟器模式。

Display Mode (显示模式)设置显示尺寸和显示模式（用于标签、注释等）。

Operating procedure 显示联机求助信息。
 (操作程序)



附录

2-185

1

附
录

C KV-H6WE2-UM

■ 功能菜单目录

a (N.O.) Contact 在当前光标位置输入一个 a (N.O.) (常开) 接点 OR (或)。
OR Input (a (常
开) 接点 OR 输入)

b (N.C.) Contact 在当前光标位置输入一个 b (N.C.) (常闭) 接点 OR (或)。
OR Input (b (常
闭) 接点 OR 输入)

a (N.O.) Contact Input 在当前光标位置输入一个 a (N.O.) (常开) 接点。
(a (常开) 接点输入)

b (N.C.) ContactInput 在当前光标位置输入一个 b (N.C.) (常闭) 接点。
(b (常闭) 接点输入)

Coil Input (线圈输入) 在当前光标位置输入一个线圈。

b (N.C.) Contact Coil 在当前光标位置输入一个 b (N.C.) 接点线圈。
 Input (b (常闭) 接点
线圈输入)

Vertical Connection 从当前光标位置向下绘制一个垂直连接线。
 Line (垂直连接线)

Delete Vertical 在当前光标位置删除垂直连接线。
Connection Line
(删除垂直连接线)

Horizontal 从当前光标位置向下绘制一个水平连接线。
Connection Line
(水平连接线)

Delete Horizontal 在当前光标位置删除水平连接线。
Connection Line
(删除水平连接线)
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新建 [Ctrl] + [N]
打开 [Ctrl] + [O]
保存 [Ctrl] + [S]
打印 [Ctrl] + [P]
PLC 监控 [Ctrl] + [F1]
转换 → 传输 → 监控器 [Ctrl] + [F8]
模拟器 [Ctrl] + [F2]

■ 快捷键目录 [   ] 表示空格键。

● 文件

撤消 [Ctrl] + [Z]
恢复 [Ctrl] + [Y]
符号选择输入 [Tab]
符号直接输入 [ENTER] (可输入助记)
删除符号 [   ]

[BackSpace]
[Delete]

a (N.O.) 接点输入 [F5]
b (N.C.) 接点输入 [Shift] + [F5]
a (N.O.) 接点 OR 输入 [F4]
b (N.C.) 接点 OR 输入 [Shift] + [F4]
线圈输入 [F7]
b (N.C.) 接点线圈输入 [Shift] + [F7]
垂直连接线 [F8], [ / ]
水平连接线 [F9], [ �]
水平连接线至线端 [Ctrl] + [Tab]
删除垂直连接线 [Shift] + [F8]
删除水平连接线 [Shift] + [F9]
宏输入 → 开发 [Shift] + [F1]
范围选择 [Shift] + [向上][向下][向左][向右]
剪切 [Ctrl] + [X]

[Ctrl] + [Delete]
复制 [Ctrl] + [C]

[Ctrl] + [Insert]
粘贴 Ctrl] + [V]

[Shift] + [Insert]
插入空行 [Shift] + [ENTER]
删除行 [Shift] + [Delete]
编辑连接线 [Ctrl] + [K], [\]
在光标位置改变设备 [Esc]
编辑目录 [Ctrl] + [F3]

● 编辑
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● 注释

转移到顶部 [Ctrl] + [Home]
转移到底部 [Ctrl] + [End]
转移到记录行 [Ctrl] + [J]
行记录 [Ctrl] + [L]
下一块 [Ctrl] + [向下]
前一块 [Ctrl] + [向上]
发现 [Home]

[End]
搜索 [Ctrl] + [F]
向后搜索 [F2]
向前搜索 [F3]
向后搜索 OUT [Shift] + [F2]
向前搜索 OUT [Shift] + [F3]
更换操作数 [Ctrl] + [R]
转换 a-b (N.O.-N.C.) 接点 [Ctrl] + [A]
使用信息 [Ctrl] + [E]

编辑注释/标签 [Ctrl] + [F7]
编辑行注释 [Ctrl] + [ENTER]
改变梯形图行至注释-设置 [Ctrl] + [Q]
改变梯形图行至注释-取消 [Ctrl] + [W]
改变当前设备的标签名称 [Ctrl] + [B]
改变当前设备的注释 [Ctrl] + [N]

● 编译

编译 [Ctrl] + [F9]
显示错误 [Ctrl] + [F10]

● 查看

放大 [Ctrl] + [PageDown]
缩小 [Ctrl] + [PageUp]
显示标签 [Ctrl] + [BackSpace]
显示注释 [Ctrl] + [   ]

● 求助

使用求助 [F1]
指令文字 [Ctrl] + [1]

● 梯形图窗口的操作

关闭窗口 [Ctrl] + [F4]
在窗口之间移动 [Ctrl] + [F6]
在窗口之间移动 (相反方向) [Ctrl] + [Shift] + [F6]
在面板之间移动 [F6]
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G-2  模拟器

■ 功能目录和菜单

对执行下列功能的功能和指令 (菜单按钮) 的简略说明。
详细说明，参阅相应的参考页码。

读取/保存一个窗口

读取和保存监控器所有窗口 File ➔ Open Window 2-111
➔ Save Window As

读取监控器所有文件。用一个新文件名 (扩展名：kal)
保存当前监控器所有窗口。

读取和保存一个注册监控窗口
File➔ Open Window 2-121

➔ Save Window As 2-120
读取注册监控文件。用一个新的文件名 (扩展名：kre)
保存当前注册监控窗口。

设置模拟器操作状态

设置和删除断开条件
Settings ➔ Set Break Condition 2-98
Edit ➔ Delete Break Condition

设置等待时间 Settings ➔ Wait Time 2-130

设置扫描时间 Settings ➔ Scan Time 2-100
设置看门狗计时器 Settings ➔ Set Watch Dog Timer 2-100

执行和停止模拟器

执行扫描 Execute ➔ Execute Continuous Scan 2-92
➔ Execute One Scan 2-93

可使用两个执行模式：连续扫描和一次扫描。

执行步 Execute ➔ Execute Continuous Step 2-102
➔ Execute One Step 2-103
➔ Execute High-speed Step 2-104
➔ Execute Continuous Step in Reverse
➔ Execute One Step in Reverse

可以使用五个执行模式：连续步、一步、高速步、反向连续步

和反向一步。 当执行步时，显示助记窗口。

停止和暂停步/扫描的执行 Execute ➔ Stop 2-108
➔ Pause

重设 Execute ➔ Reset 2-108
根据“MEMSW”给出的规格将当前值返回默认值。

设备全清除 Execute ➔ Device All Clear ➔ DM All Clear 2-108
➔ Latching Relay All Clear
➔ Counter All Clear

将各设备的当前值设置为 0 (OFF)。

梯形图监控

显示一个梯形图监控窗口 File ➔ Ladder Monitor 2-144
显示当前模拟梯形图程序的梯形图解。

在该窗口，位设备的 ON/OFF 状态可被改变，其属性

(位计数和基数) 可使用对话栏改变。

注册设备改为另外监控器 2-144
关于注册，选择要监控的设备，然后按压左鼠标键

拖放至注册监控窗口或全监控窗口。
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转移或搜索找编辑 Edit ➔ Jump in Ladder Monitor 2-105
➔ Search in Ladder Monitor 2-106
➔ Search for Device at Cursor Position in Ladder Monitor 2-107

搜索指令文字和操作数，或转移至指定行。

全监控

显示一个全监控窗口 File ➔ Monitor All 2-109
显示设备、当前值、预设值、接点、线圈和注释。

在该窗口，位设备的 ON/OFF 状态可以被改变，其属性 (位计数、基
数和注释类型）可使用对话栏改变。

注册设备 2-113
欲在全监控窗口显示的设备可通过将其从梯形图解拖放或通过使用对话
栏进行注册。

改变设备的当前值/预设值 2-118
使用对话栏，可指定当前值并写入设备。当前保存值/预设值
可以改变。

重设设备
Edit ➔ Reset Device in Monitor All/Registration Monitor 2-118

将当前选择的设备返回默认值。

注册监控

显示一个注册监控窗口 File ➔ Registration Monitor 2-119
显示注册设备的当前值、注释和计时图。在该窗口，位设备的 ON/OFF
状态可以被改变，其属性 (位计数、基数和注释类型)  可使用对话栏改
变。

注册设备 2-122
要显示在注册监控窗口的设备可通过将其从梯形图拖放或通过使用对话
栏而注册。

设置计时图表的比例数
Settings ➔ Set No. of Scales for Timing Chart 2-129

允许你设置将在计时图表上显示的扫描/步的数 (比例数)。
拷贝和删除设备属性

Edit ➔ Copy Device Attribute in Registration Monitor 2-125
 ➔ Delete Device in Registration Monitor 2-127

将为当前选择的设备设置的属性（位计数、基数和注释类型）复制到另
一个设备，或删除该设备。

分类设备 Edit ➔ Sort Devices in Registration Monitor 2-127
按顺序分类 (安排) 设备。

重设设备 Edit ➔ Reset Device in Monitor All/Registration Monitor 2-127
将选择的设备返回其默认值。

计时图表 2-128
注册设备的计时图在执行扫描或步进时显示 (仅在对话栏的“注释”设
置为“No”时)。

助记目录窗口

在执行步进时，显示一个助记目录窗口以指示当前执行的助记行改变。 2-101

当前值/预设值/属性 (对话栏)
使用对话栏改变设备类型、设备号、当前值、预设值等，或记录新设备 2-96
至每个监控器。设置位计数、基数和注释显示方法。
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改变模式

编辑器 File ➔ Editor 2-87

变为编辑器模式。

清除设备和选择编辑器
文件 ➔ 清除设备并转到编辑器 2-87

清除设备，然后变为编辑器。

打印输出

打印注册监控 File ➔ Print 2-132
打印注册监控当前显示的内容。
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■ 工具栏目录

Clear Device and Go 清除设备值并返回编辑器。
to Editor (清除设备并
返回编辑器)

Editor (编辑器) 返回编辑器而不清除设备值。

Show Ladder 当显示两个或更多窗口时，始终在底部显示梯形图监
Monitor Alwaysat 控器窗口。当从梯形图监控将设备注册至全监控或注
Bottom (始终在底部 册监控时，该功能是很方便的。
显示梯形图监控)

Ladder Monitor 显示一个梯形图监控窗口。
(梯形图监控)

Registration Monitor 显示一个新的注册监控窗口。
(注册监控)

Monitor All (全监控) 显示一个新的全监控窗口。

Open Window 读取一个保存的全监控文件或注册监控文件。
(打开窗口)

Save Window 用一个新名称保存一个全监控文件或注册监控文件。
(保存窗口)

Execute Continuous 反向连续执行一个步进 (连续取消)。
Step in Reverse
(反向执行连续步进)

Execute One Step in 反向执行一个步进 (取消)。
Reverse (反向执行一个
步进)

Execute One Step 执行一个步进。
(执行一个步进)

Execute Continuous 连续执行步进。
Step (执行连续步进)

Execute High-speed 高速执行步进。
Step (执行高速步进)

Pause (暂停) 暂时停止所有操作。

Stop (停止) 停止所有操作。

Execute Scan 执行一个扫描。
(执行扫描)

Execute Continuous 连续执行扫描。
Scan(执行连续扫描)



附录

2-192

附
录

C KV-H6WE2-UM

Break Condition 注册中断条件并显示中断条件窗口。
(中断条件)

Wait Time (等待时间) 设置等待时间。

No. of Scales for 设置显示在注册监控器计时图表上的标度数 (一个标
Timing Chart (一个 度)。
扫描或一个指令)

Reset (复位) 将当前值返回默认值。如果操作已进行停止操作。

Using Help (使用求助) 显示联机求助。
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■ 快捷键目录 [   ] 表示空格键。

● 文件

编辑器 [Ctrl] + [F1]
清除设备并转到编辑器 [Ctrl] + [F2]

● 编辑

搜索梯形图监控 [Ctrl] + [F]
向后搜索 [F2]
向前搜索 [F3]
向后搜索 OUT [Shift] + [F2]
向前搜索 OUT [Shift] + [F3]

● 执行

执行连续扫描 [F5]
执行一个扫描 [F9]
执行连续步进 [Shift] + [F8]
执行一个步进 [F8]
执行高速步进 [Shift] + [F9]
反向执行连续步进 [Shift] + [F7]
反向执行一个步进 [F7]
暂停 [F4]
停止 [Shift] + [F5]
复位 [F10]

● 查看

放大显示 [Ctrl] + [PageDown]
缩小显示 [Ctrl] + [PageUp]

● 求助

使用求助 [F1]
指令文字 [Ctrl] + [1]
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● 梯形图监控的操作

在窗格间移动 [F5]
移动光标 [向左] • [向右] • [向下] • [向上]
按块单位移动光标 [Ctrl] + [向下]•[向上]
移动光标至行头 [Home]
移动光标至行尾 [End]
反转位设备 [   ]
读取值至对话栏 [ENTER]
切换数制 (十进制 ↔ 十六进制) [Ctrl]+[E]

● 注册监控的操作

移动光标 [向下]•[向上]
在定时图表垂直移动光标 [向左]•[向右]
在定时图表改选垂直光标的选择 [Tab]
反转位设备 [   ]
读取值至对话栏 [ENTER]
删除设备 [Delete]

● 全监控的操作

移动光标 [向下]•[向上]
移动位光标 [向左]•[向右]
(仅用于二进制 16-bit 位设备)
反转位设备 [   ]
读取值至对话栏 [ENTER]

● 助记窗口的操作

移动光标 [向下]•[向上]
设置/取消断点 [   ]

● 中断条件窗口的操作

移动光标 [向下]•[向上]
改变/注册中断条件 [ENTER]
删除中断条件 [Delete]

● 所有窗口其他普通操作

关闭窗口 [Ctrl] + [F4]
在窗口间移动 [Ctrl] + [F6]
在窗口间移动 (相反方向) [Ctrl] + [Shift] + [F6]
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G-3 监控器

■ 功能目录和菜单

以下给出监控器可用功能的简略说明。
关于详细说明，参阅相应参考页码。

读取/保存一个窗口

读取和保存全监控窗口 File ➔ Open Window 2-111
➔ Save Window As

读取全监控所有文件。 用一个新文件名 (扩展名：kal) 保存当前
全监控窗口。

读取和保存一个注册监控窗口
File ➔ Open Window 2-121

➔ Save Window As 2-120
读取一个注册监控文件。用一个新文件名 (扩展名：kre)
保存当前注册监控窗口。

读取和保存所有改变 File ➔ Open Window 2-150
➔ Save Window As

用一个新文件名保存从 PLC 读取的设备设置，或读取保存的设备
设置 (扩展名：kdv)。

设置通信讯参数

设置串行端口 Settings ➔ Serial Port 2-136
设置串行通信端口和波特率 (通信速度)。
设置机号 (仅适用于 KV-300 系列) 2-137

PLC 操作模式

设置 PLC 操作模式 Execute ➔ RUN 2-147
➔ STOP

选择 PLC 操作模式。

启动和停止监控器

启动监控器 Monitor ➔ Start Monitor 2-145
当监控器启动后，传输到 PLC 的程序的操作状态实时显示在梯形
图监控窗口、注册监控窗口和全监控窗口。

停止监控器 Monitor ➔ Stop Monitor 2-145

停止监控器。

禁用输入更新/输出

禁用输入更新 Monitor ➔ Disable Input Refresh 2-149
禁用 PLC 输入继电器 (输入更新) 的读取。
* 该设置仅在 KV-300 和 Visual KV 系列可用。

禁用输出 Monitor ➔ Disable Output 2-149
禁用输出状态的更新。
* 该设置仅在 KV-300 和 Visual KV 系列可用。
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初始化设备

设备全清除
Settings ➔ Device All Clear ➔ DM All Clear 2-154

➔ Latching Relay All Clear
➔ Counter All Clear

设置各设备的当前值为 0 (OFF)。

梯形图监控

显示一个梯形图监控窗口 File ➔ Ladder Monitor 2-144
显示当前模拟的梯形图程序的梯形图解。
在该窗口，位设备的 ON/OFF 状态可以改变，其属性(位计数和基数)
可使用对话栏改变。

注册设备至另一个监控器 2-114
注册时选择一个要监控的设备。 然后按住鼠标左键，拖放至注册
监控窗口或全监控窗口。

转移和查找 2-58
Edit ➔ Jump in Ladder Monitor

➔ Search Ladder Monitor
➔ Search for Device at Cursor Position in Ladder Monitor

查找指令文字和操作数或转移到指定行。

全监控

显示全监控窗口 File ➔ Monitor All 2-109
显示设备、当前值、预设置值、接点、线圈和注释。
在该窗口，位设备的 ON/OFF 状态可以改变，其属性 (位计数、基数
和注释类型) 可使用对话栏改变。

注册设备 2-114
显示在全监控窗口的设备可通过从梯形图拖放或使用对话栏注册。

改变设备的当前值/预设置值 2-118
使用对话栏，可指定当前值并写入设备。当前保存值/预设置值可以改变。

注册监控

显示一个注册监控窗口 File ➔ Registration Monitor 2-119
显示注册设备的当前值、注释和定时图表。在该窗口，位设备

的 ON/OFF 状态可以改变，其属性 (位计数、基数和注释类型)
可使用对话栏改变。

注册设备 2-122
注册显示屏窗口显示的设备可通过从梯形图拖放或使用对话栏来注册。
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设置定时图表的换算数
Settings ➔ Set No. of Scales for Timing Chart 2-129

允许你设置计时图表上显示的换算数。

拷贝和删除设备属性
Edit ➔ Copy Device Attribute in Registration Monitor 2-125

➔ Delete Device in Registration Monitor 2-127
将当前选择设备中设置的属性 (位计数、基数和注释类型) 复制到另一
个设备，或删除该设备。

设备分类 Edit ➔ Sort Devices in Registration Monitor 2-127
按顺序分类 (安排) 设备。

计时图表 2-128
在执行扫描或步进时显示注册设备的计时图表
(仅在对话栏上的 “Comment” (注释) 设置为 “No” 时)。

改变当前值/预设置值/属性 (对话栏)
使用对话栏改变设备类型、设备号、当前值、预设置值等， 2-96
或注册新设备至各监控器。设置位计数、基数和注释显示方法。

一次改变所有当前值

一次改变所有当前值 File ➔ Change All 2-150
读取 PLC 指定范围的设备，在联机基础上改变当前值，
然后将改变的当前值写入 PLC。

改变模式

编辑器 File ➔ Editor 2-142
终止与 PLC 的通信，改变为编辑器模式。

打印输出

打印注册监控器 File ➔ Print 2-132
打印注册监控器当前显示的内容。
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■ 工具栏目录

Editor (编辑器) 退出监控器并返回编辑器。

Show Ladder 当显示两个或更多窗口时，始终在底部显示梯形图监
Monitor Always 控窗口。当在另一个窗口进行操作时该功能是很方便的。
(始终在底部显示梯
形图监控)

Ladder Monitor 显示一个梯形图监控窗口。
(梯形图监控)

Registration 显示一个注册监控窗口。
Monitor (注册监控)

Monitor All (全监控) 显示全监控窗口。

Change All (全部改变) 指定要改变的设备当前值的范围，然后全部同时改变。

Open Window 打开全监控文件或注册监控文件。
(打开窗口)

Save Window 用一个新文件名保存全监控文件或注册监控文件。
(保存窗口)

Stop Monitor (red) 停止监控器。
(停止监控器 (红色))

Start Monitor (green) 启动监控器。
(启动监控器 (绿色))

Run (运行) 设置 PLC 为 RUN (运行) 模式。

Stop (停止) 设置 PLC 为 STOP (停止)模式。

No. of Scales for 设置定时图的换算数。
Timing Chart
(定时图的换算数)

Using Help 显示联机求助。
(使用求助)
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▲ ▲

■ 快捷键目录 [   ] 表示空格键。

● 文件

● 编辑

● PLC 模式

● 监控器

● 查看

● 求助

编辑器 [Ctrl] + [F1]

在梯形图监控内搜索 [Ctrl] + [F]
向后搜索 [F2]
向前搜索 [F3]
向后搜索 OUT [Shift] + [F2]
向前搜索 OUT [Shift] + [F3]

RUN (运行) [Shift] + [F7]
STOP (停止) [Shift] + [F6]

启动监控器 [F4]
停止监控器 [F3]

放大显示 [Ctrl] + [PageDown]
缩小显示 [Ctrl] + [PageUp]

使用求助 [F1]
指令文字 [Ctrl] + [1]

● 梯形图监控窗口的操作

在窗格间移动 [F6]
移动光标 [向左]•[向右]•[向下]•[向上]
按块单位移动光标 [Ctrl] + [向下]•[向上]
移动光标至行首 [Home]
移动光标至行尾 [End]
反转位设备 [   ]
读取值至对话栏 [ENTER]
切换数制 (十进制   十六进制) [Ctrl]+[E]
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● 注册监控窗口的操作

● 全监控窗口的操作

● 所有窗口其他共有操作

移动光标 [向上]•[向下]
在定时图垂直移动光标 [向左]•[向右]
反转位设备 [   ]
读取值至对话栏 [ENTER]
删除设备 [Delete]

移动光标 [向下]•[向上]
移动位光标 [向左]•[向右]
(仅用于二进制 16-bit 位设备)
反转位设备 [   ]
读取值至对话栏 [ENTER]

关闭窗口 [Ctrl] + [F4]
在窗口间移动 [Ctrl] + [F6]
在窗口间移动 (反向) [Ctrl] + [Shift] + [F6]
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附录 H 编程注释

本附录说明创立梯形图程序的重点和注意事项。

H-1 必须修改的电路

• 左侧显示电路不能编程。根据右侧所示修改。

• 左侧所示电路禁用 0500 输出。按右侧所示进行修改，仅禁用一个扫描输出。

• 如果在两个位置使用相同线圈，后位优先，前位线圈被忽视。

• 左侧显示电路不能编程。根据右侧所示修改。

• 左侧显示电路不能编程。根据右侧所示修改。
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H-2 编程注意事项

• A 线圈输出或定时器/计数器不能直接连接至一个总线。当要求使用一个输出线圈
或一个定时器/计数器时，插入一未用内部实用继电器的 b 接点，未用特殊实用继
电器的 b 接点，或一个特殊实用继电器 2002 (始终为 ON) 作为一个哑元。

• A 接点不能连接至一根输出线。

• 确认每个接点/线圈位于从一个总线至一个输出线的通路上。确认没有未连接部分。

• 确认并联连接未产生非法短路。

• 含输出线圈的电路不能并联连接。

但是，如果并联连接的各电路分别连接于一根输出线时，可使用并联连接。
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图 a

图 b

A B C D E F G

H

I

A B C D E F G

H

IA

H-3 不能解编译的程序

当一个梯形图程序里的并联连接包括一个返回操作时，产生如下图 a 所示的解编译
(反向编译) 错误。要防止这个，改变梯形图解以消除返回操作，或分隔并联连接。
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附录 I 使用文件目录

本附录说明执行 KV 梯形建筑者软件时产生的文件。

数据目录中产生的文件

********.LDC 用于梯形建筑者的源文件
********.LDR 梯形图源文件 [KV IncrediWare (DOS) 可用]
********.RCM 接点注释 1 文件 [KV IncrediWare (DOS) 可用]
********.CM2 接点注释 2 文件
********.CM3 接点注释 3 文件
********.LVL 标签文件
********.ERR 错误文件 [KV IncrediWare (DOS) 可用]
********.MNM 助记目录文件 [KV IncrediWare (DOS) 可用]
********.COD 编码文件 [KV IncrediWare (DOS) 可用]
********.KRE 注册监控信息文件
********.KAL 全监控信息文件
********.KDV 改变所有信息文件
********.INT 梯形图注释传输范围设置文件
********.KEN MDI 设置文件

工作目录产生的文件

当软件正常关闭时这些文件自动保存和删除。

********.$DC 梯形图源文件
********.$CM 接点注释 1 文件
********.$M2 接点注释 2 文件
********.$M3 接点注释 3 文件
********.$M3 接点注释 3 文件
********.$VL 设备标签文件

注: 通过 KV 梯形建筑者或 KV IncrediWare (DOS) 以外的任何软件编辑或删除上
述带扩展名的文件时，该文件有可能工作不正常。
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附录 J 对经常性通信错误的处理措施

当你使用用 KV 梯形建筑者监控 KV 系列时，如果经常发生通信错误，请检查下列各点。

注: 各参数设置因电脑不同而异。关于设置细节，参阅电脑随机说明手册或咨询电
脑厂家。

● 视窗系统是否允许使用具体的通信端口？

检查视窗是否已激活 KV 梯形建筑者所指定的通信端口。

● 调制解调器没有指定一个具体的通信端口吗？

有些个人电脑可能为一个通信端口指定一个调制解调器。如果这样，则断开该调制
解调器或使用另一个通信端口。

● 串行鼠标没有指定一个具体的通信端口吗？

如果你使用带一个串行鼠标的膝上型电脑并用一个通信电缆更换鼠标以启动通信，
则通信端口未被激活。要解决这个问题，如果你的电脑有另一个可用的通信端口，
则用 KV 梯形建筑者指定这个端口。如无可用通信端口，则断开鼠标并重新启动
KV 单元。

● 没有指定红外通信吗？

有些个人电脑可能为通信端口指定了红外通信。在这种情况下，如果你的电脑另有
可用通信端口，则用 KV 梯形建筑者指定该端口。如无可用通信端口，则取消红
外通信设置。

● 暂停功能没有激活吗？

如果用视窗 95 激活暂停功能，通信会失败。不要使用暂停功能。
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索引 — 仅适用 Visual KV 用户

以下索引带说明，供参考。

索引 — 仅适用 Visual KV 用户

途用 题标 码页

A

出输冲脉率频的要需按 能功出输冲脉率频定特 822-3

B

器数计前当存保 / MD 至值 MOR 式模存保和式模入写 69-1

C

EC 取获，志标 得取 EC 求要的志标 )2(

卡储存入存保，序程 能功 [与 )10(E3P-VK 用使时同 ] 032-1

算计，量容序程 数计节字用使已算计 4-3

习学，量容序程 量容序程 4-3

至接连，备设他其或器感传 VK 序程线布的元单体主 76-1

池电换更，卡储存 池电换更 832-1

量容，卡储存 量容储存 032-1

D

耗消流电 格规般一 4-1

级多 MD 行执，作操器较比 式模器较比级多 432-3

G

率频量测，器数计速高 能功器数计率频 132-3

“为设重，器数计速高 0 值的外以” 能功设预 512-3

值前当取读，器数计速高 值前当的器数计速高取读 112-3

格规，器数计速高 格规器数计速高 802-3

“为值置设，器数计速高 0” 位复的器数计速高 412-3

冲脉出输用使，器数计速高 出输冲脉钟时接直 732-3

围范量测高提，器数计速高 42 器数计速高位 122-3

源入输择选，器数计速高 法方入输数计 212-3

器数计形环作用，器数计速高 能功器数计行环 522-3

值置设预定指，器数计速高 值的器较比器数计速高置预 112-3

据数收接，脑电人个 据数本文收接 813-3

从，脑电人个 VK 至据数输传 据数本文送发 913-3

J

变改，数常间时入输元单本基 能功改修的数常间时入输 32-3

习学，令指本基 令指本基 43-3

配分，号编器电继 号编器电继配分 8-3

元单本基至配分，号编器电继 单清器电继 5-3

元单展扩至配分，号编器电继 单清器电继元单展扩 6-3

器时计 / 数大最，器数计 器时计 / 单清器数计 81-3

护保，点接 护保点触 96-1

至输传，解注点接 CLPVK 能功存保见意系联 72-3

能功称名件部，口窗入接 能功和称名的分部各口窗入接 28-1

示显误错，口窗入接 表列误错 273-1

值备设的中其变改，口窗入接 式模备设 78-1

式模的中其变改，口窗入接 置设和式模择选 / 定锁键位复 28-1

器调微字数用使，口窗入接 式模器调微字数 48-1

度速择选备设高提，口窗入接 能功速快 38-1

示指的中其示显，口窗入接 息信户用 79-1

误错的中其示显，口窗入接 态状误错和息信误错 79-1

在，口窗入接 NUR 和 MARGORP 换切间式模）止停（ CLPVK 式模统系 49-1
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途用 题标 码页

K

VK 输传令指的间脑电人个和 令指信通 / 表列应响 013-3

VK 装安板面 板面至接连接直元单将 66-1

VK 用 REDLIUBREDDAL)SOD(eraWidercnIVK , 用使 项事意注的本版往以件软持支图形梯用使 )5(

)10(E3P-VK , 用使令指入输 表列号编能功 ( 序顺母字 ) 14-3

)10(E3P-VK , 能功用可 表列号编能功 612-1

)10(E3P-VK , 作操 作操程编的本基 002-1

作操查检，元单展扩 息信接连的元单展扩 57-1

用禁元单展扩 能功止禁出输 62-3

接连，元单展扩 接连 VKlausiV 元单展扩品产列系 17-1

置设，数常间时入输元单展扩 数常间时入输的元单展扩 67-1

数大最的接连要，元单展扩 量数的元单接连可 37-1

用，元单展扩 CA 平齐高其置设元单本基型 垫衬元单展扩 66-1

L

配分能功，储存据数时临 器储存据数时临 12-3

M

动驱，机电冲脉 序程置设数参 552-3

P

目项置设，能功器数计率频 备设的用使器数计率频 132-3

通普 VK 处同不，列系 规常与 VK 容兼的备设围外品产列系 )4(

Q

入输制强 FFO/NO 换切无 能功止禁新刷入输 62-3

S

间时描扫 间时描扫 3-3

自用禁，出输 VK 出输的 能功用禁出输 62-3

配分能功，储存据数 器储存据数 91-3

习学，令指术算 令指术算 83-3

T

至配分能功，器电继用实殊特 录目器电继用实殊特 68-3

态状变改时令指术算用使，器电继用实殊特 器电继用实殊特变改令指术算用 ( 记标术算 ) 态状 681-3

格规，口端信通 格规信通 603-3

目项置设，能功关开换转轮凸 备设的用使能功关开换转轮凸 332-3

用使，能功关开换转轮凸 VK 为 能功关开换转轮凸 332-3

Y

习学，令指用应 令指用应 63-3

Z

述概，冲脉钟时接直 述概出输冲脉钟时接直 732-3

目项置设，冲脉钟时接直 置设出输冲脉行进器较比器数计速高用 832-3

冲脉钟时接直 / 用使冲脉出输 1:1 FFO/NO 率比 FFO/NO 率比 1:1 832-3

度宽冲脉变可用使冲脉出输，冲脉钟时接直 度宽冲脉变可 832-3

目项置设，能功出输冲脉率频定指 备设的出输冲脉率频定指于用 822-3

间期误错生发，输传令指 表码代误错 613-3

值前当的器数计速高取读，断中 取获入输 591-3

件条入输置设，断中 性极的断中置设入输部外用 591-3

时断中个几行执，断中 序顺先优的断中 691-3

令指的用使能不，序程断中 令指的用使能不 691-3

习学，令指断中 令指断中 14-3

态状器电继出输的关无间时描扫与，令指断中 入输接直 / 出输 791-3

索引 — 仅适用 Visual KV 用户
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按英文数字排列

A/D 转换器 .......................... 1-312 [AN6], 1-334 [AD4]
A/D 换算表 .......................... 1-408 [AN6], 1-357 [AD4]
ADD/@ADD: 加 ................................................... 3-150
ANB: 与栏 ................................................................ 3-58
AND: 与 ................................................................... 3-58
ANDA/@ANDA: 与 A .......................................... 3-159
ANL: 与载入 ............................................................ 3-61
ASC/@ASC: ASCII 转换 ....................................  3-183
C: 计数器 ................................................................  3-72
CALL: 子程序调用 ................................................. 3-122
CMP/@CMP: 比较 ............................................... 3-146
COM/@COM: 补数 .............................................. 3-171
CON: 连接 ............................................................. 3-102
CTC: 计数器比较器 ............................................... 3-204
CTH0 和 CTH1 内部时钟 ..................................... 3-278
CTH1: 16 位计数器 ............................................... 3-204
D/A 转换器 .......................... 1-312 [AN6], 1-334 [AD4]
D/A 换算表 .......................... 1-408 [AN6], 1-357 [DA4]
DEC/@DEC: 减量存储 ......................................... 3-172
DI: 中断禁止 ........................................................... 3-193
DIFD: 鉴别向下 ....................................................... 3-78
DIFU: 鉴别向上 ......................................................  3-78
DIN 轨道 (安装) .................................................... 1-180
DIV/@DIV: 划分 ................................................... 3-150
DMX/@DMX: 多路分解器 .................................... 3-176
DW: 数据存储写入 ................................................. 3-136
EI: 中断启用 ........................................................... 3-193
END: 末端 ............................................................... 3-94
ENDH: 末端高 ......................................................... 3-94
ENDS: 末端阶段 .................................................... 3-106
EORA/@EORA: Or A 除外 ................................. 3-164
FOR: 重复开始 ...................................................... 3-125
HKEY: 16 按键输入 .............................................. 3-131
HSP: 高速 ................................................................ 3-86
INC/@INC: 增量存储 ............................................ 3-172
INT: 中断 ............................................................... 3-192
I/O（输入/输出）分配 ........................................... 1-187
I/O（输入/输出）继电器编号分配 ............................ 3-22
ITVL: 间隔计时器 ................................................... 3-117
JMP: 跳转 .............................................................. 3-106
KEEP: 保持 ............................................................. 3-80
KV-10/16/24/40/80 ..................... 1-167, 1-175, 1-177
KV-300 ..................................................... 1-166, 1-170
KV-AD4 ................................................................ 1-334
KV-AN6 ................................................................ 1-312
KV-B16R/B16S/C32T ........................................ 1-172
KV-C16X/C32X ................................................... 1-171
KV-DA4 ................................................................ 1-334
KV-L2 ................................................................... 1-240
KV-R1A/R16X/R16R/R16T/R8X/R8R/R8T 1-173, 1-174
KV-U4/U5 ................................................ 1-168, 1-169
KV 模式 [KV-L2] .................................................. 1-253
LD: 载入 ................................................................... 3-57
LDA/@LDA: 载入 A ............................................. 3-140
LDB: 载入栏 ............................................................ 3-57
MC: 主控制 .............................................................. 3-89
MCR: 主控制重设 .................................................... 3-89
MEMSW: 存储开关 ................................................. 3-92
MPP: 出栈 ............................................................. 3-103

索引 — 仅适用于 KV-300, KV-10/80 用户

索引 — 仅适用 KV-300, KV-10/80 用户

MPS: 推进 ............................................................. 3-103
MPX/@MPX: 多路器 ............................................ 3-176
MRD: 读取 ............................................................. 3-103
MUL/@MUL: 乘 ................................................... 3-150
NEXT: 重复末端 .................................................... 3-125
NOP: 无操作 ............................................................ 3-94
OR: Or (或) ............................................................. 3-60
ORA/@ORA: Or (或) A ....................................... 3-161
ORB: Or 栏 ............................................................. 3-60
ORL: Or 载入 .......................................................... 3-63
OUB: Out 栏 ........................................................... 3-65
OUT: Out ................................................................ 3-65
RASC/@RASC: 反向 ASCII 转换 ....................... 3-183
RES: 重设 ................................................................ 3-66
RET: 子程序返回 ................................................... 3-122
RETI: 返回中断 ..................................................... 3-192
RLA/@RLA: 左旋转 A .......................................... 3-169
ROOT/@ROOT: 平方根 ...................................... 3-185
RRA/@RRA: 右旋转 ............................................ 3-169
RS-232C 电缆连接 ............................................... 3-307
RS-232C 协议 ....................................................... 3-306
RS-422A [KV-L2] ................................................ 1-248
SBN: 子程序登录 ................................................... 3-122
SET: 设置 ................................................................ 3-66
SFT:移动 ................................................................. 3-82
SLA/@SLA: 左移位 A .......................................... 3-166
SRA/@SRA: 右移位 A ......................................... 3-166
STA/@STA: 储存 A ............................................. 3-140
STE: 步进末端 ....................................................... 3-114
STG: 阶段 .............................................................. 3-106
STP: 步进 .............................................................. 3-114
SUB/@SUB: 减 .................................................... 3-150
TBCD/@TBCD: 传输 BCD.................................. 3-180
TBIN/@TBIN: 传输 BIN ....................................... 3-180
TMH: 0.01-s 计时器 ............................................... 3-68
TMIN: 剪裁器 In .................................................... 3-138
TMR: 0.1-s 计时器 .................................................. 3-67
TMS: 1-ms 计时器 .................................................. 3-69
UDC: Up-Down 计数器 .......................................... 3-76
W-DE: 等待下边沿 .................................................. 3-98
W-OFF: 等待 OFF .................................................. 3-96
W-ON: 等待 ON ...................................................... 3-96
W-UE: 等待上边沿 .................................................. 3-98
@TMIN: 剪裁器设置 ............................................. 3-138
@xxxx: 鉴别 .......................................................... 3-137
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A
安装环境 .................................................................. 1-64

B
编程实例 ................................................................. 3-324
波特率 ..........................................2-136, 1-247 [KV-L2]

C
尺寸 ....................................................................... 1-404
串行通信 ................................................................. 3-306
传输文本数据 .......................................................... 3-319
存储卡 ................................................................... 1-230
错误代码列表 ......................................................... 1-372

D
定位控制 ................................................................. 3-296
端口1/端口2 [KV-L2] ............................................ 1-245

G
高速计数器 ............................................................. 3-276
故障排除 ................................................................ 1-372

H
宏 .............................................................................. 2-72
环境要求 .................................................................. 1-64

J
基本指令 ............................................... 3-34, 3-42, 3-56
继电器编号目录 ....................................................... 2-167
计时器/计数器 ........................................................ 2-167
接口 [RS-232C] .................................................... 3-306
接收文本数据 .......................................................... 3-318

K
扩展梯形图 ............................................................... 3-29

L
连接器接线 .............................................................. 1-72
临时存储器 .................................................. 2-172, 2-176

M
模块名称 ................................................................ 1-175

N
内部实用继电器 ........................................................ 3-11
内部注册 ................................................................. 3-135

索引 — 仅适用 KV-300, KV-10/80 用户

S
输出继电器 ............................................................... 3-10
数据存储 ................................................................... 3-19
数据存储分配 ............................................................ 3-19
数据存储或继电器的间接地址 ................................ 3-127
输入继电器 ..................................................................3-9
算术指令 ............................................. 3-38, 3-48, 3-134

T
特殊实用继电器 ...................................................... 2-174
通信 ............................................................ 2-135, 3-306

W
外围设备 ................................................................ 1-176
无程序模式 [KV-L2] .............................................. 1-292

X
系统规格 [KV-300 系列] ....................................... 1-392
系统规格 [Visual KV 系列] ................................... 1-382
系统配置 ................................................................ 1-166
系统配置 (存储卡) ................................................. 1-196
显示接口模式 [KV-L2] .......................................... 1-244

Y
应用指令 ............................................... 3-36, 3-45, 3-95

Z
暂停信号 ................................................................. 3-308
站 No. [KV-L2] ..................................................... 1-246
直接时钟脉冲 .......................................................... 3-276
指令 [串行通信] ...................................................... 3-310
指令列表 ......................................................... 3-34, 3-42
中断指令 ................................................................. 3-268
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ACCS ................................................................... 1-234
KV 和个人电脑间的数据通讯 ................................. 3-306
ON/OFF 显示屏 [P3E] ........................................ 1-215
RS-232C ....................................................................  2-9

索引 — 软件/P3E (手持编程器)

L
临时存储器 ............................................................... 3-21

M
模拟器 ...................................................................... 2-84
模拟器功能 ............................................................... 2-84

Q
启动和退出监控器 .................................................. 2-139
启动和退出模拟器 .................................................... 2-86
清除 [P3E] ............................................................ 1-232
全清除 [FNC60] [P3E] ......................................... 1-217

R
软件的启动和退出 .................................................... 2-16

S
扫描时间显示屏 [P3E] .......................................... 1-212
设置打印范围 ............................................................ 2-77
输入符号 ................................................................... 2-37
双线圈检查 ............................................................... 2-76
手持编程器清除 (P3E CLEAR):
     [FNC61] .......................................................... 1-217
手持编程器 KV-P3E ............................................. 1-196
搜索 .......................................................................... 2-58
所有数据存储清除
    (DM ALL CLEAR):  [FNC64] [P3E] .............. 1-219
所有锁存继电器重设
   (L-RELAY ALL RST): [FNC65] [P3E] ........... 1-219

T
梯形图监控 ............................................................. 2-144
替换操作数 ............................................................... 2-64
跳转 .......................................................................... 2-58
跳转到注册的行 ........................................................ 2-59
退出软件 ................................................................... 2-16
脱机编辑器启动 (OFFLINE EDITOR):
     [FNC67] [P3E] ............................................... 1-221
脱机编辑器停止 (QUIT OFF-L EDIT):
     [FNC68] [P3E] ............................................... 1-221

W
文件管理 ..................................................................  2-29

X
显示模式 ..................................................................  2-19
写入数据存储 (DM WRITE):
     [FNC72] [P3E] ............................................... 1-227
寻找程序 [P3E] ..................................................... 1-207

Y
移动光标 [P3E] ..................................................... 1-202

Z
暂停信号 ................................................................. 3-308
注释/标签 .................................................................. 2-46
转换 N.O.(常开)/N.C. (常闭) ...................................... 2-65

索引 — 软件/P3E (手持编程器)

按中文拼音排列

A
安装梯形建筑者 .......................................................... 2-9

B
编辑屏幕 ................................................................... 2-27
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保修与不承诺声明：

(1) 对于产品在材料和制造工艺方面的缺陷，KEYENCE 公司承诺向用户提供自发货之日起一 (1) 年期
限的保修。我们向购方所展示的机型或样机，目的仅在于向用户介绍常用的产品种类和产品的一般性能，而
非承诺实际提供的产品一定会与所展示的机型或样机完全相同。任何有缺陷的产品都必须由购方自费运送至
KEYENCE 公司进行检查和维修，或由购方提供 KEYENCE 公司到现场检查、维修所需的费用。
KEYENCE 公司在经过检查之后可自主决定是向购方退还购货款项还是对有缺陷的产品予以免费更换或修
理。此项保修条款不适用于因购方的不当安装、连接、修理、未经授权的改造、错误应用和不当的装运等原
因 (例如接触强电流，置于过热、过冷、潮湿、振动或户外露天环境中) 而造成的故障与缺陷。自然磨损的
部件不在保修范围之内。

(2) KEYENCE 公司随时为您提供各种产品的使用建议。但这些建议仅供参考，而对于其所购产品是否
与其预定用途相符，应由购方承担全部责任。KEYENCE 公司不对任何因产品使用而造成的损失承担责任。

(3) 除非有明确的书面规定，否则提供给购方的产品和任何样机 (“产品／样机”) 不得在公共场所和客
运环境中用作安全装置或自动防止故障装置。如果购方将产品／样机用于这些用途或以任何方式对产品进行
了错误使用，KEYENCE 公司将不承担由此引发的任何责任，另外，购方需要保障 KEYENCE 公司免于
承担产品／样机错误使用的责任或由此造成的损失。

(4) 除了在此所述的保修条款外，本产品／样机交付时不附带任何其它保修条款。KEYENCE 公司对一
切明示的、暗指的和法定的、包括但不限于各种适销性、特殊用途的适用性以及不侵犯专利权方面的保证均
明确予以否认。在任何情况下，KEYENCE 公司及其所属实体对任何个人和实体的任何直接的、间接的、
附带的、惩罚性的或特殊损失 (包括但不限于以下损失，任何因产品使用、业务中断、信息丢失、数据丢失
或不准确、利润损失、储蓄损失、采购替代产品、服务或技术所带来的成本等原因造成的) 均不承担任何责
任，也不为购方对本产品的使用或无能力使用所引发或与之相关的事务承担责任，即使 KEYENCE 公司或
其所属实体在被告知第三方有可能向购方提出赔偿金或任何其它索赔要求的情况下也不例外。在某些权限
中，上述的某些保修免责条款或损失限制有可能不适用。

购方的转让义务：如果购方所购买的产品／样机被转售或交付给第三方，购方必须向第三方提供本文件的
副本以及所有技术规范、手册、产品目录单、宣传页和随产品／样机一同提供给购方的所有其它书面材料。
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本手册的结构:
Visual KV 系列产品用户手册由 3 个单独的手册组成；1-安装，2-支
持软件， 3-编程。
请根据您的用途阅读各手册。

支持软件

1. 简介

2. 编辑器

3. 模拟器

4. 监控器

5. 附录

编程

1. 编程

2. 指令

3. 中断

4. 高速计数器

5. 定位控制

6. 中断、高速计数器、定
位控制

7. 串行通信

8. 编程范例

索引

安装

1. 配置和规格

2. 系统安装

3. 接入窗口

4. KV-D20 操作者接口
面板

5. KV-10/80 硬件

6. 手持编程器

7. KV-L2 串行接口模块

8. KV-AN6 模拟输入/输
出模块

9. KV-AD4/DA4 模拟
输入/输出模组

10. 故障排除

11. 附录
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