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                      第一章 FEPG 前后处理简介 

1-1 FEPG.GID 简介 

FEPG.GID 是一个通用、方便、友好的在科学和工程领域进行计算分析的前

后处理系统，我们的 FEPG 系统整合了 FEPG.GID 后，前后处理功能得到了很大的

加强。FEPG 与 FEPG.GID 之间相互传递数据，FEPG 产生 FEPG.GID 的前处理菜单

及数据存储格式，FEPG.GID 可以生成 FEPG 分析计算所需的模型数据文件，FEPG

计算后所生成的结果文件即为后处理文件，由 FEPG.GID 读入后进行数据结果的

图形显示和操作。两者之间的关系如图 1-1 所示。 

 

 

 

 

 

 

 

 

 

图 1-1  FEPG.GID 和 FEPG 关系示意图 

FEPG.GID 具有图形交互的可操作性，并且可以处理及可视化数值模拟的前

后处理数据。它包括几何模型的建立，边界条件的施加，有限元网格划分，以及

其他的一些参数的输入。并且可以进行数值计算结果数据可视化的后处理操作。 

FEPG.GID 有着强大的前处理和后处理结果分析功能，这里主要针对

FEPG.GID 前后处理界面和菜单作简单的说明，并辅助以几个小例题加以说明。

具体详细的使用帮助，可以参见 GID Reference Manual,以及 GID User Manual。 

GID User Manual 下载地址： 

ftp://gid.cimne.upc.es/pub/gid/Docs/GiD7-UserManual.pdf.zip 

 

GID Reference Manual 下载地址： 

ftp://gid.cimne.upc.es/pub/gid/Docs/GiD7-ReferenceManual.pdf.zip 

本书主要分为以下几个部分 

1、前处理功能；（第二章） 

2、后处理功能；（第三章） 

3、例题讲解。 （第四章） 

 

 

 

 

 

FEPG

Preprocess Postprocess

FEPG.GID

Input File Output File

(Solver)



 2

第二章 前处理功能 
第一节 主界面说明 

§1-1 主界面 
 

用户可以直接运行 FEPG.GID，也可以通过 FEPG 中的 Pre/Post>PreProc 来

启动 FEPG.GID。FEPG.GID 的基本界面如图 2-1 所示。 

 
图 2-1 界面 

 

§1-2 工具条 
 

 
图 2-2 工具条 

 
工具条是一种作为方便用户操作的辅助菜单，其每一项功能都可以在相应的

菜单中找到对应的命令，所以在这里，只介绍每一项的功能及对应菜单的位置，

具体的功能及操作在菜单对应项中具体说明，用户可以参考下面的章节。 
可以看到，本工具条被 分割为五部分 ，每一个部分分别对应以下的菜

单项 。 
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§1-2-1 第一部分： 
功能： 

 
图 2-3 视图工具条 

 
对应的菜单： 

放大：View>Zoom>In 
缩小：View>Zoom>Out 
居中：View>Rotate>Center 
刷新：View>Redraw 
旋转：View>Rotate>Trackball 
移动：View>Pan>Two point 

§1-2-2 第二部分 
功能 

 
图 2-4 创建几何模型工具条 

对应菜单： 
    创建直线：Geometry>Create>Line 
    创建圆弧：Geometry>Create>Arc 
    创建样条曲线：Geometry>Create>NURBS Line 
    创建多折线：Geometry>Create>Polyline 

§1-2-3 第三部分 
功能： 

 
图 2-5 创建模块工具条 
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对应菜单 
创建样条曲面：Geometry>Create>NURBS Surface>By contour 
创建体：Geometry>Create>Volume>By contour 
创建模块：Geometry>Create>Object 
GID 中还有的几何模块有： 

 
图 2-6 模块工具条 

 
对应的菜单： 
    矩形：Geometry>Create>Object>Rectangle 
    多边形：Geometry>Create>Object>Polygon 
    圆：Geometry>Create>Object>Circle 
    球：Geometry>Create>Object>Sphere 
    圆柱：Geometry>Create>Object>Cylinder 
    圆锥：Geometry>Create>Object>Cone 

多棱柱：Geometry>Create>Object>Prism 
圆环：Geometry>Create>Object>Torus 

 

§1-2-4 第四部分 
 
功能 

 
图 2-7 删除和察看属性工具条 

 
对应菜单： 
删除：Geometry>Delete 
属性：Utilities>List 
其中删除可以根据几何模型的种类，分为删除关键点，线，面，体。 
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       功能： 

 
图 2-8 删除工具对象条 

 
        对应菜单 
        删除关键点：Geometry>Delete>Point 
        删除线：Geometry>Delete>Line 
        删除面：Geometry>Delete>Surface 

删除体 Geometry>Delete>Volume 
删除所有类型：Geometry>Delete>All Types 

 
其中属性功能可以察看关键点，线，面，体，以及节点和单元的属性。 
 

功能 

 
图 2-9 属性工具条 

 
对应菜单 
    在几何模型界面（具体参见下一工具条操作） 
    察看关键点属性：Utilities>List>point 
    察看线属性：Utilities>List>line 
    察看面属性：Utilities>List>Surface 
    察看体属性：Utilities>List>Volume 
    在网格模型界面（具体参见下一工具条操作） 
    察看节点属性：Utilities>List>Node 

            察看单元属性：Utilities>List> Element 
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§1-2-5 第五部分 
功能： 

 
图 2-10 几何模型和网格模型切换工具条 

对应菜单： 
       Meshing>Mesh View。 

在不同的模型情况下，有些菜单的功能项会有相应的变化，例如上面提到的

属性工具菜单的变化。 

§1-3 菜单 

 
图 2-11 

 
FEPG.GID 的所有功能，用户都可以在此处找到，菜单按照如下功能分出。 
z File：文件操作 
z View：视图选择与调整 
z Geometry：几何模型操作 
z Utilities：辅助操作 
z Data：施加边界条件 
z Meshing：划分网格操作 
z Calculate：数据导出操作 
z Help：帮助文档 

下面我们按照菜单的顺序，对菜单中的一些常用的功能，以及使用方法做一

个简要的介绍，如果你想了解更多，更详细的功能，可以查找 GID Reference 

Manual，或者可以在帮助中找到。 

第二节 File 菜单 

§2-1File 主菜单 

 
图 2-12 
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在 File 菜单中，主要被分割为如下几个部分 
z 文件操作 
z 打印 
z 前后处理切换 
z 退出 

 

§2-2 文件操作 
 

在文件操作中，主要可以分为整体文件操作和部分文件操作。 
z 整体文件操作中，主要让用户保存数据、打开数据。 
z 部分文件操作中，主要让用户实现数据的导入、导出。 

如下几个菜单主要是对整体文件的保存打开操作。 
 
New 

 
    Files>New  新建文件 
打开一个没有文件名的新项目，但如果你在该新建的项目中做了一些操作或

者修改，那么当退出的时候，系统要求用户给一个文件名。 
 
Open 

 
    Files>Open 打开文件 
打开一个已存在的项目。通常要求用户打开的是一个带有.gid 后缀的文件

夹。 
 
Save 

 
    Files>Save  保存文件 
保存一个文件，当用户建立了一个模型并且做了一些操作或者修改的时候，

保存的文件都将保存在，一个以项目名为名字加.gid 的一个文件夹中。这包括所

有的几何模型信息、边界条件信息、网格模型信息等。 
当保存的时候，用户只需要给出项目名称就可以，系统将自动加上一个.gid

的后缀，一旦保存后，在该文件夹中，会有一些 ASCII 码或者二进制码的文件，

建议用户不要直接打开文件修改，以免丢失一些信息或者破坏文件，用户可以在

GID 的图形界面中去修改。 
 
Save as 

 
    Files>Save As 文件另存 
另存文件，用户可以将当前的项目更改一个项目名。系统将自动重新建立一

个.gid 的文件夹，并将该项目的文件保存在此文件夹中。 
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§2-3 导入导出 
 

对部分文件的操作中，又可以分为导入、导出。 
 
§2-3-1 导入 

 
图 2-13 

在导入菜单中可以分为如下几个部分 
 
z 导入其它几何模型（CAD）软件格式文件 
z 导入网格模型 
z 导入 GID 的文件 

 

§2-3-1-1 导入 CAD 模型文件 
 

IGES 
Files>Import>IGES 

    导入一个 IGES 文件，在 GID 中可以到 5.1 版本格式的 IGES 文件，主要可

以导入 IGES 如下部分的模型信息。 
 
模型编号和类型： 
 

100    Circular arc 
102    Composite curve 
104    Conic arc ( ellipse, hyperbola and parabola) 
106    Copious data ( forms 1, 2, 12 and 63) 
108    Plane (form1 bounded) 
110    Line 
112    Parametric spline curve 
114    Parametric spline surface 
116    Point 
118    Ruled surface 
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120    Surface of revolution 
122    Tabulated cylinder 
124    Transformation matrix ( form 0) 
126    Rational B-spline curve 
128    Rational B-spline surface 
140    Offset surface entity 
141    Bounded entity 
142    Curve on a parametric surface 
143    Bounded surface 
144    Trimmed surface 
308    Subfigure definition 
402    Associativity instance 
408    Singular subfigure instance 

 
关于几何模型导入的容差设定，可以参考菜单 Utilities>Preferences。容差的

设定可以控制模型导入的精度，比如，在 IGES 中有两个点，他们的距离在容差

的范围内，那么他们就会合并为一个点，否则就会创建一个新的点。同样适用于

类似的读入线、面、体的操作。一个适合的容差可以较好的读入模型，并且没有

破坏原始模型的信息。否则的话就会存在一些小的问题，比如断线，重叠面，交

叉面，交叉线等等的出现。 
 

DXF 
        Files>import>DXF 

导入一个 DXF 文件，GID 可以导入一个 AutoCAD 2000 版本格式的 DXF
文件，除了 DXF 文件中有关体的信息外，其他的大部分信息都可以导入。类似

于 IGES 导入操作一样，这里同样须要设定一个容差，具体的功能和方法常见

IGES 的同部分内容。当然，用户也可以做一次 collapse（合并操作），他一样可

以需要一个容差，然后在此容差的范围内，做一些几何模型的自动修补、合并功

能，可以参见菜单 Utilities>Collapse 部分的说明。 
Parasolid  

Files>import>Parasolid 
Gid 可以导入 Parasolid 11.0 版本格式的 ASCII 码或者二进制码的文件，对应

于 Parasolid 的文件的后缀分别为.x_t（ASCII 格式）.x_b（二进制码格式）。同样

的关于容差的一些使用参见 Files>Import>IGES 内容。 
 

ACIS 
Files>import>ASIC 

在 Gid 中只可以导入 ACIS5.0 版本 ASCII 格式的 SAT 文件，其文件的后缀

名为.sat。类似的容差设定参看 Files>Import>IGES 内容。 
 
VDA 

Files>import>VDA 
在 Gid 中只可以导入 VDA2.0 版本格式的文件。类似的容差设定参看

Files>Import>IGES 内容。 
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§2-3-1-2 导入网格模型文件 
 

Nastran Mesh 
Files>import>Nastran Mesh 

Gid 可以导入 Nastran6.8 版本的网格文件中的大部分信息。可导入的信息如

下： 
 

实体名称    （注释） 
GRID 
CBAR 
CBEAM    （转换为 2 节点的杆单元） 
CELAS2    （转换为 2 节点的杆单元） 
CHEXA      (8 或者 20 节点) 
CONM2 
CORD1C 
CORD1R 
CORD1S 
CORD2C 
CORD2R 
CORD2S 
CQUAD4 
CROD    （转换为 2 节点的杆单元） 
CTRIA3 
CTETRA 

 
注意：如果当前 GID 项目已经有了网格信息，那么可以有两种操作。 

z 删除已有的 GID 网格模型。 
z 保留以后的模型，将即将导入的网格模型作为补充，添加到已有的

网格模型中。 
在 GID 导入的 Nastran 网格模型中，不会读入已有的单元属性参数，比如材

料号，材料属性、边界条件等，因此用户需要重新施加边界、材料号等数据。 
 

STL Mesh 
Files>Import>STL Mesh 

Gid 可以导入 STL 的网格数据文件，并且可以支持二进制码的文件。在导入

的时候，也需要设定容差，具体关于容差的说明参看 Files>Import>IGES 的内容。 
 

GID Mesh 
Files>Import>GID Mesh 

通过这个命令，GID 可以打开一个 ASCII 格式的 GID 网格数据文件，该文

件可以是用户通过 Files>Export>Gid Mesh 文件导出，或者用户按照以下的格式，

写一个 Mesh 文件。 
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mesh dimension = 3 elemtype tetrahedra nnode = 4 
coordinates 
1 0 0 0 
2 3 0 0 
3 6 0 0 
4 3 3 0 
5 3 1.5 4 
6 3 1.5 -4 
7 1.5 0 2 
end coordinates 
elements 
1  1  2  4  5  
2  2  3  4  5  
3  1  4  2  6  
4  2  4  3  6  
5  1  2  5  7  
end elements 

在文件中 Nnode 表示每一个单元的节点数，Dimension 只可以是 2 或者 3，2
表示节点是一个二维点，即只有 X，Y 两个坐标值；3 表示一个三维点，有 X、

Y、Z 三个坐标值。 
并且文件中的单元类型（elemtype）必须是以下的类型  

Linear                     直线单元 
Triangle                    三角形单元       
Quadrilateral               四边形单元 
Tetrahedra                 四面体单元 
Hexahedra                 六面体单元 

 
Surface Mesh 

Files>Import>Surface Mesh 
GID 可以导入 STL 以及 GID 的网格数据作为 Surface mesh，注意在这里只

可以导入三角形单元、四边形单元。GID 将导入的网格转化为点、线、面，并将

它作为一个几何模型的边界，例如，一个体的边界面，然后模型可以在这个基础

上修改，并且在划分网格的时候，可在该面重新划分。在划分网格的时候，需要

输入一个最小角度，作为边界面划分网格时，在该面生成网格的角度，必须大于

该最小角度。   
 

§2-3-1-3 导入 GID 文件 
 

Batch file 
Files>Import>Batch File 

在某些时候，用户不想使用图形交互的方式，那们可以根据书写命令的方式，

然后用 GID 读入。书写的格式就和在命令行输入命令的方式一样。 
下面有一个例子，比如用户知道了一些关键点坐标，然后需要将这些点连接
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成一条直线，那么我们就可以写这么一段： 
geometry create line 

3.7 4.5 8 
2 5 9 
4,5,6 
 ... 
1 7 0.0 
escape 

可以使用任何一种类型的文本编辑器，然后保存为.bch 后缀的文件就可以

了。然后打开 GID 导入，即可。 
 
Insert GID geometry 

Files>Import>Insert GID geometry 
使用这个命令，用户可以将一个已有的 GID 项目导入到当前的项目中，以

便操作和修改。 
 

§2-3-2 输出 
 

在输出菜单中可以分为如下几个部分 
z 输出其它几何模型（CAD）软件格式文件 
z 输出网格模型 
z 输出 GID 的文件 
z 输出计算数据文件 

 
 
 
 
 
 
 
 
 

图 2-14 

 

§2-3-2-1 输出其他 CAD 格式文件 
 

IGES 
Files>Export>IGES 

GID 可以按照 IGES5.1 的格式输出，可以输出点、线、面，体的信息将会丢

失。可以导出的内容如下： 
 

116 Point 
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110 Line 
102 Composite curve 
126 Rational B-spline curve 
128 Rational B-spline surface 
142 Curve on a parametric surface 
144 Trimmed surface 

DXF 
Files>Export>Dxf 

GID 可以导出 AUTOCAD2000 版本格式的 DXF 文件，可以导出的数据类型

有点、线。由于 Autocad2000 不支持 Trimmed NURBS Surface，所有将不输出面

的信息。 
 

§2-3-2-2 输出网格文件 
 

GID Mesh 
         Files>Export>Gid Mesh 

输出为 GID 的网格数据文件，GID 可以通过 Files>import>GID Mesh 导入。 
 

§2-3-2-3 输出 GID 的文件 
 

Txt Data report 
    Files>Export>Txt Data Report 
导出 ASCCI 格式的数据文件，其中包含了该项目的所有信息，包括几何实

体信息，边界条件信息，网格信息等等。 
 

ASCII  Project 
         Files>Export>Ascci Project 

数出 ASCII 格式的数据文件，类似于 SAVE 功能，但是这里输出的是一个

ASCII 格式的文件，而 Save 输出一个二进制码的文件，这里是为了方便用户在

不同系统之间的数据传输。 
 

On Layers 
         Files>Export>On layers 

可以输出 Layer 中处于开（On）状态图层上的几何信息，关于 Layer 的功能

可以参见 Utilities>layer 中的介绍。 
 

§2-3-2-4 输出计算数据文件 
 

Calculation files 
        Files>Export>Calculation files 

输出一个数据文件，以便 FEPG 计算。其功能类似于 Calculate>Calculate 请
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参见该节介绍。 
 

Using template.bas (only mesh)  
        Files>Export>using template.bas(only mesh) 
可以根据扩展菜单中列出的格式导出对应的网格数据文件，这里输出的只是网格

的数据文件，不包含单元属性、材料参数等信息。这些格式包括： 
z DXF 
z Nastran 
z STL 
z XML 

 

§2-4 打印文件 
 

Print to files 
Files>Print to files 

可以将用户当前的项目的图形，输出为一些图形格式的文件，可以输出的格

式包括： 
z Ps screen 
z Ps Vectorial 
z EPs Screen 
z EPs Vectorial 
z BMP 
z GIF  
z JPEG 
z PNG 
z TGA 
z TIFF 
z VRML 

 
Page setup 

 
Files>Page setup 

打印文件的一些设置。 
 

Print 
 

Files>Print 
打印当前项目图形区域的模型。 
 

§2-5 前后处理切换 
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PostProcess 
 

Files>PostProcess 
将当前界面切换到后处理界面，后处理界面将不同于当前的前处理界面，具

体的功能介绍请参见下一章，关于后处理功能的介绍。 
 

§2-6 退出 
Files>Quit 

退出当前的 GID 图形交互界面。 
 

第三节 View 菜单 
 

§3-1View 主菜单 

 
图 2-15 

 
在 View 菜单中主要分为以下几个部分 

z 视图调整部分 
z 视图编辑部分 
z 视图硬拷贝部分 

 

§3-2 视图调整 
 

在这部分可以分为: 
z 缩放 
z 旋转 
z 平移 
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§3-2-1 缩放视图 
View>Zoom 
缩放功能是一个在视图显示中经常用到的功能，主要用于对局部的放大、对

整体的缩小等等。下面结合对应的菜单，逐个说明其功能和使用方法。 
 
 
 
 
 
 
 

图 2-16 

In 
View>Zoom>In 

z 功能：放大，可以将视图中的局部放大。 
z 操作方法： 

1、 点击该菜单 
2、 在命令行输入两个点坐标作为缩放窗口或者用鼠标在图形区域选

取需要放大局部两个点。 
 

Out 
 
         View>Zoom>Out 

z 功能：缩小，可以将视图中的整体模型缩小 
z 操作方法： 

1、点击该菜单 
2、在命令行输入两个点坐标或者用鼠标在图形区域选取需要放大局部

两个点 
 

Dynamic 
View>zoom>Dynamic 

z 功能：动态缩放，可以将视图根据鼠标的拖动，试图随之放大缩小。 
z 操作方法： 

1、 点击该菜单 
2、 点击鼠标左键，如果移动鼠标向下，则以图形区域中心位置为中

心缩小，反之放大，当视图到达预定大小，再点击一次鼠标左键。

此时，图形不会随鼠标的移动而缩放。 
 

Previous 
 

View>Zoom>Previous 
z 功能：回到前一次视图位置，可以一直往前追溯。与之配合使用的

是下一个 Next 功能 
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z 操作：点击该菜单即可。 
 

Next 
 

View>zoom>Next 
z 功能：回到后一次视图位置，主要是配合上一个功能 Previous 的操

作。 
z 操作：点击该菜单即可 

 
Frame 

 
View>Zoom>Frame 
z 功能：将视图处于适中的位置。 
z 操作：点击该菜单即可 

 
§3-2-2 旋转视图 
View>Rotate 
旋转功能是一个在视图显示中经常用到的功能，主要用于对视图的旋转。下

面结合对应的菜单，逐个的说明其功能和使用方法。 

 
图 2-17 

 
Trackball 

View>Rotate>Trackball 
z 功能：视图随着鼠标的移动而旋转，也可配合下面的 Center 功能，将

视图绕着一个中心旋转。 
z 操作： 

1、击该该菜单。 
2、鼠标图标将变为如下图 2-18，然后点击鼠标左键，鼠标图标将变

为如下图 2-19。此时，拖动鼠标就可以看到视图随之转动。 
 

rotatequiet.cur                 Rotate.cur                            
          图 2-18                      图 2-19 

Screen Axes 
View>Rotate>Screen Axes 
z 功能：绕着屏幕的 X,Y,Z 三个坐标轴旋转，其定义为 X——屏幕的
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长度方向，左下角为原点，Y——高度方向，Z——垂直屏幕方向。 
z 操作方法： 

1、点击该菜单 
2、此时鼠标图标如图 4-18，点击鼠标左键，鼠标图标变为图 4-20，

此时拖动鼠标，视图绕着屏幕的 X 轴旋转，每点一次鼠标左键，

鼠标图标依次在图 4-18，图 4-20，图 4-21，图 4-22 间切换，分

别表示，静止，绕屏幕 X 轴旋转，绕屏幕 Y 轴旋转，绕屏幕 Z
轴旋转。可以根据图标上的+,X,Y,Z 来区别。 

Rotatex.cur       Rotatey.cur        Rotatez.cur  
  图 4-20              图 4-21               图 4-22 

 
Object Axes 

View>Rotate>Object Axes 
z 功能：同上一个 Screen Axes 的功能，只是此处的坐标为图形区域定

义的局部坐标系。 
z 操作：类同上面的 Screen Axes 的操作。 

 
Center 

View>Rotate>Center 
z 功能：视图绕一个中心点旋转 
z 操作： 
1、点击该菜单 
2、此时鼠标图标变为一个回字形图标，选取一个关键点作为中心点。

然后配合前面的 Trackball、Screen Axes、Object Axes 菜单使用，使

视图按照一定的规律旋转。 
3、配合使用菜单 View>Zoom>Frame 取消 Center 功能。 

 
Plane XY 

View>Rotate>Plane XY 
z 功能：将视图按照工作坐标的 XY 平面，作为屏幕平面显示图形。 
z 操作：点击该菜单即可 

 
Plane XZ 

View>Rotate>Plane XZ 
z 功能：将视图按照工作坐标的 XZ 平面，作为屏幕平面显示图形。 
z 操作：点击该菜单即可 

 
 
 

Plane YZ 
View>Rotate>Plane YZ 
z 功能：将视图按照工作坐标的 YZ 平面，作为屏幕平面显示图形。 
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操作：点击该菜单即可 
 

§3-2-3 移动视图 
View>Pan 

移动功能是一个在视图显示中经常用到的功能，主要用于对视图的平移。下

面结合对应的菜单，逐个的说明其功能和使用方法。 
 
 
 
 

图 4-23 

 
Two Point 

View>Pan>Two Point 
z 功能：将一个视图从一个点的位置，移动到另一个点的位置。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标如图 4-24 在图形中的任意位置点一点，鼠标图标变

为图 4-25，并且图形区域留下一个叉。 
3、再在图形区域任意点一个点，视图从一个位置移动到了另一个位

置。移动的距离就是两个点之间的直线距离。 
 

Panfrom.cur                   Panto.cur  
图 4-24                            图 4-25 

 
Dynamic 

View>Pan>Dynamic 
z 功能：类似上面的 Two Poin 功能，但是前一个只可以移动一次，而

本操作，可以将视图移动任意多次。 
z 操作：类似于前一个菜单，只是在上一个菜单操作的第三步后，数

标图标又变回图 4-24，用户可以重复操作第 2、第 3 步。 
 
 

§3-3 视图编辑 
这一部分主要分为： 

z 渲染操作 
z 显示标签 
z 图层操作 
z 视图位置 
z 背景图 
z 多重窗口 
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§3-3-1 刷新 
 

Redraw 
View>Redraw 
z 功能：由于显卡或者显存的问题，有的时候在图形操作，新做的操

作没有及时的显示出来，则可以使用本功能，将图形区域的视图重

新刷新。 
z 操作：点击该菜单即可。 

 

§3-3-2 渲染视图 
View>render 

渲染视图，是为了让图形的表面用一种颜色涂满，以便有较为强烈的三维视

图效果。 

 
图 2-26 

Normal 
View>Render>Normal 
z 功能：取消渲染，一般情况下为灰色，如果用户操作了下面的渲染

操作，这本菜单将被激活，点击该菜单就可以取消渲染。 
z 操作：点击该菜单即可。 

 
Filled 

View>Render>Filled 
z 功能：简单渲染图形 
z 操作：点击该菜单即可 

 
Flat lighting 

View>Render>Flat lighting 
z 功能：含有光源的阴影渲染 
z 操作：点击该菜单即可 

 
Smooth lighting 

View>render>Smooth Lighting 
z 功能：类似于上一个菜单，这一功能在边界上进行了光滑处理，看

不出边界线。 
z 操作：点击该菜单即可 
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Change Light dir 
View>Render>Change light dir 
z 功能：改变光源的位置，注意该功能只有在已经作了 Flat Lighting

或者 Smooth Lighting，才可以使用。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为一个十字，用户在图形区域任意点一下，就可

以看到出现如下图 2-27 的图标，随鼠标一起移动，并且根据其与

模型的位置关系，图标也调整位置，并且模型的阴影也发生改变。 
3、当视图处于理想的状态后，点击鼠标左键，鼠标图标又变回十字

状态，重复第二步，可以再次调整光源。 
4、点击鼠标中键，或者命令行输入 Escape，或者摁以下键盘 ESC

建，结束操作。 
 

Foco_dbd.cur  
图 2-27 

 

§3-3-3 显示标签 
View>Label 

显示标签可以让用户了解几何元素的编号，便于检查模型及修改模型。 

 
图 2-28 

All 
View>Label>All 
z 功能：显示所有类型的标签，注意：在几何模型的界面下为相对应

的元素标签，比如在几何模型界面下，可以显示的是关键点、线、

面、体编号。在网格模型界面下，可以显示的是节点、单元编号。 
z 操作：点击该菜单，图形显示区域内的所有元素，都显示一个编号

标签。 
 

All In 
View>Label>All In> 
z 功能：显示下一级菜单中元素的所有编号标签。 
z 操作：类似上面 All 菜单的操作。 

可供选择的元素有： 
1、几何模型状态下，如图 2-29。 
2、网格模型状态下，如图 2-30。 
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图 2-29                                       图 2-30 

 
Select In 

View>Label>Select> 
z 功能：显示某个元素类型中部分元素的标签，注意：在几何模型的

界面下为相对应的元素标签，比如在几何模型界面下，可以显示的

是关键点、线、面、体编号。在网格模型界面下，可以显示的是节

点、单元编号。 
z 操作： 

1、点击该菜单 
2、选择需要显示的元素类型 
3、鼠标图标变为回字形，通过点击两次鼠标左键，得到一个方框，

点击鼠标中键或者键盘 ESC 键。则刚才所选方框中的该元素的编

号标签都显示出来。 
 

Off 
View>Label>Off 
z 功能：关闭所有元素的编号标签。 
z 操作：点击该菜单即可。 

 

§3-3-4 图层操作 
View>Layer 

图层操作主要是为了方面用户建立、修改较为复杂的模型。在图层的操作中，

每一个几何模型的部分或者全部属于一个图层，这样可以实现部分图层的显示与

消隐，便于几何模型的修改、创建。 

 
图 2-31 

 
On 

View>Layer>On> 
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z 功能：显示被消隐掉的图层。 
z 操作：点击该菜单，弹出一个含有消隐图层名的子菜单，选择要显

示的图层名即可。 
 

Off 
View>Layer>Off 
z 功能：与 ON 的功能相反，消隐已经显示的图层。 
z 操作：类似 On 的操作。 

 
TO Use 

View>Layer>To Use 
z 功能：将所做的模型操作得到的结果保存在该图层。 
z 操作：点击该菜单，弹出一个包含所有图层名的子菜单，选择需要

使用的图层名即可。 
 

Send 
View>Layer>Send> 

 
图 2-32 

z 功能：将一些模型元素在各个图层之间传递。 
z 操作： 

1、点击菜单 View>Layer>send 
2、选择需要发送的元素类型菜单 
3、选择需要发送到的层。 
4、此时鼠标图标变为回字形，然后选择需要传送的模型元素。 
5、点击鼠标中键或者键盘 ESC 结束操作。 

 
z 说明： 

1、菜单中有一个 Also lower entities 的选项，前面如果有勾，表明

将需要传送模型元素的低级模型元素也传送到该图层。 
2、模型元素的级别从低到高的排序如下： 

    几何模型元素    关键点    线      面      体 
    网格模型元素      节点     单元 

 
Window 

View>Layer>Windows 
对 Layer 图层的一些操作对话框，在该对话框中，可以实现以上的所有功能。 
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图 2-33 

z 说明： 
1、在进行选取图层名的操作中，选中的图层名后面的背景色为深

蓝，如图中的 Layer0，并且可以多选或者复选，操作的时候结

合键盘的 Shift 和 Ctrl 键即可。 
2、Layer to be use 功能与菜单中的 To use 一样，操作的时候只需选

中一个图层，然后点击该摁扭，然后就看见旁边的图层名为选

中的图层,如图中 Layer0 位工作图层。 
3、ON 和 OFF 功能与菜单中的 ON 和 OFF 一样，操作的时候，选

取需要消隐或者显示的图层，可以为多个图层，然后点击 ON
或 OFF 即可 

4、Color 是为了设定该图层渲染时候的颜色，操作的时候，选取需

要更改的图层，点击 Color，弹出 Windows 自带调色板，选取

需要的颜色即可。 
5、Sel 为了多选或者复选图层，如果用户有很多图层的时候，可以

通过该功能来选取需要的图层，在操作的时候，需要输入图层

名，可以使用*和?通佩符。 
6、Delete 删除图层，注意删除之前，一定要将该图层中的所有模

型元素删除。操作的时候，选取将要删除的图层，可以选取多

个，然后点击 Delete 即可. 
7、Rename 重命名图层名，操作的时候，选取需要改名的图层，然

后在输入框中输入新的图层名，点击 Rename 即可。 
8、Alphabetic 图层排序，如果该单选框没有选中，则根据图层建

立先后顺序排列，如果选中，则按照字母的排列顺序排序。 
9、To back，操作类似于 Send 但是它不是将模型元素发送到某一
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层，而是将该图层设定前景和背景，并且图形区域只显示前景

模型元素。 
10、 Send 功能与菜单中的 Send 一样，操作可常见菜单中的说明。 

 

§3-3-5 视图位置 
View>View> 

可以将视图位置作为一个文件保存，并且可以读取，以便保存和调用一些常

用的视图位置。注意：只保存视图中视角、位置等参数，并不保存整个模型。 

 
  图 2-34 

 
Save 

View>View>Save 
z 功能：保存一个视图位置，以便以后读入，该文件是一个 ASCII 格

式文件，后缀任意给定。 
z 操作：点击菜单，弹出保存文件对话框，选定文件名和路径保存。 

 
Open 

View>View>Open 
z 功能：读入一个视图位置和视角文件，让视图处于一个位置中。 
z 操作：点击菜单，弹出读入文件对话框，选定文件名和路径读入。 

 
 

§3-3-6 设定背景图 
View>Background Image> 

导入一张图片作为背景图，只支持 BMP 和 PPM 格式图片。 

 
图 2-35 

Fit Screen 
View>Background Image>Fit Screen 
z 功能：导入一张图片作为背景，并且图片可能将被拉伸或者缩小到

屏幕大小。 
z 操作：点击菜单，弹出打开文件对话框，选取路经和文件名读入文

件。 
Real Size 

View>Background Image>Real Size 
z 功能：导入一张图片作为背景，并且按照图片的实际大小显示。 
z 操作：点击菜单，弹出打开文件对话框，选取路经和文件名读入文
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件。 
Default 

View>View>Default 
z 功能：将已有的背景图片删除。 
z 操作：点击该菜单即可。 

§3-3-7 Multiple Windows 
View>Multiple Windows 

可以实现多框口操作功能 

 
图 2-36 

z 功能：可以实现多窗口的操作，根据用户的需要，选择模板中的多

窗口样式，实现多窗口显示。 
z 操作： 

1、点击该菜单。弹出图 2-36 对话框。 
2、选择需要的多窗口形式，点击 Close。 

 

§3-3-8 硬拷贝 
View>Clipboard Copy 

 
z 功能：将图形区域的图形剪切到剪贴板中 
z 操作：点击菜单即可 
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第四节 Geometry 菜单 

 
图 2-37 

 
几何模型工作菜单，主要实现一些与几何模型操作有关的功能。主要分为三

个部分： 
z 创建 
z 删除 
z 修改 

View Geometry 
Geometry>View Geometry 

切换到到几何模型界面 

§4-1 创建模型 
Geometry>Create 

 
图 2-38 

§4-1-1 基本元素创建 
Point 

Geometry>Create>Point 
z 功能：创建一个关键点 
z 操作： 

1、点击该菜单， 
2、在命令行输入坐标，或者直接用鼠标在图形区域点取。 

Line 
Geometry>Create>Line 
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z 功能：创建一条直线 
z 操作： 

1、点击该菜单 
2、鼠标图标变为十字型，在命令行输入点的坐标或者在图形区域

直接点取。 
3、可以接着上一直线的最后关键点为新的直线的开始点，继续作

一条直线。 
4、如果需要结束命令，可以点击鼠标中键或者键盘 ESC 键。 

z 说明： 
1、当输入点的坐标的时候，如果你要做一个 Z=0 平面上的点，那

么可以不需要输入 Z 轴坐标。 
2、当你输入的点已经存在的话，将会出现如图 2-39 对话框，询问

是否将该点作为操作点，或者新建一个关键点。 
3、点击完该菜单后，单击鼠标右键，会弹出一个鼠标菜单，该菜

单的说明可以参见第 9-2 节关于菜单右键的说明，在选取点的

操作中可以辅助的应用这些功能。   

 
图 2-39 

  Arc 
Geometry>Create>Arc 
z 功能：创建一段圆弧 
z 操作： 

1、点击该菜单 
2、鼠标图标变为十字型，在命令行输入点的坐标或者在图形区域

直接点取。一条圆弧的定义需要三个关键点。 
3、可以再重复第二步得到新的圆弧。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 
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z 说明：可参见创建关键点的说明。 
 

Arc Tangents 
Geometry>Create>Arc Tangents 
z 功能：创建两条直线的倒圆角，注意两直线必须要有交点。 
z 操作： 

1、点击该菜单 
2、在命令行输入倒角半径 
3、鼠标图标变为一个回字形，选取两条直线。 
4、如果还是需要创建同半径的倒圆角，可以继续选取两条直线。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键 

 
NURBS line 

Geometry>Create>NURBS Line 
z 功能：创建一条样条曲线 
z 操作： 

1、点击该菜单 
2、鼠标图标变为十字型，在命令行输入点的坐标或者在图形区域

直接点取。 
3、当需要的点足够时，单击鼠标中键或者键盘 ESC 键。 
4、如果还是需要创建样条曲线，重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键 

 
PolyLine 

Geometry>Create>PolyLine 
z 功能：创建一条多折线 
z 操作： 

1、点击该菜单 
2、鼠标图标变为一个回字形，然后在图形区域选择需要组成多折

线的直线段。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一条多折线 
4、如果还是需要创建多折线，重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键 

 
 

Parametric Line 
Geometry>Create>Parametric Line 
z 功能：创建一条参数线段 
z 操作： 

1、点击该菜单 
2、弹出 Create Parametric line 对话框如图 2-40。 
3、在对话框中 x(t)、Y(t)输入各坐标关于参数 T 的表达式。 
4、在 T0 和 T1 中输入参数方程中 t 的取值范围。 
5、选择模拟曲线点的个数 
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6、当选框 Create only points 选中为只创建点，没有选中为创建曲

线。 
7、点击 Apply。创建曲线。点击 Close 关闭对话框。 

 

 
图 2-40 

 
 

§4-1-2 创建 NURBS 曲面 
Geometry>Create>NURBS surface> 

通过它可以进行一些关于面的操作。 

 
图 2-41 

 
By Contour 

Geometry>Create>NURBS Surface>By Contour 
z 功能：通过选择封闭的边界线，生成一张 NURBS 曲面。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，选择需要的边界线。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的区面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Automatic 

Geometry>Create>NURBS Surface>Automatic 
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z 功能：根据用户输入的边界数，自动搜索由该边界数围成的封闭区

域并定义为一个 NURBS Surface。 
z 操作： 

1、点击该菜单 
2、弹出 Enter Value Window,然后输入边界数。点击 OK。 
3、此时，Enter Value window 自动将边界数加 1，用户可以修改，

继续第 2 步，如果不需要，则可以点击 Cancel 结束操作。 
 

Trimmed 
Geometry>Create>NURBS Surface>Trimmed 
z 功能：裁减区面，根据用户指定的边界面，对一个已经存在的曲面

就行裁减。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为一个回字形，点取需要裁减的面，然后选取

边界线，注意边界线必须封闭。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的曲面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Parallel lines 

Geometry>Create>NURBS Surface>Parallel lines 
z 功能：由一些平行线蒙皮为一张曲面。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为一个回字形，点取需要蒙皮的平行线。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的曲面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
By Points 

Geometry>Create>NURBS Surface>By Points 
 

z 功能：有一些关键点蒙皮为一张曲面。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为一个回字形，点取需要蒙皮的关键点。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的曲面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
By line points 

Geometry>Create>NURBS Surface>By Line Points 
z 功能：有一些线段的关键点蒙皮为一张曲面。 
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z 操作： 
1、点击该菜单 
2、此时鼠标图标变为一个回字形，点取需要蒙皮的线段。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的曲面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Search 

Geometry>Create>NURBS Surface>Search 
z 功能：根据一些线段的搜索与之相邻封闭线段，形成一张曲面。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标变为一个回字形，点取需要搜索的线段。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一张曲面。 
4、此时如果还需要再生成另一个新的曲面，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

§4-1-3 创建体 
Geometry>Create>Volume 
通过它可以创建体。 

 
图 2-42 

 
By Contour 

Geometry>Create>Volume>By Contour 
z 功能：通过选择封闭的边界面，生成一个体。 
z 操作： 

1、击该菜单。 
2、此时鼠标图标为回字形，选择需要的边界面。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一体。 
4、此时如果还需要再生成另一个新的体，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
 

Automatic 6-sided volume 
Geometry>Create>Volume>Automatic 6-sided volume 
z 功能：自动搜索得到六面体。 
z 操作：点击该菜单 
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Hole 
Geometry>Create>Volume>Hole 
z 功能：将体内含有的相同部分减去。该用功能类似布尔运算中的体

相减。 
z 操作： 

1、选择该菜单 
2、此时鼠标图标为回字形，选择被减体，接着选择要减去的体。

此时程序自动生成一个新的体。 
3、此时如果还需要再生成另一个新的体，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

§4-1-4 求交运算 
Geometry>Create>Intersection> 

主要实现一些线和线、线和面、面和面求交的运算。 

 
图 2-43 

 
Line-Line 

Geometry>Create>Intersection>Line-Line 
z 功能：求两直线的交点。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，请依次选择需要求交点的两条线。此

时就会看到两直线的交点就会求解出来了。 
3、此时如果还需要继续求另两条直线的交点，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Multiple Lines 

Geometry>Create>Intersection>Multiple Lines 
z 功能：求许多两两相交的直线段交点。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，选择需要求交点的线段。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一系列的交点。 
4、此时如果还需要再求另一些直线段的焦点，可以重复第 2、3

步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 
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Surface-2 points 
Geometry>Create>Intersection>Surface-2 points 
z 功能：将两点连线投影到一个面上，并根据投影线分切该平面。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，选择需要被投影的面，然后选择与要

投影的两个点。可以看到被选择的面，被投影线分割为两个面。 
3、此时如果还需要再根据两个点的投影分割面，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Surface-Lines 

Geometry>Create>Intersection>Surface-Lines 
z 功能：求一个面与多条线段的交点。 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，先选择面，然后选择与之线交，需求

交点的线段。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一系列的交点。 
4、此时如果还需要再求一个面与多条线段的交点，可以重复第 2、

3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Surface-Surface 

Geometry>Create>Intersection>Surface-Surface 
z 功能：求两面的交线段 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，分别选择两个需要求解交线段的面。

则可以看到在两个面的交界处，生成了一条交线段，并且可能

有一个面被交接线分割。 
3、此时如果还需要再求两个面交线段，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Multiple Surface 

Geometry>Create>Intersection>Multiple Surface 
z 功能：求解多个面的交线段 
z 操作： 

1、点击该菜单。 
2、此时鼠标图标为回字形，选择需要求交线段的多个面。 
3、单击鼠标中键或者键盘 ESC 键，则可以得到一系列的交线段，

并且可能有些面会被交线段分割。 
4、此时如果还需要再求另一些面的交线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 
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§4-1-5 创建几何模块 
Geometry>Create>Object 

创建一些几何结果比较标准的几何模块 
 

Rectangle 
Geometry>Create>Object>Rectangle 
z 功能：创建一个矩形 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为十字形，分别输入两个点作为矩形的对角点。

则可以看到生成了一个矩形面。 
3、此时如果还需要再由两点确定一矩形面，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Polygon 

Geometry>Create>Object>Polygon 
z 功能：生成多边形面 
z 操作： 

1、点击该菜单 
2、弹出一个 Enter Value Window 窗口，输入需要得到的多边形的

边数。然后点击 OK 
3、此时鼠标图标变为十字形图标，输入中心点的坐标，然后输入

该多边形的外接圆半径。 
4、此时还需要得到相同边数的多边形，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Circle 

Geometry>Create>Object>Circle 
z 功能：创建一个圆面 
z 操作： 

1、点击该菜单 
2、此时鼠标变为十字形图标，输入圆心的坐标，然后输入圆的半

径。 
3、此时还需要得到圆面，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Sphere 

Geometry>Create>Object>Sphere 
z 功能：创建一个圆球体 
z 操作： 

1、点击该菜单 
2、此时鼠标变为十字形图标，输入球心的坐标，然后输入球的半

径。 



 36

3、此时还需要得到球体，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Cylinder 

Geometry>Create>Object>Cylinder 
z 功能：创建一个圆柱 
z 操作： 

1、点击该菜单 
2、此时鼠标变为十字形图标，输入底圆圆心，弹出一个 Enter 

Normal 对话框，如下图 2-44，选择底圆的法线方向。 
3、然后输入底圆半径，最后输入圆柱高度。 
4、此时还需要得到圆柱，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

 
图 2-44 

 
Cone 

Geometry>Create>Object>Cone 
z 功能：创建一个圆锥 
z 操作： 

1、击该菜单 
2、此时鼠标变为十字形图标，输入底圆圆心，弹出一个 Enter 

Normal 对话框，如图 2-44，选择底圆的法线方向。 
3、然后输入底圆半径，最后输入圆柱高度。 
4、此时还需要得到圆锥，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Prism 
Geometry>Create>Object>Prism 

z 功能：创建一个多边形棱柱 
z 操作： 

1、击该菜单 
2、弹出一个 Enter Value Window 窗口，输入需要得到的多边形的

边数。然后点击 OK。 
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3、此时鼠标变为十字形图标，输入底边多边形的圆心，弹出一个

Enter Normal 对话框，如图 2-44，选择底边的法线方向。 
4、然后输入底边外接圆半径，最后输入棱柱高度。 
5、此时还需要得到棱柱，可以重复第 2、3、4 步。 
6、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
 
Tours 
Geometry>Create>Object>Torus 

z 功能：创建一个圆环 
z 操作： 

1、该菜单 
2、此时鼠标变为十字形图标，输入圆环的中心，弹出一个 Enter 

Normal 对话框，如图 2-44，选择底边的法线方向。 
3、然后输入两个圆环的内外半径，输入顺序不限。 
4、此时还需要得到圆环，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键 

 
 

§4-1-6 面的布尔运算 
Geometry>Create>Surface Boolean op.> 
对于面的一些布尔运算 

 
图 2-45 

 
Union 

Geometry>Create>Surface Boolean op.>Union 
z 功能：将两个面叠加在一起，删除公共的一些面、线。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，依次选择需要求叠加的面，会看到

两个面叠加在了一起，并且删除了重叠在一起的面和线。 
3、如果还需要将另外的面求叠加，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Intersection 

Geometry>Create>Surface Boolean op.>Intersection 
z 功能：求两个面的公共部分，并且删除多余的部分 
z 操作： 

1、点击该菜单 
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2、此时鼠标图标变为回字形，依次选择需要求重叠的面，会看到

两个面叠加在了一起的部分创建了一个新的面，并且删除了其

余的面和线。 
3、如果还需要将另外的面求叠加，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
 

Subtractions 
Geometry>Create>Surface Boolean op.>Subtractions 
z 功能：用一个面减与另一个面，并删除与之公共部分的面和线。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，依次选择被减面，以及需要减去的

面，会看到两个面叠加在了一起的部分被删除了，被减面重新

构造了一个新面。并删除其余多余的面和线。 
3、如果还需要将另外的面相减操作，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

§4-1-7 体的布尔运算 
 

Geometry>Create>Volume Boolean op.> 
对于体的一些布尔运算 

 

 
图 2-46 

 
Union 

Geometry>Create>Volume Boolean op.>Union 
z 功能：将两个体叠加在一起，删除公共的一些体、面、线。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，依次选择需要求叠加的体，会看到

两个面叠加在了一起，并且删除了重叠在一起的体、面和线。 
3、如果还需要将另外的体求叠加，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Intersection 

Geometry>Create>Volume Boolean op.>Intersection 
z 功能：求两个体的公共部分，并且删除多余的部分 
z 操作： 
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1、点击该菜单 
2、此时鼠标图标变为回字形，依次选择需要求重叠的体，会看到

两个体叠加在了一起的部分创建了一个新的体，并且删除了其

余的体、面和线。 
3、如果还需要将另外的体求叠加，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
 

Subtractions 
Geometry>Create>Surface Boolean op.>Subtractions 
z 功能：用一个体减与另一个体，并删除与之公共部分的体、面和线。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，依次选择被减体，以及需要减去的

体，会看到两个体叠加在了一起的部分被删除了，被减体重新

构造了一个新体。并删除其余多余的体、面和线。 
3、如果还需要将另外的体相减操作，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

 

§4-2 删除 
 

Geometry>Delete 
 

 
图 2-47 

z 功能：删除几何模型中的一些信息 
z 操作： 

1、点击该菜单 
2、选择需要删除的几何元素类型 
3、此时鼠标图标变为回字形，选择需要删除的几何模型元素。单

击鼠标中键或者键盘 ESC 键，完成操作。 
4、如果还需要删除该类型的几何元素，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

z 说明： 
1、由于几何模型元素，有一个级别顺序问题，所以在删除操作的

时候，需要删除的元素的上一级信息不许没有，否则不可以删

除该元素。 
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2、几何模型元素的级别排列如下： 
几何模型元素    关键点    线      面       体 

 
 

§4-3 编辑 
Geometry>Edit> 
几何模型修改的操作 

 
图 2-48 

 
 

Move Point 
Geometry>Edit>Move Point 
z 功能：移动关键点，并且与该关键点有关的元素一起修改。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要移动的关键点，输入新的

坐标。 
3、可以看到和该点有关的所有几何元素一起随着关键点的修改而

修改。 
4、如果还需要修改其他关键点的坐标，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Explode PolyLine 

Geometry>Edit>Explode PolyLine 
z 功能：将 PolyLine 炸开为直线 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为一个回字形，选择需要炸开的 PolyLine，单击

鼠标中键或者键盘 ESC 键。 
3、弹出一个询问是否执行该操作的警告框口。如果希望继续点击

OK，点击 Cancel 退出该操作 
4、如果点击 OK，则可以看到原来的 PolyLine 被炸开为多条线段。 
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Divide 
Geometry>Edit>Divide> 

等分线、面。 
 

 
图 2-49 

 
 

Num Divisions 
Geometry>Edit>Divide>Num Divisions 
z 功能：按照等分数等分线段。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的线段。 
3、弹出 Enter Value window 对话框，输入等分数，点击 OK。 
4、如果还需等分其他的线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Near Point 

Geometry>Edit>Divide>Near Point 
z 功能：按照用户选择的点得到等分线段。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的线段。 
3、此时鼠标图标变为十字形，在命令行输入等分点的坐标值，或

者直接在直线上点取。 
4、如果还需等分其他的线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Parameter 

Geometry>Edit>Divide>Parameter 
z 功能：根据用户输入的等分因子等分线段。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的线段。 
3、弹出 Enter Value window 对话框，输入一个介于 1 和 0 的等分
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因子数，点击 OK 摁扭。 
4、如果还需等分其他的线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Relative Length 

Geometry>Edit>Divide>Relative Length 
z 功能：根据用户输入的弧长等分因子等分弧线段。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的线段。 
3、弹出 Enter Value window 对话框，输入一个介于 1 和 0 的等分

因子数，点击 OK 摁扭。 
4、如果还需等分其他的线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
PolyLines 

Geometry>Edit>Divide>PolyLines 
z 功能：将一条 PolyLine 炸开为两条 Polyline。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被炸开的 PolyLine 线段。 
3、继续选择需要炸开的位置，注意，一定为 PolyLine 中一条组成

线段的内部端点。 
4、如果还需等分其他的线段，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Surfaces 

Geometry>Edit>Divide>Num division> 
对于曲面的等分操作。 

 
图 2-50 

 
Num Divisions 

Geometry>Edit>Divide>Num Divisions 
z 功能：将一个面等分为两部分 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的面。 
3、弹出一个选择方向对话框，如下图 2-51。其中 U Sense 表示平

行 X 轴等分、V Sense 表示平行 Y 轴等分。对于曲面视图中会

标出，点取需要等分的方向。退出选择 Cancel。 
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4、弹出 Enter Value window 对话框，输入等分数，点击 OK。 
5、如果还需等分其他的面，可以重复第 2、3、4 步。 
6、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

 
图 2-51 

 
Near Point 

Geometry>Edit>Surface>Near Point 
z 功能：根据用户输入的点，分割一个曲面为两部分。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的面。 
3、弹出一个选择方向对话框，如下图 2-51。其中 U Sense 表示平

行 X 轴等分、V Sense 表示平行 Y 轴等分。对于曲面视图中会

标出，点取需要等分的方向。退出选择 Cancel。 
4、此时鼠标图标变为十字形，在命令行输入等分点的坐标值，或

者直接在面上点取。 
5、如果还需等分其他的面，可以重复第 2、3、4 步。 
6、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Parameter 

Geometry>Edit>Divide>Surface>Parameter 
z 功能：根据用户输入的等分因子等分面。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的面。 
3、弹出一个选择方向对话框，如下图 2-51。其中 U Sense 表示平

行 X 轴等分、V Sense 表示平行 Y 轴等分。对于曲面视图中会

标出，点取需要等分的方向。退出选择 Cancel。 
4、弹出 Enter Value window 对话框，输入介于 1 和 0 之间的一个

等分因子数，点击 OK。 
5、如果还需等分其他的面，可以重复第 2、3、4 步。 
6、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Split 

Geometry>Edit>Divide>Split 
z 功能：根据用户选择的线分割面。 
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z 操作： 
1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要被等分的面。 
3、选择分割面的线，单击鼠标中键或者键盘 ESC 键。 
4、如果还需要分割其他的面，重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
 

Join Lines End Points 
Geometry>Edit>Join Lines End Points 
z 功能：将两条原本分离线的两个端点合并为一个点 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择目标线，再选择另一条线，可

以看到，目标线没有变化，而另一条线的一个端点和目标线的

一个端点合并为一个点。 
3、如果还需要合并其他的两条线的断点，可以重复第 2 步。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Swap Arc 

Geometry>Edit>Swap Arc 
z 功能：根据一个圆弧得到该圆弧的互补部分 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要得到互补圆弧的圆弧段。 
3、单击鼠标中键或者键盘 ESC 键，弹出一个警告窗口，如下图

2-52。点击 OK。 
4、可以看到，所有的原来被选的圆弧都被删除，生成一个与之在

同一个圆上，但是方向正好相反的部分圆弧。 

 
图 2-52 

 
Edit PolyLine 

Geometry>Edit>Edit PolyLine 
z 功能：设定网格划分时，PolyLine 中关键点和节点间的关系。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要设定的 PolyLine。单击鼠



 45

标中键或者键盘 ESC 键。 
3、弹出对话框如下图 2-53，其中 Use Points 表示以后节点在关键

点上生成，No Use Points 表示生成的节点可以不使用关键点，

Only Points 表示只允许在关键点上生成节点。 

 
图 2-53 

 
 

Edit NURBS Line 
Geometry>Edit>Edit NURS Line 
z 功能：编辑 NURBS 曲线的特性 
z 菜单： 

1、点击该菜单 
2、弹出一个 Edit NURBS Line 对话框，如下图 2-54，点击 Pick 摁

扭。 
3、此时鼠标图标为一个回字形，选择需要修改的 NURBS 曲线。 
4、此时 Edit NURBS Line 对话框变为如下图 2-55。 

         
图 2-54                                               图 2-55 

 
z 说明： 

1、Movement Type 移动点的方位，可以供选择的有 Screen、Point、
X-Axis、Y-Axis、Z-Axis。也就是，可以在屏幕范围内、任意

一个点的位置、沿着 X 坐标、 Y 坐标、Z 坐标移动。 
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2、Fix boundary 复选框，如果选中，表示不允许修改该曲线的边

界，也就是不允许修改两个端点的属性。 
3、Insert Knot，插入一个控制关键点 
4、Degree Elevate,提高曲线拟合精度，一般会在一些关键位置插入

控制点。 
5、Change Weight,控制某一个点附近曲线相对的质量。 
6、Cancel Weight，取消所有点附近的曲线相对质量。 
7、Reparametrize，优化该曲线控制点的位置。 
8、Simplify，将被修改过控制点的曲线，重新生成为一条类似的单

一曲线。 
 
 

Edit NURBS Surface 
Geometry>Edit>Edit NURBS Surface 
z 功能：编辑 NURBS 曲面的属性 
z 操作： 

1、点击该菜单 
2、弹出一个 Edit NURBS Suface 对话框，如下图 2-56 点击 Pick 摁

扭。 
3、此时鼠标图标为一个回字形，选择需要修改的 NURBS 曲面。 
4、此时 Edit NURBS Surface 对话框变为如下图 2-57。 
5、关于每一个对话框中的说明请参见前一个 Edit NURBS Line 的

介绍，只是要注意前面的是线，这里的是面就可以了。 
 

            
图 2-56                                          图 2-57 

  
Hole NURBS Surface 

Geometry>Edit>Hole NURBS Surface 
z 功能：裁减 NURBS 曲面中的多于部分 
z 操作： 
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1、点击该菜单 
2、此时鼠标图标为回字形，选择需要裁减的曲面。 
3、继续选择需要裁减的边界线，然后单击鼠标中键或者键盘 ESC

键。 
4、如果还需要合并其他的两条线的断点，可以重复第 2 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键 

 
Edit Surf Mesh 

Geometry>Edit>Edit Surf Mesh 
z 功能：显示导入的表面网格 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，选择需要显示的表面网格的面 
3、单击鼠标中键或者键盘 ESC 键。 
4、弹出如下图 2-58 的对话框，其中 Draw Mesh 选项为在图形中显

示网格，No Draw Mesh 选项为在图形中不显示网格，Cancel
退出当前操作。 

z 说明： 
该操作一般要先有 Surf Mesh，Surf Mesh 的使用可以参见菜单

File>Import> Surface Mesh 使用说明。 

 
图 2-58 

Convert To NURBS 
Geometry>Edit>Convert To NURBS> 
z 功能：将一个线、面转化为 NURBS 曲线、曲面。 
z 操作： 

1、点击该菜单，选择需要转换的类型（线或者面）。 
2、此时鼠标图标为回字形，选择需要转换的对象。 
3、单击鼠标中键或者键盘 ESC 键。弹出一个如下图 2-59 警告对

话框，选择 Ok 表示接受转换，如果不需要转换点击 Cancel。 

 
图 2-59 
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Simplify NURBS 
Geometry>Edit>Simplify NURBS> 
z 功能：降低 NURBS 曲线或者曲面的精度。 
z 操作： 

1、点击该菜单，选择需要的类型（线或者面） 
2、此时鼠标图标为回字形，选择需要降低精度的对象。 
3、单击鼠标中键或者键盘 ESC 键。弹出一个如下图 2-60 警告对

话框，选择 Ok 表示接受降低精度，点击 Cancel 则取消命令。 

 
图 2-60 

 

第五节 Utilities 菜单 

 
图 2-61 

Undo 
Utilities>Undo 
z 功能：可以回退到以前的操作的某一步 
z 操作： 

1、点击该菜单 
2、弹出如下图 2-62 Undo 对话框，选中选择需要回退到位置之后

部分，如下图 2-63。 
3、点击 Undo 
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图 2-62                                       图 2-63 

 
 

Layer 
Utilities>Layer 
z 功能：显示 Layer 对话框 
z 操 作 ： 点 击 该 菜 单 即 可 ， 关 于 该 菜 单 的 说 明 参 见

View>Layer>windows 菜单的说明文档。 
 

Preferences 
Utilities>Preferences 
z 功能：设定一些工作环境属性 
z 操作：点击该菜单弹出如下对话框。 

 
 

General 一般属性选项 
z Splash Window：主要用来设定程序启动是的欢迎窗口出现与否，如

果选中 Splash Window 前的复选框，则启动 GID 程序的时候出现欢

迎窗口，相反则不出现。 
z Create New Point：当出现输入一个关键点的坐标和另一个已存在关

键点相同时，是否出现提示的设置。 
1、Always：在原来关键点的附近创建一个新的关键点 
2、Ask：弹出一个提示窗口，如图 2-39。根据用户的选择是否创建

新的关键点。 
3、Never：直接引用已存在的关键点作为新的关键点使用。 
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z Display Coordinates：是否显示坐标值提示框，如果选中 Display 
Coordinates 前的复选框,则在提示框的右侧，显示一个鼠标坐标的提

示框，相反则不显示。 
z Automatic Redraw ：自动刷屏选项设置。 

1、All Windows：所有的窗口都自动刷屏，关于多重屏幕的设置可

参见 View>Multiple Windows 菜单说明文档。 
2、Current Window：自动刷新当前窗口。 
3、None：所有的窗口的操作后都不自动刷新。 

z Use More Windows：设置是否出现提示或者警告窗口。 
1、Yes：显示提示窗口 
2、 No：不显示提示窗口，如果需要数据，可以通过命令行输入。 
3、 Beginner：显示提示窗口。 

z Backup File：自动备份文件，需要用户给定一个目录、文件名以及

自动保存间隔时间。 
1、Backup File：在该条输入框中输入保存的文件目录和文件名，

也可通过旁边的浏览框选择路径和文件名。 
2、Backup Time：直接在输入框中输入，自动保存间隔时间。注意：

在 Backup Time 前的复选框，为自动备份功能的开关选项，选

中前面的复选框，表示启动自动备份。否则不执行自动备份。 
z Write Batch Files：自动保存所有的操作为批命令文件。 

1、Write Batch Files：选中该项前面的复选框，表示自动保存每步

操作的批命令，否则不保存。后面的输入框中输入保存路径和

文件名，也可以通过浏览框选择路径和文件名。 
2、 Write Rot In File：是否将关于旋转模型的操作保存在批处理文

件中，如果选中前面的复选框则写入旋转批命令，反之则不写

入。 

 
图 2-64             
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Graphics 几何属性选项 
 

z Smoothed elems (degree)：渲染是光滑单元表面的选项。当两个单元

法线的交角很小，那么渲染后可以看到是一个连续的物体表面，但

是如果存在一个较大的交角的时候渲染后就会显示连续。选中该项

前面的复选框则做光滑处理，相反则不做。后面输入框中的角度为

设定法线交角最大值，即大于这个值则需要光滑处理。 
 

z Surface Draw Type：一个面的显示方式。 
1、None 不显示 
2、Boundary Lines：用一个向面内偏置了边界的线连接而成的一个

面作为面的标示。 
3、Isoparametic Lines：用两条相互垂直的线标示出一个面的局部

坐标。 
4、Both：同时选用 2、3 作为显示方式。 

z Change Color：修改显示的模型元素的颜色。以及工作图形区域的

背景色。 
z Curve Precision：该操作可以用来修改显示曲线时的精度，精度值

介于 0 到 1 之间，可以通过拉动滚动条来实现，默认的精度值为 0.8。 
z Surface Precision：该操作和上一操作类似，是为了设定面显示的精

度，操作和含义同上。 
z Fast Rotation：快速的旋转，主要用户快速旋转模型的操作。选中

前面的复选框，表示选用该功能，反之不使用。 
 

1、Point 、line、Surfaces、Volume：在旋转的时候需要显示的模

型元素，需要显示什么点中该图标即可。 
2、Always Geometry：如果在旋转网格模型的时候，将使用几何模

型的图像来代替，不显示网格模型。 
3、Draw Graphic Objects：如果选中前面的复选框，在旋转操作的

时候，与几何模型相关的一些元素一起旋转，比如，法线、材

料、边界条件等。反之则不随模型一起旋转。 
4、Curve Precision：旋转时候曲线的显示精度。与前面的 Cure 

Precision 设定和功能一致，请参见前面的说明文档。 
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图 2-65 

 
Meshing 网格属性选项 
z Surface Mesher：面网格生成器选项。下面的网格生成方式都是基于

波前法做的，这样便于加快生成速度以及可操作性。 
1、Rfast：可以快速、可靠的生成网格，特别是一些畸变较大的面

上生成网格。 
2、Rsur：可以产生质量很高的网格。但是遇到畸变较大的面可能

会报错。 
3、2Dumg：一般不推荐该种网格生成方式 

 
z Mesh Until End：选中该选项前的复选框，则允许网格求解器，在

没有划分全部面和体的时候停止运算，反之则不可以停止运算。 
z Auto Correct Sizes：选中该选项前面的复选框，则程序自动根据模

型的大小优化生成单元的尺寸，反之则不进行优化。 
z Unstructured Size Transitions：非结构化网格的网格过渡因子的选

择，该值介于 1 到 0 之间，越小过渡越慢，网格质量越好，时间越

长，单元数越多，越大则相反。 
z Smoothing：光滑划分好的网格后的渲染形式 

1、Normal：按照普通的设定来光滑网格。 
2、HighAngle：将角度也设为一个光滑尺度。 
3、HighGeom：将几何模型的几何曲线弧度也设为一个光滑尺度。 

z No Mesh Frozen Layers：选择前面复选框，则不划分被锁定图层上

的几何模型。反之，则划分网格。 
z Allow Automatic Structured：选择前面的复选框，则允许程序自动的

划分一些符合结构划分网格的曲面，但是可能得到的网格质量不是

很好。反之则自由划分网格。 
z Mesh always by default：被选中的几何模型在划分网格的时候，会
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被认为不属于任何更高模型的方式再生成一次网格，比如：一个面

属于体，但是如果面被设定了，那么，划分网格的时候，面对于体

要生成一次网格，面本身也要生成一次网格。 
 

   
图 2-66   

 
Import 导入属性选项 
z Automatic Collapse After Import：选中前面的复选框，则在导入其他

CAD 软件文件模型后，自动合并在容差范围内的点线面。反之则

不自动合并。 
z Automatic Import Tolerance Value 选中前面的复选框则表示，程序

自动根据模型尺寸选定一个合适的容差。反之则需要在下面的复选

框中输入一个绝对容差 
z Collapse：关于合并操作时可以跨越的图层设定。需要选择下面的

一个单选框。 
1、Ignoring Layers：可以在任何层之间的几何模型元素进行合并运

算操作。 
2、Each layer separately：只允许在同一图层的几何模型元素之间进

行合并运算操作。 
z IGES：Ignore Invisible Entities：选中前面的复选框，则表示导入 

IGES 文件的时候，不导入 IGES 文件中设定为隐藏属性的几何模型

元素。反之则导入含有隐藏属性的几何模型元素。 
z IGES：Curve on surface from 3D：选中该复选框，则表示，根据 IGES

文件中的三维空间曲面信息生成 NURBS 曲线。反之则不会生成该



 54

曲线。 
 
 

 
图 2-67 

 
Font 字体设定选项 

z Normal Font：GID 界面的字体。 
z Fix Font：一些属性需要时候的字体。 
z Big Font 对话框中的字体。 
z Command Font：命令行中的字体。 

选择每个字体属性下面的字体下拉条，选择需要的字体，数字下拉条

为字体的大小，B 摁扭为设定字体加粗，I 摁扭为设定字体斜写。 



 55

 
图 2-68 

 
Calculate 

Utilities>Calculate 
z 功能：弹出一个计算器 
z 操作：点击该菜单即可，显示如下图 2-69 的多功能计算器。 

 
图 2-69 

Status 
Utilities>Status 
z 功能：统计当前项目的模型信息 
z 操作： 
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1、点击该菜单 
2、弹出一个 Status 对话框，该对话框包含了所有的模型信息，如

果没有划分网格如图 2-70，如果有网格则如图 2-71。 
 

 
图 2-70                                              图 2-71 

 
 

List 
Utilities>List> 
z 功能：列出具体某个几何模型元素的信息 
z 操作： 

1、点击该菜单 
2、选择需要统计信息的类型，此时鼠标图标为回字形，选择需要

显示的模型。 
3、单击鼠标中键或者键盘的 Esc 键。弹出一个 Info Dialog 对话框，

列出该模型的一些模型信息。点击 Close 关闭该对话框。 
 

Copy 
Utilities>Copy 
z 功能：拷贝几何模型得到新的几何模型 
z 操作： 

1、点击该菜单 
2、弹出 Copy 对话框，修改该对话框的选项得到新的模型。 

z 说明： 
1、Entities Type：被选择的几何模型类型：点、线、面、体，可被

选择的网格模型类型有节点、单元。 
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2、Transformation：拷贝方式可以选择的有： 
Translation：拉伸，沿着某一个方向从一个点拷贝到另一个点。 
Rotation：旋转，沿着一个对称轴，旋转一定的角度。 
Mirror：镜像，沿着一个对称面，镜像到对称面的另一边。 
Scale：缩放：以一个中心点为中心，给定 X、Y、Z 三个方向

的缩放因子，缩放模型。 
Offset：偏置，按照一个给定的缩放因子，沿着法线方向偏置一

定距离。 
Sweep：扫描，一个模型按照给定的曲线，旋转一定的角度。 

3、Point：一些关键点的输入，比如需要使用 Mirror 镜像功能，那

么需要三个点确定一个对称平面，那么依次输入 First Point、
Second Point、Second Point 的 X、Y、Z 的坐标就可以，或者点

击 Pick 直接选取已存在的点。 
4、Do Extrude:是否保存操作的轨迹，比如拉伸一个点到另一个点，

则其轨迹为一条直线，如果选择了 Line 则表示保存这条轨迹。

一般操作的时候，对于 Point 的操作，轨迹为 Line；对于 Line
的操作，轨迹为 Surface；对于 Surface 的操作，轨迹为 Volume。 

5、Multiple Copies：需要拷贝的份数。 
 

 
图 2-72 

 
Move 

Utilities>Move 
z 功能：将一个模型从一个位置移动到另一个位置。 
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z 操作： 
1、点击该菜单。 
2、弹出一个 Move 对话框。 

z 说明： 
该功能同 Copy 的操作一样，只是 Copy 保留原始模型，而 Move 删

除原有模型 
 

 
图 2-73 

 
Renumber 

Utilities>Renumber 
z 功能：重新命名模型编号 
z 操作： 

1、点击该菜单 
2、弹出一个警告对话框，如下图 2-74。点击 Ok 标示重新编号，

点击 Cancel 则退出该操作。 
z 说明： 

当创建模型的时候，每个模型有一个标号，可以通过 View>Label
功能察看，但是有时候删除了一些以后的编号后，新创建的模型只是根

据已有最大的编号继续编号，被删除的编号空留，所以造成了编号的不

连续，而通过该操作。则可以按照整体模型，重新编号。 
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图 2-74 

 
Id 

Utilities>Id 
z 功能：显示一个关键点或者节点的坐标值和编号等信息 
z 操作： 

1、点击该菜单 
2、此时鼠标为回字形，选择需要显示信息的点。 
3、此时可以在提示框内看到该点信息。 

Single 
Utilities>Single> 
z 功能：标示出模型元素所在的位置 
z 操作： 

1、点击该菜单 
2、选择需要标示位置模型元素的类型，在几何模型下可以选择的

类型为 Points、Lines、Surfaces、Volumes。在网格模型下可以

选择的类型为 Nodes、Elements。 
3、此时鼠标图标为回字形，点取需要标示的元素。 
4、此时可以看到，图形区域用两条相交的红色直线，并在交点处

标示出该元素的标号来标示出了它的位置。 
5、如果还需要标示同类型的其他元素，则可以重复第 2、3、4 步。 
6、如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Distance 

Utilities>Distance 
z 功能：显示两点之间的直线距离 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，依次选择两个需要测量直线距离的两

个点。 
3、可以在提示框中，显示两点的直线距离。 
4、如果还需要测量两点之间的距离，可以重复第 2、3 步。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Draw Normals 

Utilities>Draw Normals 
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z 功能：显示直线或者面的法线方向。 
z 操作： 

1、点击该菜单 
2、选择需要显示法线的元素类型，可以选择的是线、面。 
3、此时鼠标图标为回字形，选取需要显示法线的元素。 
4、此时可以看到该元素回被两个坐标显示出其法线和切线方向。 
5、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

z 说明： 
Color 为在渲染的状况下显示元素的法线方向，操作的时候，先选

取该菜单，然后单击鼠标中键或者键盘 ESC 键，弹处如下图 2-74 警告

对话框，点击 Ok 摁扭。接着按照上面的操作步骤操作。 

 
图 2-74 

 
Draw Higher 

Utilities>Draw higher 
z 功能：显示模型中元素的几何关系，比如内部、边界、孤立等。 
z 操作： 

1、点击该菜单 
2、选择需要显示的几何模型元素，可以选择的有 Point、Line、

Surface、All。 
3、此时图形显示区域，将模型元素用不同的颜色标示出该元素在

模型中的关系。 
4、如果需要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

z 说明： 
检查几何模型元素关系，可以帮助用户在生成网格的时候，检查有模型

的公共边、面重叠、孤立等。以防止生成不匹配的网格，或者说生成不连续

的网格。 
 

Repair 
Utilities>Repair 
z 功能：自动修补模型错误。 
z 操作： 

1、点击该菜单 
2、弹出一个如下图 2-75 警告对话框，选择 Ok 摁扭，则表示允许

程序自动修补模型。如果点击 Cancel 对话框，退出该操作，不

修补模型。 
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图 2-75 

 
 Collapse 

Utilities>Collapse 
z 功能：合并一些在容差范围内的同类型模型元素 
z 操作： 

1、点击该菜单 
2、选择需要合并的模型元素类型。 
3、此时鼠标图标为回字形，选择需要合并的模型元素。 
4、单击鼠标中键或者键盘 ESC 键。 

z 说明： 
1、Collapse 操作需要的容差设定可以在 Utilities>Preferences 中的

Import 选中的 Automatic import tolerance value 中设定。 
2、菜单中的 Model 为对所有模型中的元素一起做合并操作，操作

的时候，直接点曲该菜单即可。 
 

Uncollapse 
Utilities>Uncollapse 
z 功能：设定允许在容差范围内的模型元素 
z 操作： 

1、点击该菜单。 
2、选择允许在容差范围内的模型元素类型。 
3、此时鼠标图标为回字形，选择选择的模型元素。 
4、单击鼠标中键或者键盘 ESC 键。 

 
 

Dimension 
Utilities>Dimension 

在模型中添加标注 

 
图 2-76 

Create 
Utilities>Dimension>Create 

创建标注 
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图 2-77 

 
Vertex 

Utilities>Dimension>Create>Vertex 
z 功能：标注一个点的坐标 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，选择需要标注的点。 
3、此时鼠标图标变为十字形，输入一个标注需要插入位置的坐标。 
4、如果还需要标注其它的点，则可以重复第 2、3 步。 
5、如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Distance 

Utilities>Dimension>Create>Distance 
z 功能：标注两点之间的直线距离 
z 操作： 

1、 点击该菜单 
2、 此时鼠标图标为回字形，依次选择需要标注的两个点。 
3、 此时鼠标图标变为十字形，输入一个标注需要插入位置的坐

标。 
4、 如果还需要标注其它两个点的距离，则可以重复第 2、3 步。 
5、 如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Angle 

Utilities>Dimension>Create>Angle 
z 功能：标注两条边的夹角 
z 操作： 

1、 选择该菜单 
2、 此时鼠标图标为回字形，依次选择需要标注的夹角两条边的

交点、及两条边的另一个端点。 
3、 此时鼠标图标变为十字形，输入一个标注需要插入位置的坐

标。 
4、 如果还需要标注其它两条边的夹角，则可以重复第 2、3 步。 
5、 如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Radius 

Utilities>Dimension>Create>Radius 
z 功能：标注一段圆弧的半径及圆心坐标 
z 操作： 
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1、 选择该菜单 
2、 此时鼠标图标为回字形，依次选择需要标注的半径和圆心坐

标的圆弧。 
3、 此时鼠标图标变为十字形，输入一个标注需要插入位置的坐

标。 
4、 如果还需要标注其它圆弧半径和坐标，则可以重复第 2、3

步。 
5、 如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Text 

Utilities>Dimension>Create>Text 
z 功能：在模型中插入说明文档 
z 操作： 

1、点击该菜单 
2、弹出如下图 2-78 文档输入对话框。在对话框中输入说明文字，

注意请不要输入中文，图形区域不支持中文。输入结束后点击

Ok 摁扭。 
3、此时鼠标图标变为十字形，输入一个标注需要插入位置的坐标。 
4、如果还需要插入其它说明文单，则可以重复第 2、3 步。 
5、如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 

 
图 2-78 

 
Delete 

Utilities>Dimension>Delete 
z 功能：删除已经创建的标注 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，选择需要删除的标注。 
3、单击鼠标中键或者键盘 ESC 键。 

 
Edit 

Utilities>Dimension>Edit 
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z 功能：编辑已有的标注。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，选择需要修改的标注。 
3、弹出如图 2-78 的对话框，框中文字为原标注显示文字，修改后

可以替代现有的文字。点击 Ok 摁扭，确认修改标注中的文字。 
4、如果还需要编辑其它的标注，则可以重复第 2、3 步。 
5、如果要结束命令，可以单击鼠标中键或者键盘 ESC 键。 

 
Show Box 

Utilities>Dimension>Show Box 
z 功能：是否显示标注文字的边框 
z 操作： 

1、点击该菜单 
2、选择是否要显示菜单，On 为显示，Off 为不显示。 
3、此时鼠标图标为回字形，选择需要修改的标注。 
4、单击鼠标中键或者键盘 ESC 键。 

 

第六节 Data 菜单 
 

 
图 2-78 

Problem Type 
Data>Problem Type 
载入问题类型的所对应的对话框 

 
图 2-79 

 
Fepg 

Data>Problem Type>Fepg 
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功能：根据选择 FEPG 生成的问题文件，调入对应的菜单。 
操作：点击该菜单即可 
 
 

Conditions 
Data>Problem Type>Conditions 

 
   图 2-80 

 
z 功能：调出边界条件施加对话框 
z 操作：点击该菜单即可 
z 说明： 

1、该菜单中的一些选项会因为问题类型或者名字的不同而改变。 
2、该对话框中操作和规定有如下的一些规定： 

z 所有边界条件的命名原则如下 几何元素类型： point 、
line、surface、volume 加载荷名称构成。 

z 边界条件物理量命名：该物理场自由度名加 I 或者 D，其

中 I 表示 ID 规格数，规格数的类型有 1（自由）、0（没有

自由度）、-1（约束）。D 表示 Disp 给定节点值，该值为任

意的实数，或者可以写与坐标有关的表达式，如 X*Y*2
注意，一定要按照 Fortran 的格式书写，并且只可以与坐

标有关的表达式，且首字符为字母开头。 
z 料名称按照，几何模型类型加场名和单元名表示，如

line-sdull2。 
3、可以通过 Draw 功能来检查模型边界条件施加的情况，以便检

查有无错误或者遗漏。 
4、通过 Assign 来施加边界条件，操作步骤是： 

z 选择需要施加的边界条件类型 
z 输入边界条件的数字 
z 点击 Assign，此时鼠标图标变为回字形，选择需要施加的

模型类型 
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z 点击鼠标中键或者键盘 ESC 键结束命令。 
5、通过 Unassign 可以删除已经施加上的边界条件。 

 

第七节 Meshing 菜单 
 

 
图 2-81 

 

§7-1 单元划分设定 
 

§7-1-1 单元阶次选择 
 

Quadratic Elements 
Meshing>Quadratic Elements 

 
图 2-82 

 
z 功能：选择单元的阶次。 
z 操作：点击该菜单，选择需要的单元阶次 
z 说明： 

1、默认的单元阶次为一次单元 
2、二次单元分为两类，第一类 Quadratic 为一般的二次单元，比如

3 节点线单元、6 节点三角形单元、8 节点四边形单元、10 节点

四面体单元、20 节点六面体单元。而第二类 Quadratic9 只有如

下两种单元，9 节点四边形单元、27 节点六面体单元 
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§7-1-2 局部加密 
 

Assign Unstruct Sizes 
Meshing>Assign Unstruct Sizes 

 
图 2-83 

 
Points 

Meshing>Assign Unstruct Sizes>Points 
z 功能：在某些点的局部加密网格 
z 操作： 

1、点击该菜单 
2、此时弹出如图 2-84 的对话框，输入局部加密的尺寸。点击 Ok

摁扭。 
3、此时鼠标图标变为回字形，选择需要加密的点，单击鼠标中键

或者键盘 ESC 键。 
4、再一次弹出图 2-84 的对话框，重复第 2、3 步，加密其它的点

的密度。 
5、如果要结束命令，单击鼠标中键或者键盘 ESC 键。 

 
图 2-84 

 
Lines 

Meshing>Assign Unstruct Sizes>Lines 
z 功能：在某些线的局部加密网格 
z 操作： 

1、点击该菜单 
2、此时弹出如图 2-85 的对话框，输入局部加密的尺寸。点击 Ok

摁扭。 
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3、此时鼠标图标变为回字形，选择需要加密的线，单击鼠标中键

或者键盘 ESC 键。 
4、再一次弹出图 2-85 的对话框，重复第 2、3 步，加密其它的线

段的密度。 
5、如果要结束命令，单击鼠标中键或者键盘 ESC 键。 

 
图 2-85 

 
Surfaces 

Meshing>Assign Unstruct Sizes>Surfaces 
z 功能：在某些面局部加密网格 
z 操作： 

1、点击该菜单 
2、此时弹出如图 2-86 的对话框，输入局部加密的尺寸。点击 Ok

摁扭。 
3、此时鼠标图标变为回字形，选择需要加密的面，单击鼠标中键

或者键盘 ESC 键。 
4、再一次弹出图 2-86 的对话框，重复第 2、3 步，加密其它的面

密度。 
5、如果要结束命令，单击鼠标中键或者键盘 ESC 键。 

 
图 2-86 

 
Volume 

Meshing>Assign Unstruct Sizes>Volume 
z 功能：在某些体局部加密网格 
z 操作： 

6、点击该菜单 
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7、此时弹出如图 2-87 的对话框，输入局部加密的尺寸。点击 Ok
摁扭。 

8、此时鼠标图标变为回字形，选择需要加密的体，单击鼠标中键

或者键盘 ESC 键。 
9、再一次弹出图 2-87 的对话框，重复第 2、3 步，加密其它的体

密度。 
10、 如果要结束命令，单击鼠标中键或者键盘 ESC 键。 

 

 
图 2-87 

 
By Cordal error 

Meshing>Assign Unstruct Sizes>By Cordal Error 
z 功能：设定弧线段的网格误差精度 
z 操作：点击该菜单，弹出如图 2-88 对话框。 
z 说明： 

1、 调整弧线相对误差精度，在 Cordal Error 中输入误差精度，

在 Maximum Meshing Size：中输入最大网格尺寸，在 Minimum 
Meshing Size 中输入网格最小尺寸，网格生成程序会根据上面

的尺寸调整最后生成的网格。 
2、 以上设定的是所有弧线的精度，但是如果需要针对一条弧线

审定的时候，可以先选择线标签，然后在图形区域选择弧线，

设定其弧线精度和最大最小网格尺寸。 
3、 点击 OK 摁扭，退出设定对话框。 
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图 2-88 

Correct Sizes 
Meshing>Assign Unstruct Sizes>Correct Sizes 
z 功能：优化网格尺寸 
z 操作：点击该菜单，弹出图 2-89 对话框。 
z 说明 

1、在 Maximum Meshing Size：后输入单元最大尺寸；在 Minimum 
Meshing Size：后输入最小网格尺寸，默认为自动。 

2、选中 By Geometry 前的复选框，则表示所有的实体的单元大小

按照模型的形状来定义，也就是说，一个小的面上的单元尺寸，

可能会比给定的最小网格划分尺寸还小。 
3、选中 Correct Incompatible Sizes 前的复选框，则表示优化不协调

的网格尺寸，也就是说，在一个封闭的几何模型内，由于网格

尺寸选取的不合适，导致划分后的模型不是很完整，则程序减

小单元尺寸，来较好的充满模型边界。 

 
图 2-89 

 
Background Mesh 

Meshing>Assign Unstruct Size>Background Mesh 
z 功能：根据一个已有的网格来细分网格的局部尺寸。 
z 操作：点击该菜单，弹出输入文件对话框，输入背景网格文件。 
z 说明： 
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1、 此种网格局部细分，只可以用于三角形或者四面体网格中。 
2、 文件的格式为： 
z 第一行必须为 Background Mesh V 1.0 
z 下面一段与 File>import>Gid Mesh 格式一样 
z 最后一段为网格细化细化因子段。 
DesiredSize (Nodes or Elements) 
 number of        size 
 node/element 
 
下面是一个较为完整的文件格式 

 
BackgroundMesh V 1.0 
MESH dimension       2 ElemType Triangle  Nnode 3 
Coordinates 
      1        5.61705       4.81504         0.00000 
 ... 
     51        -5.64191       -1.53335        0.00000 
end coordinates 
  
Elements 
      1         24         16         26  
      2         16         10         14  
... 
     76         34         31         28  
end elements 
 
DesiredSize Elements 
      1         0.20000 
      2         0.20000 
... 
     75         1.50000 
     76         1.50000 
End DesiredSize 
 

3、 注意该网格文件必须为同模型已有的网格数据文件。 
 

§7-1-3 结构化网格 
 

Meshing>Structured 
 

用来划分结构化的网格模型。 
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图 2-90 

 
Lines 

Meshing>Structured>lines 
 
z 功能：生成等尺寸线单元 
z 操作： 

1、点击该菜单 
2、弹出如图 2-91 对话框，输入每条线段上的等分数。点击 Ok 摁

扭。 
3、此时鼠标图标变为回字形，选择需要结构划分的线段。 
4、单击鼠标中键或者键盘 ESC 键，再次弹出如图 2-91 对话框，

如果还需划分其它的线段，重复第 2、3 步。 
5、如果要结束命名，点击 Cancel、鼠标中键或者键盘 ESC 键。 

 
图 2-91 

 
Surfaces 

Meshing>Structured>Surfaces 
z 功能：对面进行结构化划分 
z 操作： 

1、 点击该菜单 
2、 此时鼠标图标变为回字形，选择需要结构化划分的面。 
3、 单击鼠标中键或者键盘 ESC 键，弹出图 2-91 对话框，输入

边的等分数目，点击 OK 摁扭。 
4、 此时鼠标图标变为回字形，选择需要等分的边。单击鼠标中

键或者键盘 ESC 键。 
5、 重新弹出图 2-91 的对话框，重复第 2、3、4 步，设定其它边

的等分数。注意当选中一条边的时候，程序同时选中所有对应

边。 
 

Volume 
Meshing>Structured>Volume 



 73

z 功能：对体进行结构化划分 
z 操作： 

1、 点击该菜单 
2、 此时鼠标标图标变为回字形，选择需要结构化划分的体。 
3、 单击鼠标中键或者键盘 ESC 键，弹出图 2-91 对话框，输入

边的等分数目，点击 OK 摁扭。 
4、 此时鼠标图标变为回字形，选择需要等分的边。单击鼠标中

键或者键盘 ESC 键。 
5、 重新弹出图 2-91 的对话框，重复第 2、3、4 步，设定其它边

的等分数。注意当选中一条边的时候，程序同时选中所有对应

边。 
 

Concentrate Elements 
Meshing>Structures>Concentrate Elements 
z 功能：设定偏置网格比例 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要产生集中网格的面或者体

的边。 
3、后单击鼠标中键或者键盘 ESC 键，弹出图 2-92 集中因子输入

对话框。修改对话框中的集中因子，注意方向为图形区域中，

被选中直线显示的箭头指向为结束端。集中因子的正负为与箭

头的相同或相反来区分。点击 Ok 摁扭确认修改值。 
4、此时鼠标图标有变为回字形，重复第 2、3 步。设定其它的线段

的集中因子。 
5、如果要结束该命令，单击鼠标中键或者键盘 ESC 键。 

 
图 2-92 

 
 

§7-1-4 网格划分顺序选择 
 

Meshing> Mesh Criteria 
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图 2-93 

 
Default 

Meshing>Mesh Criteria>Default> 
z 功能：默认方式划分网格 
z 操作： 

1、点击该菜单，选择需要设定的模型元素类型：线、面、体。 
2、此时鼠标图标变为回字形，选择需要按照确省方式划分的模型。 
3、单击鼠标中键或者键盘 ESC。 

说明： 
1、按照默认的方式划分网格，那么在边界上，不会重新生成新的

单元。 
2、如果需要在边界上生成一套对立的网格，那么可以按照下面的

Mesh 功能来实施。 
 

Mesh 
Meshing>Mesh Criteria>Mesh> 
z 功能：在边界上按照已有的节点，生成一套新的网格。 
z 操作： 

1、点击该菜单，选择需要生成单元的实体模型元素。 
2、此时鼠标变为回字形，选择需要生成网格的模型元素。 
3、单击鼠标中键或者键盘 ESC 键。 

 
No Mesh 

Meshing>Mesh Criteria>No Mesh> 
z 功能：不生成网格 
z 操作： 

1、点击该菜单，选择不需要生成单元的实体模型元素。 
2、此时鼠标变为回字形，选择不需要生成网格的模型元素。 
3、单击鼠标中键或者键盘 ESC 键。 

 

§7-1-5 单元类型 
Meshing>Element type> 

 
图 2-94 
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z 功能：指定模型元素需要划分的网格类型 
z 操作： 

1、点击该菜单，选择需要生成的网格类型。 
2、此时鼠标图标变为回字形，选择需要划分的模型元素。 
3、点击鼠标中键或者键盘 ESC 键。 

z 说明： 
 

1、单元类型有： 
线单元：2 节点线单元、3 节点线单元 

                
三角形单元：3 节点三角形单元、6 节点三角形单元 

                
四边形单元：4 节点四边形单元、8 节点四边形单元、9 节点四

边形单元 

                   
四面体单元：4 节单四面体单元、10 节单四边形单元 

           
六面体单元：8 节点六面体单元、20 节点六面体单元、27 节点六

面体单元 

 
 

2、三角形、四边形用于面的划分；四面体、六面体用于体的划分。 
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§7-1-6 显示边界单元 
 

Boundaries 
Meshing>Boundaries 
z 功能：显示表面单元。 
z 操作： 

1、点击该菜单。 
2、弹出如图 2-95 对话框，选择 Yes 则得到表面网格， 选择 NO

则取消表面网格。 
z 说明： 

1、当渲染的时候，需要操作该步骤，因为渲染的时候为了节省内

存，一般只渲染表面的边界单元 
2、有时直接在网格模型下，执行渲染（Render）操作，可能会看

不到模型，此时需要操作该操作来得到表面网格的渲染图。 
3、如果已经得到了边界网格，但是想显示全部网格，那么需要选

择对话框 2-95 中的 No 然后切换到几何模型再切换到网格模型

即可。 

 
图 2-95 

§7-1-7 显示设定单元值 
 

Draw Sizes 
Meshing>Draw Sizes 
z 功能：显示设定的单元尺寸 
z 操作：点击对应的模型元素菜单即可 
z 说明： 

1、该操作主要是为了显示模型元素的单元尺寸，注意只显示与默

认整体单元尺寸不同的单元尺寸。 
2、一般实用该操作可以预先知道单元尺寸的大致分布，并用不同

的颜色表示不同的尺寸，以便预测得到较好的网格。 
3、显示的尺寸大小为在 Assign Unstructured size 中设定的值。 

 

§7-2 取消设定或者删除网格 
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Reset Mesh Data 
Meshing>Reset Mesh Data 
z 功能：取消所有已经设定的单元尺寸。 
z 操作： 

1、点击该菜单。 
2、弹出如图 2-96 对话框，点击 Ok 摁扭就可清除所有的设定。 

 
图 2-96 

 
Cancel Mesh 

Meshing>Cancel Mesh 
z 功能：删除所有已生成的网格 
z 操作： 

1、 点击该菜单。 
2、 弹出如图 2-97 对话框，点击 OK 摁扭删除已生成的网格。 

 
图 2-97 

§7-3 网格生成功能 
 

§7-3-1 网格生成 
Meshing>Generate 
z 功能：根据设定的网格尺寸生成网格 
z 操作： 

1、点击该菜单 
2、弹出图 2-98 对话框，输入网格默认尺寸值，点击 Ok 摁扭。 
3、弹出图 2-99 对话框，显示网格生成顺序。 
4、网格生成结束后弹出如图 2-100 对话框，显示出生成的单元数、

节点数。 
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图 2-98 

 
图 2-99 

 
图 2-100 

Mesh view 
Meshing>Mesh View 
 
z 功能：网格模型和几何模型之间切换 
z 操作：点击该菜单即可 

 

§7-3-2 网格质量检验 
 

Quadratic 
Meshing>Quadratic 
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z 功能：显示单元质量 
z 操作：点击该菜单弹出如图 2-101 单元质量对话框 
z 说明： 

1、Minimum Angle：表面网格的最小单元角或者体单元的二面角，

如果存在太小的角度，则表明单元质量比较差 
2、 Maximum Angle：表面单元的最大单元角或者体单元的二面

角，如果存在太大的角度，则表明单元质量比较差。 
3、一般用最小角来判断三角形或者四面体单元的质量，用最大单

元角来判断四边形或者六面体单元的质量 
4、Element VOL：单元的尺寸（线单元的长度、面单元的面积、

体单元的体积）如果该数值比较小则认为单元质量比较差。 
5、Minimum Edge：最小单元棱长，如果该值较小则表明该单元质

量较差。 
6、Distribution：单元角度显示的方式，这里有两种，Normal 形式

显示某一个尺寸所包含的单元个数。Accumulated：则按照在某

个范围内的个数显示。 
7、Quadratic Criteria：单元判断段的尺度，可以选择的有 Minimum 

Angle、Maximum Angel、Element VOL、Minimum Edge 四种检

验标准。 
8、在对话框坐标值中，点击某一个数字，对应一个单元数，并且

在网格图形中，用红色标示出该范围内的单元。并且可以配合

对话框中 Send To Layer 将这些单元发送到某一图层， 
9、在下面的图 2-101 对话框中，表示的为使用最小单元棱长作为

检验标准，有 140 个单元的角度小于 45.7 度，如果我们双击模

型中的那条红线，那么小于 45.7 度的 140 个单元就被选中。 

 
图 2-101 
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§7-4 编辑网格 
 

Meshing>Edit Mesh 
可以修改已经产生的网格的一些属性 

 
图 2-102 

Move Node 
Meshing>Edit Mesh>Move Node 
z 功能：移动单元节点 
z 操作： 

1、点击该菜单 
2、此时鼠标图标变为回字形，选择需要移动的节点 
3、此时鼠标图标变为十字形，输入节点新的坐标。 
4、如果需要移动其它的节点，可以重复第 2、3 步。 
5、如果要结束命令，单击鼠标中键或者键盘的 ESC 键。 

 
Delete Elements 

Meshing>Edit Mesh>Delete Elements 
z 功能：删除已有的单元 
z 操作： 

1、 点击该菜单 
2、 此时鼠标为回字形，选择需要删除的单元 
3、 点击鼠标中键或者键盘的 ESC 键，删除所选单元。 
4、 如果还需要删除其它的单元，重复第 2、3 步。 
5、 如果需要结束命令，单击鼠标中键或者键盘 ESC 键。 

 
Delete Lonely Nodes 

Meshing>Edit Mesh>Delete Lonely Nodes 
z 功能：删除模型中孤立的单元节点 
z 操作： 

1、 点击该菜单 
2、 弹出图 2-103 对话框，点击 Ok 摁扭，删除孤立的单元节点。 

 
图 2-103 
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第八节 Calculate 菜单 
 

 
图 2-104 

z 功能：导出模型数据 
z 操作： 

1、点击该菜单 
2、弹出图 2-105 对话框，点击 Ok 关闭对话框 

 
图 2-105 

 

第九节 Help 菜单 

 
图 2-106 

 
Help 

Help>Help 
z 功能：启动在线帮助手册 
z 操作：点击该菜单，弹出图 2-107 帮助对话框。 
z 说明：可以提供以下三种检索方式 

z 目录排序 
z 命令名字母排序 
z 关键字检索功能。 
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图 2-107 

 
Tutorials 

Help>Tutorials 
z 功能：启动在线范例教学 
z 操作：点击该菜单，弹出图 2-108 对话框 
z 说明： 

1、该教程提供了三个例题。 
2、点击任何一个例题进去，对话框将详细的介绍每一步操作。 

 
图 2-108 
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What is New 
Help>What is New 
功能：介绍新版本功能 
操作：点击该菜单，弹出介绍新功能的对话框。 
 

FAQ 
Help>FAQ 
功能：常见问题解答 
操作：点击该菜单，弹出常见问题对话框。 
 

Visit GID Web 
Help>Visit GID Web 
功能：访问 GID 官方网站 
操作：点击该菜单，弹出网页浏览器连接 GID 官方网页。 
 

Register 
Windows>Register 
功能：输入注册信息 
操作：点击该菜单，弹出注册对话框，输入注册码。 
 

第十节 辅助功能简介 
 

§10-1 右侧菜单功能 
 

 
图 2-109 

说明： 
1、该菜单的主要功能和主菜单功能类似，注意，某些操作可能不一样，

操作的时候需要注意提示框的说明文档。 
2、在书写 Batch 文件时，主要就是按照该菜单的操作顺序，以及该菜单

中的命令名和参数书写。关于该类 Batch 文件的导入功能，参见

File>Import>Read Batch File 说明文档。 
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§10-2 鼠标菜单功能 
 

当在执行一些命令的时候，需要选择一些元素类型的时候，可以点击鼠标右

键，得到一些快捷辅助操作。由于对应的不同对象已经不同的命令菜单可能有些

改变，但是大体功能和使用都类似。故此在这里主要介绍创建线命令时，选择点

的鼠标菜单。 
说明： 

1、单击鼠标右键，弹出的对话框如下图 2-110，其中第一级菜单，在

任何操作的时候都一样，注意，没有其它操作命令的时候 Contextual
为灰色，没有第二级菜单。 

2、对于第一级菜单，大家可以参照对应的主菜单的介绍来操作，主要

介绍 Contextual 产生的第二级菜单。 
3、第二级菜单主要有以下主要选项： 
z Base：以某一个点的坐标为基准，操作的时候程序自动提取出

基准点的坐标，然后用户修改其坐标值。 
z Join C-a：自动捕捉点，该操作就是直接捕捉鼠标附近已存在的

点。 
z Point in line：该操作主要为了能够准确的获得，鼠标附近任意

线段上的一个点。 
z Point in surface：该操作主要为了能够准确的获得，鼠标附近任

意面上的一个点。 
z Tangent in line：该操作主要用来获得被选取线段的切线方向。 
z Normal in surface：该操作主要用来获取被选取面的法线方向。 
z Arc Center：该操作主要用来获取被选弧线的中心点。 

 

 
图 2-110 
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第三章   后处理 

第一节  主界面说明 

§1-1 主界面 

用户通过前处理 Files 菜单中的 Postprocess 切换到后处理界面。后处理基

本界面如下图 3-1 所示。 

 
图 3-1 后处理基本界面 

§1-2 功能工具条 

 
图 3-2 功能工具条 

工具条是一种作为方便用户操作的辅助菜单，其每一项功能都可以在相应的

菜单中找到对应的命令，所以在这里，只介绍每一项的功能及对应菜单的位置，

具体的功能及操作在菜单对应项中具体说明，用户可以参考下面的章节。 
可以看到，本工具条被 分割为五部分 ，每一个部分分别对应以下的菜
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单项 。 

§1-2-1  View 工具条 

该部分对应 View 菜单，该操作和功能与前处理中的一致，可以参见前处理

界面说明中 View 菜单说明文档。 
 
功能： 

 
图 3-3  View 菜单 

 
    对应菜单 

z 放大：View>Zoom>In 
z 缩小：View>Zoom>Out 
z 居中：View>Rotate>Center 
z 刷新：View>Redraw 
z 旋转：View>Rotate>Trackball 
z 移动：View>Pan>Two point 

§1-2-2 光源、显示类型及透视工具条 

功能： 

 
图 3-4 光源、显示类型及透视工具条 

 
对应菜单 
z 光源位置： View>Render>Chang light dir 
z 显示类型： Windows>View Style 
z 透视方式： Windows>View Style 

 
对于显示类型和透视方式有以下的选择项： 
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功能： 

 
图 3-5 显示类型 

 
图 3-6 透视方式 

§1-2-3 剪切后的显示工具条 

功能： 

 
图 3-7 剪切后的显示 

 
对应菜单： 
z 实体显示与消隐：Windows>View style 
z 面显示与消隐：Windows>View style 
z 分割面显示消隐：Windows>View style> 

§1-2-4 剪切面工具条 

功能： 
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图 3-8 剪切面 

对应菜单 
z 做分割面：Do cuts>Cut Plane 

§1-2-5 结果值工具条 

功能： 

 
图 3-9 

对应菜单： 
z 调整最大显示值：Option>Contour>Max Options>Set Value 
z 调整最小显示值：Option>Contour>Min Options>Set Value 
z 按照实际值显示：Option>Contour>Reset All 
z 列出单元、节点属性：Utilities>List 

§1-3  菜单条 

 
图 3-10  菜单条 

z Files：文件操作菜单 
z View：视图选择与调整 
z Utilities：辅助功能操作 
z Do Cuts：剪切操作 
z View Results：结果显示方式 
z Options：修改显示属性 
z Window：功能对话框 
z Help：帮助文档 
下面我们按照菜单的顺序，对菜单中的一些常用的功能，以及使用方法做一

个简要的介绍，如果你想了解更多，更详细的功能，可以查找 GID Reference 

Manual，或者可以在帮助中找到。 
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第二节   Files 菜单 

 
图 3-11  Files 菜单 

§1-1 文件操作 

New 

Files>New 
新建一个后处理文档 

Open 

File>Open 
打开已有的后处理文档 

Merge (ASCII) 

Files>Merge 
打开一个网格文件或者结果文件，添加到当前的项目中。 

§1-2 导入结果文件 

FEMAP 

Files>Import>FEMAP 
导入 FEMAP 的后处理结果文件 
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TECPLOT 

Files>Import>TECPLOT 
导入 TECPLOT 的后处理格式结果文件 

CUT 

Files>Import>Cut 
导入一个刨切位置，一般需要通过 Files>Export>Cut>导出某一位置，将其保

存为 ASCCI 文件，然后被该命令调用。 

Graphs 

Files>Import>Graphs 
插入一个已经存在的图表，一般需要通过 Files>Export>Graphs 导出某图表，

将其保存为 ASCCI 文件，然后被该命令调用。 

§1-3 导出 

§1-3-1  Post information 

Files>Export>Post information 
后处理信息文件 

ASCCI Files 

Files>Export>Post information>ASCCI Files 
导出网格及结果的 ASCCI 格式文件。并可以被 Files>Merge (ASCCI)操作读

入。 

One Binary files 

Files>Export>Post information>One Binary files 
将后处理网格及节点值信息保存为一个二进制码文件。并可以被 Files>Open

操作读入，并且读入速度比 ASCCI 文件速度快。 

Binary files 

Files>Export>Post information>Binary files 
导出网格和结果文件的二进制码文件。并可以被 Files>Open 操作读入，并

且读入速度比 ASCCI 文件速度快。 
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§1-3-2 Cut 

该菜单显示内容，与用户的操作有关，主要与 Do cuts>Cut plane>操作结果

有关，这里主要是为了保存该操作的刨切位置。 

§1-3-3 Graph 

该菜单显示的内容，与用户的操作有关，主要与 View Results>Graphs>操作

结果有关，这里主要是为了，保存该图表的数据文件。 

§1-4 打印设置 

该菜单与前处理功能和操作一致，请参见前处理对应说明文档。 

§1-5 Preprocess 

切换到前处理界面菜单。 

§1-6 Exit 

退出菜单。 

第三节  View 菜单 

 
图 3-12 View 菜单 

    该菜单的主要功能与前处理中的功能一样，请参见第二章第三节的内容 

第四节  Utilities 菜单 
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图 3-13 Utilities 菜单 

ID 

Utilities>ID 
列出节点坐标，具体功能和操作可参见第二章第五节。 

Single 

Utilities>Single> 
标示节点、单元位置，具体功能和操作可参见第二章第五节。 

Distances 

Utilities>Distances 
计算两点间距离，具体功能和操作可参见第二章第五节。 

Collapse 

Utilities>Collapse 
在该操作之前，需要使用 Do Cuts 菜单中的功能，做出一些分割体，分割面、

分割线，然后通过本操作，合并掉这些分割单元中重叠部分的节点。 

Join 

Utilities>Join 
在该操作之前，需要使用 Do Cuts 菜单中的功能，做出一些分割体，分割面、

分割线，然后通过本操作将所有显示状态下的整合为一个。 
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Delete 

Utilities>Delete 
删除设定的分割体、分割面、分割线等。 

Texture 

Utilities>texture 
给模型附着上材质（图形具有质感）。 

Status 

Utilities>Status 
列出当前项目的一些基本信息。 

 
图 3-14 状态对话框 

List 

Utilities>List> 
显示出所选择节点或者单元的信息。 
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图 3-15 

 
图 3-16 

Preferences 

Utilities>Preferences 
设定系统参数，具体操作、说明请参见第二章第五节。 

Calculate 

Utilities>Calculate 
弹出一个计算器，功能和操作参见第二章第五节。 

Dimension 

Utilities>Dimension 
在模型中添加标注，功能和操作参见第二章第五节。 
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第五节  Do cuts 菜单 

 
图 3-17 Do cuts 菜单 

Cut Plane 

Do cuts>Cut Plane 
z 功能：得到需要位置的切片 
z 操作： 

1、点击该菜单 
2、选择切片方式，两点或者三点，此时鼠标图标为十字形，此时输入

点的坐标。 
3、如果还需要得到其它的切片，重复第 2 步。 
4、如果需要结束该命令，单击鼠标中键或者键盘 ESC 键。 

z 说明： 
1、如果选择的切片方式为 2 点，表示由两点确定的直线，然后根据值

线做垂直于屏幕平面的垂直面。所得的垂直面与模型的交接面，为

所得的切片面。 
2、如果选择的切片方式为 3 点，表示由三点确定的平面与模型交接面，

为所得的切片面。 

Divide by selection 

Do Cuts>Divide by selection 
z 功能：根据用户选择的单元，设定一个显示部分。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，然后选择需要的单元。 
3、单击鼠标中键或者键盘 ESC 键，弹出图 3-18 对话框，选择 New set

摁扭，表示创建一个新的设定名称，具体的设定名称和操作，参见

第 8 节 Windows>View style 对话框中的说明。选择 Old set 摁扭，表

示还是保存在原来的设定中。点击 Cancel 则表示退出该操作。         
4、选择 New Set 后，弹出图 3-19 对话框，输入设定的名称。点击 Ok。 
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图 3-18 

 

 
图 3-19 

Divide Volume Sets 

Do cuts>Divide Volume Sets 
z 功能：获得体单元部分的显示设定。 
z 操作： 

1、点击该菜单 
2、选择分割方式，两点或者三点，此时鼠标图标为十字形，此时输入

点的坐标。当输入完要求的点数后，此时鼠标图标仍然是十字形，

此时需要选择分割后保留的部分。 
z 说明： 

1、如果选择的分割方式为 2 点，表示由两点确定的直线，然后根据该直

线垂直于屏幕平面的垂直面。所得的垂直面与模型的交接面，为所得

体的边界面，然后根据选择的保留部分的边界面构成新的体。 
2、如果选择的切片方式为 3 点，表示由三点确定的平面与模型交接面，

为所得体的边界面，然后根据选择的保留部分的边界面构成新的体。 

Divide surface sets 

Do cuts>Divide Surface sets 
z 功能：获得面单元部分的显示设定。 
z 操作： 

1、点击该菜单 
2、选择分割方式，两点或者三点，此时鼠标图标为十字形，此时输入点
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的坐标。当输入完要求的点数后，此时鼠标图标仍然是十字形，此时

需要选择分割后保留的部分。 
z 说明： 

1、如果选择的分割方式为 2 点，表示由两点确定的直线，然后根据该直

线做垂直于屏幕平面的垂直面。所得的垂直面与模型的交线，为所得

面的边界线，然后根据选择的保留部分的边界线构成新的面。 
2、如果选择的切片方式为 3 点，表示由三点确定的平面与模型交接线，

为所得面的边界线，然后根据选择的保留部分的边界线构成新的面。 
 

Divide line sets 

Do cuts>Divide line sets 
z 功能：获得线单元部分的显示设定。 
z 操作： 

1、点击该菜单 
2、选择分割方式，两点或者三点，此时鼠标图标为十字形，此时输入点

的坐标。当输入完要求的点数后，此时鼠标图标仍然是十字形，此时

需要选择分割后保留的部分。 
z 说明： 

1、如果选择的分割方式为 2 点，表示由两点确定的直线，然后根据该线

做垂直于屏幕平面的垂直面。所得的垂直面与模型的交点，为所得线

的端点，然后根据选择的保留部分的端点构成新的线。 
2、如果选择的切片方式为 3 点，表示由三点确定的平面与模型交接点，

为所得线的端点，然后根据选择的保留部分的端点构成新的线。 

Succession 

Do cuts> Succession 
z 功能：同时得到多个平行切片 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为十字形，输入两点坐标创建一条直线，弹出图 3-20

对话框，要求输入需要得到的切片数。点击 Ok 摁扭，确认命令。 
 
z 说明： 

由两点确定的直线，然后根据该线做垂直于屏幕平面的垂直面。

所得的垂直面与模型的交线，然后再沿着该交线做需要的切片数的

垂直面，这些垂直面与模型的交面，即为需要的切片面。 
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图 3-20 

Cut wire 

Do cuts>Cut wire 
 

z 功能：得到一条路经线段。 
z 操作： 

1、点击该菜单 
2、此时鼠标图表为十字形，输入该路径上点的坐标，注意，这些点必须

在单元的棱上。 
3、单击鼠标中键或者键盘 ESC 键，结束操作。 

Convert cuts to surface sets  

Do cuts>Convert cuts to surface sets 
 

z 功能：将所有的刨切保存为切面，以便保存刨切位置。 
z 操作：点击该菜单即可 
z 说明：关于保存刨切位置的文件请参见第二节，Files>Export>Cut 菜单

说明文档。 

第六节  View Results 菜单 

结果的可视化显示，可以提供的可视化显示类型有：云图、等直线、向量图、

等值面、流线、图表、动化等功能，下图 3-21 为基本功能操作菜单。 
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图 3-21 View Results 菜单 

No Results 

View Results>No Results 
z 功能：清除图形区域的结果图形。 
z 操作：点击该菜单即可。 

No Graph 

View Results>No Graph 
z 功能：清除图形区域的图表图形 
z 操作：点击该菜单即可 

Default analysis/Step 

View Results>Default analysis/Step  
z 功能：选择当前结果为第几步载荷步数 
z 操作： 

1、点击该菜单，点击进入 Load_Analysis 菜单。 
2、此时弹出显示了所有结果载荷步步数菜单，选择需要读入载荷步数。 

Contour Fill 

View Results>Contour Fill 
z 功能：以云图方式显示结果 
z 操作：点击该菜单，选择物理场，最后选择需要显示的自由度名。 

Contour Lines 

View Results>Contour Lines 
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z 功能：以等直线的方式显示结果 
z 操作：点击该菜单，选择物理场，最后选择需要显示的自由度名。 

Show Min Max 

View Results>Show Min Max 
z 功能：显示出最大最小值的位置 
z 操作：点击该菜单，选择物理场，最后选择需要显示的自由度名。 

Display Vector 

View Results>Display Vector 
z 功能：以矢量方式显示结果。 
z 操作：点击该菜单，选择物理场，最后选择需要显示的自由度名。 

Iso surfaces 

View Results>Iso Surfaces 
以等值面的方式显示结果 

 
图 3-22 

Exact 

View Results>Iso Surface>Exact 
z 功能：根据用户的选择，生成不同的等值面。 
z 操作： 

1、点击该菜单，选择物理场名，最后选择需要显示的自由度。 
2、弹出图 3-23 对话框，输入需要得到的等值面的个数。 
3、弹出图 3-24 对话框，输入每个等值面的值。 

 
图 3-23 
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图 3-24 

Automatic 

View Results>Iso surfaces>Automatic 
z 功能：按照用户输入的等值面个数，按照等分的形式显示每个面的值。 
z 操作： 

1、点击该菜单，选择物理场名，最后选择需要显示的自由度。 
2、弹出图 3-23 对话框，输入需要得到的等值面的个数。 

Automatic wide 

View Results>Iso Surfaces>Automatic wide 
z 功能：根据用户输入的每两个等值面的差值，自动生成等值面。 
z 操作： 

1、点击该菜单，选择物理场名，最后选择需要显示的自由度。 
2、弹出图 3-24 对话框，输入需要得到的等值面的公差。 

Stream lines 

View>Results>Stream lines 
z 功能：以流线的方式显示结果。 
z 操作： 

1、点击该菜单，选择物理场名，最后选择需要显示的自由度。 
2、此时鼠标图标变为十字形，输入一个出口附近的点坐标。 
3、如果还需要其它位置的流线，可以重复第 2 步。 
4、如果需要结束命令，单击鼠标中键或者键盘的 ESC 键。 

z 说明： 
        该功能只可以用于四面体单元类型的分析结果 

Graph 

View Results>Graph 
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图 3-25 

Show 

View Results>Graph>Show 
z 功能：显示图标。 
z 操作：点击该菜单即可。 

Clear 

View Results>Graph>Clear 
z 功能：清除所有的图表设定。 
z 操作：点击该菜单即可。 

Point Analysis 

View Results>Graph>Point Analysis 
z 功能：显示点随着时间步长的结果值。 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为十字形，输入模型内的点坐标。 

Point Graph 

View Results>Graph>Point Graph 
z 功能：显示一些点的结果值的比较图表。 
z 操作： 

1、点击该菜单选择 Set X axis，接着选择场名，再选择自由度名 
2、再点击该菜单，选择 Set Y axis, 接着选择场名，再选择自由度名 
3、最后再点击该菜单，选择 select points。 

Border Graph 

View Results>Graph>Border Graph 
z 功能：显示边界上或者用 cutwire 产生的路径线段的点的结果与坐标的

关系的曲线图 
z 操作： 

1、点击该菜单，选择 Set X axis，接着选择场名，再选择自由度名 
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2、再点击该菜单，选择 Set Y axis, 接着选择场名，再选择自由度名 
3、最后再点击该菜单，选择 select border。 

Deformation 

View Results>Graph>Deformation 
z 功能：察看变形结果 
z 操作：点击该菜单，选择需要察看的物理场即可。 

第七节  options 菜单 

 
图 3-26 options 菜单 

§7-1 Legends 

Options>Legends 
主要修改结果值标尺部分显示功能 

 
图 3-27 

Show 

Option>Legend>Show 
z 功能：是否显示结果值标尺框 
z 操作： 

1、点击该菜单 
2、弹出图 3-28 对话框，选择 Yes 则显示标尺框，选择 No 则不显示标

尺框。 
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图 3-28 

Opaque 

Option>Legend>Opaque 
z 功能：设定标尺框是否透明 
z 操作： 

1、点击该菜单 
2、弹出图 3-29 对话框，选择 Yes 则标尺框背景不透明，选择 No 则表

示标尺框背景透明。 
 

 
图 3-29 

Show title 

Option>Legend>Show tile 
z 功能：设定标尺框是否显示标题 
z 操作： 

1、点击该菜单 
2、弹出图 3-30 对话框，选择 Yes 则标尺框显示标题，选择 No 则表示

标尺框不显示标题。 
 

 
图 3-30 
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Change title 

Option>Legend>Change title 
z 功能：修改标尺框的标题 
z 操作： 

1、点击该菜单 
2、弹出图 3-31 对话框，输入新的标题。 

 

 
图 3-31 

Outside 

Option>Legend>Outside 
z 功能：将标尺框弹出图形界面 
z 操作：点击该菜单即可 

Automatic commands 

Option>Legend>Automatic commands 
z 功能：将当前的图形类型、场名、自由度名显示在图形窗口的下方 
z 操作： 

1、点击该菜单 
2、弹出图 3-32 对话框，选择 Yes 则显示，选择 No 则不显示。 

 
图 3-32 

§7-2 Contour 

Option>Contour 
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对于结果云图显示的修改 

 
图 3-33 

Number of Colors 

Option>Contour>Number of colors 
z 功能：设定显示的云图中色带条数。 
z 操作： 

1、点击该菜单 
2、弹出图 3-34 对话框，输入需要显示的色带条数。 

 
图 3-34 

Width Intervals 

Option>Contour>Width Intervals 
z 功能：设定色带间数值的差值 
z 操作： 

1、点击该菜单 
2、弹出图 3-35 对话框，输入每两条色带间结果值。 
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图 3-35 

 

Set limits 

Option>Contour>Set limits 
 

 
图 3-36 

Shown sets for this step 

Option>Contour>Set limits>Shown sets for this step 
z 功能：按照本时间步该自由度设定的最大最小值范围显示本时间步的结

果 
z 操作：点击该菜单即可 

 

All sets for this step 

Option>Contour>Set limits>All sets for this setp 
z 功能：按照所有时间步所有自由度设定的最大最小值范围显示本时间步

的结果 
z 操作：点击该菜单即可 

 

Shown sets for all steps 

Option>Contour>Set limits>Shown sets for all steps 
z 功能：按照所有时间步该自由度设定的最大最小值范围显示所有时间步

的结果 
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z 操作：点击该菜单即可 
 

All sets for all steps 

Option>Contour>Set limits>All sets for all steps 
z 功能：按照所有时间步所有自由度设定的最大最小值范围显示所有时间

步的结果。 
z 操作：点击该菜单即可。 

 

Define limits 

Option>contour>Define Limits 
z 功能：设定云图显示的最大最小显示范围 
z 操作： 

1、点击该菜单 
2、弹出图 3-37 对话框，点取前面的复选框，表示按照默认数值显示，

反之，点取对话框中的+和-图标来增加或者减小显示范围数值。点

击 Apply 应用退出。 
 

 
图 3-37 

 
 

Reset Limit Values 

Option>Contour>Reset Limit Values 
z 功能：清除设定本时间步自由度的最大最小值设定 
z 操作：点击该菜单即可 

 

Reset all 

Option>Contour>Reset Limit Values 
z 功能：清除所有最大最小值的设定 
z 操作：点击该菜单即可 
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Max Options 

Option>Contour>Max Options 
设定最大值显示效果 

 
图 3-38 

 

Rest Value 

Option>Contour>Max Options>Rest Value 
z 功能：重新设定最大值范围 
z 操作：点击该菜单即可 

 

Out Max color 

Option>Contour>Max Options>Out Max Color 
设定超出最大值后的颜色设定 

 
图 3-39 

 

Black 

Option>Contour>Max Options>Out Max Color>Black 
z 功能：设定超过设定最大值部分的颜色为黑色 
z 操作：点击该菜单即可 

 

Max Color 

Option>Contour>Max Options>Out Max Color>Max Color 
z 功能：设定超过设定最大值部分的颜色与最大值的颜色一致。 
z 操作：点击该菜单即可 
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Transparent 

Option>Contour>Max Options>Out Max Color>Transparent 
z 功能：设定超过设定最大值部分的颜色为透明 
z 操作：点击该菜单即可 

 

Material 

Option>Contour>Max Options>Out Max Color>Material 
z 功能：设定超过设定最大值部分的颜色为设定的材质 
z 操作：点击该菜单即可 

 

Def. Max color 

Option>Contour>Max Options>Def. Max Color 
z 功能：设定最大值的颜色。 
z 操作： 

1、点击该菜单 
2、弹出调色板对话框，选择自己需要的颜色，点击 Ok 即可 

 

Set Value 

Option>Contour>Max Options>Set Value 
z 功能：设定最大值的数值 
z 操作： 

1、点击该菜单 
2、弹出图 3-40 对话框，输入最大值。 

 

 
图 3-40 
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Min Options 

Option>Contour>Min Options 
设定最小值显示效果，该菜单和功能于前面 Max Options 一样，这里就不再

说明，具体菜单参见前面对应的说明文档。 
 

Color Scale 

Option>Contour>Color Scale 
设定云图显示效果 

 
图 3-41 

 

Standard 

Option>Contour>Color Scale>Standard 
z 功能：按照标准的显示效果显示云图 
z 操作：点击该菜单即可 

 

Inverse Standard 

Option>Contour>Color Scale>Inverse Standard 
z 功能：按照相反于标准的显示效果显示云图 
z 操作：点击该菜单即可 

 

Terrain Map 

Option>Contour>Color Scale> Terrain Map 
z 功能：按照地图中地形的显示效果显示云图 
z 操作：点击该菜单即可 
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Black White 

Option>Contour>Color Scale> Black White 
z 功能：按照黑白对比效果显示云图 
z 操作：点击该菜单即可 

 

Scale Ramp 

Option>Contour>Color Scale> Scale Ramp 
z 功能：设定最大最小值颜色之间过渡方式。 
z 操作：点击该菜单，选择需要的过渡方式 
z 说明：可以提供的过渡方式有三种，Tangent、Linear、Arc Tangent 默认

的方式为 Arc Tangent。 

 
图 3-42 

 

Scale Type 

Option>Contour>Color Scale>Scale Type 
z 功能：选择最大最小值颜色过渡比例类型 
z 操作：点击该菜单，选择需要的比例类型 
z 说明：可以提供的比例类型有 RGB 和 HSV。 

 

 
图 3-43 

 

§7-3 Iso Surface 

 
Options>Iso Surfaces 
设定等值面的显示效果 

 
图 3-44 
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Display Style 

Options>Iso Surfaces>Display Style 
z 功能：设定显示等值面的方式 
z 操作：点击该菜单，选择显示方式即可。 
z 说明：提供的显示方式有 Lines、Hidden Lines、Body、Body Lines 四种

方式 
z Lines：带由网格线的等值面 
z Hidden Lines：显示不带网格线的等值面 
z Body：显示着色后的等值面 
z Body Line：显示着色且带有边界线的等值面 

 

 
图 3-45 

 

Render 

Options>Iso surfaces>Render  
z 功能：设置等值面渲染效果 
z 操作：当击该菜单，选择渲染方式，可以选择的渲染方式有：Normal

和 flat 两种。 
z 说明： 

z Normal：普通的渲染方式 
z Flat：平滑的渲染方式 

 

 
图 3-46 

Transparences 

Options>Iso Surfaces>Transparence 
z 功能：设定等值面是否透明显示 
z 操作：点击该菜单，选择是否透明选项。 
z 说明： 

z Opaque：等值面不透明显示 
z Transparence：等值面透明显示 
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图 3-47 

 

Convert to sets 

Options>Iso Surfaces>Convert to sets 
z 功能：将等值面作为切片的方式保存 
z 操作：点击该菜单即可 

 
 

§7-4 Vectors 

Options>Vectors 
设定向量显示方式 

 
图 3-48 

 

Interior/All Vectors 

Options>Vectors>Interior/All Vectors 
z 功能：是否显示所有位置的向量 
z 操作： 

1、点击该菜单 
2、弹出图 3-49 对话框，点击 Yes 则表示显示所有位置的向量，点击

No 则表示只显示边界位置的向量。 

 
图 3-49 
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Number Of Color 

Options>Vectors>Number Of Color 
z 功能：设定向量显示的色彩个数 
z 操作： 

1、点击该菜单 
2、弹出图 3-50 对话框，输入色彩个数点击 Ok。 

 

 
图 3-50 

 

Color mode 

Options>Vectors>Color Mode 
z 功能：设定向量显示是按照彩色还是单色显示 
z 操作： 

1、点击该菜单 
2、弹出图 3-51 对话框，选择 Colour Modules 则表示按照彩色显示向

量，选择 Mono Colour 则表示按照单色显示向量。 
 

 
图 5-51 

Change Colour（Mono） 

Options>Vectors>Change Colour 
z 功能：设定单色显示的向量时的颜色 
z 操作： 
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1、点击该菜单 
2、弹出调色板对话框，选择需要的颜色，点击确定退出。 

 

Detail 

Options>Vectors>Detail 
z 功能：修改向量箭头显示的方式 
z 操作：点击该菜单，选择需要的向量箭头显示方式 
z 说明： 

可以提供的向量显示方式： 
z No Arrow：不显示向量的箭头 
z Point：以点代替箭头显示向量 
z Lines：用线的方式表示向量箭头 
z 2 Triangles：用 2 三角形面显示向量箭头 
z 4 Triangles：用 4 三角形面显示向量箭头 
z 8 Triangles：用 8 三角形面显示向量箭头 
 

 
图 5-52 

 

§7-5 Stream Lines 

 
Options>Stream Lines 

 
图 5-53 

 

Change Colour 

Options>Stream Lines>Change Colour 
z 功能：改变流线的颜色 
z 操作： 

1、点击该菜单 
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2、弹出调色板对话框，选择需要的颜色，点节确定退出。 
 

Delete 

Options>Stream Lines>Delete 
z 功能：删除已有的流线 
z 操作： 

1、点击该菜单 
2、此时鼠标图标为回字形，选择需要删除的流线，单击鼠标中键或者

键盘 ESC 键，确定操作，退出命令。 
 

Label 

Options>Stream Lines>Label 
z 功能：在流线上加标签 
z 操作： 

1、点击该菜单 
2、弹出图 5-54 对话框，选择需要施加标签的方式。 

z 说明： 
施加标签的方式有： 
z None ：没有标签 
z 0 End：在流线开始的地方标上 0，结束的地方标上需要的时间 
z Ini End：在创建流线位置，标上 0，在进口端用负数表示从流入口

到该点的时间，在出口端标上从该点到出口端的时间。 

 
图 5-54 

§7-6 Graph 

Options>Graph 
修改图表的显示属性 
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图 3-55 

 

Grids 

Options>Graph>Grids 
z 功能：在图表中显示网格线 
z 操作： 

1、点击该菜单 
2、弹出图 3-56 对话框，选择 Yes 表示显示网格线，选择 No 表示不

显示网格线。 
 

 
图 3-56 

 

Current Style 

Options>Graph>Current Style 
z 功能：设定新图表的显示类型 
z 操作： 

1、点击该菜单 
2、弹出图 3-57 对话框，选择需要的显示类型。 

z 说明： 
z Dot：点的形式显示 
z Line：折线形式显示 
z Dot Line：带有端点的折线显示 
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图 3-57 

 

Change style Graph  

Options>Graph>Change Style Graph 
z 功能：修改以后图表模型的显示类型 
z 操作： 

1、点击该菜单，选择需要修改的图表。 
2、弹出图 3-58 对话框，选择需要显示的类型。 

z 说明： 
z None：不显示该图表 
z Default：按照默认形式显示 
z Dot：点的形式显示 
z Line：折线形式显示 
z Dot Line：带有端点的折线显示 

 
图 3-58 

 

Change Graph Color 

Options>Graph>Change Graph Color 
z 功能：修改显示图表的颜色 
z 操作： 

1、点击该菜单，选择需要修改颜色的图表。 
2、弹出调色板，选择需要显示的颜色，点击确定退出。 
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Change Line width 

Options>Graph>Change Line Width 
z 功能：修改显示线的宽度 
z 操作： 

1、点击该菜单，选择需要修改的图表 
2、弹出图 3-59 对话框，输入一个介于 0.5 到 10 的数表示线的像素大

小。 
 

 
图 3-59 

 

Change Line Pattern 

Options>Graph>Change Line Pattern 
z 功能：修改图表显示的线型 
z 操作： 

1、点击该菜单，选择需要修改的图表。 
2、弹出图 3-60 对话框，选择需要的线形。 

 

 
图 3-60 
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Change Pattern factor 

Options>Graph>Change Pattern factor 
z 功能：修改线型的显示比例 
z 操作： 

1、点击该菜单，选择需要修改的图表。 
2、弹出图 3-61 对话框，输入该线显示的比例因子。 

 

 
图 3-61 

 

Change Point Size 

Options>Graph>Change Point Size 
z 功能：修改图表中点的显示大小 
z 操作： 

1、点击该菜单，选择需要修改的图表 
2、弹出图 3-62 对话框，输入点显示的像素大小。 

 

 
图 3-62 

 

Change Title Graph 

Options>Graph>Change Title Graph 
z 功能：修改图表的标题 
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z 操作： 
1、点击该菜单，选择需要修改标题的图表 
2、弹出图 3-63 对话框，输入新的标题，点击 Ok 确认修改。 

 

 
图 3-63 

Title 

Options>Graph>Title 
修改整体图表的标题 

 
图 3-64 

 

Change text 

Options>Graph>Title>Change Text 
z 功能：修改标题文字 
z 操作： 

1、点击该菜单 
2、弹出图 3-65 对话框，输入新的标题文字。 

 

 
图 3-65 
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Change Position 

Options>Graph>Title>Change Position 
z 功能：修改标题显示的位置 
z 操作：点击该菜单即可。 

 

Reset 

Options>Graph>Title>Reset 
z 功能：恢复所有修改，恢复到原来状态 
z 操作：点击该菜单即可。 

 

Reset Axis Value 

Options>Graph>Reset Axis Value 
z 功能：恢复所有修改过的坐标值 
z 操作：点击该菜单即可 

 

X Axis 

Options>Graph>X Axis 
修改图表中 X 轴的属性 

 
图 3-66 

 

Reset 

Options>Graph>X Axis>Reset 
z 功能：恢复 X 轴的修改属性。 
z 操作：点击该菜单即可 
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Set Min Value 

Options>Graph>X Axis>Set Min Value 
z 功能：设定 X 轴的最小值 
z 操作： 

1、点击该菜单 
2、弹出图 3-67 对话框，输入 X 轴最小值大小。 

 

 
图 3-67 

 

Set Max Value 

Options>Graph>X Axis>Set Max Value 
z 功能：设定 X 轴的最大值 
z 操作： 

1、点击该菜单 
2、弹出图 3-68 对话框，输入 X 轴最大值大小。 

 
图 3-68 

Set Divisions 

Options>Graph>X Axis>Set Divisions 
z 功能：设定 X 轴数值等分数 
z 操作： 

1、点击该菜单 
2、弹出图 3-69 对话框，输入等分数。 
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图 3-69 

 

 Set label 

Options>Graph>X Axis>Set label 
z 功能：设定 X 轴的标签 
z 操作： 

1、点击该菜单 
2、弹出图 3-70 对话框，输入 X 轴的标签。 

 

 
图 3-70 

 

Y Axis 

Options>Graph>Y Axis 
修改图表中 X 轴的属性，具体的每一个菜单和功能于前面 Y Axis 一样。具

体操作与功能说明参见前面文档。 
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第八节  Windows 

 
图 3-71 

View Style 

Windows>View Style 
z 功能：视图属性修改对话框 
z 操作：点击该菜单弹出图 3-72 对话框。 
z 说明： 

1、Volume、Surface、Cuts、Alphabetic Order 前都有一个复选框，选

中复选框，则表示该项被激活，图 3-72 中表示可显示体、面、切

片。并按照字母顺序排列。 
2、Style 中为可以选择的类型，有 Boundary、Hidden Bound、All Lines、

Hidden Lines、Body、Body Bound、Body Lines、Points。 
3、Render 为渲染方式,有 Normal、Flat、Smooth。后两种可以设定光

源。 
4、Culling 为视角位置可以切换为前视角和背面视角。 
5、可以通过 Rename 键修改模型的名称，通过点击图 3-72 中的“显

示”或者“消隐”摁扭，可显示或者消隐模型的相应部分。 

 
图 3-72 
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View Results 

Windows>View Results 
z 功能：显示结果图形 
z 操作：点击该菜单，弹出图 3-73 
z 说明： 

1、Steps：列出了载荷步数，选择载荷步，则下面显示该载荷步的结

果值。 
2、View：可以选择的显示形式有： 

z No Results：不显示结果图 
z Display Vectors：显示结果向量图 
z Contour fill：显示结果云图 
z Contour Lines：显示结果等直线图 
z Show Min Max：显示结果最大最小值位置  

3、Factor：尺寸比例因子，主要用来显示向量图时，控制显示的向量

的大小。 
4、Results：选择需要显示结果的物理场名。 
5、Component：选择需要显示结果的自由度名。 

 

 
图 3-73 

 

Deform Mesh 

Windows>Deform Mesh 
z 功能：设定变形与原始模型比较结果 
z 操作：点击该菜单，弹出图 3-74 对话框 
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z 说明： 
1、该对话框有两项可供选择，Main Mesh 来设定原始或者变形，

References Mesh，来设定变形前后参照设定。 
2、在 Main Mesh 中，Original 和 Deform 两个当选框，选择 Original

表示保持原型，选择 Deform 表示显示变形，并且其他选项激活。 
z Step：选择当前载荷步，这主要对于动态问题来说的。 
z Result：选择需要显示变形的物理场名 
z Factor：设定变形因子。 

3、在 Preference Mesh 中，Off、Original、Deform 三个选项，分别表

示步显示对比，Original 设定原型显示效果，Deform 设定变形后的

效果。当选中 Original 和 Doform 当选框时，不同的对话框功能激

活。 
z Use Color：一个选项是 Of Mesh 表示显示的颜色与模型中网

格的颜色一致，关于网格的颜色设定可以参见 Windows>View 
Style 对话框。另一个激活调色板选择颜色。 

z Step：选择当前载荷步，这主要对于动态问题来说的。 
z Result：选择需要显示变形的物理场名 
z Factor：设定变形因子。 

 

       
图 3-74                         图 3-75 

Animate 

Windows>Animate 



 129

z 功能：生成动画图 
z 操作：点击该菜单，弹出图 3-76 对话框 
z 说明： 

1、Result View：显示结果图，可以先通过 View Results 菜单，然后在

动画中显示结果图 
2、Automatic Limits：如果选中复选框，表示按照每一步自己的最大最

小值显示，否则按照当前最大最小值显示。 
3、Deformation ：在动画中显示变形情况，必须先通过 View 

Results>Doformation 显示变形后在做其他操作。 
4、Endless：选中复选框，表示生成的动画文件循环播放。 
5、Delay：表示每一帧的延时时间，单位是毫秒。 
6、Step：表示开始时的载荷步数。 
7、文件可以保存为动画和图片，选择中 Save 前的复选框，则可以激

活保存功能，可以保存的图片格式有 TIFF、JPEG、GIF。可以保

存的动画格式有：MPGE、AVI/ Mipge、AVI/Raw True color、AVI/Raw 
15 bpp、GIF。 

8、在最左下角的菜单条可以选择窗口大小，可供选择的窗口大小有

800*600、720*576、640*480、512*384、352*288、320*240。 
9、Static analysis animation Profile，点击该项，弹出图 3-77 对话框，

设定静态问题中自由度值变化的方式，可供选择的有四种结果值变

化形式。并可在 Steps 中设定时间步数。 

 
图 3-76 
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图 3-77 

Border Graph 

Windows>Border Graph 
 

z 功能：显示与边界坐标有关物理量的图表 
z 操作：点击该菜单，弹出图 3-75 对话框。 
z 说明： 

1、该功能与 View Results>Graphs>border Graph 功能一样。 
2、第一个菜单框，选择图表中 X 轴的物理量，可供选择的有线坐标、

模型 X 坐标、模型 y 坐标、模型 Z 坐标。 
3、第二个菜单框，选择需要显示的物理量的场名 
4、根据物理量场名的不同，对话框中显示出对应的自由度名，通过点

击不同自由度前面的单选框，设定图表中 Y 轴的物理量。 
5、Action 菜单框有 Draw Graph：显示图表，No Draw Graph：不显示

图表，Clear Graph 清除图表。三个选项。 
6、Select Border：点击该项后鼠标图标变为回字形，选择需要绘制图

表的边界线，该边界线的设定可以通过 Do cuts>Cut Wire 来绘制。 
 

 
图 3-78 
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Several Results 

Windows>Several Results 
 

z 功能：设定不同的显示方式在同一个图形中显示 
z 操作：点击该菜单，弹出图 3-79 对话框 
z 说明： 

1、选择 One By One 单选框表示图形中可以显示一种结果显示方式 
2、选择 One over Another 单选框表示图形中，可以显示多种显示方式，

比如同时显示云图和向量图。 
3、每次选择后，需要点击 Apply 摁扭来确认修改。 

 
 

 
图 3-79 

 

第九节  Help 

 

 
图 3-80 

该菜单功能与前处理第十节内容相同，具体操作参见该章。 
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第四章 例题 
 

第一节 球体的结构化网格划分 
1、启动 GID 
2、创建 1/8 半球面 
z Geometry>Create>Arc 
z 在命令行依次输入坐标 1,0 ；1<45 ；1<90。 
z View>Zoom>Frame 
z Utilities >copy 
z 设置 copy 对话框 entities types：lines ；Transformation ：Rotation；

Angle：90；second point：Y：1；Do extrude：surfaces。 
z 选择 copy 对话框的 select 按扭，选择圆弧线。点击 Finish 键，得

到 1/8 圆弧面。 
 

3、创建半球面等分点 
z 通过 View>Rotate>Trackball 调整模型到一个合适的视图位置。 
z Geometry>Edit>Divide>Num divisions 选择一条 1/8 圆弧边，在弹

出 Enter value window 对话框，输入 2，点击 OK. 
z 同样的操作，等分其余的 2 条线。 
z Geometry>Create>Line，通过鼠标右键菜单，选择 JoinC-a 项,连接

顶点与它对边中点，做出两条这样的线段。图 4-1 

 
图 4-1 

z Geometry>Create>intersection>Line-Line,选择刚做的两条线。 
z Utilities >copy 设置 copy 对话框， entities types ： points ；

Transformation ：translation；second point：pick 选择上一步得到

的点；Do extrude：NO。 
z 选择 copy 对话框的 select 按扭，选择上两步得到的点。点击 Finish

键，得到另一个点。 
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z Geometry>Create>Line, 通过鼠标右键菜单，选择 JoinC-a 项,连接

上一步得到的点，以及 0,0 点。 
z Geometry>Create>Line 按照图 4-2 分别连接球面外两点与球面边

界中点。 

 
图 4-2                          

z Geometry>Create>NURBS surfaces>automatic 弹出的 Enter Value 
window 对话框中输入 3.可以得到如下图 4-3 

 
图 4-3 

z Geometry>Create>intersection>multiple surfaces 然后选择所有的面，

单击鼠标的中键或者键盘 Esc 键。 
z 删除所有多余的几何信息，注意保留两个关键点，如下图 4-4。 
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图 4-4 

4、连接等分线 
z 选择菜单 Geometry>Create>Line, 通过鼠标右键菜单，选择 JoinC-a

项,按照下图 4-5,连接各个关键点。 

 
图 4-5 

 
z Utilities >copy 修改 Copy 对话框， entities types ： points ；

Transformation ：translation；second point：-1，0，0；Do extrude：
Line,然后点击 select 按扭，选择 accessorial point，单击鼠标中键，

或者键盘 ESC 键退出，得到一条直线。 
z 再次在 Copy 对话框中，保持上述设置，修改 second point：0，-1，

0；选择 accessorial point，单击鼠标中键，或者键盘 ESC 键退出，

得到一直线。 
z 再一次在 Copy 对话框中，保持上述设置，修改 second point：0，0，

1；选择 accessorial point，单击鼠标中键，或者键盘 ESC 键退出，

得到一直线。结果如下图 4-6 
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图 4-6 

z 生成边界面，Geometry>Create>NURBS surfaces>automatic 弹出的

Enter Value window 对话框中输入 4.可以得到如下图 4-7 

 
图 4-7 

z Geometry>Create>intersection>Surface-Lines，选择上步得到的面和

与他相交的一条线，求交点，然后删除外面多余的线，重复做两次，

得到其他的两个面和线的交点，并删除外面多余的线。得到如下图

4-8。 

 
图 4-8 

z 等分所有半球边界直线，Geometry>Edit>Divide>Num divisions。选

择直线，弹出 Enter value window 对话框输入 2，就可以得到如下

图 4-9。 
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图 4-9 

z 连接统一平面内边界线以及中心辅助点与 1/8 球面中心点，如下图

4-10。 

 
图 4-10 

5、生成 1/8 半球体 
z 删除所有的面，Geometry>delete>surface，选择所有的面。 
z Geometry>Create> NURBS surfaces>automatic 弹出的 Enter Value 

window 对话框中输入 4.可以得到如下图 4-11。 

 
图 4-11 

 
z Geometry>Create>Volume>Automatic-6-sides volume。生成 1/8 个球
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体，如下图 4-12 

 
图 4-12 

6、通过 Copy 等到 1/4 ,1/2,整体球。 
z Utilities >copy 修改 Copy 对话框， entities types：Volumes；

Transformation ：Mirror；first point ,second point ;third point 分别任

意选择一个对称面上的三个点；Do extrude： NO,然后点击 select
按扭，选择所有的体，单击鼠标中键，或者键盘 ESC 键退出，得

到 1/4 球体。 
z Utilities >copy 修改 Copy 对话框， entities types：Volumes；

Transformation ：Mirror；first point ,second point ;third point 分别任

意选择一个对称面上的三个点；Do extrude： NO,然后点击 select
按扭，选择所有的体，单击鼠标中键，或者键盘 ESC 键退出，得

到 1/2 球体。 
z Utilities >copy 修改 Copy 对话框， entities types：Volumes；

Transformation ：Mirror；first point ,second point ;third point 分别任

意选择一个对称面上的三个点；Do extrude： NO,然后点击 select
按扭，选择所有的体，单击鼠标中键，或者键盘 ESC 键退出，得

到整体球体。 
z 得到如下图 4-13,13 的一个整体球。 

 
图 4-13 

 
7、划分网格 
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z 先合并模型重合信息，通过菜单 Utilities>Collapse>Model。 
z Meshing>Structured>Volumes，选择所有的实体，单击鼠标中键或者键盘

ESC 键，弹出一个对话框，输入每条边需要该划分网格的等分数 4。点

击 OK 退出该对话框。选择所有的线段，单击鼠标中键或者键盘 ESC 键。 
z 选择菜单 Meshing>Generate,弹出输入单元最小尺寸对话框，由于我们已

经设定为结构划分，所以这里不起作用，点击 Ok 进行划分操作。 
z 网格划分程序结束后，弹出图 4-14 对话框，显示出生成的单元数，节点

数。点击 Ok 退出，可以看到图 4-15。 
 

 
图 4-14 

 
图 4-15 

 
z 通过菜单 Meshing>Boundaries，弹出对话框，选择 Yes 选项，可以看到如下

图 4-16。 
z 通过菜单 View>Render>Filled，渲染模型如图 4-17。 
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图 4-16 

 
图 4-17 
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