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请注意以下有关 Microchip 器件代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术指标。

• Microchip 确信：在正常使用的情况下， Microchip 系列产品是当今市场上同类产品中最安全的产品之一。

• 目前，仍存在着恶意、甚至是非法破坏代码保护功能的行为。就我们所知，所有这些行为都不是以 Microchip 数据手册中规定的操

作规范来使用 Microchip 产品的。这样做的人极可能侵犯了知识产权。

• Microchip 愿与那些注重代码完整性的客户合作。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是 “牢不可破”的。

代码保护功能处于持续发展中。 Microchip 承诺将不断改进产品的代码保护功能。任何试图破坏 Microchip 代码保护功能的行为均可视

为违反了《数字器件千年版权法案（Digital Millennium Copyright Act）》。如果这种行为导致他人在未经授权的情况下，能访问您的软

件或其他受版权保护的成果，您有权依据该法案提起诉讼，从而制止这种行为。
提 供 本 文档 的 中 文 版 本 仅 为 了 便 于 理 解。 Microchip
Technology Inc. 及其分公司和相关公司、各级主管与员工及

事务代理机构对译文中可能存在的任何差错不承担任何责任。
建议参考 Microchip Technology Inc. 的英文原版文档。

本出版物中所述的器件应用信息及其他类似内容仅为您提供便

利，它们可能由更新之信息所替代。确保应用符合技术规范，
是您自身应负的责任。Microchip 对这些信息不作任何明示或

暗示、书面或口头、法定或其他形式的声明或担保，包括但不

限于针对其使用情况、质量、性能、适销性或特定用途的适用
性的声明或担保。 Microchip 对因这些信息及使用这些信息而

引起的后果不承担任何责任。未经 Microchip 书面批准，不得

将 Microchip 的产品用作生命维持系统中的关键组件。在

Microchip 知识产权保护下，不得暗中或以其他方式转让任何

许可证。
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前言
简介

本章包含在使用 PICSTART Plus 器件编程器之前有必要了解的通用信息。 本章中讨论
的内容包括：

•  关于本指南

•  保修登记

•  推荐读物

•  Microchip 网站

•  开发系统客户变更通知服务

•  客户支持

关于本指南

文档编排

本文档说明了使用 PICSTART Plus 作为开发工具将固件编程到目标器件的方法。  手册
按如下方式编排：

•  第 1 章： PICSTART Plus 综述——描述了 PICSTART Plus 及其工作方式。

•  第 2 章： PICSTART Plus 的安装——PICSTART Plus 硬件和 MPLAB 软件的安装
方法。

•  第 3 章： 教程——包括编程校准存储器件、存储器件和其它 PICmicro MCU 器件的
教程。

•  第 4 章： 使用 PICSTART Plus——使用 PICSTART Plus 编程器件的方法。

•  第 5 章： PICSTART Plus——MPLAB IDE 使用参考——使用 PICSTART Plus 菜
单和 Options 菜单下的 PICSTART Plus 选项。

用户须知

所有文档均会更新，本手册也不例外。 Microchip 工具和文档都在不断演变以满足客户的需
求，因此在实际中某些对话框和 / 或工具的说明可能与本文档中描述的有所不同。 请访问我
们的网站 （www.microchip.com）获取最新的可用文档。

文档以 “DS”编号标识。 此编号位于每页的底部，在页码前面。 DS 编号的约定为
“DSXXXXXA”，其中 “XXXXX”是文档编号而 “A”是文档的版本级别。

如需了解有关开发工具的最新信息，请参阅 MPLAB IDE 在线帮助。 选择 “Help”菜单，
然后选择 “Topics”打开可用的在线帮助文件列表。
© 2005 Microchip Technology Inc. DS51028F_CN第 1 页
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•  附录 A：“硬件规范”——提供 25 针串行端口、电压变更和编程器尺寸的信息。

•  附录 B： 疑难解答——解决常见问题的方法。

本指南中使用的约定

此用户指南使用以下文档约定：

保修登记

请填写随附的保修登记卡并尽快寄出。 寄出保修登记卡的用户可得到产品更新信息。 
并可在 Microchip 网站上使用临时发布的软件。

文档约定

描述 表示 示例

Arial 字体：

斜体字 参考书目 MPLAB IDE 用户指南

需强调的文字 ... 是唯一的编译器 ...
首字母大写 窗口 Output 窗口

对话框 Settings 对话框

菜单选项 选择 Enable Programmer
引用 窗口或对话框中的字段名称 “Save project before build”
带右尖括号且带有下划线的斜
体文本

菜单路径 File>Save

粗体字 对话框按钮 单击 OK
选项卡 单击 Power 选项卡

‘bnnnn 二进制数，其中 n 是一个数字 ‘b00100, ‘b10
带尖括号 < > 的文本 键盘上的键 按下 <Enter>,<F1>
Courier 字体：

常规 Courier 源代码示例 #define START

文件名称 autoexec.bat

文件路径 c:\mcc18\h

关键字 _asm, _endasm, static

命令行选项 -Opa+, -Opa-

位的值 0, 1

斜体 Courier 可变参数 file.o，其中 file 可以是任
何有效文件名

0xnnnn 十六进制数，其中 n 是一个十
六进制数字

0xFFFF, 0x007A

方括号 [ ] 可选参数 mcc18 [ 选项 ] 文件 [ 选项 ]
花括号和直线字符： { | } 选择互斥参数；进行“或”选

择

errorlevel {0|1}

省略号 ... 替换重复文本 var_name [, 
var_name...]

表示用户提供的代码 void main (void)
{ ...
}

DS51028F_CN 第 2 页 © 2005 Microchip Technology Inc.
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推荐读物

本用户手册描述了使用 MPLAB PICSTART Plus 编程器的方法。 以下所列为其它有用

的文档。 这些 Microchip 文档均已提供，建议将它们作为补充参考资料使用。

PICSTART Plus 的 README 文件

如需了解使用 PICSTART Plus 的最新信息，请参阅 MPLAB IDE 安装目录下 Readmes
子目录的 Readme for PICSTART Plus.txt（ASCII 文本文件）。 该 Readme 文件
包括本用户指南中不一定包括的更新信息和已知问题。

PICSTART Plus 在线帮助

MPLAB IDE V6.XX 快速入门指南 （DS51281_CN）

描述设置 MPLAB IDE 软件并用它创建项目和编程器件的方法。

MPASM™ User's Guide with MPLINK™ Linker and MPLIB™ Librarian 
（DS33014）
此用户指南描述了使用 Microchip PICmicro® MCU MPASM 汇编器、 MPLINK 目标链

接器和 MPLIB 目标库文件的方法。

MPLAB IDE 在线帮助

In-Circuit Serial Programming™ (ICSP™) Guide （DS30277）
本文档包含有用的设计指南，依照这些设计指南可成功进行 ICSP 编程。其中包括硬

件设计的应用笔记和 ICSP 编程规范。

MICROCHIP 网站

Microchip 通过 WWW 网站 www.microchip.com 提供在线支持。 利用该网站，客户可

简便地获取文件和信息。您可使用常用的因特网浏览器进行访问，网站包含如下信息：

•  产品支持——数据手册和勘误表、应用笔记和样本程序、设计资源、用户指南和硬
件支持文档、最新软件发布以及归档软件。

•  常规技术支持——常见问题 （Frequently Asked Questions， FAQ）、技术支持请
求、在线讨论组、 Microchip 顾问计划成员名单。

•  Microchip 的业务范围——产品选型和定购指南、Microchip 最新发布的新闻稿、研
讨会和活动列表、 Microchip 销售办事处、代理商和厂商代表处列表。
© 2005 Microchip Technology Inc. DS51028F_CN 第 3 页
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开发系统客户变更通知服务

Microchip 客户通知服务有助于用户了解 Microchip 产品的最新信息。 订阅者将收到有
关特定产品系列或所需开发工具在发生变更、升级、修订或勘误表时的电子邮件通知。

如需注册，请访问 Microchip 网站 www.microchip.com，点击客户变更通知并按照注
册指导进行注册。

开发系统产品组包括以下类别：

•  编译器——Microchip C 编译器和其它语言工具的最新信息。 包括 MPLAB C17、
MPLAB C18 和 MPLAB C30 C 编译器； MPASM™ 和 MPLAB ASM30 汇编器；
MPLINK™ 和 MPLAB LINK30 目标链接器以及 MPLIB™ 和 MPLAB LIB30 目标库
管理器。 

•  仿真器——Microchip 在线仿真器的最新信息。包括 MPLAB ICE 2000 和 MPLAB 
ICE 4000。

•  在线调试器——Microchip 在线调试器 MPLAB ICD 2 的最新信息。

•  MPLAB IDE——Microchip MPLAB IDE （开发系统工具的 Windows® 集成开发环
境）的最新信息。此类别主要针对 MPLAB IDE 和 MPLAB SIM 模拟器、 MPLAB 
IDE 项目管理器和常规编辑与调试功能。

•  编程器——Microchip 编程器的最新信息。 包括 MPLAB PM3 和 PRO MATE® II 器
件编程器以及 PICSTART® Plus 开发编程器。

客户支持

Microchip 产品的用户可以通过以下渠道获得帮助：

•  代理商或代表处

•  当地销售办事处

•  现场应用工程师 （Field Application Engineer， FAE）
•  技术支持

•  开发系统信息热线

客户应该联络代理商、代表处或现场应用工程师 （FAE）获取支持。 当地销售办事处
也可为用户提供支持。 本文档末尾包括了销售办事处及其地址的列表。

也可通过以下站点获得技术支持： http://support.microchip.com
此外，还有一条开发系统信息热线也列出了最新版本的 Microchip 开发系统软件产品。 
此热线还为用户提供了接收最新升级包的方法。

开发系统信息热线号码为： 
1-800-755-2345——美国和加拿大大部分地区

800-820-6247——中国大陆

1-480-792-7302——全球其他地区
DS51028F_CN 第 4 页 © 2005 Microchip Technology Inc.
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第 1 章  PICSTART Plus 综述
1.1 简介

本章概述 PICSTART Plus 开发编程器的功能和要求。 本章中包括以下主题：

•  什么是 PICSTART Plus 编程器？

•  PICSTART Plus 系统组件

•  PICSTART Plus 符合 CE 标准

•  PICSTART Plus 编程器如何帮助您进行开发？

1.2 什么是 PICSTART PLUS 编程器？

PICSTART Plus 是 Microchip 单片机开发编程器，用于将用户软件写入 PICmicro 单片
机。 如果器件封装不是 PICSTART Plus 所支持的 DIP 封装，则需要使用适配器。 
Microchip 网站上列出了现有的这类器件。

1.3 PICSTART PLUS 系统组件

PICSTART Plus 开发编程器系统包括：

•  PICSTART Plus 开发编程器 （图 1-1）
•  RS-232 接口线缆，用于连接到任何标准 PC 的串行端口

•  9V 电源

•  MPLAB IDE 软件——集成开发环境，详见第 1.7 节 “MPLAB 开发工具”

•  用于编程的空白芯片

注： PICSTART Plus 编程器设计用于固件开发而非生产用途。
© 2005 Microchip Technology Inc. DS51028F_CN 第 5 页
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图 1-1： PICSTART PLUS 开发编程器

1.4 PICSTART PLUS 符合 CE 标准

PICSTART Plus 开发系统是跟据电磁兼容性要求亦即 CE 指令来设计、测试和认证的。 
这些标准由欧盟 （EU）国家规定，包括限制辐射、减少辐射的磁化系数和减少静电放
电 （ESD）的磁化系数。

1.5 PICSTART PLUS 编程器如何帮助您进行开发？

PICSTART Plus 开发编程器具有以下功能：

•  编程 PICmicro 单片机，包括程序存储器、配置位和 ID 单元。

•  在 PC 兼容的主机系统上作为 Windows® 应用程序在 MPLAB 集成开发环境
（IDE）下工作。

•  通过标准的 RS-232 线缆与 PC 通信。

•  通过 MPLAB IDE，用户可以创建、显示和编辑用于烧录到 PICmicro 单片机
（MCU）的数据。

此外，您还可以验证 PICmicro MCU 是否为空白，验证目标单片机中的代码是否与
固件匹配，并且可以从未保护的 PICmicro MCU 将代码读到 MPLAB IDE 程序存储
器窗口，以便调试代码并将其编程到其它 PICmicro MCU 器件中。
DS51028F_CN 第 6 页 © 2005 Microchip Technology Inc.



PICSTART Plus 综述
1.6 MPLAB 集成开发环境

MPLAB 桌面提供开发和调试应用程序的环境。 PICSTART Plus 已集成到 MPLAB IDE
里。

本文档涵盖了 PICSTART Plus 器件编程器的基本设置和操作，  但并未包括 MPLAB 
IDE 的所有功能。 若想全面了解 MPLAB IDE 特性和调试功能，请参照 MPLAB IDE 文
档。

1.7 MPLAB 开发工具

MPLAB IDE 集成了多种工具以提供完整的开发环境。

•  MPLAB 项目管理器

此项目管理器用于创建项目并和与该项目相关的特定文件共同工作。 在使用项目
时，只需要单击鼠标就可以重编译源代码并将它下载到模拟器或仿真器上。

•  MPLAB 编辑器

MPLAB 编辑器用于创建和编辑文本文件，如源文件、代码和链接器脚本文件。

•  MPLAB SIM 模拟器

此软件模拟器模拟了 PICmicro MCU 的指令执行和 I/O 功能。

•  MPLAB ICD 2
工作在 MPLAB IDE 下的 Microchip 在线调试器，用于 PIC18FXXX 器件。

•  MPLAB ICE 仿真器

MPLAB ICE 仿真器使用硬件实时仿真 PICmicro MCU，此过程可带有或不带有目
标系统。

•  MPASM 通用汇编器 /MPLINK 可重定位链接器 /MPLIB 库管理器

MPASM 汇编器允许在不离开 MPLAB IDE 的情况下对源代码进行汇编。 MPLINK
通过链接来自 MPASM、 MPLAB C17 和 MPLAB C18 的可重定位模块创建最终应
用程序。 MPLIB 管理定制的库文件以最大限度地复用代码。

•  MPLAB C17、 MPLAB C18 和 C30 C 编译器

MPLAB C17、MPLAB C18 和 MPLAB C30 C 编译器提供基于 ANSI 的高级源代码
解决方案。 复杂项目可使用 C 和汇编混合的源文件获取最快的速度和最好的可维
护性。

•  MPLAB PM3、 PRO MATE II、 PICSTART Plus 和 PICkit™ 编程器

使用模拟器或仿真器开发、汇编或编译代码，然后使用上述工具之一来对器件进行
编程。 这些均可用 MPLAB IDE 完成。

•  第三方工具

很多其它公司都提供与 MPLAB IDE 配合工作的针对 Microchip 产品的开发工具。 
更多信息可咨询 Microchip 网站。
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第 2 章  PICSTART Plus 的安装
2.1 简介

PICSTART Plus 开发系统需要将硬件连接到 PC 并安装 MPLAB IDE 软件。 
本章包括：

•  主机系统要求

•  安装 MPLAB IDE 软件

•  安装 PICSTART Plus 硬件

•  启动 MPLAB IDE
•  打开 / 关闭 PICSTART Plus
•  选择器件

•  选择 PICSTART Plus 编程器

•  为 PICSTART Plus 配置串行端口

•  使能 PICSTART Plus

2.2 主机系统要求

以下是运行 MPLAB IDE 所要求的最低配置：

•  与 PC 兼容的 Intel Pentium® 级系统

•  Microsoft Windows® 98 SE、 Windows ME、 Windows XP、 Windows NT® 4.0 
SP6a 工作站 （Workstations）（非服务器 （Servers））或 Windows 2000 SP2 

•  32 MB 内存 （建议 128 MB）
•  85 MB 硬盘空间

•  Internet Explorer 5.0 或更高版本用于安装和在线帮助

•  一个串行端口

2.3 安装 MPLAB IDE 软件

按照 MPLAB IDE 文档中的说明安装 MPLAB IDE 软件。 更多详细说明请参阅 MPLAB 
IDE 文档。

•  将 MPLAB IDE 光盘插入光驱 （例如： 驱动器 D）。 此光盘将自动开始安装。

•  遵循屏幕上的说明安装 MPLAB IDE。 
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2.4 安装 PICSTART PLUS 硬件

PICSTART Plus 硬件安装很简单。 首先，接上通信线缆，然后连接电源。

2.4.1 安装通信线缆

PICSTART Plus 通过 RS-232 9 针 D 型连接器提供与主机 PC 的通信。PICSTART Plus
是一种数据通信设备（Data Communication Equipment，DCE），硬件握手是通过清除
发送 （Clear-To-Send， CTS）和请求发送 （Request-To-Send， RTS）实现的。 
与 PICSTART Plus 同时提供的还有带 DB-9 连接器的一根 6 英尺数据线。 数据线缆中
通过的电线都是笔直穿过的。 此线缆不是空调制解调器 （null modem）线缆。

要安装串行通信线缆：

1. 将线缆的一端连接到 PC 上的可用 COM 端口。 查看 PC 设置找到可用的通信端
口。

2. 将线缆从 COM 端口连接到 PICSTART Plus 开发编程器。

2.4.2 安装电源

与 PICSTART Plus 一起提供了 9V 输入电源。 PICSTART Plus 要求在中心 2.5 mm 连
接柱的正极电源接线端上，连接电流为 500 mA （最大值）时电压为 +9v ± 10% 的电
源。

要安装电源：

1. 将电源线连到电源出口中的电源。

2. 将细电源线连接到 PICSTART Plus。 这样即可为 PICSTART Plus 编程器提供电
源。 此时绿色的电源灯亮起。

警告

不得将电源连接到插槽中的器件。 这样可能会造成器件损坏。
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2.5 启动 MPLAB IDE
要 启 动  MPLAB  IDE ，  双 击  安 装 软  件 后 放  置 在 桌  面 上 的  图 标 或  选 择
Start>Programs>Microchip MPLAB IDE>MPLAB IDE。 屏幕会显示 MPLAB IDE 徽标
并随后显示 MPLAB IDE 桌面。 MPLAB IDE 桌面与图 2-1 相似。

图 2-1： MPLAB IDE 桌面

2.6 打开 / 关闭 PICSTART PLUS
直接插入或拔出 PICSTART Plus 电源即可分别打开或关闭编程器。
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2.7 选择器件

选择 Configure>Select Device，从可用器件列表中选择器件 （参见图 2-2）。 在选择

器件时， Microchip 工具名称旁的指示灯显示对该器件的支持级别： 绿色——支持此器
件；黄色——有限制地支持；红色——不支持。 如果 PICSTART Plus 支持所选择的器
件，单击 OK。 
如果选择了与 PICSTART Plus 不兼容的器件，会出现一个警告，说明 PICSTART Plus
不支持此器件。 

图 2-2： SELECT DEVICE 对话框
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2.8 选择 PICSTART PLUS 编程器

从 MPLAB IDE 菜单中选择 Programmer>Select Programmer>PICSTART Plus 以选择
编程器 （图 2-3）。 一旦选定了编程器，屏幕下方会出现 PICSTART Plus。

图 2-3： 选择编程器

2.9 为 PICSTART PLUS 配置串行端口

要为 PICSTART Plus 配置串行端口，选择 Programmer> Settings （图 2-4），然后单
击 Communications 选项卡，会出现一个与图 2-5 相似的对话框。

图 2-4： 编程器设置
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图 2-5： 通信端口设置对话框

Communications 选项卡上显示出可能的 PC 串行通信端口。 选择 PICSTART Plus 使
用的 COM 端口。 如果已经为 PICSTART Plus 配置使用了编号在 4 和 255 之间的 COM
端口，则在 “Other”文本框中输入相应的编号。 单击 OK 设定 COM 端口，如果您不
选 COM 端口而想要关闭对话框，则单击 Cancel。

注： 编程器使用 COM 1 作为默认串行端口。 如果改变了串行端口选择，下一次
运行编程器时，主机软件将使用与上次会话中相同的串行端口。
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2.10 使能 PICSTART PLUS
在使能编程器之前，应选定所使用的固件支持的器件。 选择 Configure>Select Device
并选择 PICSTART Plus 支持的器件。 要检查 PC 和编程器是否正确通信，选择
Programmer>Enable Programmer （参见图 2-6）使能 PICSTART Plus 编程器。

图 2-6： 使能 PICSTART PLUS

如果在所选的 COM 端口上没找到 PICSTART Plus，会出现一个类似于图 2-7 的对话
框。

图 2-7： 通信错误对话框

如果不能在 PC 和 PICSTART Plus 之间建立通信，请检查是否已经正确安装了硬件和
软件。（参见第 2.4 节 “安装 PICSTART Plus 硬件”和第 2.3 节 “安装 MPLAB IDE 
软件”）。 如果仍然无法在 PC 和 PICSTART Plus 之间建立通信，请参阅附录 B“疑
难解答”。

如果您此前一直在使用另一个编程器 （如 PRO MATE II）为某一枚 PICSTART Plus
不支持的器件编程，则 PICSTART Plus 编程器菜单可能不可用。 请确保 PICSTART 
Plus 和使用的固件支持当前选择的器件 （参见第 2.7 节 “选择器件”）。 选择
Programmer>Select Programmer 并在列表中选择 PICSTART Plus，然后选择
Programmer>Enable Programmer 使能 PICSTART Plus。
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第 3 章  教程
3.1 简介

本章中的教程向您介绍使用 MPLAB IDE 项目向导（Project Wizard）编程 PIC18F452 
PICmicro 器件的步骤。

3.2 开始之前

在开始学习此教程之前，必须做好以下准备：

1. 安装 MPLAB IDE 软件。参见第 2.3 节 “安装 MPLAB IDE 软件”。

2. 安装 PICSTART Plus 硬件。参见第 2.4 节 “安装 PICSTART Plus 硬件”。

3. 确保您已经读过并完成了第 2.6 节 “打开 / 关闭 PICSTART Plus”和第 2.9
节 “为 PICSTART Plus 配置串行端口”中的所有说明和步骤。

4. 在开始学习此教程之前，确保 PC 和 PICSTART Plus 能够正常通信且 MPLAB
菜单中出现了 PICSTART Plus 菜单项。

3.3 编程概述

编程中档 PICmicro 器件包括以下步骤：

•  选择器件

•  创建项目

•  设置语言工具

•  为项目命名

•  将文件添加到项目中

•  编译初始项目

•  创建代码

•  编译项目

•  使能 PICSTART Plus
•  编程器件

•  验证编程
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3.4 选择器件

如果您还未在 MPLAB IDE 中选择器件，选择 Configure>Select Device 打开 Select 
Device 对话框 （图 3-1）并选择 PIC18F452 器件。

在 Microchip 编程器工具的支持下，验证 PICSTART Plus 支持此器件 （绿灯亮）。 单
击 OK。

图 3-1： 选择器件
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3.5 创建项目

要编程器件就需要一个十六进制文件。 此例中，我们将使用项目向导创建项目以产生
十六进制文件。 我们将使用一个汇编文件创建该项目和链接器脚本。 选择
Project>Project Wizard 开始使用项目向导并显示 “Welcome”屏幕 （图 3-2）。 

图 3-2： 项目向导 “WELCOME”屏幕

单击 Next> 进入项目向导中的下一个对话框。

此对话框（图 3-3）让您选择器件（已选定）。 确定选择了“PIC18F452”。 否则，请
选择 PIC18F452 器件。 单击 Next>。

图 3-3： 项目向导－选择器件

注： 在使用项目向导之前，检查将项目与工作区相关联的选项已经使能。 选择
Configure>Settings，然后单击 Projects 选项卡。 选择复选框 “Use 
one-to-one project-workspace model”，然后单击 OK。
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3.6 设置语言工具

在项目向导的第二步中，选择 Active Toolsuite 列表框中的 “Microchip MPASM 
Toolsuite”。 然后您应可在 Toolsuite Contents 框中看到“MPASM”和“MPLINK”。 
可以单击任一个查看它的位置。 如果您将 MPLAB IDE 安装在默认目录中，则 MPASM
汇编器的可执行文件为：

C:\Program Files\MPLAB IDE\MCHIP_Tools\mpasmwin.exe

MPLINK 链接器可执行文件为：

C:\Program Files\MPLAB IDE\MCHIP_Tools\mplink.exe

如果未正确显示这些内容，使用 Browse 按钮将它们设置为 MPLAB IDE 子文件夹中的
正确文件。

图 3-4： 设置语言工具位置

完成后，单击 Next>。 然后单击 OK。
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3.7 为项目命名

向导的第三步让您为项目命名并将它存入文件夹。 此样本项目叫做 18F452Proj，使
用 Browse 按钮，进入 C 驱动器然后创建一个叫做 My Projects的新文件夹。 单击
Next>。

图 3-5： 项目向导－命名项目
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3.8 将文件添加到项目中

项目向导的第四步让我们为项目选择文件。 由于我们还没有源文件，因此将使用
MPLAB IDE 模板文件。 这些模板文件是用于启动项目的简单文件。它们具有任何源文
件的基本部分并且包含可帮助您编写和组织代码的信息。 这些文件在 MPLAB IDE文件
夹中，默认情况下在您 PC 的 Program Files文件夹中。 每个 Microchip PICmicro
和 dsPIC 器件都有一个模板文件。

滚动到驱动器 C: 的 Program Files文件夹，打开它，然后向下滚动到 MPLAB IDE
文件夹。 打开 MPLAB IDE文件夹，然后向下滚动到 Mchip_Tools目录。 打开
Mchip_Tools目录，从 Template文件夹中的 Object子文件夹中选择名为
f452tmpo.asm的文件来获取一个模板。

如果您将 MPLAB IDE 安装在默认位置，则该文件的完整路径为：

C:\Program Files\MPLAB IDE\MCHIP_Tools\TEMPLATE\Object\f452tmpo.asm

图 3-6： 项目向导－选择模板文件

单击 Add>> 将文件名移到右边的窗格中，然后单击文件名前面的复选框将此文件复制
到项目目录。
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现在添加项目的第二个文件，链接器脚本。 每个器件都有一个链接器脚本。 这些文件
定义该器件的存储器配置和寄存器名称。 此链接器脚本在 MCHIP_Tools文件夹下的
LKR文件夹中。 若使用名为 18F452.lkr 的文件，其完整路径为：

C:\Program Files\MPLAB IDE\MCHIP_Tools\LKR\18F452.lkr

再次单击此文件名前的复选框将此文件复制到项目。

图 3-7： 项目向导－选择链接器脚本

确定您的对话框类似于上图，选中这两个复选框，然后单击 Next> 完成项目向导。

项目向导的结束屏幕是一个总结，显示了所选择的器件、工具套件和新项目文件名。

图 3-8： 项目向导－总结
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在单击 Finish 后，查看 MPLAB IDE 桌面上的项目窗口。 它看起来应该如图 3-9。 如
果此项目窗口未打开，选择 View>Project。

图 3-9： 项目窗口

3.9 编译初始项目

我们使用 Project 菜单汇编和链接当前文件。 这些文件中还没有任何的代码，但确保了
项目设置正确。

单击 18f452Proj.mcw 窗口确保它是激活的窗口。 现在，选择 Project>Build All 编译项
目。 出现如图 3-10 所示的 Build Results 窗口。

图 3-10： 最初的 BUILD RESULTS 窗口
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3.10 创建代码

双击项目窗口中的文件名打开模板文件 （参见图 3-11）。

在此文件的开头有一些注释，并且此区域可被用作文件的标准注释信息头。 现在您可
以不管它，但如果这是一个真实的项目，您可以在这里输入与设计有关的信息。

图 3-11： 模板文件

向下滚动到文件底部。

文件第一部分的代码主要是用于较高级的功能，如在最终应用程序中设置中断和配置
位。 现在我们可以忽略这些细节而只编写代码。 我们可以在文件中紧跟着符号 Main
所定义的位置放置自己的代码。 

图 3-12： 模板文件 - MAIN
© 2005 Microchip Technology Inc. DS51028F_CN 第 25 页



MPLAB®  PICSTART® PLUS 用户指南
打开任何源文件就可以自动进入编辑器。 输入以下代码：

Main:

clr f WREG
movwf PORTC; clear PORTC
movwf TRISC; configure PORTC as all outputs

Init
clrf COUNT

IncCount
incf COUNT
movf COUNT,W
movwf PORTC; display COUNT on PORTC

callDelay
goto IncCount; infinite loop

Delay
movlw 0x40; set outer delay loop
movwf DVAR2

Delay0
movlw 0xFF
movwf DVAR; set inner delay loop

Delay1
decfsz DVAR
goto Delay1

decfsz DVAR2
goto Delay0
return

现在模板文件应如图 3-13 所示。

图 3-13： 模板文件－添加代码
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在代码的此位，我们使用三个变量 COUNT、 DVAR和 DVAR2。 我们需要在模板文件中
为名为 UDATA的未初始化数据段定义这些变量。 在模板文件的该段已经有三个变量，
因此我们只要用相同的格式把我们的变量加在后面即可。 每个变量都是 8 位的，因此
只要为每个变量保留 1 个字节。

图 3-14： 模板文件－添加变量

3.11 编译项目

选择 Project>Build All 汇编和链接代码。 
如果汇编的代码没有错误， Output 窗口就如图 3-15：

图 3-15： 编译完成后的 OUTPUT 窗口

选择 File>Save Workspace 保存项目。

添加
此三
行
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如果汇编和链接不成功，检查以下项目然后再次编译项目：

•  检查编辑器窗口中输入的代码的拼写和格式。 确认新变量和特殊功能寄存器
TRISC 和 PORTC 是大写的。 如果汇编器在 Output 窗口中报错，双击错误，
MPLAB IDE 就会打开源代码窗口，并在左边空白处用绿色箭头指向源代码中相应
的行。 

•  检查是否为 PICmicro 器件使用了正确的汇编器 （MPASM 汇编器）和链接器。 选
择 Project>Set Language Tool Locations。 单击 “+”号展开 Microchip MPASM
工具套件及其可执行文件。 单击 MPASM 汇编器 （mpasmwin.exe）然后检查显
示的位置。 如果位置正确，单击 Cancel。 如果不正确，更改位置然后单击 OK。 
默认搜索路径可以为空。

在成功编译项目后，会加载语言工具生成的输出文件。 此文件包含可被编程到
PICmicro MCU 的目标代码和调试信息，因此可以调试源代码并在 Watch 窗口中以符
号的形式查看源变量。

现在您已经成功编译了项目，可以准备为器件编程了。

3.12 使能 PICSTART PLUS
如果您还未启动 PICSTART Plus 器件编程器，选择 Program-mer>Enable 
Programmer。 当启动该编程器时会出现 PICSTART Plus 工具栏。

选择 View>Program Memory，然后在窗口底部单击 Opcode Hex （参见图 3-16），
查看刚才编译的十六进制代码。 您可以在显示器上更改 Program Memory 窗口大小或
移动该窗口，您也可以关闭 Build Results 窗口。

图 3-16： 查看程序存储器
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3.13 编程器件

现在程序存储器中已经有数据，可以编程器件了。 确保 PIC18F452 器件被正确插入并
锁定到 PICSTART Plus 插槽。 然后，选择 Programmer>Program。 MPLAB IDE 窗口
将显示进程，并在完成时通过 Output 窗口显示结果 （参见图 3-17）。

图 3-17： 编程结果

3.14    校验编程

选择 Programmer>Verify，再次检查器件的编程。 如果器件的任何地址单元与程序存
储器不匹配，会出现一个错误日志显示此差异。 

3.15 教程总结

我们已经完成了创建、编译和编程一个简单项目的主要步骤。

我们选择了器件，即 PIC18F452。
我们使用项目向导创建项目，在使用向导的过程中我们完成了以下步骤：

•  选择 MPASM 汇编器中内置的 MPLAB IDE 和 MPLINK 链接器语言工具；

•  为项目添加文件：我们所选器件的模板文件和正确建立项目的链接器脚本。

我们编写了一些简单的代码，将变化的值从 I/O 端口发出。

然后我们编译了项目。

最后编程 PIC18F452 器件。

这些是使用 MPLAB IDE 和 PICSTART Plus 编程器件的基本步骤。 
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第 4 章  使用 PICSTART Plus
4.1 简介

本章描述了使用 PICSTART Plus 开发编程器编程和读取器件所需的步骤。

•  编程器件的准备工作

•  编程器件的步骤

•  校验编程

•  读器件

4.2 编程器件的准备工作

在编程器件前，您需要有：

•  编程到 PICmicro MCU 器件中的十六进制文件

•  要编程的空白 PICmicro MCU 器件

您还需要：

•  安装了 PICSTART Plus 硬件和 MPLAB IDE 软件 （第 2 章 “PICSTART Plus 的
安装”）

•  打开了 PICSTART Plus 编程器 （第 2.6 节 “打开 / 关闭 PICSTART Plus”）

•  在 PC 和 PICSTART Plus 编程器之间建立了通信 （第 2.9 节 “为 PICSTART 
Plus 配置串行端口”）

4.3 编程器件的步骤

按照如下步骤列表来为器件编程：

步骤 说明 参见

1 选择器件 第 4.3.1 节“选择器件”

2 选择 PICSTART Plus 编程器 第 4.3.2 节“选择编程器”

3 编程器设置 第 4.3.3 节“配置编程器设置”

4 使能 PICSTART Plus 编程器 第 4.3.4 节“使能编程器”

5 在程序存储器中装入 16 进制文件
或在程序存储器中从源代码汇编 /
编译一个 16 进制文件

第 4.3.5 节“将十六进制文件装入程序存储器”

6 设置 Configuration Bits 对话框 第 4.3.6 节“更改配置位设置”

7 需要时，编辑用户 ID 存储器 第 4.3.7 节“使用用户 ID 存储器”

8 检查器件是否为空 第 4.3.8 节“器件查空”

9 编程器件 第 4.3.9 节“编程器件”
© 2005 Microchip Technology Inc. DS51028F_CN 第 31 页



MPLAB®  PICSTART® PLUS 用户指南
4.3.1 选择器件

选择 Configure>Select Device 从可用器件列表中选择想要编程的器件 （参见
图 4-1）。 在选择器件时，Microchip 工具名称旁的指示灯可以显示该器件的支持级别： 
绿色——支持此器件；黄色——有限制地支持；红色——不支持。 如果 PICSTART 
Plus 支持所选择的器件，单击 OK。 
如果 PICSTART Plus 不支持所选择的器件，编程器就不能使能。 将会显示一条错误消
息，同时 PICSTART Plus 在 Select Programmer 列表中会变为不可用。

图 4-1： SELECT DEVICE 对话框

器件列表显示 MPLAB IDE 中当前选择的器件。 正在使用的 MPLAB IDE 版本中的任何
工具都不支持未列出的器件。

4.3.2 选择编程器

选择 Programmer>Select Programmer>PICSTART Plus，在可用编程器列表中选择
PICSTART Plus。 在选择了 PICSTART Plus 之后：

•  Programmer 菜单将把运用于 PICSTART Plus 的项包含进来。

•  显示 Programmer 工具栏。

•  选择了编程器。 （由于菜单、工具栏和状态栏的显示与否受到工作区和其它配置
设定的控制，如需了解更多有关这些项的信息，请参阅 MPLAB IDE 帮助。）

要确保 PICSTART Plus 使用的 COM 端口是在 MPLAB IDE 中选择的那个。 选择
Programmer>Settings，然后单击 Communications 选项卡。 选择需要的端口。

注： 当选择 PICSTART Plus 作为编程器时，应将调试器选项设置为 “None”。
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4.3.3 配置编程器设置

如果需要为 PICSTART Plus 配置串行通信端口，选择 Programmer> Settings
（图 4-2），然后单击 Communications 选项卡。 会出现一个与图 4-3 类似的对话框。

图 4-2： 编程器设置

图 4-3： 通信端口设置对话框

Communications 选项卡上显示出可能的 PC 串行通信端口。 选择用于连接
PICSTART Plus 的 COM 端口 1 － 4 或输入端口编号 （5 － 255），然后单击 OK。如
果已经为 PICSTART Plus 配置使用了编号在 4 到 255 之间的 COM 端口，则在
“Other”文本框中输入相应的编号。 单击 OK 设置 COM 端口，如果您想要不选择
COM 端口而关闭对话框，可以单击 Cancel。

注： 编程器使用 COM 1 作为默认串行端口。 如果您改变了串行端口选择，下一
次运行编程器时，主机软件会使用与上次会话中相同的串行端口。
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4.3.4 使能编程器

要使能 PICSTART Plus 编程器，选择 Programmer>Enable Programmer （参见
图 4-4）。

图 4-4： 使能 PICSTART PLUS

如果 PICSTART Plus 上检测到的 OS 固件版本不支持所选择的器件，就会显示与
图 4-5 类似的消息，表示正在使用的固件版本不支持器件。 请参阅第 5.8 节 “升级
PICSTART Plus 固件 OS”。

图 4-5： 固件错误消息
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如果由于串行连接问题而不能建立通信，会显示与图 4-6 类似的消息。 器件在 ZIFF 插
槽中没有对准也会导致通信错误。

图 4-6： 通信错误消息

如果不能在 PC 和 PICSTART Plus 之间建立通信，确定您已正确安装了硬件和软件。
（参见第 2.4节 “安装PICSTART Plus硬件”和第 2.3节 “安装MPLAB IDE 软件”） 
如果仍然无法在 PC 和 PICSTART Plus 之间建立通信，请参阅附录 B“疑难解答”。

在可能的情况下，也允许老版本的 PICSTART Plus 固件 OS 支持新器件。 但是，有些
新器件需要升级 PICSTART Plus 固件 OS 才能得到支持。 如需了解有关 PICSTART 固
件 OS 升级的信息，请参阅第 5.8 节 “升级 PICSTART Plus 固件 OS”。

4.3.5 将十六进制文件装入程序存储器

4.3.5.1 关于程序存储器

你可以十六进制代码、机器码或者以反汇编代码 （如果有的话）格式查看程序存储
器。要查看程序存储器，选择 View>Program Memory （图 4-7）。

图 4-7： 查看程序存储器
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Program Memory 窗口以机器码模式打开 （图 4-8）。 

图 4-8： 机器码模式

要更改显示模式，单击窗口左下角的系统按钮并从系统菜单中选择显示模式。 单击
Opcode Hex 按钮程序存储器显示将变为与图 4-9 相似。

图 4-9： OPCODE HEX 模式

单击 Symbolic 按钮，程序存储器显示将变为与图 4-10 相似。

图 4-10： 符号模式

注： 在编译项目后， MPLAB IDE 创建一个十六进制文件并将它装入程序存储
器。 存储器中的数据可以编程到 PICSTART Plus。
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4.3.5.2 将十六进制文件装入程序存储器

如果您已经准备好了将要编程到 PICmicro 单片机的十六进制文件 （例如，
code.hex），选择 File>Import 并找到十六进制文件的位置。 选择十六进制文件并单击
Open（参见图 4-11），将十六进制代码装入 MPLAB IDE 的 Program Memory 窗口。 
如果 Program Memory 窗口未打开，选择 View>Program Memory 打开它。

如果您还没有编程器件的十六进制文件，可以使用 MPLAB IDE 项目编译一个。 
MPLAB IDE 提供文本编辑器产生源代码，并和用于在 MPLAB IDE 程序存储器中将源
代码汇编 / 编译为十六进制代码的各种汇编器 / 编译器兼容。 有关使用 MPLAB IDE 项
目开发自己的源代码的方法，请参阅 MPLAB IDE 项目教程。 每次重新编译项目时，
Program Memory 窗口都会更新。

图 4-11： 导入十六进制文件

Program Memory 窗口现在应该包含来自十六进制文件的十六进制代码 （图 4-12）。 
单击 Opcode Hex 按钮查看十六进制代码。

图 4-12： 程序存储器－十六进制代码显示
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4.3.5.3 PICSTART PLUS 使用的文件格式 

PICSTART Plus 编程器可以直接使用来自 MPLAB IDE 项目的信息，不需要任何中间
步骤。 MPASM 汇编器可与 MPLAB IDE 分开使用以产生 PICSTART Plus 编程器的十六
进制文件。 或者，可以用任何与 PICmicro 单片机兼容的交叉汇编器或交叉编译器生成
的十六进制文件编程器件。

如果您正在 MPLAB IDE 外使用 MPASM 汇编器，或在 MPLAB IDE 中产生稍后和
PICSTART Plus 编程器一起使用的十六进制文件，就应该使用 IINHX32 十六进制格
式。 MPASM 汇编器十六进制文件的默认输出格式是 INHX32。

4.3.6 更改配置位设置

如果您需要更改器件中厂家默认设置的配置位或想了解配置位设置，选择
Configure>Configuration Bits （参见图 4-13）。

图 4-13： CONFIGURATION BITS 窗口－ PIC18F452

图 4-13 中显示的配置位用于 PIC18F452 器件。 配置位的类型和数量取决于所选择的
器件。 如需了解某个器件的配置位功能的更多信息，请参阅特定的器件数据手册。 

注： 在编译项目或导入十六进制文件后在窗口中更改配置位，更改的值会替代
这两项操作中设定的值。
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要更改配置位设置：

1. 单击想要更改的设置，在该设置右边会出现向下箭头。 
如果您找不到向下箭头，拉宽 Configuration Bits 窗口直到向下箭头出现。

2. 单击向下箭头查看设置选项，并选择一个您想要的 （参见图 4-14）。

图 4-14： 更改配置位设置

您也可以在源代码中指定配置位值。 使用 MPASM 汇编器 _ _CONFIG伪指令为要
编程的器件设置配置位。 每次重新编译项目或重新装载十六进制文件时，都将根据该
伪指令的值设置配置位。 如果您不在源代码中设置配置位，这些位就不会改变。 如果
您使用此对话框手动更改这些位的默认值，这些值将在编程单片机的时候编程到器件
中。

在项目编译以后在配置窗口中手动设置配置位值将会改写由该项目设置的值。 

4.3.7 使用用户 ID 存储器

如果需要的话，可以使用 ID 选项为器件产生 ID。 此 ID 可以是来自编程到器件内容的
未受保护的校验和，或者用户指定的值。 值的限制由器件存储器大小决定。 选择
Configure>ID Memory （参见图 4-15）打开 User ID Memory 对话框。 使用此对话框
进入提供此功能的器件用户 ID，并选择是否 “Use Unprotected Checksum”（使用未
受保护的校验和）（图 4-16）。

图 4-15： 配置 ID 存储器
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图 4-16： USER ID MEMORY 对话框

您也可以使用 _ _IDLOCS 伪指令设置来自 MPASM 汇编器的 ID 字节。 每次重新编译项
目或重新装载十六进制文件时，都将根据 _ _IDLOCS 伪指令的值设置 ID 单元。

项目编译以后使用 ID memory 对话框手动设置的任何 ID 值都将改写项目设置的 ID
值。

单击 OK 设置选项或单击 Cancel 取消对该对话框的设置。

4.3.8 器件查空

在进行 “查空”之前，确保器件满足以下条件：

•  器件的引脚 1 与 PICSTART Plus ZIFF 插槽的引脚 1 对准

•  拉下金属杆以将器件卡紧在 ZIFF 插槽中。 
选择 Programmer>Blank Check All 验证器件是否完全为空 （所有位都被置为
“1”）。 这也将验证所有配置位都被置为 “1”（未编程状态）。

如果你使用一次性编程 （one-time programmable， OTP）器件，某些配置位可能在
工厂里已经被编程了 （比如，振荡器位）。 使用 Configuration Bits 对话框
（Configure>Configuration Bits）将配置位设置为出厂设置，然后选择
Programmer>Blank Check OTP。 这将校验所有程序存储器位被置为 “1”，并且配置
位的值与对话框中的值匹配。

在编程之前闪存器件会被自动擦除。 OTP 器件可以被擦除，而 EPROM 器件不能被擦
除，除非它是 JW 封装类型 （带窗口）或 CERQUAD （CL）封装类型，并且没有被
代码保护。 请参阅第 4.3.10.3 节 “擦除带窗口的器件”。 
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4.3.9 编程器件

要编程整个器件 （即，所有程序存储器、配置位等等），选择 Programmer>Program
（图 4-17）。

图 4-17： 编程器件 

要有选择地编程部分程序存储器，首先选择 Programmer>Settings，然后单击
Memory Ranges 选项卡打开 Memory Ranges 对话框 （图 4-18）。 

图 4-18： 设置存储器范围
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在安装 MPLAB IDE 时默认启用 “Auto select memory areas and range”（自动选择
存储区和范围）选项。 要有选择地编程存储器范围等，就必须禁用此选项。 只可选择
适用于器件的存储区。 要有选择地编程存储器范围、配置位等，就要调整 Memory 
Ranges 对话框中的设置 （参见表 4-1）。 与选定的复选框对应的存储区将被编程。 

如需了解有关存储区、它们的窗口和 MPLAB IDE 中对话框的更多信息，请参阅
MPLAB IDE 文档。 选择编程选项，单击 OK。 然后选择 Programmer>Program，根据
Memory Ranges 对话框中的设置编程器件。

注： 如果器件被代码保护，可能就无法编程特定的存储区和范围。 对于闪存器
件来说，此操作可能导致特定区域以外的存储区和范围丢失某些现存的内
容。

表 4-1： MEMORY RANGES 对话框选项
Auto select memory areas and 
range
（自动选择存储区和范围）

此选项是默认启用的 （选中）。 启用此选项时，所选器件
的存储区和范围由 MPLAB IDE 根据其存储器中的数据自动
选择。相应的存储区和范围信息都显示为选中，但在手动
字段中不可用。 
如果自动选择选项被禁用 （未选中），您可以指定存储区
和范围。

Read all on auto select
（自动选择时全部读取）

此选项是默认启用的 （选中）。 此选项只在启用 “Auto 
select memory areas and range”时可用。 当此选项被启
用时，读操作将读取整个器件。 如果此选项被禁止，只有
MPLAB IDE 中数据所指定的存储区和范围才能被读取。

手动输入存储区和范围：

Program memory start address
（程序存储器起始地址）

用于编程或校验的程序存储器起始地址。

Program memory end address
（程序存储器结束地址）

用于编程或校验的程序存储器结束地址。

Program Memory
（程序存储器）

编程或校验程序存储器中起始地址和结束地址指定的范围。

Configuration Bits
（配置位）

编程或校验配置位。

ID Location
（ID 单元）

编程或校验用户 ID。您可以选择 Configure>ID Memory 设
置用户 ID。

EEPROM Data
（EEPROM 数据）

对于带有数据 EEPROM 的器件，利用 EEPROM Memory
窗口中的数据编程或校验数据存储器。 

Calibration Memory
（校准存储区）

对于带有校准存储区的器件，利用 Calibration Memory 窗
口中的数据编程或校验校准存储区。 
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4.3.10 编程校准存储区器件

在对包含校准存储区的器件编程时应特别注意。 在出厂前，这些器件的程序存储器的
最后一个地址被设置来存储校准参数。 并非所有的校准器件的这个值都相同。

校准存储器件的封装形式有 OTP （无窗口）、 EEPROM （有窗口）和闪存等。

无窗口的 OTP 校准器件只能被编程一次且不能被擦除。 可使用紫外线 （UV）
EPROM 擦除器擦除有窗口的 CERDIP （JW）封装或 CERQUAD （CL）封装的
EEPROM 校准器件。 如果这些器件被擦除，所有存储区包括校准数据都将被擦除。 在
编程已擦除的带校准存储区的窗口器件之前，必须恢复正确的校准值。 可使用 MPLAB 
IDE 软件擦除闪存校准器件，这样其校准数据将得到自动保留。 在对它们重新编程之
前不需要任何特殊的准备。 

对带窗口的校准器件编程或再次编程包括：

•  读校准器件

•  保存校准数据

•  擦除带窗口的器件

•  恢复校准数据

4.3.10.1 读校准器件

1. 在开始之前，给每个器件贴上识别标签。

2. 使用 Configure>Select Device 选择需要的校准存储区器件。

3. 选择 Programmer>Select Programmer>PICSTART Plus。
4. 确保 PICSTART Plus 硬件被正确连接，且器件的插槽模块正确。 将器件插入插

槽模块。

5. 选择 Programmer>Enable Programmer 使能 PICSTART Plus。
6. 打开与器件存储区相关的窗口，即 Program Memory （程序存储器）和

Configuration Bits （配置位）窗口。 默认情况下，器件被选中时存储区窗口被
MPLAB IDE 清空。 如果不是这样的话，选择 Debugger>Clear 
Memory>Program Memory 清空该窗口。

7. 选择 View>Output 打开 Output 窗口。

8. 选择 Programmer>Read。 各器件存储区的当前值会显示出来。

9. 如果已知器件是空白的或没有代码保护，但是读命令却显示一个带有数值的消
息，表明有代码保护，则应再次检查 PICSTART Plus 硬件，特别是器件
在 PICSTART Plus ZIFF 插槽中的放置。 在 Help>Topics>PICSTART Plus 下面
的 Troubleshooting （疑难解答）部分还有更多的帮助信息。

10. 如果读命令成功，转到 Program Memory（程序存储器）窗口中的最后一个可用
地址查看校准值。

注： 被代码保护的窗口器件不能被正确擦除。
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4.3.10.2 保存校准数据

1. 如果器件是带窗口封装的，必须通过以下操作方法之一保存校准数据： 
a) 写下校准值并将它存放在安全的地方。

或

b) 选择 File>Export 打开 Export Hex File （导出 16 进制文件）对话框。 在
Memory Areas 选项卡上，只选中 Calibration 复选框，保存此存储区的数据
（参见图 4-19）。

图 4-19： MEMORY AREAS 选项卡

在 File Format 选项卡上，设置或保持默认情况为 INHX32 格式 （参见图 4-20），

然后单击 OK。

图 4-20： FILE FORMAT 选项卡

2. 一旦保存了校准数据，就可以将其编程回已擦除器件。 应在器件再次用于编程源
代码之前完成此项工作。
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4.3.10.3 擦除带窗口的器件

要擦除带窗口的器件：

1. 移除器件窗口上的覆盖物，这样紫外光可以射入器件。 参见图 4-21。

图 4-21： 带窗口的器件

2. 把器件放在紫外线 （UV） EPROM 擦除器中。 根据每个设备生产商的说明使用
UV 擦除器。 彻底擦除该类器件所需的时间与光波长、光强度、器件到 UV 源的
距离和器件的工艺技术 ( 存储单元的大小）有关。 

3. 当 UV 擦除器指示擦除完成时，移除器件。 

4.3.10.4 恢复校准数据

1. 将擦除的窗口器件插入 PICSTART Plus 编程器插槽。

2. 选择 Programmer>Blank Check 确保器件为空白。 如果器件不是空白的，则它
还未被擦除。

3. 如果器件是空白的，使用以下方法之一恢复保存的校准数据：

a) 手动将保存的校准值输入到程序存储器窗口的最后一个地址内。

或

b) 选择 File>Import，从包含校准值信息的十六进制文件中导入校准值。 浏览到
该位置并选择文件。 单击 Open。

4. 一旦导入了包含校准数据的十六进制文件，就可以编程器件了。
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4.4 校验编程

选择 Programmer>Verify （参见图 4-22）验证器件内容是否与程序存储器、数据
EEPROM、校准存储器、 ID 单元和 MPLAB IDE 中的配置位匹配。

如果器件内容与当前 MPLAB IDE 中的内容 （显示在器件的存储区窗口）不匹配，校
验将失败。

图 4-22： 校验命令

4.5 读器件

要读整个器件 （即，所有程序存储器、配置位等等），在 MPLAB IDE 中选择
Programmer>Read。 
要单独地读部分程序存储器、仅读取配置位等：

1. 选择 Programmer>Settings，然后单击 Memory Ranges 选项卡 （图 4-23）。

图 4-23： MEMORY RANGES 选项卡
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2. 如果启用了“Auto select memory areas and range”（自动选择存储区和范围）
选项 （选中），禁止 （取消选中）此选项。 如果启用了此选项，您就不能手动
选择特定存储区和范围。

3. 选择要读的存储区和范围。 单击 OK。 手动设置的说明请参阅表 4-2。 

4. 选择 Programmer>Read。 与选定的复选框对应的存储区将被读取。

一旦读操作完成，存储区窗口将显示从器件读取的数据。 然后您可以：

•  修改程序存储器中的数据，以便将其保存到十六进制文件或编程到另一枚器件中。

•  选择 File>Export 将数据保存为十六进制文件。

•  插入新器件到 PICSTART Plus，将数据编程到新器件。

如果在尝试读器件时有任何问题，请参阅附录 B“疑难解答”。

表 4-2： 存储器范围手动设置
Program memory start address
（程序存储器起始地址）

用于编程或校验的程序存储器起始地址。

Program memory end address
（程序存储器结束地址）

用于编程或校验的程序存储器结束地址。

Program Memory
（程序存储器）

编程或校验程序存储器中起始地址和结束地址指定的范围。

Configuration Bits
（配置位）

编程或校验配置位。

ID Location
（ID 单元）

编程或校验用户 ID。您可以选择 Configure>ID Memory 设
置用户 ID。

EEPROM Data
（EEPROM 数据）

对于带有数据 EEPROM 的器件，利用 EEPROM Memory
窗口中的数据编程或校验数据存储器。 

Calibration Memory
（校准存储区）

对于带有校准存储区的器件，利用 Calibration Memory 窗
口中的数据编程或校验校准存储区。 
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注：
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第 5 章  PICSTART Plus —— MPLAB IDE 使用参考
5.1 简介

本章描述了 PICSTART Plus 开发编程器系统的对话框、窗口和菜单项。 更多信息请参
考 MPLAB IDE 文档或在线帮助。

本章涉及的主题：

•  PICSTART Plus 工具栏

•  Configure 菜单

•  Debugger 菜单

•  PICSTART Plus Programmer 菜单

•  编程器设置

•  PICSTART Plus 编程器所使用的文件

•  升级 PICSTART Plus 固件 OS

5.2 PICSTART PLUS 工具栏

PICSTART Plus 工具栏 （图 5-1）由一些编程器功能图标和一个程序统计显示屏组
成。

图 5-1： PICSTART PLUS 工具栏
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将鼠标指针放在工具栏项上将显示出其名称。 工具栏里的项如表 5-1 所示。

5.3 CONFIGURE 菜单

Configure 菜单是和 PICSTART Plus Programmer 菜单配合使用的 MPLAB IDE 菜单。 
Configure 菜单的详细信息，请参考 MPLAB IDE 文档或在线帮助。 Configure 菜单
（图 5-2）由五个对话框选项组成，如表 5-2 所示。

图 5-2： CONFIGURE 菜单选项

表 5-1： PICSTART PLUS 工具栏命令

符号 命令 描述

Blank Check All 检查器件是否完全空白 （所有的位置“1”）。 这也将检查
所有的配置位是否置 “1”（未编程状态）。 
（同 Programmer>Blank Check All）。

Read 读器件。 （同 Programmer>Read。）

Program 编程器件。 （同 Programmer>Program。）

Verify 验证器件已被正确编程。 （同 Programmer>Verify。）

Erase Flash Device 擦除闪存器件上的所有存储区。 
( 同 Programmer>Erase Flash Device。）

编程统计 提供尝试编程的次数： 通过、失败和总计。 选择
Programmer>Reset Program Statistics 来清除该显示屏中的
值。
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5.4 DEBUGGER 菜单

Debugger 菜单是一个 MPLAB IDE 菜单，包含选择 MPLAB 仿真器、模拟器和调试工
具的选项；而且，它还包括在 Debugger>Clear Memory 下的选项 （参见图 5-3），这
些选项可以和 PICSTART Plus 一起使用来清空 MPLAB IDE 存储区和相关窗口 （参见
表 5-3）。 在器件为空时，它将特定的存储区设置为所见值。

图 5-3： DEBUGGER 菜单下的 CLEAR MEMORY 选项

表 5-2： CONFIGURE 菜单

选项 描述

Select Device
（选择器件）

选择 MPLAB IDE 支持的您要编程的器件。 （器件的支持情况由指示灯
表示，绿色表示支持，黄色表示有限制地支持，红色表示不支持。）

Configuration Bits
（配置位）

选择器件配置位的值。 设置这些值将影响调试器和编程器操作。

External Memory
（外部存储器）

选择是否使用外部存储器。 同时也指定外部存储器的范围。

ID Memory
（ID 存储区）

输入值到 ID 存储区。

Settings
（设置）

输入工作区、调试器、程序加载、热键和项目的默认设置。

表 5-3： DEBUGGER 菜单

选项 描述

All Memory
（所有存储区）

清除 MPLAB IDE 存储区内的所有数据和相关窗口

Program Memory
（程序存储器）

清除 MPLAB IDE 程序存储器数据及其窗口

GPRs 清除 MPLAB IDE 通用寄存器数据及其窗口

EEPROM 清除 MPLAB IDE EEPROM 数据及其窗口

Configuration Bits
（配置位）

清除 MPLAB IDE 配置位数据及其窗口

注： 使用 Clear Memory 选项不会擦除器件中的内容。
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5.5 PICSTART PLUS PROGRAMMER 菜单

一 旦 选 择 了 PICSTART Plus 编 程 器，就 会 显 示 它 的完整菜单 （参见图 5-4 和
表 5-4）。 必须使能编程器，其他的菜单选项才可用。 有些 PICSTART Plus 菜单选项
可以通过 PICSTART Plus 工具栏使用。

图 5-4： PICSTART PLUS PROGRAMMER 菜单

表 5-4： PICSTART PLUS 菜单

Programmer 菜单选项 工具栏图标 功能

  Select Programmer 
（选择编程器）

 列出可用的编程器。

  Enable Programmer
（使能编程器）

 使能编程器。 

 Disable Programmer
（禁用编程器）

 禁用编程器。 

Program （编程）  编程器件。

Verify （校验）  验证器件已经正确编程。

Read （读）  读器件内容。 有选择地读 （如部分程序存储器、
仅器件配置位）可以通过设置下面的 “Settings”
来完成。

     
Blank Check All
（完全空白检查）

 检查器件是否完全空白 （所有位置“1”）。 这也
将检查所有的配置位设置为 “1”（未编程状
态）。
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Blank Check OTP
（OTP 空白检查）

 该功能用于出厂前配置位已编程的 OTP 器件。 使
用该功能之前，将显示的配置位设置成和出厂时
编程相符的设置。 该功能验证所有的程序存储器
位为 “1”，并且配置位和 Configuration Bits 对
话框中显示的设置相符。

Abort Operation
（中止操作）

取消正在进行的 Program （编程）、 Verify （校
验）或 Read （读）操作。

Reset （复位）  复位编程器硬件，同时重建 RS-232 通信。 在编程
器与电源断开时使用该选项。 该选项不复位程序
存储器窗口中的编程信息、配置位或 ID。

Reset program statistics
（复位编程统计）

复位 Program Statistics （编程统计）区中的计数
器。

Erase Flash Device
（擦除闪存器件）

仅闪存器件可用。 擦除器件中的闪存存储器。

Download PICSTART OS
（下载 PICSTART OS）

打开 Download PICSTART Plus Operating 
System （下载 PICSTART Plus 操作系统）对话
框，显示可用的固件版本列表。 只在需要不同的
固件版本来支持器件，或者新固件包含解决问题
的方案时才应该进行下载。

About （关于）  显示编程器固件 OS 版本信息。

Settings （设置）  打开 Programmer 对话框，该对话框将允许设置
存储区范围和通信端口。 Programmer 选项，如
Program （编程）、 Read （读）和 Verify （校
验）都由这些设置控制。 

表 5-4： PICSTART PLUS 菜单 （续）

Programmer 菜单选项 工具栏图标 功能
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5.5.1 Select Programmer （选择编程器）

选择 Select Programmer>PICSTART Plus，来选择 PICSTART Plus 编程器。 一旦选
择了编程器，就打开了 Output 窗口。

5.5.2 Enable Programmer （使能编程器）

选择 Programmer>Enable Programmer，来使能 PICSTART Plus 编程器。 当试图使能
PICSTART Plus 时，会发生下列情况：

•  通信成功，正在使用的固件版本支持器件，同时该版本是 MPLAB IDE 检测到的现
有的最新版本。不显示任何消息。 PICSTART Plus 工具栏可用，同时
Programmer 菜单将被更新，以包含与 PICSTART Plus 的使用相关的项。

•  MPLAB IDE 检测到的固件版本比已知的最新版本老。 PICSTART Plus 将可以使
用，但会显示 “newer firmware”（有新固件）消息。 无须下载这个新固件版本
PICSTART Plus 也能正常工作。

•  使用中的固件版本不支持所选器件。 将显示 “firm-ware required”消息。 直到下
载了支持所选器件的固件后， PICSTART Plus 才可以使用。 参见第 5.8 节 “升级
PICSTART Plus 固件 OS”。

•  接收到通信错误。 参见附录 B“疑难解答”中的第 B.2 节 “常见问题”。

5.5.2.1 OUTPUT 窗口

当您从 PICSTART Plus 菜单选择了 Programmer>Select Programmer>PICSTART 
Plus，或从 MPLAB ID 菜单选择了 View>Output 时，就打开了 Output 窗口。 该窗口包
含了关于编程输出的信息。 更多信息请参考 MPLAB IDE 文档。

Output 窗口中单击鼠标右键，得到的菜单选项为： 
•  Select All——选择 Edit 窗口中的所有文本和图例。

•  Copy——将当前窗口中所选文本复制到剪贴板。 这个操作之后，您可将所复制的
文本粘贴到另一个 MPLAB Editor 窗口、同一 MPLAB Editor 窗口的另一个位置或
另一个 Windows 应用程序。

•  Clear Page——清除 Output 窗口中的内容。

注： 由于所有消息都在此处显示，因此最好保持 Output 窗口打开。
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5.5.2.2 PROGRAM MEMORY 窗口

当您从 MPLAB IDE 菜单中选择 View>Program Memory 时， Program Memory 窗口
（图 5-5）以显示机器码的形式打开。

图 5-5： PROGRAM MEMORY 窗口

您可以十六进制代码、机器码或者反汇编代码 （如果有的话）格式查看 Program 
Memory （程序存储器）窗口。 点击窗口左下角的显示选项按钮，可以改变显示模式。

当执行读操作时，使用该存储区编译项目或执行导入会将程序存储器窗口改写。 如果
MPLAB 模拟器和 PICSTART Plus 一起使用，在使用 Program 选项前，确信 MPLAB 
IDE 包含的是您希望编程进器件的内容。

5.5.3 Disable Programmer （禁用编程器）

选择 Programmer>Disable Program-mer，禁用 PICSTART Plus 编程器。

5.5.4 Program （编程）

选择 Programmer>Program，对整个器件编程 （即，所有程序存储器和配置位等）。 
如果您想有选择地编程 （如，部分程序存储器，仅配置位），选择
Programmer>Settings 打开 Programmer Settings 对话框。 单击 Memory Ranges 选
项卡，选择编程选项。 灰色区域是器件上不可用的部分。 单击 OK。 然后选择
Programmer>Program 对器件编程。 与选中的复选框相对应的存储区将被编程。

PICSTART Plus 对器件编程以后，它将自动进行验证操作并显示发现的任何错误。可
选择 Programmer>Verify 进一步执行验证操作。

5.5.5 Verify （校验）

选择 Programmer>Verify 校验对器件的编程。 该选项验证器件的编程与 MPLAB IDE
和 Settings 对话框中的程序存储器、配置位、 ID 单元、 EEPROM 和校准存储区值
（当前显示在存储区窗口中的内容）是否匹配。

如果错误比预计的多并且那些错误声明错误数据为全 0 （0000），则器件可能没有正
确地安置在 PICSTART Plus 中，或者器件的引脚 1 未与 ZIFF 插槽的引脚 1 对准。 在
更换插槽模块时，插入一枚已知的空白器件并进行空白检查始终是个良好的习惯。
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当编程结束时， Output 窗口将显示 “Programming/Verification completed 
successfully!”（编程 / 校验成功完成！）。 如果编程失败，将出现错误消息，该消
息显示试图编程的存储区的好 （期望的）数据和坏 （实际的）数据。 

5.5.6 Read （读）

选择 Programmer>Read 来读整个器件 （即，所有的程序存储器和配置位等）。 
要有选择地读 （如，部分程序存储器、仅配置位），选择
Programmer>Settings>Memory Ranges，显示 Memory Ranges 对话框 （参见
第 5.6.1 节 “Memory Ranges 选项卡”）。 在对话框中选择要读的存储区，然后单击
OK。 灰色区域是器件上不可用的部分。 然后，选择 Programmer>Read。 和选中的复
选框相对应的存储区将被读取。

一旦完成读操作， Program Memory 窗口将显示读出的数据。 可以将数据保存为十六
进制文件，在 PICSTART Plus 中插入一枚新器件，将该数据复制到新器件（称为从主
器件编程），或者修改 MPLAB IDE 中的数据，然后保存为十六进制文件或对另一枚器
件编程。

如果您试图读一个受代码保护的器件，将得到一个警告，指出器件受代码保护，且程
序存储器可能无效。 

5.5.7  Blank Check All （完全空白检查）

将器件插入插槽后，从 PICSTART Plus 菜单中选择 Programmer>Blank Check All。 该
检查将检查器件是否为完全空白 （所有位置“1”），同时所有配置位也置“1”（未编
程状态）。 
结束时，结果将显示在 Output 窗口中，如：

Configuration memory is blank（配置存储区为空）。

EEData memory is blank（EEData 存储区为空）。

ID memory is blank（ID 存储器为空）。

Program memory is blank（程序存储器为空）。

如果您正在使用一次可编程 （OTP）器件，有些配置位 （如，振荡器位）可能已经在
出厂前编程了，同时将报告器件为非空。 确信配置位被设为出厂设置，然后选择
Programmer>Blank Check OTP。 这将检查所有程序存储器位设置为“1”，同时配
置位和对话框中的值相符。 如果一个没有被代码保护的 EPROM 器件被发现为非空，
可将它擦除。 参见第 4.3.10.3 节 “擦除带窗口的器件”。

5.5.8 Abort Operation （中止操作）

选定后，将中止进行中的编程、校验或读操作。 例如，如果您选择了

Programmer>Program，然后决定取消该操作，通过选择 Programmer>Abort Operation
可以取消编程命令。

注意

由于一部分编程可能已经发生了，因此中止编程操作可使器件处于不可知状态。
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5.5.9 Reset （复位）

如果您在操作时遇到了编程器掉电，您可能需要复位 PICSTART Plus 编程器。 选择
Programmer>Reset 来复位编程器硬件并重建 RS-232 通信。 复位不会清除 MPLAB 
IDE 中的数据或器件的内容。

5.5.10 Reset Program Statistics （复位编程统计）

选择 Programmer>Reset Program Statistics 来复位所有编程统计数据。 该命令将复位
跟踪器件编程时的 “通过”和 “失败”次数的显示。

5.5.11 Erase Flash Device （擦除闪存器件）

将器件插入到插槽，从 PICSTART Plus 菜单中选择 Programmer>Erase Flash 
Memory。 然后，从 PICSTART Plus 菜单中选择 Programmer>Blank Check All。 该检
查将验证器件是否为全空 （所有位置 “1”），同时所有配置位也置为 “1”（未编程
状态）。

5.5.12 Download PICSTART OS （下载 PICSTART OS）
要下载固件，必须有：

•  升级到可使用 PUM 的 PICSTART Plus， PICSTART Plus 版本 20 或以上。

•  MPLAB IDE 6.40 或以上。最好选择 MPLAB IDE 6.61 或以上。

当您选择 Download PICSTART OS 选项时，将会显示一个和图 5-6 相似的对话框。 

图 5-6：        下载 PICSTART PLUS OS

选择您想要下载的 PSPLS*.HEX 文件，然后单击 Open。 完成后，系统显示
“Download Complete”（下载完成）消息。

5.5.13 About （关于）

选择 Programmer>About 显示编程器中 PICSTART Plus OS 固件的版本。

注： OTP 器件无法擦除。 使用 Erase Flash Memory 选项无法擦除 EPROM 器
件。 参见第 4.3.10.3 节 “擦除带窗口的器件”。
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5.6 编程器设置

选择 Programmer>Settings，显示 Programmer Settings 对话框。该对话框有设置存
储区范围和通信的选项卡。

5.6.1 Memory Ranges 选项卡

选择 Programmer>Settings，然后单击 Memory Ranges 选项卡来选择要编程的器件
存储区。（参见表 5-5）。 

表 5-5： MEMORY RANGES 选项

选项 描述

Auto select memory areas and range
（自动选择存储区和范围）

默认为使能（选中）（参见第 5.6.1.1 节“启用自动
选项”）。 使能时，所选器件的存储区和范围将由
MPLAB IDE 自动选择。 相应的存储区和范围信息复
选框显示为选中但在手动区域中不可用。 
如果自动选择选项禁用（未选中）（参见第 5.6.1.2
节“禁用自动选项”），您可以指定存储区和范围。

Read all on auto select
（自动选择时读取整个器件）

默认为使能（选中）。 该选项只有在使用了“Auto 
select memory areas and range”（自动选择存储
区和范围）选项时才可用。 
当使用该选项时，读操作将读整个器件。 如果禁
用，只有 MPLAB IDE 中的数据指定的存储区和范
围才能被读取。 （进一步的说明，请参见第 5.6.1.1
节“启用自动选项”和第 5.6.1.2 节 “禁用自动选
项”。）

手动输入存储区和范围：

Program memory start address
（程序存储器起始地址）

输入程序存储器范围的开始地址（十六进制格
式）。

Program memory end address
（程序存储器结束地址）

输入程序存储器范围的结束地址（十六进制格
式）。

Program Memory
（程序存储器）

如果您想对程序存储器编程，选中此复选框。 该程
序存储器范围由程序存储器开始和结束地址字段决
定。

Configuration Bits
（配置位）

如果想编程配置存储区，选中此复选框。

ID Location
（ID 单元）

如果想编程 ID 单元，选中此复选框。

EEPROM Data
（EEPROM 数据）

如果想编程 EEPROM 数据存储器，选中此复选框。

Calibration Memory
（校准存储区）

如果想编程校准存储区，选中此复选框。 

注： 只有器件适用的存储区才可以选择。
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5.6.1.1 启用自动选项

当 MPLAB IDE 安装时，“Auto select memory areas and range”（自动选择存储区和
范围）和 “Read all on auto select”（自动选择时读取整个器件）选项将默认选中
（图 5-7）。 当保存工作区时，会保存所有的改变。 如果 MPLAB IDE 中没有数据，
Programmer 菜单和 PICSTART Plus 工具栏中只有 Blank Check 和 Erase 选项可用。 
但是，如果因为导入了一个十六进制文件，或者是建立了一个项目而使 MPLAB IDE 中
有一个存储区有数据，那么 Programmer 菜单和 PICSTART Plus 工具栏中的 Program
和 Verify 选项也可用。 相应的存储区和范围信息将在 Memory Ranges 选项卡上显示
为选中和禁用。

图 5-7： MEMORY RANGES 选项卡 ——启用自动选择
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5.6.1.2 禁用自动选项

如果 “Auto select memory areas and range”（自动选择存储区和范围）被禁用，将
自动禁用 “Read all on auto select”（自动选择时读取整个器件）选项。 存储区和范
围可以手动指定 （参见图 5-8）。 是对存储区和范围的选择，而不是 MPLAB IDE 存储
区中提供的数据，控制 Programmer 菜单和 PICSTART Plus 工具栏上 Program 和
Verify 选项是否可用。 存储区复选框和范围选择还将控制将要被读、编程和校验的内
容。 Output 窗口中不会出现声明哪块存储区将要进行读操作的消息。

图 5-8： MEMORY RANGES 标签——禁用自动选择
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5.6.2 Communications 选项卡

选择 Programmer>Settings，然后单击 Communications 选项卡，来设置编程器和
PC 之间通信的端口。 编程器和 PC 间的通信是通过 RS-232 （串行线）连接的。 选择
要使用的 PC COM 端口： COM1、COM2、COM3、COM4 或者在“OTHER”字段中输入端

口值（最大为 255）（图 5-9）。 默认为 COM1。 单击 OK。

图 5-9： COMMUNICATIONS 选项卡

按照第 2.4.1 节 “安装通信线缆”中的说明，来确保端口设置正确。

5.7 PICSTART PLUS 编程器所使用的文件

PICSTART Plus 编程器可以直接使用来自 MPLAB IDE 项目的信息，不需要任何中间
步骤。 MPASM 汇编器可从 MPLAB IDE 分开使用产生 PICSTART Plus 编程器的十六
进制文件。 或者，可以用与 PICmicro 单片机兼容的交叉汇编器或编译器中的十六进制
文件编程器件。

如果您在 MPLAB IDE 外单独使用 MPASM 汇编器，或在 MPLAB IDE 中产生稍后和
PICSTART Plus 编程器一起使用的十六进制文件，就应该使用 INHX8M 或 INHX32 十
六进制格式。 MPASM 汇编器默认输出的十六进制文件格式为 INHX32。 如果要对
PIC17CXXX 或 PIC18XXX 器件编程，应使用 INHX32 格式。

注： 指定使用的端口必须设置相应的属性以便与 PICSTART Plus 正确通信。 参
见第 B.2.1.2 节 “COM 端口设置”。
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5.8 升级 PICSTART PLUS 固件 OS
为了支持新的器件，您可能需要升级 PICSTART Plus 固件 OS。 升级固件 OS 的方法
取决于编程器中是否安装了 PICSTART Plus Flash 更新模块 （PUM）。

PUM 是一块含有一片 PIC18F6720 器件的印刷电路板 （PCB），该器件已被编程有支
持在 MPLAB IDE 中对某些器件进行编程所需的固件 OS 。 PUM 用来代替 PICSTART 
Plus 中的 PIC17C44 器件。 PIC17C44 器件能支持的固件 OS 最高版本为 V3.11。当
MPLAB IDE 支持新器件时， PUM 使用闪存技术来升级 PICSTART Plus 固件 OS。
本节提供的信息包括：

•  检查 PICSTART Plus 是否有 PUM
•  判断是否需要 PUM
•  安装 PUM
•  验证 PUM 工作正常

•  下载新固件

•  验证 PICSTART Plus 固件更新

5.8.1 检查 PICSTART Plus 是否有 PUM
版本号为 R20 或更高的 PICSTART Plus 已经装备了 PUM 或者已经在其 PCB 中内建
了 PIC18F6720。 PICSTART Plus 的版本号是字母 “R”后面跟一个数字，标示在塑
料包装底部的序列号旁边。 另一种确定所使用的固件 OS 的方法是在使能 PICSTART 
Plus 后，在 MPLAB IDE 中，选择 Help>About。 如果固件 OS 版本不是 4.0.5 或以
上， PICSTART Plus 不包含 PUM。

5.8.2 判断是否需要 PUM
判断是否需要 PUM 的关键是器件支持。 下列情况说明需要新的固件 OS：
•  查阅 PICSTART Plus 的 Readme （自述）文件，该文件存放在工作站上安装

MPLAB IDE 应用程序的 \MPLAB IDE\Readme目录中。 该文件详细说明了支持
器件所需的最低固件 OS 版本。 如果 PICSTART Plus 中的固件 OS 的版本不支持
所需的器件，则必须升级。

•  在 MPLAB IDE 中使能 PICSTART Plus。 如果接收到一个声明器件需要特定固件
版本的消息，则表明 MPLAB IDE 所检测到的固件 OS 版本比支持所选器件需要的
版本低。 PICSTART Plus 需要升级到支持所需器件的固件 OS 版本。 如果
PICSTART Plus 使用 PUM 或者已经将 PIC18F6720 内建在 PCB 中了，新固件
OS 可以使用 MPLAB IDE 中的 Programmer 菜单选项下载。 如果不是这样，则须
更换 PICSTART Plus 中的 PIC17C44。
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强烈建议购买一个 PUM 来配合较早的 PICSTART Plus，这是因为：

•  PICSTART Plus 固件 OS 的版本比 2.01 早，同时需要使用 MAPLAB IDE。
•  我们将不再发布任何基于 PIC17C44 的固件 OS。 这些发布止于固件 OS 版本

3.11，该版本可以在 psf31100.hex文件中找到。

•  当有新器件上市，并添加到 MPLAB IDE 选择列表中时，在 PICSTART Plus 固件
OS 中也增加了对它们的支持。 于是 PUM 将使得该 PICSTART Plus 能够继续使
用。 PUM 适用的固件文件命名为 psplsxxxxx.hex，其中 xxxxx 是版本号。

5.8.3 安装 PUM
PICSTART Plus Flash 升级模块 （PUM） PCB 取代了 PICSTART Plus 包装中的 U21
插槽中已有的 PIC17C44 单片机。 一旦安装了该处理器升级模块，您在升级固件 OS
的时候，将不再需要打开 PICSTART Plus ，烧录新器件来替换插槽中的单片机。 未来
的固件 OS 升级可以利用 MPLAB IDE 通过串口重新编程该升级 PC 板上单片机的闪存
存储器来完成。

升级后的 PICSTART Plus 将和如下一起发挥作用：

•  MPLAB 5.62 或更高版本

•  所有 MPLAB IDE 版本

如果 PICSTART Plus 包含 PIC17C44，请按以下说明安装升级 PCB：

5.8.3.1 所需装备

安装处理器升级模块，您需要：

•  随工具包提供的 PICSTART Plus 处理器升级模块。

•  十字螺丝刀

5.8.3.2 安装

1. 切断 PICSTART Plus 的电源，并断开与计算机串口的连接。

2. 小心地将 PICSTART Plus 后面的十字螺丝卸下， 除去后盖。

3. 从 U21 插槽中小心地移去 PIC17C44 单片机。

4. 小心地将 PICSTART Plus 处理器升级套件插到 U21 插槽中，确信引脚 1 的方向
正确 （引脚 1 应该靠近串口连接器）。
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图 5-10： 处理器升级模块

5. 盖上后盖，确信处理器升级工具包上的孔和后盖塑料壳上的孔对齐。

6. 将十字螺丝插入到后盖的孔里。 小心的将每个螺丝慢慢地旋紧，如果旋的过紧可
损坏塑料壳。

7. 将 PICSTART Plus 编程器重新连接到计算机的串行端口上，同时连接电源线。

5.8.4 验证 PUM 工作正常

当使用 PUM 替代 PIC17C44 时，或者第一次使用 PICSTART Plus 时，应该保证硬件
正确地工作：

•  检查连接到工作站和硬件的串行线缆的物理连接。

•  确保在 MPLAB IDE 中所选择的通信端口和实际使用的一致。

•  选择在 MPLAB IDE 中可用的最早版本的固件 OS （2.01）支持的器件
（Configure>Select Device），如 PIC16F84A。

•  选择 Programmer>Select Programmer>PICSTART Plus 作为编程器。

•  选择 Programmer>Enable Programmer。 如果您可以成功地使能编程器而没有接
收到通信错误的消息，则表明硬件工作正常。

注： 通知有可用的更新固件并不是通信错误消息。 不需要采取任何行动。
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5.8.5 下载新固件

只有当需要用新固件 OS 支持器件或新固件 OS 中包含了对已知问题的修改时，才应
该进行新固件 OS 下载。 MPLAB IDE 中的固件发布是向后兼容的——它支持以前发布
的固件 OS 版本中包含的器件。 但也有一些器件不受 MPLAB IDE 支持。

要下载固件，必须有：

•  已更新为使用 PUM 的 PICSTART Plus， PICSTART Plus 版本 20 或更高。

•  MPLAB IDE 6.40 或更高。 最好为 MPLAB IDE 6.61 或更高。

如果接收到一个声明器件需要特定的固件 OS 版本的消息，则表明 MPLAB IDE 所检测
到的固件 OS 版本比支持所选器件所需要的版本低。 PICSTART Plus 需要升级到支持
所需器件的固件 OS 版本。 欲了解最早的支持器件的固件 OS 版本的信息，参见
Readme for PICSTART Plus.txt.。
执行下列步骤，确保下载成功：

1. 在 MPLAB IDE 中，选择 Configure>Select Device，选择 MPLAB IDE 中可使用
的最早版本的固件 OS （2.01）支持的器件，如 PIC16F84A。

2. 选择 Programmer>Select Programmer>PICSTART Plus。
3. 选择 Programmer>Enable Programmer。
4. 选择 Programmer>Download PICSTART OS。 出现对话框时，从固件 OS 文件

列表中选择需要的版本。 OS 文件的格式是 psplsversion.hex，其中
version 是 OS 的版本号。 完全发布版本最末两位为 ‘00’。

5. 单击 Open 开始下载过程。

下载结束时，在 Output 窗口中将显示状态消息。

6. 选择 Programmer>Disable Programmer，禁用 PICSTART Plus。
7. 然后，选择 Programmer>Enable Programmer，这样固件 OS 版本中的改变将

被 MPLAB IDE 识别。

注： 如果 MPLAB IDE 检测到比 v4.00 更早的 OS，它将不下载升级 OS。

注： 下载时，不要试图在 MPLAB IDE 执行其它任务。
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5.8.6 验证 PICSTART Plus 固件更新

1. 打开 MPLAB IDE v6.xx 软件。

2. 选择 Programmer>Select Programmer>PICSTART Plus，选择 PICSTART Plus
编程器。 

3. 选择 View>Output 来打开 Output 窗口。

4. 选择 Programmer>Enable Programmer，开始使用 PICSTART Plus 编程器。

5. 选择 Programmer>About，显示 PICSTART Plus 固件 OS 的版本。
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附录 A 硬件规范
A.1 简介

本附录包括：

•  通过串行端口连接到 PC
•  物理尺寸和布局

A.2 通过串行端口连接到 PC
PICSTART Plus 编程器通过标准的带 DB9 连接器的 RS-232 端口连接到 PC。 此装置
默认通信速率为 19.2K 波特率。 
串行端口通信如下：

•  8 个数据位、 1 个停止位、无奇偶校验位

•  硬件流控制

•  FIFO 缓冲区应被禁止

表 A-1 提供了将 PICSTART Plus 编程器 （9 针）连接到 25 针串行端口的数据。 按照
该表中每行的指示连接相应的终端。 

A.3 物理尺寸和布局

PICSTART Plus 编程器的物理尺寸是 6 英寸× 4 英寸× 14/16 英寸。 此编程器的俯视
和后视图分别如图 A-1 和图 A-2 所示。

表 A-1： PC 主机与 PICSTART PLUS 传输信号

 25 针（PC 主机）  9 针 （PICSTART Plus）

2 TX 2 RX

3 RX 3 TX

20 DTR 4 DTR

7 通用 5 通用

6 DSR 6 +5V （上拉）

4 RTS 7 CTS

5 CTS 8 RTS
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图 A-1： PICSTART PLUS 俯视图

图 A-2： PICSTART PLUS 后视图
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附录 B 疑难解答
B.1 简介

本附录提供解决 PICSTART Plus 编程器问题的信息，包括：

•  常见问题

•  错误消息、警告和通知

•  限制

B.2 常见问题

•  无法与 PICSTART Plus 建立通信

•  高级串行通信帮助

•  看不见 Programmer Options （编程器选项）

•  软件和操作系统版本不兼容

•  空白检查问题

•  LED 指示灯闪动或不亮。

•  器件引脚损坏

•  下载不成功

B.2.1 无法与 PICSTART Plus 建立通信

当使能 PICSTART Plus 器件编程器时， MPLAB IDE 试图建立和该编程器的通信。 如
果无法建立通信，将无法进行编程。 如果尝试建立通信失败， Output 窗口中将显示相
应消息。

•  一般通信的疑难解答

•  COM 端口设置

B.2.1.1 一般通信的疑难解答

1. 确信 RS-232 线缆已经连接，电源已经连接，编程器上的电源 LED 灯亮。

2. 尝试将编程器连接到另一个串口。 如果 PC 有 25 针串口，需要一个 25 针到 9
针的串行端口适配器。

3. 确信编程器专用的 COM 端口设置正确。 检查资源，确保它们运行正常，且不和
其它的设备冲突。 如果在指定的 COM 端口上检测到有其它硬件，或者在试图建
立通信时该 COM 端口被软件所使用，连接将失败。 参考 Windows 手册或者其
它的参考文献。您可以尝试卸载、重新配置或者禁用发生冲突的设备或软件，但
只有在您熟悉那些步骤的情况下才这么做。 参见第 B.2.1.2 节 “COM 端口设
置”。

4. 驱动程序与硬件不兼容也会导致一些系统错误。 参见第 B.2.1.2 节 “COM 端口
设置”。
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5. 确信您使用的不是第三方通信驱动程序。 更多信息，请参见第 B.2.2.4 节 “第三
方通信驱动程序”。

6. 如果使用了虚拟串口 （如 USB 到串口的适配器产生的虚拟串口），确信指定的
COM 端口的属性已正确设置。 参见第 B.2.1.2 节 “COM 端口设置”。

7. 固件版本低于 2.01。 MPLAB IDE 版本要求固件版本为 2.01 或更高。

8. MPLAB 5.61 或其更低版本和固件版本 3.11 或其更高版本一起使用。 和固件版
本 3.11 及以上版本一起使用的 MPLAB 的 16 位版本，需要 5.62 或更高的版本。

更多信息，请参见第 B.2.2 节 “高级串行通信帮助”。

B.2.1.2 COM 端口设置 

Windows COM 端口设置需要格外小心。 如果您怀疑硬件与驱动程序不兼容，查看控
制面板，试着改变硬件流控制并 / 或者关闭串口的 FIFO。 按照以下 PC 的操作系统说
明：

Windows 98/ME

1. 点击系统图标。

2. 单击设备管理器选项卡。

3. 点击端口。 如果需要，单击其旁边的 ‘+’号展开端口选项。

4. 双击和编程器相连的 COM 端口。

5. 将 “流控制：”设置为 “硬件”。

6. 单击高级，清除 “使用 FIFO 缓冲区”复选框并单击确定。

7. 重启 PC，使改变生效。

Windows NT

1. 点击端口图标。 
2. 选择 COM 端口，点击设置。 设置 “流控制”为硬件。 
3. 单击高级，清除 “启用 FIFO”复选框并单击确定。 
4. 重启 PC，使改变生效。

Windows 2000/XP

1. 点击系统图标。 
2. 单击硬件选项卡。

3. 单击设备管理器。 
4. 如果需要，单击其旁边的 ‘+’号展开端口选项。 
5. 双击和编程器相连的 COM 端口。 
6. 将 “流控制：”设置为 “硬件”。

7. 单击端口设置选项卡并单击高级。 
8. 清除 “使用 FIFO 缓冲区”复选框并单击确定。 
9. 重启 PC，使改变生效。
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B.2.2 高级串行通信帮助

这里阐述了一些可能导致串行通信故障的地方。

•  与调制解调器冲突

•  串行鼠标的问题

•  中断冲突

•  第三方通信驱动程序

B.2.2.1 与调制解调器冲突

编程器不能和调制解调器或任何其它硬件共用同一个通信端口或中断。 要解决这个问
题，要么禁用其它的硬件，将其中一个移到另一个通信端口，要么断开硬件。

B.2.2.2 串行鼠标的问题

如果您有串行鼠标，确信您没有无意中指定串行鼠标通信端口作为编程器端口。

B.2.2.3 中断冲突

检查系统是否存在中断冲突。 确信每个器件只使用一个中断。

Windows 98/ME

1. 从开始菜单中选择设置 > 控制面板。 
2. 选择系统并单击设备管理器选项卡。 
3. 展开端口选项，确信没有冲突指示。

Windows NT/2000/XP

1. 从开始菜单中，选择设置 > 控制面板。 
2. 选择系统并展开端口列表。 
3. 点击列表中的一个 COM 端口，然后单击端口设置选项卡。 
4. 在端口设置对话框，单击高级。 
5. 确信没有 IRQ 冲突。

B.2.2.4 第三方通信驱动程序

编程器设计为与 Windows 操作系统提供的驱动程序一起使用。 第三方驱动程序不一定
能 够 使 用。 检 查 为 使 用 中 的 COM 端 口 所 指 定 的 驱 动 程 序。 如 果 驱 动 程 序
不 是 由 Microchip 提供的，则需要改变。

B.2.3 看不见 Programmer Options （编程器选项）

您必须选择一个所使用的固件支持的器件，然后在编程器选项可用之前选择编程器。 
选择 Programmer>Select Programmer 并从列表中选择 PICSTART Plus。 
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B.2.4 软件和操作系统版本不兼容

软件的版本与操作系统的版本混淆了。 PICSTART Plus 编程器和 MPLAB IDE 软件包含
兼容性检查，来确保符合版本要求。 最新的 PICSTART Plus 软件和 OS 固件包含在
MPLAB IDE 安装程序中。 确信使用的是最新版本的 MPLAB IDE。

B.2.5 空白检查问题

你可能遇到的空白检查问题包括：

•  PIC16C73、 PIC16C74：已知为空的器件显示为非空

•  当读空的 PIC16C55A、 PIC16C57C 或 PIC16C57 时，报告程序存储器值为
0xBFF。

B.2.5.1 PIC16C73、 PIC16C74：已知为空的器件显示为非空

当对一些 PIC16C7X （PIC16C73、 PIC16C74）器件编程时，已知为空的器件会显示
为非空，并且将不会正确编程。 这种问题的产生是因为 VPP 的上升时间太快以至于来
不 及 将 该 器 件 设 置 为 编 程 模 式。 这 种 问 题 只 发 生 在 某 些 日 期 代 码 的 器 
件上 以及 非 PIC16C7XA 器件上。

在 插 入 器 件 之 前，在 插 槽 的 VPP （引脚 1）和 接 地 端（引脚 8）之 间 插 入 一
个 0.01mF 的电容。 这将放慢 VPP 上升的时间，允许器件进入编程模式。 

B.2.5.2 当读空的 PIC16C55A、 PIC16C57C 或 PIC16C57 时，报告程序存储器值
为 0XBFF。

这些器件的晶振电路和前面的器件不同，在读操作期间会产生冲突。 
使用一个将 OSC2 （引脚 26）剪掉的插槽可解决此问题。

B.2.6 LED 指示灯闪动或不亮。

这可能是热熔丝熔断造成的。 这可能是由于选择了错误的器件或者器件被错误地放在
ZIFF 插槽中。 移去 PICSTART Plus 编程器上的器件并断开电路的电源，重置内部热
熔丝。 确信器件的引脚 1 和 PICSTART Plus ZIFF 插槽的引脚 1 对准。

LED 闪烁或不亮还可能是因为电源不兼容或电源极性相反。 确信使用的电源是
PICSTART Plus 编程器中包含的那个或用一个兼容的电源。 如果 LED 还不亮的话，请
联系 Microchip 支持。

B.2.7 器件引脚损坏

在较小的器件封装（SSOP、 PQFP 和 SOIC）中，引脚很容易弯曲，因此会在对器件
编程时产生问题。 用小的针头钳将引脚扳直，然后再尝试编程器件。 
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B.2.8 下载不成功

在下载固件进行的时候，如果电源、串行通信或者 MPLAB IDE 的状态发生中断，下载
将失败。 可能显示的错误消息包括：

•  PICSTART Plus Firmware has been corrupted. You must download a new 
operating system. （PICSTART Plus 固件被破坏。 您必须下载一个新的操作系
统。）

• PICSTART Plus not found. Please verify serial connection and try the current 
operation again.（没有发现 PICSTART Plus。 请验证串行连接并重试当前操作。）

• Download Firmware not successful. （下载固件不成功。）

•  Download Firmware not successful. Number of bytes not echoed properly. （下载
固件不成功。 字节数目回显不正确。）

选择了下载选项后， MPLAB IDE 和 PICSTART Plus 之间的通信就立即开始。 在试图
使用该选项下载固件之前，始终确信 PICSTART Plus 没有通信问题。 为了确保编程器
没有通信问题，执行 Programmer>Enable。 如果该命令能成功执行而没有通信错误，
则 PICSTART Plus 已经准备好进行下一步的通信了。

如果需要，执行固件下载。 当下载完成时，禁用、然后使能编程器，这样固件版本的
改变将完全被 MPLAB IDE 识别。 执行 Programmer>About，确认当前使用的版本。 下
载更新固件的更多细节参见第 5.8.5 节 “下载新固件”。

B.3 错误消息、警告和通知

你可能会接收到以下错误消息、警告或通知：

•  Cannot Transmit/Receive （不能发送 / 接收）

•  Newer Firmware Required （需要新固件）

•  New Firmware Available （有新固件）

•  Download Not Successful （下载不成功）

•  Could Not Open The Communications Port （不能打开通信端口）

•  Program Memory Contains Code-Protected Data

 （程序存储器包含代码保护数据）

•  Framing Error （帧错误）

•  Parity Error Found In Program Memory （在程序存储器中发现奇偶校验错误）

•  Send/Receive Errors （发送 / 接收错误）

B.3.1 不能发送 / 接收

不能发送：这是最常见的错误。 这表明 PC 不能发送任何信息到编程器。

不能接收：软件能发送信息到编程器，但编程器没有响应。

参考第 B.2.1节 “无法与PICSTART Plus建立通信”和第 B.2.2节 “高级串行通信帮
助”。

注： 如果试图将固件下载到包含 PIC17C44 的 PICSTART Plus，将接收到错误
消息。
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B.3.2 需要新固件

如果在使用选项 Programmer>Enable 后显示“This device requires firmware xx”（该
器件需要固件 xx）消息，这表明当前使用的固件版本不支持所选择的器件。 消息中声
明了支 持器件 所需的 最低固 件版本 。  必须 下载支 持 本 器 件 的 固  件，才 能 使 用
PICSTART Plus。 欲了解下载说明，请参见第 5.8.5 节 “下载新固件”。

B.3.3 有新固件

如果在使用选项 Programmer>Enable 后，显示一条消息告知有新固件可用，表明
PICSTART Plus 没有错误。 该消息只是告知用户当前 MPLAB IDE 版本中有可用的更
新的固件版本。 如果打算使用 PICSTART Plus 新支持的器件，您将需要下载更新的固
件。 否则，不必下载新固件。

B.3.4 下载不成功

在下载固件进行的时候，如果电源、串行通信或者 MPLAB IDE 的状态发生中断，下载
将失败。 可能显示的错误消息包括：

•  PICSTART Plus Firmware has been corrupted. You must download a new 
operating system. （PICSTART Plus 固件被损坏。 您必须下载一个新的操作系
统。）

•  PICSTART Plus not found. Please verify serial connection and try the current 
operation again. （没有发现 PICSTART Plus。 请验证串行连接，并重试当前操
作。）

•  Download Firmware not successful. （下载固件不成功。）

•  Download Firmware not successful. Number of bytes not echoed properly. （下载
固件不成功。 字节数目回显不正确。）

选择了下载选项后， MPLAB IDE 和 PICSTART Plus 之间的通信就立即开始。 在试图
使用选项下载固件之前，始终要确保 PICSTART Plus 没有通信问题。 为了确保编程器
没有通信问题，执行 Programmer>Enable。 如果该命令能成功执行而没有通信错误，
则 PICSTART Plus 已经准备好进行下一步的通信了。

如果需要，执行固件下载。 当下载完成时，禁用、然后使能编程器，这样固件版本的
改变将完全被 MPLAB IDE 识别。 执行 Programmer>About，确认当前使用的版本。 下
载更新固件的更多细节参见第 5.8.5 节 “下载新固件”。

B.3.5 不能打开通信端口

如果不能打开通信端口，是因为已经有其它应用程序打开了该端口或者端口不存在。
确保端口号有效并且没有其它应用程序正在使用它，如打开了另一个 MPLAB IDE 应用
程序。
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B.3.6 程序存储器包含代码保护数据

当试图去读一个某些 EEPROM 区域或程序存储器被代码保护的器件时，将显示一条
声明信息无效的消息。 代码保护的 OTP 或 EPROM 器件不能擦除；然而 Flash 器件能
擦除或反复编程。 
代码保护的存储区中的数据可能产生混乱或者显示为零。 可以对器件中不受代码保护
的区域编程。 有些器件要求在检测到代码保护时对整个器件编程。 此句改为：参考器
件的数据手册以判断代码保护是如何处理的，是不是某些存储区域在保护之外，等等。

B.3.7 帧错误

这个错误表明当试图从编程器读数据的时候，发生硬件错误。 这不是一个非常常见的
错误。 它通常表明 PC 或编程器的通信硬件发生了某种问题。

B.3.8 在程序存储器中发现奇偶校验错误

有些器件有请求奇偶计算的配置位。 如果该位设置为 “ON”，将比较程序存储器中的
内容并赋于 “偶数”或 “奇数”校验。 如果设置为 “OFF”，器件不执行比较。

在空白器件中，奇偶配置位默认地设为 “ON”。如果一个器件在编程时奇偶配置位被
设为 “ON”，那么对此器件进行的任何重编程都可能导致显示奇偶校验错误。 这个错
误的发生是因为检测到当前奇偶校验和上次编程的奇偶校验不匹配。 然而，接收到奇
偶校验错误并不停止对器件的编程。

但是，如果一个器件在编程时奇偶校验位设置为 “OFF”，在重编程时将不会为进行
奇偶校验而比较程序存储器的内容。 器件在重新编程时不会接收与奇偶校验有关的消
息。

所有的 OTP 器件，包括有奇偶校验配置位的器件均不能成功的将任何 “0”位值重新
编程成 “1”。如果一个器件在编程时奇偶校验配置位设为 “OFF”，就不能将奇偶校
验变回 “ON”。要想重新编程只能使用空白器件。

B.3.9 发送 / 接收错误

当 MPLAB IDE 试图在指定的 COM 端口上和 PICSTART Plus 通信而没有得到响应
时，就会 发 生发送 错 误。 该 错 误 一 般 会 显 示 消 息 “No programmer detected”
（未检 测 到编程器 ）。 请确保 PICSTART Plus 电 源 已 经 连 接，而 且工作站与
PICSTART Plus 已用串行线缆连接好。 确信在 MPLAB IDE 中指定的 COM 端口是实
际使用的那个。

当读器件或对器件编程时，发生接收错误，如扫描到串行超时。 这可能是由于操作期
间串行连接中断，或者器件在 PICSTART Plus ZIFF 插槽中没有正确地对准而产生的。 
虽然该错误不普遍，但多见于 Windows ME 和 98/SE 操作系统。 如果通过使用更小的
程序存储器范围或特定的存储区对器件编程仍然无法解决这个问题，则也许只能使用
另一个 Windows 操作系统。
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B.4 限制

•  一般限制

•  针对于特定器件的限制

B.4.1 一般限制

•  PICSTART Plus 开发编程器使您能编程 PICmicro 单片机器件。 某些封装类型单片
机的适配器可以购买。 查询 Microchip 网站获得购买信息。 当前支持的器件列表可
以查看 readme.pls文件。

•  PICSTART Plus 编程器设计用于固件开发而非生产用途。

•  PICSTART Plus 不支持 ICSP。
•  对于除配置位外的所有存储器空间 （未代码保护），均可以将 1 编程为 0，但不能
将 0 编程为 1，也就是说，您必须擦除后再编程。

B.4.2 针对于特定器件的限制

除了上面列出的一般限制，有些 PICmicro MCU 可能还有针对特定器件的限制。

•  PICSTART Plus 对 PIC16F87X/87XA 的限制

程序存储器的首个单元 （地址 0x0000）必须是一个 NOP 指令。

•  PICSTART Plus 对 PIC18F2331/2431 的限制

所有电源 （VDD 和 AVDD）和接地 （VSS 和 AVSS）引脚都必须使用才能对器件编
程。 PICSTART Plus 会正确处理 VDD、VSS 和 AVSS，但要器件正常工作，必须在
插槽中的引脚 7 （AVDD）和引脚 11 之间放置一个 1K Ω的电阻。 其它器件可能需
要使用所有电源和接地引脚。 如果发生本章未解释的编程错误，比如编程不一致，
请查询数据手册。

•  边界限制

有些器件有关于程序存储器的哪些范围可以指定用于编程的限制。 PICSTART 
Plus 软件会检查在 Settings 对话框中输入 Memory Range 文本框中的开始和结束
地址。 如果针对某些器件填写的地址不正确，将显示一条消息。
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Tel: 86-755-8203-2660 
Fax: 86-755-8203-1760

中国 - 顺德
Tel: 86-757-2839-5507 
Fax: 86-757-2839-5571

中国 - 青岛
Tel: 86-532-502-7355  
Fax: 86-532-502-7205

台湾地区 - 高雄
Tel: 886-7-536-4818
Fax: 886-7-536-4803

台湾地区 - 台北
Tel: 886-2-2500-6610  
Fax: 886-2-2508-0102

台湾地区 - 新竹
Tel: 886-3-572-9526
Fax: 886-3-572-6459

亚太地区

澳大利亚 Australia - Sydney
Tel: 61-2-9868-6733 
Fax: 61-2-9868-6755

印度 India - Bangalore
Tel: 91-80-2229-0061 
Fax: 91-80-2229-0062

印度 India - New Delhi
Tel: 91-11-5160-8631
Fax: 91-11-5160-8632

日本 Japan - Kanagawa
Tel: 81-45-471- 6166  
Fax: 81-45-471-6122

韩国 Korea - Seoul
Tel: 82-2-554-7200  
Fax: 82-2-558-5932 或
82-2-558-5934
新加坡 Singapore
Tel:  65-6334-8870  
Fax: 65-6334-8850

欧洲
奥地利 Austria - Weis
Tel: 43-7242-2244-399
Fax: 43-7242-2244-393
丹麦 Denmark - Ballerup
Tel: 45-4450-2828 
Fax: 45-4485-2829
法国 France - Massy
Tel: 33-1-69-53-63-20  
Fax: 33-1-69-30-90-79
德国 Germany - Ismaning
Tel: 49-89-627-144-0 
Fax: 49-89-627-144-44
意大利 Italy - Milan 
Tel: 39-0331-742611  
Fax: 39-0331-466781
荷兰 Netherlands - Drunen
Tel: 31-416-690399 
Fax: 31-416-690340
英国 England - Berkshire
Tel: 44-118-921-5869
Fax: 44-118-921-5820

全球销售及服务网点
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