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第 1章. 介紹 InduSoft Web Studio  

InduSoft Web Studio ™ (or IWS) 在Microsoft® Windows® NT/2000/XP and 
Windows® CE下是有力整合開發工具，使你能夠來建立全方位的SCADA 
(Supervisory Control And Data Acquisition) 或 HMI (Human-Machine Interface) 
應用在你的企業自動化。  

概觀 
這 InduSoft Web Studio 快速指導手冊， 將會幫助你很快地使你自己熟悉InduSoft 
Web Studio的基本功能。 

 

! 注意：  
假定你熟悉 Windows NT/2000/XP 作業系統。然而，如果當你工作中需要協助，
我們提議使用視窗桌面上的開啟(Start)->說明(Help)選項。 

 
這個開始指引被區分為下列各項章： 

" 這章節提供InduSoft Web Studio產品的簡單概觀，包括它的主要部份特徵和系統
需求。 

" 第 2 章，相於本冊出版： 提供關於這本書出版的資訊；像是編排的習慣與印刷的規
範。 

" 第 3 章，軟體安裝：說明如何安裝InduSoft Web Studio和 CEView 到你的系統
上。 

" 第 4 章， IWS 環境介面：描述IWS發展環境的所有元素；包含 menubars, toolbars, 
dialog boxes, buttons, menus等等。 

" 第 5 章， Tags的運用：描述如何在tags database上建立和編輯tags；包含tag 型
別與適當的語法。 

" 第 6 章， 建立 IWS應用程式： 說明如何來建立和編輯應用程式、物件、畫面、驅動
程式。也說明測試你的應用程式的程序。 

" 第 7 章，在 Web-Based 執行應用程式： 解釋該如何開始執行在你的Web-based 應
用程式。 

" 第 8 章，從遠端執行應用程式： 說明如何從遠地來執行與管理應用程式。 
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關於 InduSoft Web Studio 
InduSoft Web Studio 應用程式包含動態螢幕操作介面，通訊驅動程式(為了 PLCs 和 
I/O 協定例如Modbus, DFS, Profibus等等), tags 資料庫, 和附屬模組例如警報監視
器，邏輯，趨勢圖，報表，行程與系統安全。  

IWS 應用程式介面使用開放式 I/O 系統與其他 Windows 應用程式使用ODBC, DDE, 
NetDDE, OPC, or TCP/IP 協定環境下執行。你也可以使用Web瀏覽器來操作 
(Internet Explorer or Netscape)。 

此套軟體共分二個版本：  

" 發展版：可讓使用者利用一般桌上型電腦，筆記型電腦或工業級電腦在Windows 
NT/2000平台上設計開發人機介面監督控制應用程式。  

" 執行版：僅允許使用者在Windows NT/2000或Windows CE平台上在操作而無
法作發展的動作。若是使用Windows CE的平台(或稱 CEView)Studio的執行版
通常已事先建立在 HMI中。一旦須要修改時可使用裝有發展的主機，透過網路直
接線上下載新的應用程式到WinCE中。 

 

! 注意：  
在Windows CE 作業系統 (CEView)下，執行版軟體通常被載入到 HMI。假如有
需要更新CEView版本，可從發展版系統軟體中下載正確的版本到HMI or PDA。 

 

你能夠執行IWS 應用程式在你發展的工作站上或下載到執行工作站上(經由串列埠或 
TCP/IP連線) 和執行應用程式使用 IWS or CEView 執行版軟體。工作站處理掃描資料
依應用程式定義參數來連接裝置然後產生反應，顯示，儲存，而且上傳資料。  
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主要特色 
InduSoft Web Studio 產品提供特色和功能： 

" Web 介面允許你在Web瀏覽器上有視覺化畫面 (在用戶端) 經由TCP/IP通訊協定
在網際網路/企業網路和伺服器上做資料交換。 

" 獨立平台的應用程式，它允許用 IWS 所建立的應用程式在 Microsoft 任何平台上
執行(Windows NT/2000/XP and Windows CE)。 

" 線上, 遠端遙控管理與設定應用程式(下載/上傳, 命令, 系統和網路診斷，和除錯)。 
" 整合 Microsoft Windows® XP系列發展環境使用工具列、對話框、選項、客戶自
訂工作列。  

" 友善的畫面編輯器，讓你能夠建立應用程式畫面且快速的執行。 
" 提供超過百種的圖庫和動態物件，例如： 

 

– Frames 
– Icons 
– Motors 
– Pipes 

– Meters and gauges 
– LED-style indicators 
– Text and numeric displays 
– Common controls 

– Sliders and switches 
– Pumps and valves 
– Pushbuttons 
– Vehicles 

 
" 在專案中提供前後參照工具來找出 tags 位置。 
" Active-X 物件容器。 
" 自訂物件屬性來創迼出具體的和動態的物件，例如動態長條圖(bar graphs), 顏色

(color), 改變大小(resizing), 位置(position), 旋轉(rotation), 隱藏/顯示
(hide/unhide), 命令(commands), 超鏈結(hyperlinks), 和 文字輸入/輸出(text 
input/output)。 

" 延伸軟體產品使用開放式架構 API 來改變 tag值，以順應 Microsoft.NET 架構。  
" 合併式的工作表單和畫面模組，可以很容易的進入到其他應用程式內。 
" 執行期的安全性提供畫面和物件密碼保護(256 層)。 
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" 有整合的 OPC 瀏覽器使用OPC 用戶端和伺服諯模組，DDE 用戶端和伺服端模組 ， 

與 TCP/IP 用戶端和伺服端模組 ( tag 值和設定值資訊交換多種系統)。 
" 提供超過 150種通訊驅動程式給不同的設備(例如 PLCs) 由製造廠商例如

Allen-Bradley, Siemens, GE-Fanuc,有好的標準通訊協定例如MODBUS 
RTU/ASCII, DeviceNet, Profibus, Interbus, 和更多。 

" 提供超過 200多種函數給邏輯表示和程式撰寫。 
" 線上/歷史的警報和趨勢圖，和配方/報表建立 (text, XML, or RTF format–ASCII 

or UNICODE)。 
" 事件行程 (日期, 時間, 或 tag 的基本條件)。 
" 轉譯編輯可轉譯應用程式到不同的語言；在執行時期可在不同語言上切換。 
" 資料庫 Spy 視窗 (本端和遠端) 可 監視/影響 tag 值和執行功能。 
" LogWin 模組 (本端和遠端) 可 紀錄 DDE, OPC, 和 TCP/IP 傳輸, 動態模組,  tags
軌跡, 等等。 

" 一個強且可塑性 tag 資料庫可用型別有邏輯( Boolean), 整數(Integer), 實數(Real), 
和字串(String) 資料點(tags), 資料點陣列(array tags), 類別(classes), 和間接資料
點(tag)-指標。 

" 整合全部的 PC-based 控制裝置 (使用 tags 資料庫) 例如 ASAP, ISaGRAF, 
SteepleChase, 和 Think&Do 。 

" 撥接式數據通信功能去觸發，監視和結束與遠端 RAS 伺服站數據通訊。  

" 從 IWS (or CEView)中自動的傳送 E-Mail的功能。 

! 注意： 
IWS  提供不同產品的型態(舉例來說區域界面和控制室)給每一階層負責應用程
式。然而，在某產品類型中不支援這些特徵。(例如 CEView) 
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系統配備 
要使用 IWS, 你一定安裝下列各項硬體和軟體： 

" IBM相容電腦，使用 Intel® Pentium II-相容處理器或更高等級。 
" 發展版需Windows NT/2000/XP 作業系統。 
" 執行執需Windows NT/2000/XP 或 Windows CEv3.00 或 Windows CE.NET 

作業系統。 
" 最小需 128MB 動態存取記憶體 (RAM); 建議 256MB或更高需求。 
" 瀏覽器MS Internet Explorer 4.0 或更高版本。 
" 最至少 150MB硬碟剩餘空間(留給 InduSoft Web Studio程式使用)，建議最少預

留 300MB。 
" 3.5"軟碟機。 
" 光碟機 (或外接式光碟機)。 
" 標準鍵盤有功能鍵 F1到 F12。 
" 並列印表機埠 (可選用) 
" 100% IBM-相容 VGA or SVGA 顯示卡有 32MB Video RAM (VRAM) (可選用當
在執行Web-based 應用程式時)。 

" Microsoft-相容指標裝置 (例如滑鼠， 軌跡球或觸控螢幕)。 
" 一個或二個 COM 埠和可下載應用程式裝置 (可選用)。 
" 下載應用程式 Ethernet 連線 (可選用)。 

! 注意：  
InduSoft Web Studio是用UNICODE製作而成因此不適用不支援UNICODE的
平台上(Windows 9x/ME)，不過若您僅是使用瀏覽器來監控InduSoft Web 
Studio畫面時(Web Thin Clients)並不受此限制。 
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第 2章. 關於指導手冊 

本章提供有關 InduSoft Web Studio 快速指導手冊和 其他 InduSoft 排版的下列各項
資料： 

" 文字慣例： 描述本文格式的慣例，幫助你快速的閱讀及吸收這些資訊。 
" 滑鼠與選擇慣例： 描述在Windows 環境下使用滑鼠和選擇物件在印刷上的慣例。 
" 視窗慣例： 描述Windows 環境下工作的印刷上慣例。 
" 相關手冊 ： 列出其他 InduSoft 手冊(可在 IWS 安裝 CD-ROM光碟片中得到) ，

讓你能夠閱讀更多有關於 InduSoft Web Studio 產品的知識。 

文字慣例 
這本出版使用特別的很快地格式幫助你認明某項目，依下列各項： 

" 名稱，標籤，和新的術語使用斜體字來提示。 
" 檔案名字，訊息，和螢幕文字使用單一間隔粗體字來提示(例如， D:\Setup.exe)。 
" 你所設定的變數和資料使用單一間隔粗斜體字來提示 (例如，執行這個 <driver 

name>.exe 檔案，表示你必須提供一個設備名稱)。 
" 按鈕，選單，和鍵盤按鍵使用窄粗體字來提示。 
" 本章需要特別的強調會使用粗斜體字來提示。 
" 下列各項資訊使用四方形方塊提示 ，注意，警示： 

– ! 提示： 包含有用的資訊方便使用者節省發展的時間或使應用程式的執行效
率更好。 

– ! 注意： 包含額外的訊息以方便使用者更容易了解在備註前所敘述的含意。 

– $ 警示： 包含了必須的訊息以避免執行應用程式時發生錯誤而引起不必要的
問題。 
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滑鼠與選擇慣例 
這裡假定你會使用滑鼠，因為大部份個人電腦使用者在Windows 發展版上都是使用滑
鼠來操作。通常，電腦滑鼠都規劃為左鍵是主要的按鍵，右鍵是次要的按鍵。  

此操作手冊依照使用滑鼠的慣例來提示如下： 

" Double-click ：是指快速按滑鼠的左鍵兩次(雙擊滑鼠左鍵)。 
" Right-click：是指按滑鼠的右鍵一次。  
" Click 和 Select：是指先將滑鼠的游標移到要選擇的項目按左鍵使項目在螢幕上被選
定。 

" 選擇(Select)也意謂來使用你的指標設備在電腦螢幕上的亮字(highlight)或選項去
選擇。通常用觸控螢幕選擇一個物件是同等於滑鼠之選擇，因此你可使用手指接觸

(選擇)螢幕上物件或選項。 
" 你也可以使用鍵盤上的按鍵來選擇物件/選項。例如，你使用Tab 鍵來移動選項之

間，按 Enter 鍵來開啟選單，和配合使用 Ctrl 或 Alt 鍵組合鍵 (例如， Ctrl+S) 選擇
到選單上英文字母有下標線的選項 (Save)。 

" Drag：是指選定物件後按著滑鼠左鍵然後拖曳到目標位置。 

視窗慣例 
此操作手冊依照視窗慣例如下： 

" Dialog boxes (或 dialogs) 是一個傳達資訊的對話視窗。 

" Text boxes (或 fields) 會提供一個視窗的空間在當中您可以打入文字。  

" Radio buttons 在按鈕的中央有個黑點 ( )則表示項目被選定當您再按一次則黑點可
消失。 

" Check boxes 用來致能或取消一個選項命令，當按下滑鼠左鍵會有個 ( ) 符號出現
在盒中。 
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" Buttons 是具有圖示的按鈕，當按下時會有被按下的效果。 
" Lists 會列出一排下拉式的視窗列出可供選擇的選單。  

" Combo boxes 為下拉式選單，按下向下的箭頭即會列出所有選項。 

 

Using a Combo Box 

" Interface 或 Development Environment 是指整個 InduSoft Web Studio 視窗。  
" Dockable windows 你能用邊緣拖拉到界面的邊緣而且合併的視窗。  
" Toolbars 為視窗的入口僅包含按鈕及文字盒。  

!  注意：  
本指導手冊所描述對話盒與程序對 Windows 2000是有效的。一些術語可能改變
依照那操作你正在使用的系統 （類型，語言，和版本）。 
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相關參考手冊 
你可能想要瞭解為關於 InduSoft Web Studio 所的附加下列各項手冊： 

" InduSoft Web Studio Users Guide and Technical Reference Manual: 提供
InduSoft Web Studio最基本的操作程序，使用者可依照手冊的步驟建立一個很
簡單的應用程式並可借由此操作程序加速對此軟體的熟悉度。  

" InduSoft Web Studio Training Manual: 詳細指導您利用產品特性建立一個較複
雜的應用程序，您可將此手冊當成自我教育訓練的教材。 

" Drivers User Guides: 詳細描述各個InduSoft Web Studio所支援的驅動程式定
義方式以及欄位的規劃。 

 
! 注意：  
產品操作手冊擺放在 InduSoft Web Studio 光碟片 Documentation 目錄中。若
您已安裝完 IWS 在DRV的目錄下您也可發現Drivers User Guides。您也可以在
發展的環境下利用Help 選項獲得更多的技術資料。 
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第 3章. 軟體安裝 

這章節介紹InduSoft Web Studio and CEView 軟體安裝，開始使用，解除軟體安裝。
指示如下： 

" Installing InduSoft Web Studio：說明如何安裝 InduSoft Web Studio 到你的電腦上。 
" Starting InduSoft Web Studio：說明如何執行 InduSoft Web Studio。 
" Installing CEView Software：說明如何安裝 CEView 在你的電腦上。 
" Uninstalling InduSoft Web Studio: 說明如何解除 InduSoft Web Studio 和 CEView
的軟體安裝。 

安裝 InduSoft Web Studio  
InduSoft Web Studio (IWS) 發展版的應用程式，它執行在Microsoft Windows 
NT/2000/XP 作業系統上。 

你可安裝 IWS 從 InduSoft Web Studio 安裝 CD-ROM片上或從 InduSoft網站上下
載安裝的檔案(http://www.InduSoft.com)。 為了 Windows CE 應用程式，你可以使用 
IWS 下載  CEView (執行版軟體) 到 Windows CE HMI 上，使用串列埠或TCP/IP 連
線。 

IWS 安裝程式為自動的建立所需目錄，複製檔案到你的硬碟，而且會在你電腦的桌面上
建立捷徑圖示。 

! 注意： 
• 在安裝InduSoft Web Studio 軟體時，你必須使用 Administrator 權限進入到 

Windows NT/2000/XP 工作站上。  
• 你必需解除 InduSoft Web Studio 先前版本軟體安裝或者安裝新版本到不同
的目錄上。也就是說，在同一部電腦上不同目錄下是不能同時安裝相同版的

IWS。 
 

http://www.indusoft.com/
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安裝IWS 從CD-ROM依下列各項程序： 

1. 開啟你要發展的電腦電源 (Windows NT, 2000, 或 XP) 而且確定無其他的程式在
執行。  

2. 放入安裝CD-ROM片到CD-ROM光碟機裡。 

! 注意：  
CD光碟放入光碟機中時，CD瀏覽視窗會自動顯示。如果沒有，你可從 
D:\Installation 目錄中 (當 CD-ROM 機為D磁碟機)，去執行 
Setup.exe 檔案，開始安裝程式。 

 

3. 在Installation 欄位雙擊滑鼠左鍵，然後在InduSoft Web Studio 圖示起動這個 
InstallShield® 精靈。  

4. 跟隨 InstallShield 精靈 指示著手進行安裝。 

5. 當指示重新起動 Windows時， 點選這個選項 Yes, I want to restart my computer now ，
然後再點選 OK。  

! 注意：  
表示產品授權－ 使用者指引手冊 (你可從 IWS CD-ROM光碟片得到) CEView， 
對於有關授權 IWS 及[或] CEView 的指令。 
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啟動 InduSoft Web Studio 
要執行 IWS, 在Winodws 桌面上InduSoft Web Studio 圖示快速點滑鼠左鍵兩次或從

Windows的 開始 → 程式集 → InduSoft Web Studio  → InduSoft Web Studio 之選項。 

 

Starting IWS 

" 提示： 
你可以用任何像素來發展IWS。但是，強烈建議您使用800x600 (或更高)的解析
度及超過256色的開發環境來設計，應用程式的解析度(螢幕大小)是依據操作平台
的設定。 

 

安裝CEView  
當你在Windows NT/2000/XP 作業系統安裝完 InduSoft Web Studio ， IWS 會存
在 CEView 執行版檔案在下面的目錄裡： 

<InduSoft Web Studio Folder>\Redist\<WinCE version>\<Processor Type>\ 

在那裡： 

" <InduSoft Web Studio Folder> 為在安裝時所選擇的安裝目錄 (預設安裝目
錄為 C:\Program Files\InduSoft Web Studio )。 

" <Processor Type> 是處理器的平台。 InduSoft 提供 CEView 執行版給WinCE
作業系統所支援的處理器平台 (Arm, Mips, MipsFP, Pocket-Arm, Pocket-Mips, 
Pocket-SH3, PPC, SH3, SH4, Thumb, 和 x86)。 

" <WinCE version> 是 Windows CE 版本 (例如, WinCE300, WinCE400, 等
等)。 
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CEView安裝，依下列步驟： 

1. 開啟Windows CE 裝置電源，並且會自動啟動遠端代理程式的對話框。如果沒有，
可複製 CESERVER.EXE 檔案從你所安裝IWS電腦中以下的目錄 \<InduSoft Web 
Studio  Folder>\Redist\<WinCE version>\<Processor Type>\BIN 。  

2. 然後貼到 WinCE 裝置中的 \<non-volatile>  目錄，並執行它。  

! 注意：  
有不同的方法複製檔案至 WinCE 裝置 (例如，你可以在 Windows 
NT/2000/XP 電腦中分享資料夾給 WinCE 裝置或使用行動碟
ActiveSync)。假如你要複製檔案至WinCE中需要援助，請連絡 InduSoft 技
術上的支援或硬體製造業者。 

 
之後執行 CESERVER.EXE 檔案，在WinCE裝置上會啟動此 遠端代理對話視窗
(Remote Agent) 。 

3. 在遠端代理程式對話框按 Setup 按鈕，WinCE 裝置將經由(串列埠 or TCP/IP) 連
線到 Windows NT/2000/XP 電腦上。 

! 注意：  
如果要得以較好效能， InduSoft 建議在WinCE 裝置與你的 
WinNT/2000/XP 電腦之間使用TCP/IP 連線去下載和上傳檔案。 

 

4. 在Windows NT/2000/XP 電腦上啟動IWS。 

5. 從主選單列裡選擇， Project → Execution Environment 。  
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6. 當 執行環境  框顯示如下時 (參閱下面圖形)，請選擇連線方式 (Network IP 或 Serial 
Port) 並且指定它的設定值(例如， COM 埠 或 IP 位址)。 

 

執行環境對話方塊 

7. 按下 Connect 按鈕會由 IWS 連線到 WinCE 裝置。 

8. 從執行環境(Execution Environment) 對話視窗(Target 頁面)按下Install System 
Files 按鈕去下載這個 CEView 檔案到 WinCE 裝置上。 
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解除InduSoft Web Studio安裝 
如果要從你的電腦中移除 IWS 軟體，請依下列步驟： 

$ 警示：  
解除安裝 IWS 之前, 確定你已經備份 …\ InduSoft Web 
Studio\Projects\ 目錄中的資料。也要確定有 IWS 安裝光碟片或磁碟
片，以便下一次的安裝。  
當你解除 IWS 軟體時，你也會失去產品 softkey 認證。 

 

1. 從工作列視窗，選擇 開始 → 設定 → 控制台 開啟控制台。 

 
Opening the Control Panel 

2. 在控制台裡找到 新增/移除程式 圖示 ( ) 並雙擊滑鼠左鍵執行。 

3. 當 新增/移除 程式 屬性 對話視窗顯示時 (如圖)，請選擇清單中 InduSoft Web Studio 
並按下           變更/移除… 按鈕。 

4. 當顯示 Confirm File Deletion 對話框時，按下 是(Yes) 按鈕。  
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你的電腦會顯示出解除安裝精靈和移除程式的對話框。 

 

Removing the Program 

5. 當成功解除的訊息顯示時，按下 確定(OK) 按鈕，確認在 新增/移除 程式屬性 對話
框清單中已找不到IWS。  

6. 按下 取消 按鈕或 關閉 按鈕 ( )，關閉這個 新增/移除 程式屬性 對話框和關閉控
制台。 

7. 開啟檔案總管，瀏覽 InduSoft Web Studio 目錄。 

8. 確認 IWS 檔案及目錄已被刪除。 (你可能要手動來刪除剩餘下來的檔案。) 

! 注意：  
這個解除安裝工具是不會刪除你在 …\ InduSoft Web 
Studio\Projects\ 目錄下所建立或修改的檔案。 
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第 4章. IWS 開發環境 

這個章節描述 InduSoft Web Studio 開發環境 (界面)。 本章單元如下： 

" 概觀(Overview)： 提供組成 IWS 發展環境的工具和界面的簡單描述。 
" 標題列(Title Bar)： 描述標題列。 
" 狀態列(Status Bar)： 描述狀態列。 
" 主選單列(Menu Bar)： 描述你能從主選單列中，去存取不同選單的選項。 
" 工具列(Toolbars)： 描述 IWS 工具列。 
" 工作區(Workspace)： 描述 IWS 工作區。 

概觀(Overview) 
InduSoft Web Studio 使用像Windows一樣的標準的工具和界面使產品方便使用者。
IWS 也提供整合及獨特的發展環境 (如圖)，方便你選擇工具和存取資訊。 

 

InduSoft Web Studio 發展環境 
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發展環境所組成的基本單元： 

" 標題列(Title Bar)：可顯示在視窗中的應用程式或工作區 
" 狀態列(Status Bar)：此欄位於視窗的最底部，用來快速的顯示目前狀態或訊息 
" 主選單列(Menu Bar)：包含了應用程式選單的名稱及控制項可以方便使用者用滑鼠或
鍵盤選擇所要執行的功能 

" 輔助工具列(Auxiliary Toolbars)：在發展環境中提供主要功能的捷徑 
" 繪圖工具列(Displays Building Toolbars)：提供物件屬設計及工具方便使用者可以新增
及編修物件或是作動態顯示 

" 工作區(Workspace)：提供樹狀的操作方式讓使用者可以直接進入物件工作表單進行
設定工作  

" 資料庫偵測視窗(Database Spy Window)：提供除錯工具讓使用者可以監視某特定點或
強迫輸出值甚至直接執行函數 

" 輸出視窗(Output Window)：顯示除錯時的訊息 
" 顯示/工作表單(Displays/Worksheets)： 提供一個區域在此區域可以繪圖及設計工作

表單  

! 注意：  
先前的畫面是以預設畫面來顯示，您可以依據您的需求自行調整發展環境中各區域

的大小及位置。 

 
你可以在發展環境底下任何一個位置，按下滑鼠的右鍵會出現一個下拉式選單(類似下面
圖示)，與你按哪裡的區域是有關聯。 

 

Sample  IWS Pop-Up Menu 
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使用標題列(Title Bar)  
標題列 (永遠顯示在IWS 視窗的最上頭) 顯示 InduSoft Web Studio 圖示，產品名稱，和目
前被開啟顯示或工作表單之名稱。(如果開許多的顯示/工作表單)。 

 

Typical IWS Title Bar 

標題列包含下列三個按鈕 (從左至右)： 

" 最小化(Minimize) 按鈕 ( )：按此鍵可以將 IWS畫面縮小。 
" 改變大小/最大化(Resize/Maximize) 按鈕 ( / )：此兩個按鍵是互相變換的，  

– 改變大小(Resize) 可隨意變更 IWS 視窗  
– 最大化(Maximize) IWS 視窗最大化充滿你電腦的螢幕畫面 

" 離開(Exit) (或 關閉(Close)) 按鈕 ( )：按此鍵可使 InduSoft Web Studio自動儲存
資料庫後關閉，若您有修改過的畫面或工作表單則會出現提示畫面提醒您先儲存。

此按鍵與主選單列的檔案中的離開類似。  

! 注意：  
關閉發展環境是沒有關閉 IWS 執行中的工作。 
你要關閉執行中的工作，可按 停止(Stop) 圖示  在 執行 工具列 或在主選單
列上選擇  Project → Stop Application 選項。 

 

狀態列(Status Bar)的識別 
狀態列 (永遠顯示在 IWS 視窗的最下方) 包含顯示目前按下了那個工具列按鈕及提供正
在運作中的畫面資訊(在任何時候)。  

 

Sample Status Bar 

顯示欄位如下 (由左至右)： 

" Hint 欄：顯示簡短的敘述所按下的工具鈕或是目前滑鼠所選定物件。 

" Caps Lock 欄：顯示鍵盤的大寫鍵(Caps Lock)是否已鎖定。 
" Num Lock 欄：顯示鍵盤的數字鍵(Num Lock)是否已鎖定。 
" Scroll Lock 欄：顯示鍵盤的螢幕鎖定鍵(Scroll Lock)是否已被鎖定。 
" ID 欄：顯示畫面上所選定物件的辨識碼(ID)。  
" Screen Coordinate 欄：顯示目前運作中畫面上的游標座標，X是橫座標 Y是縱座標。  
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" Object Size 欄：顯示所選物件的大小W是寬度 H是高度。 
No DRAG 欄：顯示運作中的畫面的拖曳功能是否是致能(No DRAG)。 

"
提示：  
你可以按 Ctrl+D 來控制拖曳功能是否是致能。你能在任何的物體上按而且使用
鍵盤上的方向鍵來移動螢幕上的物體，像素的像素。 

 

使用主選單列(Menu Bar)  
主選單列包含了以下的選單： 

 

Main Menu Bar 

" File(檔案)： 此選項包含建立，開啟，關閉，儲存和列印應用程式的專案，也允許你
來關閉 IWS的發展環境。 

" Edit(編輯)： 此選項包含你能在顯示和工作表單上做剪下，貼上，格式和設定安全層
次。你也可以在顯示/工作表單中去復原編輯，刪除，搜尋和替換這個物件。 
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" View(檢視)： 此選項包含用工具工作的使你能夠處理的選項和工具列是看得見的在
發展環境中。主選單列也提供捷徑給對話框當你時常開啟大部分入盒中，使你能夠

訂制你的工具列，回復初始值，開啟圖庫，縮大/縮小，和設定顯示屬性。 
" Insert(插入)： 此選項包含你能建立和設定應用程式的 tags， tag 類別， 文件， 驅

動程式， 使用者， 安全設定， 顯示和 ActiveX 物件。 
" Project(專案)： 此選項包含去執行本地端或遠端的應用程式，和提供對應用程式一
般的設定。  

" Tools(工具)： 此選項提供連接到輔助工作列。 
" Window(視窗)： 此選項包含你可以管理顯示和工作表單。 
" Help(說明)： 此選項包含連接有關 IWS and  InduSoft資訊。 

! 注意：  
• 主選單列是一個船塢。 
• 假如你在主選單列按下滑鼠右鍵，會顯示下拉式選單，你可以回復到預設的主
選單列和工具列。 

• 你也能使用這下拉式選單來藏工具列，視窗和自訂發展環境。 
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使用工具列 (Toolbars) 
IWS 提供數種工具列組成圖示 (捷徑) ，它能讓你在程式中去執行不同功能的動作。這
個部份描寫工具列的功能和預設位置。 

! 注意：  
全部工具列是船塢的顯示物件。你可以在標頭使用滑鼠拖曳方式，將工具列搬移至

新的位置。 
有關工具列更深入探討請參閱， InduSoft Web Studio Users Guide and 
Technical Reference Manual。 

以下是廣泛型工具列，它預設位置在主選單區的最前方： 

" Standard 工具列：允許你執行一般的動作，例如檔案管理和印表功能。  

 

Standard Toolbar 

" Tag Properties 工具列：允許你產生，找出，而且存取不同的標籤和他們的屬性。  

 

Tag Properties Toolbar 

" Execution Control 工具列： 允許你從本端或遠端去執行和管理應用程式。  

 

Execution Control Toolbar 
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" Web 工具列： 允許你開啟 HTML 檔案。 

 
Web Toolbar 

" Align and Distribute 工具列： 允許你編輯顯示之物件。 

 

Align and Distribute Toolbar 

下列各項工具列包含編輯螢幕的工具。 這些工具列初設的位置在你編輯設計顯示視窗的
右手邊： 

" Mode 工具列： 允許你編輯畫面。 

 

Mode Toolbar 

" Bitmap 工具列： 允許你存取點陣圖螢幕編輯工具。 (這個工具列只有在背景圖層時，
才能被使用。你可以在顯示屬性的對話框裡設定背景圖層致能。)   

 

Bitmap Toolbar 

! 注意： 
這個 Bitmap 工具列預設為隱藏的。 

 
" Static Objects 工具列：允許你可以建立多邊形，矩形，線段和其他物件。 

 

Static Objects Toolbar 
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" Dynamic Properties 工具列：您可以將單一物件或一物件群組加上動態化，您可以藉
此設定使物件在執行期可根據資料點(Tag)的數值作動態變化。部份動態化功能也可
設定成可以執行命令或輸入數值(設定點)至資料點(Tag)。 

 

Dynamic Properties Toolbar 

" Active Objects 工具列： 允許你建立動態物件。動態的物件一般都比靜態物件有更多
的參數設定以提供動態活動。 

 

Active Objects Toolbar 

使用 Workspace 

這 IWS Workspace 視窗一個容易使用的介面，它能幫助你快速的尋找或建立任何應用
程式的元件(資料點，畫面，工作表單等等)。應用程式元件很有系統的用自己的圖示和
你的描述以樹狀結構來呈顯。你可以將Workspace 視窗來移動，改變大小，或隱藏起
來。 

 

The IWS Workspace  
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這 Workspace 視窗被分成四個頁面，依下列各項： 

" Database 頁面：提供在應用程式和安全系統元件上使用的全部的資料點。 這個頁面
包含下列各項檔案夾： 

– Application Tags(宣告資料點) 
– Classes(類別) 
– Shared Database(分享資料庫) 
– Internal Tags(內定資料點) 
– Security(安全) 

" Graphics 頁面： 提供在應用程式上使用全部畫面及符號。這個頁面包含下列各項檔
案夾和圖示： 

– Screens(畫面) 
– Group Screen(群組畫面) 
– Web Pages(網頁) 
– Library(圖形庫) 
– Symbols(符號) 

" Tasks 頁面：提供在應用程式上使用的全部工作表單。 這個頁面包含下列各項檔案
夾： 

– Alarms(警報) 
– Trend(趨勢) 
– Recipes(配方) 
– Report(報表) 
– ODBC(開放式資料庫連接) 
– Math(運算) 
– Scheduler(計劃程序) 

" Comm 頁面：提供與其它的設備或軟體來建立有效的使用通訊協定之工作表單， 這
個頁面包含下列各項檔案夾： 

– Drivers 
– OPC 
– TCP/IP 
– DDE 

! 注意： 
你可以在全部檔案夾和元件上按下滑鼠右鍵，來開啟與該檔案夾或元件有關的選

單。 
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第 5章. Tags(資料點)的運用  

本章節提供來建立和編輯tags(資料點)所需資訊，包含如下： 

" 資料點(Tags)命名與資料點欄位: 說明資料點(tags)和欄位必要的規則。 
" 資料點(Tag)檔案夾之運用: 說明 tag檔案夾的目的。 
" 資料點(Tag)的資料型態: 描述不同型態的資料點(tag)。 
" 資料點(Tags)的陣列: 說明如何使用資料點(tags)陣列。 
" 間接資料點(Tags)的使用: 說明如何使用間接資料點(tags)。 

資料點(Tags)命名與資料點欄位  
這個部分提供資料點(tags)命名的指導方針(資料庫位置上的識別字)和資料點欄位(tag 
fields) (在資料庫上每一個資料點(tag)內定的一組參數)。應用程式在執行期間使用的資
料點(tag)欄位。 

資料點(Tag)規則 
當你在命名資料點(tag)時，必須依下列規則： 
" 可以使用英文字母，數字和底線 ( _ )字元。 
" 不可使用下列字元：  

` ~ ! @ # $ % ^ & * ( ) - = \ + \ [ ] { } < > ? 

" 資料點名稱第一個字元必須為英文字母。 
" 資料點名稱最大長度為 32 個字元。 

類別名稱最大長度為 16 個字元。  
" 資料點名稱必須唯一：兩個不同的資料點不可給相同的名稱， 除非你建立資料點

(tag)陣列並指定唯一索引(請參閱第38頁)。 
" 資料點(Tag)名稱不區分英文字母大小寫 (為了增加可讀性，我們可以使用大寫和小
寫字母。例如，使用 TankLevel 代替 tanklevel)。 

" 資料點(Tag)名稱不可和內定的資料點名稱或運算函數(math functions)同名。 
一些有效的資料點名稱(tag)如下： 
– Temperature 
– pressure1 
– count 
– x 
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資料點(Tag)欄位語法 

你能使用 資料點屬性(Tag Properties) 對話框 (按下 資料點屬性(Tag Properties) 圖示  
位置在 資料點屬性(Tag Properties) 工具列) 來顯示資料點(tag)欄位參數。你必須依下
列的語法來使用資料點(tag)欄位：  

<TagName>-><TagField> (例如， second->Max)  

在執行期間你能用下列資料點欄位(tag  fields)： 
 

資料點(Tag)型別對應的欄位 資料點(Tag)
欄位名稱 

每個欄位對應值的描述 

邏輯 整數 實數 字串 

R=唯讀 
RW=讀+寫 

Description 定義資料點在Tags資料庫上的描
述 

% % % % RW 

Max 在執行期間資料點能夠寫入的最

大值 
& % % & RW 

Min 在執行期間資料點能夠寫入的最

小值 
& % % & RW 

Quality 資料點品質 (192=好的; 0=壞的).  
每一次從通訊工作(Driver or OPC)
或運算式更新資料點值的結果. 
無效運算 (例如除以 0) 或通訊錯
誤的資料點, 設定品質為壞的. 

% % % % R 

Size 陣列大小，假如這個資料點不是

陣列它的回傳值是 0. 
% % % % R 

TimeStamp 當資料點的值改變時記錄時間和

日期. 
% % % % R 

Unit 簡單的描述 (9字元) 一個工程單
位 (例如 Kg) 為資料點的值 

% % % % RW 

B0 … B31 任何值 (0 or 1) 為 32 bits (b0, b1, 
b2, … b31) 屬於整數資料點. (B0: 
LSB B31: MSB). 

& % & & RW 
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AlrStatus 狀態 （整數值）任何的現在與一
個資料點有關的活躍警報.  
每一個位元整數值所表示的特定

狀態: 
• Bit 0 (LSB): HiHi Alarm active 
• Bit 1: Hi Alarm active 
• Bit 2: Lo Alarm active 
• Bit 3: LoLo Alarm active 
• Bit 4: Rate Alarm active 
• Bit 5: Deviation+ Alarm active 
• Bit 6: Deviation- Alarm active 
例如:  
• If Tag->AlrStatus = 2, “Hi” alarm is 

active.  
• If Tag->AlrStatus = 3, “HiHi” and 

“Hi” alarms are active 
simultaneously. 

• If Tag->AlrStatus = 0, there are no 
active alarms  

布林資料點只有 1 (bit 1), 4 (bit 2) 
或 16 (bit 4) 值是被回傳. 

% % % & R 

Ack 指定任何警報關連到需求確認資

料點(tag). 這個欄位只有兩可能的
值: 
• 0: 警報不做需求確認 
• 1: 至少要有一個警報需求確認 

% % % & RW 

AlrDisable 指定任何警報關連資料點將變成 
active.這個欄位只有兩可能的值: 
• 0: 致能警報且當警報條件發生
時,警報會變成active. 

• 1: 禁能警報,所以每當警報條
件發生時,警報將不會改變成 
active. 

% % % & RW 

HiHi • If 0, HiHi alarm is inactive.  
• If 1, HiHi alarm is active. 

& % % & R 
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Hi • If 0, Hi alarm is inactive.  
• If 1, Hi alarm is active. 

% % % & R 

Lo • If 0, Lo alarm is inactive.  
• If 1, the Lo alarm is active. 

% % % & R 

LoLo • If 0, LoLo alarm is inactive.  
• If 1, the LoLo alarm is active. 

& % % & R 

Rate • If 0, Rate alarm is inactive.  
• If 1, the Rate alarm is active. 

% % % & R 

Devp • If 0, Dev+ alarm is inactive.  
• If 1, the Dev+ alarm is active. 

& % % & R 

Devm • If 0, Dev- alarm is inactive.  
• If 1, Dev- alarm is active. 

& % % & R 

HiHiLimit HiHi 警報界限值. & % % & RW 

HiLimit Hi 警報界限值. & % % & RW 

LoLimit Lo 警報界限值. & % % & RW 

LoLoLimit LoLo 警報界限值. & % % & RW 

RateLimit Rate 警報界限值. & % % & RW 

DevSetpoint 設定誤差(Deviation)警報點值. & % % & RW 

DevpLimit 誤差(Deviation)+ 警報界限值. & % % & RW 

DevmLimit 誤差(Deviation)- 警報界限值. & % % & RW 

 
 

! 注意： 
假定應用程式嘗試寫入值超出 Min 和 Max 欄位值界限時，資料點之資料庫將不會接受此一
新值並且會寫一個警告訊息到 LogWin. 假如你指定 Min 和 Max 屬性值為 0 (零)時，任何資
料點型別的值會寫入到資料點。 

 

$ 警示：  
你不可以使用資料點(tag)欄位 (例如位元(Bit)欄位) 去定義在警報或趨勢圖的工作表單。 
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資料點(Tag)檔案夾運用  
你可以使用資料點(tags)來當作與設備的通訊點，計算結果，警報點等等。在 IWS，全
部的資料點(tags)對應到 資料庫Database 頁面上的檔案夾也是它們起源 (application, 
internal, 或 shared)。 IWS 也提供混合型資料點，名稱叫做 classes(類別)。 

下列各項為不同 IWS 資料點(tag)檔案夾的描述： 

" Application Tags: 使用者定義的資料點為了顯示而製作的標籤，它是對指定設備執行讀
取與寫入的媒介，也是用來執行控制或數學運算的工具。 

" Internal Tags: IWS預設的資料點(Tags)。 這些點具有特定的功能(如：時間，日期，告
知收到警報，用戶登入的存儲，以此類推)，且是不能編輯或者刪除，不過，能夠從任
何IWS task來存取他們的值。 

" Shared Tags: 資料點(Tags)被建立在PC-based 控制軟體並輸入到IWS環境中。你不
能在IWS環境中去編輯分享資料點(tags)，但你可以修改這些資料點使用 PC-based 
控制軟體並重新輸入修改資料點去更新 IWS 資料庫。因此，你能定義分享資料點在
任何IWS指派給任何其他資料點。 

" Classes: 允許在應用程式資料庫中的高階封裝結構。當你建立一個類別型態資料點，
這個資料點已含蓋全部值而非單一值。你建立的類別由元素組成叫做成員。任何類別

成員的最大數量是依據產品規格。 
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資料點(Tag)的資料型態 
一個資料點可能是下列型態之一： 

 Boolean: 邏輯或有效數值 (0 or 1)。 

 Integer:整數 (正，負，或零)，相等於 C語言長整數 (4 bytes). 例如： 0, 5, 
-200。 

 Real: 實數 (浮點數) 內部儲存類似 double word，相等於 C語言 double 
(8 bytes，例如： 2.12, -10.5)。 

 String: 字元字串可含 256 字元，它可由英文字母，數字或特殊字元所組
成。例如：Recipe product X123, 01/01/90, *** On ***。 

 Class: 使用者定義的混合型資料點。 
 

前面的圖示 (和他們分別的資料點型態) 位置是在資料庫頁面(Database tab)的檔案夾
上。 

資料點(Tags)陣列 
IWS 資料點(tags) 可由單一值或陣列值所構成。 

資料點陣列(array tag) 是由一組相同名稱的資料點組成，但它們使用唯一的索引來區分
每個資料點(tags)間的差別 (一維的矩陣)。陣列的最大值要依產品規格。 

你可以依下列語法來存取陣列資料點： 

<ArrayTagName>[ArrayIndex]  

例如：tank[1], tank[2], tank[3], 和 tank[500]. 

$ 警示： 
你可以在任何資料格上規畫陣列資料點最大索引在Size欄位，當規畫size n 表示這
個資料點陣列位置從 0 to n.  
例如，假如 TagA 大小為 3， 這資料點的位置為：  
TagA[0], TagA[1], TagA[2], and TagA[3].  
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在許多情況，使用資料點陣列可精簡定義工作。例如，假如你想要顯示監測每一個水槽，

你可以使用資料點陣列來定義單一顯示所含資料點去連結任一個水槽(使用這 tk 資料點
(tag) 當作水槽的索引的號碼)。例如， 

pressure[tk], temperature[tk], and temperature[tk +1]. 

陣列的索引可以是資料點(tag)，數字值，或數學運算元+之運算式。 

! 注意： 
當陣列使用到數學運算子 + 時，你必須依照下列的語法： 

<ArrayTagName>[<NumValue1> + <NumValue2>] 

在 <NumValue1> 與 <NumValue2> 能用整數資料點(tags)或常數數值例如： 
temperature[tk+2], temperature[tk+6], 或  
temperature[TagA+ TagB] 

 
 

在IWS工作中使用資料點(tags)陣列可節省發展應用程式的時間。例如，假設你需要的
資料點(tag)為四個槽的溫度傳統的做法是： 

" temperature1 high temperature on tank  1 
" temperature2 high temperature on tank  2 
" temperature3 high temperature on tank  3 
" temperature4 high temperature on tank  4 

使用資料點陣列簡化這件工作，如下： 

temperature[j] high temperature on tank {j} 

! 注意： 
當你建立 n-position 資料點陣列，這系統建立 n+1 位置(從0 到 n)。例如： 
tag_example[15] 用 Array Size=4 會有5個元素 (start position=0, 
end position=4).  
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間接資料點(Tags)的使用 
IWS 支援在資料庫中間接存取資料點(tags)。舉例來說，考慮字串型態資料點(tags) X。 
這個資料點(tags)能在資料庫中持有任何其他的資料點(tags)名稱。這間接資料點(tag)
的語法： 

@<IndirectTagName>   

例如，假定 X  資料點(tag)持有 TEMP 字串。讀/寫 @X 提供去存取 TEMP 資料點(tag)
的值。 

! 注意：  
任何字串型態資料點被建立時已具有間接資料點(指標)。 
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第 6章. 建立 IWS 應用程式 

本章說明 (使用按部就班的個別指導) 如何建立一個IWS 應用程式和如何安裝與定義  
I/O 驅動程式。 

" 建立新的應用程式: 說明如何去建立 IWS 應用程式。 
" 詳細說明專案的設定: 說明如何在你的應用程式去定義各種的設定。 
" 建立資料點(Tags): 說明如何產生新的資料點(tags)並且把它們加在 IWS 資料點

(Tags)資料庫。 
" 建立啟動畫面 (main.scr): 說明如何去建立主要的啟動畫面。 
" 建立概要的畫面 (synoptic.scr): 說明如何在你的應用程式去建立概要的畫面。 
" 定義 I/O 通訊驅動程式: E說明如何在你的應用程式去設定 I/O 通訊驅動程式。 

建立新的應用程式 
使用下列步驟來產生新的 IWS 應用程式: 

1. 從InduSoft Web Studio 主選單列選擇 File → New 。  

2. 當 新的 對話框開啟時，按到 Project 頁面。 

 

Select the Project Tab on the New Dialog Box 

3. 輸入你的應用程式名稱到 Application name 文字盒內 (為這個例子, 輸入 
GetStart)。  
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IWS 會自動產生與應用程式相同名稱的目錄並且將你所設計應用程式的檔案放在
此目錄 (留意先前圖表在 Configuration file 文字盒)。 如要放置你的應用程式檔案於
InduSoft Web Studio的 \Projects 次目錄之外， 可按 Browse 並且導航至被偏愛
的目錄位置。 

4. 從目標平台(Target Platform)清單上選擇平台 (為這個例子，請選 CEView 
Standard)，之後按下 OK 按鈕。 

! 注意：  
你選擇 CEView Lite 和 CEView Standard 目標用平台，才能在
WindowsCE 執行應用程式。 

 

5. 當專案精靈(Project Wizard) 對話框顯示，請從 Template 清單擇選 Empty 
Application ，點選 640 X 480 之選鈕表示應用程式的解析度，並且按下 OK按鈕。 

 

Specifying an Empty Application with 640X480 Resolution 

這個新的應用程式之檔名會顯示在 Workspace 視窗。 
(本例子，專案Project檔案的名稱為 GetStart.APP)。 
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詳細說明專案的設定 
你能在專案設定(Project Settings) 對話框上使用頁面來應用某些參數到整個的專案。舉
例來說： 

" 使用 Identification 頁面提供來認別專案應用程式的資訊 (例如專案描述，修正次數，公
司名稱，設計者名稱 , 設備欄位，和一般的附註)。 

" 使用 Options 頁面敍述自動轉換，歷史警報，pc-based 控制，目標系統，通訊驅動， 
OPCs和TCP埠。 

" 使用 Runtime Desktop 頁面去致能/禁能執行時期桌面的參數。 
" 使用 Web 頁面去敍述，資料伺服器 IP 位址，傳送週期 (毫秒), URL 位置，tooltips
和檔案的壓縮，logging，和 IP 安全。 

" 使用 Preferences 頁面去致能/禁能在下載畫面至目標系統時的警告訊息。 

1. 為本例GetStart.APPS新的應用程式請依下列步驟設定： 

2. 當專案設定(Project Settings) 對話框顯示(如下圖)，選擇 Runtime Desktop 頁面
並且輸入 main 到 Startup screen 欄位上。 

 

Specifying the main Screen 

當你要執行應用程式時，IWS 將會自動開啟 main 畫面 (或你指定任何畫面) 。 

建立資料點(Tags) 
資料點(tag) 是任何變數持有的值。你可以在發展應用程式的任何時候去建立資料點
(tags)，應用程式全部的資料點(tags)被建立儲存在工作區(Workspace)的資料庫
(Database)頁面上的應用程式資料點(Application Tags)的檔案夾裡(如下圖)。 
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Application Tags Folder 

使用下列步驟來建立新的資料點(tag)： 

1. 在 Datasheet View 圖示雙擊滑鼠左鍵開啟 應用程式資料點(Application Tags) 工作
表單。 

2. 當建立新的資料點(tag)，你必須設定以下的主要屬性： 

" Name: 指定一個唯一的資料點(tag)名稱。(所有的資料點(tags)必須名稱唯一) 
" Array Size: 指定陣列資料點內部元素的數量。(單一的資料點(ags)你必須設定為

0) 
" Type: 指定資料型態要被資料點(tag)所支援(邏輯Boolean，整數Integer，實數

Real，字串String，或類別Class)。 
" Description (可選擇): 輸入資料點(tag)的描述只為了當文件說明目的。 
" Web Data: 敘述在伺服器和網路用戶端位置之間的資料點(tag)溝通行為。 

' 指定 Local 假如你要這個資料點(tag)有獨立的值在伺服器和網路用戶端位
置之間。 

' 指定 Server 假如你要分享資料點(tag)有相同的值在服器和網路用戶端位
置之間。 
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3. 為本例子的應用程式依下列的參數去建立資料點(tag)： 

 

注意 Array Size = 3 為每個資料點被指定，每個陣列元素與三個水槽之一有關： 

Level[1] ( Level of the Tank #1 
Level[2] ( Level of the Tank #2 
Level[3] ( Level of the Tank #3 

在這個例子裡不使用這個 0 元素(Level[0]) (雖然它是一個有效的資料點(tag))。 

! 注意： 
你將會產生附加的資料點(tags)當你配置應用程式。  

 

建立啟動畫面 (main.scr) 
為你的應用程式去建立新的畫面： 

1. 在 工作區(Workspace) 視窗，選擇 Graphics 頁面在Screens 檔案夾上按滑鼠右
鍵。 

 

Right-Click the Screens Folder 

應用程式所建的全部畫面儲存在IWS的 Screens 檔案夾裡。 
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2. 當彈出式選單顯示時，選擇 Insert 選項去開啟畫面屬性(Screen Attributes) 對話框。 

 

Screen Attributes Dialog Box 

3. 使用這個對話框來設定例如大小和類型的畫面屬性。以這個例子，直接按下 OK 按
鈕來接受內定設定。 

4. 在新的畫面上按下滑鼠右鍵並且從彈出式選單選擇 Background color 選項。選擇灰 
色並且按下OK 按鈕把顏色應用到這個畫面。 

 

Open the Background Color Dialog and Select a Gray Color 

5. 建立 文字(Text) 物件，在 文字(Text) 圖示 上點選。  

6. 點在畫面上並且輸入下列文字： 

Welcome to the InduSoft Sample Application.  
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7. 在文字(Text)物件上雙擊滑鼠左鍵去開啟物件屬性(Object Properties) 對話框。 

Click here to open the 
Object Properties dialog.

Use this dialog to
set  properties for

the text object.  

Click on the Text Object 
 

! 注意：  
在任何物件上雙擊滑鼠左鍵開啟的物件屬性(Object Properties) 對話框會包
含與那個物件相關的參數。 對話框會依據從複合方塊(combo box)所選擇項
目改變其內容，這個複合方塊(combo box)的清單根據你應用那些屬性到此物
件。 

這個物件屬性(Object Properties) 對話框含有一個按鈕可以控制這個對話框
永遠開啟狀態。當你每一次按下這個按鈕時會改變它的狀態(和功能) ， 如下： 
• 按圖示為  表示當你滑鼠點選擇至螢幕其它地方這個對話框即會關閉除
非你點選到其他的物件。 

• 按圖示為  無論你如何點選這個對話框會一直保持開啟狀態。  
當你按  時去關閉物件屬性(Object Properties) 對話框。 

 
 

8. ˇ(致能) 這個 Transparent 檢查盒(check box)設定文字物件的背景顏色是透明的。  

9. 按 Fonts 按鈕去指定字型設定(例如: Type=Arial, Size=20, Color=Blue)。 

10. 按 Button 圖示  去建立按鈕物件。 

11. 在畫面上按下，壓著滑鼠按鈕並且拖曳這個指標來定義按鈕物件的大小。  
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12. 在新的按鈕物件上雙擊滑鼠左鍵開啟物件屬性(Object Properties) 對話框並且輸入
下列的文字到 Caption 欄位： 

Click here to open the synoptic screen.  

 

Adding a Caption to the Button 

13. 點選按鈕物件並且點擊 Command 圖示 應用這個動態到此物件。 

14. 在按鈕物件上雙擊滑鼠左鍵重新開啟這個物件屬性(Object Properties) 對話框。 

15. 輸入 Open(“synoptic”) 到 Expression 欄位應用這個動態指令到此按鈕(如圖)：  

 

Applying the Open(“synoptic”) Command Dynamic 

當在執行時期使用者按下此按鈕，IWS 將會開啟這個synoptic 畫面。 

16. 最後，從主選單列選擇 File → Save 並且存這個畫面為 main.scr。 

17. 在畫面上按下滑鼠右鍵並且從彈出的選單選擇Close選項，去關閉 main 畫面。 

建立概要的畫面 (synoptic.scr) 
建立新的 synoptic 畫面，使用下列步驟： 
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1. 選擇 Graphics 頁面在 Screens 檔案夾上按下滑鼠右鍵。 
2. 從彈出的選單選擇 Insert 選項之後畫面屬性(Screen Attributes) 對話框會自動顯示

出來。 
3. 在對話框上使用參數設定畫面的主要屬性 (大小，類型和之前相同)。以本例子，直

接按 OK 按鈕來接受內定的設定值並且在畫面編輯視窗開啟這個畫面。 
4. 在畫面上按滑鼠右鍵來選擇 Background color。  

 

Selecting a Background Color 

5. 當這 Background Fill 對話框顯示時，請選擇 灰(gray)色並且按下OK按鈕應用這個
顏色到此畫面。 

建立畫面的標題 
用文字物件去建立畫面標題，使用下列步驟： 

1. 點選 Text 圖示  ，在畫面上點擊並且輸入: Synoptic Screen。 

2. 在文字物件上雙擊滑鼠左鍵去開啟 物件屬性(Object Properties) 對話框。 

3. 當對話框顯示時，檢查這個 transparent 檢查盒並且設定此文字物件的背景顏色為
透明的。 

4. 點擊 Fonts 按鈕並且修改字型設定(舉例來說: Type=Arial, Size=20, Color=Blue)。 

5. 移動這個物件到畫面的上方。 

 

Finished Screen Title 
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建立 日期 / 時間 文字物件 

! 注意： 
日期和時間是內定的資料點(internal tags)，持有從本地端電腦來的現在日期和現
在的時間(分別地)。日期和時間資料點(tags)可用在任何的應用程式。 

 
建立日期和時間的文字物件，使用下列步驟： 

1. 在 Text 圖示 點按，之後在畫面上點擊並且輸入：  
Date: ##########。  

2. 在文字物件上雙擊滑鼠左鍵開啟物件屬性(Object Properties) 對話框。 

3. 當對話框開啟時，抅選 Transparent 檢查盒(check box)並且設定文字物件的背景顏
色為透明的。 

 

4. 點選此文件物件並且在 Text I/O 圖示  按下應用這個動態到此物件上。 

5. 在此文字物件上雙擊滑鼠左鍵再一次開啟物件屬性(Object Properties) 對話框。 

6. 輸入 Date 到 Tag/Expression 欄位(如上圖所示) 去給定 Text I/O 動態。當在執
行時期，IWS 會根據你在文字物件給定的日期資料點(Date tag)值來取代 
########## 字元。 

7. 再一次在 Text 圖示  點取來建立時間文件物件。  

8. 在畫面上點擊並且輸入 Time: ########。  

9. 在此文字物件雙擊滑鼠左鍵開啟物件屬性(Object Properties) 對話框。 

10. 抅選Transparent 檢查盒(check box)並且設定背景顏色為透明的。  
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11. 選取此文字物件並且在這 Text I/O 圖示  點擊應用這個動態到此物件。 

12. 在此文字物件雙擊滑鼠左鍵重新開啟 物件屬性(Object Properties) 對話框並且輸
入 Time 到這個 Tag/Expression 欄位 (如圖) 指定內定資料點給 Text I/O 動態。 

 

在執行期間， IWS 會用時間資料點(tag)的值來取代 ######## 字元。 

當你建立完日期和時間文字物件後，在你的畫面應該會看到類似下面圖形。 

 

Finished Date and Time Objects 
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建立離開圖示(Exit Icon) 
為畫面建立 離開(Exit) 圖示 ，可依照下列步驟： 

1. 按下 Library 圖示  開啟圖形庫。 

2. 在清單上選擇 icons 然後在 開門(open door) 圖示雙擊滑鼠左鍵開啟此物件到你的畫
面上。 

 

Select the Open Door Icon 

3. 在圖形物件上雙擊滑鼠左鍵開啟它的物件屬性(Object Properties) 對話框。 

 

4. 選取此圖形物件並且按下 Command 圖示  應用這個動態到此物件。 

5. 在此圖形物件上雙擊滑鼠左鍵重新開啟物件屬性(Object Properties) 對話框並且輸
入 Shutdown() 到 Expression 欄位內去指定這個功能給命令動態並且應用給此
圖形物件。 
當你建立完離開(Exit) 圖示後，在你的畫面應該會看到類似下面圖形 (在畫面的右
邊)。 現在，當在執行時間在這個圖示按下， IWS 會停止 (Shutdown()) 此應用
程式 (執行模式)。 

 

Exit Icon 
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測試此應用程式 
使用下列程序來測試你的應用程式： 

1. 點擊此 執行應用程式(Run application) 圖示  (位置在IWS 工具列) 去執行這個應用
程式。 

2. 點擊此 離開(Exit) 圖示 (開門圖形) 或 切換置背後IWS (Alt+TAB)發展環境並且按下
此 停止應用程式(Stop application) 圖示  在 IWS 工具列去關閉這個應用程式。 

建立水槽物件(Tank Object) 
加入一個水槽到你的畫面，可依下列步驟： 

1. 點擊此 圖形庫(Library) 圖示   (位置在 IWS 工具列) 去開啟圖形庫。 

2. 從清單上選擇 tanks (如下圖所示)，而且在任何一個水槽雙擊滑鼠左鍵載入到此畫面
上： 

 

Select a Tank Object 

3. 在水槽物件上雙擊滑鼠左鍵開啟它的物件屬性(Object Properties) 對話框。 

來自ISW的水槽是由不同的物件與動態組合而成 (舉例來說一個長方形，一個條狀
曲線圖，等等)。你能藉由選擇物件修改這個物件的屬性或動態的從此圖形群組的複
合－方塊(combo-box)。 然而對於這個例子，你將會只是修改與水槽物件有關的資
料點(tags)。  
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4. 點擊Replace按鈕去對應水槽物件有關連的資料點(tag)。 

5. 當 Replace 對話框顯示 (如下圖)，你直接去置換現在的資料點(Current Tag) 
AnalogValue_ (一個內定資料點用來模擬水位) ，輸入 Level[Index] 在最上面的 
New Tag 欄位。 

 

Replace Dialog 

你能使用此[Index]資料點(tag)設定Level資料點(tag)陣列位置，而且可在相同
物件去顯示三個水槽任何一個的水位。 依本例子：  

當： 

" Index=1, the object shows the level of Tank #1 (Level[1]) 
" Index=2, the object shows the level of Tank #2 (Level[2]) 
" Index=3, the object shows the level of Tank #3 (Level[3]) 

6. 按 OK 按鈕來確認變更此資料點。 

因此你沒有事前在應用程式資料點資料庫去建立一個 Index 資料點(tag)， IWS 會
顯示下列的訊息框： 
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7. 當按下 Yes 按鈕會從畫面輯編器去建立此 Index 資料點(tag)。(附註你不須再一次
開啟申請資料點資料庫(application Tags database)來產生此應用程資料點
(tags)。 

 

New Tag Dialog 

8. 你必須去設定此 Index 資料點(tag) 型態(Type) 為 整數(Integer)， 陣列大小(Array Size) 
為 0，和網頁資料(Web Data) 為 本地端(Local)。 

因為此資料點(tag)是本地端(Local)，它在相同時間會有不同的值在伺服器與網路用
戶端位置。因此，本地使用者 (伺服器端)可能監視到一個水槽水位 (例如： Index=1 
Tank#1) 同時間遠端使用者 (網頁用戶端) 監視到另一個水槽的水位 (例如： 
Index=2 Tank#2)。  

下圖讓你應該如何在畫面上建立水槽物件來看之圖解(放置在底部中心)。  

 

Screen with New Tank Object 
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建立水位滑動器物件 
在你的應用程式來建立水位滑動器物件，使用下列步驟： 

1. 按下此 圖形庫(Library) 圖示  去開啟圖形庫。 

2. 從清單上選擇 滑動器(sliders) ，之後在任何顯示的滑動器物件雙擊滑鼠左鍵 (如下圖
所示) 去增加到畫面上。 

 

Selecting a Slider Object 

3. 在滑動器雙擊滑鼠左鍵去開啟它的 物件屬性(Object Properties) 對話框。 

從IWS得到滑動器是由不同的物件和動態組合而成的群體 (矩形，位置動態等等)。 
你可以從此群體的圖形複合－方塊(combo-box)選擇物件或動態去修改這些屬性。 
為此例子，你將只會修改關於此物件的資料點(tag)。 

4. 按下此 Replace 按鈕關連到此物件的資料點(tag)。 
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5. 當 Replace 對話框顯示時，在最上面新資料點(New Tag)欄位上輸入 
Level[Index]並且按 OK 按鈕來確認變更此資料點(tag)。  

 
Replacing the Current Tag 

下圖讓你應該如何在畫面上建立滑動器物件來看之圖解(放置在底部右邊)。  

 

Screen with the New Slider 

選擇一個水槽 
選擇一個水槽，使用下列步驟： 

1. 點選 Text 圖示  去建立文字物件。 

2. 在畫面上按下並輸入：Tank: #。  

3. 在文字物件上雙擊滑鼠左鍵去開啟此物件屬性(Object Properties) 對話框。 

4. 致能此 Transparent 檢查盒使文字物件的背景顏色為透明的。 
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5. 點選此文字物件並且在 Text I/O 圖示  點擊應用這個動態至此物件。 

 

6. 在此文字物件雙擊滑鼠左鍵重新開啟此物件屬性(Object Properties) 對話框並且在
此Tag/Expression 欄位上輸入 Index 指定為此文字I/O動態之內定資料點(tag)。 

7. 致能此 Input Enabled 檢查盒，使得在執行期間允許輸入新的值給此Index資料點
(tag)。 

8. 在 Minimum Value 欄位輸入 1 和在 Maximum Value欄位輸入 3。 

在執行期間，IWS 將會在此文字物件用 Index資料點(tag)的值來置換這個 # 字元。 

9. 最後，從主選單列選擇 File → Save ，並且存此畫面的檔名為 synoptic.scr。 

當你完成你的應用程式建立在畫面上看起來應該像下面圖形圖解。 

 

Finished Application Screen 

10. 在畫面上按下滑鼠右鍵並且從彈出的選單選擇Close選項，去關閉主要的畫面。 
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測試此應用程式 
使用下列程序來測試你的應用程式： 

1. 點擊此 執行應用程式(Run application) 圖示  去執行這個應用程式。 

2. 在水槽(Tank)標題上輸入第幾個水槽 (1, 2, or 3) 並且使用滑動器來修改每一個水槽
水位。注意你可以獨立的 監視/設定 每一個水槽之水位。 

3. 點擊此 離開(Exit) 圖示 (在右上角) 或 切換置背後IWS (Alt+TAB)發展環境並且按下
此 停止應用程式(Stop application) 圖示  在 IWS 工具列去關閉這個應用程式。 

設定 I/O 通訊驅動程式 
當 IWS 執行應用程式時使用 I/O驅動程式可從PLCs 與其他 I/O 設備去取得入必要的
資料值。本節說明如何去選擇，安裝和設定I/O 裝置。 

1. 在工作區(Workspace)，選擇 Comm 頁面並且Drivers 檔案夾上按滑鼠右鍵。 

2. 當顯示出彈出選單時，選擇此 Add/Remove drivers 選項。 

 

Add/Remove Drivers 
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這個通訊驅動程式(Communication Drivers) 對話框顯示如圖下。  

 

Communication Drivers Dialog 

3. 從Available drivers 清單上選擇一個驅動程式(為本例子，請選擇這個 
MODBU-Modbus Protocol RTU/ASCII 驅動程式) 之後按下 選擇(Select) 按鈕 (或在此驅
動程式上使用雙擊滑鼠左鍵)。 

這個程式會將選到的驅動程式搬移至此 Selected drivers 清單上。 

4. 按下 OK 去關閉視窗並且儲存你的改變。 

! 注意：  
如要移除此驅動程式可從Selected drivers位置， 選擇它並按下 移除(Remove)
按鈕。 

 

5. 從加號的符號方塊來顯示相鄰Drivers 的檔案夾。 按下加號的符號或在 Drivers上
面雙擊滑鼠左鍵(在此字或檔案夾上) 去顯示你所増加的驅動程式之次檔案夾。(案照
本例子，會顯示此 MODBU 次檔案夾。)  

6. 在MODBU 欄位上按滑鼠右鍵並且從彈出的選單選擇此 Settings 選項。 

 

Select Settings from the Pop-Up Menu 
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7. 當這個 通訊參數(Communication Parameters) 對話框顯示時，去指定此設定與
PLC通訊參數相匹配。 

 

Communications Parameters Dialog for MODBU Driver 

" 提示： 
選擇 Help → Communication Drivers 得到 MODBU Driver 使用者手冊 ，描述有關這
些通訊參數的詳細資訊。 

 

8. 再一次從MODBU 檔案夾按下滑鼠右鍵並且從選單上選擇 Insert 選項。 

一個 Modbu001.drv 對話框顯示在工作區裡。 注意這個對話框被分割成兩個區域： 

 

Modbu001.drv Dialog 

" 標題(Header): 一個灰色標題有數個欄位 
" 主體(Body): 工作表單之表格 
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9. 在標題區域，這些參數設定如下： 

" Description 文字方塊： 輸入 Example Modbus。 (這個參數僅僅只是文件(文字
的描述)，它不會對任何通訊方面產生影響。)  

" Enable Read When Idle 文字方塊 (布林值(Boolean values), 1= yes 和 0 = no): 輸
入 1 時 IWS 將會持續的讀值從這個驅動裝置工作表單上的主體(body)所指定的
PLC位址。 

" Enable Write on Tag Change 文字方塊 (布林值(Boolean values), 1= yes 和 0 = 
no): 輸入 1 那麼每當這資料點(tags)值改變時， IWS 將會寫入這個值從這個驅
動裝置工作表單指定的資料點(tags)。 

" Station 文字方塊 (指示這個裝置設備存取的 I/O 裝置編號。 一般上 PLC 指定的
裝置為 #1。) 輸入 1。 

" Header 文字方塊: 輸入一個參考值從下面的表格中。 

! 注意： 
你必須使用驅動裝置特殊格式在這個 Header 文字方塊。  
ModBus 協定的格式如下：  
<reference for the type of register>: 
<initial offset for the first stored value>. 

 

下面的表格清單提供MODBU 驅動裝置可接的已登記的形態： 
 

Register Type Description 

0X Coil Status 
1X Input Status 
3X Input Register 
4X Holding Register 
ID Slave ID Number 

 

例如: 4X: 0 符號是一個Holding Register對應的位移為零。 
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Sample Header Section 

10. 在Modbu001.drv 視窗裡的主體(body)域區的空白表格上，輸入下列所提供的資
訊： 

" Tag Name: 輸入此 I/O 資料點(tag)名稱。  
" Address: 輸入此 PLC 位址位移(Address offset)。 

11. 應用程式的資料點(tags)關連到PLC 位址是根據下列的表格： 
 

Driver Worksheet Application Tag 
Header Address 

PLC Address 

Level[1] 4X:0 1 4X:1 (Holding Register 1) 
Level[2] 4X:0 2 4X:2 (Holding Register 2) 
Level[3] 4X:0 3 4X:3 (Holding Register 3) 
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Completed Body Section 

12. 儲存通訊驅動裝置表單 (File → Save)。當提示選擇這個驅動裝置表單編號時，請輸
入 1 並且按下 OK 按鈕去儲存此 MODBU001.DRV 驅動裝置表單。 

 

Save the Driver Sheet 

測試通訊驅動裝置，使用下列步驟： 

1. 按下此 Run application 圖示  (在 IWS 工具列) 去執行這個應用程式。 

2. 在輸出(Output) 視窗按滑鼠右鍵 (在 IWS 發展環境的底部)並且從彈出的選單上選
擇 Settings 選項。 

 

Select Settings from the Popup Menu 
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3. 在此Log Settings 對話框裡去致能這些項目 Field Read Commands， Field Write 
Commands，和 Serial Communication (如下圖所示) 之後按OK。 

 

Specifying the Log Options 

4. 現在你開始能夠從輸出(Output) 視窗中去監視通訊的訊息。 

! 注意： 
你也能夠從LogWin 視窗 (Project → Settings → LogWin)去監視通訊的訊息。 
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第 7章. 在Web-Based 執行應用程式 

本章將說明如何去準備你的應用程式在Web上。 

! 注意： 
IWS 儲存應用程式的全部畫面在Screens 檔案夾中，位置是在工作區(Workspace) 
的 Graphics 頁面上。 

 

開啟你的應用程式的畫面，使用下列的步驟： 

1. 展開此Screens 檔案夾並且在synoptic.scr上面雙擊滑鼠左鍵。 

 

Select scynoptic.scr. 

2. 選擇 File → Save as HTML 去儲存此畫面為 HTML 格式。 

 

Saving Screens in HTML Format 
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3. 在執行這個命令後，這個網頁(Web)檔案會被儲存在此應用程式的目錄底下的 \Web 
次檔案夾裡。 

 

Viewing Web Files 

4. 從主選單列選擇 Project → Settings 開啟專案設定(Project Settings)對話框並且點
取 Web 頁面。 

5. 你必須指定此在執行期間伺服器站的IP 網址 (這個位置為你要執行 IWS 或 
CEView)到此 Data Server IP Address 欄位上。這網頁用戶端站的線上資料(tag 
values)交換是用此站所指定在這個欄位上。 

6. 你也必須指定URL 路徑到此 Web 檔案 (檔案是存放在Web 次檔案夾裡) 在這個 
URL 欄位上。這個URL 決定此首頁目錄指定為你的網頁伺服站的服務。 

假設此應用程式的 /Web 次檔案夾是首頁目錄，你可以配置網頁設定 (Web 
settings) 顯示如下圖所示，到網頁用戶端位置去測試。 

 

Specifying the Project Settings 
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! 注意： 
微軟在任何微軟的作業系統有提供網頁伺服器(Web Server)。查閱你的微軟
的文件有關於網頁伺服器(Web Server)的安裝與設定之資訊。 

 

7. 網頁設定(Web settings)完成後，按下 OK 按鈕去關閉專案設定(Project Settings) 
對話框。 

8. 在畫面編輯器關閉全部的畫面 (Window → Close All) 並且選擇 Tools → Verify 
Application 去更新 Web Settings 為了網頁(Web pages)。 

$ 警示： 
在這個專案設定(Project Settings) 選單如有任何的改變之後，你必須去執行 Tools 
→ Verify Application 。 

 

測試你的 Web-based 應用程式，使用下列步驟： 

1. 在伺服器站上按下執行應用程式(Run application) 圖示  (在IWS 的工具列) 去執行
應用程式的本地端。 

2. 開啟網際網路瀏覽器(Internet Browser) (Microsoft Internet Explorer 或 
Netscape) 並且輸入這個網址(URL address)去開啟此 synoptic.html 畫面來
自於伺服器站上(為本例子： http://127.0.0.1/synoptic.html)。 

3. 當在瀏覽器上顯示此 Log On 對話框時 (如下圖所示)，輸入 guest 在這個 User 
Name 欄位上，之後按 OK 按鈕去開啟 synoptic.html 畫面在這個瀏覽器當中。 

 

Logging On as Guest 

http://127.0.0.1/synoptic.html
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注意你可以去修改任何一個水槽的水位從本地端 (伺服器站) 使用執行時期模組的 
畫面或從遠端 (網頁用戶端) 使用瀏覽器。 

 

Modifying the Tank Level 

! 注意：  
網頁用戶端需要一個ActiveX 元件 (ISSymbol.ocx) 去管理在瀏覽器上的畫面。 
假定你的網頁用戶端有連線到網際網路上，這個元件將會自動被下載與註冊。  
不然，你必須複製這個 ISSymbol.cab 檔案從IWS的 \BIN 次檔案夾上並且貼至
到網頁用戶端站此 \<OSPath>\System32 目錄上。使用此 WinZip® 工具軟體
去unzip(解壓縮) 此 ISSymbol.cab 檔案解壓縮至此\<OSPath>\System32 目
錄並且使用 regsvr32 ISSymbol.ocx 命令去註冊這個ISSymbol.ocx 檔案。 
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第 8章. 從遠端執行應用程式 

本章說明如何從遠端位置來執行你的應用程式。 

當從本地端(在發展端的電腦上)設定完應用程式與測試應用程式之後，你可以下載這個
應用程式到遠端的執行版電腦上，在Windows NT/2000/XP作業系統上執行版為ISW
或在Windows CE作業系統上執行版為CEView。 

1. 從遠端目標電腦上，選擇 Start → InduSoft Web Studio → InduSoft Remote Agent 去確
認此遠端代理程式 (CEServer.exe) 是在執行。 

2. 當 Remote Agent 對話框顯示時，按下這個 Setup 按鈕。 

 

Verifying the Remote Agent  

3. 當 Setup 對話框顯示時，點選 Serial 或 TCP/IP 指定何種通訊協定要與發展端電腦
連線。 

 

Specifying the Device Connection Method 

! 注意： 
InduSoft 建議使用 TCP/IP， 因為效率較好。 
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4. 在遠端電腦上按下 OK 按鈕並且讓這個遠端代理程式(Remote Agent)繼續執行。  

5. 在本地端(在發展端的電腦上)從主選單列選擇 Project → Execution Environment 去開
啟此 Execution Environment 對話框。 

6. 具體說明要與目標電腦連線方式 (Network IP or Serial Port)。假定你選擇了 Network 
IP，在這個文字方塊裡輸入遠端電腦的 IP 位址。 

 

Specifying the Target Station Link Type 

7. 按下此 Connect 按鈕去連線到遠端電腦。 

! 注意： 
假如遠端電腦是CE 設備，按下這個 Install system files 按鈕去下載 CEView 執
執行版的檔案到這個遠端電腦上。 

 

8. 回到 Execution Environment 對話框並且選擇到這個 Application 頁面。按下 
Send to Target 按鈕將應用程式下載到遠端電腦上。 

 

Downloading the Application 

9. 當應用程式所有的檔案下載完成後，按下 Run 按鈕去執行遠端電腦上的應用程式。 
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