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一 TKS-764B技术特点和背景资料 
 

TKS-764B 仿真器是广州致远电子有限公司推出的一款实时在线仿真器 它完全支持 PHILIPS 公司

51LPC 系列芯片的仿真 在仿真性能上进行了全面的优化设计 能保证用户更加方便的操作和真实的仿真

效果 TKS-764B是 TKS-764的升级产品 设计者保证 TKS-764B在最大的可能性下同 TKS-764在使用上

的兼容 原 TKS-764 用户完全可以在原使用环境不便的情况下直接使用 TKS-764B 但是由于内部的变化

TKS-764不能升级到 TKS-764B  

 

z 兼容 Keil公司的硬件仿真环境 使用户能够在先进的编译环境下编译 同时也能在先进的仿真

环境下进行硬件仿真  

z 使用 PHILIPS公司授权的专用 BondOut芯片 仿真更加真实  

z 采用更加合理的 BondOut通讯方式 BondOut工作更加稳定  

z 真实仿真 LPC76X的掉电模式和空闲模式  

z 真实仿真 LPC76X的各种方式的复位 软件复位 看门狗复位 外部复位  

z 支持用户程序嵌入配置字节 使用户仿真 烧写更加方便可靠 同时在仿真中可随意观察和修

改用户配置字节  

z 内部更加可靠的保护 避免使用中误操作引起仿真器的损坏  

z 连续单步运行速度更快  

z 支持使用外部用户电源电压 用户提供的电源电压最低可达 2.7伏  

z 仿真时多而详细的状态信息提示 帮助用户迅速查找目标系统的故障  

z 系统内部多种检查 当系统配置错误时避免进入错误的运行状态  
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二  TKS-764B仿真器型号的分类 

 

在 TKS-764B发货时 根据内部的仿真芯片 BondOut的不同可能会有 2种型号  

 

z TKS-764B-768 内置仿真芯片 P87LPC768 可以仿真除 P87LPC769 以外的所有 51LPC 型号

P87LPC759/760/761/762/764/767/768  

z TKS-764B-769 内置仿真芯片 P87LPC769 可以仿真除 P87LPC768 以外的所有 51LPC 型号

P87LPC759/760/761/762/764/767/769  

 

用户在选购 TKS-764B时 可以购买指定的型号 在用户不仿真 P87LPC769/768时 购买任何一种型

号都是一样的 如果用户可能会用到 768/769 两种型号的仿真 在购买仿真器的同时也可以另外购买另外

一种型号仿真芯片 以备将来更换使用  
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三 TKS-764B仿真器使用前应该了解的知识 
 

TKS-764B仿真器是 TKS系列仿真器的一个品种 用户在使用前须仔细阅读 TKS系列仿真器用户使

用手册 的有关事项 在具备以下条件后可以开始熟悉使用 TKS-764B仿真器  
z 熟悉Windows的系统操作以及一般应用软件的操作技能  

z 了解 PHILIPS公司的 51LPC系列单片机的原理  

z 了解一般的电子电路知识  

z 准备一台符合要求的计算机和操作系统  

z 安装并熟悉 Keil的µVision2集成开发环境  

  

另外 在开始使用 TKS-764B仿真器前 您首先应该熟悉一下 TKS-764B仿真器的硬件 在您购买回

来的仿真器套件中 有几样东西是必须使用的  

z 仿真器主机 完成仿真功能的最主要部分  

z 仿真器电源 为仿真器主机提供工作电源 它的输入电源为交流 220V  

z 仿真头 带有 20脚 DIP针状插座 可以插入用户目标板的插座中 它的另外一端通过仿真电缆

连接到仿真主机 这样把仿真主机和用户目标板连接起来  

z 仿真电缆 40 芯的扁平电缆 用于连接仿真器主机和仿真头 随机提供的仿真电缆有两种长度

规格 较长的一种便于用户连接用户目标板 当用于较高频率或工作于干扰较大的环境时可使

用较短的仿真电缆  

z RS-232串口通讯电缆 用于连接仿真器主机和您的计算机 长度为 1.5m  

 

与 TKS-764B配合使用的可选附件有  

z 16脚 DIP针状插座仿真头,用于仿真 P87LPC761  

z 14脚 DIP针状插座仿真头,用于仿真 P87LPC760和 P87LPC759  

z 附加的仿真芯片 BondOut 型号为 P87LPC769或 P87LPC769 
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四  TKS-764B在 Keil中的快速操作 
 

Keil软件是德国 Keil Software/Keil Elektronik开发 近几年在国内得到迅速普及 国内使用的一般是 

比较稳定的 6.2 版本以及最新的 7.0 版本 用户可以向 Keil 公司的国内代理商广州周立功单片机发展有限

公司购买正式软件或索取 Demo 版本 也可以直接到 Keil 公司的网站下载该软件 Keil 公司的网址是

http://www.keil.com/  

当您得到该软件的安装软件后 您可以按照提示进行安装 安装完毕后 您就可以在这套功能强大的

开发平台上完成您所有的设计工作 包括源程序的编写 程序的编译和连接 软件模拟仿真的验证和排错

最后您可以使用 TKS-764B在 Keil中进行硬件的仿真和调试 直到最终完成您的设计  

在安装完毕后 您就可以编写一个简单的程序来熟悉 Keil的 IDE环境 也可以使用 Keil软件本身提供

的范例程序 下面我们主要结合 Keil的范例程序 Hello来讲解 Keil的具体使用  

当您安装完毕后 Hello程序位于\Keil\C51\EXAMPLES 具体驱动器的位置取决与您的安装选择 如 

果您选择的是缺省安装 Keil将会安装在 C盘  

 

4.1  打开 Hello工程 

在 Keil中文件的管理使用的工程的方法 而不是以前的单一文件的模式 您的所有的文件包括源程序

包括 C 程序 汇编程序 头文件 一般的文本文件都将放在工程里统一管理 在使用 Keil 前 您应该

习惯这种工程的管理方式  

点击 Keil 的图标启动 Keil 程序 然后您就可以看到 Keil 的主界面 在有的版本中 Hello工程会自动

打开 如果您没有看到 Hello工程或看到的不是 Hello工程 您可以点击 Project->Open Project按照前面提

示的路径找到该工程文件  

Hello工程是一个简单的 C语言单模块程序 完成的主要就是通过串口发送 Hello World 字符串  

工程管理窗口             文件编辑窗口             信息输出窗口 

 

 

 

 

 

 

 

 

                                

          

       

 

 

 

 

 

 

 

 

 

图 4.1 标准编译界面 
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4.2  为工程选择目标器件 

 

在打开工程以后,还应该为您的工程选择合适的目标器件 使用 TKS-764B 您必须选择 51LPC 系列为

目标器件 选择方法为 点击菜单 Project->Select Device for Target…后出现下面的对话框  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

图 4.2 目标器件选择界面 

  在此对话窗中,左边的 Data base窗口中把 Keil所支持的器件按照生产厂商进行分组列表 您可以点开

PHILIPS组 找到并选择 P87LPC764 按动对话框上的确定按钮 在您选择了 P87LPC764后 仿真时系统

将根据所选定的器件为您提供一些特定的功能选择 例如 如果您选择了 P87LPC764 进入仿真时在 

Peripherals菜单中将会增加很多外设观察选择 例如外设菜单中的 Analog Comparator 项目就为您提供了观

察和修改 P87LPC764内部比较器单元的浮动窗口  

 

4.3  编译和连接 Hello工程 

 

对于已经打开的 Hello工程 里面已经为您设置好了所有的系统配置 因此您可以直接进行编译和连

接 对于您自己新建立的工程文件 需要您自己加入文件和进行编译环境等设置 有关 Keil的设置在下面

叙述  

选择菜单 Project->Rebuilt All Target Files Keil将对 Hello工程进行连接和编译 操作结果的信息显示

在输出窗口 如果用户没有对 Hello工程做任何的改动 编译和连接将会正确完成  

 

 

 

 

 

 

 

图 4.3  编译结果在信息输出窗口的输出 
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经过编译和连接后 Hello工程已经可以进行模拟仿真或硬件仿真 模拟仿真是利用 PC的资源模仿单

片机的运行 优点是简单 不需要动用硬件 缺点是对于外部信号无法进行正确的仿真 硬件仿真正好相

反 但硬件仿真是调试的必须步骤 下面我们主要讲述硬件仿真  

 

4.4  仿真 Hello工程 

 

Hello经过编译和连接后 已经可以进行硬件仿真 也就是说可以通过 TKS-764B仿真器进行实际的硬

件仿真 在仿真前 还必须配置还硬件仿真参数 否则可能引起仿真失败      

点击菜单 Project->Option for Target..进入工程配置对话框 选择 Debug 出现下面的对话框 在这个 

对话框中 主要供用户选择仿真时需要的一些设置 在这些设置中 请用户仔细按照下面的要求选择 不

正确的选择将回造成仿真的困难和不准确 甚至难以理解的现象  

软件仿真选择                             硬件仿真选择   启动运行选择     硬件仿真参数设置 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                               仿真目标器件驱动选择  仿真配置记忆选择  仿真器类型选择 

图 4.4  仿真配置界面 

 

软件仿真选择 使用软件仿真当前的设计  

硬件仿真选择 使用硬件仿真当前的设计 使用 TKS-764B必须选择硬件仿真  

启动运行选择  

Load Application at Start 进入仿真后调入程序代码进入仿真器  

Go till main 在使用 C语言设计后直接运行到 main 函数  

仿真配置记忆选择  

Breakpoints 记忆当前设置的断点 下次进入仿真后后该断点设置存在并有效  

Watchpoints 记忆当前设置的观察项目 下次进入仿真仍有效  

Memory Display 记忆当前存储器区域的显示 下次进入仿真仍有效  

Toolbar 记忆当前的工具条设置 下次进入后仍有效  
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仿真目标器件驱动程序选择  

如果在上面选择了 87LPC764为目标器件 系统将自动生成  

仿真器类型选择 用于选择当前 Keil可以使用的硬件仿真设备  

任何可以挂接 Keil仿真环境的硬件都必须提供驱动程序 驱动程序是 dll文件 TKS系列仿真器也提

供 Keil下的驱动程序 并根据仿真器设备的不同而不同 驱动程序和详细说明都在随机提供的光盘中提供  

 当用户得到驱动程序 dll后 还必须在 Keil的配置文件中声明 才能在仿真器类型选择中找到该硬件

设备 不同的 TKS系列仿真器可能使用不同的驱动 dll 具体使用的 dll参考相应型号的说明  

 

仿真器驱动程序声明  

注意 这是 TKS-764B的声明 其他型号参考相应的使用手册 TKS-764是早期的型号 我们没有提

供 Keil下的驱动程序 而是直接使用 Keil提供的Monitor-51通用驱动 不能使用 TKS-764B的驱动程序  

在配置仿真器前 请将随机提供的 TKS系列仿真器驱动文件 TKS_764B.DLL拷贝到 Keil的安装目录

C51\bin下 例如 如果您的 Keil的安装目录为 C:\Keil 则将 TKS_764B拷贝到 C:\Keil\C51\bin目录下

然后打开 C:\Keil目录下的 Tools.ini文件 在几个分类中找到[C51] 加入下列描述  

TDRV3=C:\Keil\C51\bin\TKS_764B  ("TKS-764B Emulator")    

其中 TDRV3是驱动 DLL的序号 如果您前面已经安装了多个驱动 DLL以致占用了 TDRV3 则将

TKS的驱动程序序号向后顺延 例如 TDRV5 在随机软件中 有一个示范 Tools.ini文件 可以用来参考如

何加入驱动程序 需要注意的是该文件中驱动程序说明行所指出的路径可能和您的不同 这要根据您的 Keil

软件安装在硬盘中的位置 C:\Keil\C51\bin\TKS_764B.DLL 是驱动程序放置的路径 该路径下必须有

TKS_764B.DLL文件  

 

硬件仿真参数设置 该配置项主要设置硬件仿真的重要选项 用户必须仔细选择 点击 Settings 进入   

仿真器硬件设置对话窗  

 

通讯选择区域                缓冲选择区域 

 

                                                                  

串口选择                                                        使用可直接寻址数据缓冲 

                                                                使用可间接寻址数据缓冲 

波特率选择                                                            使用外部数据 xdata 缓冲 

时钟选择区域                                                       使用代码数据 code 缓冲 

内部 12M时钟                                                                   

内部6M时钟                                                      芯片工作模式选择 

内部 3M时钟                                                    时钟工作模式选择 

仿真头上时钟                                                          UCFG1数据 

附加选择区域                                                     启用 6x时钟 

使用外部电源                                                      启用 2.5V掉电检测 

开启 AD/DAC0                                                         启用复位后引脚为高 

开启 DAC1                                                          关闭复位引脚功能 

开启比较器                                                            启用看门狗 

 

                                                                      搜索仿真器 

 

图 4.5  仿真硬件配置界面 
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Com Port Settings串口设置区域 
z Port 选择硬件仿真器使用的串口 TKS使用串口同 Keil进行通讯  

z Baundrate 串口使用的波特率 TKS使用的是自动适应波特率 也就是该选项在一定选择范围 

内 TKS都能正常工作 选择快的波特率能加快运行速度 但是低的波特率在环境恶劣的条件下更可靠 TKS

适应的波特率范围在 1200-57600之间 但根据用户的实际情况略有差异  

注意 选定波特率后 必须先接通 TKS-764B仿真器电源 仿真器主机面板上的指示灯闪烁结束后

才可以运行 Keil的硬件仿真程序 在硬件仿真环境中用户可以在 Peripherals菜单中打开 Target Settings窗

口 图 4.5 来更改波特率 更改后整个系统重新建立连接 也可以更改串口 但是用户必须在更改后的串

口上连接仿真器  

 

Catch Option选择区域  
使用存储器缓冲区域 这样在一般的操作中仿真软件不用频繁的读取仿真器中的内容 而使用缓冲区

域 使用缓冲可以大大加快仿真速度 建议用户将该区域选项全部选中 使用缓冲的缺点是屏幕的数据刷

新慢 但是在单步或运行后所有在屏幕上显示的信息将全部刷新一次  

 

Select Oscillator选择区域  
选择仿真时使用的时钟 用户可以选择仿真器内部提供的 3个时钟频率选择 也可以选择外部时钟 仿

真头振荡器产生的时钟或用户目标板上的时钟 但是不支持用户目标板上的晶体 选择仿真内部时钟系统

的性能最稳定 但是只提供 12M/6M/3M 3个频点给用户使用 选择外部时钟用户可以根据自己的要求来选

择频率 只需要在仿真头上插入希望的晶振或使用目标系统板上的时钟 不是晶体 由于外部时钟信号从

外部引入到仿真器内部 中间要经过仿真电缆和接插件 因此稳定性和抗干扰性能不如使用内部时钟 如

果用户需要特殊频率的时钟可以采用这种选择  

由于 P87LPC700时钟配置的灵活性 TKS-764B的时钟源选择也有更加多的功能 功能的变化主要依

赖与 UCFG1的配置数据  

z UCFG1 配置为高/中/低频/外部时钟 在这种选择下 用户可以使用以下 5 种时钟选择 点击任

何 12M/6M/3M/TestBoard 选项将施加相应的时钟 点击当前的时钟选项将关闭全部的

12M/6M/3M/TestBoard的时钟 用户必须在目标板上从 X1脚输入脉冲信号作为仿真器的时钟  

� 12M 仿真器内部提供的时钟 在这种选择下 用户对 X1 脚不允许连接任何驱动电平 也

不允许连接大的负载 包括晶振和负载电容  

� 6M仿真器内部提供的时钟 其余同上  

� 3M仿真器内部提供的时钟 其余同上  

� 仿真头 TestBoard 上振荡电路提供的时钟 用户必须使用仿真电缆连接仿真头 并将振

荡板插入到仿真头上 并将合适的晶振插入到振荡板的晶振插座中 晶振的频率范围大约

为 1M-12MHz 用户在使用特殊的时钟时 也可以使用 4脚有源晶体替代振荡板插入到仿

真头的插座中 但是注意不要插反 有源晶体的 1脚对应振荡板 4脚插座的 1脚  

� 用户目标板提供的时钟 用户可以在自己的目标板上提供时钟 直接驱动 X1 脚 但是要

取消所有的时钟选择 方法是用鼠标单击当前的时钟选择 可以看到 12M/6M/3M/TestBoard

的 4种时钟选择全部不选中  

� UCFG1 配置内部 RC 时钟 在这种选择下 TKS-764B 的运行时钟用户不能选择 用户一

般可以看到 12M/6M/3M/TestBoard全部不选中  

 

Aux. 选择区域 
z Use Ext. Power 使用外部电源选择 

使用外部电源作为仿真电源 在不使用外部电源时 使用的是内部的+5V电源 要求用户板上的电源
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也必须是+5V 但是允许有 0.7V的上下偏差 如果用户需要仿真的电压跟+5V差距过大 则可以选择该项

使用的外部电源电压必须在 2.7V-5.5V 之间 外部输入电源从用户板得到 经过仿真头电源脚进入仿真器

内部 外部输入电源最低电压为 2.7V 小于 2.7伏内部电压将维持在 2.7伏不变 外部输入电压最大为 5.5V

超过 5.5V将引起内部保护装置的启动  

z 开启 AD/DAC0 

z 开启 DAC1 

TKS-764B内部使用的芯片是功能较多的芯片,一般是 87LPC768/769 在仿真功能较少的芯片时 例如

87LPC764 用户不会使用到内部的 AD/DA 功能 因此可以将这些项目关闭 经验表明 不关闭这些附加

的功能一般也不会引起问题 但是如果使用这些功能必须打开这些选项  

z 开启比较器 

开启仿真芯片的比较器功能  

 

System Configation区域 
z 芯片工作模式选择 

TKS-764B可以有 4种工作模式的选择 以适应仿真不同的目标芯片  

� 1K EPROM/64  RAM 1K的程序空间  64内部 RAM  

� 2K EPROM/64  RAM 2K的程序空间  64内部 RAM  

� 2K EPROM/128 RAM 2K的程序空间 128内部 RAM  

� 4K EPROM/128 RAM 4K的程序空间 128内部 RAM  

用户在仿真具体的 87LPC700系列芯片时 可根据该芯片的 ROM和 RAM情况选择仿真器的工作模 

式 这样可以得到准确的仿真效果 如果用户确保自己不会用到超出目标芯片的资源 也可以选择最大的

资源的工作模式 4K EPROM/128 RAM  

z 时钟工作模式选择 

用户可以选择仿真芯片的时钟工作模式 对应与 UCFG1.2-0 用户共有高/中/低频晶振 内部 RC 外

部时钟 5种选择 用户选择不同的时钟模式也就改变了 UCFG1.2-0  

z UCFG1数据 

系统当前 UCFG1的数据显示  

z 启用看门狗         对应 UCFG1.7 

z 关闭复位引脚功能  对应 UCFG1.6 

z 复位后引脚为高          对应 UCFG1.5 

z 启用 2.5V掉电检测  对应 UCFG1.4 

z 启用 6x时钟      对应 UCFG1.3 

 

如果您正确完成上述操作 您就可以进入下一步  
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五  使用 TKS-764B进行仿真 
 

(1) 用随机提供的串口电缆连接 TKS-764B和 PC机 注意选择的串口号必须同 Keil硬件仿真设置中 

的选择一致  

 

 

 

 

step over 

step info 

停止运行按钮 

全速运行按钮 

复位按钮 

 

 源程序窗口  反汇编窗口  串行口输出窗口 仿真信息窗口   

 

 

 

 

 

                                               

                                     

 

 

 

     

                                        

 

 

 

 

                           

 

 

 

 

 

 

 

 

 

主寄存器窗口  帮助文件启动  命令行输入  命令执行结果显示窗口  变量显示窗口  存储器空间显示 

 

图 5.1 标准硬件仿真界面 
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(2) 将随机提供的电源适配器的交流端子插入 220V交流电源 另一端接入 TKS-764B的电源插座  

这时 TKS-764B的指示灯将闪烁 闪烁停止后仿真器进入命令等待  

(3) 点击菜单 Debug->Start/Stop Debug Session Keil将进入硬件仿真状态  

 

关于更为详细的资料 点击上图中的帮助文件启动 参考 Keil 的随机文档 根据经验 用户在使用

Keil的仿真环境时 最为困难的是具体的操作问题 下面是一些最为常用的操作  

 

查看和修改主寄存器的内容 

 

仿真时主寄存器的内容在主寄存器窗口显示,用户除了可以观察以外,还可以修改.用鼠标点击选中一个

单元,例如 SP 然后再单击 SP的数值位置 出现文字框后输入希望数值按回车即可  

另外的输入方法是使用命令行窗口 例如 输入 A=0X34 将把 A的数值设置为 0X34  

 

观察和修改变量 

 

点击 View->Watch & Call stack Window 该窗口出现后 选择Watch1-3中的任一个窗口 按动 F2后

在 Name栏填入变量的名称 如 DPTR TL0等 也可以输入用户自己定义的变量名称 如 Temp1 Counter

等 但必须是存在的变量 如果想修改数值 可单击 Value栏 出现文本框后输入希望的数值  

 

观察反汇编程序 

 

如果用户的源程序是用 C 语言写成的 进入调试环境中可能会不出现反汇编窗口 用户可以从

View->Disassembly Window打开反汇编窗口 在反汇编窗口中点击鼠标右键 可以看到多种针对反汇编的

操作 包括反汇编显示模式 在线汇编 和程序代码的调入  

 

运行程序 

 

在 Keil的仿真环境中 有几种运行方式  

z Run 全速运行 遇到断点停下或用户按动 Stop按钮停止  

z Step info 单步跟踪运行一条指令 如果该语句为 C中的调用子程序语句或汇编中的 CALL指令        

Step info指令将跟踪进入子程序内部  

z Step over 单步运行完一条指令 如果该语句为 C中的调用子程序语句或汇编中的 CALL指令  

Step over指令将全速完成该子程序的运行 停在下一指令处  

z Run till Cursor Line 从当前位置运行到光标处  

另外 用户还必须注意当前的运行背景 即是在源程序背静下还是在反汇编背景下 源程序分汇编程

序和 C 语言程序 在不同的背景下 使用上述的运行方式会有所不同 在汇编源程序和反汇编背景下

Step Info每次只执行一条汇编指令 遇到 CALL指令会跟踪到调用程序内部 而 Step over是在执行 CALL

指令后完成执行被调用的指令 停在 CALL 的下一条指令上 在 C语言源程序背景下 Step Info是执行一

条 C语言程序 这条 C语言程序可能包含多条汇编程序 但是不包含调用函数 如果该语句中包含调用函

数 经过 Step Info运行后将跟踪到调用函数的内部 Step over则是执行完被调用的函数 但是简单语句的

作用同 Step Info一样  
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复位按钮的作用 

 

在 Keil 的仿真环境中 工具条中有 Reset 按钮 表示系统的复位 在 TKS-764B中 复位按钮的作用

相当与外部信号复位 这种复位同上电复位不同 它不影响上电标志位  

 

退出仿真状态 

 

在仿真状态中 用户不可以再对工程进行编译和连接 退出仿真的方法同进入一样 点击菜单

Debug->Start/Stop Debug Session Keil将退出硬件仿真状态  
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六 TKS-764B涉及到的 P87LPC76X的技术参数和操作方法 
 

P87LPC700的外设功能强大 但也复杂 用户必须了解 P87LPC700系列才能使用好 TKS-764B的仿真

功能  

 

6.1  TKS-764B的存储器特性 

 

在 TKS-764B的仿真芯片中 存在与 87LPC76X芯片完全相同的存储器区域 但是由于执行的是仿真

功能 二者特性并不完全相同   

z 程序代码 最大 4K 空间 这一部分在 TKS-764B 中很明显对应的也是程序代码 用户可以下

载 查看和修改  

z 0FC30H/0FC31H/0FC60H 3个标识字节 在 TKS-764B仿真器中 这 3个字节用户在任何时候

都不能改动 并且在 TKS-764B仿真器中随实际使用的芯片而不同 一般为 15H 0DDH 0FFH

如果用户在程序中使用MOVC指令读取时注意仿真器同实际芯片的区别  

z 32字节的用户参数区域 在 TKS-764B仿真器中 这 32个参数字节存在并可以通过 MOVC指

令读出 但是在任何时候用户也不能修改 它是固定的数值 可能在制作仿真器中被使用 如

果用户确实需要使用这 32 个字节作为数据区使用 建议用户暂时把它们转移到真正的 4K 用户

区域以内 仿真通过后在烧写真正的芯片时再恢复过来  

注意 为了保持用户在仿真和烧写时程序的一致性 用户可以在程序中嵌入定义的 32个数据, 

在调入程序时 TKS-764B会在 Keil的命令输出窗口提示出错信息 告诉用户这些地址单元的 ROM

数据无法下载 用户可以不理会这些出错信息 但是需要了解其中的原因  

 

z 用户配制字节 UCFG1  

这个字节位于数据空间的 0FD00H位置 用户在程序中使用MOVX指令可以读出该字节数据 UCFG1

的配置决定芯片的工作方式 用户可以通过以下几种方式改变 UCFG1  

� 在 Project->Options for Target…->Debug->Setting 见图 4.5 仿真硬件配置界面 中配置  

� 不对 UCFG1进行设置 采用 TKS-764B的缺省数值 7BH 在缺省配置下 UCFG1的配 

置效果为看门狗关闭 6Clock 时钟 2.5V 掉电检测 复位口线为高电平 关闭复位引脚 使用内部

RC振荡时钟  

� 在用户程序代码中配置 UCFG1 在代码地址为 0FD00H位置定义的数值就是 UCFG1的数 

值  

� 进入仿真环境中 不管 UCFG1的数值如何 都可以通过改动外部数据空间地址 0FD00H 

位置的数值配置 UCFG1  

 

z 用户配置字节 UCFG2 

该字节位于代码空间 0FD01H位置 设置芯片的保密等级 用户通过MOVC指令可以读出该字节内 

容 在 TKS-764B 仿真器中 该字节是无法改变的 具体的数值在制作仿真器时确定 UCFG2 同 UCFG1

一样 也可以在用户程序中嵌入 但是 TKS-764B不会执行任何改动 并且有出错信息提示  

注意 为了保持用户在仿真和烧写时程序的一致性 用户可以在程序中嵌入定义的 UCFG2 在调入

程序时 TKS-764B会在 Keil的命令输出窗口提示出错信息 告诉用户该地址单元的 ROM数据无法下载

用户可以不理会这些出错信息 但是需要了解其中的原因  

 

z 仿真芯片配置字节 PCFG1 

这个字节位于数据空间的 0FD02H 位置 用于仿真芯片的特殊功能的设置 当 PCFG1=0 仿真芯片
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的特殊功能 A/D D/A功能全部关闭 这是 TKS-764B的缺省状态 如果 PCFG1=0FFH 则 A/D D/A

功能全部开放 由于开放仿真芯片的 A/D D/A功能可能在某些以外情况下会干扰系统的运行质量 所

以如果用户不对 PCFG1进行设置 TKS-764B的缺省状态是关闭的 请用户注意的是这个参数属于仿

真芯片的设置 而不是实际芯片的设置 用户可以通过以下几种方式改变 PCFG1  

� 在 Project->Option for Target…->Debug->Setting 见图 4.5 仿真硬件配置界面 中配置  

� 不对 PCFG1 进行设置 采用 TKS-764B 的缺省数值 00H 在缺省配置下 PCFG1 的配

置效果为 A/D D/A的仿真功能全部关闭  

� 在用户程序代码中配置 PCFG1 在代码地址为 0FD02H 位置定义的数值就是 PCFG1 的数

值 进入仿真环境中 不管 PCFG1的数值如何 都可以通过改动外部数据空间地址 0FD02H

位置的数值配置 PCFG1  

 

6.2  UCFG1的配置/修改/查看 

 

� 在用户程序代码中嵌入 UCFG1配置字节 

 

UCFG1在烧写程序时一同烧写 用户程序可以通过 MOVX指令读取 0FD00H位置来得到 UCFG1 的

数值 UCFG1如果在烧写时不正确配置 LPC764将无法工作 同以前以往的仿真器不同 TKS-764B支持

程序中设置配置字节 也就是说用户只要在程序中对 0FD00H 处的代码数据进行定义就能正确进行仿真

因此 每一个 LPC700 的程序在调入时都可以按照自己的配置来调整仿真器的配置 这样跟实际的芯片的

工作环境非常类似 也能够最大限度的进行仿真 另外 该程序仿真完毕后进行芯片烧写 本身就已经带

有芯片的配置信息 不会由于疏忽而引起配置字节的改变 周立功单片机发展有限公司生产的 CPX764 编

程器支持烧写嵌入配置字节的程序代码  

注意 程序中嵌入的配置字节必须是可用的 如果地址错误或配置数据不可用 例如选择了不可用的

时钟选择 仿真器将忽略该配置数据 按照仿真器的缺省配置进行设置 TKS-764B的缺省配置为 看门狗

关闭 复位引脚禁止 复位后口线为高电平 掉电电压为 2.5V 时钟为 6 个 CLK  时钟选择为内部 RC

振荡 TKS-764B 的缺省配置同实际的 LPC764 芯片的缺省配置不同 这主要是考虑采用这种配置后用户

不用配置也可以简单的运行程序  

UCFG1位于数据空间的 0FD00H位置 用户在程序中使用 MOVX指令可以读出该字节数据 考虑到

该字节也是处于内部 EPROM区域 因此 TKS-764B认为如果用户代码区域存在 0FD00H的数据 就把它

当作配置字节 UCFG1 来对待 但是该配置字节在实际的芯片中不是位于代码区域 而是外部数据区域

这一点请用户注意 由此带来的是 在仿真过程中 不但用户查看和修改外部数据区域 0FD00H 处 操作

的是该配置字节 UCFG1 而且操作代码区域的 0FD00H 地址处 对象也是 UCFG1 这种现象只是为了用

户的方便 但是同实际的芯片是不同的  

 

汇编程序中嵌入 UCFG1非常简单 只是在程序中加入  

org   0FD00H 

UCFG1:  DB  7BH            ;7BH为配置数据,实际要根据用户情况决定. 

 

C语言程序中加入较为烦琐一些 建议用户在工程文件中另外添加一个简单的汇编文件来描述该配置

字节 该汇编文件如下: 

cseg at 0FD00H 

UCFG1:  DB  7BH            ;7BH为配置数据,实际要根据用户情况决定. 

End 
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� 进入仿真后直接观察或修改 0XFD00处的 UCFG1 

 

进入 Keil 的仿真环境中 用户仍可以观察和修改用户配置字节 修改后立即生效 用户在菜单

View->Memory Window中可以打开或关闭 Memory窗口.在打开的 Memory窗口中,有 4个 Memory区域可

以选择 用户可以任选一个 在上面的输入行中输入该区域显示的种类和起始地址 对于 LPC764 的配置

字节位于 XDATA空间的 0FD00H处 所以用户可以输入 X:0FD00H,回车后可以看到显示的从 0FD00H开

始的 XDATA数据. 

如果有必要修改配置字节,用户可以把鼠标停在 0FD00H 处,按动鼠标右键,选择 Modify Memory at 

x:00FD00H.出现修改文本行后输入希望的数值,按动回车后配置字节被更新 改动的配置字节将立即生效

直到有新的配置数据进入或断电后丢失 按动复位按钮不能使配置数据变化  

 

� 使用 Keil的外设菜单工具观察或修改 UCFG1 

连接好 TKS-764B仿真器 进入硬件仿真环境 点击菜单 Peripherals->Target Settings 打开仿真器的 

配置界面 见图 4.5 仿真硬件配置界面  

 

6.3  PCFG1的配置/修改/查看 

 

 PCFG1属于仿真芯片的配置字节 位于外部数据空间的 0FD02H 用于打开或关闭仿真芯片的 A/D

D/A 功能 在实际的芯片中没有 PCFG1 配置字节 PCFG1 可以通过用户程序代码中嵌入来实现配置 也

可以在进入仿真后直接观察或修改 0XFD02处的 UCFG1数据 用户可以参照 UCFG1的实现方法 只是注

意地址改为 0FD02H 另外 PCFG1也可以使用 Keil的外设菜单工具观察或修改  

 

6.4  用户时钟的选择 

 

在 LPC700 的时钟选择中 共有 5 种时钟的配置选择 高频晶振/中频晶振/低频晶振/内部 RC 振荡/外

部时钟输入 对于 LPC700 的这 5 种时钟配置选择 TKS-764B 均予以支持 用户可以采取两种方法对

TKS-764B 进行配置 具体详细的配置方法见下面章节的说明 在 TKS-764B 中将上面的 5 中选择分成 3

种处理方法  

z 内部 RC振荡 仿真器和用户对时钟均不需要做任何考虑  

z 高/中/低频晶振/外部时钟输入  

在这种情况下 用户必须指定时钟源 用户可以选择内部的 12M/6M/3MHz时钟 也可以选择仿

真头 TestBoard 上的时钟 用户需要在仿真头上安装随机提供的仿真振荡组件 并在组件上

插入晶振  

z 用户目标板上时钟输入 用户需要在目标板上提供时钟信号 并通过插座输入到仿真头的 X1端

子上 并取消提供的 12M/6M/3MHz/TestBoard所有时钟源  

 

注意事项  

z 在选则使用高/中/低频晶振时 如果采用仿真器提供的时钟源 绝对不允许用户板上 X1 端子上

有时钟信号 也不允许有有强驱动的信号输入 接地或电源 否则将会对仿真器产生损坏  

z TKS-764B不支持直接用户板上的晶体振荡 但支持用户板上的时钟信号输入 这一点请用户注

意  

 

在 P87LPC700 实际的芯片中 时钟的选择由 UCFG1 的数值决定的 UCFG1 定位于芯片的外部数据

区域 0FD00H位置 但是由于 UCFG1属于 EPROM的属性 需要在编程时一次性的写入 因此我们在编写
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程序时可以把 UCFG1 的配置数据按照程序数据对待 这样不但在芯片编程时不用人工配置 而且在

TKS-764B 调入程序代码时会直接调入配置字节 这样就可以直接配置好用户的时钟 用户在选择除内部

RC以外的配置后 必须存在实际的时钟输入 或者使用仿真头上的时钟振荡源 或者使用用户目标板上的

时钟输入 如果用户选择了非内部 RC 振荡但外部并没有时钟输入 这时 TKS-764B 不能进行任何运行动

作 包括单步 全速等 但是可以查看和修改内部的任何资源  

 

6.5  用户使用外部电压的问题 

 

TKS-764B 在缺省时为使用仿真器内部的+5V 电源 这样处理时 TKS-764B 最为稳定可靠 但是

TKS-764B也支持外部电源 电压范围为 2.7V-5.5V 需要指出的是 使用外部电源对仿真器来讲具有很多

不可预知的因素 可能会带来一些不稳定的情况 因此建议用户尽量使用仿真器内部提供的电源  

需要注意的是 为了保证内部 BondOut芯片的可靠工作 外部电源必须在 2.7V到 5.5V之间 小于 2.7

伏外部电源将不被使用 大于 5.5V将会引起内部保护电路的启动 如果用户在调试过程中切换电源 当前

仿真器芯片内部的状态将会被破坏 电源转换结束后仿真器内部 BondOut仿真芯片处于复位后的状态 用

户在电源转换完成后还需要按动一下复位按钮通知仿真软件 另外在切换电源过程中 用户已经调入的程

序代码在一些极特殊的条件下可能会改变  

 

6.6   调试过程中信息的显示 

 

在使用 TKS-764B 进行仿真时 仿真器会向 Keil 发送执行的状态数据 并在 Keil 的信息输出窗口显

示出来 用户打开工程文件后 如果发现信息输出窗口没有打开 可以通过菜单 View->Output Window打

开 信息显示的种类有  

 

主状态显示 

 

在进入仿真状态后 第一次运行 Run会显示当前仿真器的主要配置 如看门狗的开启 复位引脚的使

用 掉电电压的选择 时钟的选择等  

 

出错显示 

 

当运行当前用户程序出错时显示出错的原因 在以下情况下用户会接收到出错信息  

z 运行过程中外部时钟消失或者频率过高而无法使用  

z 用户定义了使用外部时钟但是运行时 TKS-764B没有发现  

z 当前用户的程序位于一个不合法的位置 例如超出了 4K程序空间  

 

 

 

 

 

 

 

 

 

图 6.2 操作信息输出窗口 
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七 TKS-764B的物理结构 
 
 

 

 

                                            监控指示 LED灯  

                                            运行指示 LED灯 

                                            电源指示 LED灯 

 

         仿真电缆插头                                       串口插座 

 

                                                          电源插座 

                              

 

图 7.1  TKS-764B平面图 顶部俯视  

 

z 监控指示 LED灯  点亮表示处于监控状态  

z 运行指示 LED灯  点亮表示进入运行状态  

z 电源指示 LED灯  点亮表示系统电源正常  

z 仿真电缆插头  插入仿真电缆连接到仿真头  

z 串口插座   插入串口通讯电缆连接到计算机  

z 电源插座   输入仿真器主机工作需要的电源  
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八 仿真头组件的使用 
 

TKS-764B 仿真器通过仿真电缆与仿真头组件连接 然后再通过仿真头上的金属插针插入到用户目标

板上进行仿真 仿真头组件包含以下附件  

 

仿真头电缆插座 

用户测试接地端                                                       外部电源指示 

                                           

                                                                    20脚仿真插座 

振荡板                               

左                晶振插座 

 

图 8.1 仿真头结构示意图 正面俯视  

z 仿真头主板 

 

仿真头电缆插座 使用时用仿真电缆连接仿真器和仿真头  

用户测试接地端 用户在进行测试时 可以使用该端作为地参考点  

振荡板 如果您选择了高/中/低频晶振/外部时钟 您必须将振荡板插入仿真头主板 并在晶振插座位

置插入合适频率的晶振  

仿真 20脚插座 用于连接仿真器和用户目标板  

外部电源指示 如果仿真头 Pin15有电源输入则该 LED点亮  

 

z 仿真电缆 

 

仿真电缆为 20芯扁平电缆      

 

z 振荡板 

 

振荡板是一块单独的 PCB板 用于产生外部时钟 需要时可以插入仿真头主板 注意插入方向  

  振荡板在使用时必须在上面的晶振插座上插入正确频率的晶体  

 

 振荡板的替换 

 

 如果用户对振荡信号有特殊的要求 可以使用用户自己的标准 DIP14封装的 4脚有源晶振插入振荡板

的位置 在插入时注意管脚位置  
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九 TKS-764B仿真器的限制 
 

任何仿真器都不能完全真实的仿真 TKS-764B也不例外 由于 P87LPC76X系列在外设方面的复杂变

化 使完全仿真 P87LPC764更加困难  

 

z TKS-764B要动态地占用 2个堆栈 这种原因是由于 BondOut仿真芯片决定的 建议用户在程序的上

部多预留 2个堆栈的位置  

 

z TKS-764B不能仿真掉电复位 由于 BondOut芯片要求按照规定的时序进行工作 因此对于掉电引起

的 BondOut 芯片复位将是致命的 会引起仿真系统的彻底紊乱 这是因为仿真监控系统无法感知同

BondOut芯片通讯失败是何种原因引起的 在 TKS-764B复位后 仿真监控系统将 AUXR1中的 BOI

位设置为 1 这将禁止掉电复位操作 如果用户确实想使用掉电复位功能 建议用户这样处理 不使

用掉电复位 但是开放掉电中断 在掉电中断处理程序中加入一条软件复位指令 ORL AUXR1 #08H

这样虽然关闭掉电检测复位功能 但是在掉电后仍能通过软件复位达到目的 这种方法是可行的 如

果用户在程序中使用指令开启掉电复位 真正掉电时会引起仿真器死机  
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十 TKS-764B使用中的常见问题 
 
1  TKS-764B同计算机通讯失败 

 
如果出现通讯失败将无法进入硬件仿真 出现这种现象的原因一般是  

z 仿真器同 PC的通讯电缆连接不良  

z 仿真器没有电源  

z 错误的选择了仿真器硬件驱动程序  

z 串口选择错误 或者该串口已经被其它设备占用  

z 计算机串口已经损坏  

z 用户已经进入了硬件仿真 退出仿真环境后又改变了波特率数值 这时重新进入仿真环境后由

于波特率改变而无法通讯 解决的办法是在改变波特率后一定对 TKS-764B重新上电复位  

 

2  单步运行后仿真器会进入 死机 状态 且运行和监控指示灯全部点亮 

 

这种现象一般出现在 C语言调试中 或者 C语言和汇编语言混合调试中 如果当用户当前的源程序窗 

口是 C源程序 但是当前 PC的位置却并没有在 C源程序的有效范围内 单步运行实际上是要求仿真器单

步运行一条 C程序语句 到下一条 C程序语句位置停止 由于当前的 PC位置并没有处于 C的有效位置

因此仿真器只能单步运行每一条汇编程序到下一条 C程序语句位置 如果这期间的汇编语句教多 可能会

耗费较多的时间 仿真器连续的单步运行 不再接收其它命令 好象进入死机状态 连续快速的在单步运

行和监控中切换 所以监控和运行指示灯会全亮  

例如 如果用户当前的 PC=0 这时在 C源程序中不会有程序运行指示 但是在汇编窗口中运行指示 

在 PC=0000H位置 如果用户把当前的窗口点击到 C程序窗口 则仿真器认为下一个单步将运行到 main()

函数位置 在用户要求单步运行后将单步运行 PC=0000H到 main()函数期间的所有汇编指令,可能要耗费较

多的时间  

采用全速运行加断点的方式可以解决这个问题  
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十一 TKS-764B的升级 
 

TKS-764B的用户享受不定期的升级服务 其中包含免费的软件升级 请定期留意我们的主页上的升

级信息 或直接使用技术支持电话询问升级事项  

 

 

十二  结束语 
 

TKS-764B是一款经过精心设计的 51LPC系列单片机仿真器 能最大限度的满足仿真时的各种需求

在近 2000 台 51LPC 系列单片机仿真器销售经验的基础上 推出的 TKS-764B 在硬件上做了全面的改进

在软件上增加了同 Keil软件的接口 使 Keil的用户能在自己熟悉的平台上编译调试程序 这种方法也大大

增加了 TKS-764B的实用性  

51LPC系列单片机虽然是一种性能优良的 51兼容芯片 但是它的 OTP特性使用户全面了解它的有一

定的难度 因此 一种优秀的 LPC仿真器能帮助用户快速准确的熟悉 51LPC系列的性能 减少开发难度

降低开发风险  

我们有上千万美金 51LPC系列单片机芯片的销售成绩 我们对 51LPC系列单片机的了解是全面而准

确的 TKS-764B的用户会得到亚洲最专业的技术支持 无论是 TKS-764B仿真器的使用 还是 51 LPC系

列单片机的应用 如过您遇到任何关于 51LPC系列单片机的问题 请致电我们的技术支持 也可以访问我

们的公司主页( http://www.zlgmcu.com )  
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