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In This Guide…
This guide contains information to use the QC Chart Tool.

1 Basic Tasks

This chapter contains instructions for using QC Chart Tool.

2 Backup and Restore

This chapter describes the steps that you need to take to back 
up and restore the QC Chart Tool Database.

3 Extraction and Queries Pane and Extraction Results Pane

This chapter describes the Extraction Queries and QC Charts 
Pane and the Extraction Results Panes.

4 Reference

This chapter contains reference and concepts information about 
QC Chart Tool.
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1 Basic Tasks
Loading Data
Loading Data

The QC Chart tool needs extractions imported in its database to create 
meaningful metrics and thresholds. Loading the tool with extractions consists 
of extracting the Stats and FEParameter data from the output text files of 
Feature Extraction.

To import Feature Extraction output text files individually

1 Click File > Import Files > FE Files or click Ctrl-F.

2 In the Browse FE Files dialog box, select the Feature Extraction text files 
that you want to load.

3 Click Open to import the extraction data from the selected files.

Figure 1 Browse FE Files dialog box
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Basic Tasks 1
To import files recursively
To import files recursively 

When you import files recursively, all FE.txt files in the selected folder and all 
subfolders below the selected folder are imported.

1 Click File > Import Files Recursively or press Ctrl-R.

2 In the Browse for Folder dialog box, select the folder that contains the data 
files to import. See Figure 2.

3 Click OK to start the import.

Figure 2 Browse For Folder dialog box

A folder containing 2000 Feature Extraction files will take approximately 
15 to 20 minutes to import.

4 Click OK to start the import.

5 If the Invalid File List message box appears, click OK to continue.
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1 Basic Tasks
To import files recursively
This message box appears if any of the files from the selected folders are 
not Feature Extraction output text files.

Figure 3 Invalid File List message box

The import process creates a “row” or “record” for each unique extraction. If a 
bar code has been extracted with various Feature Extraction protocols, these 
will result in unique records, as the extraction name is created from both the 
barcode and the name of the protocol.

Two types of data are imported:

• All Stats fields from the extraction

• Selected FEParameters fields are also imported to help you define queries 
of the extractions (see “Feature Extraction FEParameter fields used in 
QC Chart Tool” on page 61).
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Basic Tasks 1
Associate Annotations
Associate Annotations

You can create annotations for the extractions that exist in the QC Chart Tool 
database and import the annotations with the tool.

Annotations associated with an extraction can be used to filter for that 
extraction in queries. The annotation can also be used to organize data in QC 
charts produced by the QC Chart Tool, for example, to sort extractions, or to 
indicate different subsets of extractions by color- coding or by shape- coding.

You can add annotations by one of three different methods:

• Export all database records, editing and re- importing.

• Export a subset of the database records, editing and re- importing.

• Generate a new tab- delimited text file containing the annotations.

To export all database records for annotations

Once extractions are loaded into the QC Chart Tool database, all barcodes 
(and their associated FEParams and Stats) can be exported in the QC Chart 
Tool. This method will result in the export of every extraction in the database.

1 Click File > Export Database or press Ctrl-A.

The default Export Repository file name is displayed. You can change the 
file name and path before you click Save.

2 Open the text file using a spreadsheet program such as Microsoft Excel.

3 Delete all columns (Stats and FEParameters) other than BarCode and 
user- added annotations.

4 Delete records (rows in Excel) of any barcodes that you do not want to 
annotate.

5 Add additional custom columns (with descriptive column header names in 
the first row) and array annotations within those columns as desired. 

CAUTION The annotation file must contain only the BarCode and any user-added annotation. If it 
contains any of the Stats or FEParams columns, or if it fails to contain the BarCode, you 
will encounter an error.
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1 Basic Tasks
To export all database records for annotations
Column header names must not contain any spaces. The BarCode column 
must be left exactly as exported, or the annotations will not be imported 
correctly. See Table 1.

6 Confirm that Excel has not changed the formatting of the BarCode column. 

7 If the BarCode formatting has changed, change it back to decimal format:

a Select the BarCode column. See Figure 4.

b Click Format > Cells > Number.

c In the Category drop- down list, select Number. See Figure 5.

d In the Decimal places list, select 0.

The BarCodes column will be in the correct format for re- import into the 
QC Chart tool. See Figure 6.

Table 1 Example

BarCode Project Experiment RedSample GreenSample Polarity Comments Stringency

251209751852 STG_1 GE1_Human_June06 h1 h2 1 v4

251209751871 STG_1 GE1_Human_June06 h1 h2 1 v4

251209751873 STG_1 GE1_Human_June06 h1 h2 1 re-scanned v4

251209751882 STG_1 GE1_Human_June06 h2 h1 -1 v4

251209751884 STG_1 GE1_Human_June06 h2 h1 -1 v4

251209751886 STG_1 GE1_Human_June06 h2 h1 -1 v4

251269421651 STG_1 GE2_Mouse_May06 m1 m2 1 trainee Legacy

251269421653 STG_1 GE2_Mouse_May06 m1 m2 1 trainee Legacy

251269421655 STG_1 GE2_Mouse_May06 m2 m1 -1 Legacy

251269421658 STG_1 GE2_Mouse_May06 m2 m1 -1 Legacy

251209751887 CGH_prep Compare 2 preps k1 k2 1 v3

251209751890 CGH_prep Compare 2 preps k1 k2 1 v3
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Basic Tasks 1
To export all database records for annotations
Figure 4 Annotation spreadsheet with incorrectly formatted BarCode numbers

Figure 5 Select Number and 0 as Decimal places in the Format Cells dialog box.
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1 Basic Tasks
To export all database records for annotations
Figure 6 Excel spreadsheet with BarCode column correctly formatted

8 Save the annotation file in tab- delimited- text (TDT) format.

9 If you are warned that the file contains features that are not compatible 
with Text (Tab delimited) format, click Yes to keep the format.

10 In the QC Chart tool, click File > Import> Files > Annotated Extractions 
or press Ctrl-E.

11 Browse to the previously saved TDT file and click Open.
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Basic Tasks 1
To export a subset of records for annotation
To export a subset of records for annotation

A QC database may consist of extractions that have already been annotated, as 
described above. If new extractions are added, you can just export, edit and 
import a subset of those records.

1 Create a query to identify the subset of barcodes which have no annotation.

See “To find blank annotations” on page 21.

2 Export the subset to Excel.

3 Continue in “To export all database records for annotations” on page 11 
at step 2.

If you have previously added annotation, use the exact same column names as 
you used before. For example, if “GreenSample” is used as a column name as 
shown in Table 1, then you need to type that same column name into 
your new annotation spreadsheet. The column names are case- sensitive. If 
you call the column “greensample” or “Green_Sample”, the database will 
see this as a new column and your annotations will be spread over two 
different columns in the database, which makes queries difficult.

To minimize the chance of errors, open a previously saved TDT annotation file 
and copy the column names into your new annotation file.

To generate a new data set of barcodes to be annotated

Do this method of annotation if you only have a few barcodes to annotate.

1 Open a blank Excel worksheet.

2 Type in the BarCode numbers exactly as they appear in the QC database.

3 Continue at “To export all database records for annotations” on page 11 
at step 5.

CAUTION The annotation file must contain only the BarCode and any user-added annotation. If it 
contains any of the Stats or FEParams columns, or if it fails to contain the BarCode, you 
will encounter an error.
Agilent QC Tool v1.3 User Guide 15



1 Basic Tasks
To add annotations to barcodes with multiple entries
To add annotations to barcodes with multiple entries

When you rescan or re- extract an image with different protocols, you may have 
multiple extractions with the same barcode. If you enter these into the 
database, you will have multiple records with the same barcode. If you make 
an annotation file as described in “Associate Annotations” on page 11, the 
database will use the BarCode column as its primary key to connect 
annotations to database records. For this case, all records with the same 
barcode will have the same annotation. If you want to annotate what was 
different about those extractions, then follow these steps.

1 Create a query to identify the subset of barcodes which have no annotation.

See “To find blank annotations” on page 21.

2 Click File > Export Database or press Ctrl-A. 

The default Export Repository file name is displayed. You can change the 
file name and path before you click Save.

3 Open the exported database in a spreadsheet program, such as Excel.

4 Delete all columns except ExtractionName.

5 Add your annotations.

6 Save the annotation file in tab- delimited- text (TDT) format.

7 If you are warned that the file contains features that are not compatible 
with Text (Tab delimited) format, click Yes to keep the format.

8 In the QC Chart tool, click File > Import> Files > Annotated Extractions 
or press Ctrl-E.

9 Browse to the saved TDT file and click Open.

The database now keys off of the extraction name instead of the barcode, so 
each multiple instance of extraction of that same barcode can have a different 
annotation.

Note that this process works only if the extraction names are unique. The 
names will be unique if different FEParam protocols are used. But if you have 
two records because of a rescan, you will need to change the extraction name. 
You do this in two ways:

• Before the extraction, change the name of image in the FE project window, 
or

• After the extraction, and before you import into the QC Chart database, 
change the extraction file name in Windows Explorer.
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Basic Tasks 1
Queries
Queries

The QC Chart tool supports a Query Builder that allows you to select a subset 
of the extractions among the ones available in the QC Chart tool database.

A query is used to define a subset of extractions that define a representative 
data set for use in metric and threshold development. One example is a query 
that contains data only from similar biological samples processed under 
identical conditions. Another example is to query across different types of 
samples or across different processing methods. With the latter example, you 
could then use those different processing annotations to color- code a QC 
Chart. See “Color by” on page 37.

A subset of extractions may be defined in a query by specific FEParameter 
fields, or by user- added annotation fields.

To start the query builder

• Click View > Extraction Query Builder or press Ctrl-Q.

You can also right- click in the Extractions pane and select Add New.
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1 Basic Tasks
To do a basic query
To do a basic query

1 In the Column Name drop- down list, select the parameter to set. (In 
Figure 7, the selected Column Name is ColorMode.)

2 In the Operator drop- down list, select the appropriate operator.

3 In the right- most text box, select the value with which to compare the value 
of the Column Name parameter.

4 Click Add.

5 Click Verify to check that the query is valid.

If the query is valid the Show Results and Save button is enabled.

6 Click Show Results to display the results for the current query. You can 
save the query with any user- defined name.

See Figure 7.

Figure 7 Extraction Query Builder with showing basic query
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Basic Tasks 1
To do a composite query
To do a composite query

1 Create a basic query. See “To do a basic query” on page 18.

2 Click AND or OR.

Use AND to find extractions that meet all criteria. Use OR to find 
extractions that meet at least one criterion.

3 Create the next basic query.

4 To group composite queries, click a query, then click “(” or “)”. Repeat for 
the query at the other end of the group.

5 Click Verify to check that the query is valid.

If the query is valid the Show Results and Save button is enabled.

6 Click Show Results to display the results for the current query. You can 
save the query with any user- defined name.

Figure 8 shows an example of a query that will find all 2- color gene 
expression extractions.

Figure 8 Extraction Query Builder showing a composite query
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1 Basic Tasks
To save a query
To save a query

1 After you create the query, click Show Results to see the resulting 
extractions.

2 In the Enter Name for Query text box, type the name that you want to use 
to save the query.

3 Click Save.

Figure 9 Extraction Query Builder showing a query name
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Basic Tasks 1
To find blank annotations
To find blank annotations

This step is useful to identify extractions that need annotation.

1 In the Column Name list, select a column to search. This column should be 
a user- added annotation field.

2 In the Operator list, select IS NULL.

3 Click Verify.

4 Click Show Results.

The results of the query shown in Figure 10 is displayed in Figure 11 on 
page 22. All records with no Project annotations are displayed.

Once the results are displayed, these results can be exported by right- clicking 
the name of the query and choosing Export results to file. The exported file 
can then be opened and annotated as described in “To export a subset of 
records for annotation” on page 15.

Figure 10 Extraction Query Builder to search for blank annotations
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1 Basic Tasks
To find blank annotations
Figure 11 Results of query in which Project has no annotation.
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Basic Tasks 1
Defining Metric Sets and Thresholds
Defining Metric Sets and Thresholds

Metrics are defined in order for you to track desired statistical values across a 
set of extractions. These metrics can be associated in a metric set. In addition, 
you can use this tool to specify thresholds for each of the metrics.

This Configure Metrics and Thresholds dialog box is used to define metrics, 
metric sets and thresholds. 

To open the Configure Metrics and Thresholds dialog box

• Click Configure > Metrics, or press Ctrl-M.

Figure 12 Configure Metrics and Thresholds dialog box
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1 Basic Tasks
To define metric sets
To define metric sets

A metric set is a collection of one or more metrics and an associated query 
common to all the metrics. 

1 Right- click on the white space below the Metrics Set label. 

2 Choose Add Set.

A new pop- up appears asking the metric- set name. 

3 Select any suitable alphanumeric name.

4 Click OK.

To define metrics

1 In the Configure Metrics and Thresholds dialog box, from the Metric 
drop- down list, select Add New.

The Add Metric dialog box is displayed. The Choose Metric Column drop 
down list shows all available metrics from the FE Stats table. 

2 Select a metric from the Choose Metric Column list, or define a new metric 
as an expression.

Use the operator buttons and type numbers in the Numerical Constant text 
field to create a formula. 

3 Click Validate.

4 In the Metric Name text box, type a name to save the new metric.

5 Click Save.

The new metric now appears in the Metric list of the Configure Metrics and 
Thresholds dialog box.
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Basic Tasks 1
To define metrics
Figure 13 Add Metric dialog box

Example

Feature Extraction calculates a slope for the eQC spike- ins (observed versus 
expected Log Ratio). Depending upon the hybridization, this spike- in mixture 
may be present as “+1” or “- 1” polarity. If it is “- 1”, then any threshold that is 
set (e.g. Slope > 0.85), will not pass. Thus you need to make a derivative metric 
by taking the absolute of the slope. 

To do this:

1 Click Abs. The term Abs(  appears in the Metric Calculation box.
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1 Basic Tasks
To define metrics
2 From the Choose Metric Column list, select the statistic 
QCObsVsExpLRSlope, click Add, then select “)” to finish the expression

3 Validate and save the metric as Abs_eQCSlope.

The new metric now appears in the Metric list of the Configure Metrics and 
Thresholds dialog box, as shown in Figure 14.

Figure 14 Configure Metrics and Thresholds dialog box, with new Metrics listed
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Basic Tasks 1
To associate a metric with a metric set
To associate a metric with a metric set

1 Select a metric set from the Metric Sets navigation pane.

2 Select the metric from the Metric pull- down list to be associated with the 
selected metric set. In Figure 15, Test_1 is selected as the metric set.

3 Assign an Extraction Query to the metric set.

This query will filter for the appropriate extractions from your database, so 
that just the data from the queried extractions will be used in calculation of 
various statistical summary values that may be used in setting thresholds, 
described in “To set thresholds” on page 29. Figure 15 shows GE2 selected 
as the Extraction Query. The metric set will be used with two- color Gene 
Expression extractions.

Figure 15 2-color gene extraction selected to be used with the metric set

4 Click << Add/Update Metric. 

Figure 16 shows the metric Abs_eQCSlope displayed when Test_1 is 
expanded in the Metric Sets pane.
Agilent QC Tool v1.3 User Guide 27



1 Basic Tasks
To associate a metric with a metric set
To assign additional metrics to the metric set, select a different metric from 
the Metric pull- down list, then click <<Add/Update Metric.

Figure 16 Expanded metric set that shows added metric
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Basic Tasks 1
To set thresholds
To set thresholds

If you want to associate a threshold with a given metric, you can do this at the 
same time that the metric is associated with a metric set, or you can be it after 
the association.

1 In the Metric Sets pane, select the metric associated with a metric set.

2 Select the threshold to be associated with the metric:

• None

• Upper Limit

• Range

• Lower Limit

3 Click the tab for the calculation type that you want to use to set the 
threshold:

• Manual Limits

• Standard Limits

• Robust Limits

• Percentile Limits. 

The relevant calculations and their limits are displayed. 

4 Edit the limits as appropriate. The text boxes accept floating point 
constants.

5 In the Configure Metrics and Thresholds dialog box, click 
<< Add/Update Metric to add the chosen metric along with its limits to the 
selected metric- set. 

If the metric is already present then it will be updated with the new limits. 

Examples

In Figure 17, the metric Abs_eQCSlope is already associated with the 
metric set Test_1. The threshold type for the slope is set to Lower Limit, 
and the value for that limit is set to 0.85 using the “Manual” calculation 
type. The threshold value will not be calculated from the extractions 
defined in the extraction query, because it was set manually, not 
dynamically, from the data. Extractions that have an absolute slope lower 
than 0.85 will be flagged.
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1 Basic Tasks
To set thresholds
Figure 17 Threshold set manually for lower limit of 0.85

To flag extractions with a high SD of Negative Control BkSubtractedSignals, 
select the metric NegCtrlSDevBGSubSig, select Threshold Type to Upper Limit, 
select Standard type of calculation with a constant of 3 (multiplier of SD). The 
statistics of the gNegCtrlSDevBGSubSig values of all extractions that are in the 
GE2 extraction query set are calculated. For this example, calculations include 
the mean and the standard deviation. An upper limit is then set as mean + 
3*SD, which is shown to be 18.79 in Figure 18. Because this value is 
dynamically calculated with Standard type of statistics, not manually set, 
the value is grayed out and cannot be edited.
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Basic Tasks 1
To set thresholds
Figure 18 Threshold set for upper limit

If you select the Robust type of calculation, then the median and IQR 
(inter- quartile range) is calculated. Using the IQR, the robust equivalent of SD 
is also calculated.

If you select Percentage type of calculation, then the percentiles that you 
choose are calculated for an upper limit (e.g. 99%), lower limit (e.g. 1%), or 
range (e.g. 99%, 1%).
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1 Basic Tasks
To set the values to be displayed
To set the values to be displayed

If you have imported more extractions after the metric has been created, you 
can determine how values are displayed.

• In the Configure Metrics and Thresholds dialog box:

• Click Display Current Values to display the limits that were saved with 
the latest data, which may differ from the previously saved limits.

• Click Display Saved Values to display the old threshold limits.

To export metric sets

The created metric sets can be exported to an XML file and re- imported in the 
QC Chart tool as well as Feature Extraction. 

1 Right- click a metric set in the Metric Sets pane.

2 Select Export Metric Sets....

To import metric sets

You can import metric sets that have been exported as an XML file, or that 
have been downloaded to your computer from the Agilent Web site at 
http://www.agilent.com/chem/feqcmetrics.

1 Right- click anywhere in the Metric Sets pane.

2 Select Import Metric Set....

3 Browse to the appropriate metric set and click Save.

4 If you are warned that you may be overwriting Threshold settings for the 
matching metrics, click Yes.

You can copy and modify metric sets. You can associate a copied metric set 
with a different extraction query than the parent metric set. See “To copy 
a metric set” on page 34.

You can also modify metric sets, for example, add or remove thresholds, or 
modify thresholds.
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Basic Tasks 1
To set the mandatory and in-range evaluation status for metrics
To set the mandatory and in-range evaluation status for 
metrics

1 Right- click a metric set in the Metric Sets pane in the Configure Metrics 
and Thresholds dialog.

2 Select View Thresholds... The Metric Set dialog box is displayed.

Figure 19 MetricSet dialog box showing two mandatory metrics

3 To define an extraction evaluation, mark the check boxes for the metrics 
that are mandatory. For an extraction to “pass” a metric set with any 
“mandatory” type of metrics, each of the mandatory metrics must be in the 
threshold range.

4 Type the total for the Number of metrics that must be within range.

5 Click Save to save the settings.

Figure 19 indicates that two metrics are mandatory to be in- range. The 
third metric is not required to be in range. You can also specify how many 
metrics must be in range, and which metrics, if any, are mandatory.
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1 Basic Tasks
To remove a metric set
To remove a metric set

1 In the Metric Sets pane of the Configure Metrics and Thresholds dialog box, 
right- click the metric set that you want to remove.

2 Select Remove Set.

If the metric set is associated with any chart then it will still remain in the 
system.

To copy a metric set

1 In the Metric Sets pane of the Configure Metrics and Thresholds dialog box, 
right- click the metric set that you want to copy.

2 Select Duplicate Set.

Metric sets require that a query that is common to all the metrics within the 
set to be assigned with the metrics. But if you need to create metrics 
without associating a query, you can copy the metric set using (none) as the 
query. You can then associate a query later. See Figure 20.

Figure 20 Creating a copy of a metric set with no query associated
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To remove a metric from a metric set
To remove a metric from a metric set

1 In the Configure Metrics and Thresholds dialog box, in the Metric Sets 
pane, select a metric from within a metric set.

2 Click Remove Metric >>. 

To remove a metric globally

1 From the Configure Metrics and Thresholds dialog box, select the metric 
from the Metrics pull- down list.

2 Click the X button next to the name of the metric. The metric will be 
removed from the database.

3 If you are prompted to confirm that you want to delete the metric, click Yes.

If the X button is gray, the metric is associated with one or more metric sets. 
You need to remove the metric from all metric sets with which it is associated 
before you can remove the metric globally.
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Defining a QC Chart
Defining a QC Chart

A chart can be drawn on a metric set for a chosen query. The QC chart can be 
defined in the QC Chart dialog box. 

Figure 21 QC Chart dialog box

To create a new QC Chart

1 Click Configure > QC Chart... to open the QC Chart dialog box.

You can also press Ctrl-W, or right- click on a chart name in the QC Chart tab 
and select Add New from the shortcut menu.

2 Configure the dialog box according to your needs.

The dialog box components are described below.

Metric Set Select the metric set to be used with the QC chart.

Extraction Query Select the extraction query that is to be evaluated to produce a chart.

Sort by Columns Select how you want to order the extractions in the chart.
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To create a new QC Chart
Color by Indicates how the points on the chart are to be color- coded. For example, 
selecting ColorMode creates a chart where all the points that are 1- color are 
one color and points that are 2- color are another color. This list is disabled if 
the Color by in/out of threshold range check box is marked.

Color by In/Out of
Range of

threshold range

Indicates whether to color- code extraction data points depending on whether 
they fall inside or outside the threshold level. Points that are outside the limits 
will be color- coded in red and the ones within the limits will be color- coded in 
blue. All the points are connected by a light- gray line. The ShapeBy and 
ColorBy columns are disabled if this check box is marked.

ShapeBy Indicates what groups are used to differentiate the data points by shape. For 
example, selecting Username causes all the extractions that are from a 
particular user to have the same shape.
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To view the QC chart

1 In the QC Chart tab, right- click a chart name that you want to view, then 
select Show Chart Configuration.

The QC Chart dialog box appears. 

2 Select View Chart. The QC Chart View for MetricSet (“QC Chart”) appears

You can also double- click the name of the QC Chart that you want to view.

Figure 22 QC Chart View for MetricSet

The controls on this dialog box are described below.

Check boxes and buttons over the left Extraction Name Pane

Show Grids Places a grid over the plot.

Scrollable Makes the X- axis scrollable if the number of data points do not fit within the 
screen area.
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To view the QC chart
ZoomIn Activates the zoom function. When the zoom function is active, the Zoom 
button above the QC chart appears active (not gray). You can then drag and 
release the mouse to define the area to zoom. Double- click anywhere in the 
chart to return to normal view.

Use this check box if the Zoom button above the QC chart has scrolled past the 
visible area of the pane. If Zoom icon is inactive, mark the check box to 
activate it. If the Zoom icon is active, clear the check box to inactivate the 
zoom function. If the Zoom icon is inactive, and the check box is already 
marked, clear the check box first and then mark the check box again to active 
the zoom function. 

Export to File Copies the following columns to a TDT file:

• Ordinal

• Number

• ExtractionName

• InRange

• MetricName

• Ismandatory 

• Limits

The columns MetricName, Ismandatory and Limits are repeated as many 
times as the number of metrics in the metric- sets. A sample output is 
show in the Figure 23.

Figure 23 TDT output
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To view the QC chart
Print Extractions Prints the table that is displayed in the left pane, including the X- axis 
numbers and the extraction names. If the PDF check box is marked, the 
entire QC Chart is saved as a PDF file. To print the plots, click the 
Printer button above the QC chart.

PDF When marked, saves both the plots and the extraction table to a PDF file when 
Print Extraction is clicked.

Icons over the chart

Copy as Bitmap Copies the chart to the clipboard as a bitmap which can be pasted in MS Word 
and MS Paint, or in any other appropriate software.

Printer Prints all plots to the printer.

Zoom Indicates whether the zoom function is active. When active (not gray), you can 
zoom in on a chart by using the mouse to drag and release on the area to zoom. 
When the button is gray, click the button to activate the zoom function. Click 
the active button to disable the function. Double- click the chart to return to 
normal view.
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Managing Databases

To export data

You may want to export some or all of the data in your database so that you 
can use the TDT file in Excel, or to use for 3rd party graphing or statistical 
packages, or to send to customer support.

• If you want to export just a subset:

a Create a query to identify the data that you want to export.

b Right- click on that extraction query in the Extractions tab and select 
Export Results to File....

• If you want to export your entire database, then click File > Export 
Database or press Ctrl-A.

To reset the database

• Click Options > Reset Database, or press Ctrl-T.

Running this command clears all the data in the QC Chart tool database.

To remove a database

• Click Options > Remove Database.

• This command deletes the QC Chart database totally. If you want to re- use 
the tool, you have to configure the database as described in “Step 4. 
Configure the QC Chart Tool Database” in the QC Chart Tools v1.3 
Installation and Configuration Guide.
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To remove a database
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Backup and Restore

To back up QC Chart Tool Database 44

To restore the QC Chart Tool Database 45

This chapter describes the steps that are needed to backup and restore the QC 
Chart Tool Database.
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To back up QC Chart Tool Database
To back up QC Chart Tool Database

Back up your database frequently in case you need to restore lost data.

If you previously installed QC Chart Tool v1.3 and Feature Extraction v9.5.3, 
you must back up the QC Chart Tool Database (QCChartDB) before you 
upgrade to Feature Extraction v10.5 or v10.7. Feature Extraction v10.5 and 
v10.7 have a different database schema than FE v9.5.3. If you do not back 
up the QCChartDB before you install Feature Extraction v10.5 or v10.7, all 
data will be lost.

1 Close all windows of QC Chart Tool.

2 Click Start > All Programs > Agilent > Feature Extraction > Tools > 
Backup Restore Utility.

3 In the Data Backup- Restore Utility window, click Browse to choose a local 
directory and type a name for the backup file. For example, you can use a 
file name such as QCChartDB_BackupMMDDYY.

4 Click the Choose database pull down menu and select QCChartDB.

5 Click Backup to save the backup file.
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To restore the QC Chart Tool Database
To restore the QC Chart Tool Database

Do this step if you backed up your database before you upgraded Feature 
Extraction v10.5 or v10.7.

1 Close all windows of QC Chart Tool.

2 Click Start > All Programs > Agilent > Feature Extraction > Tools > 
Backup Restore Utility.

3 In the Data Backup- Restore Utility window, click Browse to select the 
backup file that you saved prior to installing Feature Extraction 9.5.3 or 
later. 

4 Click the Choose database pull down menu and select QCChartDB.

5 Click Restore to restore the data saved from previous database.
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To restore the QC Chart Tool Database
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Extraction and Queries Pane and 
Extraction Results Pane

Extraction and QC Charts Pane - Extractions Tab 48

Extraction and QC Charts Pane - QC Charts Tab 49

Extraction Results Pane 50

This chapter describes the two tabs found in the Extraction and QC Charts 
Pane as well as the Extraction Results Pane.
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Extraction and QC Charts Pane - Extractions Tab
Extraction and QC Charts Pane - Extractions Tab

This pane supports the operations as shown by the figure below. 

To open the shortcut menu, right click the name of an extraction in the 
Extractions tab.

Add New Opens the query builder, similar to clicking View > Extraction Query Builder 
or pressing Ctrl + Q. 

Edit Using
QueryBuilder

Allows you to modify an already created query. The query builder is opened 
with the previously saved query pre- populated.

Delete Deletes the highlighted query from the QC Chart database. 

Execute Executes the query and displays the results in the grid- view on the right. You 
can also double- click the query to execute the query.

Rename Allows you to rename the query.

Export Results to
File...

Exports the query results to a TDT file.
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Extraction and QC Charts Pane - QC Charts Tab
Extraction and QC Charts Pane - QC Charts Tab

This pane supports the operations as shown in the figure below.

To open the shortcut menu, right click the name of a chart in the QC Charts 
tab.

Add New Opens the QC Chart dialog box, which is same a clicking Configuring > QC 
Charts or pressing Ctrl-W.

Show Chart
Configuration

Opens the same dialog as of above but will have the saved configurations 
reflected in the dialog. This option is useful if you want to make minor changes 
to the existing configurations and save it with a different name.

Delete Removes the saved chart along with its configuration. The metric sets and 
queries associated however remain in the QC Chart database.

View Chart Opens the QC Chart View for MetricSet dialog box.

Rename Renames the chart.
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Extraction Results Pane
Extraction Results Pane

The extractions loaded into the QC Chart tool database are displayed in the 
form of a grid- view. See the figure below:

The column- headers appear in this order:

• Barcode

• User Added Annotations

• FE text Params

• FE text Stats

Right- click in the grid to see this menu:
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Extraction Results Pane
Fit Column to
Window

Makes the current column the size of the window. But it doesn’t scroll the 
column so that it is the only one visible in the screen. This option is used to 
resize the column to the size of the results pane.

Best Fit Column
Sizes

Does a best- fit for all the columns given the pane size.

Find in Current
Column

Finds the text in the current column and highlights the found item. To 
consecutively find the next matching item this operation has to be repeated.

Find in All
Columns

Finds the text in the all the columns and highlights the found item. To 
consecutively find the next matching item this operation has to be repeated.
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Extraction Results Pane
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This chapter contains reference information for using QC Chart Tool.
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Overview
Overview

The QC Chart tool is a desktop application that accumulates, aggregates and 
analyzes summary statistics from Feature Extraction output files and optional 
annotation files for the purpose of monitoring microarray processing 
performance. The data is housed in a relational database from which queries 
can be generated and saved to subset the data into user- defined logical 
groupings such as by experiment, by batch, or by date of processing. Using the 
data, metrics can be generated that monitor aspects of the microarray 
processing workflow. Metric sets can be formed that combine metrics that 
monitor different aspects of microarray processing. With metric sets, you can 
plot graphically the results from historical data and generate thresholds for 
the metrics that are appropriate for your experimental conditions and 
processing environment. The metric sets and thresholds can be used in the QC 
Chart tool on a regular basis to monitor processing performance. They can 
also be imported to Feature Extraction software to monitor each array and 
batch as it is processed.

The QC Chart Tool is meant to be used in a production environment where:

• Microarray processing protocols are standardized

• Monitoring run- to- run consistency is an important goal

The QC Chart Tool is provided as an optional accessory to Feature Extraction 
(FE). The software must be installed on a computer with a compatible version 
of FE already functionally installed. QC Chart Tool uses the FE license and 
does not require a separate license to operate. Agilent provides the software 
“AS IS” and any express or implied warranties, including, but not limited to 
any implied warranties of merchantability, satisfactory quality, reasonable 
care and skill, and fitness for a particular purpose are expressly disclaimed. 

For the most recent information on the QC Chart Tool, please go to the Web 
site: http://www.agilent.com/chem/feqcmetrics

This web site will contain updates to the software and this manual as well as 
example metric sets as they become available.
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Objective
Objective

Feature Extraction software can run a batch of arrays to generate a batch 
summary and a quality control report (QC Report) for each microarray. To 
ensure the quality of the array, you should check the QC report of each array. 
QC Chart Tool is used to get a summary of quality of multiple extractions. This 
tool lets you define quality metrics, apply those metric criteria to extraction 
data, and verify quality metrics through QC Charts.

This tool has the following features:

• Ability to have all extractions in a central database. 

• Ability to share central database.

• Ability to annotate extractions with custom annotation.

• Ability to filter extractions by defining queries.

• Defines metrics to monitor quality.

• Defines thresholds for metrics to check performance/quality of extraction.

• Defines metric sets as a set of metrics (with or without thresholds).

• Defines a Quality chart (“QC Chart”) by defining query filters, metric set, 
and chart formatting on extraction set.

• Exports QC Chart data for further use.

• Exports metric set for use in Feature Extraction.
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Application Themes
Application Themes

The QC Chart tool can sport three desktop application themes as shown in the 
figure below. You can check the desired theme for look and feel.

Use of Metric sets in Feature Extraction

Metric sets can be associated with Feature Extraction projects to give 
information to you for each extraction: 

• QC Chart showing value of each metric for each extraction

• whether metrics are within range (if thresholds are set)

• whether extraction is within range (if evaluation metric has been set)

You can export a metric set so that it can used by Feature Extraction. In the 
Feature Extraction UI, locate the QC Metric Set Browser pane. If it is not 
visible, click View > QC Metric Set Browser. Right- click in the pane and select 
Import and browse to the desired metric set. After import, double- click on the 
metric set to see the metrics, any thresholds and any mandatory metrics that 
are defined by this metric set.
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Use of Metric sets in Feature Extraction
Once a metric set has been imported into Feature Extraction, it is available to 
be associated with any Feature Extraction project. To associate a metric set 
with a project, choose the desired metric set from the drop down box QC 
Metric Set in the Other section of the Feature Extraction Project Properties 
tab.
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Use of Metric sets in Feature Extraction
Figure 24

When this project is run, the metric set will be used to yield the following 
output:

1 QC Chart: a run- chart type view showing values for metrics for each 
extraction.

a Chart visible on screen showing all extractions on X- axis with value of 
metric on Y- axis. If there are multiple metrics in the metric set, the plots 
will be stacked.

b The QC Chart can be printed or saved as text file. It is also saved by 
Feature Extraction as a PDF file.

c The key showing where barcodes are plotted along the X- axis can also be 
printed.
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2 Project Run Summary: new information.

a If thresholds are associated with the metric set, will show how many 
metrics were in range for each extraction

b If an evaluation metric was associated with the metric set, will show if 
the extraction is in range, or needs evaluation by you

3 QC Report: new information

a Header: If thresholds are associated with the metric set, will show how 
many metrics were in range for each extraction

b At the bottom of the QC Report, will show a table listing each metric and 
the value calculated for that extraction

c If thresholds are associated with the metric set, will show:

• Value of threshold

• Color- code which metrics were in range

• Whether or not the metric was set as mandatory if an evaluation criteria 
was set.
Agilent QC Tool v1.3 User Guide 59



4 Reference
Overview of Feature Extraction & QC Chart Tool Connection
Overview of Feature Extraction & QC Chart Tool Connection
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Feature Extraction FEParameter fields used in QC Chart Tool

• BarCode

• ExtractionName

• UserName

• ExtractionTime

• ComputerName

• Version

• ScanFileName

• PatternName

• DesignFileName

• Protocol_Name

• Protocol_Date

• Scan_ScannerName

• Scan_Date

• QCReportType

• ColorMode

• Scan_NumChannels

• Scan_MicronsPerPixelX

• Scan_MicronsPerPixelY

• Grid_Name

• Grid_Date

• Grid_NumRows

• Grid_NumCols

• Grid_NomSpotWidth

• Grid_NomSpotHeight
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Feature Extraction FEParameter fields used in QC Chart Tool
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