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In This Guide…
This guide contains information to learn to use your Agilent 
MassHunter Workstation Software Reporting Add-in. 

Exercise 1 Creating Reports

In this exercise, you produce reports using the Qualitative 
Analysis program and the Quantitative Analysis program. In the 
Qualitative Analysis program, you select what sections to 
include in the reports. In the Quantitative Analysis program, 
you learn about the many different templates that are available.

Exercise 2 Customizing a template

In this exercise, you learn how to customize both a Qualitative 
Analysis template and a Quantitative Analysis template. You 
make a copy of the template, open it in Excel, change the footer 
of the template, test the template, save the template and use the 
template in the Qualitative Analysis and the Quantitative 
Analysis programs.

Exercise 3 Customizing a table

In this exercise, you customize a table. You learn how to rename 
a column, delete a column, change the width of a column, and 
move a column. You also learn how to add a column to a table 
and how to add a mapped column to a table. In addition, you 
learn how to add a filter to a table using Excel features and 
using the Advanced Properties dialog box. Lastly, you learn how 
to move or delete a column in a table that has been filtered.

Exercise 4 Additional ways to customize a table

In this exercise, you learn how to do the following tasks:

• Add a table 

• Format a table (transpose and hide headers)

• Add a formula column

• Add an ISTD column to a Quantitative Analysis template

• Add a column that is already mapped
Agilent MassHunter Workstation Software Reporting Familiarization Guide 3



Exercise 5 Graphics

In this exercise, you use the Add Graphics commands to add 
graphics to a template. You also learn how to display multiple 
graphics in the same row.

Exercise 6 Advanced topics

In this exercise, you do a variety of advanced tasks including:

• Adding a page break and a sheet break

• Setting up and using Test mode

• Adding repeating sections

• Changing values in the Options worksheet

• Adding a formula using the IF function

• Using the VLOOKUP function.
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In this exercise, you explore how reports are generated in different programs.

The first exercise shows you the steps to create a report in the Qualitative 
Analysis program.

• In Task 1, you open the Qualitative Analysis program with multiple data 
files.

• In Task 2, you print an analysis report.

• In Task 3, you print a compound report.

• In Task 4, you print a graphics report.

The second section shows you the steps to create a report in the Quantitative 
Analysis program.

• In Task 5, you open the Quantitative Analysis program and load a batch.

• In Task 6 and Task 7, you generate Quantitative Analysis reports.
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1 Creating Reports 
Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Creating Reports 1
Creating reports in the Qualitative Analysis program
Creating reports in the Qualitative Analysis program

Increasing Speed of Qualitative Analysis Report Generation

One of the easiest ways to increase the speed of report generation is by 
limiting the number of graphics in the template. You can change which 
graphics are included in a report using either the Analysis Report section in 
the Method Editor or the Compound Report section in the Method Editor.

You can also try any of the following options to improve reporting speed:

• Filter for only the samples or compounds that you need to report. See 
“Task 7. Add a filter to a table” on page 74.

• Turn off any unneeded formatting options. See “Task 5. Change values on 
the Options worksheet” on page 135.

• Delete unused XML maps. See “Task 1. Add a table to a template” on 
page 86.

• Limit VLOOKUP ranges to the minimum. See “Task 7. Use the VLOOKUP 
function” on page 142.

• Print on a standalone system, if possible.

• If you are printing to a networked printer, set the Microsoft Image Writer 
as the default printer.
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1 Creating Reports 
Task 1. Open the Qualitative Analysis program
Task 1. Open the Qualitative Analysis program

In this task you open multiple data files using the current method.

 

Task 1. Open the Qualitative Analysis program with multiple data files 

Steps Detailed Instructions Comments

1 Open the Qualitative Analysis 
program and open the data files, 
sulfas-PosAutoMSMS, 
sulfas-PosMS.d and 
sulfas-PosTargetedMSMS.d in 
the folder 
\MassHunter\Data, or in the 
folder where you copied them.

a Double-click the Agilent MassHunter 
Qualitative Analysis icon, . 
The system displays the Open Data 
Files dialog box.

b Go to the folder \MassHunter\Data 
or the folder where the example files 
are located.

• The sulfas-PosMS.d file contains 
MS (TOF or Q-TOF) data, and the 
sulfas-PosAutoMSMS.d and 
sulfas-PosTargetedMSMS.d files 
contain both MS and MS/MS 
(Q-TOF) data.

• You can get help for any window, 
dialog box, or tab by pressing the F1 
key when that window is active.

• Make sure that Use current 
method is clicked.

• Make sure that the check box for 
Run ‘File Open’ actions from 
selected method is clear.

Figure 1 The Open Data File dialog box is automatically opened.
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Creating Reports 1
Task 1. Open the Qualitative Analysis program
c Press and hold the Shift key while you 
click sulfas_PosAutoMSMS, 
sulfas_PosMS.d and 
sulfas-PosTargetedMSMS.d.

d Click Open.
All three data files are displayed in 
Data Navigator, and 3 chromatograms 
are displayed in the Chromatogram 
Results window.

• If you press the Ctrl key instead, 
you can pick files which are not 
directly next to each other in the 
list.

• What you see in the main window 
at this point depends on the 
method, layout, display and plot 
settings used before you opened 
these files.

Figure 2 Qualitative Analysis main window

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments
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1 Creating Reports 
Task 1. Open the Qualitative Analysis program
2 Return the main window to its 
default workflow, General. The 
default method and layout are 
loaded.
• Make sure you can see all three 

chromatograms.

a If necessary, click Tools > Configure 
for Workflow > General.

b Click the down arrow next to the 
Maximum Number of List Panes icon 
in the Chromatogram Results Toolbar, 
and select 3.

• The display and plot settings will 
remain the same even after you 
switch to the General workflow. 
These settings differ depending on 
your specific situation.

• You can change the layout by 
clicking the View > Window 
Layouts > Load Layout command.

Figure 3 Qualitative Analysis main window with the General Workflow selected

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments

Maximum Number of 
List Panes icon

To load the default 
display and plot 
settings, click Tools > 
Plot Display Options.

The default method 
and layout are loaded.
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Creating Reports 1
Task 2. Print an analysis report
Task 2. Print an analysis report

Whenever you want to print an analysis report after performing any of the 
tasks in this exercise or the next one, use these instructions. 

An analysis report can contain the results from extracting and integrating 
chromatograms, extracting spectra, finding compounds, searching the 
database for peak spectra or generating formulas from peak spectra. 

Task 2. Print an analysis report 

Steps Detailed Instructions Comments

1 Save the intermediate report files. a Click Tools > Intermediate Report 
Files.

b Mark the Keep intermediate report 
directories check box.

c Click OK.

• Normally, intermediate report 
directories are not kept. However, 
when you are customizing a report, 
you use these files to verify any 
changes that you make to the 
templates.

• After you have finished customizing 
your report templates, remember to 
clear the Keep intermediate report 
directories check box.

2 Change the analysis report 
selections:
• Mark the check boxes for the 

chromatograms, spectra or 
tables you want to print.

• Clear the check boxes for the 
chromatograms, spectra or 
tables you do not want to print.

a In Method Explorer, click General > 
Analysis Report.

b Mark the check boxes for any 
additional sections you want to print.

c Clear any chromatogram and spectra 
choices you do not want to print.

• A section in a report is only included 
if:
• You mark the check box in this 

section.
• The results are available in the 

Qualitative Analysis program. For 
example, if you have not 
integrated the chromatogram, 
then the peak table cannot be 
included. 

• If you are keeping the intermediate 
report directories to customize a 
template, you mark all of these 
check boxes. You also need to 
generate all of these results. Then, 
all results are available when you 
are customizing a template.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 13



1 Creating Reports 
Task 2. Print an analysis report
Figure 4 Analysis Report section in the Method Editor

3 Select the template to use when 
printing this report.

a In Method Explorer, click General > 
Common Reporting Options.

b Verify that the correct Report template 
folder is selected.

c Verify that the correct Analysis report 
template is being used.

d Click the Options tab.
e Verify the settings on this tab. 

• The report templates that are 
shipped with the software are 
separated into two folders. One 
folder contains reports that are 
formatted to print on Letter size 
paper. The other folder contains 
reports that will print on A4 size 
paper.

• Three different analysis report 
templates are available in each 
folder.

Task 2. Print an analysis report (continued)

Steps Detailed Instructions Comments

Before printing the analysis 
report, you generate the results 
that you want to include. For 
example, if you want to include 
compound chromatograms, you 
need to run one of the Find 
Compounds algorithms.

If you want to increase the speed of 
printing a report, remove any 
unnecessary graphics. Including 
graphics in a report slows down 
report generation.
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Creating Reports 1
Task 2. Print an analysis report
Figure 5 Common Reporting Options > Options tab in the Method Editor window

4 Print the report. • You can interactively print the report in 
multiple ways:
• From the main menu, click File > 

Print > Analysis Report.
• From the main toolbar, click the 

Printer icon.
• Click the Print Analysis Report icon, 

 in the Method Editor 
toolbar.

• Right-click the Analysis Report 
section in the Method Editor, and 
click Print Analysis Report.

• From the data file shortcut menu in 
the Data Navigator, click Print 
Analysis Report.

• Click Generate Analysis Report in 
the Actions menu.

The Run icon  in the Method 
Editor toolbar sometimes allows you to 
choose an action from a set of 
possible actions. For example, if you 
switch to the General > Common 
Reporting Options section, four 
different actions are possible when 
you click the Run icon. If you click the 
arrow, a list of possible actions is 
shown, and you can choose which 
action to do. Choosing a different 
action from the list changes the 
default action. If you simply click the 
Run button, the default action is 
performed.

Task 2. Print an analysis report (continued)

Steps Detailed Instructions Comments

You can specify the plot limits to 
use in the report for each type of 
graphic.

Mark this check box if you do 
not want to include empty 
columns in any table in the 
report.
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1 Creating Reports 
Task 3. Print a compound report
Task 3. Print a compound report

In this task, you generate a compound report. Please refer to the 
Familiarization Guide for Qualitative Analysis or the online Help for the 
Qualitative Analysis program for information on finding compounds.

Task 3. Print a compound report 

Step Detailed Instructions Comments

1 Save the intermediate report files. a Click Tools > Intermediate Report 
Files.

b Mark the Keep intermediate report 
directories check box.

c Click OK.

• Normally, intermediate report 
directories are not kept. However, 
when you are customizing a report, 
you use these files to verify any 
changes that you make to the 
templates.

• After you have finished customizing 
your report templates, remember to 
clear the Keep intermediate report 
directories check box.

2 Change the compound report 
selections:
• Run one of the Find Compounds 

algorithms
• Mark the check boxes for the 

chromatograms, spectra or 
tables you want to print.

• Clear the check boxes for the 
chromatograms, spectra or 
tables you do not want to print.

a Click File > Open Data File to load a 
data file.

a Click one of the commands in the Find 
menu to find compounds.

b In Method Explorer, click General > 
Compound Report.

c Mark the check boxes for any 
additional sections you want to print.

d Clear any chromatogram and spectra 
choices you do not want to print.

• Only sections that are marked in the 
Compound Report tab are included 
in the report.

• A section in a report is only included 
if:
• You mark the check box in this 

section.
• The results are available in the 

Qualitative Analysis program. For 
example, if you have not found 
compounds, then the compound 
table cannot be included. 

• If you are keeping the intermediate 
report directories to customize a 
template, you mark all of these 
check boxes. You also need to 
generate all of these results. Then, 
all results are available when you 
are customizing a template.
16 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Creating Reports 1
Task 3. Print a compound report
To increase the speed of creating a 
report, remove any unnecessary 
graphics. Including graphics in a 
report slows down the creation of 
reports.

Figure 6 Compound Report tab in the Method Editor

3 Select the template to use when 
printing this report.

a In Method Explorer, click General > 
Common Reporting Options.

b Verify that the correct Report template 
folder is selected.

c Verify that the correct Compound 
report template is being used.

d Click the Options tab.
e Verify the settings on this tab. 

• The report templates that are 
shipped with the software are 
separated into two folders. One 
folder contains reports that are 
formatted to print on Letter size 
paper. The other folder contains 
reports that will print on A4 size 
paper.

• Several different compound report 
templates are available in each 
folder.

Task 3. Print a compound report 

Step Detailed Instructions Comments
Agilent MassHunter Workstation Software Reporting Familiarization Guide 17



1 Creating Reports 
Task 3. Print a compound report
4 Print the report.
• Preview the report.

a Click the arrow in the  icon and 
select Print Compound Report to print 
the report.

b In the Print Compound Report dialog 
box, click All results.

c Mark Print report.
d Mark Print preview.
e (optional) Select the Printer name to 

use. If you want to print the report to a 
printer, you select the printer to use in 
this dialog box.

f Click OK.

• You also can print a compound 
report by doing any of the following:
• Right-click the Compound Report 

section in the Method Editor, and 
click Print Compound Report.

• Click File > Print > Compound 
Report.

• Click Generate Analysis Report 
in the Actions menu.

• You can also create a PDF file by 
marking the Save report as PDF file 
check box. This option only works if 
you installed the Microsoft Excel 
PDF Add-in after installing Excel.

This button closes the 
Print Preview window 
without sending the 
report to the printer.

Figure 7 The Print Preview window showing the Compound Report 

5 Close the Print Preview window. a Click Close Print Preview in the 
toolbar.

• If you want to print the report, click 
the Print button. The report prints 
on the printer selected in the Print 
Compound Report dialog box.

Task 3. Print a compound report 

Step Detailed Instructions Comments
18 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Creating Reports 1
Task 4. Generate a graphics report
Task 4. Generate a graphics report

In this task, you generate a graphics report. This report is generated when you 
click Print in the shortcut menu in one of the graphics windows. 

Task 3. Print a graphics report 

Step Detailed Instructions Comments

1 Save the intermediate report files. a Click Tools > Intermediate Report 
Files.

b Mark the Keep intermediate report 
directories check box.

c Click OK.

• Normally, intermediate report 
directories are not kept. However, 
when you are customizing a report, 
you use these files to verify any 
changes that you make to the 
templates.

• After you have finished customizing 
your report templates, remember to 
clear the Keep intermediate report 
directories check box.

2 Select the folder to use when 
printing this report.
• You can select the folder to use.
• A graphic report always uses 

either the template graphic.xltx 
or graphicfullpage.xltx. 

a In Method Explorer, click General > 
Common Reporting Options.

b Verify that the correct Report template 
folder is selected.

• The report templates that are 
shipped with the software are 
separated into two folders. One 
folder contains reports that are 
formatted to print on Letter size 
paper. The other folder contains 
reports that will print on A4 size 
paper.

3 Print a graphics report. a Right-click the Chromatogram Results 
window and click Print.

b In the Print dialog box, click All 
chromatograms.

c Clear the One chromatogram per page 
check box.

d Select the Printer name.
e Mark the Print Preview check box.
f Click the Options tab.
g Review the settings.
h Click OK.

• You can only print a graphic if a 
graphic is currently showing in the 
Qualitative Analysis program.

• You can print a graphics report from 
any of the graphics windows 
including:
• Chromatogram Results window
• Spectrum Preview window
• MS Spectrum Results window
• Deconvolution Results window
• UV Spectrum Results window

• If the One chromatogram per page 
check box is marked, then the 
graphicfullpage.xltx template is 
used.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 19



1 Creating Reports 
Task 4. Generate a graphics report
Figure 8 The Print and Options tab in the Print dialog box

This button closes the 
Print Preview window 
without sending the 
report to the printer.

Figure 9 The Print Preview window showing the Plot Window Report 

4 Close the Print Preview window. a Click Close Print Preview in the 
toolbar.

• If you want to print the report, click 
Print. The report is printed on the 
printer selected in the Print 
Compound Report dialog box.

Task 3. Print a graphics report 

Step Detailed Instructions Comments
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Creating Reports 1
Creating reports in the Quantitative Analysis program
Creating reports in the Quantitative Analysis program

Increasing Speed of Quantitative Analysis Report Generation

One of the easiest ways to increase the speed of report generation is by 
selecting a template that does not include a lot of graphics. Many templates are 
included with the Quantitative Analysis program. Some of these templates 
include graphics, and some do not. Reports that do not include graphics print 
more quickly. If possible, select a template that does not include graphics. 
Many of the templates that do not include graphics are in the ESTD/Results 
folder, the ISTD/Results folder and the LIMs folder.

You can also try any of the following options to improve reporting speed:

• Filter for only the samples or compounds that you need to report. See 
“Task 7. Add a filter to a table” on page 74.

• Turn off any unneeded formatting options. See “Task 5. Change values on 
the Options worksheet” on page 135.

• Delete unused XML maps. See “Task 1. Add a table to a template” on 
page 86.

• Limit VLOOKUP ranges to the minimum. See “Task 7. Use the VLOOKUP 
function” on page 142.

• Print on a standalone system, if possible.

• If you are printing to a networked printer, set the Microsoft Image Writer 
as the default printer.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 21



1 Creating Reports 
Task 5. Open a batch in the Quantitative Analysis program
Task 5. Open a batch in the Quantitative Analysis program

In this task you open a batch file that you created previously. 

 

Task 5. Open the Quantitative Analysis program 

Steps Detailed Instructions Comments

1 Open the Quantitative Analysis 
program and then open a batch file.
• Select either the default batch or 

the batch you created if you did 
the exercises in the Quantitative 
Analysis Familiarization Guide.

a Double-click the Agilent MassHunter 
Quantitative Analysis (QQQ) icon 

. 
b Click File > Open Batch.
c Navigate to the folder \Your Directory

\DrugsOfAbuse\. 
d Select a batch. You can select either 

DrugsOfAbuseDemo.batch.xml of 
iii_Test_01. 

e Click Open.

• You can also start the program by 
clicking Programs > Agilent > 
MassHunter Workstation > 
Quantitative Analysis (QQQ) from 
the Start menu.

• Several different Quantitative 
Analysis icons are shown on the 
desktop. You select the one that 
matches your data type. For these 
examples, select the QQQ icon.

• You can get help for any window, 
dialog box, or tab by pressing the F1 
key when that window is active.

Figure 10 Open a batch file
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Creating Reports 1
Task 5. Open a batch in the Quantitative Analysis program
2 Analyze the batch, and inspect the 
results for each compound.
• Examine the Quantitation 

Message(s), which identify 
samples with no quantitated 
signals. 

• Save the batch to the file 
iii_Report_01, where “iii” are 
your initials.

a Click  in the 
toolbar to start batch analysis.

b Pass the mouse cursor over the 
quantitation message for Sample 1.

c Pass the mouse cursor over the flags 
for the first 2 calibration standards.

d Click File > Save Batch As.
e Type iii_Report_01.
f Click Save.

• Note that two calibration standards 
contain outlier data. Outlier data is 
data that is not in the range that you 
set as acceptable.

Figure 11 Quantitative Analysis program after analyzing batch

Task 5. Open the Quantitative Analysis program (continued)

Steps Detailed Instructions Comments
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1 Creating Reports 
Task 6. Generate quantitation reports using the standard dialog box
Task 6. Generate quantitation reports using the standard dialog box

In this task, you generate ISTD report using the one of the provided ISTD 
templates. You use the standard Report dialog box.

Task 6. Generate quantitation reports using the standard dialog box

Steps Detailed Instructions Comments

1 If necessary, open the batch file 
iii_Report_01.batch.xml. 
• If the batch is already open, skip 

to step 2.

a To start the Quantitative Analysis 
program, click the Quantitative 
Analysis (QQQ) icon on your Desktop.

b Click Open Batch  on the toolbar to 
display the Open Batch dialog box.

c Navigate to \Your Directory\
DrugsOfAbuse and select 
iii_Test_01.batch.xml.

d Click Open.

• You can also start the program by 
clicking Programs > Agilent > 
MassHunter Workstation > 
Quantitative Analysis (QQQ) from 
the Start menu.

• If the default layout is not shown, 
click Restore Default Layout on the 
toolbar before opening the batch. 

2 Select report options.
• The first template is 

Quantreport_ISTD_ResultsSum
mary_B_04_00.xltx

• The Reports folder should be \
Your Directory\
DrugsofAbuse\QuantReports.

• The default filename is 
iii_Test_01, where “iii” are your 
initials.

a Click Report > Generate. 
The system displays the standard 
Report dialog box.

b Click .
c Navigate to the Letter\ISTD\Results 

folder.
d Select 

Quantreport_ISTD_ResultsSummary_
B_04_00.xltx and click Open.
The program adds the template to the 
Template file field in the Reports pane.

e Specify the default destination 
directory for saving Excel reports in the 
Report folder text box; for example, 
\Your Directory\DrugsOfAbuse\
QuantReports\iii_Test_01.

f Mark the Start Queue Viewer check 
box.

g Click the Batch report button.

• You can only add one report at a 
time using the standard Report 
dialog box.

• The report is automatically printed 
to the default printer.
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3 Generate the report.
• View the status of the report 

generation in the Task Queue 
Viewer.

a Click OK in the Report dialog box to 
generate the report.

b Click Report > Queue Viewer to 
monitor the report generation process.
The system displays the Task Queue 
Viewer program.

c Watch the progress of the report in the 
Status column. 

• One job is added to the queue. The 
reports are printed in the order 
requested. You can see the status of 
the reports in the Queue Viewer 
program.

Task 6. Generate quantitation reports using the standard dialog box

Steps Detailed Instructions Comments
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Task 6. Generate quantitation reports using the standard dialog box
When the Status column changes to 
“Done”, the report is finished. 

d Close the Task Queue Viewer 
program.

Task 6. Generate quantitation reports using the standard dialog box

Steps Detailed Instructions Comments
26 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Creating Reports 1
Task 7. Generate quantitation reports using the advanced Report dialog boxes
Task 7. Generate quantitation reports using the advanced Report 
dialog boxes

In this task, you generate ISTD and compound reports using the 
corresponding templates. You use the advanced Report dialog boxes. You use 
the advanced Report dialog boxes if you want to do any of the following:

• Specify a different printer than the default printer.

• Re-use existing graphics files.

• Specify a different numeric format for graphics than the default format.

• Create a separate report for each sample.

• Include only some of the samples in the report.

• Include only some of the compounds in the report.

Task 7. Generate quantitation reports using the advanced Report dialog boxes

Steps Detailed Instructions Comments

1 If necessary, open the batch file 
iii_Report_01.batch.xml. 
• If the batch is already open, skip 

to step 2.

a To start the Quantitative Analysis 
program, click the Quantitative 
Analysis (QQQ) icon on your Desktop.

b Click Open Batch  on the toolbar to 
display the Open Batch dialog box.

c Navigate to \Your Directory\
DrugsOfAbuse and select 
iii_Test_01.batch.xml.

d Click Open.

• You can also start the program by 
clicking Programs > Agilent > 
MassHunter Workstation > 
Quantitative Analysis (QQQ) from 
the Start menu.

• If the default layout is not shown, 
click Restore Default Layout on the 
toolbar before opening the batch. 

2 Start to generate a report using the 
advanced Report dialog boxes.
• The destination directory should 

be \Your Directory\
DrugsofAbuse\QuantReports.

• The default filename is 
iii_Test_01, where “iii” are your 
initials.

a Click Report > Generate. 
The system displays the standard 
Report dialog box.

b Click Advanced.
c Click Generate report results file.

• If you want to generate a new report 
using existing report results and 
graphics files, you click Use 
existing report results file/report 
graphics file.

• You can also specify the Instrument 
Type determining numeric formats 
in graphics files. This value is used 
to determine how many decimal 
places to show in the graphics.
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3 Select the instrument type to use 
when generating the report.
• The DrugsOfAbuse batch was 

generated on a Triple Quadrupole 
instrument. You select QQQ for 
this batch.

a Mark Generate graphics files.
b Select QQQ for the Instrument type 

determining numeric formats in 
graphics files.

c Click Next.

• If you mark the Load graphics 
settings file check box, you can 
load the graphics settings file that 
you saved in the Quantitative 
Analysis program.

• You can also load a Fixed Graphics 
File. This file includes limits to use 
for the X and Y axis for the report. 
You can set different limits for 
different compounds.

Task 7. Generate quantitation reports using the advanced Report dialog boxes

Steps Detailed Instructions Comments
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Task 7. Generate quantitation reports using the advanced Report dialog boxes
4 Add two templates.
• The first template is 

Quantreport_ISTD_ResultsSum
mary_B_04_00.xltx

• The second template is 
QuantReport_ISTD_
ResultsByCompound_FAST_B_
04_00.xltx.

• Make sure the report name is 
TemplateName.xlsx, where 
TemplateName is the exact 
name of the template.

a Click Add under Reports. The system 
displays the Open dialog box. 

b Navigate to the Letter\ISTD\Results 
folder.

c Select 
Quantreport_ISTD_ResultsSummary_
B_03_01.xltx and click Open.
The program adds the template to the 
Template field in the Reports pane.

d In the Report File Name column in the 
Reports table, verify that the template 
is 
QuantReport_ISTD_Results_B_03_01
.xlsx.

e Select a printer for this report. 
f Click Add under Reports. The system 

displays the Open dialog box. 
g Select 

Quantreport_ISTD_ResultsByCompou
nd_FAST_B_04_00.xltx. Click Open.

h Verify that the template is 
QuantReport_ISTD_Results_B_03_01
.xlsx.

i Select a printer for this report. 
j Click Next.

• Note that the B_03_01 designation 
corresponds to the Quantitative 
Analysis software release, which 
will change over time. Therefore, 
the report file names may change 
correspondingly.

• If you want to print to A4 paper, 
navigate to the A4 folder.

• Templates are separated into the 
following folders:
• ESTD
• ISTD
• LIMs
• Method
• misc
• Outliers - this folder contains 

several folders for the different 
types of outliers.

• UnknownsAnalysis

Task 7. Generate quantitation reports using the advanced Report dialog boxes

Steps Detailed Instructions Comments

The Report File Name is filled in 
automatically.

You select a printer for each 
template.
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Task 7. Generate quantitation reports using the advanced Report dialog boxes
5  Specify which samples and 
compounds to include in the 
report.
• Select the Batch report option.
• Select All samples.
• Select All compounds.

a Click Batch report.
b Mark All samples.
c Mark All compounds.

• You can create a separate report for 
each sample by clicking Single 
sample report.

You can choose to print only some 
of the samples or some of the 
compounds. If you mark either of 
the check boxes, the appropriate 
dialog box is displayed to let you 
choose the samples or 
compounds to include.

6 Generate the reports.
• View the status of the report 

generation in the Task Queue 
Viewer.

a Click Finish in the Report dialog box to 
generate the report.

b Click Report > Queue Viewer to 
monitor the report generation process.
The system displays the Task Queue 
Viewer program.

c Watch the progress of the report in the 
Status column. 

• Only one job is added to the queue 
which will print both reports. The 
reports are printed in the order 
requested. You can see the status 
of the reports in the Queue Viewer 
program.

d Close the Task Queue Viewer program.

Task 7. Generate quantitation reports using the advanced Report dialog boxes

Steps Detailed Instructions Comments
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Agilent MassHunter Workstation Software Reporting
Familiarization Guide
Exercise 2
Customizing a template

Task 1. Open a Qualitative Analysis template    32

Task 2. Customize the footer of the Qualitative Analysis template    34

Task 3. Use the new template in the Qualitative Analysis program    39

Task 4. Open a Quantitative Analysis template    42

Task 5. Customize the footer of the Quantitative Analysis template    44

Task 6. Use the new template in the Quantitative Analysis program    48

In this exercise, you open a template and change the header and footer. You 
also verify the changes that you made. You modify both a Qualitative Analysis 
template and a Quantitative Analysis template.

• In Task 1, you open a Qualitative Analysis template in Excel.

• In Task 2, you customize the footer of the Qualitative Analysis template.

• In Task 3, you use this new template in the Qualitative Analysis program.

• In Task 4, you open a Quantitative Analysis template in Excel.

• In Task 5, you customize the footer of the Quantitative Analysis template.

• In Task 6, you use this new template in the Quantitative Analysis program.

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 1. Open a Qualitative Analysis template
Task 1. Open a Qualitative Analysis template

In this task, you prepare and open a Qualitative Analysis template.

Task 1. Open a Qualitative Analysis template

Step Detailed Instructions Comments

1 Make a copy of the 
AnalysisReport.xltx file and rename 
the file 
iii_CustomAnalysisReport.xltx

a Open the Windows Explorer program.
b Navigate to the Report Templates\

Qual folder in the folder where you 
installed the data.

c Navigate to the Letter or A4 folder
d Right-click the AnalysisReport.xltx file 

and click Copy.
e Click Edit > Paste to add a copy of the 

report template to the current folder.
f Right-click the new file, Copy of 

AnalysisReport.xltx and click 
Rename.

g Type iii_CustomAnalysisReport.xltx.

• You do the same steps to open a 
Quantitative Analysis template.

• You can (and should) change the 
name of the template that you 
modify. However, you cannot 
change the name of the graphics 
templates in the Qualitative 
Analysis program. Instead, you 
need to make a backup of the 
template and open the original 
template. When you have finished 
editing the template, you also save 
a copy of the changed template.

Figure 12 Report Templates\Qual\Letter folder

2 Remove the Read-only attribute 
from the new template.

a Right-click the new file and click 
Properties.

b Clear the Read-only check box in the 
Attributes section.

c Click OK.

• If a template is read-only, you 
cannot save any changes to the 
template.
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Task 1. Open a Qualitative Analysis template
Clear the Read-only check box.

Figure 13 Properties dialog box

3 Open the template. • Right-click the new file and click Open.

Task 1. Open a Qualitative Analysis template

Step Detailed Instructions Comments
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Task 2. Customize the footer of the Qualitative Analysis template
Task 2. Customize the footer of the Qualitative Analysis template

In this task, you change the footer of the Qualitative Analysis template that 
you opened in the task, “Task 1. Open a Qualitative Analysis template” on 
page 32.

Task 2. Customize the footer of the Qualitative Analysis template

Step Detailed Instructions Comments

1 Switch to the Page Layout view:
• Switch to the Design worksheet 

if necessary.

a Click Page Layout in the Workbook 
Views group in the View tab in the 
Ribbon. You can also click the Page 
Layout icon ( ) at the bottom of the 
Excel program to switch to the Page 
Layout view.

• In the Page Layout view, the Header 
and Footer are visible.

• The Header is printed at the top of 
each page and the footer is printed 
at the bottom of each page.

• The header and the footer each 
have three different parts: left, 
center and right. You can click on 
any of these sections to edit that 
part.

Figure 14 Switching to the Page Layout view in Excel

Click this button to switch to the 
Page Layout view.

This template has three different 
sheets. Make sure that the 
design worksheet is visible.

You can also click this button to 
switch to the Page Layout view.
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Task 2. Customize the footer of the Qualitative Analysis template
2 Change the footer.
• Add the worksheet name to the 

left section of the footer.

a Scroll to the bottom of the design page 
in Excel.

b Click the left section of the footer. A 
text section appears containing the 
text &[Picture].

c Click at the end of this text to add 
something to this section. 

d Type a space.
e Click Sheet Name in the Header & 

Footer Elements group in the Design 
tab. The text &[Tab] is added. &[Tab] 
is the name of the tab or worksheet.

• Excel has different keywords in the 
header or footer that refer to 
different pieces of information:
• &[Page] = the page number
• &[Pages] = the total number of 

pages
• &[Date] = the date the report 

was created
• &[Time] = the time the report 

was created
• &[File] = the name of the Excel 

template file
• &[Picture] = the picture that you 

selected

Figure 15 The Header and Footer Design Tab in Excel

Task 2. Customize the footer of the Qualitative Analysis template

Step Detailed Instructions Comments

The Header & Footer Tools are 
shown in the Design tab when you 
click on one of the sections in the 
header or footer. You can click 
these buttons to quickly add these 
items to the header or footer.

By default, the sheet name is 
Design. In the task “Task 1. Add a 
page break and a sheet break” on 
page 118, you will learn how to 
change the sheet name.
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Task 2. Customize the footer of the Qualitative Analysis template
3 Finish editing the footer. a Click in any of the cells in the 
spreadsheet to stop editing the footer.

b Click Normal in the Workbook Views 
group in the View tab in the Ribbon. 

4 Test the changes to the template. a Click the Add-Ins tab.
b Click Process Report.
c Click the Browse button.
d Navigate to the \MassHunter\

reports\temp folder.
e Double-click one of the folders that 

contains analysis results.
f Select Report.xml.
g Click Open.
h Click OK.
i After the report is processed, click 

Page Layout in the Workbook Views 
group in the View tab in the Ribbon.

j Scroll to the bottom of the page to see 
the change. The name of the tab is 
added after the Agilent logo.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

• You can only see the header and the 
footer in the Page Layout view.

Task 2. Customize the footer of the Qualitative Analysis template

Step Detailed Instructions Comments
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Task 2. Customize the footer of the Qualitative Analysis template
Figure 16 Verifying changes in the footer after using the Process Report command

5 Save the changes to the template.
• You have to clear the results 

first.
• You can either save the template 

to the same name or to a new 
name.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save.

c (optional) To save to a different 
template name, click Save As and click 
Other Formats. 

d In the Save As dialog box, type a new 
File name,

e Verify the folder selected in Save in is 
correct.

f Click Save.

• You can click Save As > Other 
Formats if you want to change the 
name of the template.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 2. Customize the footer of the Qualitative Analysis template

Step Detailed Instructions Comments

The name of the tab is Report. 
This word is also added to the 
footer on each page.
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Task 2. Customize the footer of the Qualitative Analysis template
Figure 17 The Save As menu in the Microsoft Office button menu

Task 2. Customize the footer of the Qualitative Analysis template

Step Detailed Instructions Comments
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Task 3. Use the new template in the Qualitative Analysis program

To use the new template in the Qualitative Analysis program you change the 
template that is used for an analysis report.

An analysis report can contain the results from extracting and integrating 
chromatograms, extracting spectra, finding compounds, searching the 
database for peak spectra or generating formulas from peak spectra. 

Task 3. Use the new template in the Qualitative Analysis program

Steps Detailed Instructions Comments

1 Open the Qualitative Analysis 
program and open the data files, 
sulfas-PosAutoMSMS, 
sulfas-PosMS.d and 
sulfas-PosTargetedMSMS.d in 
the folder \MassHunter\Data, or 
in the folder where you copied 
them.

• Follow the instructions in “Task 1. 
Open the Qualitative Analysis 
program” on page 10.

2 Change the template that is used 
for the analysis report.

a In Method Explorer, click General > 
Common Reporting Options.

b Select the template 
iii_CustomAnalysisReport.xltx as the 
Analysis report template, where iii are 
your initials.

c Clear any chromatogram and spectra 
choices you do not want to print.

• The new report template is 
automatically found and included in 
the list of possible analysis report 
templates when the Qualitative 
Analysis program is started.

• If the Qualitative Analysis program 
is already running, the new 
template is not included in the list. 
The program will search for new 
templates if you do the following:

a Click the  button next to 
the Report template folder.

b Click OK. Do not change the folder 
that is selected.
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Task 3. Use the new template in the Qualitative Analysis program
Figure 18 Analysis Report section in the Method Editor

3 Select the template to use when 
printing this report.

a In Method Explorer, click General > 
Common Reporting Options.

b Verify that the correct Report template 
folder is selected.

c Verify that the correct Analysis report 
template is being used.

d Click the Options tab.
e Verify the settings on this tab. 

• The report templates that are 
shipped with the software are 
separated into two folders. One 
folder contains reports that are 
formatted to print on Letter size 
paper. The other folder contains 
reports that will print on A4 size 
paper.

• Three different analysis report 
templates are available in each 
folder.

Task 3. Use the new template in the Qualitative Analysis program

Steps Detailed Instructions Comments

You select the new report template 
for the Analysis report here.
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4 Print the report. • You can interactively print the report in 
multiple ways:
• From the main menu, click File > 

Print > Analysis Report.
• From the main toolbar, click the 

Printer icon.
• Click the Print Analysis Report icon, 

 in the Method Editor 
toolbar.

• Right-click the Analysis Report 
section in the Method Editor, and 
click Print Analysis Report.

• From the data file shortcut menu in 
the Data Navigator, click Print 
Analysis Report.

• Click Generate Analysis Report in 
the Actions menu.

The Run icon  in the Method 
Editor toolbar sometimes allows you to 
choose an action from a set of 
possible actions. For example, if you 
switch to the General > Common 
Reporting Options section, four 
different actions are possible when 
you click the Run icon. If you click the 
arrow, a list of possible actions is 
shown, and you can choose which 
action to do. Choosing a different 
action from the list changes the 
default action. If you simply click the 
Run button, the default action is 
performed.

Task 3. Use the new template in the Qualitative Analysis program

Steps Detailed Instructions Comments
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Task 4. Open a Quantitative Analysis template

In this task, you prepare and open a Quantitative Analysis template. 

Task 4. Open a Quantitative Analysis template

Step Detailed Instructions Comments

1 Make a copy of the 
QuantReport_ISTD_Summary_B_0
4_00.xltx file and rename the file 
iii_Custom_ISTD_Summary.xltx

a Open the Windows Explorer program
b Open the Report Templates\Quant\

en-US folder in the folder where you 
installed the data.

c Navigate to the Letter or A4 folder.
d Navigate to the ISTD/Parts folder.
e Right-click the QuantReport_ISTD_

Summary_B_04_00.xltx file and click 
Copy.

f Click Edit > Paste to add a copy of the 
report template to the current folder.

g Right-click the new file, Copy of 
QuantReport_ISTD_Summary_B_04_0
0.xltx, and click Rename.

h Type iii_Custom_ISTD_Summary.xltx.

• You do the same steps to open a 
Qualitative Analysis template.

• In the Report Templates\Quant\
en-US\Letter or A4 folder, the 
templates are separated into 
additional folders, including ESTD 
and ISTD.

Figure 19 MassHunter\Report Templates\Quant\en-US\Letter\ISTD\
Parts folder

2 Remove the Read-only attribute 
from the new template.

a Right-click the new file and click 
Properties.

b Clear the Read-only check box in the 
Attributes section.

c Click OK.

• If a template is read-only, you 
cannot save any changes to the 
template.
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Clear the Read-only check 
box. This check box may 
already be clear.

Figure 20 Properties dialog box

3 Open the template. • Right-click the new file and click Open.

Task 4. Open a Quantitative Analysis template

Step Detailed Instructions Comments
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Task 5. Customize the footer of the Quantitative Analysis template

In this task, you change the footer of the Quantitative Analysis template that 
you opened in the task, “Task 4. Open a Quantitative Analysis template” on 
page 42.

Task 5. Change the footer of the Quantitative Analysis template

Step Detailed Instructions Comments

1 Switch to the Page Layout view. a Click Page Layout in the Workbook 
Views group in the View tab in the 
Ribbon. You can also click the Page 
Layout icon ( ) at the bottom of the 
Excel program to switch to the Page 
Layout view.

• In the Page Layout view, the Header 
and Footer are visible.

• The Header is printed at the top of 
each page and the footer is printed 
at the bottom of each page.

• The header and the footer each 
have three different parts: left, 
center and right. You can click on 
any of these sections to edit that 
part.

Figure 21 Switching to the Page Layout view in Excel

Click this button to switch to the 
Page Layout view.

This template has two different 
sheets. Make sure that the Design 
Summary worksheet is visible. 

You can also click this button to 
switch to the Page Layout view.
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2 Change the footer.
• Add the worksheet name to the 

left section of the footer.

a Scroll to the bottom of the design page 
in Excel.

b Click the left section of the footer. A 
text section appears containing the 
text &[File].

c Click at the end of this text to add 
something to this section. 

d Type a space.
e Click Sheet Name in the Header & 

Footer Elements group in the Design 
tab. The text &[Tab] is added. &[Tab] 
is the name of the tab or worksheet.

• Excel has different keywords in the 
header or footer that refer to 
different pieces of information:
• &[Page] = the page number
• &[Pages] = the total number of 

pages
• &[Date] = the date the report 

was created
• &[Time] = the time the report 

was created
• &[File] = the name of the Excel 

template file
• &[Picture] = the picture that you 

selected when 

Figure 22 The Header and Footer Design Tab in Excel

3 Finish editing the footer. a Click in any of the cells in the 
spreadsheet to stop editing the footer.

b Click Normal in the Workbook Views 
group in the View tab in the Ribbon. 

Task 5. Change the footer of the Quantitative Analysis template

Step Detailed Instructions Comments

The Header & Footer Elements are 
shown in the Design tab when you 
click on one of the sections in the 
header or footer. You can click 
these buttons to quickly add these 
items to the header or footer.

By default, the worksheet name in 
the template is Design-Summary. 
The worksheet name in the report 
is Summary. In a different 
exercise, you will learn how to 
change the worksheet name.
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4 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g After the report is processed, click 

Page Layout in the Workbook Views 
group in the View tab in the Ribbon.

h Scroll to the bottom of the page to see 
the change. The name of the tab is 
added after the Agilent logo.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

• You can only see the header and the 
footer in the Page Layout view.

Figure 23 Verifying changes in the footer after using the Process Report command

Task 5. Change the footer of the Quantitative Analysis template

Step Detailed Instructions Comments

The name of the tab 
is Summary. This 
word is also added 
to the footer on 
each page.
46 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Customizing a template 2
Task 5. Customize the footer of the Quantitative Analysis template
5 Save the changes to the template.
• You have to clear the results 

first.
• You can either save the template 

to the same name or to a new 
name.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save.

c (optional) To save to a different 
template name, click Save As and click 
Other Formats. 

d In the Save As dialog box, type a new 
File name,

e Verify the folder selected in Save in is 
correct.

f Click Save.

• You can click Save As > Other 
Formats if you want to change the 
name of the template.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Figure 24 The Save As menu in the Microsoft Office button menu

Task 5. Change the footer of the Quantitative Analysis template

Step Detailed Instructions Comments
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Task 6. Use the new template in the Quantitative Analysis program

To use the new template in the Quantitative Analysis program you need to 
select the new template in the Report dialog box.

Task 6. Use the new template in the Quantitative Analysis program

Steps Detailed Instructions Comments

1 Open the Quantitative Analysis 
program and open a batch file.
• Select either the default batch or 

the batch you created if you did 
the exercises in the Quantitative 
Analysis Familiarization Guide.

• Analyze the batch, and inspect 
the results for each compound.

• Follow the instructions in “Task 5. 
Open a batch in the Quantitative 
Analysis program” on page 22.

• If the Quantitative Analysis program 
is already running, you do not need 
to restart the program.

2 Open the Report dialog box.
• Verify the default destination 

directory for reports is \Your 
Directory\DrugsofAbuse\
QuantReports.

• The default filename is 
iii_Test_01, where “iii” are your 
initials.

a Click Report > Generate. 
The system displays the standard 
Report dialog box.

b Click .
c Specify the default destination 

directory for saving Excel reports in the 
Report folder text box; for example, 
\Your Directory\DrugsOfAbuse\
QuantReports\iii_Test_01.

d Mark the Start Queue Viewer check 
box.

e Click the Batch report button.
f Specify the default destination 

directory for saving Excel reports in the 
Report Folder text box; for example, 
\Your Directory\DrugsOfAbuse\
QuantReports\iii_Test_01.

• You can also specify the Instrument 
Type determining numeric formats 
in graphics files. This value is used 
to determine how many decimal 
places to show in the graphics.
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Task 6. Use the new template in the Quantitative Analysis program
3 Select the report template to use.
• Add the template, 

iii_Custom_ISTD_Summary.xltx.
• Make sure the report name is 

iii_Custom_ISTD_Summary.xls. 
By default, it is set to the name 
of the template.

a Click Add under Reports.
The system displays the Open dialog 
box. 

b Navigate to the Letter\ISTD folder.
c Select 

iii_Custom_ISTD_Summary.xltx and 
click Open.
The program adds the template to the 
Template field in the Reports pane.

d In the Report File Name column in the 
Reports table, verify that the template 
is iii_Custom_ISTD_Summary.xltx.

e Mark the Start Queue Viewer check 
box.

• Click the Advanced button if you 
want to use the advanced Report 
dialog boxes. You use the Advanced 
Report dialog boxes if you want to 
do any of the following:
• Specify a different printer than 

the default printer
• Re-use existing graphics files
• Specify a different numeric 

format for graphics than the 
default format.

• Create a separate report for each 
sample.

• Include only some of the samples 
in the report.

• Include only some of the 
compounds in the report.

4 Generate the report.
• View the status of the report 

generation in the Task Queue 
Viewer.

a Click OK in the Report dialog box to 
generate the report.

b Click Report > Queue Viewer to 
monitor the report generation process.
The system displays the Task Queue 
Viewer program.

c Watch the progress of the report in the 
Status column. 

• If you add multiple templates to the 
Reports section, only one job is 
added to the queue which will print 
all of the reports. The reports are 
printed in the order requested. You 
can see the status of the reports in 
the Task Queue Viewer program.

Task 6. Use the new template in the Quantitative Analysis program

Steps Detailed Instructions Comments

The new template is shown here.

The default printer is used when 
you use the standard Report 
dialog boxes. 
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Task 6. Use the new template in the Quantitative Analysis program
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Agilent MassHunter Workstation Software Reporting
Familiarization Guide
Exercise 3
Customizing a table

Task 1. Rename a column header in a table    53

Task 2. Delete a column from a table    56

Task 3. Change the width of a column in a table    59

Task 4. Move a column in a table    62

Task 5. Add a column to a table    66

Task 6. Add a mapped column to a table    70

Task 7. Add a filter to a table    74

Task 8. Move or delete a column in a filtered table    79

In this exercise, you customize a table in a Quantitative Analysis template. 
After each change, you verify the changes and save the template to a new 
name. An example method is available for each of these tasks

• In Task 1, you rename a column header in a table.

• In Task 2, you delete a column from a table.

• In Task 3, you change the width of a column in a table.

• In Task 4, you move a column in a table.

• In Task 5, you add a column to a table.

• In Task 6, you add a mapped column to a table.

• In Task 7, you add a filter to two different tables using the Report Designer 
Add-in and using features in Excel.

• In Task 8, you delete a column and move a column in each of those filtered 
tables.
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3 Customizing a table 
Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 1. Rename a column header in a table
Task 1. Rename a column header in a table

In this task, you rename a column header in a table in a Quantitative Analysis 
template. 

Task 1. Change the column header in a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\en-US\Letter\
ISTD\
iii_Custom_ISTD_Summary.xltx 
template, where “iii” are your 
initials.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_Custom_ISTD_Summary.xltx, where 
“iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Change the name of the Data File 
column to Acquisition File.

a Find the table labeled Sequence Table.
b Click on the cell containing the words 

Data File. This column is the second 
column in the table. 

Figure 25 Selecting the Data File cell in Excel

Click on this cell in the 
Sequence Table.

The contents of the current 
cell are shown here in the 
Formula bar.

One of the column headers 
in a table in the Quantitation 
Results section also is 
called Data File. Columns in 
different tables can have the 
same name.
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Task 1. Rename a column header in a table
c Type Acquisition File. You 
can also click in the Formula Bar to 
only overwrite part of the name.

• Two columns in the same table 
cannot have the same name. Excel 
automatically changes the name of 
the column that appears second in 
the table if two column names are 
the same.

Figure 26 Changing the header of the column to Acquisition File

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The first 

column is now called Acquisition File. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

• If you do not click in another field 
after changing the name to 
Acquisition File, the Process Report 
command does not start.

Task 1. Change the column header in a Quantitative Analysis table

Step Detailed Instructions Comments

The column header has been 
changed to Acquisition File.

The changes are shown 
here in the Formula bar.
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Task 1. Rename a column header in a table
Figure 27 Verifying changes in the column header after using the Process Report command

4 Save the changes to the template.
• You have to clear the results 

first.
• You save the template to the 

new name, iii_1_Custom_
ISTD_Summary.xltx.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_1_Custom_
ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 1. Change the column header in a Quantitative Analysis table

Step Detailed Instructions Comments

The column header is now 
Acquisition File.
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Task 2. Delete a column from a table
Task 2. Delete a column from a table

In this task, you delete a column from a table in a Quantitative Analysis 
template. 

Task 2. Delete a column from a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_1_Custom_ISTD_Summary.xltx.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_1_Custom_ISTD_Summary.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Delete the column Position in the 
Sequence Table.

a Find the table labeled Sequence Table.
b Click on the cell containing the words 

Position. This column is the fourth 
column in the table. 

Figure 28 Selecting the Position cell in Excel

Click on this cell in the 
Sequence Table.
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Customizing a table 3
Task 2. Delete a column from a table
c Right-click this cell and click Delete > 
Table Columns.

• You cannot press the Delete key on 
the keyboard to delete a column in a 
table. If you press the Delete key, 
the column header is changed and 
the column is not deleted.

Figure 29 Deleting the Position column

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuse folder.
d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The Sample 

Name column and the Volume column 
are adjacent. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 2. Delete a column from a Quantitative Analysis table

Step Detailed Instructions Comments

In the shortcut menu, click 
the command Delete > Table 
Columns.

You can also click Delete > 
Table Columns in the Cells 
group in the Home tab in the 
Ribbon.
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Task 2. Delete a column from a table
Figure 30 Verifying that the Position column is removed

4 Save the changes to the template.
• You have to clear the results 

first.
• You save the template to the 

new name, iii_2_Custom_
ISTD_Summary.xltx.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_2_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 2. Delete a column from a Quantitative Analysis table

Step Detailed Instructions Comments

The Position column is no 
longer included in this table 
in the report.
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Task 3. Change the width of a column in a table
Task 3. Change the width of a column in a table

In this task, you change the width of a column in a table in a Quantitative 
Analysis template. You use the Advanced Properties dialog box to set the 
width of a column in a table.

Task 3. Change the width of a column in a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_2_Custom_ISTD_Summary.xltx.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_2_Custom_ISTD_Summary.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Change the width of the Level 
column to 10.

a Find the table labeled Sequence Table.
b Click on the cell containing the word 

Level. This column is the fifth column 
in the table.

Figure 31 Selecting the Level column in Excel

Click on the Level column in 
the Sequence Table.

Changing the width of an 
entire column in Excel does 
not change the width of the 
column in a table.
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3 Customizing a table 
Task 3. Change the width of a column in a table
c Click Advanced Properties in the 
Add-Ins tab in the Ribbon.

d Type 10 in the Text width box.
e Click Close.
f Move the cursor over the Level column 

header to see the comment that has 
been added to this column.

• The Advanced Properties dialog box 
allows you to change the table in 
many different ways.

• Any changes that you make in this 
dialog box take effect immediately. 
You can make many changes before 
closing this dialog box.

Figure 32 Changing the width of the Level column

Figure 33 A Width comment has been added to the Level column

Task 3. Change the width of a column in a Quantitative Analysis table

Step Detailed Instructions Comments

Type the new column width for the 
selected column here.

You can specify a column width for 
each column in a table. Several 
columns already have the width 
entered.

A Width comment has been 
added to the Level column. 
The Report Designer Add-in 
reads these comments when 
the report is being processed 
and adjusts the width of the 
column automatically.

A red triangle is added to a 
cell if the cell has a comment 
added to it. The red triangle 
is not visible in this cell 
because of the drop down 
box.
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Customizing a table 3
Task 3. Change the width of a column in a table
3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK. Find the Sequence Table. The 

Level column is narrower. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 34 Verifying changes in the width of the column after using the Process Report command

4 Save the changes to the template 
iii_3_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_3_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 3. Change the width of a column in a Quantitative Analysis table

Step Detailed Instructions Comments

The width of this column in 
the table is slightly wider.
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Task 4. Move a column in a table
Task 4. Move a column in a table

In this task, you move a column in a table in a Quantitative Analysis template. 
If the table is filtered using the Excel filtering commands, refer to the task, 
Task 8. Move or delete a column in a filtered table.

Task 4. Move a column in a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_3_Custom_ISTD_Summary.xltx.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_3_Custom_ISTD_Summary.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Move the Volume column to the 
end of the table.
• Move the cursor to the edge of 

the cell until it changes to the 
Move cursor.

a Find the table labeled Sequence Table.
b Click on the cell containing the word 

Volume. This column is the fourth 
column in the table. 

c Move the cursor to the edge of the cell 
until the cursor changes to a four sided 
arrow, .

• The shape of the cursor changes 
depending upon where the cursor is 
pointing. 

Figure 35 Selecting the Volume column in the Sequence Table

Click on this cell in the 
Sequence Table.

When you move the column, 
the Volume cell and the cell 
directly under it are moved 
together automatically. You 
do not need to manually 
select both cells.
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Customizing a table 3
Task 4. Move a column in a table
d Click and drag the cursor to the end of 
the table. You only move a column 
within the same table. As you drag the 
cursor, you can see where the column 
would be placed. The location 
between the columns changes to a 
hatched line. Only release the mouse 
button when the hatched line appears 
between two cells.

e Release the cursor at the end of the 
table.

• If you try to move the column 
outside of the table, the cursor 
changes to outline the cell where 
the column would be placed. If you 
release the mouse button when the 
cursor is not within the same table, 
two things happen. First, the label 
of the cell is placed in the new 
location. Second, the label of the 
column in the table is changed. You 
cannot undo this action. You have 
to rename the cell in the table and 
also delete the cell that was added.

Figure 36 Moving the Volume column to the end of the table

Task 4. Move a column in a Quantitative Analysis table

Step Detailed Instructions Comments

The Volume column has been 
moved to the end of the 
table.

This table has some hidden 
columns. You do not need to 
move this column after the 
hidden columns.
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3 Customizing a table 
Task 4. Move a column in a table
3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The last 

column is now Volume. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 37 Verifying changes in the column header after using the Process Report command

Task 4. Move a column in a Quantitative Analysis table

Step Detailed Instructions Comments

The Volume column is now 
at the end of the table.
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Task 4. Move a column in a table
4 Save the changes to the template 
iii_4_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_4_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 4. Move a column in a Quantitative Analysis table

Step Detailed Instructions Comments
Agilent MassHunter Workstation Software Reporting Familiarization Guide 65



3 Customizing a table 
Task 5. Add a column to a table
Task 5. Add a column to a table

In this task, you add a column header in a table in a Quantitative Analysis 
template. 

Task 5. Add a column to a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_4_Custom_ISTD_Summary.xltx.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_4_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a column to the Sequence 
Table to the left of the Acquisition 
File column in the Sequence Table.
• Change the name of this column 

to Location.
• Change the formatting of this 

header to match the other 
headers in this table.

a Find the table labeled Sequence Table.
b Click on the cell containing the words 

Acquisition File. This column is the 
second column in the table. 

• The Data File column was renamed 
to Acquisition File in “Task 1. 
Rename a column header in a 
table” on page 53.

Figure 38 Selecting the Acquisition File cell in Excel

Click on this cell in the 
Sequence Table.
66 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Customizing a table 3
Task 5. Add a column to a table
c Right-click this cell and click Insert > 
Table columns to the left. 

• You click the column to the right of 
the location where you want to add 
a column.

Figure 39 Add a column to the left of the Acquisition File column.

d Follow the instructions in “Task 1. 
Rename a column header in a 
table” on page 53 to rename the 
column to Location.

e Type =”Laboratory 1” in the cell 
directly below the cell Location.

f Select the cell Location. Right-click 
the cell and click the  icon and 
click the  icon in the shortcut 
menu.

• To add a word to a table, you first 
type = and then type the words 
inside of quotation marks. You are 
actually entering a simple formula.

• Headers in a table are black and 
bold.

• You can also change the font by 
using the icons in the Font group in 
the Home tab in the Ribbon.

Task 5. Add a column to a Quantitative Analysis table

Step Detailed Instructions Comments

Click this command. The 
new column is added to the 
left of the current column.
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Task 5. Add a column to a table
Figure 40 Change the format of the Location column header.

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The first 

column is now Location. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 5. Add a column to a Quantitative Analysis table

Step Detailed Instructions Comments

To change the header to look 
like the other headers in the 
table, you click the Bold icon 
and also change the font color 
to black.

You can also use the icons in 
the Font group.

=”Laboratory 1” is added to 
this cell.
68 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Customizing a table 3
Task 5. Add a column to a table
Figure 41 Verifying a new column is added to the table

4 Save the changes to the template 
iii_5_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_5_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 5. Add a column to a Quantitative Analysis table

Step Detailed Instructions Comments

The first column is now 
Location.

When you Clear Results, the 
formula =”Laboratory 1” is 
not visible. However, it is 
still used whenever you 
process the report.
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Task 6. Add a mapped column to a table
Task 6. Add a mapped column to a table

In this task, you add a mapped column to a table in a Quantitative Analysis 
template. A “mapped column” is a column that refers to information that is 
included in the results from the Quantitative Analysis program.

Task 6. Add a mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_5_Custom_ISTD_Summary.xltx.

f Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_5_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Display the XML source.
• Hint: right-click a cell that is 

already mapped to display the 
shortcut menu.

a Find the cell containing the words 
Batch Data Path.

b Right-click the cell next to this cell.
c Click XML > XML Source.

• If the Developer tab isn’t showing:
a Click the Microsoft Office Button 

and then click Excel Options.
b In the Excel Options dialog box, 

mark the Show Developer tab in 
the Ribbon check box.

c Click OK.

Figure 42 Displaying the XML Source task pane in Excel

Right-click this cell and 
click XML > XML Source. 
You can right-click any 
mapped cell to click this 
command.

If the Developer tab in the 
Ribbon is visible, you can 
also click the Source icon 
in the XML group.
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Task 6. Add a mapped column to a table
3 Add the column Barcode to the 
end of the Sequence Table.
• Hint: click on two items in the 

Sequence Table to identify the 
correct section of the XML 
Source.

a Find the table labeled Sequence Table.
b Click the Acquisition File column.
c Click the Level column.

• As you click the mapped columns in 
the table, the list of elements in the 
XML Source window also changes.

• If the element in the list is shown in 
Bold letters, that item is already 
mapped or used in the worksheet. 

• Elements in the same map cannot 
be used more than once.

Figure 43 Selecting the Level column in Excel

d Scroll until the column after the end of 
the Sequence Table is visible.

e In the XML Source window, scroll up 
to display the element ns1:Barcode.

f Click and drag the element 
ns1:Barcode to the cell that is next to 
the Volume column.

g Click the cell Barcode.
h Right-click the cell and click the  

icon in the shortcut menu.

• A blue triangle appears in the lower 
right corner of the last column in a 
table. After adding the column 
Barcode to the table, the blue 
triangle appears at the bottom of 
the Barcode column.

• If you drag the element to a location 
that is not at the end of the table, an 
error is displayed. Right-click this 
column and click Delete > Table 
Columns to remove the column. 
Then, click and drag the element 
again to the end of the table.

Task 6. Add a mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

When you click on the Level 
column, the element 
ns1:LevelName in the XML 
Source window is 
highlighted. 

“ns1:” is part of the syntax 
of the element in the XML 
source window. Every item 
in the XML Source window 
starts with “ns1:”.
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Figure 44 Adding the Barcode column to the end of the Sequence Table

4 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table.
h Scroll to the end of the Sequence 

Table. The Barcode column is now the 
last column in the Sequence Table.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 6. Add a mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

When you click on a column 
in a table, the Table Tools 
Design tab is added to the 
Ribbon. You can change the 
Table Style using this group.

The Barcode column is 
added after the Volume 
column. You can then move 
the column to the proper 
location.

In most cases, you can only add a mapped column to a table if the mapped column is from the same section in the 
XML source as the other columns in the table. First, you identify the section in the XML source by clicking on two 
different columns in the table. Then, you choose one of the items that is in that same section. Items are in the same 
section if they are all nodes from the same element. For example, all of the elements listed between BatchID and 
Vial are in the same section. Finally, you drag the element to the end of the table.
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You can insert a mapped column into the middle of a table. First, you add an 
empty column to the table. Then, you drag the mapped column to that location. 
Then, you have to manually change the column header.

It is simpler to drag the new element to the end of the table.

Figure 45 Verifying the Barcode column is added to the end of the Sequence Table

5 Save the changes to the template 
iii_6_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_6_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 6. Add a mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

The last column in the 
Sequence Table is now the 
Barcode column.
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Task 7. Add a filter to a table

You can add a filter to a column in a table in two different ways. If you use the 
Advanced Properties dialog box to add a filter, you can add a simple filter, and 
you can still easily move and delete a column. However, if you use Excel 
features to add a filter to a table, the filter can be more complex, but then you 
have to remove the filter before you can move or delete a column.

Task 7. Add a filter to a table in a Quantitative Analysis template

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_6_Custom_ISTD_Summary.xltx.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_6_Custom_ISTD_Summary.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a filter to the Quantitation 
Results table using the Advanced 
Properties dialog box.
• Only include data files that have 

an expected concentration.

a Find the second table in the section 
Quantitation Results.

b Click the column labeled Exp Conc 
This column is the tenth (10th) column 
in the table. 

c Click Advanced Properties.
d Select NonBlanks in the Filter value 

box when the Exp Conc column is 
selected.

e Click Set Filter.
f Click Close.

• The Advanced Properties icon is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 46 Add a filter to the Sequence Table using the Advanced Properties dialog box

Select NonBlanks as the Filter 
Value and then click Set Filter. 

The filter is shown in the Filter 
column in the Table column 
properties list.
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3 Add a filter to a table using Excel.
• Add a text filter to the column 

Acquisition File in the Sequence 
Table.

• Only include an Acquisition File 
if the file name contains “Blk” or 
“Cal”.

a Find the table labeled Sequence Table.
b Click on the arrow in the cell labeled 

Acquisition File. This column is the 
third column in the table. 

c Click Text Filters > Contains. The 
Custom Auto Filter dialog box is 
opened.

• A filter allows you to only include a 
row in the table if it passes the 
filter.

Figure 47 Add a filter to the Sequence Table using Excel features

d Type Cal in the first text field.
e Click Or.
f Select contains in the second box.
g Type Blk in the second text field.
h Click OK.

Task 7. Add a filter to a table in a Quantitative Analysis template

Step Detailed Instructions Comments

Click on the arrow in the 
Acquisition File column and 
click Text Filters > Contains.
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Figure 48 Setting the text filter for the Acquisition File column in the Sequence Table

Figure 49 A filter is added to the Acquisition File column

Task 7. Add a filter to a table in a Quantitative Analysis template

Step Detailed Instructions Comments

In this example, only file names that include the 
letters “Cal” or “Blk” are included. 

The icon in the Acquisition 
File column is changed to 
show that an Excel filter is 
applied. 

The icon in the Exp Conc 
column is not changed 
when a filter is added using 
the Advanced Properties 
dialog box.
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4 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The only 

acquisition files that are included 
contain either Cal or Blk.

h Find the Quantitation Results table. 
The only acquisition files that are 
included have an expected 
concentration that is not blank. All of 
the blanks and samples have been 
removed.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 50 Verifying changes in the rows that are included in the filtered tables

Task 7. Add a filter to a table in a Quantitative Analysis template

Step Detailed Instructions Comments

The Sequence Table now 
only contains six rows. 
Before the filter was added, 
the Sequence Table 
contained eleven rows. Each 
Acquisition File contains 
either “Cal” or “Blk” in the 
name.

Every row in this table has 
an expected concentration.
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5 Save the changes to the template 
iii_7_Custom_ISTD_Summary.xltx
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_7_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 7. Add a filter to a table in a Quantitative Analysis template

Step Detailed Instructions Comments
78 Agilent MassHunter Workstation Software Reporting Familiarization Guide



Customizing a table 3
Task 8. Move or delete a column in a filtered table
Task 8. Move or delete a column in a filtered table

You can add a filter to a column in a table in two different ways. If you use the 
Advanced Properties dialog box to add a filter, you can still easily move and 
delete a column. However, if you use Excel features to add a filter to a table, 
you have to remove the filter before you can move or delete a column.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template \MassHunter\Report 
Templates\Quant\Letter\ISTD\
iii_7_Custom_ISTD_Summary.xltx.

• Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_7_Custom_ISTD_Summary.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Delete the Volume column.
• Hint: you only click the column 

header if you want to delete the 
column.

a Find the Sequence Table.
b Select the column labeled Volume and 

the cell beneath it. This column is the 
eighth (8th) column in the table. 

c Right-click the Volume column and try 
to click Delete > Table Columns. You 
cannot because this command is 
grayed out.

d Click only the cell labeled Volume.
e Right-click the Volume column and 

click Delete > Table Columns. You can 
delete this column now.

• The Sequence Table has an Excel 
filter added to it.

3 Move the Barcode column.
• You have to remove the filter 

before you can move a column.

a Find the Sequence Table.
b Click the column labeled Barcode and 

on the cell beneath it. This column is 
the eighth (8th) column in the table. 

c Move the cursor to the edge of the cell 
until the cursor changes to a four sided 
arrow, .

d Click and drag the Barcode column 
and try to move it between two other 
columns. Excel displays an error 
message that you cannot shift cells in 
a filtered range or table.

e Click OK in the error message.

• You cannot move a column if you 
have added a filter to the table using 
Excel. You cannot select a location 
between two columns to move the 
column to. Instead, you are asked 
whether or not “to replace the 
contents of the destination cells”. 
Agilent MassHunter Workstation Software Reporting Familiarization Guide 79



3 Customizing a table 
Task 8. Move or delete a column in a filtered table
Figure 51 A filter is added to the Acquisition File column

f Click the column labeled Acquisition 
File. This column is the eighth (8th) 
column in the table. 

g Click on the arrow in the cell labeled 
Acquisition File. This column is the 
third column in the table. 

h Click Text Filters > Contains. The 
Custom Auto Filter dialog box is 
opened.

i Write down the filter. This filter is 
“contains Cal or Blk”.

j Click Cancel.
k Click on the arrow in the cell labeled 

Acquisition File. This column is the 
third column in the table. 

l Click Clear Filter From “Acquisition 
File”.

• Moving a column in a filtered table 
is a four step process:

a Write down the filter.
b Remove the filter.
c Move the column.
d Add the filter again.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

If you try to move the 
Barcode column, Excel 
shows you this error or a 
similar error.
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Figure 52 The filter is removed from the Acquisition File column

e Move the Barcode column directly 
after the Acquisition File column.

f Click on the arrow in the cell labeled 
Acquisition File. This column is the 
third column in the table. 

g Click Text Filters > Contains. The 
Custom Auto Filter dialog box is 
opened.

h Type Cal in the first text field.
i Click Or.
j Select contains in the second box.
k Type Blk in the second text field.
l Click OK.

• Follow the instructions in “Task 4. 
Move a column in a table” on 
page 62 to move the Barcode 
column.

• Follow the instructions in “Task 7. 
Add a filter to a table” on page 74 to 
add the filter to the Acquisition File 
column.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

Remove the filter from the 
column. 
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Figure 53 The Barcode column is moved and the filter has been added again

4 Delete the Resp Ratio column.
• You can click the column header 

or both the column header and 
the cell below if you want to 
delete this column.

a Find the second table in the 
Quantitation Results section.

b Click the column labeled Resp Ratio 
and on the cell beneath it. This column 
is the thirteenth (13th) column in the 
table. 

c Right-click the Resp Ratio column and 
click Delete > Table Columns. The 
column is deleted.

• The second table in the 
Quantitation Results section has a 
filter added to it using the Advanced 
Properties dialog box.

5 Move the Final Conc column to 
directly after the Exp Conc column.
• You do not have to remove the 

filter before you move this 
column.

a Find the second table in the 
Quantitation Results section.

b Click the column labeled Final Conc. 
This column is the twelfth (12th) 
column in the table.

c Move the cursor to the edge of the cell 
until the cursor changes to a four sided 
arrow, .

d Click and drag the Final Conc column 
and move it after the Exp Conc 
column.

• Follow the instructions in “Task 4. 
Move a column in a table” on 
page 62 to move the Final Conc 
column.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

The Barcode column is now 
after the Acquisition File 
column

The Acquisition File column 
has the text filter again.
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Figure 54 The Barcode column and the Final Conc column are moved

6 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Sequence Table. The only 

acquisition files that are included 
contain either Cal or Blk.

h Find the Quantitation Results table. 
The only acquisition files that are 
included have an expected 
concentration that is not blank. All of 
the blanks and samples have been 
removed.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

The Barcode column is 
after the Acquisition File.

The Final Conc column is 
after the Exp Conc.
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Figure 55 Verifying that columns are moved in both filtered tables

7 Save the changes to the template 
iii_8_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_8_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 8. Move or delete a column in a filtered table in a Quantitative Analysis template

Step Detailed Instructions Comments

The Barcode column is 
moved to after the 
Acquisition File.

The Final Conc column is 
moved to after the Exp Conc 
column.
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Agilent MassHunter Workstation Software Reporting
Familiarization Guide
Exercise 4
Additional ways to customize a table

Task 1. Add a table to a template    86

Task 2. Format a table (Transposing and Hiding headers)    92

Task 3. Add a formula column to a table    95

Task 4. Add an ISTD column to a Quantitative Analysis template    100

Task 5. Add a column that is already mapped    104

In these tasks, you learn additional ways to customize a table. 

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 1. Add a table to a template

You can easily add a table to a template by using the commands in the Add 
Data menu in the Add-Ins tab in the Ribbon. A different set of commands is 
available for Qualitative Analysis templates and Quantitative Analysis 
templates. Also, different types of Qualitative Analysis templates have 
different sets of commands.

When you add a table to a template using the Add Data commands, a new XML 
map is added automatically. If you remove this table from the template in the 
future, make sure to also delete the XML map that was created. Reports print 
more quickly when you have fewer XML maps. You can delete unused XML 
maps in the using the XML maps button in the XML Maps dialog box which 
you get to by clicking the XML Maps button in the XML Source pane. 

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template, \MassHunter\Report 
Templates\Qual\Letter\
iii_CustomAnalysisReport.xltx.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_CustomAnalysisReport.xltx, where 
“iii” are your initials.

• If you did not create this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a second table to show 
additional Sample Information.
• Add the table inside the Repeat 

section.

a Find the first table in the template. The 
first two items are ItemID and Data 
Filename.

b Click on the first cell in row 5. The 
rows below this row are very narrow.

• The first table is repeated for each 
file in the results. The Report 
Designer repeats all of the rows 
between CMD:Repeat and 
CMD:EndRepeat for each data file. 
The ItemID is different for each data 
file.
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Figure 56 Selecting the first cell in row 9

c Click Add Data > Sample Information 
in the Add-Ins tab in the Ribbon.

• Extra rows are automatically added 
to the template for the new table.

Figure 57 Add a second Sample Information table.

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

Click on this cell in the 
template.

The current position in the 
template is shown here.

All of the rows between the 
CMD:Repeat row and the 
CMD:EndRepeat row are 
repeated for each ItemID. 
ItemID identifies different 
data files.

Click this command. The 
new table is added below 
row 5.

The commands in the Add 
Data menu are different for 
the Qualitative Analysis and 
Quantitative Analysis 
Program. Different types of 
Qualitative Analysis 
templates also have different 
commands.
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Figure 58 Add a second Sample Information table.

3 Compare the columns in the two 
tables.
• The XML Map changes 

depending on which table you 
are looking at.

• The names of some of the 
columns are different.

a Click on the Data Filename column in 
the first table. The XML map is 
Report_Map.

b Click on the Data File column in the 
second table. The XML map is 
Report_Map1.

• You can only map an item from an 
XML map one time. If you want to 
map an item a second time, you 
need to add a second map. This 
second map is added automatically 
when the new table is added.

4 Change the second table to include 
only the following columns:
• ItemID
• Data File
• Injector Volume
• Dilution

a Click on the Sample Name column in 
the second table. The XML map is 
Report_Map1.

b Delete all of the columns in the table 
that are after the Data File column. 

• You can delete more than one table 
column at the same time.

• Follow the instructions in “Task 2. 
Delete a column from a table” on 
page 56 to remove the columns.

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

The new table is added 
below row 5.

The XML Source pane is 
opened automatically. 
When a table is added, a 
new XML map is 
automatically added. 
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Figure 59 Delete multiple columns in the second Sample Information table.

c Click the Data File column in the 
second table.

d Add the mapped columns, InjVol and 
Dilution.

e Rename the InjVol column to Injector 
Volume.

• You click on one of the items in the 
table first to make sure that the 
correct XML map is selected. All of 
the columns in a table are mapped 
using the same XML map. The 
Report_Map1 map is selected.

• Follow the instructions in “Task 6. 
Add a mapped column to a 
table” on page 70 to add the 
columns.

• Follow the instructions in “Task 1. 
Rename a column header in a 
table” on page 53 to rename the 
columns.

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

Select the columns that you 
want to delete. Right-click 
and click Delete > Table 
Columns. All of the columns 
that are selected are 
removed.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 89



4 Additional ways to customize a table 
Task 1. Add a table to a template
Figure 60 The Injector Volume and Dilution columns are added to the second table

5 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the \MassHunter

\Reports\Temp folder.
d Double-click one of the folders that 

contains analysis results.
e Select Report.xml.
f Click Open.
g Click OK.
h Find the Injector Volume and the 

Dilution columns.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

The Injector Volume and 
Dilution columns are added to 
the second table.

You can change the 
formatting for each column 
using standard Excel 
features in the Home tab.
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Figure 61 Verifying a new Sample Information table is added to the template

6 Save the changes to the template.
• You have to clear the results 

first.
• You save the template to the 

new name, iii_1_Custom
AnalysisReport.xltx.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_1_CustomAnalysisReport.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 1. Add a table to a Qualitative Analysis template

Step Detailed Instructions Comments

The second Sample 
Information table shows the 
Injector Volume and the 
Dilution.

The first table is transposed 
and shows the information 
next to the column header. 
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Task 2. Format a table (Transposing and Hiding headers)

You can easily format a table using the commands in the Advanced Properties 
dialog box in the Add-Ins tab in the Ribbon. 

When a table is first added to a template, it is not transposed. The column 
headers appear in one row and the values appear directly below the column 
headers. If a table is transposed, then the “column headers” appear next to the 
values instead. Each column in the table is either printed in its own row or in 
a series of columns across the page. A few tables (for example, the Sample 
Information table in the Qualitative Analysis program) are transposed by 
default. 

Another way to format a table is to hide the column headers. If you add a 
repeating section, you can turn on this feature to avoid repeating the column 
headers throughout the report.

Task 2. Format a table in a Qualitative Analysis template

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template, \MassHunter\Report 
Templates\Qual\Letter\
iii_1_CustomAnalysisReport.xltx.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_1_CustomAnalysisReport.xltx, 
where “iii” are your initials.

• If you did not create this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Format the second table.
• Do not transpose the second 

sample information table. 
• Set the width of each column to 

15.

a Click on a column in the second table.
b Click Advanced Properties which is 

part of the MassHunter toolbar in the 
Add-Ins tab in the Ribbon.

c Clear the Table contents transposed 
to check box. 

d Select each Column under Table 
column properties.

e Type 15 in the Text width field.

• By default, when you add a Sample 
Information table, the Table 
contents transposed to check box is 
marked. This check box is on the 
Table tab of the Advanced 
Properties dialog box.

• Normally, a table is shown with the 
column headers in one row and the 
information in the table below each 
of these column headers. If a table 
is transposed, then the column 
header is printed next to the 
information. You can specify how 
many columns to use to show the 
information.
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Figure 62 Changing table properties in the Advanced Properties dialog box

3 Format the first table.
• Hide the header row.

a Click on a column in the first table.
b Click the Advanced Properties dialog 

box.
c Mark the Hide header row check box 

under Table properties.
d Click Close.

• You do not need to close the 
Advanced Properties dialog box to 
switch to a different table.

4 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the \MassHunter

\Reports\Temp folder.
d Double-click one of the folders that 

contains analysis results.
e Select Report.xml.
f Click Open.
g Click OK.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 2. Format a table in a Qualitative Analysis template

Step Detailed Instructions Comments

The Table contents transposed to 
check box is cleared.

The width of each column in the 
table is set to 15 using the Text width 
field.
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Task 2. Format a table (Transposing and Hiding headers)
Figure 63 Verifying a new Sample Information table is added to the template

5 Save the changes to the template, 
iii_2_CustomAnalysisReport.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_2_CustomAnalysisReport.xltx, 
where “iii” are your initials. 

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 2. Format a table in a Qualitative Analysis template

Step Detailed Instructions Comments

The second Sample 
Information table is not 
transposed. The column 
header is above the 
information.

The first table is transposed 
and the header row is hidden. 
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Task 3. Add a formula column to a table

In this task, you add a formula column to a table. In the Add Data menu, you 
click the Add Formula command to add a column to the table that contains a 
formula. An Excel comment is added to the cell to let the Report Designer 
Add-in know that the column contains a formula.

In this exercise, you will add a simple formula to a column in a table. To learn 
more about formulas, please refer to the online Help for Microsoft Excel. Also, 
many books have been written about creating formulas in Microsoft Excel.

Task 3. Add a formula column to a Qualitative Analysis table

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template \MassHunter\Report 
Templates\Qual\Letter\
iii_2_CustomAnalysisReport.xltx, 
where iii are your initials.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_2_CustomAnalysisReport.xltx, 
where “iii” are your initials.

• If you did not do the previous task, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a formula column.
• Add it to the right of the column 

End in the Integration Peak List 
Table.

• Label the column PWFH.
• Change the formula to show the 

difference of the start of the 
peak and the end of the peak.

a Find the table labeled Integration 
Peak List.

b Click on the cell containing the words 
End. This column is the fifth column in 
the table. 

c Click Add Data > Formula Column in 
the Add-Ins tab in the Ribbon.

d Follow the instructions in “Task 1. 
Rename a column header in a 
table” on page 53 to rename the 
column to PWFH.

e Click the Formulas tab in the Ribbon.
f Hide the XML Source pane, if it is 

visible.

• The Add Data > Formula Column 
command adds the column to the 
right of the column selected.

• PWFH is an abbreviation for Peak 
Width Full Height.

• You can manually enter formulas if 
you know the syntax, without using 
the Excel Function Arguments 
dialog box.
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Figure 64 Add a formula column to the right of the End column.

g Click the Insert Function button in the 
Function Library group in the Formulas 
Tab in the Ribbon

h In the select a category list, select 
Math & Trig.

i In the Select a function list, select 
SUM.

j Click OK.
k Click the Number1 box in the Function 

Arguments dialog box.
l Click the cell in the End column that is 

next to the formula cell. This cell 
contains the actual results.

m Click the Number2 box.
n Type - in this box.
o Click the cell in the Start column that 

is in the same row as this formula. The 
reference to this cell is added after the 
“-”.

p Click OK.

• By placing a “-” in the Number2 
box, you are actually subtracting the 
second number.

• Excel allows you to create many 
different formula. This is only one 
simple formula that you can enter.

• To show the formulas in a template, 
click the Formulas tab. Under 
Formula Auditing, click the Show 
Formula button. You have to turn 
this feature off before trying to 
process the report.

Task 3. Add a formula column to a Qualitative Analysis table

Step Detailed Instructions Comments

The new column PWFH is to 
the right of the End column. 
The Excel comment, 
“Formula” is added to this 
column.

This tab in the Ribbon helps 
you add a formula to the 
table. For information about 
formulas and functions, see 
the online Help for Microsoft 
Excel 2007 or Excel 2010. 
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Task 3. Add a formula column to a table
Figure 65 Using the Insert Function tool to add a formula to the RT Window column.

Figure 66 The formula has been added to the Integration Peak List table.

Task 3. Add a formula column to a Qualitative Analysis table

Step Detailed Instructions Comments

By clicking in the template, 
you select the cells to add. 
Excel automatically adds the 
correct syntax to refer to this 
cell.

A formula starts with the 
equal sign. This formula is 
a sum of the two items 
listed. The blue part of the 
formula refers to the value 
in the End column. It is 
color-coded to match the 
outline of the cell in the 
Integration Peak List table. 
The green part of the 
formula refers to the value 
in the Start column. It also 
is color-coded.
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Task 3. Add a formula column to a table
3 Test the changes to the template. a Click the Add-Ins tab in the Ribbon.
b Click Process Report.
c Click the Browse button.
d Navigate to the \MassHunter

\Reports\Temp folder.
e Double-click one of the folders that 

contains analysis results.
f Select Report.xml. 
g Click Open.
h Click OK.
i Find the Integration Peak List table. 

The PWFH column contains the 
difference between the End and the 
Start of the peak. 

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 67 Verifying the formula column in the Integration Peak List table.

Task 3. Add a formula column to a Qualitative Analysis table

Step Detailed Instructions Comments

The new column PWFH is 
included in the table after 
the End column. Each cell in 
this row contains the value 
of End - Start. 

For example in the first row, 
0.453 - 0.245 = 0.208.
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4 Save the changes to the template, 
iii_3_CustomAnalysisReport.xltx, 
where iii are your initials.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_3_CustomAnalysisReport.xltx, 
where iii are your initials.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 3. Add a formula column to a Qualitative Analysis table

Step Detailed Instructions Comments
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Task 4. Add an ISTD column to a Quantitative Analysis template

In the Quantitative Analysis program, a compound can be an internal 
standard (ISTD). You can include information about the internal standard in 
the same row in table as the related compound by adding an ISTD column.

Task 4. Add an ISTD mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ISTD\
Parts\iii_8_Custom_
ISTD_Summary.xltx template.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_8_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you do not have this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add two columns to the Target 
Compound table.
• Add the Retention Time column 

and change the name to RT.
• Add the ISTD Retention Time 

column and change the name to 
ISTD RT.

a Follow the instructions in “Task 6. Add 
a mapped column to a table” on 
page 70 to add the Retention Time 
column to the end of the table.

b Follow the instructions in “Task 1. 
Rename a column header in a 
table” on page 53 to change the name 
of the column to RT.

c Right-click the RT column header and 
click the B button to make the header 
match the font in the other headers.

d Right-click the RT column header and 
click the Format Cells command.

e Click the Alignment tab.
f Select Right (Indent) in the Horizontal 

list. Click OK.
g Click the RT column header.
h Click the Add Data > ISTD Column 

command.
i Select RT from the Select Column 

Dialog box.
j Click OK.
k If necessary, right-click the ISTD RT 

column header and click the B button 
to make the header match the font in 
the other headers.

• An ISTD column is added to the 
right of the selected column.

• You can only add an ISTD column if 
the corresponding column for the 
compound is part of the table. That 
is why you added the Retention 
Time column first, and then you 
added the ISTD column.

• (optional) You right-click the value 
for the RT and the ISTD RT and click 
the Format Cells command to select 
the number category and to select 
the number of decimal places.

• (optional) You can set the width of 
the RT and ISTD RT column to 
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Task 4. Add an ISTD column to a Quantitative Analysis template
Figure 68 Select the RT column.

Figure 69 The RT column and the ISTD RT column are part of the table.

Task 4. Add an ISTD mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

Some columns in this list start with the word ISTD. These columns are 
already internal standard columns. Do not select any of these 
columns.

The column ISTDCompoundID has to be part of the table in order to 
add an ISTD column. This column is automatically added when you 
add an ISTD column if it is not already included. the ISTDCompoundID 
column is a hidden column.

In the Target Compound 
table, you cannot see the RT 
column header because it is 
hidden behind the arrow. If 
you click on this column, 
you can see the Column 
Header in the Formula Bar. 
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Task 4. Add an ISTD column to a Quantitative Analysis template
3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Find the Target Compound Table.
h Scroll to the end of the Sequence 

Table. The Barcode column is now the 
last column in the Sequence Table.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 70 Verifying the RT and ISTD RT columns are added to the end of the table

Task 4. Add an ISTD mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments

The last two columns in 
the Target Compound table 
are the RT and ISTD RT 

The RT column is the 
retention time of that 
compound. The ISTD RT 
column is the retention 
time for the internal 
standard for that 
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Task 4. Add an ISTD column to a Quantitative Analysis template
4 Save the changes to the template, 
iii_9_Custom_ISTD_Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_9_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 4. Add an ISTD mapped column to a Quantitative Analysis table

Step Detailed Instructions Comments
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Task 5. Add a column that is already mapped

If an element in the XML Source is already being used in the template, it is 
shown in Bold letters in the XML Source. If you want to include the element 
again in a different part of the template, you need to add an additional map to 
the template.

When you add a table to a template using the Add Data commands, a new map 
is added automatically. You can add a new map file manually and then 
manually add the information from this map to the template. You cannot use 
more than one map in a table, so you cannot add items from this map to an 
existing table.

Usually, you will not need to do this task.

Task 5. Add a column that is already mapped to a Qualitative Analysis template

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template \MassHunter\Report 
Templates\Qual\Letter\
iii_3_CustomAnalysisReport.xltx, 
where iii are your initials.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_3_CustomAnalysisReport.xltx, 
where “iii” are your initials.

• If you did not create this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add the item AnalysisFileName to 
the first column in row 10.

a Find the second table in the template. 
The items in this table are ItemID, 
Data File, Injector Volume and 
Dilution.

b In the table, click Data File.
c Right-click and click XML > XML 

Source.
d Click the Dilution column.
e Try to add the AnalysisFileName item 

to the end of the table. An error 
message is displayed.

• In the XML Source window, both of 
these items are shown in bold 
which means that this item is 
already being used.

• See “Task 6. Add a mapped column 
to a table” on page 70 for 
instructions on adding a mapped 
column to a table.

Figure 71 The error that is shown if you try to map a column two times.
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f Click XML Maps in the XML Source 
pane. The XML Maps dialog box is 
opened.

g Click Add in the XML Maps dialog box.
h Navigate to the Report 

Templates/Qual/Letter folder.
i Select AnalysisReport.xsd for this 

template.
j Click Open.
k Click OK.

• Two maps are already available in 
the XML Maps dialog box.

• The map files are in the same folder 
as the templates. The Qualitative 
Analysis program has a different 
map file for each type of template. 

Figure 72 Add another map file.

Figure 73 Three XML maps are available in this template.

Task 5. Add a column that is already mapped to a Qualitative Analysis template

Step Detailed Instructions Comments

AnalysisReport.xsd - Analysis report

CompoundReport.xsd - Compound report

Graphic.xsd - Graphic report

QualitativeMethodReport.xsd - Qualitative 
Analysis Method Report

For a Quantitative Analysis template, the XML 
Source file is batch.results.xsd.

Report_Map - original map file

Report_Map1 - automatically added in Task 1 when the 
table was added

Report_Map2 - added manually in this task
Agilent MassHunter Workstation Software Reporting Familiarization Guide 105



4 Additional ways to customize a table 
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l Select Report_Map2 in the XML 
Source pane.

m Add the mapped column, 
AnalysisFileName in the first column 
of row 10.

Figure 74 Add the AnalysisFileName item.

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the \MassHunter

\Reports\Temp folder.
d Double-click one of the folders that 

contains analysis results.
e Select Report.xml.
f Click Open.
g Click OK.
h Find the first column in row 10. Verify 

that the AnalysisFileName is included 
again.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 5. Add a column that is already mapped to a Qualitative Analysis template

Step Detailed Instructions Comments

The AnalysisFileName is 
added to the first column in 
row 10. Because this cell is 
not part of a table, the 
column header is not 
automatically added above 
the value.
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Figure 75 Verifying that the AnalysisFileName is repeated

4 Save the changes to the template.
• You have to clear the results 

first.
• You save the template to the 

new name, iii_4_Custom
AnalysisReport.xltx, where iii are 
your initials.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_4_CustomAnalysisReport.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 5. Add a column that is already mapped to a Qualitative Analysis template

Step Detailed Instructions Comments

The AnalysisFileName is 
added after the second 
Sample Information table.
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Agilent MassHunter Workstation Software Reporting
Familiarization Guide
Exercise 5
Graphics

Task 1. Adding graphics to a template    110

Task 2. Display multiple graphics per row    113

In this exercise, you learn how to add graphics to a Quantitative Analysis 
template. In Task 2, you also learn how to print those graphics more 
compactly. 

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 1. Adding graphics to a template

You can easily add graphics to a template using the commands in the Add 
Graphics menu. The Report Designer Add-in has a different set of commands 
available in this menu for the Quantitative Analysis program and for each type 
of template in the Qualitative Analysis program.

Task 1. Add graphics to a Quantitative Analysis template

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ISTD\
Parts\iii_9_Custom_
ISTD_Summary.xltx template.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_9_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you do not have this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add target compound graphics.
• Add them in the Quantitation 

Results repeating section.

a Click in the first column in the last 
rows before the CMD:EndRepeat 
CompoundID row.

b Click Add Graphics > Compound 
Graphics.

• Refer to “Task 3. Add a single 
repeating section” on page 127 for 
an explanation of repeating 
sections.

• Three different graphics are added 
in the Compound Graphics table.

Figure 76 Select the RT column.

You can quickly find any 
graphics in the template 
because they are shown in 
green in the template.

The graphics are included 
in the CompoundID 
repeating section.
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3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Close the XML Source pane.
h Find the Compound Graphics section. 

The three compound graphics are 
shown in the same row.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 77 The compound graphics are added after the Target Compound table

Task 1. Add graphics to a Quantitative Analysis template

Step Detailed Instructions Comments

The Compound Graphics 
for each data file are 
shown in different rows.

All of the graphics for the 
first compound are shown 
together.
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4 Save the changes to the template, 
iii_10_Custom_ISTD_
Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_10_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 1. Add graphics to a Quantitative Analysis template

Step Detailed Instructions Comments
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Task 2. Display multiple graphics per row

If you have graphics in a template, you can specify the relative width and 
height for those graphics.

You can also mark whether or not to print graphics side-by-side. Normally, 
only graphics that are in the same row of the table are printed side-by-side. 
However, you can specify that graphics from different rows are printed 
side-by-side.

Task 2. Use the side-by-side graphics feature in a Quantitative Analysis template

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ISTD\
Parts\iii_10_Custom_
ISTD_Summary.xltx template.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_10_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you do not have the 
iii_10_Custom_ISTD_Summary.xltx 
template, example templates are 
available on the Agilent 
Technologies MassHunter 
Reporting User Information DVD in 
the Familiarization Templates 
folder.

2 Change the size of the graphics in 
the Compound Graphics table.
• Make the width of each graphic 

1/6th of the width of the page.
• Make the height of each 

graphics 1/6th of the height of 
the page.

a Click one of the graphics in the 
Compound Graphics table.

b Click Advanced Properties in the 
Add-Ins tab in the Ribbon.

c Select 1/6 for the Graphic size 
relative to page width and Height 
boxes for each graphic.

d Mark the Continue graphics across 
the page check box.

e Click Close.

• Make sure to change the width and 
height for each graphic.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 113



5 Graphics 
Task 2. Display multiple graphics per row
Figure 78 Select the RT column.

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Close the XML Source pane.
h Find the first Compound Graphics 

section. Six different graphics are 
printed in the same row.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 2. Use the side-by-side graphics feature in a Quantitative Analysis template

Step Detailed Instructions Comments

Set the relative graphic width and 
height for each of the graphics.

Mark the Continue graphics across 
the page check box. This check box 
controls whether or not different 
rows of graphics can be printed on 
the same line.

The Stack graphics vertically 
check box changes how the graphics are organized on the page. If 
this check box is cleared, then the related graphics are printed 
side-by-side. If this check box is marked, then related graphics are 
printed on consecutive rows.
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Figure 79 Graphics are printed side-by-side when you mark Continue graphics across the page.

4 Save the changes to the template, 
iii_11_Custom_ISTD_
Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_11_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 2. Use the side-by-side graphics feature in a Quantitative Analysis template

Step Detailed Instructions Comments

Six different graphics are 
printed in each row. Each 
is one sixth the width of 
the page and one sixth the 
height of the page.

Also, the graphics from 
two different data files are 
printed on the same line. 
You read the graphics from 
left to right on the page. 
For example, the graphics 
for the second data file are 
printed to the right of the 
graphics for the first data 
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Familiarization Guide
Exercise 6
Advanced topics

Task 1. Add a page break and a sheet break    118

Task 2. Use Test Mode    122

Task 3. Add a single repeating section    127

Task 4. Add a nested repeating section    131

Task 5. Change values on the Options worksheet    135

Task 6. Add a formula using the IF function    138

Task 7. Use the VLOOKUP function    142

In this exercise, you learn how to use some of the advanced features in the 
MassHunter Report Designer Add-in.

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 1. Add a page break and a sheet break

You can add a page break or a sheet break anywhere in a template.

If you add a page break, the report automatically puts the next information in 
the report at the beginning of a new page.

A sheet break is similar to a page break; the report automatically puts the next 
information in the report at the beginning of a new page. It also places the 
information on a new worksheet. When you add a sheet break, you can select 
an item that is already part of the template to label the new worksheet. This is 
important because you can include the name of the worksheet in the header or 
footer of the report. See “Task 2. Customize the footer of the Qualitative 
Analysis template” on page 34 or “Task 5. Customize the footer of the 
Quantitative Analysis template” on page 44 for more information.

Task 1. Add a page break and a sheet break

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ISTD\
Parts\iii_11_Custom_
ISTD_Summary.xltx template.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_11_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you do not have this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a sheet break to the 
Quantitation Results section.
• Select Compound to label the 

worksheet.

a Select the row containing the 
SampleID column in the Quantitation 
Results section.

b Right-click the row and click Insert. A 
row is added above the table.

c Click the first column in this new row.
d Click Add Formatting > Sheet Break 

in the Add-Ins tab in the Ribbon.
e Select Compound.
f Click OK.

• You can only select an item that is 
included between that row and the 
end of the template to use as the 
label for the worksheet.

• If the item is not part of the 
template, you can add it to the 
template and hide that column or 
cell.

• If you do not want to specify an item 
to use to label the new worksheet, 
click Cancel. The CMD:Sheet Break 
command is still added to the 
template.

3 Add a page break before the 
graphics in the Quantitation 
Results section.

a Click the first column in the row that is 
above the Compound Graphics label.

b Click Add Formatting > Page Break in 
the Add-Ins tab in the Ribbon.

• A page break only starts a new 
page. It does not change the 
worksheet label.
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Figure 80 Adding a sheet break and a page break.

4 Add the sheet name to the Header 
of the worksheet.

a Click the View tab.
b Click the Page Layout button.
c Click the left hand portion of the 

Header.
d Click the Header & Footer Tools tab.
e Click the Sheet Name button under 

Header & Footer Elements in the 
Header & Footer Tools tab.

f Click outside of the header area.
g Click Normal in the View tab.
h Click the Add-Ins tab.

• The footer also contains the Sheet 
Name in the left hand section.

Task 1. Add a page break and a sheet break

Step Detailed Instructions Comments

When you add a Sheet Break, 
you select an item to use to 
label the new worksheet. If 
you do not select an item, then 
the name of the design 
worksheet is used to label 
each of the new worksheets.

You do not select a column 
when you add a page break.
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5 Test the changes to the template. a Click the Add-Ins tab.
b Click Process Report.
c Click the Browse button.
d Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

e Select report.results.xml.
f Click Open.
g Click OK.
h Click the Meth worksheet. Each 

worksheet is labeled with the name of 
a different compound.

i Click the View tab in the Ribbon.
j Click the Page Layout button or the 

Page Break Preview button.
k The compound graphics are printed 

starting at the top of the next page.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Figure 81 The Compound Graphics are printed at the start of the page. The worksheets are labeled with the 
compound name.

Task 1. Add a page break and a sheet break

Step Detailed Instructions Comments

The header contains the 
name of the WorkSheet. 
The name of the worksheet 
is set when using the 
CMD:SheetBreak 
command.

The graphics are printed at 
the top of a new page 
because of the 
CMD:PageBreak 
command that is added.
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6 Save the changes to the template, 
iii_12_Custom_ISTD_
Summary.xltx.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_12_Custom_ISTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ISTD\Parts folder.

Task 1. Add a page break and a sheet break

Step Detailed Instructions Comments
Agilent MassHunter Workstation Software Reporting Familiarization Guide 121



6 Advanced topics 
Task 2. Use Test Mode
Task 2. Use Test Mode

Once Test Mode is enabled, you can process the report, one step at a time. 
When you click Process Report, three steps are performed. Using the Test 
Mode commands, you can pause after any of the steps:

1 Click Import XML Data to see the data that is imported into the Design 
worksheets. At this point, you can see the raw imported data, before any 
filtering. For MassHunter Quantitative Analysis, you see the data from the 
entire batch. 

2 Click Copy Data to Report to see the data after it is filtered and copied to 
the report worksheets. 

3 Click Format Report to see the data after it is formatted, and the graphics 
are imported. 

If you click Unhide Design Sheets, you can view the Design worksheets at the 
same time as the final report. The Design worksheets are hidden after the 
Format Report step.

Task 2. Use Test mode

Step Detailed Instructions Comments

1 Make a backup copy of the file 
“MassHunter Reporting 
Quant.config”.

a Open the Windows Explorer program.
b Navigate to the C:\Program Files\

Microsoft Office\Office12\Library 
folder.

c Right-click the MassHunter Reporting 
Quant.config file and click Copy.

d Click Edit > Paste to add a copy of the 
config file to the current folder.

e Right-click the new file, Copy of 
MassHunter Reporting Quant.config 
and click Rename.

f Type backup_MassHunter Reporting 
Quant.config.

• If you want to enable Test Mode in 
the Report Designer for Qualitative 
Analysis Add-in, you change the 
MassHunter Reporting Qual.config 
file.

2 Remove the Read-only attribute 
from the original config file.

a Right-click the MassHunter Reporting 
Quant.config file and click Properties.

b Clear the Read-only check box in the 
Attributes section, if necessary.

c Click OK.
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3 Change the TestMode enabled line 
from False to True.

a Right-click the MassHunter Reporting 
Quant.config file and click Open. You 
can open this file with Notepad.

b Find the line “<TestMode 
enabled=”False”/>”.

c Change the word False to True.
d Save the change. If you are using 

Notepad, click File > Save.
e Close the program.

4 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ISTD\
Parts\iii_12_Custom_
ISTD_Summary.xltx template.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, 
iii_12_Custom_ISTD_Summary.xltx., 
where “iii” are your initials.

• If you do not have the 
iii_12_Custom_ISTD_Summary.xltx 
template, example templates are 
available on the Agilent 
Technologies MassHunter 
Reporting User Information DVD in 
the Familiarization Templates 
folder.

Figure 82 The Test Mode menu.

Task 2. Use Test mode

Step Detailed Instructions Comments

When you enable Test 
Mode, a new menu is 
added to the MassHunter 
Reporting toolbar. These 
commands allow you to 
step through processing 
the report which can help 
you determine the cause of 
a problem in the template.
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5 Test the steps in the Test Mode 
menu.

a Click Test Quant > Import XML Data.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.

• The Test Quant command is part of 
the MassHunter toolbar in the 
Add-Ins tab in the Ribbon.

• You cannot skip a step. You must do 
each step in order.

• Do not repeat any of the steps. You 
must clear the results before trying 
to import a different XML Data file.

Figure 83 After the Test Quant > Import XML Data step

Task 2. Use Test mode

Step Detailed Instructions Comments

After the first step, the 
data is added to the 
template, but it is not 
filtered or copied to the 
report worksheets or 
formatted.
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g Click Test Quant > Copy Data to 
Report.

Figure 84 After the Test Quant > Copy Data to Report step

Task 2. Use Test mode

Step Detailed Instructions Comments

After the second step, the 
data is placed onto the 
appropriate worksheet 
and it is filtered, but it is 
not formatted. Also, the 
graphics are not included 
in the report yet.
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h Click Test Quant > Format Report.

Figure 85 After the Test Quant > Format Quant step

6 Clear the results and close Excel. a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
click Close.

• You can use the Clear Results 
command after any of the steps.

Task 2. Use Test mode

Step Detailed Instructions Comments

After the third step, the 
graphics are included in 
the report and the data is 
formatted.

 The Unhide Design Sheets 
command allows you to 
see the Design-Summary 
worksheet while you are 
looking at the results. 
After the Format Quant 
step, the Design 
worksheets are hidden.
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Task 3. Add a single repeating section

A repeating section allows you to organize the rows in a table differently. It 
also allows you to group different tables together. In “Task 4. Add a nested 
repeating section” on page 131, you group different tables together using a 
nested repeating section.

In this task, you add a single repeating section which lets you change how the 
data in a table is included. When you add a table to a template, the Add-in 
automatically creates the template using the first ID in the table and then the 
second ID. For example, when you add a Target Compound table to the 
template, the SampleID is the first ID, so the table has all of the information 
for each sample grouped together. By adding a repeating section, we can 
instead group all of the information about each compound together.

A repeating section is similar to the programming concept of a For/Next loop. 
CMD:Repeat is equivalent to “For each item in the Column Selected repeat the 
following lines”. CMD:EndRepeat is equivalent to “Next” or the end of the 
lines to repeat.

Task 3. Add a single repeating section

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ESTD\
Parts\iii_Custom_QuantReport_
ESTD_Summary.xltx.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, iii_Custom_QuantReport_
ESTD_Summary.xltx, where “iii” are 
your initials.

• Make a copy of the 
QuantReport_ESTD_Summary_B_0
4_00.xltx template and rename it to 
iii_Custom_QuantReport_
ESTD_Summary.xltx, where “iii” are 
your initials.

2 Add a repeating section at the end 
of the template.
• Add the Target Compound table.
• Repeat this table using the 

CompoundID.

a Select the first column in row 25.
b Click Add Data > Target Compound 

Table in the Add-Ins tab in the Ribbon. 
The Target Compound Information 
table is added at the end of the report.

c Select rows 26 to 27. Click the row 
number 26 and drag to include row 27.

• You can also fix the headers of this 
table to match the headers of the 
other tables in this template. 
Right-click the headers, and click 
the B button in the shortcut menu 
to change the font.
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Figure 86 Adding a single repeating section.

d Click Add Formatting > Repeating 
Section in the Add-Ins tab in the 
Ribbon.

e In the Select Column dialog box, select 
CompoundID.

f Click OK.

• Usually, you repeat using one of the 
ID columns.

• In order to have the compound 
information printed together, select 
the CompoundID.

• Two commands are added to the 
template. CMD:Repeat is added 
before row 26 and CMD:EndRepeat 
is added after row 27.

Task 3. Add a single repeating section

Step Detailed Instructions Comments

Row 26 and 27 are 
selected. Row 25 is not 
selected because that row 
is not being repeated.
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Figure 87 The repeating section is added around the Target Compound Information table

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Scroll the report until you find the 

Target Compound Information table. 
All of the information for each 
compound is grouped together. The 
column headers are repeated between 
each compound because that row is 
part of the repeating section.

• In the Advanced Properties dialog 
box, you can click Hide Header Row 
if you don’t want to repeat the 
header row for each compound.

Task 3. Add a single repeating section

Step Detailed Instructions Comments

The command 
CMD:Repeat is added 
before the selected rows. 
The column that is 
selected is printed in the 
second column. This is the 

The command 
CMD:EndRepeat is added 
after the selected rows. 
The column that is 
selected is also printed in 
this row. This is the end of 
the repeating section.
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Figure 88 The results after adding a repeating section using the CompoundID

4 Save the changes to the template, 
iii_1_Custom_QuantReport_
ESTD_Summary.xlt.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_1_Custom_QuantReport_
ESTD_Summary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ESTD\Parts folder.

Task 3. Add a single repeating section

Step Detailed Instructions Comments

The rows about each 
compound are grouped 
together.
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Task 4. Add a nested repeating section

A repeating section allows you to organize the rows in a table differently. It 
also allows you to group different tables together. In “Task 3. Add a single 
repeating section” on page 127, you add a single repeating section which lets 
you change how the data in a table is organized.

In this task, you group different tables together using a nested repeating 
section. A nested repeating section is simply a repeating section that is within 
another repeating section. When repeating sections are nested, the inner 
repeating section needs to end before the outer repeating section ends.

• CMD:Repeat Item1

• CMD:Repeat Item2

Rows in the template

• CMD:EndRepeat Item2

• CMD:EndRepeat Item1

Task 4. Add a nested repeating section

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ESTD\
Parts\
iii_1_Custom_QuantReport_ESTD
_Summary.xltx.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, iii_1_Custom_QuantReport_
ESTD_Summary.xltx., where “iii” are 
your initials.

• If you do not have the 
iii_1_Custom_QuantReport_ESTD_
Summary.xltx template, example 
templates are available on the 
Agilent Technologies MassHunter 
Reporting User Information DVD in 
the Familiarization Templates 
folder.

2 Add a nested repeating section at 
the end of the template.
• Add the Compound Graphics 

inside of the repeating section at 
the end of the report.

• Add an inner repeating section 
repeating on the SampleID.

a Select row 29.
b Right-click and click Insert to add a 

new row to the template.
c Click the first column in row 30.
d Click Add Graphics > Compound 

Graphics in the Add-Ins tab in the 
Ribbon.

e Select rows 27 to 32. Click the row 
number 27 and drag to include row 32.

• Do not include the rows containing 
the commands CMD:Repeat nor 
CMD:EndRepeat.
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Figure 89 Selecting both tables inside of the Repeating Section

f Click Add Formatting > Repeating 
Section in the Add-Ins tab in the 
Ribbon.

g In the Select Column dialog box, select 
SampleID.

h Click OK.

• Do not select the CompoundID 
item. The CompoundID has already 
been used in the outer repeating 
section.

• If we did not add an inner repeating 
section, then the report would be 
organized differently. For each 
compound, all of the samples in the 
Target Compound Information table 
would be included, and then all of 
the samples in the Compound 
Graphics would be included. 

Task 4. Add a nested repeating section

Step Detailed Instructions Comments

Rows 27 through 32 are 
selected. The CMD:Repeat 
row and the 
CMD:EndRepeat rows are 
not selected.
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Figure 90 An inner repeating section is added which includes both tables

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Scroll the report until you find the 

Target Compound Information table. 
All of the information for each 
compound is grouped together. Within 
each compound, the Sample 
Information and the Compound 
Graphics from each sample are 
grouped together.

Task 4. Add a nested repeating section

Step Detailed Instructions Comments

The command 
CMD:Repeat is added 
before the selected rows, 
and the command 
CMD:EndRepeat is added 
after the selected rows. 
Both of these commands 
are between the original 
CMD:Repeat CompoundID 
and CMD:EndRepeat 
CompoundID rows.
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Figure 91 The results of a repeating section using the CompoundID

4 Save the changes to the template, 
iii_2_Custom_QuantReport_ESTD
_Summary.xlt.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_2_Custom_QuantReport_ESTD_Su
mmary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ESTD\Parts folder.

Task 4. Add a nested repeating section

Step Detailed Instructions Comments

The report is organized so that 
all of the information for each 
compound is grouped together 
(the outer repeating section). 
Within each compound 
section, the information for 
each sample is grouped 
together.

Compound 1 Sample 1

Compound 1 Sample 2
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Task 5. Change values on the Options worksheet

The Options worksheet is part of every template that is shipped with the 
software. The values on this worksheet are used to set some of the formatting 
options. The values in the first table are only used if the Use Options value is 
set to True. Many of the Quantitative Analysis templates set this value to False, 
by default. Many of the Qualitative Analysis templates set this value to True by 
default.

Two options that affect the speed of report generation are Add Smart Page 
Breaks and Adjust Columns to Fit Data. These options are needed for proper 
formatting of a report. However, if you are only interested in creating output 
for a LIMS system, you may choose to set both off these options to FALSE.

Task 5. Change values on the Options worksheet

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template \MassHunter\Report 
Templates\Qual\Letter\
iii_4_CustomAnalysisReport.xltx, 
where iii are your initials.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_4_CustomAnalysisReport.xltx, 
where “iii” are your initials.

• If you did not create this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Switch to the Options worksheet.
• Set Use Options to True
• Set Include Header to False
• Set Include Footer to False

a Click the Options worksheet at the 
bottom of the program.

b Find the Use Options row.
c Select True in the Value column.
d Find the Include Header row.
e Select False in the Value column.
f Find the Include Footer row.
g Select False in the Value column.

• Only change the values in the Value 
column.

• The Options in the first section only 
change the report if the Use Options 
value is True.

• The options in the second section 
are not affected by the Use Options 
value.

• If you have a template that is 
missing an option, you can add that 
option to the options template by 
copying the option line from a 
template that does have that line. 
You have to remember to explicitly 
name the Value cell of that row to 
the value that was shown in the old 
template.
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Figure 92 Change the values in the Options worksheet

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the \MassHunter

\Reports\Temp folder.
d Double-click one of the folders that 

contains analysis results.
e Select Report.xml.
f Click Open.
g Click OK.
h Click the Microsoft Office Button and 

click Print > Print Preview.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

Task 5. Change values on the Options worksheet

Step Detailed Instructions Comments

Only change the Value 
column. In this example, the 
Include Header and Include 
Footer values are set to 
False. The header and footer 
will not be printed in the 

Each cell in the Value column 
is explicitly named. You can 
see the name of the cell here.
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Figure 93 Verifying that the header and footer are not shown

4 Save the template to 
iii_5_CustomAnalysisReport.xltx, 
where iii are your initials.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_5_CustomAnalysisReport.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

• See the MassHunter Report 
Designer Training for more 
information on the different options.

Task 5. Change values on the Options worksheet

Step Detailed Instructions Comments

The header and the footer 
are not included in the 

The Qualitative Analysis 
program lets you set several 
of these options in the user 
interface. The values that 
you set here in the template 
are overridden by the values 
in the Qualitative Analysis 
user interface when you 
print from the Qualitative 
Analysis programs.
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Task 6. Add a formula using the IF function

One of the Excel functions that you can use in a formula is the IF function. The 
IF function has the following format:

=IF(LogicalTest,Value If True, Value If False)

This formula allows you to do one of two actions, depending on whether the 
logical test is true or not. 

In this example, you check whether or not a formula is found for a peak. If the 
formula is not found, then the text “Not Found” is printed. If the formula is 
found, then the formula is printed.

The IF function is very powerful. See the Excel online Help for more 
information on this feature.

Task 6. Add a formula using the IF function

Step Detailed Instructions Comments

1 Open the Qualitative Analysis 
template \MassHunter\Report 
Templates\Qual\Letter\
iii_5_CustomAnalysisReport.xltx, 
where iii are your initials.

a Follow the instructions in “Task 1. 
Open a Qualitative Analysis 
template” on page 32 to open the 
template, 
iii_5_CustomAnalysisReport.xltx, 
where “iii” are your initials.

• If you did not create this template, 
example templates are available on 
the Agilent Technologies 
MassHunter Reporting User 
Information DVD in the 
Familiarization Templates folder.

2 Add a formula column to the 
second Peak List table.
• If the formula is not defined, 

print “Not Found”.
• If the formula is defined, print 

the formula.

a Find the Formula column in the Peak 
List table that is at the end of the 
report.

b Click the Formula column.
c Click Add Data > Formula Column in 

the Add-Ins tab in the Ribbon.
d Click the Formulas tab.
e Click Insert Function.
f In the Insert Function dialog box, 

select IF.
g Click OK.

• See the online Help for Excel for a 
complete description of the IF 
formula and other possible 
formulas.
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Figure 94 Select the IF function

h Click the Logical_test box.
i Click the cell in the Formula column.
j Type =”” in the Logical_test box.
k Type “Not Found” in the 

Value_if_true box.
l Click the Value_if_false box.
m Click the cell in the Formula column.
n Click OK.

• See the online Help for Excel for a 
complete description of the IF 
formula and other possible 
formulas.

Task 6. Add a formula using the IF function

Step Detailed Instructions Comments

Select the IF function and click OK.
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Figure 95 Enter the formula using the Function Arguments dialog box

3 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the \MassHunter

\Reports\Temp folder.
d Double-click one of the folders that 

contains analysis results.
e Select Report.xml.
f Click Open.
g Click OK.
h Find the Peak Table at the end of the 

report.
i Compare the Formula column and the 

Formula2 column.

• The Process Report command is 
part of the MassHunter toolbar in 
the Add-Ins tab in the Ribbon.

• This template has more than one 
Peak Table. Make sure that you find 
the Peak Table at the end of the 
template.

• Make sure that the results contain 
compounds that have the formula 
defined.

Task 6. Add a formula using the IF function

Step Detailed Instructions Comments

You click the cell in the 
Formula column in the table 
to get [Formula] added to the 
Logical_test and the 
Value_if_false boxes.
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Figure 96 The empty cells in the Formula column are replaced with “Not Found” in the Formula2 column

4 Save the template to 
iii_6_CustomAnalysisReport.xltx, 
where iii are your initials.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_6_CustomAnalysisReport.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Qual\en-US\
Letter folder.

Task 6. Add a formula using the IF function

Step Detailed Instructions Comments

When the cell in the 
Formula column is empty, 
the Formula2 column 
contains “Not Found”.

You can hide the original 
column using the Advanced 
Properties dialog box. You 
select the Formula column 
and click the Hidden button. 
The formula is visible in the 
Formula2 column.
Agilent MassHunter Workstation Software Reporting Familiarization Guide 141



6 Advanced topics 
Task 7. Use the VLOOKUP function
Task 7. Use the VLOOKUP function

In this task, you use the function VLOOKUP in a template to look up limits for 
different compounds. The VLOOKUP function allows you to look in a table to 
find a specific value, and then it returns another value in that row. The main 
steps that you need to do are:

1 Add a tab that contains the lookup table.

2 Add the formula column to the table that uses the VLOOKUP function.

3 Add a second formula column that uses the value returned by the 
VLOOKUP function.

The VLOOKUP function does slow down processing of the report, so you want 
to make the VLOOKUP range as small as possible.

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

1 Open the Quantitative Analysis 
template, \MassHunter\Report 
Templates\Quant\Letter\ESTD\
Parts\
iii_2_Custom_QuantReport_ESTD
_Summary.xltx.

a Follow the instructions in “Task 4. 
Open a Quantitative Analysis 
template” on page 42 to open the 
template, iii_2_Custom_QuantReport_
ESTD_Summary.xltx., where “iii” are 
your initials.

• If you do not have the 
iii_2_Custom_QuantReport_ESTD_
Summary.xltx template, example 
templates are available on the 
Agilent Technologies MassHunter 
Reporting User Information DVD in 
the Familiarization Templates 
folder.

2 Add a new worksheet to the 
template that contains the 
VLOOKUP range. For this example, 
we will use the following arbitrary 
values
• Amp 5
• Cocaine 6
• Meth 7
• MDMA 8

a Press Shift and F11. A new worksheet 
is added.

b Click the first column in row 1.
c Type Compounds.
d Click the second column in row 1.
e Type Limits.
f Enter the four compound names in the 

Compounds column.
g Enter the four limits in the Limits 

column.
h Right-click the tab at the bottom of the 

worksheet. 
i Click Rename.
j Type Limits and press Enter.

• You can also click the Insert 
Worksheet tab that is next to the 
other tabs at the bottom of the 
program.

• Instead, you can add the lookup 
table to the Options tab. The 
Options tab is not printed when the 
report is printed.
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Figure 97 Adding the new worksheet and renaming it Limits

k Click Advanced Properties in the 
Add-Ins tab in the Ribbon.

l Click the Design Worksheet tab.
m Mark the Active worksheet is a 

design worksheet check box.
n Mark the Exclude worksheet from 

final report check box.
o Click Close.

• If the Exclude worksheet from final 
report check box is marked, this 
worksheet is not printed when the 
report is printed.

Figure 98 Mark both check boxes in this dialog box

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

The Compounds and Limits are 
added to the worksheet.

The name of the worksheet is 
changed to Limits.

The name of the worksheet is shown 
in this dialog box, but you cannot edit 
it in this tab.
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3 Add the VLOOKUP formula column. a Click the Design-Summary worksheet 
tab.

b Find the Compound column in the 
second Quantitation Results table.

c Click Add Data > Formula Column.
d Rename the new column Limits.
e Click the cell containing the words 

Enter formula here.
f Click the Formulas tab in the Ribbon.
g Click Insert Function.
h In the select a category box, select 

Lookup & Reference.
i Select VLOOKUP in the Select a 

function list.
j Click OK.
k Click the cell containing the value in 

the Compound column.

• See Task 3. Add a formula column to 
a table for more information on 
adding a formula column. 

Figure 99 Add the Lookup_value to the Function Arguments dialog box

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

The Lookup_value is the 
value that you want to look 
up in the Limits 
worksheet. So, you click 
on the cell in the 
Compound column that 
contains the results. Do 
not click on the column 
header.
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l Click the Table_array box in the 
Function Arguments dialog box.

m Click the Limits worksheet tab.
n Click and drag to select the area 

containing the compound names and 
the limits.

• When you click the Limits 
worksheet tab, “Limits!” is added to 
the Table_array box.

Figure 100 Add the Table_array value to the Function Arguments dialog box

o In the Table_array box, select the 
entire string.

p Press F4.
q Type 2 in the Col_index_num box in 

the Function Arguments dialog box.
r Type False in the Range_lookup 

box.
s Click OK.

• When you press F4, a “$” is added 
before each column or row 
reference. This makes the cell 
reference absolute.

• The values are in the second 
column in the worksheet, so you 
type 2 in the Col_index_num box. If 
the values were in the third column, 
you would type 3.

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

Select the area containing 
the compound names and 
limits. You do not include 
the column headers.
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Figure 101 The Function Arguments dialog box for the VLOOKUP function

4 Add the second formula column to 
check if the Final Concentration is 
below the value in the Limits 
column.
• If the value is below the limit, 

print the message “Below limit”.
• Otherwise, print “Pass”.

a Click the Final Conc column in the 
same table.

b Click Add Data > Formula Column.
c Rename the column “Limit Check”.
d Click the cell containing the words 

Enter formula here.
e Click the Formulas tab in the Ribbon.
f Click Insert Function.
g In the select a category box, select 

Logical.
h Select IF in the Select a function list.
i Click OK.
j Click the cell containing the value in 

the Final Conc column.
k Type <
l Click the cell containing the value in 

the Limits column.
m Type Below limit in the 

Value_if_true box.
n Type Pass in the Value_if_false box.
o Click OK.

• See Task 6. Add a formula using the 
IF function for more information on 
adding a formula column using the 
IF function. 

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

Select the area containing the 
compound names and limits. 
You do not include the column 
headers.
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Figure 102 Adding the formula to see if the Final Concentration is above the limits from the VLOOKUP function

5 Test the changes to the template. a Click Process Report.
b Click the Browse button.
c Navigate to the DrugsOfAbuse\

QuantReports\DrugsOfAbuseDemo 
folder.

d Select report.results.xml.
e Click Open.
f Click OK.
g Scroll to the Quantitation Results 

table.
h Compare the results in the Limits 

column to the results in the Final Conc 
column and then check the Limit 
Check column.

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

The quotation marks are automatically 
added when you leave the field.
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Figure 103 Two different formula columns were added to the Target Compound table

6 Save the changes to the template, 
iii_3_Custom_QuantReport_ESTD
_Summary.xlt.
• You have to clear the results 

first.

a Click Clear Results in the Add-Ins tab 
in the Ribbon.

b Click the Microsoft Office Button and 
then click Save As and click Other 
Formats.

c In the Save As dialog box, type 
iii_3_Custom_QuantReport_ESTD_Su
mmary.xltx.

d Verify the folder selected in Save in is 
correct.

e Click Save.

• The Save as type is Excel Template 
(*.xltx) for most reports. If the 
report you are modifying has the 
extension .XLT, then the Save as 
type selection is Excel 97-2003 
Template (*.xlt).

• If you change the Save as type, the 
folder is automatically changed to 
the Microsoft Templates folder. 
Navigate to the \MassHunter\
Report Templates\Quant\en-US\
Letter\ESTD\Parts folder.

Task 7. Use the VLOOKUP function to add a Limits column

Step Detailed Instructions Comments

The Limits column contains the 
value from the Limits tab that 
was next to this Compound 
name.

The Limit Check column 
contains the word “Below 
Limit” if the Final 
Concentration is below the 
Limit. It contains the word 
“Pass” if the Final 
Concentration is not less than 
the Limit.
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