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In This Guide…
This guide contains information to learn to use your Agilent 
MassHunter Workstation Software -  Qualitative Analysis . 

Before you begin the exercises, please read the instructions 
in “Before you begin these exercises..." on page 8.

Exercise 1 Learn basics of qualitative analysis

In this exercise, you explore some of the many powerful 
capabilities of the Qualitative Analysis program. These tasks are 
important no matter what data type you are using.

Exercise 2 Find and identify compounds

In the first two sets of tasks, you find and identify 
low- concentration sulfa drugs within a complex matrix and 
generate their formulas for both TOF and Q- TOF data. You 
also do a molecular feature extraction on a protein digest 
with both TOF and Q- TOF data. These tasks can also be 
performed on Triple Quad data.

Exercise 3 Set up and run qualitative analysis methods using different 
workflows

In this exercise, you learn to set up and run any qualitative 
analysis method. You also learn to edit a method to 
automate the analysis and/or compound identification. Then 
you run the actions within the automated method when you 
open a data file. You also learn to create a method to 
perform automated actions with a worklist. Each of these 
tasks is done using a different workflow.

Reference

In this chapter, you learn some basics about the Qualitative 
Analysis program.
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What’s New

in B.03.01 (Qualitative Analysis)

• The Find Compounds by Formula algorithm now supports 
finding compounds using a compound exchange file (CEF).

• You can export compounds in compound exchange format 
(CEF) format.

• You can import compounds that are in compound exchange 
format (CEF) format.

• You can convert a profile spectrum to a centroid spectrum.

• You can search an accurate mass library for MS/MS spectra.

• A structure is displayed in a spectrum pane after doing a 
library search or a database search, if the structure is 
available.

• When you copy a spectrum to the Clipboard, it is copied as a 
bitmap and as a MOL file. You can copy the MOL file 
directly into the Library Editor program.

• For the Find Compounds by Targeted MS/MS results, you 
can either extract a separate MS/MS spectrum for each 
collision energy or an average MS/MS spectrum for all 
collision energies.

• For the Find Compounds by Auto MS/SM algorithm, you can 
filter results by fragment masses or neutral losses. 

• System suitability values are also calculated for MS signals.

• The Chemical Data Dictionary is available as part of the 
Qualitative Analysis program. This tool is used with the 
MassHunter Optimizer program.

• You can now define and match sequences in the Qualitative 
Analysis program. This tool is used with the MassHunter 
Optimizer program.

• You can click on a CAS number, a KEGG number, an HMP 
number or an LMP number and automatically search a site 
on the internet for that number. You can specify which 
web site to use.
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in B.03.00 (Qualitative Analysis)

• GC/QQQ data is supported.

• MS library search and MS/MS library search are supported.

• If a structure is available in the library, then you can view it 
in the Structure Viewer window and include it in reports.

• Difference spectra are automatically displayed in the 
difference window after a library search is done.

• Chromatogram Deconvolution, a new Find Compounds 
algorithm, is supported.

• The Universal integrator is supported.

in B.02.00 (Qualitative Analysis)

• The Agilent MassHunter BioConfirm Software is supported. 
This software allows you to create, edit and import 
sequences and then match sequences. Sequences can be 
provided in the protein column in the worklist. The 
Chemical Data Dictionary Editor is now included.

• Four different workflows are supported, including 
BioConfirm. Each workflow has its own method, layout and 
special section in the Method Explorer to help you do your 
tasks more easily.

• System suitability calculations can be created when 
integrating UV chromatograms. You can specify different 
pharmacopoeia.

• You can automatically subtract an averaged spectrum from a 
designated time range when extracting a peak spectrum.

• When determining Charge State, three different isotope 
models are supported: common organic molecules, peptides, 
and unbiased.

• When determining Charge State, you can specify to treat ion 
with an unassigned charge state as singly- charged.

• The Maximum Entropy Deconvolution is improved to create 
cleaner spectra. You can increase the number of iterations 
and specify the singlet width.

• For compounds with resolved isotopes, you can deconvolute 
using the new Deconvolute: Resolved Isotope algorithm.
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• Three different target data type are available for the Find 
Compounds by Molecular Feature algorithm.

• You can filter the compounds found by the Find Compounds 
by Molecular Feature algorithm before these compounds are 
written to the MHD file. This MHD file is used by Mass 
Profiler and GeneSpring.

• You can extract EIC and Raw Spectrum automatically when 
using the Find Compounds by Molecular Feature algorithm.

• You can specify a list of masses to exclude or include in the 
Find Compounds by Molecular Feature algorithm. You can 
either type this list in directly or specify a database to use.

• When determining Charge State in the Find Compounds by 
Molecular Feature algorithm, you can specify to treat ion 
with an unassigned charge state as singly- charged.

• You can specify whether or not to include ions with only one 
ion in the results for the Find Compounds by Molecular 
Feature algorithm.

• When using the Find Compounds by Formula algorithm, you 
can include sample purity calculations. You can calculate 
based on area or height, and you can use any of all of the 
following algorithms: TIC %, EIC/TIC %, ADC %, UV A %, UV 
B %, UV C %, or TWC %.

• In the Search Database algorithm, the scoring now is based 
upon accurate mass of monoisotopic ion, isotope spacing 
and isotope ratios. You can control how these three scores 
are weighted when calculating the overall score.

• The Find Compounds by Molecular Feature algorithm has 
been improved for cases with exotic elements. For example, 
the algorithm has been improved when the compound has 
many isotopes with strange patterns or a first isotope with a 
low abundance.

• In the Find Compounds by Molecular Formula algorithm, 
you can control how the different scores are weighted when 
calculating the overall score. The three parts of the score are 
mass position, isotope abundance and isotope spacing.

• The Compound Automation algorithm includes the option to 
Match Sequences. You can also specify whether to include 
only identified compounds.
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• You can save a report as a PDF file using the Microsoft PDF 
Generator Add- in. You can download this Excel 2007 add- in 
free from Microsoft.

• You can export in multiple formats: ASR, Compound 
Summary CSV, MGF and mzData. The ASR format includes 
Find by Formula results with Sample Purity (either one file 
per data file or merged). The Compound Summary CSV 
format includes mass lists (one file per data file or merged). 
The MGF format includes peptides with MS/MS spectrum 
and precursor (one file per data file or merged). The mzData 
format now has more options available.

• When printing graphics, you can select to print all graphics, 
only highlighted graphics, or only graphics that are visible. 
You can also print directly from the toolbar of any of the 
graphics windows.

• The new Excel 2007 Report Designer Add- in is supported. 
This add- in supports printing graphics side- by- side.

• Easy Access version B.02.00 is supported.

• System performance is improved.

• You can configure the compound label. You can choose from 
11 different peak labels. You can select to only include the 
first attribute that is defined or to include all of the defined 
attributes.

• You can now configure the user interface. You can select 
what types of features to show in the user interface based 
upon separation types, mass accuracy, non- ms detectors, 
BioConfirm features, and Advanced features.

in B.01.03 (Qualitative Analysis)

• Dual mode data is supported.

• UV data files can be opened.

• You can search a database for molecular formula, mass or 
mass and retention time.

• You can find compounds in a data file based on formula that 
are specified.

• You can specify what parts of an analysis report and 
compound report to include.
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• Excel 2007 is supported for Qualitative Analysis.

• You can integrate UV and other types of chromatograms.

• You can view UV spectra.

• You can automate the creation of a compound report 
including which find compounds algorithm to use and which 
compound identification algorithm to use.

• You can automate the creation of an analysis report 
including which chromatograms to extract, which spectra to 
extract and which spectra identification algorithms to use.

Before you begin these exercises...
• Copy the folder named Data from your installation disk in 

uncompressed format to any location on your hard disk. 

This folder contains all the data files needed for these 
exercises. You may need to first extract the data files from 
their .zip format.

NOTE Do not reuse the example data files already on your system unless you 
know that you copied them from the originals on the disk and you are the 
only one using them. If the example data files already on the system do not 
match the original ones on the disk exactly, then the results obtained 
during these exercises will not match those shown in the guide.
8 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Contents

Exercise 1 Learn basics of qualitative analysis      13

Basic Tasks for All Data      16

Task 1. Open the Qualitative Analysis program      16
Task 2. Zoom in and out of the chromatogram      19
Task 3. Anchor a chromatogram      21
Task 4. Change window layouts      22
Task 5. Print an analysis report      24

Tasks for MS-Only Data (TOF, Q-TOF or Triple Quad)      26

Task 6. Extract chromatograms (MS only)      26
Task 7. Interactively integrate a chromatogram (MS only)      28
Task 8. Extract spectra from a chromatogram (MS only)      31

Tasks for LC/MS/MS Data (Q-TOF and Triple Quad)      38

Task 9. Extract chromatograms (LC/MS and LC/MS/MS)      38
Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS)      40
Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS)      45

Tasks for MS and UV Data      55

Task 12. Extract chromatograms (MS and UV)      55
Task 13. Interactively integrate a chromatogram (UV) and calculate System 

Suitability values (MS and UV)      57
Task 14. Extract spectra from a chromatogram (UV)      60

Tasks for GC-MS data      64

Task 15. Configure User Interface for GC      64
Task 16. Extract chromatograms from a GC/MS data file      66
Task 17. Interactively integrate a GC/MS chromatogram      70
Task 18. Basic tasks for a GC/MS data file      75
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide 9



Contents
Exercise 2 Find and identify compounds      85

Tasks for MS-Only Data (LC/MS - TOF, Q-TOF or Triple Quad)      87

Task 1. Find compounds by molecular feature (LC/MS - MS only)      87
Task 2. Generate formulas and identify compounds (LC/MS - MS only)      91
Task 3. Print a compound report (LC/MS - MS only)      93
Task 4. Find compounds by formula and calculate sample purity (LC/MS - MS 

only)      95
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS 

only)      98

Tasks for MS/MS Data (LC/MS - Q-TOF or Triple Quad)      101

Task 1. Find compounds (LC/MS - MS and MS/MS)      101
Task 2. Identify compounds and generate formulas (LC/MS - MS and 

MS/MS)      104
Task 3. Print a compound report (LC/MS - MS/MS)      107
Task 4. Find Compounds and Search Accurate Mass Library (LC/MS - 

MS/MS)      109
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS and 

MS/MS)      112

Tasks for GC/MS Data (Triple Quad)      114

Task 1. Find compounds by chromatogram deconvolution (GC/MS - MS 
only)      114

Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS 
only)      117

Exercise 3 Set up and run qualitative analysis methods using different 
workflows      121

Task 1. Set up and run a qualitative analysis method using the general 
workflow      122

Task 2. Set up and run a method to automate an analysis using the 
Chromatogram Peak Survey workflow      128

Task 3. Set up and run a method to automate compound identification using the 
MS Target Compound Screening workflow      133

Task 4. Set up a qualitative method to run with a worklist      138
10 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Contents
Reference      141

Work with windows      142
Work with result data in Data Navigator      144
Perform operations on the chromatogram      145
Perform operations on an MS or MS/MS spectrum      146
Work with chromatographic visual data      147
Workflows      148
Customize a report template      151
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide 11



Contents
12 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide
Exercise 1
Learn basics of qualitative analysis

Basic Tasks for All Data    16

Task 1. Open the Qualitative Analysis program    16

Task 2. Zoom in and out of the chromatogram    19

Task 3. Anchor a chromatogram    21

Task 4. Change window layouts    22

Task 5. Print an analysis report    24

Tasks for MS-Only Data (TOF, Q-TOF or Triple Quad)    26

Task 6. Extract chromatograms (MS only)    26

Task 7. Interactively integrate a chromatogram (MS only)    28

Task 8. Extract spectra from a chromatogram (MS only)    31

Tasks for LC/MS/MS Data (Q-TOF and Triple Quad)    38

Task 9. Extract chromatograms (LC/MS and LC/MS/MS)    38

Task 10. Interactively integrate a chromatogram (LC/MS and 
LC/MS/MS)    40

Task 11. Extract spectra from a chromatogram (LC/MS and 
LC/MS/MS)    45

Tasks for MS and UV Data    55

Task 12. Extract chromatograms (MS and UV)    55

Task 13. Interactively integrate a chromatogram (UV) and calculate 
System Suitability values (MS and UV)    57

Task 14. Extract spectra from a chromatogram (UV)    60

Tasks for GC-MS data    64

Task 15. Configure User Interface for GC    64

Task 16. Extract chromatograms from a GC/MS data file    66

Task 17. Interactively integrate a GC/MS chromatogram    70

Task 18. Basic tasks for a GC/MS data file    75
13Agilent Technologies



1 Learn basics of qualitative analysis 
In this exercise, you explore some of the many powerful capabilities of the 
Qualitative Analysis program for working with TOF, Q- TOF and Triple Quad 
data.

First, you perform tasks whose instructions are independent of the data type.

• In Task 1, you open the program with multiple data files.

• In Task 2, you zoom in and out on specific points of data.

• In Task 3, you anchor a chromatogram so it never disappears from view 
when scrolling.

• In Task 4, you change the layout of the windows.

• In Task 5, you print an analysis report.

Then you choose whether to work with MS- only data, combined MS and 
MS/MS data, combined MS and UV data or GC/MS data. 

In these tasks, you work with MS-only data: 

• In Task 6. Extract chromatograms (MS only), you extract 
chromatograms at various levels and merge the EICs.

• In Task 7. Interactively integrate a chromatogram (MS only), you 
integrate chromatograms, change the integration parameters and 
calculate the S/N ratio for integrated peaks.

• In Task 8. Extract spectra from a chromatogram (MS only), you extract 
spectra from specific points and ranges in a chromatogram, learning to 
average them and subtract background data.

In these tasks, you work with combined MS and MS/MS data:

• Task 9. Extract chromatograms (LC/MS and LC/MS/MS)

• Task 10. Interactively integrate a chromatogram (LC/MS and 
LC/MS/MS)

• Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS)

In these tasks, you work with combined MS and UV data:

• Task 12. Extract chromatograms (MS and UV)

• Task 13. Interactively integrate a chromatogram (UV) and calculate 
System Suitability values (MS and UV)

• Task 14. Extract spectra from a chromatogram (UV)
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Learn basics of qualitative analysis 1
In these tasks, you work with GC/MS data:

• Task 15. Configure User Interface for GC

• Task 16. Extract chromatograms from a GC/MS data file

• Task 17. Interactively integrate a GC/MS chromatogram

• Task 18. Basic tasks for a GC/MS data file

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step- by- step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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1 Learn basics of qualitative analysis 
Basic Tasks for All Data
Basic Tasks for All Data

Task 1. Open the Qualitative Analysis program

In this task you open multiple data files using the current method.

 

Task 1. Open the Qualitative Analysis program with multiple data files 

Steps Detailed Instructions Comments

1 Open the Qualitative Analysis 
program. 
• Open the data files, 

sulfas-PosAutoMSMS, 
sulfas-PosMS.d and 
sulfas-PosTargetedMSMS.d in 
the folder 
\\MassHunter\Data, or in the 
folder where you copied them.

a Double-click the Agilent MassHunter 
Qualitative Analysis icon . 
The system displays the Open Data 
Files dialog box.

b Go to the folder \\MassHunter\
Data\LC or the folder where the 
example files are located.

• The sulfas-PosMS.d file contains 
MS (TOF or Q-TOF) data, and the 
sulfas-PosAutoMSMS.d and 
sulfas-PosTargetedMSMS.d files 
contain both MS and MS/MS 
(Q-TOF) data.

• You can get help for any window, 
dialog box, or tab by pressing the 
F1 key when that window is active.

• Make sure that Use current 
method is clicked.

• Make sure that the check box for 
Run ‘File Open’ actions from 
selected method is clear.

Figure 1 Open data files when opening software
16 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Learn basics of qualitative analysis 1
Task 1. Open the Qualitative Analysis program
c Press and hold the Shift key while you 
click sulfas_PosAutoMSMS, 
sulfas_PosMS.d and 
sulfas-PosTargetedMSMS.d.

d Click Open.
All three data files are displayed in 
Data Navigator, and 1-3 
chromatograms are displayed in the 
Chromatogram Results window.

e Click the List Mode icon  in the 
Chromatogram Results toolbar.

• If you press the Ctrl key instead, 
you can pick files which are not 
directly next to each other in the 
list.

• What you see in the main window 
at this point depends on the 
method, layout, display and plot 
settings used before you opened 
these files.

Figure 2 Qualitative Analysis main window

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments
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1 Learn basics of qualitative analysis 
Task 1. Open the Qualitative Analysis program
2 Return the main window to the 
default worfklow, General. The 
default method and layout are 
loaded.
• Make sure you can see all three 

chromatograms.

a If necessary, click Tools > Configure 
for Workflow > General.

b Click the down arrow next to the 
Maximum Number of List Panes icon 
in the Chromatogram Results Toolbar, 
and select 3.

• The display and plot settings remain 
the same even after you switch to 
the General workflow. These 
settings are set in the Plot Display 
Options dialog box.

• You can change the layout by 
clicking View > Window Layouts > 
Load Layout.

Figure 3 Qualitative Analysis main window with the General Workflow selected. 

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments

Maximum 
Number of 
List Panes 
icon
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Learn basics of qualitative analysis 1
Task 2. Zoom in and out of the chromatogram
Task 2. Zoom in and out of the chromatogram

In this task, you become familiar with the zoom in and zoom out features of 
the Qualitative Analysis program.

Task 2. Zoom in and out of the chromatogram 

Steps Detailed Instructions Comments

1 Practice zooming in and out of only 
one out of the three 
chromatograms (both x and y 
axes).
• Hide the others.
• Zoom in twice on last peak.
• Zoom in one more time 

autoscaling the y-axis.
• Zoom out once to the previous 

zoom position.
• Completely zoom out to the 

original chromatogram.

a Clear the check boxes in the Data 
Navigator window for the 
chromatograms you want to hide.

b Click the right mouse button and drag 
over an area on the last peak. 
Make sure that the Autoscale Y-axis 
during Zoom icon, , is not selected 
for this step. 

c Repeat step b.
d Click the Autoscale Y-axis during 

Zoom icon, , in the toolbar. 
e Click the right mouse button again and 

drag over an area of the last peak for 
the third time.
The Quality Analysis program 
automatically scales the y-axis to the 
largest point in the range.

f Click the Unzoom icon  to undo the 
last zoom operation. 
You can undo the last fifteen zoom 
operations.

g Click the Autoscale X-axis and Y-axis 
icon  to zoom out completely. 

• If a line is not checked in the Data 
Navigator window, that information 
is not displayed in any other 
window in the Qualitative Analysis 
program. You simply mark that line 
in the Data Navigator window, and 
the information is displayed in the 
other windows again.

• You can also use these zoom 
features on spectra in the Spectrum 
Preview window, the MS Spectrum 
Results window, the Deconvolution 
Results window and the UV Results 
window.

• A selected icon has an orange 
background color.
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1 Learn basics of qualitative analysis 
Task 2. Zoom in and out of the chromatogram
2 Practice zooming in and out on 
each axis separately.
• Zoom in only along the x-axis.

Hint: Right-click the x-axis 
values and move cursor from 
left to right.

• Partially zoom out the x-axis.
Hint: Move cursor in opposite 
direction.

• Completely zoom out of the 
x-axis.

• Repeat the previous steps for the 
y-axis.

a To zoom in on the x-axis, move the 
cursor to the x-axis values until a 
horizontal double arrow appears.

b Click the right mouse button and drag 
the new cursor from left to right across 
the x-axis values. 

c To zoom out on the x-axis, click the 
right mouse button and drag from right 
to left on the x-axis values.

d Click the Autoscale X-axis icon  to 
completely zoom out on the x-axis. 

a To zoom in on the y-axis, move the 
cursor to the y-axis values until a 
vertical double arrow appears.

b Click the right mouse button and drag 
the new cursor from bottom to top 
across the y-axis values. 

c To zoom out on the y-axis, click the 
right mouse button and drag from the 
top towards the bottom of the y-axis 
values.

d Click the Autoscale Y-axis icon  to 
completely zoom out on the y-axis. 

Task 2. Zoom in and out of the chromatogram (continued)

Steps Detailed Instructions Comments

Horizontal 
Double Arrow

New cursor 
appears when you 
right-click the 
x-axis values.

New cursor 
appears when 
you right-click 
the y-axis values.

Vertical Double 
Arrow
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Learn basics of qualitative analysis 1
Task 3. Anchor a chromatogram
Task 3. Anchor a chromatogram

In this task, you anchor a chromatogram. When you anchor a chromatogram, 
the anchored chromatogram remains permanently on display as you scroll 
through the other chromatograms to display them.

Task 3. Anchor a chromatogram 

Steps Detailed Instructions Comments

• Anchor a chromatogram.
• Show all three chromatograms.
• Make sure the chromatogram 

viewing list is set to 1.
• In the Chromatogram Results 

window, select the second TIC.
• Anchor this TIC.
• Scroll through the 

chromatograms.
• Clear the anchor.

a In Data Navigator mark the check 
boxes for the chromatograms you hid 
in the previous task.

b Make sure the maximum number of 
panes is set to 1 in the Chromatogram 
Results window.

c In the Chromatogram Results window, 
select the second TIC.

d Right-click inside the chromatogram, 
and click Set Anchor.

e Use the scroll bar in the 
Chromatogram Results window to 
scroll through the list of 
chromatograms. The second TIC stays 
visible always. 

f Click Chromatograms > Clear Anchor.

• When you set an anchor for a 
chromatogram, an anchor icon 
appears in Data Navigator next to 
the name of the anchored 
chromatogram.

• Two chromatograms appear in the 
Chromatogram Results window 
after you anchor one even though 
the viewing list says 1. This now 
means you view one chromatogram 
in addition to the anchored 
chromatogram.

• You can also right-click the 
chromatogram and then click Clear 
Anchor in the shortcut menu.

Figure 4 Anchored TIC 
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1 Learn basics of qualitative analysis 
Task 4. Change window layouts
Task 4. Change window layouts

In this task, you move windows within the Main View and create various 
window layouts.

Task 4. Change window layout 

Steps Detailed Instructions Comments

1 Change the window layout:
• Change the window size.
• Save a window layout.
• Unlock the layout.
• Change the Chromatogram 

Results window to be floating.
• Move the Chromatogram Results 

window.
• Display the tools for 

repositioning the windows.

• To change the size of a window, drag 
the boundary between the windows.

• To save a window layout, click View > 
Window Layouts > Save Layout.

• To unlock a layout, click View > 
Window Layouts > Lock Layout. 

• To make a window float, right-click the 
title bar of the Chromatogram Results 
window, and click Floating from the 
shortcut menu.

• To move a window, click on the title bar 
of the Chromatogram Results window 
and drag the window to the desired 
location. 

• To display the repositioning tools, drag 
the window over one of the other 
windows. When one window is 
overlapped with another, the program 
displays several layout tools, as shown 
in Figure 5.

• If the layout is unlocked, the system 
does not display an icon in the Lock 
Layout menu.

• You can only use the repositioning 
tools when the layout is unlocked.

• You can also make a window float 
by double-clicking the title bar of 
the window.

• The software has many different 
layouts created. You can also try 
loading different layouts.

• The software has four different 
workflows. Each workflow loads a 
different layout. Switching to a 
different workflow also changes the 
layout.

• If the BioConfirm program is 
installed, it also has a different 
workflow and layout.

Figure 5 Window repositioning tools
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Task 4. Change window layouts
2 Reposition the Chromatogram 
Results window.
• Move the window so that it is at 

the top, to the left, to the right 
and then at the bottom of the 
other windows.

• Move two windows together so 
that they are on top of one 
another and available only 
through the tabs at the bottom. 

• Restore the default layout.

• If you drag the cursor over one of the 
smaller icons, the window you are 
dragging will be placed above, to the 
right, below, or to the left of all of the 
other windows. 

• Drag the cursor over the larger icon. 
The window can also be placed above, 
to the right, below, or to the left of the 
other window by dragging the cursor 
over the edges of the larger icon.

• To tab two windows together, drag the 
cursor over the center of the larger 
icon. You will see a shadow version of 
the two windows tabbed together. Stop 
dragging the mouse. The two windows 
will be tabbed together.

• Click View > Window Layouts > 
Restore Default Layout.

• The cursor must be over one of the 
arrows in a box in order for 
repositioning to occur.

• Clicking the Restore Default Layout 
command restores the layout that is 
used with the General workflow. If 
you are using a different workflow, 
you need to load the layout that is 
used with that workflow.

Task 4. Change window layout (continued)

Steps Detailed Instructions Comments
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Task 5. Print an analysis report
Task 5. Print an analysis report

Whenever you want to print an analysis report after performing any of the 
tasks in this exercise or the next one, use these instructions. 

An analysis report can contain the results from extracting and integrating 
chromatograms, extracting spectra, finding compounds, searching the 
database for peak spectra or generating formulas from peak spectra. 

Task 5. Print an analysis report 

Steps Detailed Instructions Comments

1 Change the analysis report 
selections:
• Mark the check boxes for the 

chromatograms, spectra or 
tables you want to print.

• Clear the check boxes for the 
chromatograms, spectra or 
tables you do not want to print.

a In Method Explorer, click General > 
Analysis Report.

b Mark the check boxes for any 
additional selections you want to print.

c Clear any chromatogram and spectra 
choices you do not want to print.

• The Analysis report only contains 
the information that you mark in 
this section. 

• Also, if some results are not 
available, then those results are not 
included, even if those results are 
marked in this section. For example, 
if you have not integrated the 
chromatogram, then the peak table 
is not included. 

Figure 6 Analysis Report window in Method Editor
24 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Learn basics of qualitative analysis 1
Task 5. Print an analysis report
2 Print the report. • You can interactively print the report in 
multiple ways:
• From the main menu, click File > 

Print > Analysis Report.
• From the main toolbar, click the 

Printer icon.
• Click the Print Analysis Report icon, 

 in the Method Editor 
toolbar.

• Right-click the Analysis Report 
section in the Method Editor, and 
click Print Analysis Report.

• From the data file shortcut menu in 
the Data Navigator, click Print 
Analysis Report.

The Run icon  in the Method 
Editor toolbar sometimes allows you to 
choose an action from a set of 
possible actions. For example, if you 
switch to the General > Common 
Reporting Options section, four 
different actions are possible when 
you click the Run icon. If you click the 
arrow, a list of possible actions is 
shown, and you can choose which 
action to do. Choosing a different 
action from the list changes the 
default action. If you simply click the 
Run button, the default action is 
performed.

Task 5. Print an analysis report (continued)

Steps Detailed Instructions Comments
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Tasks for MS-Only Data (TOF, Q-TOF or Triple Quad)

Perform these tasks with MS data from a TOF instrument and MS- only data 
from a Q- TOF instrument.

Task 6. Extract chromatograms (MS only)

In this task, you extract and merge chromatograms from the original TIC. 

Task 6. Extract chromatograms (MS only) 

Steps Detailed Instructions Comments

1 Extract and merge extracted ion 
chromatograms (EICs) from two 
masses in the sulfas-PosMS.d 
data file.
• The m/z values are 279.09102 

and 311.08085.
• Merge the peaks from the 

individual masses into one 
chromatogram.

a In the Data Navigator window, clear 
the check boxes for the data files 
except for sulfas-PosMS.d.

b Open the Extract Chromatograms 
dialog box, using the option below or 
one of the options to the right: 
• Click Chromatograms > Extract 

Chromatograms.
c In the List of opened data files, click 

sulfas-PosMS.d.
d In the Type list, click EIC.
e In the m/z value(s) field, type 
279.09102, 311.08085. 

f Mark the Merge multiple masses into 
one chromatogram check box to 
merge the EICs.

g Click OK.
h Make sure the Maximum number of 

list panes is set to 3 in the 
Chromatogram Results toolbar.

• You can also extract 
chromatograms in one of the 
following ways:
• Right-click inside the 

chromatogram, and click Extract 
Chromatograms.

• From Data Navigator, highlight 
the TIC Scan for 
sulfas_PosMS.d, then right-click 
TIC Scan and click Extract 
Chromatograms.

• You can use an MS level of either 
All or MS.

• Note that you can also choose to 
have the extracted chromatogram 
automatically integrated after 
extraction.

• You can also extract a 
chromatogram from a mass 
spectrum.
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Task 6. Extract chromatograms (MS only)
Figure 7 The Extract Chromatograms dialog box.

Figure 8 Merged extracted ion chromatograms (EICs) compared to the 
original TIC

Task 6. Extract chromatograms (MS only) (continued)

Steps Detailed Instructions Comments
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Task 7. Interactively integrate a chromatogram (MS only)

In this task, you learn different ways to interactively integrate a 
chromatogram, change integration parameters to modify the results and view 
the signal- to- noise ratio for each peak.

Task 7. Interactively integrate a chromatogram (MS only) 

Steps Detailed Instructions Comments

1 Integrate the sulfas_PosMS.d TIC 
chromatogram.

• Integrate the sulfas_PosMS.d 
chromatogram, using any of the 
following options.
• From the main menu, click 

Chromatograms > Integrate 
Chromatogram.

• Highlight the chromatogram. Then, 
right-click the chromatogram, and 
click Integrate Chromatogram.

• In Data Navigator, highlight TIC 
Scan in the sulfas_PosMS.d > User 
Chromatograms section. Then, 
right-click TIC Scan and click 
Integrate Chromatogram.

• The integration uses the General 
Integrator, because that is the 
integrator selected in the method 
default.m. You can change this 
value in the Chromatogram > 
Integrate (MS) > Integration tab.

• Note that the integration with 
default parameters is detecting very 
small peaks.

Figure 9 Shortcut menu from Data Navigator and integrated sulfas_PosMS.d TIC chromatogram
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2 Integrate the extracted ion 
chromatogram (EIC) from Task 1.

• Right-click anywhere in the EIC 
window, and click Integrate 
Chromatogram.

• Normally you would mark the check 
box, Integrate when extracted, in 
the Extract Chromatogram dialog 
box when you set up for extraction.

3 Change the filter parameters for 
the integrated TIC. 
• Display the Integration Method 

Editor window from Method 
Explorer for MS data.

• Change the threshold to retain 
only the two largest peaks.

a From Method Explorer, click 
Chromatogram > Integrate (MS) to 
display the Integrator tab.

b Click the Peak Filters tab.
c Under Maximum number of peaks, 

mark Limit (by height) to the largest, 
if necessary, and type in 2.

d Click the TIC Scan in the Data 
Navigator window.

• Note the blue triangle that appears 
when you change a setting from the 
value that is saved in the current 
method. When you save the 
method, the triangles disappear.

Figure 10 Peak Filters tab with Limit (by height) to the largest marked

4 Reintegrate the chromatogram. • Click the Integrate Chromatogram 
icon  on the Method Editor toolbar 
to integrate using the new setting.

• Note that only the two largest 
peaks are now integrated.

Figure 11 Integration results with limited number of peaks

Task 7. Interactively integrate a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Task 7. Interactively integrate a chromatogram (MS only)
5 Calculate the signal-to-noise ratio.
• Select the sulfas_PosMS.d TIC.
• Set the first Peak Label to Area 

and the second Peak Label for 
the chromatographic peaks to 
Signal-to-noise.

• Open the Method Editor.
• Use 0.63 – 0.73 for the 

noise region, and calculate the 
signal-to-noise ratio for the 
integrated peaks.

a Click Tools > Plot Display Options.
b Click the Chromatogram tab.
c Set the first Peak labels to Area and 

the second Peak labels to 
Signal-to-Noise. 

d Click OK.
e In the Method Explorer, click 

Chromatogram > Calculate 
Signal-to-Noise.

f Type 0.63 - 0.73 for the Noise 
regions, and click the Calculate 
Signal to Noise icon .

• Make sure the TIC is highlighted 
before you calculate the 
signal-to-noise.

• The area that you specified to be 
the noise region is drawn in bold in 
the Chromatogram Results window.

Figure 12 Integrated TIC with Area and Signal-to-Noise labels

6 Restore the settings for the default 
method, and close Method Editor.

a To cancel your changes and restore 
the values from the default method, 
click the Restore to last saved values 
from file icon on the Method 
Editor toolbar. 

b Close Method Editor.

7 Return the peak labels to Retention 
Time.

a Click Tools > Plot Display Options. 
b Click the Chromatogram tab.
c Set the first Peak Label to Retention 

Time and the second Peak Label to 
None.

d Click OK.

Task 7. Interactively integrate a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Task 8. Extract spectra from a chromatogram (MS only)
Task 8. Extract spectra from a chromatogram (MS only)

In this task, you extract a spectrum from exactly where you specify in the 
chromatogram. You can tell the Qualitative Analysis program to extract a 
spectrum from a specific data point or extract an average spectrum from an 
average of multiple data points or ranges.

This task also shows you how to change spectral display options and subtract 
the background spectrum.

Task 8. Extract spectra from a chromatogram (MS only) 

Steps Detailed Instructions Comments

1 Extract spectra on specific data 
points for the peak at 0.79 min. and 
the last peak of the 
sulfas_PosMS.d data file.
• After zooming in on the region 

between 0.7 and 1.0 minutes, 
extract a spectrum from the peak 
at or near 0.79 minutes using any 
one of the options described 
under Comments.

• Open Spectrum Preview.
• After zooming in on the region 

between 1.1 and 1.4 minutes, 
extract a spectrum from the peak 
at or near 1.22 minutes.

• Copy this spectrum to the User 
Spectra section.

• Change the display to show at 
least two spectra.

a To zoom in to the first peak, right-click 
the mouse above the peak at 0.70 min. 
and drag it to below the curve at 1.0 
min., then release. 

b On the peak near 0.79 min. extract a 
spectrum in any of the ways listed in 
the Comments column.

c Click the Zoom Out icon, , in the 
Chromatogram Results toolbar.

d To open Spectrum Preview, click the 
Spectrum Preview icon, 

e Zoom into the region between 1.1 and 
1.4 min. 

f On the peak near 1.22 min. extract a 
spectrum in any of the ways listed in 
the Comments column. The spectrum 
is shown in the Spectrum Preview 
window.

g Right-click the spectrum in the 
Spectrum Preview window, and click 
Copy to User Spectra.
The Spectrum Preview window is not 
closed. 

h If necessary, click the arrow next to 
the Maximum number of list panes 
icon in the MS Spectrum Results 
toolbar, and click 2.

i Close the Method Editor window.

• When you zoom, make sure the 
AutoScale Y-axis during Zoom icon, 

is “on”. The background of the 
icon is orange when it is “on”.

• You can extract a spectrum in any of 
the following ways:
• Double-click the data point in the 

chromatogram. 
• Click the data point in the 

chromatogram, then right-click 
anywhere in the chromatogram. 
Click Extract MS Spectrum. The 
Extract Spectrum dialog box is 
displayed. Make sure the 
sulfas_PosMS.d file is selected, 
and click Extract.

• Note that when you first extract a 
spectrum, the MS Spectrum Results 
window appears containing the 
spectrum, and the type of spectrum 
and retention time appear under 
User Spectra in the Data Navigator. 

• When Spectrum Preview is enabled, 
the system displays any 
manually-selected spectrum but it is 
not kept in the User Spectra section.

• With Spectrum Preview on, 
Qualitative Analysis overwrites the 
previous spectrum when you 
extract a new spectrum.
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Figure 13 Main window with extracted spectra from both integrated peaks in the sulfas_PosMS.d file

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
32 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Learn basics of qualitative analysis 1
Task 8. Extract spectra from a chromatogram (MS only)
2 Extract a spectrum that averages 
all points within a specified range 
for the last integrated peak for the 
sulfas_PosMS.d data file:
• Delete any existing User Spectra.
• Zoom out of the chromatogram.
• Turn off Spectrum Preview.
• Use the Range Select icon on the 

Chromatogram toolbar.
• Set the range from the halfway 

point on the left to the same 
point on the right of the peak. 

• Extract the spectrum, using any 
of the options listed.

a Highlight the User Spectra to be 
deleted (Use Ctrl).

b Right-click the selected User Spectra, 
and click Delete.

c Click Yes in the Delete dialog box, if it 
is displayed.

d Click the Autoscale X-axis and Y-axis 
icon  to zoom out completely. 

e Close the Spectrum Preview window.
f Click the Range Select icon on the 

Chromatogram toolbar.
g Click at the halfway point on the left 

side of the last integrated peak and 
drag over to the halfway point on the 
right. 

h Extract the average spectrum using an 
option below or on the right.
• Right-click anywhere in the range of 

the peak, and click Extract MS 
Spectrum from the shortcut menu. 

• Click Extract in the Extract 
Spectrum dialog box.

• You can also delete all user spectra 
if you right-click the User Spectra 
line in the Data Navigator window 
and click Delete.

• You can also extract an average 
spectrum by double-clicking the 
selected range in the 
chromatogram.

• You can change whether or not you 
are asked to confirm every time you 
delete a chromatogram or spectrum 
by using the Message Box Options 
dialog box. This dialog box is 
displayed from the Tools > 
Message Box Options command.

• The Extract Spectrum dialog box is 
only shown if more than one data 
file is loaded.

Figure 14 Average spectrum extracted from selected range for last peak

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Task 8. Extract spectra from a chromatogram (MS only)
3 Extract a spectrum that averages 
the ranges of integrated peaks 1 
and 2 together for the 
sulfas_PosMS.d data file.
• Hint: Use the Range Select icon 

and the Ctrl key to select the 
Peak 1 range taken from the 
halfway point.

• Extract the spectrum, using any 
of the options on the right.

a Click the Chromatogram Results 
window title bar. The Chromatogram 
Results window becomes the active 
window, and the selected area is not 
lost.

b Press and hold the Ctrl key.
c Click at the halfway point on the left 

side of the first integrated peak, and 
drag over to the halfway point on the 
right. 

d Release the mouse.
e Release the Ctrl key.
f Extract the average spectrum using 

this option or the one on the right:
• Double-click inside the selected 

range in either peak.

• Remember that the second peak 
already has a range selected from 
step 2.

• You can also extract a spectrum by 
right-clicking anywhere in the 
chromatogram, and then click 
Extract MS Spectrum. The Extract 
Spectrum dialog box is shown. Click 
Extract.

Figure 15 An averaged spectrum created from multiple ranges.

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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4 Change the spectral display option 
for sulfas_PosMS.d.
• Change the digits after the 

decimal to one more than the 
current setting.

• Change back to the original 
number of digits.

a Click Tools > Plot Display Options.
b Click the MS and MS/MS Spectra 

tab.
c Set Digits after the decimal to one 

more than the current setting for the 
m/z values.

d Click OK.

e Repeat steps a and b, then set Digits 
after the decimal to one less than the 
current setting.

f Click OK.

• Note that the label now shows m/z 
with one more digit.

•
•

• The label should now show the 
original number of digits.

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Task 8. Extract spectra from a chromatogram (MS only)
5 Subtract a background spectrum 
every time you extract a peak 
spectrum in sulfas_PosMS.d.
• Delete any scans under User 

Spectra in Data Navigator.
• Extract a background spectrum 

in the region of 0.0 to 0.25 
minutes and have it appear in 
the Background Spectrum folder 
in Data Navigator.

• Use the current background MS 
spectrum for subtraction.

• Integrate the chromatogram, 
limiting the integrated peaks to 
4.

• Extract a peak spectrum from the 
third integrated peak.

a Under User Spectra in Data Navigator, 
highlight the User Spectra to be 
deleted (Press the Ctrl key).

b Right-click the spectra, and click 
Delete. Click Yes.

c Make sure the Range Select icon is 
selected in the Chromatogram Results 
toolbar, and drag the cursor between 
0.0 and 0.25 min.

d Right-click within the range, and click 
Extract MS Spectrum to Background.

e If a dialog box is shown, select the 
Sulfas_PosMS.d data file and click OK.

f In Method Explorer click Spectrum > 
Extract MS.

g Click the Manual Extraction tab.
h Under Manual Spectrum Background, 

select Current background spectrum 
for the MS spectrum.

i From Method Explorer click 
Chromatogram > Integrate (MS).

j Click the Peak Filters tab.
k Mark the Limit (by height) to the 

largest check box, and type 4.
l From the main menu click 

Chromatograms > Integrate 
Chromatogram > Entire 
Chromatogram.

m Click the Peak Select icon in the 
Chromatogram Results toolbar.

n Select the third integrated peak, and 
extract a peak spectrum using one of 
the following options
• Double-click the peak.
• Right-click the peak and click 

Extract peak spectrum.
• Click Chromatograms > Extract 

Peak Spectrum.
• Right-click the chromatogram in the 

Data Navigator window and click 
Extract Peak Spectrum.

• Note that at the end of this process, 
all extracted peak spectra will 
automatically have the designated 
background spectrum subtracted.

• As an alternative way to move a 
background spectrum to the 
Background Spectrum folder, follow 
these steps:
• Double-click the selected range 

to extract an averaged spectrum.
• Right-click anywhere in the 

spectrum window and click 
Move to Background Spectrum. 

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Figure 16 Spectrum with background subtracted

Task 8. Extract spectra from a chromatogram (MS only) (continued)

Steps Detailed Instructions Comments
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Tasks for LC/MS/MS Data (Q-TOF and Triple Quad)

Task 9. Extract chromatograms (LC/MS and LC/MS/MS)

In this task, you extract one chromatogram for MS data and one for MS/MS 
data in order to integrate the peaks. You cannot integrate the TIC of the 
original chromatogram because it contains both MS and MS/MS data.

Task 9. Extract chromatograms (MS and MS/MS) 

Steps Detailed Instructions Comments

1 Extract TICs for the MS data in the 
sulfas_PosTargetedMSMS.d data 
file.

a In the Data Navigator, mark the check 
box for sulfas_PosTargetedMSMS.d 
and clear the check boxes for the other 
data files.

b Display the Extract Chromatograms 
dialog box, using the option below or 
one of the options to the right: 
• Click Chromatograms > Extract 

Chromatograms.
c In the List of opened data files, click 

sulfas_PosTargetedMSMS.d, if 
necessary.

d Make sure the Type is TIC.
e From the MS Level list, click MS.
f Click OK.

• You can also extract 
chromatograms in one of the 
following ways:
• Right-click inside the 

chromatogram, and click Extract 
Chromatograms.

• From Data Navigator, click User 
Chromatograms > TIC MS (All), 
then right-click TIC MS (All) and 
click Extract Chromatograms.

• You can also extract 
chromatograms from mass spectra.
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Task 9. Extract chromatograms (LC/MS and LC/MS/MS)
Figure 17 The Extract Chromatograms dialog box.

2 Extract another chromatogram but 
based on a product ion for the 
MS/MS data.
• This time choose to integrate the 

extracted chromatogram.

a Repeat steps b-c of Step 1. 
b Click EIC as the Type.
c From the MS Level list, click MS/MS.
d From the Scans list, click Product ion.
e From the Precursor ion m/z, click 

279.09100.
f In the m/z value(s) text box, type 

186.03299.
g Mark the Integrate when extracted 

check box.
h Click OK.

• In the m/z value(s) text box, you 
can also type a range (for example, 
100 - 300)

Figure 18 TIC for MS and EIC for MS/MS data compared to the original TIC

Task 9. Extract chromatograms (MS and MS/MS) (continued)

Steps Detailed Instructions Comments
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Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS)
Task 10. Interactively integrate a chromatogram (LC/MS and 
LC/MS/MS)

In this task, you learn different ways to integrate a chromatogram, change 
integration parameters to modify the results and calculate the S/N for the 
integrated peaks for MS/MS data.

You cannot integrate the original Q- TOF TIC chromatogram because it 
contains both MS and MS/MS data, possibly in no particular order.

Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS) 

Steps Detailed Instructions Comments

1 Integrate the TIC Scan 
chromatogram for the 
sulfas_PosTargetedMSMS.d data 
file, using any of the options listed 
at right.

a Highlight the TIC Scan chromatogram, 
and choose from any one of the 
following commands to integrate the 
chromatogram.
• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 
chromatogram window, and click 
Integrate Chromatogram.

• In the Data Navigator window, 
select sulfas_PosTargetedMSMS.d 
> User Chromatograms > TIC 
Scan, then right-click the TIC Scan 
and click Integrate Chromatogram.

• Note that the program integrated 
practically all the peaks in the 
chromatogram.

• You select the integrator to use for 
MS data, MS/MS data, UV data and 
ADC data in the Method Editor 
window.

2 Change the threshold to integrate 
fewer peaks.
• Change the threshold to retain 

only the two largest peaks.

a From Method Explorer, click 
Chromatogram > Integrate (MS) to 
display the Integrator tab.

b Click the Peak Filters tab.
c In the Maximum number of peaks box, 

mark Limit (by height) to the largest, 
if necessary, and type in 2.

• Note the blue triangle that appears 
when you change a setting from the 
value saved in the current method. 
When you save the method, the 
triangles disappear.
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Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS)
Figure 19 Peak Filters tab with Limit (by height) to the largest marked

3 Reintegrate the chromatogram. d Click the  button on the Method 
Editor toolbar to integrate using the 
new setting.

• Note that only the two largest 
peaks are now integrated.

Figure 20 Integrated TIC MS and MS/MS chromatograms with higher threshold setting

Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS)
4 Integrate the EIC Product Ion 
chromatogram for the 
sulfas_PosTargetedMSMS.d data 
file, using any of the options listed 
at right.

a Highlight the EIC Product Ion 
chromatogram, and choose from any 
one of the following commands to 
integrate the chromatogram.
• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 
chromatogram window, and click 
Integrate Chromatogram.

• In the Data Navigator window, 
select sulfas_PosTargetedMSMS.d 
> User Chromatograms > EIC 
Product Ion then right-click the EIC 
Product Ion and click Integrate 
Chromatogram.

• Note that the program integrated 
practically all the peaks in the 
chromatogram.

• You select the integrator to use for 
MS data, MS/MS data, UV data and 
ADC data in the Method Editor 
window.

5 Change the filter to filter on height.
• Display the Integration Method 

Editor window from Method 
Explorer for MS/MS data.

• Change the Filter on value to 
peak height

• Mark the Absolute height check 
box.

a From Method Explorer, click 
Chromatogram > Integrate (MS/MS) 
to display the Integrator tab.

b Click the Peak Filters tab.
c Under Filter on, click Peak height.
d Under Height filters, mark the 

Absolute height check box.

• Note the blue triangle that appears 
when you change a setting from the 
value saved in the current method. 
When you save the method, the 
triangles disappear.

6 Reintegrate the chromatogram e Click the  button on the Method 
Editor toolbar to integrate using the 
new setting.

• Note that only the largest peak is 
now integrated.

Figure 21 Integrated TIC MS and MS/MS chromatograms with higher threshold setting

Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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7 Calculate the signal-to-noise ratio 
for the EIC of the product ion.
• Set the first Peak Label to Area 

and the second Peak Label for 
the chromatographic peaks to 
Signal-to-noise.

• Open the Method Editor.
• Use 0.0 - 0.76 for the 

noise region, and calculate the 
signal-to-noise ratio for the 
integrated peaks.

a Click Tools > Plot Display Options, 
and set the first Peak label to Area and 
the second Peak label to 
Signal-to-Noise.

b In Method Explorer in the 
Chromatogram section, select 
Calculate Signal to Noise.

c Type 0.0 - 0.76 for the Noise 
regions, and click the Calculate 
Signal to Noise icon .

• Make sure the TIC is highlighted 
before you calculate the 
signal-to-noise.

• The area that you specified to be 
the noise region is drawn in bold in 
the Chromatogram Results window.

Figure 22 Signal-to-Noise results for MS/MS EIC Product Ion

8 Restore the settings that are saved 
for the current method and close 
Method Editor.

a Click the Chromatogram > Calculate 
Signal-to-Noise section in the 
Method Explorer.

b Click the Restore to last saved values 
from file icon on the Method 
Editor toolbar.

c Click the Chromatogram > Integrate 
(MS/MS) section in the Method 
Explorer.

d Click the icon .
e Click the Chromatogram > Integrate 

(MS) section in the Method Explorer.
f Click the icon .
g Close Method Editor.

• To cancel your changes and restore 
the values from the method that is 
loaded, click the Restore to last 
saved values from file icon on 
the Method Editor toolbar. 

Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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9 Return the peak labels to Retention 
Time.

a Click Tools > Plot Display Options.
b Select Retention Time for the first 

Peak label and None for the second 
Peak label.

c Click OK.

10 Delete all chromatograms except 
the original.

a Under User Chromatograms in the 
Data Navigator window, highlight all 
the chromatograms except the 
original.

b Right-click the highlighted 
chromatograms, and click Delete.

Task 10. Interactively integrate a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Task 11. Extract spectra from a chromatogram (LC/MS and 
LC/MS/MS)

In this task, you extract a spectrum from exactly where you specify in the 
chromatogram. You can tell the Qualitative Analysis program to extract a 
spectrum from a specific data point or extract an average spectrum from an 
average of multiple data points or ranges. 

This task also shows you how to walk a chromatogram, change spectral display 
options and subtract the background spectrum.

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) 

Steps Detailed Instructions Comments

1 Walk a chromatogram to view the 
precursor ion and product ion for 
the last peak of 
sulfas_PosTargetedMSMS.d.
• Zoom in on the region between 

1.15 and 1.35 minutes.
• Use the Walk Chromatogram 

icon.
• Review the spectra starting at 

about 1.15 minutes, and move 
the arrow to the right. 

a Click the TIC MS(all) chromatogram in 
the Data Navigator window.

b To zoom in to the last peak, right-click 
the mouse above the peak at 1.15 
minutes and drag it to 1.35 minutes, 
then release. 

c Close the Method Editor window.
d Click the Walk Chromatogram icon 

 on the Chromatogram Results 
toolbar.

e Move the Walk Chromatogram cursor 
to above the X axis at about 1.15 
minutes, and click. 

f To navigate from spectrum to 
spectrum, use the right and left arrow 
keys on your keyboard.

• The Walk Chromatogram tool is 
particularly useful on MS/MS data 
for identifying precursor and 
product ions.

• The spectrum for each point you 
click in the Chromatogram Results 
window is automatically displayed 
in the Spectrum Preview window, 
which is opened automatically.
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Figure 23 Walk chromatogram to view the MS/MS and product ion for the background at 1.223 minutes

Figure 24 Walk chromatogram to view the MS scan for the peak at 1.229 minutes

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments

If you want the Fragmentor 
voltage included in the 
chromatogram title and the 
spectrum title, you mark the 
Expanded check box in the Plot 
Display Options dialog box. You 
mark this check box on the 
Chromatogram tab and the MS 
and MS/MS Spectrum tab.
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2 Extract spectra on specific data 
points for the peak at .33 minutes 
and the last peak of the 
sulfas_PosTargetedMSMS.d data 
file.
• After zooming in on the region 

between 0.3 and 0.4 min., extract 
a spectrum from one of the 
peaks (MS) at or near 0.33 min. 
and then one of the valleys 
(MS/MS), using any one of the 
options described under 
Comments.

• After zooming in on the region 
between 1.15 and 1.25 min., 
extract a spectrum from one of 
the peaks at or near 1.23 min. 
(not the valley yet)

• Change the display to show at 
least three spectra.

a Click the Range Select icon  from 
the Chromatogram Results toolbar.

b Close the Spectrum Preview window.
c Click the Zoom Out icon, , in the 

Chromatogram Results toolbar.
d To zoom in to the first peak, right-click 

the mouse above the peak at 0.3 min. 
and drag it to 0.4 min., then release. 

e On a peak near 0.33 min. extract a 
spectrum in any of the ways listed in 
the Comments column.

f On a valley near 0.34 min., extract the 
spectrum.

g Click the Zoom Out icon, , in the 
Chromatogram Results toolbar.

h Zoom into the region between 1.15 and 
1.25 min. 

i On a peak near 1.23 minutes, extract a 
spectrum in any of the ways listed in 
the Comments column. (Do not extract 
the valley spectrum yet.)

j If necessary, click the arrow next to 
the Maximum number of list panes 
icon in the MS Spectrum Results 
toolbar, and click 3.

• When you zoom, make sure the 
AutoScale Y-axis during Zoom icon, 

is “on”. The background of the 
icon is orange when it is on.

• You can extract a spectrum in any of 
the following ways:
• Double-click the data point in the 

chromatogram. 
• Click the data point in the 

chromatogram, then right-click 
anywhere in the chromatogram. 
Click Extract MS Spectrum. The 
Extract Spectrum dialog box is 
displayed. Make sure the 
sulfas_PosTargetedMSMS.d file 
is selected, and click Extract in 
the Extract Spectrum dialog box.

• Note that when you first extract a 
spectrum, the MS Spectrum Results 
window appears containing the 
spectrum, and the type of spectrum 
and retention time appear under 
User Spectra. All subsequent 
extracted spectra appear in both 
places as well.

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Figure 25 The Qualitative Analysis program with MS Scan and Product Ion spectra from the first peak and 
MS Scan spectrum from the last peak

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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3 Extract a product ion spectrum for 
the last peak of the 
sulfas_PosTargetedMSMS.d data 
file. 
• View the Spectrum Preview 

window.
• Extract a spectrum from the 

valley at RT 1.237 min.
• Copy this spectrum to the User 

Spectra folder.
• Change the display to show 4 

spectra.
• Turn off Spectrum Preview.

a Click the Spectrum Preview icon,  
in the main toolbar.

b On a valley near 1.23 minutes extract a 
spectrum.

c Right-click the spectrum in the 
Spectrum Preview window, and click 
Copy to User Spectra.
The Spectrum Preview window is 
between the Chromatogram Results 
window and the MS Spectrum Results 
window.

d Click the down arrow next to the 
spectrum pane list, and select 4.

e Close the Spectrum Preview window.

• When Spectrum Preview is enabled, 
the system displays any 
manually-selected spectrum in the 
Spectrum Preview window but not 
in the User Spectra section of Data 
Navigator.

• With Spectrum Preview on, 
Qualitative Analysis overwrites the 
previous spectrum when you 
extract a new spectrum.

• Spectrum Preview mode is useful 
when you quickly want to review 
the spectra in your chromatogram 
and save only a few of the spectra.

Figure 26 Main window with product ion spectrum from the last peak in 
the chromatogram

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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4 Extract a spectrum that averages 
all points within a specified range 
for the last peak for the 
sulfas_PosTargeted.d data file:
• Zoom out.
• Use the Range Select icon on the 

Chromatogram toolbar.
• Set the range across the entire 

peak. 
• Extract the spectrum, using any 

of the options listed.

a Click the Autoscale X-axis and Y-axis 
icon  in the Chromatogram Results 
toolbar to zoom out completely. 

b Click the Range Select icon on the 
Chromatogram toolbar.

c Click at about 1.21 minutes of the last 
peak and drag over to about 1.229 
minutes on the right. 

d Extract the average spectrum using 
one of the options on the right.

e Click the down arrow next to the 
Maximum number of list panes icon, 
and select 2.

• You can extract an average 
spectrum by double-clicking the 
selected range in the 
chromatogram. 

• Or, right-click anywhere in the 
chromatogram, and click Extract 
MS Spectrum from the shortcut 
menu. Then, click Extract.

• Note that both the averaged MS 
spectrum and averaged MS/MS 
spectrum appear.

Figure 27 Averaged spectra extracted from selected range for last peak

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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5 Extract spectra that average the 
ranges of peaks 1 and 4 together 
for the sulfas_PosTargeted.d data 
file.
• Hint: Use the Range Select icon 

and the Ctrl key to select the 
Peak 1 range taken from the 
halfway point.

• Extract the spectra, using any of 
the options on the right.

a Press and hold the Ctrl key.
b Click at about 0.3 min. on the left side 

of the first peak and drag over to about 
0.33 min. on the right, and release the 
mouse.

c Release the Ctrl key.
d Extract the averaged spectra using this 

option or the one on the right:
• Double-click inside the selected 

range in either peak.

• Remember that the second peak 
already has a range selected from 
step 4.

• To extract spectra, you can also 
right-click anywhere in the 
chromatogram and clicking Extract 
MS Spectrum. The Extract 
Spectrum dialog box is shown. Click 
Extract.

• The range that you select is shown 
in blue. When you use this range, 
the range that is actually used is 
shown in gray and the blue range is 
removed.

Figure 28 Averaged MS and MS/MS spectra created from multiple 
ranges.

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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6 Subtract a background spectrum 
every time you extract a peak 
spectrum for an MS/MS EIC 
extracted from 
sulfas_PosTargetedMSMS.d.
• Delete any scans under User 

Spectra in Data Navigator.
• Extract a background spectrum 

that is the average of a spectrum 
at the start of the peak and a 
spectrum at the end of the peak.

• Extract a peak spectrum from the 
integrated peaks.

a Under User Spectra in Data Navigator, 
right-click the spectra, and click 
Delete.

b Click Yes.
c Extract an integrated MS/MS EIC of 

ions 279.09100 with an m/z range of 
100-300 (see “Task 9. Extract 
chromatograms (LC/MS and 
LC/MS/MS)” on page 38)

d In Method Explorer, select Spectrum 
> Extract (MS/MS). 

e Click the Peak Spectrum Extraction 
(MS/MS) tab, if not visible.

f Under Peak spectrum background, 
click Average of spectra at peak start 
and end.

g In the Chromatogram Results toolbar, 
click the Peak Select icon.

h Select the peak at 0.8 min.
i Right-click and click Extract Peak 

Spectrum.

• Note that at the end of this process, 
all extracted peak spectra will 
automatically have the designated 
background spectrum subtracted.

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Figure 29 Product ion (MS/MS) spectra with background subtracted

7 Extract an MS/MS EIC based on 
the product ion spectra, 186.03299 
from Step 6.
• Choose to integrate after 

extraction.

a Right-click the Product Ion spectrum.
b Click Extract Chromatograms.
c From the Type list, select EIC.
d Clear the Integrate when extracted 

check box.
e From the MS level list, select MS/MS.
f Type 186.03396, 156.07760 into 

the m/z values box.
g Mark the Merge multiple masses into 

one chromatogram check box.
h Click OK.

• You separate multiple m/z values 
with a comma.

• If you type a single m/z value, then 
it is changed to a range 
automatically by using the Single 
m/z expansion range for this 
chromatogram parameters that are 
entered on the Advanced tab.

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Figure 30 Extract Chromatograms dialog box for EIC based on product 
ions

Figure 31 EIC based on background-subtracted product ion spectra

Task 11. Extract spectra from a chromatogram (LC/MS and LC/MS/MS) (continued)

Steps Detailed Instructions Comments
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Tasks for MS and UV Data

Task 12. Extract chromatograms (MS and UV)

In this task, you extract MS and UV chromatograms from a data file. 

Task 12. Extract chromatograms (MS and UV) 

Steps Detailed Instructions Comments

1 Extract UV chromatograms (DAD1 
and ADC1) from the 
sulfas_PosMS.d data file.
• Hide all data files except 

sulfas_PosMS.d
• Delete all chromatograms except 

the TIC Scan.
• Extract the DAD1 chromatogram.
• Extract the ADC1 chromatogram.
• Change the number of panes 

visible to 3.

a In the Data Navigator window, clear 
the check boxes for the data files 
except for sulfas_PosMS.d.

b Mark the check box for the 
sulfas_PosMS.d data file.

c Delete all chromatograms except the 
TIC Scan.

d Open the Extract Chromatograms 
dialog box, using the option below or 
one of the options to the right: 
• Click Chromatograms > Extract 

Chromatograms.
e In the List of opened data files, click 

sulfas-PosMS.d.
f In the Type list, click Other 

chromatograms.
g In the Detector combo box, select 
DAD1. 

h Click OK.
i Open the Extract Chromatograms 

dialog box.
j In the List of opened data files, click 

sulfas-PosMS.d.
k In the Type list, select Other 

chromatograms.
l In the Detector combo box, select 
ADC1. 

m Click OK.
n Make sure the Maximum number of 

list panes is set to 3 in the 
Chromatogram Results toolbar.

• You can also extract 
chromatograms in one of the 
following ways:
• Right-click inside the 

chromatogram, and click Extract 
Chromatograms.

• From Data Navigator, highlight 
the TIC Scan for 
sulfas_PosMS.d, then right-click 
TIC Scan and click Extract 
Chromatograms.

• Note that you can also choose to 
have the extracted chromatogram 
automatically integrated after 
extraction.
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Figure 32 The Extract Chromatograms dialog box 
with Type Other Chromatograms.

Figure 33 DAD1 and ADC1 compared to the original TIC

Task 12. Extract chromatograms (MS and UV) (continued)

Steps Detailed Instructions Comments
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Task 13. Interactively integrate a chromatogram (UV) and calculate 
System Suitability values (MS and UV)

In this task, you learn different ways to interactively integrate a 
chromatogram, change integration parameters to modify the results and view 
the signal- to- noise ratio for each peak.

Task 13. Interactively integrate a chromatogram (MS and UV) 

Steps Detailed Instructions Comments

1 Integrate the sulfas_PosMS.d UV 
chromatograms, using any of the 
options listed at right.
• Highlight the DAD1 and ADC1 

chromatogram.
• Integrate the chromatograms.

a Highlight the DAD1 and ADC1 
chromatograms.

b Integrate the sulfas_PosMS.d UV 
chromatogram, using any of the 
following options.
• From the main menu, click 

Chromatograms > Integrate 
Chromatogram.

• Highlight the chromatogram. Then, 
right-click the chromatogram, and 
click Integrate Chromatogram.

• In Data Navigator, highlight DAD1 
and ADC1 in the sulfas_PosMS.d > 
User Chromatograms section. Then, 
right-click either chromatogram and 
click Integrate Chromatogram.

• The integration uses the General 
Integrator, because that is the 
integrator selected in the method 
default.m. You can change this 
value in the Chromatogram > 
Integrate (UV) > Integrator tab.

• Note that the integration with 
default parameters is detecting very 
small peaks.
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Figure 34 One of the shortcut menus in the Data Navigator and integrated sulfas_PosMS.d chromatograms

2 Enable system suitability 
calculations. 
• Display the Chromatogram > 

Integrate (UV) > Suitability tab.
• Enable Suitability calculations.

a From Method Explorer, select 
Chromatogram > Integrate (UV) to 
display the Integrator tab.

b Click the Suitability tab.
c Mark Enable system suitability 

calculations.
d Select the United States 

Pharmacopoeia (USP).
e In the Column void time box, type 

0.15.
f In the Column length box, type 500.

• Note the blue triangle that appears 
when you change a setting from the 
value that is saved in the current 
method. When you save the 
method, the triangles disappear.

• The algorithms that are used to set 
several of the columns in the 
Integration Peak List change 
depending on the selected 
pharmacopoeia. See the online Help 
for more information.

Figure 35 Chromatogram > Integrate (UV) Suitability tab

Task 13. Interactively integrate a chromatogram (MS and UV) (continued)

Steps Detailed Instructions Comments
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3 Reintegrate the chromatogram. • Click the Integrate Chromatogram 
icon  on the Method Editor toolbar 
to integrate using the new setting.

4 View the system suitability 
calculations.
• Open the Integration Peak List 

window.
• Review the values for the noise 

region, and calculate the 
signal-to-noise ratio for the 
integrated peaks.

a Click View > Integration peak list.
b Right-click the header of the 

Integration peak list window and click 
Floating.

c Right-click the column header of any 
column that you do not want to see 
and click Remove Column. 

d Right-click any column header and 
click Add/Remove Columns to change 
the columns that are visible.

• The system suitability calculations 
are included in the Integration Peak 
List table.

• These values include k’, Tailing 
factor, Plates, Plates/M, and 
Symmetry.

Figure 36 Integrated TIC with Area and Signal-to-Noise labels

5 Restore the settings for the default 
method, and close the Method 
Editor window and the Integration 
Peak List window.

a To cancel your changes and restore 
the values from the default method, 
click the Restore to last saved values 
from file icon on the Method 
Editor toolbar. 

b Close Method Editor.
c Right-click the header of the 

Integration peak list window and click 
Floating.

d Click View > Integration Peak List.

• When you click the Floating 
command in the shortcut menu the 
second time, the Integration Peak 
List window is docked where it was 
originally.

Task 13. Interactively integrate a chromatogram (MS and UV) (continued)

Steps Detailed Instructions Comments
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Task 14. Extract spectra from a chromatogram (UV)

In this task, you extract a spectrum from exactly where you specify in the 
chromatogram. You can tell the Qualitative Analysis program to extract a UV 
spectrum from a specific data point, extract an averaged UV spectrum from an 
average of multiple data points or ranges, or extract a Peak Spectrum.

Task 14. Extract spectra from a chromatogram (MS and UV) 

Steps Detailed Instructions Comments

1 Extract spectra on specific data 
points for the peak at 1.2 min. and 
the last peak of the 
sulfas_PosMS.d data file.
• Delete the ADC1 chromatogram.
• After zooming in on the region 

between 0.17 and 0.31 minutes, 
extract a spectrum from the peak 
at or near 0.27 minutes using any 
one of the options described 
under Comments.

• Open Spectrum Preview.
• After zooming in on the region 

between 1.1 and 1.3 minutes, 
extract a spectrum from the peak 
at or near 1.17 minutes.

• Copy this spectrum to the User 
Spectra section.

• Change the display to show at 
least two spectra.

a Delete the ADC1 chromatogram.
b Click the Autoscale X-axis and Y-axis 

icon  in the Chromatogram Results 
toolbar to zoom out completely. 

c Click the Range Select icon on the 
Chromatogram Results toolbar.

d Highlight the DAD1 chromatogram.
e To zoom in to the first peak, right-click 

the mouse above the peak at 0.17 min. 
and drag it to below the curve at 0.31 
minutes, then release. 

f On the peak near 0.27 minutes, extract 
a UV spectrum using one of the 
methods in the Comments column.

g Click the Zoom Out icon, , in the 
Chromatogram Results toolbar.

h To open Spectrum Preview, click the 
Spectrum Preview icon, 

i Zoom into the region between 1.1 and 
1.3 min. 

j On the peak near 1.22 min. extract a 
UV spectrum. The spectrum is shown 
in the Spectrum Preview window.

k Right-click the spectrum, and click 
Copy to User Spectra. The Spectrum 
Preview window is tabbed with the UV 
Spectrum Results window.

l If necessary, click the arrow next to 
the Maximum number of list panes 
icon in the UV Spectrum Results 
toolbar, and select 2.

m Close the MS Spectrum Results 
window.

• You cannot extract spectra from an 
ADC chromatogram.

• When you zoom, make sure the 
AutoScale Y-axis during Zoom icon, 

is “on”. The background of the 
icon is orange when it is “on”.

• You can extract a spectrum in any of 
the following ways:
• Double-click the data point in the 

chromatogram. 
• Click the data point in the 

chromatogram, then right-click 
anywhere in the chromatogram. 
Click Extract UV Spectrum. The 
Extract Spectrum dialog box is 
displayed. Make sure the 
sulfas_PosMS.d file is selected, 
and click Extract.

• Note that when you first extract a 
spectrum, the UV Spectrum Results 
window appears containing the 
spectrum, and the type of spectrum 
and retention time appear under 
User Spectra in the Data Navigator. 

• When Spectrum Preview is enabled, 
the system displays any 
manually-selected spectrum but it is 
not kept in the User Spectra section.

• With Spectrum Preview open, 
Qualitative Analysis overwrites the 
previous spectrum when you 
extract a new spectrum.
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Figure 37 Main window with extracted UV spectra from two integrated peaks in the sulfas_PosMS.d file

Task 14. Extract spectra from a chromatogram (MS and UV) (continued)

Steps Detailed Instructions Comments
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2 Extract a spectrum that averages 
all UV points within a specified 
range for the last integrated UV 
peak for the sulfas_PosMS.d data 
file:
• Delete any existing User Spectra.
• Zoom out of the chromatogram.
• Turn off Spectrum Preview.
• Use the Range Select icon on the 

Chromatogram toolbar.
• Set the range from the halfway 

point on the left to the same 
point on the right of the peak. 

• Extract the spectrum, using any 
of the options listed.

a Highlight the User Spectra to be 
deleted (Use Ctrl).

b Right-click the selected User Spectra, 
and click Delete.

c Click Yes in the Delete dialog box, if it 
is displayed.

d Click the Autoscale X-axis and Y-axis 
icon  to zoom out completely. 

e Click the Spectrum Preview window, 
then close the window.

f Click the Range Select icon on the 
Chromatogram toolbar.

g Click at the halfway point on the left 
side of the last integrated peak in the 
DAD1 chromatogram and drag over to 
the halfway point on the right. 

h Extract the averaged spectrum using 
the option below or on the right.
• Right-click anywhere in the range of 

the peak, and click Extract UV 
Spectrum from the shortcut menu. 

• Click Extract in the Extract 
Spectrum dialog box.

• You can also extract an average 
spectrum by double-clicking the 
selected range in the 
chromatogram.

• You can change whether or not you 
are asked to confirm every time you 
delete a chromatogram or spectrum 
by using the Message Box Options 
dialog box. This dialog box is 
displayed from the Tools > 
Message Box Options command.

• The Extract Spectrum dialog box is 
only shown if more than one data 
file is loaded.

Figure 38 Average spectrum extracted from selected range for last peak

Task 14. Extract spectra from a chromatogram (MS and UV) (continued)

Steps Detailed Instructions Comments
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3 Extract a UV peak spectrum in 
sulfas_PosMS.d.
• Delete any scans under User 

Spectra in Data Navigator.
• Integrate the DAD1 

chromatogram.
• Extract a peak spectrum from the 

third integrated peak.

a Under User Spectra in Data Navigator, 
highlight the User Spectra to be 
deleted (Use Ctrl).

b Right-click the spectra, and click 
Delete.

c Click Yes.
d Highlight the DAD1 Chromatogram.
e Click Chromatogram > Integrate 

Chromatogram.
f Click the Peak Select icon in the 

Chromatogram Results toolbar.
g Click the third integrated peak (at 

0.225 minutes) in the DAD1 
chromatogram.

h Right-click the peak and click Extract 
Peak Spectrum.

• Extracted peak spectra are always 
put into either the UV Spectrum 
Results window or the MS 
Spectrum Results window, even if 
the Spectrum Preview window is 
open.

Figure 39 Integrated DAD1 chromatogram and UV Peak Spectrum

4 Close all three data files. a Click File > Close All.
b Click No when asked to save the 

results.

Task 14. Extract spectra from a chromatogram (MS and UV) (continued)

Steps Detailed Instructions Comments
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Tasks for GC-MS data
Tasks for GC-MS data

Task 15. Configure User Interface for GC

In this task, you switch to the General workflow. This is the only workflow that 
supports analyzing GC/MS data. Then, you open the User Interface 
Configuration dialog box and mark the appropriate check boxes for a GC QQQ 
system. 

Task 15. Configure User Interface for GC

Steps Detailed Instructions Comments

1 Open the Qualitative Analysis 
program. 

a Double-click the Agilent MassHunter 
Qualitative Analysis icon . 
The system displays the Open Data 
Files dialog box.

b Click Cancel in the Open Data Files 
dialog box.

• You can get help for any window, 
dialog box, or tab by pressing the 
F1 key when that window is active.

2 Switch to the General Workflow. a Click the View > Configure for 
Workflow > General command.

b Click the List Mode icon  in the 
Chromatogram Results toolbar.

• If the Data Acquisition program for 
GC-QQQ is installed on the same 
computer, the software configures 
the User Interface automatically.

• By default, chromatograms are 
overlaid. For these examples, the 
chromatograms are shown in List 
Mode.
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3 Configure the user interface to 
show GC features only.

a Click Tools > User Interface 
Configuration.

b Under Separation types, only mark the 
GC check box.

c Under Ionization type, mark the EI or 
other “hard” ionization technique 
check box. Clear the CI, APCI, ESI, 
MADLDI or other “soft” ionization 
technique check box

d Under Mass accuracy, clear the 
Accurate mass (TOF, Q-TOF) check 
box. Mark the Unit mass check box.

e Under Optional software features, 
clear the Peptide Sequence Editor 
check box.

f Under Non-MS detectors, clear the UV 
and ADC check boxes.

g Clear the Show advanced parameters 
check box.

h Click OK.

• You change which commands are 
available in the User Interface 
Configuration dialog box. 

• If a feature is not visible, it probably 
was hidden when a check box was 
cleared in the User Interface 
Configuration dialog box.

Figure 40 Configuring the user interface for a GC Triple Quadrupole

Task 15. Configure User Interface for GC

Steps Detailed Instructions Comments
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Task 16. Extract chromatograms from a GC/MS data file

In this task, you extract one BPC chromatogram from a GC/MS data file. You 
also extract an EIC chromatogram from two GC/MS/MS data file.

Task 16. Extract chromatograms from a GC/MS data file 

Steps Detailed Instructions Comments

1 Open the three example GC data 
files. 
• Open the data files, Pest - 200 - 

Scan.D, Pest - STD 200 MRM.D, 
and Pest Strawb-01 SPIKED 1 
ppb - 1 ul inj.D in the folder 
\MassHunter\Data\GC, or in 
the folder where you copied 
them.

a Click File > Close All.
b Click No in the Save dialog box.
c Click File > Open Data File.
d Go to the folder \MassHunter\Data\

GC or the folder where the example 
files are located.

e Select the three data files. 
f Clear the Load result data check box.
g Click Open.

• First, close any other data file that 
was loaded.

• The Pest - 200 -Scan.D file contains 
MS (GC/MS) data, and the Pest - 
STD 200 MRM.D and Pest 
Strawb-01 SPIKED 1 ppb - 1 ul inj.D 
files contain both MS and MS/MS 
(GC/MS) data.

• You can get help for any window, 
dialog box, or tab by pressing the 
F1 key when that window is active.

2 Configure the user interface to 
work with GC data.

• Follow the instructions in Task 15. 
Configure User Interface for GC    64.

3 Extract a BPC for the GC/MS data 
in the Pest - 200 - Scan.d data file.

a In the Data Navigator, mark the check 
box for Pest - 200 - Scan.d and clear 
the check boxes for the other data 
files.

b Open the Extract Chromatograms 
dialog box, using the option below or 
one of the options to the right: 
• Click Chromatograms > Extract 

Chromatograms.
c In the List of opened data files, click 

Pest - 200 - Scan.d, if necessary.
d Make sure the Type is BPC.
e Click OK.

• You can also extract 
chromatograms in one of the 
following ways:
• Right-click inside the 

chromatogram, and click Extract 
Chromatograms.

• From Data Navigator, click one of 
the chromatograms in the User 
Chromatograms section, then 
right-click and click Extract 
Chromatograms.

• You can also extract 
chromatograms based upon a mass 
spectrum.
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Task 16. Extract chromatograms from a GC/MS data file
Figure 41 The Extract Chromatograms dialog box.

Figure 42 TIC for GC/MS and BPC for GC/MS data

Task 16. Extract chromatograms from a GC/MS data file (continued)

Steps Detailed Instructions Comments
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Task 16. Extract chromatograms from a GC/MS data file
4 Extract the 160 -> 133 EIC from the 
MS/MS data files.
• This time choose to integrate the 

extracted chromatogram.

a In the Data Navigator, mark the check 
box for Pest - STD 200 MRM.d and 
Pest Strawb-01 SPIKED 1 ppb - 1 ul 
inj.D and clear the check box for Pest - 
200 - Scan.d.

b Open the Extract Chromatograms 
dialog box, using the option below or 
one of the options to the right: 
• Click Chromatograms > Extract 

Chromatograms.
c In the List of opened data files, click 

Pest - STD 200 MRM.d and Pest 
Strawb-01 SPIKED 1 ppb - 1 ul inj.D, if 
necessary.

d Select EIC as the Type.
e From the MS Level list, select 

MS/MS.
f From the Scans list, select Multiple 

reaction monitor.
g From the Precursor ion m/z, select 

160.
h In the m/z value(s) box, type 133.
i Mark the Integrate when extracted 

check box.
j Clear the Do cycle sum and Merge 

multiple masses into one 
chromatogram check boxes.

k Click OK.

• In the m/z value(s) text box, you 
can also type a range (for example, 
100 - 300) or multiple values 
(for example, 133, 139).

• If you type a single m/z value, it is 
automatically converted to a range 
using the parameters on the 
Advanced tab.

Figure 43 The Extract Chromatograms dialog box.

Task 16. Extract chromatograms from a GC/MS data file (continued)

Steps Detailed Instructions Comments
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5 Change the plot display options to 
not label the Time segment 
markers.

a Click Tools > Plot Display Options.
b In the Plot Display Options dialog box, 

click Line for the Time segment 
markers.

• You can customize how graphics 
are displayed in many different 
ways by modifying values in this 
dialog box.

Figure 44 Plot Display Options dialog box

6 Display all four chromatograms 
from the MS/MS data files at the 
same time.

• Select 4 in the Maximum number of 
list panes box in the Chromatogram 
Results Toolbar.

Figure 45 TIC MRM Chromatograms and EIC MRM Chromatograms for MS/MS data files

Task 16. Extract chromatograms from a GC/MS data file (continued)

Steps Detailed Instructions Comments

The example data files have many 
time segments. You remove the labels 
from the Time segment markers by 
clicking the Line button.

Maximum number of list 
panes box

The two EIC MRM 
chromatograms are 
integrated when they are 
extracted.
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Task 17. Interactively integrate a GC/MS chromatogram

In this task, you learn different ways to integrate a chromatogram, change 
integration parameters to modify the results and calculate the S/N for the 
integrated peaks for MS/MS data.

Task 17. Interactively integrate a chromatogram (GC/MS) 

Steps Detailed Instructions Comments

1 Integrate the TIC Scan 
chromatogram for the Pest - 200 - 
Scan.d data file, using any of the 
options listed at right.

a Mark the Pest - 200 - Scan.D line in the 
Data Navigator window.

b Highlight the TIC Scan chromatogram, 
and use one of the following 
commands:
• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 
chromatogram window, and click 
Integrate Chromatogram.

• In the Data Navigator window, 
select sulfas_PosTargetedMSMS.d 
> User Chromatograms > TIC 
Scan, then right-click the TIC Scan 
and click Integrate Chromatogram.

• Note that the program integrated 
practically all the peaks in the 
chromatogram.

• You select the integrator to use for 
MS data, MS/MS data, UV data and 
ADC data in the Method Editor 
window.

• This chromatogram is an MS 
chromatogram, so the values that 
are set in the Integrate (MS) section 
of the Method Editor are used when 
integrating this chromatogram.

2 Display only two chromatograms at 
the same time.

• Select 2 in the Maximum number of 
list panes box in the Chromatogram 
Results Toolbar.

Figure 46 Integrated TIC Scan Chromatogram with many small peaks

Many small peaks are 
integrated.
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3 Change the threshold to integrate 
fewer peaks.
• Change the threshold to retain 

only the three largest peaks.

a From Method Explorer, click 
Chromatogram > Integrate (MS) to 
display the Integrate (MS) tab.

b Click the Peak Filters tab.
c Under Maximum number of peaks, 

mark Limit (by height) to the largest, 
and type 3.

• Note the blue triangle that appears 
when you change a setting from the 
value saved in the current method. 
When you save the method, the 
triangles disappear.

Figure 47 Peak Filters tab with Limit (by height) to the largest marked

4 Reintegrate the chromatogram d Click the  button on the Method 
Editor toolbar to integrate using the 
new setting.

• Note that only the three largest 
peaks are now integrated.

Figure 48 Integrated TIC Scan chromatogram when limiting the number of peaks

Task 17. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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5 Integrate the TIC MRM and EIC 
MRM chromatograms for the Pest 
- STD 200 MRM.D data file.

a In the Data Navigator window, select 
the TIC MRM for the Pest - STD 200 
MRM.d data file. Press Ctrl and click 
the EIC MRM chromatogram.

b Use one of the following commands to 
integrate the chromatograms.
• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 
chromatogram window, and click 
Integrate Chromatogram.

• In the Data Navigator window, 
right-click the highlighted 
chromatograms and click Integrate 
Chromatogram.

• Press the Ctrl key to highlight more 
than one chromatogram in the Data 
Navigator window.

• Note that the program integrated 
practically all the peaks in the 
chromatogram.

• These chromatograms are MS/MS 
chromatograms, so the values that 
are set in the Integrate (MS/MS) 
section of the Method Editor 
window are used when integrating 
this chromatogram. You can select 
one integrator to use to integrate 
MS chromatograms and a different 
integrator to use to integrate 
MS/MS chromatograms.

Figure 49 Integrated MRM chromatograms 

6 Select the MS/MS (GC) 
integrator. Change the filter to only 
accept peaks with an absolute 
height greater or equal to 10,000.

a From Method Explorer, select 
Chromatogram > Integrate 
(MS/MS).

b Select MS/MS (GC).
c Click the Peak Filters tab.
d Under Filter on, click Peak height.
e Under Height filters, mark the 

Absolute height check box.
f Type 10000 as the Absolute height.

• Note the blue triangle that appears 
when you change a setting from the 
value saved in the current method. 
When you save the method, the 
triangles disappear.

Task 17. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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Task 17. Interactively integrate a GC/MS chromatogram
Figure 50 Peak Filters tab with Absolute height marked

7 Reintegrate the chromatogram g Click the  button on the Method 
Editor toolbar.

• Note that only the largest peaks are 
now integrated.

Figure 51 Integrated TIC MS and MS/MS chromatograms with higher threshold setting

8 Restore the settings that are saved 
for the current method and close 
Method Editor.

a Select the Chromatogram > Integrate 
(MS/MS) section in the Method 
Explorer.

b Click the icon .
c Select the Chromatogram > Integrate 

(MS) section in the Method Explorer.
d Click the icon .
e Close Method Editor.

• To cancel your changes and restore 
the values from the method that is 
loaded, click the Restore to last 
saved values from file icon on 
the Method Editor toolbar. 

Task 17. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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9 Delete all chromatograms except 
the original. Delete the integration 
results on the original 
chromatogram.

a Under User Chromatograms in the 
Data Navigator window, highlight all 
the chromatograms except the 
original.

b Right-click the highlighted 
chromatograms, and click Delete.

c Click Chromatograms >Clear Results.

Task 17. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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Task 18. Basic tasks for a GC/MS data file

In this task, you extract a spectrum from exactly where you specify in the 
chromatogram. You can tell the Qualitative Analysis program to extract a 
spectrum from a specific data point or extract an average spectrum from an 
average of multiple data points or ranges. 

This task also shows you how to walk a chromatogram, change spectral display 
options, subtract the background spectrum and integrate and extract peak 
spectra.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments

1 Walk a chromatogram to view the 
precursor ion and product ion for 
the last few peaks of Pest - STD 
200 MRM.d.
• Zoom in on the region between 

13 and 16 minutes.
• Use the Walk Chromatogram 

icon.
• Review the spectra starting at 

about 13 minutes, and move the 
arrow to the right. 

a Click on the TIC MRM chromatogram 
in the Data Navigator window.

b Close the Method Editor window.
c Close the MS Spectrum Results 

window.
d Click the Autoscale Y-axis during 

Zoom icon  in the Chromatogram 
Results toolbar.

e To zoom in to the last few peaks, 
right-click the mouse above the peak 
at 13 min. and drag it to 16 min., then 
release. 

f Click the Walk Chromatogram icon 
 in the Chromatogram Results 

toolbar.
g Move the Walk Chromatogram cursor 

to above the X axis at about 13 
minutes, and click. 

h To navigate from spectrum to 
spectrum, use the right and left arrow 
keys on your keyboard.

• The Walk Chromatogram tool is 
particularly useful on MS/MS data 
for identifying precursor and 
product ions.

• The spectrum for each point you 
click in the Chromatogram Results 
window is automatically displayed 
in the Spectrum Preview window, 
which is opened automatically.

• Sometimes, two spectra are 
displayed in the Spectrum Preview 
window. For example, two spectra 
are shown in the Spectrum Preview 
window for each point you click 
near the peak at 13.431 minutes.
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide 75



1 Learn basics of qualitative analysis 
Task 18. Basic tasks for a GC/MS data file
Figure 52 Walk chromatogram to view the two MRM spectra for the peak at 13. 431 minutes

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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2 Extract spectra on specific data 
points for the peak at 5.2 minutes 
and the peak at 14.3 minutes of the 
Pest - STD 200 MRM.d data file.
• Extract a spectrum from the peak 

at or near 5.2 min. and then one 
of the valleys, using any one of 
the options described under 
Comments.

• Extract a spectrum from the peak 
at or near 14.3 minutes. (not the 
valley yet)

• Change the display to show at 
least three spectra.

a Click the Range Select icon  from 
the Chromatogram Results toolbar.

b Close the Spectrum Preview window.
c Click the Zoom Out icon, , in the 

Chromatogram Results toolbar.
d To zoom in to the peak at 5.2 minutes, 

right-click the mouse above the peak 
at 4.0 min. and drag it to 6.0 min., then 
release. 

e On a peak near 5.2 min. extract a 
spectrum in any of the ways listed in 
the Comments column.

f On a valley near 5.1 min., extract the 
spectrum.

g Click the Zoom Out icon, , in the 
Chromatogram Results toolbar.

h Zoom into the region between 14 and 
15 min. 

i On a peak near 14.3 minutes, extract a 
spectrum in any of the ways listed in 
the Comments column. (Do not extract 
the valley spectrum yet.)

j If necessary, select 4 in the Maximum 
number of list panes icon in the MS 
Spectrum Results toolbar.

• When you zoom, make sure the 
AutoScale Y-axis during Zoom icon, 

is “on”. The background of the 
icon is orange when it is on.

• You can extract a spectrum in any of 
the following ways:
• Double-click the data point in the 

chromatogram. 
• Click the data point in the 

chromatogram, then right-click 
anywhere in the chromatogram. 
Click Extract MS Spectrum. The 
Extract Spectrum dialog box is 
displayed. Make sure the 
sulfas_PosTargetedMSMS.d file 
is selected, and click Extract in 
the Extract Spectrum dialog box.

• Note that when you first extract a 
spectrum, the MS Spectrum Results 
window appears containing the 
spectrum, and the type of spectrum 
and retention time appear under 
User Spectra. All subsequent 
extracted spectra appear in both 
places as well.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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Figure 53 Main window with two MRM spectra from the peak at 5.2 minutes and two MRM spectra from the 
peak at 14.3 minutes

3 Extract an MS Spectrum for the 
valley at 14.35 minutes of the Pest 
- STD 200 MRM.d data file. 
• Bring up Spectrum Preview.
• Extract a spectrum from the 

valley at RT 14.3 minutes.
• Copy this spectrum to the User 

Spectra folder.
• Change the display to show 6 

spectra.
• Turn off Spectrum Preview.

a Click the Spectrum Preview icon, 
.

b On a valley near 14.3 minutes extract a 
spectrum.

c Right-click the spectrum in the 
Spectrum Preview window, and click 
Copy to User Spectra.
Spectrum Preview is above the MS 
Spectrum Results window.

d Click the down arrow next to the 
spectrum pane list, and select 6.

e Close the Spectrum Preview window.

• When Spectrum Preview is enabled, 
the system displays any 
manually-selected spectrum in the 
Spectrum Preview window but not 
in the User Spectra section of Data 
Navigator.

• With Spectrum Preview on, 
Qualitative Analysis overwrites the 
previous spectrum when you 
extract a new spectrum.

• Spectrum Preview mode is useful 
when you quickly want to review 
the spectra in your chromatogram 
and save only a few of the spectra.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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Figure 54 Chromatogram Results and MS Spectrum Results windows

4 Extract a spectrum that averages 
all points within a specified range 
for the peak at 14.3 minutes for the 
Pest - STD 200 MRM.d data file:
• Zoom out.
• Use the Range Select icon on the 

Chromatogram toolbar.
• Set the range across the entire 

peak. 
• Extract the spectrum, using any 

of the options listed.

a Click the Range Select icon on the 
Chromatogram toolbar.

b Click at the left side of the base of the 
peak at 14.3 minutes and drag to the 
base of that peak on the right. 

c Extract the average spectrum using 
one of the options on the right.

d Select 2 in the Maximum number of 
list panes in the MS Spectrum Results 
window.

• You can extract an average 
spectrum by double-clicking the 
selected range in the 
chromatogram. 

• Or, right-click anywhere in the 
chromatogram, and click Extract 
MS Spectrum from the shortcut 
menu.

• Note that two averaged MRM 
spectra appear.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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Figure 55 Chromatogram Results and MS Spectrum Results showing two averaged spectra

5 Extract spectra that average the 
ranges of peaks at 5.2 minutes and 
at 14.3 minutes together for the 
Pest - STD 200 MRM.d data file.
• Hint: Use the Range Select icon 

and the Ctrl key to select the 
Peak 1 range taken from the 
halfway point.

• Extract the spectra, using any of 
the options on the right.

a Click the Zoom Out icon, , in the 
Chromatogram Results toolbar.

b Press the Ctrl key.
c Click at about 5.0 min. on the left side 

of the first peak and drag over to about 
5.3 min. on the right, and release the 
mouse.

d Release the Ctrl key.
e Extract the averaged spectra using this 

option or the one on the right:
• Double-click inside the selected 

range in either peak.

• Remember that the second peak 
already has a range selected from 
step 4.

• To extract spectra, you can also 
right-click anywhere in the 
chromatogram and clicking Extract 
MS Spectrum. The Extract 
Spectrum dialog box is shown. Click 
Extract.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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Figure 56 Two averaged spectra from two different ranges in the chromatogram

6 Subtract a background spectrum 
every time you extract a peak 
spectrum from Pest - STD 200 
MRM.d.
• Delete any scans under User 

Spectra in Data Navigator.
• Extract a background spectrum 

that is the average of a spectrum 
at the start of the peak and a 
spectrum at the end of the peak.

• Extract a peak spectrum from the 
integrated peaks.

a Click the User Spectra line in the Data 
Navigator. Right-click the User Spectra 
line, and click Delete.

b Click Yes.
c In Method Explorer, select Spectrum 

> Extract (MS/MS). 
d Click the Peak Spectrum Extraction 

(MS/MS) tab, if not visible.
e In the Peak spectrum background 

box, select Average of spectra at peak 
start and end.

f In the Chromatogram Results toolbar, 
click the Peak Select icon, .

g Select the peak at 14.306 minutes.
h Right-click and click Extract Peak 

Spectrum from the shortcut menu.

• Note that at the end of this process, 
all extracted peak spectra will 
automatically have the designated 
background spectrum subtracted.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide 81



1 Learn basics of qualitative analysis 
Task 18. Basic tasks for a GC/MS data file
Figure 57 Peak spectra with background subtracted

7 Integrate and extract peak spectra 
from the Pest - STD 200 MRM.d 
data file.

a Click the TIC MRM chromatogram in 
the Data Navigator window.

b Click Chromatograms > Integrate and 
Extract Peak Spectra.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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Figure 58 Integrate and Extract Peak Spectra

8 Close data files and return to 
LC/MS/MS user interface 
configuration.

a Click File > Close Data File.
b Select all files.
c Click Close.
d Click Tools > User Interface 

Configuration.
e Mark all check boxes.
f Click OK.

• If these check boxes are not 
marked, then some of the 
algorithms are not available.

Task 18. Basic tasks for a GC/MS data file

Steps Detailed Instructions Comments
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(GC/MS - MS only)    117
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2 Find and identify compounds 
In the first two sets of tasks, you find and identify low- concentration sulfa 
drugs within a complex matrix and generate their formulas for both TOF and 
Q- TOF data. You also do a molecular feature extraction on a protein digest 
with both TOF and Q- TOF data. These tasks can also be performed on Triple 
Quad data.

In the third set of tasks, you find and identify compounds in a GC/MS 
pesticide data file. You find compounds using the Find Compounds by 
Chromatogram Deconvolution algorithm. You identify these compounds 
using the Search Unit Mass Library algorithm.

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step- by- step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Find and identify compounds 2
Tasks for MS-Only Data (LC/MS - TOF, Q-TOF or Triple Quad)
Tasks for MS-Only Data (LC/MS - TOF, Q-TOF or Triple Quad)

Task 1. Find compounds by molecular feature (LC/MS - MS only)

The FindCompounds algorithms find compounds in data and create averaged 
MS spectra for each compound. This functionality is an easy way to “mine” 
information from complex data. This algorithm only works with data that 
contains MS scan data. It does not work on data with unit mass resolution (for 
example, Triple Quad data).

Task 1. Find compounds (LC/MS - MS only) 

Step Detailed Instructions Comments

1 Open the sulfas_PosMS.d 
chromatogram.
• Use the General workflow
• Select a range between 0.24 and 

1.5 minutes.

a Double-click the Mass Hunter 
Qualitative Analysis icon.

b Click the sulfa_PosMS.d data file in 
the example data file directory. Clear 
the Load result data check box and 
click Open.

c Click View > Configure for Workflow 
> General.

d Click the Range Select tool, and select 
the region from 0.24 to 1.5 minutes.

• The method Default.m is loaded 
automatically. To load this method 
interactively, click Method > Open. 
Select Default.m and click Open.

• You can get help for any window, 
dialog box, or tab by using the F1 
key when that window is active.

Figure 59 Selecting a time range in the TIC chromatogram

Range Select tool
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2 Find and identify compounds 
Task 1. Find compounds by molecular feature (LC/MS - MS only)
2 Find compounds in the 
chromatogram.
• Restrict m/z to 100-350.
• Make sure you can see 

chromatograms and spectra for 
all the compounds.

a In Method Explorer click Find 
Compounds > Find Compounds by 
Molecular Feature.

b Select Small molecules 
(chromatographic) as the Target data 
type.

c Mark the Restrict m/z to check box.
d Type 100-350.

• Learn more about Target data type 
in the online Help.

• You choose the region of the 
chromatogram for which you intend 
to find compounds. See Figure 59 
on page 87.

• The blue triangle appears when you 
change a setting from the value that 
is saved in the current method. 
When you save the method, the 
triangles disappear.

Figure 60 Restricting mass range for finding compounds by molecular feature

e Click the Results tab.
f Mark Extract ECC and Extract MFE 

spectrum.
g Mark Display only the largest and 

type 4 for the number of compounds.

• You can extract the complete result 
set for a compound after it is found 
by using the Find > Extract 
Complete Result Set command 
when a compound is highlighted.

Task 1. Find compounds (LC/MS - MS only) (continued)

Step Detailed Instructions Comments

The Advanced tab is only available if 
the Advanced check box is marked 
in the User Interface Configuration 
dialog box.
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Find and identify compounds 2
Task 1. Find compounds by molecular feature (LC/MS - MS only)
Figure 61 Changing the values in the Find Compounds by Molecular Feature > Results tab

h Click  to run the Find 
Compounds by Molecular Feature 
algorithm on the data file. 

i Change the number of panes to view in 
both the Chromatogram Results and 
MS Spectrum Results windows to 4.

j Click the Autoscale Y-axis during 
Zoom icon, , in the MS Spectrum 
Results toolbar. 

k Zoom in on the m/z range from 200 to 
350.

• The Qualitative Analysis program 
should find 4 major compounds in 
the selected range.

• The selected range is automatically 
used when you click  in the 
Method Editor toolbar. In the Find > 
Find by Molecular Feature 
command, you click either Entire 
Chromatogram or Over Selected 
Ranges.

Task 1. Find compounds (LC/MS - MS only) (continued)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 1. Find compounds by molecular feature (LC/MS - MS only)
Figure 62 Finding all four compounds in the sulfa drug mix

Task 1. Find compounds (LC/MS - MS only) (continued)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 2. Generate formulas and identify compounds (LC/MS - MS only)
Task 2. Generate formulas and identify compounds (LC/MS - MS 
only)

In this task, you generate possible formulas and search for each of those 
compounds found in Task 1.

Task 2. Generate formulas and identify compounds (LC/MS - MS only)

Step Detailed Instructions Comments

1 Generate formulas for 
Compounds 1-4.
• View the MS Formula Results for 

each compound.
• View the Compound List.
• Close the MS Spectrum Results 

window.

Hint: To obtain the same results as in 
Figure 63, make sure you have 
selected Common organic molecules 
as the Isotope model.

a In Method Explorer, click Identify 
Compounds > Generate Formulas.

b Click the Charge State tab, and select 
Common organic molecules as the 
Isotope model.

c In the Data Navigator window, click 
Compounds to highlight all of the 
compounds.

d Click the Generate Formulas from 
Compound icon  to run the 
algorithm.

e Click a compound in the Data 
Navigator to see the MS Formula 
Results for that compound.

f If necessary, click View > Compound 
List.

• By default, the MS Formula Results 
window is tabbed with the 
Chromatogram Results window. 
Click on the tab at the bottom of the 
window to switch between 
windows.

• You can see the predicted isotope 
abundance ratios on the spectrum 
plot when you zoom in at the 
appropriate m/z. See the online 
Help for more information.

• The Run icon  in the Method 
Editor toolbar sometimes allows 
you to choose an action from a set 
of possible actions. For example, 
two different actions are possible 
when you click the Run icon in this 
section. If you click the arrow, a list 
of possible actions is shown, and 
you can choose which action to do. 
Choosing a different action from the 
list changes the default action. If 
you simply click the Run button, the 
default action is performed.

2 Do a database search based on 
formulas on Compounds 1-4.
• Base search on formula.

a In the Data Navigator window, click 
Compounds.

b In Method Explorer, click Identify 
Compounds > Search Database.

c Under Search Criteria click Molecular 
formula.

d Click Identify > Search Database for 
Compounds in the main menu.

• Note in the Compound List that all 
four sulfa drugs have been 
identified (See Figure 63).

• If the DB Search Results window is 
not displayed, click View > DB 
Search Results.
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2 Find and identify compounds 
Task 2. Generate formulas and identify compounds (LC/MS - MS only)
Figure 63 DB Search Results for Compounds 1-4 in sulfas_PosMS.d

Task 2. Generate formulas and identify compounds (LC/MS - MS only)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 3. Print a compound report (LC/MS - MS only)
Task 3. Print a compound report (LC/MS - MS only)

You generate a report for each of those compounds found in Task 1. Find 
compounds by molecular feature (LC/MS -  MS only)    87 and 
identified in Task 2. Generate formulas and identify compounds (LC/MS 
-  MS only)    91.

Task 3. Print a compound report (LC/MS - MS only)

Step Detailed Instructions Comments

1 Change some of the selections in 
the method for compound reports:
• Turn off viewing the MS spectra 

zoomed in on special peaks.
• Turn off the MS/MS options in 

the report.

a In Method Explorer, click General > 
Compound Report.

b Clear the Show MS spectrum check 
box.

c Clear the Show MS/MS spectrum 
check box.

d Clear the Show MS/MS peak table 
check box.

e Click the Print Compound Report icon 
 to run the algorithm.

• These check boxes allow you to 
specify what information to include 
in a report if it is available. If the 
information is not available, that 
section is automatically skipped. 
For example, MS/MS results are 
never included when the data file 
only has MS data.

Figure 64 Compound Report window in the Method Editor
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2 Find and identify compounds 
Task 3. Print a compound report (LC/MS - MS only)
2 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked if you want to 

save the results.

Task 3. Print a compound report (LC/MS - MS only)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 4. Find compounds by formula and calculate sample purity (LC/MS - MS only)
Task 4. Find compounds by formula and calculate sample purity 
(LC/MS - MS only)

The Find Compounds algorithms find compounds in data and create 
averaged MS spectra for each compound. This functionality is an easy way 
to “mine” information from complex data. You can also compute sample 
purity.

Task 4. Find compounds by formula (LC/MS - MS only) 

Step Detailed Instructions Comments

1 Open the sulfas_PosMS.d 
chromatogram.
• Use the General workflow.
• Select a range between 0.2 and 

1.5 minutes.

a Click File > Open Data File.
b Select sulfas_PosMS.d and click OK.
c Click View > Configure for Workflow 

> General.
d Click Yes to switch workflows.
e Click No to save method parameters.
f Click the Autoscale Y-Axis during 

zoom button in the Chromatogram 
Results toolbar.

g Click the Range Select tool, and select 
the region from 0.2 to 1.5 minutes.

• If you switch to the Formula 
Confirmation and Sample Purity 
workflow, the Compound List table 
automatically shows the sample 
purity columns.

• The Find by Formula sections are 
included in the Formula 
Confirmation and Sample Purity 
Workflow section.

2 Find compounds within the 
specified range on the 
chromatogram.
• Enable sample purity 

calculations.
• Calculate the TIC %, ADC %, UV 

A%, and UV B% purity values.
• Use the maximum value as the 

purity value.
• Add columns to the Compound 

List window.
• Review results.

a In Method Explorer click Find 
Compounds by Formula > Find by 
Formula - Options tab.

b Click Database as the Source of 
formulas to confirm.

c In Method Explorer click Find 
Compounds by Formula > Find by 
Formula - Sample Purity tab.

d Mark the Compute sample purity 
check box.

e Mark the TIC %, ADC %, UV A% and 
UV B% check boxes.

f Click Maximum of all selected 
algorithms.

g In the Minimum acceptable purity 
box, type 20.

• The blue triangle appears when you 
change a setting from the value that 
is saved in the current method. 
When you save the method, the 
triangles disappear.

• This data file contains multiple sulfa 
drugs which is why the expected 
purity is 20%.
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2 Find and identify compounds 
Task 4. Find compounds by formula and calculate sample purity (LC/MS - MS only)
Figure 65 Setting sample purity options for the Find Compounds by Formula algorithm

h Click  to run the Find 
Compounds by Formula algorithm on 
the data file. 

i Change the number of panes to view in 
both the Chromatogram Results and 
MS Spectrum Results windows to 3.

j Click View > Compound List to open 
the Compound List window.

k Right-click the Algorithm column, and 
click Add/Remove Columns to open 
the Compound Columns dialog box.

l Click the Category column header to 
sort the possible columns.

m Mark the Purity Value column, the 
Purity Result column, the ADC% Area 
column, the TIC% Area column, the 
UVA% Area column, and the UVB% 
Area column. 

n Click OK.

• The Qualitative Analysis program 
finds 6 major compounds in the 
selected range.

• Other columns were removed from 
the Compound List table to show 
you the Sample Purity results.

• The Compound List was docked at 
the top of the Qualitative Analysis 
window so that more columns are 
visible. See “Task 4. Change 
window layouts” on page 22 for 
more information on moving 
windows.

Task 4. Find compounds by formula (LC/MS - MS only) (continued)

Step Detailed Instructions Comments

All of the algorithms that 
are marked are calculated, 
even if they are not used to 
determine the sample 
purity.

You specify how to 
determine the sample purity 
in this section. 
96 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Find and identify compounds 2
Task 4. Find compounds by formula and calculate sample purity (LC/MS - MS only)
Figure 66 Finding all four compounds in the sulfa drug mix

• The icon for the Compound in 
the Data Navigator indicates 
whether the Compound passed 
the Sample Purity test.

• The Purity Value column is color 
coded:
• Green - Pass
• Yellow - Fail
• Red - Cannot measure

3 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked if you want to 

save the results.

Task 4. Find compounds by formula (LC/MS - MS only) (continued)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)
Task 5. Do molecular feature extraction on a protein digest (LC/MS 
- MS only)

In this task, you do molecular feature extraction on a protein digest using 
only MS data.

Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)

Step Detailed Instructions Comments

1 Do a molecular feature extraction 
for the data file peptide-ms-only.d 
with these parameters:
• Time range is 2.5 to 4 minutes.
• Specify that the Isotope model is 

peptides.
• Filter to show only the largest 20 

compounds in abundance.
• Change the window layout to 

match that of Figure 67 (next 
page).

a Open the peptide-ms-only.d data file. 
b Click Find Compounds > Find by 

Molecular Feature in the Method 
Explorer to display the parameters in 
the Method Editor window. 

c In the Extraction tab, mark the 
Restrict retention time to check box. 

d Type 2.5 - 4.
e Clear the Restrict m/z to check box, if 

necessary.
f On the Charge State tab, select 

Peptides in the Isotope model box. 
g On the Compound Filters tab, mark the 

Limit to the largest check box and 
type 20 for the number of compounds.

h On the Results tab, mark the Extract 
ECC and Extract MFE spectrum check 
boxes.

i Click  to run the Find 
Compounds by Molecular Feature 
algorithm on the data file. 

j If necessary, click 2 in the Maximum 
number of list panes in the 
Chromatogram Results toolbar.

• The Limit to the largest filter does not 
limit the number of features extracted. 
It just limits the number of compounds 
displayed in Qualitative Analysis.

• The resulting .mhd files are stored in 
the Results directory under the data 
file directory. 

• You extract features using the 
Qualitative Analysis Molecular 
Feature algorithm. Then, you can 
compare sets of data from different 
extractions using Agilent MassHunter 
Profiling software or GeneSpring MS 
software.

• If you click Apply all filters to MHD 
file, then only compounds that pass 
the filters are written to the MHD file. 
Otherwise, compounds are written to 
the MHD file before the filters are 
applied. The Limit to the largest filter 
does not ever apply to the MHD file.

2 Find the compound spectrum for 
the m/z 570.7362 ion and 
determine the charge state, mass 
and ion species.

a In the MS Spectrum Results window, 
scroll to find the spectrum containing 
the m/z 570.7362 ion.

b Find the charge state.
c Find the ion species.
d Find this compound in the Compound 

List.
e Find the mass.

• Compound 4 has a spectrum 
containing this ion with a charge 
state of +2.

• The mass is 1139.4577. The ion 
species is (M+2H)+2. You can see 
the ion species in the MS Spectrum 
Results window and also in the 
Spectrum Peak List window in the 
column labeled Ion.
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Find and identify compounds 2
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)
Figure 67 Find Compounds by Molecular Feature with Qualitative Analysis

3 Extract an integrated EIC for this 
peptide.
• Use 570.7362 as the m/z value.

a Right-click the TIC for the data file, and 
click Extract Chromatograms.

b From the Type list, click EIC.
c Mark the Integrate when extracted 

check box.
d Type 570.7362 as the m/z value.
e Click the Advanced tab.
f Select Symmetric (ppm) and click OK.

It is important that the Single m/z 
expansion value is set appropriately 
for the data file. For this Q-TOF data 
file, an extraction range of +/- 100 
ppm is more appropriate.

Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)
4 Extract an averaged spectrum for 
the first integrated peak in the EIC.
• Zoom into what appears to be 

the first integrated peak.
• Select a range from the halfway 

point across the highest peak.

a Right-click the EIC, and drag the cursor 
to zoom in around the first integrated 
peak.

b Make sure that the Range Select icon 
has been selected, and select a range 
across the peak at the midpoint.

c Double-click within the shaded region 
of the peak to extract an averaged 
spectrum.

5 Close the data file. a Click File > Close Data File.
b Click No when asked to save results.

Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS only)

Step Detailed Instructions Comments
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Find and identify compounds 2
Tasks for MS/MS Data (LC/MS - Q-TOF or Triple Quad)
Tasks for MS/MS Data (LC/MS - Q-TOF or Triple Quad)

Task 1. Find compounds (LC/MS - MS and MS/MS)

The FindCompounds algorithms identify compounds in MS/MS data and 
create averaged MS and MS/MS spectra for each compound. This 
functionality is an easy way to “mine” information from complex data.

Task 1. Find compounds (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments

1 Open the TIC for the 
sulfas-PosAutoMSMS.d data file 
and select a range from 0.2 to 1.3 
minutes.
• Use the General workflow.
• Highlight a range from 0.2 to 1.3 

minutes.

a If the program is not open, double-click 
the Mass Hunter Qualitative Analysis 
icon. Otherwise, click File > Open 
Data File.

b Click the sulfa-PosAutoMSMS.d data 
file in the example data file directory, 
and click Open.

c Click the View > Configure for 
Workflow > General command.

d Click the Range Select icon in the 
Chromatogram Results toolbar, if 
necessary.

e Click the Auto-scale Y-axis during 
Zoom icon in the Chromatogram 
Results toolbar, if necessary.

f Click and drag to select the range from 
0.2 to 1.3 minutes.

• The method default.m is 
automatically opened. To open a 
different method, click Method > 
Open, select the method, and click 
Open. 

• A blue triangle is automatically 
shown in the Adjust Delay Time 
tabs in the Method Explorer. This 
data file also contains DAD and 
ADC data. You may ignore these 
blue triangles unless you want to 
enter a delay time.

Figure 68 Zoomed range for TIC chromatogram of sulfas-PosAutoMSMS.d data file
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2 Find and identify compounds 
Task 1. Find compounds (LC/MS - MS and MS/MS)
2 Find compounds from 0.2 to 1.3 
minutes on the chromatogram.
• Enter a Positive MS/MS TIC 

threshold of 100000.
• Exclude masses 121.0504 and 

922.0097.

a In Method Explorer click Find 
Compounds > Find by Auto MS/MS.

b Under Processing, in the Positive 
MS/MS TIC threshold, type 100000.

c Click the Excluded Masses tab.
d Click Exclude masses (or m/z 

ranges) from all new 
chromatograms. 

e Type 121.0504, 922.0097
f Select Symmetric (ppm).
g Select 20.

• You choose the region of the 
chromatogram from which you 
intend to find compounds. See 
Figure 68.

• You can extract the complete result 
set for a compound after it is found 
by using the Compounds > Extract 
Complete Result Set menu item 
when a compound is highlighted.

Figure 69 Excluded Masses tab of Find Compounds by AutoMS/MS

• Select to extract EIC, MS spectra 
and MS/MS spectra.

h Click the Results tab.
i Mark the Extract EIC, MS and 

MS/MS check boxes.
j Click  to run the Find Compounds 

by Auto MS/MS algorithm on the data 
file. 

• You can also click Find > Find 
Compounds by Auto MS/MS > 
Over Selected Ranges.

• The Qualitative Analysis program 
will find 4 compounds in the 
selected range under these 
conditions.

• In the next task you identify which 
compounds are the sulfa drugs.

Task 1. Find compounds (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 1. Find compounds (LC/MS - MS and MS/MS)
3 Display both spectra for Compound 
4 only. See Figure 70.

a Highlight Compound 4 only.
b Click the Show only the highlighted 

items icon in the main toolbar.
c Expand Compound 4 to see the 

chromatogram and two spectra.

• Showing both spectra is a convenient 
way to display all the information for a 
single compound.

• Note that both the precursor and 
product spectra are extracted for each 
compound. The red diamond 
represents the precursor ion. 

Figure 70 Data Navigator window and MS Spectrum Results window showing MS and MS/MS spectra for 
Compound 4

Task 1. Find compounds (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)
Task 2. Identify compounds and generate formulas (LC/MS - MS 
and MS/MS)

In this task, you identify and generate formulas for the compounds found 
in Task 1.

Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments

1 Do a database search of 
Compounds 1-4 based on masses.

a Highlight all compounds in the Data 
Navigator window.

b In Method Explorer, click Identify 
Compounds > Search Database.

c In the Search Criteria tab, click Mass.
d Click Identify > Search Database for 

Compounds from the main menu. You 
can instead click the Search Database 
for Compounds icon  to run the 
algorithm.

e Click View > Compound List.
f Mark the Show/Hide check boxes for 

each compound in the Compound List. 
Compounds 1 - 4 were hidden in the 
last task. Or, use the Show all 
highlighted items icon in the main 
toolbar.

g Display the Chromatogram Results 
window by clicking on the 
Chromatogram Results tab. This 
window is tabbed with the MS 
Formula Results window and the DB 
Search Results window.

• Note that three sulfa drugs have 
been identified in the Compound 
List (See Figure 72 on page 106).

• Note that no compound name was 
found for Compound 3 in the 
database search.
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Find and identify compounds 2
Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)
Figure 71 Compounds in sulfas-PosAutoMSMS.d data file identified by searching a database

Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)
2 Generate formulas for 
Compounds 1- 4.
• View the MS Formula Results for 

each compound.
• View the Compound List.
• Close the MS Spectrum Results 

window.

Hint: To obtain the same results as in 
Figure 72, make sure you have 
selected Common organic molecules 
for the Isotope model.

a In Method Explorer, click Identify 
Compounds > Generate Formulas.

b Click the Charge State tab, and select 
Common organic molecules.

c Highlight all four compounds.
d Click the Generate Formulas from 

Compound icon  to run the 
algorithm.

e Click on the Plus sign icon in the MS 
Formula Results window to expand the 
table.

f Click View > MS/MS Formula 
Details.

g Move this window to beside that of the 
MS Formula Results window.

h In Data Navigator highlight the 
compound whose MS Formula 
Results and MS/MS Formula Details 
you want to see.

i Use the scroll bar in the Compound 
List window to see the MFG results.

• By default, the MS Formula Results 
window is tabbed with the 
Chromatogram Results window. 
Click on the tab at the bottom of the 
window to switch between 
windows.

• You can see the predicted isotope 
abundance ratios on the spectrum 
plot when you zoom in at the 
appropriate m/z. See the online 
Help for more information.

• Note that one or more formula were 
found for all compounds.

• Use the Remove column shortcut 
command to remove empty 
columns from the Compound Table.

• Note that the formula from the 
database search is the same as the 
formula determined by the Generate 
Formulas algorithm.

• Click Tools > Compound Label 
Configuration to change the 
compound label.

Figure 72 MS Formula Results and MS/MS Formula Details for Compound 1 in sulfas_PosAutoMSMS.d

Task 2. Identify compounds and generate formulas (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 3. Print a compound report (LC/MS - MS/MS)
Task 3. Print a compound report (LC/MS - MS/MS)

In this task, you generate a report for each of those compounds found in 
Task 1 and identified in Task 2.

Task 3. Print a compound report (LC/MS - MS/MS)

Step Detailed Instructions Comments

1 Change some of the selections in 
the method for compound reports:
• Turn off viewing the MS spectra 

zoomed in on special peaks, if 
necessary.

• Turn on the MS/MS options in 
the report.

a In Method Explorer, click General > 
Compound Report.

b Clear the Show MS spectrum 
(zoomed in on special peaks) check 
box, if necessary.

c Mark the Show MS/MS spectrum 
check box and the Show MS/MS 
peak table check box.

• Only sections that are marked in 
this tab are included in the report.

Figure 73 Compound Report window in the Method Editor

2 Print the report.
• Preview the report.

a Click the Print Compound Report icon 
 to print the report.

b In the Print Compound Report dialog 
box, click All results.

c Mark Print report.
d Mark Print preview.
e Click OK.

• You can also create a PDF file by 
marking the Save report as PDF file 
check box. This option only works if 
you installed the Microsoft Excel 
PDF add-in after installing Excel.
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2 Find and identify compounds 
Task 3. Print a compound report (LC/MS - MS/MS)
Figure 74 Compound Report window in the Method Editor

3 Close the Print Preview window. a Click Close Print Preview in the 
toolbar.

• If you want to print the report, click 
the Print button. The report is 
printed on the printer selected 
earlier in the Print Compound 
Report dialog box.

4 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked if you want to 

save the results.

Task 3. Print a compound report (LC/MS - MS/MS)

Step Detailed Instructions Comments

This button closes the 
Print Preview window 
without sending the 
report to the printer.
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Find and identify compounds 2
Task 4. Find Compounds and Search Accurate Mass Library (LC/MS - MS/MS)
Task 4. Find Compounds and Search Accurate Mass Library 
(LC/MS - MS/MS)

The FindCompounds by Targeted MS/MS algorithm identifies compounds 
in MS/MS data and can extract an MS and MS/MS spectra for each 
compound. If MS/MS spectra from multiple collision energies are used, you 
can either extract an average MS/MS spectrum for all collision energies or 
a separate MS/MS spectrum for each collision energy. 

The Search Accurate Mass Library algorithm searches a library file (CDB) 
for a Product Ion spectrum. Only centroid spectra can be searched, so any 
profile spectrum needs to be converted to a centroid spectrum first.

Task 4. Find compounds and Search Accurate Mass Library (LC/MS - MS/MS)

Step Detailed Instructions Comments

1 Open the TIC for the 
sulfas-PosAutoMSMS.d data file.
• Use the General workflow.

a If the program is not open, double-click 
the Mass Hunter Qualitative Analysis 
icon. Click Cancel in the Open Data 
File dialog box.

b Click the View > Configure for 
Workflow > General command.

c Click Yes to switch workflows.
d Click File > Open Data File.
e Click sulfa-PosTargetedMSMS.d, and 

click Open.
f Click the Range Select icon in the 

Chromatogram Results toolbar, if 
necessary.

g Click the Auto-scale Y-axis during 
Zoom icon in the Chromatogram 
Results toolbar, if necessary.

• The method default.m is 
automatically opened. To open a 
different method, click Method > 
Open, select the method, and click 
Open. 

• A blue triangle is automatically 
shown in the Adjust Delay Time 
tabs in the Method Explorer. This 
data file also contains DAD and 
ADC data. You may ignore these 
blue triangles unless you want to 
enter a delay time.

Figure 75 Zoomed range for TIC chromatogram of sulfas-PosAutoMSMS.d data file
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2 Find and identify compounds 
Task 4. Find Compounds and Search Accurate Mass Library (LC/MS - MS/MS)
2 Find compounds using the 
Targeted MS/MS algorithm.
• Select to extract an MS/MS 

chromatogram and MS/MS 
spectra.

a In Method Explorer click Find 
Compounds > Find by Targeted 
MS/MS.

b Click the Results tab.
c Mark the Extract MS/MS 

chromatogram and Extract MS/MS 
spectrum check boxes.

d Click Find > Find Compounds by 
Targeted MS/MS.

• You can extract the complete result 
set for a compound after it is found 
by using the Compounds > Extract 
Complete Result Set menu item 
when a compound is highlighted.

• The Qualitative Analysis program 
will find 4 compounds under these 
conditions.

3 Search each compound using the 
Search Accurate Mass Library 
algorithm.
• Select the SulfasLib.CDB library
• Lower the minimum match score 

to 50.

a In Method Explorer click Identify 
Compounds > Search Accurate Mass 
Library.

b Click the Browse button. Every other 
field on this tab is grayed out.

c Select SulfasLib.cdb.
d Click Open.
e Click the Search Results tab.
f Type 50 in the Minimum match score 

box.
g Highlight all compounds in the Data 

Navigator window.
h Click Identify > Search Library for 

Compounds.

• If the selected library has the CDB 
extension, then the Search 
Accurate Mass Library algorithm is 
run when you search a library. If the 
selected library has the L extension, 
then the Search Unit Mass Library 
algorithm is run when you search a 
library.

• You can also right-click the 
Compounds line in the Data 
Navigator window and then click 
Search Library for Compounds.

• To see all of the parameters that 
affect the Search Accurate Mass 
Library algorithm, you mark the 
Advanced check box in the User 
Interface Configuration dialog box. 
Then, the Search Criteria tab is 
shown. You use this tab to filter the 
library entries that are searched on 
Ionization mode, Instrument type, 
and Collision energy.

Task 4. Find compounds and Search Accurate Mass Library (LC/MS - MS/MS)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 4. Find Compounds and Search Accurate Mass Library (LC/MS - MS/MS)
Figure 76 Results after running the Search Accurate Mass Library algorithm.

Task 4. Find compounds and Search Accurate Mass Library (LC/MS - MS/MS)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS and MS/MS)
Task 5. Do molecular feature extraction on a protein digest (LC/MS 
- MS and MS/MS)

In this task, you do molecular feature extraction on protein digest data 
obtained on a Q- TOF in Auto MS/MS mode.

Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments

1 Do a molecular feature extraction 
in the data file peptide-auto.d with 
these parameters:
• Make sure the layout is returned 

to the Default Layout.
• Time range is 2.5 to 4 minutes.
• Set the isotope model to 

peptides.
• Filter to show only the largest 20 

compounds in abundance.
• Change the window layout to 

match that of Figure 77 (next 
page).

a Open the peptide-auto.d data file. 
b Click the View > Configure for 

Workflow > General command.
c Click OK to continue.
d Click No to save method changes.
e Click Find Compounds > Find by 

Molecular Feature in the Method 
Explorer to display the parameters in 
the Method Editor window. 

f In the Extraction tab, select Small 
molecules (chromatographic) as the 
Target data type.

g Mark the Restrict retention time to 
check box. 

h Type 2.5 - 4.
i On the Charge State tab, select 

Peptides as the Isotope model. 
j On the Compound Filters tab, mark the 

Limit to the largest check box and 
type 20 for the number of compounds.

k On the Results tab, mark the Extract 
ECC and Extract MFE spectrum check 
boxes.

l Click  to run the Find 
Compounds by Molecular Feature 
algorithm on the data file. 

m If necessary, select 3 in the Maximum 
number of list panes box in the 
Chromatogram Results toolbar.

• To return the layout to the default 
layout, click View > Window Layouts 
> Restore Default Layout.

• The Limit to the largest filter does not 
limit the number of features extracted. 
It just limits the number of compounds 
displayed in Qualitative Analysis.

• You extract features using the 
Qualitative Analysis Molecular 
Feature algorithm. Then, you can 
compare sets of data from different 
extractions using Agilent MassHunter 
Profiling software or GeneSpring MS 
software.

• The resulting .mhd files are stored in 
the Results directory under the data 
file directory. 

2 Find the compound spectrum for 
the m/z 625.31585 ion and 
determine the charge state.

a In the MS Spectrum Results window, 
scroll to find the spectrum containing 
the m/z 625.3166 ion.

b Find the charge state.

• Compound 7 has a spectrum 
containing this ion with a charge 
state of +1.
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Find and identify compounds 2
Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS and MS/MS)
Figure 77 Find Compounds by Molecular Feature for a protein digest with auto MS/MS data

3 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked to save the 

results.

Task 5. Do molecular feature extraction on a protein digest (LC/MS - MS and MS/MS)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Tasks for GC/MS Data (Triple Quad)
Tasks for GC/MS Data (Triple Quad)

Task 1. Find compounds by chromatogram deconvolution (GC/MS - 
MS only)

This FindCompounds algorithm identifies compounds in GC/MS data and 
creates a cleaned MS spectrum for each compound. This functionality is 
an easy way to “mine” information from complex data. You can only use 
the Find Compounds by Chromatogram Deconvolution algorithm on 
GC/MS sample data acquired in Scan, Product Ion scan or Neutral Loss 
scan mode.

Task 1. Find compounds using Chromatogram Deconvolution (GC/MS - MS only)

Step Detailed Instructions Comments

1 Open the TIC for the Pest - 200 - 
Scan.d data file.

a If the program is not open, double-click 
the Mass Hunter Qualitative Analysis 
icon. Otherwise, click File > Open 
Data File.

b Click the Pest - 200 - Scan.d data file 
in the GC example data file folder.

c Clear the Load result data check box 
and click Open.

• You only use the General Workflow 
when working with GC/MS data.

Figure 78 TIC chromatogram from Pest - 200 - Scan.d

2 Configure the user interface to 
work with GC data.

• Follow the instructions in Task 15. 
Configure User Interface for GC    64.
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Find and identify compounds 2
Task 1. Find compounds by chromatogram deconvolution (GC/MS - MS only)
3 Find compounds using the 
chromatogram deconvolution 
algorithm.
• Enter an SNR threshold of 20.

a In Method Explorer select Find 
Compounds > Find by Chromatogram 
Deconvolution.

b Under Peak filter, in the SNR 
threshold, type 20.

• You can choose the region of the 
chromatogram from which you 
intend to find compounds. 

• You can extract the complete result 
set for a compound after it is found 
by using the Compounds > Extract 
Complete Result Set menu item 
when a compound is highlighted.

Figure 79 Settings tab of Find by Chromatogram Deconvolution

• Select to extract EIC, MS spectra 
and MS/MS spectra.

c Click the Results tab.
d Mark the Extract EIC, Extract ECC, 

Extract cleaned spectrum and Extract 
raw spectrum check boxes.

e Click  to run the Find Compounds 
by Chromatogram Deconvolution 
algorithm on the data file. 

• The Qualitative Analysis program 
finds 69 compounds under these 
conditions.

• In the next task you identify these 
compounds by searching the 
NIST08.L library.

4 Examine the compounds. See 
Figure 70.

a Select 2 in the Maximum spectra 
panes box in the MS Spectrum Results 
toolbar.

b Click the first compound in the Data 
Navigator window. 

c When the Data Navigator window is 
selected, use the arrow keys to switch 
compounds. 

• Showing both spectra is a convenient 
way to display all the information for a 
single compound.

• Note that both the cleaned spectrum 
and the raw spectrum are shown.

Task 1. Find compounds using Chromatogram Deconvolution (GC/MS - MS only)

Step Detailed Instructions Comments
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2 Find and identify compounds 
Task 1. Find compounds by chromatogram deconvolution (GC/MS - MS only)
Figure 80 Using the arrow keys in the Data Navigator window to switch compounds

Task 1. Find compounds using Chromatogram Deconvolution (GC/MS - MS only)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)
Task 2. Identify compounds using the Search Library algorithm 
(GC/MS - MS only)

In this task, you identify and generate formulas for the compounds found 
in Task 1. Find compounds by chromatogram deconvolution (GC/MS -  MS 
only)    114. You can only do this task if you have purchased the NIST08.l 
library.

Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)

Step Detailed Instructions Comments

1 Do a library search of all of the 
compounds.

a Highlight all compounds in the Data 
Navigator window.

b In Method Explorer, click Identify 
Compounds > Search Unit Mass 
Library.

c In the Settings tab, click the  
button. Select the NIST08.l library and 
click OK.

d Click Identify > Search Library for 
Compounds from the main menu. You 
can instead click the Search Library 
for Compounds icon  to run the 
algorithm.

e Close the Compound List window.
f Close the MS Spectrum results 

window by clicking View > MS 
Spectrum Results.

g Display the Chromatogram Results 
window by clicking on the 
Chromatogram Results tab. This 
window is tabbed with the MS 
Spectral Library Search Results 
window.

h Click View > Difference Results.
i Click View > Structure Viewer.

• Note that many of the compounds 
are identified after searching the 
NIST08.l library.

• You can use the search library 
algorithm on an MS/MS spectrum if 
you have an XML library. You can 
create and edit an XML library using 
the Library Editor program which is 
installed with the Quantitative 
Analysis program. See the online 
Help for more information.
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2 Find and identify compounds 
Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)
Figure 81 Compounds in Pest - 200 - Scan.D data file and the library search results

2 Close data files and return to 
LC/MS/MS user interface 
configuration.

a Click File > Close Data File.
b Select all files.
c Click Close.
d Click Tools > User Interface 

Configuration.
e Mark all check boxes.
f Click OK.

• If these check boxes are not 
marked, then some of the 
algorithms are not available.

Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)

Step Detailed Instructions Comments
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Find and identify compounds 2
Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)
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2 Find and identify compounds 
Task 2. Identify compounds using the Search Library algorithm (GC/MS - MS only)
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Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide
Exercise 3
Set up and run qualitative analysis 
methods using different workflows

Task 1. Set up and run a qualitative analysis method using the general 
workflow    122

Task 2. Set up and run a method to automate an analysis using the 
Chromatogram Peak Survey workflow    128

Task 3. Set up and run a method to automate compound identification 
using the MS Target Compound Screening workflow    133

Task 4. Set up a qualitative method to run with a worklist    138

In this exercise, you learn to set up and run any qualitative analysis method. 
You also learn to edit a method to automate the analysis and/or compound 
identification. Then you run the actions within the automated method when 
you open a data file. You also learn to create a method to perform automated 
actions with a worklist. 

You learn to create the worklist method with qualitative analysis parameters 
only or with both acquisition and qualitative analysis parameters.

An MS- only data file (Q- TOF) is used for illustration, although all of these 
tasks apply to MS/MS data from either a Q- TOF or Triple Quad as well.

Different workflows are used for these examples. You can explore these 
different workflows before deciding which one best matches your tasks. 
See “Workflows” on page 148 for more information.

The General workflow supports both GC/MS and LC/MS data. The other 
workflows only support LC/MS data.
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3 Set up and run qualitative analysis methods using different workflows 
Task 1. Set up and run a qualitative analysis method using the general workflow
Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step- by- step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.

Task 1. Set up and run a qualitative analysis method using the 
general workflow

When you first start to use the Qualitative Analysis program, the method 
default.m is loaded. You can make changes to the opened method and save 
it, or open a new method, make changes and save the method. You cannot 
overwrite the method default.m.

You can also set up to run specific actions in the method when you open a data 
file.

When you open a data file, you can also load the method that was used to 
create the results that are stored with the data file. This method is 
automatically saved whenever you save the results with the data file.

The General workflow can be used with either GC/MS or LC/MS data files.
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Set up and run qualitative analysis methods using different workflows 3
Task 1. Set up and run a qualitative analysis method using the general workflow
Task 1. Set up and run a qualitative analysis method

Steps Detailed Instructions Comments

1 Set up the method to extract a TIC 
chromatogram. 
• Open the sulfas_PosMS.d data 

file.
• Make sure that the program will 

not run any file actions when the 
data file is open.

• Make sure the method is 
Default.m.

• Make sure the window layout is 
the default layout.

• Define a TIC chromatogram for 
MS data.

• Turn off cycle sum since this is 
an MS-only data file.

a Double-click the Qualitative Analysis 
icon on your desktop.

b In the Open Data File dialog box, select 
sulfas_PosMS.d, 

c If necessary, clear the Run ‘File Open’ 
actions from selected method check 
box.

d If necessary, clear the Load result data 
check box.

e Click Open.
f Click the View > Configure for 

Workflow > General command.
g Click OK to continue loading the 

workflow.
h Click No to save the method changes.
i In Method Explorer, select 

Chromatogram > Define 
Chromatograms.

j Delete the BPC selection.
k Select TIC as the Type.
l Make sure the MS Level is MS.
m Clear the Do cycle sum check box.
n Click Add.

• The default layout for the General 
workflow is automatically loaded. If 
you want to return to this default 
layout, click View > Window 
Layouts > Restore Default Layout. 
This command always restores the 
layout that is used with the General 
workflow.

• To load a method, do this:
• Click Method > Open.
• Select the method
• Click Open.

• As you noticed in the last exercise, 
every time a change is made to a 
method, a blue triangle appears 
next to the change and in the 
Method Explorer next to the section 
which has changed.

• You can also change the workflow 
by clicking a command in the Tools 
> Configure for Workflow menu.

2 Edit the method to integrate the 
data.
• Limit the integration to the four 

highest peaks.

a In Method Explorer, click 
Chromatogram > Integrate (MS).

b Click the Peak Filters tab.
c In the Maximum number of peaks 

section, mark the Limit (by height) to 
the largest check box.

d Type 4. 

• Updating a value in the Peak Filters 
tab in the Chromatogram > 
Integrate (MS) section also updates 
values in other sections of the 
Method Explorer. Blue triangles 
appear to show these other 
sections.

3 Test the integration to make sure 
that only 4 integrated peaks 
appear.

• Click the Integrate Chromatogram 
icon  to integrate the data file. 

4 Save the method to iiiexercise1, 
where “iii” are your initials.

a From the top menu, click Method > 
Save As.

b Type iiiexercise1.
c Click Save.

• Note that saving the method causes 
all the blue triangles indicating 
value changes in the opened 
method to disappear.
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3 Set up and run qualitative analysis methods using different workflows 
Task 1. Set up and run a qualitative analysis method using the general workflow
5 Change the peak spectrum 
background to use the spectrum at 
the start of a peak.

a In Method Explorer, click Spectrum > 
Extract (MS).

b Click Peak Spectrum Extraction (MS).
c For the Peak spectrum background, 

select Spectrum at peak start.

• Any changes after saving will 
produce more blue triangles.

Figure 82 The Spectrum > Extract (MS) > Peak Spectrum Extraction (MS) tab

6 Test the MS spectrum extraction to 
make sure a background spectrum 
is subtracted.

• Click the Extract MS spectrum icon 
 to run the action on the data file. 

7 Save the method. • Save the method in one of three ways:
• Click the Save Method icon 

in the Method Editor.
• Right-click the Method 

Editor, and click Save Method.
• From the top menu click Method > 

Save.

• The Save Method icon is shown in 
Figure 82 on page 124

Task 1. Set up and run a qualitative analysis method

Steps Detailed Instructions Comments

You can click the Save 
Method icon to save the 
current method.
124 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Set up and run qualitative analysis methods using different workflows 3
Task 1. Set up and run a qualitative analysis method using the general workflow
8 Set up the method to automate the 
actions whose parameters you just 
changed.
• List the actions to be performed 

when this or another data file is 
opened.

Hint: Look under General in Method 
Explorer.

a In the Method Explorer, select General 
> File Open Actions.

b Select Integrate and Extract Peak 
Spectra from the Available actions 
list. 

c Click the Add button, , to move 
the selected action to the Actions to 
be run list. 
You can also double-click on the 
selected action to move it to the other 
list.

9 Test the File Open Actions. • Click the Run File Open Actions Now 
icon  to run the actions on the 
data file. 

• The chromatograms and spectra are 
not overwritten. New 
chromatograms and spectra are 
added.

Figure 83 The General > File Open Actions section in the Method Editor

10 Save the method and close the 
data file without saving results.

a Click the Save Method icon in Method 
Editor,

b Click File > Close Data File, and click 
No when asked to save results.

Task 1. Set up and run a qualitative analysis method

Steps Detailed Instructions Comments

Two different actions are part of 
the Actions to be run list. The first 
action is to extract the defined 
chromatograms. Then, that 
chromatogram is integrated and 
peaks are extracted.
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3 Set up and run qualitative analysis methods using different workflows 
Task 1. Set up and run a qualitative analysis method using the general workflow
11 Open the data file again and run 
the actions specified.

a Click File > Open Data File, and select 
sulfas_PosMS.d.

b Mark the Run ‘File Open’ actions from 
selected method check box.

• If you have saved the previous 
results by mistake, clear the Load 
Result data check box.

Figure 84 The Open Data File dialog box with “Run ‘File Open’ 
actions...” marked

c Click Open. • The screen should look like the one 
in Figure 85. (You may have to move 
window boundaries.)

Task 1. Set up and run a qualitative analysis method

Steps Detailed Instructions Comments
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Set up and run qualitative analysis methods using different workflows 3
Task 1. Set up and run a qualitative analysis method using the general workflow
Figure 85 Integrated TIC and background-subtracted spectra – result when sulfas_PosMS.d data file opened

12 Close the data file again, not saving 
the results.

a Click File > Close Data File.
b Click No when asked to save results.

Task 1. Set up and run a qualitative analysis method

Steps Detailed Instructions Comments
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3 Set up and run qualitative analysis methods using different workflows 
Task 2. Set up and run a method to automate an analysis using the Chromatogram Peak Survey workflow
Task 2. Set up and run a method to automate an analysis using the 
Chromatogram Peak Survey workflow

In this task you set up a qualitative analysis method that contains a list of 
analysis actions to run in a specific order. These include extracting and 
integrating chromatograms, extracting spectra, searching a database for peak 
spectra, generating formulas for spectra and printing an analysis report.

You switch to the Chromatogram Peak Survey workflow to set up this method. 
You will also set up to run this automated analysis in the method when you 
open a data file.

The Chromatogram Peak Survey workflow can only be used with LC/MS data 
files.

Task 2. Set up and run a method to automate an analysis

Steps Detailed Instructions Comments

1 Open the sulfas_PosMS.d again.
• Make sure that the method will 

not perform any actions on the 
data file when opening the file.

• Make sure the method is 
iiiexercise1.m.

a Click the View > Configure for 
Workflow > Chromatogram Peak 
Survey Workflow command.

b Click OK to switch the workflow.
c Click No to save the method changes.
d Click File > Open Data File.
e In the Open Data File dialog box, select 

sulfas_PosMS.d.
f Clear the Run ‘File Open’ actions from 

selected method check box.
g Click Open.
h Click Method > Open, select the 

iiiexercise1.m method, then click 
Open.

• Make sure the Load result data 
check box is either clear or grayed 
out.

• When you switch to a different 
workflow, a new method is loaded, 
a new window layout is loaded and 
a new section is added to the 
Method Explorer.

• If you are prompted to save changes 
to the method, click No.

2 Look at the sections for the 
Chromatogram Peak Survey 
algorithm.

• In Method Explorer, click 
Chromatogram Peak Survey 
Workflow.

• Note the eleven sections in this 
workflow. Most of these sections 
are duplicates of sections in the 
General workflow.

3 Make sure that new results will 
overwrite previous results.

a Select Previous Results in the Method 
Explorer.

b Mark Delete all previous results.
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Set up and run qualitative analysis methods using different workflows 3
Task 2. Set up and run a method to automate an analysis using the Chromatogram Peak Survey workflow
4 Make sure that a TIC will be 
extracted, and the four largest 
peaks integrated.

a Select Chromatogram Extraction.
b Click the Chromatograms tab.
c Make sure that TIC has been selected 

as the Chromatogram used to find 
mass spectra.

d Mark Signal A under Additional 
chromatograms to extract.

e Select the Chromatogram Integration 
section in the Method Explorer.

f Click the Peaks (MS) tab, and mark 
Limit (by height) to the largest and 
type 4.

• Note that the “Chromatogram 
Extraction” section is unique. You 
cannot enter this information 
anywhere else in the Method Editor.

5 Set up to extract MS spectra and 
subtract a peak spectrum 
background of the average of 
spectra before and after the peak.

a Select Mass Spectrum Extraction.
b Click the Peak Spectrum tab.
c For Peak spectrum background select 

Average of spectra at peak start and 
end.

• Note that blue triangles appear in 
other sections of Method Explorer. 
These indicate that the same 
parameter values have been 
changed elsewhere as well.

6 Choose to search a database and 
generate formulas for all spectrum 
peaks.
• Don’t change the Molecular 

Formula Generation nor the 
Database Search parameter 
values.

a Select Spectrum Peak Identification 
in the Method Explorer.

b Mark the Search a database for each 
peak check box.

c Mark the Generate formula for each 
peak check box.

d Click All peaks.

• Note that the “Spectrum Peak 
Identification” section is unique. 
You cannot enter this information 
anywhere else in the Method Editor.

7 Test the automated analysis 
process up to this point.

• Click the Run Chromatogram Peak 
Survey icon  from the Spectrum 
Peak Identification section.

• If you click the  icon from the 
Molecular Formula Generation 
section, you click the arrow first and 
select Run Chromatogram Peak 
Survey from the list of possible 
action. By default, the action that is 
run in this section is Generate 
Formulas from Spectrum Peaks. 
Several other sections also have 
different default actions.

Task 2. Set up and run a method to automate an analysis

Steps Detailed Instructions Comments
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3 Set up and run qualitative analysis methods using different workflows 
Task 2. Set up and run a method to automate an analysis using the Chromatogram Peak Survey workflow
8 Open these windows for viewing:
• DB Search Results list
• MS Formula Results list
• These lists are tabbed along with 

Chromatogram Results as in 
Figure 86

• Review each list for each MS 
scan.

• Save the method if the 
automation worked.

a Click View > DB Search Results.
b Click View > MS Formula Results.
c Move these windows so they are 

tabbed with the Chromatogram 
Results window as in Figure 86.

d Review the results for each MS scan 
to make sure that all actions in the 
Chromatogram Peak Survey algorithm 
were performed.

• SeeTask 4. Change window 
layouts    22 to learn how to move 
windows on the main screen.

• You can also use the icons in the 
main toolbar to display these 
windows.

Figure 86 Tabbed results from running automated analysis steps

Task 2. Set up and run a method to automate an analysis

Steps Detailed Instructions Comments
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Task 2. Set up and run a method to automate an analysis using the Chromatogram Peak Survey workflow
9 Save the method to iiiexercise2, 
where “iii” are your initials.

a From the menu, click Method > Save 
As.

b Type iiiexercise2.
c Click Save.

• Note that saving the method causes 
all the blue triangles indicating 
value changes in the opened 
method to disappear.

10 Set up the Analysis Report and 
indicate what sections to print for 
this exercise.
• Save the method.

a Select Analysis Report in the Method 
Explorer.

b Make any changes you want.
c Click the Print Analysis Report icon.
d If necessary, click the Save Method 

icon in Method Editor.

• You select whether or not to print 
the report when you select the 
action that you want to run.

11 Set up the method to run the 
automated analysis when the data 
file is opened
• Save the method.

a Select Automation in the Method 
Explorer.

b Click File Open Actions.
c Select each item in the Actions to run 

list, and click the Remove icon, .
d Select Chromatogram Peak Survey 

without Analysis Report in the 
Available Actions list, and click the 
Add button, .

e Click the Save Method icon in Method 
Editor.

• You can also test these actions if 
you want.

12 Close Method Editor, Method 
Explorer and Data Navigator.
• Move the windows so they look 

like the layout in Figure 87.
• Close the data file, and do not 

save results.

a Click the Close button for Method 
Editor, Method Explorer and Data 
Navigator.

b Move the windows so they look like 
Figure 87.

c Click File > Close Data File.
d Click No when asked to save results.

• Note that the window layout that 
appears when you open a new data 
file is the same as the last window 
layout used.

13 Open the sulfas_PosMS.d data file 
again to run the automated 
analysis.
• The results should look like the 

results in Figure 87.

a Click File > Open Data File.
b Select sulfas_PosMS.d
c Mark the Run ‘File Open’ actions from 

selected method check box.
d Click Open.

Task 2. Set up and run a method to automate an analysis

Steps Detailed Instructions Comments
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Task 2. Set up and run a method to automate an analysis using the Chromatogram Peak Survey workflow
Figure 87 Results of Chromatogram Peak Survey action when opening the sulfas_PosMS.d data file

14 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked to save results.

Task 2. Set up and run a method to automate an analysis

Steps Detailed Instructions Comments
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Task 3. Set up and run a method to automate compound identification using the MS Target Compound 

Screening workflow
Task 3. Set up and run a method to automate compound 
identification using the MS Target Compound Screening workflow

In this task you set up a qualitative analysis method that contains a list of 
actions to find and identify compounds. These include finding compounds 
based on a selected algorithm, searching the database for compounds, 
generating formulas for specific compounds and printing the compound 
report.

You switch to the MS Target Compound Screening workflow to set up this 
method. You can also set up this method using the Compound Automation 
Steps section. You will also set up to run the compound automation in the 
method when you open a data file.

The MS Target Compounds Screening workflow can only be used with LC/MS 
data files.

Task 3. Set up and run a method to automate compound identification

Steps Detailed Instructions Comments

1 Open the sulfas_PosMS.d again.
• Make sure that the method will 

not perform any actions on the 
data file when opening the file.

• Make sure the method is 
iiiexercise2.m.

• Start with the MS Target 
Compound Screening workflow.

a Click View > Configure for Workflow 
> MS Target Compound Screening.

b Click OK to switch the workflow.
c Click No to save the method changes.
d Click File > Open Data File.
e In the Open Data File dialog box, select 

sulfas_PosMS.d.
f Clear the Run ‘File Open’ actions from 

selected method check box.
g Click Open.
h Click Method > Open. Select the 

iiiexercise2.m method. 
i Click Open.
j Click No to save method changes.

• Make sure the Load result data 
check box is either clear or grayed 
out.

• The method Screening-Default.m is 
loaded when you switch to the MS 
Target Compound Screening 
workflow.

2 Look at the automation steps for 
finding and identifying compounds.
• Tab the Method Editor window 

in a convenient location.

a In Method Explorer, click MS Target 
Compound Screening Workflow > 
Automation.

b (optional) Tab the Method Editor 
window with the Data Navigator 
window.

c Close the Compound List window.

• In this workflow, the Method Editor 
is a floating window. You can either 
leave it as a floating window or tab 
it with another window, such as the 
Data Navigator window.
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Task 3. Set up and run a method to automate compound identification using the MS Target Compound 

Screening workflow
3 Choose to search a database and 
generate formulas for all 
compounds.
• Make sure you are finding 

compounds by molecular 
feature.

a Click the Analysis Options tab.
b Click Find by Molecular Feature.
c Mark the Search a database for each 

compound check box.
d Mark the Generate formulas for each 

compound check box.
e Click All compounds.
f Mark the Show only identified 

compounds check box.

• A compound can be identified by 
the Search Database algorithm, the 
Generate Formulas algorithm, the 
Search library algorithm or if the 
compound was found using the Find 
by Formula algorithm. If 
MassHunter BioConfirm software is 
installed, then a compound can also 
be identified by the Match 
Sequences algorithm.

4 Make sure that new results will 
overwrite previous results.

a Click the Results tab.
b Mark the Delete all previous results 

check box.

5 Test the automation process up to 
this point.

• Click the Run Compound Automation 
Steps icon  from any of the MS 
Target Compound Screening Workflow 
> Automation sections.

6 Open these windows for viewing:
• Compound List
• DB Search List
• MS Formula Results List
• Make sure the results lists are 

tabbed along with 
Chromatogram Results as in 
Figure 88

• Review each list for each 
compound (except for 
Compounds 1 and 4).

a Click View > Compound List.
b (if necessary) Click View > DB Search 

Results.
c (if necessary) Click View > MS 

Formula Results.
d Clear the Compound 1 and Compound 

4 check boxes in the Data Navigator. 
Or, you can clear the check boxes for 
Compound 1 and Compound 4 in the 
Show/Hide column in the Compound 
List window

e Review each list for each identified 
compound to make sure that all 
actions in the Compound Automation 
Steps were performed.

• See Exercise 1 Task 4 to learn how 
to move windows on the main 
screen.

• The MS Formula Results window 
and the DB Search Results window 
are tabbed with the Chromatogram 
Results window in Figure 88.

7 Save the method to iiiexercise3, 
where “iii” are your initials.

a From the top menu, click Method > 
Save As.

b Type iiiexercise3.
c Click Save.

• Note that saving the method causes 
all the blue triangles indicating 
value changes in the opened 
method to disappear.

Task 3. Set up and run a method to automate compound identification

Steps Detailed Instructions Comments
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Task 3. Set up and run a method to automate compound identification using the MS Target Compound 

Screening workflow
Figure 88 Tabbed results from running compound automation identification steps

8 Set up the Compound Report for 
this exercise.
• If necessary, save the method.

a Select Compound Report.
b Make any changes you want.
c If necessary, click the Save Method 

icon in Method Editor.

Task 3. Set up and run a method to automate compound identification

Steps Detailed Instructions Comments
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Task 3. Set up and run a method to automate compound identification using the MS Target Compound 

Screening workflow
9 Set up the method to run the 
automated compound 
identification when the data file is 
opened
• Save the method.

a Select MS Target Compound 
Screening Workflow > Automation > 
File Open Actions.

b Select any actions in the Actions to 
run list, and click the Remove icon, .

c Select Compound Automation without 
Report in the Available Actions list, 
and click the Add button, .

d Click the Save Method icon in Method 
Editor.

• You can also test these actions if 
you want.

10 Close Method Editor, Method 
Explorer and Data Navigator.
• Move the windows so they look 

like the layout in Figure 89.
• Close the data file, and do not 

save results.

a Click the Close button for Method 
Editor, Method Explorer and Data 
Navigator.

b Move the windows so they look like 
Figure 89.

c Click File > Close Data File.
d Click No when asked to save results.

• See Exercise 1 Task 4 to learn how 
to move windows.

11 Open the sulfas_PosMS.d data file 
again to run the automated 
compound identification.
• The results should look like the 

results in Figure 89.
• Hide Compounds 1 and 4 in the 

Compound List.

a Click File > Open Data File
b Mark the Run ‘File Open’ actions from 

selected method check box.
c Click Open.
d Clear the Show/Hide check boxes for 

Compounds 1 and 4 in the Compound 
List.

• Compounds 1 and 4 are not found 
by the database search algorithm, 
but they do have formulas 
generated by the formula 
generation algorithm.

Task 3. Set up and run a method to automate compound identification

Steps Detailed Instructions Comments
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Task 3. Set up and run a method to automate compound identification using the MS Target Compound 

Screening workflow
Figure 89 Results of automated compound identification when opening the sulfas_PosMS.d data file

12 Close the data file without saving 
results.

a Click File > Close Data File.
b Click No when asked to save results.

Task 3. Set up and run a method to automate compound identification

Steps Detailed Instructions Comments
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Task 4. Set up a qualitative method to run with a worklist
Task 4. Set up a qualitative method to run with a worklist 

In this task you set up a qualitative analysis method that contains a list of 
actions to execute when you run the worklist. You learn to save the method 
with both acquisition and qualitative analysis parameters, although you will 
not actually do this in this task.

Task 4. Set up a qualitative method to run with worklist

Steps Detailed Instructions Comments

1 Set up a method to automatically 
execute upon completion of every 
run in the worklist. 
• Open the sulfas_PosMS.d data 

file with the method you saved in 
Task 2.

• Make sure actions are not run 
when you open the file.

• Restore the default window 
layout.

Set up the method to perform the 
following tasks:
• Extract the defined 

chromatogram 
• Integrate and extract peak 

spectra
• Generate Analysis Report

Hint: Look under Worklist 
Automation in Method Explorer.

a To restore the default workflow, click 
View > Configure for Workflow > 
General.

b Click OK to continue.
c Click File > Open Data File.
d In the Open Data File dialog box, select 

sulfas_PosMS.d.
e Clear the Run ‘File Open’ actions from 

selected method check box.
f Click Open.
g Load the method iiiExercise2.m.
h In the Method Explorer, select 

Worklist Automation > Worklist 
Actions to display the Assign Actions 
to Run from Worklist section.

i Make sure that the following actions 
are in the Actions to be run list in this 
order:
• Extract Defined Chromatograms
• Integrate and Extract Peak Spectra
• Generate Analysis Report

j If necessary, select each of these 
actions from the Available actions list, 
and click the Add button, , to 
move the selected action to the 
Actions to be run list. 
You can also double-click on the 
selected action to copy it to the other 
list.

k If necessary, select any actions in the 
Actions to be run list that are not in 
the above list, and click the Remove 
icon .

• In this task you are creating a 
method that contains only 
qualitative analysis parameters.

• To create a worklist method from 
this method, you must add 
acquisition parameters to this 
method in the acquisition program.

• If you select Load worklist method 
(assuming it’s available) in the Open 
Data File dialog box, the program 
opens the data file using the 
qualitative analysis part of the 
acquisition method in the worklist 
that produced the data file.

• You can create a worklist method 
with both acquisition and 
qualitative analysis parameters by 
saving the qualitative analysis 
parameters to an existing 
acquisition method.

• You can also set up the method for a 
complete analysis with the Analysis 
Automation Steps. Then you would 
remove these actions and add on 
the Analysis Automation action.

• You can do the same with 
Compound Automation.
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Task 4. Set up a qualitative method to run with a worklist
Figure 90 Method Editor with Worklist Actions section displayed

2 Save the method to iiiexercise 
2worklist.m, where “iii” is your 
initials.
• Close the program and do not 

save results.

a To save the method, click Method > 
Save As. 

b Type iiiexercise2worklist.m.
c Click Save.
d Click File > Exit.
e Click No when asked if you want to 

save the results.

• After the acquisition parameters 
have been added to this method in 
the acquisition program, you can 
save it to the same name or a 
different one.

• When run from the worklist, this 
method (with acquisition 
parameters added) will acquire and 
analyze data sequentially and 
automatically. The actions in the 
Actions to be run list in the 
Worklist Actions section are run 
automatically.

Task 4. Set up a qualitative method to run with worklist

Steps Detailed Instructions Comments
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Task 4. Set up a qualitative method to run with a worklist
140 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide



Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide
Reference

Work with windows    142

Work with result data in Data Navigator    144

Perform operations on the chromatogram    145

Perform operations on an MS or MS/MS spectrum    146

Work with chromatographic visual data    147

Workflows    148

Customize a report template    151
141Agilent Technologies



4 
Work with windows
Work with windows

When you first open the Qualitative Analysis program, you see three windows 
as the default layout: Data Navigator, Method Explorer and Chromatogram 
Results. You can bring up seventeen other windows using the View menu: 
Method Editor, Spectrum Preview, MS Spectrum Results, Difference Results, 
UV Results, Integration Peak List, MS Spectrum Peak List 1, MS Spectrum 
Peak List 2, MS Actuals, Compound List, MS Formula Results, MS/MS Formula 
Details, DB Search Results, Library Search, Structure Viewer and Sample 
Information. You can also display three tool windows which are displayed 
when you start using the associated tool: Formula Calculator, Mass Calculator, 
and Recalibrate.

Window Icons in the Main Toolbar

You open and close the Qualitative Analysis windows with these icons on the main 
toolbar. Additional icons are available when the MassHunter BioConfirm software 
is installed. Commands in the View menu can also be used to open these windows.
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Work with windows
MS Spectrum
Results

Data Navigator

Spectrum 
Preview

Chromatogram Results

Method Editor

Method Explorer

Integration Peak List

MS/MS Formula 
Details

MS Spectrum 
Peak List 1

Compound List

MS Spectrum 
Peak List 2

MS Actuals

MS Formula 
Results

Sample Information

Deconvolution Results (only 
if the BioConfirm program is 
installed)

UV Results

DB Search 
Results

Difference 
Results

Library 
Search 
Results

Structure 
Viewer
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Work with result data in Data Navigator
Work with result data in Data Navigator

Data Navigator window and tools

The Data Navigator organizes all the results of extraction and spectrum 
selection either by data file or by data type.

 

When activated (default), highlighting a 
chromatogram in Data Navigator also highlights 
the corresponding spectra. The corresponding 
chromatogram and spectrum visual results are 
also highlighted. Linked Navigation only works if 
you have used the Integrate and Extract Peak 
Spectra menu item from the Chromatograms 
Menu or have run any of the Compounds 
algorithms.

Single check mark – Marks check boxes of all 
highlighted data.

Dual check marks, one gray – Marks check boxes 
of highlighted data and clears the other check 
boxes.

Dual check marks – Marks all check boxes.

Chromatograms and spectra are displayed when 
their check boxes are marked.

Check Mark Tools

Linked Navigation Icon
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Perform operations on the chromatogram
Perform operations on the chromatogram

You can perform the following operations on the whole chromatogram or on a 
selected region of the chromatogram by using the menu items:

Select range operations from shortcut menu

When you have selected a chromatographic range, you can also extract a 
spectrum and extract a spectrum to background, in addition to the operations 
mentioned above and others not mentioned.

1 To access these operations, click the Range Select icon in the 
Chromatogram Results toolbar. 

Action Menu Item

Extract a chromatogram Chromatograms > Extract Chromatograms

Extract defined chromatograms Chromatograms > Extract Defined Chromatograms

Integrate the chromatogram Chromatograms > Integrate Chromatogram

Integrate and extract peak spectra Chromatograms > Integrate and Extract Peak Spectra

Smooth the chromatogram Chromatograms > Smooth Chromatogram

Calculate Signal-to-Noise Chromatograms > Calculate Signal-to-Noise

Find compounds from auto MS/MS data Find > Find Compounds by Auto MS/MS

Find compounds from targeted MS/MS 
data

Find > Find Compounds by Targeted MS/MS

Find compounds for MS(1) data Find > Find Compounds by Molecular Feature

Find compounds by Chromatogram 
deconvolution

Find > Find Compounds by Chromatogram 
Deconvolution

Find compounds that match specific 
formulas

Find > Find Compounds by Formula
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4 
Perform operations on an MS or MS/MS spectrum
2 Click the left mouse button at the point where you want to start the range, 
drag the cursor over a range, and release the button.

3 Right- click anywhere in the chromatogram, and click the operation from 
the shortcut menu.

Save results to the data file(s)

• Click the Save icon, or click File > Save Results.

When you exit the program, it also asks if you want to save the results to 
the data file, unless you have turned off this feature. 

Perform operations on an MS or MS/MS spectrum

You can perform the following operations on an MS or MS/MS spectrum or on 
a selected region of an MS or MS/MS spectrum by using the menu items:

Action Menu Item

View the m/z, abundance, charge state 
and other information about a spectrum

View >MS Spectrum Peak List 1

Subtract the background spectrum Spectra > Subtract Background Spectrum

Add two spectra together Spectra > Add Any Spectrum (and then click another 
spectrum)

Search a database for compounds that 
match specific masses in a spectrum

Spectra >Search Database for Spectrum Peaks

Generate formulas for the masses in the 
selected range in a spectrum 

Spectra > Generate Formulas from Spectrum Peaks 
(when a range is selected in the MS spectrum)

Deconvolute using the Resolved Isotope 
algorithm

Spectra > Deconvolute (Resolved Isotope)

Search Library Identify > Search Library for Spectra
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Work with chromatographic visual data
Work with chromatographic visual data

Chromatogram Results Window

Chromatogram Results Tools

Zoom Tools 
in order

Select Tools in order
Range Select – When On, you can draw a range for 
chromatogram, for which you can perform actions

Peak Select – When On, you can select spectrum 
of an integrated peak at apex

Manual Integration – When On, you can integrate 
interactively

Walk Chromatogram – When On, you can see 
individual spectra as you click each point or use the 
left and right arrows on the keyboard.

Autoscale X-axis and Y-axis

Autoscale X-axis

Autoscale Y-axis

Unzoom

Autoscale Y-axis during Zoom

Linked Y-axis mode

To clear a tool 
selection, click 
another tool or icon.
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide 147



4 
Workflows
Workflows

Workflows help you to customize the user interface for your application. 
Each workflow loads a different method that has parameters that are 
appropriate for that workflow. Also, each workflow loads a different 
layout; these layouts include customizing the columns shown in each table. 
Lastly, four of the layouts also add a special method editor section which 
contains copies of the sections in the method editor that are important for 
that workflow. Grouping the features that are used in a specific workflow 
together makes it easier for you to customize your method.

Five different workflows are available in the Qualitative Analysis program. 
They are:

• General

• BioConfirm -  This workflow is only available if the BioConfirm software 
is installed and marked in the User Interface Configuration dialog box.

• Chromatogram Peak Survey

• Formula Confirmation and Sample Purity

• MS Target Compound Screening

If you are working with GC/MS data, you can only select the General 
workflow. If you are working with LC/MS data, you can select any of the 
workflows.

Specific Method

Each workflow loads a specific default method with more appropriate 
settings for that workflow. For example, if you switch to the BioConfirm 
workflow, the Target data type for the Find Compounds by Molecular 
Feature algorithm is set to Large molecules (proteins, oligos). This 
setting is appropriate for the BioConfirm workflow but not, by default, for 
the other workflows.

Specific Layout

In addition, each workflow loads a specific layout. A layout consists of the 
following:

• Each window’s position and size

• Which windows are tabbed

• Which windows are floating
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Workflows
• Which tabbed window is on top

• Which windows are visible by default

• Whether the status bar is visible

For each plot window (the Chromatogram Results window, the Spectrum 
Preview window, the MS Spectrum Results window, the Deconvolution 
window and the UV Results window), the following are saved:

• Whether or not the graphics are overlaid

• Whether or not the Autoscale Y- Axis during Zoom mode is on

• Whether or not the Linked Y- Axis mode is on

For each table window, the following are saved

• Which columns are visible

• The order of the columns

• The width of each column

Specific section in the Method Explorer and Method Editor

Using the Method Editor with the General workflow, you can change all of 
the parameters in the Method. 

Each of the four workflows changes the sections available in the Method 
Explorer. Each section contains only the Method Editor tabs and sections 
that are useful in that workflow. Changing a parameter in the workflow 
section also changes the parameter in the corresponding section in the 
general Method Editor sections.

Two tabs are not repeated in the general Method Editor sections. The 
Spectrum Peak Identification section and the Database Search > Search 
Criteria tab are only included in the Chromatogram Peak Survey 
workflow. These sections only affect the Chromatogram Peak Survey 
algorithm. This algorithm is only used in this workflow, and in the 
Chromatogram Peak Survey without Report action and in the 
Chromatogram Peak Survey with Analysis Report action.

BioConfirm methods and layouts

Additional default methods and layouts are provided with BioConfirm 
software to use as starting points for creating your own customized 
methods for Sequence Matching. 
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Workflows
Workflow Method Layout Method Editor 
Section

General default.m Default.xml None

BioConfirm BioConfirm
IntactProtein-Default.
m

BioConfirm-
IntactProtein-
MaximumEntropy-
Default.xml

BioConfirm Workflow

Chromatogram Peak 
Survey

ChromPeakSurvey-
Default.m

Default.xml Chromatogram Peak 
Survey Workflow

MS Target Compound 
Screening

Screening-Default.m Screening-Default.xml MS Target Compound 
Screening Workflow

Formula Confirmation 
and Sample Purity

SamplePurity-
Default.m

SamplePurity-
Default.xml

Formula Confirmation 
and Sample Purity 
Workflow
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Customize a report template
Customize a report template

Please refer to either the online Help for the MassHunter Report Designer 
Add- in or the Reporting Training DVD for detailed information on how to 
modify a report template. The following steps give you a quick look at 
what it means to customize a template.

1 Go to the folder that contains the report templates. By default, this folder 
is 
\MassHunter\Report Templates\Qual\Letter. You can select a different folder in 
the Method Explorer in the General > Common Reporting Options > 
Templates tab.

2 Make a copy of the template which you intend to modify. Right- click the 
copy and click Properties. Clear the Read- only check box. Then, right- click 
the copy and click Open from the shortcut menu.

Opening the template this way lets Excel know that this file is a template 
file. When the template is open, you can modify headers and footers and 
add, remove or move parameter columns. Refer to the online Help for more 
information. All Qualitative Analysis templates are marked Read- only. You 
change this property before you edit a template.
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Customize a report template
Many templates are installed with the Qualitative Analysis program. 
Refer to the Qualitative Analysis online Help for more information 
about the content of each report template.

3 Make the changes you want to make.

For more information on how to modify a template, see either the 
online Help for the MassHunter Report Designer add- in, or the Agilent 
MassHunter Reporting -  Training DVD.

4 To save the new template, either click Save or click Save As > Other 
Formats from the Microsoft Office button. 

5 Type an identifying name, and click Save.
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