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In This Guide...
This guide describes how to import, organize, manage, export 
and display data and other content (experiments, gene lists, 
tracks) within Agilent Genomic Workbench 6.5. It is targeted 
for users who have no DNA Analytics application license(s). 
If you do have a DNA Analytics license and intend to 
analyze your data, see the User Guide for the type of data 
you want to analyze.

1 Getting Started

This chapter gives an overview of the capabilities you have 
in Agilent Genomic Workbench without a license, and 
describes the parts of the Agilent Genomic Workbench main 
window that you use to import, organize, manage, export 
and display array data and other content.

2 Importing, Managing, and Exporting Data and Other Content

This chapter describes how to import, organize, manage, and 
export data and other content within the user interface of 
Agilent Genomic Workbench.

3 Displaying Data and Other Content

This chapter shows you how to display log ratio data from 
imported feature extraction data files, as well as gene list 
and track content, in the Genomic Viewer. It also gives you 
instructions on how to modify the display to see the data 
and content the way you prefer.

4 Data Viewing Reference

This chapter describes the tab commands, shortcut menus, 
and dialog boxes that can appear. 
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Agilent Genomic Workbench 6.5 – Data Viewing 
User Guide
1
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This guide describes how to use Agilent Genomic Workbench to display 
data if you do not have a CGH, ChIP, or methylation (CH3) DNA Analytics 
license. 

This chapter gives an overview of the window components and how to use 
Agilent Genomic Workbench to view data. Without a license, you have a 
number of capabilities, that include the import, management, export, and 
display of CGH, ChIP, and CH3 data. With a Feature Extraction (FE) 
license, you can also run an automated feature extraction workflow. For 
more information, see the Workflow User Guide.

To display imported data, you organize the data files into logical units 
called experiments. Experiments are used to define the data you want to 
display using Agilent Genomic Workbench. After you create them, and add 
array data, you can then display the data.

For a description of the commands and dialog boxes that appear when 
you use the program, see Chapter 4, “Data Viewing Reference”. 
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1 Getting Started
NOTE Descriptions in this guide cover only the commands and options that are available for 
viewing data using Agilent Genomic Workbench without a DNA Analytics license. For 
information on commands and options that are available with a license, or for information 
on eArrayXD, Sample Manager, Quality, Workflow, or SureSelect Target Enrichment, see 
the User Guide for the module that you want to use. 
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Transferring Data from the eArray Web Site
Transferring Data from the eArray Web Site

When you install Agilent Genomic Workbench, a set of “core data” is 
transferred to your database. This includes administrative data, control 
grids, and the names (only) of Catalog and workgroup probe groups, bait 
groups, microarray designs, and libraries. 

Additional data from the eArray Web site are required in order to perform 
eArrayXD functions. This content is downloaded from the eArray Web site 
using the Data command from the Home tab. For example, to search for 
expression probes from the Agilent Catalog, you must first transfer the 
Catalog expression probe data from the eArray Web site to your server. 
See “To transfer catalog and workgroup data” on page 59. For more 
information on how to download data from the eArray Web site, see the 
eArrayXD User Guide.

In order to import or analyze extracted microarray data using Agilent 
Genomic Workbench, you must first download the design files that match 
those microarrays from the eArray Web site, or import them. See “To 
download a design from eArray” on page 72 and “To import Agilent GEML 
design files” on page 48. It is not necessary to transfer the entire catalog 
or workgroup data from eArray to analyze extracted microarrays or run 
Feature Extraction or analysis workflows.
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Using Agilent Genomic Workbench on a Mac

The content of this User Guide applies to both the Windows and Mac 
versions of Agilent Genomic Workbench. Both of these versions have the 
same features. However, when you use the Mac version of the program, 
please note the following:

Windows command Equivalent Mac command

Right-click • Command-click ( -click)
• On Macs with trackpads, other options are available. On 

certain machines, you place two fingers on the trackpad 
while you press the button below the trackpad. See the user 
guide for your specific machine.

• If you have a third-party mouse that has more than one 
button, you may be able to use one of the buttons as a right 
mouse button.

Control-click Control-click (Same as the Windows command)

Shift-click Shift-click (Same as the Windows command)

 (Close button)  (Close button)
16 Data Viewing User Guide
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Using Main Window Components to Display Data

You can use the data viewing capability in Agilent Genomic Workbench 
without a license. You can view data for many types of arrays, including 
CGH, ChIP, and Methylation (CH3). You can use the data analysis 
capability in Agilent Genomic Workbench only if you have a license for 
one or more of the DNA Analytics programs (CGH, ChIP, or Methylation).

What are the main window components?

You use four primary components of the Agilent Genomic Workbench main 
window to import, manage, export and display extracted data.

• Home tab commands — import, manage and export data

• Navigator — create and fill new experiments with array data 

When you make the experiment active, the data appear in the display, 
called Genomic Viewer.

• Genomic Viewer — display data and content in four Views: Genomic 
View, Chromosome View, Gene View, and Tab View

• View tab commands — change appearance of Genomic Viewer display

Figure 1 shows the main window of Agilent Genomic Workbench when the 
Genomic Viewer tab is selected, and identifies the names of its 
components. 

To learn how to display log ratio data, content, and analyze data to show 
results, see the User Guide for which you have a DNA Analytics program 
license(s).
Data Viewing User Guide 17



1 Getting Started
What are the main window components?
Figure 1 Agilent Genomic Workbench main window with major components – unlicensed CGH version with 
Feature Extraction license
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What can you do with the main components to display data?

See the table below for the parts of the main window you use to display 
log ratio data, without a license.

Table 1 Components of Agilent Genomic Workbench main window for display of data

To do this Use this part of the main window

Change program to CGH, ChIP, 
Methylation (CH3),Expression, 
microRNA, and SureSelect Target 
Enrichment

Switch Application button: Click the button and click the 
program you want to open. Do this to display different 
data types, even if you have no license. The window and 
options are different for the different program types.

Download design files Navigator for Design Files: Right-click the name of a 
design file and click Download. Icons give the status of a 
library or microarray design (update required, draft, 
review, completed, or submitted). See the eArrayXD User 
Guide for details,

Import or export data Home tab: Click the Import or Export button to select the 
data you want to import or export. See Chapter 2, 
“Importing, Managing, and Exporting Data and Other 
Content” for more information.

Select array data to display in the three 
graphical views or in the Tab View as a 
table

Experiment pane of the Navigator: Create an experiment 
with the imported data, select the experiment, and then 
select the data within the experiment to display data. See 
Chapter 3, “Displaying Data and Other Content” for more 
information.

Display array data for only a certain 
portion of a chromosome

Genome View: Select a chromosome to display in 
Chromosome View. You cannot view log ratio data points 
here.

Chromosome View: Select a gene region to display in 
Gene View. You can display log ratio data points here if 
you select Scatter Plot in the View Preferences dialog 
box.

Gene View: See the log ratio data next to a selected 
region of a chromosome, with associated genes and 
track-based annotation. 

See Chapter 4, “Data Viewing Reference” for details 
about these Views.
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Show/Hide or customize the data 
points for the scatter plots

Gene View: Move the mouse pointer over Scatter Plot to 
display the options. Or, right-click and then click View 
Preferences.

Chromosome View: Right-click and then click View 
Preferences.

View tab: Click View Preferences.

See Chapter 3, “Displaying Data and Other Content” for 
information on how to do this.

Display array data next to tracks or 
gene lists

My Entity List pane of Navigator: Add or select a track or 
gene list to have it appear in Gene View. 

See Chapter 3, “Displaying Data and Other Content” for 
information on how to do this.

Change the appearance of the display View Tab: Click View Preferences. From the View 
Preferences dialog box, you can change the orientation, 
select what type of data to view, and configure scatter 
plot options.

Genomic Viewer: Right-click any View except the Tab 
View and select View Preferences. In the View 
Preferences dialog box, you can select to show or hide the 
scatter plots and how to display them. If you have one or 
more DNA Analytics licenses (CGH, ChIP, or Methylation), 
you can show or hide the results.

See Chapter 3, “Displaying Data and Other Content” for 
more information.

Table 1 Components of Agilent Genomic Workbench main window for display of data 

To do this Use this part of the main window
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Switching applications

You can use the Agilent Genomic Workbench to work with a variety of 
different data types. Because the requirements for the display of data (and 
calculation of results, if using a license) are different for different data 
types, you must switch the application for the type of data you want to 
display.

The Switch Applications menu, located at the upper right corner of the 
Agilent Genomic Workbench window, is used to change the application. 
The selected application is marked . The selected application is also 
displayed in the title bar of the Agilent Genomic Workbench main window.

Figure 2 Switch Application menu for the Genomic Workbench

NOTE You cannot display Expression or microRNA data in Agilent Genomic Workbench; you can 
only design their microarrays.
Data Viewing User Guide 21



1 Getting Started
Using Tabs and Command Ribbons
Using Tabs and Command Ribbons 

Tabs

When you click a tab, groups of commands or single commands appear 
that are specific for that tab. The tabs that are displayed change 
depending on what licenses you have, and what application is selected 
(such as CGH, ChIP, CH3). Without a license, you only use the Home and 
View tabs to display data.

Figure 3 Agilent Genomic Workbench tab menu for CGH without a license

The following table summarizes what you can do from the tabs of Agilent 
Genomic Workbench, with a DNA Analytics (CGH, ChIP, CH3) application 
selected, but without any license installed.

Table 2 Capabilities in tabs 

Tabs Capabilities

Home Set preferences for display of tracks.

Set eArray user and data locations.

Set licences for analysis applications.

Import array files, design files, genome builds, tracks, array 
attributes, and experiments.

Export experiments, tracks, and array attributes.

Create an experiment.

Find and go to a gene or genomic location.

eArrayXD Create and search probe groups and microarray designs. 

See the eArrayXD User Guide for information.
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Tabs
Sample Manager (Requires 
Feature Extraction license)

Import attribute files.

Export attribute files.

Display and edit sample attributes.

For more information, see the Sample Manager User Guide.

Quality (Requires Feature 
Extraction license)

Import, query, create, and chart QC Metrics.

For details, see the Quality Tools User Guide. 

Workflow (Requires Feature 
Extraction license)

Create and run a Feature Extraction workflow. Analysis 
workflow requires CGH or ChIP license.

For more information, see the Workflow User Guide.

View Set up preferences for display of data

Copy displayed data to the Clipboard

Turn on or off display of Views and Navigator

Turn on or off tabular display of signal intensity and 
annotations

Turn on or off display of Cytoband information in Gene View

Turn on or off highlight of nonunique probes

Turn on or off display of custom data

Tool Set parameters for plug-ins

Display plug-in examples

Help View program information and User Guides.

Table 2 Capabilities in tabs  (continued)

Tabs Capabilities
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Commands
Commands

The area where commands appear is called a command ribbon. The 
command ribbon that appears when you click the Home tab is shown 
below. The commands that appear in the command ribbon change 
depending on what application module is selected, and which tab in that 
application module is selected.

Figure 4 Command ribbon for the Home tab

For a complete description of all of the command ribbons and commands 
you see in Agilent Genomic Workbench, see “Command Ribbons” on 
page 113.
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Using the Navigator to Search for Data

This section gives you instructions on how to search for design files, 
extracted Feature Extraction data, experiments and other information in 
the Navigator of Agilent Genomic Workbench. The Navigator contains 
different panes when you select the eArrayXD, Sample Manager, or 
Workflow tabs. See the User Guides for those applications for information 
on the Navigator contents.

Figure 5 Navigator panes for CGH

Search pane

Design Data pane
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My Entity List pane

My Networks pane

Tasks pane

Genotypes pane (CGH only)
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Using the Navigator to Search for Data
The Navigator (Figure 5) shows the array data, experiments, and other 
content stored in Agilent Genomic Workbench that is available to the 
logged in user for display. It contains the following panes:

Navigator Pane Comments

Search Lets you search within any pane of the Navigator for a specific 
design or content, or for items that contain a specific string of 
characters, when using asterisks (*) as wildcards. See “Search 
pane” on page 123 for more information.

Design Data Contains microarray data files, organized by design and application 
type, and then by genome build. 

Shows all probe groups and microarray designs that are available 
to you, organized by folders. In general, you can:

• Expand or collapse folders to show or hide content
• Look at the icon that appears with an item to monitor its status.
• Right-click the name of a folder or item to open a shortcut menu 

that lets you take action on the item.
See “Design Data pane – icons, special text, and buttons” on 
page 129 and “Design Data pane – actions and shortcut 
menus” on page 131.

Experiment Contains Agilent Genomic Workbench experiments. Experiments 
are organizational units that contain links to microarray data and 
design files. See “Experiments Folder” on page 137, “Experiment 
pane – icons, special text, and buttons” on page 136, and 
“Experiment pane – actions and shortcut menus” on page 137.

My Entity List Contains gene lists and tracks:
• Gene Lists are collections of genes of interest. You can create 

them within the program, import and export them, and apply 
them to Gene View and Chromosome View.

• Tracks are collections of annotation or other information that 
map to specific genomic locations. You can import, export, and 
combine tracks, and display them in Gene View with your array 
data and analysis results. See “My Entity List pane – icons, 
buttons, and special text” on page 141 and “My Entity List pane 
– actions and shortcut menus” on page 141.

My Networks Contains the biological networks/pathways that you found using 
Network Search or that you create using a literature search in 
eArrayXD. For more information, see the eArrayXD Users Guide.
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Tasks Shows the jobs that you have submitted (such as downloading 
designs from eArray). Some jobs are completed locally by the 
eArrayXD server program. Others are sent to the eArray Web site 
for completion. In general, you can:
• Look at the icon that appears with a job to monitor its status.
• Right-click the name of a pending task to open a shortcut menu 

that lets you take further action on the job.
See “Tasks pane” on page 143.

Genotypes (CGH only) Shows SNP genotype reference samples in the database. You can 
import, display details, rename, or delete genotype references from 
this pane. See “To import a genotype reference file” on page 64.

Navigator Pane Comments
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To search the Navigator

You can search one or all of the panes of the Navigator for items that 
match a specific search term. Figure 6 shows the search pane of the 
Navigator, and identifies a couple of its elements.

Figure 6 Search pane of the Navigator

1 At the top of the Navigator, in the Pane list, select the pane to be 
searched. To search in all panes, select All Panels. If the pane list is 
not visible, click  to show it.

2 In the search term box, type the desired search term. The search term 
is not case sensitive, but it must contain the complete entry that you 
want to find. You can use asterisks (*) to represent one or more 
unspecified characters. For example, type *12345* to find any item that 
contains “12345”.

3 Click .

The program searches the selected pane(s) for items that match your 
search term. If it finds matching items, the program expands the 
appropriate folders, and displays the names of the matching items in 
red. The first matching item is highlighted in yellow.

4 Do any of the following:

Search Term Box

Pane List
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• To highlight the next matching item, if one is available, click 
.

• To highlight the previous matching item, click .

5 After you complete the search, click  to clear the results of the 
search, as well as your search term.
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Using the Genomic Viewer to Display Data

What is the Genomic Viewer?

Genomic Viewer is the graphics and tabular display section of the Agilent 
Genomic Workbench main window. In the Genomic Viewer, extracted data 
and analysis results can be tabulated and displayed next to depictions of 
the genome, selected chromosome, and selected genes of the species whose 
array data you are analyzing.

There are four main views in the Genomic Viewer, as shown in Figure 7.

• Genome View – A graphical representation of the entire genome for the 
selected species. Use this view to select the chromosome to show in the 
other views.

• Chromosome View – A graphical representation of the selected 
chromosome, displayed with cytobands and a plot area. Click or drag 
the mouse to select a region to display in the Gene View.

• Gene View – A more detailed view of the chromosomal region selected 
in the Chromosome View.

• Tab View – Displays design annotation and log ratio data related to the 
chromosome you select in Chromosome View

For more information on the Genomic Viewer and its views, see 
Chapter 4, “Data Viewing Reference”.
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Figure 7 Genomic Viewer in vertical orientation

Genome View

Chromosome View

Gene View

Tab View
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To change the size of and detach panes from the Agilent Genomic 
Workbench main window

• To change the size of a pane in the main window, drag one of its inside 
borders.

• To detach a pane from the main window and open it in a separate 
window, click its Detach button .

Figure 8 Changing the size of and detaching panes

Click here
to detach View

Drag a border to 
to resize pane
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To maximize and reattach panes to the Agilent Genomic Workbench 
main window

• To display a view full- screen in a separate window, click its Maximize 
button.

• To reattach a view in a separate window to the main window, click its 
Close button.

Figure 9 Maximizing and reattaching panes

Click here to
reattach View

Click here
to maximize View
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General Instructions for Displaying Microarray Data

An experiment is
the folder that

holds data from
any array set you

select for the
experiment. The
folder also holds
analysis results.

You set up experiments to display all data in the Genomic Viewer. To set 
up an experiment you:

• Import data

• Create a new experiment

• Add the imported data to the experiment

• Select the experiment to display data

Figure 10 Typical pathway for display of microarray data

Select CGH, ChIP, 
or CH3 

application

Turn on scatter 
plot options

Download or import
design files

Add data to the new 
experiment

Create an 
experiment

Import data files
• Agilent FE files

• Axon files

• UDFs (CGH)

Review data 
(tracks and 

genomic 
boundaries)

Select arrays to 
display

Select the 
experiment
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Quick-start Instructions for Displaying Microarray Data

The instructions in Table 3 show how to organize imported log ratio 
Feature Extraction data so you can display your data next to the 
corresponding cytobands. Without a DNA Analytics license, only log ratio 
data is displayed, not results.

These instructions assume that: 

• All instructions apply whether you have a license or not. 

• You use only Agilent data and design files. If you choose to use the 
demo Agilent design and data files that come with the program, you 
do not need to import those files.
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Table 3 How to display data in Agilent Genomic Workbench

To do this  Follow these instructions Comments

1 If you are in another application, click 
Switch Application.

2 Select the CGH, ChIP, or CH3 
application type.
You do not need a license to perform 
the following steps.

• If you are using a licensed version 
of the application, make sure all the 
analysis options are turned off. 
(Clear check boxes in the Analysis 
command ribbon.)

1 By default, the scatter plot for log 
ratios is turned on for Gene View. To 
view or change the scatter plot 
options, in Gene View move the 
pointer over the arrow next to Scatter 
Plot and mark one or more of the 
check boxes. See “Gene View” on 
page 151.

2 To view or change additional options 
for the scatter plot, or to change the 
orientation of the panes in the 
Genomic Viewer, right-click in one of 
the panes and select View 
Preferences. See “View 
Preferences” on page 258.

• The check boxes in Scatter Plot set 
the program to draw data points that 
represent log ratio or other selected 
values. 

• If you do not turn on the scatter plot 
functions, you will see nothing in the 
Genomic Viewer. 

• If you are using the Agilent demo files, 
continue to Create an Experiment.

Select the 
application

Turn on scatter 
plot options
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• To download a design from the eArray 
Web site, expand the Designs folder of 
the Navigator, and locate the design. 
Right-click the design, and select 
Download from eArray.com.

OR

1 To select Agilent GEML-based 
microarray design files for import, click 
Home > Import > Design Files > 
GEML File.

2 In the dialog box that appears, select 
the file you want to import, then click 
Open. 
The Import GEML design dialog box 
appears.

3 If necessary, select the Genome Build 
for your files.

4 Click Start Import.
Design Import Summary appears, and 
the design file with selected genome 
build appears in the Navigator, in the 
Imported External Designs folder of 
the Design Data pane. See “Using the 
Navigator to Search for Data” on 
page 25.

• If you want to import an Agilent or 
Axon array data file, its design file 
must be in the database. If the 
design file is not already available in 
the Navigator, or has a yellow arrow 
next to it, you must download it 
from the eArray Web site, or import 
it. 
Note: Agilent catalog designs must 
be downloaded from the eArray 
Web site.

• Designs with a green arrow are 
already downloaded.

• When you import a design file, the 
program shows the genome build(s) 
that can be used by the design file 
as nodes under the design file.

• The current builds are available in 
Agilent Genomic Workbench. 
Should you want to import a design 
file for a different genome build, you 
must import the genome build first.

1 To import Agilent FE files, click Home 
> Import > Array Files > FE File.

2 Find and select the desired file, then 
click Open. To select multiple files, 
hold down the Ctrl key and click their 
names.

3 In the dialog box that appears, in Dye 
Flip, select either Normal or Flipped 
for each FE or Universal Data File 
(UDF).

4 Click OK.
5 In the Navigator, check the Design 

Data folder to make sure that the 
program imported the correct files.

• In Dye-Flip, select Normal if:
• The test samples were labeled 

with cyanine-5 (red).
• The control samples were 

labeled with cyanine-3 (green).
• The imported ratio (test/control) 

will be reported directly.
• In Dye-Flip, select Flipped if:

• The test samples were labeled 
with cyanine-3 (green).

• The control samples were 
labeled with cyanine-5 (red).

• The imported ratio (control/test) 
will be reported with the ratio 
inverted (test/control).

Table 3 How to display data in Agilent Genomic Workbench (continued)

To do this  Follow these instructions Comments

Import design files or 
download them from 
the eArray Web site.

Import data files
• Agilent FE files

• Axon files

• UDFs
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• The program automatically puts the 
imported data under the genome 
build folder that belongs to the 
design used with the arrays.

1 In the Experiment pane of the 
Navigator, right-click the Experiments 
folder, then select New Experiment.
A dialog box appears.

2 Type a name and an optional 
description for the experiment.

3 Click OK.
4 (optional) To add data to the 

experiment now, click Properties. 
Otherwise continue and add data, as 
described in the next step.

• The new experiment appears as a 
node within the Experiment pane of 
the Navigator. The node becomes a 
folder once data is added to the 
experiment.

1 Fully expand the Design Data folder, 
and click the name of an array you 
want to add to your new experiment. 

2 Drag the selected arrays to the folder 
of the new experiment.

• To select additional arrays within the 
same design, hold down the Ctrl key 
and click their names.

• You can also right-click the name of 
the experiment, and select Show 
Properties to add arrays to an 
experiment.

Table 3 How to display data in Agilent Genomic Workbench (continued)

To do this  Follow these instructions Comments

Create an 
experiment

Add data to the new 
experiment
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Quick-start Instructions for Displaying Microarray Data
1 In the Navigator, double-click the 
name of the experiment.
A dialog box appears.

2 Click Yes. 
• In the Navigator, the name of the 

experiment turns blue, which 
indicates that it is the active 
experiment.

• You now see the scatter plot log 
ratio data in the Chromosome and 
Gene Views.

• The program automatically selects 
the first array in the experiment for 
display. 

• A data table appears in Tab View.
• At this point if the arrays within the 

experiment use a genome build 
different from the one represented 
in the Views, the program changes 
the chromosomal and gene 
information used in the Views.

Table 3 How to display data in Agilent Genomic Workbench (continued)

To do this  Follow these instructions Comments

Select the 
experiment
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Quick-start Instructions for Displaying Microarray Data
To select an array, right-click the array 
name, and click Select. To clear an array 
selection, right-click the name of the array 
in the Navigator, then click Deselect. 

You can also select or deselect several 
arrays at a time. Hold down the Shift key 
and click the contiguous arrays whose log 
ratio data you want to display. Hold down 
the Ctrl key and click the non-contiguous 
arrays whose log ratio data you want to 
display.

• In the Navigator, the icons beside 
the arrays become colored, when 
enabled for the selected 
experiment. 

• In Tab View, colored squares appear 
in the column heading for the 
arrays when selected. You can 
select or deselect only one array at 
a time in Tab View, or you can 
select or deselect all arrays at the 
same time.

• The program adds the data from the 
array to the Chromosome and Gene 
views. 

Table 3 How to display data in Agilent Genomic Workbench (continued)

To do this  Follow these instructions Comments

Select arrays to 
display
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Quick-start Instructions for Displaying Microarray Data
• In Genome View, click a chromosome 
of interest.

• In Chromosome View, drag the pointer 
over a region of the chromosome graph 
to display it with more resolution in 
Gene View.

• In Gene View, click the + and – buttons 
to zoom in and out.

• In Gene View, click anywhere within 
the scatter plot to recenter the view at 
that location. 

• To see information for the log ratio 
data, in Gene View, move the pointer 
over the arrow next to Scatter Plot to 
show the options. Under Configure 
Coloring schemes, mark the check box 
and select Log Ratio Values. 

• In Gene View, zoom in so that single 
data points are visible, then place the 
pointer over a data point. If ToolTip is 
enabled in View Preferences, a box 
appears that describes the data point.

• The solid, horizontal blue lines in 
Chromosome and Gene views are 
referred to as the View cursor. The 
chromosomal location of the cursor 
appears in the Status bar, located 
on the lower left corner of the 
screen.

• If you still cannot see the Scatter 
Plot data in Chromosome and Gene 
View or ToolTips in Gene View, do 
the following:
a Right-click either View and click 

View Preferences.
b Under Data Visibility, select All 

Views, then mark the Scatter 
Plot check box.

c Under Data Visibility, select Gene 
View and then click Scatter Tool 
Tip.

• When you right-click an empty area 
of Gene View, you can also use the 
shortcut menu to create a gene list 
or track, or to search the Agilent 
eArray database for probes from the 
selected region. See the User Guide 
for your application.

Table 3 How to display data in Agilent Genomic Workbench (continued)

To do this  Follow these instructions Comments

Review data 
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Quick-start Instructions for Displaying Microarray Data
Figure 11 Segment of Chromosome View and Gene View (horizontal orientation) with 
scatter plot of log ratio data and ToolTip
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Getting Help
Getting Help

To get help within Agilent Genomic Workbench

Agilent Genomic Workbench has several help resources. All help guides 
open in Adobe® Reader®.

Help Resource Description/Instructions

Data Viewing User Guide This user guide, which you are now reading, supplies comprehensive 
help on all available Data Viewing tasks. You can access it easily from 
anywhere within the program.

1 In any tab of Agilent Genomic Workbench, click the Help tab.
2 On the Help Ribbon, click Data Viewing.

The Data Viewing User Guide opens.

Other User Guides The Help tab in Agilent Genomic Workbench lets you view any of the 
available user guides that apply to the currently selected application 
type.

1 Set the desired application type from the Switch Application menu. 
2 In the Agilent Genomic Workbench tab bar, click Help.

The names of the available user guides appear in the command 
ribbon.

3 Click the desired help guide.
The selected guide opens.

Product Overview Guide An additional guide gives an overview of the capabilities within Agilent 
Genomic Workbench and describes how to start and find help for all of 
the programs. In addition, it helps you with system administration and 
troubleshooting. 

1 In any tab of Agilent Genomic Workbench, click the Open 
Application tab.

2 At the upper right corner of the Open Application tab, click Product 
Overview.
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To contact Agilent Technical Support

Technical support is available by phone and/or e- mail. A variety of useful 
information is also available on the Agilent Technical Support Web site.

To learn about Agilent products and services

To view information about the Life Sciences and Chemical Analysis 
products and services that are available from Agilent, go to 
www.chem.agilent.com.

Resource To find technical support contact information

Agilent Technical Support 
Web site

1 Go to http://chem.agilent.com.
2 Select a country or area.
3 Under Quick Links, select Technical Support.
4 Select from the available links to display support information.

Contact Agilent Technical 
Support by telephone or 
e-mail (United States and 
Canada)

Telephone: (800-227-9770)

E-mail: informatics_support@agilent.com

Contact Agilent Technical 
Support by telephone or 
e-mail (for your country)

1 Go to http://chem.agilent.com.
2 Select Contact Us.
3 Under Worldwide Sales and Support Phone Assistance, click to 

select a country, and then click Go. Complete e-mail and telephone 
contact information for your country is displayed.
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Agilent Genomic Workbench 6.5 – Data Viewing 
User Guide
2
Importing, Managing, and Exporting 
Data and Other Content

Importing Files 46

Working with Experiments to Organize Imported Data 60

Managing Content 70

Exporting and Saving Content 81

This chapter describes how to import, organize, manage, and export data 
and other content within the user interface of Agilent Genomic 
Workbench. The program lets you import many different kinds of files, 
including array data and design files from Agilent products and other 
sources, and other content such as annotation tracks. 

See Chapter 4, “Data Viewing Reference” for a description of the Agilent 
Genomic Workbench main window and its contents, and descriptions of 
the dialog boxes that can appear.
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Importing Files
Importing Files

You use the Home tab to import many kinds of files into Agilent Genomic 
Workbench. The table below summarizes the kinds of files you can import, 
and the topics in this section that describe how to import them.

The Design Data pane of the Navigator displays all of the content available 
for the user who is logged in. Some of this content (such as Catalog 
designs not yet downloaded) must be downloaded from the eArray Web 
site before it can be used. Some of the content is available for you to use 
but not change (red, read- only content), and some of the content you 
imported and can change (green). See “Navigator” on page 125 for more 
information on the Navigator panes and how to use them.

For information on downloading microarray designs and other content 
from the eArray Web site, see the eArrayXD User Guide.

File type Comments See these topics

Microarray data files • Agilent Feature Extraction 
(*.txt) data files

• Axon (*.gpr) data files
• Universal Data Files (UDFs) 

(*.txt files)

“To import Agilent FE or Axon 
data files” on page 50
“To import a UDF file” on 
page 51

Microarray design files • Agilent GEML (*.xml) design 
files

• Axon (*.gal) design files

“To import Agilent GEML 
design files” on page 48
“To import Axon design 
files” on page 49

Genome builds Agilent-supplied genome 
information for human, mouse 
and rat genomes

“To import a genome build” on 
page 54

Tracks BED format annotation track 
files

“To import tracks” on page 55

Array attributes Attribute .txt files that you have 
created yourself or previously 
exported from Agilent Genomic 
Workbench

“To import array attributes” on 
page 56
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To select a different location for data files
To select a different location for data files

By default, the program stores microarray and experimental data in C:\
Program Files\Agilent\Genomic Workbench Standard Edition <version 
number>\data. If you want, you can select a different location.

1 In the Home tab, click User Preferences.

The User Preferences dialog box appears. See “User Preferences” on 
page 250.

2 In the Miscellaneous tab, under Data Location, click Browse.

An Open dialog box appears.

3 Select a location, then click Open.

The selected location appears in the User Preferences dialog box, in 
Data Location.

4 Click OK.

Experiments ZIP file of experiments 
exported from Agilent Genomic 
Workbench

“To import an experiment 
file” on page 57

Custom Genome ZIP file containing at least one 
FASTA format sequence file
See the eArrayXD User Guide 
for requirements and 
information.

“To import a genome” on 
page 58

Genotype Reference (CGH 
only)

Text or .xls file that contains 
reference genotype and 
expected number of cuts for 
each SNP probe in the sample.

“To import a genotype 
reference file (CGH only)” on 
page 59.

File type Comments See these topics

CAUTION If you change the location for data files, and there is a data folder in that location, the 
data will be overwritten by the current data.
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To import Agilent GEML design files
To import Agilent GEML design files

The Agilent Genomic Workbench database must contain designs that match 
the Agilent Feature Extraction data files you want to import. Your 
imported GEML files contain array- specific information such as probe 
names, annotations, and chromosomal locations, and are associated with a 
specific genome build. 

To import an Agilent GEML file, use the following procedure:

1 In the Home tab, click Import > Design Files > GEML File.

The Import Design Files dialog box appears. See “Import” on page 211. 
The dialog box shows only *.xml files.

2 To select a file for import, click its name. To select additional files, hold 
down the Ctrl key while you click their names.

3 Click Open.

The program validates the selected file(s), and the Import GEML Design 
Files dialog box appears. See “Import GEML design files” on page 215.

• If a design file passes validation, the Status column will show Valid in 
green. 

• If a design file is already in the database, the Status column will 
show Overwrite in yellow. You can continue with the import, or 
cancel.

• If a design file is a catalog design that has not been downloaded 
from the eArray Web site, the Status will show Not allowed in red. You 
must download that design from eArray first.

• If a design file fails validation, Corrupt appears in the Status column 
beside it, and the program will not import the file. To remove the 
corrupt array from the list, click Remove .

4 Click Start Import.

The program imports the file(s). The files appear as new design folders 
in the Imported External Designs folder of the Design Data pane of the 
Navigator, with the genome build as a node within the folder.

NOTE Catalog design files must be downloaded from the eArray Web site. You can import multiple 
genome builds of the same catalog design, but you must download the design from the 
eArray Web site first. 
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To import Axon design files
You can import two design files with the same name, but associated 
with different genome builds; for example, Hg17 or Hg18. If you do, the 
program creates a single design folder with two nodes, one for each 
genome build.

To import Axon design files

You can import Axon (*.gal) microarray design files into Agilent Genomic 
Workbench. The program requires the Axon design files that match all 
Axon array data files you import.

1 In the Home tab, click Import > Design Files > Axon File.

The Import Axon Design Files dialog box appears. See “Import” on 
page 211. The dialog box shows only *.gal files.

2 To select a file for import, click its name. To select additional files, hold 
down the Ctrl key while you click their names.

3 Click Import.

The program validates the selected file(s), and the Set genome build 
and species for Axon design files dialog box appears. See “Set genome 
build and species for Axon design files” on page 236.

• If a design file passes validation, the Status column will show Valid in 
green. 

• If a design file fails validation, Corrupt appears in the Status column 
beside it, and the program will not import the file. To remove the 
corrupt array from the list, click Remove .

4 For each design file, select the appropriate Species and Genome Build.

5 Click Start Import.

The program imports the file(s). The files appear as new design folders in 
the Designs folder of the Design Data pane, organized by application 
(CGH, ChIP, or methylation, for example).
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To import Agilent FE or Axon data files
To import Agilent FE or Axon data files

You can import several types of microarray data files into Agilent Genomic 
Workbench:

• Agilent Feature Extraction (FE) *.txt data files

• Axon (*.gpr) data files

• Universal Data Files (UDFs) (*.txt files) See “To import a UDF file” on 
page 51 for instructions on how to import this file type.

In order to import Agilent Feature Extraction files, the representative 
GEML array design files must imported first. In order to import Axon data 
files, the representative Axon.gal design files must be imported first. See 
“To import Agilent GEML design files” on page 48 or “To import Axon 
design files” on page 49.

1 In the Home tab, do one of the following:

• To import Agilent FE data files, click Import > Array Files > FE 
File.

• To import Axon data files, click Import > Array Files > Axon File.

A dialog box appears. Only data files of the appropriate type appear. 
See “Import” on page 211.

2 To select a file for import, click its name. To select additional files, hold 
down the Ctrl key while you click their names.

3 Do one of the following:

• For Agilent FE files, click Open.

• For Axon files, click Import.

The Agilent Feature Extraction/Axon File Importer dialog box appears. 
See “Agilent Feature Extraction Importer” on page 163.

4 Set the following, as needed:

s

Setting Comments

Name The names of imported arrays are often cryptic. You can give 
any array a more meaningful label.
a Double-click the name of the array.
b Edit the name.
c Press Enter.
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To import a UDF file
5 Do one of the following:

• To import the file(s) while you wait, click OK.

• To import the file(s) in the background, click Run in Background. 
This lets you continue while the program imports the files.

To import a UDF file

UDF files are plain text files that contain array data in tab- delimited 
format. Files must contain the following six columns of information, in 
any order. Each column must contain the following column names, as 
column headers, or you must “map” the names from the file to these 
columns in Agilent Genomic Workbench:

• Probe name

• Chromosome name

• Start position

• Stop position

• Description

• Signal intensity data (The file can contain additional columns, each 
with data from an additional array.)

Dye Flip For each array:
• Select Normal if:

• The test samples were labeled with cyanine-5 (red).
• The control samples were labeled with cyanine-3 (green).
• The imported ratio (test/control) should be reported 

directly.
• Select Flipped if:

• The test samples were labeled with cyanine-3 (green).
• The control samples were labeled with cyanine-5 (red).
• The imported ratio (control/test) should be reported with 

the ratio inverted (test/control).
The program does not combine dye-flip pairs.

Overwrite arrays with 
duplicate names

If you mark this option, the program deletes an existing array 
data file if it has the same name as one you import.

Setting Comments
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To import a UDF file
When you import a UDF file, the program creates a new design based on 
the information you enter during import, and the information in the file 
itself. This design contains all of the arrays represented in the file. The 
program also creates a new experiment that contains the arrays. 

1 In the Home tab, click Import > Array Files > UDF File.

The UDF Files dialog box appears. See “Import” on page 211. Only *.txt 
files appear in the dialog box.

2 Select the UDF file, then click Open.

The Select data type for experiments dialog box appears. See “Select 
data type for experiments (UDF files – CGH or CH3)” on page 235.

3 For each array, set the following, as needed:

4 Click Continue.

The Universal Data Importer – Map column headers dialog box appears. 
The main table in the dialog box contains the first few rows of data 
from the file. Column headings derived from the first line of the file 
appear at the top of the table as a guide, but the program does not 
interpret these headings. See “Universal Data Importer -  Map Column 
Headers” on page 248.

Setting Comments

Experiment Name By default, the program creates an experiment with the same 
name as the imported file. To change the name:

a Double-click the name.
b Edit the name.
c Press Enter.

Data type • Select the mathematical form of the signal intensity data for 
the array. The options are ratio, log2 ratio, log10 ratio, and 
ln ratio.

Design type • Select cgh, expression, or CH3.

NOTE When you “map” a column, you assign the column heading (in an external file) to a column 
heading in Agilent Genomic Workbench.
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To import a UDF file
5 Below each column heading, select the label that identifies the content 
of the column. Use each label exactly once, except for LogRatio, which 
you can use many times. Alternatively, in Select Mapping, select a 
saved column map.

These options are available:

6 Under Species Info, select the species and Genome Build appropriate 
to the data in the file.

7 If you expect to import many similar UDFs in the future, follow these 
steps to save the column map:

a Under Mapping Info, click Save Mapping As.
An Input dialog box appears.

b Type a name for the column map, then click OK.
The name of the saved map appears in Select Mapping.

In the future, you can select this mapping and apply it to any UDF file 
that you import.

8 By default, the program creates a “Virtual Array ID” that becomes the 
ArrayID attribute for the array(s) in the UDF. To create your own 
virtual Array ID, follow these steps:

a Under ArrayID Info, clear Use System Generated Array ID.

b Double- click the number in Virtual Array ID, then type your own 
Array ID.

For more information on Array IDs, see the Sample Manager User 
Guide.

9 Click Import.

Column Label This column contains:

ProbeName Names of probes.

ChrName Names of chromosomes.

Start First chromosomal location to which each probe is designed.

Stop Last chromosomal location to which each probe is designed.

Description Text annotation related to the probe.

LogRatio Array data values that correspond to each probe. You can use this 
label more than once.
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To import a genome build
The program validates your column mapping. A dialog box appears. If 
you need to fix the column map, the dialog box has a list of the 
missing column label(s). If the column map is complete, a message asks 
if you want to import additional files with the same mapping.

10 Do one of the following:

• If you want to import additional files with the same column 
mapping, follow these steps to include these files in the import:

a Click Yes.
The UDF Files dialog box appears.

b Click the name of a file to select it for import. Hold down the Ctrl 
key while you click the names of additional files.

c Click Open.

• If you do not want to include additional file(s) in the import, click 
No.

The Program imports all requested files, and the UDF Import Summary 
dialog box appears. This dialog box shows the imported files, the 
number of lines of data that were imported for each file, and the 
number of lines that were skipped, if any. If a file name appears in red, 
the program may not have imported the file. See “UDF Import Summary 
(CGH or CH3)” on page 247.

11 Click OK.

In the Design Data pane, in the appropriate design type folder within 
the Design Data folder, a new design folder appears. The design folder 
contains the imported array data.

A new experiment appears in the Experiments folder in the Experiment 
pane, that contains the array data. This experiment has the name of the 
imported UDF file, unless you changed it during import.

To import a genome build

In general, the program uses the genome build specified in the array 
design file, and protects it from changes. If a genome build is not available 
in the program, you can import one. 
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To import tracks
1 In the Home tab, click Import > Genome Build.

The Import Genome Build dialog box appears. See “Import Genome 
Build” on page 219.

2 Set the following. All are required.

3 Click OK.

To import tracks

You can import BED format track files into Agilent Genomic Workbench. 
Track files contain specific features correlated with chromosomal 
locations, and apply to a specific genome build of a given species.

1 In the Home tab, click Import > Track.

The Import Track dialog box appears. See “Import Track” on page 220.

2 Set the following. All are required.

NOTE Use arrays from a single genome build in an experiment.

Setting Instructions

Species • Type the genome’s species of origin, as you would like it to 
appear within the program. 

Build Name • Type the name of the genome build you want to import, as 
you would like it to appear within the program. 

Refseq File This file contains information on gene locations for Gene View.

a Click Browse.
A dialog box appears.

b Select the file, then click Open.

Cyto-band File This file contains the graphic information on the cytobands for 
Genome and Chromosome Views.

a Click Browse.
A dialog box appears.

b Select the file, then click Open.
Data Viewing User Guide 55



2 Importing, Managing, and Exporting Data and Other Content
To import array attributes
3 Click OK.

The program imports the track. To view the track in Gene View, and to 
manage tracks, see “To show tracks in Gene View” on page 103.

To import array attributes

An array attributes file is a tab- delimited *.txt file that contains a list of 
arrays by ArrayID, and values for specific array attributes. Attributes are 
pieces of array- specific information, such as the hybridization temperature 
and the name of an array set that contains the array. 

Although you can import array attributes with this function, the Sample 
Manager application lets you import and assign array attributes more 
easily. See the Sample Manager User Guide for more information. 

To import an array attributes file

1 From the Home tab, click Import and then select ArrayAttributes.

The Import Attribute Files dialog box appears. See “Import” on 
page 211.

2 Select the microarray attributes file, then click Import.

Setting Instructions

Species • Select the species to which the track applies.

Build Name • Select the specific genome build of the species to which the 
track applies.

Track Name • Type a name for the track. 
This name identifies the track within the program, including 
the name that appears if you include the track in Gene View.

Track File a Click Browse.
A dialog box appears.

b Select the name of the track (*.bed) file that you want to 
import.

c Click Open.
The location of the file appears in Track File.
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The program imports the file. If the ArrayIDs in the file do not match 
the ArrayIDs of arrays in the program, a dialog box appears. The dialog 
box has a list of the ArrayIDs in the file that do not match. Click No to 
stop the import process, or click Yes to continue anyway. 

To import an experiment file

In Agilent Genomic Workbench, an experiment is a set of links to 
microarray data and design files, and any associated results. An Agilent 
Genomic Workbench experiment file is a single ZIP file that contains the 
design and data files for one or more experiments. You can import 

• Experiment files created in Agilent Genomic Workbench on another 
computer

• Agilent Genomic Workbench 5.0 and 6.0 experiment files

1 In the Home tab, click Import > Experiments.

The Import Experiments dialog box appears. See “Import” on page 211.

2 Select the ZIP file that contains the experiment(s) you want to import, 
then click OK.

The program imports the experiment file. Designs appear as new folders 
in the Design Data pane, in the applicable design type folder. Array 
data appears within the applicable design folder, organized by genome 
build. In addition, the experiment(s) appear in the Experiment pane, 
with the appropriate arrays. 

NOTE Agilent Genomic Workbench experiment files contain all of the design and array data files 
for an experiment, but do not include any analysis parameter settings, array selections, or 
analysis results. To export the data and design files from one or more experiments, see “To 
export experiments” on page 82.
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To import filters

Filters are used in Agilent Genomic Workbench to include or exclude data 
from an analysis, based on filter criteria. Filters are created in the 
interactive CGH and ChIP applications, or in workflow setup. 

1 In the Home tab, on the Command Ribbon, click Import > Filters.

The Import dialog box appears. See “Import” on page 211 for more 
information.

2 Select the file that contains the exported filter(s) for import. and then 
click Import.

3 In the filters Import dialog box, mark the Import box next to each filter 
you want to import, and then click OK.

To import a probe file

1 In the Home tab, on the Command Ribbon, click Import > Probe 
Upload.

The Probe Upload dialog box appears. See “Probe Upload” on page 228.

2 Complete the dialog box, and click Preview. See the eArrayXD User 
Guide for more information. 

To import a genome

You can import a user- defined genome for use with the Genomic Tiling or 
Bait Tiling tools. When you do, the genome becomes a permanent part of 
the database on your Genomic Workbench server, and is available to all of 
the users in your workgroup. For details on Genomic Tiling and Bait 
Tiling, and how to use the Import > Custom Genome for Tiling command, 
see the eArrayXD User Guide.
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To import a genotype reference file (CGH only)

A genotype reference sample is required in order to analyze a CGH+SNP 
microarray. A genotype reference file contains reference genotypes for one 
or more genotype reference samples.

1 From the Home tab, click Import > Genotype References.

The Import Genotype Reference Files dialog box appears.

2 Browse to a location and select the genotype reference file to import.

3 Click Open.

The Genotype Reference Importer dialog box appears. See “Genotype 
Reference Importer (CGH only)” on page 209.

4 Click OK.

The imported genotype references appear in the Navigator, in the 
Genotypes pane.

To transfer catalog and workgroup data

You can transfer probe data and exon boundary data from the eArray Web 
site to your Agilent Genomic Workbench server. You can also transfer 
probe data from both the Agilent Catalog and from the folders of your 
workgroup. Probe data are available by application type (i.e. Expression, 
ChIP, and so on). Exon boundary data apply to all application types. For 
more information, see “Catalog and Workgroup Data” on page 165.

1 In the Home tab, click Data.

2 For the selected type of data, click Download.

A Data Download task is submitted and appears in the Tasks folder of 
the Navigator.

NOTE Analysis of CGH+SNP microarrays requires a CGH license.
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Working with Experiments to Organize Imported Data

This section describes how to organize imported array data and designs 
into experiments. Experiments, shown in the Experiment pane of the 
Navigator, contain links to specific array data and design files in the 
Design Data pane. After you set up an experiment, you can then analyze 
selected array data within the experiment. 

Because experiments only contain links to the actual data and design 
files, any number of experiments can use a given set of files. In the data 
analysis applications (CGH, ChIP, or methylation, for example), 
experiments also can contain saved experiment results.

To display the array designs and data in the program

• To display the directory of data in the program, use the Design Data 
pane (Figure 12). Double- click a folder to expand or collapse it, or click 
the  and  buttons.
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To display the array designs and data in the program
In the Design Data pane, the program organizes design files by the 
application (CGH, ChIP, or methylation, for example) to which they apply. 
It organizes array data files by genome build under the design with which 
they are associated.

You can right- click many elements of the Design Data pane to open 
shortcut menus. For more information, see “Design Data pane – actions 
and shortcut menus” on page 131.

Many icons can appear in the Design Data pane. See “Design Data pane – 
icons, special text, and buttons” on page 129 for a complete list.

The Search pane can help you find specific data files or other content. See 
“To find specific content items in the Navigator” on page 71.

For more information on working with and managing microarray design 
files, see the eArrayXD User Guide.

Figure 12 Design Data pane of the Navigator
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To create a new experiment

In Agilent Genomic Workbench, experiments are organizational units that 
contain links to data and design files. To view or analyze data, you must 
first create an experiment and associate the data files with it. Because 
experiments only contain links to the actual data and design files, any 
number of experiments can use a given set of files. In data analysis 
applications (CGH, ChIP, or methylation, for example), experiments can 
also contain saved experiment results. 

1 In the Home tab, click Create Experiment.

The Create Experiment dialog box appears. See “Create Experiment” on 
page 178.

2 Type a Name and an optional Description for the experiment.

3 Do one of the following:

• To create an empty experiment, and add data to it later, click OK.
The program creates the experiment. To add arrays to the 
experiment later, see “To add arrays to an experiment” on page 64.

• To create an experiment and add data to it now, follow these steps: 
(You can add or remove data from the experiment later.)

a Click Properties.
The Experiment Properties dialog box appears. See “Experiment 
Properties” on page 195.

b Under Select Design, select the design and genome build for the 
array data.
The applicable arrays appear in Array List.

c In Array List, click the name of an array that you want in your 
experiment. Hold down the Ctrl key while you click the names of 
additional arrays.

d Click .
The program transfers the selected arrays to the Selected Array 
List.
The dialog box also has other options for adding arrays. See 
“Experiment Properties” on page 195 for more information.

e Click OK.
The program creates the new experiment, and adds data to it from 
the selected arrays.
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• To create an experiment and add data to it using the “drag and 
drop” method, follow these steps:

a To create an empty experiment, click OK.
The program creates the experiment.

b From the Design Data pane, expand a design to see the build and 
array data.

c Drag an array from the Design Data pane and drop it onto the 
experiment folder in the Experiment pane.

In all cases, a folder with the name of the new experiment appears in 
the Experiment pane of the Navigator. For more information on the 
Navigator, see “Using the Navigator to Search for Data” on page 25.

Figure 13 Experiment pane of the Navigator
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To add arrays to an experiment

After you create an experiment, or import one, you can add arrays to it. 
When you add arrays to an experiment, you create links between the 
experiment and the array data and design files. Because the program does 
not move the actual files, multiple experiments can share the same arrays. 

1 In the Experiment pane, double- click the Experiments folder to expand 
it.

2 Right- click the name of the experiment, then click Show Properties.

The Experiment Properties dialog box appears. See “Experiment 
Properties” on page 195.

3 Under Select Design, select the design file and genome build for the 
arrays to add.

The arrays for the selected design file and genome build appear in 
Array List.

4 In Array List, select the arrays to add to the experiment. To select a 
single array, click its name. To select additional arrays, hold down the 
Ctrl key while you click their names. 

5 Click .

The program transfers the selected arrays to the Selected Array List.

The dialog box also gives you other options for adding arrays. See 
“Experiment Properties” on page 195 for more information.

6 Click OK.

Or, to add array data to an experiment using the “drag and drop” method,

1 From the Design Data pane, expand a design to see the build and array 
data.

2 Drag an array from the Design Data pane and drop it onto the 
experiment folder in the Experiment pane.

If needed, the program adds appropriate design and genome build folders 
to your experiment folder in the Experiment pane. It places the arrays you 
selected in the appropriate genome build folder.
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To change the order of arrays in an experiment

When you select an experiment, a table appears in the Tab View of 
Genomic Viewer that contains log ratio values and, if selected, signal 
intensities for arrays in the experiment. See “Tab View” on page 156. You 
can change the order in which the arrays appear in the table. If you 
display separate (stacked) scatter plots in Gene View and Chromosome 
View for each array, the array order also determines the order in which 
these plots appear. You can use this feature to organize your arrays more 
logically, or to make it more convenient to display certain arrays. It is 
especially useful if you have many arrays.

1 In the Experiment pane, right- click the name of the experiment, then 
click Edit Array Order.

The Edit Array Order dialog box appears. See “Edit Array Order” on 
page 194.

2 In Design, select the design that contains the arrays whose order you 
want to change.

The arrays from the selected design appear in Array Name.

3 Do any of the following:

• To move an array up in the list, click its name, then click .

• To move an array down in the list, click its name, then click .

• To sort the list based on a specific microarray attribute, select the 
attribute in Order by.

4 Click OK.

To change the display names for arrays in an experiment

You can change the name displayed for arrays in an experiment, based on 
array attributes. When you change the display names for arrays in an 
experiment, the array names are changed only for the selected experiment. 
The display names are unchanged in the Design Data pane and in the 
other experiments.

1 Expand the folders in the Experiment pane until you see the 
experiment you want to change.

2 Right- click the experiment name, and select Show Properties.
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3 In the Experiment Properties dialog box, click Display Name by and 
select an attribute to use for display of array names. 

4 Click OK. The names of the arrays in the experiment are changed to 
the selected attribute. If the attribute does not exist for an array, the 
Global Display Name will be displayed.

To rename an array in an experiment

When you rename an array in an experiment, you change the array’s name 
only within the context of the selected experiment. The name of the array 
is unchanged in the Data pane, and in other experiments.

1 Expand the folders in the Experiment pane until you can see the array 
you want to rename.

2 Right- click the name of the array, then click Rename.

An Input dialog box appears.

3 Type the new name for the array, then click OK.

The name of the array in the tab view of the selected experiment is 
renamed. The global display name of the array is not changed.

NOTE To change the name of an array throughout Agilent Genomic Workbench, change its Global 
Display Name using Sample Manager. For more information, see the Sample Manager User 
Guide.
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To remove arrays from an experiment

When you remove arrays from an experiment, you only remove the links 
between the experiment and the data files. The files are still available in 
the program for use in other experiments. To completely remove files from 
the program, see “To remove data or design files from the program” on 
page 74.

1 In the Experiment pane, expand folders until you can see the 
experiment, and the array(s) that you want to remove from it.

2 In the Arrays or Calibration Arrays folder of the experiment, click the 
name of an array to select it for removal. Hold down the Ctrl key while 
you click the names of additional arrays.

3 Right- click one of the selected array names, then click Delete.

A Confirm dialog box appears.

4 Click Yes.

The program removes the links between the experiment and the 
selected array data files. If the removal of arrays leaves a design folder 
in the experiment empty, the program removes this folder as well. 

To show or hide the attributes of an experiment

Array attributes are pieces of information specific to an array, such as 
Array ID or hybridization temperature. You can show or hide attributes for 
the arrays in the experiment with the Experiment Attributes dialog box. 
See “Experiment Properties” on page 195.

1 Right- click the experiment whose attributes you want to show or hide, 
or to change.

2 Click Edit Attributes.

You see the array attributes and their values that were set up in the 
Sample Manager table. See the Sample Manager Guide. 

NOTE You cannot hide the required attributes. These include Array ID, Global Display Name, 
Green Sample, Red Sample (for 2-color arrays), and Polarity.
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3 Click Show/Hide Attributes. 

The Show/Hide Columns dialog box appears. See “Show/Hide 
Columns” on page 238.

4 Mark the check boxes for the attributes you want to show, or clear the 
check boxes for the attributes you want to hide.

5 Double- click the cell whose array attribute value you want to change.

6 Click Save Changes.

7 Click Close.

To display or edit the attribute values of a specific array

Array attributes are pieces of information specific to an array, such as 
array type or hybridization temperature. Sample attributes are usually set 
using the Sample Manager tab. For more information, see the Sample 
Manager User Guide. In the Navigator of the CGH module, you can 
display or change attributes for each array. You can also select a Genotype 
Reference to use for a selected CGH+SNP microarray.

1 Expand the folders of the Design Data pane or the Experiment pane 
until you can see the array of interest.

2 Right- click the name of the array, then click Show Properties.

The Microarray Properties dialog box appears, with a list of array 
attributes. See “Microarray Properties” on page 221. You can also edit 
the attributes of an array from this dialog box. In addition, if the array 
is an Agilent array, you can see header and feature information sent 
from the Agilent Feature Extraction program. 

3 When you are finished, click Close.

NOTE You cannot create new attributes using this dialog box. To do this, you must use the Sample 
Manager tab. See the Sample Manager User Guide.

NOTE Attributes for arrays that are read-only cannot be edited. For arrays where you are the 
owner, you can edit the GlobalDisplayName and Green and Red Sample attributes, but you 
cannot edit the ArrayID or the polarity.
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NOTE You use the Sample Manager tab to organize, create, import, and export array attributes. 
See the Sample Manager User Guide.
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Managing Content

This section describes how to create, find, rename, update, combine, 
and/or remove content such as designs, data, gene lists, and tracks, stored 
in Agilent Genomic Workbench. To display the data, gene list and track 
content, see Chapter 3, “Displaying Data and Other Content”.

To display a list of the content stored in the program

The Design Data and My Entity List panes of the Navigator show the 
content stored in Agilent Genomic Workbench.

Figure 14 Agilent Genomic Workbench Navigator for CGH
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Design Data pane – Shows all of the design and data files stored in the 
database. For more information, see “To display the array designs and 
data in the program” on page 60 and “Design Data pane – icons, special 
text, and buttons” on page 129. 

Experiment pane – Shows the experiments that were created or imported 
to the program. To select an experiment, double- click its name. To display 
the contents of an experiment, right- click the experiment name and then 
select Expand Node.

My Entity List pane – Shows the gene lists and tracks stored in the 
program. To view the names of gene lists or tracks available in the 
program, double- click the names of folders to expand or collapse them, or 
click the  or  buttons.

Genotypes pane (CGH Only) – Shows the genotype reference samples in 
the database. 

To find specific content items in the Navigator

At the top of the Navigator is a search pane that can help you find 
specific content items. See “Search pane” on page 123.

Figure 15 Navigator search pane

1 Type a search term in the box at the top of the Navigator. The search 
term is not case- sensitive, but it must reflect the entire name of the 
content item that you want to find. You can use asterisks (*) as 
wildcards to represent a group of unspecified characters. For example, 

NOTE Content that is used exclusively in the eArray tab, such as the probes and probe groups that 
you use to create custom microarray designs, is covered in a separate guide. See the 
eArrayXD User Guide.
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if you type *1234*, the search will find all items that contain “1234” in 
the name.

2 By default, the program searches all panes of the Navigator. To limit 
your search to a specific pane, click . In the list that appears, select 
the desired pane.

3 Click .

The program searches the selected pane(s). If it finds item(s) that 
match your search term, it expands folders so that the items are visible, 
and highlights them in red. You may need to scroll down to see all the 
search results. 

4 To clear the results of a search, click .

To display the properties of a specific design

Design properties include general information about a design, such as its 
name, application type, and associated species. They also include a list of 
the names and chromosomal locations of probes.

1 Expand the folders of the Design Data pane until you can see the 
genome build folder(s) within the design folder.

2 Right- click the genome build folder, then click Show Properties.

The Design Properties dialog box appears. See “Design Properties” on 
page 185.

To download a design from eArray

In order to analyze extracted microarray data in Agilent Genomic 
Workbench, the design for the microarray must be present in the database. 
The Design Data pane of the Navigator shows the available design content. 
See “Design Data pane – icons, special text, and buttons” on page 129.

1 Expand the Agilent Catalog or workgroup folder until you see the 
design you want to download.

2 Right click the design you want to download, and click Download from 
eArray.com.
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An information box appears that lets you know the download task is 
started. 

3 Click OK.

The task appears in the Tasks pane of the Navigator. The color of the 
circle shows the status of the task. See “Tasks pane – icons, buttons, 
and special text” on page 143.

To update probe annotation in design files

Agilent regularly makes updates to probe annotations on its eArray Web 
portal. If you have imported Agilent array designs into Agilent Genomic 
Workbench, and you are a registered eArray user, you can download the 
updated design files from within Agilent Genomic Workbench. For more 
information about eArray, go to https://earray.chem.agilent.com and click 
Help. 

1 In the Home tab, click User Preferences.

The User Preferences dialog box appears.

2 In the Miscellaneous tab, under eArray User Details, type your eArray 
Username and Password. See “User Preferences” on page 250. 

3 Click OK.

4 Expand the folders of the Design Data pane until you can see the 
design that you want to update.

5 Right- click the design, then click Download from eArray.com. This 
option appears only for Agilent designs.

A confirmation dialog box appears.

6 Click Yes.

The program downloads an updated design, if one is available.

To rename an array in the Design Data pane

This topic describes how to rename an array in the Design Data pane, 
which changes the Global Display Name for the array. If you rename an 
array in this way, and subsequently add the array to an experiment, the 
array appears in the experiment with the new name. It also changes the 
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array name in any experiment to which it is already linked. To rename an 
array only within the context of a specific experiment, see “To rename an 
array in an experiment” on page 66.

1 Expand the folders of the Design Data pane until you can see the array 
you want to rename.

2 Right- click the name of the array, then click Rename.

An Input dialog box appears.

3 Type a new name for the array, then click OK.

The program renames the array.

To remove data or design files from the program

You can delete array design and data files from the program when you are 
finished with them.

1 If an array that you want to delete is associated with an experiment, 
first delete it from the experiment. See “To remove arrays from an 
experiment” on page 67.

2 In the Design Data pane, expand folders until you can see the design 
folder or array that you want to delete.

3 Do one of the following:

• For array data files, click the name of the first array, then hold down 
the Ctrl key while you click the names of additional arrays within the 
same design. 

NOTE You can only rename an array that you imported.

NOTE You cannot delete data or design files that are read-only.
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• For array design folders, click the name of the first design folder, 
then hold down the Ctrl key while you click the names of additional 
ones. This selects the designs and all array data files within them for 
deletion.

4 Right- click the name of a selected design folder or array data file, then 
click Delete.

A confirmation dialog box appears.

5 Click Yes.

The program deletes the selected files.

To create a gene list

When you create a gene list, you create a list of the genes in a contiguous 
chromosomal region that you define. 

1 Follow these steps to define a chromosomal region for your gene list. If 
you know the exact start and end locations of the chromosomal region, 
skip to step 2.

a In Genome View, select the chromosome.
The selected chromosome appears in Chromosome View. See 
“Chromosome View” on page 149,

b In Chromosome View, in the plotting area to the right of the 
chromosome, drag the pointer over the chromosomal region of 
interest.
The program draws a blue box around the region, and displays the 
region in greater detail in Gene View.

c In Gene View, adjust the view so only the genes of interest appear. 
For a description of the adjustment commands available in Gene 
View, see “Gene View” on page 151.

2 Right- click anywhere within the log ratio plotting area in Gene View, 
then click Create Gene List.

CAUTION When you delete files, you permanently remove them from Agilent Genomic 
Workbench. To restore deleted files, you must import them again.
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The Create Gene List dialog box appears. See “Create Gene List” on 
page 180.

3 In the dialog box set the Name, Description and Color.

4 In the dialog box select the chromosomal region for the new gene list.

5 Click OK.

The new gene list appears in the Gene List folder of My Entity List in 
the Navigator.

To import a gene list

A gene list file is a plain text (*.txt) file that contains one gene name per 
line. When you import a gene list into Agilent Genomic Workbench, it 
appears in the Gene List folder in the My Entities List pane. You can use 
the gene list to highlight specific genes, or to show or hide the appearance 
of genes and data, in Gene and Chromosome Views. See “To show gene 
lists in Gene View” on page 102.

1 In the My Entities List pane, double click the Entities folder to expand 
it.

2 Right- click the Gene List folder, then click Import Gene List.

An Import dialog box appears. See “Import” on page 211.

3 Select the desired gene list file. To select additional gene list files, hold 
down the Ctrl key and click their names.

Click OK.

To display the genes in a gene list

You can display the genes in a gene list as a table.

1 Expand the folders in the My Entity List pane until you can see the 
gene list.

2 Right- click the gene list, then click View In Table.
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The Gene List dialog box appears, with a table that contains the names 
of the genes in the gene list. You can also use this dialog box to edit 
the description of the gene list and its display color. See “Gene List” on 
page 207.

You can also create gene lists. For more information, see “To create a 
gene list” on page 75.

To add one gene list to another

You can add one gene list (a source gene list) to another (the target gene 
list). The program appends the source gene list to the end of the target 
gene list, and leaves the source gene list unchanged.

1 Expand the folders in the My Entity List pane until you can see the 
gene lists to combine.

2 Right- click the source gene list, then click Add to Gene List.

A dialog box appears. For more information, see “Add Gene List 
<name> to” on page 162.

3 In Select target gene list, select the target gene list.

Click OK.

To rename a gene list 

The name of a gene list identifies it within the Gene List folder of the My 
Entity List pane. You can rename gene lists.

1 Expand the folders of the My Entity List pane until you can see the 
gene list to rename.

2 Right- click the gene list, then click Rename.

3 Type a new name for the gene list, then click OK.
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To delete gene list(s)

1 In the My Entity List pane of the Navigator, click to expand the Gene 
List folder.

2 Click the name of a gene list to delete. Hold down the Ctrl key while 
you click the names of additional gene lists. 

3 Right- click one of the selected gene lists, then click Delete.

A confirmation dialog box appears.

4 Click Yes.

To create a track (CGH only)

When you create a track, you create a list of the genes in a contiguous 
chromosomal region that you define. To create a list of genes or other 
annotations, such as CNV or miRNA, in multiple regions, create additional 
tracks, and combine them.

1 Follow these steps to define a chromosomal region for your track. If 
you know the exact start and end locations of the chromosomal region, 
skip to step 2.

a In Genome View, select the chromosome.
The selected chromosome appears in Chromosome View.

b In Chromosome View, in the plot area to the right of the 
chromosome, drag the pointer over the approximate chromosomal 
region of interest.
The program draws a blue box around the region, and displays the 
region in greater detail in Gene View.

c In Gene View, adjust the view so only the genes of interest appear. 
For a description of the adjustment commands available in Gene 
View, see “Gene View” on page 151.

2 Right- click anywhere within the plot area in Gene View, then click 
Create Track.

The Create Track dialog box appears. See “Closes the dialog box 
without creating the histogram.Create Track” on page 183.

3 In the dialog box set the Name, Description and Color.

4 In the dialog box select the chromosomal region for the new track.
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5 Click OK.

The new track appears in the Tracks folder of My Entity List pane in 
the Navigator.

To display the details of a track

You can display a table that contains the values for a list of track 
attributes.

1 In My Entity List pane, expand the Tracks folder to see the track.

2 Right- click the name of the track, then click View Details.

Track data appears in a Track table. See “Track” on page 245.

To rename a track

The name of a track identifies it both within the Tracks folder of the My 
Entity List pane, and in Gene View when you select Show In UI for the 
track. You can rename tracks.

1 Expand the folders of the My Entity List pane until you can see the 
track to rename.

2 Right- click the track, then click Rename.

3 Type a new name for the track, then click OK.

To delete tracks

1 In the My Entity List pane of the Navigator, expand the Tracks folder.

2 Click the name of a track to delete. Hold down the Ctrl key while you 
click the names of additional tracks. 

3 Right- click one of the selected tracks, then click Delete.

A confirmation dialog box appears.

4 Click Yes.
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To display genotype reference details (CGH only)

1 In the Genotypes pane of the Navigator, right- click the name of the 
genotype reference you want to display.

2 Click Show Properties.

The Genotype Reference Details dialog box appears. See “Genotype 
Reference Details (CGH only)” on page 208.

To rename a genotype reference (CGH only)

1 In the Genotypes pane of the Navigator, right- click the name of the 
genotype reference you want to rename.

The Input dialog box appears.

2 Type the new name for the genotype reference, and then click OK.

To delete a genotype reference (CGH only)

1 In the Genotypes pane of the Navigator, right- click the name of the 
genotype reference you want to delete.

2 Click Delete.

A confirmation dialog appears. 

3 Click Yes.

NOTE When you delete a genotype reference, the green and red sample attributes for any 
microarray associated with this genotype reference are reset.
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Exporting and Saving Content

This section describes how to export several kinds of files from the 
program. 

To export array attributes

You can export selected array attributes for any imported arrays. You first 
select the arrays and then the attributes for the selected arrays. You can 
export array attributes from the Home tab or from the short- cut menu for 
an experiment.

1 Click Home > Export > Array Attributes.

OR

In the Experiment pane of the Navigator, right- click an experiment of 
interest, and click Export Attributes.

The Export Array Attributes dialog box appears with the Array tab 
displayed. See “Export Array Attributes” on page 198.

If you opened this dialog box by right- clicking an experiment, only 
those arrays selected for the experiment appear in the Selected Array 
List. You can add or remove attributes from the list.

2 Under Select Design, select the design file and genome build for the 
arrays you want to add.

The arrays for the selected design file and genome build appear in 
Array List.

3 In Array List, select the arrays whose attributes you intend to export. 
To select a single array, click its name. To select additional arrays, hold 
down the Ctrl key while you click their names. 

4 Click .

The program moves the selected arrays to the Selected Array List.

5 Click Next to select attributes for the selected arrays.

The Export Array Attributes dialog box appears with the Attribute tab 
displayed. See “Export Array Attributes” on page 198.

All of the attributes for the arrays are already located in the Selected 
Attribute List. 
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6 Move any attributes you don’t want to export to the Available List.

a In the Selected Attributes List, highlight those attributes you do not 
want to export. To select additional attributes, hold down the Ctrl key 
while you click their names.

b Click .

7 Click OK.

The Export dialog box appears. See “Export” on page 197.

8 Select the folder in which to save the attributes, and click Export.

The attributes will be saved to the selected folder as a .txt file.

To export experiments

You can export experiments as a ZIP file to transfer them to another 
computer. Exported experiments contain the associated design and array 
data files, only. The program does not export information about array 
selections, or any analysis parameters or results.

1 In the Home command ribbon, click Export > Experiments.

The Export Experiments dialog box appears. See “Export 
Experiments” on page 202.

2 Mark the experiments that you want to export. To export all 
experiments, click Select All.

3 Click OK.

An Export dialog box appears. See “Export” on page 197.

4 Select a location and type a name for the exported ZIP file.

5 Click Export.

The program exports all selected experiment(s) together as a single ZIP 
file. 
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To export filters

You can export selected array, feature, design, metric, and aberration 
filters that are available in some data analysis applications in Agilent 
Genomic Workbench. The program exports all selected filters as a single 
*.xml file that you can import again at a later time.

1 In the Home tab, click Export > Filters.

The Export Filters dialog box appears. See “Export Filters” on 
page 203.

2 Under Export, mark the check boxes beside the filter(s) to export. To 
select all filters for export, click Select All.

3 Click OK.

An Export dialog box appears.

4 Select a location and type a name for the exported file, then click 
Export.

The program exports all selected filters as a single *.xml file.

To export a gene list

You can export a gene list as a text file that contains one gene per line.

1 In the My Entity List pane, in the Gene List folder, right- click the gene 
list that you want to export, then click Save As.

A Save As dialog box appears.

2 Select a location and type a name for the file.

3 Click Save.

A message appears when the operation is complete.

4 Click OK.
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To export tracks

You can export selected tracks as a BED format track file. You can then 
import this file into Agilent Genomic Workbench on another computer, or 
into a genome browser that accepts BED format files.

1 In the Home tab, click Export > Tracks.

The Export Tracks dialog box appears. See “Export Tracks” on 
page 204.

2 Mark the tracks to export. To select all tracks for export, click Select 
All.

3 Click OK.

An Export dialog box appears.

4 Select a location and type a name for the exported track file, then click 
Export.

The program exports the track(s) as a single BED format track file.

To copy what you see in the main window

You can copy panes of the main window to the Clipboard as images, and 
then paste them into a new document in another program (such as 
Microsoft® Word, or PowerPoint). The images contain only what actually 
appears on your screen; regions to which you must scroll are not included.

1 In the View tab, click Copy.

2 In the shortcut menu that appears, click the name of the pane that you 
want to copy. You can copy any view, or the Navigator. To copy all of 
the panes, click All.

The program copies the selected pane(s) to the clipboard.

3 Open a document in a program that accepts images. In that program, 
click Edit > Paste, or the appropriate paste command.

NOTE To adjust how data is displayed in the panes use the View Preferences dialog box. For 
example, you can turn on or off the cursor. See “View Preferences” on page 258 for more 
information.
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To copy the list of array colors for an experiment

You can copy the list of arrays in an experiment, and the colors assigned 
to them, to the clipboard as an image. You then paste the image into a 
document in another program such as Microsoft® Word or PowerPoint.

1 In the Experiment pane, expand the Experiments folder.

2 Right- click the name of the experiment, then click Edit Array Color.

The Edit Array Color dialog box appears. See “Edit Array Color” on 
page 193.

3 In the dialog box, click Edit > Copy.

The program copies the names of the arrays and their colors to the 
clipboard as an image.

4 Open a program that accepts images. Click Edit > Paste, or the 
appropriate paste command for the specific program.

To save data and design information from an experiment

You can save the data and design information from a single design in an 
experiment as a tab- delimited text file.

1 In the Experiment pane, expand the Experiments folder until you see 
the genome build(s) for the design you want to export.

2 Right- click the name of the genome build, then click Save As Text File.

A dialog box appears.

3 Select a location and type a name for the file, then click Save.
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To save data and design information from an experiment
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Searching for Probe and Gene Information 107

This chapter shows you how to display log ratio data from imported 
feature extraction data files, as well as gene and track content, in the 
Genomic Viewer. It also gives you instructions on how to customize the 
display of data and content to meet your needs.
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Selecting an Experiment for Displaying Data

An experiment is a set of links to microarray data and design files, and 
any associated results. Experiments are displayed in the Experiment pane 
of the Navigator that appears for applicable tabs. The Experiment pane 
does not appear if you select the miRNA or Expression modules. See 
“Using the Navigator to Search for Data” on page 25.

When you select an experiment and have no CGH, ChIP, or CH3 
application license, the program shows the log ratio data of selected 
arrays in the active experiment, if display of the data is enabled in View 
Preferences. See “View Preferences” on page 258 for more information.

When you select an experiment and Preprocessing and Analysis options 
have been turned on or set to apply, the program automatically begins the 
analysis of the selected array data with current settings and displays its 
results. 

This section describes how select an experiment to make it active and 
select or deselect arrays for further display. 

To select an experiment

When you select an experiment, the program displays log ratio data in a 
scatter plot, if that option is enabled. 

1 If necessary, do one of the following to add the desired experiment to 
the Experiment Pane in the Navigator:

• Create a new experiment and add data to it. See “To create a new 
experiment” on page 62.

• Import a saved experiment file. See “To import an experiment 
file” on page 57.

2 In the Navigator, double- click the name of the experiment.

The Experiment Selection dialog box appears.

NOTE Without an application license (CGH, ChIP, or CH3) you cannot select an experiment that 
contains results.
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To select or deselect arrays in the experiment
3 Click Yes.

In the Experiment pane of the Navigator, the name of the experiment 
turns blue. The name also appears in the title bar of the main window. 
Tables of data and design information appear in Tab View. For more 
information on the available tabs, see “Tab View” on page 156.

To select or deselect arrays in the experiment

To include arrays for display, you select them from the arrays available, 
either in an inactive experiment or the active one. When you first create 
an experiment, the program automatically sets the first array in the 
experiment for analysis. If you do not select additional arrays for display, 
only the first one will be shown when the experiment is selected.

To select the arrays for display before experiment selection:

1 Hold down the Shift key to highlight contiguous arrays or hold down the 
Ctrl key to highlight noncontiguous arrays.

2 Right- click the highlighted arrays, and click Select.

Even though the selected arrays do not change color, they will change 
color after the experiment is selected.

In the Navigator, the color of an array’s icon has the following meaning, 
after experiment selection:

Array is not selected.

Array is selected. The specific color matches the color of the column 
headings for the array in Tab View in the lower part of the window. In 
addition, the program displays aberration results and moving averages 
related to this array in this color. To configure a custom color for the 
array, see “To change the display color of an array” on page 90.

To select or deselect arrays in a selected experiment:

1 In the Navigator, expand the folders of the selected experiment.

2 Click the name of an array you want to include in the display. 
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To change the display color of an array
To include additional arrays, hold down the Ctrl key while you click 
their names. To include a contiguous block of arrays, click the name of 
the first array in the block, then hold down the Shift key while you click 
the name of the last one.

3 Right- click the name of one of the highlighted arrays, then click Select.

After you select the arrays, the program reanalyzes the data set within 
the experiment and displays the data in Genome, Chromosome, and 
Gene Views. You can see the data for just the selected arrays in the 
Selected Arrays tab in Tab View.

To customize the appearance of the scatter plot in Genome, 
Chromosome, and Gene Views, see “To change scatter plot 
appearance” on page 94.

You can also use the headings of columns in Tab View that contain array 
data to select and deselect arrays.

• Click a column heading to select that array only.

• Hold down the Ctrl key while you click a column heading to select or 
deselect an array without changing the status of other arrays.

• Right- click a column heading to open a shortcut menu with options 
that let you select or deselect that array, or all arrays.

For more information on Tab View, see “Tab View” on page 156.

To change the display color of an array

The color assigned to an array sets the color of its icon when you select 
the array within an experiment. It also changes the colored square in the 
array’s column heading in Tab View. 

1 In the Experiment pane of the Navigator, in the Experiments folder, 
expand the folder of an experiment until you can see the array of 
interest.

2 Right- click the desired array, then click Edit Array Color.

The Select Color dialog box appears. The dialog box gives three 
different ways to select the desired color. “Select Color” on page 231.

3 Select the desired color in one of the following ways:
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Samples of the color in different contexts appear under Preview. The 
upper half of the right- most color sample shows the original color for 
comparison.

4 Adjust the color as desired, then click OK.

You can also manage all of the colors for all of the arrays in an 
experiment. Right- click the desired experiment, then click Edit Array 
Color. For more information, see “Edit Array Color” on page 193.

Dialog box tab Instructions

Swatches • Click the desired color swatch.

HSB 
(Hue/Saturation/Brightness)

Type or adjust the values in H (Hue), S (Saturation), and B 
(Brightness), or alternately, follow these steps:

a Select H, then drag the slider to select a hue based on the 
color strip to its right.

b Click an appropriate location in the large color box to the 
left of the slider to set the saturation and brightness levels 
of the color.
Both the HSB and equivalent RGB values of the color 
appear in the dialog box. Note these values—they will be 
useful if you need to use this color in the future.

RGB (Red/Green/Blue) Do any of the following. Note the final RGB Values; they will be 
useful if you need to use this color in the future.

• Drag the Red, Green, and Blue sliders.
• Type or adjust values in the boxes to the right of the sliders.
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Displaying Array Data

After you select an experiment, you can change how data appear within 
the Views or change the appearance of the Views that contain the data (or 
results).

To display the scatter plots

Within the Chromosome and Gene views, there are up to three possible 
scatter plot display panels that you can turn on and off. These panels are 
used to let you examine different types of data in more detail. 

By default, display of log ratio scatter plots is turned On. If you do not 
see data in the scatter plot(s), do one of the following:

1 From the View tab, click View Preferences. See “View Preferences” on 
page 258 for more information.

2 In the View Preferences dialog box, under Data Visibility, select All 
views and then mark the box next to Scatter Plot. 

OR

1 Right- click in any of the views, and select View Preferences. See “View 
Preferences” on page 258 for more information.

2 In the View Preferences dialog box, under Data Visibility, select All 
views and then mark the box next to Scatter Plot. 

NOTE At least one scatter plot panel must be selected. The Copy Number Panel is only used for 
CGH+SNP arrays. Without a CGH license, you cannot display copy number results.
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To show or hide data in scatter plots

1 In the Gene View, move the mouse pointer over the down arrow in 
Scatter Plot until the Scatter Plot box appears, and do any of the 
following:

2 Click  to close the Scatter Plot window.

To customize scatter plot ranges and colors

You can customize the display of scatter plot data. For each log ratio or 
signal intensity scatter plot, you can choose to color code the plotted log 
ratio or signal intensity values by custom ranges and colors. For channels, 
you can set custom colors only.

Add and customize a plot

1 In Gene View, move the mouse pointer over Scatter Plot to display the 
options. 

OR

Right- click in any of the views, and select View Preferences.

2 Mark the one or all of the check boxes under Configure Coloring 
schemes.

3 Select a data type from the list.

4 Click Configure Color and Ranges.

To do this Follow these steps

Show or hide data points for a 
selected data type

• To show data points – Mark one or more check boxes under 
Configure Coloring schemes; then select how you want to 
color code the data from the Color by list.

• To hide all data points – clear the check boxes.

NOTE The View Preferences dialog box contents changes depending on the application type that 
is selected (CGH, ChIP, CH3).
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To change scatter plot appearance
The Configure Coloring Ranges and Shades dialog box appears where 
you set ranges and colors for any of the “color by” data types. For more 
information, see “Configure Coloring Ranges and Shades” on page 176.

5 In the Configure Coloring Ranges and Shades dialog box, click one of 
the tabs and then select the data type to configure.

6 Type minimum and maximum numbers to define a range for the data 
type. 

7 Click Color to open the Select Color dialog box. Use the tabs to select 
a color for the range. See “Select Color” on page 231 for more 
information.

8 Click OK to close the Select Color dialog box and return to the 
Configure Coloring Ranges and Shades dialog box.

9 Click Add Range to add the custom range to the range list.

10 When you are done, click OK to close the dialog box.

Edit or remove a range

1 In the Configure Coloring Ranges and Shades dialog box, click one of 
the tabs and then select the data type to configure.

2 In the range list, mark the Edit/Delete box to select the range. You can 
mark more than one range.

3 Click Edit Range to change the minimum and maximum values, or to 
change the color for the selected range.

4 Click Delete Range to delete the selected range.

5 Click OK to close the dialog box.

To change scatter plot appearance

You use the View Preferences dialog box to change the appearance of the 
scatter plots in Chromosome and Gene views.

1 In the Genomic Viewer, right- click in the Gene View or Chromosome 
View, and then click View Preferences.

Or, click the View tab, and then click View Preferences.

The View Preferences dialog box appears. See “View Preferences” on 
page 258.
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2 Do any of the following:

3 Click OK.

To do this Follow these steps

Show or hide the scatter plot a In the View tab under Data Visibility, in View, select All 
Views.

b Do one of the following:
To show the scatter plot, mark Scatter Plot.

To hide the scatter plot, clear Scatter Plot.

c Click OK.

Change the symbol that 
appears for data points

You can select the symbol separately for each design type.
a In the View tab, under Rendering Patterns, select the 

desired Design type.
b Under Styles, select the desired symbol.
c Click Apply.

Show a separate scatter plot 
in Gene and Chromosome 
Views for each selected array

a In the View tab, under View Alignment, under Rendering 
Style, select Stacked.

b Click Apply.

Show one scatter plot that 
contains data for selected 
arrays

a In the View tab, under View Alignment, under Rendering 
Style, select Overlaid.

b Click Apply.

Enable ToolTips for the 
scatter plot in Gene View

ToolTips show information about an individual data point when 
you place the pointer over it.
a Click the View tab.
b Under Data Visibility, in View, select Gene View.
c Mark Scatter Tool Tip.
d Click Apply.
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To print the scatter plot

You can print the scatter plot as it appears in Genome, Chromosome, and 
Gene views. Each view selected in the analysis is printed on a separate 
page. Chromosomes and genes appear on the printed pages, but tracks do 
not.

1 In the Home tab, click Print.

2 Set print options, as desired, then click OK.

To create custom scales for Views

You can customize the scale used for display in the Chromosome View and 
Gene View. Custom scales are applied to both views.

1 Click the View tab and then click View Preferences.

2 In the View Preferences dialog box, under Configure Scales, mark the 
box next to Apply for the plot for which you want to create a custom 
scale.

In Range, enter a value to use for the range. The range you enter changes 
the scale for the display of the selected data.

To locate and display data within the Views

To look through the data of the selected arrays, do any of the following. In 
general, all views are synchronized; if you select a location or region in 
one view, the other views move there as well.

To do this Follow these steps

Select a specific chromosome 
to display

• In Genome View, click the desired chromosome. 
All other views switch to the selected chromosome.

Display data in a region of the 
selected chromosome

• In Chromosome View, drag the pointer over the desired 
region.
Gene View expands (or shrinks) to show only the selected 
region. Tab View scrolls to the new cursor location.
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Zoom in and out in Gene View • Click  to zoom in.

• Click  to zoom out.

Scroll through the selected 
chromosome

• Click  to scroll up.

• Click  to scroll down.
Note: These arrows will appear side by side for horizontal 
orientation.

Return Gene View or 
Chromosome view to center

• Click anywhere in Chromosome View, or anywhere within 
the scatter plot in Gene View. 
The location you click becomes the new cursor location.

Move all Views to a specific 
genomic location

a Click Home > Go To Gene/Genomic location.
A dialog box appears.

b Under Genomic Location, select a Chromosome, and type a 
Base Position.

c Click Go.
All views move to the selected location.

Display the location of a 
specific gene in the center of 
all Views

a Click Home > Go To Gene/Genomic location.
A dialog box appears.

b Under RefSeq by Symbol, either select the desired gene (if 
available) or type the name of the gene.

c Click Go.
All views move to the location of the selected gene.

Display the data selected in 
Tab View in the center of 
Chromosome and Gene Views

• In Tab View, click any entry in any table, except a column 
heading.
Chromosome and Gene views: The genetic location of the 
selected data appears in the center of Chromosome and 
Gene Views.

Scroll to a specific column in 
Tab View

a In Tab View, right-click any column heading, then click 
Scroll To Column.
The Scroll to Column dialog box appears. See “Scroll to 
Column” on page 231.

b In Select Column, select the desired column.
c Click OK.

To do this Follow these steps
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To smooth and plot CGH log ratio data

You use a plug- in program to create separate, stacked plots of smoothed 
log ratio data for each of the selected CGH arrays in the current 
experiment. The plug- in program can perform one of several varieties of 
moving- average- like smoothing, and plots the data associated with the 
currently selected chromosome. 

The Plugin Settings command lets you change the parameters when you 
have selected to display the plot immediately after you click Plugin. 

1 Select an experiment.

2 Select the arrays that contain the log ratio data to smooth and plot.

3 Select the chromosome that contains the log ratio data of interest.

4 Click Tool > Plugin > CGHSmooth.

The CGHSmooth Parameters dialog box appears. See “CGHSmooth 
Parameters” on page 167.

5 Type the parameter values for the selected arrays in the active 
experiment and the selected chromosome.

6 Click OK.

Search for a specific column 
entry in Tab View, and move 
the cursor there

a In Tab View, right-click any entry except a column heading, 
then click Find in column.
The Find in column dialog box appears. See “Find in 
column” on page 205.

b Set the desired search parameters, then click Find Next.
The program searches the column using your search 
parameters, and highlights the row of the first entry that 
matches. The cursor moves to the location defined in the 
highlighted row. This search is only for the selected 
chromosome.

Display the exact 
chromosomal location of the 
cursor

At the bottom of the main window, look at the first cell of the 
Status bar. The location appears as the chromosome followed 
by the base position. For more information on the status bar, 
see “Status Bar” on page 161.

To do this Follow these steps
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To produce an echo example plot (CGH only)
The CGHSmooth Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “CGHSmooth 
Plot” on page 169.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.

See “Chart Properties” on page 171. 

8 (optional) To see options to save, print, zoom in or out, or change the 
auto range of the plot, right- click the plot.

To enter parameters from the Plugin Settings command and display the plot 
directly from the Plugin command

1 After step 5 above, mark Don’t Show Again, then click OK.

The plot appears.

2 To change the parameter values, exit the plot, and click Plugin 
Settings.

3 Change the values you want to change, and click OK.

4 Click Plugin.

The plot appears.

5 (optional) To show the CGHSmooth Parameters dialog box again when 
you click Plugin, click Plugin Settings, clear Don’t Show Again, and 
click OK.

To produce an echo example plot (CGH only)

The Echo Example Plot is the output of the Echo Example plug- in. It 
displays the log ratio data for the selected chromosome in the active 
experiment. Data from all of the selected arrays in the experiment appear 
as a series of stacked plots, one for each array. 

1 Select an experiment.

2 Select the arrays that contain the log ratio data to smooth and plot.

3 Select the chromosome that contains the log ratio data of interest.

4 Click Tool > Plugin > EchoExample.

5 Type the parameter values for the selected arrays in the active 
experiment and the selected chromosome.
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6 Click OK.

The Echo Example Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “Echo 
Example Plot” on page 190.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.

See “Chart Properties” on page 171. To see options to save, print, zoom 
in or out, or change the auto range of the plot, right- click the plot.

To produce a moving average example plot (CGH only)

The MovAvgExample plug- in program calculates a 10- point moving average 
of the data from the selected chromosome in the selected arrays of the 
active experiment. It displays stacked plots of moving averages for all the 
arrays, one plot per array. 

The plug- in program itself (MovAvg Example.pl, in the Plugins folder of the 
Agilent Genomic Workbench installation folder on your computer) is a 
short Perl program. It is a good example of how computed columns are 
processed. You must have Perl installed on your computer to use this 
plug- in.

1 Select an experiment.

2 Select the arrays that contain the log ratio data to smooth and plot.

3 Select the chromosome that contains the log ratio data of interest.

4 Click Tool > Plugin > MovAvg Example.

5 Type the parameter values for the selected arrays in the active 
experiment and the selected chromosome.

6 Click OK.

The MovAvg Example Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “MovAvg 
Example Plot” on page 226.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.

See “Chart Properties” on page 171. To see options to save, print, zoom 
in or out, or change the auto range of the plot, right- click the plot.
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To enter parameters from the Plugin Settings command and display the plot 
directly from the Plugin command

1 After step 5 above, mark Don’t Show Again, then click OK.

The plot appears.

2 To change the parameter values, exit the plot, and click Plugin 
Settings.

3 Change the values you want to change, and click OK.

4 Click Plugin.

The plot appears.

To show the MovAvg Example Parameters dialog box again when you 
click Plugin, click Plugin Settings, clear Don’t Show Again, and click 
OK.
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Displaying Content (Gene Lists/Tracks)
Displaying Content (Gene Lists/Tracks)

To show gene lists in Gene View

A gene list defines a set of genes of interest. 

You cannot show gene lists without a license. With a license you can 
highlight the genes in the gene list in Gene View, or limit the display of 
data, genes, and tracks to the regions defined by a gene list.

You also cannot import or export a gene list without a license, but you 
can create a gene list in the program. See “To create a gene list” on 
page 75.

To change the appearance of genes in Gene View

You use the User Preferences dialog box to change the appearance of the 
genes in Chromosome and Gene views.

1 Right- click any part of the Gene View, then click User Preferences. 

The User Preferences dialog box appears.

2 Click Tracks.

See “User Preferences” on page 250.

3 Do any of the following:

To do this Follow these steps

Show or hide genes in Gene 
View

a Under Visualization Parameters:
To show genes – Under Genes, mark Show Gene Symbols.

To hide genes – Under Genes, clear Show Gene Symbols.

b Click Apply.

Change the display font for 
genes (and track annotations) 
in Gene View

a In the Gene Symbols tab, under Font, select a new Font, 
Font Style, and Font Size.

b Click Apply
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To show tracks in Gene View
4 Click OK.

To show tracks in Gene View

Tracks contain information for specific genomic locations. A multitude of 
tracks from diverse sources is available for many species. You can display 
tracks next to genes and microarray data in Gene View.

1 Select and show microarray data. See “To select an experiment” on 
page 88.

2 In the My Entity List pane, open the Tracks folder.

3 Right- click the track you want to display, and click Show In UI.

Or, you can do this:

1 In Gene View, right- click anywhere within the scatter plot, then click 
User Preferences.

The User Preferences dialog box appears. See “User Preferences” on 
page 250.

2 Click Tracks.

3 Mark the Show In UI check box of each desired track.

4 Click OK.

The program displays the selected tracks in Gene View. 

Change the display angle for 
genes (and track annotations) 
in Gene View

a Under Visualization Parameters, under Genes, in 
Orientation (Degrees), type a new orientation in degrees. 
0º is horizontal.

b Click Apply.

To do this Follow these steps
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To change the appearance of tracks
To change the appearance of tracks

Within the Tracks tab of the User Preferences dialog box, you can change 
the appearance of tracks, as described in the table below.

To do this Follow these steps

Include track information in 
reports

a In the list of tracks, in the Show in Report column, mark the 
check boxes of the desired tracks.

b Click Apply.
Doing this adds a column with the hits from the track file. For 
each aberrant interval, it reports the entries from the track file 
for that interval in that separate column.

Show or hide annotations in 
all tracks

• To show annotations in all tracks: under Tracks, mark Show 
Annotations.

• To hide annotations in all tracks: under Tracks, clear Show 
Annotations.

Display all selected tracks as 
a single track

• Under Tracks, mark Show Overlaid.
The program combines the annotations of all selected 
tracks into a single track named Overlaid Track.

• To show tracks individually again, clear Show Overlaid.

Display the parameters and 
the list of annotations of a 
track 

• In the list of tracks, for the desired track, click Details.

Change the display font for 
track annotations (and genes)

a Under Font, select a new Font, Font Style, and Font Size for 
track annotations.

b Click Apply.
The program changes the display font of track annotations 
and genes in Gene View.
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To display tracks in UCSC Browser
To display tracks in UCSC Browser

1 Right- click Gene View, and click Show in UCSC.

The View coordinates in UCSC browser dialog box appears. See “View 
coordinates in UCSC browser” on page 256. 

2 Complete the dialog box with the track parameters, and click OK.

The UCSC Browser appears, if you are connected to the Internet.

Change the order in which 
tracks appear in Gene View.

The order of tracks in the Gene Symbols tab controls the 
left-to-right order of tracks in Gene View.

a Click the name of the track you want to move.
b Do one of the following:

• To move the track up in the list of tracks (and farther left 
in Gene View), click its name, then click Up.

• To move the track down in the list of tracks (and farther 
right in Gene View), click its name, then click Down.

c Click Apply.

Change the display angle of 
track annotations (and genes)

• Under Genes, in Orientation, type a new orientation (in 
degrees). 0º is horizontal.
The program changes the display angle of track annotations 
and genes in Gene View.

To do this Follow these steps
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To change the graphical display to a different genome build
Figure 16 Track displayed in UCSC browser

3 Follow the instructions on the Web site for what you want to do.

To change the graphical display to a different genome build

The default graphical display for Genome, Chromosome and Gene Views 
represents human genome build 18. 

• To change the graphical display to a different genome build, select an 
experiment whose data are based on a design file of a different genome 
build.

The display automatically changes when you select an experiment that 
contains a design file with a different genome build, such as human 
genome build 17, or a mouse or rat genome build.

If a genome build is not available for the design file you import, you must 
import the genome build first. See “To import a genome build” on page 54.
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Searching for Probe and Gene Information
Searching for Probe and Gene Information

To search Tab View for specific probe information 

You can find a specific entry in a column of a data table in Tab View. For 
more information on Tab View, see “Tab View” on page 156.

1 In Tab View, right- click anywhere in the column you want to search, 
then click Find in column. See “Find in column” on page 205.

The Find in column dialog box appears. The column to be searched also 
appears in the title bar of the dialog box.

2 Set the search parameters, as described below.

3 Click Find Next.

If the program finds a match, it highlights the row that contains the 
matching entry, and resets the cursor to the corresponding position. 
You can click Find Next as many times as you like, and the program 

NOTE The Find in column function works within the selected chromosome.

Parameter Comments/Instructions

Find in column • Type the text you want to find (the search term). This can be an entire 
entry, or part of one.

Direction • Select one of these options:
• Up – Search the column upwards from the current cursor location 

(the highlighted row of the table).
• Down – Search the column downwards from the current cursor 

location (the highlighted row of the table).
Tip: Click a row in Tab View to highlight it.

Conditions • Mark any of these, as desired:
• Match Case – Find entries that match upper and lower case 

characters in the search term.
• Match whole word – Find an entry only if the entire entry matches 

the search term.
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To search eArray for probe information
continues to search for additional matching entries in the column. If it 
finds no match, the message: String not found appears in black in the 
lower part of the dialog box.

4 When you complete your search, click Cancel.

To search eArray for probe information

A High Density (HD) Search from an Agilent HD probe database, retrieves 
probes that cover specific regions of the genome of a given species. The 
eArray Web site has separate databases that contain HD probes for CGH, 
ChIP- on- chip, and methylation microarrays. In a Simple HD Search, you 
set the overall density of retrieved probes. You can find more information 
about probes in the eArrayXD User Guide.

1 Right- click in the data plot area of Gene View, then click Simple HD 
Search. See “Simple HD Probe Search” on page 239.

The eArrayXD tab opens with the Simple HD Probe Search pane. The 
Genomic Intervals and Species search criteria reflect the selected region 
in the Genomic Viewer.

2 To return to the Gene View, click the Genomic Viewer tab.

To search for probes in a chromosomal location

Use this to find probes in a chromosomal region that you specify.

1 In Gene View, click on a chromosomal location, or hold down the mouse 
button and drag a chromosomal region of interest.

2 Right- click in Gene View, and click Chromosomal Location Search.

The Probe Search pane opens, with the selected location and species 
pre- set. 

3 Complete the dialog with search parameters, and click Search. See the 
eArrayXD User Guide for information on how to set the search 
parameters.

The results of the search appear in the bottom of the pane. 
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To search the Web for information on probes in Tab View
To search the Web for information on probes in Tab View

You can use any entry in a table in Tab View as the basis for a Web 
search. 

1 In Tab View, right- click any data table entry other than a column 
heading. 

2 Click one of the available sites.

If the site of interest does not appear in the shortcut menu, you can 
create a custom search link. See “To create a custom Web search link” 
below.

The selected site opens in your Internet browser. The program sends 
the table entry to the site as a search string.

To create a custom Web search link

If you need to search a different database or site based on data table 
entries, you can create your own custom search link. When you right- click 
a table entry in Tab View, a shortcut menu opens, and your custom link 
appears in it. If you select this link, Agilent Genomic Workbench opens the 
site in your Web browser and sends the table entry to the site as a search 
string.

1 Right- click any data table entry in Tab View, except a column heading, 
then click Customize Link.

The Customize Search link dialog box appears. “Customize Search 
Link” on page 184.

2 Click New.

3 In the Input dialog box, in URL name, type a name for the link.

This name will appear in the shortcut menu that opens when you 
right- click a data table entry.

4 Click OK.

5 In URL, type the complete URL needed to send a search string to the 
site. Use <target> as the query string value. 

For example, this URL sends selected table entries to Google.com:
http://www.google.com/search?hl=eng&q=<target>

6 Click Update, then click Yes.
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To update or delete a custom Web search link

1 Right- click any data table entry in Tab View other than a column 
heading, then click Customize Link.

The Customize Search link dialog box appears.

2 In URL Name, select the custom search link to update or delete.

3 Do one of the following:

4 Click Close.

To do this Follow these steps

Update a Web search link a Edit the URL name and the URL as needed.
b Click Update.

A Confirm dialog box appears.
c Click Yes.

Delete a Web search link • Click Delete.
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Agilent Genomic Workbench 6.5 – Data Viewing 
User Guide
4
Data Viewing Reference

Agilent Genomic Workbench Main Window 112

Command Ribbons 113

Switch Application Menu 122

Search pane 123

Navigator 125

Genomic Viewer 147

Status Bar 161

Dialog Boxes 162

This chapter describes the command ribbons, Navigator panes, and dialog 
boxes that can appear when you are using Agilent Genomic Workbench 
without analysis licenses. 
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Agilent Genomic Workbench Main Window
Agilent Genomic Workbench Main Window

The sections that follow describe the main components of the Agilent 
Genomic Workbench main window – Switch Application Menu, the 
command ribbons, the Navigator and the Views. You use these to import, 
organize, manage, export and display data and other content. For 
descriptions of the dialog boxes for these elements, see “Dialog Boxes” on 
page 162. Figure 17 shows the main window of Agilent Genomic 
Workbench, and identifies its main parts.

Figure 17 Agilent Genomic Workbench Unlicensed Version main window with Home command ribbon
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Command Ribbons
Command Ribbons

When you click a tab at the top of the Agilent Genomic Workbench main 
window, groups of commands appear below the tab bar. This group of 
commands is called a command ribbon, and the commands that appear 
are available only for the selected tab. The tabs that are displayed change 
depending on what application is selected (such as CGH, ChIP, CH3). This 
section describes the ribbon commands used to import, manage, export 
and display data in Agilent Genomic Workbench. For command ribbons 
that appear in the eArrayXD, Sample Manager, and Workflow tabs, see the 
User Guides for those applications.

Figure 18 Tab bar and Home command ribbon for unlicensed CGH application

Home command ribbon 

User Preferences Opens the User Preferences dialog box with the following tabs:

Figure 19 Command ribbon in the Home tab of Agilent Genomic Workbench

Tab Description

Tracks Opens a dialog box that lets you manage which tracks to display in 
Genomic Viewer and how they appear. See “Tracks tab” on 
page 251.
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Home command ribbon
Data Opens the Catalog and Workgroup Data window where you can choose to 
download data from the eArray catalog or from your workgroup. See 
“Catalog and Workgroup Data” on page 165.

Import Opens a menu of file types that you can import:

Miscellaneous Opens a dialog box where you can select a new location for your 
data files and set up access to the eArray web site. See 
“Miscellaneous tab” on page 253.

License Opens a dialog box where you can add a CGH, ChIP, or CH3 
application license, if you want to purchase one after using the 
unlicensed version. See “License tab” on page 255.

Tab Description

Option Description

Array Files Opens a menu with these options:
• FE File – Opens the Import FE Files dialog box, where you can 

select an Agilent Feature Extraction array data file to import. 
See “Import” on page 211 and “To import Agilent FE or Axon 
data files” on page 50.

• Axon File – Opens the Import Axon Files dialog box, where you 
can select Axon (*.gpr) files for import. See “Import” on 
page 211 and “To import Agilent FE or Axon data files” on 
page 50.

• UDF File – Opens the UDF Files dialog box, where you can select 
a Universal Data File (UDF) to import. See “Import” on page 211 
and “To import a UDF file” on page 51.

Design Files Opens a menu with these options:
• GEML File – Opens the Import Design Files dialog box, where 

you can select Agilent GEML-based (*.xml) array design files for 
import. See “Import” on page 211 and “To import Agilent GEML 
design files” on page 48.

• Axon Design File – Opens the Import Axon Design Files dialog 
box, where you can select Axon (*.gal) array design files for 
import. See “Import” on page 211 and “To import Axon design 
files” on page 49.

Genome Build Opens the Import Genome Build dialog box, where you can import 
Agilent-supplied genome build files. See “Import Genome 
Build” on page 219 and “To import a genome build” on page 54.
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Export Opens a menu that lets you export several kinds of files.

Track Opens the Import Track dialog box, where you can select a BED 
format track file for import, and create a display name for the track. 
See “Import Track” on page 220 and “To import tracks” on page 55.

ArrayAttributes Opens the Import microarray attributes dialog box, where you 
select a sample attributes file to import. See “Import” on page 211 
and “To import array attributes” on page 56 for more information.

Experiments Opens the Import Experiments dialog box, where you select an 
exported experiment .zip file, from which you can select 
experiments to import. See “Import” on page 211 and “To import 
an experiment file” on page 57 for more information.

Filters Opens the Import dialog box, where you select a filter file to 
import. For more information, see “Import” on page 211 and “To 
import filters” on page 58.

Probe Upload Lets you import a file of probe sequences and annotation. For more 
information, see the eArray XD User Guide. 

Custom Genome for Tiling Opens the Import Genome dialog box, where you upload a user 
defined genome for use with the Genomic Tiling and Bait Tiling 
tools in eArray XD. For more information, see the eArray XD User 
Guide. 

Genotype References (CGH 
only)

Opens the Import Genotype Reference Files dialog box, where you 
select a .txt or .xls file that contains one or more genotype 
references to use for SNP analysis. See “To import a genotype 
reference file (CGH only)” on page 59.

Option Description

Option Description

Experiments Opens the Export Experiments dialog box, where you can select 
one or more experiments for export as a single ZIP file. See “Export 
Experiments” on page 202 and “To export experiments” on 
page 82.

Filters Opens the Export Filters dialog box, where you can select one or 
more filters for export as a single *.xml file. See “Export Filters” on 
page 203 and “To export filters” on page 83.
Data Viewing User Guide 115



4 Data Viewing Reference
View Command Ribbon
Create
Experiment

Opens the Create Experiment dialog box, where you can create a new, 
empty experiment and add data to it. See “Create Experiment” on 
page 178 and “To create a new experiment” on page 62.

Save Experiment
Result

(Not available if you do not have a CGH, ChIP, or CH3 application license) 

Go to
Gene/Genomic

Location

Moves the cursor to the location in Chromosome and Gene Views that you 
select. See “Go To Gene/Genomic Location” on page 210.

Print Opens the Print window to print the display.

Exit Closes the program.

View Command Ribbon

Figure 20 View command ribbon for CGH application

View Preferences Opens the View Preferences dialog box where you can customize the 
display of data and results in the Genomic Viewer. For more information, 
see “View Preferences” on page 258.

Tracks Opens the Export Tracks dialog box, where you can select one or 
more tracks to export as a single BED format file. See “Export 
Tracks” on page 204 and “To export tracks” on page 84.

Array Attributes Opens the Export Array Attributes dialog box, where you can select 
arrays and their attributes for export. See “Export Array 
Attributes” on page 198.

Option Description
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Copy This command opens a menu with the options listed below. In general, the 
Copy command copies pane(s) of the main window to the Clipboard as an 
image. You can then paste the image into a document in another program. 
See “To copy what you see in the main window” on page 84.

Show Opens a menu with all available elements of the main window. Mark the 
check box for the one or ones you want to display.

View In Table

Signal Intensity Mark the check box to see the red and green raw signal intensities of the 
log ratio data in the Tab View.

Annotation Mark the check box to show annotations in the Tab View.

Cyto band info

View In Gene
View

Mark the check box to display cytobands in the Gene View.

NonUnique Probes

Highlight Nonunique probes in a microarray design have more than one mapping in 
the genome that is a perfect match. Because the probes represent the 
same sequence, the probe log ratio reflects a combination of log ratios 
from the redundant locations. Mark the check box to display nonunique 
probes in a different color.

Option Description

All Copies all panes of the main window to the Clipboard as an image.

Navigator Copies only the Navigator to the Clipboard as an image.

Tab View Copies only the Tab View to the Clipboard as an image.

SampleBySample view (Available only in data analysis modules, when selected) Copies only 
the Sample-by-sample View to the Clipboard as an image.

Genome view Copies only the Genome View to the Clipboard as an image.

Chromosome view Copies only the Chromosome View to the Clipboard as an image.

Gene view Copies only the Gene View to the Clipboard as an image.
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Tool command ribbon
Custom Data

Show Mark the check box to display custom data in the Genomic Viewer.

Tool command ribbon

Plugin

Plugins are ancillary programs that operate on the selected array data in 
the active experiment in specific ways. 

Opens a menu with the options described below. Custom plugins also 
appear in this menu.

CGHSmooth Opens the CGHSmooth Parameters dialog box. See “CGHSmooth 
Parameters” on page 167. You can set the parameters of the CGHSmooth 
plug- in, and create separate, stacked plots of smoothed log ratio data for 
each of the selected arrays in the current experiment. The plug- in plots 
the data associated with the currently selected chromosome.

When you open this dialog box, you see the default parameters you enter 
under Plugin Settings.

Echo Example Creates separate, stacked plots of log ratio data for each of the selected 
arrays in the current experiment. The plug- in plots the data associated 
with the currently selected chromosome. The plot appears in a new 
window. Although simple, this plug- in gives you a convenient way to view 
the log ratio data for selected arrays as separate plots. See “Echo Example 
Plot” on page 190.

Figure 21 Tool command ribbon
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MovAvg Example Opens the MovAvg Example Parameters dialog box. See “MovAvg Example 
Parameters” on page 224. You can set the parameters of the MovAvg 
Example plug- in. The plug- in calculates a 10- point moving average of each 
column of selected microarray data, and produces stacked plots of all of 
the input data and moving averages. To use this plug- in, you must have 
Perl installed on your computer.

When you open this dialog box, you see the default parameters you enter 
under Plugin Settings.

Plugin Settings

Opens another menu with these options:

CGHSmooth Opens the CGHSmooth Parameters dialog box, where you can set the 
parameters for the plug- in when you have selected to not show the 
parameters dialog box when you click Plugin. See “CGHSmooth 
Parameters” on page 167.

MovAvg Example Opens the MovAvg Example Parameters dialog box, where you can set the 
parameters for the plug- in when you have selected to not show the 
parameters dialog box when you click Plugin. See “MovAvg Example 
Parameters” on page 224.

Create

This group contains two options:

New User Opens the eArray Website, where you can add a new eArray user. 

Note Opens a dialog box where you can type notes and comments. You can 
view these notes from the Notes tab in the Agilent Genomic Workbench 
main window.

Other

Send Log Sends a log file to Agilent customer support. Use this feature if you are 
working with customer support to troubleshoot a problem.
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Help command ribbon
Help command ribbon

The Help command ribbon lets you display the available Agilent Genomic 
Workbench help guides, and get information about software version, 
installation history, and check for software updates. Help guides are 
opened in Adobe® Reader®.

Figure 22 Help command ribbon for Agilent Genomic Workbench CGH application (unlicensed)

Table 4 Table of Help for unlicensed version data viewing

Help Command Action

Application Guide Opens the Agilent Genomic Workbench application user guide for the 
selected application. 

eArrayXD Opens the eArrayXD User Guide. This guide comprehensive

help on all available eArrayXD tools.

Sample Manager Opens the Sample Manager User Guide, that shows how to use the 
Sample Manager module of Agilent Genomic Workbench to organize 
microarrays and edit their attributes. 

Feature Extraction Opens a menu that lets you choose from the following Feature Extraction 
help guides:

• Feature Extraction Quick Start Guide – An overview of how to use the 
Feature Extraction software to extract and generate QC reports for 
Agilent microarrays

• Feature Extraction User Guide – A comprehensive user guide that 
explains how to extract and generate QC reports for Agilent microarrays

• Feature Extraction Reference Guide – Contains tables that list default 
parameter values and results for Feature Extraction (FE) analyses, and 
explanations of how FE uses its algorithms to calculate results.

Quality Tools Opens the Quality Tools User Guide, that describes how to query, filter, and 
evaluate microarray extractions within Agilent Genomic Workbench.
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An additional guide is available in the Open Application tab of the 
program. The Agilent Genomic Workbench Product Overview Guide gives 
an overview of the capabilities of Agilent Genomic Workbench. It also 
describes how to start each of the component programs and find help, and 
how to enter your license information. In addition, it helps you with 
system administration and troubleshooting. To open this guide, click the 
Open Application tab, then click Product Overview.

Workflow Opens the Workflow User Guide, that describes how to use the Workflow 
module of Agilent Genomic Workbench to extract image files with Agilent 
Feature Extraction software and/or analyze data using CGH and ChIP 
analysis software. 

Data Viewing Opens the Data Viewing User Guide that describes how to import, 
organize, manage, export and display data and other content (experiments, 
gene lists, tracks) within Agilent Genomic Workbench. It is targeted for 
users who have no DNA Analytics application license(s).

About Opens a message with information about the version number and 
copyright of the program.

Installation History Opens the Installation History dialog box, that shows what versions and 
updates were installed.

Check Updates Checks for available updates to the software. If an update is available, you 
are asked if you want to install it. If no update is available, a message 
appears to let you know.

Table 4 Table of Help for unlicensed version data viewing (continued)

Help Command Action
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Switch Application Menu
Switch Application Menu 

The Switch Application menu lets you change to the other data display 
and analysis application types in Agilent Genomic Workbench. Select the 
desired application type.

CGH (Separate license required) Import, display, and analyze array- based 
comparative genomics hybridization (aCGH) data in both an interactive 
“analyze as you go” mode, and an automated workflow mode.

ChIP (Separate license required) Import, display, and analyze ChIP- on- Chip 
microarray data in both an interactive “analyze as you go” mode, and an 
automated workflow mode.

CH3 (Separate license required) Import and display data from 
microarray- based studies of genomic methylation patterns.

Expression Use eArrayXD for array- based gene expression studies.

microRNA Use eArrayXD for array- based miRNA studies.

SureSelect Target
Enrichment

Use the Quality Analyzer function for SureSelect Target Enrichment. 
Import, export, and view data, and use eArrayXD to search, and create 
Bait Groups. See the Target Enrichment User Guide for more information.

Figure 23 Switch Application menu
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Search pane
Search pane

The Search pane lets you find all occurrences of a specific search term in 
the Design Data, Experiment, and/or My Entity List panes. See “To find 
specific content items in the Navigator” on page 71. It also contains 
several buttons that you can use to move, hide, show or resize the 
Navigator.

Detach button Click to move the Navigator from the main window of the program and 
open it in a new, separate window. 

Resize buttons Click to hide, show, or expand the Navigator. 

Search term box The place where you type your desired search term. Search terms are not 
case- sensitive, but they must reflect the entire name of an array or other 
content item that you want to find. You can use asterisks (*) as wildcards 
to represent groups of unspecified characters. For example, a search term 
*25887* searches for any content that contains the string “25887”.

Pane list Lets you limit a search to a specific pane. Select the name of the desired 
pane from the list. To select all panes, select All Panels. By default, the 
program searches all panes.

Figure 24 Navigator – Search pane

Search term box Detach 
button

Resize 
buttons

Pane list 
button

Search term 
clear button

Search button

Scroll buttons
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(Show Pane List button, available only if the Pane list is not visible) 
Makes the Pane list visible.

(Hide Pane List button, available only if the Pane list is visible) Hides the 
Pane list.

(Search button) Searches the pane(s) selected in the Pane list for all 
occurrences of the term you typed in the Search term box. If the program 
finds a matching item, it expands the folder structure to make the 
matching item(s) visible, makes the lettering of each item red and 
highlights the item in yellow. Note: The search term is not case- sensitive, 
but it must reflect the entire name of the desired items. You can use 
asterisks (*) as wildcards to represent groups of unspecified characters.

Scroll buttons (Available only after a search) Lets you scroll up and down the lists of 
highlighted search items after a search.

(Clear button, available only after a search) Clears the search term from 
the Search term box, and resets the color of any matching item to its 
original color.

Figure 25 Search Panels list 
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Navigator

The Navigator contains several panes where you can look at program 
designs, experiments, data, or the status of tasks. Within each pane, you 
will see icons that tell you the status of the content. In addition, shortcut 
menus are available to let you perform tasks within the pane. These icons 
and shortcut menus are described in this section.
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Figure 26 Navigator panes for CGH

Search pane

Design Data pane

Experiment pane

My Entity List pane

Tasks pane

Ny Networks pane

Genotypes pane (CGH only)
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Pane Comments

Search Lets you search within any pane of the Navigator for a specific 
item (array or build, for example). You must type the entire array 
name or term; otherwise, use asterisks (*) as wildcards for 
unspecified strings. For example, type *1234* to find any item that 
contains “1234”.

Design Data Contains microarray data files, organized by design and application 
type, and then by genome build. 

Shows all probe groups and microarray designs that are available 
to you, organized by folders. For the SureSelect Target Enrichment 
application type, the program shows all bait groups and libraries. In 
general, you can:

• Expand or collapse folders to show or hide content.
• Look at the icon that appears with an item to monitor its status.
• Right-click the name of a folder or item to open a shortcut menu 

that lets you take action on the item.
See “Design Data pane – icons, special text, and buttons” on 
page 129 and “Design Data pane – actions and shortcut 
menus” on page 131.

For Agilent Catalog content, the names of all available items 
appear in the Agilent Catalog folder. However, to work with this 
content, you must specifically request a download of the actual 
data from the eArray Web site. 

Experiment Contains Agilent Genomic Workbench experiments. Experiments 
are organizational units that contain links to microarray data and 
design files. In data analysis modules, experiments also contain 
saved results.

My Entity List Contains gene lists and tracks:
• Gene Lists are collections of genes of interest. You can create 

them within the program, import and export them, and apply 
them to Gene View and Chromosome View.

• Tracks are collections of annotation or other information that 
map to specific genomic locations. You can import, export, and 
combine tracks, and display them in Gene View with your array 
data and analysis results.

My Networks Contains the biological networks/pathways that you found using 
Network Search or that you create using a literature search in 
eArrayXD. For more information, see the eArrayXD Users Guide
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Tasks Shows the jobs that you have submitted. Some jobs are completed 
locally by the eArrayXD server program. Others are sent to the 
eArray Web site for completion. In general, you can:
• Look at the icon that appears with a job to monitor its status.
• Right-click the name of a pending task to open a shortcut menu 

that lets you take further action on the job.
See “Tasks pane” on page 143.

Genotypes Shows the genotype references in the database. From this pane, 
you can import genotype reference files, and view details, rename, 
or delete genotype references.

Pane Comments
128 Data Viewing User Guide



Data Viewing Reference 4
Design Data pane – icons, special text, and buttons
Design Data pane – icons, special text, and buttons

Item Comments

An unexpanded folder (domain) that contains subfolders or other items.

An expanded folder. The items that it contains are visible in the Navigator.

Expands a folder to show its contents.

Collapses a folder to hide its contents.

A folder that can contain microarray design(s) or bait librar(ies).

A folder that can contain probe group(s) or bait group(s).

An item that contains Agilent content that you must update from the eArray Web site 
before you can use it.

An available microarray design with a status of Draft, or an available probe or bait
group with a status of Incomplete.

An available library or microarray design with a status of Review.

An available library or microarray design with a status of Completed.

An available library or microarray design with a status of Submitted.

An available probe or bait group with a status of Locked.

A methylation array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH+SNP array design. This folder contains array data for the design, organized by 
genome build.

A gene expression array design. This folder contains array data associated with the 
design, organized by genome build.

A ChIP array design. This folder contains array data associated with the design, 
organized by genome build.

A genome build folder within a specific design folder. This folder contains arrays 
associated with the specific genome build and design.
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A folder that contains sample data for a design. The data are read-only to the user who is 
currently logged in. The data apply to the indicated genome build, and are not used by 
eArrayXD.

A folder that contains sample data for a design. The data can be edited the user who is 
currently logged in. The data apply to the indicated genome build, and are not used by 
eArrayXD.

A single array data file.

Data from an individual microarray sample. The design from which the data were derived 
is read-only to the user who is currently logged in. These data are not used by eArrayXD.

Data from an individual microarray sample. The design from which the data were derived 
can be edited by the user who is currently logged in. These data are not used by 
eArrayXD.

Data created from a multi-pack array.

An item that matches the search term in a search.

(Dock out button) Moves the Design Data pane from the Navigator, and opens it in a, 
separate window.

(Collapse button, available only if the Design Data pane is not collapsed) Collapses the 
Design Data pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the Design Data pane is collapsed) Expands the Design 
Data pane.

Item Comments
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Design Data pane – actions and shortcut menus

The Design Data pane of the Navigator shows available content items that 
are stored on your server for the selected application type, and any 
external content that you imported. It also shows the names of items in 
the Agilent Catalog. For more information on the contents of the Design 
Data pane, and how to use eArrayXD, see the eArrayXD Users Guide. 

• Double- click any folder to expand or collapse it.

Design Data Main Folders

The Designs folder in the Design Data pane of the Navigator contains the 
following main folders:

AgilentCatalog Folder

• Right- click the name of a microarray design or probe group to open a 
shortcut menu with available options. (Note – The availability of the 
options varies by design status and ownership.) See the eArrayXD User 
Guide for information on how to use these options.

Folder Contents

AgilentCatalog Downloaded content from the Agilent Catalog that is available 
for the selected application type. See “AgilentCatalog 
Folder” on page 131.

<Workgroup Name> This folder, which bears the name of your workgroup, contains
downloaded workgroup content that is available for the 
selected application type. See “<Workgroup Name> 
Folder” on page 132.

Imported External Designs Imported design information and array data for downstream 
processing by the Agilent Genomic Workbench data analysis 
applications. Designs that you did not import are read-only. 
“Imported External Designs Folder” on page 134.

Custom Designs Custom (non catalog) designs created using eArray. Custom 
designs are hidden if they are not owned by the user who is 
logged in. “Custom Designs Folder” on page 136
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<Workgroup Name> Folder

• Double- click the name of a folder to expand or collapse it.

• Right- click on an Array Design or Probe Group and select one of the 
available actions (described in the eArrayXD User Guide).

Right- click the name of a domain folder to open a shortcut menu. See the 
eArrayXD User Guide for information on how to use these options.Main 
Folders

The Designs folder in the Design Data pane contains the following main 
folders:

AgilentCatalog Folder

• Right- click the name of a microarray design or probe group to open a 
shortcut menu with available options. (Note – The availability of the 
options varies by design status and ownership.) See the eArrayXD User 
Guide for information on how to use these options.

<Workgroup Name> Folder

• Double- click the name of a folder to expand or collapse it.

Folder Contents

AgilentCatalog Downloaded content from the Agilent Catalog that is available 
for the selected application type.

<Workgroup Name> This folder, which bears the name of your workgroup, contains
downloaded workgroup content that is available for the 
selected application type.

Imported External Designs Imported design information and array data for downstream 
processing by the Agilent Genomic Workbench data analysis 
applications. You cannot use eArrayXD to work with any of the 
items in these folders. Designs that you did not import are 
read-only. For more information, see the applicable User Guide 
for each data analysis application.

Custom Designs Custom designs created using eArray.
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• Right- click on an Array Design or Probe Group and select one of the 
available actions (described in the eArrayXD User Guide).

• Right- click the name of a domain folder to open a shortcut menu. See 
the eArrayXD User Guide for information on how to use these options.

Imported External Designs Folder

Imported external designs appear in this folder under folders for the type 
of design they represent: ChIP, Expression, CGH, or Only Stats and 
Params (for imported statistics and parameters from Feature Extraction).

• Right- click the Imported External Designs folder to open a shortcut 
menu with an Import option. When you select this option, a menu 
appears with the following options for file import:

• Only Stats and Params

Option Description

Design File Opens the Import Design Files dialog box, where you can select an 
Agilent GEML-based (*,xml) file for import. See “Import” on page 211 
and “To import Agilent GEML design files” on page 48.

Note: You cannot import Catalog designs. They must be downloaded 
from eArray.

Axon Design File Opens the Import Axon Files dialog box, where you can select Axon 
design (*.gal) files for import. See “Import” on page 211 and “To 
import Axon design files” on page 49.

FE File Opens the Import FE Files dialog box, where you can select an Agilent 
Feature Extraction (.txt) data file to import. See “Import” on page 211 
and “To import Agilent FE or Axon data files” on page 50.

Axon File Opens the Import Axon Files dialog box, where you can select Axon 
(*.gpr) files for import. See “Import” on page 211 and “To import 
Agilent FE or Axon data files” on page 50.

UDF File (For CGH and CH3 data only) Opens the UDF Files dialog box, where 
you can select a Universal Data File (UDF) to import. See “Import” on 
page 211 and “To import a UDF file” on page 51.
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Double- click the name of an imported design folder, and then double- click 
the Design Samples folder to display a list of genome builds.

Imported External Designs Folder

Imported external designs appear in this folder under the folders for the 
type of design they represent: ChIP, Expression, CGH, or Only Stats and 
Params (for imported statistics and parameters from Feature Extraction). 

• Right- click the Imported External Designs folder to open a shortcut 
menu with an Import option. When you select this option, a menu 
appears with the following options for file import:

• Double- click an imported designs folder (ChIP, Expression, CGH, Only 
Stats and Params) to display the imported designs for that data type.

• Double- click the name of an imported design folder, and then 
double- click the Design Samples folder to display a list of genome 
builds.

Option Description

Design File Opens the Import Design Files dialog box, where you can select an 
Agilent GEML-based (*,xml) file for import. See “Import” on page 211 
and “To import Agilent GEML design files” on page 48.

Note: You cannot import Catalog designs. They must be downloaded 
from eArray.

Axon Design File Opens the Import Axon Files dialog box, where you can select Axon 
design (*.gal) files for import. See “Import” on page 211 and “To 
import Axon design files” on page 49.

FE File Opens the Import FE Files dialog box, where you can select an Agilent 
Feature Extraction (.txt) data file to import. See “Import” on page 211 
and “To import Agilent FE or Axon data files” on page 50.

Axon File Opens the Import Axon Files dialog box, where you can select Axon 
(*.gpr) files for import. See “Import” on page 211 and “To import 
Agilent FE or Axon data files” on page 50.

UDF File Opens the UDF Files dialog box, where you can select a Universal Data 
File (UDF) to import. See “Import” on page 211 and “To import a UDF 
file” on page 51.
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• Double- click the name of a genome build folder to display imported 
arrays for that build.

Genome Build Folder

• Right- click the name of a genome build folder to display the following 
options:

Specific Arrays

• Right- click the name of an array to display the following options:

• Drag an array from the Design Data pane to an experiment folder in 
the Experiment pane to associate it with an experiment. You can drag 
multiple arrays at once from one genome build in a design. Hold down 
the Ctrl key while you click the additional arrays to select them. You 
can also select a contiguous block of arrays; click the first array in the 
block, then hold down the Shift key and click the last one.

Option Description

Show Properties Opens the Design Properties dialog box. See “Design Properties” on 
page 185.

Delete Opens a Confirm dialog box. If you click Yes, the program permanently 
deletes all of the arrays in this genome build folder. (Not available for 
read-only builds.)

Option Description

Show Properties Opens the Microarray Properties dialog box. See“Microarray 
Properties” on page 221 and “To display or edit the attribute values of 
a specific array” on page 68.

Rename Opens an Input dialog box, where you can type a new name for the 
array. Click OK to rename the array. (Not available for read-only 
builds.)

Delete Opens a Confirm dialog box. If you click Yes, the program permanently 
deletes the array. (Not available for read-only builds.)
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Custom Designs Folder

This folder displays custom designs available from eArrayXD.

Experiment pane – icons, special text, and buttons

Item Comments

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders. 

A methylation array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH+SNP array design. This folder contains array data for the design, organized by 
genome build.

A gene expression array design. This folder contains array data associated with the 
design, organized by genome build.

A ChIP array design. This folder contains array data associated with the design, 
organized by genome build.

A genome build folder within a specific design folder. This folder contains arrays 
associated with the specific genome build and design.

A read-only genome build folder within a specific design folder.

A genome build folder, within a specific design folder, that you can modify.

An array that is not selected for view 

An array that is selected for view and analysis. The specific color of this icon can vary.

An empty folder.

Data created from a multi-pack array.

blue 
text

The currently active experiment. All data that appear in Chromosome, Gene, and Tab 
Views come from this experiment.
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Experiment pane – actions and shortcut menus

Only the options that are not grayed out are discussed in this section. To 
enable the grayed- out options, you must have the appropriate license for 
the CGH, ChIP, or CH3 application you are using. These inactive options 
are explained in the User Guide for the application. 

• In general, double- click the Experiments folder, and the folders within 
it, to expand and collapse them. Exception: double- click the name of an 
unselected experiment to select it for display. Without a license, you 
cannot select an experiment that contains results.

Experiments Folder

• Right- click the Experiments folder to display the following options:

red text An item that matches the search term in a search.

(Dock out button) Moves the Experiment pane from the main window, and opens it in a 
separate window.

(Collapse button, available only if the Experiment pane is not collapsed) Collapses the 
Experiment pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the Experiment pane is collapsed) Expands the 
Experiment pane.

Item Comments

NOTE The displayed options change depending on the user and status of the designs, builds, and 
arrays. You may not see all of the options that are described below.
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Specific Experiment Folder

• Right- click the name of an experiment to display the following options:

Option Description

New Experiment Opens the Create Experiment dialog box, where you can name the 
new experiment, and open another dialog box that lets you add 
microarray data to the experiment. See “Create Experiment” on 
page 178.

Export Opens the Export Experiments dialog box, where you can export one 
or more experiments as a single ZIP file. See “Export Experiments” on 
page 202 and “To export experiments” on page 82.

Option Description

Select Experiment (Appears only if the experiment is not selected, and if there are no 
saved results for the experiment.) Opens the Experiment Selection 
dialog box, which asks if you want to select the experiment. Click Yes 
to select the experiment for display and analysis. Or In the 
Experiments folder, double-click the name of an experiment that is not 
selected to open the Experiment Selection dialog box. To select the 
experiment for analysis, click Yes.

Deselect Experiment (Appears only if the experiment is selected.) Removes the experiment 
data from display.

Show Properties Opens the Experiment Properties dialog box. Use this dialog box to 
see the names of the arrays in the experiment, and also to add or 
remove arrays from the experiment. See “Experiment Properties” on 
page 195.

Export Opens the Export Experiments dialog box, where you can export this 
and other experiments as a single ZIP file. See “Export 
Experiments” on page 202 and “To export experiments” on page 82.

Export Attributes Opens the Export Attributes dialog boxes, one for selecting arrays for 
which you want attributes exported and one for selecting the 
attributes you want to export with the selected arrays. See “Export 
Array Attributes” on page 198.

Edit Array Color Opens the Edit Array Color dialog box, where you can select a display 
color for each of the arrays in the experiment. For more information 
see “Edit Array Color” on page 193.
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Design Folder

• Right- click the name of a design to open a shortcut menu with a Delete 
option. If you select this option, a Confirm dialog box opens. If you 
click Yes, the program removes the links to all of the arrays under the 
design from the experiment. 

Genome Build Folder

• Right- click the name of a genome build within a design to display the 
following options:

Edit Array Order Opens the Array Order dialog box, where you can change the order of 
the arrays in the Experiment and in Tab View. See “Edit Array 
Order” on page 194.

Rename Opens an Input dialog box, where you can type a new name for the 
experiment. Click OK to rename the experiment.

Delete Opens a Confirm dialog box that asks if you want to delete the 
Experiment. Click Yes to delete it.

Note: You can delete any experiment except the selected one.

Option Description

Set for Calibration Agilent does not recommend using another array to calculate noise 
for the sample array.

Delete Opens a Confirm dialog box that asks if you want to disassociate all 
arrays under the design from the experiment. Click Yes to remove the 
links between the arrays and the experiment.

• If you delete a design from an experiment, the program removes the 
links between the experiment and the design and its arrays. The 
actual design and array data stay in the Data folder.

Show Properties Opens the Design Properties dialog box. See “Design Properties” on 
page 185.

Option Description
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Individual Arrays

• Within the folder of a specific experiment, in the Arrays folder of a 
design, right- click the name of an individual array display the following 
options:

Option Description

Select (Available if the array is not selected) Selects the array for display. 

Deselect (Available if the array is selected) Removes the array data from Genome, 
Chromosome, and Gene views. Also removes the array from the Selected 
Arrays tab in Tab View.

Rename Opens an Input dialog box, where you can type a new name for the array. 
Click OK to accept the new name for the array.

Delete Opens a Confirm dialog box that asks if you want to disassociate the 
array from the experiment. Click Yes to remove the link between the array 
and the experiment. See “To remove arrays from an experiment” on 
page 67.

• If you delete an array from an experiment, the program removes the 
link between the experiment and the array. The actual array data stays 
in the Data folder.

Show Properties Opens the Microarray Properties dialog box, where you can display and 
edit microarray attributes. 

For array files from the Agilent Feature Extraction program, you can also 
display the headers and feature data from the file.

See “Microarray Properties” on page 221 and “To display or edit the 
attribute values of a specific array” on page 68.

Edit Array Color Opens the Edit Array Color dialog box, where you can select a display 
color for the array. See “Edit Array Color” on page 193 and “To change 
the display color of an array” on page 90.

Edit Array Order Opens the Array Order dialog box, where you can change the order of the 
arrays in the Experiment and in Tab View. See “Edit Array Order” on 
page 194 and “To change the order of arrays in an experiment” on 
page 65.
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My Entity List pane – icons, buttons, and special text

My Entity List pane – actions and shortcut menus

Only the options that are not grayed out are discussed in this section. To 
enable the grayed- out options, you must have the appropriate license for 
the CGH, ChIP or CH3 application you are using. These options are 
explained in the User Guide for the application. 

• Double- click the Gene List folder to show or hide its gene lists.

Item Comments

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders.

An individual gene list or track.

red regular 
text

An item that is an exact match with the search term in a search, or a gene list that 
has not been applied and has red assigned as its custom color.

colored 
italics

A gene list that has been applied.

red bold 
italics

A track that is selected for display in Gene View.

black bold 
italics

A “combined” track that is selected for display in Gene View. A combined track 
contains information from two or more individual tracks associated by logical 
criteria.

(Dock out button) Moves the My Entity List pane from the main window, and opens 
it in a, separate window.

(Collapse button, available only if the My Entity List pane is not collapsed) Collapses 
the My Entity List pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the My Entity List pane is collapsed) Expands the 
My Entity List pane.
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Gene List Folder

• In the Gene List folder, right- click the name of a gene list to display 
the following options:

Tracks Folder

• Right- click the name of a track to display the following options:

Option Description

Rename Opens an Input dialog box, where you can type a new name for the 
gene list. Click OK to accept the new name.

Delete Opens a confirm dialog box that asks if you are sure you want to 
delete the gene list. Click Yes to confirm.

Option Comments

Show in UI Mark this option to display the track in Gene View next to the 
data and results of the selected experiment. See “To show 
tracks in Gene View” on page 103 and “User Preferences” on 
page 250.

Show in Report Mark the check box to show the track information in all the 
reports.

Genomic Boundaries Click to use the genome track to define only the regions that 
aberration detection algorithms will run. You can select this for 
only one track.

Show in UCSC Opens the UCSC (University of California at Santa Cruz) 
Genome Browser in your Web browser and uploads the track. 
You can then see information for the track.

View Details Opens a table that shows all the chromosome locations 
defined in the track.

Rename Opens an Input dialog box, where you can type a new name for 
the track. Click OK to rename the track.

Delete Opens a Delete Track dialog box that asks if you are sure you 
want to delete the track. Click Yes to delete the track.
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My Networks pane

Contains the biological networks/pathways that you found using Network 
Search or that you create using a literature search in eArrayXD. For more 
information, see the eArrayXD Users Guide.

Tasks pane

Figure 27 Tasks pane of the Navigator

Many tasks that you do in Agilent Genomic Workbench generate jobs that 
are completed in the background on your Agilent Genomic Workbench 
server or on the eArray Web site. You use the Tasks pane to keep track of 
the status of these jobs, and to take action on them when their results 
become available. 

Tasks pane – icons, buttons, and special text 

These icons, buttons, and special text items can appear in the Tasks pane 
of the Navigator:
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Tasks pane – Actions and shortcut menus

• Double- click the name of a folder to expand or collapse it.

• Right- click the name of a pending task to open a shortcut menu. The 
shortcut menu contains commands that are appropriate to the type of 
job, and its status.

For details on actions in the task menu, see the eArrayXD User Guide.

Item Details

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders. 

A pending task with a status of Submitted. The task has been submitted to the job
queue, but no action has been taken on it yet.

A pending task with a status of Processing. The task has been submitted to the 
job queue, and the program (or the eArray Web site) is processing the job.

A pending task with a status of Completed. The results of the job are now 
available for your use.

A pending task with a status of Error. An error has occurred, and you must 
re-submit the job. For probe or bait uploads, an error file is available that lists the 
errors in your input file.

(Dock out button) Moves the Tasks pane from the main window, and opens it in a 
separate window.

(Collapse button, available only if the Tasks pane is not collapsed) Collapses the 
Tasks pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the Tasks pane is collapsed) Expands the Tasks 
pane.
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Genotypes pane (CGH only)

Figure 28 Genotypes pane of the Navigator (CGH only)

In order to perform SNP analysis, there must be genotype references in 
the database for the CGH+SNP microarrays you want to analyze. The 
imported genotype references in the database are displayed in this pane. 
This pane only appears when the CGH module is selected.

Genotypes pane – Actions and shortcut menus (CGH only)

• Right- click on a genotype reference in the list, and select from the 
following options:

NOTE Without a CGH license, you cannot analyze or display results for CGH+SNP data.

Option Description

Show Properties Opens the Genotype Reference Details dialog box, where you 
can review the information contained in the selected genotype 
reference. See “Genotype Reference Details (CGH only)” on 
page 208.
Data Viewing User Guide 145



4 Data Viewing Reference
Genotypes pane – Actions and shortcut menus (CGH only)
Rename Opens the Input dialog box, where you can type a new name 
for the selected genotype reference.

Delete For genotype references that are not marked as read-only, 
deletes the selected genotype reference.

Option Description
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Genomic Viewer

This section describes the display areas that appear when you click the 
Genomic Viewer tab. The orientation of these views (vertical or horizontal) 
can be changed from View Preferences located in the View tab. See “View 
Preferences” on page 258 for more information.

Genome View

Figure 29 Genome View, vertical orientation, with human chromosomes. The X chromo-
some is selected.
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Genome View shows pictures of each of the distinct types of chromosomes 
in the selected genome. A blue box is drawn around the currently selected 
chromosome, and the cursor appears as a blue line across the 
chromosome. 

Genome View actions and shortcut menus

• Click a chromosome to select it. When you select a chromosome, 
Chromosome, Gene, and Tab Views show only genomic regions, genes, 
and data associated with it. The specific location where you click the 
chromosome sets the position of the cursor. See “The View Cursor” on 
page 155.

• On the selected chromosome, click anywhere to move the cursor. See 
“The View Cursor” on page 155. This also moves the cursor in 
Chromosome, Gene, and Tab Views.

• Right- click anywhere within Genome View to display a menu. If you 
click View Preferences, the View Preferences dialog box opens, where 
you can set preferences for the display. See “View Preferences” on 
page 258.

• Click the Detach button  (located at the top center of the pane) 
to remove Genome View from the main window and open in a separate 
window. To reattach the view, click its Close button . Drag the side 
or bottom borders of the pane to resize them. 

• Drag the side or bottom borders of the pane to resize it. 

• On a border of the pane, click a resize button (for example,  or ) that 
points away from the pane to move that border all the way to the edge 
of the main window. To move the border back to its previous location, 
click the other resize button. 
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Chromosome View

Chromosome View shows a more detailed diagram of the chromosome you 
select in Genome View. 

• Cytobands and a plotting area appear next to the chromosome. 

• When you select arrays for display, their data appear in the plotting 
area.

• The View cursor appears as a solid blue line across the chromosome 
and the plotting area.

• The selected region of the chromosome (if any) appears as a dotted 
blue box in the plotting area. 

Figure 30 Chromosome View, human X chromosome shown
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Chromosome View
Chromosome View actions and shortcut menus

• Click a cytoband, any part of the chromosome, or anywhere in the 
plotting area to move the View cursor to that location. See “The View 
Cursor” on page 155.

• Drag the pointer over any part of the plotting area to select a 
chromosomal region for display in Gene View. Drag parallel to the 
chromosome. This also moves the cursor to the center of the selected 
region. See “The View Cursor” on page 155.

• Right- click anywhere within Chromosome View to display a menu. If 
you click View Preferences, the View Preferences dialog box opens, 
where you can set preferences for the display. See “View 
Preferences” on page 258.

• Click the Detach button  (located at the top center of the pane) 
to remove Chromosome View from the main window and open in a 
separate window. To reattach the view, click its Close button . Drag 
an inside border of Chromosome View to resize the view. 

• Drag the side or bottom borders of the pane to resize it. 

• On a border of the pane, click a resize button (for example,  or ) that 
points away from the pane to move that border all the way to the edge 
of the main window. To move the border back to its previous location, 
click the other resize button. 
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Gene View

Gene View shows a more detailed view of the chromosomal region you 
select in Chromosome View. See “Chromosome View” on page 149.

• Regions that contain genes appear as small blue boxes. Gene names 
appear nearby. You can customize the appearance of gene names. 
Also, you can use a gene list to highlight genes of interest, or to 
display only the genes in the list. See “To change the appearance of 
genes in Gene View” on page 102, and “To show gene lists in Gene 
View” on page 102.

Figure 31 Gene View, with log ratio data from an experiment and CNV tracks. 
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Gene View
• Log ratio data from selected arrays in the active experiment appear 
as a scatter plot. You can also customize the scatter plot. See “To 
customize scatter plot ranges and colors” on page 93.

• The location of the cursor matches the location of the cursors in 
other views. See “The View Cursor” on page 155.

• The name of the chromosome, and the coordinates and size of the 
displayed chromosomal region appear at the top of the pane. 

• Imported tracks can also appear in Gene View. See “To show tracks 
in Gene View” on page 103.

Scatter Plot

The scatter plot command group is available in Gene View or the View 
Preferences dialog box. The selections in this box change depending on the 
DNA Analytics application you are using. Selected scatter plot panels 
appear in the Chromosome and Gene Views. Use View Preferences to 
customize the scatter plots and select the data you want to display. See 
“View Preferences” on page 258.

The drop down lists let you select how the log ratios or signal intensities 
are colored in the plot. For more information, see “To show or hide data 
in scatter plots” on page 93 and “To customize scatter plot ranges and 
colors” on page 93.

Figure 32 Scatter Plot command group in CGH Gene View
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Gene View
Gene View buttons

Zooms in to see a smaller region in more detail.

Zooms out to see a larger region in less detail.

In vertical orientation, scrolls up through the genes and data to 
lower- numbered chromosomal coordinates.

In vertical orientation, scrolls down through the genes and data to 
higher- numbered chromosomal coordinates.

In horizontal orientation, scrolls left through the genes and data to 
lower- numbered chromosomal coordinates.

In horizontal orientation, scrolls right through the genes and data to 
higher- numbered chromosomal coordinates.

(Resize buttons) The button that points away from Gene View expands the 
view. The other button restores the view to its original size.

(Detach button) Removes Gene View from the main window, and opens it 
in a separate window. 

Gene View shortcut menu and other actions

• Click anywhere in the plotting area of Gene View to move the cursor to 
that location. See “The View Cursor” on page 155.

• Drag an inside border of Gene View to resize the View. Right- click 
anywhere in the plotting area of Gene View to display the following 
options:

Option Description

Create Gene List Opens the Create Gene List dialog box, where you can create a 
new gene list based on the currently selected (or another) 
chromosomal region. See “Create Gene List” on page 180 and 
“To show gene lists in Gene View” on page 102.

Create Track Opens the Create Track dialog box, where you set the 
chromosome locations for the track. See “To create a track 
(CGH only)” on page 78 and “Closes the dialog box without 
creating the histogram.Create Track” on page 183.
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Show Intensity Bar Charts Opens the Create Signal Bar Chart dialog box, where you 
select parameters to create a signal intensity chart for the 
data. See “Create Signal Bar Chart” on page 182.

Show in UCSC Opens the View Coordinates in UCSC Browser dialog box 
where you select track information for display in the UCSC 
(University of California at Santa Cruz) Genome Browser. You 
can then view the track.

Simple HD Search Opens Simple HD Probe Search in the Search tab, where you 
can start a search of the Agilent eArray web site for probes in 
the selected (or another) chromosomal region. See “Simple 
HD Probe Search” on page 239 and “To search eArray for 
probe information” on page 108. See the eArrayXD User Guide 
for more information. 

Chromosomal Location 
Search

Opens Probe Search in the Search tab, where you can search 
for probes based on their chromosomal locations. See the 
eArrayXD User Guide for more information.

User Preferences Opens the User Preferences dialog box, where you can set 
user preferences on three separate tabs. See “User 
Preferences” on page 250 and the related pages that follow.

View Preferences Opens the View Preferences dialog box, where you can set the 
preferences for viewing data in the Genomic Viewer. See 
“View Preferences” on page 258.

Option Description
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The View Cursor

The View cursor reflects the center of the current chromosomal location of 
interest. It appears in several views:

• In Genome View, it appears as a blue bar across the selected 
chromosome.

• In Chromosome View, it is a blue bar that appears across the 
chromosome and across the plotting area of the view.

• In Gene View, it is a blue bar that appears across the plotting area 
and tracks of the view.

The position of the cursor in one View is also the position of the cursor 
in all Views. The exact chromosomal location of the cursor appears in the 
first cell of the Status bar. Several actions change the position of the View 
cursor:

• In Genome View, click anywhere on a chromosome to move the 
cursor to that location.

• In Chromosome View, click a cytoband name, part of the 
chromosome, or anywhere in the plotting area to move the cursor to 
that location.

• In Gene View, click anywhere in the plotting area to move the cursor 
to that location.

The cursor used in Gene View is the same cursor used for the tracks.

• In Tab View, click a row of a data table to move the cursor to the 
chromosomal location associated with that row.
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Tab View
Tab View

Tab View displays design annotation and log ratio data related to the 
chromosome you select in Chromosome View. 

• The exact column content of the tables depends on the specific tab 
and design, but it always includes chromosomal locations of probes

• The selected row of data appears highlighted in blue. This row 
represents data that corresponds approximately with the location of 
the cursor.

• Columns of log ratio data appear below the names of the specific 
arrays to which they correspond. If an array is selected for display 
in Chromosome and Gene views, a colored square appears next to its 
name.

Figure 33 Tab View
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Tab View
Tab View tabs and buttons

You can see the following tabs and buttons in Tab View. See Figure 33 for 
a diagram that identifies some of these elements.

Design tabs A separate tab appears for each microarray design included in the active 
experiment. The name of the design appears on each tab, along with an 
icon:

 – A methylation array design

 – An aCGH array design.

 – A CGH+SNP array design.

 – A gene expression array design.

 – A ChIP- on- Chip array design.

When you click a design tab, the data and annotation for the arrays in the 
design appear in Tab View. The program separates the arrays of the 
design into the Arrays tab and the Calibration Arrays tab (see below).

Arrays tab (Available when you click a specific design tab.) Contains a table of data 
and annotation for all arrays in a design that contain biological data.

Selected Arrays
tab

Contains a table of data and annotation for the selected arrays from all 
designs in the active experiment.

(Resize buttons) The button that points away from Tab View expands the 
view. The other button restores the view to its original size. 

(Detach button) Removes Tab View from the main window, and opens it 
in a separate window. 

Tab View actions and shortcut menus

• Click the name of an array in a column heading to select the array 
data for display.

• Right- click the name of an array in a column heading to open a 
display the following options:
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Option Description

Rename Array Opens an Input dialog box, where you can type a new name for 
the array. This only changes the name of the array within the 
active experiment.

Remove Array From 
Experiment

Opens a confirmation dialog box. Click Yes to remove the link 
between the array and the active experiment. This command 
does not delete the data file from the program. To do this, see 
“To remove data or design files from the program” on page 74.

Select Array (Available if the array is not selected.) Selects the array for 
display. A colored square appears next to the name of the 
array.

Deselect Array (Available if the array is selected.) Removes the array data 
from scatter plots, and removes the column of the array from 
the Selected Arrays tab.

Select for Calibration Selects the array for calibration. Moves the selected array to 
the Calibration Arrays tab and to the Calibration Arrays folder 
in the Experiment pane. Calibration arrays in the Experiment 
pane are marked with a “C”. See “To select or remove 
calibration array(s)” on page 73.

Deselect for Calibration Removes the selection of the array for calibration.

Edit Array Color Opens the Select Color dialog box, where you can change the 
display color of the array. See “Edit Array Color” on page 193 
and “To change the display color of an array” on page 90.

Edit Array Order Opens the Edit Array Order dialog box, where you can change 
the order in which the names of the arrays in a given design of 
the active experiment appear in Tab View and in the Data 
Navigator. In Gene View, when you display separate scatter 
plots for each array, the plots also appear in this order. See 
“Edit Array Order” on page 194 and “To change the order of 
arrays in an experiment” on page 65.

Select All Arrays Selects all arrays in all designs in the active experiment for 
display. All arrays appear in the Selected Arrays tab.

Deselect All Arrays Removes all arrays from display, and from the Selected Arrays 
tab.
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• Right- click a heading of a column other than an array data column 
to open a shortcut menu with a Scroll To Column option. If you click 
this option, the Scroll to Column dialog box appears, where you can 
select a column in the current tab. The program then scrolls the data 
table in the tab so you can see the column. See “Scroll to Column” on 
page 231.

• Click a data table entry to select the row in which it appears. This also 
moves the cursor to the location of the data point corresponding to the 
selected row.

• Right- click a data table entry to display the following options:

Select All Arrays for 
Calibration

Selects all arrays in the table as calibration arrays. Moves the 
selected arrays to the Calibration Arrays tab and to the 
Calibration Arrays folder in the Experiment pane. Calibration 
arrays in the Experiment pane are marked with a “C”.

Deselect All Arrays from 
Calibration

Removes all calibration arrays from the Calibration Arrays tab 
and Calibration Arrays folder in the Experiment pane.

Scroll to Column Opens the Scroll to Column dialog box, where you can select a 
column in the current tab. The program then scrolls the data 
table in the tab so you can see the selected column. 

Option Description

Find in Column Opens the Find in column dialog box, where you can search for 
a specific text string within the column you clicked. See “Find 
in column” on page 205.

Option Description
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Google
LocusLink

PubMed

UCSC HG15(April ‘03)

UCSC HG16(July‘03)

UCSC HG17(May‘04)

UCSC HG18(March‘06)

UCSC mm8(Feb‘06)

UCSC mm9(July‘07)

DGV(hg18)

GO

KEGG(HUMAN)

Opens your Web browser, and sends the column entry you 
clicked as a search string to the selected site. The UCSC links 
search the indicated University of California, Santa Cruz 
database related to the indicated genome build. See “To 
search the Web for information on probes in Tab View” on 
page 109.

Customize Link Opens the Customize Search link dialog box, where you can 
create or edit a custom Web link that appears in this shortcut 
menu. When you click a custom link, the program opens your 
Web browser, and sends the column entry you clicked as a 
search string to the site. See “Customize Search Link” on 
page 184 and “To update or delete a custom Web search 
link” on page 110.

(other options) If other options appear in this shortcut menu, they are custom 
Web search links. Click them to open your Web browser, and 
send the column entry you clicked as a search string to the 
site.

Option Description
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Status Bar

The Status Bar displays information related to the currently displayed 
data. There are other items on the status bar that only become active if 
you have a DNA Analytics license.

Cursor position The chromosomal location of the cursor. See “The View Cursor” on 
page 155.

Genome build The genome build associated with the currently displayed data.

Ratio type The mathematical type of the array data. The possible types are:

• ratio

• log2 ratio

• log10 ratio

• ln (natural log) ratio

Selected Row The row in the currently displayed data table that is selected. The location 
of the cursor is approximately the chromosomal location associated with 
this row.

Table size The number of rows and columns in the currently displayed tab. The size 
appears as 
<# of rows> x <# of columns>.

Figure 34 Status bar
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Dialog Boxes

This section describes the dialog boxes that can appear when you import, 
organize, manage, export and display array data and other content in 
Agilent Genomic Workbench. The dialog boxes appear in alphabetical order 
by name.

Add Gene List <name> to

Purpose: Adds genes from one gene list (the source gene list) to another 
(the target gene list).

To open: In the My Entity List pane, right- click the name of a gene list, 
then click Add to Gene List.

Select target
gene list

The gene list to which genes will be added. Select one from the list.

Figure 35 Add Gene List <name> to dialog box
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Build (Read- only) The genome build associated with the genes in the list. The 
builds of the two gene lists must match.

Description (Optional) Description of the combined gene list.

List of genes A list of the genes in the target gene list.

Gene List Color (Read- only) The current display color of the target gene list.

OK Adds the genes from the source gene list to the target gene list.

Cancel Closes the dialog box without adding any genes to the target gene list.

Agilent Feature Extraction Importer

Figure 36 Agilent Feature Extraction Importer dialog box
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Purpose: Lets you edit the name of the FE data file you will import and 
to indicate whether you want to flip the red/green ratio for the data.

To open: In the Home tab, click Import > Array Files > FE File, select 
the desired FE data file(s), then click Open.

Name Lets you edit the names of the FE files. You can change the names of the 
files to names that are easier to recognize or remember.

Dye Flip For each array:

Select Normal if:

• The test samples were labeled with cyanine- 5 (red).

• The control samples were labeled with cyanine- 3 (green).

• The imported ratio (test/control) should be reported as- is.

Select Flipped if:

• The test samples were labeled with cyanine- 3 (green).

• The control samples were labeled with cyanine- 5 (red).

• The imported ratio (control/test) should be reported with the ratio 
inverted (test/control).

The program does not combine dye- flip pairs.

Overwrite arrays
with duplicate

names

Mark this option to replace existing file(s) in the program with the 
imported one(s), if they have the same name(s).

Run in
Background

Imports the files, and lets you use your computer for other purposes while 
the import occurs. This is especially useful if you have many files to 
import.

OK Imports the files in the foreground. You cannot use your computer for 
other purposes while the import occurs.

Cancel Cancels the entire import process without importing anything.
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Catalog and Workgroup Data
Catalog and Workgroup Data

Figure 37 Catalog and Workgroup Data dialog box

Purpose: Used to download Agilent Catalog and workgroup data sets from 
the eArray website to the Agilent Genomic Workbench database. 
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To open: In the Home tab, click Data.

After you install the Agilent Genomic Workbench client program, you can 
transfer probe and bait sequences and annotation, as well as the genomic 
coordinates of exon boundaries, from the eArray Web site. Although you 
can transfer these data at any time after you install the client program, 
you must transfer it before you can do certain tasks in eArrayXD that 
require it For example, to search for expression probes from the Agilent 
Catalog, you must first transfer the Catalog expression probe data from 
the eArray Web site to your server. See the eArrayXD User Guide for more 
information.

Learn More Opens an information box that describes the type of data that is 
downloaded for the data type.

Download Submits a data download task that appears in the Tasks pane of the 
Navigator. To view the status of the download, click eArrayXD > Job 
queue > Tasks.

NOTE If your workgroup contains a large amount of data, the download may take a long time.
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CGHSmooth Parameters

Purpose: The CGHSmooth Parameters dialog box lets you configure the 
CGHSmooth plug- in. It can perform one of several varieties of 
moving- average- like smoothing, and plots the data associated with the 
currently selected chromosome. 

To open: Click Tool > Plugin > CGHSmooth.

Figure 38 CGHSmooth Parameters dialog box
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Parameters Set any of these parameters:

Don’t show again Mark this option to prevent the appearance of this dialog box in the 
future when you click Tool > Plugins > CGHSmooth. To restore the dialog 
box so it appears again, click Tool > Plugin Settings > CGHSmooth, then 
clear Don’t show again.

OK Accepts the parameters and prepares the plot. You can make further 
changes to the appearance of the plot once the plug- in displays it.

Cancel Ignores any changes you made, and closes the dialog box.

Parameter Description

Smoothing Function A number from 0 to 5. The number sets one of the following options as 
the weighting function used by the moving average algorithm. In 
general, the options weight measurements closer to the center 
position more heavily than those more distant from it.

0 – None. The plug-in applies no smoothing, and returns the original 
data. In some cases, the plug-in averages data points with identical 
positions. This sets, in effect, a window size of 0.

1 – Rectangular. The plug-in performs a standard moving average. All 
points within the rectangle (the window) receive the same weight.

2 – Gaussian. Applies a Gaussian weighting function.

3 – Triangular. Applies a triangular weighting function.

4 – Lorentzian. Applies a Lorentzian weighting function.

5 – Biexponential. Applies a biexponential weighting function.

Output Options A number from 0 to 2. The number sets one of the following options:

0 – Overlays the unsmoothed plot of each array on the smoothed plot.

1 – Displays smoothed and unsmoothed plots for each array.

2 – Displays smoothed, unsmoothed, and error plots for each array.

X-axis Label The text that appears under the X-axis of the plot as a label.

Y-axis Label The text that appears next to the Y-axis of the plot as a label.

Y-axis Range (min) The minimum value on the Y-axis.

Y-axis Range (max) The maximum value on the Y-axis.

X-axis Range (min) The minimum value on the X-axis.

X-axis Range (max) The maximum value on the X-axis.
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CGHSmooth Plot

Purpose: The CGHSmooth Plot is the output of the CGHSmooth plug- in. It 
contains separate, stacked plots of smoothed log ratio data for each of the 
selected arrays in the current experiment. 

To open: Click OK in the CGHSmooth Parameters dialog box. See 
“CGHSmooth Parameters” on page 167. 

Plot(s) Depending on the selected output option, the main plotting area shows up 
to three plots for each array in the active experiment. The plots can 
include unsmoothed and smoothed log ratio plots, and an error plot. 

Edit Opens a menu with a Copy Plot(s) to Clipboard option. If you select this 
option, the program copies the plots to the clipboard as an image. You can 
then paste the image into a document in another program.

Figure 39 CGHSmooth Plot
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When you right- click anywhere within the plotting area, the following 
options are displayed:

Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 171.

Copy Copies the chart to the Clipboard, where you can paste it into a word 
processing or other program.

Save as Opens a Save dialog box, where you can select a location for the *.png 
image file of the plots. 

Print Opens the Windows Page Setup dialog box, where you can set page 
size, margins, and orientation, and select a printer. From there, you 
click OK to open the Windows Print dialog box, where you can set 
print options and print the plot.

Zoom In Opens another menu that lets you zoom in the plot. You can zoom in 
several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to expand.

Zoom Out Opens another menu that lets you zoom out the plot. You can zoom 
out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.
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Chart Properties

Purpose: The Chart Properties dialog box lets you create titles and 
legends, as well as change the appearance, for the CGHSmooth, Echo 
Example, and MovAvg Example plots. 

To open: Use the CGHSmooth, Echo Example, or MovAvg Example plug- in 
to draw a plot. Right- click within the plotting area, then click Properties 
in the shortcut menu. 

This dialog box has four tabs. At any point, click OK to accept the settings 
in all four tabs, or click Cancel to close the dialog box without making 
any changes to the settings.

Auto Range Opens another menu that lets you zoom the plot to show the full range 
of the data. You can zoom in several ways:

• Both Axes – Appropriately zooms both axes of the specific plot to 
show the full set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis displays the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to display the full range of Y values of the data.

Option Description
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Title Tab

• Show Title – Mark this option to display a title across the top of the 
chart.

• Text – Type a title for the chart.

• Font – (Available if you mark Show Title) Click Select to open the 
Font Selection dialog box. Select the desired font attributes, then click 
OK.

• Color – (Available if you mark Show Title) Click Select to open the 
Title Color dialog box. Select or configure a color for the title, then 
click OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color” on page 231.

Figure 40 Chart Properties dialog box – Title tab
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Plot Tab

• Within the Plot tab, you can set these properties in the Domain Axis 
tab (“X” axis):

Figure 41 Chart Properties dialog box – Plot tab

Property Description

General

Label A custom label for the Domain (X) axis of the chart. Type the desired 
label.

Font The font for the custom label on the Domain (X) axis. Click Select to 
open the Font Selection dialog box. Select the desired font attributes, 
then click OK.

Paint The color of the custom label on the Domain (X) axis. Click Select to 
open the Label Color dialog box. Select the desired color, then click 
OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color” on page 231.
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• Within the Plot tab, you can set the following properties in the 
Appearance tab:

Other – Ticks tab

Show tick labels Mark this option to show, or clear it to hide, the numerical values on 
the domain axis.

Tick label font The font for the numerical values on the Domain (X) axis. Click Select 
to open the Font Selection dialog box. Select the desired font 
attributes, then click OK.

Show tick marks Mark this option to show, or clear it to hide, tick marks on the Domain 
(X) axis.

Other – Range tab

Auto-adjust range Mark this option to automatically set the range of values on the X-axis 
to include all data.

Minimum range value (Available if you do not mark Auto-adjust range) The lowest value 
represented on the X-axis.

Maximum range value (Available if you do not mark Auto-adjust range) The highest value 
represented on the X-axis. The program automatically converts large 
numbers to scientific “E” notation – for example, 1.22E8.

Property Description

Outline stroke The thickness of the lines around each plot. Click Select to open the 
Stroke Selection dialog box. Select the desired line thickness, then 
click OK.

Outline paint The color of the lines around each plot. Click Select to open the 
Outline Color dialog box. Select the desired color, then click OK. This 
dialog box is identical to the Select Color dialog box. See “Select 
Color” on page 231.

Background paint The color of the background within each plotting area. Click Select to 
open the Background Color dialog box. Select the desired color, then 
click OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color” on page 231.

Orientation Select either Vertical (X-axis on the bottom of the chart) or Horizontal 
(X-axis on the left side of the chart).

Property Description
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Other tab

The Other tab has these options:

• Draw anti- aliased – Mark this option to minimize distortion and visual 
artifacts in the plot image. This will create a smoother image, but it can 
be less sharp than the original one.

• Background paint – The color of the chart outside of the plotting area 
and legend. Click Select to open the Background Color dialog box. 
Select the desired color, then click OK. This dialog box is identical to 
the Select Color dialog box. See “Select Color” on page 231.

The other options are for future expansion, and are not available in the 
current release of Agilent Genomic Workbench.

Figure 42 Chart Properties dialog box – Other tab
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Configure Coloring Ranges and Shades

Figure 43 Configure Coloring Ranges and Shades dialog box for CGH

Purpose: This dialog box is used to enter ranges and select colors for 
scatter plot options. Tabs show scatter plot selections for the selected 
application type (CGH, ChIP, or CH3).

To open: In Gene View, move the mouse pointer over Scatter Plot to 
display the scatter plot options and then click Configure Color and 
Ranges. Or, click the View tab and click View Preferences. Then, under 
Configure Coloring schemes, click Configure Colors and Ranges.

For information on the contents of the various tabs, see the User Guide 
for the selected application.
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Confirm Overwrite

Purpose: When you import an experiment, it can contain designs and/or 
arrays that have the same names as those already available in Agilent 
Genomic Workbench. This dialog box lets you select which designs and/or 
arrays to overwrite.

To open: This dialog box appears when you import a ZIP format 
experiment file, and it contains designs and/or arrays that are already 
available in Agilent Genomic Workbench. See “To import an experiment 
file” on page 57.

Select the designs to overwrite

Design The names of the designs in the imported file that have the same names 
as designs that are already available in Agilent Genomic Workbench.

Overwrite Mark the check box for each existing design that you want to overwrite.

Select All Marks all of the check boxes under Overwrite.

Deselect All Clears all of the check boxes under Overwrite.

Figure 44 Confirm overwrite dialog box
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Select the microarrays to overwrite

Array Identification number or barcode of the array

Name The name of the array in the imported file that has the same name as 
array that is already available in Agilent Genomic Workbench.

Overwrite Mark the check box for each existing array that you want to overwrite.

Select All Marks all of the check boxes under Overwrite.

Deselect All Clears all of the check boxes under Overwrite.

OK Overwrites the selected files (both designs and arrays) and closes the 
dialog box.

Cancel Closes the dialog box, and returns you to the Import (experiments) dialog 
box. See “Import (experiments)” on page 213.

Create Experiment

Purpose: Creates an organizational unit (an experiment) that lets you 
display and analyze array data in Agilent Genomic Workbench. You add 
data to the experiment with links to array data files that are available in 
the program, a process that you can start from this dialog box. See “To 
create a new experiment” on page 62.

To open: In the Home tab of Agilent Genomic Workbench, click Create 
Experiment.

Figure 45 Create Experiment dialog box
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Name (Required) The name of the new experiment. This name identifies the 
experiment within the program and in exported reports and files. 

Description (Optional) Brief information that will later help to identify the experiment.

Properties Opens the Experiment Properties dialog box, where you can select array 
data files to add to the new experiment. See “Experiment Properties” on 
page 195.

OK Closes the dialog box and creates the new experiment.

Cancel Closes the dialog box without creating an experiment.

NOTE Click Properties to open the Experiment Properties dialog box to add array data to your new 
experiment. Otherwise, the program creates an empty experiment. You can also add arrays 
to the experiment later. See “To add arrays to an experiment” on page 64.
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Create Gene List

Purpose: To limit the genes presented in Gene View to a preselected 
number valuable for interpreting data

To open: Right- click Gene View, and click Create Gene List.

Name Type in name of gene list.

Build Select the genome build for the genes to be selected for list.

Description Describe the type or nature of the genes in the list.

Set Chromosome Start-Stop

Select a chromosome and a region in Chromosome View for selecting the 
genes in the list before you open the Create Gene List dialog box.

Figure 46 Create Gene List
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User Defined Lets you select a region from which the genes in Gene View will be 
selected. The chromosome selection list and the Start and Stop positions 
on the Y axis are enabled when this option is selected. With this option 
you can override the selections you made before opening Create Gene List.

For complete
gene view

Select all the genes in Gene View.

For aberrant
region below

cursor

Select those genes that appear in the aberrant region just below where the 
cursor sits in Gene View. Not operational in Genomic Viewer; depends on 
analysis.

Chromosome If you select User Defined, you can select a different chromosome than 
had been selected before opening the Create Gene List dialog box.

Start If you select User Defined, you can type in a Start position for defining 
the region contained the genes to be in the list.

Stop If you select User Defined, you can type in a Stop position for defining 
the region contained the genes to be in the list.

Color

Change Click to change the color of the gene list name in Data Navigator. See 
“Select Color” on page 231.
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Create Signal Bar Chart

Figure 47 Create Signal Bar Chart dialog box

Purpose: This dialog box lets you set parameters to create a histogram of 
signal intensities. You can customize the region that you want to display 
by selections in Set Chromosome Start- Stop.

To open: Right- click in the Gene View and select Show Intensity Bar 
Charts.

Set Chromosome
Start-Stop

Defines the region of the chromosome for which the bar chart will be 
defined. Select one of these options:

• User Defined – Lets you define an arbitrary region of any chromosome. 
If you select this option, select the desired chromosome in 
Chromosome, then type the beginning (Start) and end (Stop) locations 
of the desired interval.

• For complete gene view – The chromosomal region that appears in 
Gene View.

• For aberrant region below cursor – All of the intervals that begin 
before the cursor position and end after the cursor position. (Not 
available without a license.)

OK Creates the histogram using the selected region.
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Cancel Closes the dialog box without creating the histogram.Create Track 

Purpose: The Create Track dialog box lets you create a track for a 
chromosomal region based on an assigned chromosomal region. You can 
display one or more tracks next to the genes and data in Gene View. See 
“To show tracks in Gene View” on page 103.

To open: Right- click in the plotting area of Gene View for the CGH or 
CH3 application, then click Create Track in the shortcut menu. 

Name Type a name for the track. This name identifies the track when it appears 
in views and lists.

Build (Available if you select User Defined in Set Chromosome Start- Stop.) 
Select the genome build for the track.

Description Type descriptive text to attach to the track for reference.

Figure 48 Create Track dialog box
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Set Chromosome
Start-Stop

Defines the region of the chromosome for which the track will be defined. 
Select one of these options:

User Defined – Lets you define an arbitrary region of any chromosome. 
If you select this option, select the desired chromosome in 
Chromosome, then type the beginning (Start) and end (Stop) locations 
for the interval.

• For complete gene view – The chromosomal region that currently 
appears in Gene View.

OK Creates the track. To display the track in Gene View, use the Tracks tab 
of the User Preferences dialog box to enable it. See “User Preferences” on 
page 250. To export the track, see “To export tracks” on page 84.

Cancel Closes the dialog box without creating a track.

Customize Search Link

Figure 49 Customize Search Link dialog box
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Purpose: This dialog box lets you create a custom Web search link in the 
shortcut menu that appears when you right- click an entry in the Tab 
View. The link opens the URL of your choice, and sends the selected entry 
to it as a search string. See “To create a custom Web search link” on 
page 109.

To open: Right- click any entry in a table in Tab View, other than a 
column heading, then click Customize Link. 

URL Name The name of the custom Web search link that appears in the shortcut 
menu (see above). To edit an existing custom Web search link, select it 
from the list.

URL The full uniform resource locator (URL) of the desired search page. For 
the query string value, type <target> 

For example, this URL sends the selected Tab View entry to google.com:

http://www.google.com/search?hl=eng&q=<target>

New Opens an Input dialog box, where you can type a name for a new custom 
Web search link. Click OK to accept the name and add it to the URL 
name list.

Update Saves the settings in the dialog box.

Delete Deletes the currently selected custom Web search link.

Close Closes the dialog box.

Design Properties

Purpose: Gives general and detailed information about a given microarray 
design. See “To display the properties of a specific design” on page 72.

To open: In the Design Data pane of the Navigator, right- click the name 
of a genome build within a design folder, then click Show Properties. 
Several tabs are available.

Attribute tab

Displays general identifying attributes of the array design, and statistics 
such as the total number of features in the design, or the date the design 
was last modified.
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Design Properties
Non Unique Probes tab

Shows the nonunique probes in the design. Nonunique probes have more 
than one mapping in the genome that is a perfect match. 

Figure 50 Design Properties dialog box – Attribute tab
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S. No The sequence order of the probes within the table. 

Probe The name of each nonunique probe.

Value The chromosomal locations to which each of the probes binds. Because 
these are nonunique probes, multiple locations appear for each probe.

Figure 51 Design Properties dialog box – Non Unique Probes tab
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Design Properties
Data tab

Displays the names of the probes in the design and their target genomic 
locations. The tab displays the probes for one chromosome at a time.

Select
Chromosome

The chromosome whose probes appear in the list. To view the probes for 
another chromosome, select one from this list.

Probe The name (Probe ID) of each probe.

Chromosome The name of the probe chromosome.

Start The location on the selected chromosome of the first base pair for the 
probe.

Stop The location on the selected chromosome of the last base pair for the 
probe.

Figure 52 Design Properties dialog box – Data tab
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Design Properties
SNP Data tab (CGH only)

This tab appears only when you select the CGH module. It shows design 
information for SNP probes in the design.

Figure 53 Design Properties dialog box – SNP Data tab

SNP ID The SNP identification.

Probe The name (Probe ID) of the probe. The probe names are separated with a 
comma.

Chromosome The chromosome on which the probe is located.

SNP Position The position of the SNP on the chromosome.
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Echo Example Plot

Purpose: The Echo Example Plot is the output of the Echo Example 
plug- in. It displays the log ratio data for the selected chromosome in the 
active experiment. Data from all of the selected arrays in the experiment 
appear as a series of stacked plots, one for each array. 

To open: Select the desired experiment, select the desired chromosome in 
Genome View, then click Tool > Plugin > Echo Example.

Edit Opens a menu with a Copy plots to clipboard command. This command 
copies all of the plots to the clipboard as an image. You can then paste 
the image into a document in another program.

Plots Each plot displays the log ratio data for the selected chromosome from an 
individual array in the experiment.

You can right- click anywhere within each plot to display the following 
options:

Figure 54 Echo Example Plot
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Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 171.

Copy Copies the chart to the Clipboard, where you can paste it into a word 
processing or other program.

Save as Opens a Save dialog box, where you can select a location for a saved 
*.png image file of the plots. 

Print Opens the Windows Page Setup dialog box, where you can set page 
size, margins, and orientation, and select a printer. From there, you 
click OK to open the Windows Print dialog box, where you can set 
print options and print the plot.

Zoom In Opens another menu that lets you zoom in the plot. You can zoom in 
several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to expand.
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Zoom Out Opens another menu that lets you zoom out the plot. You can zoom 
out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.

Auto Range Opens another menu that lets you zoom the plot to display the full 
range of the data. You can zoom in several ways:

• Both Axes – Zooms both axes of the specific plot to show the full 
set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis displays the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to display the full range of Y values of the data.

Option Description
192 Data Viewing User Guide



Data Viewing Reference 4
Edit Array Color
Edit Array Color

Purpose: Lets you show, change, and/or export the color(s) assigned to 
the arrays in an experiment.

To open: In the Experiment pane, right- click the name of an experiment, 
then click Edit Array Color.

Edit Opens a menu with a Copy command. If you click Copy, the program 
copies the list of arrays and their assigned colors to the Clipboard. You 
can then paste the list into a document in another program such as Word 
or PowerPoint.

Select Array Mark the check box for the array(s) whose color you want to change.

Color Opens the Select Color dialog box, where you can select a new color for 
the selected array(s). If more than one array is selected, all of the selected 
arrays assume the new color. For more information about selecting array 
colors, see “To change the display color of an array” on page 90.

Figure 55 Edit Array Color dialog box
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Select All Marks all of the check boxes.

Deselect All Clears all of the check boxes.

Edit Color Opens the Select Color dialog box, where you can select a new color for 
the selected array(s). (Same function as the buttons under Color)

Restore default Restores the system default colors to all arrays.

OK Saves all assigned array colors and closes the dialog box.

Cancel Closes the dialog box without saving any changes.

Edit Array Order

Purpose: Changes the display order of the arrays in an experiment. This 
can change the order in which array data appear in Gene View and Tab 
View.

To open: In the Experiment pane, right- click the name of an experiment, 
then click Edit Array Order.

Figure 56 Edit Array Order dialog box
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Array Name The arrays in the selected design, shown in the order that they currently 
appear in the Experiment.

Design Select a design from the list. The arrays from the selected design appear 
under Array Name.

Order by (Optional) Select an array attribute. The program can set the order of 
arrays based on their respective values for the selected attribute.

Moves a selected array up in the list. To select an array, click its name.

Moves a selected array down in the list. To select an array, click its name.

OK Sets the new order of the arrays and closes the dialog box.

Cancel Closes the dialog box without changing the order of any arrays.

Experiment Properties

Figure 57 Experiment Properties dialog box
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Purpose: Lets you select array designs and data to link to an experiment. 
See “To add arrays to an experiment” on page 64.

To open: In the Create Experiment dialog box, click Properties, or in the 
Experiment pane of the Navigator, right- click the name of an experiment, 
then click Show Properties.

Experiment Name (Read- only) The name of the selected experiment.

Description Description that was typed when the experiment was created. 

Select Design

Designs Shows all of the designs available in the program. Select the design 
associated with arrays that you want to add to the experiment.

Genome Builds Shows the genome build(s) that are associated with the design. Select the 
desired genome build to display the arrays that are associated with a 
single genome build.

Arrays

Array List Shows the arrays in the selected design that are available for this 
experiment.

• To select an array to move to the Selected Array List, click its name. 

• To select additional arrays, hold down the Ctrl key while you click their 
names. 

• To select a contiguous block of arrays, click the name of the first array, 
then hold down the Shift key and click the name of the last one.

Selected Array
List

Shows the arrays that you have selected for this experiment.

Moves the selected arrays in Array List to the Selected Array List. You can 
move arrays from as many designs as you like, if they are all associated 
with the same genome build.

Moves all of the arrays in Array List to the Selected Array List.

Removes an array from the Selected Array List. To select an array for 
removal, click its name. If desired, you can re- add an array.

Clears the Selected Array List.
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Display name by Click to select an attribute to be used for display of the names of arrays 
in the experiment. The Global Display name is the name assigned in 
Sample Manager for the array. See the Sample Manager User Guide for 
more information.

OK Adds the arrays in the Selected Array list to the experiment and closes 
the dialog box.

Cancel Closes the dialog box without adding any arrays to the experiment.

Export

Purpose: Lets you select a location for an exported file. 

To open: This dialog box appears after you select specific experiment(s), 
track(s), filter(s) or array attributes to export. See “To export 
experiments” on page 82, “To export tracks” on page 84, “To export 
filters” on page 83 or “To export array attributes” on page 81.

Figure 58 Export dialog box – Several types of file exports use this dialog box. This spe-
cific example exports selected experiment(s) as a ZIP format file.
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Export Array Attributes
Look in Displays the folder or other location whose contents appear in the main 
pane of the dialog box. To select another folder or other location, click .

Moves to the next higher folder level.

Opens the Desktop.

Creates a new folder in the selected location in Look in.

Displays the names, only, of folders, files, and other locations in the main 
pane of the dialog box.

Displays both the names and more information about folders, files, and 
other locations in the main pane of the dialog box.

Main pane Displays the folders, files, and other locations in the selected location in 
Look in. Only files of the selected file type are displayed. To select file, 
click its name. To open a folder or other location, double- click its name.

File name Displays the name of the file to which the exported content will be saved. 
To change the name, you can either select a file in the main pane of the 
dialog box, or type a new name.

Files of type Sets the type of files that are displayed. To show all files, click , then 
select All Files.

Export Saves the selected content to the location given in the dialog box.

Cancel Cancels your selections and closes the dialog box.

Export Array Attributes

Purpose: This dialog box lets you select arrays whose attributes you want 
to export. It contains two tabs: an Array tab where you select the arrays, 
and an Attribute tab where you select the attributes of the selected arrays 
to export. See “To export array attributes” on page 81.

To open: In the Home command ribbon, click Export > Array Attributes, 
or in the Experiment pane of the Navigator, right- click the name of an 
experiment, then click Export Attributes.
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Array tab

Select Design

Designs Shows all of the designs available in the program. Select the design 
associated with arrays whose attributes you want to export.

Genome Builds Shows the genome build(s) associated with the design. Select the desired 
genome build to display the arrays.

Arrays

Array List Shows the arrays in the selected design.

• To select an array to move to the Selected Array List, click its name. 

• To select additional arrays, hold down the Ctrl key while you click their 
names. 

• To select a contiguous block of arrays, click the name of the first array, 
then hold down the Shift key while you click the name of the last one.

Selected Array
List

Shows the arrays that you have selected for this experiment.

Figure 59 Export Array Attributes – Array tab dialog box
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Moves the selected arrays in Array List to the Selected Array List. You can 
move arrays from as many designs as you like, if they are all associated 
with the same genome build.

Moves all of the arrays in Array List to the Selected Array List.

Removes an array from the Selected Array List. To select an array for 
removal, click its name. If desired, you can re- add an array.

Clears the Selected Array List.

Next Moves to Attribute tab for attribute removal. 

Cancel Closes the dialog box without selecting any arrays and their attributes to 
be exported.

Attribute Tab

Attributes

Selected
Attribute List

Shows the attributes for the selected arrays to be exported.

• To select an attribute to move to the Attribute List, click its name. 

Figure 60 Export Array Attributes – Attribute tab dialog box
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• To select additional attributes, hold down the Ctrl key while you click 
their names. 

• To select a contiguous block of attributes, click the name of the first 
attribute, then hold down the Shift key while you click the name of the 
last one.

Attribute List Shows the attributes that will not be exported for the selected arrays.

Removes an attribute from the Selected Attribute List. To select an 
attribute for removal, click its name. You can add the attribute to the 
Selected Attribute List at a later time.

Clears the Selected Attribute List.

Moves the selected attributes in the Attribute List to the Selected Attribute 
List. 

Moves all of the attributes in the Attribute List to the Selected Attribute 
List.

Back Moves back to the Array tab for array selection or removal.

OK Opens the Export dialog box. See “Export” on page 197.

Cancel Closes the dialog box without exporting any attributes.

NOTE Because certain attributes are required for importing an attributes file, it is important that 
you select these attributes when you export an attributes file. Required attributes are: Array 
ID, Global Display Name, Green Sample, Red Sample, and Polarity.
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Export Experiments

Purpose: Lets you select experiments for export. The program exports all 
array designs and data associated with the experiments as a single ZIP 
file. This file does not include any parameter settings, array selections, or 
results. See “To export experiments” on page 82.

To open: In the Home tab, click Export > Experiments. 

Select experi-
ments to export

Shows all experiments available for export. Mark each experiment you 
want to export.

Select All Selects all experiments for export.

Deselect All Clears all check boxes under Select experiments to export.

OK Opens an Export dialog box. See “Export” on page 197.

Cancel Cancels the export and closes the dialog box.

Figure 61 Export Experiments dialog box
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Export Filters 

Purpose: Lets you select feature- level, array- level, design, metric set, 
and/or aberration filters, to export as a single *.xml file. You can create 
and use filters only if you have a DNA Analytics application license. See 
“To export filters” on page 83.

To open: In the Home tab, click Export > Filters.

Select filters to
export

Displays all of the filters available in the program. The table has these 
columns:

• Export – Mark the check box for each filter to export.

• Filter – The name of each filter.

• Type – The type of content to which the program applies each filter.

Select All Selects all available filters for export.

Deselect All Clears all of the check boxes under Select filters to export.

Figure 62 Export Filters dialog box
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Export Tracks
OK Opens the Export dialog box, where you can select a location for the 
exported *.xml file of filters. See “Export” on page 197.

Cancel Cancels the export and closes the dialog box.

Export Tracks

Purpose: Lets you select tracks to export as a single BED format file. See 
“To export tracks” on page 84.

To open: In the Home tab, click Export > Tracks.

Select tracks Shows all of the tracks available in the program. Mark the check box for 
each track to export.

For more information about tracks, see “To create a track (CGH only)” on 
page 78 and “To show tracks in Gene View” on page 103.

Select All Selects all available tracks for export.

Figure 63 Export Tracks dialog box
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Deselect All Clears all of the check boxes under Select Tracks.

OK Opens the Export dialog box, where you can select a location for the 
exported BED format file. See “Export” on page 197.

Cancel Cancels the export and closes the dialog box.

Find in column

Purpose: This dialog box lets you set search parameters for a specific 
column entry for the selected chromosome. Based on these parameters, 
the program can highlight the row of the first entry that matches. The 
cursor then moves to the location defined in the row.

To open: Right- click any entry in a tab in Tab View other than a column 
heading, then click Find in column in the shortcut menu. 

Find in column Type all or part of the entry you want to find.

Direction Select a search direction:

• Up – Sets the search to move up in the selected column from the 
currently highlighted row.

• Down – Sets the search to move down in the selected column from the 
currently highlighted row.

Conditions Mark any of these search options:

Figure 64 Find in column dialog box
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• Match Case – Mark this option to take case into account. For example, 
if you mark Match Case, and you type aa351 in Find in column, the 
search finds the next entry in the column that contains aa351. It does 
not find entries that contain AA351 or Aa351.

• Match whole word – Mark this option to only find entries in which the 
complete entry matches what you type in Find in column. For example, 
if you type AA351 in Find in column, and mark Match whole word, the 
program finds the next AA351 entry. It does not find entries such as 
AA3512 or AA351992.

Find Next Finds the next matching entry in the selected column, and moves the 
cursor to the location defined in the row that contains the entry. The 
search is performed only for the chromosome selected in the Genome 
View.

Cancel Closes the dialog box.
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Gene List

Purpose: Lets you view the names of the genes in a specific gene list and 
to change the display color of the gene list. 

To open: In the My Entity List pane of the Navigator, right- click the name 
of a gene list, then click View in Table.

Name (Read- only) The name of the gene list.

Description (Optional) Brief descriptive comments about the gene list, such as how it 
was created or the nature of the genes in the list. You can edit the 
description.

Figure 65 GeneList dialog box
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Genotype Reference Details (CGH only)
S. No The sort order number. This is the index number of each gene within the 
gene list.

Gene Names The names of the genes in the gene list.

Color Opens the Choose Gene List Color dialog box, where you can change the 
display color for the gene list. 

OK Saves the gene list with any new description or display color, and closes 
the dialog box.

Cancel Closes the dialog box without making any changes to the gene list.

Genotype Reference Details (CGH only)

Figure 66 Genotype Reference Details dialog box

Purpose: Shows the details of the genotype reference selected in the 
Genotype pane of the Navigator. This dialog box is only available only in 
the CGH module.
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Genotype Reference Importer (CGH only)
To open: In the Genotypes pane of the Navigator, right- click on a 
genotype reference, and select Show Properties.

Genotype Reference Importer (CGH only)

Figure 67 Genotype Reference Importer dialog box

Purpose: Displays the contents of a genotype reference file you want to 
import, and lets you choose to overwrite existing genotype references in 
the database when you import the file.

To open: From the Home tab, click Import > Genotype References. In the 
Import Genotype Reference Files dialog box, browse to a location and 
select the genotype reference file you want to import, then click OK.

Reference
Samples

Displays a table of the samples in the file, including number of SNP 
probes covered by the sample.
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Go To Gene/Genomic Location
Reference
Genotypes

Displays a table of the genotypes in the file. Duplicate SNP_IDs are not 
allowed. If there are duplicate SNP_IDs in the file, only the first SNP_ID is 
imported.

Go To Gene/Genomic Location

Purpose: To find a specific gene location in Gene View by either selecting 
the RefSeq by Symbol or by selecting the Genomic Location.

To open: Click Home > Go to Gene/Genomic location.

RefSeq by Symbol Select the Reference Sequence accession symbol from NCBI, and click Go.

Genomic Location • Chromosome – The chromosome number.

NOTE If the CUT_ALLELE column is present for a genotype reference, and there is no 
IS_DOUBLY_CUT column, the IS_DOUBLY_CUT column will be automatically inferred from 
the CUT_ALLELE column.

 

Figure 68 Go To Gene/Genomic location dialog box
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Import
• Base Position – The position on the chromosome.

Click Go after selecting the chromosome number and the position of the 
gene on the chromosome.

Cancel Closes the dialog box.

Import

Purpose: Lets you select files and import them into Agilent Genomic 
Workbench. The title of this dialog box changes depending on the type of 
file to import.

To open: In the Home tab, click Import, then select any kind of import 
except Genome Build or Track. The type of file to be imported appears in 
the title of the dialog box. To import a gene list, right- click the Gene List 
folder in the My Entities List pane of the Navigator, then click Import 
Gene List.

Figure 69 Import dialog box
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Import
Use the standard Windows® Explorer commands in the dialog box to 
select a file for import. 

For some imports, you can select multiple files. Click the name of the first 
file, then hold down the Ctrl key while you click the names of additional 
files. To select a contiguous block of files, click the name of the first file 
in the block, then hold down the Shift key while you click the name of the 
last one.

File name Displays the name of a file you select for import.

Files of type Lets you select the types of files to display from the types shown in the 
table below. To display all files, click ,then select All Files.

.

Import or Open Imports the file into the program. In some cases, the name of this button 
is Open, rather than Import. Also, when you click Import, in many cases 
one or a series of additional dialog box(es) lets you further define the 
content for import. See the instructions for each specific type of import in 
Chapter 2.

Cancel Cancels the import and closes the dialog box.

File type Extension

FE array File *.txt

Axon array file *.gpr

UDF file *.txt

Design file (GEML) *.xml

Axon design file *.gal

Array attributes *.txt

Experiments *.zip

Filters *.xml

Gene list *.txt
212 Data Viewing User Guide



Data Viewing Reference 4
Import (experiments)
Import (experiments)

Purpose: Lets you select the specific experiments within a .zip experiment 
file to import into the program. See “To import an experiment file” on 
page 57.

To open: In the Home tab, click Import > Experiments. In the dialog box 
that appears, select the desired .zip experiment file, then click Import.

Select
experiments to

import

These columns appear:

• Import – Mark the check box for the experiment(s) to import.

• Experiment – The names of the experiments available for import in the 
ZIP format experiment file.

•

Select All Selects all of the experiments in the .zip file for import.

Deselect All Clears all of the check boxes under Import.

OK Imports the selected experiments into the program. If the name of an 
imported array design or data file matches one that is already available in 
the program, the Confirm overwrite dialog box appears, where you can 
select the data and/or design files that you want to overwrite. See 
“Confirm Overwrite” on page 177.

Figure 70 Import dialog box (for experiments)
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Import (filters)
Cancel Cancels the import and closes the dialog box.

Import (filters)

Figure 71 Import (for filters) dialog box

Purpose: Lets you select the specific filters within a .zip exported filter 
file to import into the program. See “To import filters” on page 58.

To open: In the Home tab, click Import > Filters. In the dialog box that 
appears, select the desired ZIP exported filter file, then click Import.

Select
experiments to

import

These columns appear:

• Import – Mark the check box for the experiment(s) to import.

• Filter – The names of the filters available for import in the .zip filter 
file.

• Type – The type of filter

Select All Selects all of the filters in the .zip file for import.

Deselect All Clears all of the check boxes under Import.
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Import GEML design files
OK Imports the selected filters into the program. If the name of a filter 
matches one that is already available in the program, the Confirm 
overwrite dialog box appears, where you can select the filters that you 
want to overwrite. See “Confirm Overwrite” on page 177.

Cancel Cancels the import and closes the dialog box.

Import GEML design files

Purpose: To display information in the design file and to remove any files 
that you don’t want to import.

To open: In the Home tab, click Import > Design Files > GEML File. 
Select the desired *.xml design files, then click Open.

File Name The name(s) of the design file(s) to be imported.

Figure 72 Import GEML design files dialog box
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Import GEML design files
ID The Agilent ID number for the design file

Type The application type, which can be CGH, ChIP, miRNA, or gene expression.

Species The species for the genome build. This appears automatically when the 
Genome Build is selected. 

Genome Build The genome build for the design. If the genome build is not read 
automatically, a “?” appears. Click Genome Build and select the correct 
value from the list.

Status • Not Set – Appears if Genome Build and Species information is not 
shown.

• Not Allowed – Appears if a Genome Build is selected that does not 
match the design, or if the design is a catalog or read- only design.

• Overwrite – Appears when the design file has been updated and will 
overwrite any existing one of the same name.

• Valid – Appears when the file is new. 

• Corrupt – Appears when the file is corrupt.

Remove Click  to remove a specific design file from the list. 

Start Import Starts the import of the design files in the list.

Cancel Cancels the upload and closes the dialog box.
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Import Genome
Import Genome

Figure 73 Import Genome dialog box

Purpose: To specify a custom genome to import. For more information, 
see the eArrayXD User Guide.

To Open: On the Home Command Ribbon, click Import and then select 
Custom Genome for Tiling.

Species Select the species of the user- defined genome to import. The species list 
contains all of the species currently available in the system. To upload a 
genome for a species that does not appear in this list, select Na. 

To select this genome for tiling, you select Na as the species.

Genome Name Type a name for the genome import job. The program uses this name to 
identify the job in the Tasks pane of the Navigator.

Genome Build Type the name of the specific build of the genome that is represented in 
your genome file. Use only letters, numbers, underscores, periods, and 
dashes.

Genome is
soft-masked

Mark this check box if repeat sequences in your genome file are 
represented by lower- case letters. If you do not mark this option, the 
program changes any lower- case characters in your sequence(s) to capital 
characters.
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Import Genome
Genome File The genome file must be a *.zip archive that contains the FASTA format 
chromosomal sequence files.

Browse Click this to browse to and locate the genome file to import.

Save The program starts your genome import, and adds the job to the Tasks 
pane of the Navigator. A dialog box tells you that the job has been 
submitted.

Cancel Click to close the dialog box without importing any data.
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Import Genome Build
Import Genome Build

Purpose: To import a new set of genome build files into Agilent Genomic 
Workbench. See “To import a genome build” on page 54.

To open: In the Home tab, click Import > Genome Build.

Species The genome’s species of origin.

Build Name The name of the build to be imported.

Refseq File The location of the RefSeq database file. This file contains chromosomal 
locations of genes. To select a Refseq file, click Browse.

CytoBand File The location of the applicable cytoband file. This file contains graphical 
cytoband information for Gene View and Chromosome View. To select a 
cytoband file, click Browse.

OK Imports the genome build and closes the dialog box.

Cancel Cancels the import and closes the dialog box.

Figure 74 Import Genome Build dialog box

CAUTION Import only Agilent-provided genome build files. 
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Import Track
Import Track

Purpose: Lets you import a BED format track file. See “To import 
tracks” on page 55. Track information can appear in Gene View. See “User 
Preferences” on page 250.

To open: In the Home tab, click Import > Track.

Species Select the species to which the track relates. 

Build Name This list contains the available genome builds for the selected species. 
Select the desired genome build.

Color Shows the currently assigned display color for the track. To change this 
color, click Change. For more information, see “Select Color” on page 231. 
You select track colors in the same way as gene list colors.

Track Name Type a name to identify the imported track. 

Track File Type the location of the BED track file to import, or click Browse to 
select a file.

Browse Opens an Open dialog box, where you can select the BED track file to 
import.

OK Imports the track into the program.

Cancel Cancels the import and closes the dialog box.

Figure 75 Import Track dialog box
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Microarray Properties
Microarray Properties

Purpose: Displays the properties associated with an array. You can also 
edit the values of specific attributes. To add attributes to the list, see the 
Sample Manager User Guide.

To open: For any array in the Data folder or Experiments folder, 
right- click the array name, then click Show Properties. For non- Agilent 
arrays, only the Attribute tab appears.

Attribute tab

• Attribute — Displays the attributes in the array by name. 

• Value – Indicates the values, if any, for each array. To edit the value of 
an attribute, select a new value for it under Value. Alternatively, click 

, then type or edit the value. 

Close Closes the dialog box.

Figure 76 Microarray Properties dialog box with list of Attributes and their values 
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Microarray Properties
FE Headers tab

Index Displays a sequential index to help identify FE properties.

Name Displays feature parameters, statistics, and constants for the whole array.

Value Displays the value for each parameter, statistic, and constant.

Close Closes the dialog box.

 

Figure 77 Microarray Properties dialog box with list of FE Headers their values
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Microarray Properties
FE Features tab

Selection List Select the chromosome whose feature information you want to display.

List Box Displays FE features and the associated data. The columns are:

Figure 78 Microarray Properties dialog box with list of FE Features and associated data

Index FeatureNum ProbeName

gIsPosAndSignif LogRatioError PValueLogRatio

gProcessedSignal rProcessedSignal gMedianSignal

rMedianSignal gBGSubSignal rBGSubSignal

gIsSaturated rIsSaturated gIsFeatNonUnifOL

rIsFeatNonUnifOL gIsBGNonUnifOL rIsBGNonUnifOL

rIsPosAndSignif gIsWellAboveBG rIsWellAboveBG
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MovAvg Example Parameters
MovAvg Example Parameters

Purpose: This dialog box lets you set display parameters for the MovAvg 
Example plug- in. The plug- in calculates a 10- point moving average of the 
data from the selected chromosome in the selected arrays of the active 
experiment. It displays stacked plots of moving averages for all the arrays, 
one plot per array. You must have Perl installed on your computer to use 
this plug- in.

To open: Click Tool > Plugin Settings > MovAvg Example. This dialog 
box also opens when you click Tool > Plugin > MovAvg Example, if Don’t 
show again is cleared. 

Parameters Set any of these parameters:

Figure 79 MovAvg Example Parameters dialog box

Parameter Description

X-axis Label The text that appears under the X-axis of the plot as a label.

Y-axis Label The text that appears next to the Y-axis of the plot as a label.

Y-axis Range (min) The minimum value on the Y-axis.

Y-axis Range (max) The maximum value on the Y-axis.

X-axis Range (min) The minimum value on the X-axis.

X-axis Range (max) The maximum value on the X-axis.
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MovAvg Example Parameters
Don’t show again Mark this option to keep this dialog box from being displayed in the 
future when you click Tool > Plugin > MovAvg Example. To restore the 
dialog box so it appears again, click Tool > Plugin Settings > MovAvg 
Example, then clear Don’t show again.

OK Click to accept the parameters and prepare the plot. You can further make 
additional changes to the appearance of the plot once the plug- in displays 
it.

Cancel Ignores any changes you made, and closes the dialog box.

How to modify the plugin

The plug- in program (MovAvg Example.pl, located in the Plugins folder of 
the Agilent Genomic Workbench installation folder on your computer) is a 
short Perl program. It is a good example of how calculated columns are 
processed. 

The plotting is very simple, but the simple plug- in architecture of MovAvg 
Example.pl lets you write your own computational methods to analyze 
data from selected arrays in the CGH application. 

• Within the code of the plug- in, you can add text strings to column 
headers to set the format. 

• To create a line graph instead of a scatter plot, you append 
-plotline to a column header. 

• To prevent the plug- in from plotting a specific column, you append 
-noplot to the column heading. Note that the plug- in removes this 
extra text from the header before it displays it on the plot. The extra 
text does not appear in figures, and is only used to set the format of 
the plot. 

MovAvg.pl shows how column- naming can be used. As you read the first 
line (which contains the header text), you can add text to the existing 
headers or add text to the headers for your generated columns, as well, to 
give you a small amount of formatting control.
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MovAvg Example Plot
MovAvg Example Plot

Purpose: This plot displays the output of the MovAvg Example plug- in. 
The plug- in calculates a 10- point moving average of the data from the 
selected chromosome in the selected arrays of the active experiment. 

To open: Click OK in the MovAvg Example Parameters dialog box. See 
“MovAvg Example Parameters” on page 224. 

Plot(s) The main plot area shows moving average line plots for the selected 
chromosome. A separate plot appears for each array.

Edit Opens a menu with a Copy Plot(s) to Clipboard option. If you select this 
option, the program copies the plots to the clipboard as an image. You can 
then paste the image into a document in another program.

Figure 80 MovAvg Example Plot
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MovAvg Example Plot
When you right- click anywhere within the plot area, the following options 
are displayed:

Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 171.

Save as Opens a Save dialog box, where you can select a location for the *.png 
image file of the plots. 

Print Opens a Page Setup dialog box, where you can set page size, margins, 
and orientation, and select a printer. From there, you click OK to open 
the Print dialog box, where you can set print options and print the plot.

Zoom In Opens another menu that lets you zoom in the plot. You can zoom in 
several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to expand.

Zoom Out Opens another menu that lets you zoom out the plot. You can zoom 
out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.

Auto Range Opens another menu that lets you zoom the plot to display the full 
range of the data. You can zoom in several ways:

• Both Axes – Zooms both axes of the specific plot to show the full 
set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis displays the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to display the full range of Y values of the data.
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Probe Upload
Probe Upload

Figure 81 Probe Upload dialog box

Purpose: Lets you set up and start a probe upload. A probe upload 
transfers probe sequences and annotation to your Agilent Genomic 
Workbench server. See the eArrayXD User Guide for more information.

To open: In the Home tab, on the Command Ribbon, click Import > Probe 
Upload.
228 Data Viewing User Guide



Data Viewing Reference 4
Probe Upload
Probe Parameter
Details

These parameters appear:

Upload Probe File
Details

Select these options:

Parameter Description 

Job Name Type a name that will help you to identify this job. 

Species Select the desired species. The program associates all probes 
in the uploaded file with this species. 

Remove replicate probes from 
upload

Mark this option to upload the first probe in each set of 
replicate  probes in your file, and ignore the others. A replicate 
probe has the same Probe ID as another probe in the file.  

If your probe file contains replicate probes, and you do not 
mark  Remove replicate probes from upload, the program 
does not  upload your file.  

Probe Precedence These options specify what the program does if it finds probes 
in your uploaded file that have the same Probe ID as probes 
that already exist in the system.  

Select one of these options:  

• Overwrite matching probes – The annotation of the 
matching uploaded probes replaces the annotation of the 
existing probes.  You can use this option to reannotate 
existing probes. 

• Skip matching probes – The program ignores matching 
uploaded probes, but does upload other probes. 

• Cancel upload if any probes already exist – The program 
cancels the entire upload process if it finds a matching 
uploaded probe. 

Parameter Description 

Probe Group Name The program creates a probe group that contains the probes in 
your uploaded file. Type a name for this probe group. 

Upload File The location of the file that contains the probes and 
annotation to be uploaded. 

Browse – Opens an Open dialog box, where you can select a 
file of probes and annotation for upload.
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Probe Upload
Preview Opens the Define Uploaded File Columns pane in the dialog box, which 
lets you view the first few lines of your uploaded file, and label the 
content of each column of data within it. See the eArrayXD User Guide 
for more information.

Cancel Cancels the probe upload and closes the dialog box.

File Format The column content of your probe file. Select one of  these 
options:  
• COMPLETE – The uploaded file contains the columns 

described  in “Complete (for probes)” on page 648.  
• MINIMAL – The uploaded file contains the columns 

described  in “Minimal (for probes)” on page 656.  

File Type The file type defines how the data items in the file are 
specified and separated. The program accepts tab-delimited 
text (*.tdt and *.txt) and Microsoft Excel (*.xls) files.  

If you use Microsoft Excel 2007 to create the file, save the file 
as an Excel 97-2003 workbook. This saves the file in the 
required *.xls format. 

Parameter Description 

CAUTION If you select Overwrite Matching Probes in Probe Precedence, the program reannotates 
matching probes upon upload. The original annotation of these probes cannot be 
recovered.
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Scroll to Column
Scroll to Column

Purpose: This dialog box lets you select a column. The program then 
scrolls the tab so that you can see the selected column.

To open: Right- click a column heading in Tab View, then click Scroll To 
Column in the shortcut menu. 

Select column Lists the columns available in the currently selected tab. Select the one 
you want to view.

OK Scrolls the current tab so that you can see the selected column.

Cancel Closes the dialog box.

Select Color

Purpose: To select a color. Three tabs are available for selecting colors: 

• Swatches tab -  select colors based on samples (swatches)

• HSB tab -  select colors based on an HSB schema (Hue, Saturation, and 
Brightness)

• RGB tab -  select colors based on an RGB schema (Red- Green- Blue)

To open: This dialog box opens when a function allows you to change a 
color. For example, right- click on an array in an experiment, click Edit 
Array Color and click the Swatches, HSB, or RGB tab.

Figure 82 Scroll to Column dialog box
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Select Color
Swatches tab

This tab is used to select a color based on color samples (swatches).

Preview The Preview area shows how the selected color appears. When you change 
the color, the original color appears at the top of the color box on the 
right.

Recent: Choose a recent color selection.

OK Click to select the color and close the dialog box.

Cancel Click to close the dialog box without changing the color.

Reset Click to change swatches, HSB, and RGB colors back to the default colors.

Figure 83 Select Color - Swatches Tab
232 Data Viewing User Guide



Data Viewing Reference 4
Select Color
HSB Tab

In this tab, you can select a color based on an HSB schema (Hue, 
Saturation, and Brightness).

Hue Click the H button, and move the slider up and down, or go up and down 
the list of numbers, to select the hue or color of the array.

Saturation Click the S button, and move the slider up and down, or go up and down 
the list of numbers, to select the saturation level for the color.

Brightness Click the B button and move the slider up and down, or go up and down 
the list of numbers, to select the brightness level for the color.

RGB Numbers Reflect the amount of red, green and blue in the resulting color.

Preview The Preview area shows how the selected color appears. When you change 
the color, the original color appears at the top of the color box on the 
right.

OK Click to select the color and close the dialog box.

Cancel Click to close the dialog box without changing the color.

Figure 84 Select Color - HSB Tab
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Select Color
Reset Click to change the swatches, HSB, and RGB colors back to default values.

RGB Tab

This tab is used to select a color based on an RGB (Red, Green Blue) 
schema.

Red Move the slider to change the amount of red in the color. Or, click the up 
or down arrow to select a number.

Green Move the slider to change the amount of green in the color. Or, click the 
up or down arrow to select a number.

Blue Move the slider to change the amount of blue in the color. Or, click the up 
or down arrow to select a number.

Preview The Preview area shows how the selected color appears. When you change 
the color, the original color appears at the top of the color box on the 
right.

OK Click to select the color and close the dialog box.

Figure 85 Select Color - RGB Tab
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Select data type for experiments (UDF files – CGH or CH3)
Cancel Click to close the dialog box without changing the color. 

Reset Click to return the swatches, HSB, and RGB colors back to default values.

Select data type for experiments (UDF files – CGH or CH3)

Purpose: Lets you specify the mathematical form of the data in an 
imported UDF file, and its associated application type. See “To import a 
UDF file” on page 51.

To open: In the Home tab, click Import > Array Files > UDF File. In the 
dialog box that appears, select the desired UDF file, then click Open.

Experiment Name By default, the experiment name is the name of the imported UDF file. To 
change the name, double- click it, then edit it as desired.

Data Type Select the mathematical form of the array data in the UDF file. The 
options are:

• ratio

• log2 ratio

• log10 ratio

• ln ratio (base e)

Design type Select the application type (CGH or CH3, for example) associated with the 
array data in the UDF file.

Figure 86 Select data type for experiments dialog box
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Set genome build and species for Axon design files
Continue Accepts your selections, and goes to the next step in the UDF import 
process.

Cancel Cancels the UDF import.

Set genome build and species for Axon design files

Purpose: Lets you set the species and genome builds associated with 
imported Axon design file(s), and to remove specific designs files from the 
import, if necessary. See “To import Axon design files” on page 49.

To open: In the Home tab, click Import > Design Files > Axon File. In 
the dialog box that appears, select at least one Axon design file, then click 
Import.

No. An index number within the dialog box for each Axon file.

Figure 87 Set genome build and species for Axon design files dialog box
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Set genome build and species for Axon design files
File Name The names of each Axon design file selected for import.

Species The species associated with each design file. If a species is incorrect, 
select the correct one from the appropriate list.

Genome Build The genome build associated with each of the design files. If a genome 
build is incorrect, select the correct one from the appropriate list.

Status The status of the file is one of the following:

• Valid – The file is a new file that can be imported.

• Overwrite – The file is a valid design file, but when you import it, it 
will replace an existing design that has the same name.

• Corrupt – The file failed validation. When you start the import process, 
the program ignores the file.

Remove Click  to remove a specific design file from the list. This can be 
useful if you select a design file in error, or if you do not want to 
overwrite an existing one.

Start Import Imports the file(s) and closes the dialog box.

Cancel Cancels the import and closes the dialog box.
Data Viewing User Guide 237



4 Data Viewing Reference
Show/Hide Columns
Show/Hide Columns

Figure 88 Show/Hide Columns dialog box

Purpose: Used to select the attributes to be displayed in the Experiment 
Attributes dialog box and the Sample Utility tab. The Sample Utility tab is 
available when you go to Sample Manager. See the Sample Manager User 
Guide for information about Sample Manager.

To open: This dialog box appears when you click Show/Hide Attributes 
at the bottom of the Experiment Attributes dialog box. 

All available attributes are shown in the Attributes column. Attributes 
with a check- mark next to them will be displayed in the Experiment 
Attributes and Sample Utilities tab for each sample. To select an attribute 
for display, mark the Show in Table box next to it. To deselect an 
attribute, clear the Show in Table box again.

Save Saves the current list of selected attributes and updates the Sample 
Utilities table based on the selections.

Select All Selects all the attributes in the list.

Deselect All Clears all check marks from attributes in the list.
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Simple HD Probe Search
Close Closes the dialog box. If changes have been made, the program asks if you 
want to save your changes before closing. 

Simple HD Probe Search

Figure 89 Simple HD Probe Search pane in the Search tab

Purpose: Lets you set up and submit a Simple HD Probe Search job to the 
eArray Web site. Two main options are available for this type of search:

• Simple Genomic Intervals HD Search – (Available for CGH, 
ChIP- on- chip, and methylation applications) Retrieves probes from the 
Agilent HD probe database on the eArray Web site based on genomic 
coordinates that you enter. 
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• Simple Gene Annotations HD Search – (Available for the CGH 
application type) Retrieves probes from the Agilent HD probe database 
on the eArray Web site based on gene annotations that you enter, such 
as gene symbols or GenBank accession numbers. 

To open: Right- click in the Gene View, and select Simple HD Search.

Search
Parameters

The table below describes the search parameters that can appear. You 
must set the Search Name, the Species, the Select HD Search by setting, 
and one or more Genomic Intervals or Gene Annotations. All other 
parameters are optional, or can be left as is.

NOTE For more information on search functions for the eArray Web site, see the eArrayXD User 
Guide.

Parameter Instructions/Details

Job Information

Search Name Type a name that will help you to identify this search job and its 
results. 

Species Select the desired species. The species that appear in the list 
reflect the species available in the HD probe database for your 
application type.

Build Number (Read-only) The name of the applicable genome build for the 
selected species. The HD probe database only contains probes 
designed to the most current genome build for each species.
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Probe Options

Filters Select one of the options below. If relevant, type a value for the 
filter in FIlter Value. Filters restrict the list of returned probes, 
based on specific criteria.

• None – The search does not apply any of the filters in the list.
• Average Spacing – In Filter Value, type the desired number of 

base pairs. This defines the average number of base pairs 
between the centers of the retrieved probes in each genomic 
interval. 

• Probes Per Interval – In Filter Value, type the desired number 
of probes. This defines the maximum number of probes that 
HD Search retrieves for each genomic interval. 

• Total Probes – In Filter Value, type the desired number of 
probes. This defines the total number of probes HD Search 
collectively retrieves for all specified genomic intervals. 

Filter Value (Available if you select a filter) Type the desired value for your 
selected filter. 

Prefer Catalog Probes (Available for HD-CGH probe searches, if you select a filter) To 
give preference to Agilent catalog probes in the probe selection 
process, mark this check box. If two probes are close to each 
other for a given probe interval, HD search selects the Agilent 
catalog probe.

Use TM Filter Removes probes with Tms that produce unsatisfactory results on 
the Agilent platform. The search always applies this filter.

Similarity Filter The options below can appear. The availability of specific options 
depends on species and application type.

• No Filter – The program does not apply a similarity filter. If you 
select this option, the Use Non-Unique Probe Filter check box 
becomes available (see below). Non-unique probes map to 
more than one location in the target genome.

• Perfect Match Filter – Removes a probe from the search 
results if it has more than one perfect match in the genome of 
the selected species.

• Similarity Score Filter – Removes a probe from the search 
results if it is designed to a given genomic region, but it also 
has significant similarity to other parts of the target genome. 
Probes such as this can cause cross-hybridization problems.

Parameter Instructions/Details
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Use Non-Unique Probe Filter (Available if you select no similarity filter) Mark this check box to 
remove a probe if it maps to multiple locations in the target 
genome. 
You can set the stringency of this filter. See below, “Max Perfect 
Genomic Hits”.

Max Perfect Genomic Hits (Available if you select no similarity filter, and mark Use 
Non-Unique Probe Filter) Sets the maximum number of 
locations to which a probe can map in the target genome, and 
still pass the non-unique probes filter. Type the desired number of 
locations.
Example: Probe A maps to two locations in the target genome, 
and Probe B maps to three locations. You select No Filter in 
Similarity Filter, mark Use Non-Unique Probe Filter, and type 2 in 
Max Perfect Genomic Hits. The filter removes Probe B, but does 
not remove Probe A.

Interval Options

Select HD Search by Genomic Intervals – Sets up the search to retrieve probes based 
on genomic intervals that you enter.
Gene Annotations – Sets up the search to retrieve probes based 
on gene annotations that you enter, such as gene symbols or 
GenBank accession numbers. 

Extend Interval Boundary Type the number of 5' base pairs and 3' base pairs by which to 
move out the start and end points of all of your genomic intervals. 
This can help retrieve additional probes that lie outside the 
initially defined regions of your genomic intervals.

Example: You type 500 in 5' base pairs and 300 in 3' base pairs. 
eArray extends an original interval of 9000–10000 to 8500–10300.

Genomic Intervals (Available if you select Genomic Intervals in Select HD Search 
By) Type either a chromosomal location or a cytoband in the box. 
Separate multiple intervals with pipe “|” characters. All of the 
intervals must be of the same type. For information about how to 
enter genomic intervals, see the eArrayXD User Guide.

Upload – Opens a File Upload dialog box, where you can upload a 
file of chromosomal locations or cytobands. 

Parameter Instructions/Details
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Gene Annotations (Available if you select Gene Annotations in Select HD Search 
By) Type a gene annotation such as a GenBank accession 
number (for example, NM_016660 or AY884282) or a gene symbol 
(for example, H3N2 or CTSB) in the box. Use pipe “|” characters 
to separate multiple annotations. eArray resolves annotations to 
genomic intervals before it starts your search.

Upload – Opens a File Upload dialog box, where you can upload a 
*.txt file of gene annotations. In the file, list one accession or 
gene symbol per line. In a given search, the annotations must all 
be of the same type. 

Include Regions (Available only for HD-CGH searches) Select one of the options 
below. You can use this parameter to limit your HD-CGH probe 
search to only exonic, or only intragenic regions of the genome.

• All – Retrieves probes in all of the specified genomic region, 
both within and outside of gene boundaries.

• Exonic – Retrieves probes in exonic sequences within genes 
in the specified genomic region. When you select this option, 
the Gene Confidence list becomes available. Select the 
appropriate Gene Confidence. See below.

• Intragenic – Retrieves probes found within gene boundaries, 
whether or not they are found in exonic sequences. When you 
select this option, the Gene Confidence list becomes available. 
Select the appropriate Gene Confidence.

Gene Confidence (Available if you select Exonic or Intragenic in Include Regions. 
See above, “Include Regions.”) Select the desired gene 
confidence level. This level reflects the relative confidence in the 
source defining the gene boundaries. For example, High 
confidence genes have known proteins defined for them. If you 
set Gene Confidence to Low, the search returns all High and 
Medium confidence genes as well as ESTs and predicted genes.

Parameter Instructions/Details
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Search Submits the search job to the eArray Web site.

Reset Clears all parameters, or restores them to their default values.

Exclude Options

Standard Exclusion Interval(s) eArray lets you select from among many sets of standard 
exclusion intervals, based on annotation tracks. To ignore 
genomic regions defined in one or more of these sets, mark this 
option, then select the desired set(s) from the list that appears. 
Control-click the names of additional sets to select them.

Custom Exclusion Interval(s) To ignore the genomic intervals defined in a file of genomic 
intervals, mark this option. 

Upload – Opens a File Upload dialog box, where you can upload a 
file of the desired genomic intervals. 

You can set both standard and custom exclusion intervals in the 
same search.

Parameter Instructions/Details
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Track

Purpose: This dialog box lets you view the chromosome locations in the 
track.

To open: Click the Details link for the desired track in the Tracks tab of 
the Preferences dialog box. See “User Preferences” on page 250.

Track Parameters These parameters appear:

Figure 90 Track details

Parameter Description

Name The name of the track.

Species The species to which the track applies.
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Data Tracks must contain entries for at least these four columns in the table:

The other columns are additional BED track file columns that can appear 
for some tracks. Agilent Genomic Workbench does not display these.

Close Closes the Track dialog box.

Format The format of the track data. Agilent Genomic Workbench supports 
the BED format.

Genome Build The specific genome build of the species to which the track applies.

Description Descriptive text saved with the track.

Parameter Description

Column Description

Chromosome The name of the chromosome

Start The first base pair of the particular feature in the chromosome.

Stop The last base pair of the particular feature in the chromosome.

Name The name of the feature. This name appears next to the defined region 
for the feature.
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UDF Import Summary (CGH or CH3)

Purpose: Reports how many lines of data were successfully imported from 
a UDF file, and how many lines were skipped. Skipped lines can be 
caused by missing chromosome mapping information, or improper 
formatting of the UDF file.

To open: Import a UDF file (see “To import a UDF file” on page 51). This 
dialog box appears after you map the columns of the UDF file.

Table Displays the file name of the imported UDF file, the number of lines that 
were successfully imported, and the number of lines, if any, that were 
skipped during import. If many lines were skipped, review the data for 
improper formatting or missing chromosome mapping information.

OK Closes the dialog box.

Figure 91 UDF Import Summary dialog box 
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Universal Data Importer - Map Column Headers

.

Purpose: Lets you set up a universal data file (UDF) for import. You 
define several properties associated with the UDF, and identify the 
contents of each column of data in the file. You can also save column 
mappings for re- use.

To open: As you go through the UDF import process (see “To import a 
UDF file” on page 51), in the Select data type for experiments dialog box, 
click Continue. See “Select data type for experiments (UDF files – CGH or 
CH3)” on page 235.

Species Info

Select Species Select the species associated with the array data in the UDF. The program 
supports these species:

Select Genome
Build

Sets the species- specific build to use.

Figure 92 Universal Data Importer - Map Column Headers dialog box
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Mapping Info

Select Mapping Applies an existing column map to the current UDF. A column map 
identifies the contents of each column of data. To create a new column 
map for the current UDF, select CUSTOM.

Save Mapping As Saves the column map under a new name. Opens an Input dialog box, 
where you can type a name for the new map. 

ArrayID Info

Virtual Array ID A number that uniquely identifies the data in the UDF. Typically, an 
Agilent microarray slide has a physical Array ID that enables Agilent 
Genomic Workbench to track the data from the slide as it goes through 
the steps of an analysis workflow. A “virtual” Array ID is, by default, a 
system- generated ID that serves the same purpose for data from UDFs. 
You can also create your own virtual Array ID.

Use System
Generated

Barcode

By default, the virtual Array ID assigned to the array data in a UDF is a 
number that is created by the program. To create your own Array ID, 
clear Use System Generated Array ID, then type a new number in 
Virtual Array ID.

Table

This table lets you identify the contents of the columns of data in the 
UDF. The first row of the table gives the column heading information from 
the UDF. The second row contains lists of labels that you apply to each 
column, and the rest of the table displays lines of data from the UDF. If 
the UDF contains data from Agilent CGH arrays, the column headings will 
exactly match the labels in the lists.

In the list below each column heading, select the applicable label. You 
must use each of the labels exactly once, except LogRatio, which you can 
use more than once. These labels are available:

Column Label This column contains:

ProbeName Names of probes.

ChrName Names of chromosomes.
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Reset Clears all the column labels in the second row of the table. If you have 
selected a saved column mapping, this command also clears the labels in 
the saved map.

Import Imports the UDF file with the specified parameters, and opens the UDF 
Import Summary dialog box (see “UDF Import Summary (CGH or 
CH3)” on page 247).

Cancel Cancels the import and closes the dialog box.

User Preferences

Purpose: This dialog box is used to set up preferences for display of 
tracks, data storage locations, and licenses.

To open: From the Home tab, click User Preferences. Or, right- click in 
the Gene View, Chromosome View, or Genome View, and click User 
Preferences.

Start First chromosomal location for each probe.

Stop Last chromosomal location for each probe.

Description Text annotation for the probe.

LogRatio Array data values that correspond to each probe. You can use this 
label more than once.

Column Label This column contains:

NOTE If you select a saved column mapping, then change or reset the column labels in the table, 
the program changes or resets the saved column map as well. 
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Tracks tab

Purpose: To import and set up the appearance of tracks next to the Gene 
View. Tracks are additional graphic displays of genomic information 
loaded from an external file. They align with genomic coordinates in Gene 
View.

To open: In the User Preferences dialog box, click the Tracks tab.

Font Options

Select the font type, style and size for the gene annotations that appear in 
the selected tracks.

Figure 93 User Preferences dialog box - Tracks tab 
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Tracks List

Track Name Name of the track already loaded or imported

Show in UI Mark the check box to display the track next to Gene View.

Show in Report Mark the check box to display the track information in all the reports.

Genomic
Boundaries

Click to use the track to define only the regions that aberration detection 
algorithms will run. You can choose to do this for only one track.

Delete Mark the check box to delete the track from the list. Then, click Delete to 
delete the track from the list. 

Details Click to display all the chromosome locations defined in the track.

Import Click to import new tracks.

Delete Click to delete the tracks selected in the Delete column.

Up Click to move a track up the list.

Down Click to move a track down the list.

Visualization Parameters

Genes These options affect the appearance of the Track and Gene View.

• Orientation – Type a number to set the angle at which the Gene 
Symbols will appear in Gene View and the Track Annotations appear in 
the tracks.

• Show Gene Symbols – Mark to show gene symbols in Gene View, and 
clear the check box to hide them.

Genomic
Boundaries

These options let you include or exclude the Genomic Boundaries from the 
analysis.

Tracks These options affect the appearance of the Track Views.

• Show Annotations – Mark to show the names of the gene regions for 
the tracks, and clear to hide them.

• Show Overlaid – Mark to overlay all the tracks that appear next to 
Gene View, and clear the check box to display the information in 
separate tracks.
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Miscellaneous tab

Purpose: For data/content set- up, this dialog box allows you to set up 
eArray access and to change the location for data.

To open: In the User Preferences dialog box, click the Miscellaneous tab.

eArray User
Details

Sets login details for the Agilent eArray Web site.

• URL – At present, https://earray.chem.agilent.com

• Username – The name registered on the eArray site.

• Password – The password registered on the eArray site.

Error Model The DLRErrorModel (Derivative Log Ratio) is the only selection. This 
measures noise in the data for CGH analyses. 

Data Location The folder where the program stores array data and design files. To select 
a location, click Browse.

Figure 94 User Preferences dialog box – Miscellaneous tab
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Configuration
Parameters

Lets you set or change location for the database server. Do not change 
these unless directed to do so by your network or database administrator.

• Database host – The fully qualified name for the computer that 
contains the Agilent Genomic Workbench database.

• Database port – The port number on which MySQL Server listens for 
its clients.

• Common Storage Location – (for display only) The location of the 
common file storage area used to store and access files created during 
various operations of Agilent Genomic Workbench. The location is set 
during installation of Agilent Genomic Workbench server and cannot be 
changed here. 

Change Click to enable configuration parameters.

Restore Click to restore configuration parameters to the original settings.

Change Writer
Preferences

Opens the File Writer Preferences dialog box, where you select file types 
that eArray creates for new microarray designs (in addition to the 
defaults). See the eArrayXD User Guide for more information.

Edit Proxy
Settings

Opens the Edit Proxy Settings dialog box, where you select to use a proxy 
and type the proxy settings to use.

Edit Server Proxy
Settings

Opens the Edit Server Proxy Settings dialog box, where you select to use a 
proxy server and type the proxy server settings to use.

Apply Applies any changes to the preferences.

OK Accepts any changes and closes the dialog box.

Cancel Cancels all changes and closes the dialog box.
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License tab

Purpose: The License tab allows you to display and update your DNA 
Analytics application license(s). The license enables the analysis 
application, and allows you to use it to analyze array data.

To open: In the User Preferences dialog box, click the License tab.

Host Name Displays the host computer name automatically.

Select Analysis
Application

Select the Agilent Genomic Workbench application for which you have a 
license.

Figure 95 User Preferences dialog box – License tab 
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Server Location Select this option if you have a concurrent user license. To edit this name, 
select Server Location, then type the name of the computer used as your 
license server. If you select this option, the Text License option is 
unavailable.

Text License Select this option if you have an application license (CGH, ChIP, CH3). To 
change the license, delete the old license text, and paste the new license 
text in the box.

OK Accepts any changes you have made, and closes the dialog box.

Cancel Closes the dialog box without changing any license information.

Apply Accepts any changes you have made, but does not close the dialog box.

View coordinates in UCSC browser

Figure 96 View coordinates in UCSC browser
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Purpose: Defines a track to upload to the UCSC Web site so that you can 
see the information in the UCSC Genome Browser.

To open: Right- click in the Gene View, and select Show in UCSC.

Name Type a name for the track. This name identifies the track when it appears 
in lists and displays.

Build (Available if you select User Defined in Set Chromosome Start- Stop.) 
Select the genome build with which to associate the track.

Description Type descriptive text to attach to the track for reference.

Set Chromosome
Start-Stop

This parameter defines the region of the chromosome for which the track 
will be defined. Select one of these options:

• User Defined – Lets you define an arbitrary region of any chromosome. 
If you select this option, select the desired chromosome in 
Chromosome, then type the beginning (Start) and end (Stop) locations 
of the desired interval.

• For complete gene view – The chromosomal region that appears in 
Gene View.

Save as Track in
Genomic

Workbench

Mark the check box to save this track in the Tracks folder in the My 
Entity List pane of the Navigator.

Change Click to open the Choose Track Color dialog box to select the color to use 
for display of the track in the Tracks folder. See “Select Color” on 
page 231.

OK Creates the track and opens the UCSC Web site, where you can display 
the track and associated information. For information on using the UCSC 
Web site, see the help and information provided there.

Cancel Closes the dialog box without creating a track.
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View Preferences

Figure 97 View Preferences dialog box for CGH

Purpose: This dialog box allows you to configure how data and results 
appear in Genome, Chromosome, and Gene views.

To open: In the View tab, click View Preferences. 

NOTE The View Preferences dialog box contents changes depending on what application is 
selected. For information on View Preferences for ChIP and CH3 applications, see the User 
Guide for the applicable module. Not all options are available when you do not have a 
license.
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View Alignment Selects the orientation and rendering style (described below).

Data Visibility For each view, or all views, selects the kind(s) of data and results to 
display. 

In View, select the view you want to configure. To set availability of 
display items for all views, select All views. Some display items are only 
available for certain views. When you select a display item, it enables the 
item for display — for some items, you must take additional steps to 
display them. For example, you may need to configure a specific algorithm 
in the toolbar.

Mark any of the following options, as available:

Option Description

Orientation

Horizontal Stacks Genome, Chromosome, and Gene views horizontally in the 
main program window. Genomic locations appear across the bottom 
of each view.

Vertical Displays Genome, Chromosome, and Gene views from left to right as 
side-by-side panes in the main program window.

Rendering Style

Overlaid In Chromosome View and in Gene View, displays data and results as a 
single, combined pane for all arrays. (Default)

Stacked In Chromosome View and in Gene View, displays a separate pane for 
each array.

Display item Description/Comments

Scatter Plot The plot(s) of individual log ratio data points.

Scatter Tool Tip The ToolTips that appear when you place the pointer over specific data 
points on the scatter plot(s) in Gene View. The tool tip shows the array 
of origin and the numerical log ratio value for the data point.

Moving Average The result of the Moving Average algorithm. See the CGH Interactive 
Analysis User Guide for more information.

Aberration The result of the selected aberration detection algorithm. See the CGH 
Interactive Analysis User Guide for more information.
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Rendering
Patterns

These options control the specific appearance of data and results in 
Genome, Chromosome, and Gene views. You configure these options 
separately for each type of application design.

• Design Type – Select the application design type for which you want to 
define rendering patterns.

• Styles – Select the display style for each of these elements:

CNVR Detected copy number variant regions. See the CGH Interactive 
Analysis User Guide for more information.

Log Ratio Error 
Envelope

The log ratio error envelope is a visual representation of the log ratio 
error calculated by Feature Extraction.

Penetrance plot The probe penetrance plot for the active experiment. If you select this 
option, all other display items are unavailable. In addition, because the 
probe penetrance plot takes into account all arrays, this option 
overrides the stacked rendering style.

Common Aberration The results of a common aberration analysis. To display this, you must 
first perform a common aberration analysis. See the CGH Interactive 
Analysis User Guide for more information.

Green Intensity Mark the check box to display green raw signal intensity. 

Red Intensity Mark the check box to display red raw signal intensity. 

Display item Description/Comments

Display element Details

Scatter Plot Select the symbol used for log ratio data points in the scatter plots in 
Chromosome and Gene views. 
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Scatter Plot (Chr
View) Point Size

Select a point size to use for display of scatter plot data points in the 
Chromosome View.

Configure Scales For Log Ratios or Signal Intensities plots, mark Apply to enable the 
custom scale. In Range, type the value to use as the range for the scatter 
plot.

Configure
Coloring schemes

Use these options to change the display of the scatter plot in the Gene 
View. These options are the same as those displayed in the Scatter Plot 
ToolTip in the Gene View.

Show Memory
Monitor in Status

Bar

Displays a memory usage monitor in the eighth cell of the status bar. For 
information about the Status Bar, see “Status Bar” on page 161.

OK Applies the changes you made to all preferences and closes the dialog box.

Moving Average Select the line style for the moving average display. Lines appear in 
the display color defined for each array. See the CGH Interactive 
Analysis User Guide for more information.

• Continuous – A solid line.
• Dashed – A dashed line.
• Dotted – A dotted line.
• Do not show area – No line.

Aberration Select the rendering style for detected aberrations.

• Semi transparent filled – Solid, colored regions (in the display 
colors defined for each array, if applicable).

• Hatched – Cross-hatched colored lines (in the display colors 
defined for each array, if applicable). 

• Do not show area – Aberrations do not appear.

Display element Details

NOTE Rendering scatter plots for more than 10 high density arrays in the Chromosome View may 
take significant time. Selecting filled circles as the rendering style for CGH scatter plots can 
also decrease performance. For faster performance, change the rendering style for CGH 
data from the filled circle to the plus (+) or cross hair sign.
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Cancel Closes the dialog box without applying changes.

Apply Applies changes without closing the dialog box.
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