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In This Guide...
This guide describes how to import, organize, manage, export 
and display data and other content (experiments, gene lists, 
tracks) within Agilent Genomic Workbench 5.0. It is targeted 
for users who have no DNA Analytics application license(s). 
If you do have a license and intend to analyze your data, see 
the corresponding User Guide.

1 Importing, Managing, and Exporting Data and Other Content

This chapter describes how to import, organize, manage, and 
export data and other content within the user interface of 
Agilent Genomic Workbench.

2 Visualizing Data and Other Content

This chapter shows you how to display log ratio data from 
imported feature extraction data files, as well as gene list 
and track content, in the Genomic Viewer. It also gives you 
instructions on how to modify the display to visualize the 
data and content the way you prefer.

3 Data Viewing Reference

This chapter describes the parts of the Genomic Workbench 
main window that you use to import, organize, manage, 
export and display array data and other content. It also 
details the relevant tab commands, shortcut menus, and 
dialog boxes that can appear. 
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Agilent Genomic Workbench 5.0 – Data Viewing
User Guide
1
Importing, Managing, and Exporting 
Data and Other Content

Importing Files 12

Working with Experiments to Organize Imported Data 24

Managing Content (Data, Gene Lists, Tracks) 30

Exporting and Saving Content 37

Use this guide if you have no DNA Analytics application license(s). It does 
not cover any analysis, or pre-  or post- analysis tasks. This chapter 
describes how to import, organize, manage, and export data and other 
content within the user interface of Agilent Genomic Workbench.

The program lets you import many different kinds of files, including array 
data and design files from Agilent products and other sources, and other 
content such as annotation tracks. 

To find out how to display log ratio data from imported feature extraction 
data files, as well as gene and track content, in the Genomic Viewer, see 
Chapter 2, “Visualizing Data and Other Content”.

To learn about the options for the main window and the dialog boxes for 
importing, organizing, managing and exporting data, see Chapter 3, “Data 
Viewing Reference”.

See the Agilent Genomic Workbench 5.0 Quick Start Guide for an 
overview of all the applications you can use with this software, both those 
that require a license and those that are free capabilities.
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1 Importing, Managing, and Exporting Data and Other Content
Importing Files

You can use the Home tab to import many kinds of files into Genomic 
Workbench. The table below summarizes the kinds of files you can import, 
and the topics in this section that describe how to import them.

Type of file Comments See these topics

Microarray data files • Agilent Feature Extraction 
(*.txt) data files

• GenePix/Axon (*.gpr) data 
files

• Universal Data Files (UDFs) 
(*.txt files)

“To import Agilent FE or 
GenePix/Axon data files” on 
page 13
“To import a UDF file” on 
page 15

Microarray design files • Agilent GEML (*.xml) design 
files

• GenePix/Axon (*.gal) design 
files

“To import Agilent GEML 
design files” on page 18
“To import GenePix/Axon 
design files” on page 19

Genome builds Agilent-supplied genome 
information for human, mouse 
and rat genomes

“To import a genome build” on 
page 19

Tracks BED format annotation track 
files

“To import tracks” on page 20

Array attributes .txt files that you have created 
yourself or previously exported 
from Agilent Genomic 
Workbench

“To import array attributes” on 
page 22

Experiments ZIP format file of experiments 
exported from DNA Analytics

“To import an experiment 
file” on page 23

NOTE To import Attribute Files, you use the Sample Manager tab. See the Sample Manager 
Guide.
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Importing, Managing, and Exporting Data and Other Content 1
To select a new location for data files

By default, the program stores design, data and experiment files in C:\
Program Files\Agilent\Genomic Workbench Standard (or Enterprise) 
Edition 5.0\data. If you like, you can select a different location. 

1 In the Home tab, click User Preferences...

The Preferences dialog box appears. See “Preferences – 
Miscellaneous” on page 163.

2 In the Miscellaneous tab, under Data Location, click Browse...

An Open dialog box appears.

3 Select a location, then click Open.

The selected location appears in the Preferences dialog box, in Data 
Location.

4 Click OK.

To import Agilent FE or GenePix/Axon data files

You can import several types of microarray data files into Genomic 
Workbench:

• Agilent Feature Extraction (FE) *.txt data files

• GenePix/Axon (*.gpr) data files

• Universal Data Files (UDFs) (*.txt files) See “To import a UDF file” on 
page 15 for instructions on how to import this file type.

If you import Agilent Feature Extraction files, the program requires the 
representative GEML array design files. If you import GenePix/Axon data 
files, the program requires the representative GenePix/Axon *.gal design 
files. See “To import Agilent GEML design files” on page 18 or “To import 
GenePix/Axon design files” on page 19.

1 In the Home tab, do one of the following:

• To import Agilent FE data files, click Import > Array Files > FE 
File...

• To import GenePix/Axon data files, click Import > Array Files > 
Axon File...
Data Viewing User Guide 13



1 Importing, Managing, and Exporting Data and Other Content
A dialog box appears. Only data files of the appropriate type appear. 
See “Import” on page 147.

2 To select a file for import, click its name. To select additional files, 
control- click their names.

3 Do one of the following:

• For Agilent FE files, click Open.

• For GenePix/Axon files, click Import.

In either case, the Agilent Feature Extraction Importer dialog box 
appears. See “Agilent Feature Extraction Importer” on page 104.

4 Set the following, as needed:

s

5 Do one of the following:

• To import the file(s) while you wait, click OK.

• To import the file(s) in the background, click Run in Background. 
This allows you to work while the program imports the files.

Setting Comments

Name The names of imported arrays are often cryptic. You can give 
any array a more meaningful label.
a Double click the name of the array.
b Edit the name, as desired.
c Press Enter (Return on a Mac).

Dye Flip For each array:
• Select Normal if:

• The test samples were labeled with cyanine-5 (red).
• The control samples were labeled with cyanine-3 (green).
• The imported ration (test/control) should be reported 

directly.
• Select Flipped if:

• The test samples were labeled with cyanine-3 (green).
• The control samples were labeled with cyanine-5 (red).
• The imported ratio (control/test) should be reported with 

the ratio inverted (test/control).
The program does not combine dye-flip pairs.

Overwrite arrays with 
duplicate names

If you mark this option, the program deletes an existing array 
data file if it has the same name as one you import.
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Importing, Managing, and Exporting Data and Other Content 1
To import a UDF file

UDF files are plain text files that contain array data in tab- delimited 
format. Files must contain the following six columns of information, in 
any order:

• Probe name

• Chromosome name

• Start position

• Stop position

• Description

• Signal intensity data (The file can contain additional columns, each 
with data from an additional array.)

When you import a UDF file, the program creates a new design based on 
the information you provide during import, and the information in the file 
itself. This design contains all of the arrays represented in the file. The 
program also creates and populates a new experiment that contains the 
arrays. 

1 In the Home tab, click Import > Array Files > UDF File...

The UDF Files dialog box appears. See “Import” on page 147. Only *.txt 
files appear in the dialog box.

2 Select the desired UDF file, then click Open.

The Select data type for experiments dialog box appears. See “Select 
data type for experiments (UDF files – CGH or CH3)” on page 174.

3 For each array, set the following, as needed:

Setting Comments

Experiment Name By default, the program creates an experiment with the same 
name as the imported file. To change the name:

a Double click the name.
b Edit the name as desired.
c Press Enter.
Data Viewing User Guide 15



1 Importing, Managing, and Exporting Data and Other Content
4 Click Continue.

The Universal Data Importer – Map column headers dialog box appears. 
The main table in the dialog box contains the first few rows of data 
from the file. Column headings derived from the first line of the file 
appear at the top of the table as a guide, but the program does not 
interpret these headings. See “Universal Data Importer -  Map Column 
Headers” on page 180.

5 Below each column heading, select the label that identifies the content 
of the column. Use each label exactly once, except for LogRatio, which 
you can use many times. Alternatively, in Select Mapping, select a 
saved column map.

These options are available:

6 Under Species Info, select the species and Genome Build appropriate 
to the data in the file.

Data type • Select the mathematical form of the signal intensity data for 
the array. The options are ratio, log2 ratio, log10 ratio, and 
ln ratio.

Design type • Select cgh, expression, or CH3.

Column Label This column contains:

ProbeName Names of probes.

ChrName Names of chromosomes.

Start First chromosomal location to which each probe is designed.

Stop Last chromosomal location to which each probe is designed.

Description Text annotation related to the probe.

LogRatio Array data values that correspond to each probe. You can use this 
label more than once.

Setting Comments
16 Data Viewing User Guide



Importing, Managing, and Exporting Data and Other Content 1
7 If you expect to import many similar UDFs in the future, follow these 
steps to save the column map:

a Under Mapping Info, click Save Mapping As.
An Input dialog box appears.

b Type a name for the column map, then click OK.
The name of the saved map appears in Select Mapping.

In the future, you can select this mapping and apply it to any UDF file 
that you import.

8 By default, the program creates a “Virtual Barcode” that becomes the 
Chip Barcode attribute for the array(s) in the UDF. To substitute a 
Virtual Barcode of your own choosing, follow these steps:

a Under Barcode Info, clear Use System Generated Barcode.

b Double- click the number in Virtual Barcode, then type the desired 
new Virtual Barcode.

9 Click Import.

The program validates your column mapping. A dialog box appears. If 
you need to fix the column map, the dialog box details the missing 
column label(s). If the column map is complete, a message asks if you 
want to import additional files with the same mapping.

10 Do one of the following:

• If you want to import additional files with the same column 
mapping, follow these steps to include these files in the import:

a Click Yes.
The UDF Files dialog box appears.

b Click the name of a file to select it for import. Control- click the 
names of additional files.

c Click Open.

• If you do not want to include additional file(s) in the import, click 
No.

The Program imports all requested files, and the UDF Import Summary 
dialog box appears. This dialog box lists the imported files, the number 
of lines of data that were imported for each file, and the number of 
lines that were skipped, if any. If a file name appears in red, the 
program may not have imported the file. See “UDF Import Summary 
(CGH or CH3)” on page 179.

11 Click OK.
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1 Importing, Managing, and Exporting Data and Other Content
In the Data pane, in the appropriate design type folder within the Data 
folder, a new design folder appears. The design folder contains the 
imported array data.

A new experiment appears in the Experiments folder in the Experiment 
pane, populated with array data. This experiment bears the name of the 
imported UDF file, unless you changed it during import.

To import Agilent GEML design files

You must import Agilent GEML (*.xml) microarray design files into 
Genomic Workbench that match the Agilent Feature Extraction data files. 
Your imported GEML files contain array- specific information such as 
probe names, annotations, and chromosomal locations, and are associated 
with a specific genome build.

1 In the Home tab, click Import > Design Files > GEML File...

The Import Design Files dialog box appears. See “Import” on page 147. 
The dialog box shows only *.xml files.

2 To select a file for import, click its name. To select additional files, 
control- click their names.

3 Click Open.

The program validates the selected file(s), and the Import GEML Design 
Files dialog box appears. See “Import GEML design files” on page 150.

If a design file fails validation, Corrupt appears in the Status column 
beside it, and the program will not import the file. To remove the 
corrupt array from the list, click its Remove button .

4 Click Start Import.

The program imports the file(s). The files appear as new design folders 
in the Data folder of the Navigator with the genome build as a node 
within the folder.

You can import two design files with the same name, but associated 
with different genome builds. If you do, the program creates a single 
design folder with two nodes, one for each genome build.
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Importing, Managing, and Exporting Data and Other Content 1
To import GenePix/Axon design files

You can import GenePix/Axon (*.gal) microarray design files into Genomic 
Workbench. The program requires the GenePix/Axon design files that 
match all GenePix/Axon array data files you import.

1 In the Home tab, click Import > Design Files > Axon File...

The Import Axon Design Files dialog box appears. See “Import” on 
page 147. The dialog box shows only *.gal files.

2 To select a file for import, click its name. To select additional files, 
control- click their names.

3 Click Import.

The program validates the selected file(s), and the Set genome build 
and species for Axon design files dialog box appears. See “Set genome 
build and species for Axon design files” on page 175.

If a design file fails validation, Corrupt appears in the Status column 
beside it, and the program will not import the file. To remove the 
corrupt array from the list, click its Remove button .

4 For each design file, select the appropriate Species and Genome Build.

5 Click Start Import.

The program imports the file(s). The files appear as new design folders in 
the Data folder of the Data pane, organized by application (CGH, ChIP, or 
methylation, for example).

To import a genome build

In general, the program uses the genome build specified in the array 
design file, and protects it from changes. If a genome build is not available 
in the program, you can import one. 
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1 Importing, Managing, and Exporting Data and Other Content
1 In the Home tab, click Import > Genome Build...

The Import Genome Build dialog box appears. See “Import Genome 
Build” on page 151.

2 Set the following. All are required.

3 Click OK.

To import tracks

You can import BED format track files into DNA Analytics. Track files 
contain specific features correlated with chromosomal locations, and apply 
to a specific genome build of a given species.

1 In the Home tab, click Import > Track...

The Import Track dialog box appears. See “Import Track” on page 152.

2 Set the following. All are required.

NOTE Use arrays from a single genome build in an experiment.

Setting Instructions

Species • Type the genome’s species of origin, as you would like it to 
appear within the program. 

Build Name • Type the name of the genome build you want to import, as 
you would like it to appear within the program. 

RefSeq File This file contains information on gene locations for Gene View.

a Click Browse...
A dialog box appears.

b Select the desired file, then click Open.

Cyto-band File This file contains the graphic information on the cyto-bands 
for Genome and Chromosome Views.

a Click Browse...
A dialog box appears.

b Select the desired file, then click Open.
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3 Click OK.

The program imports the track. To view the track in Gene View, and to 
manage tracks, see “To show tracks in Gene View” on page 57.

Setting Instructions

Species • Select the species to which the track applies.

Build Name • Select the specific genome build of the species to which the 
track applies.

Track Name • Type a name for the track. 
This name identifies the track within the program, including 
the name that appears if you include the track in Gene View.

Track File a Click Browse...
A dialog box appears.

b Select the name of the track (*.bed) file that you want to 
import.

c Click Open.
The location of the file appears in Track File.
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1 Importing, Managing, and Exporting Data and Other Content
To import array attributes

An array attributes file is a tab- delimited *.txt file that contains a list of 
arrays by barcode, and values for specific array attributes. Attributes are 
pieces of array- specific information, such as the hybridization temperature 
and the name of an array set that contains the array. 

Although you can import array attributes with this function, the Sample 
Manager application lets you import and assign array attributes much 
more easily. See the Sample Manager User Guide. This menu item will be 
eliminated from the next version of the program, and the only way to 
import array attributes will be through the Sample Manager application.

To import an array attributes file

1 Click File > Import > ArrayAttributes.

The Import microarray attributes dialog box appears. See “Import” on 
page 147.

2 Select the desired microarray attributes file, then click Import.

The program imports the file. If the barcodes in the file do not match 
the barcodes of arrays in the program, a dialog box appears. The dialog 
box lists the barcodes in the file that do not match. Click No to stop 
the import process, or click Yes to continue anyway.

Array attributes files must follow these guidelines:

• The first line of the file contains the names of array attributes, 
separated by tabs.

• The first attribute must be Chip Barcode.

• The rest of the lines of the file list the values of each attribute, one 
line per array. The order of attribute values must follow the order of 
attributes in the first line of the file.

Here is an example.

Chip Barcode ArraySet Hyb’d By

251270010402 E986 Maurice R.

251270010423 E986 Maurice R.

251270019455 E986 Maurice R.
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To import an experiment file

In Genomic Workbench, an experiment is a set of links to microarray data 
and design files, and any associated results. A Genomic Workbench 
experiment file is a single ZIP file that contains the design and data files 
associated with one or many experiments. You can import experiment files 
created in Genomic Workbench on another computer, as well as DNAx 4.0 
experiments.

1 In the Home tab, click Import > Experiments.

The Import Experiments dialog box appears. See “Import” on page 147.

2 Select the ZIP file that contains the experiment(s) you want to import, 
then click OK.

The program imports the experiment file. Designs appear as new folders 
in the Data pane, in the applicable design type folder. Array data 
appears within the applicable design folder, organized by genome build. 
In addition, the experiment(s) appear, populated with the appropriate 
arrays, in the Experiment pane. 

NOTE Genomic Workbench experiment files contain all of the design and array data files 
associated with an experiment, but do not include any analysis parameter settings, array 
selections, or analysis results. 

To export the data and design files from one or more experiments, see “To export 
experiments” on page 38.
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1 Importing, Managing, and Exporting Data and Other Content
Working with Experiments to Organize Imported Data

This section describes how to arrange imported array data and designs 
into organizational units called experiments. Experiments, found in the 
Experiment pane of the Navigator, contain links to specific array data and 
design files in the Data pane. After you set up an experiment, you can 
then analyze selected array data within the experiment. 

Because experiments only contain links to the actual data and design 
files, any number of experiments can use a given set of files. In the data 
analysis applications (CGH, ChIP, or methylation, for example), 
experiments also contain saved experiment results.

To view the array designs and data in the program

• To view the directory of data in the program, use the Data pane 
(Figure 1). Double- click a folder to expand or collapse it, or click the  
and  buttons.

Figure 1 Data pane of the Navigator
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In the Data pane, the program organizes design files by the application 
(CGH, ChIP, or methylation, for example) to which they apply. It organizes 
array data files by genome build under the design with which they are 
associated.

You can right- click many elements of the Data pane to open shortcut 
menus. For details, see “Data pane – actions and shortcut menus” on 
page 79.

Many icons can appear in the Data pane. See “Data pane – icons, special 
text, and buttons” on page 78 for a complete list.

The Search pane can help you find specific data files or other content. See 
“To find specific content items in the Navigator” on page 30.

To create a new experiment

To view or analyze data, you must first create an experiment and 
associate the desired data files with it. 

1 In the Home tab, click Create Experiment...

The Create Experiment dialog box appears. See “Create Experiment” on 
page 119.

2 Type a Name and an optional Description for the experiment.

3 Do one of the following:

• To create an empty experiment, and add data to it later, click OK.
The program creates the experiment. To add arrays to the 
experiment later, see “To add arrays to an experiment” on page 26.
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1 Importing, Managing, and Exporting Data and Other Content
• To create an experiment and populate it with data now, follow these 
steps: (You can add or remove data from the experiment later, as 
well.)

a Click Properties.
The Experiment Properties dialog box appears. See “Experiment 
Properties” on page 133.

b Under Select Design, select the design and genome build 
associated with the desired array data.
The applicable arrays appear in Array List.

c In Array List, click the name of an array that you want in your 
experiment. Control- click the names of additional arrays.

d Click .
The program transfers the selected arrays to the Selected Array 
List.
The dialog box also gives you other options for adding arrays. See 
“Experiment Properties” on page 133 for details.

e Click OK.
The program creates the new experiment, and populates it with 
the selected arrays.

In both cases, a folder with the name of the new experiment appears in 
the Experiment pane.

To add arrays to an experiment

After you create an experiment, or import one, you can add arrays to it. 

1 In the Experiment pane, double- click the Experiments folder to expand 
it.

2 Right- click the name of the desired experiment, then click Show 
Properties.

The Experiment Properties dialog box appears. See “Experiment 
Properties” on page 133.

3 Under Select Design, select the design file and genome build associated 
with the arrays you wish to add.

The arrays associated with the selected design file and genome build 
appear in Array List.
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4 In Array List, select the arrays you wish to add to the experiment. To 
select a single array, click its name. To select additional arrays, 
control- click their names. 

5 Click .

The program transfers the selected arrays to the Selected Array List.

The dialog box also gives you other options for adding arrays. See 
“Experiment Properties” on page 133 for details.

6 Click OK.

If needed, the program adds appropriate design and genome build 
folders to your experiment folder in the Experiment pane. It places the 
arrays you selected in the appropriate genome build folder.

To change the order of arrays in an experiment

You can change the order in which arrays appear in an experiment in 
tables in Tab View. If you choose to display separate scatter plots in Gene 
View and Chromosome View for each array, the array order also 
determines the order in which these plots appear. 

1 In the Experiment pane, right- click the name of the desired experiment, 
then click Edit Array Order...

The Edit Array Order dialog box appears. See “Edit Array Order” on 
page 132.

2 In Design, select the design that contains the arrays whose order you 
want to change.

The arrays from the selected design appear in Array Name.

3 Do any of the following:

• To move an array up in the list, click its name, then click .

• To move an array down in the list, click its name, then click .

• To sort the list based on a specific microarray attribute, select the 
desired attribute in Order by.

4 Click OK.
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To rename an array in an experiment

When you rename an array in an experiment, you change the array’s name 
only within the context of the given experiment. The name of the array 
remains unchanged in the Data pane, and in other experiments.

1 Expand the folders in the Experiment pane until you can see the array 
you wish to rename.

2 Right- click the name of the desired array, then click Rename.

An Input dialog box appears.

3 Type the new name for the array, then click OK.

To remove arrays from an experiment

When you remove arrays from an experiment, you only remove the links 
between the experiment and the data files. The files remain available in 
the program for use in other experiments. To completely remove files from 
the program, see “To remove data or design files from the program” on 
page 33.

1 In the Experiment pane, expand folders until you can see the desired 
experiment, and the array(s) that you want to remove from it.

2 In the Arrays or Calibration Arrays folder of the desired experiment, 
click the name of an array to select if for removal. Control- click the 
names of additional arrays.

3 Right click one of the selected array names, then click Delete.

A Confirm dialog box appears.

4 Click Yes.

The program removes the links between the experiment and the 
selected array data files. If the removal of arrays leaves a design folder 
in the experiment empty, the program removes this folder as well. 
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To edit the attribute values of a specific array

Array attributes are pieces of array- specific information such as chip 
barcode or hybridization temperature. You can view a list of attributes for 
each array that is available in the program. 

1 Expand the folders of the Data pane or the Experiment pane until you 
can see the array of interest.

2 Right- click the name of the array, then click Show Properties.

The Microarray Properties dialog box appears, with a list of array 
attributes. See “Microarray Properties -  Attribute Tab” on page 154. You 
can also edit the attributes of a specific array from this dialog box. In 
addition, if the array is an Agilent array, you can view header and 
feature information passed through from the Agilent Feature Extraction 
program. 

3 When you are finished, click Close.

NOTE You use the Sample Manager tab to organize, create, import, and export array attributes. 
See the Sample Manager User Guide.
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Managing Content (Data, Gene Lists, Tracks)

This section describes how to create, find, rename, update, combine, 
and/or remove several types of content stored in Genomic Workbench. To 
display the data, gene list and track content, see Chapter 2, “Visualizing 
Data and Other Content”.

To view a list of the content stored in the program

The Data and My Entity List panes of the Navigator show the content 
stored in Genomic Workbench.

Data pane – Shows all of the array data files stored in the program, 
organized by application (CGH, ChIP, or methylation, for example), then 
by array design, then by applicable genome build. For more information, 
see “To view the array designs and data in the program” on page 24.

My Entity List pane – Shows the gene lists and tracks stored in the 
program. To view the names of gene lists or tracks available in the 
program, double- click the names of folders to expand or collapse them, or 
click the  or  buttons.

To find specific content items in the Navigator

At the top of the Navigator is a search pane that can help you find 
specific content items. See “Search pane” on page 76.

1 Type a search term in the box at the top of the Navigator. The search 
term is not case- sensitive, but it must reflect the entire name of the 

NOTE Content that is available exclusively in the eArray tab, such as the probes and probe groups 
that you use to create custom microarray designs, is covered in a separate guide. See the 
eArrayXD User Guide.
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content item that you want to find. You can use asterisks (*) as 
wildcards to represent a group of unspecified characters.

2 By default, the program searches all panes of the Navigator. To restrict 
your search to a specific pane, click . In the list that appears, select 
the desired pane.

3 Click .

The program searches the selected pane(s). If it finds item(s) that 
match your search term, it expands folders so that the items are visible, 
and highlights them in red. You may need to scroll down to see 
retrieved items.

4 To clear the results of a search, click .

To view the properties of a specific design

Design properties include general information about a design, such as its 
name, application type, and associated species. They also include a list of 
the names and chromosomal locations of probes.

1 Expand the folders of the Data pane until you can see the genome 
build folder(s) within the desired design folder.

2 Right- click the desired genome build folder, then click Show Properties.

The Design Properties dialog box appears. See “Design Properties” on 
page 125.

To update probe annotation in design files

Agilent regularly updates probe annotations on its eArray Web portal. If 
you have imported Agilent array designs into Genomic Workbench, and 
you are a registered eArray user, you can update those design files from 
within Genomic Workbench. For more information about eArray, go to 
earray.chem.agilent.com and click Help. 

1 In the Home tab, click User Preferences.

The Preferences dialog box appears.
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2 In the Miscellaneous tab, under eArray User Details, type your eArray 
Username and Password. See “Preferences – Miscellaneous” on 
page 163. 

3 Click OK.

4 Expand the folders of the Data pane until you can see the design that 
you want to update.

5 Right- click the desired design, then click Update from eArray. This 
option appears only for Agilent designs.

A confirmation dialog box appears.

6 Click Yes.

The program downloads an updated design, if one is available.

To rename an array in the Data pane

This topic describes how to rename an array in the Data pane. 

1 Expand the folders of the Data pane until you can see the array you 
want to rename.

2 Right- click the name of the array, then click Rename.

An Input dialog box appears.

3 Type a new name for the array, then click OK.

The program renames the array.

If you rename an array in this way, and subsequently add the array to an 
experiment, the array appears in the experiment with the new name. 
However, the name of the array is unaffected in any experiment to which 
it is already linked. To rename an array only within the context of a 
specific experiment, see “To rename an array in an experiment” on 
page 28.
32 Data Viewing User Guide



Importing, Managing, and Exporting Data and Other Content 1
To remove data or design files from the program

You can delete array design and data files from the program when you are 
finished with them.

1 If an array that you want to delete is associated with an experiment, 
first delete it from the experiment. See “To remove arrays from an 
experiment” on page 28.

2 In the Data pane, expand folders until you can see the design folder or 
array that you want to delete.

3 Do one of the following:

• For array data files, click the name of the first array, then 
control- click the names of additional arrays within the same design. 

• For array design folders, click the name of the first design folder, 
then control- click the names of additional ones. This selects the 
designs and all array data files within them for deletion.

4 Right- click the name of a selected design folder or array data file, then 
click Delete.

A confirmation dialog box appears.

5 Click Yes.

The program deletes the selected files.

CAUTION When you delete files, you permanently remove them from Genomic Workbench. To 
restore deleted files, you must import them again.
Data Viewing User Guide 33



1 Importing, Managing, and Exporting Data and Other Content
To create a gene list

When you create a gene list, you create a list of the genes in a contiguous 
chromosomal region that you define. 

1 Follow these steps to define a chromosomal region for your gene list. If 
you know the exact start and end locations of the desired chromosomal 
region, skip to step 2.

a In Genome View, select the desired chromosome.
The selected chromosome appears in Chromosome View.

b In Chromosome View, in the plotting area to the right of the 
chromosome, drag the pointer over the approximate desired 
chromosomal region.
The program encloses the region in a blue box, and displays the 
region in greater detail in Gene View.

c In Gene View, adjust the view so only the genes of interest appear. 
For a description of the adjustment commands available in Gene 
View, see “Gene View” on page 92.

2 Right- click anywhere within the log ratio plotting area in Gene View, 
then click Create Gene List...

The Create Gene List dialog box appears. See “Create Gene List” on 
page 121.

3 In the dialog box set the Name, Description and Color.

4 In the dialog box select the desired chromosomal region for the new 
gene list.

5 Click OK.

The new gene list appears in the Navigator in the Gene List folder.

To rename a gene list 

The name of a gene list identifies it within the Gene List folder of the My 
Entity List pane. You can rename gene lists.

1 Expand the folders of the My Entity List pane until you can see the 
gene list that you want to rename.

2 Right- click the desired gene list, then click Rename.

3 Type a new name for the gene list, then click OK.
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To delete gene list(s)

1 In the My Entity List pane of the Navigator, expand the Gene List 
folder.

2 Click the name of a gene list that you want to delete. Control- click the 
names of additional gene lists. 

3 Right- click one of the selected gene lists, then click Delete.

A confirmation dialog box appears.

4 Click Yes.

To create a track (CGH only)

When you create a track, you create a list of the genes in a contiguous 
chromosomal region that you define, but only for the CGH application. 

1 Follow these steps to define a chromosomal region for your track. If 
you know the exact start and end locations of the desired chromosomal 
region, skip to step 2.

a In Genome View, select the desired chromosome.
The selected chromosome appears in Chromosome View.

b In Chromosome View, in the plotting area to the right of the 
chromosome, drag the pointer over the approximate desired 
chromosomal region.
The program encloses the region in a blue box, and displays the 
region in greater detail in Gene View.

c In Gene View, adjust the view so only the genes of interest appear. 
For a description of the adjustment commands available in Gene 
View, see “Gene View” on page 92.

2 Right- click anywhere within the log ratio plotting area in Gene View, 
then click Create Track.

The Create Track dialog box appears. See “Create Track (CGH only)” on 
page 123.

3 In the dialog box set the Name, Description and Color.

4 In the dialog box select the desired chromosomal region for the new 
track.

5 Click OK.
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The new track appears in the Tracks folder of My Entity List pane in 
the Navigator.

To view the details of a track

The table that you bring up contains the values for a list of track 
attributes.

1 In My Entity List pane, expand the Tracks folder to see the track.

2 Right- click the name of the track, then click View Details.

Track data appears in a Track table. See “Track” on page 177.

To rename a track

The name of a track identifies it both within the Tracks folder of the My 
Entity List pane, and in Gene View when you select Show in UI for the 
track. You can rename tracks.

1 Expand the folders of the My Entity List pane until you can see the 
track that you want to rename.

2 Right- click the desired track, then click Rename.

3 Type a new name for the track, then click OK.

To delete tracks

1 In the My Entity List pane of the Navigator, expand the Tracks folder.

2 Click the name of a track that you want to delete. Control- click the 
names of additional tracks. 

3 Right- click one of the selected tracks, then click Delete.

A confirmation dialog box appears.

4 Click Yes.
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Exporting and Saving Content

This section describes how to export several kinds of files from the 
program. 

To export array attributes

You can export selected array attributes for any imported arrays that you 
choose. You first select the arrays and then the attributes that you want 
exported for your array selection. You can access this capability from the 
Home tab or the short- cut menu for an experiment.

1 Click Home > Export > Array Attributes...

OR

In the Experiment pane of the Navigator, right- click an experiment of 
interest, and click Export Attributes.

The Export Array Attributes dialog box appears with the Array tab 
displayed. See “Export Array Attributes – Array” on page 137.

If you opened this dialog box by right- clicking an experiment, only 
those arrays associated with the experiment appear in the Selected 
Array List. You can add or subtract from the list.

2 Under Select Design, select the design file and genome build associated 
with the arrays you wish to add.

The arrays associated with the selected design file and genome build 
appear in Array List.

3 In Array List, select the arrays whose attributes you intend to export. 
To select a single array, click its name. To select additional arrays, 
control- click their names. 

4 Click .

The program transfers the selected arrays to the Selected Array List.

5 Click Next to choose attributes for the selected arrays.

The Export Array Attributes dialog box appears with the Attribute tab 
displayed. See “Export Array Attributes – Attribute” on page 139.
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All of the attributes for the arrays are already located in the Selected 
Attribute List. If you don’t want all the attributes exported, then you 
must transfer those to the Available List.

6 In the Selected Attributes List, highlight those attributes you do not 
intend to export.

7 Click .

8 Click OK.

The Export dialog box appears. See “Export” on page 135.

9 Select the folder in which to locate the attributes, and click Export.

The attributes will be saved to the selected folder as a .txt file.

To export experiments

You can export experiments as a ZIP file to transfer them to another 
computer. Exported experiments contain the associated design and array 
data files, only. The program does not export information about array 
selections, or any analysis parameters or results.

1 In the Home command ribbon, click Export > Experiments...

The Export Experiments dialog box appears. See “Export 
Experiments” on page 141.

2 Mark the experiments that you want to export. To export all 
experiments, click Select All.

3 In Export Format, select one of these options: 

• 5.0 Format – Exports the experiment(s) in a format that you can 
import into Genomic Workbench. This is the most current experiment 
format, but it is not compatible with previous versions of the 
program.

• 3.0 Format – Exports the experiment(s) in a format that you can 
import into Agilent CGH Analytics 3.0 or later. This is a “legacy” 
format that you can use to maintain compatibility with earlier 
versions of the program.

4 Click OK.

An Export dialog box appears. See “Export” on page 135.

5 Select a location and type a name for the exported ZIP file.
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6 Click Export.

The program exports all selected experiment(s) together as a single ZIP 
file. 

To export filters (CGH only)

You can export selected array, feature, and aberration filters that are 
available in the data analysis applications in Genomic Workbench. The 
program exports all selected filters as a single *.xml file that you can 
re- import at a later time.

1 In the Home tab, click Export > Filters...

The Export Filters dialog box appears. See “Export Filters (CGH 
only)” on page 142.

2 Under Export, mark the check boxes beside the filter(s) that you want 
to export. To select all filters for export, click Select All.

3 Click OK.

An Export dialog box appears.

4 Select a location and type a name for the exported file, then click 
Export.

The program exports all selected filters as a single *.xml file.

To export a gene list

You can export a gene list as a text file that contains one gene per line.

1 In the My Entity List pane, in the Gene List folder, right- click the gene 
list that you want to export, then click Save As.

A Save As dialog box appears.

2 Select a location and type a name for the file.

3 Click Save.

A success message appears.

4 Click OK.
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To export tracks

You can export selected tracks as a BED format track file. You can then 
import this file into Genomic Workbench on another computer, or into a 
genome browser that accepts BED format files.

1 In the Home tab, click Export > Tracks...

The Export Tracks dialog box appears. See “Export Tracks” on 
page 144.

2 Mark the tracks that you want to export. To select all tracks for export, 
click Select All.

3 Click OK.

An Export dialog box appears.

4 Select a location and type a name for the exported track file, then click 
Export.

The program exports the track(s) as a single BED format track file.

To copy what you see in the main window

You can copy panes of the main window to the clipboard as images, and 
then paste them into a new document in another program (such as Word, 
or PowerPoint). The images contain only what actually appears on your 
screen — regions to which you must scroll are not included.

1 In the View tab, click Copy.

2 In the shortcut menu that appears, click the name of the pane that you 
want to copy. You can copy any view, or the Navigator. To copy all of 
the panes, click All.

The program copies the selected pane(s) to the clipboard.

3 Open a document in a program that accepts images. In that program, 
click Edit > Paste, or the appropriate paste command.
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To copy the list of array colors for an experiment

You can copy the list of arrays in an experiment, and the colors assigned 
to them, to the clipboard as an image. You then paste the image into a 
document in another program such as Word or PowerPoint.

1 In the Experiment pane, expand the Experiments folder.

2 Right- click the name of the desired experiment, then click Edit Array 
Color...

The Edit Array Color dialog box appears. See “Edit Array Color” on 
page 131.

3 In the dialog box, click Edit > Copy.

The program copies the names of the arrays and their colors to the 
clipboard as an image.

4 Open a program that accepts images. Click Edit > Paste, or the 
appropriate paste command for the specific program.

To save data and design information from an experiment

You can save the data and design information from a single design in an 
experiment as a tab- delimited text file.

1 In the Experiment pane, expand the Experiments folder until you see 
the genome build(s) associated with the design you want to export.

2 Right- click the name of the desired genome build, then click Save As 
Text File...

A dialog box appears.

3 Select a location and type a name for the saved file, then click Save.
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Agilent Genomic Workbench 5.0 – Data Viewing 
User Guide
2
Visualizing Data and Other Content

Activating an Experiment for Visualizing Data 44

Visualizing Array Data 48

Visualizing Content (Tracks) 56

Searching for Probe and Gene Information 61

This chapter shows you how to display log ratio data from imported 
feature extraction data files, as well as gene and track content, in the 
Genomic Viewer. It also gives you instructions on how to modify the 
display to visualize the data and content the way you prefer.

To find out how to import, organize, manage and export data and other 
content, Chapter 1, “Importing, Managing, and Exporting Data and Other 
Content”.

To learn about the options for the main window and the dialog boxes for 
visualizing data, see Chapter 3, “Data Viewing Reference”.

See the Agilent Genomic Workbench 5.0 Quick Start Guide for an 
overview of all the applications you can use with this software, both those 
that require a license and those that are free capabilities.
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Activating an Experiment for Visualizing Data

An experiment is a set of links to microarray data and design files, and 
any associated results. 

When you activate an experiment and have no DNA Analytics application 
license, the program shows the log ratio data of selected arrays in the 
active experiment, if certain options have been set. 

When you activate an experiment and Preprocessing and Analysis options 
have been turned on or set to apply, the program automatically begins the 
analysis of the selected array data with current settings and displays its 
results, if certain options have been set. 

This section describes how to activate an experiment and select or 
deselect arrays for further viewing. 

To activate an experiment

When you make an experiment active, the program displays log ratio data 
in a scatter plot, provided it has been turned on. 

1 If necessary, do one of the following to add the desired experiment to 
the Experiment Pane in the Navigator:

• Create a new experiment and populate it with data. See “To create a 
new experiment” on page 25.

• Import a saved DNA Analytics 4.0 CGH experiment. See “To import 
an experiment file” on page 23.

2 In the Navigator, double- click the name of the experiment.

The Experiment Selection dialog box appears.

3 Click Yes.

In the Experiment pane of the Navigator, the name of the experiment 
turns blue. The name also appears in the title bar of the main window. 
Tables of data and design information appear in Tab View. For details 
on the available tabs, see “To search Tab View for specific probe 
information” on page 61.
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To select or deselect arrays in the experiment

To include arrays for viewing, you select them from among the arrays 
available either in an inactive experiment or the active one. When you 
first create an experiment, the program automatically sets the first array 
in the experiment for analysis. If you do not select any more arrays for 
viewing, only the first one will be displayed when the experiment is 
activated.

To select the arrays for viewing before experiment activation:

1 Hold down the Shift key to highlight contiguous arrays or hold down the 
Ctrl key to highlight noncontiguous arrays.

2 Right- click the highlighted arrays, and click Select.

Even though the selected arrays do not change color, they will change 
color after activation.

In the Navigator, an array’s icon has two appearances after experiment 
activation:

Array not selected.

Array selected. The specific color matches the color of the column 
headings for the array in Tab View. In addition, the program displays 
aberration results and moving averages related to this array in this color. 
To configure a custom color for the array, see “To change the display color 
of an array” on page 46.

To select or deselect arrays in an active experiment:

1 In the Navigator, expand the folders of the active experiment.

2 Click the name of an array you want to include in the display. 

To include additional arrays, control- click their names. To include a 
contiguous block of arrays, click the name of the first array in the 
block, then shift- click the name of the last one.

3 Right- click the name of one of the highlighted arrays, then click Select.

After you select the arrays, the program re- analyzes the data set within 
the experiment and posts the data in Genome, Chromosome, and Gene 
Views. You can see the data and results for just the selected arrays in 
the Selected Arrays tab in Tab View.
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To customize the appearance of the results in Genome, Chromosome, 
and Gene Views, see the Data Viewing Guide.

You can also use the headings of columns in Tab View that contain array 
data to select and deselect arrays.

• Click a column heading to select that array only.

• Control- click a column heading to select or deselect an array without 
affecting the status of other arrays.

• Right- click a column heading to open a shortcut menu with options 
that allow you to select or deselect that array, or all arrays.

For more details on Tab View, see “Tab View” on page 98.

To change the display color of an array

The color assigned to an array affects the color of its icon when you select 
the array within an experiment. It also affects the colored square in the 
array’s column heading in Tab View. 

1 In the Experiment pane of the Navigator, in the Experiments folder, 
expand the folder of an experiment until you can see the array whose 
color you want to edit.

2 Right- click the desired array, then click Edit Array Color...

The Select Color dialog box appears. The dialog box offers three 
different ways to choose the desired color. “Select Color (Edit Array 
Color) — Swatches Tab” on page 171.

3 Select the desired color in one of the following ways:
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Samples of the color in different contexts appear under Preview. The 
upper half of the right- most color sample shows the original color for 
comparison.

4 Adjust the color as desired, then click OK.

You can also manage all of the colors for all of the arrays in an 
experiment. Right- click the desired experiment, then click Edit Array 
Color... For details on the dialog box that appears, see “Edit Array 
Color” on page 131.

Dialog box tab Instructions

Swatches • Click the desired color swatch.

HSB 
(Hue/Saturation/Brightness)

Type or adjust the values in H (Hue), S (Saturation), and B 
(Brightness), or alternately, follow these steps:

a Select H, then drag the slider to select a hue based on the 
color strip to its right.

b Click an appropriate location in the large color box to the 
left of the slider to set the saturation and brightness levels 
of the color.
Both the HSB and equivalent RGB values of the color 
appear in the dialog box. Note these values—they will be 
useful if you need to duplicate this color in the future.

RGB (Red/Green/Blue) Do any of the following. Note the final RGB Values—they will 
be useful if you need to duplicate this color in the future.

• Drag the Red, Green, and Blue sliders.
• Type or adjust values in the boxes to the right of the sliders.
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Visualizing Array Data

After you activate an experiment, you can change how data appear within 
the Views or change the appearance of the Views that contain the data (or 
results).

To display the scatter plots

1 In the Gene View, move your cursor over the down arrow in Scatter 
Plot, and do any of the following:

2 Click X to close the Scatter Plot window.

To show significant data points in a scatter plot

The CGH and CH3 applications can classify log ratio data points as 
significant, or not, based on a simple cutoff value. The CGH application 
can do this with raw intensity data points as well.

To do this Follow these steps

Show or hide all log ratio data 
points

• To show all data points – Mark the Log Ratio check boxes
• To hide all data points – Clear the Log Ratio check boxes.

Show or hide all raw intensity 
(CGH) or intensity ratio (ChIP) data 
points

• To show all data points – Mark all three check boxes for 
Raw Intensity or the one for Intensity Ratio.

• To hide all data points – Clear all three check boxes for Raw 
Intensity or the one for Intensity Ratio.

Show or hide significant or 
insignificant data points

See “To show significant data points in a scatter plot” on 
page 48.

Change the size of data points • In Point Size, select a size for the data points.
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You select the cutoff value, and the program displays data points whose 
log ratios are above, below, or within the range of the cutoff value on the 
scatter plots in Gene and Chromosome Views, in three different colors.

1 In the Gene View, move your cursor over the down arrow in Scatter 
Plot. 

2 In Cutoff, select the desired cutoff value. The cutoff is an absolute 
value, and it defines a range. For example, if you select a value of 1.25, 
the program uses a cutoff range of –1.25 to +1.25 to classify data 
points.

If you select None, the program classifies all data points as significant.

3 Mark the kinds of points you want to appear in the scatter plot:

 – (Red) Points with log ratios above the selected cutoff range

 – (Green) Points with log ratios below the selected cutoff range

 – (Black) Points with log ratios within the selected cutoff range

4 Select the Point Size (in pixels) for the points in the scatter plot.

5 Click X to close the Scatter Plot window.

To change scatter plot appearance

You use the Preferences dialog box to change the appearance of the 
scatter plots in Chromosome and Gene views.

1 Right- click any part of Gene View, then click Preferences. 

The Preferences dialog box appears. See “Preferences – View Tab” on 
page 167.

2 Do any of the following:
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3 Click OK.

To print the scatter plot

You can print the scatter plot as it appears in Genome, Chromosome, and 
Gene Views. Each View selected in the analysis is printed on separate 
pages. Chromosomes and genes appear on the printed pages, but tracks do 
not.

1 Click File > Print.

2 Set print options, as desired, then click OK.

To do this Follow these steps

Show or hide the scatter plot a In the View tab under Data Visibility, in View, select All 
Views.

b Do one of the following:
To show the scatter plot, mark Scatter Plot.

To hide the scatter plot, clear Scatter plot.

c Click OK.

Change the symbol that 
appears for data points

You can select the symbol separately for each design type.
a In the View tab, under Rendering Patterns, select the 

desired Design type.
b Under Styles, in Scatter Plot, select the desired symbol.
c Click Apply.

Show a separate scatter plot 
in Gene and Chromosome 
Views for each selected array

a In the View tab, under View Alignment, under Rendering 
Style, select Stacked.

b Click Apply.

Show one scatter plot that 
contains data for selected 
arrays

a In the View tab, under View Alignment, under Rendering 
Style, select Overlaid.

b Click Apply.

Enable tool tips for the scatter 
plot in Gene View

Tool tips show information about an individual data point when 
you place the pointer over it.
a Click the View tab.
b Under Data Visibility, in View, select Gene View.
c Mark Scatter Tool Tip.
d Click Apply.
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To locate and view data within the Views

• To navigate through the data of the selected arrays, do any of the 
following. In general, all views are synchronized—if you select a location 
or region in one View, the other Views move there as well.

To do this Follow these steps

Select a specific chromosome 
to view

• In Genome View, click the desired chromosome. 
All other views switch to the selected chromosome.

View data in a region of the 
selected chromosome

• In Chromosome View, drag the cursor over the desired 
region.
Gene View expands (or shrinks) to show only the selected 
region. Tab View scrolls to the new cursor location.

Zoom in and out in Gene View • Click  to zoom in.

• Click  to zoom out.

Scroll through the selected 
chromosome

• Click  to scroll up.

• Click  to scroll down.

Re-center Gene View or 
Chromosome view

Click anywhere in Chromosome View, or anywhere within the 
scatter plot in Gene View. 
The location you click becomes the new cursor location.

Move all Views to a specific 
genomic location

a Click Home > Go To Gene/Genomic location...
A dialog box appears.

b Under Genomic Location, select a Chromosome, and type a 
Base Position.

c Click Go.
All views move to the selected location.

Center all Views on the 
location of a specific gene

a Click Home > Go To Gene/Genomic location...
A dialog box appears.

b Under RefSeq by Symbol, either select the desired gene (if 
available) or type the name of the gene.

c Click Go.
All views move to the location of the selected gene.

Center Chromosome and 
Gene Views based on data in 
Tab View

• In Tab View, click any entry in any table, except a column 
heading.
Chromosome and Gene views become centered on the 
genomic location corresponding to the selected entry.
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To smooth and plot CGH log ratio data

You use a plug- in to create separate, stacked plots of smoothed log ratio 
data for each of the selected CGH arrays in the current experiment. It can 
perform one of several varieties of moving- average- like smoothing, and 
plots the data associated with the currently selected chromosome. 

The Plugin Settings command lets you change the parameters when you 
have selected to produce the plot immediately after clicking Plugin. 

1 Activate an experiment.

2 Select the arrays whose log ratio data you want smoothed and plotted.

3 Select the chromosome whose log ratio data you want plotted.

4 Click Tool > Plugin > CGHSmooth....

The CGHSmooth Parameters dialog box appears. See “CGHSmooth 
Parameters” on page 106.

Scroll to a specific column in 
Tab View

a In Tab View, right-click any column heading, then click 
Scroll To Column.
The Scroll to Column dialog box appears. See “Scroll to 
Column” on page 169.

b In Select Column, select the desired column.
c Click OK.

Search for a specific column 
entry in Tab View, and move 
the cursor there

a In Tab View, right-click any entry except a column heading, 
then click Find in column.
The Find in column dialog box appears. See “Find in 
column” on page 145.

b Set the desired search parameters, then click Find Next.
The program searches the column based on your search 
parameters, and highlights the row of the first entry that 
matches. The cursor moves to the location defined in the 
highlighted row.

View the exact chromosomal 
location of the cursor

At the bottom of the main window, look at the first cell of the 
Status bar. The location appears as the chromosome followed 
by the base position. For more information on the status bar, 
see “Status Bar” on page 102.

To do this Follow these steps
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5 Enter the parameter values for the selected arrays in the active 
experiment and the selected chromosome.

6 Click OK.

The CGHSmooth Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “CGHSmooth 
Plot” on page 108.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.

See “Chart Properties” on page 110. You can also save, print, zoom in 
or out, or change the auto range of the plot by right- clicking the plot.

To enter parameters from the Plugin Settings command and bring up the plot 
directly from the Plugin command

1 After step 5 above, mark Don’t Show Again, then click OK.

The plot appears.

2 To change the parameter values, exit the plot, and click Plugin 
Settings.

3 Change the values you want to change, and click OK.

4 Click Plugin.

The plot appears.

To show the CGHSmooth Parameters dialog box again when you click 
Plugin, click Plugin Settings, clear Don’t Show Again, and click OK.

To produce an echo example plot (CGH only)

The Echo Example Plot is the output of the Echo Example plug- in. It 
displays the log ratio data for the selected chromosome in the active 
experiment. Data from all of the selected arrays in the experiment appear 
as a series of stacked plots, one for each array. 

1 Activate an experiment.

2 Select the arrays whose log ratio data you want plotted.

3 Select the chromosome whose log ratio data you want plotted.

4 Click Tool > Plugin > EchoExample....
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5 Enter the parameter values for the selected arrays in the active 
experiment and the selected chromosome.

6 Click OK.

The Echo Example Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “Echo 
Example Plot” on page 129.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.

See “Chart Properties” on page 110. You can also save, print, zoom in 
or out, or change the auto range of the plot by right- clicking the plot.

To produce a MovAvg Example plot (CGH only)

The MovAvgExample plug- in computes a 10- point moving average of the 
data from the selected chromosome in the selected arrays of the active 
experiment. It displays stacked plots of moving averages for all the arrays, 
one plot per array. 

The plug- in program itself (MovAvg Example.pl, located in the Plugins 
folder of the Genomic Workbench installation folder on your computer) is 
a short Perl program. It is a good example of how computed columns are 
processed. You must have Perl installed on your computer to use this 
plug- in.

1 Activate an experiment.

2 Select the arrays whose log ratio data you want averaged and plotted.

3 Select the chromosome whose log ratio data you want plotted.

4 Click Tool > Plugin > MovAvg Example....

5 Enter the parameter values for the selected arrays in the active 
experiment and the selected chromosome.

6 Click OK.

The MovAvg Example Plot appears, showing a plot of the log ratio vs. 
chromosomal position for each of the selected arrays. See “MovAvg 
Example Plot” on page 159.

7 (optional) To add a title, legend and change the appearance of the 
plot(s), right- click the plot, and click Properties.
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See “Chart Properties” on page 110. You can also save, print, zoom in 
or out, or change the auto range of the plot by right- clicking the plot.

To enter parameters from the Plugin Settings command and bring up the plot 
directly from the Plugin command

1 After step 5 above, mark Don’t Show Again, then click OK.

The plot appears.

2 To change the parameter values, exit the plot, and click Plugin 
Settings.

3 Change the values you want to change, and click OK.

4 Click Plugin.

The plot appears.

To show the MovAvg Example Parameters dialog box again when you 
click Plugin, click Plugin Settings, clear Don’t Show Again, and click 
OK.
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Visualizing Content (Tracks)

To show gene lists in Gene View

A gene list defines a set of genes of interest. 

You cannot show gene lists without a license. With a license you can 
highlight the genes in the gene list in Gene View, or restrict the display of 
data, genes, and tracks to the regions defined by a gene list.

You also cannot import or export a gene list without a license, but you 
can create a gene list in the program. See “To create a gene list” on 
page 34.

To change the appearance of genes in Gene View

You use the Preferences dialog box to change the appearance of the genes 
in Chromosome and Gene views.

1 Right- click any part of the Gene View, then click Preferences. 

The Preferences dialog box appears.

2 Click Tracks.

“Preferences – Tracks” on page 164.

3 Do any of the following:

To do this Follow these steps

Show or hide genes in Gene 
View

a Under Visualization Parameters:
To show genes – Under Genes, mark Show Gene Symbols.

To hide genes – Under Genes, clear Show Gene Symbols.

b Click Apply.

Change the display font for 
genes (and track annotations) 
in Gene View

a In the Gene Symbols tab, under Font, select a new Font, 
Font Style, and Font Size.

b Click Apply
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4 Click OK.

To show tracks in Gene View

Tracks contain information indexed to specific genomic locations. A 
multitude of tracks from diverse sources is available for many species. You 
can display tracks alongside genes and microarray data in Gene View.

1 Select and show microarray data. See “To activate an experiment” on 
page 44.

2 In the My Entity List pane, open the Tracks folder.

3 Right- click the track you want to display, and click Show in UI.

Or, you can do this:

1 In Gene View, right- click anywhere within the scatter plot, then click 
Preferences.

The Preferences dialog box appears. See “Preferences – Tracks” on 
page 164.

2 Click Tracks.

3 Mark the Show in UI check box of each desired track.

4 Click OK.

The program displays the selected tracks in Gene View. 

Change the display angle for 
genes (and track annotations) 
in Gene View

a Under Visualization Parameters, under Genes, in 
Orientation (Degrees), type a new orientation in degrees. 
0º is horizontal.

b Click Apply.

To do this Follow these steps
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Change the appearance of tracks

Within the Preferences – Tracks dialog box, you can modify the 
appearance of tracks in several additional ways. See the table below.

To do this Follow these steps

Include track information in 
reports

a In the list of tracks, in the Show in Report column, mark the 
check boxes of the desired tracks.

b Click Apply.
Doing this adds a column with the hits from the track file. For 
each aberrant interval, it reports the entries from the track file 
that falls under that interval in that separate column.

Show or hide annotations in 
all tracks

• To show annotations in all tracks: under Tracks, mark Show 
Annotations.

• To hide annotations in all tracks: under Tracks, clear Show 
Annotations.

Display all selected tracks as 
a single track

• Under Tracks, mark Show Overlaid.
The program combines the annotations of all selected 
tracks into a single track named Overlaid Track.

• To show tracks individually again, clear Show Overlaid.

View the parameters and the 
list of annotations of a track 

• In the list of tracks, next to the desired track, click Details...

Change the display font for 
track annotations (and genes)

a Under Font, select a new Font, Font Style, and Font Size for 
track annotations.

b Click Apply.
The program changes the display font of track annotations 
and genes in Gene View.
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Show track information in reports

1 In the list of tracks, in the Show in Report column, mark the check 
boxes of the desired tracks.

2 Click Apply.

Doing this adds a column with the hits from the track file. For each 
aberrant interval, it reports the entries from the track file that falls under 
that interval in that separate column.

Restrict data to the genomic boundaries of the track

1. In the list of tracks in My Entity List, right- click the track whose 
boundaries you want to use to restrict the display of the data.

3 Mark Genomic Boundaries.

You can remove the boundaries by clearing the check box.

Change the order in which 
tracks appear in Gene View.

The order of tracks in the Gene Symbols tab controls the 
left-to-right order of tracks in Gene View.

a Click the name of the track you want to move.
b Do any of the following:

• To move the track up in the list of tracks (and farther left 
in Gene View), click its name, then click Up.

• To move the track down in the list of tracks (and farther 
right in Gene View), click its name, then click Down.

c Click Apply.

Change the display angle of 
track annotations (and genes)

• Under Genes, in Orientation, type a new orientation (in 
degrees). 0º is horizontal.
The program changes the display angle of track annotations 
and genes in Gene View.

To do this Follow these steps
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Display tracks in UCSC Browser

1 Right- click Gene View, and click Show in UCSC.

The UCSC Browser appears if you are connected to the Internet.

2 Follow the instructions on the web site for what you want to do.

To change the graphical display to a different genome build

The default graphical display for Genome, Chromosome and Gene Views 
represents human genome build 18. 

• To change the graphical display to a different genome build, activate an 
experiment whose data are based on a design file of a different genome 
build.

The display automatically changes when you activate an experiment 
containing a design file with a different genome build, such as human 
genome build 17, or a mouse or rat genome build.

If a genome build is not available for the design file you import, you must 
import the genome build first. See “To import a genome build” on page 19.

To copy Views

You can copy panes of the main window to the clipboard as images, and 
then paste them into a new document in another program. The images 
contain only what actually appears on your screen—regions to which you 
must scroll are not included.

1 Click View > Copy.

A menu of Views appears.

2 Click the View you want to copy to the clipboard. To copy all available 
views as a single image, click All.

3 Open a document in another program that accepts images, such as a 
word processor or graphics program.

4 In the other program, click Edit > Paste.

The copied image appears.
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Searching for Probe and Gene Information

To search Tab View for specific probe information 

You can find a specific entry in a column of a data table in Tab View. For 
more information on Tab View, see “Tab View” on page 98.

1 In Tab View, right- click anywhere in the column you want to search, 
then click Find in column. See “Find in column” on page 145.

The Find in column dialog box appears. The column to be searched also 
appears in the title bar of the dialog box.

2 Set the search parameters, as described below.

3 Click Find Next.

If the program finds a match, it highlights the row that contains the 
matching entry, and resets the cursor to the corresponding position. 
You can click Find Next as many times as you like, and the program 
continues to search for additional matching entries in the column. If it 
finds no match, String not found. appears in black at the bottom of the 
dialog box.

4 When you finish your search, click Cancel.

Parameter Comments/Instructions

Find in column • Type the text you want to find (the search term). This can be an entire 
entry, or part of one.

Direction • Select one of these options:
• Up – Search the column upwards from the current cursor location 

(the highlighted row of the table).
• Down – Search the column downwards from the current cursor 

location (the highlighted row of the table).
Tip: Click a row in Tab View to highlight it.

Conditions • Mark any of these, as desired:
• Match Case – Return entries that match upper and lower case 

characters in the search term.
• Match whole word – Return an entry only if the entire entry 

matches the search term.
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To search Agilent eArray for probe information

You can use the chromosomal region that appears in Gene View, or 
another chromosomal region as the basis for a probe search on the Agilent 
eArray Web site. eArray is a powerful microarray design system for CGH, 
ChIP and gene expression applications. It contains a massive database of 
validated, annotated probes, and a full complement of tools for custom 
microarray design. 

Before you can search for probes in eArray, you must be a registered 
eArray user. For more information, go to eArray.chem.agilent.com. You 
must also provide your eArray user name and password in the 
Miscellaneous tab of the Preferences dialog box. See “Preferences – 
Miscellaneous” on page 163.

1 In Gene View, right- click anywhere in the plotting area, then click 
Search probes in eArray...

The Search probes in eArray dialog box appears. “Search probes in 
eArray” on page 170.

2 Do one of the following to define the chromosomal region for your 
search:

• To set the region to the one that currently appears in Gene View, 
select For complete gene view.

• To set the region numerically, select User Defined, then select a 
Chromosome and type Start and Stop locations for the desired 
region.

3 Click OK.

The eArray Web portal opens in your internet browser. 
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To search the Web for information on probes in Tab View

You can use any entry in a table in Tab View as the basis for a Web 
search. 

1 In Tab View, right- click any data table entry other than a column 
heading. 

2 Click one of the available sites.

If the site you want does not appear in the shortcut menu, you can 
create a custom search link. See “To create a custom Web search link” 
below.

The selected site opens in your Internet browser. The program passes 
the table entry to the site as a search string.

To create a custom Web search link

If you need to search a different database or site based on data table 
entries, you can create your own custom search link. When you right- click 
a table entry in Tab View, a shortcut menu opens, and your custom link 
appears in it. If you select this link, DNA Analytics opens the site in your 
Web browser and passes the table entry to the site as a search string.

1 Right- click any data table entry in Tab View, except a column heading, 
then click Customize Link...

The Customize Search link dialog box appears. “Customize Search 
Link” on page 124.

2 Click New.

3 In the Input dialog box, in URL name, type a name for the link.

This name will appear in the shortcut menu that opens when you 
right- click a data table entry.

4 Click OK.

5 In URL, type the complete URL needed to pass a search string to the 
site. Use <target> as the query string value. 

For example, this URL passes selected table entries to Google.com:
http://www.google.com/search?hl=eng&q=<target>

6 Click Update, then click Yes.
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To update or delete a custom Web search link

1 Right- click any data table entry in Tab View other than a column 
heading, then click Customize Link...

The Customize Search link dialog box appears.

2 In URL Name, select the custom search link you want to update or 
delete.

3 Do one of the following:

4 Click Close.

To do this Follow these steps

Update a Web search link a Edit the URL name and the URL as needed.
b Click Update.

A Confirm dialog box appears.
c Click Yes.

Delete a Web search link • Click Delete.
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This chapter describes the parts of the Genomic Workbench main window 
that you use to import, organize, manage, export and display array data 
and other content. It also details the relevant tab commands, shortcut 
menus, and dialog boxes that can appear. 

For specific instructions on how to use Genomic Workbench to manage 
data and accomplish related tasks, see Chapter 1, “Importing, Managing, 
and Exporting Data and Other Content.” To learn how to display data and 
content, see Chapter 2, “Visualizing Data and Other Content”.

To understand how all the guides work together to help you use Agilent 
Genomic Workbench, see the Agilent Genomic Workbench 5.0 Quick Start 
Guide.
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Genomic Workbench Main Window

The sections that follow describe the main components of the Genomic 
Workbench main window – Switch Application Menu, the command 
ribbons, the Navigator and the Views. You use these to import, organize, 
manage, export and display data and other content. For descriptions of 
the dialog boxes for these elements, see “Dialog Boxes” on page 103.

Figure 2 shows the main window of Genomic Workbench, and identifies its 
main parts. 

Figure 2 Genomic Workbench Standard Edition main window with Home command ribbon
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Status Bar

Tab View
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66 Data Viewing User Guide



Data Viewing Reference 3
Switch Application Menu 

The Switch Application menu allows you to switch to the other data 
display and analysis applications in DNA Analytics. Mark the desired 
application.

CGH (Separate license required) Imports, displays, and analyzes array- based 
comparative genomics hybridization (aCGH) data in both an interactive 
“analyze as you go” mode, and an automated workflow mode.

ChIP (Separate license required) Imports, displays, and analyzes ChIP- on- Chip 
microarray data in both an interactive “analyze as you go” mode, and an 
automated workflow mode.

CH3 (Separate license required) Imports and displays data from 
microarray- based studies of genomic methylation patterns.

Figure 3 Switch Application menu
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Command Ribbons

Home command ribbon 

User
Preferences...

Opens the User Preferences dialog box with four tabs:

Figure 4 Command ribbon in the Home tab of Genomic Workbench

Tab Description

View Opens a dialog box that lets you change in what form the data will 
appear in Genomic Viewer. See “Preferences – View Tab” on 
page 167.

Tracks Opens a dialog box that lets you manage which tracks to display in 
Genomic Viewer and how they appear. See “Preferences – 
Tracks” on page 164.

Miscellaneous Opens a dialog box where you can select a new location for your 
data files and set up access to the eArray web site. See 
“Preferences – Miscellaneous” on page 163.

License Opens a dialog box where you can add a DNA Analytics application 
license, if you choose to purchase one after using the unlicensed 
version. Preferences – License 161.
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Import/Export

Import Opens a menu of file types that you can import:

Option Description

Array Files Opens a menu with these options:
• FE File... – Opens the Import FE Files dialog box, where you can 

select an Agilent Feature Extraction array data file to import. 
See “Import” on page 147 and “To import Agilent FE or 
GenePix/Axon data files” on page 13.

• Axon File... – Opens the Import Axon Files dialog box, where 
you can select Axon (*.gpr) files for import. See “Import” on 
page 147 and “To import Agilent FE or GenePix/Axon data 
files” on page 13.

• UDF File... – Opens the UDF Files dialog box, where you can 
select a Universal Data File (UDF) to import. See “Import” on 
page 147 and “To import a UDF file” on page 15.

Design Files Opens a menu with these options:
• GEML File... – Opens the Import Design Files dialog box, where 

you can select Agilent GEML-based (*.xml) array design files for 
import. See “Import” on page 147 and “To import Agilent GEML 
design files” on page 18.

• Axon Design File – Opens the Import Axon Design Files dialog 
box, where you can select Axon (*.gal) array design files for 
import. See “Import” on page 147 and “To import 
GenePix/Axon design files” on page 19.

Genome Build... Opens the Import Genome Build dialog box, where you can import 
Agilent-provided genome build files. See “Import Genome 
Build” on page 151 and “To import a genome build” on page 19.

Probe Upload Allows you to import a file of probe sequences and annotation. For 
details, see the eArray XD User Guide. You see this only if you have 
installed Genomic Workbench Enterprise Edition.

Track... Opens the Import Track dialog box, where you can select a BED 
format track file for import, and create a display name for the track. 
See “Import Track” on page 152 and “To import tracks” on page 20.

Experiments Opens the Import Experiments dialog box, where you can select a 
ZIP format experiment file for import. See “Import” on page 147 
and “To import an experiment file” on page 23.
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Export Opens a menu that allows you to export several kinds of files.

Create
Experiment...

Opens the Create Experiment dialog box, where you can create a new, 
empty experiment and populate it with data. See “Create Experiment” on 
page 119 and “To create a new experiment” on page 25.

Save Experiment
Result

(Not available if you have no DNA Analytics application licenses) Saves 
CGH or ChIP results after analysis. Methylation results cannot be saved 
because reanalyzing methylation array data takes less time than bringing 
up saved results.

Go to
Gene/Genomic

Location

Moves the cursor to the location in Chromosome and Gene Views that you 
specify. See “Go To Gene/Genomic Location” on page 146.

Print Opens the Print window to print the display.

Exit Closes the program.

Option Description

Experiments... Opens the Export Experiments dialog box, where you can select 
one or more experiments for export as a single ZIP file. See “Export 
Experiments” on page 141 and “Click Home > Export > Array 
Attributes...” on page 37.

Filters... Opens the Export Filters dialog box, where you can select one or 
more filters for export as a single *.xml file. See “Export Filters 
(CGH only)” on page 142 and “To export filters (CGH only)” on 
page 39.

Tracks... Opens the Export Tracks dialog box, where you can select one or 
more tracks to export as a single BED format file. See “Export 
Tracks” on page 144 and “To export tracks” on page 40.
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View Command Ribbon

Orientation Select one of these options:

• Horizontal – Stacks Genome, Chromosome, and Gene views 
horizontally. Chromosomes and chromosomal locations appear in left 
to right orientation.

• Vertical –- Stacks Genome, Chromosome, and Gene views vertically. 
Chromosomes and chromosomal locations appear in top to bottom 
orientation.

Copy This command opens a menu with the options listed below. In general, the 
Copy command copies pane(s) of the main window to the Clipboard as an 
image. You can then paste the image into a document in another program. 
See “To copy what you see in the main window” on page 40.

Show Opens a menu with all available elements of the main window. Mark the 
check box for the one or ones you want to display.

Figure 5 Command Ribbon of the View tab

Option Description

All Copies all panes of the main window to the Clipboard as an image.

Navigator Isolates and copies the Navigator to the Clipboard as an image.

Tab View Isolates and copies Tab View to the Clipboard as an image.

SampleBySample view (Available only in data analysis modules, when selected) Isolates and 
copies Sample-by-sample View to the Clipboard as an image.

Genome view Isolates and copies Genome View to the Clipboard as an image.

Chromosome view Isolates and copies Chromosome View to the Clipboard as an image.

Gene view Isolates and copies Gene View to the Clipboard as an image.
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Signal Intensity Mark the check box View in Table to see the red and green raw signal 
intensities of the log ratio data in Tab View.

Scatter Plot See “Scatter Plot” on page 93.

Tool command ribbon

Plug- ins are ancillary programs that process the selected array data in the 
active experiment in specific ways.

Plugin

Opens a menu with the options listed below. If you or another user has 
created custom plug- ins, they also appear in this menu.

CGHSmooth Opens the CGHSmooth Parameters dialog box. See “CGHSmooth 
Parameters” on page 106. You can set the parameters of the CGHSmooth 
plug- in, and create separate, stacked plots of smoothed log ratio data for 
each of the selected arrays in the current experiment. The plug- in plots 
the data associated with the currently selected chromosome.

When you open this dialog box, you see the default parameters you enter 
under Plugin Settings.

Echo Example Creates separate, stacked plots of log ratio data for each of the selected 
arrays in the current experiment. The plug- in plots the data associated 
with the currently selected chromosome. The plot appears in a new 
window. Although simple, this plug- in gives you a convenient way to view 
the log ratio data for selected arrays as separate plots. See “Echo Example 
Plot” on page 129.

Figure 6 Plugin command ribbon
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MovAvg Example Opens the MovAvg Example Parameters dialog box. See “MovAvg Example 
Parameters” on page 157. You can set the parameters of the MovAvg 
Example plug- in. The plug- in calculates a 10- point moving average of each 
column of selected microarray data, and produces stacked plots of all of 
the input data and moving averages. To use this plug- in, you must have 
Perl installed on your computer.

When you open this dialog box, you see the default parameters you enter 
under Plugin Settings.

Plugin Settings

Opens another menu with these options:

CGHSmooth Opens the CGHSmooth Parameters dialog box, where you can set the 
parameters for the plug- in when you have selected to not show the 
parameters dialog box when you click Plugin. See “CGHSmooth 
Parameters” on page 106.

MovAvg Example Opens the MovAvg Example Parameters dialog box, where you can set the 
parameters for the plug- in when you have selected to not show the 
parameters dialog box when you click Plugin. See “MovAvg Example 
Parameters” on page 157.
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Help command ribbon

The Help command ribbon provides access to the Agilent Genomic 
Workbench Quick Start Guide and all the other user guides.

Figure 7 Help command ribbon for Genomic Workbench Standard Edition

Table 1 Table of Help for unlicensed version (Click only those bolded and Italicized)

Help Command Action

Help Opens the DNA Analytics application user guide for which you have the 
associated license. 

CGH Interactive Analysis – Shows how to set up all preprocessing, 
analysis, discovery and reporting options for analyzing CGH data 
interactively. Includes details on the algorithms used.

Quick Start Opens the Agilent Genomic Workbench 5.0 Quick Start Guide in Adobe 
Reader. This guide provides brief instructions on how to install and start 
the program, and how to use the basic features of the program to create 
custom microarray designs, and to analyze microarray data.

Data View Shows you how to import, manage, export and display log ratio data from 
Agilent and other sources

Workflow Gives instructions on how to set up a workflow for automated feature 
extraction and/or analysis. Also shows you how to set up the CGH and 
ChIP analysis methods to be used in a workflow.

Sample Manager Shows you how to assign identification and attribute information to image 
files, imported feature extraction (FE) files or UDF files.

eArray (Genomic Workbench Enterprise Edition must be installed) Gives 
instructions on how to design your own microarrays on your desktop, not 
the web site.

About Opens a message with details about the version number and copyright of 
the program.
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Navigator

This section describes the parts of the Navigator, and the shortcut menus 
and other functionality available within it.

Figure 8 Navigator – note the four panes within the Navigator

Search pane

Data pane

Experiment pane

My Entity List pane
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The Navigator (Figure 8) catalogs the array data, experiments, and other 
content stored in Genomic Workbench. It contains four panes:

Search pane

The Search pane allows you to find all occurrences of a specific search 
term in the Data, Experiment, and/or My Entity List panes. See “To find 
specific content items in the Navigator” on page 30. It also contains 
several buttons that you can use to detach, hide, show or resize the 
Navigator.

Pane Comments

Search Allows you to find all occurrences of a specific search term in the 
Data, Experiment, and/or My Entity List panes.

Data Contains microarray data files, organized by application type and 
design, and then by genome build.

Experiment Contains Genomic Workbench experiments. Experiments are 
organizational units within the program that contain links to 
microarray data and design files. In data analysis modules, 
experiments also contain saved results.

My Entity List Contains gene lists and tracks:
• Gene Lists are collections of genes of interest. You can create 

them within the program, import and export them, and apply 
them to Gene View and Chromosome View.

• Tracks are collections of annotation or other information that is 
correlated with specific genomic locations. You can import, 
export, and combine tracks, and display them in Gene View 
alongside your array data and analysis results.
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Detach button Click to detach the Navigator from the main window of the program and 
open it in a new, separate window. 

Resize buttons Click to hide, show, or expand the Navigator. 

Search term box Provides a box for you to type your desired search term. Search terms are 
not case- sensitive, but they must reflect the entire name of an array or 
other content item that you want to find. You can use asterisks (*) as 
wildcards to represent groups of unspecified characters.

Pane list Allows you to restrict a search to a specific pane. Select the name of the 
desired pane from the list. To select all panes, select All Panels. By 
default, the program searches all panes.

Figure 9 Navigator – Search pane

Search term box Detach 
button

Resize 
buttons

Pane list 
button

Search term 
clear button

Search button

Scroll buttons

Figure 10 Open Pane List
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(Show Pane List button, available only if the Pane list is not visible) 
Makes the Pane list visible.

(Hide Pane List button, available only if the Pane list is visible) Hides the 
Pane list.

(Search button) Searches the pane(s) selected in the Pane list for all 
occurrences of the term you typed in the Search term box. If the program 
finds a matching item, it expands the folder structure to make the 
matching item(s) visible, makes the lettering of each item red and 
highlights the item in yellow. Note: The search term is not case- sensitive, 
but it must reflect the entire name of the desired items.

Scroll buttons (Available only after a search) Lets you scroll up and down the lists of 
highlighted search items after a search.

(Clear button, available only after a search) Clears the search term from 
the Search term box, and resets the color of any matching item to its 
original color.

Data pane – icons, special text, and buttons

Item Comments

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders.

A methylation array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH array design. This folder contains array data associated with the design, 
organized by genome build.

A gene expression array design. This folder contains array data associated with the 
design, organized by genome build.

A ChIP array design. This folder contains array data associated with the design, 
organized by genome build.

A genome build folder within a specific design folder. This folder contains arrays 
associated with the specific genome build and design.
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Data pane – actions and shortcut menus

Only the options that are not grayed out are discussed in this section. To 
activate the grayed- out options, you must have the appropriate license for 
the DNA Analytics application you are using. These inactivated options are 
explained in the User Guide for your DNA Analytics application. 

• Double- click any folder to expand or collapse it.

Data Folder

• Right- click the Data folder to open a shortcut menu with an Import 
option. When you select this option, a menu appears with these options 
for file import:

A single array data file.

Data created from a multi-pack array.

red text An item that matches the search term in a search.

(Dock out button) Detaches the Data pane from the Navigator, and opens it in its own, 
separate window.

(Collapse button, available only if the Data pane is not collapsed) Collapses the Data 
pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the Data pane is collapsed) Expands the Data pane.

Item Comments

Option Description

Design File... Opens the Import Design Files dialog box, where you can select an 
Agilent GEML-based (*,xml) file for import. See “Import” on page 147 
and “To import Agilent GEML design files” on page 18.

Axon Design File... Opens the Import Axon Files dialog box, where you can select 
GenePix/Axon design (*.gal) files for import. See “Import” on 
page 147 and “To import GenePix/Axon design files” on page 19.

FE File... Opens the Import FE Files dialog box, where you can select an Agilent 
Feature Extraction array data file to import. See “Import” on page 147 
and “To import Agilent FE or GenePix/Axon data files” on page 13.
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Design Folder

• Right- click the name of design folder to open a shortcut menu with 
these options:

Genome Build Folder

• Right- click the name of a genome build folder to open a shortcut menu 
with these options:

Axon File... Opens the Import Axon Files dialog box, where you can select Axon 
(*.gpr) files for import. See “Import” on page 147 and “To import 
Agilent FE or GenePix/Axon data files” on page 13.

UDF File... Opens the UDF Files dialog box, where you can select a Universal Data 
File (UDF) to import. See “Import” on page 147 and “To import a UDF 
file” on page 15.

Option Description

Update from eArray (Available only for Agilent microarrays) Updates the annotations for 
your array design from the eArray Web site. Agilent regularly updates 
annotations in eArray as new ones become available. See “To update 
probe annotation in design files” on page 31.

Delete Opens a Confirm dialog box. If you click Yes, the program permanently 
deletes the design and all arrays associated with it.

Option Description

Show Properties... Opens the Design Properties dialog box. See “Design Properties” on 
page 125.

Delete Opens a Confirm dialog box. If you click Yes, the program permanently 
deletes all of the arrays in this genome build folder.

Option Description
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Specific Arrays

• Right- click the name of an array to open a shortcut menu with these 
options:

• Drag an array from the Data pane to an experiment folder in the 
Experiment pane to associate it with an experiment. You can drag 
multiple arrays at once from one genome build in a design. 
Control- click the additional arrays to select them. You can also select a 
contiguous block of arrays—click the first array in the block, then 
shift- click the last one.

Experiment pane – icons, special text, and buttons

Option Description

Show Properties Opens the Microarray Properties dialog box. See“Microarray 
Properties - Attribute Tab” on page 154 and “To edit the attribute 
values of a specific array” on page 29.

Rename... Opens an Input dialog box, where you can type a new name for the 
array. Click OK to rename the array.

Delete Opens a Confirm dialog box. If you click Yes, the program permanently 
deletes the array.

Item Comments

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders. 

A methylation array design. This folder contains array data associated with the design, 
organized by genome build.

A CGH array design. This folder contains array data associated with the design, 
organized by genome build.

A gene expression array design. This folder contains array data associated with the 
design, organized by genome build.
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Experiment pane – actions and shortcut menus

Only the options that are not grayed out are discussed in this section. To 
activate the grayed- out options, you must have the appropriate license for 
the DNA Analytics application you are using. These inactivated options are 
explained in the User Guide for your DNA Analytics application. 

• In general, double- click the Experiments folder, and the folders within 
it, to expand and collapse them. Exception: double- click the name of an 
unselected experiment to select it for analysis.

Experiments Folder

• Right- click the Experiments folder to open a shortcut menu with these 
options:

A ChIP array design. This folder contains array data associated with the design, 
organized by genome build.

A genome build folder within a specific design folder. This folder contains arrays 
associated with the specific genome build and design.

An array that is not selected for view 

An array that is selected for view and analysis. The specific color of this icon can vary.

An empty folder.

Data created from a multi-pack array.

blue 
text

The currently active experiment. All data that appear in Chromosome, Gene, and Tab 
Views are derived from this experiment.

red text An item that matches the search term in a search.

(Dock out button) Detaches the Experiment pane from the main window, and opens it in 
its own, separate window.

(Collapse button, available only if the Experiment pane is not collapsed) Collapses the 
Experiment pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the Experiment pane is collapsed) Expands the 
Experiment pane.

Item Comments
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Specific Experiment Folder

• Right- click the name of an experiment to open a shortcut menu with 
these options:

Option Description

New Experiment Opens the Create Experiment dialog box, where you can name the 
new experiment, and open another dialog box that allows you to 
populate the experiment with microarrays. See “Create 
Experiment” on page 119.

Export Opens the Export Experiments dialog box, where you can export one 
or more experiments as a single ZIP file. See “Export Experiments” on 
page 141 and “To export experiments” on page 38.

Option Description

Select Experiment (Appears only if the experiment is not selected.) Opens the 
Experiment Selection dialog box, which asks if you want to select the 
experiment. Click Yes to select the experiment for view and analysis. 
Or In the Experiments folder, double-click the name of an experiment 
that is not selected to open the Experiment Selection dialog box. To 
select the experiment for analysis, click Yes.

Deselect Experiment (Appears only if the experiment is selected.) Removes the experiment 
data from display.

Show Properties Opens the Experiment Properties dialog box. Use this dialog box to 
see the names of the arrays in the experiment, and also to add or 
remove arrays from the experiment. See “Experiment Properties” on 
page 133.

Export... Opens the Export Experiments dialog box, where you can export this 
and other experiments as a single ZIP file. See “Export 
Experiments” on page 141 and “To export experiments” on page 38.

Export Attributes Opens the Export Attributes dialog boxes, one for selecting arrays for 
which you want attributes exported and one for selecting the 
attributes you want to export with the selected arrays. See “Export 
Array Attributes – Array” on page 137.

Edit Array Color Opens the Edit Array Color dialog box, where you can select a display 
color for each of the arrays in the experiment. For details see “Edit 
Array Color” on page 131.
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Design Folder

• Right- click the name of a design to open a shortcut menu with a Delete 
option. If you select this option, a Confirm dialog box opens. If you 
click Yes, the program removes the links to all of the arrays under the 
design from the experiment.

Genome Build Folder

• Right- click the name of a genome build within a design to open a 
shortcut menu with these options:

Individual Arrays

• Within the folder of a specific experiment, in the Arrays folder of a 
design, right- click the name of an individual array to open a shortcut 
menu with these options:

Edit Array Order Opens the Array Order dialog box, where you can change the order of 
the arrays in the Experiment and in Tab View. See “Edit Array 
Order” on page 132.

Rename Opens an Input dialog box, where you can type a new name for the 
experiment. Click OK to rename the experiment.

Delete Opens a Confirm dialog box that asks if you want to delete the 
Experiment. Click Yes to delete it.

Note: You can delete any experiment except the selected one.

Option Description

Set for Calibration (Works only if have license) Designates all arrays associated with this 
specific genome build and design as calibration arrays. 

Delete Opens a Confirm dialog box that asks if you want to disassociate all 
arrays under the design from the experiment. Click Yes to remove the 
links between the arrays and the experiment.

• If you delete a design from an experiment, the program removes the 
links between the experiment and the design and its arrays. The 
actual design and array data remain in the Data folder.

Option Description
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Option Description

Select (Available if the array is not selected) Selects the array for display. 

Deselect (Available if the array is selected) Removes the array data from Genome, 
Chromosome, and Gene views. Also removes the array from the Selected 
Arrays tab in Tab View.

Rename... Opens an Input dialog box, where you can type a new name for the 
experiment. Click OK to rename the experiment.

Delete Opens a Confirm dialog box that asks if you want to disassociate the 
array from the experiment. Click Yes to remove the link between the array 
and the experiment. See “To remove arrays from an experiment” on 
page 28.

• If you delete an array from an experiment, the program removes the 
link between the experiment and the array. The actual array data 
remains in the Data folder.

Show Properties... Opens the Microarray Properties dialog box, where you can view and edit 
microarray attributes. 

For array files from the Agilent Feature Extraction program, you can also 
view the headers and feature data from the file.

See “Microarray Properties - Attribute Tab” on page 154 and “To edit the 
attribute values of a specific array” on page 29.

Edit Array Color... Opens the Edit Array Color dialog box, where you can select a display 
color for the array. See “Edit Array Color” on page 131 and “To change 
the display color of an array” on page 46.

Edit Array Order... Opens the Array Order dialog box, where you can change the order of the 
arrays in the Experiment and in Tab View. See “Edit Array Order” on 
page 132 and “To change the order of arrays in an experiment” on 
page 27.
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My Entity List pane – icons, buttons, and special text

My Entity List pane – actions and shortcut menus

Only the options that are not grayed out are discussed in this section. To 
activate the grayed- out options, you must have the appropriate license for 
the DNA Analytics application you are using. These inactivated options are 
explained in the User Guide for your DNA Analytics application. 

• Double- click the Gene List folder to show or hide its gene lists.

Item Comments

Click to expand a folder and display its contents.

Click to collapse a folder and hide its contents.

A folder that contains files or other folders.

An individual gene list or track.

red regular 
text

An item that is an exact match with the search term in a search, or an unapplied 
gene list that has red chosen as its custom color.

colored 
italics

A gene list that has been applied.

red bold 
italics

A track that is selected for display in Gene View.

black bold 
italics

A “combined” track that is selected for display in Gene View. A combined track 
contains information from two or more individual tracks associated by logical 
criteria.

(Dock out button) Detaches the My Entity List pane from the main window, and 
opens it in its own, separate window.

(Collapse button, available only if the My Entity List pane is not collapsed) Collapses 
the My Entity List pane, and shows its title bar at the bottom of the Navigator.

(Expand button, available only if the My Entity List pane is collapsed) Expands the 
My Entity List pane.
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Gene List Folder

• In the Gene List folder, right- click the name of a gene list to open a 
shortcut menu with these options:

Track Folder

• Right- click the name of a track to open a shortcut menu with these 
options:

Option Description

Rename... Opens an Input dialog box, where you can type a new name for the 
gene list. Click OK to accept the new name.

Delete Opens a confirm dialog box that asks if you are sure you want to 
delete the gene list. Click Yes to confirm.

Option Comments

Show in UI Mark this option to display the track in Gene View alongside 
the data and results of the selected experiment. See “To show 
tracks in Gene View” on page 57 and “Preferences – 
Tracks” on page 164.

Show in Report Mark the check box to show the track information in all the 
reports.

Genomic Boundaries Click to use the genome track to define only the regions that 
aberration detection algorithms will run. You can choose to do 
this for only one track.

Show in UCSC Opens the UCSC (University of California at Santa Cruz) 
Genome Browser in your Web browser and uploads the track. 
You can then view the track.

View Details Opens a table listing all the chromosome locations defined in 
the track.

Rename Opens an Input dialog box, where you can type a new name for 
the track. Click OK to rename the track.

Delete Opens a Delete Track dialog box that asks if you are sure you 
want to delete the track. Click Yes to delete the track.
Data Viewing User Guide 87



3 Data Viewing Reference
Genomic Viewer

Genome View

Genome View shows pictures of each of the distinct types of chromosomes 
in the selected genome. A blue box encloses the currently selected 
chromosome, and the cursor appears as a blue line across the 
chromosome. 

Figure 11 Genome View, with human chromosomes. The X chromosome is selected.
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Genome View actions and shortcut menus

• Click a chromosome to select it. When you select a chromosome, 
Chromosome, Gene, and Tab Views show only genomic regions, genes, 
and data associated with it. The specific location in which you click the 
chromosome sets the position of the cursor. See “The View Cursor” on 
page 97.

• On the selected chromosome, click anywhere to reposition the cursor. 
See “The View Cursor” on page 97. This also repositions the cursor in 
Chromosome, Gene, and Tab Views.

• Right- click anywhere within Genome View to open a shortcut menu 
with a Preferences option. If you click Preferences, the Preferences 
dialog box opens, where you can set user preferences on four separate 
tabs. See “Preferences – License” on page 161 and the topics that 
follow.

• Click the Detach button  (located at the top center of the pane) 
to remove Genome View from the main window and open in its own 
separate window. See “Resizing and detaching panes from the Genomic 
Workbench main window” on page 19 in the Quick Start Guide.

• To reattach the view, click its Close button . See “Maximizing and 
reattaching panes to the Genomic Workbench main window” on page 20 
in the Quick Start Guide.

• Drag the side or bottom borders of the pane to resize them. 

• On a border of the pane, click a resize button (for example,  or ) that 
points away from the pane to move that border all the way to the edge 
of the main window. To move the border back to its previous location, 
click the other resize button. See “Resizing and detaching panes from 
the Genomic Workbench main window” on page 19 in the Quick Start 
Guide.
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Chromosome View

Chromosome View shows a more detailed diagram of the chromosome you 
select in Genome View. 

• Cytobands and a plotting area appear alongside the chromosome. 

• When you select arrays for display, their data appear in the plotting 
area.

• The View cursor appears as a solid blue line across the chromosome 
and the plotting area.

• The selected region of the chromosome (if any) appears as a dotted 
blue box in the plotting area. 

Figure 12 Chromosome View, human X chromosome shown
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Chromosome View actions and shortcut menus

• Click a cytoband, any part of the chromosome, or anywhere in the 
plotting area to reposition the View cursor at that location. See “The 
View Cursor” on page 97.

• Drag the pointer over any part of the plotting area to select a 
chromosomal region for display in Gene View. Drag parallel to the 
chromosome. This also repositions the cursor to the center of the 
selected region. See “The View Cursor” on page 97.

• Right- click anywhere in the plotting area of Chromosome View to open 
a shortcut menu with a Preferences option. If you click Preferences, 
the Preferences dialog box opens, where you can set user preferences 
on four separate tabs. See “Preferences – License” on page 161 and the 
topics that follow.

• Click the Detach button  (located at the top center of the pane) 
to remove Chromosome View from the main window and open in its 
own separate window. See “Resizing and detaching panes from the 
Genomic Workbench main window” on page 19 in the Quick Start 
Guide.

• To reattach the view, click its Close button . See “Maximizing and 
reattaching panes to the Genomic Workbench main window” on page 20 
in the Quick Start Guide.

• Drag an inside border of Chromosome View to resize the view. 

• On a border of the pane, click a resize button (for example,  or ) that 
points away from the pane to move that border all the way to the edge 
of the main window. To move the border back to its previous location, 
click the other resize button. See “Resizing and detaching panes from 
the Genomic Workbench main window” on page 19 in the Quick Start 
Guide.
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Gene View

Gene View shows a more detailed view of the chromosomal region you 
select in Chromosome View. See “Chromosome View” on page 90.

• Regions occupied by genes appear as small blue boxes. Gene names 
appear nearby. You can customize the appearance of gene names. 
Also, you can use a gene list to highlight genes of interest, or to 
restrict the genes that appear to those in the list. See “To change the 
appearance of genes in Gene View” on page 56, and “To show gene 
lists in Gene View” on page 56.

Figure 13 Gene View, with log ratio data from an experiment and CNV tracks. 
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• Log ratio data from selected arrays in the active experiment appear 
as a scatter plot. Points appear in up to three different colors. See 
“To show significant data points in a scatter plot” on page 48. You 
can also customize the scatter plot. See “To change scatter plot 
appearance” on page 49.

• The location of the cursor matches the location of the cursors in 
other views. See “The View Cursor” on page 97.

• The name of the chromosome, and the coordinates and size of the 
displayed chromosomal region appear at the top of the pane. 

• Imported tracks can also appear in Gene View. See “To show tracks 
in Gene View” on page 57.

Scatter Plot

You access the scatter plot command group through Gene View or the 
View tab. The commands differ depending on the DNA Analytics 
application you are working with. All the scatter plot command groups 
contain the commands for log ratio data in Figure 14. Scatter plots appear 
in the Chromosome and Gene Views but only if they have been activated 
in the Preferences dialog box.

Cutoff Select the threshold of CGH or CH3 log ratios to give a visual clue about 
significance. In the above example, all data points whose log ratios are 
below the cutoff of +0.125 are significant. If you select none, the program 
classifies all points as significant.

Mark this red check box to display, or clear it to hide, points with log 
ratios above the Cutoff selected. You select the cutoff for significance in 
Cutoff. These points appear in red.

Mark this green check box to display, or clear it to hide, points that 
reflect significant decreases. You select the cutoff for significance in 
Cutoff. These points appear in green.

Figure 14 Scatter Plot command group in CH3 Gene View
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Mark this black check box to display, or clear it to hide, points that reflect 
insignificant changes. You select the cutoff for significance in Cutoff. 
These point appear in black.

Point size Sets the size (in pixels) of the points in the scatter plots.

In addition to options for log ratio plotting, the CGH command group 
includes options for raw intensity plotting. 

The ChIP command group includes options for intensity ratio plotting.

Figure 15 Scatter Plot command group in CGH Gene View

Figure 16 Scatter Plot command group in ChIP Gene View
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Gene View buttons

Zooms in to see a smaller region in more detail.

Zooms out to see a larger region in less detail.

(Available when Gene View is in vertical orientation.) Scrolls up through 
the genes and data to lower- numbered chromosomal coordinates.

(Available when Gene View is in vertical orientation.) Scrolls down 
through the genes and data to higher- numbered chromosomal coordinates.

(Available when Gene View is in horizontal orientation.) Scrolls left 
through the genes and data to lower- numbered chromosomal coordinates.

(Available when Gene View is in horizontal orientation.) Scrolls right 
through the genes and data to higher- numbered chromosomal coordinates.

(Resize buttons) The button that points away from Gene View expands the 
view. The other button restores the view to its original size. See “Resizing 
and detaching panes from the Genomic Workbench main window” on 
page 19 in the Quick Start Guide.

(Detach button) Removes Gene View from the main window, and opens it 
in its own separate window. “Resizing and detaching panes from the 
Genomic Workbench main window” on page 19 in the Quick Start Guide.
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Gene View shortcut menu and other actions

• Click anywhere in the plotting area of Gene View to move the cursor to 
that location. See “The View Cursor” on page 97.

• Drag an inside border of Gene View to resize the View. See “Resizing 
and detaching panes from the Genomic Workbench main window” on 
page 19 in the Quick Start Guide.

• Right- click anywhere in the plotting area of Gene View to open a 
shortcut menu with these options:

Option Description

Create Gene List... Opens the Create Gene List dialog box, where you can create a 
new gene list based on the currently selected (or another) 
chromosomal region. See “Create Gene List” on page 121 and 
“To show gene lists in Gene View” on page 56.

Create Track Opens the Create Track dialog box, where you specify the 
chromosome locations for the track. See “To create a track 
(CGH only)” on page 35 and “Create Track (CGH only)” on 
page 123.

Show in UCSC Opens the UCSC (University of California at Santa Cruz) 
Genome Browser in your Web browser and uploads the track. 
You can then view the track.

Search probes in eArray... Opens the Search probes in eArray dialog box, where you can 
start a search of the Agilent eArray web site for probes in the 
selected (or another) chromosomal region. See “Search 
probes in eArray” on page 170 and “To search Agilent eArray 
for probe information” on page 62.

Preferences Opens the Preferences dialog box, where you can set user 
preferences on four separate tabs. See “Preferences – 
License” on page 161 and the related pages that follow.
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The View Cursor

The View cursor reflects the center of the current chromosomal location of 
interest. It appears in several views:

• In Genome View, it appears as a blue bar across the selected 
chromosome.

• In Chromosome View, it is a blue bar that appears across the 
chromosome and across the plotting area of the view.

• In Gene View, it is a blue bar that appears across the plotting area 
and tracks of the view.

The position of the cursor in one View is also the position of the cursor 
in all Views. The exact chromosomal location of the cursor appears in the 
first cell of the Status bar. Several actions affect the position of the View 
cursor:

• In Genome View, click anywhere on a chromosome to move the 
cursor to that location.

• In Chromosome View, click a cytoband name, part of the 
chromosome, or anywhere in the plotting area to move the cursor to 
that location.

• In Gene View, click anywhere in the plotting area to move the cursor 
to that location.

The cursor used in Gene View is the same cursor used for the tracks.

• In Tab View, click a row of a data table to move the cursor to the 
chromosomal location associated with that row.
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Tab View

Tab View displays design annotation and log ratio data related to the 
chromosome you select in Chromosome View. 

• The exact column content of the tables depends on the specific tab 
and design, but it always includes chromosomal locations of probes

• The selected row of data appears highlighted in blue. This row 
represents data that corresponds approximately with the location of 
the cursor.

• Columns of log ratio data appear below the names of the specific 
arrays to which they correspond. If an array is selected for display 
in Chromosome and Gene views, a colored square appears next to its 
name.

Figure 17 Tab View

Detach buttonResize buttons

Design tabs
Selected row

Selected 
array

Unselected 
array
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Tab View tabs and buttons

You can see the following tabs and buttons in Tab View. See Figure 17 for 
a diagram that identifies some of these elements.

Design tabs A separate tab appears for each microarray design included in the active 
experiment. The name of the design appears on each tab, along with an 
icon:

 – A methylation array design

 – An aCGH array design.

 – A gene expression array design.

 – A ChIP- on- Chip array design.

When you click a design tab, the data and annotation for the arrays in the 
design appear in Tab View. The program separates the arrays of the 
design into the Arrays tab and the Calibration Arrays tab (see below).

Arrays tab (Available when you click a specific design tab.) Contains a table of data 
and annotation for all arrays in a design that contain biological data.

Selected Arrays
tab

Contains a table of data and annotation for the selected arrays from all 
designs in the active experiment.

(Resize buttons) The button that points away from Tab View expands the 
view. The other button restores the view to its original size. See “Resizing 
and detaching panes from the Genomic Workbench main window” on 
page 19 in the Quick Start Guide.

(Detach button) Removes Tab View from the main window, and opens it 
in its own separate window. See “Resizing and detaching panes from the 
Genomic Workbench main window” on page 19 in the Quick Start Guide.

Tab View actions and shortcut menus

• Click the name of an array in a column heading to select the array 
data for display.

• Right- click the name of an array in a column heading to open a 
shortcut menu with these options:
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Option Description

Rename Array... Opens an Input dialog box, where you can type a new name for 
the array. This only changes the name of the array within the 
active experiment.

Remove Array From 
Experiment

Opens a confirmation dialog box. Click Yes to remove the link 
between the array and the active experiment. This command 
does not delete the data file from the program. To do this, see 
“To remove data or design files from the program” on page 33.

Select Array (Available if the array is not selected.) Selects the array for 
display. A colored square appears next to the name of the 
array.

Deselect Array (Available if the array is selected.) Removes the array data 
from scatter plots, and removes the column of the array from 
the Selected Arrays tab.

Edit Array Color Opens the Select Color dialog box, where you can change the 
display color of the array. See “Edit Array Color” on page 131 
and “To change the display color of an array” on page 46.

Edit Array Order Opens the Edit Array Order dialog box, where you can change 
the order in which the names of the arrays in a given design of 
the active experiment appear in Tab View and in the Data 
Navigator. In Gene View, when you view separate scatter plots 
for each array, the plots also appear in this order. See “Edit 
Array Order” on page 132 and “To change the order of arrays in 
an experiment” on page 27.

Select All Arrays Selects all arrays in all designs in the active experiment for 
display. All arrays appear in the Selected Arrays tab.

Deselect All Arrays Removes all arrays from display, and from the Selected Arrays 
tab.

Scroll to Column... Opens the Scroll to Column dialog box, where you can select a 
column in the current tab. The program then scrolls the data 
table in the tab so you can see the selected column. 
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• Right- click a heading of a column other than an array data column 
to open a shortcut menu with a Scroll To Column option. If you click 
this option, the Scroll to Column dialog box appears, where you can 
select a column in the current tab. The program then scrolls the data 
table in the tab so you can see the column. See “Scroll to Column” on 
page 169.

• Click a data table entry to select the row in which it appears. This also 
moves the cursor to the location of the data point corresponding to the 
selected row.

• Right- click a data table entry to open a shortcut menu with these 
options:

Option Description

Find in Column Opens the Find in column dialog box, where you can search for 
a specific text string within the column you clicked. See “Find 
in column” on page 145.

Google...
LocusLink...

PubMed...

UCSC HG15(April ‘03)

UCSC HG16(July‘03)

UCSC HG17(May‘04)

UCSC HG18(March‘06)

UCSC mm8(Feb‘06)

UCSC mm9(July‘07)

Opens your Web browser, and passes the column entry you 
clicked as a search string to the selected site. The UCSC links 
search the indicated University of California, Santa Cruz 
database related to the indicated genome build. See “To 
search the Web for information on probes in Tab View” on 
page 63.

Customize Link... Opens the Customize Search link dialog box, where you can 
create or edit a custom Web link that appears in this shortcut 
menu. When you click a custom link, the program opens your 
Web browser, and passes the column entry you clicked as a 
search string to the site. See “Customize Search Link” on 
page 124 and “To update or delete a custom Web search 
link” on page 64.

(other options) If other options appear in this shortcut menu, they are custom 
Web search links. Click them to open your Web browser, and 
pass the column entry you clicked as a search string to the 
site.
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Status Bar

The Status Bar displays information related to the currently displayed 
data. There are other items on the status bar that only become active if 
you have a DNA Analytics application license.

Cursor position The chromosomal location of the cursor. See “The View Cursor” on 
page 97.

Genome build The genome build associated with the currently displayed data.

Ratio type The mathematical type of the array data. The possible types are:

• ratio

• log2 ratio

• log10 ratio

• ln (natural log) ratio

Selected Row The row in the currently displayed data table that is selected. The location 
of the cursor is approximately the chromosomal location associated with 
this row.

Table size The number of columns in the currently displayed tab. The size appears as 
<# of rows> x <# of columns>.

Figure 18 Status bar

Genome build Ratio type

Table size

Cursor position
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Dialog Boxes

This section describes the dialog boxes that can appear when you import, 
organize, manage, export and display array data and other content in 
Genomic Workbench. The dialog boxes appear in alphabetical order by 
name.

Add Gene List <name> to

Purpose: Adds genes from one gene list (the source gene list) to another 
(the target gene list).

To open: In the Data pane, right- click the name of a gene list, then click 
Add to Gene List.

Select target
gene list

The gene list to which genes will be added. Select one from the list.

Figure 19 Add Gene List <name> to
Data Viewing User Guide 103



3 Data Viewing Reference
Build (Read only) The genome build associated with the genes in the list. The 
builds of the two gene lists must match.

Description (Optional) Description of the combined gene list.

List of genes A list of the genes in the target gene list.

Gene List Color (Read only) The current display color of the target gene list.

OK Adds the genes from the source gene list to the target gene list.

Cancel Closes the dialog box without adding any genes to the target gene list.

Agilent Feature Extraction Importer

Purpose: Allows you to edit the name of the FE data file you intend to 
import and to specify if you want to flip the red/green ratio for the data.

Figure 20 Agilent Feature Extraction Importer
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To open: In the Home tab, click Import > Array Files > FE File..., select 
the desired FE data file(s), then click Open.

Name Allows you to edit the names of the FE files. You can change the names of 
the files to names that you are more likely to recognize or remember.

Dye Flip For each array:

Select Normal if:

• The test samples were labeled with cyanine- 5 (red).

• The control samples were labeled with cyanine- 3 (green).

• The imported ration (test/control) should be reported directly.

Select Flipped if:

• The test samples were labeled with cyanine- 3 (green).

• The control samples were labeled with cyanine- 5 (red).

• The imported ratio (control/test) should be reported with the ratio 
inverted (test/control).

The program does not combine dye- flip pairs.

Overwrite arrays
with duplicate

names

Mark this option to replace existing file(s) in the program with the 
imported one(s), if they have the same name(s).

Run in
Background

Imports the files, and allows you to use your computer for other purposes 
while the import occurs. This is especially useful if you have many files to 
import.

OK Imports the files in the foreground. You cannot use your computer for 
other purposes while the import occurs.

Cancel Cancels the entire import process without importing anything.
Data Viewing User Guide 105



3 Data Viewing Reference
CGHSmooth Parameters

Purpose: The CGHSmooth Parameters dialog box lets you configure the 
CGHSmooth plug- in. It can perform one of several varieties of 
moving- average- like smoothing, and plots the data associated with the 
currently selected chromosome. 

To open: Click Tool > Plugin > CGHSmooth.

Figure 21 CGHSmooth Parameters dialog box
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Parameters Set any of these parameters:

Don’t show again Mark this option to prevent the appearance of this dialog box in the 
future when you click Tool > Plugins > CGHSmooth. To restore the dialog 
box so it appears again, click Tool > Plugin Settings > CGHSmooth, then 
clear Don’t show again.

OK Accepts the parameters and prepares the plot. You can further refine the 
appearance of the plot once the plug- in generates it.

Cancel Discards any changes you made, and closes the dialog box.

Parameter Description

Smoothing Function A number from 0 to 5. The number sets one of the following options as 
the weighting function used by the moving average algorithm. In 
general, the options weight measurements closer to the center 
position more heavily than those more distant from it.

• 0 – None. The plug-in applies no smoothing, and returns the 
original data. In some cases, the plug-in averages data points with 
identical positions. This sets, in effect, a window size of 0.

• 1 – Rectangular. The plug-in performs a standard moving average. 
All points within the rectangle (the window) receive the same 
weight.

• 2 – Gaussian. Applies a Gaussian weighting function.
• 3 – Triangular. Applies a triangular weighting function.
• 4 – Lorentzian. Applies a Lorentzian weighting function.
• 5 – Biexponential. Applies a biexponential weighting function.

Output Options A number from 0 to 2. The number sets one of the following options:

• 0 – Overlays the unsmoothed plot of each array on the smoothed 
plot.

• 1 – Displays smoothed and unsmoothed plots for each array.
• 2 – Displays smoothed, unsmoothed, and error plots for each array.

X-axis Label The text that appears beneath the X-axis of the plot as a label.

Y-axis Label The text that appears beside the Y-axis of the plot as a label.

Y-axis Range (min) The minimum value on the Y-axis.

Y-axis Range (max) The maximum value on the Y-axis.

X-axis Range (min) The minimum value on the X-axis.

X-axis Range (max) The maximum value on the X-axis.
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CGHSmooth Plot

Purpose: The CGHSmooth Plot is the output of the CGHSmooth plug- in. It 
contains separate, stacked plots of smoothed log ratio data for each of the 
selected arrays in the current experiment. 

To open: Click OK in the CGHSmooth Parameters dialog box. See 
“CGHSmooth Parameters” on page 106. 

Plot(s) Depending on the selected output option, the main plotting area shows up 
to three plots for each array in the active experiment. The plots can 
include unsmoothed and smoothed log ratio plots, and an error plot. 

Edit Opens a menu with a Copy Plot(s) to Clipboard option. If you select this 
option, the program copies the plots to the clipboard as an image. You can 
then paste the image into a document in another program.

Figure 22 CGHSmooth Plot
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When you right- click anywhere within the plotting area, a shortcut menu 
opens with these options:

Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 110.

Save as Opens a Save dialog box, where you can select a location for the *.png 
image file of the plots. 

Print Opens the Windows Page Setup dialog box, where you can set page 
size, margins, and orientation, and select a printer. From there, you 
click OK to open the Windows Print dialog box, where you can set 
print options and print the plot.

Zoom In Opens another menu that allows you to zoom in the plot. You can 
zoom in several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to zoom in on.

Zoom Out Opens another menu that allows you to zoom out the plot. You can 
zoom out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.
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Chart Properties

Purpose: The Chart Properties dialog box lets you create titles and 
legends, as well as change the appearance, for the CGHSmooth, Echo 
Example or MovAvg Example plots. 

To open: Use the CGHSmooth, Echo Example, or MovAvg Example plug- in 
to produce a plot. Right- click within the plotting area, then click 
Properties in the shortcut menu. You can also open this dialog box when 
you right- click within the line plot in the Graphical Differential Aberration 
Summary dialog box. See “Graphical Differential Aberration Summary” on 
page 275 in the CGH Interactive Analysis User Guide.

This dialog box has four tabs. At any point, click OK to accept the settings 
in all four tabs, or click Cancel to close the dialog box without making 
any changes to the settings.

Auto Range Opens another menu that allows you to zoom the plot to encompass 
the full range of the data. You can zoom in several ways:

• Both Axes – Appropriately zooms both axes of the specific plot to 
show the full set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis encompasses the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to encompass the full range of Y values of the 
data.

Option Description
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Title Tab

• Show Title – Mark this option to display a title across the top of the 
chart.

• Text – Type a title for the chart.

• Font – (Available if you mark Show Title) Click Select to open the 
Font Selection dialog box. Select the desired font attributes, then click 
OK.

• Color – (Available if you mark Show Title) Click Select to open the 
Title Color dialog box. Select or configure a color for the title, then 
click OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color (Edit Array Color) — Swatches Tab” on page 171.

Figure 23 Chart Properties dialog box – Title tab
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Legend tab

• Show Legend – Mark this option to display a legend at the bottom of 
the chart. When you mark this option, the other options in the tab 
become available.

• Outline – The line weight of the box that surrounds the legend. Click 
Select to open the Pen/Stroke Selection dialog box. Select the desired 
line weight, then click OK.

• Outline paint – The color of the box that surrounds the legend. Click 
Select to open the Outline Color dialog box. Select the desired color, 
then click OK. This dialog box is identical to the Select Color dialog 
box. See “Select Color (Edit Array Color) — Swatches Tab” on page 171.

• Background – The background fill color of the legend. Click Select to 
open the Background Color dialog box. Select the desired color, then 
click OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color (Edit Array Color) — Swatches Tab” on page 171.

Figure 24 Chart Properties dialog box – Legend tab
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• Series label font – The font of the text within the legend. Click Select 
to open the Font Selection dialog box. Select the desired font attributes, 
then click OK.

• Series label paint – The color of the text within the legend. Click 
Select to open the Series Label Color dialog box. Select the desired 
color, then click OK. This dialog box is identical to the Select Color 
dialog box. See “Select Color (Edit Array Color) — Swatches Tab” on 
page 171.

Plot Tab

Figure 25 Chart Properties dialog box – Plot tab
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• Within the Plot tab, you can set these properties in the Domain Axis 
tab:

Property Details

General

Label A custom label for the X-axis of the chart. Type the desired label.

Font The font for the custom label on the X-axis. Click Select to open the 
Font Selection dialog box. Select the desired font attributes, then click 
OK.

Paint The color of the custom label on the X-axis. Click Select to open the 
Label Color dialog box. Select the desired color, then click OK. This 
dialog box is identical to the Select Color dialog box. See “Select Color 
(Edit Array Color) — Swatches Tab” on page 171.

Other – Ticks tab

Show tick labels Mark this option to show, or clear it to hide, the numerical values on 
the X-axis.

Tick label font The font for the numerical values on the X- axis. Click Select to open 
the Font Selection dialog box. Select the desired font attributes, then 
click OK.

Show tick marks Mark this option to show, or clear it to hide, tick marks on the X-axis.

Other – Range tab

Auto-adjust range Mark this option to automatically set the range of values on the X-axis 
to include all data.

Minimum range value (Available if you do not mark Auto-adjust range) The lowest value 
represented on the X-axis.

Maximum range value (Available if you do not mark Auto-adjust range) The highest value 
represented on the X-axis. The program automatically converts large 
numbers to scientific “E” notation – for example, 1.22E8.
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• Within the Plot tab, you can set the following properties in the 
Appearance tab:

Property Details

Outline stroke The thickness of the lines that enclose each plot. Click Select to open 
the Stroke Selection dialog box. Select the desired line thickness, then 
click OK.

Outline paint The color of the lines that enclose each plot. Click Select to open the 
Outline Color dialog box. Select the desired color, then click OK. This 
dialog box is identical to the Select Color dialog box. See “Select Color 
(Edit Array Color) — Swatches Tab” on page 171.

Background paint The color of the background within each plotting area. Click Select to 
open the Background Color dialog box. Select the desired color, then 
click OK. This dialog box is identical to the Select Color dialog box. See 
“Select Color (Edit Array Color) — Swatches Tab” on page 171.

Orientation Select either Vertical (X-axis on the bottom of the chart) or Horizontal 
(X-axis on the left side of the chart).
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Other tab

The Other tab offers these options:

• Draw anti- aliased – Mark this option to minimize distortion and visual 
artifacts in the plot image. This produces a smoother image, but it can 
be less sharp than the original one.

• Background paint – The color of the chart outside of the plotting area 
and legend. Click Select to open the Background Color dialog box. 
Select the desired color, then click OK. This dialog box is identical to 
the Select Color dialog box. See “Select Color (Edit Array Color) — 
Swatches Tab” on page 171.

The other options are for future expansion, and are not available in the 
current release of DNA Analytics.

Figure 26 Chart Properties dialog box – Other tab
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Choose Gene List Color 

Purpose: To distinguish multiple gene list names by color

To open: Right- click Gene View, click Create Gene List > Change..., or in 
Data Navigator, right- click a specific gene list, click View in Table > 
Color.

Swatches Tab Choose color based on color samples (Swatches)

HSB Tab Choose colors based on an HSB schema (Hue, Saturation, and Brightness 
or Value). See “Select Color (Edit Array Color) — HSB Tab” on page 172.

RGB Tab Choose colors based on an RGB schema (Red- Green- Blue). See “Select 
Color (Edit Array Color) — RGB Tab” on page 173.

Recent: Choose a recent color selection.

Reset Click to return HSB or RGB values back to default values.

Figure 27 Choose GeneList Color dialog box
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Confirm overwrite

Purpose: When you import an experiment, it can contain designs and/or 
arrays that have the same names as those already available in Genomic 
Workbench. This dialog box allows you to select which designs and/or 
arrays to overwrite.

To open: This dialog box appears when you import a ZIP format 
experiment file, and it contains designs and/or arrays that are already 
available in Genomic Workbench. See “To import an experiment file” on 
page 23.

Select the designs you wish to overwrite

Design The names of the designs in the imported file that have the same names 
as designs that are already available in Genomic Workbench.

Overwrite Mark the check box next to each existing design that you want to 
overwrite.

Select All Marks all of the check boxes under Overwrite.

Figure 28 Confirm overwrite dialog box
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Deselect All Clears all of the check boxes under Overwrite.

Select the microarrays you wish to overwrite

Array Identification number or barcode of the array

Name The name of the array in the imported file that has the same name as 
array that is already available in Genomic Workbench.

Overwrite Mark the check box next to each existing array that you want to 
overwrite.

Select All Marks all of the check boxes under Overwrite.

Deselect All Clears all of the check boxes under Overwrite.

OK Overwrites the selected files (both designs and arrays) and closes the 
dialog box.

Cancel Closes the dialog box, and returns you to the Import (experiments) dialog 
box. See “Import (experiments)” on page 149.

Create Experiment

Purpose: Creates an organizational unit (an experiment) that allows you 
to view and analyze array data in Genomic Workbench. You populate the 
experiment with links to array data files that are available in the program, 
a process that you can start from this dialog box. See “To create a new 
experiment” on page 25.

Figure 29 Create Experiment dialog box
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To open: In the Home tab of Genomic Workbench, click Create 
Experiment.

Name (Required) The name of the new experiment. This name identifies the 
experiment within the program and in exported reports and files. 

Description (Optional) Brief information that will later help to identify the experiment.

Properties Opens the Experiment Properties dialog box, where you can select array 
data files to populate the new experiment. See “Experiment Properties” on 
page 133.

OK Closes the dialog box and creates the new experiment.

Cancel Closes the dialog box without creating an experiment.

NOTE Click Properties to open the Experiment Properties dialog box to populate your new 
experiment with array data. Otherwise, the program creates an empty experiment. You can 
also add arrays to the experiment later. See “To add arrays to an experiment” on page 26.
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Create Gene List

Purpose: To limit the genes presented in Gene View to a preselected 
number valuable for interpreting data

To open: Right- click Gene View, and click Create Gene List.

Name Type in name of gene list.

Build Select the genome build for the genes to be selected for list.

Description Describe the type or nature of the genes in the list.

Set Chromosome Start-Stop

Select a chromosome and a region in Chromosome View for selecting the 
genes in the list before you open the Create Gene List dialog box.

Figure 30 Create Gene List
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User Defined Select to choose region from which the genes in Gene View will be 
selected. The chromosome selection list and the Start and Stop positions 
on the Y axis are activated when this option is selected. With this option 
you can override the selections you made before opening Create Gene List.

For complete
gene view

Select all the genes in Gene View.

For aberrant
region below

cursor

Select those genes that appear in the aberrant region just below where the 
cursor sits in Gene View. Not operational in Genomic Viewer; depends on 
analysis.

Chromosome If you select User Defined, you can select a different chromosome than 
had been selected before opening the Create Gene List dialog box.

Start If you select User Defined, you can type in a Start position for defining 
the region contained the genes to be in the list.

Stop If you select User Defined, you can type in a Stop position for defining 
the region contained the genes to be in the list.

Color

Change... Click to change the color of the gene list name in Data Navigator. See 
“Choose Gene List Color” on page 117.
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Create Track (CGH only)

Purpose: The Create Track dialog box allows you to create a track for a 
chromosomal region based on an assigned chromosomal region. You can 
display one or more tracks alongside the genes and data in Gene View. 
See “To show tracks in Gene View” on page 57.

To open: Right- click in the plotting area of Gene View for the CGH 
application, then click Create Track in the shortcut menu. 

Name Type a name for the track. This name identifies the track when it appears 
in views, lists, and the like.

Build (Available if you select User Defined in Set Chromosome Start- Stop.) 
Select the genome build with which to associate the track.

Description Type descriptive text to attach to the track for reference.

Set Chromosome
Start-Stop

This parameter defines the region of the chromosome for which the track 
will be defined. Select one of these options:

Figure 31 Create Track dialog box
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• User Defined – Allows you to define an arbitrary region of any 
chromosome. If you select this option, select the desired chromosome in 
Chromosome, then type the beginning (Start) and end (Stop) locations 
of the desired interval.

• For complete gene view – The chromosomal region that currently 
appears in Gene View.

OK Creates the track. To view the track in Gene View, use the Tracks tab of 
the User Preferences to enable it. See “Preferences – Tracks” on page 164. 
To export the track, see “To export tracks” on page 40.

Cancel Closes the dialog box without creating a track.

Customize Search Link

Purpose: This dialog box allows you to create a custom Web search link in 
the shortcut menu that appears when you right- click a tab entry. The link 
opens the URL of your choice, and passes the tab entry to it as a search 
string. See “To create a custom Web search link” on page 63.

To open: Right- click any entry in a tab in Tab View, other than a column 
heading, then click Customize Link... 

Figure 32 Customize Search Link dialog box
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URL Name The name of the custom Web search link that appears in the shortcut 
menu (see above). To edit an existing custom Web search link, select it 
from the list.

URL The full uniform resource locator (URL) of the desired search page. For 
the query string value, type <target> 

For example, this URL passes the selected Tab View entry to google.com:

http://www.google.com/search?hl=eng&q=<target>

New Opens an Input dialog box, where you can type a name for a new custom 
Web search link. Click OK to accept the name and add it to the URL 
name list.

Update Saves the settings in the dialog box.

Delete Deletes the currently selected custom Web search link.

Close Closes the dialog box.

Design Properties

Purpose: Provides general and detailed information about a given 
microarray design. See “To view the properties of a specific design” on 
page 31.

To open: In the Data pane of the Navigator, right- click the name of a 
genome build within a design folder, then click Show Properties. Several 
tabs are available.

Attribute tab

Lists general identifying attributes of the array design, and statistics such 
as the total number of features in the design.
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Non-Unique Probes tab

Lists the non- unique probes in the design. Non- unique probes bind to 
more than one location in a target genome. 

Figure 33 Design Properties dialog box – Attribute tab
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S. No The sequence order of the probes within the tab. 

Probe The name of the each non- unique probe.

Value The chromosomal locations to which each of the probes binds. Because 
these are non- unique probes, more than one location appear for each 
probe.

Figure 34 Design Properties dialog box – Non-Unique Probes tab
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Data tab

Lists the names of the probes in the design and the genomic locations to 
which they are designed. The tab displays the probes for one chromosome 
at a time.

Select
Chromosome

The chromosome whose probes appear in the list. To view the probes 
designed to a different chromosome, select one from this list.

Probe The name (Probe ID) of each probe.

Chromosome The name of the chromosome to which the probe is designed.

Start The location on the selected chromosome of the first base pair to which 
each probe is designed.

Stop The location on the selected chromosome of the last base pair to which 
each probe is designed.

Figure 35 Design Properties dialog box – Data tab
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Echo Example Plot

Purpose: The Echo Example Plot is the output of the Echo Example 
plug- in. It displays the log ratio data for the selected chromosome in the 
active experiment. Data from all of the selected arrays in the experiment 
appear as a series of stacked plots, one for each array. 

To open: Activate the desired experiment, select the desired chromosome 
in Genome View, then click Tool > Plugin > Echo Example.

Edit Opens a menu with a Copy plots to clipboard command. This command 
copies all of the plots to the clipboard as an image. You can then paste 
the image into a document in another program.

Plots Each plot displays the log ratio data for the selected chromosome from an 
individual array in the experiment.

You can right- click anywhere within each plot to open a shortcut menu 
with these options:

Figure 36 Echo Example Plot
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Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 110.

Save as Opens a Save dialog box, where you can select a location for a saved 
*.png image file of the plots. 

Print Opens the Windows Page Setup dialog box, where you can set page 
size, margins, and orientation, and select a printer. From there, you 
click OK to open the Windows Print dialog box, where you can set 
print options and print the plot.

Zoom In Opens another menu that allows you to zoom in the plot. You can 
zoom in several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to zoom in on.

Zoom Out Opens another menu that allows you to zoom out the plot. You can 
zoom out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.

Auto Range Opens another menu that allows you to zoom the plot to encompass 
the full range of the data. You can zoom in several ways:

• Both Axes – Appropriately zooms both axes of the specific plot to 
show the full set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis encompasses the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to encompass the full range of Y values of the 
data.
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Edit Array Color

Purpose: Allows you to show, change, and/or export the color(s) assigned 
to the arrays in an experiment.

To open: In the Experiment pane, right- click the name of an experiment, 
then click Edit Array Color.

Edit Opens a menu with a Copy command. If you click Copy, the program 
copies the list of arrays and their assigned colors to the clipboard. You 
can then paste the list into a document in another program such as Word 
or PowerPoint.

Select Array Mark the check box for the array(s) whose color you want to change.

Color Opens the Select Color dialog box, where you can pick a new color for the 
selected array(s). If more than one array is selected, all of the selected 
arrays assume the new color. For more information about selecting array 
colors, see “To change the display color of an array” on page 46.

Figure 37 Edit Array Color dialog box
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Select All Marks all of the check boxes.

Deselect All Clears all of the check boxes.

Edit Color Opens the Select Color dialog box, where you can pick a new color for the 
selected array(s). (Same function as the buttons under Color)

Restore default Restores the system default colors to all arrays.

OK Saves all assigned array colors and closes the dialog box.

Cancel Closes the dialog box without saving any changes.

Edit Array Order

Purpose: Changes the display order of the arrays in an experiment. This 
can affect the order in which array data appear in Gene View and Tab 
View.

To open: In the Experiment pane, right- click the name of an experiment, 
then click Edit Array Order.

Figure 38 Edit Array Order dialog box
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Array Name The arrays in the selected design, listed in the order that they currently 
appear in the Experiment.

Design Select a design from the list. The arrays from the selected design appear 
under Array Name.

Order by (Optional) Select an array attribute. The program can re- order arrays 
based on their respective values for the selected attribute.

Moves a selected array up in the list. To select an array, click its name.

Moves a selected array down in the list. To select an array, click its name.

OK Reorders the arrays and closes the dialog box.

Cancel Closes the dialog box without reordering any arrays.

Experiment Properties

Figure 39 Experiment Properties dialog box
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Purpose: Allows you to select array designs and data to link to an 
experiment. See “To add arrays to an experiment” on page 26.

To open: In the Create Experiment dialog box, click Properties, or in the 
Experiment pane of the Navigator, right- click the name of an experiment, 
then click Show Properties.

Experiment Name (Read only) The name of the selected experiment.

Description Description that was entered when the experiment was created. 

Select Design

Designs Lists all of the designs available in the program. Select the design 
associated with arrays that you want to add to the experiment.

Genome Builds Lists the genome build(s) associated with the design. Select the desired 
genome build to display the arrays associated with a single genome build.

Arrays

Array List Lists the arrays in the selected design that are available for this 
experiment.

• To select an array for subsequent transfer to the Selected Array List, 
click its name. 

• To select additional arrays, control- click their names. 

• To select a contiguous block of arrays, click the name of the first array, 
then shift- click the name of the last one.

Selected Array
List

Lists the arrays that you have selected for this experiment.

Moves the selected arrays in Array List to the Selected Arrays List. You 
can move arrays from as many designs as you like, as long as they are all 
associated with the same genome build.

Moves all of the arrays in Array List to the Selected Arrays List.

Removes an array from the Selected Array List. To select an array for 
removal, click its name. If desired, you can re- add an array.

Clears the Selected Array List.
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OK Populates the experiment with the arrays in the Selected Array List, and 
closes the dialog box.

Cancel Closes the dialog box without adding any arrays to the experiment.

Export

Purpose: Allows you to select a location for an exported file. 

To open: This dialog box appears after you select specific experiment(s), 
track(s), filter(s) or array attributes to export. See “To export 
experiments” on page 38, “To export tracks” on page 40, “To export filters 
(CGH only)” on page 39 or “To export array attributes” on page 37.

Look in Displays the folder or other location whose contents appear in the main 
pane of the dialog box. To select another folder or other location, click .

Navigates up one level.

Figure 40 Export dialog box – Several types of file exports use this dialog box. This spe-
cific example exports selected experiment(s) as a ZIP format file.
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Navigates to the Desktop.

Creates a new folder in the selected location in Look in.

Displays the names, only, of folders, files, and other locations in the main 
pane of the dialog box.

Displays both the names and details of folders, files, and other locations 
in the main pain of the dialog box.

Main pane Displays the folders, files, and other locations in the selected location in 
Look in. The program restricts listed files to the type selected in Files of 
type. To select file, click its name. To open a folder or other location, 
double- click its name.

File name Displays the name of the file to which the exported content will be saved. 
To change the name, you can either select a file in the main pane of the 
dialog box, or type a new name.

Files of type Restricts the files listed in the main pane to those of the appropriate type 
for your specific kind of export. To show all files, click , then select All 
Files.

Export Saves the selected content to the location specified in the dialog box.

Cancel Cancels your selections and closes the dialog box.
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Export Array Attributes – Array

Purpose: Allows you to select array designs whose selected attributes you 
will then export. See “To export array attributes” on page 37.

To open: In the Home command ribbon, click Export > Array 
Attributes..., or in the Experiment pane of the Navigator, right- click the 
name of an experiment, then click Export Attributes.

Select Design

Designs Lists all of the designs available in the program. Select the design 
associated with arrays whose attributes you want to export.

Genome Builds Lists the genome build(s) associated with the design. Select the desired 
genome build to display the arrays.

Arrays

Array List Lists the arrays in the selected design.

Figure 41 Export Array Attributes – Array tab dialog box
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• To select an array for subsequent transfer to the Selected Array List, 
click its name. 

• To select additional arrays, control- click their names. 

• To select a contiguous block of arrays, click the name of the first array, 
then shift- click the name of the last one.

Selected Array
List

Lists the arrays that you have selected for this experiment.

Moves the selected arrays in Array List to the Selected Arrays List. You 
can move arrays from as many designs as you like, as long as they are all 
associated with the same genome build.

Moves all of the arrays in Array List to the Selected Arrays List.

Removes an array from the Selected Array List. To select an array for 
removal, click its name. If desired, you can re- add an array.

Clears the Selected Array List.

Next Moves to Attribute tab for attribute removal. See “Export Array Attributes 
– Attribute” on page 139.

Cancel Closes the dialog box without selecting any arrays and their attributes to 
be exported
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Export Array Attributes – Attribute

Purpose: Allows you to remove selected array attributes from the list you 
will then export. See “To export array attributes” on page 37.

To open: In the Home command ribbon, click Export > Array 
Attributes..., or in the Experiment pane of the Navigator, right- click the 
name of an experiment, then click Export Attributes. After selecting the 
arrays whose attributes you intend to export, click Next.

Attributes

Selected
Attribute List

Lists the attributes for the selected arrays that will be exported if you 
click OK.

• To select an attribute for subsequent removal to the Attribute List, click 
its name. 

• To select additional attributes, control- click their names. 

• To select a contiguous block of attributes, click the name of the first 
attribute, then shift- click the name of the last one.

Figure 42 Export Array Attributes – Attribute tab dialog box
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Attribute List Lists the attributes that will not be exported for the selected arrays.

Removes an attribute from the Selected Attribute List. To select an 
attribute for removal, click its name. If desired, you can re- add an 
attribute.

Clears the Selected Attribute List.

Moves the selected attributes in the Attribute List to the Selected Attribute 
List. 

Moves all of the attributes in the Attribute List to the Selected Attribute 
List.

Back Moves back to the Array tab for array selection or removal.

OK Opens the Export dialog box. See “Export” on page 135.

Cancel Closes the dialog box without exporting any attributes.
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Export Experiments

Purpose: Allows you to select experiments for export. The program 
exports all array designs and data associated with the experiments as a 
single ZIP file. This file does not include any parameter settings, array 
selections, or results. See “To export experiments” on page 38.

To open: In the Home tab, click Export > Experiments... 

Export Format The file format for the exported experiment file. Select one of these 
options: 

• 5.0 Format – Exports the experiment(s) in a format that you can 
import into Genomic Workbench. This is the most current experiment 
format, but it is not compatible with previous versions of the program.

• 3.0 Format – Exports the experiment(s) in a format that you can 
import into Agilent CGH Analytics 3.0 or later. This is a “legacy” format 
that you can use to maintain compatibility with earlier versions of the 
program.

Figure 43 Export Experiments dialog box
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Select experi-
ments to export

Lists all experiments available for export. Mark each experiment you want 
to export.

Select All Selects all experiments for export.

Deselect All Clears all check boxes under Select experiments to export.

OK Opens an Export dialog box. See “Export” on page 135.

Cancel Cancels the export and closes the dialog box.

Export Filters (CGH only)

Purpose: Allows you to select feature- level, array- level, and/or aberration 
filters to export as a single *.xml file. You can create and use filters only 
if you have a DNA Analytics application license. See “To export filters 
(CGH only)” on page 39.

To open: In the Home tab, click Export > Filters...

Figure 44 Export Filters dialog box
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Select filters to
export

Lists all of the filters available in the program. The table has these 
columns:

• Export – Mark the check box next to each filter that you want to 
export.

• Filter – The name of each filter.

• Type – The type of content to which the program applies each filter.

Select All Selects all available filters for export.

Deselect All Clears all of the check boxes under Select filters to export.

OK Opens the Export dialog box, where you can select a location for the 
exported *.xml file of filters. See “Export” on page 135.

Cancel Cancels the export and closes the dialog box.
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Export Tracks

Purpose: Allows you to select tracks to export as a single BED format file. 
See “To export tracks” on page 40.

To open: In the Home tab, click Export > Tracks...

Select tracks Lists all of the tracks available in the program. Mark the check box next 
to each track that you want to export.

For more information about tracks, see “To create a track (CGH only)” on 
page 35 and “To show tracks in Gene View” on page 57.

Select All Selects all available tracks for export.

Deselect All Clears all of the check boxes under Select Tracks.

OK Opens the Export dialog box, where you can select a location for the 
exported BED format file. See “Export” on page 135.

Cancel Cancels the export and closes the dialog box.

Figure 45 Export Tracks dialog box
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Find in column

Purpose: This dialog box allows you to set search parameters for a 
specific column entry. Based on these parameters, the program can 
highlight the row of the first entry that matches. The cursor then moves to 
the location defined in the row.

To open: Right click any entry in a tab in Tab View other than a column 
heading, then click Find in column in the shortcut menu. 

Find in column Type all or part of the entry you want to find.

Direction Select a search direction:

• Up – Sets the search to scan the column you clicked in an upward 
direction from the currently highlighted row.

• Down – Sets the search to scan the column you clicked in an 
downward direction from the currently highlighted row.

Conditions Mark any of these search options:

• Match Case – Mark this option to take case into account. For example, 
if you mark Match Case, and you type aa351 in Find in column, the 
search finds the next entry in the column that contains aa351. It does 
not find entries that contain AA351 or Aa351.

Figure 46 Find in column dialog box
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• Match whole word – Mark this option to only find entries in which the 
complete entry matches what you type in Find in column. For example, 
if you type AA351 in Find in column, and mark Match whole word, the 
program finds the next AA351 entry. It does not find entries such as 
AA3512 or AA351992.

Find Next Finds the next matching entry in the selected column, and moves the 
cursor to the location defined in the row that contains the entry.

Cancel Closes the dialog box.

Go To Gene/Genomic Location

Purpose: To find a specific gene location in Gene View by either selecting 
the RefSeq by Symbol or by selecting the Genomic Location.

To open: Click Home > Go to Gene/Genomic location.

RefSeq by Symbol Select the Reference Sequence accession symbol from NCBI, and click Go.

Genomic Location • Chromosome – The chromosome number.

• Base Position – The position on the chromosome.

 

Figure 47 Go To Gene/Genomic location dialog box
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Click Go after selecting the chromosome number and the position of the 
gene on the chromosome.

Cancel Closes the dialog box.

Import

Purpose: Allows you to select files for import into Genomic Workbench.

To open: In the Home tab, click Import, then select any kind of import 
except Genome Build or Track. The type of file to be imported appears in 
the title of the dialog box. To import a gene list, right- click the Gene List 
folder in the My Entities List pane of the Navigator, then click Import 
Gene List.

Use the standard Windows Explorer commands in the dialog box to select 
a file for import. 

Figure 48 Import dialog box
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For some imports, you can select multiple files. Click the name of the first 
file, then control- click the names of additional files. To select a contiguous 
block of files, click the name of the first file in the block, then shift- click 
the name of the last one.

File name Displays the name of a file you select for import.

Files of type The program restricts the list of files to the specific types expected for the 
import. To display all files, click ,then select All Files.

.

Import Imports the file into the program. In some cases, the name of this button 
is Open, rather than Import. Also, when you click Import, in many cases 
one or a series of additional dialog box(es) allows you to further define 
the content for import. See the instructions for each specific type of 
import in Chapter 1.

Cancel Cancels the import and closes the dialog box.

Type of import File type

FE array File *.txt

Axon array file *.gpr

UDF file *.txt

Design file (GEML) *.xml

Axon design file *.gal

Array attributes *.txt

Experiments *.zip

Filters *.xml

Gene list *.txt
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Import (experiments)

Purpose: Allows you to select the specific experiments within a ZIP 
format experiment file to load into the program. See “To import an 
experiment file” on page 23.

To open: In the Home tab, click Import > Experiments. In the dialog box 
that appears, select the desired ZIP format experiment file, then click 
Import.

Select
experiments to

import

These columns appear:

• Import – Mark the check box next to the experiment(s) that you want 
to import.

• Experiment – The names of the experiments available for import in the 
ZIP format experiment file.

• Version – Version of DNA Analytics used to export the original 
experiment

Select All Selects all of the experiments in the ZIP file for import.

Deselect All Clears all of the check boxes under Import.

Figure 49 Import dialog box (for experiments)
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OK Imports the selected experiments into the program. If the name of an 
imported array design or data file matches one that is already available in 
the program, the Confirm overwrite dialog box appears, where you can 
select the data and/or design files that you want to overwrite. See 
“Confirm overwrite” on page 118.

Cancel Cancels the upload and closes the dialog box.

Import GEML design files

Purpose: To view information in the design file and to remove any files 
that you don’t want to import.

To open: In the Home tab, click Import > Design Files > GEML File... 
Select the desired *.xml design files, then click Open.

Figure 50 Import GEML design files dialog box
150 Data Viewing User Guide



Data Viewing Reference 3
File Name The name(s) of the design file(s) to be imported.

ID The Agilent ID number for the design file

Type The application type, which can be CGH, ChIP, miRNA, or gene expression.

Species At present, Genomic Workbench supports these species:

• H. sapiens

• M. musculus

• R. norvegicus

Genome Build The genome build with which this design is associated.

Status • Overwrite – Appears when the design file has been updated and will 
overwrite any existing one of the same name.

• Valid – Appears when the file is new.

• Corrupt – Appears when the file is corrupt.

Remove Click  to remove a specific design file from the list. 

Start Import Starts the import of the design files in the list.

Cancel Cancels the upload and closes the dialog box.

Import Genome Build

Purpose: To import a new set of genome build files into Genomic 
Workbench. See “To import a genome build” on page 19.

Figure 51 Import Genome Build dialog box
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To open: In the Home tab, click Import > Genome Build.

Species The genome’s species of origin. The program supports these species:

• H. sapiens

• M. musculus

• R. norvegicus

Build Name The name of the build to be imported.

Refseq File The location of the RefSeq database file. This file contains chromosomal 
locations of genes. To select a Refseq file, click Browse...

CytoBand File The location of the applicable cytoband file. This file contains graphical 
cytoband information for Gene View and Chromosome View. To select a 
cytoband file, click Browse...

OK Imports the genome build and closes the dialog box.

Cancel Cancels the import and closes the dialog box.

Import Track

CAUTION Import only Agilent-provided genome build files. 

Figure 52 Import Track dialog box
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Purpose: Allows you to import a BED format track file. See “To import 
tracks” on page 20. Track information can appear in Gene View. See 
“Preferences – Tracks” on page 164.

To open: In the Home tab, click Import > Track...

Species Select the species to which the track relates. The program supports these 
species:

• H. sapiens

• M. musculus

• R. norvegicus

Build Name This list contains the available genome builds for the selected species. 
Select the desired genome build.

Color Shows the currently assigned display color for the track. To change this 
color, click Change... For details, see “Choose Gene List Color” on 
page 117. You select track colors in exactly the same way as gene list 
colors.

Track Name Type a name to identify the imported track. 

Track File Type the location of the BED track file that you want to import, or click 
Browse... to select a file.

Browse... Opens an Open dialog box, where you can select the BED track file that 
you want to import.

OK Imports the track into the program.

Cancel Cancels the import and closes the dialog box.
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Microarray Properties - Attribute Tab

Purpose: Lists the values of attributes associated with an array. You can 
also edit the values of specific attributes. To create a new attribute, see 
the Sample Manager User Guide.

To open: For any array in the Data folder or Experiments folder, 
right- click the array name, then click Show Properties. For non- Agilent 
arrays, only the Attribute tab appears.

Attribute Tab • Attribute — Lists the attributes in the array by name. 

• Value – Indicates the values, if any, for each array. To edit the value of 
an attribute, select a new value for it under Value. Alternatively, click 

, then type or edit the value. 

Close Closes the dialog box.

For information about the options in the other tabs in this dialog box, see 
“Microarray Properties -  FE Headers” on page 156, and “Microarray 
Properties -  FE Features Tab” on page 155.

Figure 53 Microarray Properties dialog box listing Attributes and their values
154 Data Viewing User Guide



Data Viewing Reference 3
Microarray Properties - FE Features Tab

Purpose: Allows you to view feature information for arrays extracted with 
Agilent Feature Extraction software. 

To open: Right- click an array name, then click Show Properties.

Selection List Select the chromosome whose feature information you want to display.

List Box Displays FE features and the associated data. The columns are:

Figure 54 Microarray Properties dialog box listing FE Features and associated data

Index FeatureNum ProbeName

GIsPosAndSignif LogRatioError PValueLogRatio

gProcessedSignal rProcessedSignal gMedianSignal

rMedianSignal gBGSubSignal rBGSubSignal

gIsSaturated rIsSaturated gIsFeatNonUnifOL

rIsFeatNonUnifOL gIsBGNonUnifOL rIsBGNonUnifOL

rIsPosAndSignif gIsWellAboveBG rIsWellAboveBG
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Microarray Properties - FE Headers

Purpose: Allows you to view feature parameters, statistics and constants 
for an array extracted with Agilent Feature Extraction software. 

To open: For Agilent arrays in the Data folder or Experiments folder, 
right- click the name of the array, then click Show Properties.

Index Displays a sequential index to help identify FE properties.

Name Displays feature parameters, statistics, and constants for the whole array.

Value Displays the value for each parameter, statistic, and constant.

Close Closes the dialog box.

 

Figure 55 Microarray Properties dialog box listing FE Headers their values
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MovAvg Example Parameters

Purpose: This dialog box allows you to set display parameters for the 
MovAvg Example plug- in. The plug- in computes a 10- point moving average 
of the data from the selected chromosome in the selected arrays of the 
active experiment. It displays stacked plots of moving averages for all the 
arrays, one plot per array. You must have Perl installed on your computer 
to use this plug- in.

To open: Click Tool > Plugin Settings > MovAvg Example. This dialog 
box also opens when you click Tool > Plugin > MovAvg Example, if Don’t 
show again is cleared. 

Parameters Set any of these parameters:

Figure 56 MovAvg Example Parameters dialog box

Parameter Description

X-axis Label The text that appears beneath the X-axis of the plot as a label.

Y-axis Label The text that appears beside the Y-axis of the plot as a label.

Y-axis Range (min) The minimum value on the Y-axis.

Y-axis Range (max) The maximum value on the Y-axis.

X-axis Range (min) The minimum value on the X-axis.

X-axis Range (max) The maximum value on the X-axis.
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Don’t show again Mark this option to prevent the appearance of this dialog box in the 
future when you click Tool > Plugin > MovAvg Example. To restore the 
dialog box so it appears again, click Tool > Plugin Settings > MovAvg 
Example, then clear Don’t show again.

OK Click to accept the parameters and prepare the plot. You can further 
refine the appearance of the plot once the plug- in generates it.

Cancel Discards any changes you made, and closes the dialog box.

The plug- in program itself (MovAvg Example.pl, located in the Plugins 
folder of the DNA Analytics installation folder on your computer) is a 
short Perl program. It is a good example of how computed columns are 
processed. 

The plotting is very simple, but the simple plug- in architecture of MovAvg 
Example.pl allows you to write your own computational methods to 
analyze data from selected arrays in the CGH application. 

• Within the code of the plug- in, you can add text strings to column 
headers to control format. 

• To create a line graph instead of a scatter plot, you append 
-plotline to a column header. 

• To prevent the plug- in from plotting a specific column, you append 
-noplot to the column heading. Note that the plug- in removes this 
extra text from the header before it displays it on the plot. The extra 
text does not appear in figures, and is only used to control the 
format of the plot. 

• MovAvg.pl shows how column- naming can be used. As you read the 
first line (which contains the header text), you can add text to the 
existing headers or add text to the headers for your generated 
columns, as well, to give you a small amount of formatting control.
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MovAvg Example Plot

Purpose: This plot displays the output of the MovAvg Example plug- in. 
The plug- in computes a 10- point moving average of the data from the 
selected chromosome in the selected arrays of the active experiment. 

To open: Click OK in the MovAvg Example Parameters dialog box. See 
“MovAvg Example Parameters” on page 157. 

Plot(s) The main plotting area shows moving average line plots for the selected 
chromosome. A separate plot appears for each array.

Edit Opens a menu with a Copy Plot(s) to Clipboard option. If you select this 
option, the program copies the plots to the clipboard as an image. You can 
then paste the image into a document in another program.

Figure 57 MovAvg Example Plot
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When you right- click anywhere within the plotting area, a shortcut menu 
opens with these options:

Option Description

Properties Opens the Chart Properties dialog box, where you can change the 
appearance of many aspects of the plot. See “Chart Properties” on 
page 110.

Save as Opens a Save dialog box, where you can select a location for the *.png 
image file of the plots. 

Print Opens a Page Setup dialog box, where you can set page size, margins, 
and orientation, and select a printer. From there, you click OK to open 
the Print dialog box, where you can set print options and print the plot.

Zoom In Opens another menu that allows you to zoom in the plot. You can 
zoom in several ways:

• Both Axes – Zooms in the Domain (X) axis for all stacked plots, and 
zooms in the range Range (Y) axis for the specific plot in which you 
clicked.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots.
• Range Axis – Zooms in the Range (Y) axis for the specific plot in 

which you clicked.
You can also drag across an area of one of the plots to select an area 
to zoom in on.

Zoom Out Opens another menu that allows you to zoom out the plot. You can 
zoom out several ways:

• Both Axes – Zooms out the Domain (X) axis for all stacked plots, 
and zooms out the range Range (Y) axis for the specific plot in 
which you clicked.

• Domain Axis – Zooms out the Domain (X) axis for all stacked plots.
• Range Axis – Zooms out the Range (Y) axis for the specific plot in 

which you clicked.

Auto Range Opens another menu that allows you to zoom the plot to encompass 
the full range of the data. You can zoom in several ways:

• Both Axes – Appropriately zooms both axes of the specific plot to 
show the full set of data.

• Domain Axis – Zooms in the Domain (X) axis for all stacked plots 
so this axis encompasses the full range of X values of the data.

• Range Axis – Zooms in the Range (Y) axis for the specific plot in 
which you clicked to encompass the full range of Y values of the 
data.
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Preferences – License

Purpose: To view and update the license for each application you have 
installed with the DNA Analytics software, if necessary.

To open: Right- click anywhere in the graphical interface, either in 
Genome View, Chromosome View or Gene View, click Preferences and 
click the License tab.

Host Name Displays the host name, automatically.

Select Analysis
Application

Select the DNA Analytics application for which you have a license.

Figure 58 Preferences dialog box displaying License tab options
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Server Location Server location should be selected if you have a concurrent user license. If 
appropriate, click to enable and type in the name of your license server. 
The default is @localhost. Replace localhost with the name of the 
computer used as the license server. Text License is disabled (grayed) if 
Server Location is enabled.

Text License Text licenses are used if you have a workstation license. If you do have a 
workstation license, paste your license in the text box. If you have entered 
a license previously, it is displayed in the text box. Server Location is 
disabled (grayed) when Text License is enabled.

Apply Apply your changes to the parameters.

OK/Cancel Accept your changes and exit, or cancel all changes and return to the 
previously selected parameters.
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Preferences – Miscellaneous 

Purpose: This dialog box allows you to set up eArray access and to 
change the location for data.

To open: In the Home tab, click User Preferences..., then click the 
Miscellaneous tab.

The following options are relevant to data/content set- up in Genomic 
Workbench. For information about the other tabs in this dialog box, see 
“Preferences – View Tab” on page 167, “Preferences – Tracks” on page 164 
and “Preferences – License” on page 161.

eArray User
Details

Sets login details for the Agilent eArray Web site.

• URL – At present, https://earray.chem.agilent.com and grayed out

Figure 59 Preferences dialog box – Miscellaneous tab
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• Username – The name registered on the eArray site.

• Password – The password registered on the eArray site.

Scale Select the scale for rendering the appearance of data in the display. 

Data Location The folder where the program stores array data and design files. To select 
a location, click Browse...

Apply Applies any changes to the preferences.

OK Accepts any changes and closes the dialog box.

Cancel Cancels all changes and closes the dialog box.

Preferences – Tracks

Figure 60 Preferences dialog box displaying Tracks Tab options
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Purpose: To import and set up the appearance of tracks next to the Gene 
View. Tracks are additional graphic displays of genomic information 
loaded from an external file and that align with genomic coordinates in 
Gene View.

To open: Right- click anywhere in the graphical interface, either in 
Genome View, Chromosome View or Gene View, click Preferences and 
click the Tracks tab.

Font Options

Select the font type, style and size for the gene annotations that appear in 
the selected tracks.

Tracks List

Track Name Name of the track already loaded or imported

Show in UI Mark the check box to view the track next to Gene View.

Show in Report Mark the check box to view the track information in all the reports.

Genomic
Boundaries

Click to use the track to define only the regions that aberration detection 
algorithms will run. You can choose to do this for only one track.

Delete Click to delete the track from the list. 

Details Click to view all the chromosome locations defined in the track.

Import Click to import new tracks.

Up Click to move a track up the list.

Down Click to move a track down the list.

Visualization Parameters

Genes These options affect the appearance of Gene View.

• Orientation – Type in a number in degrees to set the angle at which 
the Gene Symbols will appear in Gene View and the Track Annotations 
appear in the tracks.

• Show Gene Symbols – Mark to show them in Gene View, and clear the 
check box to hide them.
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Genomic
Boundaries

These options allow you to include or exclude the Genomic Boundaries 
from the analysis.

Tracks These options affect the appearance of the Track Views.

• Show Annotations – Mark to show the names of the gene regions for 
the tracks, and clear to hide them.

• Show Overlaid – Mark to overlay all the tracks that appear next to 
Gene View, and clear the check box to view the information in separate 
tracks.
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Preferences – View Tab

Purpose: To set up how the Views are aligned and settings displayed for 
the scatter plot in Genome Viewer

To open: Right- click anywhere in the graphical interface, either in 
Genome View, Chromosome View or Gene View, click Preferences and 
click the View tab.

The View tab options control the general characteristics of how data are 
displayed on your monitor, but in Data Viewing all the data analysis 
options are grayed out.

Figure 61 Preferences dialog box displaying View tab options for Data Viewing
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View Alignment

Orientation Selects the orientation of three views in the main window:

• Horizontal – Reorients three views to a horizontal aspect in the order 
of Gene, Chromosome, and Genome views, top to bottom. The Navigator 
and Tab View orientation remains unchanged. 

• Vertical – Displays all views in a vertical aspect, left to right: Navigator, 
Genome, Chromosome, and Gene views. This is the default display. See 
“Genomic Workbench Main Window” on page 66.

Rendering Style Selects the way Chromosome and Gene data are rendered on your screen.

• Overlaid – Displays data from multiple arrays superimposed one on top 
of another (default).

• Stacked – Displays data from each array in a separate plot. 

Data Visibility

View Choose what features you want to display for the Genome, Chromosome, 
and Gene views, either individually or together. Select one or more check 
boxes:

• Scatter Plot

• Scatter Tool Tip (Gene View only)

Rendering patterns

Design type Specify the type of design to which you are applying these patterns: CGH, 
Expression, or Other.

Styles Set up the parameters for displaying your data.

• Scatter Plot - -  Specify how to display individual data points as: Color 
filled circles (ellipses), + signs, x signs, circles, rectangles and filled 
rectangles for all the points or for red and/or green intensities.

Apply Apply your changes to the parameters.

NOTE Rendering scatter plots for more then 10 high density arrays in the Chromosome View may 
take significant time. Selecting ellipses as the rendering style for CGH scatter plots can also 
decrease performance. Please change the rendering style for CGH data from ellipse to the 
plus (+) or cross hair sign.
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Scroll to Column

Purpose: This dialog box allows you to select a column. The program then 
scrolls the tab so that you can see the selected column.

To open: Right- click a column heading in Tab View, then click Scroll To 
Column... in the shortcut menu. 

Select column Lists the columns available in the currently selected tab. Select the one 
you want to view.

OK Scrolls the current tab so that you can see the selected column.

Cancel Closes the dialog box.

Figure 62 Scroll to Column dialog box
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Search probes in eArray

Purpose: To select the probes you want to update in eArray

To open: Right- click Gene View, and click Search probes in eArray.

Select a chromosome and a region in Chromosome View for selecting the 
probes related to the genes in this region.

User Defined Select to choose the region from which the probes to be searched in 
eArray will be selected. The chromosome selection list and the Start and 
Stop positions on the Y axis are activated when this option is selected. 

For complete
gene view

All the probes related to the genes in Gene View will be searched.

For aberrant
region below

cursor

Selects those probes for the genes that appear just below where the cursor 
sits in Gene View. Not operational without a license. 

Chromosome If you select User Defined, you can select a different chromosome than 
had been selected before opening this dialog box.

Start/Stop If you select User Defined, you can type in Start and Stop positions for 
defining the region contained the genes to be in the list.

Figure 63 Search probes in eArray
170 Data Viewing User Guide



Data Viewing Reference 3
Select Color (Edit Array Color) — Swatches Tab

Purpose: To select a color for each array based on color samples 
(swatches)

To open: Right- click on an array in an experiment, click Edit Array Color 
and click Swatches tab.

HSB Tab Choose colors based on an HSB schema (Hue, Saturation, and Brightness 
or Value). See 

RGB Tab Choose colors based on an RGB schema (Red- Green- Blue).

Recent: Choose a recent color selection.

Reset Click to return HSB or RGB values back to default values.

Figure 64 Select Color — Swatches Tab
Data Viewing User Guide 171



3 Data Viewing Reference
Select Color (Edit Array Color) — HSB Tab

Purpose: To select a color for each array based on an HSB schema (Hue, 
Saturation, and Brightness)

To open: Right- click on an array in an experiment, click Edit Array Color 
and click HSB tab.

Hue Click the H button, and move the slider up and down, or go up and down 
the list of numbers, to select the hue or color of the array.

Saturation Click the S button, and move the slider up and down, or go up and down 
the list of numbers, to select the saturation level for the color.

Brightness Click the B button and move the slider up and down, or go up and down 
the list of numbers, to select the brightness level for the color.

RGB Numbers Reflect the amount of red, green and blue in the resulting color.

Reset Click to return HSB values back to default values.

Figure 65 Select Color — HSB Tab
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Select Color (Edit Array Color) — RGB Tab

Purpose: To select a color for each array based on an RGB schema 
(Red- Green- Blue)

To open: Right- click on an array in an experiment, click Edit Array Color 
and click RGB tab.

Red Move the slider to change the amount of red in the color. Or, click the up 
or down arrow to select a number.

Green Move the slider to change the amount of green in the color. Or, click the 
up or down arrow to select a number.

Blue Move the slider to change the amount of blue in the color. Or, click the up 
or down arrow to select a number.

Reset Click to return RGB values back to default values.

Figure 66 Select Color — RGB Tab
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Select data type for experiments (UDF files – CGH or CH3)

Purpose: Allows you to specify the mathematical form of the data in an 
imported UDF file, and its associated application type. See “To import a 
UDF file” on page 15.

To open: In the Home tab, click Import > Array Files > UDF File... In 
the dialog box that appears, select the desired UDF file, then click Open.

Experiment Name By default, the experiment name is the name of the imported UDF file. To 
change the name, double- click it, then edit it as desired.

Data Type Select the mathematical form of the array data in the UDF file. The 
options are:

• ratio

• log2 ratio

• log10 ratio

• ln ratio (base e)

Design type Select the application type (CGH, ChIP, or expression, for example) 
associated with the array data in the UDF file.

Continue Accepts your selections, and goes to the next step in the UDF import 
process.

Cancel Cancels the UDF import.

Figure 67 Select data type for experiments dialog box
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Set genome build and species for Axon design files

Purpose: Allows you to set the species and genome builds associated with 
imported Axon design file(s), and to remove specific designs files from the 
import, if necessary. See “To import GenePix/Axon design files” on 
page 19.

To open: In the Home tab, click Import > Design Files > Axon File... In 
the dialog box that appears, select at least one Axon design file, then click 
Import.

No. An index number within the dialog box for each Axon file.

File Name The names of each Axon design file selected for import.

Figure 68 Set genome build and species for Axon design files dialog box
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Species The species associated with each design file. If a species is incorrect, 
select the correct one from the appropriate list.

Genome Build The genome build associated with each of the design files. If a genome 
build is incorrect, select the correct one from the appropriate list.

Status The status of the file is one of the following:

• Valid – The file is a new file that can be imported.

• Overwrite – The file is a valid design file, but when you import it, it 
will replace an existing design that has the same name.

• Corrupt – The file failed validation. When you start the import process, 
the program ignores the file.

Remove Click  to remove a specific design file from the list. This can be 
useful if you select a design file in error, or if you do not want to 
overwrite an existing one.

Start Import Imports the file(s) and closes the dialog box. 

Cancel Cancels the import and closes the dialog box.
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Track

Purpose: This dialog box allows you to view the chromosome locations in 
the track.

To open: Click the Details link next to the desired track in the Tracks 
tab of the Preferences dialog box. See “Preferences – Tracks” on page 164.

Track Parameters These parameters appear:

Figure 69 Track details

Parameter Description

Name The name of the track.

Species The species to which the track applies.
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Data Tracks must contain entries for at least these four columns in the table:

The other columns are additional BED track file columns that can appear 
for some tracks. DNA Analytics does not render these.

Close Closes the Track dialog box.

Format The format of the track data. DNA Analytics supports the BED format.

Genome Build The specific genome build of the species to which the track applies.

Description Descriptive text saved with the track.

Parameter Description

Column Description

Chromosome The name of the chromosome

Start The first base pair of the particular feature in the chromosome.

Stop The last base pair of the particular feature in the chromosome.

Name The name of the feature. This name appears alongside the defined 
region for the feature.
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UDF Import Summary (CGH or CH3)

Purpose: Reports how many lines of data were successfully imported from 
a UDF file, and how many lines were skipped. Skipped lines can be 
caused by missing chromosome mapping information, or improper 
formatting of the UDF file.

To open: Import a UDF file (see “To import a UDF file” on page 15). This 
dialog box appears after you map the columns of the UDF file.

Table Displays the file name of the imported UDF file, the number of lines that 
were successfully imported, and the number of lines, if any, that were 
skipped during import. If many lines were skipped, re- examine the data 
for improper formatting or missing chromosome mapping information.

OK Closes the dialog box.

Figure 70 UDF Import Summary dialog box 
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Universal Data Importer - Map Column Headers

.

Purpose: Allows you to set up a universal data file (UDF) for import. You 
specify several properties associated with the UDF, and identify the 
contents of each column of data in the file. You can also save column 
mappings for re- use.

To open: As you go through the UDF import process (see “To import a 
UDF file” on page 15), in the Select data type for experiments dialog box, 
click Continue. See “Select data type for experiments (UDF files – CGH or 
CH3)” on page 174.

Species Info

Select Species Select the species associated with the array data in the UDF. The program 
supports these species:

• M. musculus

Figure 71 Universal Data Importer - Map Column Headers dialog box
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• H. sapiens

• R. norvegicus

Select Genome
Build

Sets the species- specific build to use.

Mapping Info

Select Mapping Applies a previously saved column map to the current UDF. A column 
map identifies the contents of each column of data. To create a new 
column map for the current UDF, select CUSTOM.

Save Mapping As Saves the column map under a new name. Opens an Input dialog box, 
where you can type a name for the new map. 

Barcode Info

Virtual Barcode A number that uniquely identifies the data in the UDF. Typically, an 
Agilent microarray slide has a physical barcode that enables Genomic 
Workbench to track the data from the slide as it goes through the steps of 
an analysis workflow. A “virtual” barcode is, by default, a 
system- generated ID that serves the same purpose for data from UDFs. 
You can also specify a virtual barcode of your own choosing.

Use System
Generated

Barcode

By default, the virtual barcode assigned to the array data in a UDF is a 
number that is generated internally by the program. To specify a virtual 
barcode of your own choosing, clear Use System Generated Barcode, then 
type a new number in Virtual Barcode.

Table

This table allows you to identify the contents of the columns of data in 
the UDF. The first row of the table lists the column heading information 
from the UDF. The second row contains lists of labels that you apply to 
each column, and the rest of the table displays lines of data from the 
UDF. If the UDF contains data from Agilent CGH arrays, the column 
headings will exactly match the labels in the lists.

In the list below each column heading, select the applicable label. You 
must use each of the labels exactly once, except LogRatio, which you can 
use more than once. These labels are available:
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Reset Clears all the column labels in the second row of the table. If you have 
selected a saved column mapping, this command also clears the labels in 
the saved map.

Import Imports the UDF file with the specified parameters, and opens the UDF 
Import Summary dialog box (see “UDF Import Summary (CGH or 
CH3)” on page 179).

Cancel Cancels the import and closes the dialog box.

Column Label This column contains:

ProbeName Names of probes.

ChrName Names of chromosomes.

Start First chromosomal location to which each probe is designed.

Stop Last chromosomal location to which each probe is designed.

Description Text annotation related to the probe.

LogRatio Array data values that correspond to each probe. You can use this 
label more than once.

NOTE If you select a saved column mapping, then change or reset the column labels in the table, 
the program changes or resets the saved column map as well. 
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