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In This Guide…
This book describes the Agilent ChemStation Security Pack for 
AD, GC, LC, CE, LC-MSD, and CE-MSD techniques. The Security 
Pack is an add-on module for the Agilent ChemStation and 
helps you meet the requirements of the U.S. Food and Drug 
Administration’s (FDA) ruling on electronic records and 
signatures, CFR 21 Part 11.

1 Introduction

The first chapter provides an overview of Security Pack and 21 
CFR Part 11—FDA’s final rule for electronic records and 
electronic signatures.

2 Prerequisites, Configuration, and Installation

This chapter shows you how to setup the Security Pack in 
ChemStation.

3 A Brief Tour

Refer to this chapter for getting an introduction to the main 
concepts behind Security Pack.

4 Access Level and Batch Review Interface Changes

This chapter includes a description of the changes that have 
been made in operator mode and batch review mode.

5 Data Reanalysis

Use this chapter as a guidance for reanalyzing your data.

6 Administrator Tasks and Reference

This chapter provides an overview of administrative tasks.
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1 Introduction
Introducing Security Pack

Introducing Security Pack

Security Pack revision B.04.0x is built upon the ChemStation B.04.01. It is an 
add-on module to the Agilent ChemStation for GC, LC, CE, LC-MSD, CE-MSD 
and A/D targeted to support the compliance requirements for 21 CFR Part 11.

Security Pack provides changes to the ChemStation result management.

• It provides logon and locking procedures for each individual application.

• It offers a fully automated result and meta data versioning—each time a new 
result is calculated and displayed, the Security Pack stores this result with 
a new version number in the database.

• It protects data directory with NTFS permission rights.

Security Pack changes the operator privileges of the ChemStation operator 
user level and adds the ChemStore C/S relational database for result 
management and data storage.

The changes on the ChemStation are discussed and explained in this manual; 
for a description of the ChemStore C/S product, please refer to the Agilent 
ChemStore C/S Concepts Guide.
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21 CFR Part 11

Effective August 20, 1997, the U.S. Food and Drug Administration (FDA) 
released and published a new rule to enable pharmaceutical companies to 
approve their results with electronic signatures and to transfer paper-trail 
documentation into electronic records. This rule is known as 21 Code of 
Federal Regulations Part 11 (referred to as 21 CFR Part 11) and applies to all 
industry segments regulated by the FDA.

The impact of this rule on current work practices and data handling in the 
pharmaceutical industry has been much higher than expected. “The industry 
wanted to have a rule on electronic signatures, but what they got was a rule 
on electronic records.” (Martin Browning, former FDA inspector, during a 
validation seminar in Washington D.C.)

21 CFR Part 11 places high emphasis on the implementation of all measures to 
protect and secure electronic records. Besides all uncertainties and changes 
that 21 CFR Part 11 requires in the behavior of both the pharmaceutical 
industry and the vendors of chemical analysis equipment, it is well worth 
implementing in today’s laboratories because it can help the industry with one 
of the most important issues in pharmaceutical research—bringing new drugs 
faster to market.

The major benefits of this shift towards electronic data management are in the 
potential productivity increase for the industry. The industry can decrease its 
data output on paper, speed up the data review and approval process, and 
benefit from new automation technology based on computerized system 
control, for example, in manufacturing or dissolution drug release testing.

In addition to this rule on electronic records, other general requirements for 
computerized systems are brought to the auditor’s attention. These rules cover 
the basic requirements of validation which are limiting data access and 
ensuring data integrity and data traceability.

It is, of course, the industry that has to make sure that its work practices 
support the FDA rules, but most of the requirements also affect the chemical 
analysis systems and suppliers of these systems.
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21 CFR Part 11

This manual outlines how a chromatographic data handling system can help 
the industry to comply with the FDA rules. Security Pack meets the demands 
on data security, data integrity, and audit-trail using either a standalone 
Microsoft® Access database or a server-based Oracle® database.

21 CFR Part 11 Requirements

To fulfill the FDA rules and guidelines for compliant electronic records and 
computerized systems, it is important to understand the basic aspects of 
secure data handling.

• Data security—physical protection of data by limiting access to the system 
and preventing unauthorized access.

• Data integrity—protecting raw and meta data and preventing these from 
unauthorized modification, and linking raw data and results to reproduce 
the original results at any time, for example, in an audit situation and 
document each new result copy.

• Audit traceability—documenting who did what to the results an when, and 
tracing the user adding new reanalyzed versions to the original raw data.

General Aspects of Data Security in Computerized 
Networks—Open Versus Closed Systems

Before discussing details of data security in a chromatographic system, some 
general aspects of data security in a computerized network need to be 
considered.

It is generally known that data transfer over a public network can be accessed 
by unauthorized external persons, “hackers”, who gain access either for 
personal amusement or intentional fraud.

If an electronic identification comprising user ID and a password is used to 
approve confidential or important data, users must be sure that their 
signatures are unbreakably linked to the data and that nobody can copy this 
signature or get access to the passwords. In a public system, this would 
require additional encryption technology, for example, a private/public key 
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combination of data encryption. In contrast, if a computerized system is 
protected from unauthorized access, users can be sure that their signatures 
are private and are not accessible to unauthorized individuals.

The FDA also distinguishes between these two scenarios and defines them as 
open and closed systems. A public network system can therefore only be 
viewed as an open system and a protected network as a closed system, if it 
fulfills additional requirements.

The Security Pack is designed for and supported in a closed system only.

In FDA terms, “closed system means an environment in which access is 
controlled by persons who are responsible for the content of electronic 
records on the system” (11.3.5). The evidence of a system being a closed 
system is not a one-time check but an ongoing process of executing and 
documenting the system controls that make sure that the system is closed. In 
contrast, in an open system, “those persons being responsible for the content 
of electronic records do not control the system access.”

As a result, open systems require additional encryption technology for all data 
transfer over the network.
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2 Prerequisites, Configuration, and Installation
Prerequisites

Prerequisites

PC Hardware

The Security Pack does not require a large amount of resources from the 
computer, the minimum requirements for the PC are the same as for 
ChemStore C/S. Refer to the ChemStore C/S Installation Guide for details 
about minimum hardware requirements.

Operating System

Security Pack requires Windows XP with Service Pack 3, Windows 2003 R2 
server with Service Pack 2, or Windows Vista with Service Pack 1. 
Additionally, the hard drive on which the ChemStation Plus system is installed 
must use the NTFS format. Format the hard drive prior to the installation of 
the Security Pack.

Client Configuration

The following section will discuss how Security Pack ties into the Windows 
security tools and how the default setup configures the security settings under 
Windows. For further information on the administration of both, the Windows 
permissions and the database, please refer to Chapter 6, “Administrator Tasks 
and Reference,” starting on page 73.

Security Pack utilizes the Windows group security concept to add full 
compliance with 21 CFR Part 11 to ChemStation Plus. The section “Windows 
User Management” on page 17 briefly outlines this concept and section 
“Minimum Requirements for Windows User Administration” on page 17 
explains an easy configuration that is fully sufficient for a standalone system.

However Agilent recommends to customize the Windows security 
configuration according to the needs in the laboratory. Sections “Minimum 
Requirements for Windows User Administration” on page 17 and “Windows 
Group Policies” on page 18 briefly outline how these features built into the 
Microsoft Windows operating system can be used to make ChemStation Plus 
easier to use. 
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Windows User Management

The core part of the Windows user management in standalone usage is the 
group concept. Each Windows user is a member of a group. These groups then 
are assigned certain permissions, like logging on to a computer, installing 
software, access to certain files, etc.

Each user has its own profile, where the layout of their desktop, the 
applications they see in the start menu, and other things are stored.

System policies can be used to further customize the security settings. Using 
system policies usually requires a Windows domain, where the policies will be 
maintained centrally.

Minimum Requirements for Windows User Administration

As the user identification required by 21 CFR Part 11 for electronic records is 
done by the ChemStation plus Security Pack, the Windows user management 
can be simplified. It is sufficient to divide users in two groups:

• Operators, that normally use the ChemStation plus system and do not need 
to change database connections or do backups.

• Administrators, that do database backups and change database 
connections.

One user configuration example would use only one generic Windows user 
log-on for all users sharing one computer. Security Pack manages the system 
security and the user identification. This generic user only needs to be a 
member of the Windows user group Users. This user must not be a member of 
the Windows user group Power Users or Administrators.

NOTE When using Windows systems that are not purchased from Agilent, it is necessary to grant 
specific permissions on operating system folders used by the application. The configuration 
should be done according to the document ’Configure and Maintain your Agilent 
ChemStation computer’ (P/N G2170-90132). An electronic version of this documented is 
located on your ChemStation installation CD.
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For the administrators, we recommend personalized Windows user accounts, 
to track their actions. All users with this job description must be a member of 
either the Windows user group Power Users (Windows XP only) or 
Administrators. Chapter 6, “Administrator Tasks and Reference,” starting on 
page 73 provides further details on the security settings chosen to prevent 
unauthorized deletion of data.

Windows Group Policies 

Windows operating systems include numerous commands and settings that 
control and manage the entire computer system. One example is the control 
panel that allows for installation and removal of applications, changes of the 
PC clock and so on. An unauthorized modification of the Windows system 
settings usually causes general problems of operating the PC, but some 
settings just modify your electronic records like changing the local PC clock 
time. Security Pack is designed to be fully secure even in a system that offers 
system setting access to standard users.

However, in order to minimize the operators access to the system control, we 
recommend to restrict access to certain important commands and programs 
from the Windows system control to users with administrative rights. The best 
way of implementing the restricted access in a Windows networked data 
system are Windows 2003 server group policies. Please refer to the Microsoft 
Operating System user documentation and online help for details.

Group policies can be used to further secure and simplify system usage. They 
allow a customizing of the desktop of each user and restrict access to 
important programs and commands for the system and control. Group policies 
operate in an entire domain and are setup by the domain controller. Contact 
your local IT organization for implementing these features, as they should fit 
in the overall security strategy of your laboratory.

For use with Security Pack, we recommend the following limitations for the 
operators:

• Remove Run command from Start menu

NOTE If your Windows networked environment is structured in domains, each domain user group 
must be explicitly listed as a member of the local user group for Security Pack to work 
properly. The domain user group must not be member of the Power Users group (Windows 
XP only). 
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• Disable Registry editing tools

• Disable Task Manager

• Disable Change Password (if generic logon for users is used)

Members of the local Power Users (XP only) and Administrators group should 
have the same restrictions, except the permission to change their own Window 
password.

The other system control functionality is not required for the administrative 
tasks of the Security Pack either.

User Profiles

To ensure that all users always have the same desktop and the same start 
menu on all computers, a mandatory user profile can be used. These profiles 
are stored on a central server and cannot be changed by the individual users. 
We recommend to remove all applications except the ChemStation Plus 
applications from the start menu as well as all icons from the desktop for the 
users that are operators.

Depending on the SOP used for back-up and archival the users that perform 
the administrative tasks need access to Windows Explorer and/or the 
Windows backup application.
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Installation Procedure

Installation Procedure

To ensure a successful installation of the Security Pack, please follow this 
procedure step by step.

Preparation

1 Ensure that your PC meets the minimum requirements as outlined in the 
Agilent ChemStore C/S Installation Guide.

2 Ensure that your operating system is Windows XP with Service Pack 3, 
Windows 2003 R2 with Service Pack 2, or Windows Vista Business with 
Service Pack 1.

3 Ensure that the partition where Security Pack will be installed is in NTFS 
format.

4 If not already done, install the ChemStation software. Details on the 
ChemStation installation can be found in the respective ChemStation 
installation guide.

5 If not already done, install ChemStore C/S from the ChemStore/Security 
Pack CD-ROM. Details on the ChemStore C/S installation can be found in 
the respective ChemStore C/S installation guide.

6 Reboot your PC after ChemStore installation.

Security Pack Installation

1 Log on to the operating system as a user with administrative privileges

2 Browse the ChemStore/Security Pack CD-ROM for the G2183 folder. 

3 Select to start G2183\setup.exe.

4 On Windows Vista: Confirm the User Account Control message with Allow.

5 Reboot the PC after the installation has finished.
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Post Installation 

1 Turn on Windows Object Access Auditing to audit the access to the local 
chem32\chemstor\database directory. See also chapter “Security 
Settings” on page 90. On stand-alone systems, this can be done by Local 
Security Policies, located under Administrative Tools of the Control Panel. 
Navigate to the console tree Audit Policy. Change the settings according to 
Figure 1 and verify that the settings are effective after re-logging on to the 
operating system. In a networked environment, this should be done on a 
domain level.

2 Change the Security log settings to prevent deletion of events. Open   
Administrative Tools from Start > Programs (XP) or Start>Control Panel (Vista)

Figure 1 Audit Policy Settings 
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2 Prerequisites, Configuration, and Installation
Installation Procedure

3 Windows XP only: Open Computer Management and expand the Event 
Viewer, then right-click on security > properties. Select Do Not Overwrite Events 
(Clear Log Manually) as in Figure 2 on page 22.

Figure 2 Event Log Settings (Windows XP)
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4 Windows Vista only: Open Control Panel > Administrative Tools and expand 
the Event Viewer, then right-click on Windows logs > Security > Properties. 
Select Do Not Overwrite Events (Clear Log Manually) as in Figure 3 on page 23.

5 If applicable create a new database as outlined in section “Creating New 
Databases in the Standalone Version” on page 82.

6 Configure a database connection for the users, as outlined in section 
“Assigning a Database Connection on Windows XP operating systems” on 
page 79 or “Assigning a Database Connection on Windows Vista operating 
systems” on page 80 respectively

7 The passwords for the default users should not be changed until the system 
is fully operational and productive. Agilent recommends to assign users 
with the tasks related to the default users. Once these users are established 
the default user accounts should be disabled.

Figure 3 Event Log Settings (Windows Vista)
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2 Prerequisites, Configuration, and Installation
Installation Procedure

8 A successful installation of the Security Pack is documented in the 
ChemStation menu Help under About ChemStore. This screen will display 
both the ChemStore revision and the Security Pack revision number.

Table 1 Default Users and Functions

User Name Password Function

Admin admin System administrator, has all permissions

Manager manager Lab supervisor, can not compact a DB and 
administer users

Chemist chemist Data reviewer, can not administer users and create 
studies

Operator operator Sample operator, can only create batches of 
assigned data

Support support Support logon, has all permissions

NOTE Please ensure that always at least two users with the permission “Administer users” are 
configured in your database. Due to the strict account lockout policy it might happen that a 
single account might be locked out and the database can no longer be administered.

Figure 4 ChemStore revision and the Security Pack revision number
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Adding a ChemStation Instrument

If you decide later to add another ChemStation instrument to your Security 
Pack installation, it is mandatory to run the Security Pack installation again 
after the installation of the ChemStation instrument. This will ensure that the 
data from the second instrument is also fully protected.

To do this, perform step 1 and step 3 from the “Installation Procedure” on 
page 20.

Now the directories of the new ChemStation instrument are protected as 
outlined in the section “Security Settings” on page 90.

Removing Security Pack

If you want to remove the Security Pack from your computer, you need to 
uninstall ChemStore from your computer. This will also remove the Security 
Pack. Removal of the software requires a user that is a member of the 
Windows user group Administrators. Only these users can completely remove 
all directories created by ChemStore and protected by the ChemStation Plus 
Security Pack. Refer to the Agilent ChemStore C/S Installation Guide for 
details on how to remove ChemStore from your computer.
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3 A Brief Tour
Mandatory Logon, User Management and Lock-out

Mandatory Logon, User Management and Lock-out

Security Pack allows only authorized users to start the application. The user 
management is a user privilege arranged in the ChemStore C/S database. It 
should be performed only by administration managers. To prevent 
unauthorized access to the database or unauthorized use of the database, each 
ChemStation Plus user is given an access password and a set of permissions, 
defining which facilities are available for that user (see Agilent ChemStore C/S 
Concepts Guide, “Setting Up and Managing Users”, page 99).

To prevent unauthorized access of data within a different section of the same 
database, Security Pack allows to restrict data access of data subsets in one 
database. Access is restricted on a study level where the study is an 
organizational element in the database that can be set and managed by 
Security Pack administrators from within the database.

One of the most important requirements for limited system access is that only 
the individual users know their passwords and even the system administrator 
can only manage the users and the user IDs—but not the passwords. The 
implementation in the software therefore is a two-step approach. First, the 
database administrator sets up user identifications and appropriate 
permission rights for the individual users. Second, when the users first log on 
to the application, a log-on screen prompts for specification of the individual 
password.

This two step approach ensures that only the individual users knows their 
passwords. If the password is lost or forgotten, the database administrator can 
clear the user’s password and make the user re-run password specification 
and log-on script.

Figure 5 Prompt for specification of individual password
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After clicking OK, the Change User Password dialog box is automatically opened.

To apply the company’s individual password policy for minimum password 
length, expiry date, password uniqueness and account lock-out, set the 
appropriate parameters in the ChemStore C/S application.

Following the FDA regulations, both the ChemStation and ChemStore C/S can 
be locked while they are running. The lock-out may be private, when either the 
current user’s password or an administrator’s password must be supplied to 
unlock the session, or non-private, when any valid user ID/password 
combination is sufficient to unlock the session.

All manual session locks allow ongoing monitoring of the ChemStation Plus 
applications in case, for example, a sequence is running. The locking is also 
individual for each instrument session thus allowing to operate more than one 
instrument version from one PC.

Figure 6 Change User Password Dialog Box

Figure 7 Password Settings Dialog Box
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To lock a session privately, hit the lock button in ChemStation or 
ChemStore toolbar or select the ChemStation menu View > Lock 

ChemStation > privately or the ChemStore C/S menu Administration > Lock Session 
> privately. The ’Privately locked by user …’ dialog box can only be unlocked by 
entering a valid user name and password.

To lock a session non-privately, select the ChemStation menu View > Lock 
ChemStation > non-privately or the ChemStore C/S menu Administration > Lock 
Session > non-privately. The Locked by user ‘…’ dialog box can be unlocked by 
entering any valid user name and password.

Each unsuccessful attempt to unlock (privately and non-privately) the session 
is noted in the ChemStore database logbook as "failed to logon" with the 
ChemStation client and the PC host name (e.g. instrument 1) as identifier.

NOTE Administrators have the permission to unlock a privately locked session in cases where a 
users leaves the lab without handing over a running session. A hand-over can be done by a 
non-private session lock.

Figure 8 Private ChemStore session lock



ChemStation Security Pack User’s Guide 31

A Brief Tour 3
Mandatory Logon, User Management and Lock-out

According to 21 CFR Part 11, an automatic inactivity lock-out is available as 
an additional security feature. It allows users with the appropriate privilege 
"Administer users" to set a time after which the session is locked, and can be 
unlocked only by supplying a valid password. 

The inactivity time-out is controlled from the ChemStore database. If it is 
enabled in the ChemStore review client, all ChemStation sessions will be 
under control of this timeout setting. In case of a client/server installation of 
ChemStore, all connected ChemStation Plus clients in the network will have 
the same setting for the inactivity timeout. This inactivity setting can only be 
modified from the ChemStore review client from users with administrative 
privileges. It can not be modified by any system operator on a local data 
acquisition PC or data review PC without the appropriate ChemStore 
privileges.

The passwords that are valid depend on whether the session has been locked 
privately or non-privately.

In contrast to the manual locks, the automated lock minimizes the locked 
ChemStation session window to prevent undesired interruption of the work 
with the foreground application.

Figure 9 Non-private ChemStore session lock
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Figure 10 Time-based session lock settings

NOTE The default setting is Wait 10 min.
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Storage of Data

The application is designed to store all data in the ChemStore C/S database. 
Within the database, runs can be logically grouped for any desired purpose. 
Such a group of runs is referred to as a study. A user with the requisite 
permissions may create as many studies as desired, but each study must be 
identified with a unique name. During study creation, study access is also 
configured. Only users who can access (they are “assigned to studies”) a study 
can get access to the study data or transfer data into this study. The 
assignment of studies to users is an additional security measure to restrict 
data access within the database to those individuals that own the data.

Following the rule of part 11 on the requirements of closed systems the "assign 
studies to users" privilege is thus an additional tool to ensure closed 
subsystems within the closed system of global database. 

This is particularly important in cases where different laboratories or even 
different departments store their data in one ChemStation Plus result 
database. By assigning parts of the database (studies!) to the different user 
groups the database administrator ensures that data is only accessible to the 
data owners and that is invisible to database users who do not own these data 
(i.e. from different departments who use the same database for their results as 
well).

For more details on the assign studies to users functionality, please refer to 
ChemStore Concepts guide section "Setting up organizational information - 
assigning studies to users”.

When results are transferred from the ChemStation to ChemStore C/S, the 
individual runs (or group of runs) are assigned to a study; these runs, together 
with any previous runs assigned to the same study, are then available as a 
logical unit.

NOTE Assigning studies to users is not only a security tool but also helps increasing database 
performance on large systems. Studies containing unused or archived and deleted data 
should be de-assigned from all users. This change is reversible.
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The Security Pack is designed to store all data that the FDA defines as 
mandatory for data integrity:

• the chromatographic raw data—the full content of the d.files

• the meta data containing the information and algorithm to turn the raw 
data into meaningful results—methods and sequences

• the results as calculated in the ChemStation registers and selected in the 
report type

• additional data acquisition parameters like method, sequence, instrument 
logbooks, instrument serial numbers, and column parameters

To create a study, select in ChemStore C/S Administration > Create Study > Store 
in Addition and follow the default setup to ensure that your study stores all 
data.

Figure 11 Data storage configuration during study set-up

For further information on the study management, see Agilent ChemStore C/S 
Concepts Guide, “Setting Up Organizational Information.”

The database also links raw data with the corresponding meta data. It 
documents the result version along with the individual method version that 
was used to calculate the specified result.
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The meta data can be easily restored from one central Run information screen. 

To display the Run information screen, select  in ChemStore C/S. 

Figure 12 Run Information Screen

NOTE The Run information screen is only available in the ChemStore sample tab view.
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Data Transfer from ChemStation

During Data Acquisition

Before starting a single run or a sequence for data acquisition, the user has to 
setup the ChemStore organizational information that defines the sample 
storage location in the database and, if configured, the values for the custom 
fields. For details on the setup of the ChemStore organizational information, 
please refer to the Agilent ChemStore C/S Concepts Guide, Chapter 2, 
“ChemStore Concepts”, organizing results. 

The data transfer settings are set to transfer after each analysis. This 
configuration of the data transfer is user-independent and can not be changed. 
As soon as the data analysis part of the method is finished and the results are 
calculated, the data is transferred to the database with the ChemStore C/S 
ODBC data spooler. In case of an "Acquisition-only" run, the data is 
transferred when the acquisition is completed. 

During Data Reprocessing

A typical data analysis cycle consists of at least two steps:

1 Initial data analysis as part of the method execution right after data 
acquisition. 

2 A review of the results that were created as part of the data acquisition.

For acquisition-only runs only: Separate result calculation is executed at a 
later point in time as a user-configured batch in the ChemStation batch review 
window. 

The automated data transfer during data acquisition is described in the above 
section. The data transfer during the data review process is also managed by 
the application. As soon as one or more result values are changed or a new 
result is created, the Security Pack application transfers all runs with new 
results automatically to the ChemStore C/S database. The application 
automatically detects updated or new results by comparing the last actual 
value with the new value. Each result comparison is denoted in a text file 
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named Sec_Trac.txt. This file is stored along with the raw data files in the raw 
data *.d subdirectory. The data comparison is initialized by any activity 
creating a new result like:

• first pass result calculation after initial acquisition

• printing a report

• applying a data analysis method to a data file

• integrating a chromatogram with the integrate or auto-integrate commands

• modifying the calibration table

The application of manual integration events is different in the interactive 
data analysis view and in the batch review. The views are discussed separately 
in the next two sections:

• The interactive review in “ChemStation Data Analysis View” on page 37

• The batch review window for reprocessing of an entire batch of data in 
“ChemStation Batch Review” on page 39 

ChemStation Data Analysis View

The ChemStation data analysis view is designed for advanced review of 
individual data files, as well as reprocessing of sequences.

Sequence reprocessing offers certain recalibration options, like floating 
re-calibration or bracketing calibration. Other tasks - like modifying 
integration events or applying manual baselines - can be processed more 
conveniently in the batch review. For ChemStation operators these tasks are 
accessible in the batch review only.

Therefore, the standard data analysis view is not designed being the default 
data review window with the ChemStation Plus Security Pack. In addition, if 
the data storage is configured as recommended in “Storage of Data” on 
page 33 no data will be available on the hard disk any longer for loading into 
the data review. The data files are deleted immediately after the transfer to the 
database.
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In order to perform sequence reprocessing data has to be reloaded completely 
via the ChemStore Run Information panel. See also “Transferring Data to 
ChemStation from the Run Information Interface of ChemStore” on page 65. 
The sequence naming concept introduced with ChemStation B.02.01 helps 
avoiding interference with currently acquired data files.

Figure 13 ChemStation Plus Interactive Data Analysis View with ChemStation Operator 
Access Level

NOTE Sequence data acquired with ChemStation B.02.01 or higher can be reprocessed in Data 
Analysis view. This can be done in an idle on-line or off-line ChemStation instance.

Previously acquired sequence data needs to be reprocessed in ChemStation’s Method and 
Run Control view, preferably loaded to an off-line ChemStation instance.
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Another option is preventing ‘file deletion after transfer’ in the ChemStore 
study setup dialog. In any case the workflow should be well-defined and 
protected by user permissions. E.g. by withdrawing “Batch reload” 
permissions, the data flow can be forced in one direction only.

Data Traceability and Versioning in the Interactive Data Analysis View

The data review functions of the data analysis view of the ChemStation Plus 
are restricted to the ChemStation manager user level because the data 
versioning in this view does not cover the manual integration of a 
chromatogram.

ChemStation operators in the data analysis view can only execute a 
pre-defined method, reprocess a sequence with a different method or print a 
report. ChemStation operators cannot change the integration events or report 
type in this view. The ChemStation operator must use the batch review 
interface for reintegration of chromatograms.

What is different in the data analysis view compared to the batch review for 
manual integration?

• The manual integration events are not automatically stored with the run

• The peak table is updated immediately after the manual event was finished

• The application does not detect changed peak parameter and therefore does 
not transfer data to the database even if new results were calculated.

If the user wants to store the latest results in the database, the manual 
integration events must be saved to the data file and a report must be 
generated to initialize the result transfer.

ChemStation Batch Review

Data Traceability and Versioning in Batch Review

Batch review is the default view for reanalyzing data. It can be used for 
reprocessing the latest ChemStation sequence and for all runs that are 
submitted from the ChemStore C/S database for reanalysis. In the batch 
review also the ChemStation operator can reintegrate and recalibrate runs. 
Batch review also allows the review of a list of runs in one window. Users can 
step through runs and calculate new results both automatically and 
interactively.
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Versioning in Batch Review

For a detailed overview of the modifications of the batch review compared to 
the standard ChemStation Plus batch review operation, see “Changes to Batch 
Mode” on page 56. This section focusses on the data transfer from the batch 
review to the Chemstore C/S database.

The batch review includes a fully automated data versioning covering also the 
manual integration events. In the batch review, the manual events that were 
applied to a chromatogram are stored along with the chromatogram. 

In order to avoid the storage of preliminary results, the result creation is split 
in the graphical rework of a chromatographic data file and the result 
calculation. During the graphical rework of chromatograms and data files i.e. 
during drawing of a manual baseline, the peak table will not show the new 
results immediately like it does in the interactive data analysis. The peak table 

Figure 14 Batch Review Interface in ChemStation
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is locked until the calculation is actively performed and it includes a small info 
button that explains the different operation mode of the batch review in the 
ChemStation plus Security Pack batch review.

The result calculation is a separate step—graphical data review does not create 
a result.

As soon as the user calculates the result by pressing the Integrate button, the 
new results are calculated and they are compared with the last results that 
were stored. If there is any deviation, the data are transferred to the database 
creating a new result version.

Manual integration events are typically not stored with the method. In order 
to track these changes along with the other modifications the ChemStation 
plus Security Pack writes all changes including manual integration events to a 
text file that is stored along with the raw data in the *.d subdirectory of the 
ChemStation.

Figure 15 Peak Table Lock in the Batch Review with highlighted Integrate button
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The manual integration events are also transferred to the ChemStore run 
audit-trail. They can be reviewed with manual integration details button in the 
ChemStore audit-trail. This information can be re-used for a later recreation of 
the manual events i.e. in an audit situation. 

Figure 16 Review of Manual Integration Events in the ChemStore Audit Trail
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In addition, the application prompts the user for a comment to document the 
reason for the last change. The comment is documented in the ChemStore 
audit trail comment field along with a pointer to the text file for the proper 
identification of the changed events.

Figure 17 Result Comment after Manual Reintegration in Batch Review
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Overview of Data Transfer from ChemStation to ChemStore C/S 
Database

Any data that has been selected to be saved along with the results 
(chromatograms, spectra or raw data, method and sequence files in the 
client/server version) is transferred along with the analysis results. 

If configured in the study setups, the Security Pack deletes the raw data 
locally after the transfer to the database was performed successfully. 

The local delete process is controlled by a separate application, the ChemStore 
C/S ODBC spooler.

The spooler application handles the transfer to the server and makes sure that 
all data is integrated and stored in the database tables. This check for 
complete data transfer to the server database is mandatory to enable the 
delete process of the raw data on the local drive. The entire data transfer is 
documented in the sequence log book and in the ChemStore C/S audit trail. 

The spooler also controls and secures the data transfer from ChemStation to 
the ChemStation Plus database. In case of transfer problems or network 
trouble, the spooler pauses or stops the transfer after a certain time limit. 
After a spooler pause or spooler stop, the user can display the error and 
resume the data transfer in the spooler application after the error correction. 

Members of the Windows user groups Power Users (XP only) and 
Administrators can delete spooler jobs in addition to the review and resume 
function of system users. In case a spooler job is deleted, an entry in the 
Windows operating system security log is generated.

Figure 18 ODBC spooler (Windows users’ interface)

NOTE The spooler access for deleting spooler jobs is limited to members of the operating systems 
Power Users (XP only) and Administrator groups.
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This data transfer processing allows users to store all data in one central place 
while preventing any data loss and documenting each transfer step.

To process your data further, ChemStore C/S allows you to export information 
to MS Excel, or to print reports to a file in *.html, *.xml or *.csv format. The 
data export to file is checksum protected to ensure the identity of original 
data and exported copy. You can also export the data to the Windows 
Clipboard for use in other Windows applications.

Figure 19 ODBC Spooler (Windows administrators’ and power users’ interface)
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Retrieval of Raw and Meta Data in ChemStation Batch Review

The data storage application is the ChemStore C/S database. Following the 
default study setup, the ChemStore C/S ODBC spooler transfers all data to the 
central database and deletes the new data from the default chem32\data 
directories.

In order to re-analyze runs in the ChemStation, the user must transfer data 
from the Database Review Client back to the local hard disk drive. The raw 
data files will be removed from the client computer after retransfer. The data 
transfer from the result management is a four step process. The first step is 
querying the database.

A query is a request to retrieve a set of runs from the many thousands of runs 
your database comprises that matches certain criteria.

Start the ChemStation and select View > ChemStore Review Client. 

Select  from the ChemStore C/S Database Review Client and run a 
query. The query retrieves the results and data information in order to review 
and approve data. If you need to re-analyze or reprocess your raw and meta 
data, the data must be transferred back into the Data Analysis view of the 
ChemStation.

There are two ways to transfer data from ChemStore C/S to the ChemStation:

1 Transferring data from ChemStore C/S to the batch review of the 
ChemStation (default and recommended transfer), see “Transferring Data 
from ChemStore to Batch Review of ChemStation” on page 60.

2 Transferring data from the run information interface of ChemStore C/S to 
the ChemStation, see “Transferring Data to ChemStation from the Run 
Information Interface of ChemStore” on page 65.
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Audit Trails

All activities associated with each sample are documented in audit trails 
which track all changes that are made to a run from data acquisition over 
re-analysis to long-term archiving.

Each sample has an audit trail which is maintained separately from the 
sample data. The audit trail is archived separately from the run, so that 
archiving and de-archiving activities can be added to the audit trail; the link to 
the audit trail is maintained, even when the run is archived.

The audit trail for any run can be displayed. It contains a table showing 
information about each change in the status or the value of a custom field for 
the run. For manual re-integration events check the details of the 
re-integration with the Man. Integ. Details button. It will open an additional 
window with all manual integration details for the selected run version if the 
database query was executed based on ’all versions’. (see Figure 16 on 
page 42)

The storage of modification time and processing time in local time (calculated 
and documented with the difference to GMT) also indicates when a change 
took place. The processing time documents the time of the data transfer from 
the application to the database, the modification time documents the time the 
audit trail generating activity was performed.

In addition the two time stamps immediately reveal a deviation of data 
modification and data transfer showing a review activity of the individual run 
version.

The audit trail information can be printed directly from the table or 
individually configured in complete reports for a set of runs. Some questions, 
particularly those at the administrative level of the application, cannot be 
answered by the run-related audit-trail. 

All interactions that affect the security of the database and the application are 
tracked and documented in the database logbook. ChemStore can also be 
configured to send a notification by e-mail in case of potential security 
violations. See chapter “E-Mail notification” in the ChemStore Concepts Guide 
for details of how to set up this service. 

The log book entries can be displayed in a table.
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With this database log book and the current list of authorized users and their 
permissions, the application can be checked for its security status for the full 
record retention time.

In an audit situation, a user is now able to proof the ongoing secure status of 
the data plus the short periods of insecurity when a user with administrative 
capabilities was logged on to the system. As an example, one user had logged 
on to the system and had access to sensitive activities like archiving/deleting 
data. In a review situation, the responsible operator could prove that, except 
from this time line, the full application was secure by:

• showing the list of current permission rights in the user administration 
screen of ChemStore C/S.

• querying the database log book session Reason for entry for Permission right 
changed.

This combination of current status documentation and a query for backwards 
changes reveal all user rights and changes for the entire database lifetime.

The documentation of the data acquisition is stored in the instrument and 
sequence log book as well as in the run-specific run log books.

Figure 20 Database log book
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Figure 21 Instrument and Sequence Log book
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Automated Data Versioning

Daily work quite often requires more than one analysis copy of results. The 
FDA rules require storing all reanalysis data as versions together with the 
original raw data and results. The implementation in Security Pack first needs 
to uniquely identify the initial run version in the database. To define the initial 
run version, it uses a combination of injection time in local time using the local 
time zone settings of the computer operation system and the unique injection 
ID. Following this definition, all reprocessing copies or reanalyzed versions of 
the initial run are linked together, offering a complete history of final results 
with all intermediate steps and results. This versioning is user independent, 
computer generated and documented in the audit trail.

To ensure the full versioning, the ChemStation also must

• identify each new result

• automatically send the new result data to the database whenever a new 
result is created

Security Pack therefore stores the numeric results in a registry file 
sec_Save.reg. The registry file is stored with the data. Each new result version 
has a different registry file. Prior to creating a new result version, the system 

Figure 22 New files for Full Audit trail in the Raw Data Subdirectory
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compares the current results with the data stored in the registry file. As soon 
as it detects a deviation, a new result version is stored in the database. For a 
full traceability of the modified results, the difference between the result 
versions are documented in a text file sec_Trac.txt stored in the *.d 
subdirectory of the raw data. The storage management of the database 
minimizes the file size by limiting the result storage to the delta values.

Documentation of Versioning

In addition, the FDA regulations require a documentation of the person 
performing the changes as well as a time-stamp of the reprocessing. This 
information is automatically transferred with the new entry in the database; 
the change person ID is obtained from the log-in and is documented with the 
person’s display name. The time stamp is automatically generated from the 
time setting of the PC (for the standalone version) or the server (for the 
client/server version).

Retrieval of Result Versions in ChemStore C/S Database

When you set up a query for data retrieval in the ChemStore C/S database, you 
can choose to retrieve either all versions of the run or only the latest version. 
When all versions of the run are displayed, the Audit column of the Run List 
shows the version number of the run: 1 is the oldest version, 2 the next oldest; 
the run marked with + is the latest version. If only the latest version of the run 
is displayed, a star „*“ in the Audit column of the run list denotes that multiple 
versions of the run exist in the database.

Figure 23 Retrieval of Versions
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Security Pack does not allow to delete non-archived data. To delete data, the 
user must first be granted the privilege to archive and delete data. In case of a 
standalone system, the user can archive and delete data by copying and 
archiving the complete *.mdb file and creating a new *.mdb copy through the 
ChemStore utility.

For more details on managing standalone MS Access databases, please refer to 
the "ChemStore C/S concepts guide", Section “Backing up your local access 
database".

Data can only be deleted in the Client/Server Oracle based ChemStore C/S 
product and must have been archived prior to deleting from the database.

The entire data transfer is documented in the database log book and the audit 
trail. The database log book denotes the transfer initialization, the audit trail 
documents the completion of the transfer, including the processing 
time-stamp.
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Changes to ChemStation Operator Level

In order to limit operators’ data access and to track modifications, the 
Security Pack modifies the ChemStation operator mode significantly for the 
data review privileges. The standalone ChemStation mode does not allow the 
operator to perform any interactive reanalysis activities because these 
activities can’t be traced. The Security Pack modifies the data analysis tasks to

• store all individual run modifications with the run.

• store all method versions with their current settings in the database.

In the batch mode, the ChemStation operator is allowed to apply manual 
integration events. He is also allowed to open the integration user interface to 
change and save the global integration settings of the method.

Table 2 Shows the modifications to ChemStation operator level compared with 
the user rights of a standard ChemStation operator.

NOTE To access these features, the batch mode of the Data Analysis view must be used.

Table 2 Modifications to ChemStation operator level

User Task ChemStation Security Pack 
Operator

Standard ChemStation 
Operator

Save acquisition method No No

Save data analysis method Yes No

Load/Save sequence Yes Yes

Modify acquisition parameter Yes Yes

Reintegrate automatically Yes No

Reintegrate manually Yes, only in batch review No

Change integration events Yes, only in batch review No

Recalibrate overview and peak 
summing

Yes No
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Recalibrate other No No

Apply method to data and print 
report

Yes Yes

User-independent automated 
result versioning

Yes n/a

Access to tasks with manual 
result versioning

No No

Table 2 Modifications to ChemStation operator level (continued)

User Task ChemStation Security Pack 
Operator

Standard ChemStation 
Operator

NOTE Due to the extended method modification permissions for ChemStation Security Pack 
operators it is recommended to store validated master methods along with an example 
chromatogram in a specific study in the ChemStore database. 

Protection of validated master methods on the file system can be achieved by setting the 
read-only flag on the chem32\x\methods folder and all subfolders.
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Changes to Batch Mode

When re-integrating a chromatogram in the standard ChemStation, the peak 
results table is updated at the same time as the display of the baseline, 
retention time and compound name in the chromatogram. The ChemStation 
Plus Security Pack operates differently.

The Security Pack splits the re-analysis task in two steps. The first one allows 
to perform a graphical review of a set of runs (step through runs) and to work 
with manual integration events for each compound in a run without 
generating new results. 

The second step is the result calculation including an automated data 
versioning. The result calculation can either be initialized with a separate 

button  or by clicking run by run or automatically stepping through the full 
list of runs.

The  button is added to the batch toolbar. Calculating a new result will 
start the comparison with the last results in the sec_save.reg file and in case of 
a difference, transfer the data to the database. This mechanism allows 
constructing the baseline for multiple peaks without transferring data with 
every change.

In batch processing the new baseline is stored with the signal and hence 
individual to the signal, while in the interactive data analysis it is stored with 
the method. The signal is added to the raw data file and it might be stored in 
ChemStore C/S as part of the raw data file. In the case of manual integration 
in the interactive data analysis, the manual integration events are stored in an 
extended method file.

In the security mode of the ChemStation plus, all changes are saved 
automatically with the chromatogram. In case a user wants to disregard the 
manual integration events prior to calculating the new result, he has to 
reapply the “last -saved settings” by executing the integrate command from the 
integration menu.

The transfer of the results to the database is performed after a valid comment 
is given by selecting one of the predefined comments with a check mark or by 
typing an individual comment in the text field.The free comment must have at 
least 5 characters, if no predefined comment has been check marked.



ChemStation Security Pack User’s Guide 57

Access Level and Batch Review Interface Changes 4
Changes to ChemStation Operator Level

If the batch was loaded from a disk, all runs are calculated and transferred 
when leaving the batch processing mode. Also, in case the user prints a report 
of a selected run or creates integration results, the data will be transferred 
immediately.

The data files and the method used by the batch review are loaded into a 
write-only directory, preventing operators to make unauthorized copies of 
those files. This directory stores under the "data" directory of the 
ChemStation session and is named Chemstor. Example for this directory: C:\
chem32\1\data\Chemstor

If configured to delete raw data, the files are deleted as soon as the user leaves 
the batch processing mode or loads a new batch. 

For reasons of security, it isn’t possible to load a signal as long as the batch 
mode is active. Therefore the Load Signal option in the File menu and the 
ChemStation explorer are disabled. However, the ChemStation software 
allows overlaying multiple chromatograms of selected runs within the loaded 
batch. Re-integration and result generation are not possible, as standard 
reports cannot be generated across multiple runs. 
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Transferring Data from ChemStore to Batch Review of 
ChemStation

The default setup of Security Pack deletes the raw data from the local PCs 
after the transfer to the database. In order to re-analyze this data, raw data 
must be transferred back to the local ChemStation PC. The application 
transfers the data from the database to the ChemStation batch review. Batch 
review is a mode of data analysis that allows you to do a first-pass review of a 
batch of samples quickly and easily. You can manually modify the 
chromatograms and save the modifications for later use. You can also print 
reports of the batch results.

Transfer of data from ChemStore C/S to the ChemStation takes place in two 
stages. First you set up a batch in ChemStore C/S, and then you load the batch 
in the ChemStation.

Setting up a Batch

You can review data and mark it for transfer to the ChemStation in any of the 
Sample layouts or in Compound graphics layout. For more details on the batch 
transfer, see Agilent ChemStore C/S Concepts Guide.

1 In the ChemStore C/S review client, select a run from the Run List (Sample 
layouts) or the Summary Results Table (Compound graphics layout).

2 Check the Batch box at the bottom of the table. You can also select Review > 
Mark Run For > Batch Processing or Batch Processing from the Run List popup 
menu (right mouse button) to mark a run. To mark all runs for batch 
processing, select Review > Mark Run For > All For Batch Processing, or All For 

NOTE The setup of runs for reprocessing is a ChemStore C/S user privilege that must be granted.

NOTE During data transfer from the database to the local hard disk, the application performs a 
checksum re-calculation. It checks if the hash values are identical. Any mismatch is 
reported as an error with the message: "Hash values are different."
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Batch Processing from the Run List popup menu (right mouse button). To 
remove the batch processing marks from all runs, select Review > Mark Run 
For > None For Batch Processing or None For Batch Processing from the Run List 
popup menu.

3 After marking the run(s), select  or Review > Create Batch. The Create 
new batch dialog box appears.

4 Select the name of the run you wish to be included in the batch in the left 
panel and choose the forward arrow. To remove a run from the batch, select 
its name in the right panel and choose the back arrow.

5 Choose the Method option in the Used method group and select a method 
from the list to be saved with the batch. To specify that no method is saved, 
choose the None option in the Used method group; the ChemStation operator 
must then use a suitable method for processing.

6 Choose the All users option to ensure that all users of ChemStore get 
notification of a pending batch. To ensure that a single user gets 

Figure 24 Create new batch Dialog Box
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notification of a pending batch, choose the User option and choose the down 
arrow to select the user’s name from the list.

7 Type a comment in the Comment field to add information about the batch. 
Choose the Submit batch button to prepare the batch for access by the 
ChemStation.

Loading a Batch

Batches created in ChemStore C/S can be loaded into the ChemStation for 
reprocessing or other handling. 

Loading a Batch from ChemStore C/S

1 Select Batch > Load Batch > ChemStore. The ’Load Batch from ChemStore 
database’ dialog box appears where you can select a batch submitted from 
ChemStore by clicking to the left of the line, where the cursor changes to a 
black arrow.

2 Choose the Load Batch button to start loading the runs from ChemStore C/S 
into the Batch Review of the ChemStation.

Figure 25 Load Batch Dialog Box
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If the Files for batch missing dialog box is displayed, listing the files that can 
not be found in their original locations, copy or move the files back to their 
original locations, then choose Continue to load the complete batch, or 
choose Continue to load only those files that have been found in their original 
locations, or choose Abort to abort the loading of all files.

Loading a Batch from Disk

Batches can also be loaded from the local hard disk in case the user decided to 
disable the delete raw data after transfer button in the ChemStore study set-up 
(intending to keep the raw data on the local hard disk until first pass review 
has been completed). 

NOTE All raw data files that have been analyzed will be deleted from the local disk after closing 
the batch window. In order to reprocess data that is transferred to the database, these data 
has to be sent from ChemStore C/S to the ChemStation.

NOTE Agilent recommends to keep the ChemStore study functionality delete raw data after 
transfer enabled. Otherwise data management and data integrity gets more complicated by 
having identical analytical data in two locations.
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1 Select Batch > Load Batch > Disk. The Load Batch dialog box appears.

2 Select the batch you want to load from the list by clicking on the name in 
the File name list box.

3 Click OK.

Figure 26 Load batch from disk Dialog Box
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Transferring Data to ChemStation from the Run Information 
Interface of ChemStore

You can also choose to reload any or all files saved with a run or a complete 
sequence interactively from the Run information dialog box.

Reloading a run

1 Select a run from the Run List.

2 Select . The Run information dialog box appears.

Figure 27 Run information Dialog Box
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3 Click the Reload raw data button. A dialog box appears.

4 Enter a path.

5 Click OK.

Figure 28 Reload Raw Data file Dialog Box
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Reloading a Sequence

1 Execute a query based on all versions and select a version 1 run from the Run 
List. (Higher result versions may not have the sequence context any longer 
due to batch or single run reprocessing of some sequence runs).

2 Select . The Run information dialog box appears.

3 Choose the Reload all files... button. Dependant on the age of the acquired 
sequence, the look of the reload dialog differs. Figure 29 shows the data 
reload dialog for sequences acquired with ChemStation B.02.01 SR1 or 
higher. For sequences acquired with earlier versions of ChemStation the 
raw data and method path are not fixed and need to be adjusted manually.

NOTE For ChemStation B.02.01 SR1 and higher: The sequence reload destination should be part 
of the ChemStation data path preferences. If not, the reloaded data is not visible in the 
ChemStation explorer. Adding the path to the ChemStation path preferences needs to be 
considered, then.

Figure 29 Sequence reload destination selection
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Step 4 to 7 apply to pre-B.02.01 ChemStation data only:

4 If the sequence file exists at the destination path you can choose to 
overwrite the existing sequence or not. It is recommended to overwrite the 
existing sequence, thus ensuring the same sequence parameters.

5 The destination path for the raw data should be empty, since the reload 
function does not allow to overwrite existing data. The original full path can 
be copied by using the Ctrl+C and Ctrl+V short keys.

6 Click OK. 

7 If the Overwrite existing method files dialog box appears, check the Overwrite 
boxes for the you wish to overwrite with method from the database and 
click OK.

8 When the task is complete, a Summary appears.

Figure 30 Summary
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Integration

This section will focus on the integration using the batch review. For 
integration using the interactive Data Analysis view of the ChemStation, please 
refer to the Understanding the ChemStation manual.

Integrating a Signal Automatically

1 Select Batch > Load Batch > ChemStore. The Load Batch from ChemStore 
database dialog box appears. (See Figure 25 on page 62)

2 Select the button Load Batch... — mind the comment.

3 The batch review task starts with the application of a method to a run. The 
method usually is transferred along with the batch from the ChemStore C/S 
database. If the batch was submitted without a method, the application will 
ask you to load a local method.

4 Click either the manual integration events  
or 
Select .
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5 Select Integration > Integration Events or 

6 Enter the integration events to be used by the integrator.

7 If you wish to apply the events to re-integrate a list of samples from the 
batch, click . The software will step through the runs and 
re-integrate file after file until the batch is done or the operator stops the 
automated review.

Figure 31 Integration Events
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Integrating a Signal Manually

1 Select Batch > Load Batch > ChemStore.

2 Select the batch to be loaded.

3 Select Integration > Integrate to integrate the signal using the initial values 
specified in the integration events table of the current method.

4 Select a sub-menu from the Integration menu to specify a manual integration 
action. All functions described below are also accessible from the Status 
toolbar.

a Select Draw Baseline to define a baseline. 

Click and hold down your mouse button at one end of the baseline. Then, 
drag your mouse to the other end and release the button.

b Select Negative Peak(s) to define a baseline for negative peaks.

Click and hold down your mouse button at one end of the baseline. Then, 
drag your mouse to the other end and release the button.

c Select Tangent Skim to define a tangent.

Click and hold down your mouse button at one end of the tangent. Then, 
drag your mouse to the other end and release the button.

d Select Split Peaks to specify a drop line.

Point to the place along the x-axis where you want the drop line and click 
your mouse button to integrate the signal.

e Select Delete Peak(s) to draw a box around the peak you want to delete.

Click and hold down your mouse button at one corner of the box. Then, 
drag your mouse to the opposite corner and release the button.

5 If you are satisfied with the baseline position, continue with the next run or 
display the integration results. Both actions will trigger spooling of the new 
results to the database. If you are not satisfied with the baseline position 
reintegrate the signal. No run version will be spooled until as long as no 
new results are displayed.
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Recalibration

For a recalibration using the bracketed calculation mode, you have to reload the 
sequence and reprocess it in ChemStation’s data analysis view. For 
pre-B.02.01 ChemStation data you need to reprocess the sequence in the 
ChemStation’s method and run control view of an off-line copy. 

As an alternative, all brackets can be re-calibrate in batch mode if they are 
set-up as individual batches. If you do not want to use a bracketing mode for 
calibration, the recalibration can be performed through the batch review. 

The batch review allows to recalibrate using an averaged result of all 
calibration runs or using individual run-based changes. 

1 Load a batch in the ChemStation.

2 If you want to update the calibration table, use the standard calibration 
tools of the ChemStation. 

3 After finishing the modifications on the run and/or in the calibration table, 
click . 

This will update the calibration table using the calibration samples in the 
batch.

4 To reprocess the data and to get new results with the up-dated calibration 
table, start the automated step through runs with . 

The square brackets [] around compound results indicate results not 
generated by the current calibration. The brackets will be removed 
automatically when a new and different result using the current calibration 
is generated.
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Introduction

To keep track of actions that might affect data integrity in a ChemStore C/S 
system, certain tasks require to be logged on to the computer as a member of 
the Windows user Power Users (Windows XP only) or Administrators. 
Permissions to Chromatographic tasks like data acquisition and data review 
are administered within ChemStore C/S. Agilent does not recommend to 
perform routine work like review chromatographic data or acquiring data 
when logged on as a member of the Windows user Power Users (Windows XP 
only) or Administrators. All users that use the ChemStation Plus system must 
be members of the local Windows user group users. Otherwise the global 
group, they belong to, must be a member of the local group users. Within a 
Windows multi domain environment a trust relationship is not sufficient. 
Each global domain user group has to be explicitly included in the local 
Windows group users. Table 3 lists common administrative tasks and their 
respective ChemStation, ChemStore and Windows settings required.

Table 3 Administrative Tasks

Administrative task Membership in 
WIndows group 
Administrators required

ChemStore C/S 
permission required

ChemStation manager 
access level required

Running instruments No No No

Reanalysis of data No No No

Modifying ChemStation sequences (Study, 
custom field values, samples)

No No No

Save acquisition method to disk No No Yes

Save data analysis method to disk No No No

Resume database spooler No No No

Deleting spooler jobs Yes No No

Creating a new ChemStore C/S users No Administer users No

Assign user settings to users No Administer user 
settings

No
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Select database connection Yes No No

Data archiving (MS Access DB) Yes No No

Data archiving (Oracle DB) No Archive / Dearchive 
runs

No

Creating new database (MS Access only) Yes No No

Creating new database from template (MS 
Access only)

Yes Create database No

Table 3 Administrative Tasks (continued)

Administrative task Membership in 
WIndows group 
Administrators required

ChemStore C/S 
permission required

ChemStation manager 
access level required
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Tasks requiring a ChemStore C/S permission

The Administer users permission in the ChemStore C/S user administration 
is the key privilege in managing user rights and user roles in Security Pack. It 
allows creating a new user with specific permissions, change the permissions 
or reset the password for an existing user.

Creating a new user

1 Select Administration / Administer Users...

2 The Administer Users dialog box appears.

Figure 32 Administer Users Dialog Box
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3 Choose the Create new user button. The Create user dialog box appears.

4 Enter a Login name and a Display name.

5 Click OK.

6 Select permissions for this user from the Individual permissions panel and 
transfer them to the Permissions granted panel by using the forward arrow or 
grant standard sets of permissions by using the buttons below the Individual 
permissions panel.

7 Choose to set this user as a ChemStation Operator or as a ChemStation 
Manager.

8 Click OK.

Modifying an Existing User Profile

1 Select Administration > Administer Users. The Administer Users dialog box 
appears.

2 Select the user you want to modify from the User list.

3 Add or remove permissions.

• To add permissions, select them from the Individual permissions panel and 
transfer them to the Permissions granted panel using the forward arrow.

• To remove permissions, select them from the Permissions granted panel 
and transfer them back to the Individual permissions panel by using the 
back arrow.

4 Choose to set this user as a ChemStation Operator or as a ChemStation.

5 Click OK.

Figure 33 Create user Dialog Box
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Tasks for operating systems administrators

These tasks can only be performed when you log on to Windows as a member 
of the Windows Operating system user Administrators or if the corresponding 
application is started in run as administrator mode. On Windows XP systems 
the membership to the Power Users group is sufficient. Some tasks 
additionally require a ChemStore C/S permission.

Configuration of the DB Size Security Service

The size limit for a Microsoft Access database is 1 GByte. Therefore it is highly 
recommended not to exceed a size of 850 MBytes for the database. This 
ensures that sufficient space is left in the database to allow further 
reprocessing of the data already contained in the database. 

When a size of 750 Mbytes is reached the software will display a warning 
message during log-on to notify user, that it is approaching the size limit. As 
this message is displayed a new Access database should be created using the 
ChemStore utility. Only a member of the Windows user Administrators able 
to configure the warning limits of the service and create a new Access 
database and assign the new database connection. For details on how to 
configure the size security service please refer to the ‘ChemStore Concepts 
Guide’. For details on how to create a new Access database please refer to 
“Creating New Databases in the Standalone Version” on page 82.

NOTE When running an application as administrator it is important to close this application when 
the work is finished.
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Assigning a Database Connection on Windows XP operating 
systems

Only members of the Windows user Power Users or Administrators can 
change the database connection. All other users can only log on to the 
database currently selected. To change the database connection do the 
following:

1 Log-on to Windows as a user that is a member of the Windows user Power 
Users or Administrators

2 Select Programs > Agilent ChemStation > ChemStore Review Client from the 
Windows Start menu.

3 At the ChemStore Log On screen press the Select button (see Figure 35 on 
page 81)

4 Either select the appropriate database alias from the list or, in the case of a 
new database, select Browse and point to the new *.mdb file to create a new 
database alias in the list. (see Figure 36 on page 81)

5 In the ‘Set as default’ group,

a Mark the ‘for this session’ check box to specify that the selected database 
is the default for this instrument or application only. Windows users 
logging on to this instrument or application without Power User or 
Administrator permissions must use the specified database. 

b Mark the ‘for all sessions’ check box to specify that the selected database 
is the default for all instruments and applications on this work station. 
Windows users logging on to any instrument or application without 
Power User or Administrator permissions must use the specified 
database.

6 click OK to make the selection active.

7 Start up the Review Client and log on with any valid user account

8 Important: Close down the Review Client and log on as a member of the 
Windows user group users.
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Assigning a Database Connection on Windows Vista operating 
systems

Only members of the Windows user Administrators can change the database 
connection. All other users can only log on to the database currently selected. 
To change the database connection do the following:

1 Log-on to Windows as a user of any user group

2 Browse to All Programs > Agilent ChemStation > ChemStore Review Client from 
the Windows Start menu.

3 Right mouse click the ChemStore Review Client icon and select Run as 
administrator

4 At the Windows Vista User Account Control panel enter the password of an 
active Windows administrator account and allow the program HPCsCl00.exe 
to access your computer

Figure 34 Start ChemStore Review Client as adminstrator
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5 At the ChemStore Log On screen press the Select button

6 Either select the appropriate database alias from the list or, in the case of a 
new database, select Browse and point to the new *.mdb file to create a new 
database alias in the list.

7 In the ‘Set as default’ group,

a Mark the ‘for this session’ check box to specify that the selected database 
is the default for this instrument or application only. Windows users 
logging on to this instrument or application without Administrator 
permissions must use the specified database. 

Figure 35 Select New Database Connection

Figure 36 Selecting a new database
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b Mark the ‘for all sessions’ check box to specify that the selected database 
is the default for all instruments and applications on this work station. 
Windows users logging on to any instrument or application without 
Administrator permissions must use the specified database.

8 click OK to make the selection active.

9 Start up the Review Client and log on with any valid user account

10 Important: Close down the Review Client to end the program running in 
administrative mode

Creating New Databases in the Standalone Version

The ChemStore C/S Utility is used to create a new MS Access database in case 
the previous database has reached its size limit and/or has been archived onto 
a storage media. On Windows Vista operating systems the ChemStore C/S 
Utility application needs to be run as administrator (see also Figure 34 on 
page 80). On Windows XP operating systems it can only be used by members of 
the Windows user Power Users or Administrators.

To retain user settings, report templates, filters, queries, user interface 
settings, and customized settings, the last used database can be used as a 
template for the new database. To import settings from another database, you 
must log-on the template database as a user with the ChemStore C/S 
Permission Administer users in the template database.

1 Log-on to Windows as a user that is a member of the Windows user Power 
Users (XP only) or Administrators.

2 Select Programs > Agilent ChemStation > ChemStore Utility from the Windows 
Start menu.

3 Windows Vista only: Run the ChemStore Utility as administrator

NOTE Password settings like minimum password length and account lock out will not be 
transferred to the new database.
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4 Select File > Create Access Database. The ‘Create a new ChemStore B.04’ database 
dialog box appears.

5 Choose the Browse button

6 The Save As dialog box appears.

7 Enter a database name in the File name text box.

8 Choose the Save button.

9 Choose the Logon button if you want to import settings from a template 
database.

10 Select the database alias that should be used as a template.

11 Type in name and password of a user with administrative privileges.

12 Choose the Create button.

13 You should close the ChemStore C/S Utility once the database creation is 
successfully finished. If users should use this database now, you need to 
connect to the new database as outlined in “Assigning a Database 
Connection on Windows XP operating systems” on page 79 or “Assigning a 
Database Connection on Windows Vista operating systems” on page 80 
respectively.

Figure 37 Create new MS Access database
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Database Backup in the Standalone Version

To protect the database from unauthorized manipulation, Windows users that 
are members of the group users only have special write access to the database 
directory. Therefore they can not copy the database onto a backup or archive 
media. To backup or archive the standalone database perform the following 
steps:

1 If your operating system is Windows XP, log-on as a user that is a member of 
the Windows user groups Power Users or Administrators. On Windows 
Vista the following operations can be performed while beeing logged on as a 
Windows user. However, an administrator’s password is required.

2 If the database is to be archived, create a new database as described in the 
section “Creating New Databases in the Standalone Version” on page 82. To 
allow a consitent data management the new database name should be 
unique.

3 Copy the database file (*.mdb) from chem32\chemstor\database to the 
backup or archive media.

4 If the database was archived additionally perform the following steps:

a Delete the original database from the hard drive.

b Select Programs > Agilent ChemStation > ChemStore Review Client from the 
Windows Start menu.

c Windows Vista only: Start the Review Client as administrator (see 
Figure 34 on page 80)

d Select to open the ChemStore C/S: Select Database dialog box.

e Select the database alias that was archived and click on Delete to delete 
this alias.

f Choose Browse and select the database created in step 2. 

g Click on Open.

h Enter a database alias and select OK.

i Select the new database alias and click on OK.

j Start up the ChemStore C/S review client and close it again.

k Log-on as a member of the Windows user group users.

Further details about recommended back up procedures can be found in the 
Agilent ChemStore C/S Concepts Guide.
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Event Log File Backup on Windows XP operating systems

If you are using Security Pack together with a standalone ChemStore C/S 
installation, it is mandatory not only to perform a regular back up on the 
database files containing the analysis data, but also the Windows Event log 
files, showing that no data was deleted or altered. To store the Windows 
security log on a backup or archive media do the following:

1 Log-on to Windows as a user that is a member of the Windows user group 
Administrators.

2 Select Settings > Control Panel > Administrative Tools > Event Viewer from the 
Windows Start menu.

3 Right-click the Security Log.

4 Select the Save As function and type in a file name. Agilent recommends to 
include the Event log as EVT files in the back up to allow for easy usage later 
on.

5 Copy the event log file on the backup or archive media.

6 To prevent excessive growth of the event log file, you have the option to 
clear it. Use this option only after you copied the current event log to an 
archive media. Select Log > Clear All Events to clear the security event log.

Further details about recommended back up procedures can be found in the 
Agilent ChemStore C/S Concepts Guide. 

Event Log File Backup on Windows Vista operating systems

If you are using Security Pack together with a standalone ChemStore C/S 
installation, it is mandatory not only to perform a regular back up on the 
database files containing the analysis data, but also the Windows Event log 
files, showing that no data was deleted or altered. To store the Windows 
security log on a backup or archive media do the following:
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1 Log-on to Windows as a user of any user group

2 Select Control Panel > Administrative Tools > Event Viewer from the Windows 
Start menu.

3 Right-click on the Event Viewer icon and run it as administrator

4 Browse to Event Viewer(local) > Windows logs > Security and right-click the 
Security Log.

5 Select the Save As function and type in a file name. Agilent recommends to 
include the Event log as EVTX files in the back up to allow for easy usage 
later on.

6 Copy the event log file on the backup or archive media.

7 To prevent excessive growth of the event log file, you have the option to 
clear it. Use this option only after you copied the current event log to an 
archive media. Right-click the Security Log and select Clear Log. 

Further details about recommended back up procedures can be found in the 
Agilent ChemStore C/S Concepts Guide. 

Setting Up E-Mail Notification

The following facility is available on Client/Server systems only. It sends an 
automatic e-mail notification on specific events and needs to be set up by the 
administrator (or other user with administrator permissions). The events to 
trigger an automated e-mail notification are:

• locking of an user account due to exceeded number of unsuccessful log-on 
attempts.

• submitting a batch for review

• clearing a password

• creation of a new user

• permission modification

With the exception of 'notification of batch submission', the e-mail 
notifications should only be sent to administrators to warn about security 
violations. 

For details about the set-up, please refer to the ChemStore Concepts Guide.
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Troubleshooting Spooler Problems

Troubleshooting spooler problems splits into two sections: spooler resume 
after error correction and troubleshooting of persistent problems. The two 
associated workflows are illustrated in Figure 39 on page 88 and Figure 40 on 
page 89, respectively.

For resuming the spooler after error correction (e.g. a lost network connection 
or server downtime) members of the user groups Users can resume the spooler 
and display the error message. These users have a modified spooler window 
for resuming the transfer as shown in Figure 18 on page 44. This menu does 
not offer the option to delete spooler jobs or to pause the spooler. 

Only members of the Windows user Power Users (XP only) or Administrators 
have full access to the database spooler. The database spooler transfers the 
data to the database and temporarily stores the data. In case of a server or 
database problem the spooler pauses and needs to be resumed. To resume the 
spooler or to evaluate error messages from the database spooler do the 
following:

1 Double-click with the left mouse button on the database spooler icon in the 
lower right hand corner of the Windows task bar .

2 Check the error message by selecting Show Error and resolve the problem.

3 Click on resume to continue the data transfer to the database after the error 
was corrected.

Figure 38 Database spooler window for members of the user groups administrators
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If the spooler data is corrupt and refuses to transfer to the database you 
should follow the workflow illustrated in Figure 40 on page 89.

Figure 39 Corrective action workflow in case of a spooler error
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Figure 40 Troubleshooting of corrupted spool jobs
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Security Settings

To prevent deletion or alteration of data by standard users, the access to 
crucial directories of ChemStation PlusSecurity Pack is imited to members of 
the Windows user groups Power Users (XP only) and Administrators. Agilent 
does not recommend to change the location, permissions or auditing of these 
directories. Table 4 shows the required permission settings and Table 5 shows 
the required auditing settings for Security Pack. Upon installation these 
settings will be set correctly.

In addition it is recommended to activate the auditing function on each local 
database after creation (For details refer to the Windows help). This triggers 
more specific information to be entered to the security log file.

Table 4 Directory and file permissions

Directory Permissions Comment

\chem32\chemstor\
database

Administrators (modify)
(full control), 
Power Users (modify)
(full control)
Users (write+read 
permissions)(modify)

Used to store the local 
databases. Not required if 
used with a ChemStore C/S 
Oracle server database.

\chem32\chemstor\spool Administrators (modify)
(full control)(), 
Power Users (modify)
(full control)
Users (write+read 
permissions)(modify)()()

Used to store temporary data 
when transferring data 
between ChemStation and 
ChemStore

\chem32\1\data\chemstor Administrators (modify)
(full control), 
Power Users (modify)
(full control)
Users (full control)(modify)

Used to store temporary data 
when transferring data for a 
batch re-analysis from 
ChemStore ChemStation 

\chem32\chemstor\
hputil00.exe

Administrators (full control)
Power Users (full control)

ChemStore C/S Utility for 
creation of new databases
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Table 5 Directory and file auditing

Directory Events to Audit Comment

\chem32\chemstor\database Administrators and Power 
Users: success + failure

Logs if database files were 
deleted by a member of the 
Administrators or Power Users 
group.
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injection time, 50
instrument logbook, 49
integrate

commands, 37
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integration settings, 54
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deletion, 44
reanalysis, 50, 56, 59
reanalyze, 46
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user settings, 82

V
validation, 11
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