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2 Introduction

CCBoot enables diskless boot Windows XP, Windows Server 2003, Vista, Windows 7 and
Windows Server 2008 with iSCSI.

Diskless boot makes it possible for computers to be operated without a local disk. The ‘diskless'
computer is connected to a hard drive over a network and boots up an operating system from a
remotely located machine. CCBoot is the convergence of the rapidly emerging iSCSI protocol with
gPXE diskless boot technology.

Remote boot over iSCSI, or CCBoot, pushes the iSCSI technology even further, opening the door to
the exciting possibility of the diskless computer. CCBoot technology allows a diskless boot of most
Windows OS from an iSCSI target machine remotely located over a standard IP network.

CCBoot offers a seamless diskless boot. Eliminating the need for a local hard drive opens a wide
range of possibilities for network management. Using this configuration, the disks for many
network computers can be centrally managed, thereby facilitating backup, redundancy, and
dynamic allocation of valuable storage resources while at the same time reducing cost to the
enterprise.

Booting from iSCSI makes system administration considerably easier. Freeing a server of its boot
volume allows administrators to manage investments in their iSCSI SANS, attaining improved data
security, integrity and recovery, higher availability, quicker server deployment & repurposing, and
more efficient utilization of storage resources.

Benefits

Significantly reduce initial capital and implementation costs
Reduce power and cooling requirements

Accelerate deployments, upgrades, and server repurposing
Reduce complexity and risk

Improve critical system availability

Implement enhanced Disaster Recovery solutions



3 Features

Boot Windows XP, Windows 2003, Vista, Windows 7 and Windows 2008 from iSCSI
storage/target.

Inside DHCP, gPXE, TFTP, Image Upload and iSCSI Target. It's all-in-one solution for iSCSI
boot.

Support physical drive, volume drive and VMWare disk file.

Support upload boot image to the server and save with VMDK format.

Clients can recovery to a new clear system after reboot.

Clients can keep own system data after reboot.

Every client can boot from different images.

Support image read cache and client write-back cache.

Support RAM cache with huge memory access (AWE).

Support SSD cache.

Support “Save to Image”.

Support multiple servers, multiple NICs and load balance.

Support multiple disks.

Auto assigns write-back files for clients.

Support super clients for image writing.

Support multi DNS.

Support client write cache.

Support one image compatible with different devices (PnP).



4 System Requirements

® Server Requirements

1. Windows 2000, Windows XP, Windows 2003, Vista or Windows 2008. We recommend
Windows 2003.

2. Install latest service packs.

® Client Requirements

1. Windows XP, Windows 2003, Vista, Windows 7 or Windows 2008.
2. PXE 2.x compliant network adapter

® Recommended Server Hardware

CPU: 1.7G

RAM: 2G

System Image Disk: SATA HDD 120G

25 clients Game Disk: RAID with 2 SATA HDD
Client Write-back Disk: SATA HDD 120G
Main Board: With SATA support
Network: 100Mb Ethernet

CPU: 2G

RAM: 4G

System Image Disk: SATA HDD 120G

50 clients Game Disk: RAID with 2 STAT HDD
Client Write-back Disk: 2 SATA HDD 120G
Main Board: With RAID support

Network: 1000Mb Ethernet

CPU: 2.8G

RAM: 8G

System Image Disk: RAID with 2 SATA HDD
Client Write-back Disk: 4 SATA HDD

Main Board: With RAID support

Network: 1000Mb Ethernet, 2 - 3 NICs

100 clients

> 100 clients Using multiple servers and load balance.




5 Quick Start

5.1 Install and Configure CCBoot Server

Download CCBoot server installation package from: http://www.ccboot.com/download.htm
Launch cchootsetup.exe on the server and keep press the next button to the end (Figure 5-1).

e Setup — CCBoot E|E|@

Welcome to the CCBoot Setup
Wizard

This will install CCBoak 2,0 Build 20101106 an your campuket.

It is recommended that vou close all okher applications before
conkinuing.

Click Mext to continue, or Cancel ko exit Setup.

Mext = |[ Cancel

Figure 5-1

CCBoot will use the following ports — 67 (DHCP), 69 (TFTP), 3260 (iSCSI), 1000 (Image Upload),
8001 (Service Control). You need to open those ports on the server firewall.

Note: Please shut off other DHCP service in your LAN especially the DHCP service in the router.

Launch CCBoot and you will get the main panel as bellow (Figure 5-2):


http://www.ccboot.com/download.htm

& CCBoot v2.0 Build 20101106 =3
File Options Client Help

T L %W 0 0 ® 0 O

Add Client Delete Client Options Stop Service  Refresh Cache Help Close

Computer ... | MAC Address IP Address Rea... = Writ... = Ima... Disk... Priv... Update Time Ima

4

|

Lisk Upload Kecerang

)

ZnlinefTotalMem/Image Tisky330 007 1 3MOMIOMIM
Service During Tirme ODay OOH 09M 405
Zache Lask Update Time

Figure 5-2

Demo Environment

Server IP: 192.168.1.100

Gateway: 192.168.1.1

DNS Address: 192.168.1.1

IP Mask: 255.255.255.0

DHCP Range: 192.168.1.101-192.168.1.250
Image Save Path: D:\CCBootImage
Write-back File path: F\CCBootWrite-back

Menu “Options”->"Options Wizard” and configure step by step as bellow:



DHCP Settings [g |

Start DHCP Start TFTP

DHCP Server IP 192.168.1.100 v
IP Alocsted Start | 192,168.1,101 |
P Allocated End | 192.168.1.250 |
IP Mask | 255,255.255.0 |
IP Gateway | 192.168.1.1 |
DS Address 1 | 192.168.1.1 |
DNS Address 2 | |

Gcan DHCP
< Back. Mext = ] [ Cancel
Figure 5-3

You need to select correct local IP address as “DHCP Server IP”. Press “Scan DHCP” to check if
there are other DHCP services on the LAN. You need to stop other DHCP services on the LAN.



%)

Client Default Settings

Server IP Address | 152.168.1.100 |
Write-back File Path | F:\CCBootWirite-back |
[¥]Enable Cache | 123 | M
[Jwrite-back Limt | M
Image Save Path | oA CCBootImange |
< Back, ” Mext = ] [ Cancel
Figure 5-4

Set “Server IP Address”. Normally, it’s the same as “DHCP Server IP”. Set “Write-back File Path”
and “Image Save Path” as you want.



Server, Cache Settings

Enable Cache Enable Huge Memory Access

Available Physical Mermory | 328

i (Reconmend]

System Image Read Cache | 1a

Game Disk Read Cache | 10

Clients \Write-back Cache | o

[ ]Enable S50 Cache

55D Path |:| 550 Size

Auko Update Cache []update Cache Time

550 Cache

| L

x]

< Back ”

Mext = ][ Cancel

Figure 5-5

Keep default values in “Server Cache Settings”.
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Other Settings

Start iSCSI Service iSCSI Port 3260

[]Enable Super Client Update Game Disk:

auka add Client

Compuker MName Prefix

Server and Client Disk Mapping

Delete

< Back. ” Finish l[ Cancel

Figure 5-6

Keep default values in “Other Settings”. Press the “Finish” and confirm the popup dialog box.

5.2 Create Boot Image for Win XP and 2003

1. Choose one client PC to create boot image. Attach a hard disk on the PC.

2. Allocate a small partition about 10G size and format the partition with NTFS and cluster size is
32K. Install Windows (XP or 2003) and the latest SP into the partition.

3. After complete Windows installation, open the local area connection network properties and
configure as bellow:



Click “Properties”.

-4 Local Area Connection Status

General l Support |

Connection
Status: Connected
Duration: 16:44:04
Speed: 1.0 Gbps
Activity
S @hl Received
ent —— — eceive
>
—l
Bytes: 358,583 [ 1,224,445
I, Properties ,I[ Disable ]

Close

Figure 5-7

-4 Local Area Connection Properties @

General | Authentication | Advanced

Connect using:
ln YMware Accelerated AMD PCNet Ad “ oo ]

This connection uses the following items:

g Client for Microsoft Networks
.Q File and Printer Sharing for Microsoft Networks
45} (105 Packet Scheduler

Intemet Protocal [TCP/P)
L

Description

Transmission Control Protocol/Intemet Protocol. The default
wide area network protocol that provides communication
across diverse interconnected networks.

Show icon in notification area when connected
Notify me when this connection has limited or no connectivity

[ 0K ][ Cancel ]




Figure 5-8

Select “Internet Protocol (TCP/IP)” and click “Properties”.

Internet Protocol (TCP/IP) Properties @

General [ Alternate Configuratioh}

You can get IP settings assigned automatically if your network supports
this capability. Otherwise, you need to ask your network administrator for
the appropriate IP settings.

(®)i0btain an IP address automaticall
(O Use the following IP address:

(®) Obtain DNS server address automatically

(O Use the following DNS server addresses:

| |

[ 0K I[ Cancel ]

Figure 5-9

Select “Obtain an IP address automatically” and “Obtain DNS server address automatically”, then

click “OK” to save.

4. Goto CCBoot serverand you will find a client in the client list (Figure 5-10) that was added by
CCBoot automatically when the client PC got IP address from the CCBoot DHCP service.



l CCBoot v2.0 Build 20101106
File Options  Client  Help

T & %N 0 0 & @ ©

Add Client Delete Client Opkions Stop Service  Refresh Cache Help Close

Computer ... MAC Address IF Address Rea,,.  Writ... | Ima... Disk ... | Priv... Update Time Ima
& pcio1 O:EQ:4C:0C:E4:B6 192.168.1.101 0z2-16 19:32:09
| A

Disk Upload Receiving

OnlineiTokalMernImageiDiskiSS0 Of 1] 14MOM/OM O
Serwvice During Tirne 0Day 00H 34M 585
Update Image/Game: Enable Upload: Keep ‘Write-back: Cache Last Update Time

Figure 5-10

Double click the client to edit and check “Enable Upload Image” (Figure 5-11).
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CCBoot Client

Client Properties
Enabled
Computer Name | PC101 |
MAC fddress | DO:ED:4C0C:EHB6 |
IP address | 192.168.1.101 | Enable Upload Image
PHE | Qpe. pxe | [ ]keep write-back Fil=
Gakeway | |
Disk, Group | | [ Clear Write-back, ]
Hardware Prafils | | [ Clear Private ]
Server IP Address | 192.168.1,100 | | Savetoprivate |
Write-back File Path | F:\ CCBootwrite-back, | [ Save to Image ]
[ write-back Limitation M
Enable Client Cache | 12g M
[ ]Enable Set Resolution |:| width*height*bit*frequency

Super Client
[ ]Enable Update Image

Figure 5-11

5. Download CCBoot client installation package from: http://www.ccboot.com/download.htm
Launch ccbootsetupclient.exe and keep press the next button to the end. Then launch CCBoot client
and you will see the main panel as bellow (Figure 5-12).



http://www.ccboot.com/download.htm

= CCBootClient v2.0 Build 20101106

Client |nztall lpload Image
Install Cache Driver Syetern Disk Image | C146] i |
[] Start Cache After Login Windows Server |P Address | 192.168.1.100 |
[]5ave Cache when Shutdown WhADK. File Mame |><F'EI1 ek, |
[ Ingtall CCB oot Client ] [ lpload Image ]

Cache Settings

[ [nztall HIC ] [EreateHardwareF‘mfile] [ Save Drivers ]

Cache iz Stopped

Figure 5-12
Press the “Install CCBoot Client” button. After finished, it will require reboot system. After reboot
system, launch CCBoot client again, input the “Server IP address” and press “Upload Image” to

upload the image to the CCBoot server. Then CCBoot will create a VMDK file named
“D:\CCBootImage\XP01.vmdk” on the server. You can use this vmdk file to boot XP or Win2003.

5.3 Create Boot Image for Vista, Win7 and 2008

Take Win7 for example (Vista and Windows 2008 are the same)

1. Set CCBoot server as bellow:



CCBoot Options

X]

CHCP Settings |Client Default Settings | Server Cache Settings | Other Settings |

Start DHCP Start TFTP

DHCF Server IP 192,168.1.100 v
IP Alocated Start | 192.168.1,101 |
IP Alocated End | 192.168.1,250 |
P Mask. | 255,255.255.0 |
IP Gakteway | |
CM5 Address 1 | |
CMS Address 2 | |

[ K, ] [ Cancel

CCBoot Options

Figure 5-13

3

DHCP Settings | Client Default Settings | Server Cache Settings | Cther Settings |

Server IP Address | 192.168.1.100 |

Write-back File Path | F:\CCBootwrite-back |

| |Enable Cache | | M Reconmmend
[]write-back Limt | M

Image Save Path | oA CCBookImage |

sk, Group | AV CCBootyinit, wrndk; |

Apply ko All Clients ]
Ok ] [ Cancel

Figure 5-14




CCBoot Options

| DHCP Settings | Client Default Settings | Server Cache Settings | Other Settings |
[ ]Enable Cache Enable Huge Memory Sooess
Awvailable Physical Memary | |M Recommend
System Image Read Cache | |M
Game Disk Read Cache | |M
Clients Write-back Cache | | M
Enable S50 Cache 550 Cache
S50z A R - o | M
Auko Update Cache Update Cache Time | |
[ il ] [ Cancel
Figure 5-15

CCBoot Options @

[ DHCP Settings | Client Default Settings | Server Cache Settings ’ Other Settings L

MIStatiscsi semicsl  iscstport | 3260 |

[CJEnable Super Client Update Game Disk

Auto Add Client

Computer Name Prefix | PC

Server and Client Disk Mapping

Delete

[ ok || cancel |

Figure 5-16

2. Modify CCBoot.ini: add "createusb=1" bellow "[config]" and save



! CCBoot - Notepad
File Edit Format Miew Help

onf o ”~
-
ATSErvice=
StartDHCP=1
StartTFTP=1
IPStart=1%97.168,.1.10L1
IPER=192.158.1. 250
IPMask=255.255.255.0
IPGateway=192.168.1.1
IPDMS=192.168.1.1
IPDMNSZ =
DHCPServerIP=192.168,.1.100
EnableCache=1
serverCache=10
ServerCachez=10
EnakbleHugeMem=1
AllClientCache=0
MonitorbiskiChanges=1
AutoUpdatecache=0
autoUpdatecacheTimes=
Enablesso=0
SSDhPath=
Ssbsize=0
cefaultserverIip=152.1658.1.100
CefaultbiskGroup=
Defau1tWritebacEFi1ePath=F:\CCBDDtWPitE—back —
DefaultEnablewritebackLimit=0
DefaultwritebackmMax=200
cefaulteEnableccache=1
DefaultcCachesize=128
ImagesavePath=0:“CCEooTImage
Computerdameprefix=pPC
startiscsI=1 r

Figure 5-17

Plug into a USB key on CCBoot server. Press “Close” to shut off CCBoot interface and then
reopen. "File"->"Create Bootable USB" to create a bootable USB. Pull out the USB key.



l CCBoot v2.0 Build 20101106
FE8 Options  Client  Help

Skatt Service ) >
Pause Service \'i\b 6 6 @ 6 8

Stop Service tions Stop Service  Refresh Cache Help Close
Close LI IF Address Rea...  Writ... | Ima... Disk ... | Priv... Update Time Ima
Close Unused Inages and Disks 192.168.1.101 02-16 20:00:23

Create bootable USE

| >
Disk Upload Receiving
Onlingj TakalMern/Image DiskfSS0 - 0f1]14MOM/OMOM
Serwvice During Tirne 0Day O1H 37M 555
Update Image/Game: Enable Upload: PC101; Keep Write-back: Cache Last Update Time
Figure 5-18
4. Set one client boot from LAN, when CCBoot server get this client’s info, shut off it.
@ pciot 00:FF:4F:93:6C:75 192.168.1.101 11-03 12:45:26
@ pci02 00:E0:4C:0C:E4:B6 192.168.1.102 11-03 12:45:26
@ pC103 00:15:F2:07:84:43 192,168.1.103 [ 11-03 16:08:12

Figure 5-19

5. Modify this client’s properties as bellow:



12.
13.
14.

CCBoot Client X

Client Properties
Enabled
Computer Mame PC103
MaC Address O0:EQ:4C:0C:ES:BE
1P Address 192,168.1,103 [ ]Enable Upload Image
PXE gpe.pre Keep Write-back File
Gakeway
Disk Group CACCEootinit  wmndl; [ Clear Write-back ]
Hardware Profile [ Clear Private ]
Server [P Address 192.168.1.100 | savetoprivate |
YWrite-back File Path F:\CCBootwrite-back ’ Save to Image ]
[] erite-back Limitation | 200 M
[ ]Enable Client Cache I
[ ]Enable Set Resolution width*height*bit*Frequency

Super Client

[ ]Enable Update Image
Figure 5-20

Set boot device in BIOS for this client: first boot from USB, second boot from DVD ROM.
Plug into the USB key on this client and insert Win7 installation disk to the DVD ROM.
Restart this client, it will boot first from USB then install Win7 from DVD ROM.

During installing, you will find a 20G disk, install Win7 into this disk.

. Restart this client as the installation requires.
. Get into BIOS and set first boot from LAN, then pull out the USB key. Press F10 to save and

quit BIOS.
Restart and finish Win7 installation.
Diskless boot this client and Install CCBootclient, then shut off.
Back to CCBoot server, edit this client and press “Save to Image” to save image. When finished,
you can boot this client diskless with this image.
[ Attention] Keep well both “init.vmdk™ and “init-001.vmdk™, they are one image.

5.4 Diskless Boot Client

Edit the client properties on the CCBoot and select the correct image and you can diskless boot the



client PC.

Metwork boot from AMD AM79C978A
Copyright (C) 2883-2885 UMuare, Inc.
Copyright (C) 1997-2888 Intel Corporation

CLIENT MAC ADDR: B8 BC 29 92 3B 54 GUID: 564D1B67-7AE7-2FC7-3582-ACBA34923B54

CLIENT IP: 192.168.1.181 MASK: 255.255.255.8 DHCP IP:
GATEWAY IP: 192.168.1.1
CCBoot 2818-18-86 http://WWW.ccboot.com

Figure 5-21 (gPXE DHCP)

Microsoft® '/’

Windows™?

Copyright ® Microsoft Corporation

Figure 5-22 (Win XP Boot)

192.168.1.99




Microsoft

Windows Server2003

Copyright @ Microsoft Corpoaration

Figure 5-23 (Win 2003 Boot)

Starting Windows

© Microsoft Corporation

Figure 5-24 (Win 7 Boot)



6 Server Settings

6.1 Menu

“File” > “Start Service”: Start DHCP, TFTP and iSCSI service.

“File” -> “Pause Service”: If you have 2 or more CCBoot servers, you can choose this option to
make new boot clients boot from other servers. It will do nothing for clients already boot from
current server.

“File” -> “Stop Service”: Stop all services.

“File” -> “Close UI”: Close the main interface but the service is still running.

“File” -> “Close Unused Images and Disks”: Close the unused images and disks so that you can
implement some operations for them.

“QOptions” -> “Settings”: Configure server settings.
“Qptions” -> “Options Wizard”: A Wizard for a beginner.
“Qptions” -> “Show All Columns”: Show all columns even if you have hided some of them.

“Client” -> “Add”: Add a new client.

“Client” -> “Edit”: Edit the property of a selected client.

“Client” -> “Delete”: Delete a selected client or clients.

“Client” -> “Auto Scan”: Retrieve all power on clients’ MAC address, IP address and computer
name. You can set an IP range for auto scanning.

CCBoot Auto Scan @

Low IP Address High IP Address
192.168.1.1 - |192.168.1.255

LA LLLLLLLLLLLLL ]

[ Stop ] [ Close ]

Figure 6-1

“Client” -> “Wake On LAN”: Remotely start the selected clients. The function requires the NIC
and motherboard supports “Wake on LAN”. Please enable “Wake on LAN” in the client BIOS.
“Client” -> “Delete Private Package”: Delete the selected client’s private package.

“Client” -> “Delete Write-back File”: Delete the selected client’s write-back files

“Client” -> “Delete All Write-back File”: Delete the all clients’ write-back files.



“Help” -> “Help”: Open the user manual.
“Help” -> “About & Register”: Get the version information and enter the license information.
p g

6.2 Server Settings

6.2.1 DHCP Settings

CCBoot Options [E|
CHCP Settings | Client Default Settings | Server Cache Settings | Other Settings

Stark DHCP Stark TETP

DHCF Server IP 192.168.1.100 v
IP Alocated Start | 192,168.1,101 |
IP Allocated End | 192.168.1,250 |
IP Mask | 255.255.255.0 |
IP Gateway | 192.168.1.1 |
DS Address 1 | 192.168.1.1 |
CMS Address 2 | |

Ik ] [ Cancel

Figure 6-2

Start DHCP: Start DHCP service.

Start TFTP: Start TFTP service.

DHCP Server IP: If the server has multiple IP, you can specify the DHCP Server IP here.

IP Allocated Start: The first IP address allocated for the clients.

IP Allocated End: The last IP address allocated for the clients.

IP Mask, IP Gateway and DNS Address 1: CCBoot’s DHCP will push this mask, gateway and
DNS information to clients.

DNS Address 2: You can set the “Alternate DNS Server” here for clients.

Scan DHCP: Press this button to check out whether there’re other DHCP servers on the LAN.



6.2.2 Client Default Settings

CCBoot Options E|

| DHCP Settings | Clignt Default Settings |Ser'-.fer Cache Settings | Other Settings |

Server IP Address | 192.168.1.100 |

Write-back File Path | F:\CCBootwrite-back |

[+]Enable Cache | 128 | M
[Jvwrite-back Limt | | M

Image Save Path | Di{CCBaotImage |

Disk Group | |

Apply to All Clients ]

ik ] [ Cancel

Figure 6-3
Client Default Settings is used to define the settings for the auto-added clients.

Image Server IP: Define the server IP of the client. Pressing the “>>” button to add multiple IP
addresses. The client will boot from the first IP, if failed, it will try the next one.

Server List Settings @

Server List

192.1658.1.100

192,168.1.99
Down

| 192.168.1.99 ]

[ add | [ edt | | Delete |

{ OK i [ Cancel ]

Figure 6-4



Write-back File Path: Define the write-back file path of the client. Pressing the “>>" button to add
multiple write-back path.

Enable Cache: Define the client write cache size. CCBoot clients will store disk-writing data to the
client RAM instead of writing back to server. The first number is the write cache size of the image
disk and the second one is the write cache size of the game disk. Pressing the “Recommend” button
to get recommended cache settings based on the client physical RAM size.

The cache works as the following steps:

1. Write into the client cache.

2. If client cache is full, write back to server cache.

3. If the server cache is full, write back to the write-back path.

Client Write-back Limit: Define the maximum write-back size. We do NOT recommend setting a
limitation here if unnecessary.

Image Save Path: Define the image save path. All images uploaded from the clients will be saved
to this path. It should be large enough to store the images.

Disk Group: Define the system image and game disk of the client. Pressing “>>" button to define

the details.

CCBoot Disk Group E|

System Image Selection

Lo CCBookImagel<P01, vmdk, w [ Other Irnage ] [Merge Image]

Game Disk Selection
Local Disk: Lisk aame Disk Lisk

S Disk [0] (2,000 = IoH
e Disk [1](F0
e Disk [2] (@0

=z
e A
[
. =
e i)
Recommend game disk as NTFS and duster size 32K o ] [ cancel
Figure 6-5

System Image Selection: Select the image from the combo box list or press the “Other Image”
button to select other image for diskless booting.

Merge Image: If you use “Save to image” in client’s properties dialog box many times, it will
created many additional packages such as XP01-001.vmdk, XP01-002.vmdk. It will make diskless
booting slowly. “Merge Image” can merge all those packages to one vmdk file. You need to stop



CCBoot service before you do “Merge Image”.
Game Disk Selection: You can select a partition or a whole hard disk as game disk.

Apply All Clients: Press this button to apply the client default settings to the existing clients.

6.2.3 Cache Settings

X

CCBoot Options

DHCP Settings || Client Defaulk Settings | Server Cache Settings | Other Settings

Enable Cache Enable Huge Memary Access
Available Physical Memory | 326 M
System Image Read Cache | 10 M

izame Disk Read Cache 10 M

Clients Write-back Cache |0 M

[ ]Enable 550 Cache
350 Path S50 Size 4

Auto Update Cache []update Cache Time

Ik ] [ Zancel

Figure 6-6

Enable Cache: Enable cache function.

Enable Huge Memory Access: CCBoot can access memory over 2G if enable this option. You
need to do two modifications if you want to use this function. Please refer to chapter 5.1.
Available Physical Memory: The current free physical memory of the server.

System Image Read Cache: The image read cache size for all clients.

Game Disk Read Cache: The game disk read cache size for all clients.

Clients Write-back Cache: Cache size for write-back..

Enable SSD Cache: SSD (Solid State Disk) is a new technology hard disk that disk read and write
speed than normal disk. CCBoot can use SSD as the cache storage. If the clients request data from
the game disk, CCBoot will search it from SSD first, if existing, it will read the data from SSD. If
non-existing, it will read from the physical game disk and store it into SSD. SSD cache will improve



the disk read speed.

55D Cache Settings

%)

Disk 550Size(M)
o 10240
E: 20450
E | l20ds0 (M
i) (e ] (ovee ]
[ K ] [ Zancel ]

Figure 6-7

SSD Path: Define the SSD path. For example: E:\

SSD Size: Define the SSD file size.

Auto Update Cache: When the disk files are modified by some applications, for example, game
update application, CCBoot will update the cache immediately.

Update Cache Time: Specify a time to update cache.



6.2.4 Other Settings

CCBoot Options fg

CHCP Settings | Client Default Settings | Server Cache Settings | Other Settings |_

Skart i3CSI Service iSCSI Port 3260

[ ]Enable Super Client Update Game Disk:

Auto Add Client

Compuker Marme Prefix

Server and Client Disk Mapping

Delete

Ik ] [ Cancel

Figure 6-8

Start iISCSI Service: Start the iSCSI target service.

iSCSI Port: Define the iSCSI target service port.

Enable Super Client Update Game Disk: If you want to update game by super client, you need to
select this option to lock the read and write operations of the game disk.

Auto Add Client: All clients on the LAN will be added into CCBoot with the "Client Default
Settings" automatically.

Computer Name Prefix: Define the computer name prefix.

Server and Client Disk Mapping: Define the client’s disk letters. Normally used to define the
game disk letters. For example, the game disk letter is F on the server and you want to share it to the
client with disk letter G.



Disk Mapping @

Server Disk

Client Disk.

]

Cancel

6.3 Properties of CCBoot Client

CCBoot Client

Client Properties
Enabled

Computer Name
MAC Address

IP Address

PxE

Gateway
Disk, Group
Hardware Prafile

Server IP Address

‘Write-back File Path

Enable Client Cache

Super Clienk

[ ]Enable Update Image

Figure 6-9

Save

| PC101

Close

| D0:ED:4C:0C:E4:B6

| 192.168.1.101

| gpxe.pre

[ ]keep write-back File

|
|
| Enable Upload Image
|
|

X

| [ Clear Wrike-back

Clear Private

B

| 192.168.1.100

| [ Save ko Private

| FilCCBoatwrite-back

| [ Save ko Image

l
]
]
]

[ wirite-back Limitatior M

125 M

[]Enable set Resolution |:| width*height*hit*Frequency

Ernable Update Game Disk.

Figure 6-10




Enabled: Enable the client diskless boot from CCBoot server.

Computer Name: Define the computer name of the client.

MAC Address: Define the MAC address of the client.

IP Address: Define the IP address of the client.

PXE: Specify the PXE drive. The default drive supports the most NICs.

Gateway: Specify the gateway for current client.

Disk Group: Define the system image and game disk of the client. Pressing “>> button to define
the details.

CCBoot Disk Group E|

System Image Selection

Lo CCBookImagel<P01, vmdk, w [ Other Irnage ] [Merge Image]

Game Disk Selection
Local Disk: Lisk aame Disk Lisk

S Disk [0] (2,000 = IoH
e Disk [1](F0
e Disk [2] (@0

=z
e A
[
" =
e i)
Recommend game disk as NTFS and duster size 32K o ] [ cancel
Figure 6-11

System Image Selection: Select the image from the combo box list or press the “Other Image”
button to select other image for diskless booting.

Merge Image: If you use “Save to image” in client’s properties dialog box many times, it will
created many additional packages such as XP01-001.vmdk, XP01-002.vmdk. It will make diskless

booting slowly. “Merge Image” can merge all those packages to one vmdk file. You need to stop
CCBoot service before you do “Merge Image”.

Game Disk Selection: You can select a partition or a whole hard disk as game disk.

Hardware Profile: Specify a hardware profile for current so that different clients can load different
hardware drives.

Server IP Address: Define the server IP of the client. Pressing the “>>” button to add multiple IP
addresses. The client will boot from the first IP, if failed, it will try the next one.



Server List Settings @

Server List

1192.168.1.100 3

%, 166.1.95 [ue ]
J

| 192.168.1.99

[ add | [ edt | | Delete |

T | [ Cancel ]

Figure 6-12

Write-back File Path: Define the write-back file path of the client. Pressing the “>>” button to add
multiple write-back path.

Write-back Limitation: Define the maximum write-back size. We do NOT recommend setting a
limitation here if unnecessary.

Enable Client Cache: Define the client write cache size. CCBoot clients will store disk-writing
data to the client RAM instead of writing back to server. The first number is the write cache size of
the image disk and the second one is the write cache size of the game disk. Pressing the
“Recommend” button to get recommended cache settings based on the client physical RAM size.
The cache works as the following steps:

1. Write into the client cache.

2. If client cache is full, write back to server cache.

3. If the server cache is full, write back to the write-back path.

Enable Set Resolution: Define the resolution of client.

Enable Upload Image: Enable the client to upload its system image to the server.

Keep Write-back File: Keep the write-back file after reboot the client.

Clear Write-back: Manually clear write-back file of client.

Clear Private: Manually clear private package of client.

Save to Private: Save the client’s current system state to a package. The client will keep the state
when reboot even delete the write-back file.

Save to Image: Save the client’s current system to the boot image. You’d better stop the client
cache and shutdown the client PC before you click “Save to Image”.

Enable Update Image: Enable the client to update the image directly as a super client.

Enable Update Game Disk: Enable the client to update the game disk directly as a super client. If
you want to enable update game disk, you need to select “Enable Super Client Update Game Disk”
in “Options” -> “Other Settings” first.



7 Game Disk Settings

1. Add game disk in “Options” -> “Client Default Settings” -> “Disk Group” -> “>>”.

x]

CCBoot Disk Group

Syskern Image Selection

| DH\CCBoatImage kPO1. vmdk v|[ Other Image | | Merge Image |

Game Disk Selection

Local Disk, List Game Disk List
e Disk, [0] (0, D0, LG, H g F;
G ) (3]
=t —= 1 el
o=
Recommend game disk as NTFS and cluster size 32K oK l [ cancel
Figure 7-1

2. Set disk mapping between server and client in “Options” -> “Other Settings”.



CCBoot Options [z

| DHCP Settings | Client Default Settings | Server Cache Settings | Okher Settings |_

Disk Mapping

Server Disk, Client Disk,

. Add

m ™

(0.4 ] [ Cancel

Figure 7-2

Drive F on server is used as a game disk for clients and it will display as F in the client.
Drive G onserver is used as a game disk for clients and it will display as E in the client.
Drive H on server is used as a game disk for clients and it will display as H in the client.



8 CCBoot Client Installation

Download CCBoot client installation package from:
http://www.ccboot.com/download.htm
Launch it and keep pressing the next button till the end and then you can see the client main panel

(Figure 8-2).

5 Setup - CCBoot Client AEE

Welcome to the CCBoot Client
Setup Wizard

This will install CCBoak Client 2,0 Build 20101106 on your
compuker,

1t is recommended that you close all other applications before
conkinuing.

Click Mext to continue, or Cancel bo exit Setup.

Mext = ][ Cancel

Figure 8-1


http://www.ccboot.com/download.htm

= CCBootClient v2.0 Build 20101106

Client |nztall lpload Image
Install Cache Driver Syetern Disk Image | C146] i |
[] Start Cache After Login Windows Server |P Address | 192.168.1.100 |
[]5ave Cache when Shutdown WhADK. File Mame |><F'EI1 ek, |
[ Ingtall CCB oot Client ] [ lpload Image ]

Cache Settings

[ [nztall HIC ] [EreateHardwareF‘mfile] [ Save Drivers ]

Cache iz Stopped

Figure 8-2

Install Cache Driver: Install cache driver for client.

Start Cache After Login Windows: If checked, the client cache will be unavailable until the
windows login onto the desktop. If it’s unchecked, the client cache will be available at the
beginning.

Save Cache When Shutdown: If checked, the client will write the cache data back to server when
the client shutdown.

Install CCBoot Client: Press to install CCBoot client’s drivers and applications.

System Disk Image: Select the system disk.

Server IP Address: Input the CCBoot server’s IP address.

VMDK File Name: Define the VMDK file name.

Upload Image: Press it to upload image.

Start Cache: Press it to start client cache function.

Stop Cache: Press it to stop client cache function.

Install NIC: Press it to install NIC drives.

Create Hardware Profile: Press it to create hardware profile, you can set different hardware profile
for clients with different hardware.

Hardware Profile 1D

Hardware Profile |0

Hardware Descrption |-'f"-|'~"|D Cligrits |

[ OF. ] [ Cancel ]

Figure 8-3



Save Drives: Press it to save drives of client.

Notes:

If the "Keep Write-back File", "Enable Upload Image" or “Super Client” is checked in the client
properties, the client cache will be unavailable.

= CCBootClient v2.0 Build 20101106

Client [nztall IJpload Image
Install Cache Driver System Disk Image | C [4G] o’ |
Start Cache After Login Windows Server |P Address | 192.168.1.99 |
[] 5ave Cache When Shutdown WhADK, File M ame |><F'D'I ek, |
[ Inztall CCB oot Client ] [ Ilpload Imange ]

Cache Settings

[ Ingtall MIC ] [Eleate HardwafeF'mfilel [ Save Drivers ]

Cache iz Started: #1 Cache 32M[Read 0'rite 3 M | #2 Cache OkM[Read 0'wWrite 0] #3 Cache Ok[Read 0'wiite 0 ]

Figure 8-4



9 Cache Settings

Recommended Server Settings

Server Physical RAM | Image Cache Game Cache Write-back Cache
2G 256M 512M 256M

4G 512M 1024M 1024M

8G 1024M 4096M 2048M

16G 1024M 10240M 4096M

32G 1024M 20480M 10240M
Recommended Client Cache Settings

Client Physical RAM | Image Disk Cache #1 Game Disk #2 Game Disk
1G 256M 64M 64M

2G 384M 128M 128M

4G 512M 256M 256M

Sometimes, the client cache will cause blue screen when boot Windows. You can fix it by three

methods.

Method 1 - Reduce the client cache size. If still failed, try method 2.

Method 2 - Disable the client cache.
Method 3 - Reinstall CCBootClient with select “Start Cache After Login Windows”.




10 Super Client

The super client can update image or game disk directly.

You can set any client as the super client. Just select “Enable Update Image” or “Enable Update
Game Disk” in the client’s properties (Figure 10-1).

If you want to update game disk with super client, you need to select “Enable Super Client Update
Game Disk” in CCBoot “Options” -> “Other Settings” first (Figure 10-2).

CCBoot Client X

Client Properties
Enabled
Computer Marme | PC101 |
MAC Address | O0:ED:4C:0CESBE |
IP Address | 192,168.1.101 | Enable Upload Image
PXE | gpxe.pre | [ ]keep Write-back File
Gateway | |
Disk. Group | | [ Clear Write-back, ]
Hardware Profile | | [ Cleat Private ]
Server IP Address | 192.168.1.100 | B3] [__sevetoprivate |
Write-back File Path | F:\CCBaotwirite-back | [ Save to Image ]
[ ] Write-back Limitation M
Enable Client Cache | 128 141
Enable Set Resolution |:| width*height*bit*frequency

Super Clienk
[ ]Enable Update Image [ ]Enable Update Game Disk

Figure 10-1



CCBoot Options [z

| DHCP Settings | Client Default Settings | Server Cache Settings | Cther Settings |_

Start 551 Service iSC3I Port 3260

Enable Super Client Update Game Disk,

Auto Add Client

Compuker Mare Prefix

Server and Client Disk Mapping

Delete

K, ] [ Cancel

Figure 10-2

The super client updates image and disk directly and the updating is unrecoverable. But “Save to
Image” in the client properties is recoverable.



11 Update Image

Method 1: Use ""Keep Write-back File" and “Save to Image”

1)

2)

3)

Choose one client PC as the update client. Select "Keep Write-back File" in the client’s
properties.

Diskless boot the client and do some modifications as you wish. For example, upgrade
software in the system.

Shutdown the client PC. Click the “Save to Image” button in the client’s properties. Don’t
forget unselect “Keep Write-back File” when finished.

With this method, you will find a series of vmdk files such as xp.vmdk, xp-001.vmdk,

xp-002.vmdk and so on. “Save to Image” will create a new file xp-nnn.vmdk. If you want to recover
to the last image state, you can stop CCBoot service and delete the latest xp-nnn.vmdk. That’s to say
“Save to Image” is recoverable.

However, if you have created many xp-nnn.vmdk files, that will degrade operation

performance of the image. In this case, you need to upload the image again or use “Merge Image” to
merge all of them to one image (Chapter 6.2.2).

Method 2: Use “Super Client”

1)

2)
3)

Choose one client PC as the update client. Select “Super Client” -> “Enable Update Image” in
the client’s properties.

Diskless boot the client and do some modifications as you wish.

Shutdown the client PC. Unselect “Enable Update Image” in the client’s properties.

With this method, the client will update the image directly, so you cannot recover the image to
previous state.



12 Update Game Disk

Method 1: Update game disk on the server.
You can update game disk on the server directly. After reboot clients, they can get new game data.
Method 2: Update game disk with super client.

1) Choose one client PC as the update client. Select “Enable Super Client Update Game Disk” in
CCBoot “Options” -> “Other Settings”. Select “Super Client” -> “Enable Update Game Disk”
in the client’s properties.

2) Diskless boot the client and update the games in the game disk.

3) Shutdown the client PC. Unselect “Enable Update Game Disk” in the client’s properties.



13 Load balance and redundancy

CCBoot supports multiple servers.
Suppose

Server A—192.168.1.1
Server B —192.168.1.2
Both of them have write-back file path: E\CCBootWrite-back and F:\CCBootWrite-back.

Settings

Go to Server A, open “Options” -> “Client Default Settings”.

1. Add 192.168.1.1 and 192.168.1.2 to “Server IP Address” (Figure 13-1)

CCBoot Options E|

DHCP Settings | Client Default Settings |Server Cache Zettings | COther Settings |

Server [P Address | 192.168.1.1;192.168.1.2; || (>3]

Server List Settings

[ Server Lisk crnrnend

M 19216811
192,168.1,2

0 Coairy

| 192.168.1.2 |
[[ add | [ Ed

]
[ Ok ] [ Cancel ]

[ Delete ]

|_ Ok ] [ Cancel

Figure 13-1

2. Add “E:\CCBootWrite-back” and “F:\CCBootWrite-back” to “Write-back File Path” (Figure
13-2).



DHCP Settings | Client Default Settings | Server Cache Settings | Other Settings

Server IP Address | 192.168.1.1;192.168.1.2; |

Write-back File Path | E:\CCBootWrite-back;F:\Cq) |

Write-back File Path Settings

E:WCCBoobWrite-back,
FiCCBoobwWrite-back,

Add ] [ Delete

] [ Ok ] [ Cancel

]

[ Ok H Cancel ]

Figure 13-2

3. Click “Apply All Clients”. CCBoot will apply the client default settings to all existing clients.
Now the clients’ settings become as -

Clients

Image Server IP

Game Server IP

Werite-back File Path

Clientl

192.168.1.1;192.168.1.2

192.168.1.1;192.168.1.2

E:\CCBootWrite-back

Client2

192.168.1.2;,192.168.1.1

192.168.1.2;,192.168.1.1

F:\CCBoot\Write-back

Client3

192.168.1.1;192.168.1.2

192.168.1.1;192.168.1.2

E:\CCBootWrite-back

Client4

192.168.1.2;,192.168.1.1

192.168.1.2;,192.168.1.1

F:\CCBootWrite-back

Client1 will try to boot from 192.168.1.1 first, if failed, it will try to boot from 192.168.1.2. About
game server, it will try to connect to 192.168.1.1 first, if failed, and then try 192.168.1.2. The
write-back file path is E:\CCBootWrite-back.

Client2’s settings are different from Client1’s.

Notes: You need to add all clients before implement load balance and redundancy.

4. Copy CCBoot.ini from the Server A’s CCBoot installation folder to Server B’s. Open “Options”

-> “DHCP Settings” on the Server B. Select correct “DHCP Server IP”. Restart CCBoot service
on the Server B.

5. Now you will see that clientl connect to server A and client2 connect to server B. If you
shutdown server A, clientl can still boot from server B.




14 PnP Different Devices

1. Suppose you have 3 types of hardware:
® PC-A, PC-Al, PC-A2
® PC-B,PC-B1, PC-B2
® PC-C,PC-C1,PC-C2

2. Choose an AMD PC (only if you have both AMD and Intel specs) with the most advanced
hardware (PC-A) and do as bellow:

® Allocate a small partition about 10G size and format the partition with NTFS and cluster size is
32K.

® Install Win XP.

® Shut off OS firewall of XP.

® Run CPU PNP.reg (contact us to get it).

® My Computer->Properties->Advanced->Startup and Recovery->Settings->System Failure:
uncheck “Automatically Restart”.

® Install all drivers except sound and display.

® Install software you need.

3. Launch CCBootSetupClient.exe on PC-A. Press “Install CCBoot Client” button and in the end,

you can get an NIC drivers list as bellow: Select the drivers which you will use for all your
clients and press “OK”. If you do not know the exactly driver you need, please “select all”.

NIC Drivers X]

Please select the NIC drivers that will be used in this image:
NIC Service Hardware ID
[] sis 900-Based PCI Fast Ethernet &... SISNIC VEMN_1039&DEY_0900
NVIDIA nForce 3/4 Networking Co... NYENET34 VEN_10DE&DEY_0037;VEN_10DER....
[] NVIDI& nForce 5/6 Networking Co... NVENETS6 VEMN_10DE&DEY_0268;VEMN_10DER...
[[] Realtek RTLE139 Family PCI Fast E... rtl8139 VEN_10ECRDEY_8139
[[] Realtek RTL8169 Family Gigabit Et... RTL8023xp VEN_10ECRDEY_B167,VEN_10ECE...
Realtek RTL8168/8111 PCI-E Giga... RTLES023xp WVEN_10EC&DEY_B8168
[] vIa PCI 10/100Mb Fast Ethernet ... FETNDIS VEMN_1106&DEV_3043;VEN_1106&...
[[] Marvel Yukon 88ES001/8003/801... yukonwxp VEN_11488DEY_9000;VEN_11488&...
Broadcom NetLink Gigabit Etherne... bS7w2k VEN_14E48DEY_16XX;VEN_14E4%...
[] wMware PCI Ethernet Adapter vmxnet VEN_15ADERDEY_0720
[ Intel(R) PROJ1000 MT Desktop Ad... E1000 VEN_S086&DEY_100E;VEN_S0868...
[ Intel(R) PRO/100 VE Network Con... E100B VEN_S086&DEY_103¥;VEN_S0868...
[Jselect al [ OK J [ Canicel ]
Figure 14-1

4. Reboot this client PC and then upload image (must enable upload image for this client before on



CCBoot server).

5. Diskless boot all clients with this image to make sure they can all boot well.

6. Back to CCBoot server and edit PC-A: uncheck “Enable Upload Image” and check “Keep
Write-back File”, delete write-back files following the popup prompt. Diskless boot PC-A and
run CCBootClient to “Create Hardware Profile”: AAAA, BBBB, CCCC and so on.. Shut off
this client and go back to server, save image for this client.

7. Set AAAA for PC-A and check “Keep Write-back File”, diskless boot PC-A. It will be locked
when get into desktop first time and will be OK after restart. Install drivers for sound and
display, restart to make new display settings and then “Save Drivers” in CCBootClient.

= CCBootClient v2.0 Build 20101106

Client Inztall Jpload Image
Install Cache Driver System Disk Image C [4G] h
Start Cache After Login 'Windows Server P Address 192.168.1.100
[] 5ave Cache When Shutdown WMDK File M arne HPOT wrndk,
l Inztall CCB ook Client ] [ pload Image ]

Cache Settings

[ Install MIC ] | Create Hardware F'ru:nfile§| [ Save Drivers l

Cache iz Stopped

Figure 14-2

8. Set AAAA for PC-Al and PC-A2.
9. Do the same as step 7 and step 8 for PC-B, PC-B1, PC-B2 (use the BBBB hardware profile).
10. Do the same as step 7 and step 8 for PC-C, PC-C1, PC-C2 (use the CCCC hardware profile).



15 FAQs

1. Why it got about 1 minute delay when I get into desktop?

Please disable this service - Windows Firewall/Internet Connection Sharing (ICS).

2. Why the client cache doesn’t work?

If the "Keep Write-back File", "Enable Upload Image" or “Super Client” is checked in the client
properties, the client cache will be unavailable.

3. Some already known situations which can lead to blue screen.

a) Wrong version of NIC driver.

b) Some antivirus software will cause a blue screen, please check it out.

¢) The client cache is too large, please modify.

d) The client has not been installed correctly. Please make sure you have pressed the “Install
CCBoot Client" and complete it with a reboot before uploading the image.

For more FAQs, please refer to http://www.ccboot.com/fag.htm.



http://www.ccboot.com/faq.htm

16 Contact

yowngzsoft

Product Page: http://www.ccboot.com

Technical Support Email: support@ccboot.com

Sales Support Email: sales@ccboot.com


http://www.ccboot.com/
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