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About This Book

This preface provides information about the VMuware Player Getting Started Guide and links to VMware®
educational resources.

Intended Audience

This book is intended for anyone who wants to install and use VMware Player 3.0. VMware Player 3.0 users
include anyone who wants to create and run virtual machines or virtual appliances. You can download and
safely run prebuilt application environments provided by software vendors or colleagues.

Document Feedback

VMware welcomes your suggestions for improving our documentation. If you have comments, send your
feedback to docfeedback@vmware.com.

Education Resources

The following Education resources are available to you. To access the current version of this book and other
books, go to http://www.vmware.com/support/pubs.

VMware Professional VMware Education Services courses offer extensive hands-on labs, case study

Services examples, and course materials designed to be used as on-the-job reference
tools. Courses are available onsite, in the classroom, and live online. For onsite
pilot programs and implementation best practices, VMware Consulting
Services provides offerings to help you assess, plan, build, and manage your
virtual environment. To access information about education classes,
certification programs, and consulting services, go to:
http://www.vmware.com/services/.
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What Is VMware Player?

VMware Player is a desktop application that lets you create, configure, and run virtual machines.
With VMware Player you can use the following features:
B (Create virtual machines that can run on a Windows or Linux PC.

B Runvirtual machines, making it easy to take advantage of the security, flexibility, and portability of virtual
machines.

B Access all of the host machine hardware devices, such as USB drives, from the virtual machine.

The terms host and guest describe physical and virtual machines:

Host The physical computer on which you install the VMware Player software is
called the host machine, and its operating system is called the host operating
system.

Guest The operating system running inside a virtual machine is called a guest

operating system. The virtual machine is called the guest.

VMware Player provides an intuitive user interface for creating virtual machines or running preconfigured
virtual machines created with VMware Workstation, ESX Server, VMware Server, VMware Fusion, and GSX
Server. On Windows host machines, you can use VMware Player to open and run Microsoft Virtual PC and
Microsoft Virtual Server virtual machines, and Symantec Backup Exec System Recovery, formerly LiveState
Recovery, system images. VMware Player also lets you download virtual appliances and access Open
Virtualization Format (OVF) and Open Virtual Appliance (OVA) files. For information about VMware Player
see the compatible virtual machines and system images topic.

VMware Player makes VMware virtual machines accessible to colleagues, partners, customers, and clients,
regardless of whether they have purchased VMware products. Anyone who downloads VMware Player can
open and run compatible virtual machines.

Note Use of VMware Player is subject to the VMware Player end-user license terms. VMware provides no
support for VMware Player. You can download VMware Player from the VMware Web site.

You can also download virtual appliances to use with VMware Player from the Virtual Appliance Marketplace
from the VMware Web site.

For self-help resources, see the VMware Player FAQ under the VMware Desktop Virtualization Products
section of the VMware Web site. You can also participate in the VMware Player Discussion Forum under the
VMware Technology Network (VMTN) section of the VMware Web site. The forum enables VMTN members
to exchange information, questions, and comments regarding VMware products, services, and product support
issues.
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This chapter includes the following topics:
B “What You Can Do with VMware Player,” on page 8

B “Features in VMware Player,” on page 8

What You Can Do with VMware Player

VMware Player allows you to perform various tasks in a virtual machine. You can create and run virtual
machines, use and evaluate prebuilt applications, simplify software distribution, and collaborate with
colleagues.

Create and Run Virtual Machines

Create a virtual machine to configure and test desktops and servers as virtual machines before deploying them
to production. You can test new multitier applications, application updates, and operating system patches on
a single PC. You can host legacy applications within virtual machines, facilitating operating system migrations
and eliminating the need to port legacy applications.

Use and Evaluate Prebuilt Applications

Download and safely run prebuilt application environments on virtual machines that are available from the
Virtual Appliance Marketplace section on the VMware Web site. The Virtual Appliance Marketplace includes
virtual machines from leading software vendors, including Oracle, Red Hat, Novell, BEA, SpikeSource, IBM,
and MySQL, as well as virtual machines that are preconfigured with popular open source software.

Transform Software Distribution

Simplify software distribution by shipping preconfigured software on virtual machines. Customers can
experience the benefits of your products immediately, without setup hassles. VMware Player is ideal for
shipping evaluation copies or beta software. You can package complex, sophisticated applications, complete
with a full working environment, on a virtual machine that anyone who downloads VMware Player can use.

Collaborate with Colleagues

VMware Player makes it easy for support, development, and QA to share customer scenarios in virtual
machines.

Features in VMware Player

VMware Player is a desktop application for creating and running virtual machines.
VMware Player includes the following new features:

B Create Virtual Machine with Easy Install - Create a virtual machine and install any supported guest
operating system with Easy Install.

B New User Interface - New virtual machine library interface is now available. The interface to create virtual
machines and edit virtual machine settings is also available.

B Aero Glass Support - New Windows Display Driver Model (WDDM) graphics driver available by default
for Windows Vista and Windows 7 provides support for the Windows Aero user interface. The WDDM
driver also includes support for OpenGL 1.4 and Shader Model 3.0. VMware recommends that you use
the graphics hardware NVIDIA GeForce 8800 and ATI Radeon HD 2600 with Aero.

® 3D Graphics Improvements - OpenGL 2.1 and Shader Model 3.0 support is available for Windows XP
virtual machines. The XPDM graphics driver works with Windows XP, Windows Vista, and Windows 7.
However, only Windows XP virtual machines install the graphics driver by default.

B Multiple display Support - Virtual machines can now take advantage of multiple monitors.

8 VMware, Inc.



Chapter 1 What Is VMware Player?

Advanced Linux Sound Architecture (ALSA) - ALSA is available in VMware Player to improve the audio
in virtual machines running on a Linux host.

Drag and Drop Enhancements - Ability to drag and drop images, formatted text email attachments, and
zip folders is available for both Windows and Linux hosts. The enhancements add support for new file
types and extends the existing ability to drag and drop certain file types to a broader set of guest and host
operating systems.

Virtual Printing - Support for virtual printing allows users to print from virtual machines without mapping
network printers or installing printer drivers in the virtual machine. If virtual printing is enabled in the
virtual machine setting, all of the printers installed on the host operating system are available in the guest
operating system.

On-Demand VMware Tools Download - VMware Tools integrates the guest operating system with the
host operating system through drag and drop, cut and paste, time synchronization, and features like Unity.
The latest version of VMware Tools is dynamically downloaded during the creation of virtual machines.

VIX API for VMware Player - Software vendors can use the VIX functionality to add their own interface
to the VMware Player menu bar. VIX API documentation and additional information is available on the
VMware Web site.

For more instructions about how to use these features, select Help > Help Topics to view the online help
provided in VMware Player.
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Host System Requirements for
VMware Player

Your computer must have the compatible hardware to install VMware Player.

The minimum host system requirements for installing and using VMware Player are:
B Standard x86-compatible or x86-64 with Intel VT or AMD-V compatible PC

B Processor speed — 1.3GHz or faster

®  Memory — Minimum 1GB is required, however VMware recommends to have 2GB and above available
memory. You must have enough memory to run the host operating system, the guest operating system
for every virtual machine, and for applications on the host and guest. For more information about memory
requirements, see your guest operating system documentation.

B Hard disk — At least 1GB free disk space is recommended for each guest operating system.
This chapter includes the following topics:
B “Compatible Virtual Machines and System Images,” on page 12

B “Using Virtual Symmetric Multiprocessing,” on page 12
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Compatible Virtual Machines and System Images

VMware Player runs virtual machines and system images created with other VMware and non-VMware
products.

The following virtual machines and system images are compatible with VMware Player:

VMware Virtual VMware Player runs virtual machines created with VMware Workstation 4 and

Machines later, GSX Server 3.x, VMware Server, and ESX Server 2.5 and later.
Workstation 4 virtual machines run in legacy mode. You must use another
VMware product to upgrade virtual machines created in versions earlier than
Workstation 4 before you can run them in VMware Player.

Microsoft Virtual PC and On Windows hosts, VMware Player can run Microsoft Virtual PC and Virtual

Virtual Server Virtual Server virtual machines. When you open a Virtual PC virtual machine in

Machines VMware Player, VMware Player creates a VMware-compatible configuration
file with a .vmx file extension, and preserves the original Virtual PC
configuration file, with a .vmc file extension. You can save the VMware-
compatible virtual machine without changing your original Virtual PC
configuration file.

Symantec Backup Exec On Windows hosts, VMware Player can run system images created with
System Recovery Symantec Backup Exec System Recovery, formerly Symantec LiveState
System Images Recovery. When you open a Backup Exec System Recovery system image in

VMware Player, VMware Player creates a VMware-compatible configuration
file (with a .vmx extension), and preserves the original Backup Exec System
Recovery system image file with a .sv2i file extension.

Using Virtual Symmetric Multiprocessing

Virtual Symmetric Multiprocessing (SMP), you can assign up to four or more virtual processors to a virtual
machine on any host machine that has four logical processors.

The following are all considered to have four or more logical processors:
® A multiprocessor host with four or more physical CPUs
B A single-processor host with a multicore CPU

B A single-processor host with hyperthreading enabled

Note On hyperthreaded uniprocessor hosts, performance of virtual machines with virtual SMP might be
below normal.

With VMware Player you can power on and run multiple four-processor virtual machines concurrently.
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Supported Host and Guest Operating
Systems for VMware Player

You can check the supported host and guest operating systems list for virtual machines running in VMware
Player to verify whether your computer operating system allows you to install VMware Player.

B Supported Host Operating Systems on page 13

VMware Player is available for Windows and Linux host operating systems.

B Supported Guest Operating Systems on page 16

VMware continually adds support for new guest operating systems and new versions and updates of
currently supported operating systems.

B Processor Support for 64-Bit Guest Operating Systems on page 19

When you power on a virtual machine with a 64-bit guest operating system, VMware Player performs
an internal check. If the host CPU is not a supported 64-bit processor, you cannot power on the virtual
machine.

Supported Host Operating Systems
VMware Player is available for Windows and Linux host operating systems.

For installation, VMware Player requires approximately 250MB (Windows) or 200MB (Linux) free disk space.
You can delete the installer after installation is complete to reclaim disk space.

Windows Host Operating Systems
VMware Player supports these Windows 32-bit and 64-bit host operating systems.

The Table 3-1 lists the supported Windows 32-bit and 64-bit host operating systems.
Table 3-1. Windows Host Operating Systems

Operating System Type Operating System Edition

32-bit Windows 7 Ultimate Edition
Windows 7 Enterprise Edition
Windows 7 Professional
Windows 7 Home Premium
Windows 7 Home Basic

Windows Vista Enterprise Edition, SP1, SP2

Windows Vista Business Edition, SP1, SP2

Windows Vista Home Basic and Premium Editions, SP1, SP2
Windows Vista Ultimate Edition, SP1, SP2

Listed versions are also supported with no service pack.
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Table 3-1. Windows Host Operating Systems (Continued)

Operating System Type

Operating System Edition

Windows Server 2008 Enterprise, SP1, R2
Windows Server 2008 Standard, SP1, R2

Windows Server 2003 Enterprise Edition with SP1, R2, SP2
Windows Server 2003 Standard Edition with SP1, R2, SP2
Windows Server 2003 Small Business Edition with SP1, R2, SP2

Windows XP Home Edition with SP2 or later service pack
Windows XP Professional with SP2 or later service pack

64-bit

Windows 7 Ultimate Edition
Windows 7 Enterprise Edition
Windows 7 Business
Windows 7 Home Premium
Windows 7 Home Basic

Windows Vista Enterprise Edition, SP1, SP2

Windows Vista Business Edition, SP1, SP2

Windows Vista Home Basic and Premium Editions, SP1, SP2
Windows Vista Ultimate Edition, SP1, SP2

Listed versions are also supported with no service pack.

Windows Server 2008 Enterprise, SP1, R2
Windows Server 2008 Standard, SP1, R2

Windows Server 2003 Enterprise Edition with SP1, R2, SP2
Windows Server 2003 Standard Edition with SP1, R2, SP2
Windows Server 2003 Small Business Edition with SP1, R2, SP2

Windows XP Professional x64 Edition with SP1 or later service pack

Linux Host Operating Systems

VMware Player supports these Linux 32-bit and 64-bit distributions and kernels for the host operating systems.

VMware Player might not run on systems that do not meet these requirements.

As newer Linux kernels and distributions are released, VMware modifies and tests its products for stability

and reliability on those host platforms. VMware makes every effort to add support for new kernels and

distributions in a timely manner, but until a kernel or distribution is added to this list, its use with VMware
products is not supported. Look for newer prebuilt modules in the download area of the VMware Web site. The
Table 3-2 lists the supported Linux 32-bit and 64-bit host operating systems.

Table 3-2. Linux Host Operating Systems

Operating System Type

Operating System Edition

32-bit

Asianux Server 3

Mandriva 2009
Mandriva 2008, 2008-1

Oracle Enterprise Linux 5.2
Oracle Enterprise Linux 5.1
Oracle Enterprise Linux 5.0
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Table 3-2. Linux Host Operating Systems (Continued)

Operating System Type Operating System Edition

Red Hat Enterprise Linux 5.3 WS, AS, ES
Red Hat Enterprise Linux 5.2 WS, AS, ES
Red Hat Enterprise Linux 5.1 WS, AS, ES
Red Hat Enterprise Linux 5.0 WS, AS, ES

Red Hat Enterprise Linux 4.8 WS, AS, ES
Red Hat Enterprise Linux 4.7 WS, AS, ES
Red Hat Enterprise Linux 4.6 WS, AS, ES
Red Hat Enterprise Linux 4.5 (formerly 4.0 Update 5) WS, AS, ES

SUSE Linux Enterprise Server 11

SUSE Linux Enterprise Server 10, SP1, SP2

SUSE Linux Enterprise Desktop 11

SUSE Linux Enterprise Desktop 10, SP1, SP2

Listed versions are also supported with no service pack.

openSUSE 11

openSUSE 11.1
openSUSE 11.2
openSUSE 10.3
openSUSE 10.2

Ubuntu Linux 9.04
Ubuntu Linux 8.10
Ubuntu Linux 8.04
Ubuntu Linux 8.04.1, 8.04.2, 8.04.3
Ubuntu Linux 6.06

64-bit Asianux Server 3

CentOS 5.2
CentOS 5.1
CentOS 5.0

Mandriva 2009
Mandriva 2008, 2008-1

Note: On 64-bit Mandriva hosts, some 32-bit compatibility libraries are required.
Specifically, 32-bit glibc, X11, and 1ibXtst. so are required.

Oracle Enterprise Linux 5.2
Oracle Enterprise Linux 5.1
Oracle Enterprise Linux 5.0

Red Hat Enterprise Linux 5.3 WS, AS, ES
Red Hat Enterprise Linux 5.2 WS, AS, ES
Red Hat Enterprise Linux 5.1 WS, AS, ES
Red Hat Enterprise Linux 5.0 WS, AS, ES

Red Hat Enterprise Linux 4.8 WS, AS, ES
Red Hat Enterprise Linux 4.7 WS, AS, ES
Red Hat Enterprise Linux 4.6 WS, AS, ES
Red Hat Enterprise Linux 4.5 (formerly 4.0 Update 5) WS, AS, ES

SUSE Linux Enterprise Server 11

SUSE Linux Enterprise Server 10, SP1, SP2

SUSE Linux Enterprise Desktop 11

SUSE Linux Enterprise Desktop 10, SP1, SP2

Listed versions are also supported with no service pack.
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Table 3-2. Linux Host Operating Systems (Continued)

Operating System Type Operating System Edition

SUSE Linux Enterprise Server 10, SP1

SUSE Linux Enterprise Server 9, SP1, SP2, SP3, SP4
SUSE Linux Enterprise Desktop 10, SP1, SP2

Listed versions are also supported with no service pack.

openSUSE 11

openSUSE 11.1
openSUSE 11.2
openSUSE 10.3
openSUSE 10.2

Ubuntu Linux 9.04
Ubuntu Linux 8.10
Ubuntu Linux 8.04
Ubuntu Linux 8.04.1, 8.04.2, 8.04.3
Ubuntu Linux 6.06

Note On 64-bit Ubuntu 6.x hosts, some 32-bit compatibility libraries are required.
Specifically, 32-bit glibc and X11 are required.

Supported Guest Operating Systems
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VMware continually adds support for new guest operating systems and new versions and updates of currently
supported operating systems.

For guest operating system support, known issues, and installation instructions, see the online VMware
Compatibility Guide. Go to the VMware Web site and select Resources > Compatibility Guides, and click the
View the Guest/Host OS tab on the VMware Compatibility Guide Web site link. To access the VMware Guest
Operating System Installation Guide, click the Guest Operating System Installation Guide in the right-hand
pane. VMware Player is not listed in the guide, but the information for VMware Workstation 7.0 is applicable
to VMware Player 3.0. Operating systems that are not listed are not supported for use in a virtual machine. The
Table 3-3 lists the supported guest operating systems.

Table 3-3. Guest Operating Systems

Operating System Type Operating System Edition

Windows 32-bit Windows 7 Ultimate Edition
Windows 7 Enterprise Edition
Windows 7 Professional
Windows 7 Home Premium
Windows 7 Home Basic

Windows Vista Home Basic and Premium
Windows Vista Business

Windows Vista Enterprise

Windows Vista Ultimate

Windows Server 2008 Standard Edition without Hyper-V
Windows Server 2008 Datacenter Edition without Hyper-V
Windows Server 2008 Enterprise Edition without Hyper-V
(Aero and 3-D effects not yet supported)

Windows Server 2003 Standard Edition
Windows Server 2003 Small Business Edition
Windows Server 2003 Web Edition

Windows Server 2003 Enterprise

VMware, Inc.
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Table 3-3. Guest Operating Systems (Continued)

Operating System Type

Operating System Edition

Windows XP Professional
Windows XP Home Edition

Windows PE
Windows RE

Windows 2000 Professional
Windows 2000 Server
Windows 2000 Advanced Server

Windows NT 4.0 Workstation with SP6
Windows NT 4.0 Server with SP6
Windows NT 4.0 Terminal Server Edition with SP6

Windows Me

Windows 95

Windows 3.1 (with Window for Workgroups)

Windows 64-bit

Windows 7 Ultimate Edition
Windows 7 Enterprise Edition
Windows 7 Business
Windows 7 Home Premium
Windows 7 Home Basic

Windows Vista Home Basic and Premium
Windows Vista Business

Windows Vista Enterprise

Windows Vista Ultimate

Windows Server 2008 x64 Standard Ed. without Hyper-V
Windows Server 2008 Datacenter x64 Ed. without Hyper-V
Windows Server 2008 Enterprise x64 Ed. without Hyper-V
(Aero and 3-D effects not yet supported)

Windows Server 2003 Standard Edition
Windows Server 2003 Small Business Edition
Windows Server 2003 Web Edition
Windows Server 2003 Enterprise

Windows Server 2003

Windows XP Professional

Windows PE

Windows RE

Linux 32-bit

Asianux Server

CentOS

Mandrake Linux

Mandriva Linux

Mandriva Corporate Desktop
Mandriva Corporate Server

Novell Linux Desktop

Oracle Enterprise Linux

VMware, Inc.
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Table 3-3. Guest Operating Systems (Continued)

Operating System Type

Operating System Edition

Red Hat Linux

Red Hat Enterprise Linux Server

Red Hat Enterprise Linux Advanced Server (AS)

Red Hat Enterprise Linux Enterprise Server (ES)

Red Hat Enterprise Linux Workstation

Red Hat Enterprise Linux Desktop with or without the Workstation Option
Red Hat Enterprise Linux Advanced Platform

SUSE Linux

openSUSE Linux

SUSE Linux Enterprise Server
SUSE Linux Enterprise Desktop

Turbolinux Server
Turbolinux Enterprise Server
Turbolinux Workstation
Turbolinux Desktop

Ubuntu Linux

Linux 64-bit

Asianux Server

CentOS

Mandriva Linux
Mandriva Corporate Desktop
Mandriva Corporate Server

Oracle Enterprise Linux

Red Hat Enterprise Linux Server

Red Hat Enterprise Linux Advanced Server (AS)

Red Hat Enterprise Linux Enterprise Server (ES)

Red Hat Enterprise Linux Workstation

Red Hat Enterprise Linux Desktop with or without the Workstation Option
Red Hat Enterprise Linux Advanced Platform

SUSE Linux

openSUSE Linux

SUSE Linux Enterprise Server
SUSE Linux Enterprise Desktop

Turbolinux Server

Ubuntu Linux

Novell NetWare 32-Bit

NetWare

Novell Open Enterprise Server 32-bit

Open Enterprise Server 32-bit

FreeBSD 32-bit

FreeBSD 32-bit

Norte If you use SCSI virtual disks larger than 2GB with FreeBSD 4.0-4.3,
the guest operating system does not boot. For information about SCSI disks
on FreeBSD 4.0- 4.3, see the VMware Guest Operating System Installation Guide
on the VMware Compeatibility Guide Web site. Go to the VMware Web site
and select Resources > > Compatibility Guides, and click the View the
Guest/Host OS tab on the VMware Compatibility Guide Web site link.

FreeBSD 64-bit

FreeBSD 64-bit

Sun 32-bit

Solaris x86 32-bit

Sun Java Desktop System (JDS)
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Table 3-3. Guest Operating Systems (Continued)

Operating System Type Operating System Edition
Sun 64-bit Solaris x86 64-bit
Microsoft MS-DOS MS-DOS

Processor Support for 64-Bit Guest Operating Systems

When you power on a virtual machine with a 64-bit guest operating system, VMware Player performs an
internal check. If the host CPU is not a supported 64-bit processor, you cannot power on the virtual machine.

VMware Player supports virtual machines with 64-bit guest operating systems, running on host machines with
the following processors:

B Revision D or later of AMD Athlon 64, Opteron, Turion 64, and Sempron
B Intel Pentium 4 and Core 2 processors with EM64T and Intel Virtualization Technology

VMware also provides a standalone utility that you can use without VMware Player to perform the same check
and determine whether your CPU is supported for VMware Player virtual machines with 64-bit guest operating
systems. Download the 64-bit processor check utility from the downloads area of the VMware Web site.
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Installing and Running VMware Player

The installation instructions for VMware Player require a product CD to install on Windows and Linux hosts.
If you do not have a product CD, download VMware Player from the VMware Web site.

If you are installing VMware Player from a CD and autorun is enabled, follow the prompts when you insert
the CD in your CD-ROM drive.

If you are installing VMware Player from a CD and autorun is not enabled, double-click the VMware-Player-
<xxxxx>.exe installer file in the Windows directory of the CD. In the filename, <xxxxx> is a series of numbers
representing the version and build numbers.

B [Install VMware Player on a Windows Host on page 21

To begin creating and configuring virtual machines you must install VMware Player on your Windows
host.

B Install VMware Player on a Linux Host on page 22

To begin creating and configuring virtual machines you must install VMware Player on your Linux host.

B Start VMware Player on page 23

To start VMware Player you must open the .vmx virtual machine configuration file.

B Close VMware Player on page 23

Close VMware Player before you shut down the host computer.

Install VMware Player on a Windows Host

To begin creating and configuring virtual machines you must install VMware Player on your Windows host.

If you downloaded the software, follow the installation procedure, but install from the directory where you
saved the installer file, rather than the Windows directory on the CD.

Prerequisites

Make sure that your host and guest operating systems are supported. See Chapter 3, “Supported Host and
Guest Operating Systems for VMware Player,” on page 13.

Procedure

1 On the Welcome page, click Next.

2 On the Destination Folder page, select the location for VMware Player files.
B [f you want VMware Player to be installed in the default location, click Next.
B To choose an alternative location for VMware Player files, and click Change.

3 (Optional) Deselect any shortcuts on the Shortcuts page, and click Next.

VMware, Inc. 21
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4  Click Continue to begin the installation.
VMware Player and any shortcuts you selected are installed on your host machine.

5  Click Finish.

Install VMware Player on a Linux Host

22

To begin creating and configuring virtual machines you must install VMware Player on your Linux host.

If you downloaded the software, follow the installation procedure, but install from the directory where you
saved the installer file, rather than the Linux directory on the CD.

Norte If you do not enable host-only networking when you install VMware Player, you cannot allow a virtual
machine to use bridged and host-only networking.

Prerequisites

Make sure that your host and guest operating systems are supported. See Chapter 3, “Supported Host and
Guest Operating Systems for VMware Player,” on page 13.

Procedure
1 Log on to your Linux host with the user name you plan to use when you run VMware Player.
2 In the terminal window, become root user to perform the initial installation steps.
su or sudo
The command you use depends on your Linux distribution and configuration.
3 If you are installing from a downloaded file, mount the VMware Player CD-ROM.
B VMware-Player-e.x.p-<xxxxxxxx>.1386.bundle

B VMware-Player-e.Xx.p-<xxxxxxxx>.x86_64.bundle

VMware-Player-<version>—<xxxxx>.<architecture>.bundle is the installation file. In the filename, <xxxx-
xxxx> is a series of numbers representing the version and build numbers.

4 Run the bundle specifying the installation file:
sh VMware-Player-e.x.p—<xxxxxxxx>.<architecture>.bundle
5  Accept the EULA to continue.

6  (Optional) If the GUI based VMware Player installer fails, run the installation file with the --console
command in your terminal.

Command-Line Installation Options

You can use command-line installation options to install VMware Player on a Linux host.

Command-Line Installation Options Reference

To use the options you must be logged in as root. After you finish the installation process, exit from the root
account.

Table 4-1. List of Command-Line Installation Options

Command-Line Installation Option Option Description

—gtk Opens the GUI based VMware installer. This is the default
option.

—-console Allows you to use the terminal for installation.
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Table 4-1. List of Command-Line Installation Options (Continued)

Command-Line Installation Option Option Description

——custom Shows all the installation questions. You can customize the
installation directories, set or reset the Eclipse directories and
hard limit for the number of open file descriptors.

——regular Shows installation questions that have not been answered
before or are required. This is the default option.

—-required Shows only the EULA, then proceeds to install Workstation.

—-ignore-errors or -1 Allows the installation to continue even if there is an error in
one of the installer scripts. However, the section that has an
error does not complete, so the component may not be
properly configured.

Start VMware Player

To start VMware Player you must open the .vmx virtual machine configuration file.

Procedure

1  Select Start > Programs > VMware Player in Windows or use the corresponding program menu in a Linux
X windows session.

B On Windows, type vmplayer from the Start > Run command menu. You can also type
<path>\vmplayer.exe in the command interpreter, where <path> is the appropriate path on your
system to the VMware Player executable file.

B From the Linux command line, type <path>/vmplayer, where <path> is the appropriate path on your
system to the VMware Player executable file. To run VMware Player process in the background, type
<path>/vmplayer &.

2 On the VMware Player welcome page, select Open a VM.
3 Browse for the configuration file of the virtual machine to run.

You can also select a recently used virtual machine or download a virtual appliance from the Virtual
Appliance Marketplace.

You can use the Files of type field to filter the files that are displayed when you browse.

VMware Player can open .vmx VMware configuration files, OVF, and OVA files. On Windows, VMware
Player can open .vmc Microsoft Virtual PC and Virtual Server files and .sv2i Symantec Backup Exec
System Recovery system images.

4  Select a .vmx virtual machine configuration file, and click Open.

Close VMware Player

Close VMware Player before you shut down the host computer.

On Linux, depending on the exit behavior preference settings, the virtual machine either suspends or shuts
down and the VMware Player window closes.

For ACE instances, the options in the drop-down menu depend on which features the system administrator
makes available.
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Procedure

B On Windows, select File > Exit.

B On Linux, select an option based on the exit behavior settings.
B Select File > Power Off and Quit.

B Select File > Suspend and Quit.

24
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Uninstalling VMware Player

The following sections describe how to uninstall VMware Player on Windows and Linux hosts.

Uninstall VMware Player on a Windows Host on page 25

Toinstall the latest version of VMware Player on a Windows host you must uninstall the previous version
of the product.

Uninstall VMware Player on a Windows Vista or Windows 7 Host on page 25

To install the latest version of VMware Player on a on a Widows Vista or Windows 7 host you must
uninstall the previous version of the product.

Uninstall VMware Player on a Linux Host on page 26

To install the latest version of VMware Player on a Linux host you must uninstall the previous version
of the product.

Uninstall VMware Player on a Windows Host

To install the latest version of VMware Player on a Windows host you must uninstall the previous version of
the product.

Procedure

1  Select Start > Control Panel > Add or Remove Programs.

2 Locate VMware Player in the list of currently installed programs and click Remove.
3 Follow the prompts to complete the uninstall.

Uninstall VMware Player on a Windows Vista or Windows 7 Host

To install the latest version of VMware Player on a on a Widows Vista or Windows 7 host you must uninstall

the previous version of the product.

Procedure

1

VMware, Inc.

Based on your host operating system, use one of the following methods to uninstall VMware Player:
B On Windows Vista, select Start > Control Panel > Programs and Features > Uninstall a program.

B On Windows 7, select Start > Control Panel > Programs > Programs and Features > Uninstall a
program.

Right-click and select Uninstall.
A confirmation dialog box appears.

Select Yes.
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Uninstall VMware Player on a Linux Host

To install the latest version of VMware Player on a Linux host you must uninstall the previous version of the
product.

Procedure

1  Enter the vmware-installer -u vmware-player command to remove VMware Player from your system.

2 Select Yes or No to confirm whether you want to preserve or remove your configuration files.
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