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General Information
Introduction
This first chapter contains general information that will be useful to know 
before using MPLAB-ICD.

Highlights
The information you will garner from this chapter:

• About this Guide

• Recommended Reading

• Warranty Registration

• Troubleshooting

• The Microchip Internet Web Site

• Development Systems Customer Notification Service

• Customer Support

About This Guide

Document Layout
This document describes how to use MPLAB-ICD as a development tool to 
debug firmware on a target board. The manual layout is as follows:

• Chapter 1: MPLAB-ICD Preview – What MPLAB-ICD is and how it 
works.

• Chapter 2: MPLAB-ICD Installation – How to install MPLAB-ICD hard-
ware and software and establish communications.

• Chapter 3: Getting Started with MPLAB-ICD – How to get 
MPLAB-ICD up and running.

• Chapter 4: MPLAB-ICD Basic Functions – The basic functions of 
MPLAB-ICD.

• Chapter 5: Demo Board Example of Use – The menu options of 
MPLAB-ICD.

• Chapter 6: MPLAB-ICD Menu Options – The menu options of 
MPLAB-ICD.

• Chapter 7: Troubleshooting – How to solve common problems.

• Appendix A: MPLAB-ICD Hardware – A description of the header, 
module and demo board hardware.
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• Glossary – A glossary of terms used in this guide.

• Index – Cross-reference listing of terms, features, and sections of this 
document.

• Worldwide Sales and Service – A listing of Microchip sales and 
service locations and telephone numbers worldwide.

Conventions Used in this Guide
This manual uses the following documentation conventions: 

Updates
All documentation becomes dated, and this user’s guide is no exception. 
Since MPLAB, MPLAB-ICD, and other Microchip tools are constantly evolving 
to meet customer needs, some MPLAB dialogs and/or tool descriptions may 
differ from those in this document. Please refer to our web site to obtain the 
latest documentation available.

Warranty Registration
Please complete the enclosed Warranty Registration Card and mail it 
promptly. Sending in your Warranty Registration Card entitles you to receive 
new product updates. Interim software releases are available at the Microchip 
web site.

Documentation Conventions

Description Represents Examples

Angle Brackets: < > Delimiters for special keys. <TAB>, <ESC>

Italic characters Referenced books. MPLAB User’s 
Guide

Courier Font User entered code or sample 
code.

#define ENIGMA

Underlined, Italics Text 
with Right Arrow

Defines a menu selection from 
the menu bar.

File > Save

0xnnn 0xnnn represents a hexadeci-
mal number where n is a hexa-
decimal digit.

0xFFFF, 0x007A

In-text Bold Characters Designates a button. OK, Cancel
DS51184A-page 2  1999 Microchip Technology Inc.



General Information
Recommended Reading
This user’s guide describes how to use MPLAB-ICD. The user may also find 
the data sheets for specific microcontroller devices informative in developing 
firmware.

README.ICD

For the latest information on using MPLAB-ICD, read the README.ICD file 
(ASCII text file) included with the MPLAB-ICD software. The README.ICD 
file contains update information that may not be included in this document.

README.XXX

For the latest information on other Microchip tools (MPLAB, MPASM, etc.), 
read the associated README files (ASCII text file) included with the MPLAB 
software.

MPLAB User’s Guide (DS51025)

Comprehensive guide that describes installation and features of Microchip’s 
MPLAB Integrated Development Environment, as well as the editor and 
simulator functions in the MPLAB environment.

MPASM User’s Guide with MPLINK and MPLIB (DS33014)

This user’s guide describes how to use the Microchip PICmicro assembler 
(MPASM), the linker (MPLINK) and the librarian (MPLIB).

Technical Library CD-ROM (DS00161)

This CD-ROM contains comprehensive data sheets for Microchip PICmicro® 
devices available at the time of print. To obtain this disk, contact the nearest 
Microchip Sales and Service location (see back page) or download individual 
data sheet files from the Microchip website (http://www.microchip.com).

Embedded Control Handbook Vol.1 & 2 (DS00092 & DS00167)

These handbooks contain a wealth of information about microcontroller 
applications. To obtain these documents, contact the nearest Microchip Sales 
and Service location (see back page).

The application notes described in these manuals are also obtainable from 
Microchip Sales and Service locations or from the Microchip web site 
(http://www.microchip.com).

Microsoft Windows Manuals

This manual assumes that users are familiar with Microsoft Windows 
operating system. Many excellent references exist for this software program, 
and should be consulted for general operation of Windows.

Troubleshooting
See Chapter 7 for information on common problems.
 1999 Microchip Technology Inc. DS51184A-page 3
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The Microchip Internet Web Site
Microchip provides on-line support on the Microchip World Wide Web (WWW)
site.

The web site is used by Microchip as a means to make files and information
easily available to customers. To view the site, the user must have access to
the Internet and a web browser, such as Netscape® Navigator or Microsoft®

Internet Explorer®. Files are also available for FTP download from our FTP
site.

Connecting to the Microchip Internet Web Site

The Microchip website is available by using your favorite Internet browser to
attach to: 

http://www.microchip.com

The file transfer site is available by using an FTP program/client to connect to: 

ftp://ftp.microchip.com

The website and file transfer site provide a variety of services. Users may
download files for the latest Development Tools, Data Sheets, Application
Notes, User’s Guides, Articles, and Sample Programs. A variety of Microchip
specific business information is also available, including listings of Microchip
sales offices, distributors, and factory representatives. Other data available for
consideration is:

• Latest Microchip Press Releases
• Technical Support Section with Frequently Asked Questions 
• Design Tips
• Device Errata
• Job Postings
• Microchip Consultant Program Member Listing
• Links to other useful web sites related to Microchip Products
• Conferences for products, Development Systems, technical information 

and more
• Listing of seminars and events
DS51184A-page 4  1999 Microchip Technology Inc.



General Information
Development Systems Customer Notification Service
Microchip started the customer notification service to help our customers 
keep current on Microchip products with the least amount of effort. Once you 
subscribe to one of our list servers, you will receive email notification 
whenever we change, update, revise or have errata related to that product 
family or development tool. See the Microchip WWW page for other Microchip 
list servers.

The Development Systems list names are:

• Compilers

• Emulators

• Programmers

• MPLAB

• Otools 

Once you have determined the names of the lists that you are interested in, 
you can subscribe by sending a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe <listname> yourname

Here is an example: 

subscribe mplab John Doe 

To UNSUBSCRIBE from these lists, send a message to:

listserv@mail.microchip.com 

with the following as the body:

unsubscribe <listname> yourname

Here is an example: 

unsubscribe mplab John Doe

The following sections provide descriptions of the available Development 
Systems lists.

Compilers
The latest information on Microchip C compilers, Linkers, and Assemblers. 
These include MPLAB-C17, MPLAB-C18, MPLINK, MPASM as well as the 
Librarian, MPLIB for MPLINK.

To SUBSCRIBE to this list, send a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe compilers yourname
 1999 Microchip Technology Inc. DS51184A-page 5
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Emulators
The latest information on Microchip In-Circuit Emulators. These include 
MPLAB-ICE and PICMASTER.

To SUBSCRIBE to this list, send a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe emulators yourname

Programmers
The latest information on Microchip PICmicro device programmers. These 
include PRO MATE II and PICSTART Plus.

To SUBSCRIBE to this list, send a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe programmers yourname

MPLAB
The latest information on Microchip MPLAB, the Windows Integrated 
Development Environment for development systems tools. This list is focused 
on MPLAB, MPLAB-SIM, MPLAB’s Project Manager and general editing and 
debugging features. For specific information on MPLAB compilers, linkers, 
and assemblers, subscribe to the COMPILERS list. For specific information 
on MPLAB emulators, subscribe to the EMULATORS list. For specific 
information on MPLAB device programmers, please subscribe to the 
PROGRAMMERS list.

To SUBSCRIBE to this list, send a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe mplab yourname

Otools
The latest information on other development system tools provided by 
Microchip. For specific information on MPLAB and its integrated tools refer to 
the other mail lists.

To SUBSCRIBE to this list, send a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe otools yourname
DS51184A-page 6  1999 Microchip Technology Inc.



General Information
Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Corporate Applications Engineer (CAE)

• Hot line

Customers should call their distributor, representative, or field application 
engineer (FAE) for support. Local sales offices are also available to help 
customers. See the back cover for a listing of sales offices and locations.

Corporate applications engineers (CAEs) may be contacted at 
(480) 786-7627.

In addition, there is a Systems Information and Upgrade Line. This line 
provides system users a listing of the latest versions of all of Microchip's 
development systems software products. Plus, this line provides information 
on how customers can receive any currently available upgrade kits.

The Hot Line Numbers are: 

1-800-755-2345 for U.S. and most of Canada, and 

1-480-786-7302 for the rest of the world.
 1999 Microchip Technology Inc. DS51184A-page 7
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Chapter 1.  MPLAB-ICD Preview
1.1  Introduction
This section gives you a preview of MPLAB-ICD (In-Circuit Debugger) 
features and functions, as well as its hardware and software elements.

1.2  Highlights
Topics covered in this chapter:

• What is MPLAB-ICD

• How MPLAB-ICD Helps You

• Trade-Offs of Using MPLAB-ICD

• MPLAB-ICD Components

• MPLAB Integrated Development Environment (IDE)

• MPLAB Development Tools

• Host Computer System Requirements

1.3  What is MPLAB-ICD
MPLAB-ICD is a low cost evaluation kit for the PIC16F87X series 
microcontrollers. Utilizing the In-Circuit Debugging capability of the 
PIC16F87X and Microchip’s In-Circuit Serial Programming™ (ICSP™) 
protocol, the MPLAB-ICD is a programmer as well as an in-circuit debugger. It 
operates under the MPLAB IDE, connects to an application, and runs like the 
actual PIC16F87X microcontroller in the design.

MPLAB-ICD is intended to be used as an evaluation and debugging aid in a 
laboratory environment.

The MPLAB-ICD offers these features:

• Real-time code execution

• In-circuit debugging

• Built-in programmer

• 3.0V to 5.5V operating range

• Operation from voltage (VDD) supplied by the target application

• Operating frequencies from 32 kHz to 20 MHz

• Source level and symbolic debugging

• MPLAB user interface

• Microsoft Windows® 3.X/95/98 compatible

• RS-232 Interface
 1999 Microchip Technology Inc. DS51184A-page 9
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1.4  How MPLAB-ICD Helps You
The MPLAB-ICD allows you to:

• Debug your source code in your own application

• Debug your hardware in real-time

• Program a target PIC16F87X using Microchip’s ICSP protocol

1.5  Trade-offs of Using MPLAB-ICD
Due to the built-in in-circuit debugging capability of the PIC16F87X and ICSP 
function offered by the Debugger, the MPLAB-ICD will use the following on-
chip resources:

• MCLR/VPP shared for programming

• RB3 reserved for low-voltage programming 

• RB6 and RB7 reserved for programming and in-circuit debugging

• Six (6) general purpose file registers reserved for debug monitor:
70h, 1EBh to 1EFh

• First program memory location (address 0x000) must be a NOP instruc-
tion

• Program memory 0x1F00-0x1FFF reserved for Debug Code

• One stack level not available

Note: MPLAB-ICD does not support low-voltage programming. Disable
this function while using the ICD.
DS51184A-page 10  1999 Microchip Technology Inc.
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1.6  MPLAB-ICD Components
The MPLAB-ICD consists of four basic components:

1. MPLAB-ICD Module
2. MPLAB-ICD Header
3. MPLAB-ICD Demo Board
4. MPLAB software

Figure 1.1:  MPLAB-ICD Components

1.6.1 MPLAB-ICD Module
The MPLAB-ICD Module contains all debugging, programming, and control 
logic. It is connected to the PC’s serial port via a 9-pin serial cable and to the 
MPLAB-ICD Header or target using a 6-wire modular cable. This module 
contains the firmware to provide serial communications to the PC, to drive the 
MPLAB-ICD communications to the Header/target board, and to program a 
target PIC16F87X using ICSP, all from the MPLAB IDE. The module is 
powered from the target application and requires 70 mA (max) in addition to 
what the target consumes.

1.6.2 MPLAB-ICD Header
The MPLAB-ICD Module connects to the MPLAB-ICD Header via a 9-inch 
modular cable. For in-circuit emulation, a PIC16F877 needs to be plugged 
into the header which then plugs into a 28-pin or 40-pin PIC16F87X DIP 
socket on an application or the MPLAB-ICD Demo Board. The MPLAB-ICD 
Header is powered by the target application, from a 3.0V to 5.5V source.

The modular cable also can be plugged into a modular connector on the 
application circuit with the appropriate connections to the PIC16F87X to allow 
in-circuit emulation of QFP and DIE parts.

MPLAB™-IDE

MPLAB-ICD Module MPLAB-ICD Demo Board 
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1.6.3 MPLAB-ICD Demo Board
The Demo Board is provided for demonstration/evaluation of the PIC16F87X 
in the absence of a target application board. It is connected to the 
MPLAB-ICD Module via the MPLAB-ICD Header. The PIC16F877 can be 
unplugged from the Header and plugged directly into the demo board for 
stand-alone operation.

The Demo Board (Figure 1.2) has the following hardware features:

1. 40- and 28-pin sockets. See Appendix A for how to use stand-offs to
select the desired pin count socket.

2. Eight DIP switches to connect/disconnect each of the eight LEDs to/from
their respective PORTC pin.

3. Eight red LEDs connected to PORTC for displaying 8-bit binary values.
4. Two push-button switches, one for RESET and one for external stimulus

on RB0.
5. A potentiometer for analog input on RA0.
6. A small prototyping area.
7. A connector area to access the I/O pins of the PIC16F87X for expansion

prototyping.
8. A jumper to select the RC oscillator (approximately 2 MHz) or an external

crystal.
9. Socket for external crystal.
10. A connector for a 9V, 0.75A power supply, similar to the PICSTART® Plus

programmer power supply.
11. Provisions for a MAX232 and associated hardware that may be popu-

lated to add RS-232 capability.

Figure 1.2:  MPLAB-ICD Demo Board
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1.6.4 MPLAB Software
The MPLAB software runs in the Windows 3.1/95/98 environment. It provides 
full display, modification, and control of the target application under emulation.

1.7  MPLAB Integrated Development Environment 
The MPLAB desktop provides an environment for developing and debugging 
your application. MPLAB-ICD is integrated into the MPLAB IDE.

This document covers the basic setup and operation of the MPLAB-ICD, but it 
does not cover all functions of the MPLAB IDE. Read the MPLAB User’s 
Guide (DS51025) to get a full understanding of the features and debug 
capabilities of the MPLAB IDE.
 1999 Microchip Technology Inc. DS51184A-page 13
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1.8  MPLAB Development Tools
The MPLAB IDE integrates several tools to provide a complete development 
environment.

• MPLAB Project Manager

Use the Project Manager to create a project and work with the specific
files related to the project. When using a project, source code is rebuilt
and downloaded to the simulator or emulator with a single mouse click.

• MPLAB Editor

Use the MPLAB Editor to create and edit text files such as source files,
code, and linker script files.

• MPLAB-SIM Simulator

The software simulator models the instruction execution and I/O of the
PICmicro Microcontrollers (MCUs).

• MPLAB-ICE Emulator

The MPLAB-ICE emulator uses hardware to emulate PICmicros in real
time, either with or without a target system.

• MPASM Universal Assembler/MPLINK Relocatable Linker/
MPLIB Librarian

The MPASM assembler allows source code to be assembled without
leaving MPLAB. MPLINK creates the final application by linking relocat-
able modules from MPASM and MPLAB-C17 (PIC17CXXX C compiler).
MPLIB manages custom libraries for maximum code reuse.

• PRO MATE® II and PICSTART® Plus Programmers

Develop code with the simulator or an emulator, assemble or compile it,
and then use one of these tools to program devices. This can all be
accomplished with MPLAB. Although PRO MATE II does not require
MPLAB to operate, programming is easier using MPLAB.

• PICMASTER® and PICMASTER-CE Emulators

These emulators use hardware to emulate PICmicros in real time, either
with or without a target system. MPLAB-ICE is the newest emulator from
Microchip.

• Third Party Tools

Many other companies have development tools for Microchip products
that work with MPLAB. Consult the Microchip Third Party Guide
(DS00104).
DS51184A-page 14  1999 Microchip Technology Inc.
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Chapter 2.  MPLAB-ICD Installation
2.1  Introduction
How to install the MPLAB-ICD hardware and software and how to 
communicate between the MPLAB-ICD Demo Board and PC is discussed in 
this chapter.

2.2  Highlights
Topics covered in this chapter:

• MPLAB-ICD Kit Components

• Host Computer System Requirements

• Installing the Hardware

• Installing the Software

2.3  MPLAB-ICD Kit Components
The MPLAB-ICD system kit includes the following items (Figure 2.1),

1. The MPLAB-ICD Header (plugged inside the 40-pin DIP socket on the
MPLAB-ICD Demo Board)

2. The MPLAB-ICD Module
3. The MPLAB-ICD Demo Board
4. RS-232 Cable
5. 40-pin DIP and 28-pin SDIP connection sockets (the 40-pin socket has

been used for connecting the MPLAB-ICD Header to the 40-pin socket
on the MPLAB-ICD Demo Board)

6. 9-inch 6-conductor modular cable
7. Disks/CD with complete system software and documentation
8. Manuals:

- MPLAB-ICD User’s Guide (this document)
- MPLAB User’s Guide (not shown)
- MPASM with MPLINK and MPLIB User’s Guide (not shown)

9. A Warranty Registration card (not shown)
 1999 Microchip Technology Inc. DS51184A-page 15
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Figure 2.1:  MPLAB-ICD Kit Components

2.4  Host Computer System Requirements
To take advantage of the debugger system features, you must install the 
MPLAB software on a host computer having the following minimum 
configuration:

• PC compatible machine: 486 or higher

• VGA required, super VGA recommended

• MS-DOS/PC-DOS version 5.0 or greater

• Microsoft Windows 3.X/95/98

• 4 MB RAM, 16 MB recommended

• 8 MB available hard disk space, 20MB recommended

• One free serial port

• Mouse or other pointing device

• 9V, 0.75A Power Supply (PICSTART Plus or Equivalent)
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2.5  Installing the Hardware
Install the MPLAB-ICD system hardware by following these steps:

1. Plug a PIC16F87X into the 40-pin DIP socket in the MPLAB-ICD Header. 
2. Connect the 9-inch modular cable between the MPLAB-ICD Module and

the MPLAB-ICD Header.
3. Plug the 40-pin connection socket into the 40-pin DIP socket in the

MPLAB-ICD Demo Board or target application. If using the Demo Board,
make sure to insert the 40-pin stand-off first (See Section A.3.1).

4. Plug the MPLAB-ICD Header into the connection socket in the Demo
Board or target application (Figure 2.2). You can also connect the
MPLAB-ICD Header to a 28-pin SDIP socket in the Demo Board/target
via the 28-pin SDIP connection socket.

5. Connect the RS-232 cable between the serial port of the host computer
and the MPLAB-ICD Module.

6. Turn on the power to the host computer.
7. Turn on the power to the MPLAB-ICD Demo Board/target application

which also powers the MPLAB-ICD Module. (For the Demo Board, you
can use the 9 VDC center-positive power adapter supplied with 
PICSTART Plus Programmer.)

Figure 2.2:  MPLAB-ICD Hardware Connection

To RS232

Power in

Target Application or Demo Board

MPLAB-ICD Module

MPLAB-ICD Demo Board 

Target socket

MPLAB-ICD Header
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2.6  Installing the Software
The MPLAB-ICD is an add-on tool for the MPLAB Software. To install MPLAB, 
follow these steps:

1. Enter Microsoft Windows and insert the MPLAB CD-ROM into the
CD-ROM drive.

2. Execute the setup program:

a) Windows 3.1: From the File Manager, or from the
Program Manager>Run option, run X:\MPvvvvv.exe, where X is the
drive designation of the CD-ROM drive, and vvvvv is the version
number of MPLAB.

b) Windows 95/98: Click the Start button and select Run. Enter 
X:\MPvvvvv.exe, where X is the drive designation of the CD-ROM
drive, and vvvvv is the version number of MPLAB. Then click OK.

3. Follow the instructions to install the MPLAB IDE with MPLAB-ICD
support.
DS51184A-page 18  1999 Microchip Technology Inc.
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Chapter 3.  Getting Started with MPLAB-ICD
3.1  Introduction
This chapter describes how to get the hardware and software for MPLAB-ICD 
up and working.

3.2  Highlights
Topics covered in this chapter:

• Communicating with MPLAB-ICD

• MPLAB-ICD Operations

• Getting the Most from MPLAB – Using Projects

3.3  Communicating with MPLAB-ICD
Follow the steps listed below to set up MPLAB for use with the MPLAB-ICD 
hardware. Once proper operation is established, no further changes are 
needed, unless reconfiguration is desired. To reconfigure, follow steps 6 
through 9.

1. Make sure the MPLAB-ICD is connected to the host PC via the RS-232
cable.

2. Make sure there is power provided to the target application from which
the MPLAB-ICD Module will be drawing power.

3. From the Microchip MPLAB program group, run MPLAB.
4. If MPLAB was previously in ICD mode, MPLAB will either find the

MPLAB-ICD Module and start, or it will display a message that it cannot
find the MPLAB-ICD.

5. If MPLAB cannot find the MPLAB-ICD, select the Editor Only option from
the dialog and MPLAB will start without attempting to connect to the
MPLAB-ICD.

6. Select the Options > Development Mode menu item to open the Devel-
opment Mode dialog (Figure 3.1). 
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Figure 3.1:  Development Mode Dialog Box

7. Select MPLAB-ICD.
8. Select the desired processor, COM port, and baud rate for communica-

tion with MPLAB-ICD.
9. Click the Reset button.

If no problems occur, the Development Mode dialog will close and the 
MPLAB-ICD dialog will open. See Chapter 4 for more information on the 
MPLAB-ICD dialog.

If MPLAB still cannot find MPLAB-ICD, see Chapter 7.

3.4  MPLAB-ICD Operations
The MPLAB-ICD is a programmer as well as an in-circuit debugger. It 
programs hex files into the PIC16F87X and offers basic debugging features 
like real-time code execution, stepping, and breakpoint. Its debug feature is 
built inside the PIC16F87X and activated by programming the Debug Code 
into the target processor. It has limited functions when compared to a full-
featured in-circuit emulator but provides cost-effective functions to debug and 
program applications for a PIC16F87X.

To enable in-circuit debugging, the Debug Code residing in the microcontroller 
in the MPLAB-ICD Module is programmed into the target PIC16F87X. The 
code is an MPASM module that will be programmed into the PIC16F87X on 
the MPLAB-ICD Header automatically by MPLAB. This code will reside in the 
last 0x100 words of program memory. For example, it will reside in 0x1F00 to 
0x1FFF of the PIC16F877 processor. 

Note: MPLAB-ICD does not support low voltage programming.
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3.5  Getting the Most from MPLAB – Using Projects 
MPLAB is the host software for the MPLAB-ICD and the MPLAB-SIM 
simulator. It functions as a sophisticated debugging tool, providing access to 
RAM, ROM, EEPROM, and a variety of other debug functions. 

3.5.1 Creating a Project
Developing and debugging code in the MPLAB environment is based on 
projects. Although emulation can be performed without having a project open, 
projects have the following advantages:

• Single or multiple source files can be easily built and maintained.

• Symbolic debugging is available.

• The debugging environment can be saved for later use.

Some of the information that is retained with a project is:

• Development mode and processor

• Source files associated with the project

• Name of the final PICmicro executable file

• Open windows and their sizes and positions

• Named break settings

• Configuration bit settings

For more information on creating and using projects, refer to the MPLAB 
User’s Guide (DS51025).

Note: If you do not put your source files into a project, MPLAB cannot
debug properly.
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3.5.2 Saving a Project
Once you have the MPLAB-ICD system and software configured, it is 
advisable to save your current project to retain the values for later use, or use 
as a backup or default as you continue with your debugging.

Development Mode

The selected development mode is retained with the project information. To 
change the development mode for a project, follow these steps:

• Open the project. The previously used development mode will be 
selected.

• Change the development mode by selecting Options>Development 
Mode to access the Development Mode dialog.

• Save the project.
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Chapter 4.  MPLAB-ICD Basic Functions
4.1  Introduction
This chapter discusses the basic operations of MPLAB-ICD and MPLAB 
debugging functions of the In-Circuit Debugger. For more information on 
general debugging features, refer to the MPLAB User’s Guide. 

4.2  Highlights 
Topics covered in this chapter:

• The MPLAB-ICD Dialog

• Program Execution

• Breakpoints

• How to use MPLAB-ICD

4.3  The MPLAB-ICD Dialog
The MPLAB-ICD dialog (Figure 4.1) has all the programming and setup 
functions for the MPLAB-ICD. These functions include basic programmer 
functions like blank check, program, read, verify, erase and set the ICD to 
debug mode. Other functions like Run, Halt, and Step are on the Debug menu 
and MPLAB toolbar.

The MPLAB-ICD dialog is always open when the ICD is enabled. Closing this 
window will disable the ICD.

The next sections describe components found in the ICD Module dialog.
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Figure 4.1:  MPLAB-ICD Dialog

4.3.1 Configuration Bits and Device Selection
This section of the dialog allows you to set the various configuration bits on 
the PIC16F87X processors. To select, click on the arrow to see the drop-down 
list and then highlight the option desired. 

Table 4.1:  Configuration Bits and Device Selection Options

Item Options

Device See the Product Line Card (DS00148) for available 
devices. If you change the device here, any open 
MPLAB projects (except in Editor Only mode) will 
close and program memory, configuration bits, and 
ID’s will be cleared.

Oscillator RC, LP, XT or HP

Watchdog Timer On/Off

Power Up Timer On/Off

Brown Out Detect On/Off

Low Voltage Program
(Should be disabled 
when using ICD)

Select low voltage programming function or
use RB3 as digital I/O and 
use HV on MCLR for programming
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4.3.2 ID’s and Checksum
Displays the checksum for the data and the ID code. To use the checksum as 
the ID, select the checkbox.

4.3.3 Voltages
Allows you to check the value of the VDD and VPP voltages on the target 
application by clicking the Update button.

MPLAB-ICD develops its needed VPP ≈ 12V from the target board’s VDD 
through use of a charge pump.

4.3.4 Program Options
The default program address range is set to the maximum program memory 
available based on the device you selected. However, you can set the 
program address range yourself. Enter the Start and End Addresses of 
program memory for the function performed (e.g., program, read, or verify).

The program address range does not apply to the erase function. 

Click the box next to the item to select or unselect the memory areas for the 
programmer functions. For example, if you want to read program memory 
only, select Program Memory and unselect the other memory types.

To erase all memory before programming, select Erase All before Program. To 
program debug code into a device, select Enable Debug Mode.

If you are only using MPLAB-ICD to program a part, you should uncheck the 
Enable Debug Mode box. This will not download the debug code to 0x1F00 to 
0x1F00 and will not enable MPLAB-ICD for debug operations. Keep this box 
checked to enable debug mode each time you press the Program button.

Code Protect Data EE On/Off

Flash Memory Write Select whether to allow unprotected program 
memory to be written by EECON control

Code Protect 0000h to 1FFFh code protected
1000 to 1FFFF
1F00h to 1FFFh code protected
Code Protection Off

Table 4.1:  Configuration Bits and Device Selection Options (Continued)

Item Options

Note: The erase function will erase all data on the PIC16F87X including
memory, ID, and configuration bits.
 1999 Microchip Technology Inc. DS51184A-page 25



MPLAB™-ICD User’s Guide
4.3.5 Status
The Status bar displays the executed MPLAB-ICD function and the status.

4.3.6 COM Port Pull-Down Menu
Select the COM port (COM1, COM2, COM3 or COM4) for MPLAB-ICD 
communications. The value shown in the dialog is the one last chosen, 
usually from the Development Mode dialog.

4.3.7 Baud Rate Pull-Down Menu
Select the COM port baud rate for MPLAB-ICD communications. The value 
shown in the dialog is the one last chosen, usually from the Development 
Mode dialog.

4.3.8 Upload Options Pull-Down Menu
The options for the amount of data uploaded are:

• Minimum (FSR, W, Status, PCLATH) (Very Fast)

• SFRs only (Fast)

• Minimum and Watch windows (Slow)

• All Registers (Very Slow)

Options selection affects the time between single step events. The first 
selection has less than a second delay, where as the last selection will have 
about a 2 second delay.

4.3.9 Operating Frequency Range Pull-Down Menu
Select the operation frequency range of the MPLAB-ICD. Options are:

• 32 kHz – 500 kHz

• 500 kHz – 2 MHz

• 2 MHz – 10 MHz

• 10 MHz – 20 MHz
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4.3.10 Function Buttons
Click these buttons to perform the assigned function on the PIC16F87X in the 
MPLAB-ICD Header. If you have specified an address range in the Program 
Options section, the assigned function will be performed on the specified 
memory range and type only (except for the erase function).

The function buttons are:

• Blank – Checks to see if device is blank.

• Read – Reads memory areas specified under Program Options, i.e., 
program memory, configuration bits, ID locations and/or EEPROM data.

• Program – Programs memory areas specified under Program Options, 
i.e., program memory, configuration bits, ID locations and/or EEPROM 
data. Also downloads debug code at IF00 to IFFF if Enabled Debug 
Mode is checked.

• Verify – Verifies programming of memory areas specified under Pro-
gram Options, i.e., program memory, configuration bits, ID locations, 
and/or EEPROM data.

• Erase – Erases all memory areas.

• Self Test – Performs a self-test on the MPLAB ICD hardware.
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4.4  Program Execution
The MPLAB-ICD executes in real-time mode or in step mode.

• Real-time execution occurs when the PIC16F87X in the MPLAB-ICD 
Header is put in MPLAB’s Run mode.

• Step mode execution can be accessed after the processor is halted.

4.4.1 Real-Time Execution
When the MPLAB-ICD is run in real time, instructions execute just as the 
processor would without the debugger. The PIC16F87X executes in real time 
until a breakpoint halts the debugger or until the HALT function is manually 
executed.

To execute in real time, click the Run icon on the Tool Bar or issue the Debug 
> Run > Run command. The Debug Tool Bar provides Run, Halt, and Step 
buttons for controlling the debugger. While in the run mode, Register displays 
on the screen will not update.

4.4.2 Step Mode Execution
Step Mode Execution occurs when you single step the processor or execute 
Debug > Run > Step. Step mode execution provides the capability to step 
through the code one instruction at a time, to watch the program flow, and to 
see the register contents at each instruction (as set in the dialog box).

Debug > Run > Animate is a method to automatically single step the 
processor. To view the changing registers in the Special Function Register 
window or the Watch windows, use Animate. Obviously, Animate runs slower 
than the Run function.

4.5  Breakpoints
A breakpoint is a state where the processor halts after a certain condition is 
met. The MPLAB-ICD provides the followings ways to set a breakpoint:

• Break on Address Match

• Break on User Halt

4.5.1 Break on Address Match
The Debug function of the PIC16F87X allows one breakpoint to be set. This 
breakpoint can be at any program memory address location. The processor 
breaks only after the instruction is executed. For example, if a breakpoint is 
set at address 005Ah, the processor breaks after executing the instruction at 
address 005Ah.

To set a breakpoint, either select Debug>Bread Settings or select the source 
code address in the Program Memory window and click the right mouse 
button.
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4.5.2 Break on User Halt
The PIC16F87X executes until you press the Halt button or select 
Debug>Run>Halt.

4.6  How to use MPLAB-ICD
The MPLAB-ICD is a programmer as well as an in-circuit debugger. The 
typical functions that would be used to debug and test an application are 
discussed in the following sections.

4.6.1 Load the Hex File for Debug
Load the hex codes to MPLAB using File > Import > Download to Memory 
command. Your codes should be limited to 0h to 1EFFh because the last 100 
words of code memory on the PIC16F87X will be reserved for the Debug 
Code.

Once the hex file is imported, you can go to the Windows Menu and open the 
following windows:

• Program Memory

• Special File Registers

• File Registers

• EEPROM Memory

4.6.2 Program the Target Processor
In the MPLAB-ICD dialog box, check that you have chosen the correct device, 
oscillator, and configuration bit settings under Device Specifications. Next, 
make sure the Program Options are correct for your application. If you have 
Enabled Debug Mode checked, the debug code will be downloaded and the 
PIC16F87X will be enabled for debug operations. Then, click the Program 
button to program the PIC16F87X in the MPLAB-ICD Header. Programming 
will take a couple of minutes and will be a little longer if the target application 
is running at a low voltage. 

After this, you may minimize the MPLAB-ICD dialog, but do not close it. 
Closing the MPLAB-ICD dialog with disable the ICD.

Note: Data for the EEPROM memory should be placed at 0x2100 to
0x217F in your source code.

Note: The debug code is a special code at 1F00h-1FFFh in the
PIC16F877 and must be present to use the in-circuit debugging
capabilities of the MPLAB-ICD.
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4.6.3 Debug Functions
You can use the following functions with MPLAB-ICD. You can only set one 
breakpoint at a time.

• Run – Real time program execution.

• Reset – Reset the PIC16F87X (MCLR Reset).

• Break Settings – Set breakpoints.

• Halt – Halt program execution.

• Step – Single step through program execution. After the program is 
halted, each selection of Step will execute one line of the program.

• Animate – Single step through program execution automatically. After 
the program is halted, select Animate to execute one line of the pro-
gram at a time.

• Change PC – Change program counter.

4.6.4 Modify Functions 
If you need to modify the program being debugged, simply assemble a new 
hex file and download it. You can also use the Modify Dialog to edit program 
memory before downloading it into the 16F87x with the Program button. If 
you do this, the object code generated by your source code will not match the 
code in the PIC16F87X.

You can use Window>Modify to change a register, words of program memory, 
or data in the EEPROM area. Use Window>File Registers and 
Window>Special Function Registers to view internal data registers.
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Chapter 5.  Demo Board Example of Use
5.1  Introduction
This chapter discusses an example of use for the MPLAB-ICD Demo Board.

5.2  Highlights 
Topics covered in this chapter:

• A/D Example Overview

• A/D Example Main Routine

• A/D Example Source Code

5.3  A/D Example Overview
The demo.asm program is a simple implementation of the PIC16F87X’s 
analog-to-digital (A/D) converter using the MPLAB-ICD demo board. This 
program configures the A/D Module to convert on A/D channel 0 (the 
potentiometer) and display the results on the LEDs on PORTC.

To setup the device, program the PIC16F87X with a compiled version of the 
demo877.asm program, e.g., demo877.hex. You can use MPASM or any 
other third-party assembler.

To set up the demo board, make sure that:

• an oscillator type has been selected using jumper JP1. The program 
was developed using RC OSC.

• the DIP switch (SW3) has all switches in the ON position, to connect all 
LEDs to their respective PORTC pin.

For more information on A/D module operation, please refer to the PICmicro 
Midrange Microcontroller Family Reference Manual (DS33023) for an 
operational description and a list of related application notes. For detailed 
information on the demo board hardware, please refer to Chapter A.
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Figure 5.1:  A/D Example

5.4  A/D Example Main Routine
The main routine of demo877.asm (Figure 5.2) begins by configuring 
PORTC, the A/D module and Timer0. It then waits for a Timer0 overflow to 
start the    A/D conversion of the value from the potentiometer. When the 
conversion is complete, the value is displayed on the LEDs, and the program 
loops back to wait for another Timer0 overflow to start another A/D 
conversion.
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Figure 5.2:  Program Flow Chart
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5.5  A/D Example Source Code
;**********************************************************
;*  DEMO877.ASM
;**********************************************************
;*  Microchip Technology Incorporated
;*  16 December 1998
;*  Assembled with MPASM V2.20
;**********************************************************
;*  This program configures the A/D Module to convert on
;*  A/D channel 0 (the potentiometer) and display the
;*  results on the LEDS on PORTC. Make sure that the DIP
;*  switch SW3 has all switches in the ON position.
;**********************************************************

     list p=16f877

     ; Include file, change directory if needed
     include "c:\progra~1\mplab\p16f877.inc"

     ; Start at the reset vector
     org     0x000
     nop
Start
     bcf       STATUS,RP0     ;Go to BANK0
     bcf       STATUS,RP1
     clrf      PORTC          ;Clear PORTC
     movlw     B’01000001’    ;Fosc/8, A/D enabled
     movwf     ADCON0

     bsf       STATUS,RP0     ;Go to BANK1
     movlw     B’10000111’    ;TMR0 prescaler, 1:256
     movwf     OPTION_REG
     clrf      TRISC          ;PORTC all outputs
     movlw     B’00001110’    ;Left justify,1 analog channel
     movwf     ADCON1         ;VDD and VSS references

     bcf       STATUS,RP0     ;Go to BANK0

Main
     btfss     INTCON,T0IF    ;Wait for Timer0 to timeout
     goto      Main
     bcf       INTCON,T0IF

     bsf       ADCON0,GO      ;Start A/D conversion
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Wait
     btfss     PIR1,ADIF      ;Wait for conversion to complete
     goto      Wait

     movf      ADRESH,W       ;Write A/D result to PORTC
     movwf     PORTC          ;LEDs

     goto      Main           ;Do it again

     end
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NOTES:
DS51184A-page 36  1999 Microchip Technology Inc.



MPLAB™-ICD USER’S GUIDE

Chapter 6.  MPLAB-ICD Menu Options
6.1  Introduction
This chapter gives detailed information on using the MPLAB menu options 
directly applicable to the ICD Debugger.

6.2  Highlights
Topics covered in this chapter:

• File Menu

• Debug Menu

• Options Menu

6.3  File Menu
Instead of using MPLAB projects, you can use the File > Import > Download 
to Memory command to load the hex file to MPLAB-ICD. Once loaded into 
memory, you can open different windows under the Windows Menu to view 
program memory, special file registers, file registers, and source window.

6.4  Debug Menu
The following debug functions are available to control the MPLAB-ICD.

6.4.1 Run
Run options allow you to run your program in real-time or single-step mode. 
See Section 4.6.3 for a discussion of each run option.

6.4.2 Breakpoint Settings
The MPLAB-ICD debug function supports a single breakpoint at a time. Use 
the Debug > Breakpoint Settings command or press F2 to open the 
Breakpoint Setting dialog. Enter the address location where the breakpoint is 
to be set. You can also use the right mouse button to set a breakpoint.
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6.5  Options Menu
Go to Options > Development Mode to select MPLAB-ICD. Also, specify the 
processor to be debugged, the COM port, and baud rate used to 
communicate with the PC host.

You may also specify the com port, baud rate, and amount of data uploaded in 
the MPLAB-ICD dialog (Chapter 4). This dialog appears after you have 
clicked Reset in the Development Mode dialog.

If you are using breakpoints and single step, you can upload selected data to 
improve speed. Data upload options are:

• Minimum (FSR, W, Status, PCLATH) (Very Fast)

• SFRs only (Fast)

• Minimum and Watch windows (Slow)

• All Registers (Very Slow)

Data will be uploaded on a single step, a breakpoint or a halt.
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Chapter 7.  Troubleshooting
7.1  Introduction
This section describes some common problems associated with running 
MPLAB-ICE and steps to follow to resolve those problems.

7.2  Highlights
Topic covered in this chapter:

• Common Problems

7.3  Common Problems
Communications cannot be established with MPLAB-ICD.

If you cannot establish communications with MPLAB-ICD, follow these steps:

1. Make sure there is power to the demo board/target application.
MPLAB-ICD is powered by the demo board/target application. Also, if
you are using the demo board, make sure the power supply has the cor-
rect rating (9.0V, 0.75A).

2. Check that the MPLAB-ICD Header is plugged in to the demo board/tar-
get application correctly, e.g., all header pins are plugged into the socket
and the header is correctly oriented. Also, make sure you are using the
correct stand-off if you are using the demo board.

3. Check that the PIC16F87X is plugged in to the MPLAB-ICD Header cor-
rectly, e.g., all pins are plugged into the socket and the PIC16F87X is
correctly oriented.

4. Check that the connection between the MPLAB-ICD and the host com-
puter, via the RS-232 cable, is secure.

5. Check that the connection between the MPLAB-ICD Header and
MPLAB-ICD Module, via the 9-inch modular cable, is secure.

6. Check the settings for MPLAB-ICD in the Development Mode dialog
(Options>Development Mode) in MPLAB. Make sure you selected the
correct PICmicro, COM port, and baud rate for your application.

If communications still cannot be established, contact Microchip Customer 
Support, as described in General Information.
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The MPLAB-ICD Module returns a communications error on Reset, 
Single Step, Halt or Run.

When using the MPLAB-ICD Demo Board, make sure that the oscillator select 
jumper is correctly set to RC or oscillator and that the part is correctly 
programmed for this selection. If using an oscillator, make sure that there is 
one in the socket. This problem usually results in the part being programmed 
OK and debug mode set OK but when a reset, single step, halt or run 
command is executed, the ICD Module returns a communications error.

The LED on the MPLAB-ICD Module is blinking.

If the LED on the MPLAB-ICD Module is blinking, reset the module by cycling 
the power to the application on and off. Then reselect the COM port for the 
MPLAB-ICD in the MPLAB-ICD dialog box. The LED should stop blinking.

Debug mode doesn’t seem to be working.

1. Closing the MPLAB-ICD dialog will disable the ICD. So, if you have
closed this dialog, you will need to re-enable MPLAB-ICD. Select
Options > Development Mode, select MPLAB-ICD Programmer/Debug-
ger, and click Reset .

2. Debug code must be programmed into the device before debug mode
will work. Select Debug Mode  from the MPLAB-ICD dialog to program
the device with debug code.

When single stepping, the program runs too slowly.

Check the upload options in the MPLAB-ICD dialog. If you are uploading a 
large amount of data, e.g., all memory, you can expect about a 5 second delay 
between steps. To reduce the delay, select an option that uploads less data.

When single stepping, the program runs too quickly OR some registers 
are not updated.

Check the upload options in the MPLAB-ICD dialog. If you are uploading a 
small amount of data, the time between steps will be less than if you were 
uploading all memory. If you are not getting all of the data uploaded that you 
expect, check that you have selected the correct type(s) of registers for 
upload.

When halting, single stepping, or stopping on a breakpoint, MPLAB 
seems to lock up.

Check the upload options in the MPLAB-ICD dialog. If you are uploading a 
large amount of data, e.g., all memory, you can expect about a 5 second delay 
between steps. To reduce the delay, select an option that uploads less data.

The following I/O pins are not functioning correctly: RB3, RB6 or RB7.

These pins are reserved for programming/debugging. Refer to Section 1.5 for 
more information.
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Appendix A.  MPLAB-ICD Hardware
A.1 Introduction
The MPLAB-ICD hardware consists of the MPLAB-ICD Module, Header and, 
if included, Demo Board.

A.2 MPLAB-ICD Module and Header
The MPLAB-ICD Module and Header are be used to perform the ICD 
functions on the Demo Board or in the target application.

A.2.1 Voltage and Current Specifications

The MPLAB-ICD Header is powered by the target application, from a 3.0V to 
5.5V source. The current ratings for the ICD in different operating modes and 
voltages are as follows: 

A.2.2 Silkscreens and Schematics

This section contains the silkscreen and schematic diagrams for the 
MPLAB-ICD Module and Header.

Figure A.1:  MPLAB-ICD Module Silkscreen 

5V 3V

Debug 35 mA (max) 20 mA (max)

Run 40 mA 25 mA

Verify 60 mA 50 mA

Program 60 mA 50 mA
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Figure A.2:  MPLAB-ICD Module Schematic, Part 1 
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Figure A.3:  MPLAB-ICD Module Schematic, Part 2 
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Figure A.4:  MPLAB-ICD Header Silkscreen 

This Header layout may change 
in future revisions of the product. 
However, newer layouts will be 
functionally identical.
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Figure A.5:  MPLAB-ICD Header Schematic 
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A.3 MPLAB-ICD Demo Board
The MPLAB-ICD Demo Board is a simple demonstration board that supports 
PIC16F87X microcontrollers. The board can be used stand-alone with a pre-
programmed part, or with the MPLAB-ICD Module and Header. A sample 
program is provided to demonstrate the unique features of the devices. 
Although a 40-pin and a 28-pin socket are provided to accommodate the 
different packages, only one processor can be run at a time.

A.3.1 Processor Sockets

Available sockets are:

• 40-pin socket for PIC16F874/877

• 28-pin socket for PIC16F873/876

Additional 40- and 28-pin sockets have been provided as stand-offs. Simply 
insert the desired socket onto the Demo Board and then insert the 
MPLAB-ICD Header. Without the stand-off, the Header would plug into both 
sockets, and not function properly.

A.3.2 Display

Eight red LEDs are connected to PORTC of each processor type. The 
PORTC pins are set high to light the LEDs.

A.3.3 DIP Switches

Eight DIP Switches are provided in a package as SW3. When all switches are 
in the ON position, each of eight red LEDs is connected to a pin of PORTC.

A.3.4 Power Supply

The MPLAB-ICD Module is powered by the target application’s VDD with a 
voltage range of 3.0V to 5.5V (and current value of 0.75A or larger). If you 
own a PICSTART Plus Programmer, you can use its power adapter to power 
the Demo Board.
DS51184A-page 46  1999 Microchip Technology Inc.



MPLAB-ICD Hardware
A.3.5 RS-232 Serial Port

An RS-232 level shifting IC has been provided to support connection to an 
RS-232 host through the DB9 connector. The port is configured as DCE, and 
can be connected to a PC using a straight through cable, as opposed to a null 
modem cable. The circuitry must be populated by the user:

• U4 – Analog Devices MAX233A or equivalent

• R14-R19 – 330Ω, 1/8W resistor

• C7-C11 – 0.1 µF capacitors

A.3.6 Push-button Switches

Two push buttons provide the following functions:

• MCLR to reset the processor

• Active low switch connected to RB0

A.3.7 Oscillator Options

You can use the on-board RC oscillator circuit or plug an oscillator in the 4-pin 
socket. Make sure to set the jumper (JP1) to the proper selection.

• Socket provided for clock oscillator – use an oscillator from 32 kHz to 
20 Mhz

• RC circuit – the frequency generated by the 4.7K resistor and 20 pF 
capacitor ranges from about 3.5 Mhz to 6 Mhz depending on the operat-
ing voltage and ambient temperature. 

A.3.8 Analog Input

A 1K ohm potentiometer is connected through a series 470 ohm resistor (to 
protect the part should the pin be configured as an output) to RA0/AN0. The 
port can be adjusted from VDD to GND to provide an analog input to the 
PIC16F87X parts.

A.3.9 Silkscreens and Schematics

This section contains the silkscreen and schematic diagrams for the 
MPLAB-ICD Demo Board.
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Figure A.6:  MPLAB-ICD Demo Board Silkscreen 
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Figure A.7:  MPLAB-ICD Demo Board Schematic, Part 1 
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Figure A.8:  MPLAB-ICD Demo Board Schematic, Part 2 
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Glossary
Introduction
To provide a common frame of reference, this glossary defines the terms that 
follow.

Highlights
This glossary contains definitions for the following systems:

• MPLAB IDE

• MPLAB-ICD

Terms
Application

A set of software and hardware developed by the user, usually designed to be 
a product controlled by a PICmicro microcontroller.

Assembler Source Code

A text file that is processed by an assembler to produce a one-to-one 
correspondence between assembler instructions and PICmicro machine 
code.

Assemble

To translate a user’s “ASM” source text code into machine code.

Breakpoint – Software

An address where execution of the firmware will halt.

Build

A function that recompiles all the source files for an application.

C Source Code

A program written in the high level language called “C,” and which will be 
converted into PICmicro machine code.

Compile

To translate a user’s “C” source text code into machine code.

Configuration Bits

Unique bits programmed to set modes of operation. A configuration bit may or 
may not be preprogrammed. These bits are set in the device specifications 
section of the MPLAB-ICD dialog.
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Data RAM

General purpose file registers from RAM on the PICmicro device being 
debugged. The File Register window displays data RAM.

Download

Download is the process of sending data from the host PC to the debugger or 
to the target board.

Debug Code

Code, written in assembly or C, that you are using the ICD to debug.

EEPROM

Electrically Erasable Programmable Read Only Memory.

Export

Send data out of MPLAB in a standardized format.

File Registers

On-chip general purpose and special function registers.

Halt

The command that stops the debugger. Executing Halt is the same as 
stopping at a break point. The program counter stops, and the user can 
inspect and change register values, and single step through code.

Hex Code

A file of executable instructions assembled or compiled from source code into 
standard hex format code. Hex code can be directly converted to object code.

High Level Language

A language for writing programs that is of a higher level of abstraction from the 
processor than assembler code. High level languages (such as C) employ a 
compiler to translate statements into machine instructions that the target 
processor can execute.

ICD

In-Circuit Debugger. MPLAB-ICD is Microchip’s in-circuit debugger for 
PIC16F87X devices that works with MPLAB.

ICE

In-Circuit Emulator. MPLAB-ICE is Microchip’s in-circuit emulator that works 
with MPLAB.

IDE

Integrated Development Environment. An application that has multiple 
functions for firmware development. The MPLAB IDE integrates a compiler, 
an assembler, a project manager, an editor, a debugger, a simulator, and an 
assortment of other tools within one Windows application. A user developing 
an application should be able to write code, compile, debug and test an 
application without leaving the MPLAB desktop.
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Bring data into the MPLAB Integrated Development Environment (IDE) from 
an outside source

Make Project

A command that rebuilds an application, re-compiling only those source files 
that have changed since the last complete compilation. 

MPLAB-ICD

Microchip’s in-circuit debugger for PIC16F87X devices that works with 
MPLAB. 

MPLAB-ICE

Microchip’s in-circuit emulator that works with MPLAB. 

MPLAB-SIM

Microchip’s simulator that works with MPLAB. 

MPLAB Software

The name of the main executable program that supports the IDE with an 
Editor, Project Manager, and Emulator/Simulator Debugger. The MPLAB 
Software resides on the PC host. The executable file name is MPLAB.EXE. 
MPLAB.EXE calls many other files. 

MRU

Most Recently Used. Refers to files and windows available to be selected 
from MPLAB main pull down menus.

Non Real-Time

Refers to the processor executing single step instructions, or MPLAB being 
run in simulator mode.

Object code

The machine code that is produced from the source code after it is processed 
by an assembler or compiler. This code will be the memory-resident code that 
will run on the PICmicro in the user’s application. Relocatable code is code 
produced by MPASM or MPLAB-C17 that can be run through MPLINK.

PC

Any IBM or compatible Personal Computer. MPLAB needs a 486X or better 
machine.

PC Host

The computer running Windows 3.1x or Windows 95/98. 

PICmicro

PICmicro refers to the PIC12CXX, PIC14000, PIC16C5X, PIC16CXX, and 
PIC17CXX Microchip microcontroller families.
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PICMASTER

The hardware unit that provides tools for emulating and debugging firmware 
applications. This unit contains emulation memory, break point logic, 
counters, timers, and a trace analyzer among some of its tools. MPLAB-ICE is 
the newest emulator from Microchip.

Pod

The external emulator box that contains emulation memory, trace memory, 
event and cycle timers, and trace/break point logic. Occasionally used as an 
abbreviated name for the MPLAB-ICE Emulator.

Power-on-Reset Emulation

A software randomization process that writes random values in data RAM 
areas to simulate uninitialized values in RAM upon initial power application.

Program Counter

A register that specifies the current execution address.

Program Memory

Memory in the emulator or simulator containing the downloaded target 
application firmware.

Project

A set of source files and instructions to build the object code for an 
application.

Prototype System

A term referring to a user’s target application, or target board.

PWM Signals

Pulse Width Modulation Signals. Certain PICmicro devices have a PWM 
peripheral.

Radix

The number base, hex, or decimal, used in selecting an address and for 
entering data in the Window > Modify command.

Real-time

When released from the halt state, the processor runs in real-time mode and 
behaves exactly as the normal chip would behave. In real-time mode, the real-
time trace buffer is enabled and constantly captures all selected cycles, and 
all break logic is enabled. In the MPLAB-ICD, the processor executes in real-
time until a valid break point causes a halt, or until the user halts the 
debugger.

In the simulator real-time simply means execution of the microcontroller 
instructions as fast as they can be simulated by the host CPU.   

Run

The command that releases the debugger from halt, allowing it to run the 
application code and change or respond to I/O in real time.
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SFR

Special Function Registers of a PICmicro.

Simulator

A software program that models the operation of the PICmicro 
microprocessor.

Simulator Stimulus

Data generated to exercise the response of simulation to external signals. 
Often the data is put into the form of a list of actions in a text file. 

Single Step

This command steps though code, one instruction at a time. After each 
instruction, MPLAB updates register windows, watch variables, and status 
displays so you can analyze and debug instruction execution. 

You can also single step C compiler source code, but instead of executing 
single instructions, MPLAB will execute all assembly level instructions 
generated by the line of the high level C statement.

Source

Source code, usually a text file of assembly instructions or C code.

Special Function Registers

Registers that control I/O processor functions, I/O status, timers, or other 
modes or peripherals.

Stack

“Push-Down” list of calling routines. Each time a PICmicro microcontroller 
executes a call or responds to an interrupt, the software pushes the return 
address to the stack. A return command pops the address from the stack.

Step-Into

This command is the same as Single Step. Step-Into (as opposed to Step-
Over) follows a CALL instruction into a subroutine.

Step-Over

Step-Over allows you to debug code without stepping into subroutines. When 
stepping over a CALL instruction, the next break point will be set at the 
instruction after the CALL. If for some reason, the subroutine gets into an 
endless loop or does not return properly, the next break point will never be 
reached.

The Step-Over command is similar to Single Step except for its handling of 
CALL instructions. 

Symbol

An label usually produced by an assembler or compiler that refers to machine 
locations by function names, variable locations, constant declarations, source 
line-number, or other reference to user source code.
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System Button

The System Button is located in the upper left corner of Windows and some 
dialogs. This button usually has “Minimize,” “Maximize,” and “Close.” In some 
MPLAB windows, additional modes or functions can be found under the 
System Button.

Target

Refers to user hardware.

Target Application

Firmware residing on the target board.

Target Board

The circuitry and programmable device that makes up the target application.

Target Processor

The microcontroller device on the target application board that is being 
debugged.

Template

Lines of text that you build for inserting into your files at a later time. The 
MPLAB Editor stores templates in template files. 

Tool Bar

A row or column of icons that you can click on to execute MPLAB functions.

Trace

An emulator or simulator function that logs program execution. The emulator 
logs program execution into its trace buffer which is uploaded to MPLAB’s 
trace window. MPLAB-ICD does not have this feature.

Trace Memory

Trace memory contained within the Emulator. Trace Memory is sometimes 
called the Trace Buffer.

Trigger Output

Trigger output refers to an emulator output signal that can be generated at any 
address or address range, and is independent of the trace and break point 
settings. Any number of trigger output points can be set.

Upload

The Upload function transfers data from the debugger to the host PC or from 
the target board to the debugger. 

Warning

An alert that is provided to warn you of a situation that would cause physical 
damage to a device, software file, or equipment.

Watch Dog Timer

A timer on a PICmicro microcontroller that resets the processor after a 
selectable length of time. 
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Watch Variable

A variable that you may monitor during a debugging session. Watch windows 
contain a list of watch variables that are updated at each break point, as set 
by the MPLAB-ICD mode.
 1999 Microchip Technology Inc. DS51184A-page 57



MPLAB™-ICD User’s Guide
NOTES:
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