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第一章 TMS320VC5509 DSP 介绍 

 
1.1  TMS320VC5000 系列 DSP 概述 

TMS320C5000 系列 DSP 芯片目前包括了 TMS320C54x 和 TMS320C55x 两大类。这

两类芯片软件可以互相移植，所不同的是 TMS320C55x 具有更低的功耗和更高的性能。 
TMS320C55x 是目前功耗最低的一种 DSP 芯片，与 TMS320C54x 软件兼容，与

TMS320C54x相比，其综合性能提高的5倍，而功耗仅为TMS320C54x的1/6。TMS320C55x
采用变指令长度以提高代码效率，增强并行机制以提高循环效率。TMS320C55x 以其极

低的功耗和优越的性能可能在通信、消费电子等很多领域得到广泛的应用。 
 

1.2  TMS320VC5509 DSP 性能特点 
TMS320VC5509 是一款速度高、低功耗的定点 DSP，工作主频达 144MHz，每时钟

周期执行 1-2 条指令，两个乘法器、两个加法器、三套内部读总线和两套内部写总线。片

上集成 128K×16Bit RAM，32K×16Bit ROM，最大可扩展 8M×16Bit SDRAM，16Bit
位宽的外部扩展数据总线。片上集成的外围有：两个 20Bit 的定时器和看门狗、6 通道

DMA 控制器、3 个 MCBSP 串口（其中两个还可以作为 MMC/SD 串口）、数字可编程 PLL
时钟驱动器、USB 接口、I2C 总线接口、3.3V 的 IO 电压和 1.5V 的内核电压。 

        
1.3  TMS320VC5509 DSP 主要应用 

 嵌入式 DSP 应用 
 通讯 
 高性能仪器仪表 
 智能机器人 
 工业控制 
 网络安全设备 
 图象应用 
 手持设备 
 功能丰富、小型的个人与便携产品 
 2G、2.5G、3G 手机与基站 
 数字音频播放器 
 数码相机 
 电子图书 
 语音识别 
 GPS 接收机 
 指纹/模式识别 
 无线调制解调器 
 耳机 
 生物辨识应用等 

 
1.4   TMS320VC55x DSP 方框图 
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第二章 KP5509ADP 开发板介绍 
 

2.1  KP5509ADP 概要 
这款以 TMS320VC5509 为核心的评估板即可以作为软件评估板使用，也可以直接用以

项目开发。该板上除了将芯片集成的外围全部引出来之外，还增加了 10Bit 的 AD 和 DA
器件，使该板可以直接接收模拟信号并将处理完的信号以模拟信号形式输出；增加了语音

处理功能，能够将由麦克风发出的音频信号转换为数字信号进行处理，并将处理的结果通

过语音芯片以模拟信号发送到耳机接口；还增加了 RS232 串口，用户可以通过该接口进行

数据收发，除此之外，评估板上还引出 HPI 接口、外部 RAM 扩展口、用户 IO 口、显示屏

口和键盘口等。 
 

2.2  KP5509ADP 主要特征 
 120M 始时钟运行 
 4M×16bit  DRAM 
 1Mbit    FLASH 
 语音接口 
 AD 输入口 
 DA 输出口 
 RS232 接口 
 USB 接口 
 I2C 总线接口 
 同步串口接口 
 JTAG 口 
 键盘、液晶屏接口 
 多个用户 IO 
 5V 单电源供电 

 
2.3  KP5509ADP 原理框图 
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第三章  KP5509ADP 的操作说明 
3.1  电路板      

TMS320VC5509 评估电路板尺寸为：165mm×100mm， 
整电路板外形如: 图 3-1 所示： 

 

3-1 电路板外形图 
3.1.1 电源 
评估板由单 5V 直流电源供电，评估板内部将 5V 转换为 3.3V 和 1.5V 供各器件使用。

外部电源通过 J6 或 J7 输入。 
D7、D8 分别是 5V 和 3.3V 指示灯，当电路板正常供电时，指示灯亮。 

 
3.2   存储空间分配 
评估板对 TMS320VC5509 存储空间的分配如：图 3-2 所示： 
 

J9 

J17 

J12 J5 J11J3 

J1 

J2 

S

J10 J4 J8 J7 J6

J18 

J13 

J14 

J15 

J16 
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图 3-2 存储空间分配图 

 
 
3.2.1  SDRAM 接口 

  TMS320VC5509 支持 SDRAM 接口，评估板在 CE0 空间配置了 4M 字节的

SDRAM。SDRAM 由片上的控制寄存器进行配置，具体的使用方法见评估板的例程。

       
 
3.2.2  CPLD 空间 

评估板使用 CPLD 进行译码控制大部分外围器件，包括 AD、DA、RS232 串口、语

音、FLASH 等。这些器件的控制地址通过 CPLD 映射到 TMS320VC5509 的 CE3 空

间。具体控制地址的操作将在后续部分详细介绍。 
 
3.2.3  用户空间 
评估板将 CE1、CE2 空间通过对外接口的形式留给用户使用。用户可以通过对外接口

可以外扩 SRAM、SDRAM、FLASH 等。 
 
3.3   时钟选择 
评估板选择 12MHz 晶体时钟作为 TMS320VC5509 的输入时钟，这样可以方便的满足

USB 控制器对 48MHz 时钟的要求。除此之外，该时钟还通过分频做为 AD、DA 器件

的工作时钟。 
 
3.4  对外接口 

评估板上有多个对外接口给用户使用，每个接口的功能、管脚数、及在评估板的标

号如：表 3-1 所示： 
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序号 标号 功能 接口方式 
1 J1 AD 信号输入 SMA 接口 
2 J2 DA 信号输出 SMA 接口 
3 J3 CPLD 编程 IDC-10 
4 J4 JTAG IDC-14 
5 J5 RS232 接口 DB9 
6 J6 5V 电源输入 插孔 
7 J7 5V 电源输入 IDC-2 
8 J8 电源开关 DIP6 
9 J9 HPI 接口 IDC-50 
10 J10 外扩 RAM 接口 IDC-50 
11 J11 USB 接口 USB-B 型母头 
12 J12 同步串口＋I2C IDC-10 
13 J13 麦克输入 音频输入座 
14 J14 音频直接输入 音频输入座 
15 J15 音频直接输出 音频输入座 
16 J16 耳机接口 音频输入座 
17 J17 IO 口 IDC-10 
18 J18 语音输入选择  
19 S1 系统复位按钮  

                        （表 3-1） 
3.4.1  J1  AD 输入接口 

AD 器件使用的是 AD7470，输入接口采用 SMA 接口，输入信号主要参数见：表 3-2。
AD 通过 CPLD 与 TMS320VC5509 相连，占用 CE3 空间的 0x60001 地址，在使用 AD
进行数据采集时，直接读取该地址数据就可以得到采样结果。AD 器件占用

TMS320VC5509 的外部中断 0，完成一次采集给 DSP 发送一次中断信号。 
 

序号 主要参数 要求 备注 
1 输入信号 0~2.5V  
2 采样率 ≤1MHz 默认 200KHz 
3 位数 10Bit  
4 编码方式 N=(Vi/2.5V)×1023 N 为无符号数 
5 输出方式 并行输出  

                      表 3-2 
3.4.2   J2  DA 输出接口 

DA 器件使用的是 AD7392,输出接口采用 SMA 接口，DA 的主要参数见：表 3-3。DA
通过 CPLD 与 TMS320VC5509 相连，占用 CE3 空间的 0x600013 地址，使用 DA 输出数

据时，直接将数据写到该地址即可。 
 

序号 主要参数 要求 备注 
1 输出信号 VP-P≤2.5V（DC=0）  
2 转换时间 ≥60us 与用户写入速度有关 
3 位数 10Bit  
4 输出电压 VO=2.5×n/1024 N 为无符号数 

                       （表 3-3） 
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J6 

3.4.3  J3  CPLD 编程接口 
CPLD 选用的是 ALTERA 公司的 EPM7128，共 2500 门。CPLD 内部逻辑在出厂前已

经编好，一般情况下用户无需改变。如有特殊要求需要改变控制逻辑时，可以通过此接

口对 CPLD 重新编程。 
 
3.4.4  J4  JTAG 接口 

JTAG 接口是 TMS320VC5509 的仿真接口，用户通过此接口连接仿真器，进行程序

调试。该接口的定义见：表 3-4。 
 

管脚号 信号定义 
1 TMS 
2 TRST- 
3 TDI 
4 GND 
5 PD 
6 NC 
7 TDO 
8 GND 
9 TCK-RET 
10 GND 
11 TCK 
12 GND 
13 EMU0 
14 EMU1 

（表 3-4） 
 

3.4.5   J5  RS232 接口 
RS232 接口使用 DB-9 孔座，定义见：表 3-5。 

 
管脚号 评估板 PC 机 
2 TXD RXD 
3 RXD TXD 
4 CTS DTR 
5 GND GND 
8 RTS CTS 

                           （表 3-5） 
3.4.6   J6、J7  ＋5V 输入 

评估板对 5V 留有两个输入口，其中 J7 使用 IDC-2 针座，1 脚为 5V 输入，2 脚为 GND。

J6 使用电源输入连接头，定义如：图 3-3 所示。 
 

     
                          
 
 
 

（图 3-3）  
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3.4.7  J8  电源开关 
电源开关选用拨码开关，如：图 3-1 方向放置电路板，将开关拨向右侧时评估板关电，

拨向左侧时评估板上电。 
 
3.4.8  J9  评估板 HPI 接口 

评估板 HPI 接口使用 IDC-50 插座，具体定义见：表 3-6。 
管脚号 信号定义 管脚号 信号定义 
1 A0 2 D0 
3 A1 4 D1 
5 A2 6 D2 
7 A3 8 D3 
9 A4 10 D4 
11 A5 12 D5 
13 A6 14 D6 
15 A7 16 D7 
17 A8 18 D8 
19 A9 20 D9 
21 A10 22 D10 
23 A11 24 D11 
25 A12 26 D12 
27 A13 28 D13 
29 HINT 30 D14 
31 HR/W 32 D15 
33 HRDY 34 ARE 
35 HCNT0 36 HDS2 
37 HCNT1 38 HDS1 
39 HBE0 40 HCS 
41 HBE1 42 HAS 
43 INT1 44 INT2 
45 GND 46 GND 
47 3.3V 48 3.3V 
49 5.0V 50 5.0V 

（表 3-6） 
 

3.4.9  J10  外部 RAM 接口 
外部 RAM 接口选用 IDC-50 插座，接口管脚定义见：表 3-7。 
 

管脚号 信号定义 管脚号 信号定义 
1 A0 2 D0 
3 A1 4 D1 
5 A2 6 D2 
7 A3 8 D3 
9 A4 10 D4 
11 A5 12 D5 
13 A6 14 D6 
15 A7 16 D7 
17 A8 18 D8 
19 A9 20 D9 
21 A10 22 D10 
23 A11 24 D11 



 12

25 A12 26 D12 
27 A13 28 D13 
29 ARE 30 D14 
31 AOE 32 D15 
33 AWE 34 SDA10 
35 ARDY 36 CLKMEM 
37 CE1 38 SDWE 
39 CE2 40 SDCAS 
41 BE0 42 SDRAS 
43 BE2 44 GND 
45 GND 46 GND 
47 3.3V 48 3.3V 
49 5.0V 50 5.0V 

                    
  （表 3-7） 

3.4.10  J11  USB 接口 
USB 接口选用 B 型母头，管脚定义见：表 3-8。 
管脚号 USB 座信号定义 DSP 信号定义 
1 USBVDD GPIO7 
2 D- DN 
3 D+ DP 
4 GND GND 
5 机壳 GND 
6 机壳 GND 

（表 3-8） 
在设计时使用 GPIO7 判断 USB 接口的电源状态，DSP 的 PV 管脚通过上拉电阻与

DP 连接。 
 
3.4.11  J12  同步串口+I2C 

该接口使用 IDC-10 插座将 DSP 的同步串口 1 和 I2C 总线引出，管脚定义见：表 3-9。 
管脚号 信号定义 
1 S10 
2 S11 
3 S12 
4 S13 
5 S14 
6 S15 
7 SDA 
8 SCL 
9 NC 
10 GND 

            
（表 3-9） 

3.4.12  J13  麦克输入接口 
        麦克输入接口使用双通道耳机插座，与插头连线的对应关系见：图 3-4。使用麦克

进行语音输入时要求将 J18 的 1 脚与 2 脚短接。麦克接口的输入幅度为 0～100mV。 
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（图 3-4） 
3.4.13  J14  音频输入接口 

语音信号输入接口使用双通道耳机插座，与插头连线的对应关系见：图 3-5。使用该

接口输入时要求将 J18 的 3 脚与 2 脚短接，该接口的输入幅度为 0～1.578 V。 
 

                           
                           
 
 
 

（图 3-5） 
3.4.14  J15 音频输出接口 

语音信号输出接口使用双通道耳机插座，与插头连线的对应关系见：图 3-6。评估板

的语音输出为单声道输出，输出幅度为 0～1.578V。 
 
 
 

         
 
 

（图 3-6） 
 
3.4.15  J16  耳机接口 

耳机接口使用双通道耳机插座，与插头连线的对应关系见：图 3-7。评估板的耳机输

出为单声道输出，输出幅度为 0～1.578V。 
  
 
 
 
 
 
                     

（图 3-7） 
 
3.4.16  J17  IO 接口 

IO 接口使用 IDC-10 插座，控制地址为 0X600007，接口定义见： 

麦克输入

GND

语音输出

GND

 

耳机输出

GND

音频输入   
GND
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表 3-10。接口共 8 根控制线，其中 IO1～IO4 为输出，对应该地址的 D0～D3 数据位，

输出时直接在该地址相应的数据位写 0 或 1 即可。IO5～IO8 为输入，对应该地址的 D4～
D7 数据线，使用时直接从该地址读数即可，读回数的 D4～D7 分别对应 IO5～IO8 的状

态。 
 

管脚号 信号定义 备注 
1 IO1 输出 
2 IO2 输出 
3 IO3 输出 
4 IO4 输出 
5 IO5 输入 
6 IO6 输入 
7 IO7 输入 
8 IO8 输入 
9 GND  
10 GND  

 
                        （表 3-10） 
 
3.4.17   J18  语音输入选择 

将 J18 的 1 脚与 2 脚短路则选择麦克输入，将 3 脚与 2 脚短路则选择语音输入，该

接口的管脚定义见：图 3-8。 
 

 

（图 3-8） 
 
3.4.18   S1  复位按钮 

该按钮用于对 DSP 的复位。 
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第四章 系统安装 
 

本章介绍的是如何将仿真器和评估板连接到计算机上和如何给目标板供电以及软件的安

装。 
4.1  系统组成 

开发机的硬件和软件配置 
PC 机配置 指标 

CPU Pentium Ⅲ以上   
内存 不小于 128M 
操作系统 Windows2000 或 XP 
仿真器 建议使用 USB2.0 或 560 实时仿真工具 
开发软件 CCS2.1 或以上版本 
VC 版本 VC6.0 或以上版本 
 

4.2  仿真器与开发板的连接 
按照以下步骤操作，以确保主机与仿真器和评估板的正确连接。安装之前，请清理

桌面上的导线等金属物品，以防短路。并将手上的静电放掉，以防止将芯片损坏。 
（1）关闭主机电源 
（2）仿真器主机端与主机正确连接（具体接口应视具体系统而定） 
（3）将仿真器的目标板侧的数据排线与板卡的 J4（JTAG）接口连接 
（4）将 5V 电源供电插头与开发板的数字 5V（J6 口）插座连接 

下图所示的是连接框图： 
 
 
 
 
 
 
 
 
 
 

4.3  仿真器与开发板的供电 
仿真器的供电方式，根据其型号的不同，有 PC 机直接供电方式或独立+5V 直流电源供

电方式。评估板供电方式，采用独立+5V 电源供电。 
4.4  CCS 的安装和设置 

您在使用 TMS320VC5509  EVM 板进行开发时，需要安装 CCS for C5000（建议

使用 2.2 版本）。安装 CCS 没有需要特别说明的地方，在 CCS 安装完成后，请按照如

下步骤设置 CCS（以 TI 560P 实时仿真器为例）。 
其它厂家的 DSP 开发工具，请参考各自安装说明，这里不一一详述。 

I. 运行 CCS Setup： 
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II. 选择驱动程序： 

 
 
 
 
 
 
 
 
 
 
 

 
本例中使用的是 TMDXEMU560 仿真器，请选择 C55xx XDS560 Emulator 驱动程

序。 
 

III. 配置板子属性： 
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IV. 处理器配置： 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

添加处理器 CPU_1，因为调试的是 C5509，所以也可以将 DSP_1 
命名为：5509 
 
V. 配置启动 gel 文件： 

添加与 KP5509ADP 板相适应的 GEL 文件 C5509.gel。此处假设将 GEL 文件

复制到 CCS 安装目录的\CC\GEL 子目录下。 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
VI. 保存设置并退出： 
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第五章  BIOS 设置 
 
本评估板提供的例程都使用了 BIOS 进行相关设置，本章内容首先对评估板上常用的

BIOS 设置进行介绍，以方便用户更好的理解每个例程。 
 
5.1  建立 BIOS 文件 

首先建立一新的工程，为叙述方便，假定建立 TEST.pjt 。然后点击

File->New->DSP/BIOS Configuration，选择 TMS320C55XX 页的 C55XX.cdb，点击 OK，

出现 BIOS 界面，选择 File->Save，在文件名栏输入 test，将 BIOS 文件存储在当前工作

目录，CCS 会生成 test.cdb、testcfg.cmd、testcfg.s55、testcfg_c.c 等文件在工程中使用，

BIOS 的配置方法将在后面详细介绍。点击 Project->Add Files to Project 分别将生成的 
test.cdb 文件和 testcfg.cmd 文件加入到工程即可，CCS 会自动将其它 BIOS 文件加入到

工程，出现（图 5-1）界面。 

 
（图 5-1） 

5.2  选择芯片型号 
在 BIOS 中需设置所选芯片的型号，右击 system->Global settings，点击 properties

出现（图 5-2）界面，在 chip support library 中选择 5509。 
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（图 5-2） 
5.3  大模式编译设置 

由于 CE0、CE1、CE2、CE3 空间超出了 64K 空间范围，所以在使用这些空间时编

译选项中应选择大模式编译。在本评估板设计时使用了 CE0、CE3 空间，所以在编译时

都选用了大模式编译。设置为大模式编译需要两个步骤。具体设置方法如下： 
 在 BIOS 中进行设置，打开该工程所选的.cdb 文件。右击 system->Global settings，

点击 properties 出现（图 5-2）界面，在 memory model 中选择 Large 选项。 
 在编译模式中选择 Larage 模式，设置方法如下： 点击 project->Build Options 出

现（图 5-3）界面，在 advanced 中选择 large memory model。 
 

通过以上设置，CCS 在编译工程时就会按大模式编译，如果以上两项设置只设置一

个，编译将会出错，两项都不设置则按小模式编译，无法访问大于 64K 的存储空间。 
                                                    
                                                                         
                                                                          
                                                                          
                                                                  
                                                                         
                                                                          
                                                                     
                                                                    
                                                                       
                                                                 
                                                                          
                                                                          
                                                                          

 
 
 

（图 5-3） 

wh
下划线
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5.4  EMIF 的设置 
评估板在 CE0 空间使用了 SDRAM，因此必须将该空间接口设置为 SDRAM 接口；

在 CE3 空间配置了 CPLD 控制地址，选用的是 16Bit SRAM 操作方式，故必须将该空间

设置为 16-bit wide asynchronous 模式。 
设置方法如下： 

右击 chip support library->EMIF->EMIF configuration manager，点击 insert emifCfg
在该项下增加 emifCfg0。右击 emifCfg0，点击 properties，出现 
（图 5-4）界面，将 CE0 空间设置为 32-bit wide SDRAM(实际使用为 16-bit wide)，在

Global settings 中将“memory clock frequency”设置为“CLKMEM = DSP CLK/2”， 设
置完后点击该界面的 SDRAM 页如（图 5-5），选择 initialize SDRAM,其它参数如 图 5-5
设置。类似的将 CE3 空间设置为 16-bit wide asynchronous，如果在使用时对 CE1、CE2
空间进行了扩展，也需要进行相应的设置才能使用。设置完后右击 EMIF resource 
manager->Hemif0,点击 properties，选择 Enable pre-initialization,在 pre-initialization 中选择

emifCfg0 并确定。 
 

（在工程中只有对 CE0、CE3 空间进行如上设置后才可以访问该空间） 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                           （图 5-4） 

 
  
 
 
 
 
 
 
 
 
 
 
 

wh
下划线
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（图 5-5） 
5.5  外部总线模式设置 

TMS320VC5509 的数据线、地址线、控制线可以工作在四种模式下，分别为：data 
EMIF、full EMIF、Non-multiplexed EHPI、Multiplexed EHPI，四种模式的详细说明请参

阅 TMS320VC5509.pdf。 
本 DSP 开发板使用的是：Full EMIF 模式。 
在 BIOS 中设置方法如下:   
右击 chip support library->chip-global CLS device configuration->chip configuration，

点击 properties，在 parallel port mode 项选择 full EMIF。 
进行此设置之前必须完成大模式编译设置（见本章 5.3） 

5.6 中断设置 
利用 BIOS 可以将中断服务函数与中断向量表相关联， TMS320VC5509 共有 32 个

中断（包括软中断），设置时首先查阅中断向量表（表 5-1），查到要设置的中断在中断

向量表的位置，再在 BIOS 中进行设置。 
下面以设置外部中断 0 为例进行详细说明，首先在中断向量表中查到外不中断 0 的

中断向量地址为 0X10，中断级别为 2，然后打开.cdb 文件，在 Scheduling 中右击

HWI_INT2 选择 properties，弹出 HWI_INT2 属性对话框见（图 5-6），在 function 中输入

程序中使用的中断服务函数的中断名（前面加下划线），例如图 5-6 中输入_EXT_INT0，
则在程序中使用的中断函数为 void EXT_INT0( )，如此设置后程序中的中断服务函数就

与中断向量相关联了，如果需要中断事件触发时进入中断服务函数还需要打开中断，打

开中断时首先打开中断全局使能，可以通过调用 BIOS 的 API 函数 IRQ_globalEnable( )
实现，然后将中断使能寄存器（IER）中该中断对应位置‘1’即可打开该中断。对于中

断寄存器及其它与中断相关内容请参阅 TMS320VC5509.pdf。             

wh
下划线

wh
下划线
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（表 5-1） 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

 （图 5-6） 
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5.7  MCBSP（同步串口）设置 
在评估板上语音器件和 Flash 都使用的同步串行接口，所以在使用这两个器件时需

要对同步串口进行配置。 
下面以设置 MCBSP0（Flash 器件接口）为例说明如何配置： 
打开.cdb 文件，击 MCBSP Configuration Manager 选择 insert mcbspCfg，在该项增加

mcbspCfg0，右击 properties，根据外接器件的时序要求对该项内容进行配置见（图 5-7），
对该项中接收模式、发送模式等项设置完成后，点击确定。设置完成后，右击 MCBSP 
Resource Manager 下的 Hmcbsp0，选择 properties，在弹出的对话框中选择 open Handle to 
MCBSP，并选择 Enable pre-initilization 在 pre-initilization 中选择 mcbspCfg0，见（图 5-8） 

          
 
 
 
 
 
 
 
 
 
 
 
 

 
（图 5-7） 

 
 
 
 
 
 
 
 
 
 
 
 
 
         （图 5-8） 
5.8  PLL 设置 

对 PLL 设置 用来设置 DSP 的工作时钟，设置方法如下： 
右击 PLL Configuration Manager 选择 insert pllCfg，就会在该项下加入 pllCfg0，右

击 pllCfg0 选择 properties，弹出 pllCfg0 属性对话框见（图 5-9），在 PLL Multiply Value
中输入时钟的乘数，在 PLL divide value 中选择时钟的分频数，从而得到 DSP 的工作时

钟，在图 5-9 中乘数为 5，分频选择了 CLKOUT = 1/2CLKIN,由于 DSP 的时钟输入使用

的是 24MHz 晶体，所以 DSP 的工作时钟为 24×5/2＝60MHz，设置完成后右击 PLL 
Resource Manager 下的 pll0，选择 properties，弹出 pll0 属性对话框见（图 5-10），点击
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Enable Configuation PLL 左侧的方框，然后在 Pre-initilize 下拉框中选择 pllCfg0，如此设

置完成后 DSP 进行编译的程序，就会在设定的时钟频率下运行。 
 

 
 
 
 
 
 
 
 
 
 
 
 

（图 5-9） 
 

               
 
 
 
 
 

 
 
 
 
 
 
                             （图 5-10） 
5.9  BIOS 其它设置 

利用 BIOS 还可以进行其它设置，具体内容可参阅 TI 提供的相关文档。 
 

以上内容简单介绍了使用 BIOS 对 DSP 极其部分片上外围的设置，除了利用 BIOS
设置外，还可以通过其它方法实现，可参阅 TI 提供的相关文档。 
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第六章  KP5509ADP 开发板测试程序 
 

本评估板所有的例程都是在 CCS2.2 版本下调试通过，在 CCS2.2 以下版本下编译可能出

错，需要在该版本建立 BIOS 文件，并进行相关设置（BIOS 升级），详见第五章。 
 

6.1  LED 指示灯控制 
功能说明： 

BUSTEST.pjt 主要演示了评估板上指示灯的使用，三个指示灯的控制地址分别是

0X60004、0X60005、0X60006。在控制地址写 1 对应的灯亮，写 0 灯灭，程序实现的

就是三个灯的循环亮灭。 
程序使用了 CPLD 的控制地址，需要通过 BIOS 设置 EMIF，将 CE3 空间设置成

16-bit wide asynchronous。 
操作说明: 

 启动 CCS 后 
 Project→Open 打开工程文件  BUSTEST.pjt 
 File→Load Program 加载程序 Debug\ BUSTEST.out 
 Debug→Run 运行程序 
运行后可以看见三个灯的循环亮灭。 

6.2  AD 测试程序 
功能说明：  

ADTEST.pjt说明了评估板上AD的使用，AD采集的数据暂存在0X60001地址，AD每

采集完一次对DSP发送一次中断请求，DSP响应该中断并在0X60001地址读取采集的数

据，详见例程。 
AD占用DSP的外部中断0，中断函数与中断向量的关联设置见第五章中断设置部分，

程序中中断函数为 void ADINT（）。 
程序使用了CPLD的控制地址，需要通过BIOS设置EMIF，将CE3空间设置成 16-bit 

wide asynchronous。 
除了以上设置还须在程序中打开全局中断使能和外部中断0使能，所使用语句见（图

5-11）。完成这些设置后即可使用外部中断0。  
 

 
（图5-11） 

在例程中将采集的数据存放在dada1[1024]缓存中，可以通过CCS在该存储区查看采

集的数据。 
 

操作说明: 
 使用连接线将函数信号发生器的信号输入到 J1（0～2.5V） 
 评估板上电 
 启动 CCS 后 
 Project→Open 打开工程文件  ADTEST.pjt 

*(int *)0x0 = 0x4; //外部中断 0 使能 
 

 IRQ_globalEnable();//全局中断使能 
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 File→Load Program 加载程序 Debug\ ADTEST.out 
 Debug→Run 运行程序 

运行后在CCS中点击view->Memory，弹出Memory Window Options对话框，在该框

的Address中输入0x2ed（AD采集数据存储的起始地址），在page选项选择DATA，可以

看到AD采集的数据结果。 
 
6.3  DA 测试程序 

功能说明： 
DATEST.pjt 说明了 DA 的使用，DA 的复位地址为 0X600011，若在该地址写‘0’，

则 DA 处于复位状态，所以使用前必须在程序中该地址写‘1’ 
（本例程已经在该地址写‘1’）。 
DA 的输出控制地址为 0X600013， CPU 将处理完成的数据直接写到该地址，CPLD

内部控制逻辑就会将数据送到 DA 进行转换。 
本例程序中 DSP 首先计算了一组正弦数据，然后程序循环将正弦数据送到 DA 进行

转换。 
程序使用了CPLD的控制地址，需要通过BIOS设置EMIF，将CE3空间设置成 16-bit 

wide asynchronous。 
操作说明: 

 启动 CCS 后 
 Project→Open 打开工程文件  DATEST.pjt 
 File→Load Program 加载程序 Debug\ DATEST.out 
 Debug→Run 运行程序 

通过示波器可以在 J2 口测试到正弦波。 
 

6.4  AD/ DA 测试程序 
  功能说明： 

AD_DA.pjt 是 AD 与 DA 同时使用的程序，程序综合了 AD 测试程序和 DA 测试程

序。在运行时 DSP 实时将从 AD 采集的数据发送到 DA 转换。 
在 BIOS 设置时综合了 AD 测试程序和 DA 测试程序的设置。 

操作说明: 
 使用连接线将函数信号发生器的信号输入到 J1（0～2.5V） 
 启动 CCS 后 
 Project→Open 打开工程文件  AD_DA.pjt 
 File→Load Program 加载程序 Debug\ AD_DA.out 
 Debug→Run 运行程序 

通过示波器可以在 J2 口测试到输入到 JI 的信号。 
 

6.5  语音回放程序 
功能说明： 

评估板上使用 AD73311 作为语音处理器件，AD73311.pjt 说明了该器件的使用方法。 
在使用前需要对该器件进行复位，复位地址是 0X600001，复位时在该地址写 0，经

过 20ms 左右时间在该地址置 1，器件进入工作状态 
（本例程已经进行了设置）。 

该器件与 DSP 的接口使用的是 DSP 的 MCBSP2，使用时应对同步串口进行相应的

设置，设置的参数需要满足 AD73311 的接口时序要求（本例程已经完成该设置）。若用

户开发语音程序时请参照第五章的 MCBSP 设置部分以及本例程中对 MCBSP2 的设置。 
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本例程中还对 AD73311 的控制寄存器进行了设置，通过设置这些寄存器可以控制

音频采样率、音量调整、静音输出等多种功能。若用户在开发语音程序时请参照本例程

对 AD73311 的控制寄存器进行设置，除此之外用户还需仔细阅读 AD73311.pdf，以便更

好的使用该语音芯片。 
程序运行时将采集的音频信号直接发送出去，本例程中接收语音数据采用中断的方

式，接收函数与同步串口 2 的接收中断相关联。若用户开发语音程序时请参照本例程设

置及第五章中断设置部分。 
程序使用了CPLD的控制地址，需要通过BIOS设置EMIF，将CE3空间设置成 16-bit 

wide asynchronous。 
操作说明: 

 将 J18 跳线接在 2、3 脚 
 在 J14 （line in）端输入音频信号，在 J15（Earphone）端接上耳机。 
 启动 CCS 后 
 Project→Open 打开工程文件  AD73311.pjt 
 File→Load Program 加载程序 Debug\AD73311.out 
 Debug→Run 运行程序 

运行后可以通过耳机收听到输入的音频信号（注意如果音频信号出现饱和失真，可

以通过调小输入音频信号来解决；也可以通过调整 AD73311 的放大增益解决）。 
将 J18 跳线接在 1、2 脚，将麦克风接到 J13，重复上述步骤，可以在耳机中听到麦

克风输入的音频信号。 
 

6.6 语音录放程序 
功能说明： 

AUDIO.pjt 演示了语音的录放功能，运行程序时，LED1 亮、LED2 灭表示评估板运

行在录音状态，此时可以通过麦克或 line in 接口进行录音，两种方式的选择通过 J18 跳

线实现，录音时 DSP 将采集的音频信号存储到 SDRAM 中，录音时间大约 1 分钟。录

音完成后程序开始回放录音，此时 LED1 灭、LED2 亮，DSP 从 SDRAM 中读取音频数

据，再送到语音器件进行 DA 转换，通过耳机口接上耳机就可以听到开始的录音。之后

程序循环运行，反复进行录放。 
     若用户开发语音程序，对 BIOS 的设置与语音回放程序基本相同，只是增加了对 CE0

空间的设置，将 CE0 空间设置为 SDRAM，具体设置方法参照例程及第五章 EMIF 设置

部分。 
操作说明： 

 将 J18 跳线接在 2、3 脚。 
 在 J14（line in）端输入音频信号，在 J15 （Earphone）端接上耳机， 
 评估板上电。 
 启动 CCS 后。 
 Project→Open 打开工程文件  AUDIO.pjt 
 File→Load Program 加载程序 Debug\AUDIO.out 
 Debug→Run 运行程序 

运行后开始 LED1 亮、LED2 灭，此时程序将采集的音频数据存放到 SDRAM 中，

大概过 1 分钟，LED1 灭、LED2 亮，程序将刚才的录音通过耳机输出口输出，在耳机

中可以收听该音频信号（注意如果音频信号出现饱和失真，可以通过调小输入音频信号

来解决；也可以通过调整 AD73311 的放大增益解决）。 
将 J18 跳线接在 1、2 脚，将麦克风接到 J13，重复上述步骤，可以将麦克风输入的

音频信号进行录音回放。 
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6.7  串口测试程序 
功能说明： 

本评估板上采用的是 TL16C550 作为串口协议转换器件。使用评估板上 RS232 串口

收发数据时要先对该器件进行设置。 
首先对器件复位，复位地址是 0x600002，复位时先在该地址写 1，约过 20ms 在该

地址写 0，本例程中 tl16c550RS( )复位函数已完成此功能设置。 
复位完成后还要对器件内部寄存器进行设置，来确定 RS232 的波特率和工作模式。

本例程中使用 tl16c550init( )函数进行设置，该函数有两个参数，第一个参数设置串口的

波特率，该参数的数值与波特率的对应关系见（表 6-2），第二个参数设置 TL16C550 的

LCR 寄存器，该寄存器的功能见 TL16C550.pdf 文档中的详细说明。 
TL16C550 共有七个工作寄存器，控制地址为 0x600018—0x60001F，若用户在开发

过程中还要使用其它寄存器，请参考 TL16C550.pdf 查阅各寄存器的详细功能，再对其

进行设置。 
本例程中发送采用查询的方式，接收采用中断的方式，接收中断占用的是 DSP 的

外部中断 3，中断函数是 void RS232REV( )。若用户开发串口程序时请参照例程及第五

章中断设置部分。 
程序使用了CPLD的控制地址，需要通过BIOS设置EMIF，将CE3空间设置成 16-bit 

wide asynchronous。 
在使用串口时，首先调用了函数 startCOM( )，使 RS232 串口进入发送接收状态，

等待接收或发送数据。发送时调用发送函数 send_byte( )，接收时调用函数 get_byte( )。 
波特率 设置值 

50 2304 
75 1536 
110 1047 

134.5 857 
150 768 
300 384 
600 192 

1200 96 
1800 64 
2000 58 
2400 48 
3600 32 
4800 24 
7200 16 
9600 12 
19200 6 
38400 3 
56000 2 

                            （表 6-2） 
操作说明: 

 使用直连串口线将评估板 RS232 接口与 PC 机 RS232 串口相连 
 启动 CCS 后 
 Project→Open 打开 RS232 目录下的工程文件  16C550.pjt 
 File→Load Program 加载程序 Debug\16C550.out 
 Debug→Run 运行程序 

本例程循环按顺序发送 0～254，通过通过 PC 机的串口测试软件（此软件可以从

网上下载），可以接收到这些数据，接收波特率应设置为 19200bps。 
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将 PC 机串口测试软件发送波特率设置为 19200bps，然后发送数据到评估板的

RS232 串口。本例程可以接收该数据，并将接收到的数据存放在 rev_buffer 数组中，可

以通过 CCS 观察到该数组的数据。 
 
6.8  I/O 测试程序 

功能说明： 
程序循环读入 IO5~IO8 的状态，然后通过 IO1~IO3 送出。 
程序使用了CPLD的控制地址，需要通过BIOS设置EMIF，将CE3空间设置成 16-bit 

wide asynchronous。 
 

    操作说明： 
 通过 IO 接口在 IO5~IO8 输入不同的高低电平 
 启动 CCS 后 
 Project→Open 打开工程文件  IOTEST.pjt 
 File→Load Program 加载程序 Debug\ IOTEST.out 
 Debug→Run 运行程序 

使用示波器可以检测到：IO1 输出的状态和 IO5 相同 
                IO2 输出的状态和 IO6 相同 
                IO3 输出的状态和 IO7 相同 
              IO4 输出的状态和 IO8 相同 
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第七章  系统脱机工作   
 

7.1  FLASH 的在线烧写 
用户开发的程序最终要烧写到评估板上的 FLASH，以便脱机运行。 

7.2  烧写 FLASH 的步骤如下： 
（1）用 CCS 将最终程序编译生成.out 格式文件。 
（2）将.out 文件转化为.hex 文件。 
（3）在生成.hex 文件之前首先用文本编译器编写.cmd 文件，文件格式参照（图 7-1） 

 
 

 
 
 
 
 
 
 
 

（图 7-1） 
 

上述文件做好后，在 DOS 模式下运行 Flash_Program 目录下的 hex55.exe，键入

以下指令： 
   hex55   *.cmd 

其中*.cmd 就是前面生成的.cmd 文件，运行之后就会生成相应的 hex 文件，如：图

7-1 会生成 bustest.hex。 
（4）将生成的.hex 文件转换为.dat 文件。 
在 DOS 下运行 Flash_Program 目录下的 transcode.exe，键入以下指令 
      transcode  *.hex   *.dat      

*.hex 为待转换的.hex 文件，*.dat 为输出的数据文件。 
注：（转换时请不要加后缀文件名） 

（5）将生成的数据文件烧写到 FLASH。 
打开 CCS ，加载  write_flash 目录下的 write_flash.out 文件，再通过

file->data->load 将步骤 4 生成的.dat 文件载入。载入数据文件时直接点击 OK 即可。

运行程序，开始烧写 FLASH。 
在烧写的过程中，首先对 FLASH 进行擦除，擦除时 LED1 灯亮，擦除完毕时

LED1 灭，擦除完成后开始对时烧写，烧写时 LED2 亮，烧写完成灭，烧写过程可

能需要几分钟时间，未烧写完成前最好不要停止程序。 
（6）烧写完成后关电重启或复位即可运行 FLASH 中的程序。 

 

-boot   ；说明创建 boot 文件 
-v5510:2 ; 生成 55X boot 文件格式 
-serial8 ; 使用串行加载方式 
-a ； ASCII 格式 
-reg_config 0x1c00,0x0293 ；在 0x1c00 积存器写 0x0293 
-delay 0x100 ；延迟 0x100 个 CPU 时钟周期 
-o bustest.hex ; 输出.hex 文件 
bustest.out ；输入的.out 文件 

wh
高亮
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第八章  参考文献 

8.1  bootloader.pdf  

文档介绍了 TMS320VC5509 片上 bootloader 的特点；详细说明了器件的各种 bootload

的方式及其相应的设置；还介绍了 boot 表的产生方法。 

8.2  assembly language.pdf 

文档详细介绍了 TMS320C55X 汇编语言的使用。 

8.3  BIOS_codesize.pdf 

DSP/BIOS 核是可以升级的库，可以理解为存储在目标上的一个实时操作系统，占用部

分存储空间。用户可以参考此文档对 DSP/BIOS 的占用空间进行设置，达到既使用

DSP/BIOS 使程序更加简洁高效，又不会让 DSP/BIOS 占用太多的用户空间。 

8.4  C C++ Complier.pdf 

文档详细介绍了如何使用 C/C++编译器进行编译、优化、生成库文件等内容。 

8.5  TMS320VC5509_I2C.pdf 

该文档详细介绍了 TMS320VC5509 片上 I2C 总线的使用方法。 

8.6  TMS320C55xAPI 

TMS320C55x 片上支持库（CSL）提供了许多 C 语言的函数，用于控制片上的外围设

备。使用这些函数可以在使用外围设备时更加方便、开发周期更短、操作硬件更直接

等特点。文档详细介绍了这些函数的使用方法。 

8.7  CCS-toturial.pdf 

文档详细介绍了 CCS 的使用。 

8.8  TMS320C55X_library.pdf 

TMS320C55X 提供了多个数字处理函数库，这些函数经过了优化处理，用户调用这些

函数不但方便而且还可以提高程序的运行速度，这个文档详细介绍了这些函数及其使

用方法。 

8.9  Mnemonic instruction.pdf 
TMS320C55X系列DSP可以使用两种格式指令，一种是mnemonic格式，另一种是algebraic
格式，文档介绍了前一种的指令格式的各种操作。 

8.10   eripherals.pdf 

文档介绍了 TMS320C55X 系列 DSP 片上的外围设备及其使用。 
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8.11   rogrammer’s guide.pdf  

文档详细介绍了优化 C 程序和汇编程序的方法，以及如何为特殊的应用编写程序。 

8.12  TMS320VC5509.pdf 

文档详细的介绍了 TMS320VC5509。 

8.13  TMS320C55X.pdf 

文档介绍了 TMS320C55X 系列 DSP 的结构、寄存器、使用方法。 

其它参考文档： 

8.14  AD73311.pdf 

8.15  AD7393.pdf 

8.16  AD7470.pdf 

8.17  AMS1117.pdf 

8.18  AT25F1024.pdf 

8.19  LM285.pdf 

8.20  LM358.pdf 

8.21  MAX3232.pdf 

8.22  MT48LC4M16.pdf 

8.23  TL16C550.pdf 

 

 

 

 


