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State Transition Matrix

1.
Rational ClearQuest WinNT 4.0 Windows2000 Windows98 WindowsMe
WindowsXP
ClearQuest setup.exe Rational ClearQuest
ClearQuest Web cQ Custom
Choose Features Web Server Components
CQ Web
Rational ClearQuest ClearQuest
1 Create Schema Repository
SQL Server Oracle Access2000
Schema Repository
Web Web WinNT4.0
Win2000Server
2 Rational ClearQuest
ClearQuest
3 Web Web ClearQuest Web
IE  Netscape Web
Web
CQ 500M CQ Web IE
IE 5.01
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2
ClearQuest Microsoft SQL Server 7.0 Microsoft SQL Server2000 Oracle(8.0.5
8.1.6 8.1.7) Access2000 SQL2000  Access2000
2 1 Access
Access Access jash
Access test.mdb ““c:\ 77
Access ““\jash\ \test.mdb””
Access
2 2 Microsoft SQL Server
cQ SQL cQ
SQL
ClearQuest Microsoft SQL sa
Microsoft SQL Server
ClearQuest Desinger ClearQuest
Maintenance Tool
1 ““SQL Server -> IP -> 7z “<
2 CQ sa Administrator
CQadmin
test ““SQL Server -> IP -> -> 7z
<< > CQadmin “<sQL
Server 7z test ““SQL Server
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SQL Server BB — CQadmin

) ]ﬂ&%ﬁ%ﬁae]ﬁﬁmﬁl
m? BFRIM]: Cadrmin
B{rdair
=
=
-
=
=
WP
BAmE
e EFAIR S S NEHEE .
SIEEED): | master j
BEIL) | Simplified Chinese |
TR B | ®Em |
““db_owner>” “c 7z
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5QL Server BBt — CQadmin
Bl | BE8Eac 'kr- thlE ]
EE BT LG ISR EE(S)

Al BEE AP

OB medb
O E pubs
tempdhb
VI F&DE Chadmin
W B EEDE  CQadmin

- COl admin 5
“HLR I EE R E A A (D).
EHEE RS PMRIT |A
€ public
€ db_owner |
(1€ db_accessadmin
(1€ db_securityadmin
] €% db ddladrmin b

WiE B4 = |

DB ClearQuest Designer

CQadmin test
““db_owner~”

SQL2000

Rational ClearQuest

CQ ClearQuest
CQ Web
1 Rational ClearQuest Maintenance Tool
ClearQuest

Tool cqdbsetup.exe

Designer CQ

Rational ClearQuest Maintenance
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s’lRatinnal ClearQuest Haintenance Tool

File Commection Schema Repository Help

et % N Qa2 e

Exizting Connections:

The dialog shows the properties of the schema repositery for the

3 : . .
=~ Feim currently selected connection. To make or modify conmections and
SjmchroF]..lJWl[ll]Lif schema repositories, use the menus or toolbar.
Schema Repository Froperties for “COSchem™
Yendor: | J
Physical Databaze Name: ETRES
Database Server Name: |j ash
Bead-Only User Hame: |CQad.min
FRead-0nly User Fassword: |*>Mc*
| meir | 250
cQ
11
1 ““Schema Repository->Create”” Create

ﬁiRatiunal ClearQuest Naintenance Tnu* — Create [#EIRHIEE]
File Comnection Schema Repository Help

e
=

Exiszting Connections:

Enter the properties of the new schema repesitory. If the vender
type of the new schema repository iz not Microsoft Access or SAL
Anywhere, you must have created a physical database on your
databasze system prior to running this wizard.

CQS chem

Schema Reposzitory Properties for "fIERHIBIEE"

Vendor:

Physical Database Hame: |ﬂﬁu§
Database Server Name: |_-| azh
Administrator Hame: |CQadmin
hdministrator Fassword: |*m:|c
Fead/frite User Hame: |CQadmin
Readfrite User Password: |****
Bead-Only User Hame: |CQadmin
Eead-0Only User Fassword: |****

FT—Fmw > Cancel #ERBh
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““Create sample database”” “c 7

=101 %]

File Connection SchemaRepository  Help

%'&;’ ﬂ’|x-'? %Bgu:ahﬁ%}n

Existing Conmections:

fhen wou create a new schema repository, Clearfuest also allows
wou to create a sample database, populated with sample records,
that matches the default schema.

Tou could later use the ClearBuest Designer to create one by
wourzel £

[~ Lreate zample datahasel

Schema to use: IEnterprise j

Database Hame: ISAHPL

Deseription:

< _E—# (B I W I Cancel | FEHD |
)

1 2
CQ Maintenance Tool

1 ““Connection->New”” New Conncetion
2 Existing Connections Vendor SQL_SERVER Physical
Database Name Database Server Name

1P Read-Only User Name CQadmin Read-Only User
Password test ““Finish””
1 3

Maintenance Tool

CQ Designer
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Eational ClearQuest Schema Eepo... rs_(|

Schema Repository(s]

chem

Synehr oF LW,

Hext > | Cancel Help

2 Rational ClearQuest Designer

CQ Designer CQ
Basic  Perl

2 1 CQ Designer

Rational ClearQuest Designer cqdesign.exe
“ 7 User Name
Password 2.4 ““ok””

Open Schema - Step 1 of 2 2] x|

. Checlout = zchema to edit or
icontimme editing previonsly sawed work

1 wxx wxx
: g::: s {" Wiew a version of an existing schema.
o mmx xmx
Schema Latest | Che~
Name Yersion C

1 [EEL]A 2 bt —
2 |Commuon 1 No

3 |DefectTracking 1 No

A 1

4

.ﬂ.n-u.hi-niﬂ'h-.rlin

Ao
%

[¥ Show this wizard at startup

<o m=m | mm | mm |

admin

Designer

Schema Schema Name
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check out check 1in
Version 1
1 ““File-> New Schema”~
2 schema list DefectTracking, version 1 “c 77
3 Schema Name test comment << > ce »>
4 database €< 2 cc 2>

5 check out database <7

6 Test

2 3

2.2

““Database->New Database”” Database

2 Logical Database Name test ( 1-4 ) Comment

3 Vendor SQL_SERVER Physical Database Name test Database
Server Name IP test

test ““Production Database”” “ 7

4 Timeout Poll Interval 0. “ 7z

5 test “ 7z

6 ““Database was created successfully””

7 check out e 7z

2 4

cQ
CQ Designer ““Tools->User Administration”” User
Administration
0K
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2 4 1
User Administration Group Action
Add Group Add Group

Dzer Administration §|

Search Search Keyword: | Search

Users

Login Hame | Masterzhip Desecription

ﬁ admin lacal > _ -

ﬁ Engineer lacalr leer seitiom

ﬁlead “local ¥

ﬁQE “local ¥ .

Group b hd
ﬁuser “local ¥ oup Action
ﬁ 22 lacalr
& TS Jocal B Action ¥

Ttilities ¥
< | >
Groups:
Hame Mastership
MfizeH docal >
0 TEL
O Fed Local? 0K
0 EREEE
Cancel
Help
4 | >
name “e i Active
MembershipGroups MembershipUsers
Subscribe ““All existing and future databases”~”
““Select databases””
““New User”” 2.4.2
“Apply,, “OK’,
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2 4 2
User Administration User Action
Add User Add User
Add User 3 3
. Privileges=
Login: |zwp £
[wlhctive User ~
Password: |**** [(Dynamic Lizt Adminiztrator
[JFublic Folder Administrator
Confirm Fassword: |**** []5QL Editer
_ [User Administrator B
Lz |ﬂ;ﬁﬁ [JSchema Desizner
.. Wa11 Near=fGranmms Vizihla b’
E-mail: |zhanwanpin2l:||:|3@hntmail. com
Clear A11
Fhore: |
Mastership: [Local> | | Subscribe

(" M1 existing and future databazes
(¢ Select databazes

[Uzer
[JTL

Description:

Groups: filiaE
CF &8

Clear #11 Checlt 411
Add User Clear ALl | T Cancel | Help |

Login zwp Login Groups
Privileges
Subscribe
Add User OK
3
““DB Action”” Upgrade Upgrade
OK
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Rational ClearQuest Designer ““File->Open Schema””
test < >?  Comment <«
72 test
Defect Record
Types->Defect Defect

=

=iy Rational ClearQuest Designer

File Edit Wiew Database Tools Package ‘Window Help
|| poje| BE| v|&2] 5 |=8E] ] X

El--a test, wersiom &
. Schema Properties
a Record Types
EE Defert
- Fields
D States and Ac
D Farms
D Record Seript
[+ acord lypes — ate
----- D Record Type Familie:
EEI---D Global Seripts
----- D Dynamic List Hames

File->Save Work File->Check In

Database->Upgrade Database €< 7
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Upgrade Database - Step 2 of 2 il
Choose the new schema werszion mumber for the
databaze. This list shows only the schema
versions later than the ome used by the
selected databasze. This list does not show
the most recent schema werszion 1f 1t 1=
currently checked out.
Yersions:
<t—sm| = | mm | m=m |
2 51 Fields
Defect Fields
Field Name Type Default Yalue | Permission |Value Change,
otate STATE
version INT
lock wversion INT
locked by INT
history JOURNAL
is_duplicate INT

unduplicate state

SHORT_STRING

Headline

SHORT_STRING

Description MULTILINE_STRING
Priority SHORT_STRING
Severity SHORT_STRING
Submitter REFERENCE BASIC.PERL
Submit_Date DATE_TIME BASIC,PERL
Owner REFEBRENCE
old_id SHORT_STRING
Keywords MULTILINE_STRING
Symptoms MULTILINE_STRING
MNote Entry MULTILINE_STRING BASIC,PERL
klatmnn | ~nnm LALII TII IRIC COTMIRIT
Type
id 8 id
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State State 2.6.1
Headline

Description

Priority

Severity:

Submitter

Submit_Date

Owner

Symptoms
Note Entry
Notes_Log
Attachments

1 Add Field

DefectFields - R M EE £

wl c@ Thiz dialog box contains properties for the
zelected field .

General |]'[elp Text I
Field Hame: |ﬁT3iﬂﬂﬂf
IE Column Hame: Ikcxxl

Type: [SHORT_STRING |
[v ¥isitle in Gu
Owned By Hone

Maximum Length ISEI

2 Field Name “ 7> DB Colunmn Name

kexx  Type SHORT_STRING

Field Name DB Column Name Type
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Kexx
Mk
Xt
Tjsj
Bb
Choice List

Choice List

Production Database

Production Database = Test Database CQ

Master
Master SQL SERVER
DB DB Production Database
CQ Master
Schema
Test Database Schema
CQ Designer CQ
ClearQuest Maintenance Tool Schema
Designer Schema
CQSchema  Schema Schema
Schema CQ Designer Database
CQ

Production Database

SHORT_STRING
SHORT_STRING
SHORT_STRING
SHORT_STRING
SHORT_STRING

Test Database

Test Database

Test Database  Master
CQ
Production Database
Schema CQ
““New Database””

710075
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New Databasze — 5S5tep 1 of 4 ISE

The Hew Databasze wizard creates a logical database for
wou. Tou must create a physical databasze on wour
databaze system prior to runming this wizard

Logical Database |TEST
Hame:
Comment
REFRIIEE I R ENAER
FT-#w | B# | #B |
Producation Database Logical Database Name SQL Server
SQL Server CQ
““Comment””
Logical DatabaseName 5
Schema
38 A
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New Databaze — S5tep 2 of 4 r5_<|

Flaaze anter properties for the physical

databasze.

Vendor: |SQL_SERVER |
Physical Databaze Hame: |F=|:'|:|':|]]]3

Database Serwver Name: |ja5h

Administrator Wame: [CQadnin

Administrator Fassword: |****

FeadMrite User Hame: |I:Qadmin

Readffrite User Fassword: |****

% Production Database ‘/

{ Test Database [(This does HOT hawe your production data)

<t—s@[F-fw>] By | =

““Producation Database””

Producation Database “e 7z

Producation Database

Master Schema Schema

Producation Database

New Databaze — S5tep 4 of 4 r5_<

A schema must be associated with the new databasze. FPick
a schema from the following list to associate it with
the new database. HNote that the checlked-out schemas are
not shown on the list.

Schema Schema |Checked|Checked On#
Hame Terzion Ot Owner
4 |AnalystStudia 1 Ho
5 |Dewel opmentstudia 1 Ha W
TestItudia
T |UnifiedChangzeManazement |1 Ho
5 |Ent erprise 1 Ho
9|
i v
A L] >

< E—# (@) | FERl | K #ERh
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““TestStudio”” Schema
Schem ClearQuest Maintenance Tool Schema Repository
Master Schema Name Schema
CQ
Test Database ““Test Database””
New Databaze — S5tep 2 of 4 [5_(|

Flease enter properties for the physical

databasze.

Vendor: |5QL_SERVER ~|
Phy=zical Databaze Name: |i_|1I]H]]B

Databasze Serwer Hame: |j35h

Adminiztrator Hame: [CRadmin

Administrator Password: |****

ReadfMrite User Hame: |I:Qadmin

Read/Mrite Uzser Fazsword: |****

(" Froduction Databaze
@ Tect Databaze (Thiz does HOI hawve gyour pr

< E—# (B) |'F—*¢_E () >| HLiH #EEh

ClearQuest

Eational ClearQuest Login

S
User Hame |ﬂ;ﬁﬁ

Pazzword |****

x]

Database

fzer - HRIRHARRAT E |

0K | Cancel Help |
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web

web

AHD WeD BEn TR IAD R 1
LI, B - | “ 3 & - B . 3 m[@
Rl ik =0 EEE wE b LA D -
W) (] e L Best ot gt = &

|_QESCROMENAP NN SANIADCHIEEON  CLESPCURNTHOME  HELP- ARol

the s-development company™

Rational® ClearQuest”’

ClearQuest Web Logan

User Name
Password
Schems Fepository [MEiRsrN =
o
futohame Test - WOEEE =]
Logen | Refreshbblin

0 Capyright 1598 - 2001 Ralional Software (omontion
ALL RIGHT S RESERVED See “Ab<n Boo” Ror logal rofices

&Ratiunal ClearQuest EHaintenance Tool

IS8 Connection Schema Eepository Help
ﬁ Import Frofile | @Jh. # Q-“
Export Frofile E

Q%@'ﬁ CEEET 1a the properties of the =zchema repository for the

Exit

= T ] o d conmection. Te make or modify commections and
kgl oynichro H connection [fEJAZR =] # ] es, use the menus or toolbar.

Schema Kepository Froperties for "COSchem™

Yendor: | J

Phy=ical Databasze Name: B RIEE]

Databaze Serwer Name: |_] ash

Bead-Only User Hame: |CQadmin

Read-Only User Fassword: |****

Exit R/
Export Commection(s) to Profile
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