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本指南介绍如何安装 NI-DAQ 7.0 驱动软件和数据采集设备（DAQ），并确
保你的设备正常运行。 

本指南不适用于在苹果机操作系统（Mac OS）上使用的 NI-DAQ产品。有
关用于苹果机操作系统的 NI-DAQ产品的信息请查阅相关发行物。 
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约定 

下列约定适用于本手册： 
  该标志引导您进入子目录及从对话框选项中选择执行最终操作。如菜单

 
 

等

N
 

»»

File>>Page Setup>>Options即告诉您按下 File菜单，选择 Page Setup选
项，最终选取 Options执行。 

       这个图标表示提示，即给您一些参考信息。 

    这个图标表示注意，请您注意一些重要信息。 

                这个图标表示警告，建议你采取预防措施防止意外事故，数据丢失或者 

系统崩溃的发生。 

粗体字表示您可在软件中选择或点击的选项，即表示菜单名、对话框选

项、和 LED 
 

斜体字表示变量、注意事项、参考或词汇表中的词条。同时也表示您必

需键入的文字或数值。 字 
斜体
等宽字体表示您应键入的文本或字符，同时表示部分代码、编写例程及 
句法例程。等宽字体也用作驱动器、路径、函数、操作、变量、文件名、 
等宽字体
粗体字
扩展名和代码摘录所对应的名称。 

这种格式字体表示计算机自动显示在屏幕上的信息，也可以用于强调不

同于其它例程的代码行。 
等宽字体黑体 

这种字体表示你必需键入的文字或数值 宽字体斜体字
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从哪里开始 

图 1说明了安装 NI-DAQ 7.0 和 DAQ设备的步骤，以及在本文档何
处可以找到相关信息。 
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查对 NI-DAQ 7.0 的 Readme文件中所列出的 NI-DAQ 7.0支持的操作系统、应用

软件、编程语言和设备，以了解在你的应用中要安装和使用 NI-DAQ 7.0哪些部分。

如果你现有的应用中包含不被支持的部分，请你不要安装 NI-DAQ 7.0。 

图 1 安装过程概述 

*关于设备信号和终端连接的帮助信息，可在线从测量与自动化管理器帮助中的传统 NI-DAQ 部分和

测量与自动化管理器帮助中的 NI-DAQmx 部分查阅。这些帮助信息可以通过测量与自动化管理器

（MAX）帮助菜单访问。另外，设备信号连接和附加信号的信息在设备文档中。这些文档可从设备

文档浏览器中得到。使用这些设备文档，参考使用说明中步骤 10.浏览和安装设备文档。 

至此，你已经完成你设备的安装和配置。

NI-DAQmx传统 NI-DAQ 

使用 DAQ助手（从 MAX或者 NI应用

软件中启动）配置通道和测量任务。查

阅 DAQ 助手帮助和测量与自动化管理

器帮助的 NI-DAQmx部分。 

使用 MAX 来配置通道。有关传统

NI-DAQ，查阅测量与自动化管理器的

帮助。 

根据本指南中所述方法配置通道。你

用何种 API为每个设备编写程序？ 

不需要

需要 

根据 SCXI 快速入门指南或者 NI

开关入门指南中所述方法，安装、

配置与测试该模块和/或机箱

你需要安装 SCXI或者开关模块吗? 

按照本指南所述方法安装、配置和测试你的 DAQ设备。在测量和自动化管理器（MAX）

的帮助文件中有关于传统 NI-DAQ和 NI-DAQmx的有用信息与设备终端的帮助。 

按照本指南中的使用说明安装你的驱动软件和文档。

阅读有关新的 NI-DAQmx应用编程接口（API）和指南中所描述的其它 NI-DAQ 7.0 API。

不需要 

需要 

按应用软件中

使用说明升级

根据 NI-DAQ 7.0 的 Readme文件，确认你已经安装的

应用软件版本是正确的。你需要升级吗?             



 
 

 

NI-DAQ 7.0 软件 

国家仪器测量设备是与 NI-DAQ 驱动软件包装在一起的。这些驱动软件是一个
很大的函数和 VI 库。从你的应用软件，如 LabVIEW 或者 LabWindows/CVITM

中可以调用这些库来编程，实现你的 NI 测量设备的所有特性。测量设备包括
DAQ设备，如 E系列多功能 I/O设备（MIO）、SCXI信号调理模块和开关模块。
驱动软件提供应用程序编程接口（API）。该接口是一个包含各种 VI、函数、类、
属性和特性的库，来为你的设备创建应用程序。 

NI-DAQ 7.0产品包括两个 NI-DAQ驱动程序。每一个驱动程序都有它自己
的 API、硬件配置和软件配置。 

z 传统 NI-DAQ 是 NI-DAQ 早期版本的升级。传统 NI-DAQ 具有与
NI-DAQ 6.9.3相同的 VI和函数并且以同样的方式工作。不同之处是你
可以在同一台计算机上使用传统 NI-DAQ 和 NI-DAQmx，而 NI-DAQ 
6.9.3不能。 

z NI-DAQmx是最新版的 NI-DAQ驱动程序。它拥有新的 VI和函数以及
编写测量设备程序的开发工具。 
NI-DAQmx具有以下超越传统 NI-DAQ的优点。 
- DAQ助手—— 用于 LabVIEW、LabWindows/CVI和Measurement 

Studio，为你的设备配置通道和测量任务的图形化方式。你也可以
使用 DAQ助手，为 NI应用程序的任务生成 NI-DAQmx代码。 

- 性能上的增强，包括更快的单点模拟 I/O和多线程。 

- 更简单，更直观的 API，创建 DAQ应用程序比 NI-DAQ的早期版
本使用更少的函数和 VI。 

- 扩展了 LabVIEW 的 NI-DAQmx API 功能，包括数据采集的属性
（property）节点以及改进了支持模拟 I/O的波形数据类型。 

- 为 ANSI C、LabWindows/CVI和Measurement Studio提供类似的
API和功能，包括内在的.NET 和 C++ 接口。 

可以使用 NI-DAQmx的用户 

如果满足下列条件可以安装和使用 NI-DAQmx: 

z 使用的是Windows操作系统。 

z 仅仅使用 PCI或者 PXI E 系列多功能DAQ设备和/或我们支持的 SCXI
或者 SCC模块。 

©National Instruments                                                  NI-DAQ 7.0快速入门指南 
 

5



 
 

z 如果你正在使用 NI 的应用软件，如 LabVIEW、LabWindows/CVI 或
Measurement Studio，为了使用 NI-DAQmx你必须采用这些应用软件的
7.0版或者更新的版本。 

  注意  如果你使用Measurement Studio .NET中的语言，你必须使用 NI-DAQmx。 

必须使用传统 NI-DAQ的用户 

如果满足下列条件之一，请安装和使用传统 NI-DAQ: 

z 有 NI-DAQmx不支持的设备，比如 AT E 系列多功能 DAQ设备，数字
I/O（DIO）设备和动态信号采集设备。 

z 在加速计、线性电压微分转换器（LVDT）或者旋转可变微分转换器
（RVDT）虚拟通道中使用了 NI-DAQmx 不支持的 SCXI-1530、
SCXI-1531或 SCXI-1540设备。 

z 使用 LabVIEW实时（RT）模块。 

z 打算从 NI-DAQ 6.9.x升级并且不想更新现有的应用程序。 

z 使用 LabVIEW、LabWindows/CVI或者 Measurement Studio7.0以前的
版本。 

z 使用 Visual Basic 6.0。 

 注意  传统 NI-DAQ 支持 NI 应用软件的最早版本是 6.0 版。LabVIEW、
LabWindows/CVI或者Measurement Studio 6.x版可以使用 NI-DAQ 7.0所售产品中的传
统 NI-DAQ。 

传统 NI-DAQ不再支持的产品 

下列 NI-DAQ 6.9.3支持的产品，传统 NI-DAQ已不再支持。 

z NI LabVIEW、LabWindows/CVI或者Measurement Studio应用软件 6.0
以前的版本。 

z Windows 95 操作系统。 

z 一些老设备，比如 1200 系列多功能 DAQ设备、VXI DAQ 设备或者
远程 SCXI设备。 

关于支持和不支持的产品列表，可查阅本指南后面的 NI-DAQ 7.0支持的操作系统、应
用软件、编程语言和设备支持一节。 
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NI-DAQ如何和你的系统配合 

图 2 是测量系统概述，说明你用于测量真实世界中物理量的系统的组成。 

测量应用 
应用软件 

LabVIEW、LabWindows/CVI、Measurement Studio或者其它编程环境 
应用程序编程接口（API） 

NI-DAQmx、传统 NI-DAQ、NI-SWITCH或者其它 API
配置测量与

自动化管理

器（MAX） 驱动引擎 
NI-DAQmx、传统 NI-DAQ、VISA等 
数据采集与模块化仪器 

 
PCI                 PXI             PCMCIA 

信号调理 

 
PXI/SCXI组合机箱           SCXI           SCC 

传感器和变换器 

 
现实的信号和物理量 

图 2 测量系统概述 

计算机通过测量设备接收原始数据。信号调理部分使用传感器和转换器调理待

测物理量，使测量设备更加容易接收数据。软件采集这些原始数据，以可以理

解的形式显示它们；对数据进行处理，使数据可以图形、表格或者文件的形式

形成报表。软件也对测量系统进行控制，通知测量设备应何时以及从哪个通道

采集或生成数据。 

NI 测量设备和应用软件是与 NI-DAQ 驱动软件集成在一起来编程实现你的 NI
测量设备全部功能，比如配置、采集、从 NI 测量设备生成数据和发送数据到
NI 测量设备。使用 NI-DAQ 使你不必亲自编写这些程序。应用软件，如
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LabVIEW，发送命令到驱动程序，例如采集和返回一个热电偶读数，然后显示
和分析采集数据。 

你可以在 LabVIEW或者任何支持 ANSI C接口的动态链接库（DLLs）调用的
编程环境中，使用 NI-DAQ 的驱动程序。无论编程环境如何，你的 DAQ 应用
程序都可以如图 2 所示地使用 NI-DAQ。 

步骤 1. 确认您已安装合适的应用软件版本 

如果您打算使用 NI 应用软件（LabVIEW、LabWindows/CVI 和 Measurement 
Studio），请立刻安装它。对于 NI-DAQmx，你必须使用 NI应用软件的 7.0及以
后的版本。而对于传统 NI-DAQ，你可以使用 NI应用软件的 6.0及以后的版本。
有关这方面内容,请查阅位于本指南后面的 NI-DAQ 7.0 支持的操作系统、应用
软件、编程语言和设备一节。 

 提示  如果你现在有一个早期版本的应用软件或者 NI-DAQ编写的应用程序，请先
给应用程序作一个备份。然后你可以升级你的软件，修改你的应用程序。如果你想用

那个具有传统 NI-DAQ API的未修改的原应用程序，你就可以用到这份备份了。 

步骤 2. 如果您想要将版本升级，请卸载 NI-DAQ 

如果你打算从以前的版本升级到 NI-DAQ 7.0，在安装当前版本之前请先卸载
NI-DAQ 的早期版本。这可以通过选择控制面板》添加或删除程序（Control 
Panels>>Add/Remove Programs）来完成卸载操作。登录 ni.com/support/install
可查阅有关具体操作系统的卸载方法。 
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步骤 3. 安装 NI-DAQ 7.0软件 

插入本 CD 

 
NI-DAQ 7.0 安装程序将自动打开运行。如果没有自动运行，选择开始》运行
（Start>>Run）。然后键入 x:\setup.exe，这里 x是指本 CD所在光驱盘符。有关
疑难解答和具体操作系统的使用说明，请登录 ni.com/support/install查阅硬件安
装向导。 

 警告  如果你现有的应用程序中含有不被支持的组件，请不要安装 NI-DAQ 7.0。
安装软件之前，请查阅 NI-DAQ 7.0 CD中的 NI-DAQ 7.0 Readme 文件或者位于本指
南后面的 NI-DAQ 7.0支持的操作系统、应用软件、编程语言和设备一节。 

 提示  在安装新设备之前安装你的驱动软件，否则Windows将检测不到你的设备，
并且你会看到要求你安装驱动程序的警告信息。 

选择要安装的 API/s 

 警告  NI-DAQ 7.0 不能与早期版本的 NI-DAQ 共存与同一个系统中。当你安装
NI-DAQ 7.0时，传统 NI-DAQ将取代 NI-DAQ 6.9.x及其以前的版本，以及这些早期版
本已安装的所有支持文件。当你安装 NI-DAQmx时，老版本 NI-DAQ将被删除。 

NI-DAQ 7.0 包含几种驱动程序和它们的 APIs——传统 NI-DAQ、NI-DAQmx
和 NI-SWITCH。你可以安装其中任何一个或者全部驱动程序，这取决于你使用
的设备。这方面信息可以查阅在本指南开始处的 NI-DAQ 7.0软件一节中关于传
统 NI-DAQ和 NI-DAQmx部分的说明。 

安装 NI-SWITCH 后，可以用它为 NI 开关模块编写程序。NI-SWITCH 是符合
IVI 的开关仪器驱动程序，它支持所有 NI 开关模块。NI-SWITCH 有一个交互
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式软件前面板，用于测试开关应用程序和排除疑难问题。NI-SWITCH 2.0要求
你安装 NI-DAQmx和 NI-VISA 3.0。 

安装支持文件 

NI-DAQ 7.0安装程序会自动检测系统中已安装的 NI软件，并且从该 CD中自
动选择最新版本的驱动程序、应用软件和语言支持文件。 

 

1. 检查安装程序检测和选择的正确支持文件与应用软件和（或）语言的正确
版本号。双击一个特征项前面的加号可以展开子特征项的列表，如上图所

示。你可以选择附加选项来安装支持文件、范例和文档。请按照软件的提

示操作。 

 注意  如果你先安装 NI-DAQ 7.0，后安装 NI应用软件 7.0版，那么你需要再次运行
NI-DAQ 7.0安装程序安装正确的应用软件支持文件。 

2. 单击 完成（Finish）。 

3. 当安装程序完成时，会打开一个消息提示框问你是否想立刻重新启动计算
机。单击否（No），然后关闭计算机。 
如果你需要安装 RT系列的产品，登录 ni.com/support/install查阅

硬件安装向导中有关 RT系列产品的安装说明。 

4. 关闭电源，拔掉计算机或者 PXI机箱插头。 
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步骤 4. 打开设备、附件和电缆的包装盒 

你的设备装在一个抗静电包装盒中，可以防止对设备造成静电损害（ESD）。ESD
可能会损害设备中的一些部件。 

 警告 不要触摸连接头暴露在外的引脚。 

为了避免 ESD损害，请采取如下预防措施： 

z 用一条接地的导线或者抓住一个接地的导体让你自己接地。 

z 从包装盒中取出设备之前先让抗静电包装盒与计算机机箱的金属部分

接触一下。 

从包装盒中取出设备，检查一下设备中有没有松动的部件或者 看有没有损坏迹
象。如果设备看起来有任何损坏请通知 NI。不要在计算机、PXI机箱或者 SCXI
基座中安装已损坏的设备。 

当设备不再使用时，请将设备存放到抗静电包装盒中。 

有关安全性和适应性的信息，可以查阅该设备文档中步骤 10. 浏览或安装设备
文档。 

步骤 5. 安装设备、附件和电缆 

如果你打算要安装多个 DAQ 设备，现在可以都安装上。关于你设备硬件规范
的更多信息，比如插槽规格，可以查阅该设备文档中步骤 10. 浏览或安装设备
文档。 

如果你的系统包括开关或 SCXI信号调理模块（这些模块将被连接到 DAQ设备
上），请首先根据本指南安装 DAQ组件。 

 注意 下列使用说明不适用于 RT系列产品。登录 ni.com/support/install

查阅硬件安装向导可以得到 RT系列产品安装说明的帮助。 
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PCI 设备 

 警告 请确保计算机电源是关闭的。在安装硬件之前，请遵循正确的 ESD 预防
措施确保你是接地的。 

安装 PCI设备须完成以下步骤。 

1. 打开计算机机箱盖和扩展插槽盖。 

2. 触摸计算机机箱的金属部分以释放静电。 

3. 将设备插入 PCI系统插槽。要逐渐地将设备插入到插槽的正确位置，不要
以强力将设备插入。 

 

1 PCI DAQ板       3 PCI计算机 
2 PCI系统插槽 

4. 用螺丝将设备支架固定在计算机后面板托架上。 

5. 重新装上计算机机箱盖。 

至此，你的 PCI设备安装完成。 
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PXI 设备 

 警告 请确保 PXI机箱电源是关闭的。在安装硬件之前，请采取正确的 ESD预
防措施确保你是接地的。 

安装 PXI模块须完成以下步骤。 

1. 打开未使用的 PXI插槽的填充板。有关插槽规格的信息可以查阅该设备文
档中步骤 10. 浏览或安装设备文档对的描述。 

2. 触摸机箱的金属部分以释放静电。 

3. 将设备插入 PXI插槽。用按入/弹出器（injector/ejector）的把柄将设备完全
插入槽中。 

4. 用螺丝将设备前面板固定在机箱前面板托架上。 

 

1 PXI 机箱     3 处于按下位置的按入/弹出器把柄 
2 PXI模块 

 

至此，你的 PXI设备安装完成。 
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PCMCIA 设备 

你可以将NI PCMCIA设备安装在任何可用的 II型 PC卡插槽中。安装 PCMCIA
设备须完成下面的步骤。 

 警告 确保计算机电源是关闭的。如果你的 PCMCIA 支持热插入，那么计算机
电源可以是开着的。在安装硬件之前，请采取正确的 ESD预防措施确保你是接地
的。 

1. 如果你的计算机上有 PCMCIA插槽盖的话，请移走。 

2. 将 PCMCIA设备的 PCMCIA总线插头稳固地插入到插槽中。NI PCMCIA
设备有两个插头，一端是 68 针 PCMCIA总线插头，另一端是 I/O插头。
PCMCIA设备是键控的，所以你只能以一种方式插入。 

3. 连上 I/O 电缆。要注意在插入或拔出电缆连接头时不要拉伤 I/O 电缆。你
在插入或者拔出电缆时应该一直抓的是电缆的连接头。将它从 PCMCIA设
备上拔出时不要直接拉 I/O电缆。 

 

 

1. PCMCIA 计算机    4 附件 
2 PCMCIA 插座     5 I/O信号 
3 I/O电缆 
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至此，你的 PCMCIA设备安装完成。 

USB/IEEE 1394 设备 

 警告 在安装硬件之前，请采取正确的 ESD预防措施确保你是接地的。 

 注意 如果你正在使用 BP-1 电池组，请按照你的 BP-1 安装指南中的安装方法
操作并略过本指南中的步骤 1。如果你没有使用 BP-1电池组，则下列用法说明是
正确的。 

安装 USB或者 1394接口的 NI设备须完成如下步骤。 

1. 一些 USB或者 1394接口的 NI设备需要外部电源。 

z 如果你的设备有外部电源，请检查该外部电源电压，并使你所在

地区的电压（120或 230VAC）与你的设备要求的电压相匹配。然
后将电源一端连接到供电插座上，另一端连接到你的设备后面。 

z 如果你的设备有电源线，请将电源线一端接到设备上，另一端接

到供电插座上。 

2. 从计算机的USB或 1394端口或者从其它任何一个集线器或 1394设备连接
电缆到你设备上任何一个可用的 USB或 1394端口。若有的话，拧紧固定
螺丝以稳固连接。再连接该 USB或 1394电缆的另一端到你设备上的 USB
或 IEEE 1394端口。下图图示说明了 USB电缆和它的连接头。 

 
1 计算机或 USB集线器端接头   3 设备端接头 

 

至此，你的 USB/IEEE 1394设备安装完成。如果你的 USB/IEEE 1394设备后面
板带有电源开关，你可以打开设备的电源了。 
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附件 

安装附件、端子板和（或）SCC模块请按照它们的安装指南中的用法说明操作。
对于 SCXI，在本指南中其用法一直说明到步骤 12. 加上传感器和信号为止。 

步骤 6. 打开你计算机或者 PXI机箱电源 

在安装完硬件后计算机第一次重启时，Windows操作系统可以自动检测到任何
一个新安装的设备。在一些 Windows 操作系统中，每一个 NI 设备被安装时都
会弹出发现新硬件对话框。缺省情况下，自动安装软件（推荐）【Install the 
software automatically (Recommended)】选项被选择。单击下一步（Next）或
者确定（Yes）安装每个设备的软件，这样Windows就能识别该设备了。 

当计算机检测到一个 USB或者 IEEE 1394设备时，该设备上的电源 LED指示
灯就会根据你设备的状态闪烁或者点亮。NI 的 IEEE 1394设备还有一个 COM 
LED 指示灯，当该设备被检测到时它就会闪烁。关于 LED 指示灯工作模式查
阅步骤 10。浏览或安装设备文档一节中对该设备文档的描述。 

步骤 7. 启动测量与自动化管理器（MAX） 

双击桌面上的测量与自动化管理器（Measurement & Automation Explorer）图标
可以打开MAX。 

步骤 8. 确认你的设备被识别 

1. 展开 设备与接口（Devices and Interfaces） 项。 

2. 检查你的设备在设备与接口（Devices and Interfaces）项下显现。 
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当一个设备传统 NI-DAQ和 NI-DAQmx都支持，且传统 NI-DAQ和 NI-DAQmx
都已安装时，该设备将以不同名字分别列在设备与接口（Devices and Interfaces）
项的传统 NI-DAQ和 NI-DAQmx文件夹下。如果你的设备没有出现，请按<F5>
刷 新 MAX 的 视 图 。 如 果 设 备 仍 然 没 有 被 识 别 ， 登 录
ni.com\support\install查阅关于排除疑难部分内容。 

3. 在存放你用来为设备编程的 NI-DAQ API的文件夹下，右击你想测试的设
备。 

z 如果该设备在传统 NI-DAQ文件夹下，那么选择属性（Properties），
然后单击该属性窗口中的检测资源（Test Resources）。 

z 如果该设备在 NI-DAQmx文件夹下，请选择自检（Self-Test）。 

 

4. 当自检完成时，如果有错误出现将弹出消息框指出。如果有错误出现， 登

录 ni.com\support\install查阅关于排除疑难部分内容。 
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步骤 9. 配置你的设备 

请配置你安装的每个设备。为了在传统NI-DAQ和NI-DAQmx环境下使用设备，
你必须分别在每个环境中配置设备的属性。 

1. 右击设备名，选择属性（Properties）。要确保点击了 NI-DAQ API 文件夹
下你要所用设备的设备名。 

2. 配置该设备属性。 

z 如果你使用附件，请加入该附件信息。 

z 如果你在传统 NI-DAQ 环境下使用设备，你可以改变 它的 AI、
AO、OPC或者远程入口的缺省设置。关于设备缺省设置的更多信
息请查阅你的设备文档在下一步骤中的描述。 

3. 点击 OK 接受修改。 

 提示 对于传统 NI-DAQ 和 NI-DAQmx 都支持的设备，你可以用传统 NI-DAQ 到
NI-DAQmx 的转换向导将传统 NI-DAQ 虚拟通道和刻度配置转换成 NI-DAQmx 配
置。该向导也可以转换 SCXI和附件配置，但不能转换 SCC配置。你必须为你要用
的每个 API单独配置 SCC信息。用法说明查阅 NI-DAQmx的测量与自动化管理器帮
助中关于将传统 NI-DAQ配置转换成 NI-DAQmx配置一节的内容。 

步骤 10. 浏览和安装设备文档 

NI-DAQ 7.0 软件产品中包括设备文档 CD。该 CD 包含被支持的 DAQ、SCXI
和开关设备的在线文档。设备文档包括描述设备端子、设备特征、设备操作的

帮助文件和设备文档的 PDF文件。你可以使用设备文档浏览器去查找、查看和
打印每个设备的文档。 

插入 NI-DAQ 7.0设备文档 CD，你可以在任何时候使用 NI-DAQ设备文档浏览
器。该 NI-DAQ 7.0文档浏览器有如下选项： 

z 浏览设备文档（Browse Device Documents）选项用于打开文档浏览器
和显示每个设备的设备文档。 

z 安装设备文档（Install Device Documents）选项用于将文档浏览器和所
有设备文档拷贝到硬盘上。安装后，浏览器可以从开始》程序》国家仪

器》NI-DAQ》浏览设备文档（Start » Programs » National Instruments 
» NI-DAQ » Browse Device Documentation）打开。 

如果浏览器没有自动打开，选择开始》运行（Start»Run）然后键入 x:\autorun.exe，
这里 x是该 CD所在光驱盘符。 
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 注意 要使用 NI-DAQ 7.0文档的某些特征，包括它的帮助系统和设备文档浏览
器，你必须有 Internet Explorer 5.0及以后的版本。 

步骤 11. 如果适用的话，安装 SCXI或者开关模块 

如果你的系统包括连接到DAQ设备的 SCXI信号调节或开关模块，请查阅 SCXI
快速入门指南和 NI 开关入门指南来安装和配置 SCXI和开关的硬件。 

本指南的剩余部分仅适用于带有端子板或者 SCC附件的 DAQ设备。 

 

步骤 12. 加载传感器和信号 

将传感器和信号连接到设备或者附件端子。 

有用信息可从下列文档获得： 

z 信号与端子连接： 

- E 系列帮助，设备用户手册的 PDF 文件和附件的 PDF 文件都在设备
文档浏览器上。 

- 引脚分配的信息在测量与自动化管理器帮助中传统NI-DAQ部分和测
量与自动化管理器帮助中 NI-DAQmx部分中，这些都可以通过MAX
帮助菜单访问。 

z  开关规格中包括了设备布局的信息。 

z  传感器的使用： 

- 如果你用 LabVIEW，那么这部分内容可查阅与 LabVIEW软件包装在
一起的 LabVIEW测量手册，或者登录 ni.com/manuals查阅。 

- 如果你使用其它编程环境和 NI-DAQmx，那么这部分内容可以查阅
NI-DAQmx帮助的传感器主题。你可以通过开始》程序》国家仪器》
NI-DAQ》NI-DAQmx帮助（Start » Programs » National Instruments 
» NI-DAQ » NI-DAQmx Help）来访问它。 

- 如果你使用其它编程环境和传统 NI-DAQ，那么这部分内 容可以查阅
传统 NI-DAQ 用户手册中的第五章 变换器的变换函数。你可以通过
开始》程序》国家仪器》NI-DAQ》传统 NI-DAQ 用户手册（Start » 
Programs » National Instruments » NI-DAQ » Traditional NI-DAQ 
User Manual）来访问它 

©National Instruments                                                  NI-DAQ 7.0快速入门指南 
 

19



 
 

步骤 13. 运行测试面板 

许多设备都有一个测试面板用于测试特定的设备功能，比如采集和生成信号的

功能。 

1. 打开MAX帮助查看测试面板操作方法。 

a. 在MAX中，无论你要测试什么，请先选择帮助》帮助主题》NI-DAQmx
或传统 NI-DAQ（Help » Help Topics » NI-DAQmx or Traditional 
NI-DAQ）打开MAX的帮助。 

b. 在内容选项卡中，展开测量与自动化管理器》MAX 去寻找你要测试
的 NI-DAQ 版本》Getting Started》DAQ 设备》测试 DAQ 设备
（Measurement & Automation Explorer » MAX for the version of 
NI-DAQ you will test » Getting Started » DAQ Devices » Testing DAQ 
Devices）。 

c. 单击测试 DAQ设备（Testing DAQ Devices）打开该测试面板的操作
方法的帮助主题。 

d. 缩小帮助窗口，将它拖到右边，以防覆盖MAX的配置窗口。 
2. 点击MAX使它成为活动窗口。 

3. 在传统 NI-DAQ设备或者 NI-DAQmx设备条目下，右击要测试的设备。 

4. 选择测试面板（Test Panels）打开一个用于所选设备的测试面板。 

 

下图表示的是一个测试面板的范例。 
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5. 点击测试设备不同功能的标签。点击 MAX 帮助窗口可以查看测试面板在
传统 NI-DAQ和 NI-DAQmx中的操作方法。 

6. 如果出现错误测试面板将会显示一个提示信息。有关疑难解答的信息可查
阅 NI-DAQmx索引帮助或者访问 ni.com/support。 

7. 当测试完成时，点击关闭（Close）或 OK关闭测试面板。 

步骤 14. 配置所有附加的新设备 

如果你安装了多个 DAQ设备，请重复执行步骤 9到步骤 13配置这些设备。 

步骤 15. 配置通道和任务 

一个实际通道是指一个端子或者引脚，在它上面你可以测量或者生成模拟或数

字信号。而虚拟通道是一个各种设置的集合，它可以包括设备名、实际通道、

输入端子连接、测量或发生信号类型和缩放比例信息。在传统 NI-DAQ及其更
早的版本中，配置虚拟通道是用来记录在不同的测量应用中哪些通道被使用的

一种可选的方式。而在 NI-DAQmx中，虚拟通道被整合到每个测量应用中。 
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在传统 NI-DAQ中，你可以用MAX配置虚拟通道。而在 NI-DAQmx中，你可
以用 DAQ助手配置虚拟通道。DAQ助手可从MAX或者你的应用软件中打开。
你也可以在你的应用程序中用 NI-DAQmx API配置虚拟通道。 

任务，NI-DAQmx中的一个重要的新概念，是指具有定时、触发和其它属性的
一个或多个虚拟通道的集合。从概念上说，任务代表了你要执行的测量或信号

生成。你可以在一个任务中建立和保存所有配置信息，然后在应用程序中使用

该任务。 

在 NI-DAQmx中，你可以将虚拟通道配置为任务的一部分或者将其从任务中分
离出来。在任务内部创建的虚拟通道称为局部通道。在任务外部定义的虚拟通

道称为全局通道。你可以在 MAX 或者你的应用软件中创建全局通道。然后可
以在任何应用程序中使用全局通道或者把它们加到各种不同的任务中。如果你

修改了一个全局通道，这种变化将影响所有引用了该全局通道的任务。大多数

情况下，使用局部通道更简单一些。 

 

 

 

在 NI-DAQmx中配置任务 

当你使用 NI-DAQmx时，可以用 DAQ助手配置任务。但你必须使用 NI应用软
件包 7.0版才能用 DAQ助手创建任务和通道。 

z 在MAX中，右击数据邻居（Data Neighborhood），选择新建（Create 
New），再在新建（Create New）窗口中，选择 NI-DAQmx 任务
（NI-DAQmx Task），然后点击下一步（Next）。 

z 你也可以直接从 NI应用软件里面打开 DAQ助手。 

- 在 LabVIEW中，有好几种方法可以打开 DAQ助手： 
z 从 Express Input选项板中将 DAQ Assistant Express VI拖下来。详情见

LabVIEW入门中相关描述。 

z 你也可以使用 DAQmx Task Name控件来打开 DAQ助手。右击该控件，
选择新任务（DAQ助手）【New Task（DAQ Assistant）】。在帮助教程
LabVIEW的“建立 NI-DAQmx测量”条目中即可查阅到关于如何使用
DAQmx Task Name控件创建任务和为该任务生成代码的指导步骤。在
LabVIEW 中，选择帮助》建立 NI-DAQmx 测量（Help » Taking an 
NI-DAQmx Measurement）可以打开该指南。 

- 在 LabWindows/CVI中，选择工具》创建/编辑 DAQmx任务（Tools » 
Create/Edit DAQmx Tasks）。 

- 在Measurement Studio中，打开 Visual Studio .NET，选择工程》增加
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新项目（Project » Add New Item）打开增加新项目对话框。然后在类
别（Categories）窗中，选择Measurement Studio》助手（Measurement 
Studio » Assistants.）。在模板（Templates）窗中，选择 DAQmx任务
类（DAQmx Task Class）。 

通过上述方法，即可打开 DAQ助手。 

 

接着按照在线帮助创建新任务。 

1. 选择 I/O类型，比如模拟输入。 

2. 选择要执行的测量或信号发生。 

3. 选择要用的传感器，若可用的话。 

4. 选择要加到该任务中的通道。你可以增加全局通道到该任务中，或者选择
实际通道，从中在该任务里创建局部通道。 

5. 如果必要，配置该测量的各种设置、定时和触发。 

6. 保存任务。 

z 如果你是从 LabVIEW或者 LabWindows/CVI中  打开 DAQ助手
的话，点击 OK。 

z 如果你是从Measurement Studio中打开 DAQ助手的话，选择文件》
保存（File » Save）。 

z 如果你是从 MAX 中打开 DAQ 助手的话，点击保存任务（Save 
Task）。 

现在你可以在应用程序中使用该任务了。关于使用任务或生成代码的更多信息

可以查阅 DAQ助手帮助或者应用软件文档。 
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为 NI-DAQmx配置全局通道 

当你使用 NI-DAQmx时，可以使用 DAQ助手配置全局通道。 

z 在MAX中，右击数据邻居（Data Neighborhood），选择新建（Create 
New）。在新建（Create New）窗口中，选择 NI-DAQmx 全局通道
（NI-DAQmx Global Channel），然后点击下一步（Next）。 

z 你也可以直接从 LabVIEW 7.0、LabWindows/CVI 7.0或者Measurement 
Studio7.0中打开 DAQ助手。 

- 在 LabVIEW中，可以用 DAQmx Global Channel控件来打开 DAQ助
手。右击该控件，选择新通道（DAQ 助手）【New Channel（DAQ 
Assistant）】。 

- 在 LabWindows/CVI 或者Measurement Studio中，你首先要按前面描
述的方法创建一个任务。然后在 DAQ助手中，点击增加现有 DAQmx
全局通道（Add Existing DAQmx Global Channels）将全局通道加到
你的任务中。 

通过上述方法打开 DAQ助手。然后可按照在线帮助创建一个新的全局通道。 

1. 选择 I/O类型，比如模拟输入。 

2. 选择要执行的测量或信号发生。 

3. 若可用的话，选择待用的传感器，。 

4. 选择待用的实际通道。 

5. 配置该测量的各项设置。 

6. 保存任务。 

z 如果你是从 LabVIEW或者 LabWindows/CVI中打开 DAQ助手的
话，点击 OK。 

z 如果你是从Measurement Studio中打开 DAQ助手的话，选择文件》
保存（File » Save）。 

z 如果你是从 MAX 中打开 DAQ 助手的话，点击保存通道（Save 
Channel）。 

现在你可以在应用程序中使用该全局通道或者将该全局通道加到一个任务中。

关于使用通道或生成代码的更多信息可以查阅 DAQ 助手帮助或者应用软件文
档。 

为传统 NI-DAQ配置虚拟通道 

当你使用传统 NI-DAQ时，可以在MAX中配置虚拟通道。 

1. 在MAX中，右击数据邻居（Data Neighborhood），选择新建（Create New）。 
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2. 在 Create New 窗口中选择传统 NI-DAQ 虚拟通道（Traditional NI-DAQ 
Virtual Channel），然后点击完成（Finish）。则打开创建新通道向导。 

 

3. 按照创建新通道向导中的帮助创建一个新通道。关于配置不同通道类型的
其它信息可以查阅测量与自动化帮助中传统 NI-DAQ部分。 

着手开发应用程序 

范例 

每个 API都包括一个程序范例集，帮助你入手开发应用程序。你可以修改这些
例程的代码，将它保存在应用程序中。你也可以利用这些例程开发一个新的应

用程序，或者将例程代码加到一个现有应用程序中。 

打开国家仪器范例寻找器（National Instruments Example Finder），可以查找
LabVIEW和 LabWindows/CVI的例程。 

z 在 LabVIEW中，选择帮助》搜索例程（Help » Find Examples）。 

z 在 LabWindows/CVI 中，选择帮助》NI Example Finder（Help » NI 
Example Finder）。 

Measurement Studio、Visual Basic和 ANSI C的例程在下列目录中： 

z 为 Measurement Studio 支持的语言编写的 NI-DAQmx 例程在以下目录
中： 

- MeasurementStudio\VCNET\Examples\DAQmx 
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- MeasurementStudio\DotNET\Examples\DAQmx 



 
 

z 为 Visual Basic编写的传统 NI-DAQ例程在以下目录中： 

- NI-DAQ\Examples\Visual Basic with Measurement Studio

目录包含一个到 ActiveX 控件例程的链接，这些例程可用于
Measurement Studio。 

- NI-DAQ\Examples\VBasic 目录包含的例程与 Measurement 
Studio无关 

z 为 ANSI C 编写的 NI-DAQmx 例程在 NI-DAQ\Examples\DAQmx 

ANSI C目录中 

z 为ANSI C编写的传统NI-DAQ例程在 NI-DAQ\Examples\VisualC
目录中 

 

有关其它例程请查阅 ni.com/zone。 

有关测量应用程序和设备的信息 

每个应用软件包和驱动程序都包含关于编写测量和控制测量设备应用程序的信

息。下面提到的文档假定你已拥有 NI-DAQ 7.0和 NI应用软件 7.0版。 

LabVIEW 

如果你是新用户，阅读 LabVIEW入门可获得 LabVIEW的相关知识。请选择开
始》程序》国家仪器》LabVIEW》搜索 LabVIEW书架（Start»Programs»National 
Instruments»LabVIEW»Search the LabVIEW Bookshelf）查阅这部分内容。 

LabVIEW测量手册则包含传统 NI-DAQ和 NI-DAQmx的 API概述，并且描述
了一些测量概念。选择开始》程序》国家仪器》LabVIEW》搜索 LabVIEW 书
架（Start»Programs»National Instruments»LabVIEW»Search the LabVIEW 
Bookshelf）查阅这部分内容。 

在 LabVIEW 中建立 NI-DAQmx 测量这一条目详细说明了如何在 LabVIEW 中
建立一个测量应用程序的步骤，并且描述了 NI-DAQmx的一些关键的新特征和
概念，比如 DAQ 助手和任务。在 LabVIEW 中选择帮助》建立 NI-DAQmx 测
量（Help»Taking an NI-DAQmx Measurement）可以打开该教程。 

LabVIEW传统 NI-DAQ VI索引帮助和 LabVIEW NI-DAQmx VI索引帮助描述了
LabVIEW 的 VI及其属性。 在 LabVIEW中，选择帮助（Help）和 LabVIEW 
VI索引帮助可以得到你要用的 NI-DAQ API 的信息。 

LabWindows/CVI 

LabWindows/CVI帮助的数据采集库（Data Acquisition Library）部分包含了传统
NI-DAQ和 NI-DAQmx的 API概述、测量概念和函数索引。在 LabWindows/CVI
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中，选择帮助》内容（Help»Contents）查阅这部分内容。 

Measurement Studio 

NI Measurement Studio帮助包含了 NI-DAQmx API概述、测量任务与概念和函
数索引。该帮助文件已被整合到Visual Studio .NET文档中。在Visual Studio .NET
中，选择帮助》内容（Help»Contents）查阅这部分内容。 

Measurement Studio索引包含传统 NI-DAQ API概述、测量概念和函数索引。在
Visual Studio .NET 中，选择 Measurement Studio》Measurement Studio 
Reference查阅这部分内容。 

没有安装 NI应用软件情况下的 ANSI C  

传统 NI-DAQ用户手册和 NI-DAQmx帮助包含 API概述。NI-DAQmx帮助还包
含测量概念的一般信息。传统 NI-DAQ C索引帮助和 NI-DAQmx C索引帮助描
述 了 C 函 数 和 属 性 。 选 择 开 始 》 程 序 》 国 家 仪 器 》 NI-DAQ
（Start»Programs»National Instruments»NI-DAQ）和你要用的 NI-DAQ API
文档的标题可查阅这部分内容。 

没有安装 NI应用软件情况下的.NET 语言  

NI Measurement Studio帮助中包含 NI-DAQmx API概述、测量任务与概念和函
数索引。该帮助文件被整合到 Visual Studio .NET文档中。在 Visual Studio .NET
中，选择帮助》内容（Help»Contents）查阅这部分内容。 

 注意 如果你使用.NET language 却未安装 Visual Studio .NET，你可能不能够浏览

NIMeasurement Studio帮助。 

设备文档 

NI-DAQ 7.0包括设备文档浏览器。该浏览器包含所支持的 DAQ、SCXI和开关
设备的在线文档，比如描述设备插脚引线、特征与操作的帮助文件和已印刷的

设备文档的 PDF文件。只需插入本 CD，任何时候你都可以使用设备文档浏览
器查找、查看和/或打印每个设备的文档。安装设备文档浏览器后，设备文档可
通过开始》程序》国家仪器》NI-DAQ》浏览设备文档（Start»Programs»National 
Instruments»NI-DAQ»Browse Device Documentation.）来访问。 
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SCXI和开关多基座配置 

SCXI-1346 隔离式多基座电缆适配器安装指南中包含开发 SCXI 和开关多基座
应用程序的设置方法说明。 

开关 

NI 开关帮助中包含了开关模块和 NI-SWITCH 仪器驱动的技术和程序设计支
持。 

NI-SWITCH仪器驱动快速索引指南中包含 API概述和函数/VI概述。  

培训课程 

如果你使用 NI的产品着手开发应用时需要更多帮助，NI将向你提供培训课程。
登录 ni.com/traning可以参加课程或者获得一份详细的课程提纲。 

技术支持 

登录 ni.com/support 或 ni.com/zone，可获得额外支持。 

在同一台计算机上使用传统 NI-DAQ 和 NI-DAQmx 

用 NI-DAQ早期版本开发的现有应用程序可以在传统 NI-DAQ下运行。符合下
列约束条件，你就能够在同一台计算机上使用传统 NI-DAQ 和 NI-DAQmx： 

z 一次只有一个 API控制一个特定设备。 

- 在 NI-DAQmx 中使用一个设备后，你不保留所有使用该设备的
NI-DAQmx 任务才能重新通过传统 NI-DAQ 使用该设备。不保留
NI-DAQmx任务可通过调用 DAQmx Clear Task VIs或者函数实现。 

- 在传统 NI-DAQ中使用一个设备后，你必须先复位该设备才能重新在
NI-DAQmx 中使用该设备。对于 SCXI 设备，你必须复位 DAQ 设备
通信机。 
z 调用传统 NI-DAQ Device Reset VI 或 Init_DA_Brds函数。 

z 要复位传统 NI-DAQ 中的所有设备，在 MAX 中右击传统
NI-DAQ设备（Traditional NI-DAQ Devices）文件夹，选择复
位传统 NI-DAQ驱动（Reset Driver for Traditional NI-DAQ）。 

z 在 SCXI数据采集系统中，你必须使用相同的 API为所有设备－连接的
DAQ设备和插入的 SCXI模块－编写程序。 
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登录 ni.com/support可获得以下主题的细节和帮助： 

z 如何将 NI-DAQmx代码加到传统 NI-DAQ应用程序中。 

z 如何运行使用相同设备的传统 NI-DAQ和 NI-DAQmx应用程序。 
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NI-DAQ 7.0 支持的操作系统、应用软件、编程语言

和设备 

NI-DAQmx 7.0版还不能支持全系列 NI测量设备。下一个 NI-DAQ发行版本将
对 NI-DAQmx中新设备和现有设备增加支持，并且将继续支持传统 NI-DAQ。 

支持的操作系统 

NI-DAQmx、传统NI-DAQ和NI-SWITCH 2.0支持Windows 2000/NT/XP/Me/98。
在 Windows NT 上运行的 NI-DAQ 7.0 要求 Service Pack 6 或更新的版本。
Measurement Studio要求 Visual Studio .NET 2003。而 Visual Studio .NET 2003要
求Windows 2000/NT 4.0/XP。访问 ni.com/support/install上的硬件安装向导可获
得关于具体操作系统的安装说明。 

登录 ni.com/downloads可以找到和下载支持其它操作系统的 NI-DAQ的早期版
本。 

支持的应用软件和编程语言 

表 1列出了 NI-DAQmx和传统 NI-DAQ支持的应用软件版本。如果你没有使用
NI应用软件，参阅表 2。 

表 1. NI-DAQ 7.0 支持的应用软件 

NI应用软件 NI-DAQmx 支
持的版本 

传统 NI-DAQ支持的版本 

LabVIEW  7.0  6.0－7.0 
LabVIEW RT模块  －  6.0－7.01 
LabWindows/CVI  7.0  6.0－7.0 
Measurement Studio  7.0  6.0－7.02 
1 LabVIEW RT用户的DAQ应用程序必须使用传统NI-DAQ。NI-DAQmx
的未来版本将会支持 LabVIEW RT。 
2 传统 NI-DAQ不包括Measurement StudioC＋＋或者.NET接口。 

 

 

表 2 列出 NI-DAQmx和传统 NI-DAQ支持的编程语言和版本。 

表 2.NI-DAQ 7.0支持的编程语言 

编程语言 NI-DAQmx 支 持
的版本 

传统NI-DAQ支持
的版本 
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ANSI C 
✓支持 ✓支持 

Microsoft Visual C++ Class libraries 
C DLL 

 
7.01 

6.0–7.0 

— 

6.0–7.0 
Visual Basic 6.0 （通过 ActiveX） － 6.0 
Microsoft .NET 语言 
(C# 和 Visual Basic .NET) 

.NET 1.1 
— 

1 要求Measurement Studio7.0版 
 

NI-DAQ的早期版本支持其它应用软件和语言版本。登录 ni.com/downloads
可以找到和下载驱动的早期版本。 

支持的设备 

对于特定设备模块的名字可查阅本 CD 上的 NI-DAQ 7.0  Readme 文件。表 3
列出 NI-DAQmx、传统 NI-DAQ和 NI-SWITCH 2.0支持的设备系列。 

表 3。NI-DAQ 7.0支持的设备 
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设备 NI-DAQmx 传统 NI-DAQ NI-SWITCH 2.0 
PCI和 PXI E系列多功能 DAQ设备，如 NI 
PCI-6052E  支持✓ 支持 不可用 

USB和FireWire(IEEE 1394)接口的DAQPad 
设备 

－ 
✓ 支

持 
不可用 

DAQCard E系列 PCMCIA设备 － 
✓ 支

持 
不可用 

NI PCI-6013/6014 16位基本型多功能 DAQ
设备 

－ 
✓ 支

持 
不可用 

S系列多功能 DAQ设备，如 NI PXI-6115 － 
支持 不可用 

数字 I/O设备，如 NI 653X系列设备 － 
✓ 支

持 
不可用 

NI PCI-4551、PCI-4552和 
PCI与 PXI-4472动态信号采集设备 

－ 
✓ 支 不可用 



 
 

持 
NI PCI和 PXI 671X/673X模拟输出设备 － 

✓ 支

持 
不可用 

NI 660X计数器/定时器 I/O设备 － 
✓ 支

持 
不可用 

NI SCXI-1530、SCXI-1531和 SCXI-1540信
号调节模块 ✓支持 1 支持 不可用 

所有其它 SCXI信号调节模块 
✓支持 ✓ 支

持 
不可用 

SCC系列信号调节模块 
支持 ✓ 支

持 
不可用 

NI SCXI-1166和 SCXI-1193开关模块 
支持✓ － ✓ 

所有其它 SCXI开关模块 
支持✓ ✓ 支

持 
✓ 

NI PXI-2566和 PXI-2593开关模块 
✓支持 － ✓ 

所有其它 PXI开关模块 － 
－ ✓ 

NI PXI-4204和 PXI-4220模块 
✓支持 － － 

1 这些设备在 NI-DAQmx中是支持的，但不支持创建加速计、线性电压微分转换器（LVDT）
和旋转可变微分转换器（RVDT）虚拟通道。 

NI-DAQ 7.0支持的新设备列表可查阅NI-DAQ 7.0 CD上的NI-DAQ 7.0 Readme
文件。 

NI-DAQmx未来发行版本支持更多设备 
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NI-DAQ的未来发行版本在 NI-DAQmx中将支持另外一些设备。这些设备目前
仅传统 NI-DAQ支持。 



 
 

仅限传统 NI-DAQ中使用的设备 

NI-DAQmx不支持下列设备，在 NI-DAQ以后的发行版中将会支持它们。下列
设备仅受传统 NI-DAQ支持。 

z AT E系列设备 

z AT-AO-6/10 模拟输出设备 

z AT-DIO-32F 32位并行 DIO设备 

z DAQCard-AI-16E-4和 DAQCard-AI-16XE-50 PCMCIA设备 

z NI PCI-4451/4452/4454 动态信号采集和生成设备 

z NI 4350/4351 数据记录器 

NI-DAQ 7.0不再支持的设备 

下列产品 NI-DAQ 7.0 不支持－即 NI-DAQmx 和传统 NI-DAQ 都不支持－在
NI-DAQ以后的版本中也不会支持。你必须使用 NI-DAQ 6.9.x或者更早的版本
为这些设备编写程序。 

z AT-MIO-16F-5 多功能 DAQ设备 

z DAQCard-500、 DAQCard-516、 DAQCard-700、 DAQCard-1200 和
DAQCard-AO-2DC PCMCIA设备 

z 用于并行口的 DAQPad-1200和 DAQPad-MIO-16XE-50 设备 

z Lab-PC系列 ISA 和 PC/XT MIO设备 

z PC-516 16位，50 kS/s MIO设备 

z PC-AO-2DC 低功耗 AO和电流环（current loop）DAQ 设备 

z 用于 PC的 PC-LPM-16PnP MIO设备 

z 用于 PC的 PC-OPDIO-16 光隔离 DIO设备 

z 用于 PC的 PC-TIO-10 定时器和 DIO接口 

z PCI-1200 12位, 100 kS/s MIO设备 

z SCXI-1200 12位 DAQ和控制模块 

z SCXI-2000 4槽基座 

z SCXI-2400 串行接口模块 

z VXI DAQ 模块, VXI-SC支座与模块，和 VXI-TB 用于 VXI总线的端
子板。 
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