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PIC32MX 入门工具包
用户指南
前言
简介

本章包含使用 PIC32MX 入门工具包前需要了解的、有用的一般信息。本章讨论的内容
包括：

• 文档编排

• 本指南使用的约定

• 推荐读物

• Microchip 网站

• 开发系统变更通知客户服务

• 客户支持

• 文档版本历史

文档编排

本文档介绍了如何将 PIC32MX 入门工具包用作开发工具来在目标电路板上仿真和调试
固件。本手册的内容编排如下：

• 第 1 章 PIC32MX 入门工具包简介简要概述了 PIC32MX 入门工具包，重点讨论了
其特性和使用方法。

• 第 2 章 PIC32MX 入门工具包教程提供了安装 PIC32MX 入门工具包以及使用
Microchip 的 MPLAB IDE 编译和运行 PIC32MX 入门工具包中教程程序的逐步指导。

• 第 3 章 创建新项目提供了使用 MPLAB IDE 创建一个新项目并将其装载到 PIC32MX
入门工具包的逐步指导。

• 第 4 章 PIC32MX 入门工具包硬件对 PIC32MX 入门工具包中包括的硬件的功能进
行了更详细的说明。

• 附录 A　PIC32MX 入门工具包原理图给出了 PIC32MX 入门工具包的框图和详细
的原理图。 

客户须知

所有文档均会更新，本手册也不例外。 Microchip 的工具和文档将不断演变以满足客户的需求，因此
在实际使用中有些对话框和 / 或工具说明可能与本文档所述之内容有所不同。请访问我们的网站
（www.microchip.com）获取最新文档。

文档均标记有 “DS”编号。 该编号出现在每页底部的页码之前。 DS 编号的命名约定为
“DSXXXXXA”，其中 “XXXXX”为文档编号，“A”为文档版本。

欲了解开发工具的最新信息，请参考 MPLAB® IDE 在线帮助。从 Help （帮助）菜单选择 Topics
（主题），打开现有在线帮助文件列表。
 2008 Microchip Technology Inc. DS61144B_CN 第 1 页
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本指南使用的约定

本用户指南采用以下文档约定：

文档约定

说明 涵义 示例

Arial 字体：

斜体字 参考书目 MPLAB® IDE User’s Guide

需强调的文字 ... 仅有的编译器 ...
首字母大写 窗口 Output 窗口

对话框 Settings 对话框

菜单选项 选择 Enable Programmer
引用 窗口或对话框中的字段名 “Save project before build”
带右尖括号前有下划线的斜体文字 菜单路径 File>Save

粗体字 对话框按钮 单击 OK
选项卡 单击 Power 选项卡

尖括号 < > 括起的文字 键盘上的按键 按下 <Enter> 或 <F1>
Courier New 字体：

常规 Courier New 源代码示例 #define START

文件名 autoexec.bat

文件路径 c:\mcc18\h

关键字 _asm, _endasm, static

命令行选项 -Opa+, -Opa-

位值 0, 1

源代码示例 0xFF, ‘A’

斜体 Courier New 可变参数 file.o，其中 file可以是任一有
效文件名

方括号 [ ] 可选参数 mcc18 [options] file 
[options]

花括号和竖线： { | } 选择互斥参数； “或”选择 errorlevel {0|1}

省略号 ... 替换重复文字 var_name [, var_name...]

表示由用户提供的代码 void main (void)
{ ...
}

DS61144B_CN 第 2 页  2008 Microchip Technology Inc.



前言
推荐读物

本用户指南介绍了如何使用 PIC32MX 入门工具包。 
以下 Microchip 文档均已提供，并建议读者作为补充参考资料。

PIC32MX 的自述文件
有关使用 PIC32MX 单片机的最新信息，请阅读 PIC32MX.txt文件 （ASCII 文本文
件），该文件位于 PIC32MX 入门工具包中包含的 CD 的根目录下。自述文件通常包含
了本用户指南中可能未提供的最新更新信息和已知问题。

自述文件
有关使用其他工具的最新信息，请阅读与该工具相关的自述文件，文件位于 PIC32MX
入门工具包安装目录的 Readmes子目录下。自述文件通常包含了本用户指南中可能未
提供的更新信息和已知问题。

PIC32MX Data Sheet （DS61143A）
欲了解有关 PIC32MX 通用 32 位器件的详细信息，请查阅此文档。该数据手册包含的
参考信息包括：

• 器件存储器映射

• 器件引脚排列和封装详细信息

• 器件电气规范

• 器件包括的外设列表

MPLAB® C32 C 编译器用户指南 （DS51686A_CN）
本文档详细介绍了使用 Microchip 的 MPLAB C32 C 编译器为 PIC32MX 器件开发应用
程序的方法。 MPLAB C32 是基于 GNU 的语言工具，以自由软件基金会 （Free     
Software Foundation， FSF）提供的源代码为基础。欲知有关 FSF 的更多信息，请访
问其网站 （www.fsf.org）。

MPLAB® IDE 用户指南 （DS51519A_CN）
欲知有关 MPLAB IDE 软件的安装和实现，以及该软件中包含的 MPLAB 编辑器和
MPLAB SIM 软件模拟器的更多信息，请查阅此文档。 

MICROCHIP 网站

Microchip 网站 （www.microchip.com）为客户提供在线支持。客户可通过网站方便地获
取文件和信息。只要使用常用的因特网浏览器即可访问，网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和样本程序、设计资源、用户指南和硬
件支持文档、最新的软件版本以及存档软件

• 一般技术支持——常见问题 （FAQ）、技术支持请求、在线讨论组和 Microchip 顾
问计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动
安排表、 Microchip 销售办事处、代理商以及工厂代表列表
 2008 Microchip Technology Inc. DS61144B_CN 第 3 页
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开发系统变更通知客户服务

Microchip 的客户通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在
他们感兴趣的某个产品系列或开发工具发生变更、更新、发布新版本或勘误表时，收
到电子邮件通知。

欲要注册，请登录 Microchip 网站 www.microchip.com，点击 “变更通知客户”
（Customer Change Notification）服务并按照注册说明完成注册。

开发系统产品的分类如下：

• 编译器——Microchip C 编译器及其他语言工具的最新信息。包括 MPLAB C18、
MPLAB C30 和 MPLAB C32 C 编译器； ASM32、 MPASM™ 和 MPLAB ASM30
汇编器； MPLINK™ 和 MPLAB LINK30 以及 MPLAB LINK32 目标链接器；
MPLIB™ 和 MPLAB LIB30 目标库管理器。

• 仿真器——Microchip 在线仿真器的最新信息。包括 MPLAB REAL ICE™ 和
MPLAB ICE 2000 在线仿真器。

• 在线调试器——Microchip 在线调试器的最新信息。 包括 MPLAB ICD 2 和
PICkit™ 2。

• MPLAB® IDE——用于开发系统工具的 Windows® 集成开发环境 Microchip　
MPLAB IDE 的最新信息。主要针对 MPLAB IDE、 MPLAB IDE 项目管理器、
MPLAB 编辑器、 MPLAB SIM 软件模拟器以及一般编辑和调试功能。

• 编程器——Microchip 编程器的最新信息。 包括 MPLAB PM3 器件编程器以及
PICSTART® Plus、 PICkit™ 1 和 PICkit 2 开发编程器。

客户支持

Microchip 产品的用户可以通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师 （FAE）
• 技术支持

用户应联系代理商、代表处或应用工程师 （FAE）寻求支持。当地销售办事处也可为
用户提供帮助。 本文档后附有销售办事处的联系方式。

也可通过 http://support.microchip.com 获得网上技术支持。

文档版本历史

版本 A （2007 年 10 月）

这是 PIC32MX 入门工具包用户指南的初始版本。

版本 B （2007 年 10 月）

去除了 “机密”状态。
DS61144B_CN 第 4 页  2008 Microchip Technology Inc.
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PIC32MX 入门工具包
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第 1 章  PIC32MX 入门工具包简介
1.1 引言

感谢购买 Microchip Technology 的 PIC32MX 入门工具包。该工具包为 Microchip 的 32
位单片机新产品线提供了一个低成本的模块化开发系统。 
该入门工具包带有预先装载的演示软件，以供用户体验 PIC32MX 的新功能之用。用户 
还可通过模块化扩展接口对其功能进行扩展。 PIC32MX 入门工具包还提供了用于全面
调试和编程功能的板上电路。

1.2 主要内容

本章涵盖以下主题：

• 工具包内容

• PIC32MX 入门工具包的功能和特性

• 使用随取即用的 PIC32MX 入门工具包

• PIC32MX 演示程序

PIC32MX 入门工具包 CD-ROM 中包括了 PIC32MX MCU 中的预编程示例代码，以供
将来参考。 CD-ROM 中也包括所有项目文件，因此可以直接使用该代码将入门工具包
中的 PIC32MX MCU 恢复至其原始状态 （即，如果使用了其他程序对该示例器件再编
程过），或者您也可将教程代码用作进一步体验的平台。

1.3 工具包内容

PIC32MX 入门工具包包含以下组件：

• PIC32MX 入门工具包电路板

• USB MINI-B 电缆

• PIC32 入门工具包安装 CD-ROM，包括：

- 用户指南

- PIC32MX 系列数据手册

- PIC32MX 系列参考手册

- PIC32MX 系列外设库手册

- 原理图和 PCB 图文件

- 用于 PIC32MX 器件的代码示例

如果您缺少该工具包的任何部件，请与 Microchip 销售办事处联系，以获得帮助 （参
见本手册最后一页的销售办事处列表）。
 2008 Microchip Technology Inc. DS61144B_CN 第 5 页
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1.4 PIC32MX 入门工具包的功能和特性

PIC32MX 入门工具包的电路板布局如图 1-1 所示。该电路板包括图中所示的以下主要
功能部件： 
1. PIC32MX360F512L 32 位单片机

2. 绿色电源指示 LED
3. 通过 USB 或扩展板为入门工具包提供 +3.3V 稳压电源

4. 为单片机提供精确时钟的板上晶振 （8 MHz）
5. 用于板上调试器通信的 USB 连接

6. 用于板上调试的 PIC18LF4550 USB 单片机

7. 橙色调试指示 LED
8. 三个用于用户自定义输入的按钮式开关

9. 三个用户自定义指示 LED
10.  连接各种扩展板的连接器 （在电路板的反面）

欲知这些功能部件的更多详细信息，请参见第 4 章“PIC32MX 入门工具包硬件”。

图 1-1： PIC32MX 入门工具包演示板布局

1
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9
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PIC32MX 入门工具包简介
1.5 使用随取即用的 PIC32MX 入门工具包

PIC32MX 入门工具包是随取即用的，可用作 PIC32MX 器件的演示板。在 PIC32MX
入门工具包中的 PIC32MX360F512L 器件上预编程了经典的“Simon Says”游戏程序
（即 simon_says_demo.hex），可以立即使用该游戏来演示 PIC32MX 入门工具包
的使用。

1.5.1 游戏玩法

在 USB 电缆插入入门工具包之后，三个 LED 开始闪烁，指示新游戏开始。通过按下
SW1-SW3 中的任一开关选择游戏难度级别（SW3 最易，SW1 最难）来开始游戏。游
戏的目标是尽可能地模拟灯的图案，直到您疲惫为止。最后，如果图案模拟的不对，
则所有的 LED 亮起，表示游戏结束。在短暂暂停后，您可以再次按下某个开关，以便
开始新的游戏。

如果将该入门工具包连接到 MPLAB IDE，游戏停止。在 MPLAB IDE 中按下编程按钮
时，将把所选择的 MPLAB IDE 项目装载到入门工具包中。通过打开 c:\Program 
Files\Microchip\pic32_solutions\simon_says_demo目录下的
simon_says_demo.mcw文件，可以将 Simon 游戏重新装载到入门工具包。 

1.6 安装 PIC32MX 入门工具包

入门工具包 CD-ROM 内包含 MPLAB IDE、MPLAB C32 C 编译器工具、代码示例、示
例项目、技术文档、入门教程和 《PIC32MX 入门工具包用户指南》。将 CD 插入 CD
驱动器后，自动安装应用程序将引导您安装工具和必要的文档。  

1.7 PIC32MX 演示程序

PIC32MX 入门工具包的 CD-ROM 中含有 PIC32MX 器件中的预编程示例代码，作为
将来参考之用。 CD-ROM 中也包括了所有的项目文件，因此可以直接使用该代码将
PIC32MX 恢复至其原始状态 （即，如果使用了其他程序对该示例器件再编程过），或
者您也可将教程代码用作进一步体验的平台。
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第 2 章  PIC32MX 入门工具包教程
2.1 引言

本章是您开始使用 PIC32MX 入门工具包的自学教程。

2.2 主要内容

本章讨论的内容包括：

• 主机要求

• 安装入门工具包电路板

• 开始教程项目

• 编译项目

• 对器件编程

• 运行程序

• 教程程序工作原理

2.3 主机要求

要与入门工具包电路板通信并对其编程，必须满足以下软硬件要求：

• PC 兼容系统

• PC 上有可用 USB 端口或者自供电的 USB 集线器

• CD-ROM 驱动器

•  Windows XP® 

（PIC32MX 入门工具包未在 Microsoft® Windows NT®、 Windows 2000® 或
Microsoft Vista™ 操作系统上测试过）
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2.4 安装入门工具包电路板

由于入门工具包是 USB 设备，因此安装起来毫不费力；大部分工作可由操作系统完
成。开始安装前请关闭所有应用程序。

2.4.1 安装工具和项目

1. 将 PIC32 入门工具包 CD 插入 CD-ROM 驱动器并单击 “install from CD”菜单
选项。 如果安装应用程序没有自动启动，请找到并打开 CD 上的 setup.exe文
件。 
将显示如下窗口：

图 2-1： 安装 PIC32 入门工具包电路板

2. 提示重启系统时，请照做。

2.4.2 查看入门教程

查看入门教程需执行以下步骤：

1. 在计算机重启后，打开 Getting Started Tutorial （入门教程）菜单。 
2. 查看教程指导，以了解连接入门工具包电路板和运行教程项目的步骤。

如果您按照入门教程执行过这些安装步骤，请跳至第 14 页的第 2.5 节 “开始教程项
目”。

否则，请继续到下一页，了解关于如何连接电路板和安装设备驱动程序的指导信息。

注： 此对话框还提供了另一个选项，单击该选项可查看 Microchip 网站上是否
发布了该入门工具包软件的新版本。 
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2.4.3 连接入门工具包电路板

使用随附的 USB 电缆将该电路板连接到计算机的空闲 USB 端口上。（也可以使用不
由总线供电的 USB 集线器。）将电缆的另一端与入门工具包电路板的 USB 连接器连
接。

检查电路板： 绿色电源 LED D3 应该亮起。如果没亮，请检查端口、集线器以及电路
板之间的连接是否完好。

2.4.4 安装 USB 设备驱动程序

安装 USB 设备驱动程序请执行以下步骤：

1. 在 USB 电缆连接后，将打开一个 “Found New Hardware Wizard”对话框，如
图 2-2 所示。在问及选择 “install the software automatically”（自动安装软件）
还是 “install from a list or specific location”（从列表或指定位置安装）时，请
选择 “Install software automatically”并单击 Next （下一步）。 

图 2-2： FOUND NEW HARDWARE WIZARD （找到新硬件向导） 

注： 此处描述的 USB 驱动程序的安装步骤以 Microsoft Windows XP 操作系统
上的驱动程序安装为参考。
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2. 如图 2-3 所示，下一个对话框在向导搜索设备时对向导进行跟踪。（此操作可能
需要几秒钟。） 完成后，单击 Next。 

图 2-3： 硬件向导

3. 在向导找到驱动程序时，将跳出一个关于 Windows 徽标测试 （Windows Logo 
testing）的对话框，如图 2-4 所示。单击 Continue Anyway （仍然继续）。

图 2-4： WINDOWS 徽标测试 
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4. 下一窗口 （图 2-5）指示入门工具包的软件安装完毕。单击 Finish （完成）。

图 2-5： 设备驱动程序安装完毕
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2.5 开始教程项目

单击计算机桌面上的 MPLAB IDE 图标。 MPLAB IDE 打开时同时打开装载的入门工具
包教程项目，如图 2-6 所示。如果 MPLAB IDE 没有装载入门工具包教程项目，请从菜
单栏中选择 File>Open Workspace... 并找到教程项目文件： c:\Program Files\ 
Microchip\pic32_solutions\PIC32MX_Starter_Kit\sample_code\

StarterKitTutorial\StarterKitTutorial.mcw （或者浏览到您安装 MPLAB IDE
时使用的文件路径）。

MPLAB IDE 界面左边的窗格显示了用于构建应用程序的项目文件 .c、 .h和 .lib文
件。这些项目文件根据文件类型存放在相应的文件夹中。

MPLAB IDE 界面的 “Output”窗格中应显示 “Starter Kit Found”消息。 如果没有看
到该消息，请从菜单栏中选择 Debugger>Select Tool>PIC32MX Starter Kit。 如果这样
做还是没找到项目的话，那么请检查驱动程序的安装，以及硬件与 PC 之间的连接是
否完好。 

图 2-6： MPLAB® IDE 工作区
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2.6 编译项目

从 MPLAB IDE 主窗口菜单栏中单击 Project>Make。将显示编译 Output （输出）窗
口，如图 2-7 所示。

观察编译过程。当显示消息 “BUILD SUCCEEDED”（编译成功）时，表示接下来您
可以对器件编程了。

图 2-7： 编译完成后的 OUTPUT 窗口
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2.7 对器件编程

2.7.1 对器件编程

单击器件编程工具栏上的 “Program All Memories”（编程所有存储器）按钮，如图
2-8 所示。

图 2-8： 器件编程工具栏

此时将打开一个 Programming Warning （编程警告）窗口 （图 2-9），警告此操作将
覆写存储器内容。单击 Yes。 

图 2-9： PROGRAMMING WARNING 窗口

Output 窗口 （图 2-10）将跟踪输出过程。如果窗口中出现 “Done”字样，表示对器
件编程完毕。

图 2-10： OUTPUT 窗口
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2.8 运行程序

要运行新程序，请从 MPLAB IDE 菜单栏中单击 Debugger>Run 或单击调试工具栏
（图 2-11）上的 Run （运行）按钮 （蓝绿色三角形按钮）。 

图 2-11： 调试窗口

2.9 教程程序工作原理

该入门工具包教程演示了一个简单的应用程序。该程序可根据用户输入菜单做出相应
的响应。 它可向 MPLAB IDE 的入门工具包 Output 窗口打印可用的菜单选择。该程序
流程如图 2-12 所示。
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图 2-12： PIC32MX 入门工具包教程程序的流程图
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该教程程序包含支持打印功能的调试打印库。还包含使 LED 闪烁的外设库头文件。打
印功能的头文件为 db_utils.h。 
根据打印头文件给出的宏定义可对调试打印宏进行扩展。本教程中的打印功能是将需
打印的内容输出到界面窗口中 MPLAB PIC32MX 选项卡中的 Output 窗口。要实现这
个功能，需要在 C32 编译器选项中添加宏定义 “PIC32_STARTER_KIT”。

当程序运行时， Output 窗口 （图 2-13）将跟踪该程序的运行过程。

图 2-13： OUTPUT 窗口

在打印菜单之后，该应用程序将显示请求您输入菜单选择的提示信息，如图 2-14 所
示。

图 2-14： TARGET IN 窗口

在 Enter Information to be Returned（输入要返回的信息）框中键入您的选择，然后单
击 Send （发送）。 
该程序将根据输入的菜单项做出相应的响应。观察入门工具包电路板上的 LED。如果
您输入的菜单项不正确，则所有 LED 都将翻转 （闪烁）一次。
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注：
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第 3 章  创建新项目
3.1 引言

本章介绍了如何创建一个新项目。 

3.2 重点内容

本章讨论的内容包括：

• 创建新项目

• 编译项目

• 对器件编程

• 运行程序

学习完本章之后，您将能够完成以下任务：

• 使用 Project Wizard （项目向导）创建项目

• 汇编和链接代码并设置配置位

• 设置 MPLAB IDE 以使用 PIC32MX 入门工具包

• 对芯片编程并运行程序

3.3 创建新项目

第一步在 MPLAB IDE 中创建一个项目和工作区。通常情况下每个工作区包含一个项
目。

项目包含编译应用程序所需的文件 （即，源代码、头文件和库等）及其相应的编译选
项。

工作区可包含一个或多个项目、选定器件的信息、调试／编程工具以及 MPLAB IDE 配
置设置。

MPLAB IDE 包含帮助创建新项目的 Project Wizard。在开始创建项目之前，创建一个
用来存放项目文件、名为 “MyProject”的文件夹 （下面指导中假定其存放在
C:\MyProject目录下）非常重要。 
创建新项目将执行以下任务：

任务 1，选择器件 （第 22 页）。 
任务 2，选择语言工具包 （第 23 页）。

任务 3，为项目命名 （第 24 页）。

任务 4，将文件添加到项目中 （第 25 页）。

任务 5，确认配置设置 （第 27 页）。

任务 6，编译项目 （第 28 页）。

任务 7，对器件编程 （第 29 页）。

任务 8，运行程序 （第 30 页）。
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3.3.1 任务 1，选择器件

1.1. 启动 MPLAB IDE。
1.2. 单击菜单栏上的 File>Close Workspace，关闭打开的任何工作区。 
1.3. 单击 Project>Project Wizard... 以启动向导。

1.4. 在欢迎窗口中，单击 Next。
Project Wizard 第一步： 打开如图 3-1 所示的窗口。 

图 3-1： 选择器件

1.5. 从 “Device”下拉框中选择 “PIC32MX360F512L”。 
1.6. 单击 Next。 

Project Wizard 第二步： 打开如图 3-2 所示的对话框。
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图 3-2： 选择工具包

3.3.2 任务 2，选择语言工具包

2.1. 从 “Active Toolsuite”下拉框中单击 “Microchip PIC32 C Compiler 
Toolsuite”。该工具包包含即将使用的汇编器和链接器。如果 PIC32 编译器
选项不存在，请选中 “show all installed toolsuites”复选框。

2.2. 在 “Toolsuite Contents”框内选择 “MPLAB C32 C Compiler 
(pic32-gcc.exe)”。

2.3. 在 “Location”框中单击 Browse... 并找到： 
“c:\Program Files\Microchip\MPLAB C32\bin\pic32-as.exe”。

2.4. 在 “Tool-suite Contents”框内选择 “MPLAB 32 LINK Object Linker 
(pic30-ld.exe)”，单击 Browse... 并找到：
“c:\Program Files\Microchip\MPLAB C32\bin\pic32-Id.exe”。

2.5. 单击 Next 继续。 
Project Wizard 第三步： 打开如图 3-3 所示的对话框。
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图 3-3： 为项目命名

3.3.3 任务 3，为项目命名

3.1. 在 “Create New Project File”域内单击 Browse... 并找到
“C:\MyProject\BlinkLED”，以将项目存放到您在开始创建新项目之前创建
的 MyProject文件夹内。

3.2. 单击 Next 继续。 
Project Wizard 第四步： 打开如图 3-4 所示的对话框。
DS61144B_CN 第 24 页  2008 Microchip Technology Inc.



创建新项目
图 3-4： 将文件添加到项目中 

3.3.4 任务 4，将文件添加到项目中

由于没有创建任何 “.c”文件，可以跳过该窗口。 
4.1. 单击 Next 继续。 
4.2. 在摘要屏幕上单击 Finish 按钮。

已在 MPLAB IDE 内创建了一个项目和一个工作区。 
BlinkLED.mcw为工作区文件，而 BlinkLED.mcp为项目文件。 

4.3. 单击菜单栏上的 File>New，以创建一个新文件。

您可以看到一个新的空白文件。 
4.4. 单击 File>Save As...，以将该文件命名为 “blinkLED.c”并将其保存到同

一文件夹 （此例中指 C:\MyProject文件夹）下。 
4.5. 现在请将例 3-1 提供的源代码复制到 blinkLED.c文件中。
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例 3-1： 项目源代码

#include <plib.h>        /* PIC32 peripheral library */ 

void main (void)

{   

   int str_int;

   /* setup LED */

   mPORTDClearBits(BIT_0);/* Turn off LED0 on startup */

   mPORTDSetPinsDigitalOut(BIT_0);/* Make RD0 (LED0) as output */

   mPORTDClearBits(BIT_1);/* Turn off LED1 on startup */

   mPORTDSetPinsDigitalOut(BIT_1);/* Make RD0 (LED1) as output */

   mPORTDClearBits(BIT_2);/* Turn off LED2 on startup */

   mPORTDSetPinsDigitalOut(BIT_2);/* Make RD0 (LED2) as output */

   while(1) // go for ever

   {

for(i=0; i<200000; i++);// put a delay

mPORTDToggleBits(BIT_0);/* turn ON LED0 */

for(i=0; i<200000; i++);// put a delay

mPORTDToggleBits(BIT_1);/* turn ON LED1 */

for(i=0; i<200000; i++);// put a delay

mPORTDToggleBits(BIT_2);/* turn ON LED2 */

   };

   return 0;

}
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4.6. 在项目窗口中，将 blinkLED.c文件添加到源文件 （Source Files）目录
下，如图 3-5 所示。 

图 3-5： 添加源文件 

4.7. 单击菜单栏上的 Debugger>Select Tool>PIC32MX Starter Kit，将其设置
为目标板。 

3.3.5 任务 5，确认配置设置

5.1. 单击 Configure>Configuration Bits，确认入门工具包的配置设置是否正确。 
该入门工具包的典型配置设置如图 3-6 所示。 

注： 请确保入门工具包演示板已与 PC 连接。

注： 配置设置也可嵌入到源文件中。欲知更多信息，请参见 《MPLAB® C32 
C 编译器用户指南》（DS51686A_CN）
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图 3-6： 配置位设置 

注意未选中 “Configuration Bits set in code”复选框。

3.3.6 任务 6，编译项目

6.1. 单击 MPLAB IDE 主窗口的菜单栏中的 Project>Make，显示编译 Output 窗
口 （图 3-7）。

6.2. 观察编译过程。当显示 “BUILD SUCCEEDED”消息时，您可以准备对器
件编程了。

图 3-7： 编译完成后的输出窗口
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3.3.7 任务 7，对器件编程

7.1. 单击器件编程工具栏上的 “Program All Memories”（编程所有存储器）按
钮，如图 3-8 所示。

图 3-8： 对器件编程窗口

将打开 Programming Warning 窗口 （图 3-9），警告此操作将覆写存储器的
当前内容。 

7.2. 单击 Yes。 

图 3-9： PROGRAMMING WARNING 窗口

Output 窗口 （图 3-10）将跟踪输出过程。出现 “Done”字符表示对器件
编程完毕。

图 3-10： OUTPUT 窗口
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3.3.8 任务 8，运行程序

8.1. 单击 MPLAB IDE 菜单栏上的 Debugger>Run 或单击调试工具栏上的 Run
按钮 （蓝绿色三角形按钮）来运行新程序 （如图 3-11 所示）。 

图 3-11： 运行程序

入门工具包 LED 闪烁，表示程序运行成功。 
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第 4 章   PIC32MX 入门工具包硬件
4.1 引言

本章介绍了 PIC32MX 入门工具包的硬件功能部件。 

4.2 硬件功能

下面列出了 PIC32MX 入门工具包的主要功能部件。这些功能将按照第 1.4 节
“PIC32MX 入门工具包的功能和特性”中给出的顺序进行说明。欲知它们在电路板上的
具体位置，请参见第 6 页中的图 1-1。

4.2.1 处理器支持

PIC32MX入门工具包设计为具有一个永久贴装（即，已焊接）的PIC32MX360F512L处理
器。

4.2.2 电源

有两种方法可为 PIC32MX 入门工具包提供电源：

• 通过连接到 J1 的 USB 总线供电。

• 将一个可提供 +5V 稳压直流电源的外部应用电路板连接到入门工具包电路板反面
的 J2 应用电路板连接器上。

提供了一个绿色 LED （D3）用来显示 PIC32 单片机是否上电。

4.2.3 USB 连接

PIC32MX 入门工具包包括一片 PIC18LF4550 USB 单片机，用它来为协议转换提供
USB 连接和支持。 PIC18LF4550 可通过两种连接方式硬线连接到 PIC32MX 器件：

• 将 PIC18LF4550 的 I/O 引脚与 PIC32MX 器件的 ICSP™ 引脚连接

• 将 PIC18LF4550 的 I/O 引脚与 PIC32MX 器件的 JTAG 引脚连接

PIC32MX 入门工具包目前使用了 PIC32MX 器件的 JTAG 引脚来进行编程和调试。在
该入门工具包的早期版本中， PIC18LF4550 中装载了 USB 自举程序固件，这使得可
以方便地通过 USB 连接对连接固件进行升级。 

注： 基本型 PIC32MX 入门工具包不包括应用电路板，因此需要通过 USB 总线
进行供电。 
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4.2.4 开关

按钮式开关提供了以下功能：

• SW1： 连接到 RD6 的低电平有效开关

• SW2： 连接到 RD7 的低电平有效开关

• SW3： 连接到 RD13 的低电平有效开关

这些开关不具有去抖动电路，且需要使用内部上拉电阻；这要求您学习研究一下去抖
动技术。开关未按下时被拉至高电平 （+3.3V）。按下时开关接地。 

4.2.5 LED

将 LED 以及 RD0 至 RD2 与处理器的 PORTD 引脚进行连接。可将 PORTD 引脚置为
高电平来点亮 LED。

4.2.6 振荡器选项

该工具包电路板上安装的单片机有一个振荡器电路与之连接。主振荡器使用了 8 MHz
的晶振 （Y2）并用作控制器的主振荡器。 PIC32 设计不需要使用外部晶振。如果需
要，您的设计中可以使用内部振荡器。

USB 子系统核心处的 PIC18LF4550 使用其内部 8 MHz 晶振 （Y1）来为自己独立提
供时钟。

4.2.7 120 引脚模块化扩展连接器

PIC32MX 入门工具包演示板设计成具有一个 120 引脚的模块化扩展接口，从而使得该
板能够提供基本的通用功能，并且易于扩展到将来可能采用的新技术。
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附录 A PIC32MX 入门工具包原理图
A.1 引言

本章提供了 PIC32MX 入门工具包的详细技术信息。

A.2 开发板框图

图 A-1：  PIC32MX 入门工具包的高阶框图

A.3 入门工具包电路板原理图

图 A-2 PIC32MX CPU
图 A-3 PIC18LF4550 调试 CPU
图 A-4 应用电路板连接器

图 A-5 开关和 LED
图 A-6 电源
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图
 A-3： PIC32MX 入门工具包电路板原理图 2 （共 5 张）（PIC18LF4550 调试 CPU）
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图 A-4： PIC32MX 入门工具包电路板原理图 3 （共 5 张）（应用电路板连接器）
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图 A-5：  PIC32MX 入门工具包电路板原理图 4 （共 5 张）（开关和 LED）
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DS
图 A-6： PIC32MX 入门工具包电路板原理图 5 （共 5 张）（电源）
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